PHP Manual

PHP Manual

Stig Sæther Bakken
Alexander Aulbach
Egon Schmid
Jim Winstead
Lars Torben Wilson
Rasmus Lerdorf
Andrei Zmievski
Jouni Ahto

Edited by

Stig Sæther Bakken

Egon Schmid

This file was generated: Fri Apr 12 03:03:58 2002
Go to http://www.php.net/docs.php to get the actual version.

Copyright © 1997, 1998, 1999, 2000, 2001, 2002 the PHP Documentation Group


Manual de PHP

Tabla de contenidos

Prefacio
Sobre este Manual
Sobre la traducción
I. Conceptos Básicos
1. Introducción
2. Instalación
3. Configuración
4. Seguridad
II. Referencia del Lenguaje
5. Sintaxis básica
6. Types
7. Variables
8. Constantes
9. Expresiones
10. Operadores
11. Estructuras de Control
12. Funciones
13. Clases y Objetos
14. References Explained
III. Características
15. Manejando errores
16. Creando imágenes GIF
17. Autentificación HTTP con PHP
18. Cookies
19. El envío de archivos
20. Usando archivos remotos
21. Manejando conexiones
22. Conexiones persistentes a bases de datos
23. Safe Mode
IV. Referencia de las Funciones
I. Funciones específicas de Apache
II. Funciones de matrices
III. Funciones Ortográficas
IV. Funciones matemáticas de precisión arbitraria
V. Bzip2 Compression Functions
VI. Funciones de calendario
VII. CCVS API Functions
VIII. soporte de las funciones COM para Windows
IX. Funciones de Clases/Objectos
X. Funciones de ClibPDF
XI. Crack functions
XII. CURL, Client URL Library Functions
XIII. Funciones de pago electrónico
XIV. Crédit Mutuel CyberMUT functions
XV. Cyrus IMAP administration functions
XVI. Character type functions
XVII. Funciones de la capa de abstraccion de bases de datos (dbm-style)
XVIII. Funciones de fecha y hora
XIX. Funciones para dBase
XX. Funciones dbm
XXI. dbx functions
XXII. DB++ Functions
XXIII. Direct IO functions
XXIV. Funciones con directorios
XXV. Funciones de DOM XML
XXVI. .NET functions
XXVII. Error Handling and Logging Functions
XXVIII. FrontBase Functions
XXIX. Funciones filePro
XXX. Funciones del sistema de ficheros
XXXI. Funciones Forms Data Format (Formato de Datos de Formularios)
XXXII. FriBiDi functions
XXXIII. Funciones FTP
XXXIV. Function Handling functions
XXXV. GNU Gettext
XXXVI. GMP functions
XXXVII. Funciones HTTP
XXXVIII. Funciones para Hyperwave
XXXIX. Funciones para ICAP - Internet Calendar Application Protocol
XL. iconv functions
XLI. Funciones de imágenes
XLII. Funciones IMAP
XLIII. Funciones para Informix
XLIV. Funciones InterBase
XLV. Ingres II functions
XLVI. IRC Gateway Functions
XLVII. Java
XLVIII. Funciones LDAP
XLIX. Funciones de Correo
L. mailparse functions
LI. Funciones matemáticas
LII. Multi-Byte String Functions
LIII. MCAL functions
LIV. Funciones Criptográficas
LV. Funciones Hash
LVI. Funciones de Microsoft SQL Server
LVII. Ming functions for Flash
LVIII. Miscelánea de funciones
LIX. mnoGoSearch Functions
LX. funciones mSQL
LXI. Funciones MySQL
LXII. Mohawk Software session handler functions
LXIII. muscat functions
LXIV. Funciones de Red
LXV. Ncurses terminal screen control functions
LXVI. Lotus Notes functions
LXVII. ODBC functions
LXVIII. Funciones de Oracle 8
LXIX. OpenSSL functions
LXX. Funciones Oracle
LXXI. Ovrimos SQL functions
LXXII. Output Control Functions
LXXIII. Object property and method call overloading
LXXIV. PDF functions
LXXV. Verisign Payflow Pro functions
LXXVI. opciones e información de PHP
LXXVII. Funciones POSIX
LXXVIII. Funciones de PostgreSQL
LXXIX. Process Control Functions
LXXX. Funciones de ejecución de programas
LXXXI. Printer functions
LXXXII. Pspell Functions
LXXXIII. GNU Readline
LXXXIV. Funciones GNU Recode
LXXXV. Funciones de expresiones regulares compatibles con Perl
LXXXVI. qtdom functions
LXXXVII. Funciones para expresiones regulares
LXXXVIII. Funciones Semáforo y de memoria compartida
LXXXIX. SESAM database functions
XC. Session handling functions
XCI. Shared Memory Functions
XCII. Shockwave Flash functions
XCIII. Funciones SNMP
XCIV. Socket functions
XCV. Funciones de cadenas
XCVI. Funciones de Sybase
XCVII. Funciones URL
XCVIII. Funciones sobre variables
XCIX. vpopmail functions
C. W32api functions
CI. Funciones WDDX
CII. Funciones de intérprete XML
CIII. XMLRPC functions
CIV. XSLT functions
CV. YAZ
CVI. NIS funciona
CVII. Zip File Functions (Read Only Access)
CVIII. Funciones de Compresión
V. Extending PHP 4.0
24. Overview
25. Extension Possibilities
26. Source Layout
27. PHP's Automatic Build System
28. Creating Extensions
29. Using Extensions
30. Troubleshooting
31. Source Discussion
32. Accepting Arguments
33. Creating Variables
34. Duplicating Variable Contents: The Copy Constructor
35. Returning Values
36. Printing Information
37. Startup and Shutdown Functions
38. Calling User Functions
39. Initialization File Support
40. Where to Go from Here
41. Reference: Some Configuration Macros
42. API Macros
VI. FAQ: Frequently Asked Questions
43. General Information
44. Mailing lists
45. Obtaining PHP
46. Database issues
47. Installation
48. Build Problems
49. Using PHP
50. PHP and HTML
51. PHP and COM
52. PHP and other languages
53. Migrating from PHP 2 to PHP 3
54. Migrating from PHP 3 to PHP 4
55. Miscellaneous Questions
VII. Apéndices
A. Using PHP from the command line
B. Migrating from PHP 3 to PHP 4
C. Migrando de PHP/FI 2.0 a PHP 3.0
D. El debugger de PHP
E. Desarrollo en PHP
F. List of Function Aliases
G. List of Reserved Words
H. List of Resource Types
I. About the manual
Function Index
J. missing stuff
VIII. ???
56. About This Edition

Siguiente
Prefacio


Prefacio

Tabla de contenidos
Sobre este Manual
Sobre la traducción

PHP, acrónimo de "PHP: Hypertext Preprocessor", es un lenguaje interpretado de alto nivel embebido en páginas HTML. La mayoría de su sintaxis es similar a C, Java y Perl, con solamente un par de caracteristicas PHP específicas. La meta de este lenguaje es permitir escribir a los creadores de páginas web, páginas dinámicas de una manera rápida y fácil.

Sobre este Manual

Este manual está escrito en SGML usando DocBook DTD y DSSSL (Document Style and Semantics Specification Language) para su creación. Las herramientas usadas para crear las versiones HTML, TeX y RTF son Jade, escrita por James Clark y The Modular DocBook Stylesheets escrita por Norman Walsh. El marco de trabajo de la documentación de PHP fue creado por Stig Sæther Bakken.

Anterior | Inicio | Siguiente
Manual de PHP |  | Sobre la traducción


Conceptos Básicos

Manual de PHP
Anterior Siguiente

I. Conceptos Básicos

Tabla de contenidos
1. Introducción
2. Instalación
3. Configuración
4. Seguridad

Anterior | Inicio | Siguiente
Sobre la traducción |  | Introducción


Introducción

Manual de PHP
Anterior Siguiente

Capítulo 1. Introducción

Tabla de contenidos
Qué es PHP?
Qué se puede hacer con PHP?
Corta historia de PHP

Qué es PHP?

PHP (acronimo de "PHP: Hypertext Preprocessor") es un lenguaje interpretado de alto nivel embebido en páginas HTML y ejecutado en el servidor.

Una respuesta corta y concisa, pero que significa realmente? Un ejemplo nos aclarará las cosas:

Ejemplo 1-1. Un ejemplo introductorio

<html>
    <head>
        <title>Ejemplo PHP</title>
    </head>
    <body>
        <?php echo "Hola, este es un ejemplo con PHP!"; ?>
    </body>
</html>

Podemos ver que no es lo mismo que un script CGI escrito en otro lenguaje de programación como Perl o C -- En vez de escribir un programa con muchos comandos para crear una salida en HTML, escribimos el código HTML con cierto código PHP embebido (introducido) en el mismo, que producirá cierta salida (en nuestro ejemplo, producir un texto). El código PHP se incluye entre etiquetas especiales de comienzo y final que nos permitirán entrar y salir del modo PHP.

Lo que distingue a PHP de la tecnología Javascript, la cual se ejecuta en la má;quina cliente, es que el código PHP es ejecutado en el servidor. Si tuviesemos un script similar al de nuestro ejemplo en nuestro servidor, el cliente sólamente recibiría el resultado de su ejecución en el servidor, sin ninguna posibilidad de determinar que código ha producido el resultado recibido. El servidor web puede ser incluso configurado para que procese todos los ficheros HTML con PHP.

Anterior | Inicio | Siguiente
Conceptos Básicos | Subir | Qué se puede hacer con PHP?


Qué se puede hacer con PHP?

Al nivel más básico, PHP puede hacer cualquier cosa que se pueda hacer con un script CGI, como procesar la información de formularios, generar páginas con contenidos dinámicos, o mandar y recibir cookies.

Quizas la característica más potente y destacable de PHP es su soporte para una gran cantidad de bases de datos. Escribir un interfaz via web para una base de datos es una tarea simple con PHP. Las siguientes bases de datos están soportadas actualmente:

Adabas D | Ingres | Oracle (OCI7 and OCI8)
dBase | InterBase | PostgreSQL
Empress | FrontBase | Solid
FilePro | mSQL | Sybase
IBM DB2 | MySQL | Velocis
Informix | ODBC | Unix dbm

PHP también soporta el uso de otros servicios que usen protocolos como IMAP, SNMP, NNTP, POP3, HTTP y derivados. Tambien se pueden abrir sockets de red directos (raw sockets) e interactuar con otros protocolos.

Anterior | Inicio | Siguiente
Introducción | Subir | Corta historia de PHP


Corta historia de PHP

PHP fue concebido en otono de 1994 por Rasmus Lerdorf. Las primeras versiones no distribuidas al público fueron usadas en un sus páginas web para mantener un control sobre quien consultaba su currículum. La primera versión disponible para el público a principios de 1995 fue conocida como "Herramientas para paginas web personales" (Personal Home Page Tools). Consistian en un analizador sintáctico muy simple que solo entendia unas cuantas macros y una serie de utilidades comunes en las páginas web de entonces, un libro de visitas, un contador y otras pequenas cosas. El analizador sintactico fue reescrito a mediados de 1995 y fue nombrado PHP/FI version 2. FI viene de otro programa que Rasmus habia escrito y que procesaba los datos de formularios. Asi que combinó las "Herramientas para paginas web personales", el "intérprete de formularios", anadio soporte para mSQL y PHP/FI vio la luz. PHP/FI crecio a gran velocidad y la gente empezó a contribuir en el código.

Es difícil dar estadísticas exactas, pero se estima que a finales de 1996 PHP/FI se estaba usando al menos en 15.000 páginas web alrededor del mundo. A mediados de 1997 este número habia crecido a mas de 50.000. A mediados de 1997 el desarrollo del proyecto sufrio un profundo cambio, dejó de ser un proyecto personal de Rasmus, al cual habian ayudado un grupo de usuarios y se convirtio en un proyecto de grupo mucho más organizado. El analizador sintáctico se reescribio desde el principio por Zeev Suraski y Andi Gutmans y este nuevo analizador establecio las bases para PHP versión 3. Gran cantidad de codigo de PHP/FI fue portado a PHP3 y otra gran cantidad fue escrito complétamente de nuevo.

Hoy en día (finales 1999), tanto PHP/FI como PHP3 se distribuyen en un gran número de productos comerciales tales como el servidor web "C2's StrongHold" y Redhat Linux. Una estimación conservativa basada en estadísticas de NetCraft (ver también Estudio de NetCraft sobre servidores web), es que más de 1.000.000 de servidores alrededor del mundo usan PHP. Para hacernos una idea, este número es mayor que el número de servidores que utilizan el "Netscape's Enterprise server" en Internet.

A la vez que todo esto está pasando, el trabajo de desarrollo de la próxima generación de PHP está en marcha. Esta versión utiliza el potente motor de scripts Zend para proporcionar altas prestaciones, así como soporta otros servidores web, además de apache, que corren PHP como módulo nativo.

Anterior | Inicio | Siguiente
Qué se puede hacer con PHP? | Subir | Instalación


Instalación

Manual de PHP
Anterior Siguiente

Capítulo 2. Instalación

Tabla de contenidos
Bajándose la última versión
Instalación en sistemas UNIX
Instalación en sistemas Windows 95/98/NT
¿Problemas?

Bajándose la última versión

El código fuente y las distribuciones binarias para algunas plataformas (incluído Windows) se pueden encontrar en http://www.php.net/.

Anterior | Inicio | Siguiente
Corta historia de PHP | Subir | Instalación en sistemas UNIX


Instalación en sistemas UNIX

Esta sección le guiará a través de la configuración e instalación del PHP. Conocimientos y software necesarios:

  • Habilidades básicas en UNIX (ser capaz de manejar el "make" y un compilador de C)

  • Un compilador ANSI de C

  • Un servidor web

Instrucciones Rápidas de Instalación (Versión Módulo de Apache)

1.  gunzip apache_1.3.x.tar.gz
2.  tar xvf apache_1.3.x.tar
3.  gunzip php-3.0.x.tar.gz
4.  tar xvf php-3.0.x.tar
5.  cd apache_1.3.x
6.  ./configure --prefix=/www
7.  cd ../php-3.0.x
8.  ./configure --with-mysql --with-apache=../apache_1.3.x --enable-track-vars
9.  make
10. make install
11. cd ../apache_1.3.x
12. ./configure --prefix=/www --activate-module=src/modules/php3/libphp3.a
13. make
14. make install

  En lugar de este paso quizás prefiera simplemente copiar el binario
  httpd encima del binario existente. Si lo hace, asegúrese antes de
  cerrar su servidor.

15. cd ../php-3.0.x
16. cp php3.ini-dist /usr/local/lib/php3.ini

  Puede editar el archivo /usr/local/lib/php3.ini para ajustar opciones
  del PHP. Si prefiere tenerlo en otro sitio, utilice
  --with-config-file-path=/path en el paso 8.

17. Edite su archivo httpd.conf o srm.conf y añada:

            AddType application/x-httpd-php3 .php3

  Puede elegir la extensión que desee aquí. .php3 es simplemente nuestra
  sugerencia.

18. Utilice su método habitual para iniciar el servidor Apache (debe detener
    y reiniciar el servidor, no solamente hacerlo recargarse usando una
    señal HUP o USR1.)

Configuración

Hay dos maneras de configurar el PHP.

  • Utilizando el script de "setup" que viene con el PHP. Este script le hace una serie de preguntas (casi como el script "install" del PHP/FI 2.0) y ejecuta el "configure" al final. Para ejecutar este script, escriba ./setup.

    Este script también creará un archivo llamado "do-conf", que contendrá las opciones pasadas a la configuración. Puede editar este archivo para cambiar algunas opciones sin tener que re-ejecutar el "setup". Escriba luego ./do-conf para ejecutar la configuración con las nuevas opciones.

  • Ejecutar el "configure" a mano. Para ver las opciones de que dispone, escriba ./configure --help.

Los detalles sobre las distintas opciones de configuración son listados a continuación.

Módulo del Apache

Para configurar el PHP como módulo de Apache, responda "yes" a "Build as an Apache module?" (la opción --with-apache=DIR es la que lo configura) y especifique el directorio base de la distribución de Apache. Si ha desempacado el Apache en /usr/local/www/apache_1.2.4, este será su directorio base de la distribución de Apache. El directorio por defecto es /usr/local/etc/httpd.

Módulo fhttpd

Para configurar el PHP como módulo fhttpd, responda "yes" a "Build as an fhttpd module?" (la opción --with-fhttpd=DIR es la que lo configura) y especifique el directorio base del fuente del fhttpd. El directorio por defecto es /usr/local/src/fhttpd. Si está ejecutando fhttpd, configurar PHP como módulo le dará mejor rendimiento, más control y capacidad de ejecución remota.

CGI version

El valor por defecto es configurar el PHP como programa CGI. Si está ejecutando un servidor web para el que el PHP tiene soporte como módulo, debería elegir dicha solución por motivos de rendimiento. Sin embargo, la versión CGI permite a los usuarios del Apache el ejecutar distintas páginas con PHP bajo distintos identificadores de usuario. Por favor, asegúrese de haber leído el capítulo sobre Seguridad si va a ejecutar el PHP como CGI.

Opciones de soporte para Base de Datos

El PHP tiene soporte nativo para bastantes bases de datos (así como para ODBC):

Adabas D

--with-adabas=DIR

Compila con soporte para Adabas D. El parámetro es el directorio de instalación de Adabas D y por defecto vale /usr/local/adabasd.

Página de Adabas

dBase

--with-dbase

Habilita el soporte integrado para DBase. No se precisan librerías externas.

filePro

--with-filepro

Habilita el soporte integrado de sólo lectura para filePro. No se precisan librerías externas.

mSQL

--with-msql=DIR

Habilita el soporte para mSQL. El parámetro es el directorio de instalación de mSQL y por defecto vale /usr/local/Hughes. Este es el directorio por defecto de la distribución mSQL 2.0. configure detecta automáticamente qué versión de mSQL está ejecutándose y el PHP soporta tanto 1.0 como 2.0, pero si compila el PHP con mSQL 1.0 sólo podrá acceder a bases de datos de esa versión y viceversa.

Vea también Directivas de Configuración de mSQL en el archivo de configuración.

Página de mSQL

MySQL

--with-mysql=DIR

Habilita el soporte para MySQL. El parámetro es el directorio de instalación de MySQL y por defecto vale /usr/local. Este es el directorio de instalación de la distribución de MySQL.

Vea también Directivas de Configuración de MySQL en el archivo de configuración.

Página de MySQL

iODBC

--with-iodbc=DIR

Incluye soporte para iODBC. Esta característica se desarrolló inicialmente para el iODBC Driver Manager, un gestor de controlador de ODBC de redistribución libre que ese ejecuta bajo varios sabores de UNIX. El parámetro es el directorio de instalación de iODBC y por defecto vale /usr/local.

Página de FreeODBC o página de iODBC

OpenLink ODBC

--with-openlink=DIR

Incluye soporte para OpenLink ODBC. El parámetro es el directorio de instalación de OpenLink ODBC y por defecto vale /usr/local/openlink.

Página de OpenLink Software

Oracle

--with-oracle=DIR

Incluye soporte para Oracle. Se ha probado y debería funcionar al menos con las versiones de la 7.0 a la 7.3. El parámetro es el directorio ORACLE_HOME. No necesita especificar este parámetro si su entorno de Oracle ya está ajustado.

Página de Oracle

PostgreSQL

--with-pgsql=DIR

Incluye soporte para PostgreSQL. El parámetro es el directorio base de la instalación de PostgreSQL y por defecto vale /usr/local/pgsql.

Vea también Directivas de Configuración de Postgres en el archivo de configuración.

Página de PostgreSQL

Solid

--with-solid=DIR

Incluye soporte para Solid. El parámetro es el directorio de instalación y vale por defecto /usr/local/solid.

Página de Solid

Sybase

--with-sybase=DIR

Incluye soporte para Sybase. El parámetro es el directorio de instalación y vale por defecto /home/sybase.

Vea también Directivas de Configuración de Sybase en el archivo de configuración.

Página de Sybase

Sybase-CT

--with-sybase-ct=DIR

Incluye soporte para Sybase-CT. El parámetro es el directorio de instalación de Sybase-CT y por defecto vale /home/sybase.

Vea también Directovas de Configuración de Sybase-CT en el archivo de configuración.

Velocis

--with-velocis=DIR

Incluye soporte para Velocis. El parámetro es el directorio de instalación de Velocis y vale por defecto /usr/local/velocis.

Página de Velocis

Una librería a medida de ODBC

--with-custom-odbc=DIR

Incluye soporte para una librería a medida arbitraria de ODBC. El parámetro es el directorio base y por defecto vale /usr/local.

Esta opción implica que se ha definido CUSTOM_ODBC_LIBS cuando se ejecutó el script de configuración. También deberá tener una cabecera odbc.h válida en algún lugar de su sendero (path) de inclusión. Si no tiene uno, créelo e incluya su cabecera específica desde ahí. Su cabecera puede requerir algunas definiciones extra, particularmente si es multiplataforma. Defínalas en CFLAGS.

Por ejemplo, puede usar Sybase SQL Anywhere bajo QNX como sigue: CFLAGS=-DODBC_QNX LDFLAGS=-lunix CUSTOM_ODBC_LIBS="-ldblib -lodbc" ./configure --with-custom-odbc=/usr/lib/sqlany50

ODBC Unificado

--disable-unified-odbc

Deshabilita el módulo de ODBC Unificado, que es un interfaz común a todas las bases de datos con interfaces basados en ODBC, tales como Solid y Adabas D. También funciona para librerías normales de ODBC. Ha sido probado con iODBC, Solid, Adabas D y Sybase SQL Anywhere. Requiere que uno (y sólo uno) de estos módulos o el módulo de Velocis esté habilitado, o que se especifique una librería a medida de ODBC. Esta opción sólo se puede aplicar si alguna de estas opciones es usada: --with-iodbc, --with-solid, --with-adabas, --with-velocis, o --with-custom-odbc.

Vea también Directivas de Configuración de ODBC Unificado en el archivo de configuración.

LDAP

--with-ldap=DIR

Incluye soporte para LDAP (Lightweight Directory Access Protocol - Protocolo Ligero de Acceso a Directorios). El parámetro es el directorio base de instalación de LDAP, y por defecto vale /usr/local/ldap.

Puede encontrar más información sobre LDAP en RFC1777 y en RFC1778.

Otras opciones de configuración

--with-mcrypt=DIR

--with-mcrypt

Incluye soporte para la librería mcrypt. Vea la documentación de mcrypt para más información. Si utiliza el argumento opcional DIR, el PHP buscará mcrypt.h en DIR/include.

--enable-sysvsem

--enable-sysvsem

Incluye soporte para semáforos Sys V (soportados por muchos derivados Unix). Vea la documentación sobre Semáforos y Memoria Compartida para más información.

--enable-sysvshm

--enable-sysvshm

Incluye soporte para la memoria compartida Sys V (soportada por muchos derivados Unix). Vea la documentación sobre Semáforos y Memoria Compartida para más información.

--with-xml

--with-xml

Incluye soporte para un parser XML no validador que utiliza la librería expat de James Clark. Vea la referencia de funciones XML para más detalles.

--enable-maintainer-mode

--enable-maintainer-mode

Activa avisos extra de dependencias y del compilador utilizados por algunos de los desarrolladores del PHP.

--with-system-regex

--with-system-regex

Utiliza la librería de expresiones regulares del sistema en lugar de la incluída. Si está compilando PHP como módulo de servidor, debe utilizar la misma librería cuando genere el PHP y cuando lo enlace con el servidor. Active esto si la librería del sistema proporciona características especiales que pueda necesitar. Se recomienda utilizar la librería incluída siempre que sea posible.

--with-config-file-path

--with-config-file-path=DIR

El path utilizado para buscar el archivo de configuración cuando arranca el PHP.

--with-exec-dir

--with-exec-dir=DIR

Sólo permite ejecutar programas en DIR cuando está en modo seguro. Por defecto vale /usr/local/bin. Esta opción sólo fija el valor por defecto. Puede ser cambiado posteriormente mediante la directiva safe_mode_exec_dir en el fichero de configuración .

--enable-debug

--enable-debug

Habilita información de depuración adicional. Esto hace posible obtener información más detallada cuando hay problemas con el PHP. (Nótese que esto no tiene que ver con las facilidades de depuración o con la información disponible para los script PHP).

--enable-safe-mode

--enable-safe-mode

Habilita el "modo seguro" por defecto. Esto impone varias restricciones sobre lo que el PHP puede hacer, tales como abrir fichero sólo en el raiz de documentos. Lea el capítulo de Seguridad para más información. Los usuarios de CGI deberán siempre habilitar el modo seguro. Esta opción sólo fija el valor por defecto. Puede ser habilitado o deshabilitado posteriormente mediante la directiva safe_mode en el archivo de configuración.

--enable-track-vars

--enable-track-vars

Hace que el PHP lleve el control de dónde proceden las variables GET/POST/cookie usando las matrices HTTP_GET_VARS, HTTP_POST_VARS y HTTP_COOKIE_VARS. Esta opción sólo fija el valor por defecto. Puede ser habilitado o deshabilitado posteriormente mediante la directiva track_vars en el archivo de configuración.

--enable-magic-quotes

--enable-magic-quotes

Habilita las comillas mágicas por defecto. Esta opción sólo fija el valor por defecto. Puede ser habilitada o deshabilitada posteriormente mediante la directiva magic_quotes_runtime en el archivo de configuración. Vea también las directivas magic_quotes_gpc y magic_quotes_sybase.

--enable-debugger

--enable-debugger

Habilita el soporte de depuración interno del PHP. Esta característica aún está en estado experimental. Vea también las directivas de Configuración del Depurador en el archivo de configuración.

--enable-discard-path

--enable-discard-path

Si está habilitado, el ejecutable CGI del PHP se puede situar tranquilamente fuera del árbol de la web y la gente no podrá saltarse la seguridad del .htaccess. Lea la sección en el capítulo de seguridad sobre esta opción.

--enable-bcmath

--enable-bcmath

Habilita las funciones matemáticas de precisión arbitraria estilo bc. Vea también la opción bcmath.scale en el archivo de configuración.

--enable-force-cgi-redirect

--enable-force-cgi-redirect

Habilita la comprobación de seguridad para redirecciones internas del servidor. Deberá usar esta opción si está ejecutando la versión CGI bajo Apache.

Cuando se utiliza el PHP como un ejecutable CGI, siempre comprueba primero is está siendo utilizado bajo redirección (por ejemplo bajo Apache, usando directivas Action). Esto asegura que el ejecutable del PHP no se puede usar para saltarse los mecanismos estánder de autentificación del servidor web llamando al ejecutale directamente, como en http://my.host/cgi-bin/php/secret/doc.html. Este ejemplo accede al archivo http://my.host/secret/doc.html pero sin respetar ningún ajuste de seguridad del httpd para el directorio /secret.

No habilitando esta opción se deshabilita la comprobación y se permite el saltarse los ajustes de seguridad y autenticación del httpd. Haga esto sólo si el software de su servidor no puede indicar que se ha realizado una redirección segura y que todos sus archivos bajo la raiz de documentos y los directorios de los usuarios pueden ser accedidos por cualquiera.

Lea la sección en el capítulo de seguridad acerca de esta opción.

--disable-short-tags

--disable-short-tags

Deshabilita las etiquetas de PHP en formato corto <? ?>. Debe deshabilitar el formato corto si desea usar PHP con XML. Con el formato corto deshabilitado, la única etiqueta de código de PHP es <?php ?>. Esta opción sólo fija el valor por defecto. Puede ser habilitada o deshabilitada posteriormente mediante la directiva short_open_tag en el archivo de configuración.

--enable-url-includes

--enable-url-includes

Hace posible ejecutar código en otros servidores HTTP o FTP directamente desde el PHP usando include(). Vea también la opción include_path en el archivo de configuración.

--disable-syntax-hl

--disable-syntax-hl

Desconecta el resalte de sintáxis.

CPPFLAGS y LDFLAGS

Para hacer que la instalación de PHP busque los archivos de cabecera o de librería en distintos directorios, modifique las variables de entorno CPPFLAGS y LDFLAGS respectivamente. Si está utilizando un shell "sensible", podrá ejecutar LDFLAGS=-L/my/lib/dir CPPFLAGS=-I/my/include/dir ./configure

Construyendo

Cuando el PHP está configurado, ya está listo para construir el ejecutable CGI o la librería PERL. El comando make debería ocuparse de esto. Si fallara y no puede saber el motivo, vea la sección de Problemas.

Probando

Si ha construído el PHP como un programa CGI, puede probar su funcionamiento tecleando make test. Siempre es buena idea probar su construcción. Así puede atrapar pronto los problemas del PHP en su plataforma sin tener que batallar con ellos luego.

Comprobando la velocidad

Si ha construído el PHP como un programa CGI, puede comprobar la velocidad de su código escribiendo make bench. Nótese que se el modo seguro está habilitado por defecto, el test no podrá finalizar si se toma más de los 30 segundos disponibles. Esto se debe a que la función set_time_limit() no se puede usar en modo seguro. Use el ajuste de configuración max_execution_time para controlar este tiempo en sus propios script. make bench ignora el archivo de configuración.

Anterior | Inicio | Siguiente
Instalación | Subir | Instalación en sistemas Windows 95/98/NT


Instalación en sistemas Windows 95/98/NT

Esta guía de instalación le ayudará a instalar y configurar el PHP en sus servidores web bajo Windows 9x/NT. Esta guía fue compilada por Bob Silva. La última revisión puede encontrarse en http://www.umesd.k12.or.us/php/win32install.html.

Esta guía proporciona soporte de instalacion para:

  • Personal Web Server (se recomienda la última versión)

  • Internet Information Server 3 ó 4

  • Apache 1.3.x

  • Omni HTTPd 2.0b1

Pasos Generales de Instalación

Los siguientes pasos deben realizarse en todas las instalaciones antes de las instrucciones específicas de cada servidor.

  • Extraiga el archivo de distribución a un directorio de su elección. "C:\PHP3\" es un buen comienzo.

  • Copie el archivo 'php3.ini-dist' a su directorio '%WINDOWS%' y renómbrelo a 'php3.ini'. Su directorio '%WINDOWS%' es típicamente:

    c:\windows para Windows 95/98
    c:\winnt o c:\winnt40 para servidores NT

  • Edite su archivo 'php3.ini':

    • Necesitaá cambiar la opción 'extension_dir' para que apunte a su php-install-dir, o a donde quiera que haya puesto sus archivos 'php3_*.dll'. P.ej.: c:\php3

    • Si está utilizando Omni Httpd, no siga el siguiente paso. Fije el 'doc_root' para que apunte a la raiz web de sus servidores. P.ej.: c:\apache\htdocs o c:\webroot

    • Elija qué módulos desearía cargar cuando comience el PHP. Puede descomentar las líneas: 'extension=php3_*.dll' para cargar estos módulos. Algunos módulos requieren que tenga instaladas en sus sistema librerías adicionales para que el módulo funcione correctamente. El FAQ de PHP tiene más información sobre dónde obtener librerías de soporte. También puede cargar un módulo dinámicamente en su script utilizando: dl("php_*.dll");

    • En el PWS y el IIS puede fijar el browscap.ini para que apunte a: 'c:\windows\system\inetsrv\browscap.ini' bajo Windows 95/98 y a 'c:\winnt\system32\inetsrv\browscap.ini' bajo NT Server.

Las DLL para las extensiones del PHP van precedidas de 'php3_'. Esto evita confusiones entre las extensiones del PHP y sus librerías de soporte.

Windows 95/98/NT y PWS/IIS 3

El método recomendado para configurar estos servidores es usar el archivo INF incluído con la distribución (php_iis_reg.inf). Quizás desee editar este archivo y asegurarse que las extensiones y directorios de instalación se ajustan a su configuración. O puede seguir los pasos que siguen para hacerlo de forma manual.

AVISO: Estos pasos conllevan el trabajar directamente con el registro de windows. Un error aquí puede dejar su sistema en un estado inestable. Le recomendamos encarecidamente que haga una copia de seguridad del registro con antelación. El equipo de Desarrollo del PHP no se hará responsable si se daña su registro.

  • Ejecute Regedit.

  • Navegue hasta: HKEY_LOCAL_MACHINE /System /CurrentControlSet /Services /W3Svc /Parameters /ScriptMap.

  • En el menú de edición elija: New->String Value.

  • Escriba la extensión que desea usar para sus script PHP. P.ej.: .php3

  • Haga doble click en el nuevo valor de cadena y escriba la ruta al php.exe en el campo del valor. P.ej.: c:\php3\php.exe %s %s. La parte '%s %s' son MUY importantes, pues el PHP no funcionará correctamente sin ella.

  • Repita estos pasos para cada extensión que desee asociar con los scripts PHP.

  • Ahora navegue hasta: HKEY_CLASSES_ROOT

  • En el menú de edición elija: New->Key.

  • Déle a la clave el nombre de la extensión que preparó en la sección anterior. P.ej.: .php3

  • Marque la nueva clave y en el panel del lado derecho haga doble click en "default value" y escriba phpfile.

  • Repita el último paso para cada extensión que haya preparado en la sección previa.

  • Ahora cree otra New->Key bajo HKEY_CLASSES_ROOT y denomínela phpfile.

  • Marque la nueva clave phpfile y haga doble click en el panel derecho sobre "default value" y escriba PHP Script.

  • Pulse el botón derecho sobre la clave phpfile y seleccione New->Key y llámela Shell.

  • Pulse el botón derecho sobre la clave Shell y elija New->Key y llámela open.

  • Pulse el botón derecho sobre la clave open y elija New->Key y llámela command.

  • Marque la nueva clave command y en el panel derecho haga doble click sobre "default value" y entre la ruta hasta el php.exe. P.ej.: c:\php3\php.exe -q %1. (no olvide el %1).

  • Salga del Regedit.

Los usuarios de PWS e IIS3 tienen ahora un sistema completamente operativo. Los usuarios del IIS3 también pueden usar una curiosa herramienta de Steven Genusa para configurar sus mapeados de script.

Windows NT e IIS 4

Para instalar el PHP en un NT Server con IIS 4, siga estas instrucciones:

  • En el Controlador de Servicios de Internet (MMC), elija el sitio Web o el directorio de comienzo de una aplicación.

  • Abra las propiedades del directorio (haciendo click derecho y eligiendo propiedades) y luego pulse sobre la pestaña Carpeta Inicial, Directorio Virtual o Directorio.

  • Pulse el botón Configuración y luego pulse sobre la pestaña Mapas de Aplicación.

  • Pulse en Añadir, y en la caja Programa, escriba: c:\path-to-php-dir\php.exe %s %s. DEBE mantene los %s %s al final, pues el PHP no funcionará correctamente si se equivoca al hacerlo.

  • En la caja Extensión, escriba la extensión de fichero que desea asociar a los script de PHP. Debe repetir los pasos 5 y 6 para cada extensión que desee asociar con los scripts PHP ( .php3 y .phtml son habituales).

  • Ajuste la seguridad apropiada (esto se realiza en el Controlador de Servicio de Internet (ISM)), y si su NT Server usa el sistema de archivos NTFS, añada derechos de ejecución para I_USR_ al directorio que contenga el php.exe.

Windows 9x/NT y Apache 1.3.x

Debe editar sus archivos srm.conf o httpd.conf para configurar el Apache para que trabaje con el ejecutable CGI del PHP.

Aunque puede haber algunas variaciones al configurar PHP bajo Apache, esta es lo suficientemente simple para ser usada por el novato. Por favor, consulte la Documentación del Apache para saber de las subsiguientes directivas de configuración.

  • ScriptAlias /php3/ "c:/ruta-al-dir-del-php/"

  • AddType application/x-httpd-php3 .php3

  • AddType application/x-httpd-php3 .phtml

  • Action application/x-httpd-php3 "/php3/php.exe"

Para utilizar la capacidad de marcado del código fuente, cree simplemente un script de PHP y pegue este código en él: <?php show_source("script_original_php.php3"); ?>. Sustituya script_original_php.php3 por el nombre del archivo del que desea visualizar el código fuente (esta es la única forma de hacerlo). Nota: Bajo Win-Apache todas las barras invertidas de una ruta tal como: "c:\directory\file.ext", deben ser convertidas a barras hacia adelante.

Omni HTTPd 2.0b1 para Windows

Esta ha resultado ser la configuración más sencilla:

Paso 1: Instale el servidor Omni
Paso 2: Pulse el botón derecho sobre el icono azul del OmniHTTPd que está en la barrita del sistema y elija Propiedades
Paso 3: Pulse sobre Web Server Global Settings
Paso 4: En la pestaña 'External', escriba: virtual = .php3 | actual = c:\ruta-al-dir-del-php\php.exe
Paso 5: En la pestaña Mime, escriba: virtual = wwwserver/stdcgi | actual = .php3
Paso 6: Pulse en OK

Repita los pasos 2 a 6 para cada extensión que desee asociar al PHP.

Módulos del PHP

Tabla 2-1. Módulos del PHP

php3_calendar.dll | Funciones de conversión de calendario
php3_crypt.dll | Funciones de criptografía
php3_dbase.dll | Funciones para DBase
php3_dbm.dll | Emulación GDBM con la librería Berkeley DB2
php3_filepro.dll | Acceso SÓLO LECTURA a bases de datos filepro
php3_gd.dll | Funciones de librería GD para manipular GIF
php3_hyperwave.dll | Funciones de HyperWave
php3_imap4r2.dll | Funciones de IMAP 4
php3_ldap.dll | Funciones de LDAP
php3_msql1.dll | Cliente de mSQL 1
php3_msql2.dll | Cliente de mSQL 2
php3_mssql.dll | Cliente de MSSQL client (requiere las librerías de MSSQL DB
php3_mysql.dll | Funciones de MySQL
php3_nsmail.dll | Funciones de correo de Netscape
php3_oci73.dll | Funciones de Oracle
php3_snmp.dll | Funciones get y walk de SNMP (¡sólo en NT!)
php3_zlib.dll | Funciones de ZLib

Anterior | Inicio | Siguiente
Instalación en sistemas UNIX | Subir | ¿Problemas?


¿Problemas?

Lea las PMF (FAQ)

Algunos problemas son más comunes que otros. Los más comunes están listados en las PMF (Preguntas Más Frecuentes) del PHP, que están en http://www.php.net/FAQ.php

Informes de error

Si cree que ha encontrado un error en el PHP, por favor infórmenos. Los desarrolladores del PHP probablemente no tengan conocimiento del mismo, y salvo si informa del mismo, pocas probabilidades habrá de que lo solucionen. Puede informar de los errores usando el sistema de rastreo de errores en http://bugs.php.net/.

Otros problemas

Si aún se encuentra atascado, alguien de la lista de correos del PHP puede ser capaz de ayudarle. Deberá buscar primero en los archivos, por si acaso alguien ya ha respondido a otra persona que tuvo el mismo problema que usted. Los archivos están disponibles desde la página de soporte en http://www.php.net/. Para suscribirse a la lista de correo de PHP, envíe un correo vacío a php-general-subscribe@lists.php.net. La dirección de la lista de correo es php-general@lists.php.net.

Si desea ayuda sobre la lista de correo, intente ser preciso y de los detalles necesarios sobre su entorno (qué sistema operativo, qué versión de PHP, qué servidor web, si está ejecutando el PHP como CGI o como módulo de servidor, etc.) y también código suficiente para que otros puedan reproducir y comprobar su problema.

Anterior | Inicio | Siguiente
Instalación en sistemas Windows 95/98/NT | Subir | Configuración


Configuración

Manual de PHP
Anterior Siguiente

Capítulo 3. Configuración

Tabla de contenidos
El archivo de configuración

El archivo de configuración

El archivo de configuración (llamado php3.ini en PHP 3.0, y simplemente php.ini a partir del PHP 4.0) es leído cuando arranca el PHP. Para las versiones de PHP como módulo de servidor esto sólo ocurre una vez al arrancar el servidor web. Para la versión CGI, esto ocurre en cada llamada.

Cuando se utiliza PHP como módulo Apache, también puede cambiar los ajustes de configuración utilizando directivas en los archivos de configuración del Apache y en los .htaccess.

Con el PHP 3.0 hay directivas Apache que se corresponden a cada uno de los ajustes de configuración del php3.ini, con la excepción que su nombre va precedido de "php3_".

Con el PHP 4.0 sólo hay unas pocas directivas de Apache que le permiten cambiar los ajustes de configuración del PHP.

php_value nombre valor

Fija el valor de la variable especificada.

php_flag nombre on|off

Fija una opción de configuración de tipo Boolean.

php_admin_value nombre valor

Fija el valor de la variable especificada. Los ajustes de configuración de tipo "Admin" sólo se pueden fijar desde los archivos principales de configuración del Apache, y no desde los .htaccess.

php_admin_flag nombre on|off

Fija una opción de configuración de tipo Boolean.

Puede ver los ajustes de los valores de configuración en la salida de phpinfo(). También puede acceder a los valores individuales de los ajustes de configuración utilizando get_cfg_var().

Directivas Generales de Configuración

asp_tags boolean

Permite el uso de las etiquetas estilo ASP <% %> además de las habituales etiquetas <?php ?>. También se incluye el atajo para imprimir variables <%= $valor %>. Para más información, vea Escapando del HTML.

Nota: El soporte para etiquetas estilo ASP se añadió en la 3.0.4.

auto_append_file string

Especifica el nombre de un archivo que es troceado automáticamente después del archivo principal. El archivo se incluye como si fuese llamado mediante la función include(), así que se utiliza include_path.

El valor especial none desconecta la adición automática de archivos.

Nota: Si el script es terminado con exit(), no tendrá lugar la adición automática.

auto_prepend_file string

Especifica el nombre de un archivo que es troceado automáticamente antes del archivo principal. Specifies the name of a file that is automatically parsed before the main file. El archivo se incluye como si fuese llamado mediante la función include(), así que se utiliza include_path.

El valor especial none desconecta la adición automática de archivos.

cgi_ext string

display_errors boolean

Determina si los errores se visualizan en pantalla como parte de la salida en HTML o no.

doc_root string

"Directorio raiz" del PHP en el servidor. Sólo se usa si no está vacío. Si el PHP se configura con safe mode, no se sirven archivos fuera de este directorio.

engine boolean

Esta directiva sólo es realmente útil en la versión de PHP como módulo Apache. Se utiliza por sitios que desean habilitar la ejecución del PHP directorio por directorio o en base a cada servidor virtual. Poniendo php3_engine off en los sitios apropiados del archivo httpd.conf, se puede habilitar o deshabilitar el PHP.

error_log string

Nombre del fichero para registrar los errores de un script. Si se utiliza el valor especial syslog, los errores se envían al registro de errores del sistema. En UNIX se refiere a syslog(3) y en Windows NT al registro de eventos. El registro de errores del sistema no es soportado bajo Windows 95.

error_reporting integer

Fija el nivel de informe de errores. El parámetro es un entero que representa un campo de bits. Sume los valores de los niveles de informe de error que desea.

Tabla 3-1. Niveles de Informe de Errores

valor de bit | informe habilitado
1 | errores normales
2 | avisos normales
4 | errores del troceador (parser)
8 | avisos de estilo no críticos
El valor por defecto para esta directiva es 7 (se muestran los errores normales, avisos normales y errores de parser).

open_basedir string

Limita los archivos que se pueden abrir por el PHP al árbol de directorios especificado.

Cuando un script intenta abrir un archivo con, por ejemplo, fopen o gzopen, se comprueba su localización. Si el fichero está fuera del árbol de directorios especificado, PHP se negará a abrirlo. Todos los enlaces simbólicos son resueltos, de modo que no es posible evitar esta limitación usando uno de ellos.

El valor especial . indica que el directorio base será aquel en el que reside el script.

Bajo Windows, separe los directorios mediante punto y coma. En el resto de sistemas, sepárelos con dos puntos ":". Como módulo de Apache, los senderos para open_basedir de los directorios padre se heredan ahora automáticamente.

Nota: El soporte para directorios múltiples se añadió en la 3.0.7.

El valor por defecto es permitir abrir todos los archivos.

gpc_order string

Fija el order de troceo de variables GET/POST/COOKIE. El valor por defecto de esta directiva es "GPC". Fijándola, por ejemplo, a "GP", hará que el PHP ignore por completo las cookies y que sobreescriba las variables recibidas por GET con las que tengan el mismo nombre y vengan por POST.

ignore_user_abort string

Por defecto está a on. Si se cambia a off, los script terminarán tan pronto como intenten enviar algo después de que un cliente ha roto la conexión. ignore_user_abort().

include_path string

Especifica una lista de directorios en los que las funciones require(), include() y fopen_with_path() buscan los archivos. El formato es similar a la variable de entorno de sistema PATH: una lista de directorios separados por dos puntos en UNIX o por punto y coma en Windows.

Ejemplo 3-1. include_path en UNIX

include_path=.:/home/httpd/php-lib

Ejemplo 3-2. include_path en Windows

include_path=".;c:\www\phplib"
El valor por defecto para esta directiva es . (sólo el directorio actual).

isapi_ext string

log_errors boolean

Dice si los mensajes de error de los script deben ser registrados o no en el registro del servidor. Esta opción, por tanto, es específica del mismo.

magic_quotes_gpc boolean

Fija el estado magic_quotes para operaciones GPC (Get/Post/Cookie). Si magic_quotes vale on, todas las ' (comilla sencilla), " (comilla doble), \ (barra invertida) y los NUL son automáticamente marcados con una barra invertida. Si además magic_quotes_sybase vale on, la comilla sencilla es marcada con otra comilla sencilla en lugar de la barra invertida.

magic_quotes_runtime boolean

Si se habilita magic_quotes_runtime, muchas de las funciones que devuelven datos de algún tipo de fuente externa incluyendo bases de datos y archivos de texto devolverán las comillas marcadas con una barra invertida. Si también está activo magic_quotes_sybase, la comilla simple es marcada con una comilla simple en lugar de la barra invertida.

magic_quotes_sybase boolean

Si magic_quotes_sybase está a on, la comilla simple es marcada con una comilla simple en lugar de la barra invertida cuando están habilitados magic_quotes_gpc o magic_quotes_runtime.

max_execution_time integer

Fija el tiempo máximo en segundos que se le permite usar a un script antes de ser finalizado por el intérprete. Así se evita que scripts mal escritos puedan bloquear el servidor.

memory_limit integer

Fija el tamaño máximo de memoria en bytes que se permite reclamar a un script. Así se evita que script mal escritos se coman toda la memoria dispomible de un servidor.

nsapi_ext string

short_open_tag boolean

Indica si se debe permitir el formato corto (<? ?>) de la etiqueta de apertura del PHP. Si desea utilizar PHP en combinación con XML, deberá desactivar esta opción. Si está desactivada, deberá utilizar el formato largo de la etiqueta de apertura (<?php ?>).

sql.safe_mode boolean

track_errors boolean

Si está habilitada, el último mensaje de error estará siempre presente en la variable global $php_errormsg.

track_vars boolean

Si está activada, la información de entrada de GET, POST y de las cookies se puede encontrar en las matrices asociativas $HTTP_GET_VARS,$HTTP_POST_VARS y $HTTP_COOKIE_VARS respectivamente.

upload_tmp_dir string

El directorio temporal utilizado para almacenar archivos cuando se envían al servidor. Debe tener permiso de escritura para el usuario bajo el que corra el PHP.

user_dir string

El nombre base del directorio utilizado bajo el directorio inicial de un usuario para los archivos PHP. Por ejemplo: paginas_html.

warn_plus_overloading boolean

Si está activada, esta opción hace que el PHP muestre un aviso cuando el operador suma (+) se utiliza en cadenas. Así es más fácil encontrar scripts que necesitan ser reescritos utilizando en su lugar el concatenador de cadenas (.).

Directivas de Configuración de Correo

SMTP string

Nombre DNS o dirección IP del servidor de SMTP que el PHP bajo Windows deberá usar para enviar correo con la función mail().

sendmail_from string

La dirección del remitente ("De:") para los correos enviados desde PHP bajo Windows.

sendmail_path string

Localización del programa sendmail. Generalmente /usr/sbin/sendmail o /usr/lib/sendmail. configure intenta localizarle este archivo lo mejor que puede y fijar un valor por defecto, pero en caso de fallo, lo puede usted fijar aquí.

Los sistemas que no usan sendmail deberán fijar esta directiva al nombre del programa alternativo que ofrezca su sistema de correo, si es que existe. Por ejemplo, los usuarios del Qmail pueden fijarlo normalmente a /var/qmail/bin/sendmail.

Directivas de Configuración de Modo Seguro

safe_mode boolean

Para activar el modo seguro del PHP. Lea el Capítulo de seguridad para más información.

safe_mode_exec_dir string

Si el PHP se utiliza en modo seguro, la función system() y el resto de funciones que ejecutan programas del sistema se niegan a ejecutar programas que no estén en este directorio.

Directivas de Configuración del Debugger

debugger.host string

Nombre DNS o dirección IP del servidor usado por el debugger.

debugger.port string

Número de puerto usado por el debugger.

debugger.enabled boolean

Indica si el debugger está habilitado o no.

Directivas de Carga de Extensiones

enable_dl boolean

Esta directiva sólo es útil en la versión del PHP como módulo del Apache. Puede habilitar o deshabilitar para un servidor virtual o para un directorio la carga dinámica de extensiones de PHP mediante dl().

La razón principal para deshabilitar la carga dinámica es la seguridad. Con la carga dinámica es posible ignorar las restricciones safe_mode y open_basedir.

El valor por defecto es permitir la carga dinámica, excepto cuando se usa el modo seguro. En modo seguro, siempre es imposible usar dl().

extension_dir string

En qué directorio debe buscar el PHP las extensiones cargables dinámicamente.

extension string

Qué extensiones dinámicas debe cargar el PHP cuando arranca.

Directivas de Configuración de MySQL

mysql.allow_persistent boolean

Si permitir o no conexiones MySQL persistentes.

mysql.default_host string

El servidor por defecto para utilizar cuando se conecte al servidor de bases de datos si no se especifica otro distinto.

mysql.default_user string

El nombre de usuario por defecto para utilizar cuando se conecta al servidor de base de datos si no se especifica otro.

mysql.default_password string

La clave por defecto para utilizar cuando se conecta al servidor de base de datos si no se especifica otro.

mysql.max_persistent integer

El número máximo de conexiones persistentes de MySQL por proceso.

mysql.max_links integer

El número máximo de conexiones de MySQL por proceso, incluyendo las persistentes.

Directivas de Configuración de mSQL

msql.allow_persistent boolean

Si se permiten o no conexiones persistentes de mSQL.

msql.max_persistent integer

El número máximo de conexiones persistentes mSQL por proceso.

msql.max_links integer

El número máximo de conexiones de mSQL por proceso, incluyendo las persistentes.

Directivas de Configuración de Postgres

pgsql.allow_persistent boolean

Si se permiten o no conexiones persistentes de Postgres.

pgsql.max_persistent integer

El número máximo de conexiones persistentes Postgres por proceso.

pgsql.max_links integer

El número máximo de conexiones de Postgres por proceso, incluyendo las persistentes.

SESAM Configuration Directives

sesam_oml string

Name of BS2000 PLAM library containing the loadable SESAM driver modules. Required for using SESAM functions. The BS2000 PLAM library must be set ACCESS=READ,SHARE=YES because it must be readable by the apache server's user id.

sesam_configfile string

Name of SESAM application configuration file. Required for using SESAM functions. The BS2000 file must be readable by the apache server's user id.

The application configuration file will usually contain a configuration like (see SESAM reference manual):

CNF=B
NAM=K
NOTYPE

sesam_messagecatalog string

Name of SESAM message catalog file. In most cases, this directive is not neccessary. Only if the SESAM message file is not installed in the system's BS2000 message file table, it can be set with this directive.

The message catalog must be set ACCESS=READ,SHARE=YES because it must be readable by the apache server's user id.

Directivas de Configuración de Sybase

sybase.allow_persistent boolean

Si se permiten o no conexiones persistentes de Sybase.

sybase.max_persistent integer

El número máximo de conexiones persistentes Sybase por proceso.

sybase.max_links integer

El número máximo de conexiones de Sybase por proceso, incluyendo las persistentes.

Directivas de Configuración de Sybase-CT

sybct.allow_persistent boolean

Si se permiten o no conexiones persistentes de Sybase-CT. El valor por defecto es on.

sybct.max_persistent integer

El número máximo de conexiones persistentes Sybase-CT por proceso. El valor por defecto es -1, que significa ilimitadas.

sybct.max_links integer

El número máximo de conexiones de Sybase-CT por proceso, incluyendo las persistentes. El valor por defecto es -1, que significa ilimitadas.

sybct.min_server_severity integer

Los mensajes de servidor con gravedad mayor o igual que sybct.min_server_severity serán reportados como avisos. Este valor también se puede cambiar desde un script usando la función sybase_min_server_severity(). El valor por defecto es 10, que reporta los errores de información con gravedad o mayores.

sybct.min_client_severity integer

Los mensajes de librería de cliente con gravedad mayor o igual que sybct.min_client_severity serán reportados como avisos. Este valor también se puede cambiar desde un script usando la función sybase_min_client_severity(). El valor por defecto es 10, que desconecta los avisos.

sybct.login_timeout integer

El número máximo de segundos de espera por un intento de conexión con éxito antes de indicar un fallo. Nótese que si se ha excedido max_execution_time cuando finaliza la espera de un intento de conexión, el script será finalizado antes de que se pueda tomar una acción en caso de fallo. El valor por defecto es 1 minuto.

sybct.timeout integer

El número máximo de segundos de espera por una operación de consulta o select_db con éxito antes de indicar un fallo. Nótese que si se ha excedido max_execution_time cuando finaliza la espera de un intento de conexión, el script será finalizado antes de que se pueda tomar una acción en caso de fallo. El valor por defecto es sin límite.

sybct.hostname string

El nombre de la máquina desde la que dice estarse conectando, para que se visualize con sp_who(). El valor por defecto es "none".

Directivas de Configuración de Informix

ifx.allow_persistent boolean

Si se permiten o no conexiones persistentes de Informix.

ifx.max_persistent integer

El número máximo de conexiones persistentes de Informix por proceso.

ifx.max_links integer

El número máximo de conexiones Informix por proceso, incluyendo las persistentes.

ifx.default_host string

El servidor por defecto al que conectarse si no se especifica uno en ifx_connect() o en ifx_pconnect().

ifx.default_user string

El id de usuario por defecto para utilizar si no se especifica uno en ifx_connect() o en ifx_pconnect().

ifx.default_password string

La clave por defecto para utilizar si no se especifica uno en ifx_connect() o en ifx_pconnect().

ifx.blobinfile boolean

Fíjelo a TRUE si desea recibir las columnas blob (objetos binarios grandes) en un archivo, y a FALSE si las desea en memoria. Puede cambiar el ajuste en tiempo de ejecución utilizando ifx_blobinfile_mode().

ifx.textasvarchar boolean

Fíjelo a TRUE si desea recibir las columnas TEXT como cadenas normales en las instrucciones select, y a FALSE si quiere usar parámetros de identificador de blobs. Puede cambiar el ajuste en tiempo de ejecución utilizando ifx_textasvarchar().

ifx.byteasvarchar boolean

Fíjelo a TRUE si desea devolver las columnas BYTE como cadenas normales en las instrucciones select, y a FALSE si quiere usar parámetros de identificador de blobs. Puede cambiar el ajuste en tiempo de ejecución utilizando ifx_byteasvarchar().

ifx.charasvarchar boolean

Fíjelo a TRUE si desea suprimir los espacios a la derecha de las columnas CHAR cuando las solicita.

ifx.nullformat boolean

Fíjelo a TRUE si desea que las columnas NULL (nulas) se devuelvan como la cadena literal "NULL", y a FALSE si desea que se devuelvan como la cadena vacía "". Puede cambiar el ajuste en tiempo de ejecución utilizando ifx_nullformat().

Directivas de Configuración de Matemática BC

bcmath.scale integer

Número de dígitos decimales para todas las funciones de bcmath.

Directivas de Configuración de Capacidades de los Navegadores

browscap string

Nombre del archivo de capacidades del navegador. Vea también get_browser().

Directivas Unificadas de Configuración de ODBC

uodbc.default_db string

Fuentes de datos ODBC a utilizar si no se especifica una en odbc_connect() o en odbc_pconnect().

uodbc.default_user string

Nombre de usuario si no se especifica uno en odbc_connect() o en odbc_pconnect().

uodbc.default_pw string

Clave para usar si no se especifica una en odbc_connect() o en odbc_pconnect().

uodbc.allow_persistent boolean

Si se permiten o no conexiones persistentes de ODBC.

uodbc.max_persistent integer

El número máximo de conexiones persistentes de ODBC por proceso.

uodbc.max_links integer

El número máximo de conexiones ODBC por proceso, incluyendo las persistentes.

Anterior | Inicio | Siguiente
¿Problemas? | Subir | Seguridad


Seguridad

Manual de PHP
Anterior Siguiente

Capítulo 4. Seguridad

Tabla de contenidos
Binarios CGI
Modulo Apache

PHP es un potente lenguaje y el interprete, tanto incluido en el servidor web como modulo o ejecutado como un binario CGI, puede acceder a ficheros, ejecutar comandos y abrir comunicaciones de red en el servidor. Todas estas caracteristicas hacen que lo que se ejecute en el servidor web sea inseguro por defecto. PHP ha sido disenado especificamente, para ser un lenguaje mas seguro para escribir programas CGI, que Perl o C y con la correcta seleccion de las opciones de configuración del tiempo de compilación y ejecucion se consigue la exacta combinación de libertad y seguridad que se necesita.

Ya que existen diferentes modos de utilizar PHP, existen multitud de opciones de configuración que permiten controlar su funcionamiento. Una gran selección de opciones garantiza que se pueda usar PHP para diferentes usos, pero tambien significa que existen combinaciones de estas opciones y configuraciones del servidor que producen instalaciones inseguras. Este capitulo explica las diferentes combinaciones de opciones de configuración y las situaciones donde pueden ser usadas de manera segura.

Binarios CGI

Posibles ataques

Usando PHP como un binario CGI es una opción para instalaciones que por cualquier causa no quieren integrar PHP como modulo en el software servidor (p.ej: Apache), o usaran PHP con diferentes clases de CGI wrappers para crear entornos chroot y setuid seguros para los scripts. Esta configuración implica generalmente el instalar el binario ejecutable de PHP en el directorio cgi-bin del servidor web. El documento del CERT CA-96.11 recomienda no instalar interpretes en cgi-bin. Aunque el binario PHP puede ser usado como interprete independiente, PHP esta diseñado para prevenir los ataques que esta configuración hace posible.

  • Accediendo a ficheros del sistema: http://my.host/cgi-bin/php?/etc/passwd

    La información introducida despues del signo de interrogación (?) es transferida como argumento de la línea de comando al intérprete por el interfaz del CGI. Normalmente los interpretes abren y ejecutan el fichero especificado como el primer argumento en la línea de comando.

    Cuando se ejecuta como un CGI script, PHP rechaza interpretar los argumentos de la línea de comando.

  • Accediendo cualquier documento web en el servidor: http://my.host/cgi-bin/php/secret/doc.html

    La información con el camino (path) de la URL despues del nombre del binario PHP, /secret/doc.html es usada convencionalmente para especificar el nombre del fichero que sera abierto e interpretado por el programa CGI. Normalmente, algunas directivas del servidor web (Apache:Action) son usadas para redireccionar peticiones de documentos como http://my.host/secret/script.php3 al interprete PHP. Con esta configuración, el servidor web comprueba primero los permisos de acceso al directorio /secret, y despues crea la petición redireccionada http://my.host/cgi-bin/php/secret/script.php3. Desafortunadamente, si la petición es hecha de esta forma en un principio, el servidor web no comprueba los permisos de acceso del fichero /secret/script.php3, sino solamente del fichero /cgi-bin/php. De esta manera cualquier usuario que pueda acceder /cgi-bin/php tambien puede acceder a cualquier documento protegido en el servidor web.

    En PHP, a la hora de compilar, la opción de configuracion --enable-force-cgi-redirect y las directivas de configuracion a la hora de ejecutar doc_root y user_dir pueden ser usadas para prevenir este ataque, si el arbol de documentos del servidor tiene cualquier directorio con acceso restringido. Ver mas adelante la explicacion de las diferentes combinaciones.

Caso 1: solamente se sirven ficheros publicos

Si tu servidor no contiene informacion que este protegida con clave o acceso de control de IPs, no se necesitan estas opciones de configuracion. Si tu servidor web no permite realizar redireccionamientos, o el servidor no tiene modo de comunicar al binario PHP que la peticion es una peticion segura redireccionada, podeis especificar la opcion --disable-force-cgi-redirect en el script de configuracion. De todas maneras, teneis que aseguraros que vuestros scripts PHP no confíen en la manera al llamar al script, ni de forma directa http://my.host/cgi-bin/php/dir/script.php3 o por redireccion http://my.host/dir/script.php3.

Redireccionamiento puede ser configurado en Apache usando las directivas AddHandler y Action (ver mas abajo).

Caso 2: usando --enable-force-cgi-redirect

Esta opcion a la hora de compilar previene que alguien llame PHP directamente con una url como la siguiente http://my.host/cgi-bin/php/secretdir/script.php3. PHP solamente analizara en este modo si ha pasado por una regla de redireccionamiento en el servidor.

Normalmente la redireccion en la configuracion de Apache es hecha con la siguientes directivas:

Action php3-script /cgi-bin/php
    AddHandler php3-script .php3

Esta opcion ha sido solo comprobada con el servidor web Apache, y depende de Apache para fijar la variable de entorno CGI no estandar REDIRECT_STATUS en las peticiones de redireccionamiento. Si tu servidor web no soporta ningun modo para informar si una peticion es directa o redireccionada, no podeis usar esta opcion y debereis usar alguno de los otros modos de ejecucion de la version CGI documentados aqui.

Caso 3: Usando doc_root or user_dir

Incluir contenidos activos, como script y ejecutables, en el directorio de documentos del servidor web, es algunas veces considerada una practica insegura. Si por algun fallo de configuracion, los scripts no son ejecutados pero mostrados como documentos HTML, cualquiera podra conseguir codigo registrado o informacion de seguridad, como p.ej: claves de acceso. Por ello, muchos administradores prefieren utilizar otra estructura de directorios que contenga solamente los scripts, los cuales seran solamente accesibles via PHP CGI, y por ello siempre seran interpretados y no mostrados.

Habra que tener en cuenta que si el metodo que asegura que las peticiones no son redireccionadas, como hemos descrito en la seccion anterior, no esta disponible, sera necesario configurar un script doc_root que sea diferente del "web document root".

Podeis definir el script PHP "document root" con la directiva de configuracion doc_root en el fichero de configuracion, o definir la variable de entorno PHP_DOCUMENT_ROOT. Si esta definida, la version CGI de PHP siempre obtendra el nombre del fichero a abrir con doc_root y el camino (path) utilizado en la peticion, asi podeis estar seguros que ningun script sera ejecutado fuera de este directorio (excepto para user_dir, ver a continuacion)

Otra opcion que se puede usar aqui es user_dir. Cuando user_dir no esta definido, lo unico que controla la apertura del fichero es doc_root. Si intentamos abrir una url tal como esta http://my.host/~user/doc.php3 no se abrira un fichero en el directorio de usuarios, en su lugar se abrira un fichero llamado ~user/doc.php3 en el directorio doc_root. (si, un directorio que empieza por tilde [~]).

Si user_dir esta definido por ejemplo como public_php, una peticion tal como http://my.host/~user/doc.php3, abrira un fichero llamado doc.php3 en el directorio llamado public_php del directorio "home" del usuario. Si el directorio del usuario es /home/user, el fichero ejecutado sera /home/user/public_php/doc.php3.

La expansion de user_dir ocurre sin tener en cuenta la configuracion de doc_root, de este modo se puede controlar los accesos al directorio principal (document root) y al directorio de usuario separadamente.

Caso 4: Analizador PHP fuera del arbol web.

Una opcion muy segura es poner el analizador binario PHP, en algun lugar fuera del arbol de ficheros web. Por ejemplo en /usr/local/bin. La unica pega real de esta opcion es que habra que poner una linea similar a:

#!/usr/local/bin/php

como primera linea en cualquier fichero que contenga codigo PHP. Tambien sera necesario asignar al fichero permisos de ejecucion. De esta manera, es tratado de la misma manera que cualquier otro CGI script escrito en Perl o sh o otro lenguaje utilizado para scripts y que utilicen el mecanismo #! para ejecutarse.

Para conseguir que PHP maneje correctamente con esta configuracion, la informacion de PATH_INFO y PATH_TRANSLATED, el analizador PHP deberia ser compilado con la opcion de configuracion --enable-discard-path.

Anterior | Inicio | Siguiente
Configuración | Subir | Modulo Apache


Modulo Apache

Cuando PHP es usado como modulo Apache, hereda los permisos de usuario de Apache (normalmente "nobody")

Anterior | Inicio | Siguiente
Seguridad | Subir | Referencia del Lenguaje


Referencia del Lenguaje

Manual de PHP
Anterior Siguiente

II. Referencia del Lenguaje

Tabla de contenidos
5. Sintaxis básica
6. Types
7. Variables
8. Constantes
9. Expresiones
10. Operadores
11. Estructuras de Control
12. Funciones
13. Clases y Objetos
14. References Explained

Anterior | Inicio | Siguiente
Modulo Apache |  | Sintaxis básica


Sintaxis básica

Manual de PHP
Anterior Siguiente

Capítulo 5. Sintaxis básica

Tabla de contenidos
Saliendo de HTML
Separación de instrucciones
Comentarios

Saliendo de HTML

Hay cuatro formas de salir de HTML y entrar en el "modo de código PHP":

Ejemplo 5-1. Formas de salir de HTML

1.  <? echo ("esta es la más simple, una instrucción de procesado SGML\n"); ?>

2.  <?php echo("si quiere servir documentos XML, haga esto\n"); ?>

3.  <script language="php">
        echo ("a algunos editores (como FrontPage) no les
              gustan las intrucciones de procesado");
    </script>

4.  <% echo ("Puedes también usar etiquetas tipo ASP"); %>
    <%= $variable; # Esto es una forma abreviada de "<%echo .." %>

La primera forma sólo está disponible si se han habilitado las etiquetas cortas. Esto se puede hacer a través de la función short_tags(), habilitando la opción de configuración short_open_tag en el archivo de configuración de PHP, o compilando PHP con la opción --enable-short-tags en configure.

La cuarta manera está disponible sólo si se han habilitado las etiquetas tipo ASP usando la opción de configuración asp_tags.

Nota: El soporte para las etiquetas tipo ASP se añadió en 3.0.4.

La etiqueta de cierre de un bloque incluirá el carácter de nueva línea final si hay uno presente.

Anterior | Inicio | Siguiente
Referencia del Lenguaje | Subir | Separación de instrucciones


Separación de instrucciones

Las instrucciones se separan igual que en C o perl - terminando cada sentencia con un punto y coma.

La etiqueta de cierre (?>) también implica el fin de la sentencia, así lo siguiente es equivalente:

<?php
    echo "Esto es una prueba";
?>

<?php echo "Esto es una prueba" ?>

Anterior | Inicio | Siguiente
Sintaxis básica | Subir | Comentarios


Comentarios

PHP soporta comentarios tipo 'C', 'C++' y shell de Unix. Por ejemplo:

<?php
    echo "Esto es una prueba"; // Esto es un comentario tipo c++ para una línea
    /* Esto es un comentario multilínea
       otra línea más de comentario*/
    echo "Esto es aún otra prueba";
    echo "Una Prueba Final"; # Este es un comentario tipo shell
?>

El tipo de comentario de "una línea" sólo comenta, en realidad, hasta el fin de la línea o el bloque actual de código PHP, lo que venga primero.

<h1>Esto es un <?# echo "simple";?> ejemplo.</h1>
<p>La cabecera de arriba dirá 'Esto es un ejemplo'.

Se debería tener cuidado para no anidar comentarios de tipo 'C', lo cual puede ocurrir cuando se comentan grandes bloques.

<?php
 /*
    echo "Esto es una prueba"; /* Este comentario causará un problema */
 */
?>

Anterior | Inicio | Siguiente
Separación de instrucciones | Subir | Types


Types

Manual de PHP
Anterior Siguiente

Capítulo 6. Types

Tabla de contenidos
Enteros
Números en punto flotante
Cadenas
Arrays
Objetos
Type juggling

PHP soporta los siguientes tipos:

  • array

  • números en punto flotante

  • entero

  • objeto

  • cadena

El tipo de una variable normalmente no lo indica el programador; en su lugar, lo decide PHP en tiempo de ejecución dependiendo del contexto en el que se utilice esa variable.

Si se quisiese obligar a que una variable se convierta a un tipo concreto, se podría forzar la variable o usar la función settype() para ello.

Nótese que una variable se puede comportar de formas diferentes en ciertas situaciones, dependiendo de qué tipo sea en ese momento. Para más información, vea la sección Conversión de Tipos.

Enteros

Los enteros se puede especificar usando una de las siguientes sintaxis:

$a = 1234; # número decimal
$a = -123; # un número negativo
$a = 0123; # número octal (equivalente al 83 decimal)
$a = 0x12; # número hexadecimal (equivalente al 18 decimal)

Anterior | Inicio | Siguiente
Comentarios | Subir | Números en punto flotante


Números en punto flotante

Los números en punto flotante ("double") se pueden especificar utilizando cualquiera de las siguientes sintaxis:

$a = 1.234; $a = 1.2e3;

Anterior | Inicio | Siguiente
Types | Subir | Cadenas


Cadenas

Las cadenas de caracteres se pueden especificar usando uno de dos tipos de delimitadores.

Si la cadena está encerrada entre dobles comillas ("), las variables que estén dentro de la cadena serán expandidas (sujetas a ciertas limitaciones de interpretación). Como en C y en Perl, el carácter de barra invertida ("\") se puede usar para especificar caracteres especiales:

Tabla 6-1. Caracteres protegidos

secuencia | significado
\n | Nueva línea
\r | Retorno de carro
\t | Tabulación horizontal
\\ | Barra invertida
\$ | Signo del dólar
\" | Comillas dobles
\[0-7]{1,3} | la secuencia de caracteres que coincida con la expresión regular es un carácter en notación octal
\x[0-9A-Fa-f]{1,2} | la secuencia de caracteres que coincida con la expresión regular es un carácter en notación hexadecimal

Se puede proteger cualquier otro carácter, pero se producirá una advertencia en el nivel de depuración más alto.

La segunda forma de delimitar una cadena de caracteres usa el carácter de comilla simple ("'"). Cuando una cadena va encerrada entre comillas simples, los únicos caracteres de escape que serán comprendidos son "\\" y "\'". Esto es por convenio, así que se pueden tener comillas simples y barras invertidas en una cadena entre comillas simples. Las variables no se expandirán dentro de una cadena entre comillas simples.

Otra forma de delimitar cadenas es usando la sintaxis de documento incrustado ("<<<"). Se debe proporcionar un identificador después de <<<, después la cadena, y después el mismo identificador para cerrar el entrecomillado.

Ejemplo 6-1. He aquí un ejemplo de entrecomillado de cadenas con sintaxis de documento incrustado

$str = <<<EOD
Ejemplo de cadena
Expandiendo múltiples líneas
usando sintaxis de documento incrustado.
EOD;

Nota: La sintaxis de documento incristado fue añadida en PHP 4.

Las cadenas se pueden concatenar usando el operador '.' (punto). Nótese que el operador '+' (suma) no sirve para esto. Por favor mire Operadores de cadena para más información.

Se puede acceder a los caracteres dentro de una cadena tratándola como un array de caracteres indexado numéricamente, usando una sintaxis similar a la de C. Vea un ejemplo más abajo.

Ejemplo 6-2. Algumos ejemplos de cadenas

<?php
/* Asignando una cadena. */
$str = "Esto es una cadena";

/* Añadiendo a la cadena. */
$str = $str . " con algo más de texto";

/* Otra forma de añadir, incluye un carácter de nueva línea protegido. */
$str .= " Y un carácter de nueva línea al final.\n";

/* Esta cadena terminará siendo '<p>Número: 9</p>' */
$num = 9;
$str = "<p>Número: $num</p>";

/* Esta será '<p>Número: $num</p>' */
$num = 9;
$str = '<p>Número: $num</p>';

/* Obtener el primer carácter de una cadena  */
$str = 'Esto es una prueba.';
$first = $str[0];

/* Obtener el último carácter de una cadena. */
$str = 'Esto es aún una prueba.';
$last = $str[strlen($str)-1];
?>

Conversión de cadenas

Cuando una cadena se evalúa como un valor numérico, el valor resultante y el tipo se determinan como sigue.

La cadena se evaluará como un doble si contiene cualquiera de los caracteres '.', 'e', o 'E'. En caso contrario, se evaluará como un entero.

El valor viene dado por la porción inicial de la cadena. Si la cadena comienza con datos de valor numérico, este será el valor usado. En caso contrario, el valor será 0 (cero). Los datos numéricos válidos son un signo opcional, seguido por uno o más dígitos (que opcionalmente contengan un punto decimal), seguidos por un exponente opcional. El exponente es una 'e' o una 'E' seguidos por uno o más dígitos.

Cuando la primera expresión es una cadena, el tipo de la variable dependerá de la segunda expresión.

$foo = 1 + "10.5";              // $foo es doble (11.5)
$foo = 1 + "-1.3e3";            // $foo es doble (-1299)
$foo = 1 + "bob-1.3e3";         // $foo es entero (1)
$foo = 1 + "bob3";              // $foo es entero (1)
$foo = 1 + "10 Cerditos";     // $foo es entero (11)
$foo = 1 + "10 Cerditos"; // $foo es entero (11)
$foo = "10.0 cerdos " + 1;        // $foo es entero (11)
$foo = "10.0 cerdos " + 1.0;      // $foo es double (11)

Para más información sobre esta conversión, mire en la página del manual de Unix strtod(3).

Si quisiera probar cualquiera de los ejemplos de esta sección, puede cortar y pegar los ejemplos e insertar la siguiente línea para ver por sí mismo lo que va ocurriendo:

echo "\$foo==$foo; el tipo es " . gettype( $foo ) . "<br>\n";

Anterior | Inicio | Siguiente
Números en punto flotante | Subir | Arrays


Arrays

Los arrays actualmente actúan tanto como tablas hash (arrays asociativos) como arrays indexados (vectores).

Arrays unidimensionales

PHP soporta tanto arrays escalares como asociativos. De hecho, no hay diferencias entre los dos. Se puede crear una array usando las funciones list() o array(), o se puede asignar el valor de cada elemento del array de manera explícita.

$a[0] = "abc";
$a[1] = "def";
$b["foo"] = 13;

También se puede crear un array simplemente añadiendo valores al array. Cuando se asigna un valor a una variable array usando corchetes vacíos, el valor se añadirá al final del array.

$a[] = "hola"; // $a[2] == "hola"
$a[] = "mundo"; // $a[3] == "mundo"

Los arrays se pueden ordenar usando las funciones
asort(), arsort(),
ksort(), rsort(),
sort(), uasort(),
usort(), y uksort()
dependiendo del tipo de ordenación que se desee.

Se puede contar el número de elementos de un array usando la función count().

Se puede recorrer un array usando las funciones next() y prev(). Otra forma habitual de recorrer un array es usando la función each().

Arrays Multidimensionales

Los arrays multidimensionales son bastante simples actualmente. Para cada dimensión del array, se puede añadir otro valor [clave] al final:

$a[1]      = $f;           # ejemplos de una sola dimensión
$a["foo"]  = $f;

$a[1][0]     = $f;         # bidimensional
$a["foo"][2] = $f;         # (se pueden mezclar índices numéricos y asociativos)
$a[3]["bar"] = $f;         # (se pueden mezclar índices numéricos y asociativos)

$a["foo"][4]["bar"][0] = $f;   # tetradimensional!

En PHP3 no es posible referirse a arrays multidimensionales directamente dentro de cadenas. Por ejemplo, lo siguiente no tendrá el resultado deseado:

$a[3]['bar'] = 'Bob';
echo "Esto no va a funcionar: $a[3][bar]";

En PHP3, lo anterior tendrá la salida Esto no va a funcionar: Array[bar]. De todas formas, el operador de concatenación de cadenas se puede usar para solucionar esto:

$a[3]['bar'] = 'Bob';
echo "Esto no va a funcionar: " . $a[3][bar];

En PHP4, sin embargo, todo el problema se puede circunvenir encerrando la referencia al array (dentro de la cadena) entre llaves:

$a[3]['bar'] = 'Bob';
echo "Esto va a funcionar: {$a[3][bar]}";

Se pueden "rellenar" arrays multidimensionales de muchas formas, pero la más difícil de comprender es cómo usar el comando array() para arrays asociativos. Estos dos trozos de código rellenarán el array unidimensional de la misma manera:

# Ejemplo 1:

$a["color"]	= "rojo";
$a["sabor"]	= "dulce";
$a["forma"]	= "redondeada";
$a["nombre"]	= "manzana";
$a[3]		= 4;

# Example 2:
$a = array(
     "color" => "rojo",
     "sabor" => "dulce",
     "forma" => "redondeada",
     "nombre"  => "manzana",
     3       => 4
);

La función array() se puede anidar para arrays multidimensionales:

<?
$a = array(
     "manzana"  => array(
          "color"  => "rojo",
          "sabor"  => "dulce",
          "forma"  => "redondeada"
     ),
     "naranja"  => array(
          "color"  => "naranja",
          "sabor"  => "ácido",
          "forma"  => "redondeada"
     ),
     "plátano"  => array(
          "color"  => "amarillo",
          "sabor"  => "paste-y",
          "forma"  => "aplatanada"
     )
);

echo $a["manzana"]["sabor"];    # devolverá "dulce"
?>

Anterior | Inicio | Siguiente
Cadenas | Subir | Objetos


Objetos

Inicialización de Objetos

Para inicializar un objeto, se usa la sentencia new para instanciar el objeto a una variable.

class foo {
    function do_foo () {
        echo "Doing foo.";
    }
}

$bar = new foo;
$bar->do_foo();

Anterior | Inicio | Siguiente
Arrays | Subir | Type juggling


Type juggling

PHP no requiere (o soporta) la declaración explícita del tipo en la declaración de variables; el tipo de una variable se determina por el contexto en el que se usa esa variable. Esto quiere decir que si se asigna un valor de cadena a la variable var, var se convierte en una cadena. Si después se asigna un valor entero a la variable var, se convierte en una variable entera.

Un ejemplo de conversión de tipo automática en PHP3 es el operador suma '+'. Si cualquiera de los operandos es un doble, entonces todos los operandos se evalúan como dobles, y el resultado será un doble. En caso contrario, los operandos se interpretarán como enteros, y el resultado será también un entero. Nótese que esto NO cambia los tipos de los operandos propiamente dichos; el único cambio está en cómo se evalúan los operandos.

$foo = "0";  // $foo es una cadena (ASCII 48)
$foo++;      // $foo es la cadena "1" (ASCII 49)
$foo += 1;   // $foo ahora es un entero (2)
$foo = $foo + 1.3;  // $foo ahora es un doble (3.3)
$foo = 5 + "10 Cerditos Pequeñitos"; // $foo es entero (15)
$foo = 5 + "10 Cerditos";     // $foo es entero (15)

Si los últimos dos ejemplos anteriores parecen confusos, vea Conversión de cadenas.

Si se desea obligar a que una variable sea evaluada con un tipo concreto, mire la sección Forzado de tipos. Si se desea cambiar el tipo de una variable, vea la función settype().

Si quisiese probar cualquiera de los ejemplos de esta sección, puede cortar y pegar los ejemplos e insertar la siguiente línea para ver por sí mismo lo que va ocurriendo:

echo "\$foo==$foo; el tipo es " . gettype( $foo ) . "<br>\n";

Nota: La posibilidad de una conversión automática a array no está definida actualmente.

$a = 1;       // $a es un entero
$a[0] = "f";  // $a se convierte en un array, en el que $a[0] vale "f"

Aunque el ejemplo anterior puede parecer que claramente debería resultar en que $a se convierta en un array, el primer elemento del cual es 'f', consideremos esto:

$a = "1";     // $a es una cadena
$a[0] = "f";  // ¿Qué pasa con los índices de las cadenas? ¿Qué ocurre?

Dado que PHP soporta indexación en las cadenas vía offsets usando la misma sintaxis que la indexación de arrays, el ejemplo anterior nos conduce a un problema: ¿debería convertirse $a en un array cuyo primer elemento sea "f", o debería convertirse "f" en el primer carácter de la cadena $a?

Por esta razón, tanto en PHP 3.0.12 como en PHP 4.0b3-RC4, el resultado de esta conversión automática se considera que no está definido. Los parches se están discutiendo, de todas formas.

Forzado de tipos

El forzado de tipos en PHP funciona como en C: el nombre del tipo deseado se escribe entre paréntesis antes de la variable a la que se pretende forzar.

$foo = 10;   // $foo es un entero
$bar = (double) $foo;   // $bar es un doble

Los forzados de tipo permitidos son:

  • (int), (integer) - fuerza a entero (integer)

  • (real), (double), (float) - fuerza a doble (double)

  • (string) - fuerza a cadena (string)

  • (array) - fuerza a array (array)

  • (object) - fuerza a objeto (object)

Nótese que las tabulaciones y espacios se permiten dentro de los paréntesis, así que los siguientes ejemplos son funcionalmente equivalentes:

$foo = (int) $bar;
$foo = ( int ) $bar;

Puede no ser obvio que ocurrirá cuando se fuerce entre ciertos tipos. Por ejemplo, lo siguiente debería ser tenido en cuenta.

Cuando se fuerza el cambio de un escalar o una variable de cadena a un array, la variable se convertirá en el primer elemento del array:

$var = 'ciao';
$arr = (array) $var;
echo $arr[0];  // produce la salida 'ciao'

Cuando se fuerza el tipo de una variable escalar o de una cadena a un objeto, la variable se convertirá en un atributo del objeto; el nombre del atributo será 'scalar':

$var = 'ciao';
$obj = (object) $var;
echo $obj->scalar;  // produce la salida 'ciao'

Anterior | Inicio | Siguiente
Objetos | Subir | Variables


Variables

Manual de PHP
Anterior Siguiente

Capítulo 7. Variables

Tabla de contenidos
Conceptos Básicos
Variables predefinidas
Ambito de las variables
Variables variables
Variables externas a PHP

Conceptos Básicos

En PHP las variables se representan como un signo de dólar seguido por el nombre de la variable. El nombre de la variable es sensible a minúsculas y mayúsculas.

$var = "Bob";
$Var = "Joe";
echo "$var, $Var"; // produce la salida "Bob, Joe"

En PHP3, las variables siempre se asignan por valor. Esto significa que cuando se asigna una expresión a una variable, el valor íntegro de la expresión original se copia en la variable de destino. Esto quiere decir que, por ejemplo, después e asignar el valor de una variable a otra, los cambios que se efectúen a una de esas variables no afectará a la otra. Para más información sobre este tipo de asignación, vea Expresiones.

PHP4 ofrece otra forma de asignar valores a las variables: asignar por referencia. Esto significa que la nueva variable simplemente referencia (en otras palabras, "se convierte en un alias de" o "apunta a") la variable original. Los cambios a la nueva variable afectan a la original, y viceversa. Esto también significa que no se produce una copia de valores; por tanto, la asignación ocurre más rápidamente. De cualquier forma, cualquier incremento de velocidad se notará sólo en los bucles críticos cuando se asignen grandes arrays u objetos.

Para asignar por referencia, simplemente se antepone un ampersand (&) al comienzo de la variable cuyo valor se está asignando (la variable fuente). Por ejemplo, el siguiente trozo de código produce la salida 'Mi nombre es Bob' dos veces:

<?php
$foo = 'Bob';              // Asigna el valor 'Bob' a $foo
$bar = &$foo;              // Referencia $foo vía $bar.
$bar = "Mi nombre es $bar";  // Modifica $bar...
echo $foo;                 // $foo también se modifica.
echo $bar;
?>

Algo importante a tener en cuenta es que sólo las variables con nombre pueden ser asignadas por referencia.

<?php
$foo = 25;
$bar = &$foo;      // Esta es una asignación válida.
$bar = &(24 * 7);  // Inválida; referencia una expresión sin nombre.

function test() {
   return 25;
}

$bar = &test();    // Inválida.
?>

Anterior | Inicio | Siguiente
Type juggling | Subir | Variables predefinidas


Variables predefinidas

PHP proporciona una gran cantidad de variables predefinidas a cualquier script que se ejecute. De todas formas, muchas de esas variables no pueden estar completamente documentadas ya que dependen de sobre qué servidor se esté ejecutando, la versión y configuración de dicho servidor, y otros factores. Algunas de estas variables no estarán disponibles cuando se ejecute PHP desde la línea de comandos.

A pesar de estos factores, aquí tenemos una lista de variables predefinidas disponibles en una instalación por defecto de PHP 3 corriendo como modulo de un Apache 1.3.6 con su configuración también por defecto.

Para una lista de variables predefinidas (y muchas más información útil), por favor, vea (y use) phpinfo().

Nota: Esta lista no es exhaustiva ni pretende serlo. Simplemente es una guía de qué tipo de variables predefinidas se puede esperar tener disponibles en un script.

Variables de Apache

Estas variables son creadas por el servidor web Apache. Si se está utilizando otro servidor web, no hay garantía de que proporcione las mismas variables; pueden faltar algunas, o proporcionar otras no listadas aquí. Dicho esto, también están presentes las variables de la especificación CGI 1.1, por lo que también se deben tener en cuenta.

Tenga en cuenta que unas pocas, como mucho, de estas variables van a estar disponibles (o simplemente tener sentido) si se ejecuta PHP desde la línea de comandos.

GATEWAY_INTERFACE

Qué revisión de la especificación CGI está usando el servidor; por ejemplo 'CGI/1.1'.

SERVER_NAME

El nombre del equipo servidor en el que se está ejecutando el script. Si el script se está ejecutando en un servidor virtual, este será el valor definido para dicho servidor virtual.

SERVER_SOFTWARE

Una cadena de identificación del servidor, que aparece en las cabeceras al responderse a las peticiones.

SERVER_PROTOCOL

Nombre y revisión del protocolo a través del que se solicitó la página; p.ej. 'HTTP/1.0';

REQUEST_METHOD

Qué método de petición se usó para acceder a la página; p.ej. 'GET', 'HEAD', 'POST', 'PUT'.

QUERY_STRING

La cadena de la petición, si la hubo, mediante la que se accedió a la página.

DOCUMENT_ROOT

El directorio raíz del documento bajo el que se ejecuta el script, tal y como está definido en el fichero de configuración del servidor.

HTTP_ACCEPT

Los contenidos de la cabecera Accept: de la petición actual, si hay alguna.

HTTP_ACCEPT_CHARSET

Los contenidos de la cabecera Accept-Charset: de la petición actual, si hay alguna. Por ejemplo: 'iso-8859-1,*,utf-8'.

HTTP_ENCODING

Los contenidos de la cabecera Accept-Encoding: de la petición actual, si la hay. Por ejemplo: 'gzip'.

HTTP_ACCEPT_LANGUAGE

Los contenidos de la cabecera Accept-Language: de la petición actual, si hay alguna. Por ejemplo: 'en'.

HTTP_CONNECTION

Los contenidos de la cabecera Connection: de la petición actual, si hay alguna. Por ejemplo: 'Keep-Alive'.

HTTP_HOST

Los contenidos de la cabecera Host: de la petición actual, si hay alguna.

HTTP_REFERER

La dirección de la página (si la hay) desde la que el navegador saltó a la página actual. Esto lo establece el navegador del usuario; no todos los navegadores lo hacen.

HTTP_USER_AGENT

Los contenidos de la cabecera User_Agent: de la petición actual, si hay alguna. Indica el navegador que se está utilizando para ver la página actual; p.ej. Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586). Entre otras cosas, se puede usar este valor con get_browser() para adaptar la funcionalidad de la página a las posibilidades del navegador del usuario.

REMOTE_ADDR

La dirección IP desde la que el usuario está viendo la página actual.

REMOTE_PORT

El puerto que se está utilizando en la máquina del usuario para comunicarse con el servidor web.

SCRIPT_FILENAME

La vía de acceso absoluta del script que se está ejecutando.

SERVER_ADMIN

El valor que se haya dado a la directiva SERVER_ADMIN (en Apache) en el fichero de configuración del servidor web. Si el script se está ejecutando en un servidor virtual, será el valor definido para dicho servidor virtual.

SERVER_PORT

El puerto del equipo servidor que está usando el servidor web para la comunicación. Para configuraciones por defecto, será '80'; al usar SSL, por ejemplo, cambiará al puerto que se haya definido como seguro para HTTP.

SERVER_SIGNATURE

Una cadena que contiene la versión del servidor y el nombre del servidor virtual que es añadida a las páginas generadas por el servidor, si está característica está activa.

PATH_TRANSLATED

Vía de acceso basada en el sistema de ficheros- (no el directorio raíz del documento-) del script en cuestión, después de que el servidor haya hecho la conversión virtual-a-real.

SCRIPT_NAME

Contiene la vía de acceso del script actual. Es útil para páginas que necesitan apuntar a sí mismas.

REQUEST_URI

La URI que se dió para acceder a esta página; por ejemplo, '/index.html'.

Variables de entorno

Estas variables se importan en el espacio de nombres global de PHP desde el entorno en el que se esté ejecutando el intérprete PHP. Muchas son proporcionadas por el intérprete de comandos en el que se está ejecutando PHP, y dado que a sistemas diferentes les gusta ejecutar diferentes tipos de intérpretes de comandos, es imposible hacer una lista definitiva. Por favor, mire la documentación de su intérprete de comandos para ver una lista de las variables de entorno definidas.

Otras variables de entorno son las de CGI, que están ahí sin importar si PHP se está ejecutando como un módulo del servidor o como un intérprete CGI.

Variables de PHP

Estas variables son creadas por el propio PHP.

argv

Array de argumentos pasados al script. Cuando el script se ejecuta desde la línea de comandos, esto da un acceso, al estilo de C, a los parámetros pasados en línea de comandos. Cuando se le llama mediante el método GET, contendrá la cadena de la petición.

argc

Contiene el número de parámetros de la línea de comandos pasados al script (si se ejecuta desde la línea de comandos).

PHP_SELF

El nombre del fichero que contiene el script que se esta ejecutando, relativo al directorio raíz de los documentos. Si PHP se está ejecutando como intérprete de línea de comandos, esta variable no está disponible.

HTTP_COOKIE_VARS

Un array asociativo de variables pasadas al script actual mediante cookies HTTP. Sólo está disponible si el seguimiento de variables ha sido activado mediante la directiva de configuración track_vars o la directiva <?php_track_vars?>.

HTTP_GET_VARS

Un array asociativo de variables pasadas al script actual mediante el método HTTP GET. Sólo está disponible si --variable tracking-- ha sido activado mediante la directiva de configuración track_vars o la directiva <?php_track_vars?>.

HTTP_POST_VARS

Un array asociativo de variables pasadas al script actual mediante el método HTTP POST. Sólo está disponible si --variable tracking-- ha sido activado mediante la directiva de configuración track_vars o la directiva <?php_track_vars?>.

Anterior | Inicio | Siguiente
Variables | Subir | Ambito de las variables


Ambito de las variables

El ámbito de una variable es el contexto dentro del que la variable está definida. La mayor parte de las variables PHP sólo tienen un ámbito simple. Este ámbito simple también abarca los ficheros incluidos y los requeridos. Por ejemplo:

$a = 1;
include "b.inc";

Aquí, la variable $a dentro del script incluido b.inc. De todas formas, dentro de las funciones definidas por el usuario aparece un ámbito local a la función. Cualquier variables que se use dentro de una función está, por defecto, limitada al ámbito local de la función. Por ejemplo:

$a = 1; /* ámbito global */

Function Test () {
    echo $a; /* referencia a una variable de ámbito local */
}

Test ();

Este script no producirá salida, ya que la orden echo utiliza una versión local de la variable $a, a la que no se ha asignado ningún valor en su ámbito. Puede que usted note que hay una pequeña diferencia con el lenguaje C, en el que las variables globales están disponibles automáticamente dentro de la función a menos que sean expresamente sobreescritas por una definición local. Esto puede causar algunos problemas, ya que la gente puede cambiar variables globales inadvertidamente. En PHP, las variables globales deben ser declaradas globales dentro de la función si van a ser utilizadas dentro de dicha función. Veamos un ejemplo:

$a = 1;
$b = 2;

Function Sum () {
    global $a, $b;

    $b = $a + $b;
}

Sum ();
echo $b;

El script anterior producirá la salida "3". Al declarar $a y $b globales dentro de la función, todas las referencias a tales variables se referirán a la versión global. No hay límite al número de variables globales que se pueden manipular dentro de una función.

Un segundo método para acceder a las variables desde un ámbito global es usando el array $GLOBALS propio de PHP3. El ejemplo anterior se puede reescribir así:

$a = 1;
$b = 2;

Function Sum () {
    $GLOBALS["b"] = $GLOBALS["a"] + $GLOBALS["b"];
}

Sum ();
echo $b;

El array $GLOBALS es un array asociativo con el nombre de la variable global como clave y los contenidos de dicha variable como el valor del elemento del array.

Otra característica importante del ámbito de las variables es la variable static. Una variable estática existe sólo en el ámbito local de la función, pero no pierde su valor cuando la ejecución del programa abandona este ámbito. Consideremos el siguiente ejemplo:

Function Test () {
    $a = 0;
    echo $a;
    $a++;
}

Esta función tiene poca utilidad ya que cada vez que es llamada asigna a $a el valor 0 y representa un "0". La sentencia $a++, que incrementa la variable, no sirve para nada, ya que en cuanto la función termina la variable $a desaparece. Para hacer una función útil para contar, que no pierda la pista del valor actual del conteo, la variable $a debe declararse como estática:

Function Test () {
    static $a = 0;
    echo $a;
    $a++;
}

Ahora, cada vez que se llame a la función Test(), se representará el valor de $a y se incrementará.

Las variables estáticas también proporcionan una forma de manejar funciones recursivas. Una función recursiva es la que se llama a sí misma. Se debe tener cuidado al escribir una función recursiva, ya que puede ocurrir que se llame a sí misma indefinidamente. Hay que asegurarse de implementar una forma adecuada de terminar la recursión. La siguiente función cuenta recursivamente hasta 10, usando la variable estática $count para saber cuándo parar:

Function Test () {
    static $count = 0;

    $count++;
    echo $count;
    if ($count < 10) {
        Test ();
    }
    $count--;
}

Anterior | Inicio | Siguiente
Variables predefinidas | Subir | Variables variables


Variables variables

A veces es conveniente tener nombres de variables variables. Dicho de otro modo, son nombres de variables que se pueden establecer y usar dinámicamente. Una variable normal se establece con una sentencia como:

$a = "hello";

Una variable variable toma el valor de una variable y lo trata como el nombre de una variable. En el ejemplo anterior, hello, se puede usar como el nombre de una variable utilizando dos signos de dólar. p.ej.

$$a = "world";

En este momento se han definido y almacenado dos variables en el árbol de símbolos de PHP: $a, que contiene "hello", y $hello, que contiene "world". Es más, esta sentencia:

echo "$a ${$a}";

produce el mismo resultado que:

echo "$a $hello";

p.ej. ambas producen el resultado: hello world.

Para usar variables variables con arrays, hay que resolver un problema de ambigüedad. Si se escribe $$a[1] el intérprete necesita saber si nos referimos a utilizar $a[1] como una variable, o si se pretendía utilizar $$a como variable y el índice [1] como índice de dicha variable. La sintaxis para resolver esta ambiguedad es: ${$a[1]} para el primer caso y ${$a}[1] para el segundo.

Anterior | Inicio | Siguiente
Ambito de las variables | Subir | Variables externas a PHP


Variables externas a PHP

Formularios HTML (GET y POST)

Cuando se envía un formulario a un script PHP, las variables de dicho formulario pasan a estar automáticamente disponibles en el script gracias a PHP. Por ejemplo, consideremos el siguiente formulario:

Ejemplo 7-1. Variables de formulario simples

<form action="foo.php3" method="post">
    Name: <input type="text" name="name"><br>
    <input type="submit">
</form>

Cuando es enviado, PHP creará la variable $name, que contendrá lo que sea que se introdujo en el campo Name: del formulario.

PHP también maneja arrays en el contexto de variables de formularios, pero sólo en una dimensión. Se puede, por ejemplo, agrupar juntas variables relacionadas, o usar esta característica para recuperar valores de un campo select input múltiple:

Ejemplo 7-2. Variables de formulario más complejas

<form action="array.php" method="post">
    Name: <input type="text" name="personal[name]"><br>
    Email: <input type="text" name="personal[email]"><br>
    Beer: <br>
    <select multiple name="beer[]">
        <option value="warthog">Warthog
        <option value="guinness">Guinness
        <option value="stuttgarter">Stuttgarter Schwabenbräu
        </select>
    <input type="submit">
</form>

Si la posibilidad de PHP de track_vars está activada, ya sea mediante la opción de configuración track_vars o mediante la directiva <?php_track_vars?>, las variables enviadas con los métodos POST o GET también se encontrarán en los arrays asociativos globales $HTTP_POST_VARS y $HTTP_GET_VARS.

IMAGE SUBMIT variable names

Cuando se envía un formulario, es posible usar una imagen en vez del botón submit estándar con una etiqueta como:

<input type=image src="image.gif" name="sub">

Cuando el usuario hace click en cualquier parte de la imagen, el formulario que la acompaña se transmitirá al servidor con dos variables adicionales, sub_x y sub_y. Estas contienen las coordenadas del click del usuario dentro de la imagen. Los más experimentados puede notar que los nombres de variable enviados por el navegador contienen un guión en vez de un subrayado (guión bajo), pero PHP convierte el guión en subrayado automáticamente.

Cookies HTTP

PHP soporta cookies de HTTP de forma transparente tal y como están definidas en en las Netscape's Spec. Las cookies son un mecanismo para almacenar datos en el navegador y así rastrear o identificar a usuarios que vuelven. Se pueden crear cookies usando la función SetCookie(). Las cookies son parte de la cabecera HTTP, así que se debe llamar a la función SetCookie antes de que se envíe cualquier salida al navegador. Es la misma restricción que para la función header(). Cualquier cookie que se reciba procedente del cliente será convertida automáticamente en una variable de PHP como con los datos en los métodos GET y POST.

Si se quieren asignar múltiples valores a una sola cookie, basta con añadir [] al nombre de la. Por ejemplo:

SetCookie ("MyCookie[]", "Testing", time()+3600);

Nótese que una cookie reemplazará a una cookie anterior que tuviese el mismo nombre en el navegador a menos que el camino (path) o el dominio fuesen diferentes. Así, para una aplicación de carro de la compra se podría querer mantener un contador e ir pasándolo. P.ej.

Ejemplo 7-3. SetCookie Example

$Count++;
SetCookie ("Count", $Count, time()+3600);
SetCookie ("Cart[$Count]", $item, time()+3600);

Variables de entorno

PHP hace accesibles las variables de entorno automáticamente tratándolas como variables normales.

echo $HOME;  /* Shows the HOME environment variable, if set. */

Dado que la información que llega vía mecanismos GET, POST y Cookie crean automáticamente variables de PHP, algunas veces es mejor leer variables del entorno explícitamente para asegurarse de que se está trabajando con la versión correcta. La función getenv() se puede usar para ello. También se puede asignar un valor a una variable de entorno con la función putenv().

Puntos en los nombres de variables de entrada

Típicamente, PHP no altera los nombres de las variables cuando se pasan a un script. De todas formas, hay que notar que el punto no es un carácter válido en el nombre de una variable PHP. Por esta razón, mire esto:
$varname.ext;  /* nombre de variable no válido */
Lo que el intérprete ve es el nombre de una variable $varname, seguido por el operador de concatenación, y seguido por la prueba (es decir, una cadena sin entrecomillar que no coincide con ninguna palabra clave o reservada conocida) 'ext'. Obviamente, no se pretendía que fuese este el resultado.

Por esta razón, es importante hacer notar que PHP reemplazará automáticamente cualquier punto en los nombres de variables de entrada por guiones bajos (subrayados).

Determinando los tipos de variables

Dado que PHP determina los tipos de las variables y los convierte (generalmente) según necesita, no siempre resulta obvio de qué tipo es una variable dada en un momento concreto. PHP incluye varias funciones que descubren de qué tipo es una variable. Son gettype(), is_long(), is_double(), is_string(), is_array(), y is_object().

Anterior | Inicio | Siguiente
Variables variables | Subir | Constantes


Constantes

Manual de PHP
Anterior Siguiente

Capítulo 8. Constantes

PHP define varias constantes y proporciona un mecanismo para definir más en tiempo de ejecución. Las constantes son como las variables, salvo por las dos circunstancias de que las constantes deben ser definidas usando la función define(), y que no pueden ser redefinidas más tarde con otro valor.

Las constantes predefinidas (siempre disponibles) son:

__FILE__

El nombre del archivo de comandos que está siendo interpretado actualmente. Si se usa dentro de un archivo que ha sido incluido o requerido, entonces se da el nombre del archivo incluido, y no el nombre del archivo padre.

__LINE__

El número de línea dentro del archivo que está siendo interpretado en la actualidad. Si se usa dentro de un archivo incluido o requerido, entonces se da la posición dentro del archivo incluido.

PHP_VERSION

La cadena que representa la versión del analizador de PHP en uso en la actualidad; e.g. '3.0.8-dev'.

PHP_OS

El nombre del sistema operativo en el cuál se ejecuta el analizador PHP; e.g. 'Linux'.

TRUE

Valor verdadero.

FALSE

Valor falso.

E_ERROR

Denota un error distinto de un error de interpretación del cual no es posible recuperarse.

E_WARNING

Denota una condición donde PHP reconoce que hay algo erróneo, pero continuará de todas formas; pueden ser capturados por el propio archivo de comandos. Un ejemplo sería una inválida regexp en ereg().

E_PARSE

El interprete encontró sintaxis inválida en el archivo de comandos. La recuperación no es posible.

E_NOTICE

Ocurrió algo que pudo ser o no un error. La ejecución continúa. Los ejemplos incluyen usar una cadena sin comillas como un índice "hash", o acceder a una variable que no ha sido inicializada.

Las constantes E_* se usan típicamente con la función error_reporting() para configurar el nivel de informes de error.

Se pueden definir constantes adicionales usando la función define().

Nótese que son constantes, no macros tipo C; con una constante sólo se pueden representar datos escalares válidos.

Ejemplo 8-1. Definiendo Constantes

<?php
define("CONSTANTE", "Hola mundo.");
echo CONSTANTE; // muestra "Hola mundo."
?>

Ejemplo 8-2. Usando __FILE__ y __LINE__

<?php
function report_error($file, $line, $message) {
    echo "Un error occurrió en $file en la línea $line: $message.";
}

report_error(__FILE__,__LINE__, "Algo fue mal!");
?>

Anterior | Inicio | Siguiente
Variables externas a PHP | Subir | Expresiones


Expresiones

Manual de PHP
Anterior Siguiente

Capítulo 9. Expresiones

Las expresiones son la piedra angular de PHP. En PHP, casi cualquier cosa que escribes es una expresión. La forma más simple y ajustada de definir una expresión es "cualquier cosa que tiene un valor".

Las formas más básicas de expresiones son las constantes y las variables. Cuando escribes "$a = 5", estás asignando '5' a $a. '5', obviamente, tiene el valor 5 o, en otras palabras '5' es una expresión con el valor 5 (en este caso, '5' es una constante entera).

Después de esta asignación, esperarás que el valor de $a sea 5 también, de manera que si escribes $b = $a, esperas que se comporte igual que si escribieses $b = 5. En otras palabras, $a es una expresión también con el valor 5. Si todo va bien, eso es exactamente lo que pasará.

Las funciones son un ejemplo algo más complejo de expresiones. Por ejemplo, considera la siguiente función:

function foo () {
    return 5;
}

Suponiendo que estés familiarizado con el concepto de funciones (si no lo estás échale un vistazo al capítulo sobre funciones), asumirás que teclear $c = foo() es esencialmente lo mismo que escribir $c = 5, y has acertado. Las funciones son expresiones que valen el valor que retornan. Como foo() devuelve 5, el valor de la expresión 'foo()' es 5. Normalmente las funciones no devuelven un valor fijo, sino que suele ser calculado.

Desde luego, los valores en PHP no se limitan a enteros, y lo más normal es que no lo sean. PHP soporta tres tipos escalares: enteros, punto flotante y cadenas (los tipos escalares son aquellos cuyos valores no pueden 'dividirse' en partes menores, no como los arrays, por ejemplo). PHP también soporta dos tipos compuestos (no escalares): arrays y objetos. Se puede asignar cada uno de estos tipos de valor a variables o bien retornarse de funciones, sin ningún tipo de limitación.

Hasta aquí, los usuarios de PHP/FI 2 no deberían haber notado ningún cambio. Sin embargo, PHP lleva las expresiones mucho más allá, al igual que otros lenguajes. PHP es un lenguaje orientado a expresiones, en el sentido de que casi todo es una expresión. Considera el ejemplo anterior '$a = 5'. Es sencillo ver que hay dos valores involucrados, el valor de la constante entera '5', y el valor de $a que está siendo actualizado también a 5. Pero la verdad es que hay un valor adicional implicado aquí, y es el valor de la propia asignación. La asignación misma se evalúa al valor asignado, en este caso 5. En la práctica, quiere decir que '$a = 5', independientemente de lo que hace, es una expresión con el valor 5. De esta manera, escribir algo como '$b = ($a = 5)' es como escribir '$a = 5; $b = 5;' (un punto y coma marca el final de una instrucción). Como las asignaciones se evalúan de derecha a izquierda, puedes escribir también '$b = $a = 5'.

Otro buen ejemplo de orientación a expresiones es el pre y post incremento y decremento. Los usuarios de PHP/FI 2 y los de otros muchos lenguajes les sonará la notación variable++ y variable--. Esto son las operaciones de incremento y decremento. En PHP/FI 2, la instrucción '$a++' no tiene valor (no es una expresión), y no puedes asignarla o usarla de ningún otro modo. PHP mejora las características del incremento/decremento haciéndolos también expresiones, como en C. En PHP, como en C, hay dos tipos de incremento - pre-incremento y post-incremento. Ambos, en esencia, incrementan la variable y el efecto en la variable es idéntico. La diferencia radica en el valor de la propia expresion incremento. El preincremento , escrito '++$variable', se evalúa al valor incrementado (PHP incrementa la variable antes de leer su valor, de ahí el nombre 'preincremento'). El postincremento, escrito '$variable++', se evalúa al valor original de $variable antes de realizar el incremento (PHP incrementa la variable después de leer su valor, de ahí el nombre 'postincremento').

Un tipo muy corriente de expresiones son las expresiones de comparación. Estas expresiones se evalúan a 0 o 1, significando FALSO (FALSE) o CIERTO (TRUE), respectivamente. PHP soporta > (mayor que), >= (mayor o igual que), == (igual que), != (distinto), < (menor que) y <= (menor o igual que). Estas expresiones se usan frecuentemente dentro de la ejecución condicional como la instrucción if.

El último tipo de expresiones que trataremos, es la combinación operador-asignación. Ya sabes que si quieres incrementar $a en 1, basta con escribir '$a++' o ++$a'. Pero qué pasa si quieres añadir más de 1, por ejemplo 3? Podrías escribir '$a++' múltiples veces, pero no es una forma de hacerlo ni eficiente ni cómoda. Una práctica mucho más corriente es escribir '$a = $a + 3'. '$a + 3' se evalúa al valor de $a más 3, y se asigna de nuevo a $a, lo que resulta en incrementar $a en 3. En PHP, como en otros lenguajes como C, puedes escribir esto de una forma más concisa, que con el tiempo será más clara y también fácil de entender. Añadir 3 al valor actual de $a se puede escribir como '$a += 3'. Esto quiere decir exactamente "toma el valor de $a, súmale 3, y asígnalo otra vez a $a". Además de ser más corto y claro, también resulta en una ejecución más rápida. El valor de '$a += 3', como el valor de una asignación normal y corriente, es el valor asignado. Ten en cuenta que NO es 3, sino el valor combinado de $a más 3 (ése es el valor asignado a $a). Cualquier operación binaria puede ser usada en forma de operador-asignación, por ejemplo '$a -= 5' (restar 5 del valor de $a), '$b *= 7' (multiplicar el valor de $b por 5), etc.

Hay otra expresión que puede parecer extraña si no la has visto en otros lenguaes, el operador condicional ternario:

$first ? $second : $third

Si el valor de la primera subexpresión es verdadero (distinto de cero), entonces se evalúa la segunda subexpresión, si no, se evalúa la tercera y ése es el valor.

El siguiente ejemplo te ayudará a comprender un poco mejor el pre y post incremento y las expresiones en general:

function double($i) {
    return $i*2;
}
$b = $a = 5;        /* asignar el valor cinco a las variables $a y $b */
$c = $a++;          /* postincremento, asignar el valor original de $a (5) a $c */
$e = $d = ++$b;     /* preincremento, asignar el valor incrementado de $b (6) a
                       $d y a $e */

/* en este punto, tanto $d como $e son iguales a 6 */

$f = double($d++);  /* asignar el doble del valor de $d antes
                       del incremento, 2*6 = 12 a $f */
$g = double(++$e);  /* asignar el doble del valor de $e después
                       del incremento, 2*7 = 14 a $g */
$h = $g += 10;      /* primero, $g es incrementado en 10 y termina valiendo 24.
                       después el valor de la asignación (24) se asigna a $h,
                       y $h también acaba valiendo 24. */

Al principio del capítulo hemos dicho que describiríamos los distintos tipos de instrucciones y, como prometimos, las expresiones pueden ser instrucciones. Sin embargo, no todas las expresiones son instrucciones. En este caso, una instrucción tiene la forma 'expr' ';', es decir, una expresión seguida de un punto y coma. En '$b=$a=5;', $a=5 es una expresión válida, pero no es una instrucción en sí misma. Por otro lado '$b=$a=5:' sí es una instrucción válida.

Una última cosa que vale la pena mencionar, es el valor booleano de las expresiones. En muchas ocasiones, principalmente en condicionales y bucles, no estás interesado en el valor exacto de la expresión, sino únicamente si es CIERTA (TRUE) o FALSA (FALSE) (PHP no tiene un tipo booleano específico). El valor de verdad de las expresiones en PHP se calcula de forma similar a perl. Cualquier valor numérico distinto de cero es CIERTO (TRUE), cero es FALSO (FALSE). Fíjate en que los valores negativos son distinto de cero y considerados CIERTO (TRUE)! La cadena vacía y la cadena "0" son FALSO (FALSE); todas las demás cadenas son TRUE. Con los tipos no escalares (arrays y objetos) - si el valor no contiene elementos se considera FALSO (FALSE), en caso contrario se considera CIERTO (TRUE).

PHP te brinda una completa y potente implementación de expresiones, y documentarla enteramente está más allá del objetivo de ete manual. Los ejemplos anteriores, deberían darte una buena idea de qué son las expresiones y cómo construir expresiones útiles. A lo largo del resto del manual, escribiremos expr para indicar una expresión PHP válida.

Anterior | Inicio | Siguiente
Constantes | Subir | Operadores


Operadores

Manual de PHP
Anterior Siguiente

Capítulo 10. Operadores

Tabla de contenidos
Operadores Aritméticos
Operadores de Asignación
Operadores Bit a bit
Operadores de Comparación
Operador de ejecución
Operadores de Incremento/decremento
Operadores Lógicos
Precedencia de Operadores
Operadores de Cadenas

Operadores Aritméticos

¿Recuerdas la aritmética básica del colegio? Pues estos operadores funcionan exactamente igual.

Tabla 10-1. Operadores Aritméticos

ejemplo | nombre | resultado
$a + $b | Adición | Suma de $a y $b.
$a - $b | Substracción | Diferencia entre $a y $b.
$a * $b | Multiplicación | Producto de $a and $b.
$a / $b | División | Cociente de $a entre $b.
$a % $b | Módulo | Resto de $a dividido entre $b.

Anterior | Inicio | Siguiente
Expresiones | Subir | Operadores de Asignación


Operadores de Asignación

El operador básico de asignación es "=". A primera vista podrías pensar que es el operador de comparación "igual que". Pero no. Realmente significa que el operando de la izquierda toma el valor de la expresión a la derecha, (esto es, "toma el valor de").

El valor de una expresión de asignación es el propio valor asignado. Esto es, el valor de "$a = 3" es 3. Esto permite hacer cosas curiosas como

$a = ($b = 4) + 5; // ahora $a es igual a 9, y $b vale 4.

Además del operador básico de asignación, existen los "operadores combinados" para todas las operaciones aritméticas y de cadenas que sean binarias. Este operador combinado te permite, de una sola vez, usar una variable en una expresión y luego establecer el valor de esa variable al resultado de la expresión. Por ejemplo:

$a = 3;
$a += 5; // establece $a a 8, como si hubiésemos escrito: $a = $a + 5;
$b = "Hola ";
$b .= "Ahí!"; // establece $b a "Hola Ahí!", igual que si hiciésemos $b = $b . "Ahí!";

Fíjate en que la asignación realiza una nueva copia de la variable original (asignación por valor), por lo que cambios a la variable original no afectan a la copia. Esto puede tener interés si necesitas copiar algo como un array con muchos elementos dentro de un bucle que se repita muchas veces (cada vez se realizará una nueva copia del array). PHP4 soporta asignación por referencia, usando la sintaxis $var = &$othervar;, pero esto no es posible en PHP3. 'Asignación por referencia' quiere decir que ambas variables acabarán apuntando al mismo dato y que nada es realmente copiado.

Anterior | Inicio | Siguiente
Operadores | Subir | Operadores Bit a bit


Operadores Bit a bit

Los operadores bit a bit te permiten activar o desactivar bits individuales de un entero.

Tabla 10-2. Operadores Bit a bit

ejemplo | nombre | resultado
$a & $b | Y | Se activan los bits que están activos tanto en $a como $b.
$a | $b | O | Se activan los bits que están activos en $a o que lo están en $b.
$a ^ $b | Xor ("o exclusiva") | Se activan los bits que están activos en $a o en $b pero no en ambos a la vez.
~ $a | No | Se activan los bits que no están activos en $a.
$a << $b | Desplazamiento a la izquierda | Desplaza los bits de $a, $b posiciones hacia la izquierda (por aritmética binaria, cada posición desplazada equivale a multiplicar por dos el valor de $a)
$a >> $b | Desplazamiento a la derecha | Desplaza los bits de $a, $b posiciones hacia la derecha (por aritmética binaria, cada posición desplazada equivale a dividir entre dos el valor de $a)

Anterior | Inicio | Siguiente
Operadores de Asignación | Subir | Operadores de Comparación


Operadores de Comparación

Los operadores de comparación, como su nombre indica, permiten comparar dos valores.

Tabla 10-3. Operadores de Comparación

ejemplo | nombre | resultado
$a == $b | Igualdad | Cierto si $a es igual a $b.
$a === $b | Identidad | Cierto si $a es igual a $b y si son del mismo tipo (sólo PHP4)
$a != $b | Desigualdad | Cierto si $a no es igual a $b.
$a < $b | Menor que | Cierto si $a es estrictamente menor que $b.
$a > $b | Mayor que | Cierto si $a es estrictamente mayor que $b.
$a <= $b | Menor o igual que | Cierto si $a es menor o igual que $b.
$a >= $b | Mayor o igual que | Cierto si $a es mayor o igual que $b.

Otro operador condicional es el operador "?:" (o ternario), que funciona como en C y otros muchos lenguajes.

(expr1) ? (expr2) : (expr3);

La expresión toma el valor expr2 si expr1 se evalúa a cierto, y expr3 si expr1 se evalúa a falso.

Anterior | Inicio | Siguiente
Operadores Bit a bit | Subir | Operador de ejecución


Operador de ejecución

PHP soporta un operador de ejecución: el apóstrofe invertido (``). ¡Fíjate que no son apostrofes normales! PHP intentará ejecutar la instrucción contenida dentro de los apóstrofes invertidos como si fuera un comando del shell; y su salida devuelta como el valor de esta expresión (i.e., no tiene por qué ser simplemente volcada como salida; puede asignarse a una variable).

$output = `ls -al`;
echo "<pre>$output</pre>";

Ver también system(),
passthru(), exec(),
popen(), y
escapeshellcmd().

Anterior | Inicio | Siguiente
Operadores de Comparación | Subir | Operadores de Incremento/decremento


Operadores de Incremento/decremento

PHP soporta los operadores de predecremento y post incremento al estilo de C.

Tabla 10-4. Operadores de Incremento/decremento

ejemplo | nombre | efecto
++$a | Preincremento | Incrementa $a en uno y después devuelve $a.
$a++ | Postincremento | Devuelve $a y después incrementa $a en uno.
--$a | Predecremento | Decrementa $a en uno y después devuelve $a.
$a-- | Postdecremento | Devuelve $a y después decrementa $a en uno.

He aquí un listado de ejemplo:

<?php
echo "<h3>Postincremento</h3>";
$a = 5;
echo "Debería ser 5: " . $a++ . "<br>\n";
echo "Debería ser 6: " . $a . "<br>\n";

echo "<h3>Preincremento</h3>";
$a = 5;
echo "Debería ser 6: " . ++$a . "<br>\n";
echo "Debería ser 6: " . $a . "<br>\n";

echo "<h3>Postdecremento</h3>";
$a = 5;
echo "Debería ser 5: " . $a-- . "<br>\n";
echo "Debería ser 4: " . $a . "<br>\n";

echo "<h3>Predecremento</h3>";
$a = 5;
echo "Debería ser 4: " . --$a . "<br>\n";
echo "Debería ser 4: " . $a . "<br>\n";
?>

Anterior | Inicio | Siguiente
Operador de ejecución | Subir | Operadores Lógicos


Operadores Lógicos

Tabla 10-5. Operadores Lógicos

ejemplo | nombre | resultado
$a and $b | Y | Cierto si tanto $a como $b son ciertos.
$a or $b | O | Cierto si $a o $b son ciertos.
$a xor $b | O exclusiva | Cierto si $a es cierto o $b es cierto, pero no ambos a la vez.
! $a | Negación | Cierto si $a no es cierto.
$a && $b | Y | Cierto si tanto $a como $b son ciertos.
$a || $b | O | Cierto si $a o $b son ciertos.

La razón de las dos variaciones de "y" y "o" es que operan con distinta precedencia (ver Precedencia de Operadores.)

Anterior | Inicio | Siguiente
Operadores de Incremento/decremento | Subir | Precedencia de Operadores


Precedencia de Operadores

La precedencia de operadores especifica cómo se agrupan las expresiones. Por ejemplo, en la expresión 1 + 5 * 3, la respuesta es 16 y no 18 porque el operador de multiplicación ("*") tiene una mayor precedencia que el de adición ("+").

La siguiente tabla lista la precedencia de operadores, indicándose primero los de menor precedencia.

Tabla 10-6. Precedencia de Operadores

Asociatividad | Operadores
izquierda | ,
izquierda | or
izquierda | xor
izquierda | and
derecha | print
izquierda | = += -= *= /= .= %= &= |= ^= ~= <<= >>=
izquierda | ? :
izquierda | ||
izquierda | &&
izquierda | |
izquierda | ^
izquierda | &
no asociativo | == != ===
no asociativo | < <= > >=
izquierda | << >>
izquierda | + - .
izquierda | * / %
derecha | ! ~ ++ -- (int) (double) (string) (array) (object) @
derecha | [
no asociativo | new

Anterior | Inicio | Siguiente
Operadores Lógicos | Subir | Operadores de Cadenas


Operadores de Cadenas

Hay dos operadores de cadenas. El primero es el operador de concatenación ('.'), que devuelve el resultado de concatenar sus operandos izquierdo y derecho. El segundo es el operador de concatenación y asignación ('.='). Consulta Operadores de Asignación para más información.

$a = "Hola ";
$b = $a . "Mundo!"; // ahora $b contiene "Hola Mundo!"

$a = "Hola ";
$a .= "Mundo!"; // ahora $a contiene "Hola Mundo!"

Anterior | Inicio | Siguiente
Precedencia de Operadores | Subir | Estructuras de Control


Estructuras de Control

Manual de PHP
Anterior Siguiente

Capítulo 11. Estructuras de Control

Tabla de contenidos
if
else
elseif
Sintaxis Alternativa de Estructuras de Control
while
do..while
for
foreach
break
continue
switch
require()
include()
require_once()
include_once()

Todo archivo de comandos PHP se compone de una serie de sentencias. Una sentencia puede ser una asignación, una llamada a función, un bucle, una sentencia condicional e incluso una sentencia que no haga nada (una sentencia vacía). Las sentencias normalmente acaban con punto y coma. Además, las sentencias se pueden agrupar en grupos de sentencias encapsulando un grupo de sentencias con llaves. Un grupo de sentencias es también una sentencia. En este capítulo se describen los diferentes tipos de sentencias.

if

La construcción if es una de las más importantes características de muchos lenguajes, incluido PHP. Permite la ejecución condicional de fragmentos de código. PHP caracteriza una estructura if que es similar a la de C:

if (expr)
     sentencia

Como se describe en la sección sobre expresiones, expr se evalúa a su valor condicional. Si expr se evalúa como TRUE, PHP ejecutará la sentencia, y si se evalúa como FALSE - la ignorará.

El siguiente ejemplo mostraría a es mayor que b si $a fuera mayor que $b:

if ($a > $b)
     print "a es mayor que b";

A menudo, se desea tener más de una sentencia ejecutada de forma condicional. Por supuesto, no hay necesidad de encerrar cada sentencia con una cláusula if. En vez de eso, se pueden agrupar varias sentencias en un grupo de sentencias. Por ejemplo, este código mostraría a es mayor que b si $a fuera mayor que $b, y entonces asignaría el valor de $a a $b:

if ($a > $b) {
     print "a es mayor que b";
     $b = $a;
 }

Las sentencias if se pueden anidar indefinidamente dentro de otras sentencias if, lo cual proporciona una flexibilidad completa para ejecuciones condicionales en las diferentes partes de tu programa.

Anterior | Inicio | Siguiente
Operadores de Cadenas | Subir | else


else

A menudo queremos ejecutar una sentencia si se cumple una cierta condicion, y una sentencia distinta si la condición no se cumple. Esto es para lo que sirve else. else extiende una sentencia if para ejecutar una sentencia en caso de que la expresión en la sentencia if se evalúe como FALSE. Por ejemplo, el siguiente código mostraría a es mayor que b si $a fuera mayor que $b, y a NO es mayor que b en cualquier otro caso:

if ($a > $b) {
     print "a es mayor que b";
 } else {
     print "a NO es mayor que b";
 }

La sentencia else se ejecuta solamente si la expresión if se evalúa como FALSE, y si hubiera alguna expresión elseif - sólo si se evaluaron también a FALSE (Ver elseif).

Anterior | Inicio | Siguiente
Estructuras de Control | Subir | elseif


elseif

elseif, como su nombre sugiere, es una combinación de if y else. Como else, extiende una sentencia if para ejecutar una sentencia diferente en caso de que la expresión if original se evalúa como FALSE. No obstante, a diferencia de else, ejecutará esa expresión alternativa solamente si la expresión condicional elseif se evalúa como TRUE. Por ejemplo, el siguiente código mostraría a es mayor que b, a es igual a b o a es menor que b:

if ($a > $b) {
     print "a es mayor que b";
 } elseif ($a == $b) {
     print "a es igual que b";
 } else {
     print "a es mayor que b";
 }

Puede haber varios elseifs dentro de la misma sentencia if. La primera expresión elseif (si hay alguna) que se evalúe como TRUE se ejecutaría. En PHP, también se puede escribir 'else if' (con dos palabras) y el comportamiento sería idéntico al de un 'elseif' (una sola palabra). El significado sintáctico es ligeramente distinto (si estas familiarizado con C, es el mismo comportamiento) pero la línea básica es que ambos resultarían tener exactamente el mismo comportamiento.

La sentencia elseif se ejecuta sólo si la expresión if precedente y cualquier expresión elseif precedente se evalúan como FALSE, y la expresión elseif actual se evalúa como TRUE.

Anterior | Inicio | Siguiente
else | Subir | Sintaxis Alternativa de Estructuras de Control


Sintaxis Alternativa de Estructuras de Control

PHP ofrece una sintaxis altenativa para alguna de sus estructuras de control; a saber, if, while, for, y switch. En cada caso, la forma básica de la sintaxis alternativa es cambiar abrir-llave por dos puntos (:) y cerrar-llave por endif;, endwhile;, endfor;, or endswitch;, respectivamente.

<?php if ($a==5): ?>
 A es igual a 5
 <?php endif; ?>

En el ejemplo de arriba, el bloque HTML "A = 5" se anida dentro de una sentencia if escrita en la sintaxis alternativa. El bloque HTML se mostraría solamente si $a fuera igual a 5.

La sintaxis alternativa se aplica a else y también a elseif. La siguiente es una estructura if con elseif y else en el formato alternativo:

if ($a == 5):
     print "a es igual a 5";
     print "...";
 elseif ($a == 6):
     print "a es igual a 6";
     print "!!!";
 else:
     print "a no es ni 5 ni 6";
 endif;

Mirar también while, for, e if para más ejemplos.

Anterior | Inicio | Siguiente
elseif | Subir | while


while

Los bucles while son los tipos de bucle más simples en PHP. Se comportan como su contrapartida en C. La forma básica de una sentencia while es:

while (expr) sentencia

El significado de una sentencia while es simple. Le dice a PHP que ejecute la(s) sentencia(s) anidada(s) repetidamente, mientras la expresión while se evalúe como TRUE. El valor de la expresión es comprobado cada vez al principio del bucle, así que incluso si este valor cambia durante la ejecución de la(s) sentencia(s) anidada(s), la ejecución no parará hasta el fin de la iteración (cada vez que PHP ejecuta las sentencias en el bucle es una iteración). A veces, si la expresión while se evalúa como FALSE desde el principio de todo, la(s) sentencia(s) anidada(s) no se ejecutarán ni siquiera una vez.

Como con la sentencia if, se pueden agrupar multiples sentencias dentro del mismo bucle while encerrando un grupo de sentencias con llaves, o usando la sintaxis alternativa:

while (expr): sentencia ... endwhile;

Los siguientes ejemplos son idénticos, y ambos imprimen números del 1 al 10:

/* ejemplo 1 */

 $i = 1;
 while ($i <= 10) {
     print $i++;  /* el valor impreso sería
                     $i antes del incremento
                     (post-incremento) */
 }

 /* ejemplo 2 */

 $i = 1;
 while ($i <= 10):
     print $i;
     $i++;
 endwhile;

Anterior | Inicio | Siguiente
Sintaxis Alternativa de Estructuras de Control | Subir | do..while


do..while

Los bucles do..while son muy similares a los bucles while, excepto que las condiciones se comprueban al final de cada iteración en vez de al principio. La principal diferencia frente a los bucles regulares while es que se garantiza la ejecución de la primera iteración de un bucle do..while (la condición se comprueba sólo al final de la iteración), mientras que puede no ser necesariamente ejecutada con un bucle while regular (la condición se comprueba al principio de cada iteración, si esta se evalúa como FALSE desde el principio la ejecución del bucle finalizará inmediatamente).

Hay una sola sintaxis para los bucles do..while:

$i = 0;
 do {
     print $i;
 } while ($i>0);

El bucle de arriba se ejecutaría exactamente una sola vez, después de la primera iteración, cuando la condición se comprueba, se evalúa como FALSE ($i no es más grande que 0) y la ejecución del bucle finaliza.

Los usuarios avanzados de C pueden estar familiarizados con un uso distinto del bucle do..while, para permitir parar la ejecución en medio de los bloques de código, encapsulandolos con do..while(0), y usando la sentencia break. El siguiente fragmento de código demuestra esto:

do {
     if ($i < 5) {
         print "i no es lo suficientemente grande";
         break;
     }
     $i *= $factor;
     if ($i < $minimum_limit) {
         break;
     }
     print "i es correcto";
     ...procesa i...
 } while(0);

No se preocupes si no entiende esto completamente o en absoluto. Se pueden codificar archivos de comandos e incluso archivos de comandos potentes sin usar esta 'propiedad'.

Anterior | Inicio | Siguiente
while | Subir | for


for

Los bucles for son los bucles más complejos en PHP. Se comportan como su contrapartida en C. La sintaxis de un bucle for es:

for (expr1; expr2; expr3) sentencia

La primera expresión (expr1) se evalúa (ejecuta) incondicionalmente una vez al principio del bucle.

Al comienzo de cada iteración, se evalúa expr2 . Si se evalúa como TRUE, el bucle continúa y las sentencias anidadas se ejecutan. Si se evalúa como FALSE, la ejecución del bucle finaliza.

Al final de cada iteración, se evalúa (ejecuta) expr3.

Cada una de las expresiones puede estar vacía. Que expr2 esté vacía significa que el bucle debería correr indefinidamente (PHP implicitamente lo considera como TRUE, al igual que C). Esto puede que no sea tan inútil como se podría pensar, puesto que a menudo se quiere salir de un bucle usando una sentencia break condicional en vez de usar la condición de for.

Considera los siguientes ejemplos. Todos ellos muestran números del 1 al 10:

/* ejemplo 1 */

 for ($i = 1; $i <= 10; $i++) {
     print $i;
 }

 /* ejemplo 2 */

 for ($i = 1;;$i++) {
     if ($i > 10) {
         break;
     }
     print $i;
 }

 /* ejemplo 3 */

 $i = 1;
 for (;;) {
     if ($i > 10) {
         break;
     }
     print $i;
     $i++;
 }

 /* ejemplo 4 */

 for ($i = 1; $i <= 10; print $i, $i++) ;

Por supuesto, el primer ejemplo parece ser el mas elegante (o quizás el cuarto), pero uno puede descubrir que ser capaz de usar expresiones vacías en bucles for resulta útil en muchas ocasiones.

PHP también soporta la "sintaxis de dos puntos" alternativa para bucles for.

for (expr1; expr2; expr3): sentencia; ...; endfor;

Otros lenguajes poseen una sentencia foreach para traducir un array o una tabla hash. PHP3 no posee tal construcción; PHP4 sí (ver foreach). En PHP3, se puede combinar while con las funciones list() y each() para conseguir el mismo efecto. Mirar la documentación de estas funciones para ver un ejemplo.

Anterior | Inicio | Siguiente
do..while | Subir | foreach


foreach

PHP4 (PHP3 no) incluye una construcción foreach, tal como perl y algunos otros lenguajes. Esto simplemente da un modo fácil de iterar sobre arrays. Hay dos sintaxis; la segunda es una extensión menor, pero útil de la primera:

foreach(expresion_array as $value) sentencia
foreach(expresion_array as $key => $value) sentencia

La primera forma recorre el array dado por expresion_array. En cada iteración, el valor del elemento actual se asigna a $value y el puntero interno del array se avanza en una unidad (así en el siguiente paso, se estará mirando el elemento siguiente).

La segunda manera hace lo mismo, salvo que la clave del elemento actual será asignada a la variable $key en cada iteración.

Nota: Cuando foreach comienza su primera ejecución, el puntero interno a la lista (array) se reinicia automáticamente al primer elemento del array. Esto significa que no se necesita llamar a reset() antes de un bucle foreach.

Nota: Hay que tener en cuanta queforeach con una copia de la lista (array) especificada y no la lista en si, por ello el puntero de la lista no es modificado como en la construcción each.

Puede haber observado que las siguientes son funcionalidades idénticas:

reset( $arr );
while( list( , $value ) = each( $arr ) ) {
   echo "Valor: $value<br>\n";
}

foreach( $arr as $value ) {
   echo "Valor: $value<br>\n";
}

Las siguientes también son funcionalidades idénticas:

reset( $arr );
while( list( $key, $value ) = each( $arr ) ) {
   echo "Key: $key; Valor: $value<br>\n";
}

foreach( $arr as $key => $value ) {
   echo "Key: $key; Valor: $value<br>\n";
}

Algunos ejemplos más para demostrar su uso:

/* foreach ejemplo 1: sólo valor*/
$a = array(1, 2, 3, 17);

foreach($a as $v) {
   print "Valor actual de \$a: $v.\n";
}

/* foreach ejemplo 2: valor (con clave impresa para ilustrar) */
$a = array(1, 2, 3, 17);

$i = 0; /* sólo para propósitos demostrativos */

foreach($a as $v) {
   print "\$a[$i] => $k.\n";
}

/* foreach ejemplo 3: clave y valor */
$a = array(
   "uno" => 1,
   "dos" => 2,
   "tres" => 3,
   "diecisiete" => 17
);

foreach($a as $k => $v) {
   print "\$a[$k] => $v.\n";
}

Anterior | Inicio | Siguiente
for | Subir | break


break

break escapa de la estructuras de control iterante (bucle) actuales for, while, o switch.

break accepta un parámetro opcional, el cual determina cuantas estructuras de control hay que escapar.

$arr = array ('one', 'two', 'three', 'four', 'stop', 'five');
while (list (, $val) = each ($arr)) {
    if ($val == 'stop') {
        break;    /* You could also write 'break 1;' here. */
    }
    echo "$val<br>\n";
}

/* Using the optional argument. */

$i = 0;
while (++$i) {
    switch ($i) {
    case 5:
        echo "At 5<br>\n";
        break 1;  /* Exit only the switch. */
    case 10:
        echo "At 10; quitting<br>\n";
        break 2;  /* Exit the switch and the while. */
    default:
        break;
    }
}

Anterior | Inicio | Siguiente
foreach | Subir | continue


continue

continue se usa dentro de la estructura del bucle para saltar el resto de la iteración actual del bucle y continuar la ejecución al comienzo de la siguiente iteración.

continue accepta un parámetro opcional, el cual determina cuantos niveles (bluces) hay que saltar antes de continuar con la ejecución.

while (list($key,$value) = each($arr)) {
     if ($key % 2) { // salta los miembros impares
         continue;
     }
     do_something_odd ($value);
 }
$i = 0;
while ($i++ < 5) {
    echo "Outer<br>\n";
    while (1) {
        echo "  Middle<br>\n";
        while (1) {
            echo "  Inner<br>\n";
            continue 3;
        }
        echo "This never gets output.<br>\n";
    }
    echo "Neither does this.<br>\n";
}

Anterior | Inicio | Siguiente
break | Subir | switch


switch

La sentencia switch es similar a una serie de sentencias IF en la misma expresión. En muchas ocasiones, se quiere comparar la misma variable (o expresión) con nuchos valores diferentes, y ejecutar una parte de código distinta dependiendo de a qué valor es igual. Para ello sirve la sentencia switch.

Los siguientes dos ejemplos son dos modos distintos de escribir la misma cosa, uno usa una serie de sentencias if, y el otro usa la sentencia switch:

if ($i == 0) {
     print "i es igual a 0";
 }
 if ($i == 1) {
     print "i es igual a 1";
 }
 if ($i == 2) {
     print "i es igual a 2";
 }

 switch ($i) {
     case 0:
         print "i es igual a 0";
         break;
     case 1:
         print "i es igual a 1";
         break;
     case 2:
         print "i es igual a 2";
         break;
 }

Es importante entender cómo se ejecuta la sentencia switch para evitar errores. La sentencia switch ejecuta línea por línea (realmente, sentencia a sentencia). Al comienzo, no se ejecuta código. Sólo cuando se encuentra una sentencia case con un valor que coincide con el valor de la expresión switch PHP comienza a ejecutar las sentencias. PHP continúa ejecutando las sentencias hasta el final del bloque switch, o la primera vez que vea una sentencia break. Si no se escribe una sentencia break al final de una lista de sentencias case, PHP seguirá ejecutando las sentencias del siguiente case. Por ejemplo:

switch ($i) {
     case 0:
         print "i es igual a 0";
     case 1:
         print "i es igual a 1";
     case 2:
         print "i es igual a 2";
 }

Aquí, si $i es igual a 0, ¡PHP ejecutaría todas las sentecias print! Si $i es igual a 1, PHP ejecutaría las últimas dos sentencias print y sólo si $i es igual a 2, se obtendría la conducta 'esperada' y solamente se mostraría 'i es igual a 2'. Así, es importante no olvidar las sentencias break (incluso aunque pueda querer evitar escribirlas intencionadamente en ciertas circunstancias).

En una sentencia switch, la condición se evalúa sólo una vez y el resultado se compara a cada sentencia case. En una sentencia elseif, la condición se evalúa otra vez. Si tu condición es más complicada que una comparación simple y/o está en un bucle estrecho, un switch puede ser más rápido.

La lista de sentencias de un case puede también estar vacía, lo cual simplemente pasa el control a la lista de sentencias del siguiente case.

switch ($i) {
     case 0:
     case 1:
     case 2:
         print "i es menor que 3, pero no negativo";
         break;
     case 3:
         print "i es 3";
 }

Un case especial es el default case. Este case coincide con todo lo que no coincidan los otros case. Por ejemplo:

switch ($i) {
     case 0:
         print "i es igual a 0";
         break;
     case 1:
         print "i es igual a 1";
         break;
     case 2:
         print "i es igual a 2";
         break;
     default:
         print "i no es igual a 0, 1 o 2";
 }

La expresión case puede ser cualquier expresión que se evalúe a un tipo simple, es decir, números enteros o de punto flotante y cadenas de texto. No se pueden usar aquí ni arrays ni objetos a menos que se conviertan a un tipo simple.

La sintaxis alternativa para las estructuras de control está también soportada con switch. Para más información, ver Sintaxis alternativa para estructuras de control.

switch ($i):
     case 0:
         print "i es igual 0";
         break;
     case 1:
         print "i es igual a 1";
         break;
     case 2:
         print "i es igual a 2";
         break;
     default:
         print "i no es igual a 0, 1 o 2";
 endswitch;

Anterior | Inicio | Siguiente
continue | Subir | require()


require

Manual de PHP
Anterior Capítulo 11. Estructuras de Control Siguiente

require()

La sentencia require() se sustituye a sí misma con el archivo especificado, tal y como funciona la directiva #include de C.

Un punto importante sobre su funcionamiento es que cuando un archivo se incluye con include() o se requiere con require()), el intérprete sale del modo PHP y entra en modo HTML al principio del archivo referenciado, y vuelve de nuevo al modo PHP al final. Por esta razón, cualquier código dentro del archivo referenciado que debiera ser ejecutado como código PHP debe ser encerrado dentro de etiquetas válidas de comienzo y fin de PHP.

require() no es en realidad una función de PHP; es más una construcción del lenguaje. Está sujeta a algunas reglas distintas de las de funciones. Por ejemplo, require() no esta sujeto a ninguna estructura de control contenedora. Por otro lado, no devuelve ningún valor; intentar leer un valor de retorno de una llamada a un require() resulta en un error del intérprete.

A diferencia de include(), require() siempre leerá el archivo referenciado, incluso si la línea en que está no se ejecuta nunca. Si se quiere incluir condicionalmente un archivo, se usa include(). La sentencia conditional no afecta a require(). No obstante, si la línea en la cual aparece el require() no se ejecuta, tampoco se ejecutará el código del archivo referenciado.

De forma similar, las estructuras de bucle no afectan la conducta de require(). Aunque el código contenido en el archivo referenciado está todavía sujeto al bucle, el propio require() sólo ocurre una vez.

Esto significa que no se puede poner una sentencia require() dentro de una estructura de bucle y esperar que incluya el contenido de un archivo distinto en cada iteración. Para hacer esto, usa una sentencia include().

require( 'header.inc' );

When a file is require()ed, the code it contains inherits the variable scope of the line on which the require() occurs. Any variables available at that line in the calling file will be available within the called file. If the require() occurs inside a function within the calling file, then all of the code contained in the called file will behave as though it had been defined inside that function.

If the require()ed file is called via HTTP using the fopen wrappers, and if the target server interprets the target file as PHP code, variables may be passed to the require()ed file using an URL request string as used with HTTP GET. This is not strictly speaking the same thing as require()ing the file and having it inherit the parent file's variable scope; the script is actually being run on the remote server and the result is then being included into the local script.

/* This example assumes that someserver is configured to parse .php
 * files and not .txt files. Also, 'works' here means that the variables
 * $varone and $vartwo are available within the require()ed file. */

/* Won't work; file.txt wasn't handled by someserver. */
require ("http://someserver/file.txt?varone=1&vartwo=2");

/* Won't work; looks for a file named 'file.php?varone=1&vartwo=2'
 * on the local filesystem. */
require ("file.php?varone=1&vartwo=2");

/* Works. */
require ("http://someserver/file.php?varone=1&vartwo=2");

$varone = 1;
$vartwo = 2;
require ("file.txt");  /* Works. */
require ("file.php");  /* Works. */

En PHP3, es posible ejecutar una sentencia return dentro de un archivo referenciado con require(), en tanto en cuanto esa sentencia aparezca en el ámbito global del archivo requerido (require()). No puede aparecer dentro de ningún bloque (lo que siginifica dentro de llaves({})). En PHP4, no obstante, esta capacidad ha sido desestimada. Si se necesita esta funcionalidad, véase include().

Ver tambien include(), require_once(),
include_once(), readfile(),
 y virtual().

Anterior | Inicio | Siguiente
switch | Subir | include()


include

Manual de PHP
Anterior Capítulo 11. Estructuras de Control Siguiente

include()

La sentencia include() incluye y evalúa el archivo especificado.

Si "URL fopen wrappers" esta activada en PHP (como está en la configuración inicial), se puede especificar el fichero que se va a incluir usando una URL en vez de un fichero local (con su Path) Ver Ficheros remotos y fopen() para más información.

Un punto importante sobre su funcionamiento es que cuando un archivo se incluye con include() o se requiere con require(), el intérprete sale del modo PHP y entra en modo HTML al principio del archivo referenciado, y vuelve de nuevo al modo PHP al final. Por esta razón, cualquier código dentro del archivo referenciado que debiera ser ejecutado como código PHP debe ser encerrado dentro de etiquetas válidas de comienzo y fin de PHP.

Esto sucede cada vez que se encuentra la sentencia include(), así que se puede usar una sentencia include() dentro de una estructura de bucle para incluir un número de archivos diferentes.

$archivos = array ('primero.inc', 'segundo.inc', 'tercero.inc');
for ($i = 0; $i < count($archivos); $i++) {
    include $archivos[$i];
}

include() difiere de require() en que la sentencia include se re-evalúa cada vez que se encuentra (y sólo cuando está siendo ejecutada), mientras que la sentencia require() se reemplaza por el archivo referenciado cuando se encuentra por primera vez, se vaya a evaluar el contenido del archivo o no (por ejemplo, si está dentro de una sentencia if cuya condición evaluada es falsa).

Debido a que include() es una construcción especial del lenguaje, se debe encerrar dentro de un bloque de sentencias si está dentro de un bloque condicional.

/* Esto es ERRÓNEO y no funcionará como se desea. */

 if ($condicion)
     include($archivo);
 else
     include($otro);

 /* Esto es CORRECTO. */

 if ($condicion) {
     include($archivo);
 } else {
     include($otro);
 }

En ambos, PHP3 y PHP4, es posible ejecutar una sentencia return dentro de un archivo incluido con include(), para terminar el procesado de ese archivo y volver al archivo de comandos que lo llamó. Existen algunas diferencias en el modo en que esto funciona, no obstante. La primera es que en PHP3, return no puede aparecer dentro de un bloque a menos que sea un bloque de función, en el cual return se aplica a esa función y no al archivo completo. En PHP4, no obstante, esta restricción no existe. También, PHP4 permite devolver valores desde archivos incluidos con include(). Se puede capturar el valor de la llamada a include() como se haría con una función normal. Esto genera un error de intérprete en PHP3.

Ejemplo 11-1. include() en PHP3 y PHP4

Asumamos la existencia del siguiente archivo (llamado test.inc) en el mismo directorio que el archivo principal:
<?php
echo "Antes del return <br>\n";
if ( 1 ) {
   return 27;
}
echo "Después del return <br>\n";
?>

Asumamos que el archivo principal (main.html) contiene lo siguiente:
<?php
$retval = include( 'test.inc' );
echo "El archivo devolvió: '$retval'<br>\n";
?>

Cuando se llama a main.html en PHP3, generará un error del intérprete en la linea 2; no se puede capturar el valor de un include() en PHP3. En PHP4, no obstante, el resultado será:
Antes del return
El archivo devolvió: '27'

Ahora, asumamos que se ha modificado main.html para que contenga lo siguiente:
<?php
include( 'test.inc' );
echo "De vuelta en main.html<br>\n";
?>

En PHP4, la salida será:
Antes del return
De vuelta en main.html
No obstante, PHP3 dará la siguiente salida:
Antes del return
27De vuelta en main.html

Parse error: parse error in /home/torben/public_html/phptest/main.html on line 5

El error del intérprete es resultado del hecho de que la sentencia return está encerrada en un bloque de no-función dentro de test.inc. Cuando el return se mueve fuera del bloque, la salida es:
Antes del return
27De vuelta en main.html

El '27' espúreo se debe al hecho de que PHP3 no soporta devolver valores con return desde archivos como ese.

When a file is include()ed, the code it contains inherits the variable scope of the line on which the include() occurs. Any variables available at that line in the calling file will be available within the called file. If the include() occurs inside a function within the calling file, then all of the code contained in the called file will behave as though it had been defined inside that function.

If the include()ed file is called via HTTP using the fopen wrappers, and if the target server interprets the target file as PHP code, variables may be passed to the include()ed file using an URL request string as used with HTTP GET. This is not strictly speaking the same thing as include()ing the file and having it inherit the parent file's variable scope; the script is actually being run on the remote server and the result is then being included into the local script.

/* This example assumes that someserver is configured to parse .php
 * files and not .txt files. Also, 'works' here means that the variables
 * $varone and $vartwo are available within the include()ed file. */

/* Won't work; file.txt wasn't handled by someserver. */
include ("http://someserver/file.txt?varone=1&vartwo=2");

/* Won't work; looks for a file named 'file.php?varone=1&vartwo=2'
 * on the local filesystem. */
include ("file.php?varone=1&vartwo=2");

/* Works. */
include ("http://someserver/file.php?varone=1&vartwo=2");

$varone = 1;
$vartwo = 2;
include ("file.txt");  /* Works. */
include ("file.php");  /* Works. */

See also require(), require_once(),
include_once(), readfile(),
    and virtual().


require_once

Manual de PHP
Anterior Capítulo 11. Estructuras de Control Siguiente

require_once()

The require_once() statement replaces itself with the specified file, much like the C preprocessor's #include works, and in that respect is similar to the require() statement. The main difference is that in an inclusion chain, the use of require_once() will assure that the code is added to your script only once, and avoid clashes with variable values or function names that can happen.

For example, if you create the following 2 include files utils.inc and foolib.inc

Ejemplo 11-2. utils.inc

<?php
define(PHPVERSION, floor(phpversion()));
echo "GLOBALS ARE NICE\n";
function goodTea() {
        return "Oolong tea tastes good!";
}
?>

Ejemplo 11-3. foolib.inc

<?php
require ("utils.inc");
function showVar($var) {
        if (PHPVERSION == 4) {
                print_r($var);
        } else {
                dump_var($var);
        }
}

// bunch of other functions ...
?>
And then you write a script cause_error_require.php

Ejemplo 11-4. cause_error_require.php

<?php
require("foolib.inc");
/* the following will generate an error */
require("utils.inc");
$foo = array("1",array("complex","quaternion"));
echo "this is requiring utils.inc again which is also\n";
echo "required in foolib.inc\n";
echo "Running goodTea: ".goodTea()."\n";
echo "Printing foo: \n";
showVar($foo);
?>
When you try running the latter one, the resulting ouptut will be (using PHP 4.01pl2):

GLOBALS ARE NICE
GLOBALS ARE NICE

Fatal error:  Cannot redeclare causeerror() in utils.inc on line 5

By modifying foolib.inc and cause_errror_require.php to use require_once() instead of require() and renaming the last one to avoid_error_require_once.php, we have:

Ejemplo 11-5. foolib.inc (fixed)

...
require_once("utils.inc");
function showVar($var) {
...

Ejemplo 11-6. avoid_error_require_once.php

...
require_once("foolib.inc");
require_once("utils.inc");
$foo = array("1",array("complex","quaternion"));
...
And when running the latter, the output will be (using PHP 4.0.1pl2):

GLOBALS ARE NICE
this is requiring globals.inc again which is also
required in foolib.inc
Running goodTea: Oolong tea tastes good!
Printing foo:
Array
(
    [0] => 1
    [1] => Array
        (
            [0] => complex
            [1] => quaternion
        )

)

Also note that, analogous to the behavior of the #include of the C preprocessor, this statement acts at "compile time", e.g. when the script is parsed and before it is executed, and should not be used for parts of the script that need to be inserted dynamically during its execution. You should use include_once() or include() for that purpose.

For more examples on using require_once() and include_once(), look at the PEAR code included in the latest PHP source code distributions.

See also: require(),
include(), include_once(),
get_required_files(),
get_included_files(), readfile(),
    and virtual().


include_once

Manual de PHP
Anterior Capítulo 11. Estructuras de Control Siguiente

include_once()

The include_once() statement includes and evaluates the specified file during the execution of the script. This is a behavior similar to the include() statement, with the important difference that if the code from a file has already been included, it will not be included again.

As mentioned in the require_once() description, the include_once() should be used in the cases in which the same file might be included and evaluated more than once during a particular execution of a script, and you want to be sure that it is included exactly once to avoid problems with function redefinitions, variable value reassignments, etc.

For more examples on using require_once() and include_once(), look at the PEAR code included in the latest PHP source code distributions.

See also: require(),
include(), require_once(),
get_required_files(),
get_included_files(), readfile(),
    and virtual().

Anterior | Inicio | Siguiente
require_once() | Subir | Funciones


Funciones

Manual de PHP
Anterior Siguiente

Capítulo 12. Funciones

Tabla de contenidos
Funciones definidas por el usuario
Parámetros de las funciones
Devolver valores
old_function
Funciones variable

Funciones definidas por el usuario

Una función se define con la siguiente sintaxis:

function foo ($arg_1, $arg_2, ..., $arg_n) {
    echo "Función de ejemplo.\n";
    return $retval;
}

Cualquier instrucción válida de PHP puede aparecer en el cuerpo de la función, incluso otras funiones y definiciones de clases.

En PHP3, las funciones deben definirse antes de que se referencien. En PHP4 no existe tal requerimiento.

PHP no soporta la sobrecarga de funciones, y tampoco es posible redefinir u ocultar funciones previamente declaradas.

PHP3 no soporta un número variable de parámetros, aunque sí soporta parámetros por defecto (ver Valores por defecto de de los parámetros para más información). PHP4 soporta ambos: ver Listas de longitud variable de parámetros y las referencias de las funciones func_num_args(), func_get_arg(), y func_get_args() para más información.

Anterior | Inicio | Siguiente
include_once() | Subir | Parámetros de las funciones


Parámetros de las funciones

La información puede suministrarse a las funciones mediante la lista de parámetros, una lista de variables y/o constantes separadas por comas.

PHP soporta pasar parámetros por valor (el comportamiento por defecto), por referencia, y parámetros por defecto. Listas de longitud variable de parámetros sólo están soportadas en PHP4 y posteriores; ver Listas de longitud variable de parámetros y la referencia de las funciones func_num_args(), func_get_arg(), y func_get_args() para más información. Un efecto similar puede conseguirse en PHP3 pasando un array de parámetros a la función:

function takes_array($input) {
    echo "$input[0] + $input[1] = ", $input[0]+$input[1];
}

Pasar parámetros por referencia

Por defecto, los parámetros de una función se pasan por valor (de manera que si cambias el valor del argumento dentro de la función, no se ve modificado fuera de ella). Si deseas permitir a una función modificar sus parámetros, debes pasarlos por referencia.

Si quieres que un parámetro de una función siempre se pase por referencia, puedes anteponer un ampersand (&) al nombre del parámetro en la definición de la función:

function add_some_extra(&$string) {
    $string .= ' y algo más.';
}
$str = 'Esto es una cadena, ';
add_some_extra($str);
echo $str;    // Saca 'Esto es una cadena, y algo más.'

Si deseas pasar una variable por referencia a una función que no toma el parámetro por referencia por defecto, puedes anteponer un ampersand al nombre del parámetro en la llamada a la función:

function foo ($bar) {
    $bar .= ' y algo más.';
}
$str = 'Esto es una cadena, ';
foo ($str);
echo $str;    // Saca 'Esto es una cadena, '
foo (&$str);
echo $str;    // Saca 'Esto es una cadena, y algo más.'

Parámetros por defecto

Una función puede definir valores por defecto para los parámetros escalares estilo C++:

function makecoffee ($type = "cappucino") {
    return "Hacer una taza de $type.\n";
}
echo makecoffee ();
echo makecoffee ("espresso");

La salida del fragmento anterior es:
Hacer una taza de cappucino.
Hacer una taza de espresso.

El valor por defecto tiene que ser una expresión constante, y no una variable o miembro de una clase.

En PHP 4.0 también es posible especificar unset como parámetro por defecto. Esto significa que el argumento no tomará ningún valor en absoluto si el valor no es suministrado.

Destacar que cuando se usan parámetros por defecto, estos tienen que estar a la derecha de cualquier parámetro sin valor por defecto; de otra manera las cosas no funcionarán de la forma esperada. Considera el siguiente fragmento de código:

function makeyogurt ($type = "acidophilus", $flavour) {
    return "Haciendo un bol de $type $flavour.\n";
}

echo makeyogurt ("mora");   // No funcionará de la manera esperada

La salida del ejemplo anterior es:
Warning: Missing argument 2 in call to makeyogurt() in
/usr/local/etc/httpd/htdocs/php3test/functest.html on line 41
Haciendo un bol de mora.

Y ahora, compáralo con:

function makeyogurt ($flavour, $type = "acidophilus") {
    return "Haciendo un bol de $type $flavour.\n";
}

echo makeyogurt ("mora");   // funciona como se esperaba

La salida de este ejemplo es:
Haciendo un bol de acidophilus mora.

Lista de longitud variable de parámetros

PHP4 soporta las listas de longitud variable de parámetros en las funciones definidas por el usuario. Es realmente fácil, usando las funciones func_num_args(), func_get_arg(), y func_get_args().

No necesita de ninguna sintaxis especial, y las listas de parámetros pueden ser escritas en la llamada a la función y se comportarán de la manera esperada.

Anterior | Inicio | Siguiente
Funciones | Subir | Devolver valores


Devolver valores

Los valores se retornan usando la instrucción opcional return. Puede devolverse cualquier tipo de valor, incluyendo listas y objetos.

function square ($num) {
    return $num * $num;
}
echo square (4);   // saca '16'.

No puedes devolver múltiples valores desde una función, pero un efecto similar se puede conseguir devolviendo una lista.

function small_numbers() {
    return array (0, 1, 2);
}
list ($zero, $one, $two) = small_numbers();

Anterior | Inicio | Siguiente
Parámetros de las funciones | Subir | old_function


old_function

La instrucción old_function permite declarar una función usando una sintaxis idéntica a la de PHP/FI2 (excepto que debes reemplazar 'function' por 'old_function').

Es una característica obsoleta, y debería ser usada únicamente por el conversor PHP/FI2->PHP3.

Aviso

Las funciones declaradas como old_function no pueden llamarse desde el código interno de PHP. Entre otras cosas, esto significa que no puedes usarlas en funciones como usort(), array_walk(), y register_shutdown_function(). Puedes solventar esta limitación escribiendo un "wrapper" (en PHP3 normal) que a su vez llame a la función declarada como old_function.

Anterior | Inicio | Siguiente
Devolver valores | Subir | Funciones variable


Funciones variable

PHP soporta el concepto de funciones variable, esto significa que si una variable tiene unos paréntesis añadidos al final, PHP buscará una función con el mismo nombre que la evaluación de la variable, e intentará ejecutarla. Entre otras cosas, esto te permite implementar retrollamadas (callbacks), tablas de funciones y demás.

Ejemplo 12-1. Ejemplo de función variable

<?php
function foo() {
    echo "Dentro de foo()<br>\n";
}

function bar( $arg = '' ) {
    echo "Dentro de bar(); el parámetro fue '$arg'.<br>\n";
}

$func = 'foo';
$func();
$func = 'bar';
$func( 'test' );
?>

Anterior | Inicio | Siguiente
old_function | Subir | Clases y Objetos


Clases y Objetos

Manual de PHP
Anterior Siguiente

Capítulo 13. Clases y Objetos

Tabla de contenidos
class

class

Una clase es una colección de variables y de funciones que acceden a esas variables. Una clase se define con la siguiente sintaxis:

<?php
class Cart {
    var $items;  // Items en nuestro carro de la compra

    // Añadir $num artículos de tipo $artnr al carro

    function add_item ($artnr, $num) {
        $this->items[$artnr] += $num;
    }

    // Sacar $num artículos del tipo $artnr del carro

    function remove_item ($artnr, $num) {
        if ($this->items[$artnr] > $num) {
            $this->items[$artnr] -= $num;
            return true;
        } else {
            return false;
        }
    }
}
?>

El ejemplo define una clase llamada Cart que consiste en un array asociativo de artículos en el carro y dos funciones para meter y sacar ítems del carro

Las clases son tipos, es decir, son plantillas para variables. Tienes que crear una variable del tipo deseado con el operador new.

$cart = new Cart;
 $cart->add_item("10", 1);

Este ejemplo crea un objeto $cart de clase Cart. La función add_item() de ese objeto se llama para añadir un item del artículo número 10 al carro.

Las Clases pueden ser extensiones de otras clases. Las clases extendidas o derivadas tienen todas las variables y funciones de la clase base y lo que les añadas al extender la definición. La herencia múltiple no está soportada.

class Named_Cart extends Cart {
    var $owner;

    function set_owner ($name) {
        $this->owner = $name;
    }
}

Ese ejemplo define una clase Named_Cart (carro con nombre o dueño) que tiene todas las variables y funciones de Cart, y además añade la variable $owner y una función adicional set_owner(). Un carro con nombre se crea de la forma habitual y, una vez hecho, puedes acceder al propietario del carro. En los carros con nombre también puedes acceder a las funciones normales del carro:

$ncart = new Named_Cart;    // Creamos un carro con nombre
$ncart->set_owner ("kris"); // Nombramos el carro
print $ncart->owner;        // Imprimimos el nombre del propietario
$ncart->add_item ("10", 1); // Funcionalidad heredada de Cart

Entre funciones de una clase, la variable $this hace referencia al propio objeto. Tienes que usar $this->loquesea para acceder a una variable o función llamada loquesea del objeto actual.

Los constructores son funciones de una clase que se llaman automáticamente al crear una nueva instancia (objeto) de una clase. Una función se convierte en constructor cuando tiene el mismo nombre que la clase.

class Auto_Cart extends Cart {
    function Auto_Cart () {
        $this->add_item ("10", 1);
    }
}

Este ejemplo define una clase Auto_Cart que es un Cart junto con un constructor que inicializa el carro con un item del tipo de artículo "10" cada vez que se crea un nuevo Auto_Cart con "new". Los constructores también pueden recibir parámetros y estos parámetros pueden ser opcionales, lo que los hace más útiles.

class Constructor_Cart extends Cart {
    function Constructor_Cart ($item = "10", $num = 1) {
        $this->add_item ($item, $num);
    }
}

// Compramos las mismas cosas aburridas de siempre

$default_cart   = new Constructor_Cart;

// Compramos las cosas interesantes

$different_cart = new Constructor_Cart ("20", 17);

Atención

Para las clases derivadas, el constructor de la clase padre no es llamado automáticamente cuando se llama al constructor de la clase derivada.

Anterior | Inicio | Siguiente
Funciones variable | Subir | References Explained


References Explained

Manual de PHP
Anterior Siguiente

Capítulo 14. References Explained

Tabla de contenidos
What are References
What do References
What aren't References
Returning References
Unsetting References
Spotting the Reference

What are References

References in PHP are means to call same variable content with different names. They are not like C pointers, they are symbol table aliases. Note that in PHP, variable names and variable content are different, so same content can have different names. The most close analogy is Unix filenames and files - variable names are directory entries, while variable contents is the file itself. References can be thought of as hardlinking in Unix filesystem.

Anterior | Inicio | Siguiente
Clases y Objetos | Subir | What do References


What do References

PHP references allow you to make two variables to refer to the same content. Meaning, when you do:

$a =& $b

it means that $a and $b point to the same variable.

Nota: $a and $b are completely equal here, that's not $a is pointing to $b or vice versa, that's $a and $b pointing to the same place.

The second thing references do is to pass variables by-reference. This is done by making local function variable and caller variable to be reference to the same content. Example:

function foo (&$var) {
    $var++;
}

$a=5;
foo ($a);

will make $a to be 6. This happens because in the function foo the variable $var refers to the same content as $a.

The third thing reference can do is return by-reference.

Anterior | Inicio | Siguiente
References Explained | Subir | What aren't References


What aren't References

As said above, references aren't pointers. That means, the following construct won't do what you expect:

function foo (&$var) {
    $var =& $GLOBALS["baz"];
}
foo($bar);

What will happen that $var in foo will be bound with $bar in caller, but then it will be re-bound with $GLOBALS["baz"]. There's no way to bind $bar in the caller to something else using reference mechanism, since $bar is not available in the function foo (it is represented by $var, but $var has only variable contents and not name-to-value binding in the calling symbol table).

Anterior | Inicio | Siguiente
What do References | Subir | Returning References


Returning References

Returning by-refernce it is useful when you want to use function to find variable which should be bound to. When returning references, use this syntax:

function &find_var ($param) {
    ...code...
    return $found_var;
}

$foo =& find_var ($bar);
$foo->x = 2;

In this example, property of the object returned by the find_var function would be set, not of the copy, as it would be without using reference syntax.

Nota: Unlike parameter passing, here you have to use & in both places - to indicate that you return by-reference, not a copy as usual, and to indicate than reference binding and not usual assignment should be done for $foo.

Anterior | Inicio | Siguiente
What aren't References | Subir | Unsetting References


Unsetting References

When you unset the reference, you just break the binding between variable name and variable content. This does not mean that variable content will be destroyed. For example:

$a = 1;
$b =& $a;
unset ($a);

won't unset $b, just $a.

Again, it might be useful to think about this as analogous to Unix unlink call.

Anterior | Inicio | Siguiente
Returning References | Subir | Spotting the Reference


Spotting the Reference

Many syntax constructs in PHP are implemented via referencing mechanisms, so everything told above about reference binding also apply to these constructs. Some constructs, like passing and returning by-reference, are mentioned above. Other constructs that use references are:

global References

When you declare variable as global $var you are in fact creating reference to a global variable. That means, this is the same as:

$var =& $GLOBALS["var"];

That means, for example, that unsetting $var won't unset global variable.

$this

In an object method, $this is always reference to the caller object.

Anterior | Inicio | Siguiente
Unsetting References | Subir | Características


Características

Manual de PHP
Anterior Siguiente

III. Características

Tabla de contenidos
15. Manejando errores
16. Creando imágenes GIF
17. Autentificación HTTP con PHP
18. Cookies
19. El envío de archivos
20. Usando archivos remotos
21. Manejando conexiones
22. Conexiones persistentes a bases de datos
23. Safe Mode

Anterior | Inicio | Siguiente
Spotting the Reference |  | Manejando errores


Manejando errores

Manual de PHP
Anterior Siguiente

Capítulo 15. Manejando errores

Hay 4 tipos de errores y avisos en PHP. Esto son:

  • 1 - Errores Normales de Funciones (Normal Function Errors)

  • 2 - Avisos Normales (Normal Warnings)

  • 4 - Errores del Analizador de código (Parser Errors)

  • 8 - Avisos (Notices, advertencia que puedes ignorar, pero que puede implicar un error en tu código.

Los 4 números de arriba son sumados para definir un nivel de aviso de error. El nivel de aviso de error por defecto es el nivel 7, el cual es la suma de 1+2+4, es decir todo excepto los avisos. Este nivel puede ser cambiado en el fichero php3.ini con la directiva error_reporting. También puede ser configurado en el fichero de configuración del servidor de páginas Apache httpd.conf, con la directiva php3_error_reporting o también se puede cambiar en tiempo de ejecución usando la función error_reporting ().

Todas las expresioness PHP pueden también ser llamadas con el prefijo "@", el cual desactiva el aviso de errores para esa expresión en particular. Si ocurre un error en una expresión en tal situación y la característica track_errors está habilitada, podrás encontrar el mensaje de error en la variable global $php_errormsg.

Anterior | Inicio | Siguiente
Características | Subir | Creando imágenes GIF


Creando imágenes GIF

Manual de PHP
Anterior Siguiente

Capítulo 16. Creando imágenes GIF

PHP no está limitado a crear solo salidas de HTML. Puede ser usado también para crear ficheros de imágenes GIF, o incluso mejor secuencias de imágenes GIF. Necesitará compilar PHP con la libreria de funciones de imágenes GD para esta tarea.

Ejemplo 16-1. Creación de GIFs con PHP

<?php
    Header("Content-type: image/gif");
    $string=implode($argv," ");
    $im = imagecreatefromgif("images/button1.gif");
    $orange = ImageColorAllocate($im, 220, 210, 60);
    $px = (imagesx($im)-7.5*strlen($string))/2;
    ImageString($im,3,$px,9,$string,$orange);
    ImageGif($im);
    ImageDestroy($im);
?>
Este ejemplo será llamado desde una página con una línea como esta: <imgsrc="button.php3?text"> Este script de arriba button.php3 toma esta cadena "text" la situa sobre la imagen base, en este caso es "images/button1.gif" y muestra la imagen resultante. Esta es una forma muy conveniente para evitar tener que dibujar un nuevo botón cada vez que quiera cambiar el texto del mismo. Con este método los botones son generados dinámicamente.

Anterior | Inicio | Siguiente
Manejando errores | Subir | Autentificación HTTP con PHP


Autentificación HTTP con PHP

Manual de PHP
Anterior Siguiente

Capítulo 17. Autentificación HTTP con PHP

Las caracteríticas de autentificación HTTP en PHP solo estan disponibles cuando se está ejecutando como un módulo en Apache y hasta ahora no lo estan en la versión CGI. En un script PHP como módulo de Apache, se puede usar la función header() para enviar un mensaje de "Autentificación requerida" al navegador cliente haciendo que muestre una ventana de entrada emergente con nombre de usuario y contraseña. Una vez que el usuario ha rellenado el nombre y la contraseña, la URL que contiene el script PHP vuelve a ser llamada con las variables $PHP_AUTH_USER, $PHP_AUTH_PW y $PHP_AUTH_TYPE rellenas con el nombre de usuario, la contraseña y el tipo de autentificación respectivamente. Sólo autentificación "Básica" esta soportada en este momento. Consulte la función header() para más información.

Un fragmento de script de ejmplo que fuerce la autentificación del cliente en una página sería como el siguiente:

Ejemplo 17-1. Ejemplo de autentificación HTTP

<?php
  if(!isset($PHP_AUTH_USER)) {
    Header("WWW-Autentificación: Basic realm=\"Mi Reino\"");
    Header("HTTP/1.0 401 No autorizado");
    echo "Texto a enviar si pulsa el botón Cancelar\n";
    exit;
  } else {
    echo "Hola $PHP_AUTH_USER.<P>";
    echo "Ha introducido $PHP_AUTH_PW como su contraseña.<P>";
  }
  ?>

En vez de, sencillamente, mostrar $PHP_AUTH_USER y $PHP_AUTH_PW, seguramente quiera comprobar la validez del nombre de usuario y la contraseña. Tal vez enviando una consulta a una base de datos o buscando el usuario en un fichero dbm.

Vigile aquí los navegadores Interner Explorer con bugs. Parecen muy quisquillosos con el orden de las cabeceras. Enviar la cabecera WWW-Autentificación antes que la cabecera HTTP/1.0 401 parece ser el truco por ahora.

Para prevenir que alguien escriba un script que revele la contraseña de una página que ha sido autentificada a través de algún mecanismo externo tradicional, las variables PHP_AUTH no serán rellenadas si algún tipo de autentificación externo ha sido activado para una página en particular. En este caso, la variable $REMOTE_USER puede ser usada para identificar al usuario autentificado externamente.

Nota, a pesar de todo, lo ya dicho no proteje de que alguien que controle una URL no autentificada robe contraseñas de URLs autentificadas en el mismo servidor.

Tanto Netscape como Internet Explorer borrarán la caché de la ventana de autentificación en el navegador local después de recibir una respuesta 401 del servidor. Esto puede usarse, de forma efectiva, para "desconectar" a un usuario, forzandole a reintroducir su nombre y contraseña. Algunas personas usan esto para "hacer caducar" entradas, o para proveer un botón de "desconectar".

Ejemplo 17-2. Ejemplo de autentificación HTTP forzando una reentrada

<?php
  function authenticate() {
   Header( "WWW-Authenticate: Basic realm=\"Test Autentificación Sistema\"");
   Header( "HTTP/1.0 401 No autorizado");
   echo "Debe introducir un nombre de usuario y contraseña válidos para acceder a
   este recurso\n";
   exit;
  }

  if(!isset($PHP_AUTH_USER) || ($SeenBefore == 1 && !strcmp($OldAuth, $PHP_AUTH_USER)) ) {
   authenticate();
  }
  else {
   echo "Bienvenido: $PHP_AUTH_USER<BR>";
   echo "Old: $OldAuth";
   echo "<FORM ACTION=\"$PHP_SELF\" METHOD=POST>\n";
   echo "<INPUT TYPE=HIDDEN NAME=\"SeenBefore\" VALUE=\"1\">\n";
   echo "<INPUT TYPE=HIDDEN NAME=\"OldAuth\" VALUE=\"$PHP_AUTH_USER\">\n";
   echo "<INPUT TYPE=Submit VALUE=\"Re Authenticate\">\n";
   echo "</FORM>\n";
  }
?>

Este comportamiento no es requerido por el estándar de autentificación básica de HTTP, por lo que nunca debe depender de esto. Pruebas con Lynx han demostrado que Lynx no borra las credenciales de autentificación con una respuesta 401 del servidor, por lo que pulsando atrás y después adelante abriría el recurso de nuevo (siempre que los requerimientos de contraseña no hayan cambiado).

Además note que esto no funciona usando el servidor IIS de Microsoft y la versión CGI de PHP debido a una limitación del IIS

Anterior | Inicio | Siguiente
Creando imágenes GIF | Subir | Cookies


Cookies

Manual de PHP
Anterior Siguiente

Capítulo 18. Cookies

PHP soporta transparentemente cookies HTTP. Las Cookies son un mecanismo que sirve para almacenar datos en el navegador del usuario remoto, para así poder identificar al usuario cuando vuelva. Se pueden poner cookies usando la funcion setcookies(). Las Cookies son parte de la cabecera HTTP, por tanto la función setcookie() debe ser llamada antes de que se produzca cualquier salida al navegador. Esta limitación es la misma a la de la función header().

Cualquier cookie enviada a ti desde el cliente, automáticamente se convertirá en una variable PHP igual como ocurre con los métodos de datos GET y POST. Si deseas asignar multiples valores a una cookie simple, añade simplemente [] a el nombre de la cookie. Para más detalles ver la función setcookie().

Anterior | Inicio | Siguiente
Autentificación HTTP con PHP | Subir | El envío de archivos


El envío de archivos

Manual de PHP
Anterior Siguiente

Capítulo 19. El envío de archivos

Tabla de contenidos
Envío de archivos con el método POST
Errores comunes
Envío de más de un archivo
Soporte del método PUT

Envío de archivos con el método POST

PHP es capaz de recibir envíos de archivo de cualquier navegador que cumpla la norma RFC-1867 (entre los que se incluyen Netscape Navigator 3 o posterior, Microsoft Internet Explorer 3 con un parche o posterior sin éste). Ésta característica permite que los usuarios envien archivos de texto y binarios. Mediante la autentificación y funciones de manejo de archivos de PHP, es posible un control total de quién puede enviar archivos y que se hace con éstos una vez recibidos.

Es importante destacar que PHP también soporta el método PUT para envío de archivos tal y como lo utiliza Netscape Composer y el cliente Amaya de W3C. Consulte Soporte del método PUT para más detalles.

Una página de envío de archivos se puede crear mediante un formulario parecido a éste:

Ejemplo 19-1. Formulario de envío de archivo

&lt;FORM ENCTYPE=&quot;multipart/form-data&quot; ACTION=&quot;_URL_&quot; METHOD=POST&gt;
&lt;INPUT TYPE=&quot;hidden&quot; name=&quot;MAX_FILE_SIZE&quot; value=&quot;1000&quot;&gt;
Enviar este archivo: &lt;INPUT NAME=&quot;userfile&quot; TYPE=&quot;file&quot;&gt;
&lt;INPUT TYPE=&quot;submit&quot; VALUE=&quot;Enviar&quot;&gt;
&lt;/FORM&gt;
La _URL_ debe tener como destino un script PHP. El campo MAX_FILE_SIZE debe encontrarse antes del campo INPUT y su valor determina el tamaño máximo de archivo que se puede enviar en bytes. Tras la recepción del archivo se definirán en el script PHP destino las siguientes variables:

  • $userfile - El archivo temporal que se ha guardado en el servidor.

  • $userfile_name - El nombre original del archivo enviado.

  • $userfile_size - El tamaño del archivo recibido.

  • $userfile_type - El tipo mime del archivo si el navigador envio esta información. Por ejemplo: &quot;image/gif&quot;.

Es importante recordar que la primera palabra &quot;$userfile&quot; de éstas variables corresponde al nombre ("NAME=") del campo "INPUT TYPE=file" del formulario. En el ejemplo anterior usamos &quot;userfile&quot;.

Los archivos enviados serán guardados en el directorio temporal por defecto del servidor. Podemos variar este directorio mediante la variable de entorno TMPDIR en el entorno donde corre PHP. No se puede establecer este valor usando putenv() desde un script PHP.

El script PHP que recibe el archivo enviado debe implementar las acciones que se deben llevar a cabo con el archivo acabado de recibir. Por ejemplo se podria utilizar $file_size para decidir descartar los archivos que sean demadiado pequeños o demasiado grandes. Sean cual sean las acciones a tomar se debe borrar el archivo temporal o moverlo a algún otro directorio.

El archivo recibido será eliminado inmediatamente del directorio temporal al finalizar el script PHP que lo recibió si no ha sido movido o renombrado.

Anterior | Inicio | Siguiente
Cookies | Subir | Errores comunes


Errores comunes

El valor de MAX_FILE_SIZE no puede ser mayor que el tamaño del archivo que se especifica en la variable upload_max_filesize del archivo PHP3.ini o la correspondiente directiva php3_upload_max_filesize de Apache. Por defecto es 2 Megabytes.

El servidor CERN parece que elimina cualquier cosa antes del primer espacio en blanco en la cabecera mime content-type que recibe de los clientes. Mientras esto no varie, CERN httpd no podrá soportar el envío de archivos.

Anterior | Inicio | Siguiente
El envío de archivos | Subir | Envío de más de un archivo


Envío de más de un archivo

Es posible el envio de varios archivos simultáneamente y poder clasificar la información automáticamente por arrays. Esto de hace de la misma manera en que se organizan por arrays los SELECT o CHECKBOX:

Nota: El soporte para múltiple envios de archivos se añadió en la versión 3.0.10

Ejemplo 19-2. Formulario de envío multiple de archivos

&lt;form action=&quot;file-upload.html&quot; method=&quot;post&quot; enctype=&quot;multipart/form-data&quot;&gt;
  Enviar estos archivos:&lt;br&gt;
  &lt;input name=&quot;userfile[]&quot; type=&quot;file&quot;&gt;&lt;br&gt;
  &lt;input name=&quot;userfile[]&quot; type=&quot;file&quot;&gt;&lt;br&gt;
  &lt;input type=&quot;submit&quot; value=&quot;Enviar&quot;&gt;
&lt;/form&gt;

Cuando el formulario es procesado, los arrays $userfile, $userfile_name, y $userfile_size se crearán de alcance global (igual que $HTTP_POST_VARS). Cada uno será un array con índice numérico con los valores apropiados para los archivos enviados.

Por ejemplo, supongamos que los siguientes archivos /home/test/review.html y /home/test/xwp.out son enviados. En este caso, $userfile_name[0] almacenaría el valor review.html, y $userfile_name[1] almacenaría el valor xwp.out. Así, $userfile_size[0] almacenaría el tamaño de review.html y así con los valores siguientes.

Anterior | Inicio | Siguiente
Errores comunes | Subir | Soporte del método PUT


Soporte del método PUT

PHP soporta el metodo HTTP PUT que usan aplicaciones como Netscape Composer y Amaya de W3C. Las peticiones PUT son más sencillas que el método POST. Un ejemplo:

PUT /path/filename.html HTTP/1.1

Esto normalmente significaría que el cliente remoto quiere salvar el contenido como: /path/filename.html en tu árbol web. Lógicamente no una buena idea que la gente pueda escribir en tu árbol web. Para manipular esta petición debes decirle al servidor que esta petición sea atendida por un script PHP. En Apache, por ejemplo, se utiliza para esto la directiva Script en los alguno de los archivos de configuración del servidor. Un sitio típico de uso es dentro del bloque &lt;Directory&gt; o quizás en el bloque &lt;Virtualhost&gt;. Una linia así deberia hacer ésta función:

Script PUT /put.php3

Ésto le dice a Apache que envie todas peticiones PUT para URIs que contengan esta linia al script put.php3. Se asume que PHP se encuentra activo y con la extension php3 enlazada a él.

Dentro del script put.php3 se podría implementar algo así:

&lt;? copy($PHP_UPLOADED_FILE_NAME,$DOCUMENT_ROOT.$REQUEST_URI); ?&gt;

Esto copiaria el archivo a la localización requerida por el cliente remoto. Aqui se pueden ejecutar funciones de autentificación de usuario o cualquier otro tipo de chequeo. El archivo se guarda en el archivo temporal del sistema servidor de la misma manera que el Método POST. Cuando la petición finaliza, el archivo temporal es eliminado. En consequencia el script dede proceder al trato de éste inmediatamente, ya sea para copiarlo, renombrarlo, etc. El archivo se encuentra en la variable $PHP_PUT_FILENAME, y el destino sugerido por el cliente en la variable $REQUEST_URI (puede variar en servidores diferentes de Apache). No es necesario hacer caso al destino sugerido por el cliente. Por ejemplo se podrían copiar los archivos enviados a directorios especialmente designados para esta tarea.

Anterior | Inicio | Siguiente
Envío de más de un archivo | Subir | Usando archivos remotos


Usando archivos remotos

Manual de PHP
Anterior Siguiente

Capítulo 20. Usando archivos remotos

Siempre que el soporte para la "envoltura URL fopen" esté habilitado cuando se configura PHP (lo cual ocurre a menos que se pasa explícitamente la opción --disable-url-fopen-wrapper a configure), se pueden usar URLs HTTP y FTP con la mayoría de las funciones que toman un archivo como parámetro, incluyendo las sentencias require() e include().

Nota: No se pueden usar archivos remotos en las sentencias include() y require() en Windows.

Por ejemplo, se puede usar este para abrir un archivo en un servidor web remoto, analizar en la salida la información que se quiera, y entonces, usar la información en una consulta a base de datos, o simplemente para sacarls en un estilo que coincida con el resto de su sitio web.

Ejemplo 20-1. Obtener el título de una página remota

<?php
  $archivo = fopen("http://www.php.net/", "r");
  if (!$archivo) {
    echo "<p>No se pudo abrir el archivo remoto.\n";
    exit;
  }
  while (!feof($archivo)) {
    $linea = fgets($archivo, 1024);
    /* Esto sólo funciona si el título y sus etiquetas
       están en una línea. */
    if (eregi("<title>(.*)</title>", $linea, $salida)) {
      $title = $salida[1];
      break;
    }
  }
  fclose($file);
?>

También se puede escribir a archivos en un FTP siempre que se conecte como un usuario con los correctos derechos de acceso, y el archivo no exista ya.Para conectar como un usuario distinto de 'anonymous', se necesita especificar el nombre de usuario (y posiblemente contraseña) dentro de la URL, tales como 'ftp://usuario:clave@ftp.ejemplo.com/camino/a/archivo'. (Se puede usar la misma clase de sintaxis para acceder a archivos via HTTP cuando se requería una autenticació de same sort of syntax to access files via HTTP when they require Basic authentication.)

Ejemplo 20-2. Storing data on a remote server

<?php
  $file = fopen("ftp://ftp.php.net/incoming/outputfile", "w");
  if (!$file) {
    echo "<p>Unable to open remote file for writing.\n";
    exit;
  }
  /* Write the data here. */
  fputs($file, "$HTTP_USER_AGENT\n");
  fclose($file);
?>

Nota: You might get the idea from the example above to use this technique to write to a remote log, but as mentioned above, you can only write to a new file using the URL fopen() wrappers. To do distributed logging like that, you should take a look at syslog().

Anterior | Inicio | Siguiente
Soporte del método PUT | Subir | Manejando conexiones


Manejando conexiones

Manual de PHP
Anterior Siguiente

Capítulo 21. Manejando conexiones

Nota: Todo lo siguiente se aplica a partir de la 3.0.7 y posterior.

Internamente en PHP se mantiene el estado de la conexión. Hay 3 posibles estados:

  • 0 - NORMAL

  • 1 - ABORTED (Abortado)

  • 2 - TIMEOUT (Fuera de tiempo)

Cuando un script PHP se está ejecutando se activa el estado NORMAL. Si el cliente remoto se desconecta, se pasa al estado ABORTADO. Esto suele ocurrir cuando el usuario pulsa en el botón STOP del navegador. Si se alcanza el límite de tiempo impuesto por PHP (ver set_time_limit()), se pasa al estado TIMEOUT.

Puedes decidir si quieres que la desconexión de un cliente cause que tu script sea abortado. Algunas veces es cómodo que tus scripts se ejecuten por completo, incluso si no existe ya un navegador remoto que reciba la salida. El comportamiento por defecto es sin embargo, que tu script se aborte cuando el cliente remoto se desconecta. Este comportamiento puede ser configurado vía la directiva ignore_user_abort en el fichero php3.ini, o también con la función ignore_user_abort(). Si no le espeficicas al PHP que cuando un usuario aborte lo ignore, tu script terminará su ejecución. La única excepción es si tienes registrada un función de desconexión usando la función register_shutdown_function(). Con una función de desconexión, cuando un usuario remoto pulsa en el botón STOP, la próxima vez que tu script intenta mostrar algo, PHP detecta que la conexión ha sido abortada y se llama a la función de desconexión. Esta función de desconexión también se llama al final de la ejecución de tu script cuando se ha ejecutado normalmente, de manera que si quieres hacer algo diferente en caso de que un cliente se haya desconectado, puedes usar la función connection_aborted(). Esta función devuelve verdadero si la conexión fue abortada.

Tu script también se puede terminar por un temporizador interno. El timeout por defecto es de 30 segundos. Se puede cambiar usando la directiva max_execution_time en el fichero php3.ini o la correspondiente directiva php3_max_execution_time en la configuración del servidor de páginas Apache, como también con la función set_time_limit(). Cuando el temporizador expira, el script se aborta como en el caso de la desconexión del cliente, de manera que si se ha definido una función de desconexión, esta se llamará. Dentro de esta función de desconexión, puedes comprobar si fue el timeout el que causó que se llamara a la función de desconexión, llamando a la función connection_timeout(). Esta función devolverá verdadero si el timeout causa que se llame a la función de desconexión.

Hay que destacar que ambos, el estado ABORTED y el TIMEOUT, se pueden activar al mismo tiempo. Esto es posible si le dices a PHP que ignore las desconexiones intencionadas de los usuarios. PHP aún notará el hecho de que el usuario puede haberse desconectado, pero el script continuará ejecutándose. Si se alcanza el tiempo límite de ejecución será abortado y, si se ha definido una función de desconexión, esta será llamada. En este punto, encontrarás que las funciones connection_timeout() y connection_aborted() devuelven verdadero. Puedes comprobar ambos estados de una manera simple usando la función connection_status(). Esta función devuelve un campo de bit de los estados activos. De este modo, si ambos estados están activos devolvería por ejemplo un valor 3.

Anterior | Inicio | Siguiente
Usando archivos remotos | Subir | Conexiones persistentes a bases de datos


Conexiones persistentes a bases de datos

Manual de PHP
Anterior Siguiente

Capítulo 22. Conexiones persistentes a bases de datos

Las conexiones persistentes son enlaces SQL que no se cierran cuando termina la ejecución del archivo de comandos. Cuando se pide una conexión persistente, PHP comprueba si hay ya una conexión persistente idéntica (que permanecía abierta desde antes) - y si existe, la usa. Si no existe, crea un enlace. Una conexión 'idéntica' es una conexión que se abrió hacia el mismo "host", con el mismo nombre de usuario y la misma contraseña (donde sea aplicable).

La gente que no está familiarizada con el modo como trabajan y distribuyen la carga los servidores "web" puede confundir que persistente significa lo que no es. En particular, ellas no te dan la habilidad de abrir 'sesiones de usuario' en el mismo enlace SQL, no dan la habilidad de construir una transacción de forma eficiente, y no hacen un montón de otras cosas. De hecho, para ser extremadamente claros sobre el tema las conexiones persistentes no te dan ninguna functionalidad que no fuera posible con sus hermanas no-persistentes.

¿Por qué?

Esto tiene que ver con el modo como funcionan los servidores "web". Hay tres modos en que un servidor "web" puede utilizar PHP para generar páginas web.

El primer método es usar PHP como una capa CGI. Cuando corre de este modo, se crea y destruye una instancia del intérprete PHP por cada página solicitada (para una página PHP) a tu servidor. Debido a que se destruye después de cada petición, cualquier recurso que adquiera (como un enlace a un servidor de base de datos SQL) se cierra cuando es destruido. En este caso, no se gana nada si se intentan usar conexiones persistentes.

El segundo, y más popular, método es correr PHP como un módulo en un servidor web multiproceso, lo cual actualmente sólo incluye Apache. Un servidor multiproceso tiene típicamente un proceso (el padre) que coordina un conjunto de procesos (sus hijos) que realmente hacen el trabajo se servir las páginas web. Cuando entra cada petición de un cliente, es entregada a uno de los hijos que no esté ya sirviendo a otro cliente. Esto significa que cuando el mismo cliente hace una segunda petción al servidor, puede ser atendidp por un proceso hijo distinto del de la primera vez. Lo que una conexión persistente hace por ti en este caso es hacerlo de tal modo que cada proceso hijo sólo necesita conectar a tu SQL server la primera vez que sirve una página que hace uso de una conexión así. Cuando otra página solicita una conexión a SQL server, puede reutilizar la conexión que el hijo estableció previamente.

El último método es usar PHP como un "plug-in" para un servidor web multihilo. En la actualidad es solamente teórico -- PHP no funciona aún como "plug-in" para ningún servidor web multihilo. Hay trabajo en progreso para soportar ISAPI, WSAPI y NSAPI (en Windows), lo cual permitirá a PHP ser utilizado como "plug-in" para servidores web multihilo como Netscape FastTrack, Internet Information Server (IIS) de Microsoft, y O'Reilly's WebSite Pro. Cuando esto ocurra, el comportamiento será exactamente el mismo que para el modelo de multiprocesador descrito anteriormente.

Si las conexiones persistentes no aportan ninguna funcionalidad añadida, ¿para qué son buenas?

La respuesta aqui es extremadamente simple -- eficiencia. Las conexiones persistentes son buenas si las cabeceras de control para crear un enlace a tu servidor SQL es alta. Que estas cabeceras sean o no realmente altas depende de muchos factores. Como, qué clase de base de datos es, si esta o no situada en el mismo ordenador que el servidor web, cómo está de cargada la máquina donde se encuentre el servidor SQL, y otras así. El hecho fundamental es que si la cabecera de conexión es alta, las conexiones persistentes te ayudan considerablemente . Ellas hacen que el proceso hijo simplemente conecte solamente una vez durante todo su intervalo de vida, en vez de cada vez que procesa una pagina que requiere conectar al servidor SQL. Esto significa que por cada hijo que abrió una conexión persistente tendrá su propia conexión persistente al servidor. Por ejemplo, si tienes 20 procesos hijos distintos que corran un archivo de comandos que cree una conexión persistente a tu servidor SQL, tendrías 20 conexiones diferentes a ti servidor SQL, una por cada hijo.

Un resumen importante. Las conexiones persistentes fueron diseñadas para tener una equivalencia uno-a-uno con las conexiones normales. Eso significa que deberís siempre ser capaz de reemplazar las conexiones persistentes por conexiones no persistentes y no cambiará, el modo como se comporta el archivo de comandos. Puede cambiar la eficiencia del archivo de comandos (y probablemete lo hará), ¡pero no su comportamiento!

Anterior | Inicio | Siguiente
Manejando conexiones | Subir | Safe Mode


Safe Mode

Manual de PHP
Anterior Siguiente

Capítulo 23. Safe Mode

Tabla de contenidos
Functions restricted/disabled by safe mode

The PHP safe mode is an attempt to solve the shared-server security problem. It is architecturally incorrect to try to solve this problem at the PHP level, but since the alternatives at the web server and OS levels aren't very realistic, many people, especially ISP's, use safe mode for now.

The configuration directives that control safe mode are:
safe_mode = Off
safe_mode_gid = 0
safe_mode_include_dir =
safe_mode_exec_dir =
open_basedir =
safe_mode_allowed_env_vars = PHP_
safe_mode_protected_env_vars = LD_LIBRARY_PATH
disable_functions =

When safe_mode is on, PHP checks to see if the owner of the current script matches the owner of the file to be operated on by a file function. For example:
-rw-rw-r--    1 rasmus   rasmus       33 Jul  1 19:20 script.php
-rw-r--r--    1 root     root       1116 May 26 18:01 /etc/passwd
Running this script.php
<?php
 readfile('/etc/passwd');
?>
results in this error when safe mode is enabled:
Warning: SAFE MODE Restriction in effect. The script whose uid is 500 is not
allowed to access /etc/passwd owned by uid 0 in /docroot/script.php on line 2

If instead of safe_mode, you set an open_basedir directory then all file operations will be limited to files under the specified directory For example (Apache httpd.conf example):
<Directory /docroot>
  php_admin_value open_basedir /docroot
</Directory>
If you run the same script.php with this open_basedir setting then this is the result:
Warning: open_basedir restriction in effect. File is in wrong directory in
/docroot/script.php on line 2

You can also disable individual functions. Note that the disable_functions directive can not be used outside of the php.ini file which means that you cannot disable functions on a per-virtualhost or per-directory basis in your httpd.conf file. If we add this to our php.ini file:
disable_functions readfile,system
Then we get this output:
Warning: readfile() has been disabled for security reasons in
/docroot/script.php on line 2

Functions restricted/disabled by safe mode

This is a still probably incomplete and possibly incorrect listing of the functions limited by safe mode.

Tabla 23-1. Safe mode limited functions

Function | Limitations
dbmopen() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
dbase_open() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
filepro() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
filepro_rowcount() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
filepro_retrieve() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
ifx_*() | sql_safe_mode restrictions, (!= safe mode)
ingres_*() | sql_safe_mode restrictions, (!= safe mode)
mysql_*() | sql_safe_mode restrictions, (!= safe mode)
pg_loimport() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
posix_mkfifo() | Checks whether the directory in which you are about to operate, has the same UID as the script that is being executed.
putenv() | Obeys the safe_mode_protected_env_vars and safe_mode_allowed_env_vars ini-directives. See also the documentation on putenv()
move_uploaded_file() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
chdir() | Checks whether the directory in which you are about to operate, has the same UID as the script that is being executed.
dl() | This functions is disabled in safe-mode
backtick operator | This functions is disabled in safe-mode
shell_exec() (functional equivalent of backticks) | This functions is disabled in safe-mode
exec() | You can only execute executables within the safe_mode_exec_dir. For practical reasons it's currently not allowed to have .. components in the path to the executable.
system() | You can only execute executables within the safe_mode_exec_dir. For practical reasons it's currently not allowed to have .. components in the path to the executable.
passthru() | You can only execute executables within the safe_mode_exec_dir. For practical reasons it's currently not allowed to have .. components in the path to the executable.
popen() | You can only execute executables within the safe_mode_exec_dir. For practical reasons it's currently not allowed to have .. components in the path to the executable.
mkdir() | Checks whether the directory in which you are about to operate, has the same UID as the script that is being executed.
rmdir() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
rename() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed. Checks whether the directory in which you are about to operate, has the same UID as the script that is being executed.
unlink() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed. Checks whether the directory in which you are about to operate, has the same UID as the script that is being executed.
copy() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed. Checks whether the directory in which you are about to operate, has the same UID as the script that is being executed. (on source and target)
chgrp() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
chown() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed.
chmod() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed. In addition, you cannot set the SUID, SGID and sticky bits
touch() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed. Checks whether the directory in which you are about to operate, has the same UID as the script that is being executed.
symlink() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed. Checks whether the directory in which you are about to operate, has the same UID as the script that is being executed. (note: only the target is checked)
link() | Checks whether the file(s)/directories you are about to operate on, have the same UID as the script that is being executed. Checks whether the directory in which you are about to operate, has the same UID as the script that is being executed. (note: only the target is checked)
getallheaders() | In safe mode, headers beginning with 'authorization' (case-insensitive) will not be returned. Warning: this is broken with the aol-server implementation of getallheaders()!
Any function that uses php4/main/fopen_wrappers.c | ??

Anterior | Inicio | Siguiente
Conexiones persistentes a bases de datos | Subir | Referencia de las Funciones


Referencia de las Funciones

Manual de PHP
Anterior Siguiente

IV. Referencia de las Funciones

Tabla de contenidos
I. Funciones específicas de Apache
II. Funciones de matrices
III. Funciones Ortográficas
IV. Funciones matemáticas de precisión arbitraria
V. Bzip2 Compression Functions
VI. Funciones de calendario
VII. CCVS API Functions
VIII. soporte de las funciones COM para Windows
IX. Funciones de Clases/Objectos
X. Funciones de ClibPDF
XI. Crack functions
XII. CURL, Client URL Library Functions
XIII. Funciones de pago electrónico
XIV. Crédit Mutuel CyberMUT functions
XV. Cyrus IMAP administration functions
XVI. Character type functions
XVII. Funciones de la capa de abstraccion de bases de datos (dbm-style)
XVIII. Funciones de fecha y hora
XIX. Funciones para dBase
XX. Funciones dbm
XXI. dbx functions
XXII. DB++ Functions
XXIII. Direct IO functions
XXIV. Funciones con directorios
XXV. Funciones de DOM XML
XXVI. .NET functions
XXVII. Error Handling and Logging Functions
XXVIII. FrontBase Functions
XXIX. Funciones filePro
XXX. Funciones del sistema de ficheros
XXXI. Funciones Forms Data Format (Formato de Datos de Formularios)
XXXII. FriBiDi functions
XXXIII. Funciones FTP
XXXIV. Function Handling functions
XXXV. GNU Gettext
XXXVI. GMP functions
XXXVII. Funciones HTTP
XXXVIII. Funciones para Hyperwave
XXXIX. Funciones para ICAP - Internet Calendar Application Protocol
XL. iconv functions
XLI. Funciones de imágenes
XLII. Funciones IMAP
XLIII. Funciones para Informix
XLIV. Funciones InterBase
XLV. Ingres II functions
XLVI. IRC Gateway Functions
XLVII. Java
XLVIII. Funciones LDAP
XLIX. Funciones de Correo
L. mailparse functions
LI. Funciones matemáticas
LII. Multi-Byte String Functions
LIII. MCAL functions
LIV. Funciones Criptográficas
LV. Funciones Hash
LVI. Funciones de Microsoft SQL Server
LVII. Ming functions for Flash
LVIII. Miscelánea de funciones
LIX. mnoGoSearch Functions
LX. funciones mSQL
LXI. Funciones MySQL
LXII. Mohawk Software session handler functions
LXIII. muscat functions
LXIV. Funciones de Red
LXV. Ncurses terminal screen control functions
LXVI. Lotus Notes functions
LXVII. ODBC functions
LXVIII. Funciones de Oracle 8
LXIX. OpenSSL functions
LXX. Funciones Oracle
LXXI. Ovrimos SQL functions
LXXII. Output Control Functions
LXXIII. Object property and method call overloading
LXXIV. PDF functions
LXXV. Verisign Payflow Pro functions
LXXVI. opciones e información de PHP
LXXVII. Funciones POSIX
LXXVIII. Funciones de PostgreSQL
LXXIX. Process Control Functions
LXXX. Funciones de ejecución de programas
LXXXI. Printer functions
LXXXII. Pspell Functions
LXXXIII. GNU Readline
LXXXIV. Funciones GNU Recode
LXXXV. Funciones de expresiones regulares compatibles con Perl
LXXXVI. qtdom functions
LXXXVII. Funciones para expresiones regulares
LXXXVIII. Funciones Semáforo y de memoria compartida
LXXXIX. SESAM database functions
XC. Session handling functions
XCI. Shared Memory Functions
XCII. Shockwave Flash functions
XCIII. Funciones SNMP
XCIV. Socket functions
XCV. Funciones de cadenas
XCVI. Funciones de Sybase
XCVII. Funciones URL
XCVIII. Funciones sobre variables
XCIX. vpopmail functions
C. W32api functions
CI. Funciones WDDX
CII. Funciones de intérprete XML
CIII. XMLRPC functions
CIV. XSLT functions
CV. YAZ
CVI. NIS funciona
CVII. Zip File Functions (Read Only Access)
CVIII. Funciones de Compresión

Anterior | Inicio | Siguiente
Safe Mode |  | Funciones específicas de Apache


Funciones específicas de Apache

Manual de PHP
Anterior Siguiente

I. Funciones específicas de Apache

Tabla de contenidos
apache_lookup_uri — Efectua una petición parcial a la URI especificada y devuelve toda la información sobre ella.
apache_note — Recibe y establece los valores de una petición en una tabla de notas del Apache
getallheaders — Recibe todas las cabeceras de una petición HTTP
virtual — Ejecuta una sub-petición al Apache

Anterior | Inicio | Siguiente
Referencia de las Funciones | Subir | apache_lookup_uri


apache_lookup_uri

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

apache_lookup_uri -- Efectua una petición parcial a la URI especificada y devuelve toda la información sobre ella.

Descripción

class apache_lookup_uri ( string filename)

Esta función efectua una llamada parcial a URI. Esta llamada no hace sino obtener toda la información importante sobre el recurso pedido y la devuelve en un tipo clase .Las propiedades de esa clase son:

status
the_request
status_line
method
content_type
handler
uri
filename
path_info
args
boundary
no_cache
no_local_copy
allowed
send_bodyct
bytes_sent
byterange
clength
unparsed_uri
mtime
request_time

Nota: Nota: apache_lookup_uri solo funciona cuando el PHP está instalado como módule del Apache.

Anterior | Inicio | Siguiente
Funciones específicas de Apache | Subir | apache_note


apache_note

(PHP 3>= 3.0.2, PHP 4 >= 4.0.0)

apache_note -- Recibe y establece los valores de una petición en una tabla de notas del Apache

Descripción

string apache_note ( string note_name [, string note_value])

apache_note() es una función específica del Apache que recibe y establece valores de la petición en una tabla de notas. Si se llama con un solo parámetro,devuelve el valor de note_name. Si se llama con dos parámetros, establece el valor de note_value en note_value y devuelve el valor que había en note_name.

Anterior | Inicio | Siguiente
apache_lookup_uri | Subir | getallheaders


getallheaders

(PHP 3, PHP 4 >= 4.0.0)

getallheaders -- Recibe todas las cabeceras de una petición HTTP

Descripción

array getallheaders ( void)

Esta función devuelve asociados en un vector todas las cabeceras de la actual petición HTTP.

Nota: También puedes obtener los valores de las variables de los CGIs mediante variables de entorno, que funcionan, esté o no el PHP funcionando como módulo del Apache. Utiliza phpinfo()para ver una lista de todas las variables de entorno definidas de esta forma.

Ejemplo 1. ObtenerTodaslasCabeceras() Ejemplo

$cabeceras = getallheaders();
while (list($cabecera, $valor) = each($cabeceras)) {
    echo "$cabecera: $valor<br>\n";
}
Este ejemplo visualiza todas las cabeceras de la petición actual.

Nota: ObtenerTodaslasCabeceras() actualmente solo funcionará si el PHP es cargado como módulo del Apache .

Anterior | Inicio | Siguiente
apache_note | Subir | virtual


virtual

(PHP 3, PHP 4 >= 4.0.0)

virtual -- Ejecuta una sub-petición al Apache

Descripción

int virtual ( string filename)

virtual() es una función específica del Apache que es equivalente a <!--#include virtual...--> en mod_include. Esto ejecuta una sup-petición al Apache .Esto, es util para incluir CGI-scripts o páginas .shtml o cualquier tipo de fichero que puedas procesar mediante el Apache. Los CGI-scripts deberán generar cabeceras válidas. Esto, implica como mínimo un include() ó un require(); La función virtual() no puede ser usada para incluir un documento que sea por si mismo un documento PHP.

Anterior | Inicio | Siguiente
getallheaders | Subir | Funciones de matrices


Funciones de matrices

Manual de PHP
Anterior Siguiente

II. Funciones de matrices

Tabla de contenidos
array — Crear una matriz
array_count_values — Cuenta todos los valores de una matriz
array_flip — Intercambia los valores de una matriz
array_keys — Devuelve todas las claves de una matriz
array_merge — Combina dos o más matrices
array_pad — Rellena una matriz con un valor hasta el tamaño especificado
array_pop — Extrae el último elemento de la matriz
array_push — Inserta uno o más elementos al final de la matriz
array_reverse — Devuelve una matriz con los elementos en orden inverso
array_shift — Extrae un elemento del comienzo de la matriz
array_slice — Extrae una porción de la matriz
array_splice — Suprime una porción de la matriz y la sustituye por otra cosa
array_unshift — Introduce uno o más elementos al principio de la matriz
array_values — Devuelve todos los valores de una matriz
array_walk — Aplica una función del usuario a cada elemento de una matriz.
arsort — Ordena una matriz en orden inverso y mantiene la asociación de índices
asort — Ordena una matriz y mantiene la asociación de índices
compact — Crea una matriz que contiene variables y sus valores
count — Cuenta los elementos de una variable
current — Devuelve el elemento actual de una matriz
each — Devuelve el siguiente par clave/valor de una matriz
end — Mueve el puntero interno de una tabla al último elemento
extract — Importa variables a la tabla de símbolos desde una matriz
in_array — Devuelve TRUE si un valor está en una matriz
key — Obtiene una clave de una matriz asociativa
krsort — Ordena una matriz por clave en orden inverso
ksort — Ordena una matriz por clave
list — Asigna variables como si fueran una matriz
next — Avanza el puntero interno de una matriz
pos — Obtiene el elemento actual de una matriz
prev — Rebobina el puntero interno de una matriz
rango — Crea una matriz que contiene un rango de enteros
reset — Fija el puntero interno de una matriz a su primer elemento
rsort — Ordena una matriz en orden inverso
shuffle — Mezcla una matriz
sizeof — Obtiene el número de elementos de una matriz
sort — Ordena una matriz
uasort — Ordena una matriz mediante una función de comparación definida por el usuario y mantiene la asociación de índices
uksort — Ordena una matriz por claves mediante una función definida por el usuario
usort — Ordena una matriz por valores mediante una funcion definida por el usuario

Anterior | Inicio | Siguiente
virtual | Subir | array


array

(unknown)

array -- Crear una matriz

Descripción

array array ( mixed ...)

Devuelve una matriz con los parámetros que se le pasan. A dichos parámetros se les puede dar un índice usando el operador =>.

Nota: array() es una construcción del lenguaje que se utiliza para representar matrices literales, no una función regular.

El siguiente ejemplo demuestra cómo crear una matriz bidimensional, cómo especificar claves para matrices asociativas, y cómo especificar índices no consecutivos en matrices normales.

Ejemplo 1. Ejemplo de array()

$frutas = array (
    "frutas"  => array("a"=>"naranja", "b"=>"plátano", "c"=>"manzana"),
    "números" => array(1, 2, 3, 4, 5, 6),
    "hoyos"   => array("primero", 5 => "segundo", "tercero")
);

Vea también: list().

Anterior | Inicio | Siguiente
Funciones de matrices | Subir | array_count_values


array_count_values

(PHP 4 >= 4.0.0)

array_count_values -- Cuenta todos los valores de una matriz

Descripción

array array_count_values ( array entrada)

array_count_values() devuelve una matriz usando los valores de la matriz entrada como claves y su frecuencia de aparición en la entrada como valores.

Ejemplo 1. Ejemplo de array_count_values()

$matriz = array(1, "hola", 1, "mundo", "hola");
array_count_values($matriz); // devuelve array(1=>2, "hola"=>2, "mundo"=>1)

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array | Subir | array_flip


array_flip

(PHP 4 >= 4.0.0)

array_flip -- Intercambia los valores de una matriz

Descripción

array array_flip ( array trans)

array_flip() devuelve una matriz con los valores intercambiados.

Ejemplo 1. Ejemplo de array_flip()

$trans = array_flip ($trans);
$original = strtr ($str, $trans);

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_count_values | Subir | array_keys


array_keys

(PHP 4 >= 4.0.0)

array_keys -- Devuelve todas las claves de una matriz

Descripción

array array_keys ( array entrada [, mixed val_a_buscar])

array_keys() devuelve las claves, numéricas y de cadena, de la matriz entrada.

Si se especifica el parámetro opcional val_a_buscar, sólo se devuelven las claves para dicho valor. De otro modo, se devuelven todas las claves de la entrada.

Ejemplo 1. Ejemplo de array_keys()

$matriz = array(0 => 100, "color" => "rojo");
array_keys ($matriz);       // devuelve array (0, "color")

$matriz = array(1, 100, 2, 100);
array_keys ($matriz, 100);  // devuelve array (0, 2)

Vea también: array_values().

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_flip | Subir | array_merge


array_merge

(PHP 4 >= 4.0.0)

array_merge -- Combina dos o más matrices

Descripción

array array_merge ( array matriz1, array matriz2 [, ...])

array_merge() combina los elementos de dos o más matrices conjuntamente de modo que los valores de una son agregados al final de los valores de la anterior. Devuelve la matriz resultante.

Si las matrices de entrada tienen las mismas claves de cadena, el último valor para cada clave reemplazará el valor previo de la misma. Si, por el contrario, las matrices tienen la misma clave numérica, esto no pasa y los valores son simplemente agregados.

Ejemplo 1. Ejemplo de array_merge()

$matriz1 = array ("color" => "rojo", 2, 4);
$matriz2 = array ("a", "b", "color" => "verde", "forma" => "trapezoide");
array_merge ($matriz1, $matriz2);

La matriz resultante sería array("color" => "verde", 2, 4, "a", "b", "forma" => "trapezoide").

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_keys | Subir | array_pad


array_pad

(PHP 4 >= 4.0.0)

array_pad -- Rellena una matriz con un valor hasta el tamaño especificado

Descripción

array array_pad ( array entrada, int tama_relleno, mixed valor_relleno)

array_pad() Devuelve una copia de la entrada rellenada hasta el tamaño tama_relleno con el valor valor_relleno. Si tama_relleno es positivo, entonces la matriz es rellenada por la derecha, y si es negativo, por la izquierda. Si el valor absoluto de tama_relleno es menor o igual que el tamaño de la entrada no se produce relleno alguno.

Ejemplo 1. Ejemplo de array_pad()

$entrada = array (12, 10, 9);

$resultado = array_pad ($entrada, 5, 0);
// el resultado es array (12, 10, 9, 0, 0)

$resultado = array_pad ($entrada, -7, -1);
// el resultado es array (-1, -1, -1, -1, 12, 10, 9)

$resultado = array_pad ($entrada, 2, "no");
// no rellenado

Anterior | Inicio | Siguiente
array_merge | Subir | array_pop


array_pop

(PHP 4 >= 4.0.0)

array_pop -- Extrae el último elemento de la matriz

Descripción

mixed array_pop ( array matriz)

array_pop() extrae y devuelve el último valor de la matriz, acortando la matriz en un elemento.

Ejemplo 1. Ejemplo de array_pop()

$pila = array ("naranja", "manzana", "frambuesa");
$fruta = array_pop ($pila);

Tras esto, $pila contiene sólo 2 elementos: "naranja" y "manzana", y $fruta contiene "frambuesa".

Vea también: array_push(),
array_shift(), y
array_unshift().

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_pad | Subir | array_push


array_push

(PHP 4 >= 4.0.0)

array_push -- Inserta uno o más elementos al final de la matriz

Descripción

int array_push ( array matriz, mixed var [, ...])

array_push() considera a la matriz como una pila, e inserta las variables que se le pasan al final de la matriz. La longitud de la matriz se incrementa en el número de variables insertadas. Tiene el mismo efecto que ejecutar:
$matriz[] = $var;
para cada var.

Devuelve el nuevo número de elementos de la matriz.

Ejemplo 1. Ejemplo de array_push()

$pila = array (1, 2);
array_push($pila, "+", 3);
Este ejemplo dejará $pila conteniendo 4 elementos: 1, 2, "+", y 3.

Vea también: array_pop(),
array_shift(), y
array_unshift().

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_pop | Subir | array_reverse


array_reverse

(PHP 4 >= 4.0.0)

array_reverse -- Devuelve una matriz con los elementos en orden inverso

Descripción

array array_reverse ( array matriz)

array_reverse() toma la matriz de entrada y devuelve una nueva matriz con los elementos en orden inverso.

Ejemplo 1. Ejemplo de array_reverse()

$entrada = array ("php", 4.0, array ("verde", "rojo"));
$resultado = array_reverse ($entrada);
Esto hace que $resultado contenga array (array ("verde", "rojo"), 4.0, "php").

Nota: Esta función fue añadida en PHP 4.0 Beta 3.

Anterior | Inicio | Siguiente
array_push | Subir | array_shift


array_shift

(PHP 4 >= 4.0.0)

array_shift -- Extrae un elemento del comienzo de la matriz

Descripción

mixed array_shift ( array matriz)

array_shift() extrae el primer valor de la matriz y lo devuele, acortando la matriz en un elemnto y moviendo todo hacia arriba.

Ejemplo 1. Ejemplo de array_shift()

$args = array ("-v", "-f");
$opcion = array_shift ($args);
Esto da como resultado que $args tenga como elemento restante "-f" y que $opcion valga "-v".

Vea también: array_unshift(),
array_push(), y
array_pop().

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_reverse | Subir | array_slice


array_slice

(PHP 4 >= 4.0.0)

array_slice -- Extrae una porción de la matriz

Descripción

array array_slice ( array matriz, int desplazamiento [, int tamano])

array_slice() devuelve una secuencia de elementos de la matriz especificada por los parámetros desplazamiento y tamano.

Si el desplazamiento es positivo, la secuencia comenzará en dicha posición de la matriz. Si el desplazamiento es negativo, la secuencia comenzará en esa posición desde el final de la matriz.

Si se especifica el tamano y éste es positivo, la secuencia contendrá tantos elementos como se diga en él. Si fuese negativo, la secuencia se detendrá a tantos elementos del final de la matriz. Si se omite, la secuencia contendrá todos los elementos desde el desplazamiento hasta el final de la matriz.

Ejemplo 1. Ejemplo de array_slice() examples

$entrada = array ("a", "b", "c", "d", "e");

$salida = array_slice ($entrada, 2);      // devuelve "c", "d", y "e"
$salida = array_slice ($entrada, 2, -1);  // devuelve "c", "d"
$salida = array_slice ($entrada, -2, 1);  // devuelve "d"
$salida = array_slice ($entrada, 0, 3);   // devuelve "a", "b", y "c"

Vea también: array_splice().

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_shift | Subir | array_splice


array_splice

(PHP 4 >= 4.0.0)

array_splice -- Suprime una porción de la matriz y la sustituye por otra cosa

Descripción

array array_splice ( array entrada, int desplazamiento [, int tamano [, array sustitucion]])

array_splice() suprime los elementos designados por el desplazamiento y el tamano de la matriz entrada, y los sustituye con los elementos de la matriz de sustitucion si se especifica.

Si el desplazamiento es positivo, el comienzo de la parte suprimida sería en esa posición desde el comienzo de la matriz de entrada. Si el desplazamiento es negativo, se cuenta la posición desde el final de la matriz de entrada.

Si se omite tamano, se suprime todo desde el desplazamiento hasta el final de la matriz. Si se especifica el tamano y es positivo, se suprimirán tantos elementos como se especifica. Si fuera negativo, el final de la porción eliminada estará a tantos elementos del final de la matriz. Truco: para eliminar todo desde el desplazamiento hasta el final de la matriz cuando también se especifica sustitucion, utilice count($entrada) como tamano.

Si se especifia la matriz de sustitucion, entonces los elementos suprimidos son reemplazados con los elementos de dicha matriz. Si los valores de desplazamiento y tamano son tales que nada es borrado, los elementos de la matriz sustitucion se insertarán en la posición indicada por el desplazamiento. Truco: si sólo se va a sustituir algo por un elemento nada más, no hace falta poner array() alrededor del mismo, salvo que dicho elemento sea una matriz en sí mismo.

Las siguientes funciones son equivalentes:
array_push($entrada, $x, $y)     array_splice($entrada, count($entrada), 0, array($x, $y))
array_pop($entrada)              array_splice($entrada, -1)
array_shift($entrada)            array_splice($entrada, 0, 1)
array_unshift($entrada, $x, $y)  array_splice($entrada, 0, 0, array($x, $y))
$a[$x] = $y                    array_splice($entrada, $x, 1, $y)

Devuelve una matriz que tiene los elementos eliminados

Ejemplo 1. Ejemplos de array_splice()

$entrada = array("rojo", "verde", "azul", "amarillo");

array_splice($entrada, 2);      // $entrada vale ahora array("rojo", "verde")
array_splice($entrada, 1, -1);  // $entrada vale ahora array("rojo", "amarillo")
array_splice($entrada, 1, count($entrada), "naranja");
                              // $entrada vale ahora array("rojo", "naranja")
array_splice($entrada, -1, 1, array("negro", "marrón"));
                              // $entrada vale ahora array("rojo", "verde",
                              //          "azul", "negro", "marrón")

Vea también: array_slice().

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_slice | Subir | array_unshift


array_unshift

(PHP 4 >= 4.0.0)

array_unshift -- Introduce uno o más elementos al principio de la matriz

Descripción

int array_unshift ( array matriz, mixed var [, ...])

array_unshift() añade los elementos que se le pasan al principio de la matriz. Nótese que la lista de elementos es añadida como un todo, de modo que los elementos añadidos mantienen su orden.

Devuelve el número de elementos en la matriz.

Ejemplo 1. Ejemplo de array_unshift()

$cola = array("p1", "p3");
array_unshift($cola, "p4", "p5", "p6");
Esto hará que $cola contenga 5 elementos: "p4", "p5", "p6", "p1", y "p3".

Vea también: array_shift(),
array_push(), y
array_pop().

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_splice | Subir | array_values


array_values

(PHP 4 >= 4.0.0)

array_values -- Devuelve todos los valores de una matriz

Descripción

array array_values ( array entrada)

array_values() devuelve todos los valores de la matriz entrada.

Ejemplo 1. Ejemplo de array_values()

$matriz = array("talla" => "XL", "color" => "dorado");
array_values($matriz);    // devuelve array("XL", "dorado")

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
array_unshift | Subir | array_walk


array_walk

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

array_walk -- Aplica una función del usuario a cada elemento de una matriz.

Descripción

int array_walk ( array matriz, string func, mixed datosvarios)

Aplica la función llamada func a cada elemento de la matriz. La función func recibirá el valor de la matriz como primer parámetro y la clave como segundo. Si se proporciona el parámetro datosvarios será pasado como tercer parámetro a la función de usuario.

Si func necesita más de dos o 3 argumentos, dependiendo de datosvarios, se generará un aviso cada vez que array_walk() llama a func. Estos avisos pueden suprimirse si se pone '@' antes de la llamada a array_walk(), o usando la función error_reporting().

Nota: Si func precisa trabajar con los valores reales de la matriz, especifique que el valor del primer parámetro de func debe pasarse por referencia. Desde ese instante, los cambios realizados sobre dichos elementos también serán realizados en la propia matriz.

Nota: El pasar la clave y los datos de usuario a func fue una característica añadida en PHP 4.0.

En PHP 4 se debe llamar reset() las veces necesarias, pues array_walk() no reajusta la matriz por defecto.

Ejemplo 1. Ejemplo de array_walk()

$frutas = array ("d"=>"limón", "a"=>"naranja", "b"=>"plátano", "c"=>"manzana");

function test_alterar (&$item1, $clave, $prefix) {
   $item1 = "$prefix: $item1";
}

function test_ver ($item2, $clave) {
   echo "$clave. $item2<br>\n";
}

array_walk ($frutas, 'test_ver');
reset ($frutas);
array_walk ($frutas, 'test_alterar', 'fruta');
reset ($frutas);
array_walk ($frutas, 'test_ver');

Vea también: each() y list().

Anterior | Inicio | Siguiente
array_values | Subir | arsort


arsort

(PHP 3, PHP 4 >= 4.0.0)

arsort -- Ordena una matriz en orden inverso y mantiene la asociación de índices

Descripción

void arsort ( array matriz)

Esta función ordena una matriz de modo que los índices mantengan su correlación con los elementos de la misma a los que están asociados. Esto se utiliza principalmente para ordenar matrices asociativas en las que el orden de los elementos es importante.

Ejemplo 1. Ejemplo de arsort()

$frutas = array ("d"=>"limón", "a"=>"naranja", "b"=>"plátano", "c"=>"manzana");
arsort ($frutas);
for (reset ($frutas); $clave = key ($frutas); next ($frutas)) {
    echo "frutas[$clave] = ".$frutas[$clave]."\n";
}
Este ejemplo mostraría:
frutas[b] = plátano
frutas[a] = naranja
frutas[c] = manzana
frutas[d] = limón
 Las frutas han sido ordenadas en orden alfabético inverso y los índices asociados con cada elemento se han mantenido.

Vea también: asort(), rsort(), ksort(), y sort().

Anterior | Inicio | Siguiente
array_walk | Subir | asort


asort

(PHP 3, PHP 4 >= 4.0.0)

asort -- Ordena una matriz y mantiene la asociación de índices

Descripción

void asort ( array matriz)

Esta función ordena una matriz de modo que los índices mantengan su correlación con los elementos de la misma a los que están asociados. Esto se utiliza principalmente para ordenar matrices asociativas en las que el orden de los elementos es importante.

Ejemplo 1. Ejemplo de asort()

$frutas = array ("d"=>"limón", "a"=>"naranja", "b"=>"plátano", "c"=>"manzana");
asort ($frutas);
for (reset ($frutas); $clave = key ($frutas); next ($frutas)) {
    echo "frutas[$clave] = ".$frutas[$clave]."\n";
}
Este ejemplo mostrará:
frutas[d] = limón
frutas[a] = naranja
frutas[c] = manzana
frutas[d] = plátano
 Las frutas han sido ordenadas en orden alfabético y los índices asociados con cada elemento se han mantenido.

Vea también: arsort(), rsort(), ksort(), y sort().

Anterior | Inicio | Siguiente
arsort | Subir | compact


compact

(PHP 4 >= 4.0.0)

compact -- Crea una matriz que contiene variables y sus valores

Descripción

array compact ( string nombrevar | array nombrevars [, ...])

compact() toma un número variable de parámetros. Cada uno puede ser tanto una cadena que contiene el nombre de la variable, como una matriz de nombres de variable. La matriz puede contener otras matrices de nombres de variable en su interior; compact() los procesa recursivamente.

Para cada uno de estos, compact() busca una variable con dicho nombre en la tabla de símbolos y la añade a la matriz de salida de modo que el nombre de la variable es la clave y el contenido de ésta es el valor para dicha clave. Para resumir, hace lo contrario de extract(). Devuelve la matriz de salida con las variables añadidas a la misma.

Ejemplo 1. Ejemplo de compact()

$ciudad = "San Francisco";
$estado = "CA";
$evento = "SIGGRAPH";

$location_vars = array ("ciudad", "estado");

$resultado = compact ("evento", $location_vars);

Tras esto, $resultado valdrá array ("evento" => "SIGGRAPH", "ciudad" => "San Francisco", "estado" => "CA").

Vea también: extract().

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
asort | Subir | count


count

(PHP 3, PHP 4 >= 4.0.0)

count -- Cuenta los elementos de una variable

Descripción

int count ( mixed var)

Devuelve el número de elementos en var, que típicamente es una matriz (porque cualquier otra cosa tendría sólo un elemento).

Devuele 1 si la variable no es una matriz.

Devuelve 0 si la variable no tiene valor.

Aviso

count() puede devolver 0 para una variable sin valor, pero también puede devolver 0 para una variable ya inicializada pero con una matriz vacía. Utilice isset() para comprobar si una variable está inicializada.

Vea también: sizeof(),
isset(), y
is_array().

Anterior | Inicio | Siguiente
compact | Subir | current


current

(PHP 3, PHP 4 >= 4.0.0)

current -- Devuelve el elemento actual de una matriz

Descripción

mixed current ( array matriz)

Cada matriz tiene un puntero interno al elemento "actual", que se inicializa al primer elemento insertado en la misma.

La función current() simplemente devuelve el elemento de la tabla al que apunta el puntero interno. No mueve el puntero de ninguna manera. Si el puntero interno apunta fuera del final de la lista de elementos, current() devuelve FALSE.

Aviso

Si la matriz contiene elementos vacíos (0 ó "", la cadena vacía) esta función devolverá FALSE también para dichos elementos. Esto hace imposible determinar si se está realmente al final de la lista en tales matrices usando current(). Para recorrer adecuadamente una matriz que pueda contener elementos vacíos, utilice la función each().

Vea también: end(), next(), prev() y reset().

Anterior | Inicio | Siguiente
count | Subir | each


each

(PHP 3, PHP 4 >= 4.0.0)

each -- Devuelve el siguiente par clave/valor de una matriz

Descripción

array each ( array matriz)

Devuelve el par clave/valor actual para la matriz y avanza el cursor de la misma. Esta pareja se devuele en una matriz de 4 elementos, con las claves 0, 1, key, y value. Los elementos 0 y key contienen el nombre de clave del elemento de la matriz, y 1 y value contienen los datos.

Si el puntero interno para la matriz apunta pasado el final del contenido de la matriz, each() devuelve FALSE.

Ejemplo 1. Ejemplos de each()

$chorrada = array ("bob", "fred", "jussi", "jouni", "egon", "marliese");
$tonteria = each ($chorrada);

$tonteria contiene ahora los siguientes pares clave/valor:

  • 0 => 0
  • 1 => 'bob'
  • key => 0
  • value => 'bob'
$chorrada = array ("Robert" => "Bob", "Seppo" => "Sepi");
$tonteria = each ($chorrada);

$tonteria contiene ahora los siguientes pares clave/valor:

  • 0 => 'Robert'
  • 1 => 'Bob'
  • key => 'Robert'
  • value => 'Bob'

each() se usa normalmente de forma conjunta a list() para recorrer una matriz; por ejemplo, $HTTP_POST_VARS:

Ejemplo 2. Recorriendo $HTTP_POST_VARS con each()

echo "Valores enviados con el método POST:<br>";
reset ($HTTP_POST_VARS);
while (list ($clave, $val) = each ($HTTP_POST_VARS)) {
    echo "$clave => $val<br>";
}

Cuando se ha ejecutado each(), el cursor de la matriz quedará en el siguiente elemento de la misma, o en el último si llega al final de ésta.

Vea también: key(), list(),
current(), reset(),
next(), y prev().

Anterior | Inicio | Siguiente
current | Subir | end


end

(PHP 3, PHP 4 >= 4.0.0)

end -- Mueve el puntero interno de una tabla al último elemento

Descripción

end ( array matriz)

end() avanza el puntero interno de la matriz al último elemento.

Vea también: current(),
each(), end(),
next(), y reset().

Anterior | Inicio | Siguiente
each | Subir | extract


extract

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

extract -- Importa variables a la tabla de símbolos desde una matriz

Descripción

void extract ( array matriz_vars [, int tipo_extraccion [, string prefijo]])

Esta función se utiliza para importar variables desde una matriz a la tabla de símbolos actual. Toma la matriz asoiativa matriz_vars y trata las claves como nombres de variable y los valores como los valores de éstas. Para cada par clave/valor creará una variable en la tabla de símbolos actual, sujeto a los parámetros tipo_extraccion y prefijo.

extract() controla las colisiones con las variables que ya existen. La forma de tratar éstas se determina por el tipo_extraccion. Puede tener únicamente uno de los siguientes valores:

EXTR_OVERWRITE

Si hay colisión, sobreescribe la variable existente.

EXTR_SKIP

Si hay colisión, no sobreescribas la variable existente.

EXTR_PREFIX_SAME

Si hay una colisión, añade el prefijo a la nueva variable.

EXTR_PREFIX_ALL

Añade el prefijo a todas las variables.

Si no se especifica tipo_extraccion, se asume que vale EXTR_OVERWRITE.

Nótese que el prefijo sólo se necisita si tipo_extraccion vale EXTR_PREFIX_SAME o EXTR_PREFIX_ALL.

extract() comprueba si cada clave es un nombre válido de variable, y sólo lo importa si lo es.

Nota: N.T.: En el caso español, no valdría "año" como nombre variable (pero sí como clave en una matriz cualquiera).

Un uso posible para extract sería importar en la tabla de símbolos las variables contenidas en la matriz asociativa que devuelve wddx_deserialize().

Ejemplo 1. Ejemplo de extract()

<php?

/* Suponemos que $matriz_var es una matriz devuelta por
   wddx_deserialize */

$tamano = "grande";
$matriz_var = array ("color" => "azul",
                    "tamano"  => "media",
                    "forma" => "esfera");
extract ($matriz_var, EXTR_PREFIX_SAME, "wddx");

print "$color, $tamano, $forma, $wddx_tamano\n";

?>

El programa anterior producirá:
azul, grande, esfera, media

La variable $tamano no fue sobreescrita porque especificamos EXTR_PREFIX_SAME, que provocó la creación de $wddx_tamano. Si se hubiera especificado EXTR_SKIP, $wddx_tamano ni siquiera habría sido creada. EXTR_OVERWRITE habría provocado que $tamano tuviera el valor "media", y EXTR_PREFIX_ALL habría provocado que aparecieran nuevas variables llamadas $wddx_color, $wddx_tamano, y $wddx_forma.

Anterior | Inicio | Siguiente
end | Subir | in_array


in_array

(PHP 4 >= 4.0.0)

in_array -- Devuelve TRUE si un valor está en una matriz

Descripción

bool in_array ( mixed aguja, array pajar)

Busca la aguja en el pajar, y devuelve TRUE si se encuentra y FALSE en caso contrario.

Ejemplo 1. Ejemplo de in_array()

$os = array ("Mac", "NT", "Irix", "Linux");
if (in_array ("Irix", $os))
    print "Encontrado Irix";

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
extract | Subir | key


key

(PHP 3, PHP 4 >= 4.0.0)

key -- Obtiene una clave de una matriz asociativa

Descripción

mixed key ( array matriz)

key() devuelve el elemento índice de la posición actual en la matriz.

Vea también: current(), next()

Anterior | Inicio | Siguiente
in_array | Subir | krsort


krsort

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

krsort -- Ordena una matriz por clave en orden inverso

Descripción

int krsort ( array matriz)

Ordena una matriz por clave en orden inverso, manteniendo las correlaciones clave a dato. Esto es útil principalmente en matrices asociativas.

Ejemplo 1. Ejemplo de krsort()

$frutas = array ("d"=>"limón", "a"=>"naranja", "b"=>"plátano", "c"=>"manzana");
krsort ($frutas);
for (reset ($frutas); $clave = key ($frutas); next ($frutas)) {
    echo "frutas[$clave] = ".$frutas[$clave]."\n";
}
Este ejemplo mostrará:
frutas[d] = limón
frutas[c] = manzana
frutas[b] = plátano
frutas[a] = naranja

Vea también: asort(), arsort(),
ksort() sort(), y
rsort().

Anterior | Inicio | Siguiente
key | Subir | ksort


ksort

(PHP 3, PHP 4 >= 4.0.0)

ksort -- Ordena una matriz por clave

Descripción

int ksort ( array matriz)

Ordena una matriz por clave, manteniendo las correlaciones clave a dato. Esto es útil principalmente en matrices asociativas.

Ejemplo 1. Ejemplo de ksort()

$frutas = array ("d"=>"limón", "a"=>"naranja", "b"=>"plátano", "c"=>"manzana");
ksort ($frutas);
for (reset ($frutas); $clave = key ($frutas); next ($frutas)) {
    echo "frutas[$clave] = ".$frutas[$clave]."\n";
}
Este ejemplo mostrará:
frutas[a] = naranja
frutas[b] = plátano
frutas[c] = manzana
frutas[d] = limón

Vea también: asort(), arsort(), sort(), y rsort().

Anterior | Inicio | Siguiente
krsort | Subir | list


list

(unknown)

list -- Asigna variables como si fueran una matriz

Descripción

void list ( mixed ...)

Como array(), esta no es realmente una función, sino una construcción del lenguaje. list() se usa para asignar una lista de variables en una sola operación.

Ejemplo 1. Ejemplo de list()

<table>
 <tr>
  <th>Nombre empleado</th>
  <th>Sueldo</th>
 </tr>

<?php

$resultado = mysql($conn, "SELECT id, nombre, salario FROM empleados");
while (list($id, $nombre, $salario) = mysql_fetch_row($resultado)) {
    print(" <tr>\n".
          "  <td><a href=\"info.php3?id=$id\">$nombre</a></td>\n".
          "  <td>$salario</td>\n".
          " </tr>\n");
}

?>

</table>

Vea también: each(), array().

Anterior | Inicio | Siguiente
ksort | Subir | next


next

(PHP 3, PHP 4 >= 4.0.0)

next -- Avanza el puntero interno de una matriz

Descripción

mixed next ( array matriz)

Devuelve el elemento de la matriz que ocupa el lugar siguiente al apuntado por el puntero interno, o FALSE si no hay más elementos.

next() se comporta como current(), con una diferencia. Avanza el puntero interno de la matriz en una posición antes de devolver el elemento. Eso significa que devuelve el siguiente elemento de la matriz y que avanza el puntero interno en uno. Si al avanzar se pasa del final de la lista de elementos, next() devuelve FALSE.

Aviso

Si la matriz contiene elementos vacíos, esta función también devolverá FALSE para dichos elementos. Para recorrer adecuadamente una matriz que pueda contener elementos vacíos, vea la función each().

Vea también: current(), end() prev() y reset()

Anterior | Inicio | Siguiente
list | Subir | pos


pos

(PHP 3, PHP 4 >= 4.0.0)

pos -- Obtiene el elemento actual de una matriz

Descripción

mixed pos ( array matriz)

Este es un alias para current().

Vea también: end(), next(), prev() y reset().

Anterior | Inicio | Siguiente
next | Subir | prev


prev

(PHP 3, PHP 4 >= 4.0.0)

prev -- Rebobina el puntero interno de una matriz

Descripción

mixed prev ( array matriz)

Devuelve el elemento de la matriz que está en la posición anterior a la que apuntaba previamente el puntero interno, o FALSE si no hay más elementos.

Aviso

Si la matriz contiene elementos vacíos, esta función también devolverá FALSE para dichos elementos. Para recorrer adecuadamente una matriz que puede contener elementos vacíos, vea la función each().

prev() se comporta igual que next(), excepto que rebobina el puntero interno una posición en lugar de avanzarlo.

Vea también: current(), end() next() y reset()

Anterior | Inicio | Siguiente
pos | Subir | rango


rango

(unknown)

rango -- Crea una matriz que contiene un rango de enteros

Descripción

array rango ( int bajo, int alto)

rango() devuelve una matriz de enteros desde bajo hasta alto, ambos inclusive.

Vea un ejemplo de su uso en la función shuffle().

Anterior | Inicio | Siguiente
prev | Subir | reset


reset

(PHP 3, PHP 4 >= 4.0.0)

reset -- Fija el puntero interno de una matriz a su primer elemento

Descripción

mixed reset ( array matriz)

reset() rebobina el puntero interno de la matriz a su primer elemento.

reset() devuelve el valor del primer elemento de la matriz.

Vea también: current(),
each(), next(),
prev(), y reset().

Anterior | Inicio | Siguiente
rango | Subir | rsort


rsort

(PHP 3, PHP 4 >= 4.0.0)

rsort -- Ordena una matriz en orden inverso

Descripción

void rsort ( array matriz)

Esta función ordena una matriz en orden inverso (mayor a menor).

Ejemplo 1. Ejemplo de rsort()

$frutas = array ("limón", "naranja", "plátano", "manzana");
rsort ($frutas);
for (reset ($frutas); list ($clave, $valor) = each ($frutas); ) {
    echo "frutas[$clave] = ", $valor, "\n";
}
Este ejemplo mostrará:
frutas[0] = plátano
frutas[1] = naranja
frutas[2] = manzana
frutas[3] = limón
 Las frutas han sido ordenadas en orden alfabético inverso.

Vea también: arsort(),
asort(), ksort(),
sort(), y usort().

Anterior | Inicio | Siguiente
reset | Subir | shuffle


shuffle

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

shuffle -- Mezcla una matriz

Descripción

void shuffle ( array matriz)

Esta función mezcla (cambia aleatoriamente el orden de los elementos de) una matriz.

Ejemplo 1. Ejemplo de shuffle()

$numeros = range (1,20);
srand (time());
shuffle ($numeros);
while (list(, $numero) = each ($numeros)) {
    echo "$numero ";
}

Vea también: arsort(), asort(),
ksort(), rsort(),
sort() y usort().

Anterior | Inicio | Siguiente
rsort | Subir | sizeof


sizeof

(PHP 3, PHP 4 >= 4.0.0)

sizeof -- Obtiene el número de elementos de una matriz

Descripción

int sizeof ( array matriz)

Devueve el número de elementos de la matriz.

Vea también: count()

Anterior | Inicio | Siguiente
shuffle | Subir | sort


sort

(PHP 3, PHP 4 >= 4.0.0)

sort -- Ordena una matriz

Descripción

void sort ( array matriz)

Esta función ordena una matriz. Los elementos estarán ordenados de menor a mayor cuando la función termine.

Ejemplo 1. Ejemplo de sort()

$frutas = array ("limón", "naranja", "plátano", "manzana");
sort ($frutas);
for (reset ($frutas); $clave = key ($frutas); next ($frutas)) {
    echo "frutas[$clave] = ".$frutas[$clave]."\n";
}
Este ejemplo mostrará:
frutas[0] = limón
frutas[1] = manzana
frutas[2] = naranja
frutas[3] = plátano
 Las frutas han sido ordenadas en orden alfabético.

Vea también: arsort(),
asort(), ksort(),
rsort(), y usort().

Anterior | Inicio | Siguiente
sizeof | Subir | uasort


uasort

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

uasort -- Ordena una matriz mediante una función de comparación definida por el usuario y mantiene la asociación de índices

Descripción

void uasort ( array matriz, function func_comparar)

Esta función ordena una matriz de modo que los índices de la misma mantengan su correlación con los elementos a los que están asociados. Esto se utiliza principalmente para ordenar matrices asociativas en las que el orden de los elementos es importante. La función de comparación viene definida por el usuario.

Anterior | Inicio | Siguiente
sort | Subir | uksort


uksort

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

uksort -- Ordena una matriz por claves mediante una función definida por el usuario

Descripción

void uksort ( array matriz, function func_comparar)

Esta función ordenará las claves de una matriz utilizando una función de comparación suministrada por el usuario. Si la matriz a ordenar necesita utilizar un criterio poco trivial, esta es la función que deberá usar.

Ejemplo 1. Ejemplo de uksort()

function micomparar ($a, $b) {
    if ($a == $b) return 0;
    return ($a > $b) ? -1 : 1;
}
$a = array (4 => "cuatro", 3 => "tres", 20 => "veinte", 10 => "diez");
uksort ($a, micomparar);
while (list ($clave, $valor) = each ($a)) {
    echo "$clave: $valor\n";
}
Este ejemplo mostrará: 20: veinte 10: diez 4: cuatro 3: tres

Vea también: arsort(),
asort(), uasort(),
ksort(), rsort(), y
sort().

Anterior | Inicio | Siguiente
uasort | Subir | usort


usort

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

usort -- Ordena una matriz por valores mediante una funcion definida por el usuario

Descripción

void usort ( array matriz, function func_comparar)

Esta función ordenará una matriz por sus valores utilizando una función suministrada por el usuario. Si la matriz que desea ordenar necesita utilizar un criterio poco trivial, esta es la función que deberá usar.

La función de comparación deberá devolver un entero menor, igual, o mayor que cero, si el primer argumento se considera respectivamente menor que, igual que, o mayor que el segundo. Si dos miembros resultan ser iguales, su orden en la matriz ordenada será cualquiera.

Ejemplo 1. Ejemplo de usort()

function cmp ($a, $b) {
    if ($a == $b) return 0;
    return ($a > $b) ? -1 : 1;
}
$a = array (3, 2, 5, 6, 1);
usort ($a, cmp);
while (list ($clave, $valor) = each ($a)) {
    echo "$clave: $valor\n";
}
Este ejemplo mostrará: 0: 6 1: 5 2: 3 3: 2 4: 1

Nota: Obviamente en este caso trivial la función rsort() habría sido más apropiada.

Aviso

La función quicksort subyacente en ciertas librerías de C (tales como las de Solaris) pueden hacer que el PHP falle si la función de comparación no devuelve valores consistentes.

Vea también: arsort(),
asort(), ksort(),
rsort() y sort().

Anterior | Inicio | Siguiente
uksort | Subir | Funciones Ortográficas


Funciones Ortográficas

Manual de PHP
Anterior Siguiente

III. Funciones Ortográficas

Las funciones aspell() permiten comprobar la ortografía de una palabra ofreciendote sugerencias. .

Para estas funciones, son necesarias las librerias aspell (ortográficas) disponibles en http://metalab.unc.edu/kevina/aspell/

Tabla de contenidos
aspell_check — Comprueba una palabra
aspell_check-raw — Comprueba una palabra sin cambiarla o intentar arreglarla
aspell_new — Lee un nuevo diccionario
aspell_suggest — sugiere la ortografía para una palabra

Anterior | Inicio | Siguiente
usort | Subir | aspell_check


aspell_new

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

aspell_new -- Lee un nuevo diccionario

Descripción

int aspell_new ( string master, string personal)

aspell_new() Abre un nuevo diccionario devolviendo el identificador de este para ser utilizado en otras funciones ortográficas.

Ejemplo 1. Nuevo_diccionario

$aspell_link=aspell_new("english");

Anterior | Inicio | Siguiente
aspell_check-raw | Subir | aspell_suggest


aspell_check

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

aspell_check -- Comprueba una palabra

Descripción

boolean aspell_check ( int dictionary_link, string word)

aspell_check() comprueba la ortografía de una palabra, y devuelve cierto(TRUE) si la ortografía es correcta ,falso (FALSE) si no lo es .

Ejemplo 1. aspell_check

$aspell_link=aspell_new("english");
if (aspell_check($aspell_link,"testt")) {
    echo "Está bien escrita";
} else {
    echo "Lo siento, está mal escrita";
}

Anterior | Inicio | Siguiente
Funciones Ortográficas | Subir | aspell_check-raw


aspell_check-raw

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

aspell_check-raw -- Comprueba una palabra sin cambiarla o intentar arreglarla

Descripción

boolean aspell_check_raw ( int dictionary_link, string word)

aspell_check_raw() chequea la ortografía de una palabra,sin cambiarla ni intentar arreglarla esté bien o mal.Si está bien, devuelve cierto (TRUE), si no lo está, devuelve falso(FALSE).

Ejemplo 1. aspell_check_raw

$aspell_link=aspell_new("english");
if (aspell_check_raw($aspell_link,"testt")) {
    echo "Está bein escrito";
} else {
    echo "Lo siento,mal escrito";
}

Anterior | Inicio | Siguiente
aspell_check | Subir | aspell_new


aspell_suggest

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

aspell_suggest -- sugiere la ortografía para una palabra

Descripción

array aspell_suggest ( int dictionary_link, string word)

aspell_suggest() devuelve un array con posibles correciones ortográficas para la palabra dada.

Ejemplo 1. aspell_suggest

$aspell_link=aspell_new("english");

if (!aspell_check($aspell_link,"testt")) {
    $sugerencias=aspell_suggest($aspell_link,"testt");

    for($i=0; $i < count($sugerencias); $i++) {
       echo "Posibles palabras: " . $sugerencias[$i] . "<br>";
    }
}

Anterior | Inicio | Siguiente
aspell_new | Subir | Funciones matemáticas de precisión arbitraria


Funciones matemáticas de precisión arbitraria

Manual de PHP
Anterior Siguiente

IV. Funciones matemáticas de precisión arbitraria

Estas funciones sólo están disponibles si el PHP se configuró con --enable-bcmath.

Tabla de contenidos
bcadd — Suma dos números de precisión arbitriaria.
bccomp — Compara dos números de precisión arbitraria.
bcdiv — Divide dos números de precisión arbitraria.
bcmod — Obtiene el módulo de un número de precisión arbitraria.
bcmul — Multiplica dos números de precisión arbitraria.
bcpow — Eleva un número de precisión arbitraria a otro.
bcscale — Fija el parámetro de escala por defecto para todas las funciones matemáticas bc.
bcsqrt — Obtiene la raíz cuadrada de un número de precisión arbitraria.
bcsub — Resta un número de precisión arbitraria de otro.

Anterior | Inicio | Siguiente
aspell_suggest | Subir | bcadd


bcadd

(PHP 3, PHP 4 >= 4.0.0)

bcadd -- Suma dos números de precisión arbitriaria.

Descripción

string bcadd ( string operando izq, string operando der [, int escala])

Suma el operando izq con el operando der y devuelve la suma en una string. El parámetro opcional escala se usa para fijar el número de dígitos tras el punto decimal que aparecerán en el resultado.

Vea también bcsub().

Anterior | Inicio | Siguiente
Funciones matemáticas de precisión arbitraria | Subir | bccomp


bccomp

(PHP 3, PHP 4 >= 4.0.0)

bccomp -- Compara dos números de precisión arbitraria.

Descripción

int bccomp ( string operando izq, string operando der [, int escala])

Compara el operando izq con el operando der y devuelve el resultado como un entero. El parámetro opcional escala se usa para fijar el número de dígitos tras el punto decimal que se utilizarán en la comparación. El valor devuelto es 0 si los dos operandos son iguales. Si el operando izq es mayor que el operando der el valor devuelto es +1 y si el operando izq es menor que el operando der el valor devuelto es -1.

Anterior | Inicio | Siguiente
bcadd | Subir | bcdiv


bcdiv

(PHP 3, PHP 4 >= 4.0.0)

bcdiv -- Divide dos números de precisión arbitraria.

Descripción

string bcdiv ( string operando izq, string operando der [, int escala])

Divide el operando izq por el operando der y devuelve el resultado. El parámetro opcional escala fija el número de dígitos tras el punto decimal a usar en el resultado.

Vea también bcmul().

Anterior | Inicio | Siguiente
bccomp | Subir | bcmod


bcmod

(PHP 3, PHP 4 >= 4.0.0)

bcmod -- Obtiene el módulo de un número de precisión arbitraria.

Descripción

string bcmod ( string operando izq, string modulo)

Obtiene el módulo del operando izq usando modulo.

Vea también bcdiv().

Anterior | Inicio | Siguiente
bcdiv | Subir | bcmul


bcmul

(PHP 3, PHP 4 >= 4.0.0)

bcmul -- Multiplica dos números de precisión arbitraria.

Descripción

string bcmul ( string operando izq, string operando der [, int escala])

Multiplica el operando izq por el operando der y devuelve el resultado. El parámetro opcional escala fija el número de dígitos tras el punto decimal del resultado.

Vea también bcdiv().

Anterior | Inicio | Siguiente
bcmod | Subir | bcpow


bcpow

(PHP 3, PHP 4 >= 4.0.0)

bcpow -- Eleva un número de precisión arbitraria a otro.

Descripción

string bcpow ( string x, string y [, int escala])

Eleva x a la potencia de y. El parámetro opcional escala se puede usar para fijar el número de dígitos tras el punto decimal del resultado.

Vea también bcsqrt().

Anterior | Inicio | Siguiente
bcmul | Subir | bcscale


bcscale

(PHP 3, PHP 4 >= 4.0.0)

bcscale -- Fija el parámetro de escala por defecto para todas las funciones matemáticas bc.

Descripción

string bcscale ( int escala)

Esta función fija el parámetro de escala por defecto para las subsiguientes funciones matemáticas bc que no especifican dicho parámetro explícitamente.

Anterior | Inicio | Siguiente
bcpow | Subir | bcsqrt


bcsqrt

(PHP 3, PHP 4 >= 4.0.0)

bcsqrt -- Obtiene la raíz cuadrada de un número de precisión arbitraria.

Descripción

string bcsqrt ( string operando, int escala)

Devuelve la raíz cuadrada del operando. El parámetro opcional escala fija el número de dígitos tras el punto decimal del resultado.

Vea también bcpow().

Anterior | Inicio | Siguiente
bcscale | Subir | bcsub


bcsub

(PHP 3, PHP 4 >= 4.0.0)

bcsub -- Resta un número de precisión arbitraria de otro.

Descripción

string bcsub ( string operando izq, string operando der [, int escala])

Resta el operando der desde el operando izq y devuelve el resultado en una cadena. El parámetro opcional escala se utiliza para fijar el número de dígitos tras el punto decimal del resultado.

Vea también bcadd().

Anterior | Inicio | Siguiente
bcsqrt | Subir | Bzip2 Compression Functions


Bzip2 Compression Functions

Manual de PHP
Anterior Siguiente

V. Bzip2 Compression Functions

The bzip2 functions are used to transparently read and write bzip2 (.bz2) compressed files.

Requirements

This module uses the functions of the bzip2 library by Julian Seward

Installation

Bzip2 support in PHP is not enabled by default. You will need to use the --with-bz2 configuration option when compiling PHP to enable bzip2 support. This module requires bzip2/libbzip2 version >= 1.0.x.

Runtime Configuration

???

Resource types

This extension defines one resource type: a file pointer identifying the bz2-file to work on.

Predefined constants

???

Example

This example opens a temporary file and writes a test string to it, then prints out the contents of the file.

Ejemplo 1. Small bzip2 Example

<?php

$filename = "/tmp/testfile.bz2";
$str = "This is a test string.\n";

// open file for writing
$bz = bzopen($filename, "w");

// write string to file
bzwrite($bz, $str);

// close file
bzclose($bz);

// open file for reading
$bz = bzopen($filename, "r");

// read 10 characters
print bzread($bz, 10);

// output until end of the file (or the next 1024 char) and close it.
print bzread($bz);

bzclose($bz);

?>
Tabla de contenidos
bzclose — Close a bzip2 file pointer
bzcompress — Compress a string into bzip2 encoded data
bzdecompress — Decompresses bzip2 encoded data
bzerrno — Returns a bzip2 error number
bzerror — Returns the bzip2 error number and error string in an array
bzerrstr — Returns a bzip2 error string
bzflush — Force a write of all buffered data
bzopen — Open a bzip2 compressed file
bzread — Binary safe bzip2 file read
bzwrite — Binary safe bzip2 file write

Anterior | Inicio | Siguiente
bcsub | Subir | bzclose


bzclose

(PHP 4 >= 4.0.4)

bzclose -- Close a bzip2 file pointer

Description

int bzclose ( resource bz)

Closes the bzip2 file referenced by the pointer bz.

Returns TRUE on succes, FALSE on failure.

The file pointer must be valid, and must point to a file successfully opened by bzopen().

See also bzopen().

Anterior | Inicio | Siguiente
Bzip2 Compression Functions | Subir | bzcompress


bzcompress

(PHP 4 >= 4.0.4)

bzcompress -- Compress a string into bzip2 encoded data

Description

string bzcompress ( string source [, int blocksize [, int workfactor]])

bzcompress() compresses the source string and returns it as bzip2 encoded data.

The optional parameter blocksize specifies the blocksize used during compression and should be a number from 1 to 9 with 9 giving the best compression, but using more resources to do so. blocksize defaults to 4.

The optional parameter workfactor controls how the compression phase behaves when presented with worst case, highly repetitive, input data. The value can be between 0 and 250 with 0 being a special case and 30 being the default value. Regardless of the workfactor, the generated output is the same.

Ejemplo 1. bzcompress() Example

<?php
$str = "sample data";
$bzstr = bzcompress($str, 9);
print( $bzstr );
?>

See also bzdecompress().

Anterior | Inicio | Siguiente
bzclose | Subir | bzdecompress


bzdecompress

(PHP 4 >= 4.0.4)

bzdecompress -- Decompresses bzip2 encoded data

Description

string bzdecompress ( string source [, int small])

bzdecompress() decompresses the source string containing bzip2 encoded data and returns it. If the optional parameter small is TRUE, an alternative decompression algorithm will be used which uses less memory (the maximum memory requirement drops to around 2300K) but works at roughly half the speed. See the bzip2 documentation for more information about this feature.

Ejemplo 1. bzdecompress()

<?php
$start_str = "This is not an honest face?";
$bzstr = bzcompress($start_str);

print( "Compressed String: " );
print( $bzstr );
print( "\n<br>\n" );

$str = bzdecompress($bzstr);
print( "Decompressed String: " );
print( $str );
print( "\n<br>\n" );
?>

See also bzcompress().

Anterior | Inicio | Siguiente
bzcompress | Subir | bzerrno


bzerrno

(PHP 4 >= 4.0.4)

bzerrno -- Returns a bzip2 error number

Description

int bzerrno ( resource bz)

Returns the error number of any bzip2 error returned by the file pointer bz.

See also bzerror() and bzerrstr().

Anterior | Inicio | Siguiente
bzdecompress | Subir | bzerror


bzerror

(PHP 4 >= 4.0.4)

bzerror -- Returns the bzip2 error number and error string in an array

Description

array bzerror ( resource bz)

Returns the error number and error string, in an associative array, of any bzip2 error returned by the file pointer bz.

Ejemplo 1. bzerror() Example

<?php
$error = bzerror($bz);

echo $error["errno"];
echo $error["errstr"];
?>

See also bzerrno() and bzerrstr().

Anterior | Inicio | Siguiente
bzerrno | Subir | bzerrstr


bzerrstr

(PHP 4 >= 4.0.4)

bzerrstr -- Returns a bzip2 error string

Description

string bzerrstr ( resource bz)

Returns the error string of any bzip2 error returned by the file pointer bz.

See also bzerrno() and bzerror().

Anterior | Inicio | Siguiente
bzerror | Subir | bzflush


bzflush

(PHP 4 >= 4.0.4)

bzflush -- Force a write of all buffered data

Description

int bzflush ( resource bz)

Forces a write of all buffered bzip2 data for the file pointer bz.

Returns TRUE on succes, FALSE on failure.

See also bzread() and bzwrite().

Anterior | Inicio | Siguiente
bzerrstr | Subir | bzopen


bzopen

(PHP 4 >= 4.0.4)

bzopen -- Open a bzip2 compressed file

Description

resource bzopen ( string filename, string mode)

Opens a bzip2 (.bz2) file for reading or writing. filename is the name of the file to open. mode is similar to the fopen() function (`r' for read, `w' for write, etc.).

If the open fails, the function returns FALSE, otherwise it returns a pointer to the newly opened file.

Ejemplo 1. bzopen() Example

<?php
$bz = bzopen("/tmp/foo.bz2", "r");
$decompressed_file = bzread($bz, filesize("/tmp/foo.bz2"));
bzclose($bz);

print( "The contents of /tmp/foo.bz2 are: " );
print( "\n<br>\n" );
print( $decompressed_file );
?>

See also bzclose().

Anterior | Inicio | Siguiente
bzflush | Subir | bzread


bzread

(PHP 4 >= 4.0.4)

bzread -- Binary safe bzip2 file read

Description

string bzread ( resource bz [, int length])

bzread() reads up to length bytes from the bzip2 file pointer referenced by bz. Reading stops when length (uncompressed) bytes have been read or EOF is reached, whichever comes first. If the optional parameter length is not specified, bzread() will read 1024 (uncompressed) bytes at a time.

Ejemplo 1. bzread() Example

<?php
$bz = bzopen("/tmp/foo.bz2", "r");
$str = bzread($bz, 2048);
print( $str );
?>

See also bzwrite() and bzopen().

Anterior | Inicio | Siguiente
bzopen | Subir | bzwrite


bzwrite

(PHP 4 >= 4.0.4)

bzwrite -- Binary safe bzip2 file write

Description

int bzwrite ( resource bz, string data [, int length])

bzwrite() writes the contents of the string data to the bzip2 file stream pointed to by bz. If the optional length argument is given, writing will stop after length (uncompressed) bytes have been written or the end of string is reached, whichever comes first.

Ejemplo 1. bzwrite() Example

<?php
$str = "uncompressed data";
$bz = bzopen("/tmp/foo.bz2", "w");
bzwrite($bz, $str, strlen($str));
bzclose($bz);
?>

See also bzread() and bzopen().

Anterior | Inicio | Siguiente
bzread | Subir | Funciones de calendario


Funciones de calendario

Manual de PHP
Anterior Siguiente

VI. Funciones de calendario

Las funciones de calendario sólo están disponibles si ha compilado la extensión de calendario que hay en dl/calendar. Lea el documento dl/README como referencia de uso.

La extensión calendar presenta una serie de funciones para simplificar la conversión entre los distintos formatos de calendario. El intermediario estándar en que se basa es en la Cuenta de Días Juliana. La Cuenta de Días Juliana es una cuenta que comienza mucho antes que lo que mucha gente podría necesitar contar (como alrededor del 4000 AC). Para convertir entre sistemas de calendario, primero deberá convertir a la Cuenta de Días Juliana y luego al sistema de su elección. ¡La Cuenta de Días es muy diferente del Calendario Juliano! Para más información sobre sistemas de calendario, visite http://genealogy.org/~scottlee/cal-overview.html. En estas instrucciones se han incluído extractos entrecomillados de dicha página.

Tabla de contenidos
easter_date — devuelve la marca de tiempo UNIX para la medianoche de Pascua de un año dado
easter_days — obtiene el número de días tras el 21 de marzo en que cae la Pascua en un año dado
FrenchToJD — Convierte del Calendario Republicano Francés a la Cuenta de Días
GregorianToJD — Convierte de fecha Gregoriana a Cuenta de Días
JDDayOfWeek — Devuelve el día de la semana
JDMonthName — Devuelve el nombre de un mes
JDToFrench — Convierte de Cuenta de Días al Calendario Republicano Francés
JDToGregorian — Convierte de Cuenta de Días a fecha Gregoriana
JDToJewish — Convierte de Cuenta de Días a Calendario Judío
JDToJulian — Convierte de Cuenta de Días a Calendario Juliano
JewishToJD — Convierte del Calendario Judío a la Cuenta de Días
JulianToJD — Convierte de Calendario Juliano a Cuenta de Días

Anterior | Inicio | Siguiente
bzwrite | Subir | easter_date


JDToGregorian

(PHP 3, PHP 4 >= 4.0.0)

JDToGregorian -- Convierte de Cuenta de Días a fecha Gregoriana

Descripción

string jdtogregorian ( int diajuliano)

Convierte de Cuenta de Días Juliana a una cadena que contiene la fecha Gregoriana en formato "mes/día/año"

Anterior | Inicio | Siguiente
JDToFrench | Subir | JDToJewish


GregorianToJD

(PHP 3, PHP 4 >= 4.0.0)

GregorianToJD -- Convierte de fecha Gregoriana a Cuenta de Días

Descripción

int gregoriantojd ( int mes, int dia, int anno)

El rango válido para el Calendario Gregoriano es desde el 4714 A.C. hasta el 9999 D.C.

Aunque este programa puede manejar fechas tan lejanas como el 4714 A.C., usarlo no tendría sentido. El calendario Gregoriano fue instituído el 15 de octubre de 1582 (o el 5 de octubre de 1582 en el calendario Juliano). Algunos países no lo aceptaron hasta mucho después. Por ejemplo, Gran Bretaña se convirtió en 1752, la URSS en 1918 y Grecia en 1923. Muchos países europeos usaron el calendario Juliano antes que el Gregoriano.

Ejemplo 1. Funciones de calendario

<?php
$jd = GregorianToJD(10,11,1970);
echo("$jd\n");
$gregoriano = JDToGregorian($jd);
echo("$gregoriano\n");
?>

Anterior | Inicio | Siguiente
FrenchToJD | Subir | JDDayOfWeek


JDToJulian

(PHP 3, PHP 4 >= 4.0.0)

JDToJulian -- Convierte de Cuenta de Días a Calendario Juliano

Descripción

string jdtojulian ( int diajuliano)

Convierte una Cuenta de Días Juliana a una cadena que contiene la fecha del Calendario Juliano en formato "mes/día/año".

Anterior | Inicio | Siguiente
JDToJewish | Subir | JewishToJD


JulianToJD

(PHP 3, PHP 4 >= 4.0.0)

JulianToJD -- Convierte de Calendario Juliano a Cuenta de Días

Descripción

int juliantojd ( int mes, int dia, int anno)

Rango válido para el Calendario Juliano: del 4713 A.C al 9999 D.C.

Aunque este programa puede manejar fechas tan lejanas como el 4713 A.C., usarlo no tendría sentido. El calendario se creó en el 46 A.C., pero sus detalles no se estabilizaron hasta al menos el 8 D.C., y quizás no lo hiciera hasta el siglo IV. Además, el comienzo de un año variaba de una a otra cultura: no todas aceptaban enero como el primer mes.

Anterior | Inicio | Siguiente
JewishToJD | Subir | CCVS API Functions


JDToJewish

(PHP 3, PHP 4 >= 4.0.0)

JDToJewish -- Convierte de Cuenta de Días a Calendario Judío

Descripción

string jdtojewish ( int diajuliano)

Convierte una Cuenta de Días Juliana al Calendario Judío.

Anterior | Inicio | Siguiente
JDToGregorian | Subir | JDToJulian


JewishToJD

(PHP 3, PHP 4 >= 4.0.0)

JewishToJD -- Convierte del Calendario Judío a la Cuenta de Días

Descripción

int jewishtojd ( int mes, int dia, int anno)

El rango válido para el Calendario Judío va del año 1 hasta el 9999

Aunque este programa puede manejar fechas tan lejanas como el año 1 (3761 A.C.), usarlo no tendría sentido. El Calendario Judío ha estado en uso miles de años, pero en los días primeros no había una fórmula que calculara el comienzo de un mes. Un mes comenzaba cuando se veía por primera vez la luna nueva.

Anterior | Inicio | Siguiente
JDToJulian | Subir | JulianToJD


JDToFrench

(PHP 3, PHP 4 >= 4.0.0)

JDToFrench -- Convierte de Cuenta de Días al Calendario Republicano Francés

Descripción

string jdtofrench ( int diajuliano)

Convierte una Cuenta de Días Juliana al Calendario Republicano Francés.

Anterior | Inicio | Siguiente
JDMonthName | Subir | JDToGregorian


FrenchToJD

(PHP 3, PHP 4 >= 4.0.0)

FrenchToJD -- Convierte del Calendario Republicano Francés a la Cuenta de Días

Descripción

int frenchtojd ( int mes, int dia, int anno)

Convierte una fecha del Calendario Republicano Francés a la Cuenta de Días Juliana.

Estas rutinas sólo convierten fechas entre los años 1 y 14 (fechas Gregorianas del 22 de septiembre de 1792 al 22 de septiembre de 1806). Esto cubre ampliamente el periodo en el que estuvo en uso este calendario.

Anterior | Inicio | Siguiente
easter_days | Subir | GregorianToJD


JDMonthName

(PHP 3, PHP 4 >= 4.0.0)

JDMonthName -- Devuelve el nombre de un mes

Descripción

string jdmonthname ( int diajuliano, int modo)

Devuelve una cadena que contiene el nombre del mes. modo le dice a esta función a qué calendario debe convertir la Cuenta de Días Juliana, y qué tipo de nombres de mes debe devolver.

Tabla 1. Modos de calendario

Modo | Significado
0 | Gregoriano - abreviado
1 | Gregoriano
2 | Juliano - abreviado
3 | Juliano
4 | Judío
5 | Republicano Francés

Anterior | Inicio | Siguiente
JDDayOfWeek | Subir | JDToFrench


JDDayOfWeek

(PHP 3, PHP 4 >= 4.0.0)

JDDayOfWeek -- Devuelve el día de la semana

Descripción

mixed jddayofweek ( int diajuliano, int modo)

Devuelve el día de la semana. Dependiendo del modo, devuelve un entero o una cadena.

Tabla 1. Modos para el día de la semana

Modo | Significado
0 | devuelve el día de la semana como entero (0=domingo, 1=lunes, etc)
1 | devuelve una cadena con el día de la semana (inglés, gregoriano)
2 | devuelve una cadena con el día de la semana abreviado (inglés, gregoriano)

Anterior | Inicio | Siguiente
GregorianToJD | Subir | JDMonthName


easter_date

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

easter_date -- devuelve la marca de tiempo UNIX para la medianoche de Pascua de un año dado

Descripción

int easter_date ( int anno)

Devuelve la marca de tiempo UNIX que corresponde a la medianoche de Pascua del año dado. Si no se especifica un año, se asume el actual.

Aviso: Esta función generará un aviso si el año está fuera del rango para las marcas de tiempo del UNIX (es decir, antes de 1970 o después del 2037).

Ejemplo 1. ejemplo de easter_date()

echo date( "d-M-Y", easter_date(1999) );        /* "04-Apr-1999" */
echo date( "d-M-Y", easter_date(2000) );        /* "23-Apr-2000" */
echo date( "d-M-Y", easter_date(2001) );        /* "15-Apr-2001" */

La fecha del Día de Pascua fue definida por el Concilio de Nicea en el 325 D.C. como el domingo tras la primera luna llena que cayera en o después del equinoccio de Primavera. El equinoccio se supone que siempre cae en el 21 de marzo, de modo que el cálculo se reduce a determinar la fecha de la luna llena y la del domingo siguiente. El algoritmo usado aquí fue introducido en el año 532 por Dionisio Exiguo. Bajo el Calendario Juliano (para años anteriores al 1753), se usa un ciclo simple de 19 años para calcular las fases de la luna. Bajo el Calendario Gregoriano (años posteriores al 1753, diseñado por Clavio y Lilio, e introducido por el Papa Gregorio XIII en Octubre de 1582, y en Gran Bretaña y sus colonias en septiembre de 1752) se añaden dos factores de corrección para hacer el ciclo más preciso.

(El código se basa en un programa en C de Simon Kershaw, <webmaster@ely.anglican.org>)

Vea easter_days() para calcular la Pascua antes del 1970 o después del 2037.

Anterior | Inicio | Siguiente
Funciones de calendario | Subir | easter_days


easter_days

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

easter_days -- obtiene el número de días tras el 21 de marzo en que cae la Pascua en un año dado

Descripción

int easter_days ( int anno)

Devuelve el número de días tras el 21 de marzo en que cae la Pascua en un año dado. Si no se especifica año, se asume el actual.

Esta función se puede usar en lugar de easter_date() para calcular la Pascua para años que se salen del rango de las marcas de fecha del UNIX (o sea, antes del 1970 o después del 2037).

Ejemplo 1. ejemplo de easter_date()

echo easter_days(1999);        /* 14, es decir, 4  de abril */
echo easter_days(1492);        /* 32, es decir, 22 de abril  */
echo easter_days(1913);        /*  2, es decir, 23 de marzo */

La fecha del Día de Pascua fue definida por el Concilio de Nicea en el 325 D.C. como el domingo tras la primera luna llena que cayera en o después del equinoccio de Primavera. El equinoccio se supone que siempre cae en el 21 de marzo, de modo que el cálculo se reduce a determinar la fecha de la luna llena y la del domingo siguiente. El algoritmo usado aquí fue introducido en el año 532 por Dionisio Exiguo. Bajo el Calendario Juliano (para años anteriores al 1753), se usa un ciclo simple de 19 años para calcular las fases de la luna. Bajo el Calendario Gregoriano (años posteriores al 1753, diseñado por Clavio y Lilio, e introducido por el Papa Gregorio XIII en Octubre de 1582, y en Gran Bretaña y sus colonias en septiembre de 1752) se añaden dos factores de corrección para hacer el ciclo más preciso.

(El código se basa en un programa en C de Simon Kershaw, <webmaster@ely.anglican.org>)

Vea también easter_date().

Anterior | Inicio | Siguiente
easter_date | Subir | FrenchToJD


CCVS API Functions

Manual de PHP
Anterior Siguiente

VII. CCVS API Functions

These functions interface the CCVS API, allowing you to directly work with CCVS from your PHP scripts. CCVS is RedHat's solution to the "middle-man" in credit card processing. It lets you directly address the credit card clearing houses via your *nix box and a modem. Using the CCVS module for PHP, you can process credit cards directly through CCVS via your PHP Scripts. The following references will outline the process.

To enable CCVS Support in PHP, first verify your CCVS installation directory. You will then need to configure PHP with the --with-ccvs option. If you use this option without specifying the path to your CCVS installation, PHP Will attempt to look in the default CCVS Install location (/usr/local/ccvs). If CCVS is in a non-standard location, run configure with: --with-ccvs=$ccvs_path, where $ccvs_path is the path to your CCVS installation. Please note that CCVS support requires that $ccvs_path/lib and $ccvs_path/include exist, and include cv_api.h under the include directory and libccvs.a under the lib directory.

Additionally, a ccvsd process will need to be running for the configurations you intend to use in your PHP scripts. You will also need to make sure the PHP Processes are running under the same user as your CCVS was installed as (e.g. if you installed CCVS as user 'ccvs', your PHP processes must run as 'ccvs' as well.)

Additional information about CCVS can be found at http://www.redhat.com/products/ccvs.

This documentation section is being worked on. Until then, RedHat maintains slightly outdated but still useful documentation at http://www.redhat.com/products/ccvs/support/CCVS3.3docs/ProgPHP.html.

Update: CCVS has been discontinued by Red Hat and there are no plans to issue further keys or support contracts. Those looking for a replacement can consider MCVE by Main Street Softworks as a potential replacement. It is similar in design and has documented PHP support!

Tabla de contenidos
ccvs_init — Initialize CCVS for use
ccvs_done — Terminate CCVS engine and do cleanup work
ccvs_new — Create a new, blank transaction
ccvs_add — Add data to a transaction
ccvs_delete — Delete a transaction
ccvs_auth — Perform credit authorization test on a transaction
ccvs_return — Transfer funds from the merchant to the credit card holder
ccvs_reverse — Perform a full reversal on an already-processed authorization
ccvs_sale — Transfer funds from the credit card holder to the merchant
ccvs_void — Perform a full reversal on a completed transaction
ccvs_status — Check the status of an invoice
ccvs_count — Find out how many transactions of a given type are stored in the system
ccvs_lookup — Look up an item of a particular type in the database #
ccvs_report — Return the status of the background communication process
ccvs_command — Performs a command which is peculiar to a single protocol, and thus is not available in the general CCVS API
ccvs_textvalue — Get text return value for previous function call

Anterior | Inicio | Siguiente
JulianToJD | Subir | ccvs_init


ccvs_init

(PHP 4 >= 4.0.2)

ccvs_init -- Initialize CCVS for use

Description

string ccvs_init ( string name)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
CCVS API Functions | Subir | ccvs_done


ccvs_done

(PHP 4 >= 4.0.2)

ccvs_done -- Terminate CCVS engine and do cleanup work

Description

string ccvs_done ( string sess)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_init | Subir | ccvs_new


ccvs_new

(PHP 4 >= 4.0.2)

ccvs_new -- Create a new, blank transaction

Description

string ccvs_new ( string session, string invoice)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_done | Subir | ccvs_add


ccvs_add

(PHP 4 >= 4.0.2)

ccvs_add -- Add data to a transaction

Description

string ccvs_add ( string session, string invoice, string argtype, string argval)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_new | Subir | ccvs_delete


ccvs_delete

(PHP 4 >= 4.0.2)

ccvs_delete -- Delete a transaction

Description

string ccvs_delete ( string session, string invoice)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_add | Subir | ccvs_auth


ccvs_auth

(PHP 4 >= 4.0.2)

ccvs_auth -- Perform credit authorization test on a transaction

Description

string ccvs_auth ( string session, string invoice)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_delete | Subir | ccvs_return


ccvs_return

(PHP 4 >= 4.0.2)

ccvs_return -- Transfer funds from the merchant to the credit card holder

Description

string ccvs_return ( string session, string invoice)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_auth | Subir | ccvs_reverse


ccvs_reverse

(PHP 4 >= 4.0.2)

ccvs_reverse -- Perform a full reversal on an already-processed authorization

Description

string ccvs_reverse ( string session, string invoice)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_return | Subir | ccvs_sale


ccvs_sale

(PHP 4 >= 4.0.2)

ccvs_sale -- Transfer funds from the credit card holder to the merchant

Description

string ccvs_sale ( string session, string invoice)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_reverse | Subir | ccvs_void


ccvs_void

(PHP 4 >= 4.0.2)

ccvs_void -- Perform a full reversal on a completed transaction

Description

string ccvs_void ( string session, string invoice)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_sale | Subir | ccvs_status


ccvs_status

(PHP 4 >= 4.0.2)

ccvs_status -- Check the status of an invoice

Description

string ccvs_status ( string session, string invoice)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_void | Subir | ccvs_count


ccvs_count

(PHP 4 >= 4.0.2)

ccvs_count -- Find out how many transactions of a given type are stored in the system

Description

int ccvs_count ( string session, string type)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_status | Subir | ccvs_lookup


ccvs_lookup

(PHP 4 >= 4.0.2)

ccvs_lookup -- Look up an item of a particular type in the database #

Description

string ccvs_lookup ( string session, string invoice, int inum)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_count | Subir | ccvs_report


ccvs_report

(PHP 4 >= 4.0.2)

ccvs_report -- Return the status of the background communication process

Description

string ccvs_report ( string session, string type)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_lookup | Subir | ccvs_command


ccvs_command

(PHP 4 >= 4.0.2)

ccvs_command -- Performs a command which is peculiar to a single protocol, and thus is not available in the general CCVS API

Description

string ccvs_command ( string session, string type, string argval)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_report | Subir | ccvs_textvalue


ccvs_textvalue

(PHP 4 >= 4.0.2)

ccvs_textvalue -- Get text return value for previous function call

Description

string ccvs_textvalue ( string session)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ccvs_command | Subir | soporte de las funciones COM para Windows


soporte de las funciones COM para Windows

Manual de PHP
Anterior Siguiente

VIII. soporte de las funciones COM para Windows

Estas funciones solo están disponibles en la versión para Windows de PHP. Estas funciones han sido añadidas en PHP4.

Tabla de contenidos
com_get — ???
com_invoke — ???
com_load — ???
com_propget — ???
com_propput — ???
com_propset — ???
com_set — ???

Anterior | Inicio | Siguiente
ccvs_textvalue | Subir | com_get


com_load

(PHP 3>= 3.0.3)

com_load -- ???

Descripción

string com_load ( string module name [, string server name])

Anterior | Inicio | Siguiente
com_invoke | Subir | com_propget


com_invoke

(PHP 3>= 3.0.3)

com_invoke -- ???

Descripción

mixed com_invoke ( resource object, string function_name [, mixed function parameters, ...])

Anterior | Inicio | Siguiente
com_get | Subir | com_load


com_propget

(PHP 3>= 3.0.3, PHP 4 >= 4.0.5)

com_propget -- ???

Descripción

mixed com_propget ( resource object, string property)

Anterior | Inicio | Siguiente
com_load | Subir | com_propput


com_get

(PHP 3>= 3.0.3, PHP 4 >= 4.0.5)

com_get -- ???

Descripción

mixed com_get ( resource object, string property)

Anterior | Inicio | Siguiente
soporte de las funciones COM para Windows | Subir | com_invoke


com_propput

(PHP 3>= 3.0.3, PHP 4 >= 4.0.5)

com_propput -- ???

Descripción

void com_propput ( resource object, string property, mixed value)

Anterior | Inicio | Siguiente
com_propget | Subir | com_propset


com_propset

(PHP 3>= 3.0.3, PHP 4 >= 4.0.5)

com_propset -- ???

Descripción

void com_propset ( resource object, string property, mixed value)

Esta función es un alias para com_propput().

Anterior | Inicio | Siguiente
com_propput | Subir | com_set


com_set

(PHP 3>= 3.0.3, PHP 4 >= 4.0.5)

com_set -- ???

Descripción

void com_set ( resource object, string property, mixed value)

Esta función es un alias para com_set().

Anterior | Inicio | Siguiente
com_propset | Subir | Funciones de Clases/Objectos


Funciones de Clases/Objectos

Manual de PHP
Anterior Siguiente

IX. Funciones de Clases/Objectos

Tabla de contenidos
get_class_methods — Devuelve un vector (matriz unidimensional) con los nombres de los métodos de la clase en question.
get_class_vars — Devuelve un vector con las propiedades (inicializadas por defecto) de la clase
get_object_vars — Devuelve un vector de propiedades del objecto
method_exists — Comprueba que el metódo de clase existe

Anterior | Inicio | Siguiente
com_set | Subir | get_class_methods


get_class_methods

(PHP 4 >= 4.0.0)

get_class_methods -- Devuelve un vector (matriz unidimensional) con los nombres de los métodos de la clase en question.

Descripción

vector get_class_methods ( string class_name)

Esta función devuelve un vector con los nombres de los métodos definidos en la clase especificada como class_name.

Anterior | Inicio | Siguiente
Funciones de Clases/Objectos | Subir | get_class_vars


get_class_vars

(PHP 4 >= 4.0.0)

get_class_vars -- Devuelve un vector con las propiedades (inicializadas por defecto) de la clase

Descripción

array get_class_vars ( string class_name)

Esta función devuelve un vector con las propiedades que han sido inicializadas por defecto en la clase.

Anterior | Inicio | Siguiente
get_class_methods | Subir | get_object_vars


get_object_vars

(PHP 4 >= 4.0.0)

get_object_vars -- Devuelve un vector de propiedades del objecto

Descripción

array get_class_vars ( object obj)

Esta función devuelve un vector con las propiedades de objecto definidas en el objecto especificado como obj.

Anterior | Inicio | Siguiente
get_class_vars | Subir | method_exists


method_exists

(PHP 4 >= 4.0.0)

method_exists -- Comprueba que el metódo de clase existe

Descripción

bool method_exists ( object object, string method_name)

Esta función devuelve verdadero si el metódo referido por method_name ha sido definido en el objecto object, en cualquier otro case devuelve falso

Anterior | Inicio | Siguiente
get_object_vars | Subir | Funciones de ClibPDF


Funciones de ClibPDF

Manual de PHP
Anterior Siguiente

X. Funciones de ClibPDF

ClibPDF Le permite crear documentos PDF con PHP. Está disponible en FastIO pero no es software libre. Debería leer la licencia antes de comenzar a utilizar ClibPDF. Si usted no puede cumplir el acuerdo de la licencia considere el utilizar la pdflib de Thomas Merz, que tambien es muy potente. La funcionalidad y la API de ClibPDF son similares a la pdflib de Thomas Merz pero, de acuerdo con FastIO, ClibPDF es mas rápida y crea documentos mas pequeños. Esto puede haber cambiado con la nueva versión 2.0 de pdflib. Un simple banco de pruebas (el ejemplo pdfclock.c de pdflib 2.0 trasformado en un script php) en realidad no muestra ninguna diferencia en velocidad. Por tanto, pruebe las dos y vea cual hace el mejor trabajo para usted.

Esta documentación debería ser leída junto con el manual de ClibPDF ya que este explica la librería con mucho mas detalle.

Muchas funciones en le ClibPDF nativa y el módulo PHP, así como en pdflib, tienen el mismo nombre. Todas las funciones excepto cpdf_open() toman el manejador del documento com el primer parámetro. Actualmente este manejador no se usa internamente desde que ClibPDF no soporta la creación de varios documentos PDF al mismo tiempo. Realmente, ni debería intentarlo, los resultados son impredecibles. No puedo supervisar cuales son las consecuencias en un sistema multihilo. De acuerdo con el autor de ClibPDF, esto cambiará en alguno de las próximas veriones (la versión actual, cuando eto fue escrito es 1.10). Si usted necesita esta capacidad, use el módulo pdflib.

Nota: La función cpdf_set_font() ha cambiado desde que PHP3 soporta fuentes asiáticas. El parámetro que codifica ya no es un entero sino una cadena.

Una gran ventaja de ClibPDF sobre pdflib es la posibilidad de crear el documento PDF completamente en memoria sin usar ficheros temporales. Esto también proporciona la capaciad de pasar coordenadas en una unidad de longitud predefinida. Esta es una cualidad útil pero puede ser simulada con pdf_translate().

La mayoría de las funciones son fáciles de usar. La parte mas difícil es, probablemente, crear un documento PDF muy simple. El siguiente ejemplo debería ayudarle a comenzar. En él se crea un documento con una página. La página contiene el texto "Times-Roman" con una fuente de 30pt. El texto está subrayado.

Ejemplo 1. Ejemplo simple de ClibPDF

<?php
$cpdf = cpdf_open(0);
cpdf_page_init($cpdf, 1, 0, 595, 842);
cpdf_add_outline($cpdf, 0, 0, 0, 1, "Page 1");
cpdf_set_font($cpdf, "Times-Roman", 30, "WinAnsiEncoding");
cpdf_set_text_rendering($cpdf, 1);
cpdf_text($cpdf, "Times Roman outlined", 50, 750);
cpdf_moveto($cpdf, 50, 740);
cpdf_lineto($cpdf, 330, 740);
cpdf_stroke($cpdf);
cpdf_finalize($cpdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($cpdf);
cpdf_close($cpdf);
?>

La distribución de pdflib contiene un ejemplo mas comlejo que crea una serie de páginas con un reloj analógico. Aquí está ese ejemplo convertido en PHP usando la extensión ClibPDF:

Ejemplo 2. Ejemplo con pdfclock de la distribución pdflib 2.0

<?php
$radius = 200;
$margin = 20;
$pagecount = 40;

$pdf = cpdf_open(0);
cpdf_set_creator($pdf, "pdf_clock.php3");
cpdf_set_title($pdf, "Reloj Analógico");

while($pagecount-- > 0) {
  cpdf_page_init($pdf, $pagecount+1, 0, 2 * ($radius + $margin), 2 * ($radius + $margin), 1.0);

  cpdf_set_page_animation($pdf, 4, 0.5, 0, 0, 0);  /* limpiar */

  cpdf_translate($pdf, $radius + $margin, $radius + $margin);
  cpdf_save($pdf);
  cpdf_setrgbcolor($pdf, 0.0, 0.0, 1.0);

  /*  cambio de minuto */
  cpdf_setlinewidth($pdf, 2.0);
  for ($alpha = 0; $alpha < 360; $alpha += 6)
    {
    cpdf_rotate($pdf, 6.0);
    cpdf_moveto($pdf, $radius, 0.0);
    cpdf_lineto($pdf, $radius-$margin/3, 0.0);
    cpdf_stroke($pdf);
    }

  cpdf_restore($pdf);
  cpdf_save($pdf);

  /* cambios de 5 minutos */
  cpdf_setlinewidth($pdf, 3.0);
  for ($alpha = 0; $alpha < 360; $alpha += 30)
  {
    cpdf_rotate($pdf, 30.0);
    cpdf_moveto($pdf, $radius, 0.0);
    cpdf_lineto($pdf, $radius-$margin, 0.0);
    cpdf_stroke($pdf);
  }

  $ltime = getdate();

  /* dibujar la aguja de las horas */
  cpdf_save($pdf);
  cpdf_rotate($pdf, -(($ltime['minutos']/60.0) + $ltime['horas'] - 3.0) * 30.0);
  cpdf_moveto($pdf, -$radius/10, -$radius/20);
  cpdf_lineto($pdf, $radius/2, 0.0);
  cpdf_lineto($pdf, -$radius/10, $radius/20);
  cpdf_closepath($pdf);
  cpdf_fill($pdf);
  cpdf_restore($pdf);

  /* dibujar el minutero */
  cpdf_save($pdf);
  cpdf_rotate($pdf, -(($ltime['segundos']/60.0) + $ltime['minutos'] - 15.0) * 6.0);
  cpdf_moveto($pdf, -$radius/10, -$radius/20);
  cpdf_lineto($pdf, $radius * 0.8, 0.0);
  cpdf_lineto($pdf, -$radius/10, $radius/20);
  cpdf_closepath($pdf);
  cpdf_fill($pdf);
  cpdf_restore($pdf);

  /* dibujar la seguna mano */
  cpdf_setrgbcolor($pdf, 1.0, 0.0, 0.0);
  cpdf_setlinewidth($pdf, 2);
  cpdf_save($pdf);
  cpdf_rotate($pdf, -(($ltime['segundos'] - 15.0) * 6.0));
  cpdf_moveto($pdf, -$radius/5, 0.0);
  cpdf_lineto($pdf, $radius, 0.0);
  cpdf_stroke($pdf);
  cpdf_restore($pdf);

  /* dibujar un pequeño círculo en el centro */
  cpdf_circle($pdf, 0, 0, $radius/30);
  cpdf_fill($pdf);

  cpdf_restore($pdf);

  cpdf_finalize_page($pdf, $pagecount+1);
}

cpdf_finalize($pdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($pdf);
cpdf_close($pdf);
?>
Tabla de contenidos
cpdf_add_annotation — Añade una anotación
cpdf_add_outline — Añade una marca en la página actual
cpdf_arc — Dibuja un arco
cpdf_begin_text — Inicializa una sección de texto
cpdf_circle — Dibuja un círculo
cpdf_clip — Ajusta al camino actual
cpdf_close — Cierra un documento PDF
cpdf_closepath — Cierra el camino
cpdf_closepath_fill_stroke — Cierra, llena y traza el camino actual
cpdf_closepath_stroke — Cierra el camino y dibuja una línea a lo largo del camino
cpdf_continue_text — Pone texto en la línea siguiente
cpdf_curveto — Dibuja una curva
cpdf_end_text — Finaliza una sección de texto
cpdf_fill — LLena el camino actual
cpdf_fill_stroke — LLena y traza el camino actual
cpdf_finalize — Finaliza un documento
cpdf_finalize_page — Finaliza una página
cpdf_global_set_document_limits — Sets document limits for any pdf document
cpdf_import_jpeg — Abre una imagen JPEG
cpdf_lineto — Dibuja una línea
cpdf_moveto — Define el punto actual
cpdf_open — Abre un nuevo documento PDF
cpdf_output_buffer — Pone el documento PDF en el buffer de memoria
cpdf_page_init — Comienza una nueva página
cpdf_place_inline_image — Situa una imagen en la página
cpdf_rect — Dibuja un rectángulo
cpdf_restore — Restaura un entorno formalmente salvado
cpdf_rlineto — Dibuja una línea
cpdf_rmoveto — Define el punto actual
cpdf_rotate — Define la rotación
cpdf_save — Salva el entorno actual
cpdf_save_to_file — Escribe el documento PDF en un fichero
cpdf_scale — Define la escala
cpdf_set_char_spacing — Determina el espacio entre caracteres
cpdf_set_creator — Define el campo creator en el documento PDF
cpdf_set_current_page — Define la página actual
cpdf_set_font — Selecciona la fuente y el tamaño actual
cpdf_set_horiz_scaling — Define la escala horizontal del texto
cpdf_set_keywords — Pone el valor del campo 'keywords'(palabras clave) de un documento PDF
cpdf_set_leading — Define la distancias entre las líneas de texto
cpdf_set_page_animation — Define la separación entre páginas
cpdf_set_subject — Define el valor del campo subjet de un documento PDF
cpdf_set_text_matrix — Define la matriz de texto
cpdf_set_text_pos — Define la posición del texto
cpdf_set_text_rendering — Determina cómo es presentado el texto
cpdf_set_text_rise — Define la elevación del texto
cpdf_set_title — Define el campo title de un documento PDF
cpdf_set_word_spacing — Define el espacio entre palabras
cpdf_setdash — Defina el patrón de la raya
cpdf_setflat — Define la monotonía
cpdf_setgray — Pone el color de relleno y dibujo a gris
cpdf_setgray_fill — Pone el color de relleno al valor gris
cpdf_setgray_stroke — Define el color para dibujar al valor gris
cpdf_setlinecap — Define el parámetro linecap
cpdf_setlinejoin — Define el parámetro linejoin
cpdf_setlinewidth — Define la profundidad de la línea
cpdf_setmiterlimit — Define el límite del inglete
cpdf_setrgbcolor — Pone el color de relleno y dibujo al valor de color rgb
cpdf_setrgbcolor_fill — Pone el color de relleno a l valor de clor rgb
cpdf_setrgbcolor_stroke — Pone el color de dibujo al valor de color rgb
cpdf_show — Muestra el texto en la posición actual
cpdf_show_xy — Muestra texto en la posición
cpdf_stringwidth — Devuelve la anchura del texto en la fuente actual
cpdf_stroke — Dibuja una línea a lo largo del camino
cpdf_text — Muestra texto conparámetros
cpdf_translate — Define el sistema de origen de coordenadas

Anterior | Inicio | Siguiente
method_exists | Subir | cpdf_add_annotation


cpdf_global_set_document_limits

(PHP 4 >= 4.0.0)

cpdf_global_set_document_limits -- Sets document limits for any pdf document

Description

void cpdf_global_set_document_limits ( int maxpages, int maxfonts, int maximages, int maxannotations, int maxobjects)

La función cpdf_global_set_document_limits() define varios límites del documento. Esta función debe ser llamada antes de cpdf_open() para que haga efecto. Ello define los límites de cualquier documento abierto con anterioridad.

Vea también cpdf_open().

Anterior | Inicio | Siguiente
cpdf_finalize_page | Subir | cpdf_import_jpeg


cpdf_set_creator

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_creator -- Define el campo creator en el documento PDF

Descripción

void cpdf_set_creator ( string creator)

La función cpdf_set_creator() define el creador de un documento PDF.

Vea también cpdf_set_subject(),
            cpdf_set_title(),
            cpdf_set_keywords().

Anterior | Inicio | Siguiente
cpdf_set_char_spacing | Subir | cpdf_set_current_page


cpdf_set_title

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_title -- Define el campo title de un documento PDF

Descripción

void cpdf_set_title ( string title)

La función cpdf_set_title() define el título de un documento PDF

Vea también cpdf_set_subject(),
            cpdf_set_creator(),
            cpdf_set_keywords().

Anterior | Inicio | Siguiente
cpdf_set_text_rise | Subir | cpdf_set_word_spacing


cpdf_set_subject

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_subject -- Define el valor del campo subjet de un documento PDF

Descripción

void cpdf_set_subject ( string subject)

La función cpdf_set_subject() define el asunto de un documento PDF

Vea también cpdf_set_title(),
            cpdf_set_creator(),
            cpdf_set_keywords().

Anterior | Inicio | Siguiente
cpdf_set_page_animation | Subir | cpdf_set_text_matrix


cpdf_set_keywords

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_keywords -- Pone el valor del campo 'keywords'(palabras clave) de un documento PDF

Descripción

void cpdf_set_keywords ( string keywords)

La función cpdf_set_keywords() define las palabras clave de un documento PDF.

Vea también cpdf_set_title(),
         cpdf_set_creator(),
         cpdf_set_subject().

Anterior | Inicio | Siguiente
cpdf_set_horiz_scaling | Subir | cpdf_set_leading


cpdf_open

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_open -- Abre un nuevo documento PDF

Descripción

int cpdf_open ( int compression, string filename)

LA función cpdf_open() abre un documento PDF nuevo. El primer parámetro activa la compresión del documento si no es igual a 0. El segundo parámetro, opcional, es el fichero en el que el documento es escrito. Si es omitido, el documento es creado en memoria y puede ser escrito en un fichero mediante la función cpdf_save_to_file() o escrito por la salida estándar con cpdf_output_buffer().

Nota: El valor de retorno será necesario en nuevas versiones de ClibPDF como el primer parámetro en todas las demás funciones que escriben en el documento PDF.

La librería ClibPDF toma el nombre de fichero "-" como sinónimo de stdout (salida estándar). Si se compila PHP como módulo de apache esto no funcionará porque la manera en que ClibPDF direcciona a la salida estándar no funciona con apache. Usted puede solucionar este problema evitando el enobre de fichero y usando cpdf_output_buffer() para la salida de documentos PDF.

Vea también cpdf_close(), cpdf_output_buffer().

Anterior | Inicio | Siguiente
cpdf_moveto | Subir | cpdf_output_buffer


cpdf_close

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_close -- Cierra un documento PDF

Descripción

void cpdf_close ( int pdf document)

La función cpdf_close() cierra un documento PDF. Esta debería ser la última operación incluso después de cpdf_finalize(), cpdf_output_buffer() y cpdf_save_to_file().

Vea también cpdf_open().

Anterior | Inicio | Siguiente
cpdf_clip | Subir | cpdf_closepath


cpdf_page_init

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_page_init -- Comienza una nueva página

Descripción

void cpdf_page_init ( int pdf document, int page number, int orientation, double height, double width, double unit)

La función cpdf_page_init() crea una nueva página de altura height y profundidad width. La página tiene el número page number y orientación orientation. orientation puede ser 0 para retrato y 1 para paisaje. El último parámetro opcional unit define la unidad del sistema de coordenadas. El valor debería ser el número de puntos postscript por unidad. Como el valor de una pulgada el igual a 72 puntos, un valor de 72 sería la unidad para una pulgada. Por defecto es 72.

Vea también cpdf_set_current_page().

Anterior | Inicio | Siguiente
cpdf_output_buffer | Subir | cpdf_place_inline_image


cpdf_finalize_page

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

cpdf_finalize_page -- Finaliza una página

Descripción

void cpdf_finalize_page ( int pdf document, int page number)

La función cpdf_finalize_page() finaliza una página con número de página page number. Esta función es sólo para ahorrar memoria. Una página terminada ocupa menos memoria pero no puede volver a ser modificada.

Vea también cpdf_page_init().

Anterior | Inicio | Siguiente
cpdf_finalize | Subir | cpdf_global_set_document_limits


cpdf_finalize

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_finalize -- Finaliza un documento

Descripción

void cpdf_finalize ( int pdf document)

La función cpdf_finalize() finaliza un documento. Aún se tiene que llamar a cpdf_close().

Vea también cpdf_close().

Anterior | Inicio | Siguiente
cpdf_fill_stroke | Subir | cpdf_finalize_page


cpdf_output_buffer

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

cpdf_output_buffer -- Pone el documento PDF en el buffer de memoria

Descripción

void cpdf_output_buffer ( int pdf document)

La función cpdf_output_buffer() muestra el documento PDF por la salida estándar. El documento debe ser creado en memoria, que es el caso de la función cpdf_open() cuando ha sido llamada sin parámetros.

Vea también cpdf_open().

Anterior | Inicio | Siguiente
cpdf_open | Subir | cpdf_page_init


cpdf_save_to_file

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_save_to_file -- Escribe el documento PDF en un fichero

Descripción

void cpdf_save_to_file ( int pdf document, string filename)

La función cpdf_save_to_file() guarda el documento PDF en un fichero si este documeto ha sido creado en memoria. Esta función no es necesaria si el documento PDF ha sido abierto mediante la especificación de un nombre de fichero en la función cpdf_open().

Vea también cpdf_output_buffer(), cpdf_open().

Anterior | Inicio | Siguiente
cpdf_save | Subir | cpdf_scale


cpdf_set_current_page

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

cpdf_set_current_page -- Define la página actual

Descripción

void cpdf_set_current_page ( int pdf document, int page number)

La función cpdf_set_current_page() define la página en la que se van a realizar todas las operaciones. Uno puede cambiar entre páginas a menos que una página ha sido finalizada con cpdf_finalize_page().

Vea también cpdf_finalize_page().

Anterior | Inicio | Siguiente
cpdf_set_creator | Subir | cpdf_set_font


cpdf_begin_text

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_begin_text -- Inicializa una sección de texto

Descripción

void cpdf_begin_text ( int pdf document)

La función cpdf_begin_text() comienza una sección de texto. Debe ser terminada con cpdf_end_text().

Ejemplo 1. Salida de texto

<?php cpdf_begin_text($pdf);
cpdf_set_font($pdf, 16, "Helvetica", "WinAnsiEncoding");
cpdf_text($pdf, 100, 100, "Algún texto");
cpdf_end_text($pdf) ?>

Vea también cpdf_end_text().

Anterior | Inicio | Siguiente
cpdf_arc | Subir | cpdf_circle


cpdf_end_text

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_end_text -- Finaliza una sección de texto

Descripción

void cpdf_end_text ( int pdf document)

La función cpdf_end_text() finaliza unasección de texto que fue inicializada con cpdf_begin_text().

Ejemplo 1. Salida de texto

<?php cpdf_begin_text($pdf);
cpdf_set_font($pdf, 16, "Helvetica", "WinAnsiEncoding");
cpdf_text($pdf, 100, 100, "Algún texto");
cpdf_end_text($pdf) ?>

Vea también cpdf_begin_text().

Anterior | Inicio | Siguiente
cpdf_curveto | Subir | cpdf_fill


cpdf_show

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_show -- Muestra el texto en la posición actual

Descripción

void cpdf_show ( int pdf document, string text)

La función cpdf_show() muestra la cadena text en la posixción actual.

Vea también cpdf_text(),
            cpdf_begin_text(),
            cpdf_end_text().

Anterior | Inicio | Siguiente
cpdf_setrgbcolor_stroke | Subir | cpdf_show_xy


cpdf_show_xy

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_show_xy -- Muestra texto en la posición

Descripción

void cpdf_show_xy ( int pdf document, string text, double x-koor, double y-koor, int mode)

La función cpdf_show_xy() muestra la cadena text en la posición con coordenadas (x-coor, y-coor). El último parámetro opcional determina la longitud de la unidad. Si es 0 o se omite, se usa la unidad por defecto especificada para la página. De otro modo las coordenadas son medidas en puntos postscript, despreciando la unidad actual.

Nota: La función cpdf_show_xy() es idéntica a cpdf_text() sin el parámetro opcional.

Vea también cpdf_text().

Anterior | Inicio | Siguiente
cpdf_show | Subir | cpdf_stringwidth


cpdf_text

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_text -- Muestra texto conparámetros

Descripción

void cpdf_text ( int pdf document, string text, double x-koor, double y-koor, int mode, double orientation, int alignmode)

La función cpdf_text() muestra la cadena text en la posición de coordenadas (x-coor, y-coor). El parámero opcional determina la longitud de la unidad. Si es 0 o se omite, se usa la unidad por defecto especificada para la página. De otro modo las coordenadas son medidas en puntos postscript despreciando la unidad actual. El parámetro opcional orientation es la rotación del texto en grados. El parámetro opcional alignmode determina cómo está alineado el texto. Vea la documentación de ClibPDF para los posibles valores.

Vea también cpdf_show_xy().

Anterior | Inicio | Siguiente
cpdf_stroke | Subir | cpdf_translate


cpdf_set_font

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_font -- Selecciona la fuente y el tamaño actual

Descripción

void cpdf_set_font ( int pdf document, string font name, double size, string encoding)

La función cpdf_set_font() define la fuente actual, el tamaño y la codificación. Actualmente solo son soportadas las fuentes estándar de postscript. El último parámetro encoding puede tomar los siguientes valores: "MacRomanEncoding", "MacExpertEncoding", "WinAnsiEncoding", y "NULL". "NULL" es para el cifrado incluído en la fuente. Para mas información vea el manual de ClibPDF, especialmente para cómo soportar las fuentes asiáticas.

Anterior | Inicio | Siguiente
cpdf_set_current_page | Subir | cpdf_set_horiz_scaling


cpdf_set_leading

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_leading -- Define la distancias entre las líneas de texto

Descripción

void cpdf_set leading ( int pdf document, double distance)

La función cpdf_set_leading() define la distancia entre las líneas de texto. Esto se usará si el texto es la salida de cpdf_continue_text().

Vea también cpdf_continue_text().

Anterior | Inicio | Siguiente
cpdf_set_keywords | Subir | cpdf_set_page_animation


cpdf_set_text_rendering

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_text_rendering -- Determina cómo es presentado el texto

Descripción

void cpdf_set_text_rendering ( int pdf document, int mode)

La función cpdf_set_text_rendering() determina cómo es presentado el texto. Los posibles valores para mode son 0=llenar texto, 1=poner texto, 2=llenar y poner texto, 3=invisible, 4=llenar texto y añadirlo al camino de corte, 5=poner texto y añadirlo al camino de corte, 6=llenar y poner texto y añadirlo al camino de corte, 7=añadirlo al camino de corte

Anterior | Inicio | Siguiente
cpdf_set_text_pos | Subir | cpdf_set_text_rise


cpdf_set_horiz_scaling

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_horiz_scaling -- Define la escala horizontal del texto

Descripción

void cpdf_set_horiz_scaling ( int pdf document, double scale)

La función cpdf_set_horiz_scaling() define la escala horizontal al scale por ciento.

Anterior | Inicio | Siguiente
cpdf_set_font | Subir | cpdf_set_keywords


cpdf_set_text_rise

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_text_rise -- Define la elevación del texto

Descripción

void cpdf_set_text_rise ( int pdf document, double value)

La función cpdf_set_text_rise() define la elevación del texto a value unidades.

Anterior | Inicio | Siguiente
cpdf_set_text_rendering | Subir | cpdf_set_title


cpdf_set_text_matrix

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_text_matrix -- Define la matriz de texto

Descripción

void cpdf_set_text_matrix ( int pdf document, array matrix)

La función cpdf_set_text_matrix() define una matriz que describe una transformación aplicada a la fuente actual de texto.

Anterior | Inicio | Siguiente
cpdf_set_subject | Subir | cpdf_set_text_pos


cpdf_set_text_pos

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_text_pos -- Define la posición del texto

Descripción

void cpdf_set_text_pos ( int pdf document, double x-koor, double y-koor, int mode)

La función cpdf_set_text_pos() define la posición del texto para la siguiente llamada a cpdf_show().

El último parámetro opcional mode determina la longitud de la unidad. Si es 0 o se omite, se usa el valor por defecto para la página. De otro modo, las coordenadas son medidas en puntos postscript, despreciando la unidad actual.

Vea también cpdf_show(), cpdf_text().

Anterior | Inicio | Siguiente
cpdf_set_text_matrix | Subir | cpdf_set_text_rendering


cpdf_set_char_spacing

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_char_spacing -- Determina el espacio entre caracteres

Descripción

void cpdf_set_char_spacing ( int pdf document, double space)

LA función cpdf_set_char_spacing() define el espacio entre caracteres.

Vea también cpdf_set_word_spacing(), cpdf_set_leading().

Anterior | Inicio | Siguiente
cpdf_scale | Subir | cpdf_set_creator


cpdf_set_word_spacing

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_set_word_spacing -- Define el espacio entre palabras

Descripción

void cpdf_set_word_spacing ( int pdf document, double space)

La función cpdf_set_word_spacing() especifica el espacio entre palabras.

Vea también cpdf_set_char_spacing(), cpdf_set_leading().

Anterior | Inicio | Siguiente
cpdf_set_title | Subir | cpdf_setdash


cpdf_continue_text

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_continue_text -- Pone texto en la línea siguiente

Descripción

void cpdf_continue_text ( int pdf document, string text)

La función cpdf_continue_text() pone la cadena text en la línea siguiente.

Vea también cpdf_show_xy(),
            cpdf_text(),
            cpdf_set_leading(),
            cpdf_set_text_pos().

Anterior | Inicio | Siguiente
cpdf_closepath_stroke | Subir | cpdf_curveto


cpdf_stringwidth

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_stringwidth -- Devuelve la anchura del texto en la fuente actual

Descripción

double cpdf_stringwidth ( int pdf document, string text)

La función cpdf_stringwidth() devuelve la anchura de la cadena text. Requiere haber definido antes una fuente.

Vea también cpdf_set_font().

Anterior | Inicio | Siguiente
cpdf_show_xy | Subir | cpdf_stroke


cpdf_save

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_save -- Salva el entorno actual

Descripción

void cpdf_save ( int pdf document)

La función cpdf_save() salva el entorno actual. Funciona como el comando gsave de postscript. Muy útil si se quiere trasladar o trotar un objeto sin afetar a los demás.

Vea también cpdf_restore().

Anterior | Inicio | Siguiente
cpdf_rotate | Subir | cpdf_save_to_file


cpdf_restore

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_restore -- Restaura un entorno formalmente salvado

Descripción

void cpdf_restore ( int pdf document)

La función cpdf_restore() restaura el entorno salvado con cpdf_save(). Funciona como el comando grestore de postscript. Muy útil si se quiere trasladar o rotar un objeto sin afectar ortros objetos.

Ejemplo 1. Salvar/Restaurar

<?php cpdf_save($pdf);
// hacer todo tipo de rotaciones, transformaciones, ...
cpdf_restore($pdf) ?>

Vea también cpdf_save().

Anterior | Inicio | Siguiente
cpdf_rect | Subir | cpdf_rlineto


cpdf_translate

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_translate -- Define el sistema de origen de coordenadas

Descripción

void cpdf_translate ( int pdf document, double x-koor, double y-koor, int mode)

La función cpdf_translate() define el sistema origen de coordenadas en el punto (x-coor, y-coor).

El último parámetro opcional determina la longitud de la unidad. Si es 0 o se omite, se usa la unidad por defecto especificada en la página. De otro modo las coordenadas son medidas en puntos postscript, depreciando la unidad actual.

Anterior | Inicio | Siguiente
cpdf_text | Subir | Crack functions


cpdf_scale

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_scale -- Define la escala

Descripción

void cpdf_scale ( int pdf document, double x-scale, double y-scale)

La función cpdf_scale() define el factor de escala en los dos sentidos.

Anterior | Inicio | Siguiente
cpdf_save_to_file | Subir | cpdf_set_char_spacing


cpdf_rotate

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_rotate -- Define la rotación

Descripción

void cpdf_rotate ( int pdf document, double angle)

La función cpdf_rotate() define la rotación en angle grados.

Anterior | Inicio | Siguiente
cpdf_rmoveto | Subir | cpdf_save


cpdf_setflat

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setflat -- Define la monotonía

Descripción

void cpdf_setflat ( int pdf document, double value)

La función cpdf_setflat() pone la monotonía a un valor de entre 0 y 100.

Anterior | Inicio | Siguiente
cpdf_setdash | Subir | cpdf_setgray


cpdf_setlinejoin

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setlinejoin -- Define el parámetro linejoin

Descripción

void cpdf_setlinejoin ( int pdf document, long value)

La función cpdf_setlinejoin() define el parámetro entre un valor de 0 y 2. 0 = ingletes, 1 = redondear, 2 = ángulo oblícuo

Anterior | Inicio | Siguiente
cpdf_setlinecap | Subir | cpdf_setlinewidth


cpdf_setlinecap

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setlinecap -- Define el parámetro linecap

Description

void cpdf_setlinecap ( int pdf document, int value)

La función cpdf_setlinecap() define el parámetro linecap entre los valores 0 y 2. 0 = empalmar al final, 1 = redondear, 2 = esquina proyectada

Anterior | Inicio | Siguiente
cpdf_setgray_stroke | Subir | cpdf_setlinejoin


cpdf_setmiterlimit

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setmiterlimit -- Define el límite del inglete

Descripción

void cpdf_setmiterlimit ( int pdf document, double value)

La función cpdf_setmiterlimit() define el límite del inglete a un valor mayor o igual a 1.

Anterior | Inicio | Siguiente
cpdf_setlinewidth | Subir | cpdf_setrgbcolor


cpdf_setlinewidth

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setlinewidth -- Define la profundidad de la línea

Descripción

void cpdf_setlinewidth ( int pdf document, double width)

La función cpdf_setlinewidth() define la preofundidad de la línea a width.

Anterior | Inicio | Siguiente
cpdf_setlinejoin | Subir | cpdf_setmiterlimit


cpdf_setdash

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setdash -- Defina el patrón de la raya

Descripción

void cpdf_setdash ( int pdf document, double white, double black)

La función cpdf_setdash() define el patrón de la raya white unidades blancas y black unidades negras. Si los dos son 0 se pone una línea sólida.

Anterior | Inicio | Siguiente
cpdf_set_word_spacing | Subir | cpdf_setflat


cpdf_moveto

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_moveto -- Define el punto actual

Descripción

void cpdf_moveto ( int pdf document, double x-koor, double y-koor, int mode)

La funcióncpdf_moveto() pone el punto actual en las coordenadas x-koor y y-koor.

El último parámetro opcional determina la longitud de la unidad. Si es 0 o se omite, la unidad por defecto será la especificada para la página. De otro modo las coordenadas se medirán en puntos postscript despreciando la unidad en curso.

Anterior | Inicio | Siguiente
cpdf_lineto | Subir | cpdf_open


cpdf_rmoveto

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

cpdf_rmoveto -- Define el punto actual

Descripción

void cpdf_rmoveto ( int pdf document, double x-koor, double y-koor, int mode)

La función cpdf_rmoveto() pone el punto actual relativo a las coordenadas x-koor y y-koor.

El último parámetro opciona determina la loingitud de la unidad. Si es 0 o se omite, la unidad por defecto será la especificada para la página. De otro modo las coordenadas se medirán en puntos postscript, despreciando la unidad en curso.

Vea también cpdf_moveto().

Anterior | Inicio | Siguiente
cpdf_rlineto | Subir | cpdf_rotate


cpdf_curveto

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_curveto -- Dibuja una curva

Descripción

void cpdf_curveto ( int pdf document, double x1, double y1, double x2, double y2, double x3, double y3, int mode)

La función cpdf_curveto() dibuja una curva Bezier desde el punto actual al punto (x3, y3) usando (x1, y1) y (x2, y2) como puntos de control.

El último parámetro opcional especifica el tamaño de la unidad. Si es 0 o se omite, se usa la unidad especificada para la página. De otro modo las coordenadas se miden en puntos postscript, despreciando la unidad en curso.

Vea también cpdf_moveto(),
            cpdf_rmoveto(),
            cpdf_rlineto(),
            cpdf_lineto().

Anterior | Inicio | Siguiente
cpdf_continue_text | Subir | cpdf_end_text


cpdf_lineto

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_lineto -- Dibuja una línea

Descripción

void cpdf_lineto ( int pdf document, double x-koor, double y-koor, int mode)

La función cpdf_lineto() dibuja una línea desde el punto actual al punto con coordenadas (x-koor, y-koor).

El último parámetro opcional determina el tamaño de la unidad. Si es 0 o se omite, se usa el valor especificado para la página por defecto. De otro modo las coordenadas se miden en puntos postscript, despreciando la unidad actual.

Vea también cpdf_moveto(),
            cpdf_rmoveto(),
            cpdf_curveto().

Anterior | Inicio | Siguiente
cpdf_import_jpeg | Subir | cpdf_moveto


cpdf_rlineto

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

cpdf_rlineto -- Dibuja una línea

Descripción

void cpdf_rlineto ( int pdf document, double x-koor, double y-koor, int mode)

La función cpdf_rlineto() dibuja una línea desde el punto actual al punto relativo con coordenadas (x-koor, y-koor).

El último parámetro opcional determina la longitud de la unidad. Si es 0 o se omite, se usa el valor por defecto para la página. De otro modo las coordenadas se miden en puntos postscript, despreciando la unidad actual.

Vea también cpdf_moveto(),
            cpdf_rmoveto(),
            cpdf_curveto().

Anterior | Inicio | Siguiente
cpdf_restore | Subir | cpdf_rmoveto


cpdf_circle

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_circle -- Dibuja un círculo

Descripción

void cpdf_circle ( int pdf document, double x-koor, double y-koor, double radius, int mode)

La función cpdf_circle() dibuja un círculo con centro en el punto (x-koor, y-koor) y radio radius.

El último parámetro opcional define el tamaño de la unidad. Si es 0 o se omite, se usa el valor por defecto para la página. De otro modo las coordenadas se miden en puntos postscript, despreciando la unidad actual.

Vea también cpdf_arc().

Anterior | Inicio | Siguiente
cpdf_begin_text | Subir | cpdf_clip


cpdf_arc

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_arc -- Dibuja un arco

Descripión

void cpdf_arc ( int pdf document, double x-koor, double y-koor, double radius, double start, double end, int mode)

La función cpdf_arc() dibuja un arco con el centro rn el punto (x-koor, y-koor) y radio radius, empezando en el ángulo start y terminando en el ángulo end.

El último parámetro opcional especifica el tamaño de la unidad. Si es 0 o se omite, se usa la unidad especificada por defecto. De otro modo las coordenadas son medidas en puntos postscript,despreciando la unidad actual.

Vea también cpdf_circle().

Anterior | Inicio | Siguiente
cpdf_add_outline | Subir | cpdf_begin_text


cpdf_rect

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_rect -- Dibuja un rectángulo

Descripción

void cpdf_rect ( int pdf document, double x-koor, double y-koor, double width, double height, int mode)

La función cpdf_rect() dibuja un rectángulo con su esquina inferior izquierda en el punto (x-koor, y-koor). La anchura es widgth. La altura es height.

El último parámetro opcional define el tamaño de la unidad. Si es 0 o se omite, se usa la unidad por defecto especificada para la página. De otro modo las coordenadas se miden en puntos postscript, despreciando la unidad actual.

Anterior | Inicio | Siguiente
cpdf_place_inline_image | Subir | cpdf_restore


cpdf_closepath

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_closepath -- Cierra el camino

Descripción

void cpdf_closepath ( int pdf document)

La función cpdf_closepath() cierra el camino actual.

Anterior | Inicio | Siguiente
cpdf_close | Subir | cpdf_closepath_fill_stroke


cpdf_stroke

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_stroke -- Dibuja una línea a lo largo del camino

Descripción

void cpdf_stroke ( int pdf document)

La función cpdf_stroke() dibuja una línea a lo largo del camino actual.

Vea también cpdf_closepath(), cpdf_closepath_stroke().

Anterior | Inicio | Siguiente
cpdf_stringwidth | Subir | cpdf_text


cpdf_closepath_stroke

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_closepath_stroke -- Cierra el camino y dibuja una línea a lo largo del camino

Descripción

void cpdf_closepath_stroke ( int pdf document)

La función cpdf_closepath_stroke() es una
combinación de cpdf_closepath() y
cpdf_stroke(). Después limpia el camino.

Vea también cpdf_closepath(), cpdf_stroke().

Anterior | Inicio | Siguiente
cpdf_closepath_fill_stroke | Subir | cpdf_continue_text


cpdf_fill

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_fill -- LLena el camino actual

Descripción

void cpdf_fill ( int pdf document)

La función cpdf_fill() llena el interior del camino actual con el color alctual de relleno.

Vea también cpdf_closepath(),
            cpdf_stroke(),
            cpdf_setgray_fill(),
            cpdf_setgray(),
            cpdf_setrgbcolor_fill(),
            cpdf_setrgbcolor().

Anterior | Inicio | Siguiente
cpdf_end_text | Subir | cpdf_fill_stroke


cpdf_fill_stroke

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_fill_stroke -- LLena y traza el camino actual

Descripción

void cpdf_fill_stroke ( int pdf document)

La función cpdf_fill_stroke() llena el interior del camino actual con el color de relleno actual y dibuja el camino actual.

Vea también cpdf_closepath(),
            cpdf_stroke(),
            cpdf_fill(),
            cpdf_setgray_fill(),
            cpdf_setgray(),
            cpdf_setrgbcolor_fill(),
            cpdf_setrgbcolor().

Anterior | Inicio | Siguiente
cpdf_fill | Subir | cpdf_finalize


cpdf_closepath_fill_stroke

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_closepath_fill_stroke -- Cierra, llena y traza el camino actual

Descripción

void cpdf_closepath_fill_stroke ( int pdf document)

La función cpdf_closepath_fill_stroke() cierra, llena el interior del caminoa catual con el color actual de relleno y dibuja el camino actual.

Vea también cpdf_closepath(),
            cpdf_stroke(),
            cpdf_fill(),
            cpdf_setgray_fill(),
            cpdf_setgray(),
            cpdf_setrgbcolor_fill(),
            cpdf_setrgbcolor().

Anterior | Inicio | Siguiente
cpdf_closepath | Subir | cpdf_closepath_stroke


cpdf_clip

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_clip -- Ajusta al camino actual

Descripción

void cpdf_clip ( int pdf document)

La función cpdf_clip() ajusta todos los dibujos al camino actual.

Anterior | Inicio | Siguiente
cpdf_circle | Subir | cpdf_close


cpdf_setgray_fill

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setgray_fill -- Pone el color de relleno al valor gris

Descripción

void cpdf_setgray_fill ( int pdf document, double value)

La función cpdf_setgray_fill() define el valor de gris actual para rellelanr un camino.

Vea también cpdf_setrgbcolor_fill().

Anterior | Inicio | Siguiente
cpdf_setgray | Subir | cpdf_setgray_stroke


cpdf_setgray_stroke

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setgray_stroke -- Define el color para dibujar al valor gris

Descripción

void cpdf_setgray_stroke ( int pdf document, double gray value)

La función cpdf_setgray_stroke() pone el color de dibujo actual al valor de gris dado.

Vea también cpdf_setrgbcolor_stroke().

Anterior | Inicio | Siguiente
cpdf_setgray_fill | Subir | cpdf_setlinecap


cpdf_setgray

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setgray -- Pone el color de relleno y dibujo a gris

Descripción

void cpdf_setgray ( int pdf document, double gray value)

La función cpdf_setgray_stroke() pone el color de relleno y dibujo al color gris dado.

Vea también cpdf_setrgbcolor_stroke(), cpdf_setrgbcolor_fill().

Anterior | Inicio | Siguiente
cpdf_setflat | Subir | cpdf_setgray_fill


cpdf_setrgbcolor_fill

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setrgbcolor_fill -- Pone el color de relleno a l valor de clor rgb

Descripción

void cpdf_setrgbcolor_fill ( int pdf document, double red value, double green value, double blue value)

La función cpdf_setrgbcolor_fill() pone el color rgb actual para rellenar un camino.

Vea también cpdf_setrgbcolor_stroke(), cpdf_setrgbcolor().

Anterior | Inicio | Siguiente
cpdf_setrgbcolor | Subir | cpdf_setrgbcolor_stroke


cpdf_setrgbcolor_stroke

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setrgbcolor_stroke -- Pone el color de dibujo al valor de color rgb

Descripción

void cpdf_setrgbcolor_stroke ( int pdf document, double red value, double green value, double blue value)

La función cpdf_setrgbcolor_stroke() pone el color de dibujo actual al valor de color rgb dado.

Vea también cpdf_setrgbcolor_fill(), cpdf_setrgbcolor().

Anterior | Inicio | Siguiente
cpdf_setrgbcolor_fill | Subir | cpdf_show


cpdf_setrgbcolor

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

cpdf_setrgbcolor -- Pone el color de relleno y dibujo al valor de color rgb

Descripción

void cpdf_setrgbcolor ( int pdf document, double red value, double green value, double blue value)

La función cpdf_setrgbcolor_stroke() pone el color de relleno y dibujo actual al color rgb dado.

Vea también cpdf_setrgbcolor_stroke(), cpdf_setrgbcolor_fill().

Anterior | Inicio | Siguiente
cpdf_setmiterlimit | Subir | cpdf_setrgbcolor_fill


cpdf_add_outline

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

cpdf_add_outline -- Añade una marca en la página actual

Descripción

void cpdf_add_outline ( int pdf document, string text)

La función cpdf_add_outline() añade una marca con el texto text que apunta a la página actual.

Ejemplo 1. Añadiendo un contorno de página

<?php
$cpdf = cpdf_open(0);
cpdf_page_init($cpdf, 1, 0, 595, 842);
cpdf_add_outline($cpdf, 0, 0, 0, 1, "Página 1");
// ...
// Algún dibujo
// ...
cpdf_finalize($cpdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($cpdf);
cpdf_close($cpdf);
?>

Anterior | Inicio | Siguiente
cpdf_add_annotation | Subir | cpdf_arc


cpdf_set_page_animation

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

cpdf_set_page_animation -- Define la separación entre páginas

Descripción

void cpdf_set_page_animation ( int pdf document, int transition, double duration)

La función cpdf_set_page_animation() define la transición entre páginas que se siguen.

El valor de transition puede ser

0 para ninguno,
1 para dos líneas que se barren a través de la pantalla, revelen la página,
2 para múltiples líneas,
3 para que una caja revele la página,
4 para una única línea,
5 para que la página naterior se disipe para revelar la pagina,
6 para que el efecto de disolución se mueva de un extremop de la página al otro,
7 para que la página antígua simplemente sea reemplazada por la nueva página (default)

El valor de duration es el número de segundos entre las páginas que se pasan.

Anterior | Inicio | Siguiente
cpdf_set_leading | Subir | cpdf_set_subject


cpdf_import_jpeg

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

cpdf_import_jpeg -- Abre una imagen JPEG

Descripción

int cpdf_open_jpeg ( int pdf document, string file name, double x-koor, double y-koor, double angle, double width, double height, double x-scale, double y-scale, int mode)

La función cpdf_import_jpeg() abre una imagen almacenada en el fichero de nombre file name. El formato de la imagen debe ser JPEG. La imagen es situada en la página actual en la posición (x-koor, y-koor). La imagen es rotada angle grados.

El último parámetro opcional determina el tamaño de la unidad. Si es 0 o se omite, se usa la unidad por defecto especificada para la página. De otro modo las coordenadas se miden en puntos postscript, despreciando la unidad actual.

Vea también cpdf_place_inline_image(),

Anterior | Inicio | Siguiente
cpdf_global_set_document_limits | Subir | cpdf_lineto


cpdf_place_inline_image

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

cpdf_place_inline_image -- Situa una imagen en la página

Descripción

void cpdf_place_inline_image ( int pdf document, int image, double x-koor, double y-koor, double angle, double width, double height, int mode)

La función cpdf_place_inline_image() situa una imagen creada con las funciones de imagenes de PHP en la posición de la página (x-koor, y-koor). La imagen puede ser escalada al mismo tiempo.

El último parámetro opcional determina el tamaño de la unidad. Si es 0 o se omite, se usa la unidad por defecto especificada para la página. De otro modo las coordenadas son medidas en puntos postscript, descartando la unidad actual.

Vea también cpdf_import_jpeg(),

Anterior | Inicio | Siguiente
cpdf_page_init | Subir | cpdf_rect


cpdf_add_annotation

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

cpdf_add_annotation -- Añade una anotación

Descripción

void cpdf_add_annotation ( int pdf document, double llx, double lly, double urx, double ury, string title, string content, int mode)

La función cpdf_add_annotation() añade una nota con la esquina inferior izquierda en (llx, lly) y la esquina superior derecha en (urx, ury).

El últomo parámetro opcional determina el tamaño de la unidad. Si es 0 o se omite, se usa la unidad por defecto especificada para la página. De otro modo las coordenadas se miden en puntos postscript, despreciando la unidad actual.

Anterior | Inicio | Siguiente
Funciones de ClibPDF | Subir | cpdf_add_outline


Crack functions

Manual de PHP
Anterior Siguiente

XI. Crack functions

These functions allow you to use the CrackLib library to test the 'strength' of a password. The 'strength' of a password is tested by that checks length, use of upper and lower case and checked against the specified CrackLib dictionary. CrackLib will also give helpful diagnostic messages that will help 'strengthen' the password.

Requirements

More information regarding CrackLib along with the library can be found at http://www.users.dircon.co.uk/~crypto/.

Installation

In order to use these functions, you must compile PHP with Crack support by using the --with-crack[=DIR] option.

Runtime Configuration

???

Resource types

???

Predefined constants

???

Example

This example shows how to open a CrackLib dictionary, test a given password, retrieve any diagnostic messages, and close the dictionary.

Ejemplo 1. CrackLib example

<?php
// Open CrackLib Dictionary
$dictionary = crack_opendict('/usr/local/lib/pw_dict')
     or die('Unable to open CrackLib dictionary');

// Perform password check
$check = crack_check($dictionary, 'gx9A2s0x');

// Retrieve messages
$diag = crack_getlastmessage();
echo $diag; // 'strong password'

// Close dictionary
crack_closedict($dictionary);
?>

Nota: If crack_check() returns TRUE, crack_getlastmessage() will return 'strong password'.

Tabla de contenidos
crack_opendict — Opens a new CrackLib dictionary
crack_closedict — Closes an open CrackLib dictionary
crack_check — Performs an obscure check with the given password
crack_getlastmessage — Returns the message from the last obscure check

Anterior | Inicio | Siguiente
cpdf_translate | Subir | crack_opendict


crack_opendict

(PHP 4 >= 4.0.5)

crack_opendict -- Opens a new CrackLib dictionary

Description

resource crack_opendict ( string dictionary)

Returns a dictionary resource identifier on success, or FALSE on failure.

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

crack_opendict() opens the specified CrackLib dictionary for use with crack_check().

Nota: Only one dictionary may be open at a time.

See also: crack_check(), and crack_closedict().

Anterior | Inicio | Siguiente
Crack functions | Subir | crack_closedict


crack_closedict

(PHP 4 >= 4.0.5)

crack_closedict -- Closes an open CrackLib dictionary

Description

bool crack_closedict ( [resource dictionary])

Returns TRUE on succes, FALSE on failure.

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

crack_closedict() closes the specified dictionary identifier. If dictionary is not specified, the current dictionary is closed.

Anterior | Inicio | Siguiente
crack_opendict | Subir | crack_check


crack_check

(PHP 4 >= 4.0.5)

crack_check -- Performs an obscure check with the given password

Description

bool crack_check ( [resource dictionary, string password])

Returns TRUE if password is strong, or FALSE otherwise.

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

crack_check() performs an obscure check with the given password on the specified dictionary . If dictionary is not specified, the last opened dictionary is used.

Anterior | Inicio | Siguiente
crack_closedict | Subir | crack_getlastmessage


crack_getlastmessage

(PHP 4 >= 4.0.5)

crack_getlastmessage -- Returns the message from the last obscure check

Description

string crack_getlastmessage ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

crack_getlastmessage() returns the message from the last obscure check.

Anterior | Inicio | Siguiente
crack_check | Subir | CURL, Client URL Library Functions


CURL, Client URL Library Functions

Manual de PHP
Anterior Siguiente

XII. CURL, Client URL Library Functions

PHP supports libcurl, a library, created by Daniel Stenberg, that allows you to connect and communicate to many different types of servers with many different types of protocols. libcurl currently supports the http, https, ftp, gopher, telnet, dict, file, and ldap protocols. libcurl also supports HTTPS certificates, HTTP POST, HTTP PUT, FTP uploading (this can also be done with PHP's ftp extension), HTTP form based upload, proxies, cookies and user+password authentication.

In order to use the CURL functions you need to install the CURL package. PHP requires that you use CURL 7.0.2-beta or higher. PHP will not work with any version of CURL below version 7.0.2-beta.

To use PHP's CURL support you must also compile PHP --with-curl[=DIR] where DIR is the location of the directory containing the lib and include directories. In the "include" directory there should be a folder named "curl" which should contain the easy.h and curl.h files. There should be a file named "libcurl.a" located in the "lib" directory.

These functions have been added in PHP 4.0.2.

Once you've compiled PHP with CURL support, you can begin using the curl functions. The basic idea behind the CURL functions is that you initialize a CURL session using the curl_init(), then you can set all your options for the transfer via the curl_exec() and then you finish off your session using the curl_close(). Here is an example that uses the CURL functions to fetch the PHP homepage into a file:

Ejemplo 1. Using PHP's CURL module to fetch the PHP homepage

<?php

$ch = curl_init ("http://www.php.net/");
$fp = fopen ("php_homepage.txt", "w");

curl_setopt ($ch, CURLOPT_INFILE, $fp);
curl_setopt ($ch, CURLOPT_HEADER, 0);

curl_exec ($ch);
curl_close ($ch);
fclose ($fp);
?>

Tabla de contenidos
curl_close — Close a CURL session
curl_exec — Perform a CURL session
curl_init — Initialize a CURL session
curl_setopt — Set an option for a CURL transfer
curl_version — Return the current CURL version

Anterior | Inicio | Siguiente
crack_getlastmessage | Subir | curl_close


curl_init

(PHP 4 >= 4.0.2)

curl_init -- Initialize a CURL session

Description

int curl_init ( [string url])

The curl_init() will initialize a new session and return a CURL handle for use with the curl_setopt(), curl_exec(), and curl_close() functions. If the optional url parameter is supplied then the CURLOPT_URL option will be set to the value of the parameter. You can manually set this using the curl_setopt() function.

Ejemplo 1. Initializing a new CURL session and fetching a webpage

<?php
$ch = curl_init();

curl_setopt ($ch, CURLOPT_URL, "http://www.zend.com/");
curl_setopt ($ch, CURLOPT_HEADER, 0);

curl_exec ($ch);

curl_close ($ch);
?>

See also: curl_close(), curl_setopt()

Anterior | Inicio | Siguiente
curl_exec | Subir | curl_setopt


curl_setopt

(PHP 4 >= 4.0.2)

curl_setopt -- Set an option for a CURL transfer

Description

bool curl_setopt ( int ch, string option, mixed value)

The curl_setopt() function will set options for a CURL session identified by the ch parameter. The option parameter is the option you want to set, and the value is the value of the option given by the option.

The value should be a long for the following options (specified in the option parameter):

  • CURLOPT_INFILESIZE: When you are uploading a file to a remote site, this option should be used to tell PHP what the expected size of the infile will be.

  • CURLOPT_VERBOSE: Set this option to a non-zero value if you want CURL to report everything that is happening.

  • CURLOPT_HEADER: Set this option to a non-zero value if you want the header to be included in the output.

  • CURLOPT_NOPROGRESS: Set this option to a non-zero value if you don't want PHP to display a progress meter for CURL transfers

    Nota: PHP automatically sets this option to a non-zero parameter, this should only be changed for debugging purposes.

  • CURLOPT_NOBODY: Set this option to a non-zero value if you don't want the body included with the output.

  • CURLOPT_FAILONERROR: Set this option to a non-zero value if you want PHP to fail silently if the HTTP code returned is greater than 300. The default behaviour is to return the page normally, ignoring the code.

  • CURLOPT_UPLOAD: Set this option to a non-zero value if you want PHP to prepare for an upload.

  • CURLOPT_POST: Set this option to a non-zero value if you want PHP to do a regular HTTP POST. This POST is a normal application/x-www-from-urlencoded kind, most commonly used by HTML forms.

  • CURLOPT_FTPLISTONLY: Set this option to a non-zero value and PHP will just list the names of an FTP directory.

  • CURLOPT_FTPAPPEND: Set this option to a non-zero value and PHP will append to the remote file instead of overwriting it.

  • CURLOPT_NETRC: Set this option to a non-zero value and PHP will scan your ~./netrc file to find your username and password for the remote site that you're establishing a connection with.

  • CURLOPT_FOLLOWLOCATION: Set this option to a non-zero value to follow any "Location: " header that the server sends as a part of the HTTP header (note this is recursive, PHP will follow as many "Location: " headers that it is sent.)

  • CURLOPT_PUT: Set this option a non-zero value to HTTP PUT a file. The file to PUT must be set with the CURLOPT_INFILE and CURLOPT_INFILESIZE.

  • CURLOPT_MUTE: Set this option to a non-zero value and PHP will be completely silent with regards to the CURL functions.

  • CURLOPT_TIMEOUT: Pass a long as a parameter that contains the maximum time, in seconds, that you'll allow the curl functions to take.

  • CURLOPT_LOW_SPEED_LIMIT: Pass a long as a parameter that contains the transfer speed in bytes per second that the transfer should be below during CURLOPT_LOW_SPEED_TIME seconds for PHP to consider it too slow and abort.

  • CURLOPT_LOW_SPEED_TIME: Pass a long as a parameter that contains the time in seconds that the transfer should be below the CURLOPT_LOW_SPEED_LIMIT for PHP to consider it too slow and abort.

  • CURLOPT_RESUME_FROM: Pass a long as a parameter that contains the offset, in bytes, that you want the transfer to start from.

  • CURLOPT_SSLVERSION: Pass a long as a parameter that contains the SSL version (2 or 3) to use. By default PHP will try and determine this by itself, although, in some cases you must set this manually.

  • CURLOPT_TIMECONDITION: Pass a long as a parameter that defines how the CURLOPT_TIMEVALUE is treated. You can set this parameter to TIMECOND_IFMODSINCE or TIMECOND_ISUNMODSINCE. This is a HTTP-only feature.

  • CURLOPT_TIMEVALUE: Pass a long as a parameter that is the time in seconds since January 1st, 1970. The time will be used as specified by the CURLOPT_TIMEVALUE option, or by default the TIMECOND_IFMODSINCE will be used.

The value parameter should be a string for the following values of the option parameter:

  • CURLOPT_URL: This is the URL that you want PHP to fetch. You can also set this option when initializing a session with the curl_init() function.

  • CURLOPT_USERPWD: Pass a string formatted in the [username]:[password] manner, for PHP to use for the connection. connection.

  • CURLOPT_PROXYUSERPWD: Pass a string formatted in the [username]:[password] format for connection to the HTTP proxy.

  • CURLOPT_RANGE: Pass the specified range you want. It should be in the "X-Y" format, where X or Y may be left out. The HTTP transfers also support several intervals, seperated with commas as in X-Y,N-M.

  • CURLOPT_POSTFIELDS: Pass a string containing the full data to post in an HTTP "POST" operation.

  • CURLOPT_REFERER: Pass a string containing the "referer" header to be used in an HTTP request.

  • CURLOPT_USERAGENT: Pass a string containing the "user-agent" header to be used in an HTTP request.

  • CURLOPT_FTPPORT: Pass a string containing the which will be used to get the IP address to use for the ftp "PORT" instruction. The POST instruction tells the remote server to connect to our specified IP address. The string may be a plain IP address, a hostname, a network interface name (under UNIX), or just a plain '-' to use the systems default IP address.

  • CURLOPT_COOKIE: Pass a string containing the content of the cookie to be set in the HTTP header.

  • CURLOPT_SSLCERT: Pass a string containing the filename of PEM formatted certificate.

  • CURLOPT_SSLCERTPASSWD: Pass a string containing the password required to use the CURLOPT_SSLCERT certificate.

  • CURLOPT_COOKIEFILE: Pass a string containing the name of the file containing the cookiee data. The cookie file can be in Netscape format, or just plain HTTP-style headers dumped into a file.

  • CURLOPT_CUSTOMREQUEST: Pass a string to be used instead of GET or HEAD when doing an HTTP request. This is useful for doing DELETE or another, more obscure, HTTP request.

    Nota: Don't do this without making sure your server supports the command first.

The following options expect a file descriptor that is obtained by using the fopen() function:

  • CURLOPT_FILE: The file where the output of your transfer should be placed, the default is STDOUT.

  • CURLOPT_INFILE: The file where the input of your transfer comes from.

  • CURLOPT_WRITEHEADER: The file to write the header part of the output into.

  • CURLOPT_STDERR: The file to write errors to instead of stderr.

Anterior | Inicio | Siguiente
curl_init | Subir | curl_version


curl_exec

(PHP 4 >= 4.0.2)

curl_exec -- Perform a CURL session

Description

bool curl_exec ( int ch)

This function is should be called after you initialize a CURL session and all the options for the session are set. Its purpose is simply to execute the predefined CURL session (given by the ch).

Anterior | Inicio | Siguiente
curl_close | Subir | curl_init


curl_close

(PHP 4 >= 4.0.2)

curl_close -- Close a CURL session

Description

void curl_close ( int ch)

This functions closes a CURL session and frees all ressources. The CURL handle, ch, is also deleted.

Anterior | Inicio | Siguiente
CURL, Client URL Library Functions | Subir | curl_exec


curl_version

(PHP 4 >= 4.0.2)

curl_version -- Return the current CURL version

Description

string curl_version ( void)

The curl_version() function returns a string containing the current CURL version.

Anterior | Inicio | Siguiente
curl_setopt | Subir | Funciones de pago electrónico


Funciones de pago electrónico

Manual de PHP
Anterior Siguiente

XIII. Funciones de pago electrónico

Estas funciones solo están disponibles si el intérprete ha sido compilado con --with-cybercash=[DIR]. Estas funciones han sido añadidas en PHP4.

Tabla de contenidos
cybercash_base64_decode —
cybercash_base64_encode — ???
cybercash_decr — ???
cybercash_encr — ???

Anterior | Inicio | Siguiente
curl_version | Subir | cybercash_base64_decode


cybercash_encr

(PHP 4 >= 4.0.0)

cybercash_encr -- ???

Descripción

array cybercash_encr ( string wmk, string sk, string inbuff)

La función devuelve un array asociativo con los elementos "errcode" y, si "errcode" es FALSE, "outbuff" (string), "outLth" (long) y "macbuff" (string).

Anterior | Inicio | Siguiente
cybercash_decr | Subir | Crédit Mutuel CyberMUT functions


cybercash_decr

(PHP 4 >= 4.0.0)

cybercash_decr -- ???

Descripción

array cybercash_decr ( string wmk, string sk, string inbuff)

La función devuelve un array asociativo con los elementos "errcode" y, si "errcode" es FALSE, "outbuff" (string), "outLth" (long) y "macbuff" (string).

Anterior | Inicio | Siguiente
cybercash_base64_encode | Subir | cybercash_encr


cybercash_base64_encode

(PHP 4 >= 4.0.0)

cybercash_base64_encode -- ???

Descripción

string cybercash_base64_encode ( string inbuff)

Anterior | Inicio | Siguiente
cybercash_base64_decode | Subir | cybercash_decr


cybercash_base64_decode

(PHP 4 >= 4.0.0)

cybercash_base64_decode --

Descripción

string cybercash_base64_decode ( string inbuff)

Anterior | Inicio | Siguiente
Funciones de pago electrónico | Subir | cybercash_base64_encode


Crédit Mutuel CyberMUT functions

Manual de PHP
Anterior Siguiente

XIV. Crédit Mutuel CyberMUT functions

This extension allows you to process credit cards transactions using Crédit Mutuel CyberMUT system (http://www.creditmutuel.fr/centre_commercial/vendez_sur_internet.html).

CyberMUT is a popular Web Payment Service in France, provided by the Crédit Mutuel bank. If you are foreign in France, these functions will not be useful for you.

These functions are only available if PHP has been compiled with the --with-cybermut[=DIR] option, where DIR is the location of libcm-mac.a and cm-mac.h. You will require the appropriate SDK for your platform, which may be sent to you after your CyberMUT's subscription (contact them via Web, or go to the nearest Crédit Mutuel).

The use of these functions is almost identical to the original functions, except for the parameters of return for cybermut_creerformulairecm() and cybermut_creerreponsecm(), which are returned directly by functions PHP, whereas they had passed in reference in the original functions.

These functions have been added in PHP 4.0.6.

Nota: These functions only provide a link to CyberMUT SDK. Be sure to read the CyberMUT Developers Guide for full details of the required parameters.

Tabla de contenidos
cybermut_creerformulairecm — Generate HTML form of request for payment
cybermut_testmac — Make sure that there no was data diddling contained in the received message of confirmation
cybermut_creerreponsecm — Generate the acknowledgement of delivery of the confirmation of payment

Anterior | Inicio | Siguiente
cybercash_encr | Subir | cybermut_creerformulairecm


cybermut_creerformulairecm

(PHP 4 >= 4.0.5)

cybermut_creerformulairecm -- Generate HTML form of request for payment

Description

string cybermut_creerformulairecm ( string url_CM, string version, string TPE, string montant, string ref_commande, string texte_libre, string url_retour, string url_retour_ok, string url_retour_err, string langue, string code_societe, string texte_bouton)

cybermut_creerformulairecm() is used to generate the HTML form of request for payment.

Ejemplo 1. First step of payment (equiv cgi1.c)

<?php
// Directory where the keys are located
putenv("CMKEYDIR=/var/creditmut/cles");

// Version number
$VERSION="1.2";

  $retour =  cybermut_creerformulairecm(
  "https://www.creditmutuel.fr/test/telepaiement/paiement.cgi",
  $VERSION,
  "1234567890",
  "300FRF",
  $REFERENCE,
  $TEXTE_LIBRE,
  $URL_RETOUR,
  $URL_RETOUR_OK,
  $URL_RETOUR_ERR,
  "francais",
  "company",
  "Paiement par carte bancaire");

  echo $retour;
?>

See also cybermut_testmac() and cybermut_creerreponsecm().

Anterior | Inicio | Siguiente
Crédit Mutuel CyberMUT functions | Subir | cybermut_testmac


cybermut_testmac

(PHP 4 >= 4.0.5)

cybermut_testmac -- Make sure that there no was data diddling contained in the received message of confirmation

Description

bool cybermut_testmac ( string code_MAC, string version, string TPE, string cdate, string montant, string ref_commande, string texte_libre, string code-retour)

cybermut_testmac() is used to make sure that there was not data diddling contained in the received message of confirmation. Pay attention to parameters code-retour and texte-libre, which cannot be evaluated as is, because of the dash. You must retrieve them by using:
<?php
  $code_retour=$HTTP_GET_VARS["code-retour"];
  $texte_libre=$HTTP_GET_VARS["texte-libre"];
?>

Ejemplo 1. Last step of payment (equiv cgi2.c)

<?php
// Make sure that Enable Track Vars is ON.
// Directory where are located the keys
putenv("CMKEYDIR=/var/creditmut/cles");

// Version number
$VERSION="1.2";

$texte_libre = $HTTP_GET_VARS["texte-libre"];
$code_retour = $HTTP_GET_VARS["code-retour"];

$mac_ok = cybermut_testmac($MAC,$VERSION,$TPE,$date,$montant,$reference,$texte_libre,$code_retour);

if ($mac_ok) {

  //
  // insert data processing here
  //
  //

  $result=cybermut_creerreponsecm("OK");
} else {
  $result=cybermut_creerreponsecm("Document Falsifie");
}

?>

See also cybermut_creerformulairecm() and cybermut_creerreponsecm().

Anterior | Inicio | Siguiente
cybermut_creerformulairecm | Subir | cybermut_creerreponsecm


cybermut_creerreponsecm

(PHP 4 >= 4.0.5)

cybermut_creerreponsecm -- Generate the acknowledgement of delivery of the confirmation of payment

Description

string cybermut_creerreponsecm ( string phrase)

cybermut_creerreponsecm() returns a string containing delivery acknowledgement message.

The parameter is "OK" if the message of confirmation of the payment was correctly identified by cybermut_testmac(). Any other chain is regarded as an error message.

See also cybermut_creerformulairecm() and cybermut_testmac().

Anterior | Inicio | Siguiente
cybermut_testmac | Subir | Cyrus IMAP administration functions


Cyrus IMAP administration functions

Manual de PHP
Anterior Siguiente

XV. Cyrus IMAP administration functions

Aviso

This function is currently not documented, only the argument list is available.

Tabla de contenidos
cyrus_connect — Connect to a Cyrus IMAP server
cyrus_authenticate — Authenticate agaings a Cyrus IMAP server
cyrus_bind — Bind callbacks to a Cyrus IMAP connection
cyrus_unbind — Unbind ...
cyrus_query — Send a query to a Cyrus IMAP server
cyrus_close — Close connection to a cyrus server

Anterior | Inicio | Siguiente
cybermut_creerreponsecm | Subir | cyrus_connect


cyrus_connect

(PHP 4 >= 4.1.0)

cyrus_connect -- Connect to a Cyrus IMAP server

Description

resource cyrus_connect ( [string host [, string port [, int flags]]])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
Cyrus IMAP administration functions | Subir | cyrus_authenticate


cyrus_authenticate

(PHP 4 >= 4.1.0)

cyrus_authenticate -- Authenticate agaings a Cyrus IMAP server

Description

bool cyrus_authenticate ( resource connection [, string mechlist [, string service [, string user [, int minssf [, int maxssf]]]]])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
cyrus_connect | Subir | cyrus_bind


cyrus_bind

(PHP 4 >= 4.1.0)

cyrus_bind -- Bind callbacks to a Cyrus IMAP connection

Description

bool cyrus_bind ( resource connection, array callbacks)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
cyrus_authenticate | Subir | cyrus_unbind


cyrus_unbind

(PHP 4 >= 4.1.0)

cyrus_unbind -- Unbind ...

Description

bool cyrus_unbind ( resource connection, string trigger_name)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
cyrus_bind | Subir | cyrus_query


cyrus_query

(PHP 4 >= 4.1.0)

cyrus_query -- Send a query to a Cyrus IMAP server

Description

bool cyrus_query ( resource connection, string query)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
cyrus_unbind | Subir | cyrus_close


cyrus_close

(PHP 4 >= 4.1.0)

cyrus_close -- Close connection to a cyrus server

Description

bool cyrus_close ( resource connection)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
cyrus_query | Subir | Character type functions


Character type functions

Manual de PHP
Anterior Siguiente

XVI. Character type functions

The functions provided by this extension check whether a character or string falls into a certain character class according to the current locale (see also setlocale()).

When called with an integer argument these functions behave exactly like their C counterparts from "ctype.h".

When called with a string argument they will check every character in the string and will only return TRUE if every character in the string matches the requested criteria.

Passing anything else but a string or integer will return FALSE immediately.

Requirements

None besides functions from the standard C library which are always available.

Installation

Beginning with PHP 4.2.0 these functions are enabled by default. For older versions you have to configure and compile PHP with --enable-ctype.

Runtime Configuration

???

Resource types

???

Predefined constants

???
Tabla de contenidos
ctype_alnum — Check for alphanumeric character(s)
ctype_alpha — Check for alphabetic character(s)
ctype_cntrl — Check for control character(s)
ctype_digit — Check for numeric character(s)
ctype_lower — Check for lowercase character(s)
ctype_graph — Check for any printable character(s) except space
ctype_print — Check for printable character(s)
ctype_punct — Check for any printable character which is not whitespace or an alphanumeric character
ctype_space — Check for whitespace character(s)
ctype_upper — Check for uppercase character(s)
ctype_xdigit — Check for character(s) representing a hexadecimal digit

Anterior | Inicio | Siguiente
cyrus_close | Subir | ctype_alnum


ctype_alnum

(PHP 4 >= 4.0.4)

ctype_alnum -- Check for alphanumeric character(s)

Description

bool ctype_alnum ( string text)

Returns TRUE if every character in text is either a letter or a digit, FALSE otherwise. In the standard C locale letters are just [A-Za-z]. The function is equivalent to (ctype_alpha($text) || ctype_digit($text)).

See also ctype_alpha(), ctype_digit(), and setlocale().

Anterior | Inicio | Siguiente
Character type functions | Subir | ctype_alpha


ctype_alpha

(PHP 4 >= 4.0.4)

ctype_alpha -- Check for alphabetic character(s)

Description

bool ctype_alpha ( string text)

Returns TRUE if every character in text is a letter from the current locale, FALSE otherwise. In the standard C locale letters are just [A-Za-z] and ctype_alpha() is equivalent to (ctype_upper($text) || ctype_lower($text)), but other languages have letters that are considered neither upper nor lower case.

See also ctype_upper(),
ctype_lower(), and
setlocale().

Anterior | Inicio | Siguiente
ctype_alnum | Subir | ctype_cntrl


ctype_cntrl

(PHP 4 >= 4.0.4)

ctype_cntrl -- Check for control character(s)

Description

bool ctype_cntrl ( string text)

Returns TRUE if every character in text has a special control function, FALSE otherwise. Control characters are e.g. line feed, tab, esc.

Anterior | Inicio | Siguiente
ctype_alpha | Subir | ctype_digit


ctype_digit

(PHP 4 >= 4.0.4)

ctype_digit -- Check for numeric character(s)

Description

bool ctype_digit ( string text)

Returns TRUE if every character in text is a decimal digit, FALSE otherwise.

See also ctype_alnum() and ctype_xdigit().

Anterior | Inicio | Siguiente
ctype_cntrl | Subir | ctype_lower


ctype_lower

(PHP 4 >= 4.0.4)

ctype_lower -- Check for lowercase character(s)

Description

bool ctype_lower ( string text)

Returns TRUE if every character in text is a lowercase letter in the current locale.

See also ctype_alpha() and ctype_upper().

Anterior | Inicio | Siguiente
ctype_digit | Subir | ctype_graph


ctype_graph

(PHP 4 >= 4.0.4)

ctype_graph -- Check for any printable character(s) except space

Description

bool ctype_graph ( string text)

Returns TRUE if every character in text is printable and actually creates visible output (no white space), FALSE otherwise.

See also ctype_alnum(), ctype_print(), and ctype_punct().

Anterior | Inicio | Siguiente
ctype_lower | Subir | ctype_print


ctype_print

(PHP 4 >= 4.0.4)

ctype_print -- Check for printable character(s)

Description

bool ctype_print ( string text)

Returns TRUE if every character in text will actually create output (including blanks). Returns FALSE if text contains control characters or characters that do not have any output or control function at all.

See also ctype_cntrl(), ctype_graph(), and ctype_punct().

Anterior | Inicio | Siguiente
ctype_graph | Subir | ctype_punct


ctype_punct

(PHP 4 >= 4.0.4)

ctype_punct -- Check for any printable character which is not whitespace or an alphanumeric character

Description

bool ctype_punct ( string text)

Returns TRUE if every character in text is printable, but neither letter, digit or blank, FALSE otherwise.

See also ctype_cntrl(), ctype_graph(), and ctype_punct().

Anterior | Inicio | Siguiente
ctype_print | Subir | ctype_space


ctype_space

(PHP 4 >= 4.0.4)

ctype_space -- Check for whitespace character(s)

Description

bool ctype_space ( string text)

Returns TRUE if every character in text creates some sort of white space, FALSE otherwise. Besides the blank character this also includes tab, vertical tab, line feed, carriage return and form feed characters.

Anterior | Inicio | Siguiente
ctype_punct | Subir | ctype_upper


ctype_upper

(PHP 4 >= 4.0.4)

ctype_upper -- Check for uppercase character(s)

Description

bool ctype_upper ( string text)

Returns TRUE if every character in text is a uppercase letter in the current locale.

See also ctype_alpha() and ctype_lower().

Anterior | Inicio | Siguiente
ctype_space | Subir | ctype_xdigit


ctype_xdigit

(PHP 4 >= 4.0.4)

ctype_xdigit -- Check for character(s) representing a hexadecimal digit

Description

bool ctype_xdigit ( string text)

Returns TRUE if every character in text is a hexadecimal 'digit', that is a decimal digit or a character from [A-Fa-f] , FALSE otherwise.

See also ctype_digit().

Anterior | Inicio | Siguiente
ctype_upper | Subir | Funciones de la capa de abstraccion de bases de datos (dbm-style)


Funciones de la capa de abstraccion de bases de datos (dbm-style)

Manual de PHP
Anterior Siguiente

XVII. Funciones de la capa de abstraccion de bases de datos (dbm-style)

Estas funciones son la base para el acceso a bases de datos del estilo Berkeley DB.

Este es un nivel de abstraccion general para varias bases de datos. Como tal su funcionalidad esta limitada a un grupo de modernas bases de datos como Sleepycat Software's DB2. (Esta no debe confundirse con IBM DB2 software, la cual es soportada mediante las funciones ODBC.)

El comportamiento de varios aspectos depende de la implementacion de la base de datos. Funciones como dba_optimize() y dba_sync() cumpliran su funcionalidad con unas bases de datos pero no con otras.

Los siguientes manejadores (handlers) estan soportados:

  • dbm es el mas antiguo (original) tipo de base de datos de la familia de Berkeley DB. Se debe evitar su uso, si es posible. Nosotros no soportamos las funciones de compatibilidad de DB2 y gdbm, porque ellas solo son compatibles a nivel de codigo fuente, pero no pueden manejar el formato original dbm.

  • ndbm es un tipo mas nuevo y mas flexible que dbm. Todavia tiene la mayoria de las limitaciones de dbm (Por lo tanto es descartado).

  • gdbm es el gestor de bases de datos de GNU (database manager).

  • db2 es Sleepycat Software's DB2. Es descrito como "un conjunto de herramientas de programacion que proveen acceso de alto nivel a bases de datos en aplicaciones standalone o en el modelo cliente/servidor. "

  • cdb es "una rapida, de confianza, sencilla herramienta para la creacion y lectura de bases de datos constantes." Fue creada por el autor de qmail y puede encontrarse en here. Como la base es constante solo se soportan las operaciones de lectura.

Ejemplo 1. Ejemplo de DBA

<?php

$id = dba_open("/tmp/test.db", "n", "db2");

if(!$id) {
    echo "dba_open failed\n";
    exit;
}

dba_replace("key", "This is an example!", $id);

if(dba_exists("key", $id)) {
    echo dba_fetch("key", $id);
    dba_delete("key", $id);
}

dba_close($id);
?>

DBA es "binary safe" y no tiene ningun limite arbitrario. Hereda todas sus limitaciones de la implementacion de base de datos que tenga.

Todos las bases de datos basadas en ficheros deben proveer un mecanismo para establecer el modo a la hora de crear nuevas bases de datos, si ello es posible. Habitualmente este modo es pasado como el cuarto argumento en dba_open() o en dba_popen().

Se puede acceder a todas las entradas de una base de datos de modo secuencial (lineal) usando las funciones dba_firstkey() y dba_nextkey(). No se puede cambiar la base de datos mientras se recorre (traversing) por ella.

Ejemplo 2. Recorriendo una base de datos

<?php

# ...open database...

$key = dba_firstkey($id);

while($key != false) {
    if(...) { # remember the key to perform some action later
        $handle_later[] = $key;
    }
    $key = dba_nextkey($id);
}

for($i = 0; $i < count($handle_later); $i++)
    dba_delete($handle_later[$i], $id);

?>

Tabla de contenidos
dba_close — Cerrar uba base de datos
dba_delete — Borra una entrada especificada por la clave key
dba_exists — Comprueba si la clave key existe
dba_fetch — Extrae los datos especificados por la clave key
dba_firstkey — Conseguir la primera clave
dba_insert — Insertar una entrada
dba_nextkey — Extraer la siguiente clave
dba_open — Abrir una base de datos
dba_optimize — Optimiza la base de datos
dba_popen — Apertura persistente de una base de datos
dba_replace — Reemplaza o inserta una entrada
dba_sync — Sincroniza la base de datos

Anterior | Inicio | Siguiente
ctype_xdigit | Subir | dba_close


dba_close

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_close -- Cerrar uba base de datos

Descripcion

void dba_close ( int handle)

dba_close() cierra la conexion con una base de datos previamente abierta y libera todos los recursos especificados por handle.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_close() no devuelve ningun valor.

Ver tambien: dba_open() dba_popen()

Anterior | Inicio | Siguiente
Funciones de la capa de abstraccion de bases de datos (dbm-style) | Subir | dba_delete


dba_delete

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_delete -- Borra una entrada especificada por la clave key

Descripcion

bool dba_delete ( string key, int handle)

dba_delete() borra la entrada especificada por key de la base de datos especificada por handle.

key es la clave de la entrada que es borrada.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_delete() devuelve TRUE o FALSE, si la entrada es borrada o no, respectivamente.

Ver tambien:
dba_exists()
dba_fetch()
dba_insert()
dba_replace()

Anterior | Inicio | Siguiente
dba_close | Subir | dba_exists


dba_exists

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_exists -- Comprueba si la clave key existe

Descripcion

bool dba_exists ( string key, int handle)

dba_exists() comprueba si la clave key existe en la base de datos especificada por handle.

key es la clave para la que se realiza la comprobacion.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_exists() devuelve TRUE o FALSE, si la clave es hallada o no, respectivamente.

Ver tambien:
dba_fetch()
dba_delete()
dba_insert()
dba_replace()

Anterior | Inicio | Siguiente
dba_delete | Subir | dba_fetch


dba_fetch

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_fetch -- Extrae los datos especificados por la clave key

Descripcion

string dba_fetch ( string key, int handle)

dba_fetch() extrae los datos especificados por la clave key de la base de datos determinada por handle.

key es la clave de la entrada de los datos que queremos extraer.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_fetch() devuelve la cadena asociada o FALSE, si el par key/data es hallado o no, respectivamente.

Ver tambien:
dba_exists()
dba_delete()
dba_insert()
dba_replace()

Anterior | Inicio | Siguiente
dba_exists | Subir | dba_firstkey


dba_firstkey

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_firstkey -- Conseguir la primera clave

Descripcion

string dba_firstkey ( int handle)

dba_firstkey() devuelve la primera clave de la base de datos especificada por handle y resetea el puntero interno de claves. Esto permite una busqueda lineal por toda la base de datos.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_firstkey() devuelve la clave o FALSE en funcion de si tiene exito o falla, respectivamente.

Ver tambien: dba_nextkey()

Anterior | Inicio | Siguiente
dba_fetch | Subir | dba_insert


dba_insert

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_insert -- Insertar una entrada

Descripcion

bool dba_insert ( string key, string value, int handle)

dba_insert() inserta la entrada descrita con key y value dentro de la base de datos especificada por handle. Fallara si ya existe una entrada con el mismo parametro key.

key es la clave de la entrada a ser insertada.

value es el valor a ser insertado.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_insert() devuelve TRUE o FALSE, en funcion de si tiene exito o falla, respectivamente.

Ver tambien:
dba_exists()
dba_delete()
dba_fetch()
dba_replace()

Anterior | Inicio | Siguiente
dba_firstkey | Subir | dba_nextkey


dba_nextkey

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_nextkey -- Extraer la siguiente clave

Descripcion

string dba_nextkey ( int handle)

dba_nextkey() devuelve la siguiente clave de la base de datos especificada por handle e incrementa el puntero de claves interno.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_nextkey() devuelve la clave o FALSE dependiendo de si tiene exito o falla, respectivamente.

Ver tambien: dba_firstkey()

Anterior | Inicio | Siguiente
dba_insert | Subir | dba_open


dba_popen

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_popen -- Apertura persistente de una base de datos

Descripcion

int dba_popen ( string path, string mode, string handler [, ...])

dba_popen() establece una instancia persistente para path con mode usando handler.

path normalmente es el "path" en el sistema de ficheros.

mode es "r" para acceso de lectura, "w" para lectura/escritura de una base de datos ya existente, "c" para lectura/escritura y creacion de una base datos si esta no existe, y "n" para crear, truncar y lectura/escritura.

handler es el nombre del manejador (handler) que sera usado para el acceso al path. Es pasado como un parametro opcional a dba_popen() y puede usarse en lugar de ella.

dba_popen() devuelve un valor positivo de handler o FALSE, en el caso de que la apertura de la base de datos se realice o si falla, respectivamente.

Ver tambien: dba_open() dba_close()

Anterior | Inicio | Siguiente
dba_optimize | Subir | dba_replace


dba_open

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_open -- Abrir una base de datos

Descripcion

int dba_open ( string path, string mode, string handler [, ...])

dba_open() establece una instancia para path con mode usando handler.

path normalmente es el "path" en el sistema de ficheros.

mode es "r" para acceso de lectura, "w" para lectura/escritura de una base de datos ya existente, "c" para lectura/escritura y creacion de una base datos si esta no existe, y "n" para crear, truncar y lectura/escritura.

handler es el nombre de el manejador (handler) que sera usado para el acceso al path. Es pasado como un parametro opcional a dba_open() y puede usarse en lugar de ella.

dba_open() devuelve un valor positivo de handler o FALSE, en el caso de que la apertura de la base de datos se realice o si falla, respectivamente.

Ver tambien: dba_popen() dba_close()

Anterior | Inicio | Siguiente
dba_nextkey | Subir | dba_optimize


dba_optimize

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_optimize -- Optimiza la base de datos

Descripcion

bool dba_optimize ( int handle)

dba_optimize() optimiza la base de datos especificada por handle.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_optimize() devuelve TRUE o FALSE, si la optimizacion tiene exito o falla, respectivamente.

Ver tambien: dba_sync()

Anterior | Inicio | Siguiente
dba_open | Subir | dba_popen


dba_replace

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_replace -- Reemplaza o inserta una entrada

Descripcion

bool dba_replace ( string key, string value, int handle)

dba_replace() reemplaza o inserta la entrada descrita con key y value dentro de la base de datos especificada por handle.

key es la clave de la entrada a insertar.

value es el valor a ser insertado.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_replace() devuelve TRUE o FALSE, dependiendo de si tiene exito o falla respectivamente.

Ver tambien:
dba_exists()
dba_delete()
dba_fetch()
dba_insert()

Anterior | Inicio | Siguiente
dba_popen | Subir | dba_sync


dba_sync

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

dba_sync -- Sincroniza la base de datos

Descripcion

bool dba_sync ( int handle)

dba_sync() sincroniza la base de datos especificada por handle. Esto probablemente realice una escritura fisica en el disco, si es soportado.

handle es un manejador (handle) de la base de datos devuelto por dba_open().

dba_sync() devuelve TRUE o FALSE, si la sincronizacion tiene exito o falla, respectivamente.

Ver tambien: dba_optimize()

Anterior | Inicio | Siguiente
dba_replace | Subir | Funciones de fecha y hora


Funciones de fecha y hora

Manual de PHP
Anterior Siguiente

XVIII. Funciones de fecha y hora

Tabla de contenidos
checkdate — valida una fecha u hora
date — da formato a la fecha/hora local
getdate — obtiene información de fecha y hora
gettimeofday — obtiene la hora actual
gmdate — da formato a una fecha/hora GMT/CUT
gmmktime — obtiene el valor timestamp UNIX de una fecha GMT
gmstrftime — da formato a una fecha/hora GMT/CUT según las convenciones locales
microtime — devuelve el valor timestamp UNIX actual con microsegundos
mktime — obtiene el timestamp UNIX de una fecha
strftime — da formato a la hora o fecha local de acuerdo con las convenciones locales
time — devuelve el timestamp UNIX actual

Anterior | Inicio | Siguiente
dba_sync | Subir | checkdate


checkdate

(PHP 3, PHP 4 >= 4.0.0)

checkdate -- valida una fecha u hora

Descripción

int checkdate ( int month, int day, int year)

Devuelve un valor verdadero si la fecha dada es válida; en caso contrario, devuelve un valor falso. Comprueba la validez de la fecha formada por los argumentos. Se considera válida una fecha si:

  • el año está entre 0 y 32767, ambos incluidos

  • el mes está entre 1 y 12, ambos incluidos

  • el día está en el rango permitido para el mes dado. Se tienen en consideración los años bisiestos.

Anterior | Inicio | Siguiente
Funciones de fecha y hora | Subir | date


date

(PHP 3, PHP 4 >= 4.0.0)

date -- da formato a la fecha/hora local

Descripción

string date ( string format [, int timestamp])

Devuelve una cadena formateada de acuerdo con la cadena de formato dada, utilizando el valor de timestamp dado o la hora local actual si no hay parámetro.

Se reconocen los siguientes caracteres en la cadena de formato:

  • a - "am" o "pm"

  • A - "AM" o "PM"

  • d - día del mes, dos dígitos con cero a la izquierda; es decir, de "01" a "31"

  • D - día de la semana, en texto, con tres letras; por ejemplo, "Fri"

  • F - mes, en texto, completo; por ejemplo, "January"

  • h - hora, de "01" a "12"

  • H - hora, de "00" a "23"

  • g - hour, sin ceros, de "1" a "12"

  • G - hour, sin ceros; de "0" a "23"

  • i - minutos; de "00" a "59"

  • j - día del mes sin cero inicial; de "1" a "31"

  • l ('L' minúscula) - día de la semana, en texto, completo; por ejemplo, "Friday"

  • L - "1" or "0", según si el año es bisiesto o no

  • m - mes; de "01" a "12"

  • n - mes sin cero inicial; de "1" a "12"

  • M - mes, en texto, 3 letras; por ejemplo, "Jan"

  • s - segundos; de "00" a "59"

  • S - sufijo ordinal en inglés, en texto, 2 caracteres; por ejemplo, "th", "nd"

  • t - número de días del mes dado; de "28" a "31"

  • U - segundos desde el valor de 'epoch'

  • w - día de la semana, en número, de "0" (domingo) a "6" (sábado)

  • Y - año, cuatro cifras; por ejemplo, "1999"

  • y - año, dos cifras; por ejemplo, "99"

  • z - día del año; de "0" a "365"

  • Z - diferencia horaria en segundos (de "-43200" a "43200")

Los caracteres no reconocidos se imprimen tal cual. El formato "Z" siempre devuelve "0" en la función gmdate()()

Ejemplo 1. Ejemplo de date()

print (date("l dS of F Y h:i:s A"));
print ("July 1, 2000 is on a " . date("l", mktime(0,0,0,7,1,2000)));

Es posible usar date() y mktime() juntas para obtener fechas futuras o pasadas.

Ejemplo 2. Ejemplo de date() y mktime()

$tomorrow  = mktime(0,0,0,date("m")  ,date("d")+1,date("Y"));
$lastmonth = mktime(0,0,0,date("m")-1,date("d"),  date("Y"));
$nextyear  = mktime(0,0,0,date("m"),  date("d"),  date("Y")+1);

Para dar formato a fechas en otros idiomas, se deben usar las funciones setlocale() y strftime().

Ver también gmdate() y mktime().

Anterior | Inicio | Siguiente
checkdate | Subir | getdate


getdate

(PHP 3, PHP 4 >= 4.0.0)

getdate -- obtiene información de fecha y hora

Descripción

array getdate ( int timestamp)

Devuelve un array asociativo que contiene la información de fecha del valor timestamp como los siguientes elementos:

  • "seconds" - segundos

  • "minutes" - minutos

  • "hours" - horas

  • "mday" - día del mes

  • "wday" - día de la semana, en número

  • "mon" - mes, en número

  • "year" - año, en número

  • "yday" - día del año, en número; por ejemplo, "299"

  • "weekday" - día de la semana, en texto, completo; por ejemplo, "Friday"

  • "month" - mes, en texto, completo; por ejemplo, "January"

Anterior | Inicio | Siguiente
date | Subir | gettimeofday


gettimeofday

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

gettimeofday -- obtiene la hora actual

Descripción

array gettimeofday ( void)

Es un interfaz para gettimeofday(2). Devuelve un array asociativo que contiene los datos devueltos por esta llamada al sistema.

  • "sec" - segundos

  • "usec" - microsegundos

  • "minuteswest" - minutos al oeste de Greenwich

  • "dsttime" - tipo de corrección dst

Anterior | Inicio | Siguiente
getdate | Subir | gmdate


gmdate

(PHP 3, PHP 4 >= 4.0.0)

gmdate -- da formato a una fecha/hora GMT/CUT

Descripción

string gmdate ( string format, int timestamp)

Idéntica a la función data() excepto en que la hora devuelta es la de Greenwich (GMT). Por ejemplo, si se utiliza en Finlandia (GMT +0200), la primera línea del ejemplo devuelve "Jan 01 1998 00:00:00", mientras la segunda imprime "Dec 31 1997 22:00:00".

Ejemplo 1. Ejemplo de gmdate()

echo date( "M d Y H:i:s",mktime(0,0,0,1,1,1998) );
echo gmdate( "M d Y H:i:s",mktime(0,0,0,1,1,1998) );

Ver también date(), mktime() y gmmktime().

Anterior | Inicio | Siguiente
gettimeofday | Subir | gmmktime


gmmktime

(PHP 3, PHP 4 >= 4.0.0)

gmmktime -- obtiene el valor timestamp UNIX de una fecha GMT

Descripción

int gmmktime ( int hour, int minute, int second, int month, int day, int year [, int is_dst])

Idéntica a mktime(), excepto en que los parámetros representan una fecha GMT.

Anterior | Inicio | Siguiente
gmdate | Subir | gmstrftime


gmstrftime

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

gmstrftime -- da formato a una fecha/hora GMT/CUT según las convenciones locales

Descripción

string gmstrftime ( string format, int timestamp)

Se comporta como strftime(), excepto en que la hora devuelta es la de Greenwich (GMT). Por ejemplo, si se utiliza en la zona horaria EST (GMT -0500), la primera línea del ejemplo imprime "Dec 31 1998 20:00:00", mientras la segunda imprime "Jan 01 1999 01:00:00".

Ejemplo 1. Ejemplo de gmstrftime()

setlocale ('LC_TIME','en_US');
echo strftime ("%b %d %Y %H:%M:%S",mktime(20,0,0,12,31,98))."\n";
echo gmstrftime ("%b %d %Y %H:%M:%S",mktime(20,0,0,12,31,98))."\n";

Ver también strftime().

Anterior | Inicio | Siguiente
gmmktime | Subir | microtime


microtime

(PHP 3, PHP 4 >= 4.0.0)

microtime -- devuelve el valor timestamp UNIX actual con microsegundos

Descripción

string microtime ( void)

Devuelve la cadena "msec sec", donde sec es la hora actual en número de segundos desde el valor Unix Epoch (0:00:00 del 1 de enero de 1970, hora GMT), y msec es la parte de microsegundos. Esta función sólo está disponible en sistemas operativos con admiten la llamada al sistema gettimeofday().

Ver también time().

Anterior | Inicio | Siguiente
gmstrftime | Subir | mktime


mktime

(PHP 3, PHP 4 >= 4.0.0)

mktime -- obtiene el timestamp UNIX de una fecha

Descripción

int mktime ( int hour, int minute, int second, int month, int day, int year [, int is_dst])

Advertencia: Véase el extraño orden de los argumentos, que se diferencia del orden de argumentos en una llamada mktime() de UNIX y que no permite eliminar parámetros de derecha a izquierda (ver abajo). Es un error común mezclar estos valores en un script.

Devuelve el valor timestamp Unix correspondiente a los argumentos dados. El timestamp es un entero de tipo long que contiene el número de segundos entre el valor Unix Epoch (1 de enero de 1970) y la hora especificada.

Se pueden eliminar argumentos en orden de derecha a izquierda; en los argumentos omitidos se toma el valor de la fecha y hora locales.

is_dst puede ponerse a 1 si la hora corresponde a horario de verano, 0 si no, o -1 (valor por omisión) si no se sabe.

Nota: is_dst se añadió en la versión 3.0.10.

mktime() es útil para realizar cálculos y validaciones con fechas, ya que calcula automáticamente el valor correcto para una entrada fuera de rango. Por ejemplo, cada una de las líneas siguientes produce la cadena "Jan-01-1998".

Ejemplo 1. Ejemplo de mktime()

echo date( "M-d-Y", mktime(0,0,0,12,32,1997) );
echo date( "M-d-Y", mktime(0,0,0,13,1,1997) );
echo date( "M-d-Y", mktime(0,0,0,1,1,1998) );

El último día de cada mes se puede expresar como el día "0" del mes siguiente, no el día -1. Los dos ejemplos siguientes producen la cadena "The last day in Feb 2000 is: 29".

Ejemplo 2. El último día del próximo mes

$lastday=mktime(0,0,0,3,0,2000);
echo strftime("Last day in Feb 2000 is: %d",$lastday);

$lastday=mktime(0,0,0,4,-31,2000);
echo strftime("Last day in Feb 2000 is: %d",$lastday);

Ver también date() y time().

Anterior | Inicio | Siguiente
microtime | Subir | strftime


strftime

(PHP 3, PHP 4 >= 4.0.0)

strftime -- da formato a la hora o fecha local de acuerdo con las convenciones locales

Descripción

string strftime ( string format, int timestamp)

Devuelve una cadena formateada según la cadena de formato dada utilizando el valor timestamp o la hora local actual. Los nombres del mes y el día de la semana y otras cadenas dependientes del idioma respetan lo establecido con setlocale().

Se reconocen los siguientes especificadores de conversión en la cadena de formato:

  • %a - nombre del día de la semana abreviado

  • %A - nombre del día de la semana completo

  • %b - nombre del mes abreviado

  • %B - nombre del mes completo

  • %c - representación de fecha y hora preferidas en el idioma actual

  • %d - día del mes en número (de 00 a 31)

  • %H - hora como un número de 00 a 23

  • %I - hora como un número de 01 a 12

  • %j - día del año como un número de 001 a 366

  • %m - mes como un número de 01 a 12

  • %M - minuto en número

  • %p - `am' o `pm', según la hora dada, o las cadenas correspondientes en el idioma actual

  • %S - segundos en número

  • %U - número de la semana en el año, empezando con el primer domingo como el primer día de la primera semana

  • %W - número de la semana en el año, empezando con el primer lunes como el primer día de la primera semana

  • %w - día de la semana en número (el domingo es el 0)

  • %x - representación preferida de la fecha sin la hora

  • %X - representación preferida de la hora sin la fecha

  • %y - año en número de 00 a 99

  • %Y - año en número de cuatro cifras

  • %Z - nombre o abreviatura de la zona horaria

  • %% - carácter `%'

Ejemplo 1. Ejemplo de strftime()

setlocale ("LC_TIME", "C");
print(strftime("%A in Finnish is "));
setlocale ("LC_TIME", "fi_FI");
print(strftime("%A, in French "));
setlocale ("LC_TIME", "fr_CA");
print(strftime("%A and in German "));
setlocale ("LC_TIME", "de_DE");
print(strftime("%A.\n"));
Este ejemplo funciona si se tienen los respectivos `locales' instalados en el sistema.

Ver también setlocale() y mktime().

Anterior | Inicio | Siguiente
mktime | Subir | time


time

(PHP 3, PHP 4 >= 4.0.0)

time -- devuelve el timestamp UNIX actual

Descripción

int time ( void)

Devuelve la hora actual como número de segundos transcurridos desde las 00:00:00 del 1 de enero de 1970 GMT (Unix Epoch).

Ver también date().

Anterior | Inicio | Siguiente
strftime | Subir | Funciones para dBase


Funciones para dBase

Manual de PHP
Anterior Siguiente

XIX. Funciones para dBase

Estas funciones permiten el acceso a datos almacenados en formato dBase (dbf).

No hay soporte para índices o campos Memo. Tampoco hay soporte para bloqueo: si dos procesos concurrentes en el servidor modifican el mismo fichero dBase, probablemente se destruirán los datos.

A diferencia de las bases de datos SQL, las "bases de datos" dBase no pueden cambiar su definición. Una vez creado el fichero, la definición de la base de datos es fija. No hay índices que aceleren la búsqueda u organicen los datos de distinto modo. Los ficheros dBase son simples ficheros secuenciales con registros de longitud fija. Los nuevos registros se añaden al final del fichero y los registros borrados se conservan hasta que se llama a la función dbase_pack()().

Se recomienda no utilizar ficheros dBase como bases de datos, sino elegir cualquier servidor SQL; MySQL o Postgres son opciones habituales con PHP. El soporte para dBase se proporciona para permitir importar y exportar datos a y desde la base de datos web, ya que este formato de ficheros es aceptado habitualmente por las hojas de datos y los organizadores de Windows. La importación y exportación de datos es lo único para lo que sirve el soporte dBase.

Tabla de contenidos
dbase_add_record — añade un registro a un fichero dBase
dbase_close — cierra un fichero dBase
dbase_create — crea una base de datos dBase
dbase_delete_record — borra un registro del fichero dBase
dbase_get_record — lee un registro de un fichero dBase
dbase_get_record_with_names — lee un registro de un fichero dBase como array asociativo
dbase_numfields — cuenta el número de campos en un fichero dBase
dbase_numrecords — cuenta el número de registros en un fichero dBase
dbase_open — abre un fichero dBase
dbase_pack — "empaqueta" un fichero dBase
dbase_replace_record — reemplaza un registro en un fichero dBase

Anterior | Inicio | Siguiente
time | Subir | dbase_add_record


dbase_create

(PHP 3, PHP 4 >= 4.0.0)

dbase_create -- crea una base de datos dBase

Descripción

int dbase_create ( string filename, array fields)

El parámetro fields es un array de arrays, cada uno de los cuales describe el formato de un campo de la base de datos. Cada campo consiste de un nombre, un carácter que indica el tipo de campo, una longitud, y una precisión.

Los tipos de campos disponibles son:

L

Lógico. No tienen longitud ni precisión.

M

Memo. (Sin soporte en PHP.) No tienen longitud ni precisión.

D

Fecha (almacenada como AAAAMMDD). No tienen longitud ni precisión.

N

Número. Tienen longitud y precisión (número de cifras tras el punto decimal).

C

Cadena.

Si la base de datos se crea con éxito, se devuelve un dbase_identifier; en caso contrario, devuelve FALSE.

Ejemplo 1. Crear un fichero dBase

// "database" name
$dbname = "/tmp/test.dbf";

// database "definition"
$def =
    array(
        array("date",     "D"),
        array("name",     "C",  50),
        array("age",      "N",   3, 0),
        array("email",    "C", 128),
        array("ismember", "L")
    );

// creation
if (!dbase_create($dbname, $def))
    print "<strong>Error!</strong>";

Anterior | Inicio | Siguiente
dbase_close | Subir | dbase_delete_record


dbase_open

(PHP 3, PHP 4 >= 4.0.0)

dbase_open -- abre un fichero dBase

Descripción

int dbase_open ( string filename, int flags)

Los "flags" son los que utiliza la llamada al sistema open(). Normalmente, 0 significa sólo lectura, 1 sólo escritura y 2 lectura y escritura.

Devuelve un dbase_identifier del fichero abierto, o FALSE si no pudo abrirse el fichero.

Anterior | Inicio | Siguiente
dbase_numrecords | Subir | dbase_pack


dbase_close

(PHP 3, PHP 4 >= 4.0.0)

dbase_close -- cierra un fichero dBase

Descripción

bool dbase_close ( int dbase_identifier)

Cierra el fichero asociado con dbase_identifier.

Anterior | Inicio | Siguiente
dbase_add_record | Subir | dbase_create


dbase_pack

(PHP 3, PHP 4 >= 4.0.0)

dbase_pack -- "empaqueta" un fichero dBase

Descripción

bool dbase_pack ( int dbase_identifier)

Empaqueta el fichero especificado, borrando definitivamente todos los registros marcados con la función dbase_delete_record().

Anterior | Inicio | Siguiente
dbase_open | Subir | dbase_replace_record


dbase_add_record

(PHP 3, PHP 4 >= 4.0.0)

dbase_add_record -- añade un registro a un fichero dBase

Descripción

bool dbase_add_record ( int dbase_identifier, array record)

Añade los datos de record a la base de datos. Si el número de elementos del registro proporcionado no es igual al número de campos de la base de datos, la operación fallará y la función devolverá FALSE.

Anterior | Inicio | Siguiente
Funciones para dBase | Subir | dbase_close


dbase_replace_record

(PHP 3>= 3.0.11, PHP 4 >= 4.0.0)

dbase_replace_record -- reemplaza un registro en un fichero dBase

Descripción

bool dbase_replace_record ( int dbase_identifier, array record, int dbase_record_number)

Reemplaza los datos asociados con el registro record_number con los datos de record en el fichero de datos. Si el número de elementos del registro proporcionado no es igual al número de campos de la base de datos, la operación fallará y la función devolverá FALSE.

dbase_record_number es un entero en el rango de 1 al número de registros en el fichero de datos (devuelto por la función dbase_numrecords()).

Anterior | Inicio | Siguiente
dbase_pack | Subir | Funciones dbm


dbase_delete_record

(PHP 3, PHP 4 >= 4.0.0)

dbase_delete_record -- borra un registro del fichero dBase

Descripción

bool dbase_delete_record ( int dbase_identifier, int record)

Marca el registro record para ser borrado del fichero de datos. Para eliminar realmente el registro del fichero, debe llamarse a la función dbase_pack().

Anterior | Inicio | Siguiente
dbase_create | Subir | dbase_get_record


dbase_get_record

(PHP 3, PHP 4 >= 4.0.0)

dbase_get_record -- lee un registro de un fichero dBase

Descripción

array dbase_get_record ( int dbase_identifier, int record)

Devuelve los datos del registro record en un array. El array se indexa a partir de 0, e incluye un elemento con el índice asociativo 'deleted', que vale 1 si el registro ha sido marcado para borrar (ver dbase_delete_record().

Cada campo se convierte al tipo PHP apropiado. (Las fechas se guardan como cadenas.)

Anterior | Inicio | Siguiente
dbase_delete_record | Subir | dbase_get_record_with_names


dbase_get_record_with_names

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

dbase_get_record_with_names -- lee un registro de un fichero dBase como array asociativo

Descripción

array dbase_get_record_with_names ( int dbase_identifier, int record)

Devuelve los datos del registro record en un array asociativo. El array incluye también un elemento con índice 'deleted' que vale 1 si el registro ha sido marcado para borrar (ver dbase_delete_record().

Cada campo se convierte al tipo PHP apropiado. (Las fechas se transforman en cadenas.)

Anterior | Inicio | Siguiente
dbase_get_record | Subir | dbase_numfields


dbase_numfields

(PHP 3, PHP 4 >= 4.0.0)

dbase_numfields -- cuenta el número de campos en un fichero dBase

Descripción

int dbase_numfields ( int dbase_identifier)

Devuelve el número de campos (columnas) en el fichero especificado. Los números de campo va de 0 a dbase_numfields($db)-1, mientras los números de registros van de 1 a dbase_numrecords($db).

Ejemplo 1. Uso de dbase_numfields()

$rec = dbase_get_record($db, $recno);
$nf  = dbase_numfields($db);
for ($i=0; $i < $nf; $i++) {
    print $rec[$i]."<br>\n";
}

Anterior | Inicio | Siguiente
dbase_get_record_with_names | Subir | dbase_numrecords


dbase_numrecords

(PHP 3, PHP 4 >= 4.0.0)

dbase_numrecords -- cuenta el número de registros en un fichero dBase

Descripción

int dbase_numrecords ( int dbase_identifier)

Devuelve el número de registros (filas) en el fichero especificado. Los números de registro van de 1 a dbase_numrecords($db), mientras los números de campo van de 0 a dbase_numfields($db)-1.

Anterior | Inicio | Siguiente
dbase_numfields | Subir | dbase_open


Funciones dbm

Manual de PHP
Anterior Siguiente

XX. Funciones dbm

Estas funcione le permiten almacenar registros en una base de datos estilo dbm. Este tipo de base de datos (soportadas por las librerías db y gdbm de Berkeley, así como por algunas librerías del sistema y por una librería incluída para acceso a archivos de texto) guarda pares clave/valor (en oposición a los registros completos soportados por las bases de datos relacionales).

Ejemplo 1. ejemplo de dbm

$dbm = dbmopen("vistoya", "w");
if (dbmexists($dbm, $idusuario)) {
  $visto_ya = dbmfetch($dbm, $idusuario);
} else {
  dbminsert($dbm, $idusuario, time());
}
do_stuff();
dbmreplace($dbm, $idusuario, time());
dbmclose($dbm);

Tabla de contenidos
dblist — describe la librería compatible dbm que se está usando
dbmclose — cierra una base de datos dbm
dbmdelete — borra el valor de una clave de una base de datos dbm
dbmexists — dice si existe un valor para una clave dada en la base de datos dbm
dbmfetch — obtiene un valor para una clave desde la base de datos dbm
dbmfirstkey — obtiene la primera clave de una base de datos dbm
dbminsert — inserta un valor para una clave en la base de datos dbm
dbmnextkey — obtiene la siguiente clave de una base de datos dbm
dbmopen — abre una base de datos dbm
dbmreplace — sustituye el valor de una clave en la base de datos dbm

Anterior | Inicio | Siguiente
dbase_replace_record | Subir | dblist


dbmopen

(PHP 3, PHP 4 >= 4.0.0)

dbmopen -- abre una base de datos dbm

Descripción

int dbmopen ( string fichero, string indicadores)

El primer argumento es el nombre con sendero completo del archivo dbm que se va a abrir y el segundo es el modo de apertura, que puede ser "r", "n", "c" o "w", que significan sólo lectura, nuevo (implica lectura/escritura y suele truncar una base de datos si ya existía con ese nombre), crear (implica lectura/escritura, pero sin truncar la base de datos) y abrir para lectura/escritura, respectivamente.

Devuelve un identificador que se pasa al resto de funciones dbm si tiene éxito, o FALSE si falla.

Si se utiliza el soporte de ndbm, este creará los archivos fichero.dir y fichero.pag. gdbm sólo utiliza un archivo y lo mismo hace el soporte interno de archivos de texto, mientras que el db de Berkeley crea un archivo fichero.db. Nótese que el PHP hace su propio bloqueo de archivo sobre el que pudiera realizar la propia librería dbm. El PHP no borra los archivos .lck que crea. Los utiliza simplemente como i-nodos fijos en los que hacer el bloqueo. Para más información sobre archivos dbm, vea las páginas man de su Unix o obtenga el gdbm de GNU desde ftp://prep.ai.mit.edu/pub/gnu.

Anterior | Inicio | Siguiente
dbmnextkey | Subir | dbmreplace


dbmclose

(PHP 3, PHP 4 >= 4.0.0)

dbmclose -- cierra una base de datos dbm

Descripción

bool dbmclose ( int identif_dbm)

Desbloquea y cierra la base de datos especificada.

Anterior | Inicio | Siguiente
dblist | Subir | dbmdelete


dbmexists

(PHP 3, PHP 4 >= 4.0.0)

dbmexists -- dice si existe un valor para una clave dada en la base de datos dbm

Descripción

bool dbmexists ( int identif_dbm, string clave)

Devuelve TRUE si hay un valor asociado con la clave.

Anterior | Inicio | Siguiente
dbmdelete | Subir | dbmfetch


dbmfetch

(PHP 3, PHP 4 >= 4.0.0)

dbmfetch -- obtiene un valor para una clave desde la base de datos dbm

Descripción

string dbmfetch ( int identif_dbm, string clave)

Devuelve el valor asociado con la clave.

Anterior | Inicio | Siguiente
dbmexists | Subir | dbmfirstkey


dbminsert

(PHP 3, PHP 4 >= 4.0.0)

dbminsert -- inserta un valor para una clave en la base de datos dbm

Descripción

int dbminsert ( int identif_dbm, string clave, string valor)

Añade el valor a la base de datos con la clave especificada.

Devuelve -1 si la base de datos se abrío en modo sólo lectura, 0 si la inserción tuvo éxito y 1 si la clave ya existía (para sustituir el valor, utilice dbmreplace().)

Anterior | Inicio | Siguiente
dbmfirstkey | Subir | dbmnextkey


dbmreplace

(PHP 3, PHP 4 >= 4.0.0)

dbmreplace -- sustituye el valor de una clave en la base de datos dbm

Descripción

bool dbmreplace ( int identif_dbm, string clave, string valor)

Sustituye el valor para la clave especificada de la base de datos.

También añadirá la clave a la base de datos si no existía antes.

Anterior | Inicio | Siguiente
dbmopen | Subir | dbx functions


dbmdelete

(PHP 3, PHP 4 >= 4.0.0)

dbmdelete -- borra el valor de una clave de una base de datos dbm

Descripción

bool dbmdelete ( int identif_dbm, string clave)

Borra el valor para la clave en la base de datos.

Devuelve FALSE si la clave no existía en la base de datos.

Anterior | Inicio | Siguiente
dbmclose | Subir | dbmexists


dbmfirstkey

(PHP 3, PHP 4 >= 4.0.0)

dbmfirstkey -- obtiene la primera clave de una base de datos dbm

Descripción

string dbmfirstkey ( int identif_dbm)

Devuelve la primera clave de la base de datos. Nótese que no se garantiza ningún orden en particular, pues la base de datos se crea utilizando una tabla hash, que no garantiza ordenación alguna.

Anterior | Inicio | Siguiente
dbmfetch | Subir | dbminsert


dbmnextkey

(PHP 3, PHP 4 >= 4.0.0)

dbmnextkey -- obtiene la siguiente clave de una base de datos dbm

Descripción

string dbmnextkey ( int identif_dbm, string clave)

Devuelve la clave que sigue a clave. Llamando a dbmfirstkey() seguida de llamadas sucesivas a dbmnextkey() se pueden visitar todos los pares clave/valor de la base de datos dbm. Por ejemplo:

Ejemplo 1. Visitanco cada par clave/valor en una base de datos dbm.

$clave = dbmfirstkey($id_dbm);
while ($clave) {
    echo "$clave = " . dbmfetch($id_dbm, $clave) . "\n";
    $clave = dbmnextkey($id_dbm, $clave);
}

Anterior | Inicio | Siguiente
dbminsert | Subir | dbmopen


dblist

(PHP 3, PHP 4 >= 4.0.0)

dblist -- describe la librería compatible dbm que se está usando

Descripción

string dblist ( void)

Anterior | Inicio | Siguiente
Funciones dbm | Subir | dbmclose


dbx functions

Manual de PHP
Anterior Siguiente

XXI. dbx functions

The dbx module is a database abstraction layer (db 'X', where 'X' is a supported database). The dbx functions allow you to access all supported databases using a single calling convention. In order to have these functions available, you must compile PHP with dbx support by using the --enable-dbx option and all options for the databases that will be used, e.g. for MySQL you must also specify --with-mysql. The dbx-functions themselves do not interface directly to the databases, but interface to the modules that are used to support these databases. To be able to use a database with the dbx-module, the module must be either linked or loaded into PHP, and the database module must be supported by the dbx-module. Currently, MySQL, PostgreSQL, Microsoft SQL Server, FrontBase, Sybase-CT and ODBC are supported, but others will follow (soon, I hope :-).

Documentation for adding additional database support to dbx can be found at http://www.guidance.nl/php/dbx/doc/.

Tabla de contenidos
dbx_close — Close an open connection/database
dbx_connect — Open a connection/database
dbx_error — Report the error message of the latest function call in the module (not just in the connection)
dbx_query — Send a query and fetch all results (if any)
dbx_sort — Sort a result from a dbx_query by a custom sort function
dbx_compare — Compare two rows for sorting purposes

Anterior | Inicio | Siguiente
dbmreplace | Subir | dbx_close


dbx_close

(PHP 4 >= 4.0.6)

dbx_close -- Close an open connection/database

Description

bool dbx_close ( object link_identifier)

Returns TRUE on success, FALSE on error.

Ejemplo 1. dbx_close() example

<?php
$link = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die ("Could not connect");

print("Connected successfully");
dbx_close($link);
?>

Nota: Always refer to the module-specific documentation as well.

See also: dbx_connect().

Anterior | Inicio | Siguiente
dbx functions | Subir | dbx_connect


dbx_connect

(PHP 4 >= 4.0.6)

dbx_connect -- Open a connection/database

Description

object dbx_connect ( mixed module, string host, string database, string username, string password [, int persistent])

dbx_connect() returns an object on success, FALSE on error. If a connection has been made but the database could not be selected, the connection is closed and FALSE is returned. The persistent parameter can be set to DBX_PERSISTENT, if so, a persistent connection will be created.

The module parameter can be either a string or a constant, though the latter form is preferred. The possible values are given below, but keep in mind that they only work if the module is actually loaded.

  • DBX_MYSQL or "mysql"

  • DBX_ODBC or "odbc"

  • DBX_PGSQL or "pgsql"

  • DBX_MSSQL or "mssql"

  • DBX_FBSQL or "fbsql" (available from PHP 4.1.0)

  • DBX_SYBASECT or "sybase_ct" (CVS only)

The host, database, username and password parameters are expected, but not always used depending on the connect functions for the abstracted module.

The returned object has three properties:

database

It is the name of the currently selected database.

handle

It is a valid handle for the connected database, and as such it can be used in module-specific functions (if required).

$link = dbx_connect (DBX_MYSQL, "localhost", "db", "username", "password");
mysql_close ($link->handle); // dbx_close($link) would be better here

module

It is used internally by dbx only, and is actually the module number mentioned above.

Ejemplo 1. dbx_connect() example

<?php
$link = dbx_connect (DBX_ODBC, "", "db", "username", "password", DBX_PERSISTENT)
    or die ("Could not connect");

print ("Connected successfully");
dbx_close ($link);
?>

Nota: Always refer to the module-specific documentation as well.

See also: dbx_close().

Anterior | Inicio | Siguiente
dbx_close | Subir | dbx_error


dbx_error

(PHP 4 >= 4.0.6)

dbx_error -- Report the error message of the latest function call in the module (not just in the connection)

Description

string dbx_error ( object link_identifier)

dbx_error() returns a string containing the error message from the last function call of the abstracted module (e.g. mysql module). If there are multiple connections in the same module, just the last error is given. If there are connections on different modules, the latest error is returned for the module specified by the link_identifier parameter.

Ejemplo 1. dbx_error() example

<?php
$link   = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die ("Could not connect");

$result = dbx_query($link, "select id from non_existing_table");
if ( $result == 0 ) {
    echo dbx_error ($link);
}
dbx_close ($link);
?>

Nota: Always refer to the module-specific documentation as well.

The error message for Microsoft SQL Server is actually the result of the mssql_get_last_message() function.

Anterior | Inicio | Siguiente
dbx_connect | Subir | dbx_query


dbx_query

(PHP 4 >= 4.0.6)

dbx_query -- Send a query and fetch all results (if any)

Description

object dbx_query ( object link_identifier, string sql_statement [, long flags])

dbx_query() returns an object or 1 on success, and 0 on failure. The result object is returned only if the query given in sql_statement produces a result set.

Ejemplo 1. How to handle the returned value

<?php
$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, 'SELECT id, parentid, description FROM table');

if ( is_object($result) ) {
    // ... do some stuff here, see detailed examples below ...
    // first, print out field names and types
    // then, draw a table filled with the returned field values
}
else if ( $result == 1 ) {
    echo("Query executed successfully, but no result set returned");
}
else {
    exit("Query failed");
}

dbx_close($link);
?>

The flags parameter is used to control the amount of information that is returned. It may be any combination of the following constants with the bitwise OR operator (|):

DBX_RESULT_INDEX

It is always set, that is, the returned object has a data property which is a 2 dimensional array indexed numerically. For example, in the expression data[2][3] 2 stands for the row (or record) number and 3 stands for the column (or field) number. The first row and column are indexed at 0.

If DBX_RESULT_ASSOC is also specified, the returning object contains the information related to DBX_RESULT_INFO too, even if it was not specified.

DBX_RESULT_INFO

It provides info about columns, such as field names and field types.

DBX_RESULT_ASSOC

It effects that the field values can be accessed with the respective column names used as keys to the returned object's data property.

Associated results are actually references to the numerically indexed data, so modifying data[0][0] causes that data[0]['field_name_for_first_column'] is modified as well.

Note that DBX_RESULT_INDEX is always used, regardless of the actual value of flags parameter. This means that the following combinations is effective only:

  • DBX_RESULT_INDEX

  • DBX_RESULT_INDEX | DBX_RESULT_INFO

  • DBX_RESULT_INDEX | DBX_RESULT_INFO | DBX_RESULT_ASSOC - this is the default, if flags is not specified.

The returing object has four or five properties depending on flags:

handle

It is a valid handle for the connected database, and as such it can be used in module specific functions (if required).

$result = dbx_query ($link, "SELECT id FROM table");
mysql_field_len ($result->handle, 0);

cols and rows

These contain the number of columns (or fields) and rows (or records) respectively.

$result = dbx_query ($link, 'SELECT id FROM table');
echo $result->rows; // number of records
echo $result->cols; // number of fields

info (optional)

It is returned only if either DBX_RESULT_INFO or DBX_RESULT_ASSOC is specified in the flags parameter. It is a 2 dimensional array, that has two named rows (name and type) to retrieve column information.

Ejemplo 2. lists each field's name and type

$result = dbx_query ($link, 'SELECT id FROM table',
                     DBX_RESULT_INDEX | DBX_RESULT_INFO);

for ($i = 0; $i < $result->cols; $i++ ) {
    echo $result->info['name'][$i] . "\n";
    echo $result->info['type'][$i] . "\n";
}
data

This property contains the actual resulting data, possibly associated with column names as well depending on flags. If DBX_RESULT_ASSOC is set, it is possible to use $result->data[2]["field_name"].

Ejemplo 3. outputs the content of data property into HTML table

$result = dbx_query ($link, 'SELECT id, parentid, description FROM table');

echo "<table>\n";
foreach ( $result->data as $row ) {
    echo "<tr>\n";
    foreach ( $row as $field ) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";

Nota: Always refer to the module-specific documentation as well.

See also: dbx_connect().

Anterior | Inicio | Siguiente
dbx_error | Subir | dbx_sort


dbx_sort

(PHP 4 >= 4.0.6)

dbx_sort -- Sort a result from a dbx_query by a custom sort function

Description

bool dbx_sort ( object result, string user_compare_function)

Returns TRUE on success, FALSE on error.

Nota: It is always better to use ORDER BY SQL clause instead of dbx_sort(), if possible.

Ejemplo 1. dbx_sort() example

<?php
function user_re_order ($a, $b) {
    $rv = dbx_compare ($a, $b, "parentid", DBX_CMP_DESC);
    if ( !$rv ) {
        $rv = dbx_compare ($a, $b, "id", DBX_CMP_NUMBER);
    }
    return $rv;
}

$link   = dbx_connect (DBX_ODBC, "", "db", "username", "password")
    or die ("Could not connect");

$result = dbx_query ($link, "SELECT id, parentid, description FROM tbl ORDER BY id");
    // data in $result is now ordered by id

dbx_sort ($result, "user_re_order");
    // data in $result is now ordered by parentid (descending), then by id

dbx_close ($link);
?>

See also dbx_compare().

Anterior | Inicio | Siguiente
dbx_query | Subir | dbx_compare


dbx_compare

(PHP 4 >= 4.1.0)

dbx_compare -- Compare two rows for sorting purposes

Description

int dbx_compare ( array row_a, array row_b, string column_key [, int flags])

dbx_compare() returns 0 if the row_a[$column_key] is equal to row_b[$column_key], and 1 or -1 if the former is greater or is smaller than the latter one, respectively, or vice versa if the flag is set to DBX_CMP_DESC. dbx_compare() is a helper function for dbx_sort() to ease the make and use of the custom sorting function.

The flags can be set to specify comparison direction:

  • DBX_CMP_ASC - ascending order

  • DBX_CMP_DESC - descending order

and the preferred comparison type:

  • DBX_CMP_NATIVE - no type conversion

  • DBX_CMP_TEXT - compare items as strings

  • DBX_CMP_NUMBER - compare items numerically

One of the direction and one of the type constant can be combined with bitwise OR operator (|). The default value for the flags parameter is DBX_CMP_ASC | DBX_CMP_NATIVE.

Ejemplo 1. dbx_compare() example

<?php
function user_re_order ($a, $b) {
    $rv = dbx_compare ($a, $b, "parentid", DBX_CMP_DESC);
    if ( !$rv ) {
        $rv = dbx_compare ($a, $b, "id", DBX_CMP_NUMBER);
    }
    return $rv;
}

$link   = dbx_connect (DBX_ODBC, "", "db", "username", "password")
    or die ("Could not connect");

$result = dbx_query ($link, "SELECT id, parentid, description FROM table ORDER BY id");
    // data in $result is now ordered by id

dbx_sort ($result, "user_re_order");
    // date in $result is now ordered by parentid (descending), then by id

dbx_close ($link);
?>

See also dbx_sort().

Anterior | Inicio | Siguiente
dbx_sort | Subir | DB++ Functions


DB++ Functions

Manual de PHP
Anterior Siguiente

XXII. DB++ Functions

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

db++, made by the german company Concept asa, is a relational database system with high performance and low memory and disk usage in mind. While providing SQL as an additional language interface it is not really a SQL database in the first place but provides its own AQL query language which is much more influenced by the relational algebra then SQL is.

Concept asa always had an interest in supporting open source languages, db++ has had Perl and Tcl call interfaces for years now and uses Tcl as its internal stored procedure language.

Requirements

This extension relies on external client libraries so you have to have a db++ client installed on the system you want to use this extension on.

Concept asa provides db++ Demo versions and documentation for Linux, some other UNIX versions. There is also a Windows version of db++, but this extension doesn't support it (yet).

Installation

In order to build this extension yourself you need the db++ client libraries and header files to be installed on your system (these are included in the db++ installation archives by default). You have to run configure with option --with-dbplus to build this extension.

configure looks for the client libraries and header files under the default paths /usr/dbplus, /usr/local/dbplus and /opt/dblus. If you have installed db++ in a different place you have add the installation path to the configure option like this: --with-dbplus=/your/installation/path.

Runtime Configuration

???

Resource Types

dbplus_relation

Most db++ functions operate on or return dbplus_relation resources. A dbplus_relation is a handle to a stored relation or a relation generated as the result of a query.

Predefined Constants

db++ error codes

Tabla 1. DB++ Error Codes

PHP Constant | db++ constant | meaning
DBPLUS_ERR_NOERR | ERR_NOERR | Null error condition
DBPLUS_ERR_DUPLICATE | ERR_DUPLICATE | Tried to insert a duplicate tuple
DBPLUS_ERR_EOSCAN | ERR_EOSCAN | End of scan from rget()
DBPLUS_ERR_EMPTY | ERR_EMPTY | Relation is empty (server)
DBPLUS_ERR_CLOSE | ERR_CLOSE | The server can't close
DBPLUS_ERR_WLOCKED | ERR_WLOCKED | The record is write locked
DBPLUS_ERR_LOCKED | ERR_LOCKED | Relation was already locked
DBPLUS_ERR_NOLOCK | ERR_NOLOCK | Relation cannot be locked
DBPLUS_ERR_READ | ERR_READ | Read error on relation
DBPLUS_ERR_WRITE | ERR_WRITE | Write error on relation
DBPLUS_ERR_CREATE | ERR_CREATE | Create() system call failed
DBPLUS_ERR_LSEEK | ERR_LSEEK | Lseek() system call failed
DBPLUS_ERR_LENGTH | ERR_LENGTH | Tuple exceeds maximum length
DBPLUS_ERR_OPEN | ERR_OPEN | Open() system call failed
DBPLUS_ERR_WOPEN | ERR_WOPEN | Relation already opened for writing
DBPLUS_ERR_MAGIC | ERR_MAGIC | File is not a relation
DBPLUS_ERR_VERSION | ERR_VERSION | File is a very old relation
DBPLUS_ERR_PGSIZE | ERR_PGSIZE | Relation uses a different page size
DBPLUS_ERR_CRC | ERR_CRC | Invalid crc in the superpage
DBPLUS_ERR_PIPE | ERR_PIPE | Piped relation requires lseek()
DBPLUS_ERR_NIDX | ERR_NIDX | Too many secondary indices
DBPLUS_ERR_MALLOC | ERR_MALLOC | Malloc() call failed
DBPLUS_ERR_NUSERS | ERR_NUSERS | Error use of max users
DBPLUS_ERR_PREEXIT | ERR_PREEXIT | Caused by invalid usage
DBPLUS_ERR_ONTRAP | ERR_ONTRAP | Caused by a signal
DBPLUS_ERR_PREPROC | ERR_PREPROC | Error in the preprocessor
DBPLUS_ERR_DBPARSE | ERR_DBPARSE | Error in the parser
DBPLUS_ERR_DBRUNERR | ERR_DBRUNERR | Run error in db
DBPLUS_ERR_DBPREEXIT | ERR_DBPREEXIT | Exit condition caused by prexit() * procedure
DBPLUS_ERR_WAIT | ERR_WAIT | Wait a little (Simple only)
DBPLUS_ERR_CORRUPT_TUPLE | ERR_CORRUPT_TUPLE | A client sent a corrupt tuple
DBPLUS_ERR_WARNING0 | ERR_WARNING0 | The Simple routines encountered a non fatal error which was corrected
DBPLUS_ERR_PANIC | ERR_PANIC | The server should not really die but after a disaster send ERR_PANIC to all its clients
DBPLUS_ERR_FIFO | ERR_FIFO | Can't create a fifo
DBPLUS_ERR_PERM | ERR_PERM | Permission denied
DBPLUS_ERR_TCL | ERR_TCL | TCL_error
DBPLUS_ERR_RESTRICTED | ERR_RESTRICTED | Only two users
DBPLUS_ERR_USER | ERR_USER | An error in the use of the library by an application programmer
DBPLUS_ERR_UNKNOWN | ERR_UNKNOWN |

Tabla de contenidos
dbplus_add — Add a tuple to a relation
dbplus_aql — Perform AQL query
dbplus_chdir — Get/Set database virtual current directory
dbplus_close — Close a relation
dbplus_curr — Get current tuple from relation
dbplus_errcode — Get error string for given errorcode or last error
dbplus_errno — Get error code for last operation
dbplus_find — Set a constraint on a relation
dbplus_first — Get first tuple from relation
dbplus_flush — Flush all changes made on a relation
dbplus_freealllocks — Free all locks held by this client
dbplus_freelock — Release write lock on tuple
dbplus_freerlocks — Free all tuple locks on given relation
dbplus_getlock — Get a write lock on a tuple
dbplus_getunique — Get a id number unique to a relation
dbplus_info — ???
dbplus_last — Get last tuple from relation
dbplus_lockrel — Request write lock on relation
dbplus_next — Get next tuple from relation
dbplus_open — Open relation file
dbplus_prev — Get previous tuple from relation
dbplus_rchperm — Change relation permissions
dbplus_rcreate — Creates a new DB++ relation
dbplus_rcrtexact — Creates an exact but empty copy of a relation including indices
dbplus_rcrtlike — Creates an empty copy of a relation with default indices
dbplus_resolve — Resolve host information for relation
dbplus_rkeys — Specify new primary key for a relation
dbplus_restorepos — ???
dbplus_ropen — Open relation file local
dbplus_rquery — Perform local (raw) AQL query
dbplus_rrename — Rename a relation
dbplus_rsecindex — Create a new secondary index for a relation
dbplus_runlink — Remove relation from filesystem
dbplus_rzap — Remove all tuples from relation
dbplus_savepos — ???
dbplus_setindex — ???
dbplus_setindexbynumber — ???
dbplus_sql — Perform SQL query
dbplus_tcl — Execute TCL code on server side
dbplus_tremove — Remove tuple and return new current tuple
dbplus_undo — ???
dbplus_undoprepare — ???
dbplus_unlockrel — Give up write lock on relation
dbplus_unselect — Remove a constraint from relation
dbplus_update — Update specified tuple in relation
dbplus_xlockrel — Request exclusive lock on relation
dbplus_xunlockrel — Free exclusive lock on relation

Anterior | Inicio | Siguiente
dbx_compare | Subir | dbplus_add


dbplus_add

(PHP 4 >= 4.1.0)

dbplus_add -- Add a tuple to a relation

Description

int dbplus_add ( resource relation, array tuple)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

This function will add a tuple to a relation. The tuple data is an array of attribute/value pairs to be inserted into the given relation. After successful execution the tuple array will contain the complete data of the newly created tuple, including all implicitly set domain fields like sequences.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

Anterior | Inicio | Siguiente
DB++ Functions | Subir | dbplus_aql


dbplus_aql

(PHP 4 >= 4.1.0)

dbplus_aql -- Perform AQL query

Description

resource dbplus_aql ( string query [, string server [, string dbpath]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_aql() will execute an AQL query on the given server and dbpath.

On success it will return a relation handle. The result data may be fetched from this relation by calling dbplus_next() and dbplus_current(). Other relation access functions will not work on a result relation.

Further information on the AQL A... Query Language is provided in the original db++ manual.

Anterior | Inicio | Siguiente
dbplus_add | Subir | dbplus_chdir


dbplus_chdir

(PHP 4 >= 4.1.0)

dbplus_chdir -- Get/Set database virtual current directory

Description

string dbplus_chdir ( [string newdir])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_chdir() will change the virtual current directory where relation files will be looked for by dbplus_open(). dbplus_chdir() will return the absolute path of the current directory. Calling dbplus_chdir() without giving any newdir may be used to query the current working directory.

Anterior | Inicio | Siguiente
dbplus_aql | Subir | dbplus_close


dbplus_close

(PHP 4 >= 4.1.0)

dbplus_close -- Close a relation

Description

int dbplus_close ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Calling dbplus_close() will close a relation previously opened by dbplus_open().

Anterior | Inicio | Siguiente
dbplus_chdir | Subir | dbplus_curr


dbplus_curr

(PHP 4 >= 4.1.0)

dbplus_curr -- Get current tuple from relation

Description

int dbplus_curr ( resource relation, array tuple)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_curr() will read the data for the current tuple for the given relation and will pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_first(),
dbplus_prev(),
dbplus_next(), and
dbplus_last().

Anterior | Inicio | Siguiente
dbplus_close | Subir | dbplus_errcode


dbplus_errcode

(PHP 4 >= 4.1.0)

dbplus_errcode -- Get error string for given errorcode or last error

Description

string dbplus_errcode ( int errno)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_errcode() returns a cleartext error string for the error code passed as errno of for the result code of the last db++ operation if no parameter is given.

Anterior | Inicio | Siguiente
dbplus_curr | Subir | dbplus_errno


dbplus_errno

(PHP 4 >= 4.1.0)

dbplus_errno -- Get error code for last operation

Description

int dbplus_errno ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_errno() will return the error code returned by the last db++ operation.

See also dbplus_errcode().

Anterior | Inicio | Siguiente
dbplus_errcode | Subir | dbplus_find


dbplus_find

(PHP 4 >= 4.1.0)

dbplus_find -- Set a constraint on a relation

Description

int dbplus_find ( resource relation, array constraints, mixed tuple)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_find() will place a constraint on the given relation. Further calls to functions like dbplus_curr() or dbplus_next() will only return tuples matching the given constraints.

Constraints are triplets of strings containing of a domain name, a comparison operator and a comparison value. The constraints parameter array may consist of a collection of string arrays, each of which contains a domain, an operator and a value, or of a single string array containing a multiple of three elements.

The comparison operator may be one of the following strings: '==', '>', '>=', '<', '<=', '!=', '~' for a regular expression match and 'BAND' or 'BOR' for bitwise operations.

See also dbplus_unselect().

Anterior | Inicio | Siguiente
dbplus_errno | Subir | dbplus_first


dbplus_first

(PHP 4 >= 4.1.0)

dbplus_first -- Get first tuple from relation

Description

int dbplus_first ( resource relation, array tuple)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_curr() will read the data for the first tuple for the given relation, make it the current tuple and pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_curr(),
dbplus_prev(),
dbplus_next(), and
dbplus_last().

Anterior | Inicio | Siguiente
dbplus_find | Subir | dbplus_flush


dbplus_flush

(PHP 4 >= 4.1.0)

dbplus_flush -- Flush all changes made on a relation

Description

int dbplus_flush ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_flush() will write all changes applied to relation since the last flush to disk.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

Anterior | Inicio | Siguiente
dbplus_first | Subir | dbplus_freealllocks


dbplus_freealllocks

(PHP 4 >= 4.1.0)

dbplus_freealllocks -- Free all locks held by this client

Description

int dbplus_freealllocks ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_freeaalllocks() will free all tuple locks held by this client.

See also dbplus_getlock(),
dbplus_freelock(), and
dbplus_freerlocks().

Anterior | Inicio | Siguiente
dbplus_flush | Subir | dbplus_freelock


dbplus_freelock

(PHP 4 >= 4.1.0)

dbplus_freelock -- Release write lock on tuple

Description

int dbplus_freelock ( resource relation, string tname)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_freelock() will release a write lock on the given tuple previously obtained by dbplus_getlock().

See also dbplus_getlock(),
dbplus_freerlocks(), and
dbplus_freealllocks().

Anterior | Inicio | Siguiente
dbplus_freealllocks | Subir | dbplus_freerlocks


dbplus_freerlocks

(PHP 4 >= 4.1.0)

dbplus_freerlocks -- Free all tuple locks on given relation

Description

int dbplus_freerlocks ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_freerlocks() will free all tuple locks held on the given relation.

See also dbplus_getlock(),
dbplus_freelock(), and
dbplus_freealllocks().

Anterior | Inicio | Siguiente
dbplus_freelock | Subir | dbplus_getlock


dbplus_getlock

(PHP 4 >= 4.1.0)

dbplus_getlock -- Get a write lock on a tuple

Description

int dbplus_getlock ( resource relation, string tname)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_getlock() will request a write lock on the specified tuple. It will return zero on success or a non-zero error code, especially DBPLUS_ERR_WLOCKED, on failure.

See also dbplus_freelock(),
dbplus_freerlocks(), and
dbplus_freealllocks().

Anterior | Inicio | Siguiente
dbplus_freerlocks | Subir | dbplus_getunique


dbplus_getunique

(PHP 4 >= 4.1.0)

dbplus_getunique -- Get a id number unique to a relation

Description

int dbplus_getunique ( resource relation, int uniqueid)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_getunique() will obtain a number guaranteed to be unique for the given relation and will pass it back in the variable given as uniqueid.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

Anterior | Inicio | Siguiente
dbplus_getlock | Subir | dbplus_info


dbplus_info

(PHP 4 >= 4.1.0)

dbplus_info -- ???

Description

int dbplus_info ( resource relation, string key, array )

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Not implemented yet.

Anterior | Inicio | Siguiente
dbplus_getunique | Subir | dbplus_last


dbplus_last

(PHP 4 >= 4.1.0)

dbplus_last -- Get last tuple from relation

Description

int dbplus_last ( resource relation, array tuple)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_curr() will read the data for the last tuple for the given relation, make it the current tuple and pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_first(),
dbplus_curr(),
dbplus_prev(), and
dbplus_next().

Anterior | Inicio | Siguiente
dbplus_info | Subir | dbplus_lockrel


dbplus_lockrel

(unknown)

dbplus_lockrel -- Request write lock on relation

Description

int dbplus_lockrel ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_lockrel() will request a write lock on the given relation. Other clients may still query the relation, but can't alter it while it is locked.

Anterior | Inicio | Siguiente
dbplus_last | Subir | dbplus_next


dbplus_next

(PHP 4 >= 4.1.0)

dbplus_next -- Get next tuple from relation

Description

int dbplus_next ( resource relation, array )

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_curr() will read the data for the next tuple for the given relation, will make it the current tuple and will pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_first(),
dbplus_curr(),
dbplus_prev(), and
dbplus_last().

Anterior | Inicio | Siguiente
dbplus_lockrel | Subir | dbplus_open


dbplus_open

(PHP 4 >= 4.1.0)

dbplus_open -- Open relation file

Description

resource dbplus_open ( string name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

The relation file name will be opened. name can be either a file name or a relative or absolute path name. This will be mapped in any case to an absolute relation file path on a specific host machine and server.

On success a relation file resource (cursor) is returned which must be used in any subsequent commands referencing the relation. Failure leads to a zero return value, the actual error code may be asked for by calling dbplus_errno().

Anterior | Inicio | Siguiente
dbplus_next | Subir | dbplus_prev


dbplus_prev

(PHP 4 >= 4.1.0)

dbplus_prev -- Get previous tuple from relation

Description

int dbplus_prev ( resource relation, array tuple)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_curr() will read the data for the next tuple for the given relation, will make it the current tuple and will pass it back as an associative array in tuple.

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure. See dbplus_errcode() or the introduction to this chapter for more information on db++ error codes.

See also dbplus_first(),
dbplus_curr(),
dbplus_next(), and
dbplus_last().

Anterior | Inicio | Siguiente
dbplus_open | Subir | dbplus_rchperm


dbplus_rchperm

(PHP 4 >= 4.1.0)

dbplus_rchperm -- Change relation permissions

Description

int dbplus_rchperm ( resource relation, int mask, string user, string group)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_rchperm() will change access permissions as specified by mask, user and group. The values for these are operating system specific.

Anterior | Inicio | Siguiente
dbplus_prev | Subir | dbplus_rcreate


dbplus_rcreate

(PHP 4 >= 4.1.0)

dbplus_rcreate -- Creates a new DB++ relation

Description

resource dbplus_rcreate ( string name, mixed domlist [, boolean overwrite])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_rcreate() will create a new relation named name. An existing relation by the same name will only be overwritten if the relation is currently not in use and overwrite is set to TRUE.

domlist should contain the domain specification for the new relation within an array of domain description strings. ( dbplus_rcreate() will also accept a string with space delimited domain description strings, but it is recommended to use an array). A domain description string consists of a domain name unique to this relation, a slash and a type specification character. See the db++ documentation, especially the dbcreate(1) manpage, for a description of available type specifiers and their meanings.

Anterior | Inicio | Siguiente
dbplus_rchperm | Subir | dbplus_rcrtexact


dbplus_rcrtexact

(PHP 4 >= 4.1.0)

dbplus_rcrtexact -- Creates an exact but empty copy of a relation including indices

Description

resource dbplus_rcrtexact ( string name, resource relation, boolean overwrite)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_rcrtexact() will create an exact but empty copy of the given relation under a new name. An existing relation by the same name will only be overwritten if overwrite is TRUE and no other process is currently using the relation.

Anterior | Inicio | Siguiente
dbplus_rcreate | Subir | dbplus_rcrtlike


dbplus_rcrtlike

(PHP 4 >= 4.1.0)

dbplus_rcrtlike -- Creates an empty copy of a relation with default indices

Description

resource dbplus_rcrtlike ( string name, resource relation, int flag)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_rcrtexact() will create an empty copy of the given relation under a new name, but with default indices. An existing relation by the same name will only be overwritten if overwrite is TRUE and no other process is currently using the relation.

Anterior | Inicio | Siguiente
dbplus_rcrtexact | Subir | dbplus_resolve


dbplus_resolve

(PHP 4 >= 4.1.0)

dbplus_resolve -- Resolve host information for relation

Description

int dbplus_resolve ( string relation_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_resolve() will try to resolve the given relation_name and find out internal server id, real hostname and the database path on this host. The function will return an array containing these values under the keys 'sid', 'host' and 'host_path' or FALSE on error.

See also dbplus_tcl().

Anterior | Inicio | Siguiente
dbplus_rcrtlike | Subir | dbplus_rkeys


dbplus_rkeys

(PHP 4 >= 4.1.0)

dbplus_rkeys -- Specify new primary key for a relation

Description

resource dbplus_rkeys ( resource relation, mixed domlist)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_rkeys() will replace the current primary key for relation with the combination of domains specified by domlist.

domlist may be passed as a single domain name string or as an array of domain names.

Anterior | Inicio | Siguiente
dbplus_resolve | Subir | dbplus_restorepos


dbplus_restorepos

(PHP 4 >= 4.1.0)

dbplus_restorepos -- ???

Description

int dbplus_restorepos ( resource relation, array tuple)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Not implemented yet.

Anterior | Inicio | Siguiente
dbplus_rkeys | Subir | dbplus_ropen


dbplus_ropen

(PHP 4 >= 4.1.0)

dbplus_ropen -- Open relation file local

Description

resource dbplus_ropen ( string name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_ropen() will open the relation file locally for quick access without any client/server overhead. Access is read only and only dbplus_current() and dbplus_next() may be applied to the returned relation.

Anterior | Inicio | Siguiente
dbplus_restorepos | Subir | dbplus_rquery


dbplus_rquery

(PHP 4 >= 4.1.0)

dbplus_rquery -- Perform local (raw) AQL query

Description

int dbplus_rquery ( string query, string dbpath)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_rquery() performs a local (raw) AQL query using an AQL interpreter embedded into the db++ client library. dbplus_rquery() is faster than dbplus_aql() but will work on local data only.

Anterior | Inicio | Siguiente
dbplus_ropen | Subir | dbplus_rrename


dbplus_rrename

(PHP 4 >= 4.1.0)

dbplus_rrename -- Rename a relation

Description

int dbplus_rrename ( resource relation, string name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_rrename() will change the name of relation to name.

Anterior | Inicio | Siguiente
dbplus_rquery | Subir | dbplus_rsecindex


dbplus_rsecindex

(PHP 4 >= 4.1.0)

dbplus_rsecindex -- Create a new secondary index for a relation

Description

resource dbplus_rsecindex ( resource relation, mixed domlist, int type)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_rsecindex() will create a new secondary index for relation with consists of the domains specified by domlist and is of type type

domlist may be passed as a single domain name string or as an array of domain names.

Anterior | Inicio | Siguiente
dbplus_rrename | Subir | dbplus_runlink


dbplus_runlink

(PHP 4 >= 4.1.0)

dbplus_runlink -- Remove relation from filesystem

Description

int dbplus_runlink ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_unlink() will close and remove the relation.

Anterior | Inicio | Siguiente
dbplus_rsecindex | Subir | dbplus_rzap


dbplus_rzap

(PHP 4 >= 4.1.0)

dbplus_rzap -- Remove all tuples from relation

Description

int dbplus_rzap ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_rzap() will remove all tuples from relation.

Anterior | Inicio | Siguiente
dbplus_runlink | Subir | dbplus_savepos


dbplus_savepos

(PHP 4 >= 4.1.0)

dbplus_savepos -- ???

Description

int dbplus_savepos ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Not implemented yet.

Anterior | Inicio | Siguiente
dbplus_rzap | Subir | dbplus_setindex


dbplus_setindex

(PHP 4 >= 4.1.0)

dbplus_setindex -- ???

Description

int dbplus_setindex ( resource relation, string idx_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Not implemented yet.

Anterior | Inicio | Siguiente
dbplus_savepos | Subir | dbplus_setindexbynumber


dbplus_setindexbynumber

(PHP 4 >= 4.1.0)

dbplus_setindexbynumber -- ???

Description

int dbplus_setindexbynumber ( resource relation, int idx_number)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Not implemented yet.

Anterior | Inicio | Siguiente
dbplus_setindex | Subir | dbplus_sql


dbplus_sql

(PHP 4 >= 4.1.0)

dbplus_sql -- Perform SQL query

Description

resource dbplus_sql ( string query, string server, string dbpath)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Not implemented yet.

Anterior | Inicio | Siguiente
dbplus_setindexbynumber | Subir | dbplus_tcl


dbplus_tcl

(PHP 4 >= 4.1.0)

dbplus_tcl -- Execute TCL code on server side

Description

int dbplus_tcl ( int sid, string script)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

A db++ server will prepare a TCL interpreter for each client connection. This interpreter will enable the server to execute TCL code provided by the client as a sort of stored procedures to improve the performance of database operations by avoiding client/server data transfers and context switches.

dbplus_tcl() needs to pass the client connection id the TCL script code should be executed by. dbplus_resolve() will provide this connection id. The function will return whatever the TCL code returns or a TCL error message if the TCL code fails.

See also dbplus_resolve().

Anterior | Inicio | Siguiente
dbplus_sql | Subir | dbplus_tremove


dbplus_tremove

(PHP 4 >= 4.1.0)

dbplus_tremove -- Remove tuple and return new current tuple

Description

int dbplus_tremove ( resource relation, array tuple [, array current])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_tremove() removes tuple from relation if it perfectly matches a tuple within the relation. current, if given, will contain the data of the new current tuple after calling dbplus_tremove().

Anterior | Inicio | Siguiente
dbplus_tcl | Subir | dbplus_undo


dbplus_undo

(PHP 4 >= 4.1.0)

dbplus_undo -- ???

Description

int dbplus_undo ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Not implemented yet.

Anterior | Inicio | Siguiente
dbplus_tremove | Subir | dbplus_undoprepare


dbplus_undoprepare

(PHP 4 >= 4.1.0)

dbplus_undoprepare -- ???

Description

int dbplus_undoprepare ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Not implemented yet.

Anterior | Inicio | Siguiente
dbplus_undo | Subir | dbplus_unlockrel


dbplus_unlockrel

(PHP 4 >= 4.1.0)

dbplus_unlockrel -- Give up write lock on relation

Description

int dbplus_unlockrel ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_unlockrel() will release a write lock previously obtained by dbplus_lockrel().

Anterior | Inicio | Siguiente
dbplus_undoprepare | Subir | dbplus_unselect


dbplus_unselect

(PHP 4 >= 4.1.0)

dbplus_unselect -- Remove a constraint from relation

Description

int dbplus_unselect ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Calling dbplus_unselect() will remove a constraint previously set by dbplus_find() on relation.

Anterior | Inicio | Siguiente
dbplus_unlockrel | Subir | dbplus_update


dbplus_update

(PHP 4 >= 4.1.0)

dbplus_update -- Update specified tuple in relation

Description

int dbplus_update ( resource relation, array old, array new)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_update() replaces the tuple given by old with the data from new if and only if old completely matches a tuple within relation.

Anterior | Inicio | Siguiente
dbplus_unselect | Subir | dbplus_xlockrel


dbplus_xlockrel

(PHP 4 >= 4.1.0)

dbplus_xlockrel -- Request exclusive lock on relation

Description

int dbplus_xlockrel ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_xlockrel() will request an exclusive lock on relation preventing even read access from other clients.

See also dbplus_xunlockrel().

Anterior | Inicio | Siguiente
dbplus_update | Subir | dbplus_xunlockrel


dbplus_xunlockrel

(PHP 4 >= 4.1.0)

dbplus_xunlockrel -- Free exclusive lock on relation

Description

int dbplus_xunlockrel ( resource relation)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

dbplus_xunlockrel() will release an exclusive lock on relation previously obtained by dbplus_xlockrel().

Anterior | Inicio | Siguiente
dbplus_xlockrel | Subir | Direct IO functions


Direct IO functions

Manual de PHP
Anterior Siguiente

XXIII. Direct IO functions

Direct I/O Functions

PHP supports the direct io functions as described in the Posix Standard (Section 6) for performing I/O functions at a lower level than the C-Language stream I/O functions (fopen, fread,..).

Installation

To get these functions to work, you have to configure PHP with --enable-dio.

Tabla de contenidos
dio_open — Opens a new filename with specified permissions of flags and creation permissions of mode
dio_read — Reads n bytes from fd and returns them, if n is not specified, reads 1k block
dio_write — Writes data to fd with optional truncation at length
dio_truncate — Truncates file descriptor fd to offset bytes
dio_stat — Gets stat information about the file descriptor fd
dio_seek — Seeks to pos on fd from whence
dio_fcntl — Performs a c library fcntl on fd
dio_close — Closes the file descriptor given by fd

Anterior | Inicio | Siguiente
dbplus_xunlockrel | Subir | dio_open


dio_open

(PHP 4 >= 4.2.0)

dio_open -- Opens a new filename with specified permissions of flags and creation permissions of mode

Description

resource dio_open ( string filename, int flags [, int mode])

dio_open() opens a file and returns a new file descriptor for it, or -1 if any error occurred. If flags is O_CREAT, optional third parameter mode will set the mode of the file (creation permissions). The flags parameter can be one of the following options:

  • O_RDONLY - opens the file for read access

  • O_WRONLY - opens the file for write access

  • O_RDWR - opens the file for both reading and writing

The flags parameter can also include any combination of the following flags:

  • O_CREAT - creates the file, if it doesn't already exist

  • O_EXCL - if both, O_CREAT and O_EXCL are set, dio_open() fails, if file already exists

  • O_TRUNC - if file exists, and its opened for write access, file will be truncated to zero length.

  • O_APPEND - write operations write data at the end of file

  • O_NONBLOCK - sets non blocking mode

Anterior | Inicio | Siguiente
Direct IO functions | Subir | dio_read


dio_read

(PHP 4 >= 4.2.0)

dio_read -- Reads n bytes from fd and returns them, if n is not specified, reads 1k block

Description

string dio_read ( resource fd [, int n])

The function dio_read() reads and returns n bytes from file with descriptor resource. If n is not specified, dio_read() reads 1K sized block and returns them.

Anterior | Inicio | Siguiente
dio_open | Subir | dio_write


dio_write

(PHP 4 >= 4.2.0)

dio_write -- Writes data to fd with optional truncation at length

Description

int dio_write ( resource fd, string data [, int len])

The function dio_write() writes up to len bytes from data to file fd. If len is not specified, dio_write() writes all data to the specified file. dio_write() returns the number of bytes written to fd.

Anterior | Inicio | Siguiente
dio_read | Subir | dio_truncate


dio_truncate

(PHP 4 >= 4.2.0)

dio_truncate -- Truncates file descriptor fd to offset bytes

Description

bool dio_truncate ( resource fd, int offset)

Function dio_truncate() causes the file referenced by fd to be truncated to at most offset bytes in size. If the file previously was larger than this size, the extra data is lost. If the file previously was shorter, it is unspecified whether the file is left unchanged or is extended. In the latter case the extended part reads as zero bytes. Returns 0 on success, otherwise -1.

Anterior | Inicio | Siguiente
dio_write | Subir | dio_stat


dio_stat

(PHP 4 >= 4.2.0)

dio_stat -- Gets stat information about the file descriptor fd

Description

array dio_stat ( resource fd)

Function dio_stat() returns information about the file with file descriptor fd. dio_stat() returns an associative array with the following keys:

  • "device" - device

  • "inode" - inode

  • "mode" - mode

  • "nlink" - number of hard links

  • "uid" - user id

  • "gid" - group id

  • "device_type" - device type (if inode device)

  • "size" - total size in bytes

  • "blocksize" - blocksize

  • "blocks" - number of blocks allocated

  • "atime" - time of last access

  • "mtime" - time of last modification

  • "ctime" - time of last change

On error dio_stat() returns NULL.

Anterior | Inicio | Siguiente
dio_truncate | Subir | dio_seek


dio_seek

(PHP 4 >= 4.2.0)

dio_seek -- Seeks to pos on fd from whence

Description

int dio_seek ( resource fd, int pos, int whence)

The function dio_seek() is used to change the file position of the file with descriptor resource. The parameter whence specifies how the position pos should be interpreted:

  • SEEK_SET - specifies that pos is specified from the beginning of the file

  • SEEK_CUR - Specifies that pos is a count of characters from the current file position. This count may be positive or negative

  • SEEK_END - Specifies that pos is a count of characters from the end of the file. A negative count specifies a position within the current extent of the file; a positive count specifies a position past the current end. If you set the position past the current end, and actually write data, you will extend the file with zeros up to that position

Anterior | Inicio | Siguiente
dio_stat | Subir | dio_fcntl


dio_fcntl

(PHP 4 >= 4.2.0)

dio_fcntl -- Performs a c library fcntl on fd

Description

mixed dio_fcntl ( resource fd, int cmd [, mixed arg])

The dio_fcntl() function performs the operation specified by cmd on the file descriptor fd. Some commands require additional arguments args to be supplied.

arg is an associative array, when cmd is F_SETLK or F_SETLLW, with the following keys:

  • "start" - offset where lock begins

  • "length" - size of locked area. zero means to end of file

  • "wenth" - Where l_start is relative to: can be SEEK_SET, SEEK_END and SEEK_CUR

  • "type" - type of lock: can be F_RDLCK (read lock), F_WRLCK (write lock) or F_UNLCK (unlock)

cmd can be one of the following operations:

  • F_SETLK - Lock is set or cleared. If the lock is held by someone else dio_fcntl() returns -1.

  • F_SETLKW - like F_SETLK, but in case the lock is held by someone else, dio_fcntl() waits until the lock is released.

  • F_GETLK - dio_fcntl() returns an associative array (as described above) if someone else prevents lock. If there is no obstruction key "type" will set to F_UNLCK.

  • F_DUPFD - finds the lowest numbered available file descriptor greater or equal than arg and returns them.

Anterior | Inicio | Siguiente
dio_seek | Subir | dio_close


dio_close

(PHP 4 >= 4.2.0)

dio_close -- Closes the file descriptor given by fd

Description

void dio_close ( resource fd)

The function dio_close() closes the file descriptor resource.

Anterior | Inicio | Siguiente
dio_fcntl | Subir | Funciones con directorios


Funciones con directorios

Manual de PHP
Anterior Siguiente

XXIV. Funciones con directorios

Tabla de contenidos
chdir — cambia de directorio
dir — clase directorio
closedir — cierra el manejador de directorios
opendir — abre el manejador de directorios
readdir — lee las entradas del manejador de directorios
rewinddir — rebobinar el manejador de directorios

Anterior | Inicio | Siguiente
dio_close | Subir | chdir


chdir

(PHP 3, PHP 4 >= 4.0.0)

chdir -- cambia de directorio

Description

int chdir ( string directory)

Cambia el directorio PHP actual a directory. Devuelve FALSE si no puede cambiar al directorio, TRUE si todo va bien.

Anterior | Inicio | Siguiente
Funciones con directorios | Subir | dir


dir

(PHP 3, PHP 4 >= 4.0.0)

dir -- clase directorio

Descripcion

new dir ( string directory)

Un mecanismo semi-orientado a objetos para leer directorios. El parametro directory abre el directorio. Dos propiedades estan disponibles cuando el directorio ha sido abierto. La propiedad de manejo puede ser usada con otras funciones de directorios tal como readdir(), rewinddir() y closedir(). La propiedad de trayectoria (path) es fijada para encaminar el directorio que ha sido abierto. Tres metodos estan disponibles: leer, rebobinar y cerrar.

Ejemplo 1. dir() Ejemplo

$d = dir("/etc");
      echo "Handle: ".$d->handle."<br>\n";
      echo "Path: ".$d->path."<br>\n";
      while($entry=$d->read()) {
      echo $entry."<br>\n";
      }
      $d->close();

Anterior | Inicio | Siguiente
chdir | Subir | closedir


closedir

(PHP 3, PHP 4 >= 4.0.0)

closedir -- cierra el manejador de directorios

Descripcion

void closedir ( int dir_handle)

Cierra la secuencia de directorio determinada por dir_handle. La secuencia debe de haber sido abierta previamente con opendir().

Anterior | Inicio | Siguiente
dir | Subir | opendir


opendir

(PHP 3, PHP 4 >= 4.0.0)

opendir -- abre el manejador de directorios

Descripcion

int opendir ( string path)

Devuelve un manejador de directorio para ser usado con las llamadas closedir(), readdir() y rewinddir().

Anterior | Inicio | Siguiente
closedir | Subir | readdir


readdir

(PHP 3, PHP 4 >= 4.0.0)

readdir -- lee las entradas del manejador de directorios

Descripcion

string readdir ( int dir_handle)

Devuelve el nombre del siguiente fichero en el directorio. Los nombres de ficheros no son devueltos en ningun orden especial .

Ejemplo 1. Listar todos los ficheros en un directorio

<?php
      $handle=opendir('.');
      echo "Directory handle: $handle\n";
      echo "Files:\n";
      while ($file = readdir($handle)) {
       echo "$file\n";
       }
       closedir($handle);
       ?>

Tener en cuenta que readdir() devolvera tambien . y .. Si no quereis estas entradas podeis borrarlas:

Ejemplo 2. Listar todos los ficheros en un directorio excepto . y ..

<?php
      $handle=opendir('.');
      while ($file = readdir($handle)) {
       if ($file != "." && $file != "..") {
         echo "$file\n";
     }
     }
     closedir($handle);
     ?>

Anterior | Inicio | Siguiente
opendir | Subir | rewinddir


rewinddir

(PHP 3, PHP 4 >= 4.0.0)

rewinddir -- rebobinar el manejador de directorios

Descripcion

void rewinddir ( int dir_handle)

Inizializa la secuencia de directorio determinada por dir_handle al principio del directorio.

Anterior | Inicio | Siguiente
readdir | Subir | Funciones de DOM XML


Funciones de DOM XML

Manual de PHP
Anterior Siguiente

XXV. Funciones de DOM XML

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

Estas funciones son disponibles solamente si PHP fué configurado con --with-dom=[DIR], usando al libreria de XML de GNOME. Usted va a necesitar como mínimo libxml-2.0.0 (la versión beta no trabajará). Estas functiones fueron añadidas en PHP4.

Este module define las siguientes constantes:

Tabla 1. Constantes de XML

Constante | Valor | Descripción
XML_ELEMENT_NODE | 1 |
XML_ATTRIBUTE_NODE | 2 |
XML_TEXT_NODE | 3 |
XML_CDATA_SECTION_NODE | 4 |
XML_ENTITY_REF_NODE | 5 |
XML_ENTITY_NODE | 6 |
XML_PI_NODE | 7 |
XML_COMMENT_NODE | 8 |
XML_DOCUMENT_NODE | 9 |
XML_DOCUMENT_TYPE_NODE | 10 |
XML_DOCUMENT_FRAG_NODE | 11 |
XML_NOTATION_NODE | 12 |
XML_GLOBAL_NAMESPACE | 1 |
XML_LOCAL_NAMESPACE | 2 |

Este modulo define un número de clases. Las funciones de DOM XML devuelven un árbol conteniendo la structura del documento XML, en el cual cada nodo es un objecto perteneciente a una de estas clases.

Tabla de contenidos
xmldoc — Crea un objecto DOM representando un documento XML
xmldocfile — Creat un objecto DOM a partir de un archivo XML
xmltree — Crea un árbol de objectos PHP a partir del un document XML

Anterior | Inicio | Siguiente
rewinddir | Subir | xmldoc


xmldoc

(PHP 4 >= 4.0.0)

xmldoc -- Crea un objecto DOM representando un documento XML

Descripción

object xmldoc ( string str)

Esta función analiza el documento XML contenido en el texto str y devuelve un objecto de clase "Documento Dom", que tiene las propiedades "doc" (resource), "version" (string) y "typo" (long).

Anterior | Inicio | Siguiente
Funciones de DOM XML | Subir | xmldocfile


xmldocfile

(PHP 4 >= 4.0.0)

xmldocfile -- Creat un objecto DOM a partir de un archivo XML

Descripción

object xmldocfile ( string filename)

Esta función analiza el documento XML contenido en el archivo referido en filename y devuelve un objecto de clase "Documento Dom", que tiene las propiedades "doc" (resource), "version" (string) y "typo" (long).

Anterior | Inicio | Siguiente
xmldoc | Subir | xmltree


xmltree

(PHP 4 >= 4.0.0)

xmltree -- Crea un árbol de objectos PHP a partir del un document XML

Descripción

object xmltree ( string str)

Esta función analiza el documento XML contenido en el texto str y devuelve in árbol de objectos PHP representando el documento analizado.

Anterior | Inicio | Siguiente
xmldocfile | Subir | .NET functions


.NET functions

Manual de PHP
Anterior Siguiente

XXVI. .NET functions

Tabla de contenidos
dotnet_load — Loads a DOTNET module

Anterior | Inicio | Siguiente
xmltree | Subir | dotnet_load


dotnet_load

(unknown)

dotnet_load -- Loads a DOTNET module

Description

int dotnet_load ( string assembly_name [, string datatype_name [, int codepage]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
.NET functions | Subir | Error Handling and Logging Functions


Error Handling and Logging Functions

Manual de PHP
Anterior Siguiente

XXVII. Error Handling and Logging Functions

These are functions dealing with error handling and logging. They allow you to define your own error handling rules, as well as modify the way the errors can be logged. This allows you to change and enhance error reporting to suit your needs.

With the logging functions, you can send messages directly to other machines, to an email (or email to pager gateway!), to system logs, etc., so you can selectively log and monitor the most important parts of your applications and websites.

The error reporting functions allow you to customize what level and kind of error feedback is given, ranging from simple notices to customized functions returned during errors.

Tabla de contenidos
error_log — envía un mensaje de error a algún lugar
error_reporting — establece que errores PHP son registrados
restore_error_handler — Restores the previous error handler function
set_error_handler — Sets a user-defined error handler function.
trigger_error — Generates a user-level error/warning/notice message
user_error — Generates a user-level error/warning/notice message

Anterior | Inicio | Siguiente
dotnet_load | Subir | error_log


error_log

(PHP 3, PHP 4 >= 4.0.0)

error_log -- envía un mensaje de error a algún lugar

Descripción

int error_log ( string message, int message_type [, string destination [, string extra_headers]])

Envía un mensaje de error al log de errores del servidor web, a un puerto TCP o a un fichero. El primer parámetro, message (mensaje), es el mensaje de error que debe ser registrado. El segundo parámetro, message_type (tipo de mensaje) indica el lugar al que debe dirigirse:

Tabla 1. error_log() tipos de log

0 | message es enviado al registro de sistema de PHP, utilizando el mecanismo de registro de sistema del Sistema Operativo, o a un fichero, dependiendo del valor de la directiva de configuración error_log
1 | message es enviado por correo electrónico a la dirección del parámetro destination (destino). Este es el único tipo de mensaje donde se utiliza el cuarto parámetro, extra_headers. Este tipo de mensaje utiliza la misma funcionalidad interna que mail() realiza.
2 | message es enviado a través de la conexión de depuración de PHP. Esta opción está disponible sólo si la depuración remota ha sido activada. En este caso el parámetro destination especifica el nombre de host o dirección IP y, opcionalmente, el número de puerto del socket que recibe la información de depuración.
3 | message es añadido al fichero destination.

Ejemplo 1. error_log() ejemplos

// Send notification through the server log if we can not
// connect to the database.
if (!Ora_Logon($username, $password)) {
    error_log("Oracle database not available!", 0);
}

// Notify administrator by email if we run out of FOO
if (!($foo = allocate_new_foo()) {
    error_log("Big trouble, we're all out of FOOs!", 1,
              "operator@mydomain.com");
}

// other ways of calling error_log():
error_log("You messed up!", 2, "127.0.0.1:7000");
error_log("You messed up!", 2, "loghost");
error_log("You messed up!", 3, "/var/tmp/my-errors.log");

Anterior | Inicio | Siguiente
Error Handling and Logging Functions | Subir | error_reporting


error_reporting

(PHP 3, PHP 4 >= 4.0.0)

error_reporting -- establece que errores PHP son registrados

Descripción

int error_reporting ( [int level])

Establece el nivel de registro de los errores PHP y devuelve el nivel anterior. El nivel de registro es una máscara de bits de los valores siguientes (siga los enlaces a los valores internos para obtener sus significados):

Tabla 1. error_reporting() valores de bit

valor | nombre interno
1 | E_ERROR
2 | E_WARNING
4 | E_PARSE
8 | E_NOTICE
16 | E_CORE_ERROR
32 | E_CORE_WARNING

Anterior | Inicio | Siguiente
error_log | Subir | restore_error_handler


restore_error_handler

(PHP 4 )

restore_error_handler -- Restores the previous error handler function

Description

void restore_error_handler ( void)

Used after changing the error handler function using set_error_handler(), to revert to the previous error handler (which could be the built-in or a user defined function)

See also error_reporting(),
set_error_handler(),
trigger_error(), user_error()

Anterior | Inicio | Siguiente
error_reporting | Subir | set_error_handler


set_error_handler

(PHP 4 )

set_error_handler -- Sets a user-defined error handler function.

Description

string set_error_handler ( string error_handler)

Sets a user function (error_handler) to handle errors in a script. Returns the previously defined error handler (if any), or FALSE on error. This function can be used for defining your own way of handling errors during runtime, for example in applications in which you need to do cleanup of data/files when a critical error happens, or when you need to trigger an error under certain conditions (using trigger_error())

The user function needs to accept 2 parameters: the error code, and a string describing the error. The example below shows the handling of internal execptions by triggering errors and handling them with a user defined function:

Ejemplo 1. Error handling with set_error_handler() and trigger_error()

<?php

// redefine the user error constants - PHP4 only
define (FATAL,E_USER_ERROR);
define (ERROR,E_USER_WARNING);
define (WARNING,E_USER_NOTICE);

// set the error reporting level for this script
error_reporting  (FATAL + ERROR + WARNING);

// error handler function
function myErrorHandler ($errno, $errstr) {
    switch ($errno) {
    case FATAL:
    echo "<b>FATAL</b> [$errno] $errstr<br>\n";
    echo "  Fatal error in line ".__LINE__." of file ".__FILE__;
    echo ", PHP ".PHP_VERSION." (".PHP_OS.")<br>\n";
    echo "Aborting...<br>\n";
    exit -1;
    break;
    case ERROR:
    echo "<b>ERROR</b> [$errno] $errstr<br>\n";
    break;
    case WARNING:
    echo "<b>WARNING</b> [$errno] $errstr<br>\n";
    break;
    default:
    echo "Unkown error type: [$errno] $errstr<br>\n";
    break;
    }
}

// function to test the error handling
function scale_by_log ($vect, $scale) {
    if ( !is_numeric($scale) || $scale <= 0 )
    trigger_error("log(x) for x <= 0 is undefined, you used: scale = $scale",
      FATAL);
    if (!is_array($vect)) {
    trigger_error("Incorrect input vector, array of values expected", ERROR);
    return null;
    }
    for ($i=0; $i<count($vect); $i++) {
    if (!is_numeric($vect[$i]))
    trigger_error("Value at position $i is not a number, using 0 (zero)",
      WARNING);
    $temp[$i] = log($scale) * $vect[$i];
    }
    return $temp;
}

// set to the user defined error handler
$old_error_handler = set_error_handler("myErrorHandler");

// trigger some errors, first define a mixed array with a non-numeric item
echo "vector a\n";
$a = array(2,3,"foo",5.5,43.3,21.11);
print_r($a);

// now generate second array, generating a warning
echo "----\nvector b - a warning (b = log(PI) * a)\n";
$b = scale_by_log($a, M_PI);
print_r($b);

// this is trouble, we pass a string instead of an array
echo "----\nvector c - an error\n";
$c = scale_by_log("not array",2.3);
var_dump($c);

// this is a critical error, log of zero or negative number is undefined
echo "----\nvector d - fatal error\n";
$d = scale_by_log($a, -2.5);

?>
And when you run this sample script, the output will be

vector a
Array
(
    [0] => 2
    [1] => 3
    [2] => foo
    [3] => 5.5
    [4] => 43.3
    [5] => 21.11
)
----
vector b - a warning (b = log(PI) * a)
<b>WARNING</b> [1024] Value at position 2 is not a number, using 0 (zero)<br>
Array
(
    [0] => 2.2894597716988
    [1] => 3.4341896575482
    [2] => 0
    [3] => 6.2960143721717
    [4] => 49.566804057279
    [5] => 24.165247890281
)
----
vector c - an error
<b>ERROR</b> [512] Incorrect input vector, array of values expected<br>
NULL
----
vector d - fatal error
<b>FATAL</b> [256] log(x) for x <= 0 is undefined, you used: scale = -2.5<br>
  Fatal error in line 16 of file trigger_error.php, PHP 4.0.1pl2 (Linux)<br>
Aborting...<br>

See also error_reporting(),
restore_error_handler(),
trigger_error(), user_error()

Anterior | Inicio | Siguiente
restore_error_handler | Subir | trigger_error


trigger_error

(PHP 4 )

trigger_error -- Generates a user-level error/warning/notice message

Description

void trigger_error ( string error_msg [, int error_type])

Used to trigger a user error condition, it can be used by in conjunction with the built-in error handler, or with a user defined function that has been set as the new error handler (set_error_handler()). This function is useful when you need to generate a particular response to an exception at runtime. For example:

if (assert ($divisor == 0))
   trigger_error ("Cannot divide by zero", E_USER_ERROR);

Nota: See set_error_handler() for a more extensive example.

See also error_reporting(),
set_error_handler(),
restore_error_handler(),
user_error()

Anterior | Inicio | Siguiente
set_error_handler | Subir | user_error


user_error

(PHP 4 >= 4.0.0)

user_error -- Generates a user-level error/warning/notice message

Description

void user_error ( string error_msg [, int error_type])

This is an alias for the function trigger_error().

See also error_reporting(),
set_error_handler(),
restore_error_handler(), and
trigger_error()

Anterior | Inicio | Siguiente
trigger_error | Subir | FrontBase Functions


FrontBase Functions

Manual de PHP
Anterior Siguiente

XXVIII. FrontBase Functions

These functions allow you to access FrontBase database servers. In order to have these functions available, you must compile php with fbsql support by using the --with-fbsql option. If you use this option without specifying the path to fbsql, php will search for the fbsql client libraries in the default installation location for the platform. Users who installed FrontBase in a non standard directory should always specify the path to fbsql: --with-fbsql=/path/to/fbsql. This will force php to use the client libraries installed by FrontBase, avoiding any conflicts.

More information about FrontBase can be found at http://www.frontbase.com/.

Documentation for FrontBase can be found at http://www.frontbase.com/cgi-bin/WebObjects/FrontBase.woa/wa/productsPage?currentPage=Documentation.

Frontbase support has been added to PHP 4.0.6.

Tabla de contenidos
fbsql_affected_rows — Get number of affected rows in previous FrontBase operation
fbsql_autocommit — Enable or disable autocommit.
fbsql_change_user — Change logged in user of the active connection
fbsql_close — Close FrontBase connection
fbsql_commit — Commits a transaction to the database
fbsql_connect — Open a connection to a FrontBase Server
fbsql_create_db — Create a FrontBase database
fbsql_create_blob — Create a BLOB
fbsql_create_clob — Create a CLOB
fbsql_database_password — Sets or retrieves the password for a FrontBase database
fbsql_data_seek — Move internal result pointer
fbsql_db_query — Send a FrontBase query
fbsql_db_status — Get the status for a given database
fbsql_drop_db — Drop (delete) a FrontBase database
fbsql_errno — Returns the numerical value of the error message from previous FrontBase operation
fbsql_error — Returns the text of the error message from previous FrontBase operation
fbsql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
fbsql_fetch_assoc — Fetch a result row as an associative array
fbsql_fetch_field — Get column information from a result and return as an object
fbsql_fetch_lengths — Get the length of each output in a result
fbsql_fetch_object — Fetch a result row as an object
fbsql_fetch_row — Get a result row as an enumerated array
fbsql_field_flags — Get the flags associated with the specified field in a result
fbsql_field_name — Get the name of the specified field in a result
fbsql_field_len — Returns the length of the specified field
fbsql_field_seek — Set result pointer to a specified field offset
fbsql_field_table — Get name of the table the specified field is in
fbsql_field_type — Get the type of the specified field in a result
fbsql_free_result — Free result memory
fbsql_insert_id — Get the id generated from the previous INSERT operation
fbsql_list_dbs — List databases available on a FrontBase server
fbsql_list_fields — List FrontBase result fields
fbsql_list_tables — List tables in a FrontBase database
fbsql_next_result — Move the internal result pointer to the next result
fbsql_num_fields — Get number of fields in result
fbsql_num_rows — Get number of rows in result
fbsql_pconnect — Open a persistent connection to a FrontBase Server
fbsql_query — Send a FrontBase query
fbsql_read_blob — Read a BLOB from the database
fbsql_read_clob — Read a CLOB from the database
fbsql_result — Get result data
fbsql_rollback — Rollback a transaction to the database
fbsql_set_lob_mode — Set the LOB retrieve mode for a FrontBase result set
fbsql_select_db — Select a FrontBase database
fbsql_start_db — Start a database on local or remote server
fbsql_stop_db — Stop a database on local or remote server
fbsql_tablename — Get table name of field
fbsql_warnings — Enable or disable FrontBase warnings
fbsql_database — Get or set the database name used with a connection
fbsql_get_autostart_info — No description given yet
fbsql_hostname — Get or set the host name used with a connection
fbsql_password — Get or set the user password used with a connection
fbsql_set_transaction — Set the transaction locking and isolation
fbsql_username — Get or set the host user used with a connection

Anterior | Inicio | Siguiente
user_error | Subir | fbsql_affected_rows


fbsql_affected_rows

(PHP 4 >= 4.0.6)

fbsql_affected_rows -- Get number of affected rows in previous FrontBase operation

Description

int fbsql_affected_rows ( [int link_identifier])

fbsql_affected_rows() returns the number of rows affected by the last INSERT, UPDATE or DELETE query associated with link_identifier. If the link identifier isn't specified, the last link opened by fbsql_connect() is assumed.

Nota: If you are using transactions, you need to call fbsql_affected_rows() after your INSERT, UPDATE, or DELETE query, not after the commit.

If the last query was a DELETE query with no WHERE clause, all of the records will have been deleted from the table but this function will return zero.

Nota: When using UPDATE, FrontBase will not update columns where the new value is the same as the old value. This creates the possibility that fbsql_affected_rows() may not actually equal the number of rows matched, only the number of rows that were literally affected by the query.

If the last query failed, this function will return -1.

See also: fbsql_num_rows().

Anterior | Inicio | Siguiente
FrontBase Functions | Subir | fbsql_autocommit


fbsql_autocommit

(PHP 4 >= 4.0.6)

fbsql_autocommit -- Enable or disable autocommit.

Description

bool fbsql_autocommit ( resource link_identifier [, bool OnOff])

fbsql_autocommit() returns the current autocommit status. if the optional OnOff parameter is given the auto commit status will be changed. With OnOff set to TRUE each statement will be committed automatically, if no errors was found. With OnOff set to FALSE the user must commit or rollback the transaction using either fbsql_commit() or fbsql_rollback().

See also: fbsql_commit() and fbsql_rollback()

Anterior | Inicio | Siguiente
fbsql_affected_rows | Subir | fbsql_change_user


fbsql_change_user

(unknown)

fbsql_change_user -- Change logged in user of the active connection

Description

resource fbsql_change_user ( string user, string password [, string database [, int link_identifier]])

fbsql_change_user() changes the logged in user of the current active connection, or the connection given by the optional parameter link_identifier. If a database is specified, this will default or current database after the user has been changed. If the new user and password authorization fails, the current connected user stays active.

Anterior | Inicio | Siguiente
fbsql_autocommit | Subir | fbsql_close


fbsql_close

(PHP 4 >= 4.0.6)

fbsql_close -- Close FrontBase connection

Description

boolean fbsql_close ( [resource link_identifier])

Returns: TRUE on success, FALSE on error.

fbsql_close() closes the connection to the FrontBase server that's associated with the specified link identifier. If link_identifier isn't specified, the last opened link is used.

Using fbsql_close() isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

Ejemplo 1. fbsql_close() example

<?php
    $link = fbsql_connect ("localhost", "_SYSTEM", "secret")
        or die ("Could not connect");
    print ("Connected successfully");
    fbsql_close ($link);
?>

See also: fbsql_connect() and fbsql_pconnect().

Anterior | Inicio | Siguiente
fbsql_change_user | Subir | fbsql_commit


fbsql_commit

(PHP 4 >= 4.0.6)

fbsql_commit -- Commits a transaction to the database

Description

bool fbsql_commit ( [resource link_identifier])

Returns: TRUE on success, FALSE on failure.

fbsql_commit() ends the current transaction by writing all inserts, updates and deletes to the disk and unlocking all row and table locks held by the transaction. This command is only needed if autocommit is set to false.

See also: fbsql_autocommit() and fbsql_rollback()

Anterior | Inicio | Siguiente
fbsql_close | Subir | fbsql_connect


fbsql_connect

(PHP 4 >= 4.0.6)

fbsql_connect -- Open a connection to a FrontBase Server

Description

resource fbsql_connect ( [string hostname [, string username [, string password]]])

Returns a positive FrontBase link identifier on success, or an error message on failure.

fbsql_connect() establishes a connection to a
FrontBase server.  The following defaults are assumed for missing
optional parameters: hostname = 'NULL',
username = '_SYSTEM' and
password = empty password.

If a second call is made to fbsql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling fbsql_close().

Ejemplo 1. fbsql_connect() example

<?php

    $link = fbsql_connect ("localhost", "_SYSTEM", "secret")
        or die ("Could not connect");
    print ("Connected successfully");
    fbsql_close ($link);

?>

See also fbsql_pconnect() and fbsql_close().

Anterior | Inicio | Siguiente
fbsql_commit | Subir | fbsql_create_db


fbsql_create_db

(PHP 4 >= 4.0.6)

fbsql_create_db -- Create a FrontBase database

Description

bool fbsql_create_db ( string database name [, resource link_identifier])

fbsql_create_db() attempts to create a new database on the server associated with the specified link identifier.

Ejemplo 1. fbsql_create_db() example

<?php
    $link = fbsql_pconnect ("localhost", "_SYSTEM", "secret")
        or die ("Could not connect");
    if (fbsql_create_db ("my_db")) {
        print("Database created successfully\n");
    } else {
        printf("Error creating database: %s\n", fbsql_error ());
    }
?>

See also: fbsql_drop_db().

Anterior | Inicio | Siguiente
fbsql_connect | Subir | fbsql_create_blob


fbsql_create_blob

(PHP 4 >= 4.2.0)

fbsql_create_blob -- Create a BLOB

Description

string fbsql_create_blob ( string blob_data [, resource link_identifier])

Returns: A resource handle to the newly created blob.

fbsql_create_blob() creates a blob from blob_data. The returned resource handle can be used with insert and update commands to store the blob in the database.

Ejemplo 1. fbsql_create_blob() example

<?php
    $link = fbsql_pconnect ("localhost", "_SYSTEM", "secret")
        or die ("Could not connect");
    $filename = "blobfile.bin";
    $fp = fopen($filename, "rb");
    $blobdata = fread($fp, filesize($filename));
    fclose($fp);

    $blobHandle = fbsql_create_blob($blobdata, $link);

    $sql = "INSERT INTO BLOB_TABLE (BLOB_COLUMN) VALUES ($blobHandle);";
    $rs = fbsql_query($sql, $link);
?>

See also: fbsql_create_clob(),
fbsql_read_blob(),
fbsql_read_clob(), and
fbsql_set_lob_mode().

Anterior | Inicio | Siguiente
fbsql_create_db | Subir | fbsql_create_clob


fbsql_create_clob

(PHP 4 >= 4.2.0)

fbsql_create_clob -- Create a CLOB

Description

string fbsql_create_clob ( string clob_data [, resource link_identifier])

Returns: A resource handle to the newly created CLOB.

fbsql_create_clob() creates a clob from clob_data. The returned resource handle can be used with insert and update commands to store the clob in the database.

Ejemplo 1. fbsql_create_clob() example

<?php
    $link = fbsql_pconnect ("localhost", "_SYSTEM", "secret")
        or die ("Could not connect");
    $filename = "clob_file.txt";
    $fp = fopen($filename, "rb");
    $clobdata = fread($fp, filesize($filename));
    fclose($fp);

    $clobHandle = fbsql_create_clob($clobdata, $link);

    $sql = "INSERT INTO CLOB_TABLE (CLOB_COLUMN) VALUES ($clobHandle);";
    $rs = fbsql_query($sql, $link);
?>

See also: fbsql_create_blob(),
fbsql_read_blob(),
fbsql_read_clob(), and
fbsql_set_lob_mode().

Anterior | Inicio | Siguiente
fbsql_create_blob | Subir | fbsql_database_password


fbsql_database_password

(PHP 4 >= 4.0.6)

fbsql_database_password -- Sets or retrieves the password for a FrontBase database

Description

string fbsql_database_password ( resource link_identifier [, string database_password])

Returns: The database password associated with the link identifier.

fbsql_database_password() sets and retrieves the database password used by the connection. if a database is protected by a database password, the user must call this function before calling fbsql_select_db(). if the second optional parameter is given the function sets the database password for the specified link identifier. If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if fbsql_connect() was called, and use it.

This function does not change the database password in the database nor can it be used to retrive the database password for a database.

Ejemplo 1. fbsql_create_clob() example

<?php
    $link = fbsql_pconnect ("localhost", "_SYSTEM", "secret")
        or die ("Could not connect");
    fbsql_database_password($link, "secret db password");
    fbsql_select_db($database, $link);
?>

See also: fbsql_connect(),
fbsql_pconnect() and
fbsql_select_db().

Anterior | Inicio | Siguiente
fbsql_create_clob | Subir | fbsql_data_seek


fbsql_data_seek

(PHP 4 >= 4.0.6)

fbsql_data_seek -- Move internal result pointer

Description

bool fbsql_data_seek ( resource result_identifier, int row_number)

Returns: TRUE on success, FALSE on failure.

fbsql_data_seek() moves the internal row pointer of the FrontBase result associated with the specified result identifier to point to the specified row number. The next call to fbsql_fetch_row() would return that row.

Row_number starts at 0.

Ejemplo 1. fbsql_data_seek() example

<?php
    $link = fbsql_pconnect ("localhost", "_SYSTEM", "secret")
        or die ("Could not connect");

    fbsql_select_db ("samp_db")
        or die ("Could not select database");

    $query = "SELECT last_name, first_name FROM friends;";
    $result = fbsql_query ($query)
        or die ("Query failed");

    # fetch rows in reverse order

    for ($i = fbsql_num_rows ($result) - 1; $i >=0; $i--) {
        if (!fbsql_data_seek ($result, $i)) {
            printf ("Cannot seek to row %d\n", $i);
            continue;
        }

        if(!($row = fbsql_fetch_object ($result)))
            continue;

        printf("%s %s<BR>\n", $row->last_name, $row->first_name);
    }

    fbsql_free_result ($result);
?>

Anterior | Inicio | Siguiente
fbsql_database_password | Subir | fbsql_db_query


fbsql_db_query

(PHP 4 >= 4.0.6)

fbsql_db_query -- Send a FrontBase query

Description

resource fbsql_db_query ( string database, string query [, resource link_identifier])

Returns: A positive FrontBase result identifier to the query result, or FALSE on error.

fbsql_db_query() selects a database and executes a query on it. If the optional link identifier isn't specified, the function will try to find an open link to the FrontBase server and if no such link is found it'll try to create one as if fbsql_connect() was called with no arguments

See also fbsql_connect().

Anterior | Inicio | Siguiente
fbsql_data_seek | Subir | fbsql_db_status


fbsql_db_status

(PHP 4 >= 4.1.0)

fbsql_db_status -- Get the status for a given database

Description

int fbsql_db_status ( string database_name [, resource link_identifier])

Returns: An integer value with the current status.

fbsql_db_status() requests the current status of the database specified by database_name. If the link_identifier is omitted the default link_identifier will be used.

The return value can be one of the following constants:

  • FALSE - The exec handler for the host was invalid. This error will occur when the link_identifier connects directly to a database by using a port number. FBExec can be available on the server but no connection has been made for it.

  • FBSQL_UNKNOWN - The Status is unknown.

  • FBSQL_STOPPED - The database is not running. Use fbsql_start_db() to start the database.

  • FBSQL_STARTING - The database is starting.

  • FBSQL_RUNNING - The database is running and can be used to perform SQL operations.

  • FBSQL_STOPPING - The database is stopping.

  • FBSQL_NOEXEC - FBExec is not running on the server and it is not possible to get the status of the database.

See also: fbsql_start_db() and fbsql_stop_db().

Anterior | Inicio | Siguiente
fbsql_db_query | Subir | fbsql_drop_db


fbsql_drop_db

(PHP 4 >= 4.0.6)

fbsql_drop_db -- Drop (delete) a FrontBase database

Description

bool fbsql_drop_db ( string database_name [, resource link_identifier])

Returns: TRUE on success, FALSE on failure.

fbsql_drop_db() attempts to drop (remove) an entire database from the server associated with the specified link identifier.

Anterior | Inicio | Siguiente
fbsql_db_status | Subir | fbsql_errno


fbsql_errno

(PHP 4 >= 4.0.6)

fbsql_errno -- Returns the numerical value of the error message from previous FrontBase operation

Description

int fbsql_errno ( [resource link_identifier])

Returns the error number from the last fbsql function, or 0 (zero) if no error occurred.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_errno() to retrieve the error code. Note that this function only returns the error code from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

<?php
fbsql_connect("marliesle");
echo fbsql_errno().": ".fbsql_error()."<BR>";
fbsql_select_db("nonexistentdb");
echo fbsql_errno().": ".fbsql_error()."<BR>";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno().": ".fbsql_error()."<BR>";
?>

See also: fbsql_error() and fbsql_warnings().

Anterior | Inicio | Siguiente
fbsql_drop_db | Subir | fbsql_error


fbsql_error

(PHP 4 >= 4.0.6)

fbsql_error -- Returns the text of the error message from previous FrontBase operation

Description

string fbsql_error ( [resource link_identifier])

Returns the error text from the last fbsql function, or '' (the empty string) if no error occurred.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_error() to retrieve the error text. Note that this function only returns the error text from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

<?php
fbsql_connect("marliesle");
echo fbsql_errno().": ".fbsql_error()."<BR>";
fbsql_select_db("nonexistentdb");
echo fbsql_errno().": ".fbsql_error()."<BR>";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno().": ".fbsql_error()."<BR>";
?>

See also: fbsql_errno() and fbsql_warnings().

Anterior | Inicio | Siguiente
fbsql_errno | Subir | fbsql_fetch_array


fbsql_fetch_array

(PHP 4 >= 4.0.6)

fbsql_fetch_array -- Fetch a result row as an associative array, a numeric array, or both

Description

array fbsql_fetch_array ( resource result [, int result_type])

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

fbsql_fetch_array() is an extended version of fbsql_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must the numeric index of the column or make an alias for the column.

select t1.f1 as foo t2.f1 as bar from t1, t2

An important thing to note is that using fbsql_fetch_array() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

The optional second argument result_type in fbsql_fetch_array() is a constant and can take the following values: FBSQL_ASSOC, FBSQL_NUM, and FBSQL_BOTH.

For further details, see also fbsql_fetch_row() and fbsql_fetch_assoc().

Ejemplo 1. fbsql_fetch_array() example

<?php
fbsql_connect ($host, $user, $password);
$result = fbsql_db_query ("database","select user_id, fullname from table");
while ($row = fbsql_fetch_array ($result)) {
    echo "user_id: ".$row["user_id"]."<br>\n";
    echo "user_id: ".$row[0]."<br>\n";
    echo "fullname: ".$row["fullname"]."<br>\n";
    echo "fullname: ".$row[1]."<br>\n";
}
fbsql_free_result ($result);
?>

Anterior | Inicio | Siguiente
fbsql_error | Subir | fbsql_fetch_assoc


fbsql_fetch_assoc

(PHP 4 >= 4.0.6)

fbsql_fetch_assoc -- Fetch a result row as an associative array

Description

array fbsql_fetch_assoc ( resource result)

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows.

fbsql_fetch_assoc() is equivalent to calling fbsql_fetch_array() with FBSQL_ASSOC for the optional second parameter. It only returns an associative array. This is the way fbsql_fetch_array() originally worked. If you need the numeric indices as well as the associative, use fbsql_fetch_array().

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must use fbsql_fetch_array() and have it return the numeric indices as well.

An important thing to note is that using fbsql_fetch_assoc() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

For further details, see also fbsql_fetch_row() and fbsql_fetch_array().

Ejemplo 1. fbsql_fetch_assoc() example

<?php
fbsql_connect ($host, $user, $password);
$result = fbsql_db_query ("database","select * from table");
while ($row = fbsql_fetch_assoc ($result)) {
    echo $row["user_id"];
    echo $row["fullname"];
}
fbsql_free_result ($result);
?>

Anterior | Inicio | Siguiente
fbsql_fetch_array | Subir | fbsql_fetch_field


fbsql_fetch_field

(PHP 4 >= 4.0.6)

fbsql_fetch_field -- Get column information from a result and return as an object

Description

object fbsql_fetch_field ( resource result [, int field_offset])

Returns an object containing field information.

fbsql_fetch_field() can be used in order to obtain information about fields in a certain query result. If the field offset isn't specified, the next field that wasn't yet retrieved by fbsql_fetch_field() is retrieved.

The properties of the object are:

  • name - column name

  • table - name of the table the column belongs to

  • max_length - maximum length of the column

  • not_null - 1 if the column cannot be NULL

  • type - the type of the column

Ejemplo 1. fbsql_fetch_field() example

<?php
fbsql_connect ($host, $user, $password)
    or die ("Could not connect");
$result = fbsql_db_query ("database", "select * from table")
    or die ("Query failed");
# get column metadata
$i = 0;
while ($i < fbsql_num_fields ($result)) {
    echo "Information for column $i:<BR>\n";
    $meta = fbsql_fetch_field ($result);
    if (!$meta) {
        echo "No information available<BR>\n";
    }
    echo "<PRE>
max_length:   $meta->max_length
name:         $meta->name
not_null:     $meta->not_null
table:        $meta->table
type:         $meta->type
</PRE>";
    $i++;
}
fbsql_free_result ($result);
?>

See also fbsql_field_seek().

Anterior | Inicio | Siguiente
fbsql_fetch_assoc | Subir | fbsql_fetch_lengths


fbsql_fetch_lengths

(PHP 4 >= 4.0.6)

fbsql_fetch_lengths -- Get the length of each output in a result

Description

array fbsql_fetch_lengths ( [resource result])

Returns: An array that corresponds to the lengths of each field in the last row fetched by fbsql_fetch_row(), or FALSE on error.

fbsql_fetch_lengths() stores the lengths of
each result column in the last row returned by
fbsql_fetch_row(),
fbsql_fetch_array() and
fbsql_fetch_object() in an array, starting at
offset 0.

See also: fbsql_fetch_row().

Anterior | Inicio | Siguiente
fbsql_fetch_field | Subir | fbsql_fetch_object


fbsql_fetch_object

(PHP 4 >= 4.0.6)

fbsql_fetch_object -- Fetch a result row as an object

Description

object fbsql_fetch_object ( resource result [, int result_type])

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

fbsql_fetch_object() is similar to fbsql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

The optional argument result_type is a constant and can take the following values: FBSQL_ASSOC, FBSQL_NUM, and FBSQL_BOTH.

Speed-wise, the function is identical to fbsql_fetch_array(), and almost as quick as fbsql_fetch_row() (the difference is insignificant).

Ejemplo 1. fbsql_fetch_object() example

<?php
fbsql_connect ($host, $user, $password);
$result = fbsql_db_query ("database", "select * from table");
while ($row = fbsql_fetch_object ($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
fbsql_free_result ($result);
?>

See also: fbsql_fetch_array() and fbsql_fetch_row().

Anterior | Inicio | Siguiente
fbsql_fetch_lengths | Subir | fbsql_fetch_row


fbsql_fetch_row

(PHP 4 >= 4.0.6)

fbsql_fetch_row -- Get a result row as an enumerated array

Description

array fbsql_fetch_row ( resource result)

Returns: An array that corresponds to the fetched row, or FALSE if there are no more rows.

fbsql_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Subsequent call to fbsql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

See also: fbsql_fetch_array(),
fbsql_fetch_object(),
fbsql_data_seek(),
fbsql_fetch_lengths(), and
fbsql_result().

Anterior | Inicio | Siguiente
fbsql_fetch_object | Subir | fbsql_field_flags


fbsql_field_flags

(PHP 4 >= 4.0.6)

fbsql_field_flags -- Get the flags associated with the specified field in a result

Description

string fbsql_field_flags ( resource result, int field_offset)

fbsql_field_flags() returns the field flags of the specified field. The flags are reported as a single word per flag separated by a single space, so that you can split the returned value using explode().

Anterior | Inicio | Siguiente
fbsql_fetch_row | Subir | fbsql_field_name


fbsql_field_name

(PHP 4 >= 4.0.6)

fbsql_field_name -- Get the name of the specified field in a result

Description

string fbsql_field_name ( resource result, int field_index)

fbsql_field_name() returns the name of the specified field index. result must be a valid result identifier and field_index is the numerical offset of the field.

Nota: field_index starts at 0.

e.g. The index of the third field would actually be 2, the index of the fourth field would be 3 and so on.

Ejemplo 1. fbsql_field_name() example

// The users table consists of three fields:
//   user_id
//   username
//   password.

$res = fbsql_db_query("users", "select * from users", $link);

echo fbsql_field_name($res, 0) . "\n";
echo fbsql_field_name($res, 2);

The above example would produce the following output:

user_id
password

Anterior | Inicio | Siguiente
fbsql_field_flags | Subir | fbsql_field_len


fbsql_field_len

(PHP 4 >= 4.0.6)

fbsql_field_len -- Returns the length of the specified field

Description

int fbsql_field_len ( resource result, int field_offset)

fbsql_field_len() returns the length of the specified field.

Anterior | Inicio | Siguiente
fbsql_field_name | Subir | fbsql_field_seek


fbsql_field_seek

(PHP 4 >= 4.0.6)

fbsql_field_seek -- Set result pointer to a specified field offset

Description

bool fbsql_field_seek ( resource result, int field_offset)

Seeks to the specified field offset. If the next call to fbsql_fetch_field() doesn't include a field offset, the field offset specified in fbsql_field_seek() will be returned.

See also: fbsql_fetch_field().

Anterior | Inicio | Siguiente
fbsql_field_len | Subir | fbsql_field_table


fbsql_field_table

(PHP 4 >= 4.0.6)

fbsql_field_table -- Get name of the table the specified field is in

Description

string fbsql_field_table ( resource result, int field_offset)

Returns the name of the table that the specified field is in.

Anterior | Inicio | Siguiente
fbsql_field_seek | Subir | fbsql_field_type


fbsql_field_type

(PHP 4 >= 4.0.6)

fbsql_field_type -- Get the type of the specified field in a result

Description

string fbsql_field_type ( resource result, int field_offset)

fbsql_field_type() is similar to the fbsql_field_name() function. The arguments are identical, but the field type is returned instead. The field type will be one of "int", "real", "string", "blob", and others as detailed in the FrontBase documentation.

Ejemplo 1. fbsql_field_type() example

<?php

fbsql_connect ("localhost", "_SYSTEM", "");
fbsql_select_db ("wisconsin");
$result = fbsql_query ("SELECT * FROM onek;");
$fields = fbsql_num_fields ($result);
$rows   = fbsql_num_rows ($result);
$i = 0;
$table = fbsql_field_table ($result, $i);
echo "Your '".$table."' table has ".$fields." fields and ".$rows." records <BR>";
echo "The table has the following fields <BR>";
while ($i < $fields) {
    $type  = fbsql_field_type  ($result, $i);
    $name  = fbsql_field_name  ($result, $i);
    $len   = fbsql_field_len   ($result, $i);
    $flags = fbsql_field_flags ($result, $i);
    echo $type." ".$name." ".$len." ".$flags."<BR>";
    $i++;
}
fbsql_close();

?>

Anterior | Inicio | Siguiente
fbsql_field_table | Subir | fbsql_free_result


fbsql_free_result

(PHP 4 >= 4.0.6)

fbsql_free_result -- Free result memory

Description

bool fbsql_free_result ( int result)

fbsql_free_result() will free all memory associated with the result identifier result.

fbsql_free_result() only needs to be called if you are concerned about how much memory is being used for queries that return large result sets. All associated result memory is automatically freed at the end of the script's execution.

Anterior | Inicio | Siguiente
fbsql_field_type | Subir | fbsql_insert_id


fbsql_insert_id

(PHP 4 >= 4.0.6)

fbsql_insert_id -- Get the id generated from the previous INSERT operation

Description

int fbsql_insert_id ( [resource link_identifier])

fbsql_insert_id() returns the ID generated for an column defined as DEFAULT UNIQUE by the previous INSERT query using the given link_identifier. If link_identifier isn't specified, the last opened link is assumed.

fbsql_insert_id() returns 0 if the previous query does not generate an DEFAULT UNIQUE value. If you need to save the value for later, be sure to call fbsql_insert_id() immediately after the query that generates the value.

Nota: The value of the FrontBase SQL function LAST_INSERT_ID() always contains the most recently generated DEFAULT UNIQUE value, and is not reset between queries.

Anterior | Inicio | Siguiente
fbsql_free_result | Subir | fbsql_list_dbs


fbsql_list_dbs

(PHP 4 >= 4.0.6)

fbsql_list_dbs -- List databases available on a FrontBase server

Description

resource fbsql_list_dbs ( [resource link_identifier])

fbsql_list_dbs() will return a result pointer containing the databases available from the current fbsql daemon. Use the fbsql_tablename() function to traverse this result pointer.

Ejemplo 1. fbsql_list_dbs() example

$link = fbsql_connect('localhost', 'myname', 'secret');
$db_list = fbsql_list_dbs($link);

while ($row = fbsql_fetch_object($db_list)) {
    echo $row->Database . "\n";
}

The above example would produce the following output:

database1
database2
database3
...

Nota: The above code would just as easily work with fbsql_fetch_row() or other similar functions.

Anterior | Inicio | Siguiente
fbsql_insert_id | Subir | fbsql_list_fields


fbsql_list_fields

(PHP 4 >= 4.0.6)

fbsql_list_fields -- List FrontBase result fields

Description

resource fbsql_list_fields ( string database_name, string table_name [, resource link_identifier])

fbsql_list_fields() retrieves information
about the given tablename. Arguments are the database name and
the table name. A result pointer is returned which can be used
with fbsql_field_flags(),
fbsql_field_len(),
fbsql_field_name(), and
fbsql_field_type().

A result identifier is a positive integer. The function returns -1 if a error occurs. A string describing the error will be placed in $phperrmsg, and unless the function was called as @fbsql() then this error string will also be printed out.

Ejemplo 1. fbsql_list_fields() example

$link = fbsql_connect('localhost', 'myname', 'secret');

$fields = fbsql_list_fields("database1", "table1", $link);
$columns = fbsql_num_fields($fields);

for ($i = 0; $i < $columns; $i++) {
    echo fbsql_field_name($fields, $i) . "\n";;
}

The above example would produce the following output:

field1
field2
field3
...

Anterior | Inicio | Siguiente
fbsql_list_dbs | Subir | fbsql_list_tables


fbsql_list_tables

(PHP 4 >= 4.0.6)

fbsql_list_tables -- List tables in a FrontBase database

Description

resource fbsql_list_tables ( string database [, resource link_identifier])

fbsql_list_tables() takes a database name and returns a result pointer much like the fbsql_db_query() function. The fbsql_tablename() function should be used to extract the actual table names from the result pointer.

Anterior | Inicio | Siguiente
fbsql_list_fields | Subir | fbsql_next_result


fbsql_next_result

(PHP 4 >= 4.0.6)

fbsql_next_result -- Move the internal result pointer to the next result

Description

bool fbsql_next_result ( int result_id)

When sending more than one SQL statement to the server or executing a stored procedure with multiple results will cause the server to return multiple result sets. This function will test for additional results available form the server. If an additional result set exists it will free the existing result set and prepare to fetch the words from the new result set. The function will return TRUE if an additional result set was available or FALSE otherwise.

Ejemplo 1. fbsql_next_result() example

<?php
    $link = fbsql_connect ("localhost", "_SYSTEM", "secret");
    fbsql_select_db("MyDB", $link);
    $SQL = "Select * from table1; select * from table2;";
    $rs = fbsql_query($SQL, $link);
    do {
        while ($row = fbsql_fetch_row($rs)) {
        }
    } while (fbsql_next_result($rs));
    fbsql_free_result($rs);
    fbsql_close ($link);
?>

Anterior | Inicio | Siguiente
fbsql_list_tables | Subir | fbsql_num_fields


fbsql_num_fields

(PHP 4 >= 4.0.6)

fbsql_num_fields -- Get number of fields in result

Description

int fbsql_num_fields ( resource result)

fbsql_num_fields() returns the number of fields in a result set.

See also:
fbsql_db_query(),
fbsql_query(),
fbsql_fetch_field(), and
fbsql_num_rows().

Anterior | Inicio | Siguiente
fbsql_next_result | Subir | fbsql_num_rows


fbsql_num_rows

(PHP 4 >= 4.0.6)

fbsql_num_rows -- Get number of rows in result

Description

int fbsql_num_rows ( resource result)

fbsql_num_rows() returns the number of rows in a result set. This command is only valid for SELECT statements. To retrieve the number of rows returned from a INSERT, UPDATE or DELETE query, use fbsql_affected_rows().

Ejemplo 1. fbsql_num_rows() example

<?php

$link = fbsql_connect("localhost", "username", "password");
fbsql_select_db("database", $link);

$result = fbsql_query("SELECT * FROM table1;", $link);
$num_rows = fbsql_num_rows($result);

echo "$num_rows Rows\n";

?>

See also: fbsql_affected_rows(),
fbsql_connect(),
fbsql_select_db(), and
fbsql_query().

Anterior | Inicio | Siguiente
fbsql_num_fields | Subir | fbsql_pconnect


fbsql_pconnect

(PHP 4 >= 4.0.6)

fbsql_pconnect -- Open a persistent connection to a FrontBase Server

Description

resource fbsql_pconnect ( [string hostname [, string username [, string password]]])

Returns: A positive FrontBase persistent link identifier on success, or FALSE on error.

fbsql_pconnect() establishes a connection to a FrontBase server. The following defaults are assumed for missing optional parameters: host = 'localhost', username = "_SYSTEM" and password = empty password.

fbsql_pconnect() acts very much like fbsql_connect() with two major differences.

To set Frontbase server port number, use fbsql_select_db().

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use.

This type of links is therefore called 'persistent'.

Anterior | Inicio | Siguiente
fbsql_num_rows | Subir | fbsql_query


fbsql_query

(PHP 4 >= 4.0.6)

fbsql_query -- Send a FrontBase query

Description

resource fbsql_query ( string query [, resource link_identifier])

fbsql_query() sends a query to the currently active database on the server that's associated with the specified link identifier. If link_identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if fbsql_connect() was called with no arguments, and use it.

Nota: The query string shall always end with a semicolon.

fbsql_query() returns TRUE (non-zero) or FALSE to indicate whether or not the query succeeded. A return value of TRUE means that the query was legal and could be executed by the server. It does not indicate anything about the number of rows affected or returned. It is perfectly possible for a query to succeed but affect no rows or return no rows.

The following query is syntactically invalid, so fbsql_query() fails and returns FALSE:

Ejemplo 1. fbsql_query() example

<?php
$result = fbsql_query ("SELECT * WHERE 1=1")
    or die ("Invalid query");
?>

The following query is semantically invalid if my_col is not a column in the table my_tbl, so fbsql_query() fails and returns FALSE:

Ejemplo 2. fbsql_query() example

<?php
$result = fbsql_query ("SELECT my_col FROM my_tbl")
    or die ("Invalid query");
?>

fbsql_query() will also fail and return FALSE if you don't have permission to access the table(s) referenced by the query.

Assuming the query succeeds, you can call fbsql_num_rows() to find out how many rows were returned for a SELECT statement or fbsql_affected_rows() to find out how many rows were affected by a DELETE, INSERT, REPLACE, or UPDATE statement.

For SELECT statements, fbsql_query() returns a new result identifier that you can pass to fbsql_result(). When you are done with the result set, you can free the resources associated with it by calling fbsql_free_result(). Although, the memory will automatically be freed at the end of the script's execution.

See also: fbsql_affected_rows(),
fbsql_db_query(),
fbsql_free_result(),
fbsql_result(),
fbsql_select_db(), and
fbsql_connect().

Anterior | Inicio | Siguiente
fbsql_pconnect | Subir | fbsql_read_blob


fbsql_read_blob

(PHP 4 >= 4.2.0)

fbsql_read_blob -- Read a BLOB from the database

Description

string fbsql_read_blob ( string blob_handle [, resource link_identifier])

Returns: A string containing the BLOB specified by blob_handle.

fbsql_read_blob() reads BLOB data from the database. If a select statement contains BLOB and/or BLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_blob() to get the actual BLOB data from the database.

Ejemplo 1. fbsql_read_blob() example

<?php
    $link = fbsql_pconnect ("localhost", "_SYSTEM", "secret")
        or die ("Could not connect");
    $sql = "SELECT BLOB_COLUMN FROM BLOB_TABLE;";
    $rs = fbsql_query($sql, $link);
    $row_data = fbsql_fetch_row($rs);
    // $row_data[0] will now contain the blob data for teh first row
    fbsql_free_result($rs);

    $rs = fbsql_query($sql, $link);
    fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
    $row_data = fbsql_fetch_row($rs);
    // $row_data[0] will now contain a handle to the BLOB data in the first row
    $blob_data = fbsql_read_blob($row_data[0]);
    fbsql_free_result($rs);

?>

See also: fbsql_create_blob(),
fbsql_read_blob(),
fbsql_read_clob(), and
fbsql_set_lob_mode().

Anterior | Inicio | Siguiente
fbsql_query | Subir | fbsql_read_clob


fbsql_read_clob

(PHP 4 >= 4.2.0)

fbsql_read_clob -- Read a CLOB from the database

Description

string fbsql_read_clob ( string clob_handle [, resource link_identifier])

Returns: A string containing the CLOB specified by clob_handle.

fbsql_read_clob() reads CLOB data from the database. If a select statement contains BLOB and/or CLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_clob() to get the actual CLOB data from the database.

Ejemplo 1. fbsql_read_clob() example

<?php
    $link = fbsql_pconnect ("localhost", "_SYSTEM", "secret")
        or die ("Could not connect");
    $sql = "SELECT CLOB_COLUMN FROM CLOB_TABLE;";
    $rs = fbsql_query($sql, $link);
    $row_data = fbsql_fetch_row($rs);
    // $row_data[0] will now contain the clob data for teh first row
    fbsql_free_result($rs);

    $rs = fbsql_query($sql, $link);
    fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
    $row_data = fbsql_fetch_row($rs);
    // $row_data[0] will now contain a handle to the CLOB data in the first row
    $clob_data = fbsql_read_clob($row_data[0]);
    fbsql_free_result($rs);

?>

See also: fbsql_create_blob(),
fbsql_read_blob(),
fbsql_read_clob(), and
fbsql_set_lob_mode().

Anterior | Inicio | Siguiente
fbsql_read_blob | Subir | fbsql_result


fbsql_result

(PHP 4 >= 4.0.6)

fbsql_result -- Get result data

Description

mixed fbsql_result ( resource result, int row [, mixed field])

fbsql_result() returns the contents of one cell from a FrontBase result set. The field argument can be the field's offset, or the field's name, or the field's table dot field's name (tabledname.fieldname). If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than fbsql_result(). Also, note that specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Calls to fbsql_result() should not be mixed with calls to other functions that deal with the result set.

Recommended high-performance alternatives:
fbsql_fetch_row(),
fbsql_fetch_array(), and
fbsql_fetch_object().

Anterior | Inicio | Siguiente
fbsql_read_clob | Subir | fbsql_rollback


fbsql_rollback

(PHP 4 >= 4.0.6)

fbsql_rollback -- Rollback a transaction to the database

Description

bool fbsql_rollback ( [resource link_identifier])

Returns: TRUE on success, FALSE on failure.

fbsql_rollback() ends the current transaction by rolling back all statements issued since last commit. This command is only needed if autocommit is set to false.

See also: fbsql_autocommit() and fbsql_commit()

Anterior | Inicio | Siguiente
fbsql_result | Subir | fbsql_set_lob_mode


fbsql_set_lob_mode

(PHP 4 >= 4.2.0)

fbsql_set_lob_mode -- Set the LOB retrieve mode for a FrontBase result set

Description

bool fbsql_set_lob_mode ( resource result, string database_name)

Returns: TRUE on success, FALSE on error.

fbsql_set_lob_mode() sets the mode for retrieving LOB data from the database. When BLOB and CLOB data is stored in FrontBase it can be stored direct or indirect. Direct stored LOB data will always be fetched no matter the setting of the lob mode. If the LOB data is less than 512 bytes it will always be stored directly.

  • FBSQL_LOB_DIRECT - LOB data is retrieved directly. When data is fetched from the database with fbsql_fetch_row(), and other fetch functions, all CLOB and BLOB columns will be returned as ordinary columns. This is the default value on a new FrontBase result.

  • FBSQL_LOB_HANDLE - LOB data is retrieved as handles to the data. When data is fetched from the database with fbsql_fetch_row (), and other fetch functions, LOB data will be returned as a handle to the data if the data is stored indirect or the data if it is stored direct. If a handle is returned it will be a 27 byte string formatted as "@'000000000000000000000000'".

See also:
    fbsql_create_blob(),
    fbsql_create_clob(),
    fbsql_read_blob(), and
    fbsql_read_clob().

Anterior | Inicio | Siguiente
fbsql_rollback | Subir | fbsql_select_db


fbsql_select_db

(PHP 4 >= 4.0.6)

fbsql_select_db -- Select a FrontBase database

Description

bool fbsql_select_db ( string database_name [, resource link_identifier])

Returns: TRUE on success, FALSE on error.

fbsql_select_db() sets the current active database on the server that's associated with the specified link identifier. If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if fbsql_connect() was called, and use it.

The client contacts FBExec to obtain the port number to use for the connection to the database. If the database name is a number the system will use that as a port number and it will not ask FBExec for the port number. The FrontBase server can be stared as FRontBase -FBExec=No -port=<port number> <database name>.

Every subsequent call to fbsql_query() will be made on the active database.

if the database is protected with a database password, the user must call fbsql_database_password() before selecting the database.

See also:
    fbsql_connect(),
    fbsql_pconnect(),
    fbsql_database_password() and
    fbsql_query().

Anterior | Inicio | Siguiente
fbsql_set_lob_mode | Subir | fbsql_start_db


fbsql_start_db

(PHP 4 >= 4.0.6)

fbsql_start_db -- Start a database on local or remote server

Description

bool fbsql_start_db ( string database_name [, resource link_identifier])

Returns: TRUE on success, FALSE on failure.

fbsql_start_db()

See also: fbsql_db_status() and fbsql_stop_db().

Anterior | Inicio | Siguiente
fbsql_select_db | Subir | fbsql_stop_db


fbsql_stop_db

(PHP 4 >= 4.0.6)

fbsql_stop_db -- Stop a database on local or remote server

Description

bool fbsql_stop_db ( string database_name [, resource link_identifier])

Returns: TRUE on success, FALSE on failure.

fbsql_stop_db()

See also: fbsql_db_status() and fbsql_start_db().

Anterior | Inicio | Siguiente
fbsql_start_db | Subir | fbsql_tablename


fbsql_tablename

(PHP 4 >= 4.2.0)

fbsql_tablename -- Get table name of field

Description

string fbsql_tablename ( resource result, int i)

fbsql_tablename() takes a result pointer returned by the fbsql_list_tables() function as well as an integer index and returns the name of a table. The fbsql_num_rows() function may be used to determine the number of tables in the result pointer.

Ejemplo 1. fbsql_tablename() example

<?php
fbsql_connect ("localhost", "_SYSTEM", "");
$result = fbsql_list_tables ("wisconsin");
$i = 0;
while ($i < fbsql_num_rows ($result)) {
    $tb_names[$i] = fbsql_tablename ($result, $i);
    echo $tb_names[$i] . "<BR>";
    $i++;
}
?>

Anterior | Inicio | Siguiente
fbsql_stop_db | Subir | fbsql_warnings


fbsql_warnings

(PHP 4 >= 4.0.6)

fbsql_warnings -- Enable or disable FrontBase warnings

Description

bool fbsql_warnings ( [bool OnOff])

Returns TRUE if warnings is turned on otherwise FALSE.

fbsql_warnings() enables or disables FrontBase warnings.

Anterior | Inicio | Siguiente
fbsql_tablename | Subir | fbsql_database


fbsql_database

(PHP 4 >= 4.0.6)

fbsql_database -- Get or set the database name used with a connection

Description

string fbsql_database ( resource link_identifier [, string database])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
fbsql_warnings | Subir | fbsql_get_autostart_info


fbsql_get_autostart_info

(PHP 4 >= 4.1.0)

fbsql_get_autostart_info -- No description given yet

Description

array fbsql_get_autostart_info ( [resource link_identifier])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
fbsql_database | Subir | fbsql_hostname


fbsql_hostname

(PHP 4 >= 4.0.6)

fbsql_hostname -- Get or set the host name used with a connection

Description

string fbsql_hostname ( resource link_identifier [, string host_name])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
fbsql_get_autostart_info | Subir | fbsql_password


fbsql_password

(PHP 4 >= 4.0.6)

fbsql_password -- Get or set the user password used with a connection

Description

string fbsql_password ( resource link_identifier [, string password])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
fbsql_hostname | Subir | fbsql_set_transaction


fbsql_set_transaction

(PHP 4 >= 4.2.0)

fbsql_set_transaction -- Set the transaction locking and isolation

Description

void fbsql_set_transaction ( resource link_identifier, int Locking, int Isolation)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
fbsql_password | Subir | fbsql_username


fbsql_username

(PHP 4 >= 4.0.6)

fbsql_username -- Get or set the host user used with a connection

Description

string fbsql_username ( resource link_identifier [, string username])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
fbsql_set_transaction | Subir | Funciones filePro


Funciones filePro

Manual de PHP
Anterior Siguiente

XXIX. Funciones filePro

Estas funciones permiten acceso en modo de solo-lectura a datos guardados en bases de datos filePro.

filePro es una marca registrada de fP Technologies, Inc. Mas informacion sobre filePro puede encontrarse en http://www.fptech.com/.

Tabla de contenidos
filepro — lee y verifica el fichero de mapeo
filepro_fieldcount — encuentra cuantos campos existen en una base de datos filePro
filepro_fieldname — obtiene el nombre de un campo
filepro_fieldtype — obtiene el tipo de campo
filepro_fieldwidth — obtiene la anchura de un campo
filepro_retrieve — extrae informacion de una base de datos filePro
filepro_rowcount — encuentra cuantas filas existen en una base de datos filePro

Anterior | Inicio | Siguiente
fbsql_username | Subir | filepro


filepro

(PHP 3, PHP 4 >= 4.0.0)

filepro -- lee y verifica el fichero de mapeo

Descripcion

bool filepro ( string directory)

Lee y verifica el fichero de mapeo, guardando la relacion de campos e informacion.

Ningun bloqueo es realizado, por ello, no se deberia modificar la base de datos filePro cuando puede ser abierta con PHP.

Anterior | Inicio | Siguiente
Funciones filePro | Subir | filepro_fieldcount


filepro_fieldname

(PHP 3, PHP 4 >= 4.0.0)

filepro_fieldname -- obtiene el nombre de un campo

Descripcion

string filepro_fieldname ( int field_number)

Devuelve el nombre del campo correspondiente a field_number.

Anterior | Inicio | Siguiente
filepro_fieldcount | Subir | filepro_fieldtype


filepro_fieldtype

(PHP 3, PHP 4 >= 4.0.0)

filepro_fieldtype -- obtiene el tipo de campo

Descripcion

string filepro_fieldtype ( int field_number)

Devuelve el tipo de campo del campo correspondiente a field_number.

Anterior | Inicio | Siguiente
filepro_fieldname | Subir | filepro_fieldwidth


filepro_fieldwidth

(PHP 3, PHP 4 >= 4.0.0)

filepro_fieldwidth -- obtiene la anchura de un campo

Descripcion

int filepro_fieldwidth ( int field_number)

Devuelve la anchura de el campo correspondiente a field_number.

Anterior | Inicio | Siguiente
filepro_fieldtype | Subir | filepro_retrieve


filepro_retrieve

(PHP 3, PHP 4 >= 4.0.0)

filepro_retrieve -- extrae informacion de una base de datos filePro

Descripcion

string filepro_retrieve ( int row_number, int field_number)

Devuelve la informacion de la base de datos contenida en la localizacion especificada.

Anterior | Inicio | Siguiente
filepro_fieldwidth | Subir | filepro_rowcount


filepro_fieldcount

(PHP 3, PHP 4 >= 4.0.0)

filepro_fieldcount -- encuentra cuantos campos existen en una base de datos filePro

Descripcion

int filepro_fieldcount ( void)

Devuelve el numero de campos (columnas) existentes en la base de datos filePro abierta.

Ver tambien filepro().

Anterior | Inicio | Siguiente
filepro | Subir | filepro_fieldname


filepro_rowcount

(PHP 3, PHP 4 >= 4.0.0)

filepro_rowcount -- encuentra cuantas filas existen en una base de datos filePro

Descripcion

int filepro_rowcount ( void)

Devuelve el numero de filas (entradas) existentes en la base de datos filePro abierta.

Ver tambien filepro().

Anterior | Inicio | Siguiente
filepro_retrieve | Subir | Funciones del sistema de ficheros


Funciones del sistema de ficheros

Manual de PHP
Anterior Siguiente

XXX. Funciones del sistema de ficheros

Tabla de contenidos
basename — Devuelve la parte del path correspondiente al nombre del fichero
chgrp — Cambia el grupo de un fichero
chmod — Cambia permisos de un fichero
chown — Cambia el propietario de un fichero
clearstatcache — Limpia la cache de estado de un fichero
copy — Copia un fichero
delete — Una entrada manual inútil
dirname — Devuelve la parte del path correspondiente al directorio
diskfreespace — Devuelve el espacio disponible en un directorio
fclose — Cierra el apuntador a un fichero abierto
feof — Verifica si el apuntador a un fichero está al final del fichero (end-of-file)
fgetc — Obtiene un caracter del fichero apuntado
fgetcsv — Obtiene una línea del fichero apuntado y extrae los campos CSV
fgets — Obtiene una línea del fichero apuntado
fgetss — Obtiene una línea del fichero apuntado y quita las etiquetas HTML
file — lee un fichero completo hacia un array
file_exists — Verifica si un fichero existe
fileatime — Obtiene la última fecha de acceso a un fichero
filectime — Obtiene la fecha de cambio del inode del fichero
filegroup — Obtiene el grupo de un fichero
fileinode — Obtiene el inode del fichero
filemtime — Obtiene la fecha de modificación del fichero
fileowner — Obtiene el propietario del fichero
fileperms — Obtiene los permisos del fichero
filesize — Obtiene el tamaño del fichero
filetype — Obtiene el tipo de fichero
flock — Bloqueo de ficheros portable y asesorado
fopen — Abre un fichero o una URL
fpassthru — Saca todos los datos restantes del fichero apuntado
fputs — Escribe en el fichero apuntado
fread — Lee ficheros en plan binario
fseek — Sitúa el apuntador a un fichero
ftell — Pregunta por la posición del apuntador de lectura/escritura de un fichero
fwrite — Escribe ficheros en plan binario
is_dir — Dice si el fichero nombrado es un directorio
is_executable — Dice si el fichero nombrado es ejecutable
is_file — Dice si el fichero nombrado es un fichero regular
is_link — Dice si el fichero indicado es un enlace simbólico
is_readable — Dice si el fichero indicado se puede leer
is_writeable — Dice si se puede escribir en el fichero indicado
link — Crea un enlace fuerte
linkinfo — Consigue información sobre un enlace
lstat — Da información sobre un fichero o enlace simbólico
mkdir — Crea un directorio
pclose — Cierra el fichero de proceso apuntado
popen — Abre el fichero de proceso apuntado
readfile — Muestra el contenido de un fichero
readlink — Devuelve el objetivo de un enlace simbólico
rename — Renombra un fichero
rewind — Rebobina la posición del apuntador al fichero
rmdir — Elimina un directorio
set_file_buffer — Fija el buffer de fichero del fichero apuntado
stat — Da información sobre un fichero
symlink — Crea un enlace simbólico
tempnam — Crea un fichero de nombre único
touch — Fija la fecha de modificación de un fichero
umask — Cambia la umask actual
unlink — Borra un fichero

Anterior | Inicio | Siguiente
filepro_rowcount | Subir | basename


basename

(PHP 3, PHP 4 >= 4.0.0)

basename -- Devuelve la parte del path correspondiente al nombre del fichero

Descripción

string basename ( string path)

Dada una cadena (string) que contiene el path de un fichero, esta función devuelve el nombre base del fichero.

En Windows, tanto la barra (/) como la barra inversa (\) pueden usarse como caracter separador en el path. En otros entornos, se usa la barra directa (/).

Ejemplo 1. Ejemplo de basename()

$path = "/home/httpd/html/index.php3";
$file = basename($path); // $file toma el valor "index.php3"

Ver también: dirname()

Anterior | Inicio | Siguiente
Funciones del sistema de ficheros | Subir | chgrp


chgrp

(PHP 3, PHP 4 >= 4.0.0)

chgrp -- Cambia el grupo de un fichero

Descripción

int chgrp ( string filename, mixed group)

Trata de cambiar el grupo al que pertenece el fichero filename al grupo group. Sólo el superusuario puede cambiar el grupo de un fichero arbitrariamente; otros usuarios pueden cambiar el grupo del fichero a cualquier grupo del cual el usuario sea miembro.

Devuelve TRUE en caso de éxito; en otro caso devuelve FALSE.

En Windows, no hace nada y devuelve TRUE.

Ver también chown() y chmod().

Anterior | Inicio | Siguiente
basename | Subir | chmod


chmod

(PHP 3, PHP 4 >= 4.0.0)

chmod -- Cambia permisos de un fichero

Descripción

int chmod ( string filename, int mode)

Trata de cambiar los permisos del fichero especificado por filename a los permisos dados por mode.

Cuidado que mode no es asumido de forma automática como un valor octal. Para asegurar que se hace la operación esperada necesitas anteponer un cero (0) como prefijo del parámetro mode:

chmod( "/somedir/somefile", 755 );   // decimal; probablemente incorrecto
chmod( "/somedir/somefile", 0755 );  // octal; valor correcto de mode

Devuelve TRUE en caso de éxito y FALSE en otro caso.

Ver también chown() y chgrp().

Anterior | Inicio | Siguiente
chgrp | Subir | chown


chown

(PHP 3, PHP 4 >= 4.0.0)

chown -- Cambia el propietario de un fichero

Descripción

int chown ( string filename, mixed user)

Trata de cambiar el propietario del fichero filename al usuario user. Sólo el superusuario puede cambiar el propietario de un fichero.

Devuelve TRUE en caso de éxito; en otro caso devuelve FALSE.

Nota: En Windows, no hace nada y devuelve TRUE.

Ver también chown() y chmod().

Anterior | Inicio | Siguiente
chmod | Subir | clearstatcache


clearstatcache

(PHP 3, PHP 4 >= 4.0.0)

clearstatcache -- Limpia la cache de estado de un fichero

Descripción

void clearstatcache ( void)

Invocar la llamada del sistema stat o lstat es bastante costoso en la mayoría de los sistemas. Por lo tanto, el resultado de la última llamada a cualquiera de las funciones de estado (listadas abajo) es guardado para usarlo en la próxima llamada de este tipo empleando el mismo nombre de fichero. Si deseas forzar un nuevo chequeo del estado del fichero, por ejemplo si el fichero está siendo chequeado muchas veces y puede cambiar o desaparecer, usa esta función para borrar los resultados almacenados en memoria de la última llamada.

Este valor sólo es cacheado durante el tiempo de vida de una petición simple.

Entre las funciones afectadas se incluyen stat(),
lstat(),
file_exists(),
is_writeable(),
is_readable(),
is_executable(),
is_file(),
is_dir(),
is_link(),
filectime(),
fileatime(),
filemtime(),
fileinode(),
filegroup(),
fileowner(),
filesize(),
filetype(), y
fileperms().

Anterior | Inicio | Siguiente
chown | Subir | copy


copy

(PHP 3, PHP 4 >= 4.0.0)

copy -- Copia un fichero

Descripción

int copy ( string source, string dest)

Hace una copia de un fichero. Devuelve TRUE si la copia tiene éxito, y FALSE en otro caso.

Ejemplo 1. Ejemplo de copy()

if (!copy($file, $file.'.bak')) {
    print("failed to copy $file...<br>\n");
}

Ver también: rename().

Anterior | Inicio | Siguiente
clearstatcache | Subir | delete


delete

(unknown)

delete -- Una entrada manual inútil

Descripción

void delete ( string file)

Esto es una entrada manual inútil para satisfacer a esas personas que están buscando unlink() o unset() en el lugar equivocado.

Ver también: unlink() para borrar ficheros, unset() para borrar variables.

Anterior | Inicio | Siguiente
copy | Subir | dirname


dirname

(PHP 3, PHP 4 >= 4.0.0)

dirname -- Devuelve la parte del path correspondiente al directorio

Descripción

string dirname ( string path)

Dada una cadena (string) conteniendo el path a un fichero, esta función devolverá el nombre del directorio.

En Windows, tanto la barra (/) como la barra inversa (\) son usadas como separadores de caracteres. En otros entornos, debe usarse la barra directa (/).

Ejemplo 1. Ejemplo de dirname()

$path = "/etc/passwd";
$file = dirname($path); // $file toma el valor "/etc"

Ver también: basename()

Anterior | Inicio | Siguiente
delete | Subir | diskfreespace


diskfreespace

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

diskfreespace -- Devuelve el espacio disponible en un directorio

Descripción

float diskfreespace ( string directory)

Dada una cadena (string) conteniendo el nombre de un directorio, esta función devolverá el número de bytes disponibles en el disco correspondiente.

Ejemplo 1. Ejemplo de diskfreespace()

$df = diskfreespace("/"); // $df contiene el numero de bytes
                          // disponibles en "/"

Anterior | Inicio | Siguiente
dirname | Subir | fclose


fclose

(PHP 3, PHP 4 >= 4.0.0)

fclose -- Cierra el apuntador a un fichero abierto

Description

int fclose ( int fp)

Se cierra el fichero apuntado por fp.

Devuelve TRUE en caso de éxito y FALSE en caso de fallo.

El apuntador al fichero debe ser válido y debe apuntarse a un fichero abierto con éxito con fopen() o con fsockopen().

Anterior | Inicio | Siguiente
diskfreespace | Subir | feof


feof

(PHP 3, PHP 4 >= 4.0.0)

feof -- Verifica si el apuntador a un fichero está al final del fichero (end-of-file)

Descripción

int feof ( int fp)

Devuelve TRUE si el apuntador del fichero está en EOF o si ocurre un error; en otro caso devuelve FALSE.

The file pointer must be valid, and must point to a file El apuntador al fichero debe ser válido, y debe apuntar a un fichero abierto con éxito por fopen(), popen(), o fsockopen().

Anterior | Inicio | Siguiente
fclose | Subir | fgetc


fgetc

(PHP 3, PHP 4 >= 4.0.0)

fgetc -- Obtiene un caracter del fichero apuntado

Descripción

string fgetc ( int fp)

Devuelve una cadena (string) conteniendo un simple caracter leido del fichero apuntado por fp. Devuelve FALSE para EOF (como hace feof()).

El apuntador al fichero debe ser valido, y debe apuntar a un fichero abierto con éxito por fopen(), popen(), o fsockopen().

Ver también fread(), fopen(),
popen(), fsockopen(), y
fgets().

Anterior | Inicio | Siguiente
feof | Subir | fgetcsv


fgetcsv

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

fgetcsv -- Obtiene una línea del fichero apuntado y extrae los campos CSV

Descripción

array fgetcsv ( int fp, int length [, string delimiter])

Parecida a fgets() excepto que fgetcsv() parsea la línea que lee buscando campos en formato CSV y devuelve un array conteniendo los campos leidos. El delimitador de campo es una coma, a menos que se especifique otro delimitador con el tercer parámetro opcional.

fp debe ser un apuntador válido a un fichero abierto con éxito por fopen(), popen(), o fsockopen()

la longitud debe ser mayor que la línea más larga que pueda encontrarse en le fichero CSV (permitiendo arrastrar caracteres de fin de línea)

fgetcsv() devuelve FALSE en caso de error, incluyendo el fin de fichero.

NOTA: Una línea en blanco en un fichero CSV se devuelve como un array que contiene un único campo nulo, y esto no será tratado como un error.

Ejemplo 1. Ejemplo de fgetcsv() - Leer e imprimir el contenido completo de un fichero CSV

$row = 1;
$fp = fopen ("test.csv","r");
while ($data = fgetcsv ($fp, 1000, ",")) {
    $num = count ($data);
    print "<p> $num fields in line $row: <br>";
    $row++;
    for ($c=0; $c<$num; $c++) {
        print $data[$c] . "<br>";
    }
}
fclose ($fp);

Anterior | Inicio | Siguiente
fgetc | Subir | fgets


fgets

(PHP 3, PHP 4 >= 4.0.0)

fgets -- Obtiene una línea del fichero apuntado

Descripción

string fgets ( int fp, int length)

Devuelve una cadena de como mucho length - 1 bytes leidos del fichero apuntado por fp. La lectura acaba cuando son leidos length - 1 bytes, cuando se llega a una nueva línea (el caracter de nueva línea se incluye en el valor devuelto), o cuando se llega a un EOF (lo que ocurra primero).

Si ocurre un error, devuelve FALSE.

Fallos Comunes:

Los que hayan usado la semantica de 'C' de la función fgets deben darse cuenta de la diferencia que hay en como el EOF es devuelto por esta función.

El apuntador al fichero debe ser válido, y debe apuntar a un
fichero abierto con éxito con fopen(),
popen(), o
fsockopen().

A continuación un ejemplo sencillo:

Ejemplo 1. Leyendo un fichero línea por línea

$fd = fopen ("/tmp/inputfile.txt", "r");
while (!feof($fd)) {
    $buffer = fgets($fd, 4096);
    echo $buffer;
}
fclose ($fd);

Ver también fread(), fopen(),
popen(), fgetc(), y
fsockopen().

Anterior | Inicio | Siguiente
fgetcsv | Subir | fgetss


fgetss

(PHP 3, PHP 4 >= 4.0.0)

fgetss -- Obtiene una línea del fichero apuntado y quita las etiquetas HTML

Descripción

string fgetss ( int fp, int length [, string allowable_tags])

Idéntica a fgets(), excepto que fgetss trata de quitar cualquier etiqueta HTML y PHP del texto que lee.

Se puede utilizar el tercer parámetro opcional para especificar etiquetas que no deben de quitarse.

Nota: allowable_tags fue añadido en PHP 3.0.13, PHP4B3.

Ver también fgets(), fopen(),
fsockopen(), popen(), y
strip_tags().

Anterior | Inicio | Siguiente
fgets | Subir | file


file

(PHP 3, PHP 4 >= 4.0.0)

file -- lee un fichero completo hacia un array

Descripción

array file ( string filename [, int use_include_path])

Idéntica a readfile(), excepto que file() devuelve el fichero en un array. Cada elemento del array corresponde a una línea del fichero, con el caracter de nueva línea incluido.

Se puede utilizar el segundo parámetro opcional y ponerle el valor "1", si también se quiere buscar el fichero en el include_path.

Ver también readfile(), fopen(), y popen().

Anterior | Inicio | Siguiente
fgetss | Subir | file_exists


file_exists

(PHP 3, PHP 4 >= 4.0.0)

file_exists -- Verifica si un fichero existe

Descripción

int file_exists ( string filename)

Devuelve TRUE si el fichero especificado por filename existe; y FALSE en otro caso.

El resultado de esta función es cacheado. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
file | Subir | fileatime


fileatime

(PHP 3, PHP 4 >= 4.0.0)

fileatime -- Obtiene la última fecha de acceso a un fichero

Descripción

int fileatime ( string filename)

Devuelve la fecha a la que el fichero fue accedido por última vez, o FALSE en caso de error.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
file_exists | Subir | filectime


filectime

(PHP 3, PHP 4 >= 4.0.0)

filectime -- Obtiene la fecha de cambio del inode del fichero

Descripción

int filectime ( string filename)

Devuelve el momento en el que el fichero fue cambiado por última vez, o FALSE en caso de error.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
fileatime | Subir | filegroup


filegroup

(PHP 3, PHP 4 >= 4.0.0)

filegroup -- Obtiene el grupo de un fichero

Descripción

int filegroup ( string filename)

Devuelve el identificador (ID) de grupo del propietario del fichero, o FALSE en caso de un error. El ID del grupo es devuelto en formato numérico, usar posix_getgrgid() para obtener el nombre del grupo.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
filectime | Subir | fileinode


fileinode

(PHP 3, PHP 4 >= 4.0.0)

fileinode -- Obtiene el inode del fichero

Descripción

int fileinode ( string filename)

Devuelve el número de inode del fichero, o FALSE en caso de un error.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
filegroup | Subir | filemtime


filemtime

(PHP 3, PHP 4 >= 4.0.0)

filemtime -- Obtiene la fecha de modificación del fichero

Descripción

int filemtime ( string filename)

Devuelve el momento en el que el fichero fue modificado por última vez, o FALSE en caso de un error.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
fileinode | Subir | fileowner


fileowner

(PHP 3, PHP 4 >= 4.0.0)

fileowner -- Obtiene el propietario del fichero

Descripción

int fileowner ( string filename)

Devuelve el identificador (ID) de usuario del propietario del fichero, o FALSE en caso de error. El ID de usuario se devuelve en formato numérico, usar posix_getpwuid() para obtener el nombre del usuario.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
filemtime | Subir | fileperms


fileperms

(PHP 3, PHP 4 >= 4.0.0)

fileperms -- Obtiene los permisos del fichero

Descripción

int fileperms ( string filename)

Devuelve los permisos del fichero, o FALSE en caso de error.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
fileowner | Subir | filesize


filesize

(PHP 3, PHP 4 >= 4.0.0)

filesize -- Obtiene el tamaño del fichero

Descripción

int filesize ( string filename)

Devuelve el tamaño del fichero, o FALSE en caso de error.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
fileperms | Subir | filetype


filetype

(PHP 3, PHP 4 >= 4.0.0)

filetype -- Obtiene el tipo de fichero

Descripción

string filetype ( string filename)

Devuelve el tipo de fichero. Valores posibles son fifo, char, dir, block, link, file, y unknown.

Devuelve FALSE si ocurre un error.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
filesize | Subir | flock


flock

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

flock -- Bloqueo de ficheros portable y asesorado

Description

bool flock ( int fp, int operation)

PHP soporta un método portable de bloquear ficheros completos de manera asesorada (lo que significa que todos los programas que acceden tienen que usar el mismo modo de bloqueo o éste no funcionará).

flock() opera sobre fp el cual debe ser un apuntador a un fichero abierto. operation toma uno de los siguientes valores:

  • Para que adquiera un bloqueo compartido (lectura), fija operation a 1.

  • Para adquirir un bloqueo exclusivo (escritura), fija operation a 2.

  • Para liberar un bloqueo (compartido o exclusivo), fija operation a 3.

  • Si no quieres que flock() bloquee mientras está activado, suma 4 al valor de operation.

flock() permite establece un modelo simple de lectura/escritura el cual puede usarse en prácticamente cualquier plataforma (incluyendo la mayoria de sistemas Unix e incluso Windows).

flock() devuelve TRUE en caso de éxito y FALSE en caso de error (ej. cuando no se puede establecer un bloqueo).

Anterior | Inicio | Siguiente
filetype | Subir | fopen


fopen

(PHP 3, PHP 4 >= 4.0.0)

fopen -- Abre un fichero o una URL

Descripción

int fopen ( string filename, string mode [, int use_include_path])

Si filename comienza con "http://" (no es sensible a mayúsculas), se abre una conexión HTTP 1.0 hacia el servidor especificado y se devuelve un apuntador de fichero al comienzo del texto de respuesta.

No maneja redirecciones HTTP, por eso se debe incluir una barra final cuando se trata de directorios.

Si filename comienza con "ftp://" (no es sensible a mayúsculas), se abre una conexión ftp hacia el servidor especificado y se devuelve un apuntador al fichero requerido. Si el servidor no soporta ftp en modo pasivo, esto fallará. Se pueden abrir fichero via ftp para leer o para escribir (pero no ambas cosas simultáneamente).

Si filename no comienza con nada de lo anterior, el fichero se abre del sistema de ficheros, y se devuelve un apuntador al fichero abierto.

Si el abrir el fichero falla, la función devuelve FALSE.

mode puede ser cualquiera de lo siguiente:

  • 'r' - Abre para sólo lectura; sitúa el apuntador del fichero al comienzo del mismo.

  • 'r+' - Abre para lectura y escritura; situa el apuntador del fichero al comienzo del fichero.

  • 'w' - Abre para sólo escritura; sitúa el apuntador del fichero al comienzo del fichero y trunca el fichero con longitud cero. Si el fichero no existe, trata de crearlo.

  • 'w+' - Abre el fichero para lectura y escritura; sitúa el apuntador del fichero al comienzo del fichero y trunca el fichero con longitud cero. Si el fichero no existe, trata de crearlo.

  • 'a' - Abre sólo para escribir (añadir); sitúa el apuntador del fichero al final del mismo. Si el fichero no existe, trata de crearlo.

  • 'a+' - Abre para lectura y escritura (añadiendo); sitúa el apuntador del fichero al final del mismo. Si el fichero no existe, trata de crearlo.

Además, mode puede contener la letra 'b'. Esto es útil para sistemas que diferencian entre ficheros binarios y de texto (ej. es inútil en Unix). Si no se necesita, será ignorado.

Puede usarse el tercer parámetro opcional y fijarlo a "1", si también se quiere buscar el fichero en el include_path.

Ejemplo 1. Ejemplo de fopen()()

$fp = fopen("/home/rasmus/file.txt", "r");
$fp = fopen("http://www.php.net/", "r");
$fp = fopen("ftp://user:password@example.com/", "w");

Si experimentas problemas a la hora de leer y escribir a ficheros y estas usando la version de PHP como módulo para el servidor, recuerda que debes asegurar que los ficheros y directorios que estas usando son accesibles al proceso servidor.

En la plataforma Windows, ten cuidado de escribir correctamente las barras invertidas en el path del fichero (poniéndolas dobles), o usa barras directas.

$fp = fopen("c:\\data\\info.txt", "r");

Ver también fclose(), fsockopen(), y popen().

Anterior | Inicio | Siguiente
flock | Subir | fpassthru


fpassthru

(PHP 3, PHP 4 >= 4.0.0)

fpassthru -- Saca todos los datos restantes del fichero apuntado

Descripción

int fpassthru ( int fp)

Lee hasta el EOF del fichero apuntado y escribe los resultados a la salida estándar (stdout).

Si ocurre un error, fpassthru() devuelve FALSE.

El apuntador al fichero debe ser válido, y debe apuntar a un fichero abierto con éxito por fopen(), popen(), o fsockopen(). El fichero se cierra cuando fpassthru() termina de leerlo (dejando fp sin ninguna utilidad).

Si sólo quieres volcar el contenido de un fichero a stdout puedes If you just want to dump the contents of a file to stdout you may usar la función readfile(), la cual te libra de la llamada a fopen().

Ver también readfile(),
fopen(), popen(), y
fsockopen()

Anterior | Inicio | Siguiente
fopen | Subir | fputs


fputs

(PHP 3, PHP 4 >= 4.0.0)

fputs -- Escribe en el fichero apuntado

Descripción

int fputs ( int fp, string str [, int length])

fputs() es un alias de fwrite(), y es idéntico a él en todo. Notar que el parámetro length es opcional y si no se pone la cadena entera será escrita.

Anterior | Inicio | Siguiente
fpassthru | Subir | fread


fread

(PHP 3, PHP 4 >= 4.0.0)

fread -- Lee ficheros en plan binario

Descripción

string fread ( int fp, int length)

fread() lee hasta length bytes del apuntador de fichero referenciado por fp. La lectura acaba cuando length bytes se han leido o se alcanza EOF, lo que ocurra primero.

// Mete el contenido de un fichero en una cadena
$filename = "/usr/local/something.txt";
$fd = fopen ($filename, "r");
$contents = fread ($fd, filesize ($filename));
fclose ($fd);

Ver también fwrite(), fopen(),
fsockopen(), popen(),
fgets(), fgetss(),
file(), y fpassthru().

Anterior | Inicio | Siguiente
fputs | Subir | fseek


fseek

(PHP 3, PHP 4 >= 4.0.0)

fseek -- Sitúa el apuntador a un fichero

Descripción

int fseek ( int fp, int offset)

Fija el indicador de posición del fichero referenciado por fp a tantos bytes como indica offset. Es equivalente a la llamada (en C) fseek(fp, offset, SEEK_SET).

Si va bien, devuelve 0; en otro caso, devuelve -1. Tener en cuenta que situarse más alla de EOF no se considera un error.

No puede usarse sobre apuntadores de ficheros devueltos por fopen() si usan los formatos "http://" or "ftp://".

Ver también ftell() y rewind().

Anterior | Inicio | Siguiente
fread | Subir | ftell


ftell

(PHP 3, PHP 4 >= 4.0.0)

ftell -- Pregunta por la posición del apuntador de lectura/escritura de un fichero

Descripción

int ftell ( int fp)

Devuelve la posición del apuntador de fichero referenciado por fp; es decir, la distancia en la secuencia del fichero.

Si ocurre un error, devuelve FALSE.

El apuntador al fichero debe ser válido, y debe referirse a The file pointer must be valid, and must point to a file un fichero abierto con éxito por fopen() o popen().

Ver también fopen(), popen(), fseek() y rewind().

Anterior | Inicio | Siguiente
fseek | Subir | fwrite


fwrite

(PHP 3, PHP 4 >= 4.0.0)

fwrite -- Escribe ficheros en plan binario

Descripción

int fwrite ( int fp, string string [, int length])

fwrite() escribe el contenido de string al fichero apuntado por fp. Si se da el argumento length, la escritura acaba antes de que length bytes sean escritos o se alcance el final de string, lo que ocurra primero.

Tener en cuenta que si se da el argumento length, entonces la opción de configuración magic_quotes_runtime será ignorada y los caracteres de barra no se quitarán de la cadena string.

Ver también fread(), fopen(),
fsockopen(), popen(), y
fputs().

Anterior | Inicio | Siguiente
ftell | Subir | is_dir


set_file_buffer

(PHP 3>= 3.0.8, PHP 4 )

set_file_buffer -- Fija el buffer de fichero del fichero apuntado

Description

int fwrite ( int fp, int buffer)

set_file_buffer() fija el buffer para operaciones de escritura en el apuntador de fichero fp con buffer bytes. Si buffer es 0 entonces las operaciones de escritura no usan un buffer intermedio.

La función devuelve 0 en caso de éxito, o EOF si la petición no se puede realizar.

Tener en cuenta que por defecto cualquier fopen hace una llamada a set_file_buffer de 8K.

Ver también fopen().

Anterior | Inicio | Siguiente
rmdir | Subir | stat


is_dir

(PHP 3, PHP 4 >= 4.0.0)

is_dir -- Dice si el fichero nombrado es un directorio

Descripción

bool is_dir ( string filename)

Devuelve TRUE si el nombre del fichero existe y es un directorio.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Ver también is_file() y is_link().

Anterior | Inicio | Siguiente
fwrite | Subir | is_executable


is_executable

(PHP 3, PHP 4 >= 4.0.0)

is_executable -- Dice si el fichero nombrado es ejecutable

Descripción

bool is_executable ( string filename)

Devuelve TRUE si el fichero indicado existe y es ejecutable.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Ver también is_file() y is_link().

Anterior | Inicio | Siguiente
is_dir | Subir | is_file


is_file

(PHP 3, PHP 4 >= 4.0.0)

is_file -- Dice si el fichero nombrado es un fichero regular

Descripción

bool is_file ( string filename)

Devuelve TRUE si el fichero nombrado existe y es un fichero regular.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Ver también is_dir() y is_link().

Anterior | Inicio | Siguiente
is_executable | Subir | is_link


is_link

(PHP 3, PHP 4 >= 4.0.0)

is_link -- Dice si el fichero indicado es un enlace simbólico

Descripción

bool is_link ( string filename)

Devuelve TRUE si el fichero indicado existe y es un enlace simbólico.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Ver también is_dir() y is_file().

Anterior | Inicio | Siguiente
is_file | Subir | is_readable


is_readable

(PHP 3, PHP 4 >= 4.0.0)

is_readable -- Dice si el fichero indicado se puede leer

Descripción

bool is_readable ( string filename)

Devuelve TRUE si el fichero indicado existe y se puede leer.

Recuerda que PHP puede acceder al fichero con el identificador de usuario con el que el servidor web se ejecuta (a menudo 'nobody'). No se tienen en cuenta las limitaciones de modos seguros.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Ver también is_writeable().

Anterior | Inicio | Siguiente
is_link | Subir | is_writeable


is_writeable

(PHP 3, PHP 4 >= 4.0.0)

is_writeable -- Dice si se puede escribir en el fichero indicado

Descripción

bool is_writeable ( string filename)

Devuelve TRUE si el fichero indicado existe y se puede escribir en él. El argumento filename puede ser el nombre de un directorio, lo que permite verificar si un directorio tiene permiso de escritura.

Recuerda que PHP puede acceder al fichero con el identificador de usuario con el que el servidor web se ejecuta (a menudo 'nobody'). No se tienen en cuenta las limitaciones de modos seguros.

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Ver también is_readable().

Anterior | Inicio | Siguiente
is_readable | Subir | link


link

(PHP 3, PHP 4 >= 4.0.0)

link -- Crea un enlace fuerte

Descripción

int link ( string target, string link)

link() crea un enlace fuerte.

Ver también symlink() para crear enlaces débiles, y readlink() junto con linkinfo().

Anterior | Inicio | Siguiente
is_writeable | Subir | linkinfo


linkinfo

(PHP 3, PHP 4 >= 4.0.0)

linkinfo -- Consigue información sobre un enlace

Descripción

int linkinfo ( string path)

linkinfo() da el campo st_dev de la extructura stat de UNIX C devuelto por la llamada al sistema lstat. Esta función se usa para verificar si un enlace (apuntado por path) existe realmente (usando el mismo método que la macro S_ISLNK definida en stat.h). Devuelve 0 o FALSE en caso de error.

Ver también symlink(), link(), y readlink().

Anterior | Inicio | Siguiente
link | Subir | lstat


mkdir

(PHP 3, PHP 4 >= 4.0.0)

mkdir -- Crea un directorio

Descripción

int mkdir ( string pathname, int mode)

Trata de crear el directorio especificado por pathname.

Ten en cuenta que debes especifiar el modo como un número octal, lo que significa que debes anteponerle un 0 al número.

mkdir ("/path/to/my/dir", 0700);

Devuelve TRUE en caso de éxito y FALSE en caso de fallo.

Ver también rmdir().

Anterior | Inicio | Siguiente
lstat | Subir | pclose


pclose

(PHP 3, PHP 4 >= 4.0.0)

pclose -- Cierra el fichero de proceso apuntado

Descripción

int pclose ( int fp)

Cierra un fichero que representa un tuberia (pipe) abierta con popen().

El apuntador al fichero debe ser válido, y debe haber sido devuelto por una llamada con éxito a popen().

Devuelve el estado de terminación del proceso que estaba ejecutándose.

Ver también popen().

Anterior | Inicio | Siguiente
mkdir | Subir | popen


popen

(PHP 3, PHP 4 >= 4.0.0)

popen -- Abre el fichero de proceso apuntado

Descripción

int popen ( string command, string mode)

Abre una tubería (pipe) a un proceso ejecutado haciendo fork al comando dado por command

Devuelve un apuntador de fichero idéntico al devuelto por fopen(), excepto que este es unidireccional (sólo puede usarse o para leer o para escribir) y debe cerrarse con pclose(). Este apuntador puede usarse con fgets(), fgetss(), y fputs().

Si ocurre un error, devuelve FALSE.

$fp = popen ("/bin/ls", "r");

Ver también pclose().

Anterior | Inicio | Siguiente
pclose | Subir | readfile


readfile

(PHP 3, PHP 4 >= 4.0.0)

readfile -- Muestra el contenido de un fichero

Descripción

int readfile ( string filename [, int use_include_path])

Lee un fichero y lo escribe a la salida estándar.

Devuelve el número de bytes leidos del fichero. Si ocurre un error, se devuelve FALSE y a menos que la función fuera llamada como @readfile, se imprime un mensaje de error

Si filename comienzo por "http://" (no es sensible a mayúsculas), se abre una conexión HTTP 1.0 al servidor especificado y el texto de la respuesta se escribe a la salida estándar.

No maneja redirecciones HTTP, por eso se debe incluir una barra final cuando se trata de directorios.

Si filename comienza con "ftp://" (no es sensible a mayúsculas), se abre una conexión ftp al servidor especificado y el fichero que se pide se escribe en la salida estándar. Si el servidor no soporta ftp en modo pasivo, la función fallará.

Si filename no comienza con ninguna de las cadenas anteriores, el fichero será abierto del sistema de ficheros y su contenido escrito en la salida estándar.

Se puede usar el segundo parámetro opcional y fijarlo a "1", si si quieres que también se busque el fichero en el include_path.

Ver también fpassthru(),
file(), fopen(),
include(), require(), y
virtual().

Anterior | Inicio | Siguiente
popen | Subir | readlink


readlink

(PHP 3, PHP 4 >= 4.0.0)

readlink -- Devuelve el objetivo de un enlace simbólico

Descripción

string readlink ( string path)

readlink() hace lo mismo que la función C readlink C y devuelve el contenido del path del enlace simbólico o 0 en caso de error.

Ver también symlink(),
readlink() y
linkinfo().

Anterior | Inicio | Siguiente
readfile | Subir | rename


rename

(PHP 3, PHP 4 >= 4.0.0)

rename -- Renombra un fichero

Descripción

int rename ( string oldname, string newname)

Trata de renombrar oldname como newname.

Devuelve TRUE en caso de éxito y FALSE en caso de fallo.

Anterior | Inicio | Siguiente
readlink | Subir | rewind


rewind

(PHP 3, PHP 4 >= 4.0.0)

rewind -- Rebobina la posición del apuntador al fichero

Descripción

int rewind ( int fp)

Fija el indicador de posición del fichero dado por fp al comienzo de del fichero.

Si ocurre un error, devuelve 0.

El apuntador al fichero debe ser válido, y debe apuntar a un fichero abierto con éxito por fopen().

Ver también fseek() y ftell().

Anterior | Inicio | Siguiente
rename | Subir | rmdir


rmdir

(PHP 3, PHP 4 >= 4.0.0)

rmdir -- Elimina un directorio

Descripción

int rmdir ( string dirname)

Trata de eliminar el directorio indicado por pathname. El directorio debe estar vacio, y los permisos relevantes deben permitir esto.

Si ocurre un error, devuelve 0.

Ver también mkdir().

Anterior | Inicio | Siguiente
rewind | Subir | set_file_buffer


stat

(PHP 3, PHP 4 >= 4.0.0)

stat -- Da información sobre un fichero

Descripción

array stat ( string filename)

Recoje los datos sobre el fichero indicado por filename.

Devuelve un array conteniendo los datos del fichero con los siguientes elementos:

  1. dispositivo (device)

  2. inode

  3. modo de protección del inode

  4. número de enlaces

  5. id de usuario del propietario

  6. id de grupo del propietario

  7. tipo de dispositivo si es un inode device *

  8. tamaño en bytes

  9. fecha del último acceso access

  10. fecha de la última modificación

  11. fecha del último cambio

  12. tamaño del bloque para el sistema I/O *

  13. número de bloques ocupados

* - sólo válido en sistemas que soportan el tipo st_blksize --otros sistemas (como Windows) devuelven -1

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
set_file_buffer | Subir | symlink


lstat

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

lstat -- Da información sobre un fichero o enlace simbólico

Descripción

array lstat ( string filename)

Reúne los datos del fichero o enlace simbólico indicado por filename. Esta función es idéntica a la función stat() excepto que si el nombre en el parámetro filename es un enlace simbólico, son devueltos los datos (status) del enlace simbólico, y no los del fichero al que apunta el enlace simbólico.

Devuelve un array conteniendo los datos del fichero con los siguientes elementos:

  1. dispositivo (device)

  2. inode

  3. número de enlaces

  4. id de usuario del propietario

  5. id de grupo del propietario

  6. tipo de disposivo si es un inode device *

  7. tamaño en bytes

  8. fecha del último acceso

  9. fecha de la última modificación

  10. fecha del último cambio

  11. tamaño de bloque para el sistema I/O *

  12. número de bloques ocupados

* - sólo válido en sistemas que soportan el tipo st_blksize --otros sistemas (como Windows) devuelven -1

Los resultados de esta función son cacheados. Ver clearstatcache() para más detalles.

Anterior | Inicio | Siguiente
linkinfo | Subir | mkdir


symlink

(PHP 3, PHP 4 >= 4.0.0)

symlink -- Crea un enlace simbólico

Descripción

int symlink ( string target, string link)

symlink() crea un enlace simbólico del objetivo target con el nombre especificado por link.

Ver también link() para crear enlaces fuertes, y readlink() junto con linkinfo().

Anterior | Inicio | Siguiente
stat | Subir | tempnam


tempnam

(PHP 3, PHP 4 >= 4.0.0)

tempnam -- Crea un fichero de nombre único

Descripción

string tempnam ( string dir, string prefix)

Crea un fichero temporal de nombre único en el directorio especificado. Si el directorio no existe tempnam() puede generar un fichero en el directorio temporal del sistema.

El comportamiento de la función tempnam() depende del sistema. En Windows la variable de entorno TMP se impone sobre el parámetro dir, en Linux la variable de entorno TMPDIR tiene preferencia, mientras que en SVR4 siempre se usará el parámetro dir si si el directorio al que apunta existe. Consulta la documentación del sistema sobre la función tempnam(3) en caso de duda.

Devuelve el nombre del nuevo fichero temporal, o una cadena nula en caso de fallo.

Ejemplo 1. Ejemplo de tempnam()

$tmpfname = tempnam ("/tmp", "FOO");

Anterior | Inicio | Siguiente
symlink | Subir | touch


touch

(PHP 3, PHP 4 >= 4.0.0)

touch -- Fija la fecha de modificación de un fichero

Descripción

int touch ( string filename, int time)

Trata de fijar la fecha de modificación del fichero indicado por filename al valor dado por time. Si no se pone la opción time, se utiliza la fecha actual.

Si el fichero no existe, será creado.

Devuelve TRUE en caso de éxito y FALSE en otro caso.

Anterior | Inicio | Siguiente
tempnam | Subir | umask


umask

(PHP 3, PHP 4 >= 4.0.0)

umask -- Cambia la umask actual

Descripción

int umask ( int mask)

umask() fija las umask PHP con la mascara & 0777 y y devuelve la antigua umask. Cuando PHP se está usando como un módulo del servidor, la umask se restaura cuando cada petición es finalizada.

umask() sin argumentos sólamente devuelve la umask actual.

Anterior | Inicio | Siguiente
touch | Subir | unlink


unlink

(PHP 3, PHP 4 >= 4.0.0)

unlink -- Borra un fichero

Descripción

int unlink ( string filename)

Borra el fichero filename. Es similar a la función unlink() del Unix C.

Devuelve 0 o FALSE en caso de error.

Ver también rmdir() para borrar directorios.

Anterior | Inicio | Siguiente
umask | Subir | Funciones Forms Data Format (Formato de Datos de Formularios)


Funciones Forms Data Format (Formato de Datos de Formularios)

Manual de PHP
Anterior Siguiente

XXXI. Funciones Forms Data Format (Formato de Datos de Formularios)

El Formato de Datos de Formulario (FDF) está diseñado para el manejo de formularios en archivos PDF. Se aconseja leer la información disponible en http://partners.adobe.com/asn/developer/acrosdk/forms.html para más información sobre lo que es FDF y cómo se usa en general.

Nota: Actualmente Adobe sólo proporciona una versión compatible con libc5 para Linux. Las pruebas con glibc2 provocaron un fallo de segmentado. Si alguien es capaz de hacerla funcionar, por favor coméntelo en esta página.

Nota: Si tiene problemas configurando php con soporte de fdftk, compruebe si el archivo de cabecera FdfTk.h y la librería libFdfTk.so están en su lugar correcto. Deberían encontrarse respectivamente en fdftk-dir/include y en fdftk-dir/lib. Este problema no se dará si se limita a desempaqueta la distribucón del FtdTk.

La idea general del FDF es similar a los formularios HTML. La diferencia básicamente está en el formato en que se transmiten los datos al servidor cuando se pulsa el botón de envío (este es realmente el Formato de Datos de Formulario) y el formato del formulario en sí mismo (que es el Formato de Documento Portable, PDF). Procesar lo datos del FDF es una de las características que proporcionan las funciones fdf. Pero aún hay más. Uno también puede tomar un formulario PDF y rellenar los campos de entrada con datos sin modificar el formulario en sí mismo. En dicho caso, lo que se hace es crear un documento FDF (fdf_create()), fijar los valores de cada campo de entrada (fdf_set_value()) y asociarlo con un formulario PDF (fdf_set_file()). Finalmente, debe ser enviado al navegador con el MimeType application/vnd.fdf. El plug-in de Acrobar reader de su navegador reconoce el MimeType, lee el formulario PDF asociado y rellena los datos a partir del documento FDF.

Los siguientes ejemplos muestran cómo se evalúan los datos de los formularios.

Ejemplo 1. Evaluando un documento FDF

<?php
// Guarda los datos FDF en un archivo temporal
$fdffp = fopen("test.fdf", "w");
fwrite($fdffp, $HTTP_FDF_DATA, strlen($HTTP_FDF_DATA));
fclose($fdffp);

// Abre archivo temporal y evalúa los datos
// El formulario pdf contenía varios campos de texto con los nombres
// volumen, fecha, comentario, editorial, preparador, y dos casillas de verificación
// muestra_editorial y muestra_preparador.
$fdf = fdf_open("test.fdf");
$volume = fdf_get_value($fdf, "volumen");
echo "El campo volumen tiene el valor '<B>$volume</B>'<BR>";

$date = fdf_get_value($fdf, "fecha");
echo "El campo fecha tiene el valor '<B>$date</B>'<BR>";

$comment = fdf_get_value($fdf, "comentario");
echo "El campo comentario tiene el valor '<B>$comment</B>'<BR>";

if(fdf_get_value($fdf, "muestra_editorial") == "On") {
  $publisher = fdf_get_value($fdf, "editorial");
  echo "El campo editorial tiene el valor '<B>$publisher</B>'<BR>";
} else
  echo "No se debe mostrar la editorial.<BR>";

if(fdf_get_value($fdf, "muestra_preparador") == "On") {
  $preparer = fdf_get_value($fdf, "preparador");
  echo "El campo preparador tiene el valor '<B>$preparer</B>'<BR>";
} else
  echo "No se debe mostrar el preparador.<BR>";
fdf_close($fdf);
?>
Tabla de contenidos
fdf_close — Cerrar un documento FDF
fdf_create — Crear un documento FDF
fdf_get_file — Obtener el valor de la clave /F
fdf_get_status — Obtener el valor de la clave /STATUS
fdf_get_value — Obtener el valor de un campo
fdf_next_field_name — Obtener el nombre del siguiente campo
fdf_open — Abrir un documento FDF
fdf_save — Guardar un documeto FDF
fdf_set_ap — Ajusta la apariencia de un campo
fdf_set_file — Fijar el valor de la clave /F
fdf_set_status — Fija el valor de la clave /STATUS
fdf_set_value — Fijar el valor de un campo

Anterior | Inicio | Siguiente
unlink | Subir | fdf_close


fdf_open

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_open -- Abrir un documento FDF

Descripción

int fdf_open ( string filename)

La función fdf_open() abre un archivo con datos de formulario. Este archivo debe contener los datos tal y como se devuelven en un formulario PDF. Actualmente dicho archivo debe crearse "manualmente" usando la función fopen() y escribiendo en éste el contenido de HTTP_FDF_DATA usando fwrite(). No existe un mecanismo similar al de los formularios HTML donde se crea una variable para cada campo de entrada.

Ejemplo 1. Accediendo a los datos del formulario

<?php
// Guarda los datos FDF en un archivo temporal
$fdffp = fopen("test.fdf", "w");
fwrite($fdffp, $HTTP_FDF_DATA, strlen($HTTP_FDF_DATA));
fclose($fdffp);

// Abre archivo temporal y evalúa los datos
$fdf = fdf_open("test.fdf");
...
fdf_close($fdf);
?>

Vea también fdf_close().

Anterior | Inicio | Siguiente
fdf_next_field_name | Subir | fdf_save


fdf_close

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_close -- Cerrar un documento FDF

Descripción

void fdf_close ( int fdf_document)

La función fdf_close() cierra un documento FDF.

Vea también fdf_open().

Anterior | Inicio | Siguiente
Funciones Forms Data Format (Formato de Datos de Formularios) | Subir | fdf_create


fdf_create

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_create -- Crear un documento FDF

Descripción

int fdf_create ( void )

La función fdf_create() crea un documento FDF nuevo. Esta función se necesita si se desea rellenar los campos de entrada en un documento PDF.

Ejemplo 1. Rellenando un documento PDF

<?php
$outfdf = fdf_create();
fdf_set_value($outfdf, "volumen", $volume, 0);

fdf_set_file($outfdf, "http:/testfdf/resultlabel.pdf");
fdf_save($outfdf, "outtest.fdf");
fdf_close($outfdf);
Header("Content-type: application/vnd.fdf");
$fp = fopen("outtest.fdf", "r");
fpassthru($fp);
unlink("outtest.fdf");
?>

Vea también fdf_close(),
         fdf_save(),
         fdf_open().

Anterior | Inicio | Siguiente
fdf_close | Subir | fdf_get_file


fdf_save

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_save -- Guardar un documeto FDF

Descripción

int fdf_save ( string filename)

La función fdf_save() guarda un documento FDF. El kit de FDF proporciona una forma de volcar el documento a stdout si el parámetro filename es '.'. Esto no funciona si el PHP se utiliza como un módulo del apache. En tal caso se deberá escribir a un fichero y utilizar p. ej. fpassthru() para visualizarlo.

Vea también fdf_close() y el ejemplo para fdf_create().

Anterior | Inicio | Siguiente
fdf_open | Subir | fdf_set_ap


fdf_get_value

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_get_value -- Obtener el valor de un campo

Descripción

string fdf_get_value ( int fdf_document, string fieldname)

La función fdf_get_value() devuelve el valor de un campo.

Vea también fdf_set_value().

Anterior | Inicio | Siguiente
fdf_get_status | Subir | fdf_next_field_name


fdf_set_value

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_set_value -- Fijar el valor de un campo

Descripción

void fdf_set_value ( int fdf_document, string fieldname, string value, int isName)

La función fdf_set_value() fija el valor de un campo. El parámetro final determina si el valor del campo se deberá convertir a un Nombre PDF (isName = 1) o convertir en una Cadena PDF (isName = 0).

Vea también fdf_get_value().

Anterior | Inicio | Siguiente
fdf_set_status | Subir | FriBiDi functions


fdf_next_field_name

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_next_field_name -- Obtener el nombre del siguiente campo

Descripción

string fdf_next_field_name ( int fdf_document, string fieldname)

La función fdf_next_field_name() devuelve el nombre del campo tras el campo fieldname o el nombre del primer campo si el segundo parámetro es NULL.

Vea también fdf_set_field(), fdf_get_field().

Anterior | Inicio | Siguiente
fdf_get_value | Subir | fdf_open


fdf_set_ap

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_set_ap -- Ajusta la apariencia de un campo

Descripción

void fdf_set_ap ( int fdf_document, string field_name, int face, string filename, int page_number)

La función fdf_set_ap() ajusta la apariencia de un campo (p. ej. el valor de la clave /AP). Los valores posibles de face son 1=FDFNormalAP, 2=FDFRolloverAP, 3=FDFDownAP.

Anterior | Inicio | Siguiente
fdf_save | Subir | fdf_set_file


fdf_set_status

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_set_status -- Fija el valor de la clave /STATUS

Descripción

void fdf_set_status ( int fdf_document, string status)

La función fdf_set_status() fija el valor de la clave /STATUS.

Vea también fdf_get_status().

Anterior | Inicio | Siguiente
fdf_set_file | Subir | fdf_set_value


fdf_get_status

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_get_status -- Obtener el valor de la clave /STATUS

Descripción

string fdf_get_status ( int fdf_document)

La función fdf_get_status() devuelve el valor de la clave /STATUS.

Vea también fdf_set_status().

Anterior | Inicio | Siguiente
fdf_get_file | Subir | fdf_get_value


fdf_set_file

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_set_file -- Fijar el valor de la clave /F

Descripción

void fdf_set_file ( int fdf_document, string filename)

La función fdf_set_file() fija el valor de la clave /F. La clave /F es simplemente una referencia a un formulario PDF que se va a rellenar con datos. En un entorno web es un URL (p.ej. http:/testfdf/resultlabel.pdf).

Vea también fdf_get_file() y el ejemplo para fdf_create().

Anterior | Inicio | Siguiente
fdf_set_ap | Subir | fdf_set_status


fdf_get_file

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

fdf_get_file -- Obtener el valor de la clave /F

Descripción

string fdf_get_file ( int fdf_document)

La función fdf_set_file() devuelve el valor de la clave /F.

Vea también fdf_set_file().

Anterior | Inicio | Siguiente
fdf_create | Subir | fdf_get_status


FriBiDi functions

Manual de PHP
Anterior Siguiente

XXXII. FriBiDi functions

Tabla de contenidos
fribidi_log2vis — Convert a logical string to a visual one

Anterior | Inicio | Siguiente
fdf_set_value | Subir | fribidi_log2vis


fribidi_log2vis

(PHP 4 >= 4.0.4)

fribidi_log2vis -- Convert a logical string to a visual one

Description

string fribidi_log2vis ( string str, string direction, int charset)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
FriBiDi functions | Subir | Funciones FTP


Funciones FTP

Manual de PHP
Anterior Siguiente

XXXIII. Funciones FTP

FTP es el acrónimo de File Transfer Protocol (Protocolo de Transferencia de Ficheros.

Cuando se utiliza el módulo FTP, se definen las siguientes constantes: FTP_ASCII, y FTP_BINARY.

Tabla de contenidos
ftp_cdup — Cambia al directorio padre
ftp_chdir — Cambia de directorio en un servidor FTP
ftp_connect — Establece una conexión FTP
ftp_delete — Borra un fichero del servidor FTP.
ftp_fget — Descarga un fichero del servidor FTP y lo guarda en un fichero abierto.
ftp_fput — Sube un fichero abierto al servidor FTP.
ftp_get — Descarga un fichero del servidor FTP.
ftp_login — Comienza la sesion en una conexión FTP
ftp_mdtm — Devuelve la fecha de última modificación del fichero especificado.
ftp_mkdir — Crea un directorio
ftp_nlist — Devuelve una lista de ficheros del directorio dado.
ftp_pasv — Activa o desactiva el modo pasivo.
ftp_put — Sube un fichero al servidor FTP.
ftp_pwd — Devuelve el nombre del directorio actual
ftp_quit — Cierra una conexión FTP
ftp_rawlist — Devuelve una lista detallada de ficheros del directorio dado.
ftp_rename — Renombra un fichero del servidor FTP.
ftp_rmdir — Borra un directorio
ftp_size — Devuelve el tamaño del fichero especificado.
ftp_systype — Devuelve el identificador de tipo de sistema del servidor FTP remoto.

Anterior | Inicio | Siguiente
fribidi_log2vis | Subir | ftp_cdup


ftp_connect

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_connect -- Establece una conexión FTP

Descripción

int ftp_connect ( string host [, int port])

Si tiene éxito, devuelve un flujo FTP. En caso de error, devuelve FALSE.

ftp_connect() establece una conexión FTP al host especificado. El parámetro port especifica un puerto alternativo al que conectar. Si se omite o es cero, se usa el puerto FTP por defecto, 21.

Anterior | Inicio | Siguiente
ftp_chdir | Subir | ftp_delete


ftp_login

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_login -- Comienza la sesion en una conexión FTP

Descripción

int ftp_login ( int ftp_stream, string username, string password)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

Inicia una sesion (envía identificador de usuario y contraseña) en el flujo FTP especificado.

Anterior | Inicio | Siguiente
ftp_get | Subir | ftp_mdtm


ftp_pwd

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_pwd -- Devuelve el nombre del directorio actual

Descripción

int ftp_pwd ( int ftp_stream)

Devuelve el directorio actual, o FALSE en caso de error.

Anterior | Inicio | Siguiente
ftp_put | Subir | ftp_quit


ftp_cdup

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_cdup -- Cambia al directorio padre

Descripción

int ftp_cdup ( int ftp_stream)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

Cambia al directorio padre.

Anterior | Inicio | Siguiente
Funciones FTP | Subir | ftp_chdir


ftp_chdir

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_chdir -- Cambia de directorio en un servidor FTP

Descripción

int ftp_chdir ( int ftp_stream, string directory)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

Cambia al directorio especificado por el parámetro directory.

Anterior | Inicio | Siguiente
ftp_cdup | Subir | ftp_connect


ftp_mkdir

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_mkdir -- Crea un directorio

Descripción

string ftp_mkdir ( int ftp_stream, string directory)

Si tiene éxito, devuelve el nombre del directorio recién creado. En caso de error, devuelve FALSE.

Crea el directorio especificado por el parámetro directory.

Anterior | Inicio | Siguiente
ftp_mdtm | Subir | ftp_nlist


ftp_rmdir

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_rmdir -- Borra un directorio

Descripción

int ftp_rmdir ( int ftp_stream, string directory)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

Borra el directorio especificado por el parámetro directory.

Anterior | Inicio | Siguiente
ftp_rename | Subir | ftp_size


ftp_nlist

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_nlist -- Devuelve una lista de ficheros del directorio dado.

Descripción

int ftp_nlist ( int ftp_stream, string directory)

Si tiene éxito, devuelve un array de nombres de fichero. En caso de error, devuelve FALSE.

Anterior | Inicio | Siguiente
ftp_mkdir | Subir | ftp_pasv


ftp_rawlist

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_rawlist -- Devuelve una lista detallada de ficheros del directorio dado.

Descripción

int ftp_rawlist ( int ftp_stream, string directory)

ftp_rawlist() ejecuta el comando FTP LIST, y devuelve el resultado como un array. Cada elemento del array corresponde a una línea de texto. La salida no se procesa de ninguna forma. Se puede utilizar el identificador de tipo de sistema devuelto por ftp_systype() para determinar cómo se deben interpretar los resultados.

Anterior | Inicio | Siguiente
ftp_quit | Subir | ftp_rename


ftp_systype

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_systype -- Devuelve el identificador de tipo de sistema del servidor FTP remoto.

Descripción

int ftp_systype ( int ftp_stream)

Devuelve el tipo de sistema remoto, o FALSE en caso de error.

Anterior | Inicio | Siguiente
ftp_size | Subir | Function Handling functions


ftp_pasv

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_pasv -- Activa o desactiva el modo pasivo.

Descripción

int ftp_pasv ( int ftp_stream, int pasv)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

ftp_pasv() activa el modo pasivo si el parámetro pasv es TRUE (desactiva el modo pasivo si pasv es FALSE.) En modo pasivo, las conexiones de datos son iniciadas por el cliente, en lugar de ser iniciadas por el servidor.

Anterior | Inicio | Siguiente
ftp_nlist | Subir | ftp_put


ftp_get

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_get -- Descarga un fichero del servidor FTP.

Descripción

int ftp_get ( int ftp_stream, string local_file, string remote_file, int mode)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

ftp_get() baja el fichero remote_file del servidor FTP, y lo guarda localmente como local_file. El modo de transferencia especificado por el parámetro mode debe ser FTP_ASCII o bien FTP_BINARY.

Anterior | Inicio | Siguiente
ftp_fput | Subir | ftp_login


ftp_fget

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_fget -- Descarga un fichero del servidor FTP y lo guarda en un fichero abierto.

Descripción

int ftp_fget ( int ftp_stream, int fp, string remote_file, int mode)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

ftp_fget() baja el fichero remote_file del servidor FTP, y lo escribe en el puntero a fichero fp. El modo de transferencia especificado por el parámetro mode debe ser FTP_ASCII o bien FTP_BINARY.

Anterior | Inicio | Siguiente
ftp_delete | Subir | ftp_fput


ftp_put

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_put -- Sube un fichero al servidor FTP.

Descripción

int ftp_put ( int ftp_stream, string remote_file, string local_file, int mode)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

ftp_put() sube el fichero local local_file al servidor FTP y lo guarda como remote_file. El modo de transferencia especificado por el parámetro mode debe ser FTP_ASCII o bien FTP_BINARY.

Anterior | Inicio | Siguiente
ftp_pasv | Subir | ftp_pwd


ftp_fput

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_fput -- Sube un fichero abierto al servidor FTP.

Descripción

int ftp_fput ( int ftp_stream, string remote_file, int fp, int mode)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE

ftp_fput() sube los datos apuntados por el puntero a fichero fp hasta alcanzar el final del fichero. Los resultados se guardan en el fichero remote_file del FTP remoto. El modo de transferencia especificado por el parámetro mode debe ser FTP_ASCII o bien FTP_BINARY.

Anterior | Inicio | Siguiente
ftp_fget | Subir | ftp_get


ftp_size

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_size -- Devuelve el tamaño del fichero especificado.

Descripción

int ftp_size ( int ftp_stream, string remote_file)

Si tiene éxito devuelve el tamaño del fichero, o -1 en caso de error.

ftp_size() devuelve el tamaño de un fichero. Si ocurre algún error, o si el fichero no existe, devuelve -1. No todos los servidores soportan esta característica.

Anterior | Inicio | Siguiente
ftp_rmdir | Subir | ftp_systype


ftp_mdtm

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_mdtm -- Devuelve la fecha de última modificación del fichero especificado.

Descripción

int ftp_mdtm ( int ftp_stream, string remote_file)

Si tiene éxito, devuelve una marca de tiempo UNIX (UNIX timestamp). En caso de error, devuelve -1.

ftp_mdtm() comprueba la fecha de última modificación de un fichero, y la devuelve como una marca de tiempo UNIX. Si se produce algún error, o el fichero no existe, devuelve -1. Tenga en cuenta que no todos los servidores soportan esta característica.

Anterior | Inicio | Siguiente
ftp_login | Subir | ftp_mkdir


ftp_rename

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_rename -- Renombra un fichero del servidor FTP.

Descripción

int ftp_rename ( int ftp_stream, string from, string to)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

ftp_rename() renombra el fichero especificado por el parámetro from con el nuevo nombre to

Anterior | Inicio | Siguiente
ftp_rawlist | Subir | ftp_rmdir


ftp_delete

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_delete -- Borra un fichero del servidor FTP.

Descripción

int ftp_delete ( int ftp_stream, string path)

Si tiene éxito, devuelve TRUE. En caso de error, devuelve FALSE.

ftp_delete() borra el fichero especificado por el parámetro path del servidor FTP.

Anterior | Inicio | Siguiente
ftp_connect | Subir | ftp_fget


ftp_quit

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ftp_quit -- Cierra una conexión FTP

Descripción

int ftp_quit ( int ftp_stream)

ftp_connect() cierra el flujo FTP ftp_stream.

Anterior | Inicio | Siguiente
ftp_pwd | Subir | ftp_rawlist


Function Handling functions

Manual de PHP
Anterior Siguiente

XXXIV. Function Handling functions

These functions all handle various operations involved in working with functions.

Tabla de contenidos
call_user_func — Call a user function given by the first parameter
create_function — Create an anonymous (lambda-style) function
func_get_arg — Devuelve un elemento de la lista de argumentos.
func_get_args — Devuelve un array que contiene la lista de argumentos de una función.
func_num_args — Devuelve el número de argumentos pasados a la función.
function_exists — Devuelve TRUE si la función dada ha sido definida
register_shutdown_function — Registra una función para su ejecución en el cierre.

Anterior | Inicio | Siguiente
ftp_systype | Subir | call_user_func


call_user_func

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

call_user_func -- Call a user function given by the first parameter

Description

mixed call_user_func ( string function_name [, mixed parameter [, mixed ...]])

Call a user defined function given by the function_name parameter. Take the following:

function barber ($type) {
    print "You wanted a $type haircut, no problem";
}
call_user_func ('barber', "mushroom");
call_user_func ('barber', "shave");

Anterior | Inicio | Siguiente
Function Handling functions | Subir | create_function


create_function

(PHP 4 )

create_function -- Create an anonymous (lambda-style) function

Description

string create_function ( string args, string code)

Creates an anonymous function from the parameters passed, and returns a unique name for it. Usually the args will be passed as a single quote delimited string, and this is also recommended for the code. The reason for using single quoted strings, is to protect the variable names from parsing, otherwise, if you use double quotes there will be a need to escape the variable names, e.g. \$avar.

You can use this function, to (for example) create a function from information gathered at run time:

Ejemplo 1. Creating an anonymous function with create_function()

$newfunc = create_function('$a,$b','return "ln($a) + ln($b) = ".log($a * $b);');
echo "New anonymous function: $newfunc\n";
echo $newfunc(2,M_E)."\n";
// outputs
// New anonymous function: lambda_1
// ln(2) + ln(2.718281828459) = 1.6931471805599
Or, perhaps to have general handler function that can apply a set of operations to a list of parameters:

Ejemplo 2. Making a general processing function with create_function()

function process($var1, $var2, $farr) {
    for ($f=0; $f < count($farr); $f++)
    echo $farr[$f]($var1,$var2)."\n";
}

// create a bunch of math functions
$f1 = 'if ($a >=0) {return "b*a^2 = ".$b*sqrt($a);} else {return false;}';
$f2 = "return \"min(b^2+a, a^2,b) = \".min(\$a*\$a+\$b,\$b*\$b+\$a);";
$f3 = 'if ($a > 0 && $b != 0) {return "ln(a)/b = ".log($a)/$b;} else {return false;}';
$farr = array(
    create_function('$x,$y', 'return "some trig: ".(sin($x) + $x*cos($y));'),
    create_function('$x,$y', 'return "a hypotenuse: ".sqrt($x*$x + $y*$y);'),
    create_function('$a,$b', $f1),
    create_function('$a,$b', $f2),
    create_function('$a,$b', $f3)
    );

echo "\nUsing the first array of anonymous functions\n";
echo "parameters: 2.3445, M_PI\n";
process(2.3445, M_PI, $farr);

// now make a bunch of string processing functions
$garr = array(
    create_function('$b,$a','if (strncmp($a,$b,3) == 0) return "** \"$a\" '.
    'and \"$b\"\n** Look the same to me! (looking at the first 3 chars)";'),
    create_function('$a,$b','; return "CRCs: ".crc32($a)." , ".crc32(b);'),
    create_function('$a,$b','; return "similar(a,b) = ".similar_text($a,$b,&$p)."($p%)";')
    );
echo "\nUsing the second array of anonymous functions\n";
process("Twas brilling and the slithy toves", "Twas the night", $garr);
and when you run the code above, the output will be:

Using the first array of anonymous functions
parameters: 2.3445, M_PI
some trig: -1.6291725057799
a hypotenuse: 3.9199852871011
b*a^2 = 4.8103313314525
min(b^2+a, a^2,b) = 8.6382729035898
ln(a/b) = 0.27122299212594

Using the second array of anonymous functions
** "Twas the night" and "Twas brilling and the slithy toves"
** Look the same to me! (looking at the first 3 chars)
CRCs: -725381282 , 1908338681
similar(a,b) = 11(45.833333333333%)

But perhaps the most common use for of lambda-style (anonymous) functions is to create callback functions, for example when using array_walk() or usort()

Ejemplo 3. Using anonymous functions as callback functions

$av = array("the ","a ","that ","this ");
array_walk($av, create_function('&$v,$k','$v = $v."mango";'));
print_r($av);  // for PHP3 use var_dump()
// outputs:
// Array
// (
//   [0] => the mango
//   [1] => a mango
//   [2] => that mango
//   [3] => this mango
// )

// an array of strings ordered from shorter to longer
$sv = array("small","larger","a big string","it is a string thing");
print_r($sv);
// outputs:
// Array
// (
//   [0] => small
//   [1] => larger
//   [2] => a big string
//   [3] => it is a string thing
// )

// sort it from longer to shorter
usort($sv, create_function('$a,$b','return strlen($b) - strlen($a);'));
print_r($sv);
// outputs:
// Array
// (
//   [0] => it is a string thing
//   [1] => a big string
//   [2] => larger
//   [3] => small
// )

Anterior | Inicio | Siguiente
call_user_func | Subir | func_get_arg


func_get_arg

(PHP 4 >= 4.0.0)

func_get_arg -- Devuelve un elemento de la lista de argumentos.

Descripción

int func_get_arg ( int arg_num)

Devuelve el argumento que está en la posición arg_num en la lista de argumentos de una función definida por el usuario. Los argumentos de la función se cuentan comenzando por la posición cero. func_get_arg() generará un aviso si se llama desde fuera de la definición de la función.

Si arg_num es mayor que el número de argumentos pasados realmente, se generará un aviso y func_get_arg() devolverá FALSE.

<?php
function foo() {
   $numargs = func_num_args();
   echo "Number of arguments: $numargs<br>\n";
   if ( $numargs >= 2 ) {
      echo "Second argument is: " . func_get_arg( 1 ) . "<br>\n";
   }
}

foo( 1, 2, 3 );
?>

func_get_arg() puede utilizarse conjuntamente
       con func_num_args() y
func_get_args() para permitir a las funciones
       definidas por el usuario que acepten listas de argumentos de
       longitud variable.

Nota: Esta función fue añadida en PHP 4.

Anterior | Inicio | Siguiente
create_function | Subir | func_get_args


func_get_args

(PHP 4 >= 4.0.0)

func_get_args -- Devuelve un array que contiene la lista de argumentos de una función.

Descripción

int func_get_args ( void )

Devuelve un array en el que cada elemento es el miembro correspondiente de la lista de argumentos de la función definida por el usuario actual. func_get_args() generará un aviso si es llamada desde fuera de la definición de la función.

<?php
function foo() {
   $numargs = func_num_args();
   echo "Number of arguments: $numargs<br>\n";
   if ( $numargs >= 2 ) {
      echo "Second argument is: " . func_get_arg( 1 ) . "<br>\n";
   }
   $arg_list = func_get_args();
   for ( $i = 0; $i < $numargs; $i++ ) {
      echo "Argument $i is: " . $arg_list[$i] . "<br>\n";
   }
}

foo( 1, 2, 3 );
?>

func_get_args() puede utilizarse conjuntamente con func_num_args() y func_get_arg() para permitir a las funciones definidas por el usuario que acepten listas de argumentos de longitud variable.

Nota: Esta función fue añadida en PHP 4.

Anterior | Inicio | Siguiente
func_get_arg | Subir | func_num_args


func_num_args

(PHP 4 >= 4.0.0)

func_num_args -- Devuelve el número de argumentos pasados a la función.

Descripción

int func_num_args ( void )

Devuelve el número de argumentos pasados a la función actual definida por el usuario. func_num_args() generará un aviso si es llamada desde fuera de la definición de la función.

<?php
function foo() {
   $numargs = func_num_args();
   echo "Number of arguments: $numargs\n";
}

foo( 1, 2, 3 );  // Prints 'Number of arguments: 3'
?>

func_num_args() puede utilizarse conjuntamente con func_get_arg() y func_get_args() para permitir a las funciones definidas por el usuario que acepten listas de argumentos de longitud variable.

Nota: Esta función fue añadida en PHP 4.

Anterior | Inicio | Siguiente
func_get_args | Subir | function_exists


function_exists

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

function_exists -- Devuelve TRUE si la función dada ha sido definida

Descripción

int function_exists ( string function_name)

Consulta la lista de funciones definidas buscando function_name (nombre de función). Devuelve TRUE si encuentra el nombre de función dado, FALSE en otro caso.

Anterior | Inicio | Siguiente
func_num_args | Subir | register_shutdown_function


register_shutdown_function

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

register_shutdown_function -- Registra una función para su ejecución en el cierre.

Descripción

int register_shutdown_function ( string func)

Registra la función nombrada en func para que se ejecute cuando el script procese su finalización.

Aviso:

Debido a que no se permite ningún tipo de salida en el navegador en esta función, no será capaz de depurarla utilizando sentencias como print o echo.

Anterior | Inicio | Siguiente
function_exists | Subir | GNU Gettext


GNU Gettext

Manual de PHP
Anterior Siguiente

XXXV. GNU Gettext

Tabla de contenidos
bindtextdomain — Establece la ruta para un dominio
dcgettext — Omite el dominio para una única busqueda
dgettext — Omite el dominio actual
gettext — Realiza una busqueda del mensaje en el dominio actual
textdomain — Establece el dominio actual

Anterior | Inicio | Siguiente
register_shutdown_function | Subir | bindtextdomain


bindtextdomain

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

bindtextdomain -- Establece la ruta para un dominio

Descripción

string bindtextdomain ( string domain, string directory)

La función bindtextdomain() establece la ruta para el dominio.

Anterior | Inicio | Siguiente
GNU Gettext | Subir | dcgettext


dcgettext

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

dcgettext -- Omite el dominio para una única busqueda

Description

string dcgettext ( string domain, string message, int category)

Esta función permite omitir el dominio actual para una busqueda de un mensaje. Además permite especificar una categoría.

Anterior | Inicio | Siguiente
bindtextdomain | Subir | dgettext


dgettext

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

dgettext -- Omite el dominio actual

Descripción

string dgettext ( string domain, string message)

La función dgettext() permite omitir el dominio actual para una única busqueda.

Anterior | Inicio | Siguiente
dcgettext | Subir | gettext


gettext

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

gettext -- Realiza una busqueda del mensaje en el dominio actual

Descripción

string gettext ( string message)

Esta función devuelve la traducción de la cadena si encuentra una en la tabla de traducciones, o el mensaje enviado si no se encuentra ninguna. Puede usar un carácter de subrayado como un alias para esta función.

Ejemplo 1. gettext()-check

<?php
// Establece el idioma en alemán
putenv ("LANG=de");

// Especifica la localización de las tablas de traducción
bindtextdomain ("myPHPApp", "./locale");

// Elige un dominio
textdomain ("myPHPApp");

// Imprime un mensaje de prueba
print (gettext ("Welcome to My PHP Application"));
?>

Anterior | Inicio | Siguiente
dgettext | Subir | textdomain


textdomain

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

textdomain -- Establece el dominio actual

Descripción

int textdomain ( [string library])

Esta función establece el dominio en el que se realizarán las busquedas provocadas por las llamadas a gettext(), normalmente el nombre dado a la aplicación. Se devuelve el dominio anterior. Puede llamar a la función sin parámetros para obtener el dominio actual sin necesidad de cambiarlo.

Anterior | Inicio | Siguiente
gettext | Subir | GMP functions


GMP functions

Manual de PHP
Anterior Siguiente

XXXVI. GMP functions

These functions allow you to work with arbitrary-length integers using GNU MP library. In order to have these functions available, you must compile PHP with GMP support by using the --with-gmp option.

You can download the GMP library from http://www.swox.com/gmp/. This site also has the GMP manual available.

You will need GMP version 2 or better to use these functions. Some functions may require more recent version of the GMP library.

These functions have been added in PHP 4.0.4.

Nota: Most GMP functions accept GMP number arguments, defined as resource below. However, most of these functions will accept also numeric and string arguments, given it's possible to convert the latter to number. Also, if there's faster function that can operate on integer arguments, it would be used instead of slower function when supplied arguments are integers. This is done transparently, so the bootom line is that you can use integers in every function that expects GMP number. See also gmp_init() function.

Ejemplo 1. Factorial function using GMP

<?php
function fact ($x) {
    if ($x <= 1)
        return 1;
    else
        return gmp_mul ($x, fact ($x-1));
}

print gmp_strval (fact (1000)) . "\n";
?>

This will calculate factiorial of 1000 (pretty big number) very fast.

Tabla de contenidos
gmp_abs — Absolute value
gmp_add — Add numbers
gmp_and — Logical AND
gmp_clrbit — Clear bit
gmp_cmp — Compare numbers
gmp_div — Divide numbers
gmp_div_q — Divide numbers
gmp_div_qr — Divide numbers and get quotient and remainder
gmp_div_r — Remainder of the division of numbers
gmp_divexact — Exact division of numbers
gmp_fact — Factorial
gmp_gcd — Calculate GCD
gmp_gcdext — Calculate GCD and multipliers
gmp_hamdist — Hamming distance
gmp_init — Create GMP number
gmp_intval — Convert GMP number to integer
gmp_invert — Inverse by modulo
gmp_jacobi — Jacobi symbol
gmp_legendre — Legendre symbol
gmp_mod — Modulo operation
gmp_mul — Multiply numbers
gmp_neg — Negate number
gmp_or — Logical OR
gmp_perfect_square — Perfect square check
gmp_popcount — Population count
gmp_pow — Raise number into power
gmp_powm — Raise number into power with modulo
gmp_prob_prime — Check if number is "probably prime"
gmp_random — Random number
gmp_scan0 — Scan for 0
gmp_scan1 — Scan for 1
gmp_setbit — Set bit
gmp_sign — Sign of number
gmp_sqrt — Square root
gmp_sqrtrm — Square root with remainder
gmp_strval — Convert GMP number to string
gmp_sub — Subtract numbers
gmp_xor — Logical XOR

Anterior | Inicio | Siguiente
textdomain | Subir | gmp_abs


gmp_init

(PHP 4 >= 4.0.4)

gmp_init -- Create GMP number

Description

resource gmp_init ( mixed number)

Creates a GMP number from integer or string. String representation can be decimal or hexadecimal. In the latter case, the string should start with 0x.

Ejemplo 1. Creating GMP number

<?php
    $a = gmp_init (123456);
    $b = gmp_init ("0xFFFFDEBACDFEDF7200");
?>

Nota: It is not necessary to call this function if you want to use integer or string in place of GMP number in GMP functions, like gmp_add(). Function arguments are automatically converted to GMP numbers, if such conversion is possible and needed, using the same rules as gmp_init().

Anterior | Inicio | Siguiente
gmp_hamdist | Subir | gmp_intval


gmp_intval

(PHP 4 >= 4.0.4)

gmp_intval -- Convert GMP number to integer

Description

int gmp_intval ( resource gmpnumber)

This function allows to convert GMP number to integer.

Aviso

This function returns useful result only if the number actually fits the PHP integer (i.e., signed long type). If you want just to print the GMP number, use gmp_strval().

Anterior | Inicio | Siguiente
gmp_init | Subir | gmp_invert


gmp_strval

(PHP 4 >= 4.0.4)

gmp_strval -- Convert GMP number to string

Description

string gmp_strval ( resource gmpnumber [, int base])

Convert GMP number to string representation in base base. The default base is 10. Allowed values for the base are from 2 to 36.

Ejemplo 1. Converting GMP number to string

<?php
    $a = gmp_init("0x41682179fbf5");
    printf ("Decimal: %s, 36-based: %s", gmp_strval($a), gmp_strval($a,36));
?>

Anterior | Inicio | Siguiente
gmp_sqrtrm | Subir | gmp_sub


gmp_add

(PHP 4 >= 4.0.4)

gmp_add -- Add numbers

Description

resource gmp_add ( resource a, resource b)

Add two GMP numbers. The result will be GMP number representing the sum of the arguments.

Anterior | Inicio | Siguiente
gmp_abs | Subir | gmp_and


gmp_sub

(PHP 4 >= 4.0.4)

gmp_sub -- Subtract numbers

Description

resource gmp_sub ( resource a, resource b)

Subtract b from a and returns the result.

Anterior | Inicio | Siguiente
gmp_strval | Subir | gmp_xor


gmp_mul

(PHP 4 >= 4.0.4)

gmp_mul -- Multiply numbers

Description

resource gmp_mul ( resource a, resource b)

Multiplies a by b and returns the result.

Anterior | Inicio | Siguiente
gmp_mod | Subir | gmp_neg


gmp_div_q

(PHP 4 >= 4.0.4)

gmp_div_q -- Divide numbers

Description

resource gmp_div_q ( resource a, resource b [, int round])

Divides a by b and returns the integer result. The result rounding is defined by the round, which can have the following values:

  • GMP_ROUND_ZERO: The result is truncated towards 0.

  • GMP_ROUND_PLUSINF: The result is rounded towards +infinity.

  • GMP_ROUND_MINUSINF: The result is rounded towards -infinity.

This function can also be called as gmp_div().

See also gmp_div_r(), gmp_div_qr()

Anterior | Inicio | Siguiente
gmp_div | Subir | gmp_div_qr


gmp_div_r

(PHP 4 >= 4.0.4)

gmp_div_r -- Remainder of the division of numbers

Description

resource gmp_div_r ( resource n, resource d [, int round])

Calculates remainder of the integer division of n by d. The remainder has the sign of the n argument, if not zero.

See the gmp_div_q() function for description of the round argument.

See also gmp_div_q(), gmp_div_qr()

Anterior | Inicio | Siguiente
gmp_div_qr | Subir | gmp_divexact


gmp_div_qr

(PHP 4 >= 4.0.4)

gmp_div_qr -- Divide numbers and get quotient and remainder

Description

array gmp_div_qr ( resource n, resource d [, int round])

The function divides n by d and returns array, with the first element being [n/d] (the integer result of the division) and the second being (n - [n/d] * d) (the remainder of the division).

See the gmp_div_q() function for description of the round argument.

Ejemplo 1. Division of GMP numbers

<?php
    $a = gmp_init ("0x41682179fbf5");
    $res = gmp_div_qr ($a, "0xDEFE75");
    printf("Result is: q - %s, r - %s",
            gmp_strval ($res[0]), gmp_strval ($res[1]));
?>

See also gmp_div_q(), gmp_div_r().

Anterior | Inicio | Siguiente
gmp_div_q | Subir | gmp_div_r


gmp_div

(PHP 4 >= 4.0.4)

gmp_div -- Divide numbers

Description

resource gmp_divexact ( resource a, resource b)

This function is an alias to gmp_div_q().

Anterior | Inicio | Siguiente
gmp_cmp | Subir | gmp_div_q


gmp_mod

(PHP 4 >= 4.0.4)

gmp_mod -- Modulo operation

Description

resource gmp_mod ( resource n, resource d)

Calculates n modulo d. The result is always non-negative, the sign of d is ignored.

Anterior | Inicio | Siguiente
gmp_legendre | Subir | gmp_mul


gmp_divexact

(PHP 4 >= 4.0.4)

gmp_divexact -- Exact division of numbers

Description

resource gmp_divexact ( resource n, resource d)

Divides n by d, using fast "exact division" algorithm. This function produces correct results only when it is known in advance that d divides n.

Anterior | Inicio | Siguiente
gmp_div_r | Subir | gmp_fact


gmp_cmp

(PHP 4 >= 4.0.4)

gmp_cmp -- Compare numbers

Description

int gmp_cmp ( resource a, resource b)

Returns positive value if a > b, zero if a = b and negative value if a < b.

Anterior | Inicio | Siguiente
gmp_clrbit | Subir | gmp_div


gmp_neg

(PHP 4 >= 4.0.4)

gmp_neg -- Negate number

Description

resource gmp_neg ( resource a)

Returns -a.

Anterior | Inicio | Siguiente
gmp_mul | Subir | gmp_or


gmp_abs

(PHP 4 >= 4.0.4)

gmp_abs -- Absolute value

Description

resource gmp_abs ( resource a)

Returns absolute value of a.

Anterior | Inicio | Siguiente
GMP functions | Subir | gmp_add


gmp_sign

(PHP 4 >= 4.0.4)

gmp_sign -- Sign of number

Description

int gmp_sign ( resource a)

Return sign of a - 1 if a is positive and -1 if it's negative.

Anterior | Inicio | Siguiente
gmp_setbit | Subir | gmp_sqrt


gmp_fact

(PHP 4 >= 4.0.4)

gmp_fact -- Factorial

Description

resource gmp_fact ( int a)

Calculates factorial (a!) of a.

Anterior | Inicio | Siguiente
gmp_divexact | Subir | gmp_gcd


gmp_sqrt

(PHP 4 >= 4.0.4)

gmp_sqrt -- Square root

Description

resource gmp_sqrt ( resource a)

Calculates square root of a.

Anterior | Inicio | Siguiente
gmp_sign | Subir | gmp_sqrtrm


gmp_sqrtrm

(unknown)

gmp_sqrtrm -- Square root with remainder

Description

array gmp_sqrtrm ( resource a)

Returns array where first element is the integer square root of a (see also gmp_sqrt()), and the second is the remainder (i.e., the difference between a and the first element squared).

Anterior | Inicio | Siguiente
gmp_sqrt | Subir | gmp_strval


gmp_perfect_square

(PHP 4 >= 4.0.4)

gmp_perfect_square -- Perfect square check

Description

bool gmp_perfect_square ( resource a)

Returns TRUE if a is a prefect square, FALSE otherwise.

See also: gmp_sqrt(), gmp_sqrtrm().

Anterior | Inicio | Siguiente
gmp_or | Subir | gmp_popcount


gmp_pow

(PHP 4 >= 4.0.4)

gmp_pow -- Raise number into power

Description

resource gmp_pow ( resource base, int exp)

Raise base into power exp. The case of 0^0 yields 1. exp cannot be negative.

Anterior | Inicio | Siguiente
gmp_popcount | Subir | gmp_powm


gmp_powm

(PHP 4 >= 4.0.4)

gmp_powm -- Raise number into power with modulo

Description

resource gmp_powm ( resource base, resource exp, resource mod)

Calculate (base raised into power exp) modulo mod. If exp is negative, result is undefined.

Anterior | Inicio | Siguiente
gmp_pow | Subir | gmp_prob_prime


gmp_prob_prime

(PHP 4 >= 4.0.4)

gmp_prob_prime -- Check if number is "probably prime"

Description

int gmp_prob_prime ( resource a [, int reps])

If this function returns 0, a is definitely not prime. If it returns 1, then a is "probably" prime. If it returns 2, then a is surely prime. Reasonable values of reps vary from 5 to 10 (default being 10); a higher value lowers the probability for a non-prime to pass as a "probable" prime.

The function uses Miller-Rabin's probabilistic test.

Anterior | Inicio | Siguiente
gmp_powm | Subir | gmp_random


gmp_gcd

(PHP 4 >= 4.0.4)

gmp_gcd -- Calculate GCD

Description

resource gmp_gcd ( resource a, resource b)

Calculate greatest common divisor of a and b. The result is always positive even if either of or both input operands are negative.

Anterior | Inicio | Siguiente
gmp_fact | Subir | gmp_gcdext


gmp_gcdext

(PHP 4 >= 4.0.4)

gmp_gcdext -- Calculate GCD and multipliers

Description

array gmp_gcdext ( resource a, resource b)

Calculates g, s, and t, such that a*s + b*t = g = gcd(a,b), where gcd is gretest common divisor. Returns array with respective elements g, s and t.

Anterior | Inicio | Siguiente
gmp_gcd | Subir | gmp_hamdist


gmp_invert

(PHP 4 >= 4.0.4)

gmp_invert -- Inverse by modulo

Description

resource gmp_invert ( resource a, resource b)

Computes the inverse of a modulo b. Returns FALSE if an inverse does not exist.

Anterior | Inicio | Siguiente
gmp_intval | Subir | gmp_jacobi


gmp_legendre

(PHP 4 >= 4.0.4)

gmp_legendre -- Legendre symbol

Description

int gmp_legendre ( resource a, resource p)

Compute the Legendre symbol of a and p. p should be odd and must be positive.

Anterior | Inicio | Siguiente
gmp_jacobi | Subir | gmp_mod


gmp_jacobi

(PHP 4 >= 4.0.4)

gmp_jacobi -- Jacobi symbol

Description

int gmp_jacobi ( resource a, resource p)

Computes Jacobi symbol of a and p. p should be odd and must be positive.

Anterior | Inicio | Siguiente
gmp_invert | Subir | gmp_legendre


gmp_random

(PHP 4 >= 4.0.4)

gmp_random -- Random number

Description

resource gmp_random ( int limiter)

Generate a random number. The number will be up to limiter words long. If limiter is negative, negative numbers are generated.

Anterior | Inicio | Siguiente
gmp_prob_prime | Subir | gmp_scan0


gmp_and

(PHP 4 >= 4.0.4)

gmp_and -- Logical AND

Description

resource gmp_and ( resource a, resource b)

Calculates logical AND of two GMP numbers.

Anterior | Inicio | Siguiente
gmp_add | Subir | gmp_clrbit


gmp_or

(PHP 4 >= 4.0.4)

gmp_or -- Logical OR

Description

resource gmp_or ( resource a, resource b)

Calculates logical inclusive OR of two GMP numbers.

Anterior | Inicio | Siguiente
gmp_neg | Subir | gmp_perfect_square


gmp_xor

(PHP 4 >= 4.0.4)

gmp_xor -- Logical XOR

Description

resource gmp_xor ( resource a, resource b)

Calculates logical exclusive OR (XOR) of two GMP numbers.

Anterior | Inicio | Siguiente
gmp_sub | Subir | Funciones HTTP


gmp_setbit

(PHP 4 >= 4.0.4)

gmp_setbit -- Set bit

Description

resource gmp_setbit ( resource &a, int index [, bool set_clear])

Sets bit index in a. set_clear defines if the bit is set to 0 or 1. By default the bit is set to 1.

Anterior | Inicio | Siguiente
gmp_scan1 | Subir | gmp_sign


gmp_clrbit

(PHP 4 >= 4.0.4)

gmp_clrbit -- Clear bit

Description

resource gmp_clrbit ( resource &a, int index)

Clears (sets to 0) bit index in a.

Anterior | Inicio | Siguiente
gmp_and | Subir | gmp_cmp


gmp_scan0

(PHP 4 >= 4.0.4)

gmp_scan0 -- Scan for 0

Description

int gmp_scan0 ( resource a, int start)

Scans a, starting with bit start, towards more significant bits, until the first clear bit is found. Returns the index of the found bit.

Anterior | Inicio | Siguiente
gmp_random | Subir | gmp_scan1


gmp_scan1

(PHP 4 >= 4.0.4)

gmp_scan1 -- Scan for 1

Description

int gmp_scan1 ( resource a, int start)

Scans a, starting with bit start, towards more significant bits, until the first set bit is found. Returns the index of the found bit.

Anterior | Inicio | Siguiente
gmp_scan0 | Subir | gmp_setbit


gmp_popcount

(PHP 4 >= 4.0.4)

gmp_popcount -- Population count

Description

int gmp_popcount ( resource a)

Return the population count of a.

Anterior | Inicio | Siguiente
gmp_perfect_square | Subir | gmp_pow


gmp_hamdist

(PHP 4 >= 4.0.4)

gmp_hamdist -- Hamming distance

Description

int gmp_hamdist ( resource a, resource b)

Returns the hamming distance between a and a. Both operands should be non-negative.

Anterior | Inicio | Siguiente
gmp_gcdext | Subir | gmp_init


Funciones HTTP

Manual de PHP
Anterior Siguiente

XXXVII. Funciones HTTP

Estas funciones permiten manipular la salida que se envía al navegador remoto a nivel de protocolo HTTP.

Tabla de contenidos
header — Manda una cabecera HTTP
setcookie — Envía una cookie

Anterior | Inicio | Siguiente
gmp_xor | Subir | header


header

(PHP 3, PHP 4 >= 4.0.0)

header -- Manda una cabecera HTTP

Descripción

int header ( string string)

La función header() se utiliza al comienzo de un fichero HTML para enviar las cadenas de texto de la cabecera HTTP. Consulte la Especificación HTTP 1.1 para obtener más información sobre las cabeceras http. Nota: Recuerde que la función header() debe llamarse antes de que se genere salida alguna, bien con etiquetas HTML normales o con PHP. Un error muy frecuente consiste en leer código con include() o con auto_prepend, y que dicho código inserte espacios o líneas en blanco antes de llamar a header().

Hay dos casos especiales de llamadas a header. La primera es la cabecera "Location". No sólo envía esta cabecera al navegador, sino que también devuelve un código de estado REDIRECT a Apache. Desde el punto de vista del programador de scripts esto no debería ser importante, pero para la gente que comprende las interioridades de Apache sí puede serlo.

header("Location: http://www.php.net");  /* Redirect browser to PHP web site */
exit;  /* Make sure that code below does not get executed when we redirect. */

El segundo caso especial se produce con cualquier cabecera que comience con la cadena, "HTTP/" (las mayúsculas no son significativas). Por ejemplo, si tiene la directiva ErrorDocument 404 de Apache apuntando a un script PHP, es una buena idea asegurarse de que su script de PHP genera realmente un 404. La primera cosa que debe hacer en su script sería:

header("http/1.0 404 Not Found");

Los scripts de PHP a menudo generan HTML dinámico que no debe almacenarse en la caché del navegador cliente o en la caché de cualquier proxy situado entre el servidor y el navegador cliente. Se puede obligar a muchos proxies y clientes a que deshabiliten el almacenamiento en caché con

header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");             // Date in the past
  header("Last-Modified: " . gmdate("D, d M Y H:i:s") . " GMT"); // always modified
  header("Cache-Control: no-cache, must-revalidate");           // HTTP/1.1
  header("Pragma: no-cache");                                   // HTTP/1.0

Anterior | Inicio | Siguiente
Funciones HTTP | Subir | setcookie


setcookie

(PHP 3, PHP 4 >= 4.0.0)

setcookie -- Envía una cookie

Descripción

int setcookie ( string name, string value, int expire, string path, string domain, int secure)

setcookie() define una cookie para ser enviada con el resto de la información de la cabecera. Las cookies deben enviarse antes de mandar cualquier otra cabecera (esta es una restricción de las cookies, no de PHP). Esto requiere que sitúe las llamadas a esta función antes de cualquier etiqueta <html> o <head>.

Todos los parámetros excepto name son opcionales. Si sólo se especifica el parámetro name, la cookie con ese nombre se borrará del cliente remoto. También puede sustituir cualquier parámetro por una cadena de texto vacía ("") y saltar así ese parámetro. Los parámetros expire y secure son números enteros y no se pueden saltar con una cadena de texto vacía. En su lugar utilice un cero (0). El parámetro expire es un entero de tiempo típico de UNIX tal como lo devuelven las funciones time() o mktime(). El parámetro secure indica que la cookie se debe transmitir única y exclusivamente sobre una conexión segura HTTPS.

Fallos habituales:

Las cookies no se hacen visibles hasta la siguiente carga de una página para la que la cookie deba estar visible.

Las llamadas múltiples a setcookie() en el mismo script se ejecutarán en orden inverso. Si está intentando borrar una cookie antes de insertar otra, debe situar la llamada de inserción antes de la de borrado.

A continuación se muestran algunos ejemplos::

Ejemplo 1. setcookie(), ejemplos

setcookie("TestCookie","Test Value");
setcookie("TestCookie",$value,time()+3600);  /* expire in 1 hour */
setcookie("TestCookie",$value,time()+3600,"/~rasmus/",".utoronto.ca",1);

Tenga en cuenta que el campo value de la cookie se codifica como URL (urlencode) automáticamente cuando envía la cookie. Cuando ésta se recibe, se descodifica autómaticamente y se asigna a una variable con el mismo nombre que el nombre de la cookie. Para ver el contenido de nuestra cookie de prueba en un script, simplemente utilice uno de los siguientes ejemplos:

echo $TestCookie;
echo $HTTP_COOKIE_VARS["TestCookie"];

También puede utilizar arrays de cookies empleando la notación de array en el nombre de la cookie. Esto tiene como efecto establecer tantas cookies como elementos de array, pero cuando el script recibe la cookie, se guardan los valores en un array con el nombre de la cookie:

setcookie( "cookie[three]", "cookiethree" );
setcookie( "cookie[two]", "cookietwo" );
setcookie( "cookie[one]", "cookieone" );
if ( isset( $cookie ) ) {
   while( list( $name, $value ) = each( $cookie ) ) {
      echo "$name == $value<br>\n";
   }
}

Para obtener más información sobre las cookies, consulte la especificación de cookies de Netscape, que se encuentra en http://www.netscape.com/newsref/std/cookie_spec.html.

Microsoft Internet Explorer 4 con Service Pack 1 no funciona correctamente con las cookies que tienen asociado el parámetro path.

Netscape Communicator 4.05 y Microsoft Internet Explorer 3.x funcionan aparentemente de manera incorrecta cuando no se especifican los parámetros path y time.

Anterior | Inicio | Siguiente
header | Subir | Funciones para Hyperwave


Funciones para Hyperwave

Manual de PHP
Anterior Siguiente

XXXVIII. Funciones para Hyperwave

Introducción

Hyperwave ha sido desarrollado en el IICM en Graz. Comenzó con el nombre Hyper-G y cambió a Hyperwave cuando fue comercializado (Si lo recuerdo bien, fue en 1996).

Hyperwave no es software gratuiro. La versión actual, 4.1, está disponible en www.hyperwave.com. Se puede solicitar gratuitamente una versión limitada (30 días).

Hyperwave es un sistema de información similar a una base de datos (HIS, Hyperwave Information Server - Servidor Hyperwave de Información). Su objetivo es el almacenamiento y manipulación de documentos. Un documento puede ser cualquier bloque posible de datos que también puede ser almacenado en un archivo. Cada documento se acompaña por su registro de objeto. El registro de objeto contiene metadatos para el documento. Los metadatos son una lista de atributos que pueden ser extendidos por el usuario. Ciertos atributos siempre son fijados por el servidor Hyperwave, otros pueden ser modificados por el usuario. Un atributo es un par nombre/valor de la forma nombre=valor. El registro completo del objeto tiene tantos de estos pares como guste el usuario. El nombre de un atributo no tiene porqué ser único, p. ej. un título puede aparecer varias veces en el registro de un objeto. Esto tiene sentido si se desea especificar un título en diferentes idiomas. En dicho caso existe la convención de que cada valor de título esté precedido por la abreviatura de dos letras del idioma, seguida por dos puntos, como p. ej. 'en:Title in English' o 'es:Título en Español'. Otros atributos tales como descripciones o palabras clave son canditatos potenciales a esta diferenciación. También se pueden reemplazar las abreviaturas de idioma por cualquier otra cadena siempre y cuando estén separadas por los dos puntos del resto del valor del atributo.

Cada registro de objeto tiene una representación nativa como cadena con cada par nombre/valor separado por una línea nueva. La extensión Hyperwave también conoce una segunda representación que consiste en un array asociativo donde el nombre del atributo es la clave. Los valores de atributo multilingües en sí mismos forman otro array asociativo donde la clave es la abreviatura del idioma. Realmente cualquier atributo múltiple forma una tabla asociativa donde la cadena a la izquierda de los dos puntos en el valor de atributo es la clave. (Esto no se ha implementado por completo. Sólo los atributos Title, Description y Keyword son tratados adecuadamente.)

Aparte de los documentos, todos los hiper-enlaces contenidos en un documento son almacenados también como registros de objeto. Cuando el documento sea insertado en la base de datos, los hiper-enlaces que haya en un documento serán borrados del mismo y almacenados como objetos individuales. El registro de objeto del enlace contiene información acerca de dónde comienza y dónde termina. Para recuperar el documento original se deberá recuperar el documento sin los enlaces y la lista de los mismos para reinsertarla (Las funciones hw_pipedocument() y hw_gettext() hacen esto para usted). La ventaja de separar los enlaces del documento es obvia. Una vez un documento al que apunta un enlace cambia de nombre, el enlace puede modificarse fácilmente. El documento que contiene el enlace no se ve afectado. Incluso se puede añadir un enlace a un documento sin alterarlo.

Decir que hw_pipedocument() y hw_gettext() hacen automáticamente la inserción de enlaces no es tan simple como suena. Insertar los enlaces implica una cierta jerarquía en los documentos. En un servidor web esto viene dado por el sistema de archivos, pero el Hyperwave tiene su propia jerarquía y los nombres no representan la posición de un objeto en dicha jerarquía. Por tanto, la creación de los enlaces precisa primeramente de realizar un mapeado entre el espacio de nombres y la jerarquía del Hyperwave y el espacio de nombres respectivo de una jerarquía de web. La diferencia fundamental entre Hyperwave y la web es la distinción clara entre nombres y jerarquía que se da en el primero. El nombre no contiene ninguna información sobre la posición del objeto en la jerarquía. En la web, el nombre también contiene la información sobre la posición en la jerarquía del objeto. Esto nos lleva a dos posibles formas de mapeo. O bien se reflejan la jerarquía del Hyperwave y el nombre del objeto Hyperwave en el URL o sólo el nombre. Para facilitar las cosas, se utiliza el segundo método. El objeto Hyperwave de nombre 'mi_objeto' es mapeado a 'http://host/mi_objeto' sin importar dónde reside dentro de la jerarquía de Hyperwave. Un objeto con el nombre 'padre/mi_objeto' podría ser el hijo de 'mi_objeto' en la jerarquía Hyperwave, aunque en el espacio de nombres web aparezca justamente lo opuesto y el usuario pueda ser llevado a confusión. Esto sólo se puede evitar seleccionando nombres de objetos razonables.

Hecha esta decisión surge un segundo problema. ¿Cómo implicar al PHP? el URL http://host/mi_objeto no llamará a ningún script PHP a no ser que se le diga al servidor que lo transforme en p. ej. 'http://host/script_php3/mi_objeto' y que el 'script_php3' luego evalúe la variable $PATH_INFO y recupere el objeto con nombre 'mi_objeto' del servidor Hyperwave. Hay sólo un pequeño inconveniente que se puede resolver fácilmente. Cuando se reescribe cualquier URL no se permite el acceso a ningún otro documento en el servidor web. Un script de PHP para buscar en el servidor Hyperwave sería imposible. Por lo tanto se necesitará al menos una segunda regla de reescritura para que excluya ciertos URL, como los que empiecen p. ej. por http://host/Hyperwave. Básicamente esto sería compartir un espacio de nombres entre el servidor web y el servidor Hyperwave.

Los enlaces se insertan en los documentos basándose en el mecanismo citado más arriba.

Se vuelve más complicado si el PHP no se está ejecutando como módulo del servidor o como script CGI, sino que se ejecuta como aplicación, p. ej. para volcar el contenido del servidor de Hyperwave a un CD-ROM. En dicho caso tiene sentido mantener la jerarquía Hyperwave y mapearla en el sistema de archivos. Esto entra conflicto con los nombres de los objetos si estos reflejan su propia jerarquía (p. ej. eligiendo nombres que comienzan por '/'). Por tanto, la '/' tendrá que ser reemplazada por otro carácter, p. ej. '_' para continuar.

El protocolo de red para comunicarse con el servidor Hyperwave se denomina HG-CSP (Hyper-G Client/Server Protocol, Protocolo Hyper-G Cliente/Servidor). Está basado en mensajes que inician ciertas acciones, p. ej. obtener el registro de un objeto. En versiones anteriores del Servidor Hyperwave se distribuyeron dos clientes nativos (Harmony, Amadeus) para la comunicación con el servidor. Ambos desaparecieron cuando se comercializó el Hyperwave. Para sustituírlo se proporcionó el llamado wavemaster. El wavemaster es como un conversor de protocolo de HTTP a HG-CSP. La idea es realizar toda la administración de la base de datos y la visualización de documentos con una interfaz web. El wavemaster implementa una serie de posicionadores para acciones que permiten personalizar la interfaz. Dicho conjunto de posicionadores se denomina el Lenguaje PLACE. El PLACE no posee muchas de las características de un lenguaje de programación real y las extensiones al mismo únicamente alargan la lista de posicionadores. Esto ha obligado al uso de JavaScript que, en mi opinión, no hace la vida más fácil.

Añadir soporte de Hyperwave al PHP rellenaría el espacio que deja la falta de un lenguaje de programación que permita personalizar la interfaz. El PHP implementa todos los mensajes definidos en el HG-CSP pero además proporciona comandos más poderosos, p. ej. recuperar documentos completos.

El Hyperwave tiene su propia terminología para dar nombre a ciertos tipos de información. Esta ha sido ampliamente extendida y anulada. Casi todas las funciones operan en uno de los siguientes tipos de datos.

  • ID de objeto: Un valor entero único paara cada objeto del servidor Hyperwave. También es uno de los atributos del registro de objeto (ObjectID). Los ID de objeto se usan generalmente como parámetros de entrada que especifican a un objeto.

  • registro de objeto: Una cadena con pares atributo-valor con la forma atributo=valos. Los pares están separados unos de otros por un retorno de carro. Un registro de objeto puede convertirse fácilmente en una tabla (array) de objetos usando hw_object2array(). Varias funciones devuelven registros de objeto. Los nombres de dichas funciones terminan en obj.

  • tabla de objetos: Una tabla asociativa con todos los atributos de un objeto. La clave es el nombre del atributo. Si un atributo aparece más de una vez en un registro de objeto será convertido en otra tabla asociativa o indizada. Los atributos que dependen del idioma (como el título, claves o descripción) se convertirán en una tabla asociativa con la abreviatura del idioma como clave. El resto de los atributos múltiples crearán una tabla indizada. Las funciones de PHP nunca devuelven tablas de objetos.

  • hw_document: Este es un nuevo tipo de datos que almacena el documento actual, p. ej. HTML, PDF, etc. Está algo optimizado para documentos HTML pero puede usarse para cualquier formato.

Varias funciones que devuelven una tabla de registros de objeto también devuelven una tabla asociativa con información estadística sobre los mismos. La tabla es el último elemento del registro de objeto. La tabla estadística contiene los siguientes elementos:

Hidden

Número de registros de objeto con el atributo PresentationHints puesto a Hidden.

CollectionHead

Número de registros de objeto con el atributo PresentationHints puesto a CollectionHead.

FullCollectionHead

Número de registros de objeto con el atributo PresentationHints puesto a FullCollectionHead.

CollectionHeadNr

Índice a una tabla de regitros de objeto con el atributo PresentationHints puesto a CollectionHead.

FullCollectionHeadNr

Índice a una tabla de regitros de objeto con el atributo PresentationHints puesto a FullCollectionHead.

Total

Total: Número de registros de objeto.

Integración con Apache

La extensión Hyperwave se utiliza mejor cuando el PHP se compila como un módulo de Apache. En tal caso el servidor Hyperwave subyacente puede ser ocultado casi por completo de los usuarios si el Apache utiliza su motor de re-escritura. Las siguientes instrucciones explicarán esto.

Como el PHP con soporte Hyperwave incluído en el Apache se ha diseñado para sustituir la solución nativa de Hyperwave basada en Wavemaster, asumiré que el servidor Apache sólo sirve como interfaz web para el Hyperwave. Esto no es necesario, pero simplifica la configuración. El concepto es bastante sencillo. Primeramente necesita un script PHP que evalúe la variable PATH_INFO y que trate su valor como el nombre de un objeto Hyperwave. Llamemos a este script 'Hyperwave'. El URL http://nombre.servidor/Hyperwave/nombre_de_objeto devolvería entonces el objeto Hyperwave llamado 'nombre_de_objeto'. Dependiendo del tipo del objeto, así reaccionará el script. Si es una colección, probablemente devolverá un lista de hijos. Si es un documento devolverá el tipo MIME y el contenido. Se puede mejorar ligeramente si se usa el motor de re-escritura del Apache. Desde el punto de vista del usuario será más sencillo si el URL http://nombre.servidor/nombre de objeto devuelve el objeto. La regla de reescritura es muy sencilla:

RewriteRule ^/(.*) /usr/local/apache/htdocs/HyperWave/$1 [L]

Ahora todo URL apunta a un objeto en el servidor Hyperwave. Esto provoca un problema sencillo de resolver. No hay forma de ejecutar otro script, p. ej. para buscar, salvo el script 'Hyperwave'. Esto se puede solucionar con otra regla de reescritura como la siguiente:

RewriteRule ^/hw/(.*) /usr/local/apache/htdocs/hw/$1 [L]

Esta reservará el directorio /usr/local/apache/htdocs/hw para script adicionales y otros archivos. Sólo hay que asegurarse que esta regla se evalúa antes de la otra. Sólo hay un pequeño inconveniente: todos los objetos Hyperwave cuyo nombre comienza por 'hw/' serán ocultados. así que asegúrese que no utiliza dichos nombres. Si necesita más directorios, p. ej. para imágenes, simplemente añada más reglas o sitúe los archivos en un solo directorio. Por último, no olvide conectar el motor de re-escritura con

RewriteEngine on

Mi experiencia me ha demostrado que necesitará los siguientes scripts:

  • para devolver el script en sí

  • para permitir las búsquedas

  • para identificarse

  • para ajustar su perfil

  • uno para cada función adicional como mostrar los atributos del objeto, mostrar información sobre usuarios, mostrar el estado del servidor, etc.

Pendientes

Aún hay varias cosas pendientes:

  • hw_InsertDocument debe dividirse en hw_InsertObject() y hw_PutDocument().

  • Los nombres de algunas funciones aún no están fijados.

  • Muchas funciones precisan la conexión actual como primer parámetro. Esto obliga a escribir mucho, lo cual no es con frecuencia necesario si sólo hay una conexión abierta. Una conexión por defecto mejoraría esto.

  • La conversión de registro de objeto a tabla de objeto necesita manipular cualquier atributo múltiple.

Tabla de contenidos
hw_Array2Objrec — convierte atributos de tabla de objeto a registro de objeto
hw_Children — id de objeto de los hijos
hw_ChildrenObj — registros de objeto de los hijos
hw_Close — cierra la conexión Hyperwave
hw_Connect — abre una conexión
hw_Cp — copia objetos
hw_Deleteobject — borra objetos
hw_DocByAnchor — id del objeto al que pertenece un enlace
hw_DocByAnchorObj — registro de objeto al que pertenece un enlace
hw_DocumentAttributes — registro de objeto de un documento_hw
hw_DocumentBodyTag — marca 'BODY' de un documento_hw
hw_DocumentContent — devuelve el contenido de un documento_hw
hw_DocumentSetContent — fija/sustituye el contenido de un documento_hw
hw_DocumentSize — tamaño de un documento_hw
hw_EditText — recupera documento de texto
hw_Error — número de error
hw_ErrorMsg — devuelve un mensaje de error
hw_Free_Document — libera un documento_hw
hw_GetAnchors — id de objeto de los enlaces de un documento
hw_GetAnchorsObj — registros de objeto de los enlaces de un documento
hw_GetAndLock — devuelve registro de objeto y lo bloquea
hw_GetChildColl — id de objeto de colecciones hijas
hw_GetChildCollObj — registros de objeto de colecciones hijas
hw_GetChildDocColl — id de objeto de documentos hijos de una colección
hw_GetChildDocCollObj — registros de objeto de documentos hijos de una colección
hw_GetObject — registro de objeto
hw_GetObjectByQuery — buscar objeto
hw_GetObjectByQueryColl — buscar objeto en colección
hw_GetObjectByQueryCollObj — buscar objeto en colección
hw_GetObjectByQueryObj — buscar objeto
hw_GetParents — id de objeto de los padres
hw_GetParentsObj — registros de objeto de los padres
hw_GetRemote — Obtiene un documento remoto
hw_GetRemoteChildren — Obtiene el hijo del documento remoto
hw_GetSrcByDestObj — Devuelve los enlaces que apuntan al objeto
hw_GetText — obtiene un documento de texto
hw_Username — nombre del usuario actualmente conectado
hw_Identify — identificarse como usuario
hw_InCollections — comprueba si los id de objeto están en las colecciones
hw_Info — información sobre conexión
hw_InsColl — insertar colección
hw_InsDoc — insertar documento
hw_InsertDocument — subir cualquier objeto
hw_InsertObject — inserta un registro de objeto
hw_mapid — Mapea in id global a un id virtual local
hw_Modifyobject — modifica el registro de objeto
hw_Mv — mueve objetos
hw_New_Document — crear nuevo documento
hw_Objrec2Array — convierte atributos de registro de objeto a tabla de objetos
hw_OutputDocument — muestra el documento_hw
hw_pConnect — hacer una conexión de base de datos permanente
hw_PipeDocument — recupera cualquier documento
hw_Root — ID del objeto raíz
hw_Unlock — desbloquea objeto
hw_Who — Lista de los usuarios actualmente conectados

Anterior | Inicio | Siguiente
setcookie | Subir | hw_Array2Objrec


hw_Array2Objrec

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

hw_Array2Objrec -- convierte atributos de tabla de objeto a registro de objeto

Descripción

strin hw_array2objrec ( array tabla_objetos)

Convierte una tabla_objetos en un registro de objeto. Los atributos múltiples como 'Título' en distintos idiomas son tratados correctamente.

Vea también hw_objrec2array().

Anterior | Inicio | Siguiente
Funciones para Hyperwave | Subir | hw_Children


hw_Children

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Children -- id de objeto de los hijos

Descripción

array hw_children ( int conexión, int IDobjeto)

Devuelve una tabla de id de objeto. Cada uno de ellos pertenece a un hijo de la colección cuyo ID es IDobjeto. La tabla contiene tanto los documentos como las colecciones hijas.

Anterior | Inicio | Siguiente
hw_Array2Objrec | Subir | hw_ChildrenObj


hw_ChildrenObj

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_ChildrenObj -- registros de objeto de los hijos

Descripción

array hw_childrenobj ( int conexión, int IDobjeto)

Devuelve una tabla de registros de objeto. Cada uno de ellos pertenece a un hijo de la colección cuyo ID es IDobjeto. La tabla contiene tanto los documentos como las colecciones hijas.

Anterior | Inicio | Siguiente
hw_Children | Subir | hw_Close


hw_Close

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Close -- cierra la conexión Hyperwave

Descripción

int hw_close ( int conexión)

Devuelve FALSE si la conexión no es un índice válido de conexión, y TRUE en caso contrario. Cierra la conexión dada con el servidor de Hyperwave.

Anterior | Inicio | Siguiente
hw_ChildrenObj | Subir | hw_Connect


hw_Connect

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Connect -- abre una conexión

Descripción

int hw_connect ( string servidor, int puerto, string usuario, string clave)

Abre una conexión con un servidor Hyperwave y devuelve un índice de conexión si hay éxito, o FALSE si la conexión no se pudo realizar. Cada argumento debe ser una cadena entrecomillada salvo el número de puerto. Los argumentos de usuario y clave son opcionales y pueden omitirse. En tal caso no se realizará identificación alguna con el servidor. Es similar a identificarse como el usuario 'anonymous'. Esta función devuelve un índice de conexión que se necesita para otras funciones Hyperwave. Puede tener varias conexiones abiertas a la vez. Recuerde que la clave no está encriptada.

Vea también hw_pConnect().

Anterior | Inicio | Siguiente
hw_Close | Subir | hw_Cp


hw_Cp

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Cp -- copia objetos

Descripción

int hw_cp ( int conexión, array tabla_id_objeto, int id destino)

Copia los objetos cuyos id se especifican en el segundo parámetro a la colección identificada como id destino.

El valor devuelto es el número de objetos copiados.

Vea también hw_mv().

Anterior | Inicio | Siguiente
hw_Connect | Subir | hw_Deleteobject


hw_Deleteobject

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Deleteobject -- borra objetos

Descripción

int hw_deleteobject ( int conexión, int objeto_a_borrar)

Borra el objeto con el id dado como segundo parámetro. Borrará todas las instancias del mismo.

Devuelve TRUE si no hay error o FALSE en caso contrario.

Vea también hw_mv().

Anterior | Inicio | Siguiente
hw_Cp | Subir | hw_DocByAnchor


hw_DocByAnchor

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_DocByAnchor -- id del objeto al que pertenece un enlace

Descripción

int hw_docbyanchor ( int conexión, int IDenlace)

Devuelve el id de objeto del documento al que pertenece el IDenlace.

Anterior | Inicio | Siguiente
hw_Deleteobject | Subir | hw_DocByAnchorObj


hw_DocByAnchorObj

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_DocByAnchorObj -- registro de objeto al que pertenece un enlace

Descripción

string hw_docbyanchorobj ( int conexión, int IDenlace)

Devuelve el registro de objeto del documento al que pertenece el IDenlace.

Anterior | Inicio | Siguiente
hw_DocByAnchor | Subir | hw_DocumentAttributes


hw_DocumentAttributes

(PHP 3>= 3.0.3)

hw_DocumentAttributes -- registro de objeto de un documento_hw

Descripción

string hw_documentattributes ( int documento_hw)

Devuelve el registro de objeto del documento dado.

Vea también hw_DocumentBodyTag(), hw_DocumentSize().

Anterior | Inicio | Siguiente
hw_DocByAnchorObj | Subir | hw_DocumentBodyTag


hw_DocumentBodyTag

(PHP 3>= 3.0.3)

hw_DocumentBodyTag -- marca 'BODY' de un documento_hw

Descripción

string hw_documentbodytag ( int documento_hw)

Devuelve la marca BODY del documento. Si el documento es de tipo HTML la etiqueta BODY deberá imprimirse antes que el documento.

Vea también hw_DocumentAttributes(), hw_DocumentSize().

Anterior | Inicio | Siguiente
hw_DocumentAttributes | Subir | hw_DocumentContent


hw_DocumentContent

(PHP 3>= 3.0.8)

hw_DocumentContent -- devuelve el contenido de un documento_hw

Descripción

string hw_documentcontent ( int documento_hw)

Devuelve el contenido del documento. Si el documento es de tipo HTML el contenido es todo lo que hay tras la etiqueta BODY. La información de las etiquetas HEAD y BODY se almacenan en el registro de objeto.

Vea también hw_DocumentAttributes(),
         hw_DocumentSize(),
         hw_DocumentSetContent().

Anterior | Inicio | Siguiente
hw_DocumentBodyTag | Subir | hw_DocumentSetContent


hw_DocumentSetContent

(PHP 3>= 3.0.8)

hw_DocumentSetContent -- fija/sustituye el contenido de un documento_hw

Descripción

string hw_documentsetcontent ( int documento_hw, string contenido)

Fija o sustituye el contenido del documento. Si el documento es de tipo HTML el contenido es todo lo que hay tras la etiqueta BODY. La información de las etiquetas HEAD y BODY se almacenan en el registro de objeto. Si proporciona también esta información en el contenido del documento, el servidor Hyperwave modificará el registro del objeto cuando sea insertado el documento. Probablemente no es una buena idea. Si esta función falla, el documento retendrá su anterior contenido.

Vea también hw_DocumentAttributes(),
         hw_DocumentSize(),
         hw_DocumentContent().

Anterior | Inicio | Siguiente
hw_DocumentContent | Subir | hw_DocumentSize


hw_DocumentSize

(PHP 3>= 3.0.3)

hw_DocumentSize -- tamaño de un documento_hw

Descripción

int hw_documentsize ( int documento_hw)

Devuelve el tamaño en bytes del documento.

Vea también hw_DocumentBodyTag(), hw_DocumentAttributes().

Anterior | Inicio | Siguiente
hw_DocumentSetContent | Subir | hw_EditText


hw_ErrorMsg

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_ErrorMsg -- devuelve un mensaje de error

Descripción

string hw_errormsg ( int conexión)

Devuelve una cadena que contiene el último mensaje de error o 'No Error'. Si devuelve FALSE es que la función fracasó. El mensaje está relacionado con el último comando.

Anterior | Inicio | Siguiente
hw_Error | Subir | hw_Free_Document


hw_EditText

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_EditText -- recupera documento de texto

Descripción

int hw_edittext ( int conexión, int documento_hw)

Envía el documento de texto al servidor. El registro de objeto del documento no puede ser modificado mientras el documento es editado. Esta función sólo funcionará para objetos puros de texto. No abrirá ninguna conexión especial de datos y por tanto bloquea la conexión de control durante la transferencia.

Vea también hw_PipeDocument(),
         hw_FreeDocument(),
         hw_DocumentBodyTag(),
         hw_DocumentSize(),
         hw_OutputDocument(),
         hw_GetText().

Anterior | Inicio | Siguiente
hw_DocumentSize | Subir | hw_Error


hw_Error

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Error -- número de error

Descripción

int hw_error ( int conexión)

Devuelve el último número de error. Si el valor devuelto es 0 no ha habido errores. El error está relacionado con el último comando.

Anterior | Inicio | Siguiente
hw_EditText | Subir | hw_ErrorMsg


hw_Free_Document

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Free_Document -- libera un documento_hw

Descripción

int hw_free_document ( int documento_hw)

Libera la memoria ocupada por el documento Hyperwave.

Anterior | Inicio | Siguiente
hw_ErrorMsg | Subir | hw_GetAnchors


hw_GetParents

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetParents -- id de objeto de los padres

Descripción

array hw_getparentsobj ( int conexión, int IDobjeto)

Devuelve una tabla indizada de id de objeto. Cada una pertenece a un padre del objeto con ID IDobjeto.

Anterior | Inicio | Siguiente
hw_GetObjectByQueryObj | Subir | hw_GetParentsObj


hw_GetParentsObj

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetParentsObj -- registros de objeto de los padres

Descripción

array hw_getparentsobj ( int conexión, int IDobjeto)

Devuelve una tabla indizada de registros de objeto junto a una tabla asociativa con información estadística sobre estos. La tabla asociativa es el último elemento de la tabla devuelta. Cada registro de objeto pertenece a un padre del objeto con ID IDobjeto.

Anterior | Inicio | Siguiente
hw_GetParents | Subir | hw_GetRemote


hw_GetChildColl

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetChildColl -- id de objeto de colecciones hijas

Descripción

array hw_getchildcoll ( int conexión, int IDobjeto)

Devuelve una tabla de id de objeto. Cada ID de objeto pertenece a una colección hija de la colección con ID IDobjeto. La función no devolverá documentos hijos.

Vea también hw_GetChildren(), hw_GetChildDocColl().

Anterior | Inicio | Siguiente
hw_GetAndLock | Subir | hw_GetChildCollObj


hw_GetChildCollObj

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetChildCollObj -- registros de objeto de colecciones hijas

Descripción

array hw_getchildcollobj ( int conexión, int IDobjeto)

Devuelve una tabla de registros de objeto. Cada uno de ellos pertenece a una colección hija de la colección con ID IDobjeto. La función no devolverá documentos hijos.

Vea también hw_ChildrenObj(), hw_GetChildDocCollObj().

Anterior | Inicio | Siguiente
hw_GetChildColl | Subir | hw_GetChildDocColl


hw_GetRemote

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetRemote -- Obtiene un documento remoto

Descripción

int hw_getremote ( int conexión, int IDobjeto)

Devuelve un documento remoto. Los documentos remotos en la notación de Hyperwave son los obtenidos de una fuente externa. Los documentos remotos típicos son páginas web externas o consultas a bases de datos. Para poder acceder a las fuentes externas a través de documentos remotos, el Hyperwave presenta el HGI (Hyperwave Gateway Interface - Interfaz de Pasarela de Hyperwave) que es similar al CGI. Actualmente, sólo se puede acceder a servidores ftp y http y a algunas bases de datos. Llamar a hw_GetRemote() devuelve el documento de la fuente externa. Si desea usar esta función debe familiarizarse con los HGI. Debería considerar el usar PHP en lugar del Hyperwave para acceder a fuentes externas. Añadir soporte de bases de datos a través de una pasarela Hyperwave sería más difícil que hacerlo en PHP.

Vea también hw_GetRemoteChildren().

Anterior | Inicio | Siguiente
hw_GetParentsObj | Subir | hw_GetRemoteChildren


hw_GetRemoteChildren

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetRemoteChildren -- Obtiene el hijo del documento remoto

Descripción

int hw_getremotechildren ( int conexión, string registro de objeto)

Devuelve el hijo de un documento remoto. Los hijos de documentos remotos son en sí mismos documentos remotos. Esto tiene sentido cuando se afina una consulta de bases de datos y se explica en la Guía de Programación de Hyperwave. Si el número de hijos es 1 la función devolverá el documento en sí mismo formateado con la Interfaz de Pasarela de Hyperwave (HGI). Si el número de hijos es mayor de 1 devolverá una tabla de registros de objeto, con cada uno posible candidato para otra llamada a hw_GetRemoteChildren(). Dichos registros de objeto son virtuales y no existen en el servidor Hyperwave, y por lo tanto no poseen un ID de objeto válido. La apariencia exacta de dicho registro de objeto depende del HGI. Si desea usar esta función deberá estar muy familiarizado con los HGI. También debería considerar el uso del PHP en lugar de Hyperwave para acceder a fuentes externas. Añadir soporte de bases de datos a través de una pasarela de Hyperwave resulta más difícil que hacerlo en PHP.

Vea también hw_GetRemote().

Anterior | Inicio | Siguiente
hw_GetRemote | Subir | hw_GetSrcByDestObj


hw_GetSrcByDestObj

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetSrcByDestObj -- Devuelve los enlaces que apuntan al objeto

Descripción

array hw_getsrcbydestobj ( int conexión, int IDobjeto)

Devuelve los registros de objeto de todos los enlaces que apuntan al objeto con ID IDobjeto. El objeto puede ser tanto un documento como un enlace de tipo destino.

Vea también hw_GetAnchors().

Anterior | Inicio | Siguiente
hw_GetRemoteChildren | Subir | hw_GetText


hw_GetObject

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetObject -- registro de objeto

Descripción

array hw_getobject ( int conexión, [int|array] IDobjeto, string consulta)

Devuelve el registro de objeto para el objeto cuyo ID es IDobjeto si el segundo parámetro es un entero. Si es una tabla la función devolverá una tabla de registros de objeto. En tal caso, el último parámetro, que es una cadena de consulta, también es evaluado.

La cadena de consulta tiene la sintáxis siguiente:

<expr> ::= "(" <expr> ")" |

"!" <expr> | /* NO */

<expr> "||" <expr> | /* O */

<expr> "&&" <expr> | /* Y */

<atributo> <operador> <valor>

<atributo> ::= /* cualquier atributo (Título, Autor, TipoDocumento ...) */

<operador> ::= "=" | /* igual */

"<" | /* menor que (comparación de cadenas) */

">" | /* mayor que (comparación de cadenas) */

"~" /* expresión regular */

La consulta permite seleccionar elementos de la lista de objetos dada. Al contrario de otras funciones de búsqueda, esta consulta no puede utilizar atributos indizados. El número de registros de objeto devueltos depende de la consulta y de si está permitido el acceso al objeto.

Vea también hw_GetAndLock(), hw_GetObjectByQuery().

Anterior | Inicio | Siguiente
hw_GetChildDocCollObj | Subir | hw_GetObjectByQuery


hw_GetAndLock

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetAndLock -- devuelve registro de objeto y lo bloquea

Descripción

string hw_getandlock ( int conexión, int IDobjeto)

Devuelve el registro de objeto para el objeto con ID IDobjeto. También bloqueará el objeto, de modo que otros usuarios no podrán acceder al mismo hasta que sea desbloqueado.

Vea también hw_Unlock(), hw_GetObject().

Anterior | Inicio | Siguiente
hw_GetAnchorsObj | Subir | hw_GetChildColl


hw_GetText

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetText -- obtiene un documento de texto

Descripción

int hw_gettext ( int conexión, int IDobjeto [, mixed IDraiz/prefijo])

Devuelve el documento con ID de objeto IDobjeto. Si el documento tiene enlaces que pueden ser insertados, serán insertados ahora. El parámetro opcional IDraiz/prefijo puede ser una cadena o un entero. Si es un entero determina la forma en que los enlaces se insertan en el documento. Por defecto es 0 y los enlaces se crean a partir del nombre del objeto de destino de los mismos. Esto es útil para aplicaciones web. Si un enlace apunta a un objeto con nombre 'pelicula_internet' el enlace HTML será <A HREF="/pelicula_internet">. La posición actual del objeto de destino en la jerarquía de documentos es despreciada. Tendrá que ajustar su navegador web para que reescriba dicho URL a, por ejemplo, '/mi_script.php3/pelicula_internet'. 'mi_script.php3' deberá evaluar $PATH_INFO y recuperar el documento. Todos los enlaces tendrán el prefijo '/mi_script.php3'. Si no desea este efecto puede fijar el parámetro opcional IDraiz/prefijo al prefijo que desee en su lugar. En este caso deberá ser una cadena.

Si el IDraiz/prefijo es un entero distinto de 0, el enlace se construye con todos los nombres de objeto comenzando con el objeto de id IDraiz/prefijo, separado por una barra relativa al objeto actual. Si por ejemplo el documento anterior 'pelicula_internet' está situado en 'a-b-c-pelicula_internet' donde '-' es el separador entre niveles jerárquicos en el servidor Hyperwave y el documento fuente está situado en 'a-b-d-fuente', el enlace HTML resultante sería: <A HREF="../c/pelicula_internet">. Esto es útil cuando desea bajarse el contenido completo del servidor al disco y mapear la jerarquía de documentos en el sistema de archivos.

Esta función sólo trabajará en documentos de texto puros. No se abrirá una conexión de datos especial y por tanto bloqueará la conexión de control durante la transferencia.

Vea también hw_PipeDocument(),
         hw_FreeDocument(),
         hw_DocumentBodyTag(),
         hw_DocumentSize(),
         hw_OutputDocument().

Anterior | Inicio | Siguiente
hw_GetSrcByDestObj | Subir | hw_Username


hw_GetObjectByQuery

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetObjectByQuery -- buscar objeto

Descripción

array hw_getobjectbyquery ( int conexión, string consulta, int max_resultados)

Busca objetos en todo el servidor y devuelve una tabla de id de objeto. El número máximo de resultados será max_resultados. Si max_resultados vale -1, el número máximo de resultados es ilimitado.

La consulta funcionará sólo con atributos indizados.

Vea también hw_GetObjectByQueryObj().

Anterior | Inicio | Siguiente
hw_GetObject | Subir | hw_GetObjectByQueryColl


hw_GetObjectByQueryObj

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetObjectByQueryObj -- buscar objeto

Descripción

array hw_getobjectbyqueryobj ( int conexión, string consulta, int max_resultados)

Busca objetos en todo el servidor y devuelve una tabla de registros de objeto. El número máximo de resultados será max_resultados. Si max_resultados vale -1, el número máximo de resultados es ilimitado.

La consulta funcionará sólo con atributos indizados.

Vea también hw_GetObjectByQuery().

Anterior | Inicio | Siguiente
hw_GetObjectByQueryCollObj | Subir | hw_GetParents


hw_GetObjectByQueryColl

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetObjectByQueryColl -- buscar objeto en colección

Descripción

array hw_getobjectbyquerycoll ( int conexión, int IDobjeto, string consulta, int max_resultados)

Busca objetos en la colección cuyo ID es IDobjeto y devuelve una tabla de ID de objeto. El número máximo de resultados será max_resultados. Si max_resultados vale -1, el número máximo de resultados es ilimitado.

La consulta funcionará sólo con atributos indizados.

Vea también hw_GetObjectByQueryCollObj().

Anterior | Inicio | Siguiente
hw_GetObjectByQuery | Subir | hw_GetObjectByQueryCollObj


hw_GetObjectByQueryCollObj

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetObjectByQueryCollObj -- buscar objeto en colección

Descripción

array hw_getobjectbyquerycollobj ( int conexión, int IDobjeto, string consulta, int max_resultados)

Busca objetos en la colección cuyo ID es IDobjeto y devuelve una tabla de registros de objeto. El número máximo de resultados será max_resultados. Si max_resultados vale -1, el número máximo de resultados es ilimitado.

La consulta funcionará sólo con atributos indizados.

Vea también hw_GetObjectByQueryColl().

Anterior | Inicio | Siguiente
hw_GetObjectByQueryColl | Subir | hw_GetObjectByQueryObj


hw_GetChildDocColl

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetChildDocColl -- id de objeto de documentos hijos de una colección

Descripción

array hw_getchilddoccoll ( int conexión, int IDobjeto)

Devuelve una tabla de id de objeto para los documentos hijos de una colección.

Vea también hw_GetChildren(), hw_GetChildColl().

Anterior | Inicio | Siguiente
hw_GetChildCollObj | Subir | hw_GetChildDocCollObj


hw_GetChildDocCollObj

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetChildDocCollObj -- registros de objeto de documentos hijos de una colección

Descripción

array hw_getchilddoccollobj ( int conexión, int IDobjeto)

Devuelve una tabla de registros de objeto para los documentos hijos de una colección.

Vea también hw_ChildrenObj(), hw_GetChildCollObj().

Anterior | Inicio | Siguiente
hw_GetChildDocColl | Subir | hw_GetObject


hw_GetAnchors

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetAnchors -- id de objeto de los enlaces de un documento

Descripción

array hw_getanchors ( int conexión, int IDobjeto)

Devuelve una tabla de id de objeto con los enlaces del documento cuyo ID es IDobjeto.

Anterior | Inicio | Siguiente
hw_Free_Document | Subir | hw_GetAnchorsObj


hw_GetAnchorsObj

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_GetAnchorsObj -- registros de objeto de los enlaces de un documento

Descripción

array hw_getanchorsobj ( int conexión, int IDobjeto)

Devuelve una tabla de registros de objeto con los enlaces del documento cuyo ID es IDobjeto.

Anterior | Inicio | Siguiente
hw_GetAnchors | Subir | hw_GetAndLock


hw_Mv

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Mv -- mueve objetos

Descripción

int hw_mv ( int conexión, array tabla de id de objeto, int id origen, int id destino)

Mueve los objetos cuyas id se especifican en el segundo parámetro desde la colección con id id origen hasta la colección con el id id destino. Si el id de destino es 0, los objetos serán disociados de la colección origen. Si esta fuese la última instancia del objeto, este sería borrado. Si desea borrar todas las instancias de una vez, utilice hw_deleteobject().

El valor devuelto es el número de objetos movidos.

Vea también hw_cp(), hw_deleteobject().

Anterior | Inicio | Siguiente
hw_Modifyobject | Subir | hw_New_Document


hw_Identify

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Identify -- identificarse como usuario

Descripción

int hw_identify ( string nombre, string clave)

Le identifica como el usuario nombre y clave. La identificación sólo es válida para la sesión actual. No pienso que esta función sea necesaria con mucha frecuancia. En muchos casos será más fácil identificarse al abrir la conexión.

Vea también hw_Connect().

Anterior | Inicio | Siguiente
hw_Username | Subir | hw_InCollections


hw_InCollections

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_InCollections -- comprueba si los id de objeto están en las colecciones

Descripción

array hw_incollections ( int conexión, array tabla_id_objeto, array tabla_id_colecciones, int colecciones_devueltas)

Comprueba si el conjunto de objetos (documentos o colecciones) especificado por el parámetro tabla_id_objeto es parte de las colecciones enumeradas en tabla_id_colecciones. Cuando el cuarto parámetro colecciones_devueltas es 0, el subconjunto de id de objeto que es parte de las colecciones (es decir, los documentos o colecciones hijos de una o más colecciones de id de colecciones o de sus subcolecciones, recursivamente) es devuelto en forma de tabla. Cuando el cuarto parámetro es 1, sin embargo, el conjunto de colecciones que tienen uno o más objetos de este subconjunto como hijos es devuelto como tabla. Esta opción permite a un cliente, p. ej., remarcar en una visualización gráfica la parte de la jerarquía de colecciones que contiene las coincidencias de una consulta previa.

Anterior | Inicio | Siguiente
hw_Identify | Subir | hw_Info


hw_Info

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Info -- información sobre conexión

Descripción

string hw_info ( int conexión)

Devuelve información sobre la conexión actual. La cadena devuelta tiene el siguiente formato: <Cadenaservidor>, <Anfitrión>, <Puerto>, <Usuario>, <Puerto del Usuario>, <Intercambio de bytes>

Anterior | Inicio | Siguiente
hw_InCollections | Subir | hw_InsColl


hw_InsColl

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_InsColl -- insertar colección

Descripción

int hw_inscoll ( int conexión, int IDobjeto, array tabla_objetos)

Inserta una nueva colección con los atributos de la tabla_objetos en la colección cuyo ID de objeto es IDobjeto.

Anterior | Inicio | Siguiente
hw_Info | Subir | hw_InsDoc


hw_InsDoc

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_InsDoc -- insertar documento

Descripción

int hw_insdoc ( int conexión, int IDpadre, string registro_de_objeto, string texto)

Inserta un nuevo documento con los atributos del registro_de_objeto en la colección cuyo ID de objeto es IDpadre. Esta función inserta tanto un registro de objeto sólo como un registro de objeto y el texto puro en ASCII dado en texto si este es especificado. si desea insertar un documento general de cualquier tipo, utilice en su lugar hw_insertdocument().

Vea también hw_InsertDocument(), hw_InsColl().

Anterior | Inicio | Siguiente
hw_InsColl | Subir | hw_InsertDocument


hw_InsertDocument

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_InsertDocument -- subir cualquier objeto

Descripción

int hw_insertdocument ( int conexión, int id_padre, int documento_hw)

Sube un documento a la colección dada por id_padre. El documento debe ser creado antes con la función hw_NewDocument(). Asegúrese que el registro de objeto del nuevo documento contenga al menos los atributos: Type, DocumentType, Title y Name (así, en inglés). Posiblemente desee fijar también el MimeType. La función devuelve la id de objeto del nuevo documento, o FALSE.

Vea también hw_PipeDocument().

Anterior | Inicio | Siguiente
hw_InsDoc | Subir | hw_InsertObject


hw_InsertObject

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_InsertObject -- inserta un registro de objeto

Descripción

int hw_insertobject ( int conexión, string reg de objeto, string parametro)

Inserta un objeto en el servidor. Este puede consistir en cualquier objeto hyperwave válido. Vea la documentación sobre el HG-CSP si desea información detallada sobre cuáles tienen que ser los parámetros.

Nota: Si se desea insertar un enlace, el atributo Position siempre se fijará a un valor comienzo/final o a 'invisible'. Las posiciones invisibles se necesitan si la anotación no tiene enlace correspondiente en el texto anotado.

Vea también hw_PipeDocument(),
         hw_InsertDocument(),
         hw_InsDoc(),
         hw_InsColl().

Anterior | Inicio | Siguiente
hw_InsertDocument | Subir | hw_mapid


hw_mapid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

hw_mapid -- Mapea in id global a un id virtual local

Descripción

int hw_mapid ( int conexión, int id servidor, int id objeto)

Mapea un id de objeto global en un servidor hyperwave, incluso con aquellos a los que no se ha conectado con hw_connect(), sobre un id virtual de objeto. Este id virtual se puede utilizar como cualquier otro id de objeto, p. ej. para obtener el registro de objeto por medio de hw_getobject(). El id de servidor es la primera parte del id global de objeto (GOid) de aquel que es realmene el número IP expresado como entero.

Nota: Para usar esta función deberá activar el indicador F_DISTRIBUTED, que actualmenes sólo se puede fijar en tiempo de compilación desde hg_comm.c. Por defecto está inactivo. Lea el comentario al principio de hg_comm.c

Anterior | Inicio | Siguiente
hw_InsertObject | Subir | hw_Modifyobject


hw_Modifyobject

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

hw_Modifyobject -- modifica el registro de objeto

Descripción

int hw_modifyobject ( int conexión, int objeto_a_cambiar, array eliminar, array añadir, int modo)

Este comando permite eliminar, añadir, o modificar atributos individuales de un registro de objeto. El objeto está especificado por el ID de objeto objeto_a_cambiar. La primera tabla, eliminar, es la lista de atributos a eliminar. La segunda tabla, añadir, es la lista de atributos a añadir. Para modificar un atributo, hay que borrar el antiguo y añadir uno nuevo. hw_modifyobject() siempre eliminará los atributos antes de añadir los nuevos excepto si el valor del atributo a eliminar no es una cadena o una tabla.

El último parámetro determina si la modificación se realiza de manera recursiva. 1 quiere decir que sea recursiva. Si alguno de los objetos no se puede modificar, será ignorado sin avisar. Incluso hw_error() podría no indicar un error aunque alguno de los objetos no pueda ser modificado.

Las claves de ambas tablas son los nombres de los atributos. El valor de cada elemento de la tabla puede ser una tabla, una cadena o cualquier otra cosa. Si es una tabla, cada valor de atributo se construye como la clave de cada elemento más dos puntos y el valor de cada elemento. Si es una cadena se toma como valor del atributo. Una cadena vacía producirá la supresión completa del atributo. Si el valor no es ni cadena ni tabla, sino otra cosa, p. ej. un entero, no se realizará operación alguna en el atributo. Esto es necesario se desea añadir un atributo completamente nuevo, no solamente un nuevo valor para un atributo existente. Si la tabla eliminar contuviera una cadena vacía para dicho atributo, este se intentaría suprimir, lo que fallaría porque este no existe. La siguiente adición de un nuevo valor para dicho atributo también fallará. Fijando el valor para dicho atributo p. ej. a 0 hará que ni siquiera se intente eliminar, pero funcionará la adición del mismo.

Si desea cambiar el atributo 'Nombre' con el valor actual 'libros' por el de 'artículos' deberá crear dos tablas y llamar a hw_modifyobject().

Ejemplo 1. modificando un atributo

// $conexion es una conexión con el servidor Hyperwave
       // $idobj es la ID del objeto a modificar
       $tablasupr = array("Nombre" => "libros");
       $tablaanad = array("Nombre" => "artículos");
       $hw_modifyobject($conexion, $idobj, $tablasupr, $tablaanad);
Para borrar/añadir un par nombre=valor de/a el registro de objeto, simplemente pase la tabla eliminar/añadir y fije el último/tercer parámetro a tabla vacía. Si el atributo es el primero con dicho nombre que se añade, fije el valor del atributo en la tabla eliminar a un valor entero.

Ejemplo 2. añadiendo un atributo completamente nuevo

// $conexion es una conexión con el servidor Hyperwave
       // $idobj es la ID del objeto a modificar
       $tablasupr = array("Nombre" => 0);
       $tablaanad = array("Nombre" => "artículos");
       $hw_modifyobject($conexion, $idobj, $tablasupr, $tablaanad);

Nota: Los atributos plurilingües, p. ej. 'Título', se pueden modificar de dos maneras. O bien proporcionando los valores de los atributos en su forma nativa 'lenguaje':'título', bien proporcionando una tabla con los elementos para cada lenguaje según se describe más arriba. El ejemplo anterior podría quedar entonces:

Ejemplo 3. modificando el atributo Título

$tablasupr = array("Título" => "es:Libros");
       $tablaanad = array("Título" => "es:Artículos");
       $hw_modifyobject($conexion, $idobj, $tablasupr, $tablaanad);
o

Ejemplo 4. modificando el atributo Título

$tablasupr = array("Título" => array("es" => "Libros"));
       $tablaanad = array("Título" => array("es" => "Artículos", "ge"=>"Artikel"));
       $hw_modifyobject($conexion, $idobj, $tablasupr, $tablaanad);
Esto elimina el título español 'Libros' y añade el título español 'Artículos' y el título alemán 'Artikel'.

Ejemplo 5. eliminando atributos

$tablasupr = array("Título" => "");
       $tablaanad = array("Tñitulo" => "es:Artículos");
       $hw_modifyobject($conexion, $idobj, $tablasupr, $tablaanad);

Nota: Esto eliminará todos los atributos con el nombre 'Título' y añadirá un nuevo atributo 'Título'. Esto es útil cuando se desea eliminar atributos de forma recursiva.

Nota: Si necesita eliminar todos los atributos con un cierto nombre tendrá que pasar una cadena vacía como el valor del atributo.

Nota: Sólo los atributos 'Title', 'Description' y 'Keyword' (así, en inglés) manejarán de forma apropiada el prefijo de idioma. Si estos atributos no llevaran prefijo de idioma, se les asignariá el prefijo 'xx'.

Nota: El atributo 'Name' es bastante especial. En algunos casos no puede ser completamente eliminado. Obtendrá un mensaje de error 'Change of base attribute' ('Cambio de atributo base', no está muy claro cuando ocurre). Por tanto, tendrá siempre que añadir un nuevo atributo Name primero y luego eliminar el anterior.

Nota: No debe rodear esta función de llamadas a hw_getandlock() ni a hw_unlock(). hw_modifyobject() ya lo hace internamente.

Devuelve TRUE si no hay error o FALSE en caso contrario.

Anterior | Inicio | Siguiente
hw_mapid | Subir | hw_Mv


hw_New_Document

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_New_Document -- crear nuevo documento

Descripción

int hw_new_document ( string registro_de_objeto, string datos_documento, int tama_documento)

Devuelve un nuevo documento Hyperwave en el que los datos del documento están fijados a datos_documento y el registro de objeto a registro_de_objeto. La longitud de los datos_documento debe pasarse en tama_documento. Esta función no inserta el documento en el servidor Hyperwave.

Vea también hw_FreeDocument(),
         hw_DocumentSize(),
         hw_DocumentBodyTag(),
         hw_OutputDocument(),
         hw_InsertDocument().

Anterior | Inicio | Siguiente
hw_Mv | Subir | hw_Objrec2Array


hw_Objrec2Array

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Objrec2Array -- convierte atributos de registro de objeto a tabla de objetos

Descripción

array hw_objrec2array ( string registro_de_objeto)

Convierte un registro_de_objeto en una tabla de objetos. Las claves de la tabla resultante son los nombres de los atributos. Los atributos múltiples como 'Título' en distintos idiomas forman su propia tabla. Las claves de esta tabla son las partes a la izquierda de los dos puntos del valor del atributo. Actualmente, sólo los atributos 'Title', 'Description' y 'Keyword' (así, en inglés) son correctamente tratados. Otros atributos múltiples generan una tabla indizada. Actualmente, sólo el atributo 'Group' es tratado correctamente.

Vea también hw_array2objrec().

Anterior | Inicio | Siguiente
hw_New_Document | Subir | hw_OutputDocument


hw_OutputDocument

(PHP 3>= 3.0.3)

hw_OutputDocument -- muestra el documento_hw

Descripción

int hw_outputdocument ( int documento_hw)

Muestra el documento sin la etiqueta BODY.

Anterior | Inicio | Siguiente
hw_Objrec2Array | Subir | hw_pConnect


hw_pConnect

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_pConnect -- hacer una conexión de base de datos permanente

Descripción

int hw_pconnect ( string servidor, int puerto, string usuario, string clave)

Devuelve un índice de conexión si hay éxito, o FALSE si la conexión no puede hacerse. Abre una conexión permanente a un servidor Hyperwave. Cada uno de los argumentos debe ser una cadena entrecomillada excepto el número de puerto. El argumento usuario y la clave son opcionales y pueden omitirse. En tal caso no se realizará ninguna identificación con el servidor. Es similar a la identificación anónima del usuario. Esta función devuelve un índice de conexión que se necesita para otras funciones de Hyperwave. Se pueden tener varias conexiones permanentes abiertas a la vez.

Vea también hw_Connect().

Anterior | Inicio | Siguiente
hw_OutputDocument | Subir | hw_PipeDocument


hw_PipeDocument

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_PipeDocument -- recupera cualquier documento

Descripción

int hw_pipedocument ( int conexión, int IDobjeto)

Devuelve el documento Hyperwave cuyo ID de objeto es IDobjeto. Si el documento tiene enlaces que pueden ser insertados, deberán haberse insertado ya. El documento será transferido a través de una conexión de datos especial que no bloquea la conexión de control.

Vea también hw_GetText() para saber más sobre
        inserción de enlaces,
         hw_FreeDocument(),
         hw_DocumentSize(),
         hw_DocumentBodyTag(),
         hw_OutputDocument().

Anterior | Inicio | Siguiente
hw_pConnect | Subir | hw_Root


hw_Root

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Root -- ID del objeto raíz

Descripción

int hw_root ( )

Devuelve la ID de objeto de la colección hiper-raíz. Actualmente siempre vale 0. La colección hija de la hiper-raíz es la colección raíz del servidor al que se ha conectado.

Anterior | Inicio | Siguiente
hw_PipeDocument | Subir | hw_Unlock


hw_Unlock

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Unlock -- desbloquea objeto

Descripción

int hw_unlock ( int conexión, int IDobjeto)

Desbloquea un documento para que otros usuarios puedan acceder al mismo de nuevo.

Vea también hw_GetAndLock().

Anterior | Inicio | Siguiente
hw_Root | Subir | hw_Who


hw_Who

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

hw_Who -- Lista de los usuarios actualmente conectados

Descripción

int hw_who ( int conexión)

Devuelve una tabla de los usuarios actualmente conectados al servidor Hyperwave. Cada elemento de esta tabla contiene en sí mismo los elementos ID, nombre, sistema, onSinceDate (conectadoDesdeFecha), onSinceTime (conectadoDesdeHora), TotalTime (TiempoTotal) y self (propio). 'self' es 1 si esta línea corresponde al usuario que realizó la petición.

Anterior | Inicio | Siguiente
hw_Unlock | Subir | Funciones para ICAP - Internet Calendar Application Protocol


hw_Username

(unknown)

hw_Username -- nombre del usuario actualmente conectado

Descripción

string hw_getusername ( int conexión)

Devuelve el nombre de usuario de la conexión.

Anterior | Inicio | Siguiente
hw_GetText | Subir | hw_Identify


Funciones para ICAP - Internet Calendar Application Protocol

Manual de PHP
Anterior Siguiente

XXXIX. Funciones para ICAP - Internet Calendar Application Protocol

Para hacer funcionar estas funciones, deberá compilar el PHP con --with-icap. Eso indicará que se precisa la instalación de la librería ICAP. Obtenga la última versión en http://icap.chek.com/, compílela e instálela.

Tabla de contenidos
icap_close — Cierra un stream ICAP
icap_delete_event — Borra un evento de un calendario ICAP
icap_fetch_event — Obtiene un evento del stream de calendario/
icap_list_alarms — Devuelve una lista de los eventos que una alarma ha disparado en el instante dado
icap_list_events — Devuelve una lista de eventos entre dos instantes dados
icap_open — Abre una conexión ICAP
icap_snooze — Apaga la alarma de un evento
icap_store_event — Almacena un evento en un calendario ICAP

Anterior | Inicio | Siguiente
hw_Who | Subir | icap_close


icap_open

(PHP 4 >= 4.0.0)

icap_open -- Abre una conexión ICAP

Descripción

stream icap_open ( string calendario, string usuario, string clave, string opciones)

Si hay éxito devuelve un stream (flujo) ICAP, o FALSE en caso de error.

icap_open() abre una conexión ICAP con el servidor de calendario especificado. Si se especifica el parámetro opcional opciones, también éste es pasado a dicho buzón.

Anterior | Inicio | Siguiente
icap_list_events | Subir | icap_snooze


icap_close

(unknown)

icap_close -- Cierra un stream ICAP

Descripción

int icap_close ( int stream_icap, int banderas)

Cierra el stream ICAP dado.

Anterior | Inicio | Siguiente
Funciones para ICAP - Internet Calendar Application Protocol | Subir | icap_delete_event


icap_fetch_event

(PHP 4 >= 4.0.0)

icap_fetch_event -- Obtiene un evento del stream de calendario/

Descripción

object icap_fetch_event ( stream stream_icap, id id_evento, options opciones)

icap_fetch_event() obtiene el evento del stream de calendario especificado por el parámetro id_evento.

Devuelve un objeto de evento compuesto por:

  • int id - ID de dicho evento.

  • int public - TRUE si el evento es público, FALSE si es privado.

  • string category - Cadena con la categoría del evento.

  • string title - Cadena de título del evento.

  • string description - Cadena de descripción del evento.

  • int alarm - Número de minutos antes que el evento envíe una alarma/recordatorio.

  • object start - Objeto que contiene una entrada datetime (fecha/hora).

  • object end - Objeto que contiene una entrada datetime.

Todas las entradas datetime consisten en un objeto compuesto por:

  • int year - año

  • int month - mes

  • int mday - día del mes

  • int hour - hora

  • int min - minutos

  • int sec - segundos

Anterior | Inicio | Siguiente
icap_delete_event | Subir | icap_list_alarms


icap_list_events

(PHP 4 >= 4.0.0)

icap_list_events -- Devuelve una lista de eventos entre dos instantes dados

Descripción

array icap_list_events ( stream stream_icap, datetime instante_inicio, datetime instante_final)

Devuelve una tabla de ID de evento que están entre los dos instantes dados.

La función icap_list_events() toma un instante de inicio y uno de final para un stream de calendario. Se devuelve una tabla de ID de evento que están entre los instantes dados.

Todas las entradas datetime consisten en un objeto compuesto por:

  • int year - año

  • int month - mes

  • int mday - día del mes

  • int hour - hora

  • int min - minutos

  • int sec - segundos

Anterior | Inicio | Siguiente
icap_list_alarms | Subir | icap_open


icap_store_event

(PHP 4 >= 4.0.0)

icap_store_event -- Almacena un evento en un calendario ICAP

Descripción

int icap_store_event ( int stream_icap, object evento)

icap_store_event() Guarda un evento en un calendario ICAP. Un objeto de evento consiste en:

  • int public - 1 si es público, 0 si es privado;

  • string category - Cadena con la categoría del evento.

  • string title - Cadena de título del evento.

  • string description - Cadena de descripción del evento.

  • int alarm - Número de minutos antes que el evento envíe una alarma/recordatorio.

  • object start - Objeto que contiene una entrada datetime (fecha/hora).

  • object end - Objeto que contiene una entrada datetime.

Todas las entradas datetime consisten en un objeto compuesto por:

  • int year - año

  • int month - mes

  • int mday - día del mes

  • int hour - hora

  • int min - minutos

  • int sec - segundos

Devuelve TRUE en caso de éxito y FALSE en caso de error.

Anterior | Inicio | Siguiente
icap_snooze | Subir | iconv functions


icap_delete_event

(PHP 4 >= 4.0.0)

icap_delete_event -- Borra un evento de un calendario ICAP

Descripción

int icap_delete_event ( int id_evento)

icap_delete_event() borra el evento de calendario especificado por el id_evento.

Devuelve TRUE.

Anterior | Inicio | Siguiente
icap_close | Subir | icap_fetch_event


icap_snooze

(PHP 4 >= 4.0.0)

icap_snooze -- Apaga la alarma de un evento

Descripción

int icap_snooze ( int id_evento)

icap_snooze() apaga la alarma del evento de calendario especificado por el id_evento.

Returns TRUE.

Anterior | Inicio | Siguiente
icap_open | Subir | icap_store_event


icap_list_alarms

(PHP 4 >= 4.0.0)

icap_list_alarms -- Devuelve una lista de los eventos que una alarma ha disparado en el instante dado

Descripción

array icap_list_alarms ( stream stream_icap, datetime instante_alarma)

Devuelve una tabla de identificadores de evento para los que una alarma debiera apagarse en el instante indicado.

La función icap_list_alarms() toma una estructura datetime para un stream de calendario. Se devuelve una tabla de los identificadores de evento de todas las alarmas que debieran apagarse en el instante indicado.

Todas las entradas datetime consisten en un objeto compuesto por:

  • int year - año

  • int month - mes

  • int mday - día del mes

  • int hour - hora

  • int min - minutos

  • int sec - segundos

Anterior | Inicio | Siguiente
icap_fetch_event | Subir | icap_list_events


iconv functions

Manual de PHP
Anterior Siguiente

XL. iconv functions

This module contains an interface to the iconv library functions. To be able to use the functions defined in this module you must compile you PHP interpreter using the --with-iconv option. In order to do so, you must have iconv() function in standard C library or libiconv installed on your system. libiconv library is available from http://www.gnu.org/software/libiconv/.

iconv library function converts files between various encoded character sets. The supported character sets depend on iconv() implementation on your system. Note that iconv() function in some system is not work well as you expect. In this case, you should install libiconv library.

Tabla de contenidos
iconv — Convert string to requested character encoding
iconv_get_encoding — Get current setting for character encoding conversion
iconv_set_encoding — Set current setting for character encoding conversion
ob_iconv_handler — Convert character encoding as output buffer handler

Anterior | Inicio | Siguiente
icap_store_event | Subir | iconv


iconv

(PHP 4 >= 4.0.5)

iconv -- Convert string to requested character encoding

Description

string iconv ( string in_charset, string out_charset, string str)

It converts the string string encoded in in_charset to the string encoded in out_charset. It returns the converted string or FALSE, if it fails.

Ejemplo 1. iconv() example:

echo iconv("ISO-8859-1","UTF-8","This is test.");

Anterior | Inicio | Siguiente
iconv functions | Subir | iconv_get_encoding


iconv_get_encoding

(PHP 4 >= 4.0.5)

iconv_get_encoding -- Get current setting for character encoding conversion

Description

array iconv_get_encoding ( [string type])

It returns the current settings of ob_iconv_handler() as array or FALSE in failure.

See also: iconv_set_encoding() and ob_iconv_handler().

Anterior | Inicio | Siguiente
iconv | Subir | iconv_set_encoding


iconv_set_encoding

(PHP 4 >= 4.0.5)

iconv_set_encoding -- Set current setting for character encoding conversion

Description

array iconv_set_encoding ( string type, string charset)

It changes the value of type to charset and returns TRUE in success or FALSE in failure.

Ejemplo 1. iconv_set_encoding() example:

iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");

See also: iconv_get_encoding() and ob_iconv_handler().

Anterior | Inicio | Siguiente
iconv_get_encoding | Subir | ob_iconv_handler


ob_iconv_handler

(PHP 4 >= 4.0.5)

ob_iconv_handler -- Convert character encoding as output buffer handler

Description

array ob_iconv_handler ( string contents, int status)

It converts the string encoded in internal_encoding to output_encoding.

internal_encoding and output_encoding should be defined by iconv_set_encoding() or in configuration file.

Ejemplo 1. ob_iconv_handler() example:

ob_start("ob_iconv_handler"); // start output buffering

See also: iconv_get_encoding() and iconv_set_encoding().

Anterior | Inicio | Siguiente
iconv_set_encoding | Subir | Funciones de imágenes


Funciones de imágenes

Manual de PHP
Anterior Siguiente

XLI. Funciones de imágenes

Puede usar las funciones de imágenes de PHP para obtener el tamaño de imágenes JPEG, GIF y PNG, y si tiene la libreria GD (disponible en http://www.boutell.com/gd/) además será capaz de crear y manipular imágenes.

Tabla de contenidos
GetImageSize — Obtiene el tamaño de una imagen GIF, JPG o PNG
ImageArc — Dibuja una elipse parcial
ImageChar — Dibuja un carácter horizontalmente
ImageCharUp — Dibuja un carácter vertical
ImageColorAllocate — Reserva un color para una imagen
ImageColorAt — Obtiende el índice del color de un pixel
ImageColorClosest — Obtiene el índice del color más cercano al color especificado
ImageColorExact — Devuelve el índice del color especificado
ImageColorResolve — Devuelve el índice del color especificado o su posible alternativa más cercana
ImageColorSet — Establece el color para el índice de la paleta especificado
ImageColorsForIndex — Obtiene los colores de un índice
ImageColorsTotal — Encuentra el número de colores de la paleta de una imagen
ImageColorTransparent — Define un color como transparente
ImageCopyResized — Copia y redimensiona parte de una imagen
ImageCreate — Crea una nueva imagen
ImageCreateFromGif — Crea una nueva imagen desde un fichero o una URL
ImageDashedLine — Dibuja una línea discontinua
ImageDestroy — Destruye una imagen
ImageFill — Relleno
ImageFilledPolygon — Dibuja un polígono relleno
ImageFilledRectangle — dibuja un rectángulo relleno
ImageFillToBorder — Relleno de un color especifico
ImageFontHeight — Devuelve la altura de una fuente
ImageFontWidth — Devuelve la anchura de una fuente
ImageGif — Envía una imagen al navegador o a un fichero
ImageInterlace — Activa o desactiva el entrelazado
ImageLine — Dibuja una línea
ImageLoadFont — Carga una fuente nueva
ImagePolygon — Dibuja un polígono
ImagePSBBox — Devuelve el borde que rodea un rectángulo de texto usando fuentes PostScript Type1
ImagePSCopyFont — hace una copia de una fuente ya cargada para futuras modificaciones
ImagePSEncodeFont — Cambia el vector de codificación de caracteres de una fuente
ImagePSFreeFont — Libera la memoria usada por un fuente PostScript Type 1
ImagePSLoadFont — Carga una fuente PostScript Type 1 desde un fichero
ImagePSText — Para dibujar una cadena de texto sobre una imagen usando fuentes PostScript Type1
ImageRectangle — Dibuja un rectángulo
ImageSetPixel — Dibuja un pixel
ImageString — Dibuja una cadena de texto horizintalmente
ImageStringUp — Dibuja una cadena de texto verticalmente
ImageSX — Obtiene la anchura de la imagen
ImageSY — Obtiene la altura de la imagen
ImageTTFBBox — Devuelve un caja que rodea al texto usando fuentes TypeType
ImageTTFText — Escribe texto en la imagen usando fuentes TrueType

Anterior | Inicio | Siguiente
ob_iconv_handler | Subir | GetImageSize


GetImageSize

(PHP 3, PHP 4 >= 4.0.0)

GetImageSize -- Obtiene el tamaño de una imagen GIF, JPG o PNG

Descripción

array getimagesize ( string filename [, array imageinfo])

La función GetImageSize() determinará el tamaño de cualquier fichero de imagen GIF, JPG o PNG y devolverá sus dimensiones junto al tipo de fichero en una cadena de texto que pueda ser usada en una marca HTML IMG normal.

Devuelve una matriz con 4 elementos. El índice 0 contiene la anchura de la imagen en pixels. El índice 1 contiene la altura. El índice 2 es una marca indicando el tipo de imagen. 1 = GIF, 2 = JPG, 3 = PNG. El índice 3 es una cadena de texto con el string correcto "height=xxx width=xxx" para ser usado directamente en una marca IMG.

Ejemplo 1. GetImageSize

<?php $size = GetImageSize("img/flag.jpg"); ?>
<IMG SRC="img/flag.jpg" <?php echo $size[3]; ?>>

El parámetro opcional imageinfo permite extraer información adicional del fichero de imagen. Actualmente esto devolverá las diferentes marcas APP de los JPG en una matriz asociada. Algunos programas usan estas marcas APP para incluir información textual en las imagenes. Uno bastante común incluye información IPTC http://www.iptc.org/ en la marca APP13. Puede usar la función iptcparse() para convertir la marca binaria APP13 en algo leible.

Ejemplo 2. GetImageSize devolviendo IPTC

<?php
    $size = GetImageSize("testimg.jpg",&$info);
    if (isset($info["APP13"])) {
        $iptc = iptcparse($info["APP13"]);
        var_dump($iptc);
    }
?>

Nota: Esta función no requiere la libreria de imagenes GD.

Anterior | Inicio | Siguiente
Funciones de imágenes | Subir | ImageArc


ImageArc

(PHP 3, PHP 4 >= 4.0.0)

ImageArc -- Dibuja una elipse parcial

Descripción

int imagearc ( int im, int cx, int cy, int w, int h, int s, int e, int col)

ImageArc dibuja una elipse parcial centrada en cx, cy (la esquina superior izquierda es 0,0) en la imagen que representa im. w y h especifican la anchura y altura respectivamente mientras que los puntos de inicio y final vienen indicados por los parámetros s y e en grados.

Anterior | Inicio | Siguiente
GetImageSize | Subir | ImageChar


ImageChar

(PHP 3, PHP 4 >= 4.0.0)

ImageChar -- Dibuja un carácter horizontalmente

Descripción

int imagechar ( int im, int font, int x, int y, string c, int col)

ImageChar dibuja el primer carácter de c en la imagen identificada como id con su esquina superior izquierda en x, y (arriba izquierda es 0,0) con el color col. Si la fuente es 1, 2, 3, 4 o 5 se usa una fuente predefinida (números mayores corresponden con tamaños mayores).

Vea también imageloadfont().

Anterior | Inicio | Siguiente
ImageArc | Subir | ImageCharUp


ImageCharUp

(PHP 3, PHP 4 >= 4.0.0)

ImageCharUp -- Dibuja un carácter vertical

Descripción

int imagecharup ( int im, int font, int x, int y, string c, int col)

ImageCharUp dibuja el caracter c verticalmente en la imagen identificado como im en las coordenadas x, y (arriba izquierda es 0,0) con el color col. Si la fuente es 1, 2, 3, 4 o 5 se usa una fuente predefinida.

Vea también imageloadfont().

Anterior | Inicio | Siguiente
ImageChar | Subir | ImageColorAllocate


ImageColorAllocate

(PHP 3, PHP 4 >= 4.0.0)

ImageColorAllocate -- Reserva un color para una imagen

Descripción

int imagecolorallocate ( int im, int red, int green, int blue)

ImageColorAllocate devuelve un identificador del color representado por la mezcla de los componentes RGB dados. El parámetro im es el resultado de la función imagecreate(). ImageColorAlocate tiene que ser invocada para crear cada color que va a ser usado por la imagen que representa im.

$white = ImageColorAllocate($im, 255,255,255);
$black = ImageColorAllocate($im, 0,0,0);

Anterior | Inicio | Siguiente
ImageCharUp | Subir | ImageColorAt


ImageColorAt

(PHP 3, PHP 4 >= 4.0.0)

ImageColorAt -- Obtiende el índice del color de un pixel

Descripción

int imagecolorat ( int im, int x, int y)

Devuelve el índice del color del pixel especificado en la posición de la imagen.

Vea también imagecolorset() y imagecolorsforindex().

Anterior | Inicio | Siguiente
ImageColorAllocate | Subir | ImageColorClosest


ImageColorClosest

(PHP 3, PHP 4 >= 4.0.0)

ImageColorClosest -- Obtiene el índice del color más cercano al color especificado

Descripción

int imagecolorclosest ( int im, int red, int green, int blue)

Devuelve el índice del color de la paleta de la imagen que sea más "cercano" al valor RGB especificado.

La "distancia" entre el color deseado y cada color de la paleta es calculada como si los valores RGB representasen puntos en un espacio tridimensional.

Vea también imagecolorexact().

Anterior | Inicio | Siguiente
ImageColorAt | Subir | ImageColorExact


ImageColorExact

(PHP 3, PHP 4 >= 4.0.0)

ImageColorExact -- Devuelve el índice del color especificado

Descripción

int imagecolorexact ( int im, int red, int green, int blue)

Devuelve el índice del color especificado de la paleta de la imagen.

Si el color no existe en la paleta de la imagen, se devuelve el valor -1.

Vea también imagecolorclosest().

Anterior | Inicio | Siguiente
ImageColorClosest | Subir | ImageColorResolve


ImageColorResolve

(PHP 3>= 3.0.2, PHP 4 >= 4.0.0)

ImageColorResolve -- Devuelve el índice del color especificado o su posible alternativa más cercana

Descripción

int imagecolorresolve ( int im, int red, int green, int blue)

Esta función garantiza el resultado de un índice de color para un color solicitado, ya sea el color exacto o su alternativa más cercana.

Vea también imagecolorclosest().

Anterior | Inicio | Siguiente
ImageColorExact | Subir | ImageColorSet


ImageColorSet

(PHP 3, PHP 4 >= 4.0.0)

ImageColorSet -- Establece el color para el índice de la paleta especificado

Descripción

bool imagecolorset ( int im, int index, int red, int green, int blue)

Establece el índice especificado de la paleta con el color introduciod. Esto es útil para crear efectos de rellenado en imagenes con paletas sin la sobrecarga de tener que realizar el rellenado.

Vea también imagecolorat().

Anterior | Inicio | Siguiente
ImageColorResolve | Subir | ImageColorsForIndex


ImageColorsForIndex

(PHP 3, PHP 4 >= 4.0.0)

ImageColorsForIndex -- Obtiene los colores de un índice

Descripción

array imagecolorsforindex ( int im, int index)

Devuelve una matriz asociativa con las claves red, green y blue que contienen los valores apropiados para el color especificado en el índice.

Vea también imagecolorat() y imagecolorexact().

Anterior | Inicio | Siguiente
ImageColorSet | Subir | ImageColorsTotal


ImageColorsTotal

(PHP 3, PHP 4 >= 4.0.0)

ImageColorsTotal -- Encuentra el número de colores de la paleta de una imagen

Descripción

int imagecolorstotal ( int im)

Encuentra el número de colores de la paleta de una imagen.

Vea también imagecolorat() y imagecolorsforindex().

Anterior | Inicio | Siguiente
ImageColorsForIndex | Subir | ImageColorTransparent


ImageColorTransparent

(PHP 3, PHP 4 >= 4.0.0)

ImageColorTransparent -- Define un color como transparente

Descripción

int imagecolortransparent ( int im [, int col])

ImageColorTransparent establece como color transparente a col en la imagen im. im es el identificador de imagen devuelto por imagecreate() y col es el identificador de color devuelto por imagecolorallocate().

Se devuelve el identificador del color transparente (o el actual, si no se especifica ninguno).

Anterior | Inicio | Siguiente
ImageColorsTotal | Subir | ImageCopyResized


ImageCopyResized

(PHP 3, PHP 4 >= 4.0.0)

ImageCopyResized -- Copia y redimensiona parte de una imagen

Descripción

int imagecopyresized ( int dst_im, int src_im, int dstX, int dstY, int srcX, int srcY, int dstW, int dstH, int srcW, int srcH)

ImageCopyResize copia una porción rectangular de una imagen hacia otra imagen. dst_im es la imagen de destino, src_im es el identificador de la imagen origen. Si la altura y anchura de las coordenadas de origen y destino difieren se realizará un estrechamiento o un estiramiento apropiado del fragmento de la imagen. Las coordenadas van localizadas sobre la esquina superior izquierda. Esta función se puede usar para copiar regiones dentro de la misma imagen (si dst_im es igual que src_im) pero si las regiones se solapan los resultados seran impredecibles.

Anterior | Inicio | Siguiente
ImageColorTransparent | Subir | ImageCreate


ImageCreate

(PHP 3, PHP 4 >= 4.0.0)

ImageCreate -- Crea una nueva imagen

Descripción

int imagecreate ( int x_size, int y_size)

ImageCreate devuelve un identificador de imagen representando una imagen en blanco de tamaño x_size por y_size.

Anterior | Inicio | Siguiente
ImageCopyResized | Subir | ImageCreateFromGif


ImageCreateFromGif

(PHP 3, PHP 4 >= 4.0.0)

ImageCreateFromGif -- Crea una nueva imagen desde un fichero o una URL

Descripción

int imagecreatefromgif ( string filename)

imagecreatefromgif() devuelve un identificador de imagen representando la imagen obtenida del nombre del fichero dado.

imagecreatefromgif() devuelve una cadena vacia si hay algun fallo. Además muestra un mensaje de error, que desafortunadamente se representa como un link roto en un navegador. Para depurarlo fácilmente el siguiente ejemplo producirá un error de GIF:

Ejemplo 1. Ejemplo de control de un error durante la creación (cortesía vic@zymsys.com )

function LoadGif($imgname)
{
  $im = @imagecreatefromgif($imgname); /* Attempt to open */
  if ($im == "") { /* See if it failed */
    $im = ImageCreate(150,30); /* Create a blank image */
    $bgc = ImageColorAllocate($im,255,255,255);
    $tc  = ImageColorAllocate($im,0,0,0);
    ImageFilledRectangle($im,0,0,150,30,$bgc);
    ImageString($im,1,5,5,"Error loading $imgname",$tc); /* Output an errmsg */
  }
  return $im;
}

Nota: Desde que todo el soporte a GIFs ha sido eliminado en la libreria GD a partir de la versión 1.6, esta función no está disponible si está usando esa versión de la libreria GD.

Anterior | Inicio | Siguiente
ImageCreate | Subir | ImageDashedLine


ImageDashedLine

(PHP 3, PHP 4 >= 4.0.0)

ImageDashedLine -- Dibuja una línea discontinua

Descripción

int imagedashedline ( int im, int x1, int y1, int x2, int y2, int col)

ImageLine dibuja una línea discontinua desde x1,y1 hasta x2, y2 (arriba izquierda es 0.0) en la imagen im con el color col.

Vea también imageline().

Anterior | Inicio | Siguiente
ImageCreateFromGif | Subir | ImageDestroy


ImageDestroy

(PHP 3, PHP 4 >= 4.0.0)

ImageDestroy -- Destruye una imagen

Descripción

int imagedestroy ( int im)

ImageDestroy libera la memoria asociada a la imagen im. im es la imagen devuelta por la función imagecreate().

Anterior | Inicio | Siguiente
ImageDashedLine | Subir | ImageFill


ImageFill

(PHP 3, PHP 4 >= 4.0.0)

ImageFill -- Relleno

Descripción

int imagefill ( int im, int x, int y, int col)

ImageFill realiza un relleno empezando en la coordenada x,y (arriba izquierda es 0,0) con el color col en la imagen im.

Anterior | Inicio | Siguiente
ImageDestroy | Subir | ImageFilledPolygon


ImageFilledPolygon

(PHP 3, PHP 4 >= 4.0.0)

ImageFilledPolygon -- Dibuja un polígono relleno

Descripción

int imagefilledpolygon ( int im, array points, int num_points, int col)

ImageFilledPolygon crea un polígono relleno en la imagen im, points es una matriz PHP conteniendo los vértices del poligono, por ejemplo. points[0] = x0, points[1] = y0, points[2] = x1, points[3] = y1, etc. num_points es el número total de vértices.

Anterior | Inicio | Siguiente
ImageFill | Subir | ImageFilledRectangle


ImageFilledRectangle

(PHP 3, PHP 4 >= 4.0.0)

ImageFilledRectangle -- dibuja un rectángulo relleno

Descripción

int imagefilledrectangle ( int im, int x1, int y1, int x2, int y2, int col)

ImageFilledRectangle crea un rectángulo relleno con color col en la imagen im comenzando con las coordenadas superiores izquierdas x1, y1 y finalizando en las coordenadas inferiores derechas x2, y2. 0,0 es la esquina superior izquierda de la imagen.

Anterior | Inicio | Siguiente
ImageFilledPolygon | Subir | ImageFillToBorder


ImageFillToBorder

(PHP 3, PHP 4 >= 4.0.0)

ImageFillToBorder -- Relleno de un color especifico

Descripción

int imagefilltoborder ( int im, int x, int y, int border, int col)

ImageFillToBorder realiza un relleno hasta el color del borde que está definido por border. El punto de inicio para el relleno es x,y (arriba izquierda es 0,0) y la región se rellena con el color col.

Anterior | Inicio | Siguiente
ImageFilledRectangle | Subir | ImageFontHeight


ImageFontHeight

(PHP 3, PHP 4 >= 4.0.0)

ImageFontHeight -- Devuelve la altura de una fuente

Descripción

int imagefontheight ( int font)

Devuelve la altura en pixels de un carácter en un fuente específica.

Vea también imagefontwidth() y imageloadfont().

Anterior | Inicio | Siguiente
ImageFillToBorder | Subir | ImageFontWidth


ImageFontWidth

(PHP 3, PHP 4 >= 4.0.0)

ImageFontWidth -- Devuelve la anchura de una fuente

Descripción

int imagefontwidth ( int font)

Devuelve la anchura en pixels de un carácter en un fuente específica.

Vea también imagefontheight() y imageloadfont().

Anterior | Inicio | Siguiente
ImageFontHeight | Subir | ImageGif


ImageGif

(PHP 3, PHP 4 >= 4.0.0)

ImageGif -- Envía una imagen al navegador o a un fichero

Descripción

int imagegif ( int im, string filename)

imagegif() crea el fichero GIF en filename a partir de la imagen im. El parámetro im es el resultado de usar la función imagecreate().

El formato de la imagen será GIF87a a menos que la imagen se halla hecho transparente con imagecolortransparent(), en cuyo caso el formato de la imagen será GIF89a.

El parametro del nombre del fuichero es opcional, y si se deja en blanco, la imagen será mostrada directamente. Enviando un tipo de imagen/gif usando la función header(), puede crear un script PHP que muestre imagenes GIF directamente.

Nota: Desde que todo el soporte a GIFs ha sido eliminado en la libreria GD a partir de la versión 1.6, esta función no está disponible si está usando esa versión de la libreria GD.

Anterior | Inicio | Siguiente
ImageFontWidth | Subir | ImageInterlace


ImageInterlace

(PHP 3, PHP 4 >= 4.0.0)

ImageInterlace -- Activa o desactiva el entrelazado

Descripción

int imageinterlace ( int im [, int interlace])

ImageInterlace() activa o desactiva el bit de entrelazado. Si interlace es 1 la imagen im será entrelazada, y si interlace es 0 el bit de entrelazado se desactiva.

Esta función devuelve como ha cambiado el estado del bit de entralazado de la imagen.

Anterior | Inicio | Siguiente
ImageGif | Subir | ImageLine


ImageLine

(PHP 3, PHP 4 >= 4.0.0)

ImageLine -- Dibuja una línea

Descripción

int imageline ( int im, int x1, int y1, int x2, int y2, int col)

ImageLine dibuja una línea desde x1,y1 hasta x2,y2 (arriba izquierda es 0,0) en la imagen im con el color col.

Vea también imagecreate() y imagecolorallocate().

Anterior | Inicio | Siguiente
ImageInterlace | Subir | ImageLoadFont


ImageLoadFont

(PHP 3, PHP 4 >= 4.0.0)

ImageLoadFont -- Carga una fuente nueva

Descripción

int imageloadfont ( string file)

ImageLoadFont carga una fuente de bitmaps definida por el usuario y devuelve un identificador para esa fuente (que siempre es mayor de 5, de forma que no pueda entrar en conflicto con las fuentes predefinidas)..

El formato del fichero de la fuente es actualmente binario y dependiente de la arquitectura. Esto significa que tiene que generar los ficheros de las fuentes en el mismo tipo de CPU que la que tiene la máquina que está ejecutando PHP.

Tabla 1. Formato del fichero de fuentes

Posición en bytes | tipo de datos C | Descripción
byte 0-3 | int | número de carácteres en la fuente
byte 4-7 | int | valor del primer carácter de la fuente (normalmente 32 para el espacio)
byte 8-11 | int | Anchura en pixels de cada carácter
byte 12-15 | int | Altura en pixels de cada carácter
byte 16- | char | matriz con los datos del carácter, un byte por pixel en cada carácter, haciendo un total de (número carácteres* altura*anchura) bytes.

Vea también ImageFontWidth() y ImageFontHeight().

Anterior | Inicio | Siguiente
ImageLine | Subir | ImagePolygon


ImagePolygon

(PHP 3, PHP 4 >= 4.0.0)

ImagePolygon -- Dibuja un polígono

Descripción

int imagepolygon ( int im, array points, int num_points, int col)

ImagePolygon crea un polígono en la imagen id. points es un array PHP conteniendo los vértices del polígono. de la siguiente forma points[0] = x0, points1 = y0, points[2] = x1, points[3] = y1, etc. num_points es el número total de vértices.

Vea también imagecreate().

Anterior | Inicio | Siguiente
ImageLoadFont | Subir | ImagePSBBox


ImagePSBBox

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

ImagePSBBox -- Devuelve el borde que rodea un rectángulo de texto usando fuentes PostScript Type1

Descripción

array imagepsbbox ( string text, int font, int size, int space, int width, float angle)

size representa pixels.

space perimte cambiar el valor por defecto de un espacio en una fuentes. Este valor es añadido al valor normal y puede ser negativo.

tightness permite controlar la cantidad de espacio en blanco entre carácteres. Este valor se añade a la anchura normal del carácter y puede ser negativo.

angle viene dado en grados.

Los parámetros space y tightness vienen expresados en unidades de espacio de carácteres, donde una unidad es 1/1000 el borde de una M.

Los parámetros space, tightness y angle son opcionales.

El borde es calculado usando la información disponible de las métricas del carácter, y desafortunadamente tiende a diferir ligeramente de los resultados obtenidos de digitalizar el texto. Si el ángulo es de 0 grados, puede esperar que el texto necesite un pixel más en cada dirección.

Esta función devuelve un array conteniuendo los siguientes elementos:

0 | coordenada x inferior izquierda
1 | coordenada y inferior izquierda
2 | coordenada x superior derecha
3 | coordenada y superior derecha

Vea también imagepstext().

Anterior | Inicio | Siguiente
ImagePolygon | Subir | ImagePSCopyFont


ImagePSEncodeFont

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

ImagePSEncodeFont -- Cambia el vector de codificación de caracteres de una fuente

Descripción

int imagepsencodefont ( string encodingfile)

Carga un vector de codificación de caracteres desde un archivo y cambia el vector de codificación de las fuentes a él. Loads a character encoding vector from from a file and changes the fonts encoding vector to it. En las fuentes PostScript normalmente faltan muchos caracteres por encima de 127, seguramente quiera cambiar esto si emplea u idioma distinto del inglés.El formato exacto de este archivo está descrito en la documentación de T1libs. T1lib viene con dos archivos listos para usar, IsoLatin1.enc y IsoLatin2.enc.

Si se encuentra usando esta función todo el tiempo, una forma mucho mejor de definir la codificación es establecer ps.default_encoding en el archivo de configuración para que apunte al archivo de codificación correcto y todas las fuentes que cargue tendrán de forma automática la codificación correcta.

Anterior | Inicio | Siguiente
ImagePSCopyFont | Subir | ImagePSFreeFont


ImagePSFreeFont

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

ImagePSFreeFont -- Libera la memoria usada por un fuente PostScript Type 1

Descripción

void imagepsfreefont ( int fontindex)

Vea también imagepsloadfont().

Anterior | Inicio | Siguiente
ImagePSEncodeFont | Subir | ImagePSLoadFont


ImagePSLoadFont

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

ImagePSLoadFont -- Carga una fuente PostScript Type 1 desde un fichero

Descripción

int imagepsloadfont ( string filename)

En el caso de que todo vaya bien, tiene que devolver un índice de fuente correcto que puede ser usado para futuras operaciones. En caso contrario la función devuelve FALSE e imprime un mensaje describiendo donde ha fallado

Vea también imagepsfreefont().

Anterior | Inicio | Siguiente
ImagePSFreeFont | Subir | ImagePSText


ImagePSText

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

ImagePSText -- Para dibujar una cadena de texto sobre una imagen usando fuentes PostScript Type1

Descripción

array imagepstext ( int image, string text, int font, int size, int foreground, int background, int x, int y [, int space [, int tightness [, float angle [, int antialias_steps]]]])

size viene expresado en pixels.

foreground es el color en el cual el texto será pintado. background es el color en el que el texto tratará de resaltar con antialiaing. Los pixels con el color background no se pintan, de forma que la imagen de fondo no necesita ser de un color sólido.

Las coordenadas dadas por x, y definirán el origen (o punto de referencia) del primer carácter (la esquina superior izquierda del carácter). Esto es diferente de la función ImageString(), donde x, y definen la esquina superiro derecha del primer carácter. Consulte la documentación de PostScript sobre fuentes y su sistema de medidas si tiene algún problema entendiendo como funcion.

space permite cambiar el valor por defecto de un espacio en la fuente. Esta cantidad es sumada al valor normal y puede ser negativa.

tightness permite controlar la cantidad de espacio en blanco entre caracteres. Esta cantidad es sumada al valor normal y puede ser negativa.

angle viene en grados.

antialias_steps permite controlar el número de colores usados para el antialising del texto. Los valores permitidos son 4 y 16. El valor superior está recomendado para textos con tamaños inferiores a 20, donde el efecto en la calidad del texto es bastante visible. Con tamaños superiores use 4. Hace un menor uso de cálculo.

Parameters space y tightness están expresados en unidades de espacio de caracteres, donde 1 unidad es 1/1000 de una M mayúscula.

Los parámetros space, tightness, angle y antialias son opcionales.

Esta función devuelve una matriz conteniendo los siguientes elementos:

0 | coordenada x inferior izquierda
1 | coordenada y inferior izquierda
2 | coordenada x superior derecha
3 | coordenada y superior derecha

Vea también imagepsbbox().

Anterior | Inicio | Siguiente
ImagePSLoadFont | Subir | ImageRectangle


ImageRectangle

(PHP 3, PHP 4 >= 4.0.0)

ImageRectangle -- Dibuja un rectángulo

Descripción

int imagerectangle ( int im, int x1, int y1, int x2, int y2, int col)

ImageRectangle crea un rectángulo de color col en la imagen im comenzando en la coordenada superior izquierda x1,y1 y finalizando en la coordenada inferior derecha x2,y2. 0,0 es la esquina superior izquierda de la imagen.

Anterior | Inicio | Siguiente
ImagePSText | Subir | ImageSetPixel


ImageSetPixel

(PHP 3, PHP 4 >= 4.0.0)

ImageSetPixel -- Dibuja un pixel

Descripción

int imagesetpixel ( int im, int x, int y, int col)

ImageSetPixel dibuja un pixel x,y (arriba izquierda 0,0) en la imagen im con color col.

Vea también imagecreate() y imagecolorallocate().

Anterior | Inicio | Siguiente
ImageRectangle | Subir | ImageString


ImageString

(PHP 3, PHP 4 >= 4.0.0)

ImageString -- Dibuja una cadena de texto horizintalmente

Descripción

int imagestring ( int im, int font, int x, int y, string s, int col)

ImageString dibuja la cadena s en la imagen identificada por im en las coordenadas x,y (arriba izquierda es 0,0) en el color col. Si la fuente es 1, 2, 3, 4 o 5, se emplea una fuente interna.

Vea también imageloadfont().

Anterior | Inicio | Siguiente
ImageSetPixel | Subir | ImageStringUp


ImageStringUp

(PHP 3, PHP 4 >= 4.0.0)

ImageStringUp -- Dibuja una cadena de texto verticalmente

Descripción

int imagestringup ( int im, int font, int x, int y, string s, int col)

ImageStringUp dibuja la cadena s verticalmente en la imagen identificada por im en las coordenadas x,y (arriba izquierda es 0,0) en el color col. Si la fuente es 1, 2, 3, 4 o 5, se usa una fuente interna.

Vea también imageloadfont().

Anterior | Inicio | Siguiente
ImageString | Subir | ImageSX


ImageSX

(PHP 3, PHP 4 >= 4.0.0)

ImageSX -- Obtiene la anchura de la imagen

Descripción

int imagesx ( int im)

ImageSX devuelva la anchura de la imagen identificado por im.

Vea también imagecreate() y imagesy().

Anterior | Inicio | Siguiente
ImageStringUp | Subir | ImageSY


ImageSY

(PHP 3, PHP 4 >= 4.0.0)

ImageSY -- Obtiene la altura de la imagen

Descripción

int imagesy ( int im)

ImageSY devuelve la altura de la imagen identificada por im.

Vea también imagecreate() y imagesx().

Anterior | Inicio | Siguiente
ImageSX | Subir | ImageTTFBBox


ImageTTFBBox

(PHP 3>= 3.0.1, PHP 4 >= 4.0.0)

ImageTTFBBox -- Devuelve un caja que rodea al texto usando fuentes TypeType

Descripción

array ImageTTFBBox ( int size, int angle, string fontfile, string text)

Esta función calcula y devuelve un rectángulo en pixels que encierra un texto con TrueType.

text

La cadena que ha de ser medida.

size

El tamaño de la fuente.

fontfile

El nombre del archivo de fuente TrueType. (Puede ser también una URL.)

angle

Ángulo en grados en el text que va a ser medido.

ImageTTFBBox() devuelve una matriz con 8 elementos representando cuatro puntos que hacen una caja rodeando al texto:

0 | esquina inferior izquierda, posición X
1 | esquina inferior izquierda, posición Y
2 | esquina inferior derecha, posición X
3 | esquina inferior derecha, posición Y
4 | esquina superior derecha, posición X
5 | esquina superior derecha, posición Y
6 | esquina superior izquierda, posición X
7 | esquina superior izquierda, posición Y

Los puntos son relativos a text a pesar del ángulo, de forma que "superior izquierda" significa la esquina superior izquierda viendo el texto horizontalmente.

Esta función requiere tanto la libreria GD como la libreria Freetype.

Vea también ImageTTFText().

Anterior | Inicio | Siguiente
ImageSY | Subir | ImageTTFText


ImageTTFText

(PHP 3, PHP 4 >= 4.0.0)

ImageTTFText -- Escribe texto en la imagen usando fuentes TrueType

Descripción

array ImageTTFText ( int im, int size, int angle, int x, int y, int col, string fontfile, string text)

ImageTTFText escribe la cadenatext en la imagen identificada por im, comenzando en las coordenadas x,y (arriba izquierda es 0,0), con un ángulo de angle en el color col, usando el ficheor de fuente TrueType identificado por fontfile.

Las coordenadas dadas por x,y definirán el punto base del primer carácter. (la esquina inferior izquierda del carácter). Esto es diferente de la función ImageString(), donde x,y definen la esquina superior derecha del primer carácter.

El angle viene dado en grados, donde 0 grados representa el texto de izquierda a derecha (dirección las 3 en punto), y valores superiores representan una rotación en el sentido de las agujas de un reloj. (ej. un valor de 90 representaría un texto que fuese de abajo hacia arriba).

fontfile es la ruta hacia la fuente TrueType que desee usar.

text es la cadena de texto que puede incluir secuencias de caracteres UTF-8 (de la forma: &123; ) para acceder a caracteres de la fuente más allá de los primeros 255.

col es el índice de color. El uso de un índice de color negativo tiene el efecto de desactivar el antialiasing.

ImageTTFText() devuelve una matriz con 8 elementos representando cuatro puntos que hace una caja que cubre el texto.El orden de los puntos en arriba izquierda, arriba derecha, abajo derecha, abajo izquierda. Los puntos son relativos al texto a pesar del ángulo, por lo que "arriba izquierda" significa en la esquina superior izquierda cuando ve el texto horizontalmente.

Este script de ejemplo producirá un GIF negro de 400x30 pixels, con las palabras "Testing..." en blanco con la fuente Arial.

Ejemplo 1. ImageTTFText

<?php
Header("Content-type: image/gif");
$im = imagecreate(400,30);
$black = ImageColorAllocate($im, 0,0,0);
$white = ImageColorAllocate($im, 255,255,255);
ImageTTFText($im, 20, 0, 10, 20, $white, "/path/arial.ttf", "Testing... Omega: &#937;");
ImageGif($im);
ImageDestroy($im);
?>

Esta función requiere la libreria GD y la libreria FreeType.

Vea también ImageTTFBBox().

Anterior | Inicio | Siguiente
ImageTTFBBox | Subir | Funciones IMAP


Funciones IMAP

Manual de PHP
Anterior Siguiente

XLII. Funciones IMAP

Para hacer funcionar estas funciones, debe compilar PHP con --with-imap. Esto requiere que la libreria c-client esté instalada. Obtenga la última versión de ftp://ftp.cac.washington.edu/imap/ y compílela. Luego copie c-client/c-client.a al directorio /usr/local/lib o a cualquier otro directorio de su LINK path y copie c-client/rfc822.h, mail.h y linkage.h al directorio /usr/local/include o a cualquier otro de su INCLUDE path.

Decir que estas funciones no están limitadas al protocolo IMAP, a pesar de sus nombres. La librería subyacente c-client también soporta NNTP, POP3 y métodos de acceso local a buzones de correo. Vea imap_open() para una mayor información.

Tabla de contenidos
imap_8bit — Convierte una cadena de 8bit a una cadena quoted-printable
imap_alerts — Esta función devuelve todos los mensajes de alerta IMAP (si hubo) que han ocurrido durante la petición de la pagina o desde que la pila de alertas fue inicializada.
imap_append — Agrega una cadena de mensaje al buzón especificado
imap_base64 — Decodifica texto codificado en BASE64
imap_binary — Convierte una cadena de 8bit a una cadena base64
imap_body — Lee el cuerpo del mensaje
imap_check — Comprueba el estado del buzón actual
imap_clearflag_full — Limpia los flags de los mensajes
imap_close — Cierra una sesión IMAP
imap_createmailbox — Crea un buzón nuevo
imap_delete — Marca un mensaje para ser borrado en el buzón actual
imap_deletemailbox — Elimina un buzón
imap_errors — Esta función devuelve todos los errores IMAP (si hubo) que han occurrido durante la petición de la página o desde que la pila de errores se inicializó.
imap_expunge — Elimina todos los mensajes marcados como borrados
imap_fetchbody — Localiza una sección particular en el cuerpo del mensaje
imap_fetchheader — Devuelve la cabecera del mensaje
imap_fetchstructure — Lee la estructuta de un mensaje concreto
imap_getmailboxes — Lee la lista de buzones, devolviendo informacón detallada de cada uno
imap_getsubscribed — Lista todos los buzones subscritos
imap_header — Lee la cabecera del mensaje
imap_headers — Returns headers for all messages in a mailbox
imap_last_error — Esta función devuelve el último error IMAP (si se produjo) que ocurrió durante la petición de esta página.
imap_listmailbox — Lee la lista de buzones
imap_listsubscribed — Lista todos los buzones subscritos
imap_mail_copy — Copia los mensajes especificados a un buzón
imap_mail_move — Mueve los mensajes especificados a un buzón
imap_mailboxmsginfo — Obtiene información acerca del buzón actual
imap_msgno — Esta función devuelve el número de secuencia del mensaje para el UID dado.
imap_num_msg — Informa del número de mensajes en el buzón actual
imap_num_recent — Informa el número de mensajes recientes en el buzón actual
imap_open — Abre una sesión IMAP
imap_ping — Comprueba si la sesión IMAP está aún activa
imap_qprint — Convierte una cadena quoted-printable a una cadena de 8 bit
imap_renamemailbox — Renombra un buzón
imap_reopen — Reabre una sesión IMAP a un nuevo buzón
imap_rfc822_parse_adrlist — Examina la cadena dirección
imap_rfc822_write_address — Devuleve una dirección de correo correctamente formateada dado el buzón, host, e información personal.
imap_scanmailbox — Lee la lista de buzones y toma una cadena para buscar en el texto del buzón
imap_search — Esta función devuelve un array de mensajes que coinciden con el criterio de busqueda dado.
imap_setflag_full — Activa flags en los mensajes
imap_sort — Ordena un array de cabeceras de mensajes
imap_status — Esta función devuelve el información de estado de otro buzón distinto al actual.
imap_subscribe — Subscribe to a mailbox
imap_uid — Esta función devuelve el UID del número de secuencia del mensaje dado
imap_undelete — Desmarca los mensajes que están marcados como borrados
imap_unsubscribe — Unsubscribe from a mailbox

Anterior | Inicio | Siguiente
ImageTTFText | Subir | imap_8bit


imap_append

(PHP 3, PHP 4 >= 4.0.0)

imap_append -- Agrega una cadena de mensaje al buzón especificado

Descripción

int imap_append ( int imap_stream, string mbox, string message, string flags)

Devuelve TRUE si no hay error y FALSE en caso contrario.

imap_append() agrega una cadena de mensaje al buzón especificado mbox. Si se especifica el parámetro flags, escribe las opciones o condiciones establecidas en el parámetro flags al buzón.

Cuando conecte con el servidor Cyrus IMAP, debe usar "\r\n" como finalizador de linea en vez de "\n" o la operación fallará.

Anterior | Inicio | Siguiente
imap_alerts | Subir | imap_base64


imap_base64

(PHP 3, PHP 4 >= 4.0.0)

imap_base64 -- Decodifica texto codificado en BASE64

Descripción

string imap_base64 ( string text)

imap_base64() decodifica texto codificado en BASE-64. El mensaje decodificado es devuelto como una cadena.

Anterior | Inicio | Siguiente
imap_append | Subir | imap_binary


imap_body

(PHP 3, PHP 4 >= 4.0.0)

imap_body -- Lee el cuerpo del mensaje

Descripción

string imap_body ( int imap_stream, int msg_number, int flags)

imap_body() devuelve el cuerpo del mensaje, numerado msg_number del buzón actual. Los flags opcionales son una máscara de bit con una o mas de las siguientes:

  • FT_UID - El msgno es un UID

  • FT_PEEK - No activar \Seen flag si no está ya activa

  • FT_INTERNAL - La cadena devuelta está en formato interno, no canoniza a CRLF.

Anterior | Inicio | Siguiente
imap_binary | Subir | imap_check


imap_check

(PHP 3, PHP 4 >= 4.0.0)

imap_check -- Comprueba el estado del buzón actual

Descripción

object imap_check ( int imap_stream)

Devuelve información acerca del buzón actual. Devuelve FALSE si falla.

La función imap_check() comprueba el estado del buzón actual en el servidor y devuelve la información en un objeto con las siguientes propiedades.

Date : fecha del mensaje
Driver : controlador
Mailbox : nombre del buzón
Nmsgs : número de mensajes
Recent : número de mensajes recientes

Anterior | Inicio | Siguiente
imap_body | Subir | imap_clearflag_full


imap_close

(PHP 3, PHP 4 >= 4.0.0)

imap_close -- Cierra una sesión IMAP

Descripción

int imap_close ( int imap_stream, int flags)

Cierra una sesión imap. Toma un parámetro flag opcional, CL_EXPUNGE, el cual purgará el buzón de forma trasparente antes de cerrarla.

Anterior | Inicio | Siguiente
imap_clearflag_full | Subir | imap_createmailbox


imap_createmailbox

(PHP 3, PHP 4 >= 4.0.0)

imap_createmailbox -- Crea un buzón nuevo

Descripción

int imap_createmailbox ( int imap_stream, string mbox)

imap_createmailbox() crea un buzón nuevo especificado por mbox (ver imap_open() para el formato del parámetro mbox).

Devuelve TRUE si no hay error y FALSE en caso contrario.

Ver También imap_renamemailbox() y imap_deletemailbox().

Anterior | Inicio | Siguiente
imap_close | Subir | imap_delete


imap_delete

(PHP 3, PHP 4 >= 4.0.0)

imap_delete -- Marca un mensaje para ser borrado en el buzón actual

Descripción

int imap_delete ( int imap_stream, int msg_number)

Devuelve TRUE.

La función imap_delete() marca el mensaje referenciado por msg_number para su eliminación. El borrado físico de los mensajes es realizado por imap_expunge().

Anterior | Inicio | Siguiente
imap_createmailbox | Subir | imap_deletemailbox


imap_deletemailbox

(PHP 3, PHP 4 >= 4.0.0)

imap_deletemailbox -- Elimina un buzón

Descripción

int imap_deletemailbox ( int imap_stream, string mbox)

imap_deletemailbox() elimina el buzón especificado (ver imap_open() para el formato del mbox).

Devuelve TRUE si no hay error y FALSE en caso contrario.

Ver También imap_createmailbox() y imap_reanmemailbox().

Anterior | Inicio | Siguiente
imap_delete | Subir | imap_errors


imap_expunge

(PHP 3, PHP 4 >= 4.0.0)

imap_expunge -- Elimina todos los mensajes marcados como borrados

Descripción

int imap_expunge ( int imap_stream)

imap_expunge() elimina todos los mensajes marcados por la función imap_delete().

Devuleve TRUE.

Anterior | Inicio | Siguiente
imap_errors | Subir | imap_fetchbody


imap_fetchbody

(PHP 3, PHP 4 >= 4.0.0)

imap_fetchbody -- Localiza una sección particular en el cuerpo del mensaje

Descripción

string imap_fetchbody ( int imap_stream, int msg_number, string part_number, flags flags)

Esta función busca una sección particular en el cuerpo de los mensajes especificados, como una cadena de texto y devuleve esa cadena. La especificación de la sección es una cadena de enteros delimitados por comas,los cuales indexan las partes del cuerpo como indica la especificación IMAP4. Partes del cuerpo no son decodificadas por esta función.

Las opciones para imap_fetchbody () son una máscara de bit con una o más de las siguientes

  • FT_UID - El msgono es un UID

  • FT_PEEK - No activar \Seen flag si no esta ya activa

  • FT_INTERNAL - La cadena devuelta está en formato "interno", sin ningún intento por canonizar CRLF

Anterior | Inicio | Siguiente
imap_expunge | Subir | imap_fetchheader


imap_fetchstructure

(PHP 3, PHP 4 >= 4.0.0)

imap_fetchstructure -- Lee la estructuta de un mensaje concreto

Descripción

object imap_fetchstructure ( int imap_stream, int msg_number [, int flags])

Esta función busca toda la información estructurada en el mensaje especificado. El parámetro opcional flags sólo tiene una opcion, FT_UID, la cual indica a la función que trate el argumento msg_number como un UID. El objeto devuelto incluye el sobre, la fecha interna, el tama¤o, flags y la estructura del cuerpo con un objeto similar por cada mime adjunto al mensaje. La estructura de los objetos devueltos es como sigue:

Tabla 1. Objetos Devueltos para imap_fetchstructure()

type | Tipo primario del cuerpo
encoding | Body transfer encoding
ifsubtype | TRUE si hay una cadena de subtipo
subtype | MIME subtype
ifDescripción | TRUE si hay una cadena de Descripción
Description | Conenido de la cadena de Descripción
ifid | TRUE si hay una cadena de identificación
id | Cadena de Identificación
lines | Número de lineas
bytes | Número de bytes
ifdisposition | TRUE si hay una cadena de configuración
disposition | Cadena de configuración
ifdparameters | TRUE si el array dparameters existe
dparameters [a] | Array de parametro de configuración
ifparameters | TRUE si el array de parámetros existe
parameters [b] | MIME parameters array
parts [c] | Array de objetos describiendo cada parte del mensaje
Notas: a. dparameters es un array de objetos donde cada objeto tiene un "atributo" y una propiedad "valor". b. parameter es un array de objetos donde cada objetor tiene un "atributo" y una propiedad "valor". c. parts es un array de objetos identico en estructura al objeto del primer nivel, con la limitación de que este no puede contener más objetos 'parts'.

Tabla 2. Tipo primario del cuerpo

0 | texto
1 | multiparte
2 | mensaje
3 | aplicación
4 | audio
5 | imagen
6 | video
7 | otro

Tabla 3. Codificacion para tranferencia

0 | 7BIT
1 | 8BIT
2 | BINARY
3 | BASE64
4 | QUOTED-PRINTABLE
5 | OTRO

Anterior | Inicio | Siguiente
imap_fetchheader | Subir | imap_getmailboxes


imap_header

(PHP 3, PHP 4 >= 4.0.0)

imap_header -- Lee la cabecera del mensaje

Descripción

object imap_header ( int imap_stream, int msg_number [, int fromlength [, int subjectlength [, string defaulthost]]])

Esta función devuelve un objeto con varios elementos de la cabecera.

remail, date, Date, subject, Subject, in_reply_to, message_id,
newsgroups, followup_to, references

message flags:
Recent - 'R' si es reciente y ha sido leido,
'N' si es reciente y no ha sido leido,
' ' si no es reciente
Unseen - 'U' si no ha sido leido Y no es reciente,
' ' si ha sido leido O no y es reciente
Answered -'A' si ha sido contestado,
' ' si no ha sido contestado
Deleted - 'D' si ha sido borrado,
' ' si no ha sido borrado
Draft - 'X' if draft,
' ' if not draft
Flagged - 'F' si esta if flagged,
' ' if not flagged

OBSERVE que el comportamiento Recent/Unseen es un poco extra¤o. Si quiere conocer
si un mensaje es Unseen, debe comprobarlo asi

Unseen == 'U' || Recent == 'N'

toaddress (la linea to: al completo, hasta 1024 caracteres)

to[] (devuelve un array de objetos a partir de la linea To, conteniendo:)
personal
adl
mailbox
host

fromaddress (la linea from: al completo, hasta 1024 caracteres)

from[] (devuelve un array de objetos a partir de la linea From, conteniendo:)
personal
adl
mailbox
host

ccaddress (la linea cc: al completo, hasta 1024 caracteres)
cc[] (devuelve un array de objetos a partir de la linea Cc:, conteniendo:)
personal
adl
mailbox
host

bccaddress (la linea bcc al completo, hasta 1024 caracteres)
bcc[] (devuelve un array de objetos a partir de la linea Bcc, conteniendo:)
personal
adl
mailbox
host

reply_toaddress (la linea reply_to: al completo, hasta 1024 caracteres)
reply_to[] (devuelve un array de objetos a partir de la linea Reply_to,
conteniendo:)
personal
adl
mailbox
host

senderaddress (la linea sender: al completo, hasta 1024 caracteres)
sender[] (devuelve un array de objetos a partir de la linea sender, conteniendo:)
personal
adl
mailbox
host

return_path (la linea return-path: al completo, hasta 1024 caracteres)
return_path[] (devuelve un array de objetos a partir de la linea return_path,
conteniendo:)
personal
adl
mailbox
host

udate (fecha del mensaje en formato unix)

fetchfrom (la linea from formateada hasta ajustarse a los caracteres
indicados en fromlength)

fetchsubject (la linea subject formateada hasta ajustarse a los caracteres
indicados en subjectlength)

Anterior | Inicio | Siguiente
imap_getsubscribed | Subir | imap_headers


imap_headers

(PHP 3, PHP 4 >= 4.0.0)

imap_headers -- Returns headers for all messages in a mailbox

Descripción

array imap_headers ( int imap_stream)

Devuelve un array de cadenas formateadas con informacion de la cabecera. Un elemento por mensaje de correo.

Anterior | Inicio | Siguiente
imap_header | Subir | imap_last_error


imap_listmailbox

(PHP 3, PHP 4 >= 4.0.0)

imap_listmailbox -- Lee la lista de buzones

Descripción

array imap_listmailbox ( int imap_stream, string ref, string pat)

Devuelve un array que contiene los nombres de los buzones.

Anterior | Inicio | Siguiente
imap_last_error | Subir | imap_listsubscribed


imap_getmailboxes

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

imap_getmailboxes -- Lee la lista de buzones, devolviendo informacón detallada de cada uno

Descripción

array imap_getmailboxes ( int imap_stream, string ref, string pat)

Devuelve un array de objetos coneniendo información del buzón. Cada objeto tiene los atributos name, especificando el nombre completo del buzón; delimiter, que es el delimitador jerárquico para la parte de la jerarquía dónde está este buzón; y attributes. Attributes es una máscara de bits contra la que se puede probar:

  • LATT_NOINFERIORS - Este buzón no tiene "hijos" (No ha buzones por debajo de él)

  • LATT_NOSELECT - Esto es sólo un contenedor, no un buzón - No puede abrirlo.

  • LATT_MARKED - Este buzón está marcado. Unicamente usado por UW-IMAPD.

  • LATT_UNMARKED - Este buzón no está marcado. Unicamente usado por UW-IMAPD.

ref normalmente debería ser solo el servidor IMAP, de la forma: {imap_server:imap_port}, y pattern especifica, dónde en la estructura jerárquica del buzón, para comenzar a buscar. Si quiere todo los buzones, pase el parámetro pattern como una cadena vacía.

Hay dos caracteres especiales que puede pasar como parte del parámetro pattern: '*' and '%'. '*' significa que devuelva todos los buzones. Si pasa el parámetro pattern como '*', obtendrá una lista con la jerarquía completa del buzón. %' significa que devuelva sólo el nivel actual. Pasar '%' en el parámetro pattern devolverá sólo el nivel más alto de los buzones; '~/mail/%' en UW_IMAPD devolverá cada buzón del directorio ~/mail, pero ninguno de los subdirectorios de ese directorio.

Anterior | Inicio | Siguiente
imap_fetchstructure | Subir | imap_getsubscribed


imap_listsubscribed

(PHP 3, PHP 4 >= 4.0.0)

imap_listsubscribed -- Lista todos los buzones subscritos

Descripción

array imap_listsubscribed ( int imap_stream, string ref, string pattern)

Devuelve un array de todos los buzones que usted tiene subscritos. Los parámetros ref y pattern especifican la localización desde donde comenzará a buscar y el patrón que el nombre del buzón debe encontrar.

Anterior | Inicio | Siguiente
imap_listmailbox | Subir | imap_mail_copy


imap_getsubscribed

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

imap_getsubscribed -- Lista todos los buzones subscritos

Descripción

array imap_getsubscribed ( int imap_stream, string ref, string pattern)

Esta función es idéntica a imap_getmailboxes(), excepto que esta sólo devuelve los buzones a los que está subscrito el usuario.

Anterior | Inicio | Siguiente
imap_getmailboxes | Subir | imap_header


imap_mail_copy

(PHP 3, PHP 4 >= 4.0.0)

imap_mail_copy -- Copia los mensajes especificados a un buzón

Descripción

int imap_mail_copy ( int imap_stream, string msglist, string mbox, int flags)

Devuelve TRUE si no hay error y FALSE en caso contrario.

Copia los mensajes especificados por msglist a un buzón especificado. msglist es un rango no números de mensajes.

Flags es una máscara de bit de uno o más

  • CP_UID - los números de secuencia contienen UIDS

  • CP_MOVE - Elimina los mensajes del buzon actual despues de copiarlos

Anterior | Inicio | Siguiente
imap_listsubscribed | Subir | imap_mail_move


imap_mail_move

(PHP 3, PHP 4 >= 4.0.0)

imap_mail_move -- Mueve los mensajes especificados a un buzón

Descripción

int imap_mail_move ( int imap_stream, string msglist, string mbox)

Mueve los mensajes especificados por msglist al buzón especicifado. msglist es un rango no números de mensajes.

Devuelve TRUE si no hay error y FALSE en caso contrario.

Anterior | Inicio | Siguiente
imap_mail_copy | Subir | imap_mailboxmsginfo


imap_num_msg

(PHP 3, PHP 4 >= 4.0.0)

imap_num_msg -- Informa del número de mensajes en el buzón actual

Descripción

int imap_num_msg ( int imap_stream)

Devuelve el número de mensajes en el buzón actual.

Anterior | Inicio | Siguiente
imap_msgno | Subir | imap_num_recent


imap_num_recent

(PHP 3, PHP 4 >= 4.0.0)

imap_num_recent -- Informa el número de mensajes recientes en el buzón actual

Descripción

int imap_num_recent ( int imap_stream)

Devuleve el número de mensajes recientes en el buzón actual.

Anterior | Inicio | Siguiente
imap_num_msg | Subir | imap_open


imap_open

(PHP 3, PHP 4 >= 4.0.0)

imap_open -- Abre una sesión IMAP

Descripción

int imap_open ( string mailbox, string username, string password, int flags)

Devuleve la sesion IMAP si no hay error y FALSE en caso contrario. Esta función también puede ser usada para abrir sesiones con servidores POP3 y NNTP. Para conectarse a un servidor IMAP escuchando por el puerto 143 en una máquina local, haga lo siguiente:

$mbox = imap_open("{localhost:143}INBOX","user_id","password");

Para conectarse a un servidor POP3 escuchando por el puerto 110, use:

$mbox = imap_open("{localhost/pop3:110}INBOX","user_id","password");

Para conectarse a un servidor NNTP escuchando por el puerto 119, use:

$nntp = imap_open("{localhost/nntp:119}comp.test","","");

Para conectarse a un servidor remoto sustituya "localhost", por el nombre o dirección IP del servidor al cual quiere conectarse.

Las opciones son una máscara de bit con una o más de los siguientes:

  • OP_READONLY - Abre el buzón en modo de sólo lectura

  • OP_ANONYMOUS - No usa o actualiza un .newsrc para las noticias

  • OP_HALFOPEN - Para nombres IMAP y NNTP, abre una conexión pero no abre un buzón

  • CL_EXPUNGE - Purga automaticamente el buzón antes de cerrar la sesión

Anterior | Inicio | Siguiente
imap_num_recent | Subir | imap_ping


imap_ping

(PHP 3, PHP 4 >= 4.0.0)

imap_ping -- Comprueba si la sesión IMAP está aún activa

Descripción

int imap_ping ( int imap_stream)

Devuelve TRUE si la sesión está activa, FALSE en caso contrario.

La función imap_ping() pings the stream to see it is still active. Esto puede descubrir que hay correo nuevo; este es el método preferido para hacer una comprobación periodica del buzón, asi como para mantener activa sesiones en servidores que tienen inactivity timeout.

Anterior | Inicio | Siguiente
imap_open | Subir | imap_qprint


imap_renamemailbox

(PHP 3, PHP 4 >= 4.0.0)

imap_renamemailbox -- Renombra un buzón

Descripción

int imap_renamemailbox ( int imap_stream, string old_mbox, string new_mbox)

Esta función renombra un buzon (ver imap_open() para el formato del parámetro mbox).

Devuelve TRUE si no hay error y FALSE en caso contrario.

Ver También imap_createmailbox() and imap_deletemailbox().

Anterior | Inicio | Siguiente
imap_qprint | Subir | imap_reopen


imap_reopen

(PHP 3, PHP 4 >= 4.0.0)

imap_reopen -- Reabre una sesión IMAP a un nuevo buzón

Descripción

int imap_reopen ( string imap_stream, string mailbox [, string flags])

Devuelve TRUE si no hay error y FALSE en caso contrario.

Esta funció reabre la sesión especificada con un nuevo buzón.

Las opciones son máscaras de bit con una o más de las siguientes:

  • OP_READONLY - Abre el buzón en modo de sólo lectura

  • OP_ANONYMOUS - No usa o actualiza .newsrc para noticias

  • OP_HALFOPEN - Para nombres IMAP y NNTP, abre una conexión pero no abre el buzon.

  • CL_EXPUNGE - Expurga automaticamente el buzon antes de cerra la sesión

Anterior | Inicio | Siguiente
imap_renamemailbox | Subir | imap_rfc822_parse_adrlist


imap_subscribe

(PHP 3, PHP 4 >= 4.0.0)

imap_subscribe -- Subscribe to a mailbox

Descripción

int imap_subscribe ( int imap_stream, string mbox)

Da de alta un nuevo buzón.

Devuleve TRUE si no hay error y FALSE en caso contrario.

Anterior | Inicio | Siguiente
imap_status | Subir | imap_uid


imap_undelete

(PHP 3, PHP 4 >= 4.0.0)

imap_undelete -- Desmarca los mensajes que están marcados como borrados

Descripción

int imap_undelete ( int imap_stream, int msg_number)

Esta funcion elimina la marca de borrado de un mensaje especifico, puesta por la función imap_delete().

Devuleve TRUE si no hay error y FALSE en caso contrario.

Anterior | Inicio | Siguiente
imap_uid | Subir | imap_unsubscribe


imap_unsubscribe

(PHP 3, PHP 4 >= 4.0.0)

imap_unsubscribe -- Unsubscribe from a mailbox

Descripción

int imap_unsubscribe ( int imap_stream, string mbox)

Da de baja el buzón especificado.

Devuelve TRUE si no hay error y FALSE en caso contrario.

Anterior | Inicio | Siguiente
imap_undelete | Subir | Funciones para Informix


imap_qprint

(PHP 3, PHP 4 >= 4.0.0)

imap_qprint -- Convierte una cadena quoted-printable a una cadena de 8 bit

Descripción

string imap_qprint ( string string)

Convierte una cadena quoted-printable a una cadena de 8 bit

Devuelve una cadena de 8 bit (binary)

Anterior | Inicio | Siguiente
imap_ping | Subir | imap_renamemailbox


imap_8bit

(PHP 3, PHP 4 >= 4.0.0)

imap_8bit -- Convierte una cadena de 8bit a una cadena quoted-printable

Descripción

string imap_8bit ( string string)

Convierte una cadena de 8bit a una cadena quoted-printable.

Devuelve una cadena quoted-printable

Anterior | Inicio | Siguiente
Funciones IMAP | Subir | imap_alerts


imap_binary

(PHP 3>= 3.0.2, PHP 4 >= 4.0.0)

imap_binary -- Convierte una cadena de 8bit a una cadena base64

Descripción

string imap_binary ( string string)

Convierte una cadena de 8bit a una cadena base64.

Devuleve una cadena base64.

Anterior | Inicio | Siguiente
imap_base64 | Subir | imap_body


imap_scanmailbox

(PHP 3, PHP 4 >= 4.0.0)

imap_scanmailbox -- Lee la lista de buzones y toma una cadena para buscar en el texto del buzón

Descripción

array imap_scanmailbox ( int imap_stream, string string)

Devuelve un array que contiene los nombres de los buzones que tienen el parámetro string en el texto del buzón.

Anterior | Inicio | Siguiente
imap_rfc822_write_address | Subir | imap_search


imap_mailboxmsginfo

(PHP 3>= 3.0.2, PHP 4 >= 4.0.0)

imap_mailboxmsginfo -- Obtiene información acerca del buzón actual

Descripción

object imap_mailboxmsginfo ( int imap_stream)

Devuelve información acerca del buzón actual. Devuelve FALSE en caso de fallo.

La función imap_mailboxmsginfo() comprueba el estado del buzón actual en el servidor y devuelve la información en un objeto con las siguientes propiedades.

Date : fecha del mensaje
Driver : driver
Mailbox : nombre del buzón
Nmsgs : número de mensajes
Recent : número de los mensajes recientes
Unread : número de los mensajes no leidos
Size : tama¤o del buzon

Anterior | Inicio | Siguiente
imap_mail_move | Subir | imap_msgno


imap_rfc822_write_address

(PHP 3>= 3.0.2, PHP 4 >= 4.0.0)

imap_rfc822_write_address -- Devuleve una dirección de correo correctamente formateada dado el buzón, host, e información personal.

Descripción

string imap_rfc822_write_address ( string mailbox, string host, string personal)

Devuelve una dirección de correo correctamente formateada, dado el buzón, host, e información personal.

Anterior | Inicio | Siguiente
imap_rfc822_parse_adrlist | Subir | imap_scanmailbox


imap_rfc822_parse_adrlist

(PHP 3>= 3.0.2, PHP 4 >= 4.0.0)

imap_rfc822_parse_adrlist -- Examina la cadena dirección

Descripción

string imap_rfc822_parse_adrlist ( string address, string default_host)

Esta función examina la cadena dirección y para cada dirección, devuelve un array de objetos. Los 4 objetos son:

mailbox - el nombre del buzón (username)
host - el nombre del ordenador
personal - el nombre personal
adl - ruta del dominio

Anterior | Inicio | Siguiente
imap_reopen | Subir | imap_rfc822_write_address


imap_setflag_full

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

imap_setflag_full -- Activa flags en los mensajes

Descripción

string imap_setflag_full ( int stream, string sequence, string flag, string options)

Esta función a¤ade el flag especificado al conjunto de flags activos para los mensajes en la secuencia especificada.

Los flags que puede seleccionar son "\\Seen", "\\Answered", "\\Flagged", "\\Deleted", "\\Draft", y "\\Recent" ( definidos en el RFC2060)

Las opciones son una máscara de bit con uno o más de los siguientes:

ST_UID El argumento sequence contiene UIDs en vez de
números secuenciales

Anterior | Inicio | Siguiente
imap_search | Subir | imap_sort


imap_clearflag_full

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

imap_clearflag_full -- Limpia los flags de los mensajes

Descripción

string imap_clearflag_full ( int stream, string sequence, string flag, string options)

Esta funcion elimina el flag especificado del conjunto de flags activos para los mensajes en la secuencia especificada.

Las opciones son una máscara de bit con uno o más de los siguientes:

ST_UID El argumento sequence contiene UIDs en vez de
números secuenciales

Anterior | Inicio | Siguiente
imap_check | Subir | imap_close


imap_sort

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

imap_sort -- Ordena un array de cabeceras de mensajes

Descripción

string imap_sort ( int stream, int criteria, int reverse, int options)

Devuelve un array de números de mensajes ordenados por los parametros dados

Rev es 1 para una ordenación inversa.

Criteria puede ser uno (y sólo uno) de los siguientes:

SORTDATE Fecha del mensaje
SORTARRIVAL Fecha de llegada
SORTFROM mailbox in first From address
SORTSUBJECT Asunto del mensaje
SORTTO mailbox in first To address
SORTCC mailbox in first cc address
SORTSIZE tama¤o del mensaje en bytes

Las opciones son una máscara de bit con uno o más de los siguientes:

SE_UID Devuelve UIDs en vez de números secuenciales
SE_NOPREFETCH No preselecciona los mensajes buscados.

Anterior | Inicio | Siguiente
imap_setflag_full | Subir | imap_status


imap_fetchheader

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

imap_fetchheader -- Devuelve la cabecera del mensaje

Descripción

string imap_fetchheader ( int imap_stream, int msgno, int flags)

Esta función localiza el formato de la cabecera RFC 822 del mensaje especificado como una cadena de texto y devuelve esa cadena de texto.

The options are:

FT_UID El argumento msgno es un UID
FT_INTERNAL La cadena devuelta esta en formato "interno",
sin ningún intento de canonizar CRLF

FT_PREFETCHTEXT The RFC822.TEXT should be pre-fetched at the
same time. Esto evita un extra RTT en una
conexión IMAP si se desea un mensaje completo de
texto (e.g. en una operación de
"guardar a un fichero local")

Anterior | Inicio | Siguiente
imap_fetchbody | Subir | imap_fetchstructure


imap_uid

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

imap_uid -- Esta función devuelve el UID del número de secuencia del mensaje dado

Descripción

int imap_uid ( int imap_stream, int msgno)

Esta función devuelve el UID del número de secuencia del mensaje dado. Esta función es la inversa a imap_msgno().

Anterior | Inicio | Siguiente
imap_subscribe | Subir | imap_undelete


imap_msgno

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

imap_msgno -- Esta función devuelve el número de secuencia del mensaje para el UID dado.

Descripción

int imap_msgno ( int imap_stream, int uid)

Esta función devuelve el número de secuencia del mensaje para el UID dado. Esta función es la inversa a imap_uid().

Anterior | Inicio | Siguiente
imap_mailboxmsginfo | Subir | imap_num_msg


imap_search

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

imap_search -- Esta función devuelve un array de mensajes que coinciden con el criterio de busqueda dado.

Descripción

array imap_search ( int imap_stream, string criteria, int flags)

Esta función realiza una busqueda en el buzón actualmente abierto indicado por imap_stream. criteria es una cadena, delimitada por espacios, en la cual las siguientes palabras claves son permitidas. Cualquier argumento múltiple (ej. FROM "joey smith") debe estar entre comillas.

  • ALL - devuelve todos los mensajes que coinciden con el resto del criterio

  • ANSWERED - busca mensajes con el flag \\ANSWERED activado

  • BCC "string" - busca mensajes con "cadena" en el campo Bcc:

  • BEFORE "date" - busca mensajes con Date: antes de "date"

  • BODY "string" - busca mensajes con "cadena" en el cuerpo del mensaje

  • CC "string" - busca mensajes con "cadena" en el campo Cc:

  • DELETED - busca mensajes eliminados

  • FLAGGED - busca mensajes con el flag \\FLAGGED (sometimes referred to as Important or Urgent) activado

  • FROM "string" - busca mensajes con "cadena" en el campo From:

  • KEYWORD "string" - busca mensajes con "cadena" como una palabra clave

  • NEW - busca mensajes nuevos

  • OLD - busca mensajes viejos

  • ON "date" - busca mensajes con "date" igual a Date:

  • RECENT - busca mensajes con el flag \\RECENT activado

  • SEEN - busca mensajes que han sido leidos (la opcion \\SEEN activada)

  • SINCE "date" - busca mensajes conwith Date: after "date"

  • SUBJECT "string" - busca mensajes con "string" en el campo Subject:

  • TEXT "string" - busca mensajes con el texto "string"

  • TO "string" - busca mensajes con "string" en el campo To:

  • UNANSWERED - busca mensajes que no han sido respondidos

  • UNDELETED - busca mensajes que no han sido eliminados

  • UNFLAGGED - busca mensajes que no estan flagged

  • UNKEYWORD "string" - busca mensajes que no coinciden con la palabra clave "string"

  • UNSEEN - busca mensajes que no han sido leidos aún

Por ejemplo, para buscar todos los mensajes no contestados enviados por Mamá, usaría: "UNANSWERED FROM mamá". La busqueda parece ser no sensitiva. Esta lista de criterios está tomada del codigo fuente del UW c-client y puede que este incompleta o sea inexacta.

Valores validos para los flags son SE_UID, que provoca que el array devuelto contenga UIDs en vez de los numeros de secuencia de los mensajes

Anterior | Inicio | Siguiente
imap_scanmailbox | Subir | imap_setflag_full


imap_last_error

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

imap_last_error -- Esta función devuelve el último error IMAP (si se produjo) que ocurrió durante la petición de esta página.

Descripción

string imap_last_error ( void)

Esta función devuelve el texto completo del último error IMAP que ocurrió en la pagina actual. La plia de errores The error stack is untouched; llamando despues a la función imap_last_error(), sin que se produzca un error, devolverá el mismo error.

ATENCIàN: esta función no esta disponible aún en PHP4.

Anterior | Inicio | Siguiente
imap_headers | Subir | imap_listmailbox


imap_errors

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

imap_errors -- Esta función devuelve todos los errores IMAP (si hubo) que han occurrido durante la petición de la página o desde que la pila de errores se inicializó.

Descripción

array imap_errors ( void)

Esta función devuelve un array de todos los mensajes de error IMAP generados desde la última llamada a imap_errors(), o el principio de la página. Cuando se llama a imap_errors(), la pila de errores se inicializa.

ATENCIàN: esta función no esta disponible aún en PHP4.

Anterior | Inicio | Siguiente
imap_deletemailbox | Subir | imap_expunge


imap_alerts

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

imap_alerts -- Esta función devuelve todos los mensajes de alerta IMAP (si hubo) que han ocurrido durante la petición de la pagina o desde que la pila de alertas fue inicializada.

Descripción

array imap_alerts ( void)

Esta función devuelve un array con todos los mensajes de alerta IMAP generados desde la última llamada a imap_alerts(), o el comienzo de la pagina. Cuando se llama a imap_alerts(), la pila de alerta es inicializada. La especificación IMAP requiere que estos mensajes sean pasados al usuario.

Anterior | Inicio | Siguiente
imap_8bit | Subir | imap_append


imap_status

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

imap_status -- Esta función devuelve el información de estado de otro buzón distinto al actual.

Descripción

object imap_status ( int imap_stream, string mailbox, int options)

Esta función devuelve un objeto que contiene información de estado. Las opciones válidas son:

  • SA_MESSAGES - activa status->messages con el número de mensajes en el buzon

  • SA_RECENT - activa status->recent con el número de mensajes recientes en el buzón

  • SA_UNSEEN - activa status->unseen con el número de mesajes no leidos (nuevos) en el buzón

  • SA_UIDNEXT - activa status->uidnext con el próximo uid a usar en el bizón

  • SA_UIDVALIDITY - activa status->uidvalidity con una constante que cambia cuando los uids del buzon ya no son válidos

  • SA_ALL - activa todos los de arriba

status->flags contienen una máscara de bits la cual puede ser comprobada contra cualquiera de las propiedades de arriba.

Anterior | Inicio | Siguiente
imap_sort | Subir | imap_subscribe


Funciones para Informix

Manual de PHP
Anterior Siguiente

XLIII. Funciones para Informix

El conector para Informix Online (ODS) 7.x, SE 7.x y Universal Server (IUS) 9.x se encuentra implementado en "functions/ifx.ec" y "functions/php3_ifx.h". Para ODS 7.x está completado, con total soporte para columnas de tipo BYTE y TEXT. Para IUS 9.x está parcialmente finalizado: los tipos de datos nuevos están allí (en el IUS 9.x), pero la funcionalidad para SLOB y CLOB se encuentra bajo construcción todavía.

Notas de configuración:

Antes de ejecutar el guión (script) "configure", asegúrate que la variable "INFORMIXDIR" ha sido definida.

Si ejecutas "configure --with_informix=yes" entonces el guión de configuración detectará automáticamente las librerías y los directorios include. Puedes obviar esta detección definiendo las variables de entorno "IFX_LIBDIR", "IFX_LIBS" y "IFX_INCDIR". Definirás la variable de compilación condicional "HAVE_IFX_IUS" si la versión de Informix es 9.00 o superior.

Algunas notas sobre el uso de BLOBs (columnas de tipo TEXT y BYTE):

BLOBs son normalmente manipulados por enteros, los cuales representan identificadores de BLOB. Las consultas de selección devuelven un "blob id" para columnas de tipo BYTE y TEXT. Si eliges trabajar con los BLOBs en memoria (con: "ifx_blobinfile(0);") entonces puedes obtener el contenido con "string_var = ifx_get_blob($blob_id);". Si prefieres manipularlos en ficheros usa "ifx_blobinfile(1);" y "ifx_get_blob($blob_id);" devolverá el nombre del archivo. En este caso, utiliza las funciones habituales de entrada y salida de ficheros para obtener el contenido de los blob.

Para consultas de inserción y actualización debes crear estos identificadores de blob con "ifx_create_blob(..);". Entonces pondrás los identificadores de blob en un array y sustituirás en la cadena de la consulta las columnas de tipo blob por una interrogación (?). Para inserciones y actualizaciones eres responsable de definir el contenido de los blob con ifx_update_blob(...).

La conducta de columnas BLOB puede ser modificada mediante variables de configuración, las cuales pueden ser definidas en tiempo de ejecución mediante funciones.

variable de configuración: ifx.textasvarchar

variable de configuración: ifx.byteasvarchar

funciones en tiempo de ejecución:

ifx_textasvarchar(0): usa identificadores de blob para columnas de tipo TEXT en las consultas de selección

ifx_byteasvarchar(0): usa identificadores de blob para columnas de tipo BYTE en las consultas de selección

ifx_textasvarchar(1): devuelve columnas de tipo TEXT como si fueran de tipo VARCHAR, sin tener que usar identificadores de blob en las consultas de selección

ifx_byteasvarchar(1): devuelve columnas de tipo BYTE como si fueran de tipo VARCHAR, sin tener que usar identificadores de blob en las consultas de selección.

variable de configuración: ifx.blobinfile

función en tiempo de ejecución:

ifx_blobinfile_mode(0): devuelve columnas de tipo BYTE en memoria, el identificador de blob te permite obtener el contenido.

ifx_blobinfile_mode(1): devuelve columnas de tipo BYTE en un fichero, el identificador te permite saber el nombre de dicho archivo.

Si defines ifx_text/byteasvarchar a 1 entonces puedes usar columnas de tipo TEXT y BYTE en las consultas de selección como campos de tipo VARCHAR, pero teniendo en cuenta que tendrán un mayor tamaño que el habitual. Ya que en PHP todas las cadenas son posibles, esto permite datos binarios. De esta forma, se pueden manejar correctamente. La información devuelta puede contener cualquier cosa, tú eres responsable del contenido.

Si defines ifx_blobinfile a 1, utiliza el nombre del archivo devuelto por ifx_get_blob(..) para acceder a los contenidos del blobs. En este caso, ERES REPONSABLE DE ELIMINAR EL ARCHIVO TEMPORAL GENERADO POR INFORMIX cuando accedas a los registros. Cada nueva fila obtenida creará un nuevo archivo temporal para cada columna de tipo BYTE.

El directorio donde se guardan los archivos temporales puede ser definido por la variable de entorno blobdir, por defecto es ".", es decir, el directorio actual. Así, putenv(blobdir=tmpblob"); definirá un directorio donde se localizarán todos los ficheros temporales y facilitará su borrado. Todos los nombres de los archivos comienzan por "blb".

Recortado (trimming) automático de datos de tipo "char" (SQLCHAR y SQLNCHAR):

Puede ser definido con la variable de configuración

ifx.charasvarchar: si se define a 1 eliminará automáticamente los espacios en blanco al final de la cadena.

Valores NULL:

La variable de configuración ifx.nullformat (y en tiempo de ejecución ifx_nullformat()) cuando sea definida a TRUE devolverá columnas NULL como la cadena "NULL", si es definida a FALSE entonces la cadena vacía. Esto permite distinguir entre columnas NULL y vacías.

Tabla de contenidos
ifx_affected_rows — Obtiene el número de registros procesados por una consulta
ifx_blobinfile_mode — Define el modo por defecto para los blob en todas las consultas de selección
ifx_byteasvarchar — Define el modo por defecto para los campos de tipo byte
ifx_close — Cierra una conexión con Informix
ifx_connect — Abre una conexión con un servidor Informix
ifx_copy_blob — Duplica el objeto blob dado
ifx_create_blob — Crea un objeto blob
ifx_create_char — Crea un objeto char
ifx_do — Ejecuta una sentencia SQL preparada previamente
ifx_error — Devuelve el código de error de la última llamada a Informix
ifx_errormsg — Devuelve el mensaje de error de la última llamada a Informix
ifx_fetch_row — Obtiene registros como un array (vector) enumerado
ifx_fieldproperties — Indica las propiedades de los campos de una consulta SQL
ifx_fieldtypes — Obtiene los campos de una consulta SQL
ifx_free_blob — Borra el objeto blob
ifx_free_char — Elimina un objeto char
ifx_free_result — Libera los recursos de una consulta
ifx_get_blob — Obtiene el contenido de un objeto blob
ifx_get_char — Obtiene el contenido de un objeto char
ifx_getsqlca — Después de una consulta, obtiene el contenido de sqlca.sqlerrd[0..5]
ifx_htmltbl_result — Muestra todos los registros de una consulta en una tabla HTML
ifx_nullformat — Define el valor por defecto cuando se leen valores nulos
ifx_num_fields — Devuelve el número de columnas en una consulta
ifx_num_rows — Cuenta los registros ya leídos de una consulta
ifx_pconnect — Abre una conexión permanente con Informix
ifx_prepare — Prepara una sentencia SQL para su ejecución
ifx_query — Envía una consulta a Informix
ifx_textasvarchar — Define el modo por defecto para los campos de tipo text
ifx_update_blob — Actualiza el contenido de un objeto blob
ifx_update_char — Actualiza el contenido de un objeto char
ifxus_close_slob — Cierra un objeto slob
ifxus_create_slob — Crea un objeto slob y lo abre
ifx_free_slob — Elimina un objeto slob
ifxus_open_slob — Abre un objeto slob
ifxus_read_slob — Lee un número de bytes (nbytes) de un objeto slob
ifxus_seek_slob — Define el fichero o posición en memoria
ifxus_tell_slob — Devuelve el fichero actual o la posición en memoria
ifxus_write_slob — Escribe una cadena en un objeto slob

Anterior | Inicio | Siguiente
imap_unsubscribe | Subir | ifx_affected_rows


ifx_connect

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_connect -- Abre una conexión con un servidor Informix

Descripción

int ifx_connect ( [string database [, string userid [, string password]]])

Si tuvo éxito, devuelve un identificador de conexión en otro caso FALSE.

ifx_connect() establece una conexión con un servidor INFORMIX. Todos los argumentos son opcionales, y si no se pasan, se toman los valores del fichero de configuración (ifx.default_host para el ordenador donde se encuentra el servidor (si no es definida, las librerías de Infomix usarán la variable de entorno INFORMIXSERVER), ifx.default_user para el usuario (userid), ifx.default_password para la contraseña (password) (ninguna, si no es definida).

Para una segunda llamada a ifx_connect() con los mismos argumentos, no se establecerá una nueva conexión, en vez de eso, el identificador de enlace de la conexión abierta será devuelto.

La conexión con el servidor será cerrada tan pronto como la ejecución del guión (script) finalice, a menos que anteriormente se haya llamando a ifx_close().

Examina también ifx_pconnect(), y ifx_close().

Ejemplo 1. Conexión a una base de datos Informix

$conn_id = ifx_pconnect (mydb@ol_srv1, "imyself", "mypassword");

Anterior | Inicio | Siguiente
ifx_close | Subir | ifx_copy_blob


ifx_pconnect

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_pconnect -- Abre una conexión permanente con Informix

Descripción

int ifx_pconnect ( [string database [, string userid [, string password]]])

Devuelve un identificador positivo de enlace persistente si hubo conexión, o FALSE si se produjo un error.

ifx_pconnect() actúa muy parecido a ifx_connect() con dos principales diferencias.

Esta función se comporta exactamente igual que ifx_connect() cuando PHP no es ejecutado como un módulo de Apache. La primera diferencia es cuando se conecta, la función intentará encontrar un enlace (persistente) que exista con el mismo servidor, usuario y contraseña. Si es hallado, el identificador del enlace será devuelto en vez de abrir una nueva conexión.

Segundo, la conexión al servidor no se cerrará cuando la ejecución del guión (script) finalice. En vez de esto, la conexión permanecerá abierta para usos futuros (ifx_close() no cerrará el enlace creado por ifx_pconnect()).

Este tipo de enlace es, por tanto, llamado 'persistente'

Examina también: ifx_connect().

Anterior | Inicio | Siguiente
ifx_num_rows | Subir | ifx_prepare


ifx_close

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_close -- Cierra una conexión con Informix

Descripción

int ifx_close ( [int link_identifier])

Devuelve: TRUE siempre.

ifx_close() cierra un enlace a una base de datos Informix que esté asociado con el identificador de enlace (link_identifier). Si el identificador de enlace no es especificado, el último enlace abierto es asumido.

Observa que esto no es necesario habitualmente ya que las conexiones no permanentes son cerradas automáticamente al finalizar el guión (script).

ifx_close() no cerrará enlaces persistentes generados por ifx_pconnect().

Examina también: ifx_connect(), y ifx_pconnect().

Ejemplo 1. Cierre de una conexión a Informix

$conn_id = ifx_connect (mydb@ol_srv, "itsme", "mypassword");
... algunas consultas y código ...
ifx_close($conn_id);

Anterior | Inicio | Siguiente
ifx_byteasvarchar | Subir | ifx_connect


ifx_query

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_query -- Envía una consulta a Informix

Descripción

int ifx_query ( string query [, int link_identifier [, int cursor_type [, mixed blobidarray]]])

Devuelve un identificador positivo de resultado si tuvo éxito, FALSE en otro caso.

Un entero (integer) "result_id" usado por otras funciones para obtener el resultado de la consulta. Es definido "affected_rows" (registros procesados) y se puede obtener mediante la función ifx_affected_rows().

ifx_query() envía una consulta a la base de datos activa actualmente en el servidor, la cual está representada por el identificador de enlace especificado (link_identifier). Si el identificador no es definido, el último enlace abierto es asumido. Si el enlace no se encuentra abierto, ifx_connect() es llamado y utilizado.

Ejecuta una consulta (query) sobre una conexión (link_identifier). Un cursor es definido y abierto para las consultas de selección. El parámetro opcional tipo de cursor (cursor_type) te permite que sea un cursor de tipo "scroll" y/o "hold". Es una máscara y puede ser IFX_SCROLL, IFX_HOLD o ambos. Las consultas que no son de selección son ejecutadas inmediatamente.

Para cualquier tipo de consulta el número (estimado o real) de registros procesados es guardo y se puede obtener mediante ifx_affected_rows().

Si tienes columnas BLOB (BYTE o TEXT) en una consulta de actualización, puedes añadir un parámetro blobidarray conteniendo los identificadores de blob y sustituir los valores de esas columnas por una "?" en el texto de la consulta.

Si el contenido de la columna de tipo TEXT (o BYTE) lo permite, también puedes usar "ifx_textasvarchar(1)" y "ifx_byteasvarchar(1)". Esto supone manejar columnas de tipo TEXT (o BYTE) como si fueran columnas normales de tipo VARCHAR (pero teniendo en cuenta que tendrán un mayor tamaño que el habitual), para consultas de selección y no necesitas preocuparte por los identificadores de blob.

La opción por defecto ifx_textasvarchar(0) o ifx_byteasvarchar(0) devuelve identificadores de blob (valores enteros) para las consultas de selección. Puedes obtener el contenido del blob como una cadena o un fichero con las funciones para blob (ver más adelante).

Examina también: ifx_connect().

Ejemplo 1. Mostrar todos los registros de la tabla "orders" como una tabla html

ifx_textasvarchar(1);      // usa "modo texto" para blobs
$res_id = ifx_query("select * from orders", $conn_id);
if (! $res_id) {
    printf("Can't select orders : %s\n<br>%s<br>\n", ifx_error());
    ifx_errormsg();
    die;
}
ifx_htmltbl_result($res_id, "border=\"1\"");
ifx_free_result($res_id);

Ejemplo 2. Inserta valores en la tabla "catalog"

// crea identificadores de blob para una columna de tipo byte y otra text
$textid = ifx_create_blob(0, 0, "Text column in memory");
$byteid = ifx_create_blob(1, 0, "Byte column in memory");
                      // almacena los identificadores de blob en un array llamado blobid
$blobidarray[] = $textid;
$blobidarray[] = $byteid;
                      // lanza la consulta
$query = "insert into catalog (stock_num, manu_code, " .
         "cat_descr,cat_picture) values(1,'HRO',?,?)";
$res_id = ifx_query($query, $conn_id, $blobidarray);
if (! $res_id) {
  ... error ...
}
                     // libera el resultado
ifx_free_result($res_id);

Anterior | Inicio | Siguiente
ifx_prepare | Subir | ifx_textasvarchar


ifx_prepare

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_prepare -- Prepara una sentencia SQL para su ejecución

Descripción

int ifx_prepare ( string query, int conn_id [, int cursor_def, mixed blobidarray])

Devuelve un entero (integer) result_id para usarlo con ifx_do(). Es definido "affected_rows" (registros procesados) y se puede obtener mediante la función ifx_affected_rows().

Prepara una consulta (query) sobre una conexión (link_identifier). Un cursor es definido y abierto para las consultas de selección. El parámetro opcional tipo de cursor (cursor_type) te permite que sea un cursor de tipo "scroll" y/o "hold". Es una máscara y puede ser IFX_SCROLL, IFX_HOLD o ambos.

Para cualquier tipo de consulta el número estimado de registros afectados (procesados) es guardado y puede ser obtenido mediante ifx_affected_rows().

Si tienes columnas BLOB (BYTE o TEXT) en una consulta, puedes añadir un parámetro blobidarray conteniendo los identificadores de blob y sustituir los valores de esas columnas por una "?" en el texto de la consulta.

Si el contenido de la columna de tipo TEXT (o BYTE) lo permite, puedes también usar "ifx_textasvarchar(1)" y "ifx_byteasvarchar(1)". Esto supone manejar columnas de tipo TEXT (o BYTE) como si fueran columnas normales de tipo VARCHAR (pero teniendo en cuenta que tendrán un mayor tamaño que el habitual), para consultas de selección y no necesitas preocuparte por los identificadores de blob.

La opción por defecto ifx_textasvarchar(0) o ifx_byteasvarchar(0) devuelve identificadores de blob (valores enteros) para las consultas de selección. Puedes obtener el contenido del blob como una cadena o un fichero con las funciones para blob (ver más adelante).

Examina también: ifx_do().

Anterior | Inicio | Siguiente
ifx_pconnect | Subir | ifx_query


ifx_do

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_do -- Ejecuta una sentencia SQL preparada previamente

Descripción

int ifx_do ( int result_id)

Devuelve TRUE si se realizó, FALSE si hubo algún error.

Ejecuta una consulta preparada anteriormente o abre un cursor para ella.

No libera result_id si hubo un error.

También define el número real de registros procesados para consultas que no sean de selección y se puede obtener mediante ifx_affected_rows().

Examina también: ifx_prepare() (hay un ejemplo).

Anterior | Inicio | Siguiente
ifx_create_char | Subir | ifx_error


ifx_error

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_error -- Devuelve el código de error de la última llamada a Informix

Descripción

string ifx_error ( void)

Los códigos de error de Informix (SQLSTATE & SQLCODE) son representados como se especifica a continuación:

x [SQLSTATE = aa bbb SQLCODE=cccc]

donde x = un espacio : no hubo error

E : hubo error

N : no hay más datos

W : aviso

? : no definido

Si el carácter "x" es cualquier otra cosa diferente a un espacio, SQLSTATE y SQLCODE describen el error con mayor detalle.

Examina el manual de Informix para el significado de SQLSTATE y SQLCODE.

Devuelve en una cadena un caracter describiendo el resultado de una sentencia y los valores SQLSTATE y SQLCODE asociados con la última sentencia SQL ejecutada. El formato de la cadena es "(char) [SQLSTATE=(dos dígitos) (tres dígitos) SQLCODE=(un dígitos)]". El primer carácter puede ser ' ' (un espacio) (no hubo error), 'W' (la sentencia provocó un aviso), 'E' (la consulta produjo un error) o 'N' (la sentencia no devolvió ningún dato).

Examina también: ifx_errormsg()

Anterior | Inicio | Siguiente
ifx_do | Subir | ifx_errormsg


ifx_errormsg

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_errormsg -- Devuelve el mensaje de error de la última llamada a Informix

Descripción

string ifx_errormsg ( [int errorcode])

Devuelve el mensaje de error asociado con el error más reciente de Informix. Si definismos el parámetro opcional "errorcode" (código de error), nos dará el mensaje de error correspondiente a ese código.

Examina también: ifx_error()

printf("%s\n<br>", ifx_errormsg(-201));

Anterior | Inicio | Siguiente
ifx_error | Subir | ifx_fetch_row


ifx_affected_rows

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_affected_rows -- Obtiene el número de registros procesados por una consulta

Descripción

int ifx_affected_rows ( int result_id)

result_id es un identificador válido del resultado de ifx_query() o ifx_prepare().

Devuelve el número de filas procesadas por una consulta representada por un result_id (identificador de resultado).

Para inserciones, actualizaciones y borrados el número es exactamente los registros procesados (sqlerrd[2]). Para las consultas de selección es una estimación (sqlerrd[0]). No confíes en él.

Es útil llamarla después de ejecutar ifx_prepare() pues así podemos limitar las consultas a número razonable de registros.

Examina también: ifx_num_rows()

Ejemplo 1. Número de registros procesados por una consulta

$rid = ifx_prepare ("select * from emp where name like " . $name, $connid);
if (! $rid) {
    ... error ...
}
$rowcount = ifx_affected_rows ($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br>", $rowcount);  // Demasiados registros en el resultado
    die ("Please restrict your query<br>\n");                      // Por favor, restringe tu consulta
}

Anterior | Inicio | Siguiente
Funciones para Informix | Subir | ifx_blobinfile_mode


ifx_getsqlca

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

ifx_getsqlca -- Después de una consulta, obtiene el contenido de sqlca.sqlerrd[0..5]

Descripción

array ifx_getsqlca ( int result_id)

result_id es un identificador válido del resultado de ifx_query() o ifx_prepare().

Devuelve una seudo fila (array asociativo) con los valores de sqlca.sqlerrd[0] a sqlca.sqlerrd[5] de una consulta ejecutada, representada ésta con un identificador de resultado result_id.

Para inserciones, actualizaciones y borrados los valores devueltos son aquellos definidos por el servidor después de que la consulta sea ejecutada. Esto da acceso al número de registros procesados y al valor de una columna de tipo serial en una consulta de inserción. Para consultas de selección, los valores son guardados cuando se prepara la sentencia. También permite conocer el número estimado de registros procesados. El uso de esta función evita el sobrecoste de ejecutar la consulta "select dbinfo('sqlca.sqlerrdx')", como obtener los valores guardados por el conector para Informix en el momento apropiado.

Ejemplo 1. Obtener los valores sqlca.sqlerrd[x]

/* suponiendo que la primera columna de la tabla 'sometable' es de tipo serial */
$qid = ifx_query("insert into sometable values(0, '2nd column', 'another column' ", $connid);
if (! $qid) {
    ... error ...
}
$sqlca = ifx_getsqlca ($qid);
$serial_value = $sqlca["sqlerrd1"];
echo "The serial value of the inserted row is : " . $serial_value<br>\n"; // El valor de tipo serial del registro insertado es:

Anterior | Inicio | Siguiente
ifx_get_char | Subir | ifx_htmltbl_result


ifx_fetch_row

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_fetch_row -- Obtiene registros como un array (vector) enumerado

Descripción

array ifx_fetch_row ( int result_id [, mixed position])

Devuelve un array (vector) correspondiente a la fila leída o FALSE si no hay más registros.

Las columnas blob son devueltas como identificadores de blob enteros (integer) para usarlos con ifx_get_blob() a menos que hayas usado ifx_textasvarchar(1) o ifx_byteasvarchar(1), en cuyo caso los blobs son devueltos como cadenas de texto. Devuelve FALSE si hubo error.

result_id es un identificador válido del resultado de ifx_query() o ifx_prepare() (sólo para consultas de selección).

position es un parámetro opcional para una operación de lectura sobre un cursor de tipo "scroll": "NEXT" (siguiente), "PREVIOUS" (anterior), "CURRENT" (actual), "FIRST" (primero), "LAST" (último) o un número. Si se especifica un número, un registro concreto es leído. Este parámetro opcional es sólo válido para cursores de tipo scroll.

ifx_fetch_row() lee el contenido de un registro de la consulta representada por el identificador de resultado indicado. La fila (registro) es devuelta en un array. Cada columna es guarda en un array, empezando éste desde cero.

Las llamadas posteriores a ifx_fetch_row() devolverán el registro siguiente en el resultado de la consulta, o FALSE si no hay más filas.

Ejemplo 1. Leer registros

$rid = ifx_prepare ("select * from emp where name like " . $name,
                     $connid, IFX_SCROLL);
if (! $rid) {
    ... error ...
}
$rowcount = ifx_affected_rows($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br>", $rowcount);  // Demasiados registros en el resultado
    die ("Please restrict your query<br>\n");                      // Por favor, restringe tu consulta
}
if (! ifx_do ($rid)) {
   ... error ...
}
$row = ifx_fetch_row ($rid, "NEXT");
while (is_array($row)) {
    for(reset($row); $fieldname=key($row); next($row)) {
        $fieldvalue = $row[$fieldname];
        printf ("%s = %s,", $fieldname, $fieldvalue);
    }
    printf("\n<br>");
    $row = ifx_fetch_row ($rid, "NEXT");
}
ifx_free_result ($rid);

Anterior | Inicio | Siguiente
ifx_errormsg | Subir | ifx_fieldproperties


ifx_htmltbl_result

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_htmltbl_result -- Muestra todos los registros de una consulta en una tabla HTML

Descripción

int ifx_htmltbl_result ( int result_id [, string html_table_options])

Devuelve el número de registros leídos o FALSE si hubo error.

Muestra todas las filas de la consulta result_id dentro de una tabla html. El argumento segundo, opcional, es una cadena de parámetros del tag <table>

Ejemplo 1. Mostrar resultado como una tabla HTML

$rid = ifx_prepare ("select * from emp where name like " . $name,
                     $connid, IFX_SCROLL);
if (! $rid) {
   ... error ...
}
$rowcount = ifx_affected_rows ($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br>", $rowcount);  // Demasiados registros en el resultado
    die ("Please restrict your query<br>\n");                      // Por favor, restringe tu consulta
}
if (! ifx_do($rid) {
  ... error ...
}

ifx_htmltbl_result ($rid, "border=\"2\"");

ifx_free_result($rid);

Anterior | Inicio | Siguiente
ifx_getsqlca | Subir | ifx_nullformat


ifx_fieldtypes

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_fieldtypes -- Obtiene los campos de una consulta SQL

Descripción

array ifx_fieldtypes ( int result_id)

Dada una consulta representada por result_id devuelve un array con los nombres de campo como llaves y los tipos como datos. Si no tuvo éxito da FALSE.

Ejemplo 1. Nombres y tipos de campos de una consulta SQL

$types = ifx_fieldtypes ($resultid);
if (! isset ($types)) {
  ... error ...
}
for ($i = 0; $i < count($types); $i++) {
    $fname = key($types);
    printf("%s :\t type =  %s\n", $fname, $types[$fname]);
    next($types);
}

Anterior | Inicio | Siguiente
ifx_fieldproperties | Subir | ifx_free_blob


ifx_fieldproperties

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_fieldproperties -- Indica las propiedades de los campos de una consulta SQL

Descripción

array ifx_fieldproperties ( int result_id)

Dada una consulta representada por result_id devuelve un array con los nombres de campo como llaves y las propiedades como datos. FALSE es devuelto si hubo error.

Devuelve las propiedades SQL de cada campo como un array. Las propiedades son codificadas así: "SQLTYPE;longitud;precisión;escala;ISNULLABLE" siendo SQLTYPE el tipo de dato definido en Informix como puede ser "SQLVCHAR" etc. e ISNULLABLE (puede ser nulo) igual a "Y" sí o "N" no.

Ejemplo 1. Propiedades de los campos de una consulta SQL

$properties = ifx_fieldtypes ($resultid);
if (! isset($properties)) {
  ... error ...
}
for ($i = 0; $i < count($properties); $i++) {
    $fname = key ($properties);
    printf ("%s:\t type =  %s\n", $fname, $properties[$fname]);
    next ($properties);
}

Anterior | Inicio | Siguiente
ifx_fetch_row | Subir | ifx_fieldtypes


ifx_num_fields

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_num_fields -- Devuelve el número de columnas en una consulta

Descripción

int ifx_num_fields ( int result_id)

Dada una consulta representada por result_id devuelve el número de columnas o FALSE si se produjo un error.

Después de preparar o ejecutar una consulta, una llamada a esta función te da el número de columnas en la consulta.

Anterior | Inicio | Siguiente
ifx_nullformat | Subir | ifx_num_rows


ifx_num_rows

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_num_rows -- Cuenta los registros ya leídos de una consulta

Descripción

int ifx_num_rows ( int result_id)

Da el número de registros ya leídos de una consulta representada por un result_id después de llamar a ifx_query() o ifx_do().

Anterior | Inicio | Siguiente
ifx_num_fields | Subir | ifx_pconnect


ifx_free_result

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ifx_free_result -- Libera los recursos de una consulta

Descripción

int ifx_free_result ( int result_id)

Libera los recursos representados por el identificador result_id de una consulta. Devuelve FALSE si hubo error.

Anterior | Inicio | Siguiente
ifx_free_char | Subir | ifx_get_blob


ifx_create_char

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ifx_create_char -- Crea un objeto char

Descripción

int ifx_create_char ( string param)

Crea un objeto char. param será el contenido del char.

Anterior | Inicio | Siguiente
ifx_create_blob | Subir | ifx_do


ifx_free_char

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ifx_free_char -- Elimina un objeto char

Descripción

int ifx_free_char ( int bid)

Borra el objeto char representado por el identificador del char bid. Devuelve FALSE si se produjo un error, en otro caso TRUE.

Anterior | Inicio | Siguiente
ifx_free_blob | Subir | ifx_free_result


ifx_update_char

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ifx_update_char -- Actualiza el contenido de un objeto char

Descripción

int ifx_update_char ( int bid, string content)

Actualiza el contenido de un objeto char representado por su identificador bid. content es una cadena con la información nueva. Devuelve FALSE si se produjo un error, en otro caso TRUE.

Anterior | Inicio | Siguiente
ifx_update_blob | Subir | ifxus_close_slob


ifx_get_char

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ifx_get_char -- Obtiene el contenido de un objeto char

Descripción

int ifx_get_char ( int bid)

Devuelve el contenido de un objeto char representado por su identificador bid.

Anterior | Inicio | Siguiente
ifx_get_blob | Subir | ifx_getsqlca


ifx_create_blob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_create_blob -- Crea un objeto blob

Descripción

int ifx_create_blob ( int type, int mode, string param)

Crea un objeto blob.

type (tipo): 1 = TEXT, 0 = BYTE

mode (modo): 0 = el contenido del objeto blob es conservado en memoria, 1 = el contenido del objeto blob es mantenido en un archivo.

param: si mode = 0: apunta al contenido en memoria, si mode = 1: contiene el nombre del fichero.

Devuelve FALSE si hubo error, en otro caso el identificador del nuevo objeto blob.

Anterior | Inicio | Siguiente
ifx_copy_blob | Subir | ifx_create_char


ifx_copy_blob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_copy_blob -- Duplica el objeto blob dado

Descripción

int ifx_copy_blob ( int bid)

Duplica el objeto blob dado. bid es el identificador del objeto blob a copiar.

Devuelve FALSE si hubo error, en otro caso el identificador del nuevo objeto blob.

Anterior | Inicio | Siguiente
ifx_connect | Subir | ifx_create_blob


ifx_free_blob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_free_blob -- Borra el objeto blob

Descripción

int ifx_free_blob ( int bid)

Elimina el objeto blob representado por el identificador bid. Devuelve FALSE si se produjo error, en otro caso TRUE.

Anterior | Inicio | Siguiente
ifx_fieldtypes | Subir | ifx_free_char


ifx_get_blob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_get_blob -- Obtiene el contenido de un objeto blob

Descripción

int ifx_get_blob ( int bid)

Devuelve el contenido de un objeto blob representado por su identificador bid.

Anterior | Inicio | Siguiente
ifx_free_result | Subir | ifx_get_char


ifx_update_blob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_update_blob -- Actualiza el contenido de un objeto blob

Descripción

ifx_update_blob ( int bid, string content)

Actualiza el contenido de un objeto blob representado por su identificador bid. content es una cadena con el nuevo contenido. Devuelve FALSE si hubo error, en otro caso TRUE.

Anterior | Inicio | Siguiente
ifx_textasvarchar | Subir | ifx_update_char


ifx_blobinfile_mode

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_blobinfile_mode -- Define el modo por defecto para los blob en todas las consultas de selección

Descripción

void ifx_blobinfile_mode ( int mode)

Define el modo por defecto para los blob en todas las consultas de selección. El modo (mode) "0" quiere decir que guarda en memoria los blobs de tipo BYTE y modo "1" significa guardarlos en un archivo.

Anterior | Inicio | Siguiente
ifx_affected_rows | Subir | ifx_byteasvarchar


ifx_textasvarchar

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_textasvarchar -- Define el modo por defecto para los campos de tipo text

Descripción

void ifx_textasvarchar ( int mode)

Define el modo por defecto para los campos de tipo text en todas las consultas de selección. Modo (mode) "0" devolverá un identificador de blob y "1" dará el contenido en un campo de tipo varchar.

Anterior | Inicio | Siguiente
ifx_query | Subir | ifx_update_blob


ifx_byteasvarchar

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_byteasvarchar -- Define el modo por defecto para los campos de tipo byte

Descripción

void ifx_byteasvarchar ( int mode)

Define el modo por defecto para los campos de tipo byte en todas las consultas de selección. Modo (mode) "0" devolverá un identificador de blob y "1" dará el contenido en un campo de tipo varchar.

Anterior | Inicio | Siguiente
ifx_blobinfile_mode | Subir | ifx_close


ifx_nullformat

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifx_nullformat -- Define el valor por defecto cuando se leen valores nulos

Descripción

void ifx_nullformat ( int mode)

Define el valor por defecto cuando se leen valores nulos. Modo (mode) "0" devuelve "", y modo "1" devuelve "NULL".

Anterior | Inicio | Siguiente
ifx_htmltbl_result | Subir | ifx_num_fields


ifxus_create_slob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifxus_create_slob -- Crea un objeto slob y lo abre

Descripción

int ifxus_create_slob ( int mode)

Crea un objeto slob y lo abre. Modos: 1 = LO_RDONLY, 2 = LO_WRONLY, 4 = LO_APPEND, 8 = LO_RDWR, 16 = LO_BUFFER, 32 = LO_NOBUFFER o una combinación de ellos. También puedes usar nombres de constantes IFX_LO_RDONLY, IFX_LO_WRONLY, etc. Devuelve FALSE si hubo error, en otro caso el identificador del nuevo objeto slob.

Anterior | Inicio | Siguiente
ifxus_close_slob | Subir | ifx_free_slob


ifx_free_slob

(unknown)

ifx_free_slob -- Elimina un objeto slob

Descripción

int ifxus_free_slob ( int bid)

Borra un objeto slob. bid es el identificador del objeto slob. Devuelve FALSE si hubo error, TRUE en otro caso.

Anterior | Inicio | Siguiente
ifxus_create_slob | Subir | ifxus_open_slob


ifxus_close_slob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifxus_close_slob -- Cierra un objeto slob

Descripción

int ifxus_close_slob ( int bid)

Cierra un objeto slob representado por su identificador de slob bid. Devuelve FALSE si hubo error, TRUE en otro caso.

Anterior | Inicio | Siguiente
ifx_update_char | Subir | ifxus_create_slob


ifxus_open_slob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifxus_open_slob -- Abre un objeto slob

Descripción

int ifxus_open_slob ( long bid, int mode)

Abre un objeto slob. bid será un identificador de slob que válido. Modos: 1 = LO_RDONLY, 2 = LO_WRONLY, 4 = LO_APPEND, 8 = LO_RDWR, 16 = LO_BUFFER, 32 = LO_NOBUFFER o una combinación de ellos. Devuelve FALSE si hubo error, en otro caso el identificador del nuevo objeto slob.

Anterior | Inicio | Siguiente
ifx_free_slob | Subir | ifxus_read_slob


ifxus_tell_slob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifxus_tell_slob -- Devuelve el fichero actual o la posición en memoria

Descripción

int ifxus_tell_slob ( long bid)

Devuelve el fichero actual o la posición en memoria de un objeto slob abierto, bid será un identificador de slob válido. Si hubo error entonces da FALSE.

Anterior | Inicio | Siguiente
ifxus_seek_slob | Subir | ifxus_write_slob


ifxus_seek_slob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifxus_seek_slob -- Define el fichero o posición en memoria

Descripción

int ifxus_seek_blob ( long bid, int mode, long offset)

Define el fichero o posición en memoria de un objeto slob abierto, bid será un identificador de slob válido. Modos (mode): 0 = LO_SEEK_SET, 1 = LO_SEEK_CUR, 2 = LO_SEEK_END y offset es el desplazamiento en bytes. Si hubo error entonces da FALSE.

Anterior | Inicio | Siguiente
ifxus_read_slob | Subir | ifxus_tell_slob


ifxus_read_slob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifxus_read_slob -- Lee un número de bytes (nbytes) de un objeto slob

Descripción

int ifxus_read_slob ( long bid, long nbytes)

Lee un número de bytes (nbytes) de un objeto slob. bid es un identificador de slob válido y nbytes es el número de bytes a leer. Devuelve FALSE si hubo error, sino la cadena.

Anterior | Inicio | Siguiente
ifxus_open_slob | Subir | ifxus_seek_slob


ifxus_write_slob

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

ifxus_write_slob -- Escribe una cadena en un objeto slob

Descripción

int ifxus_write_slob ( long bid, string content)

Escribe una cadena en un objeto slob. bid es un identificador de slob válido y content el contenido a escribir. Devuelve FALSE si hubo error, sino el número de bytes escritos.

Anterior | Inicio | Siguiente
ifxus_tell_slob | Subir | Funciones InterBase


Funciones InterBase

Manual de PHP
Anterior Siguiente

XLIV. Funciones InterBase

Tabla de contenidos
ibase_bind —
ibase_close —
ibase_connect —
ibase_execute —
ibase_fetch_row —
ibase_free_query —
ibase_free_result —
ibase_pconnect —
ibase_prepare —
ibase_query —
ibase_timefmt —

Anterior | Inicio | Siguiente
ifxus_write_slob | Subir | ibase_bind


ibase_connect

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_connect --

Descripcion

ibase_connect ( )

Anterior | Inicio | Siguiente
ibase_close | Subir | ibase_execute


ibase_pconnect

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_pconnect --

Descripcion

ibase_pconnect ( )

Anterior | Inicio | Siguiente
ibase_free_result | Subir | ibase_prepare


ibase_close

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_close --

Descripcion

ibase_close ( )

Anterior | Inicio | Siguiente
ibase_bind | Subir | ibase_connect


ibase_query

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_query --

Descripcion

ibase_query ( )

Anterior | Inicio | Siguiente
ibase_prepare | Subir | ibase_timefmt


ibase_fetch_row

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_fetch_row --

Descripcion

ibase_fetch_row ( )

Anterior | Inicio | Siguiente
ibase_execute | Subir | ibase_free_query


ibase_free_result

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_free_result --

Descripcion

ibase_free_result ( )

Anterior | Inicio | Siguiente
ibase_free_query | Subir | ibase_pconnect


ibase_prepare

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_prepare --

Descripcion

ibase_prepare ( )

Anterior | Inicio | Siguiente
ibase_pconnect | Subir | ibase_query


ibase_bind

(3.0.6 - 3.0.7 only)

ibase_bind --

Descripcion

ibase_bind ( )

Anterior | Inicio | Siguiente
Funciones InterBase | Subir | ibase_close


ibase_execute

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_execute --

Descripcion

ibase_execute ( )

Anterior | Inicio | Siguiente
ibase_connect | Subir | ibase_fetch_row


ibase_free_query

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_free_query --

Descripcion

ibase_free_query ( )

Anterior | Inicio | Siguiente
ibase_fetch_row | Subir | ibase_free_result


ibase_timefmt

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

ibase_timefmt --

Descripcion

ibase_timefmt ( )

Anterior | Inicio | Siguiente
ibase_query | Subir | Ingres II functions


Ingres II functions

Manual de PHP
Anterior Siguiente

XLV. Ingres II functions

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

These functions allow you to access Ingres II database servers.

In order to have these functions available, you must compile php with Ingres support by using the --with-ingres option. You need the Open API library and header files included with Ingres II. If the II_SYSTEM environment variable isn't correctly set you may have to use --with-ingres=DIR to specify your Ingres installation directory.

When using this extension with Apache, if Apache does not start and complains with "PHP Fatal error: Unable to start ingres_ii module in Unknown on line 0" then make sure the environement variable II_SYSTEM is correctly set. Adding "export II_SYSTEM="/home/ingres/II" in the script that starts Apache, just before launching httpd, should be fine.

Nota: If you already used PHP extensions to access other database servers, note that Ingres doesn't allow concurrent queries and/or transaction over one connection, thus you won't find any result or transaction handle in this extension. The result of a query must be treated before sending another query, and a transaction must be commited or rolled back before opening another transaction (which is automaticaly done when sending the first query).

Tabla de contenidos
ingres_connect — Open a connection to an Ingres II database.
ingres_pconnect — Open a persistent connection to an Ingres II database.
ingres_close — Close an Ingres II database connection
ingres_query — Send a SQL query to Ingres II
ingres_num_rows — Get the number of rows affected or returned by the last query
ingres_num_fields — Get the number of fields returned by the last query
ingres_field_name — Get the name of a field in a query result.
ingres_field_type — Get the type of a field in a query result.
ingres_field_nullable — Test if a field is nullable.
ingres_field_length — Get the length of a field.
ingres_field_precision — Get the precision of a field.
ingres_field_scale — Get the scale of a field.
ingres_fetch_array — Fetch a row of result into an array.
ingres_fetch_row — Fetch a row of result into an enumerated array.
ingres_fetch_object — Fetch a row of result into an object.
ingres_rollback — Roll back a transaction.
ingres_commit — Commit a transaction.
ingres_autocommit — Switch autocommit on or off.

Anterior | Inicio | Siguiente
ibase_timefmt | Subir | ingres_connect


ingres_connect

(PHP 4 >= 4.0.2)

ingres_connect -- Open a connection to an Ingres II database.

Description

resource ingres_connect ( [string database [, string username [, string password]]])

Returns a Ingres II link resource on success, or FALSE on failure.

ingres_connect() opens a connection with the Ingres database designated by database, which follows the syntax [node_id::]dbname[/svr_class].

If some parameters are missing, ingres_connect() uses the values in php.ini for ingres.default_database, ingres.default_user and ingres.default_password.

The connection is closed when the script ends or when ingres_close() is called on this link.

All the other ingres functions use the last opened link as a default, so you need to store the returned value only if you use more than one link at a time.

Ejemplo 1. ingres_connect() example

<?php
    $link = ingres_connect ("mydb", "user", "pass")
        or die ("Could not connect");
    print ("Connected successfully");
    ingres_close ($link);
?>

Ejemplo 2. ingres_connect() example using default link

<?php
    ingres_connect ("mydb", "user", "pass")
        or die ("Could not connect");
    print ("Connected successfully");
    ingres_close ();
?>

See also ingres_pconnect(), and ingres_close().

Anterior | Inicio | Siguiente
Ingres II functions | Subir | ingres_pconnect


ingres_pconnect

(PHP 4 >= 4.0.2)

ingres_pconnect -- Open a persistent connection to an Ingres II database.

Description

resource ingres_pconnect ( [string database [, string username [, string password]]])

Returns a Ingres II link resource on success, or FALSE on failure.

See ingres_connect() for parameters details and examples. There are only 2 differences between ingres_pconnect() and ingres_connect() : First, when connecting, the function will first try to find a (persistent) link that's already opened with the same parameters. If one is found, an identifier for it will be returned instead of opening a new connection. Second, the connection to the Ingres server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ingres_close() will not close links established by ingres_pconnect()). This type of link is therefore called 'persistent'.

See also ingres_connect(), and ingres_close().

Anterior | Inicio | Siguiente
ingres_connect | Subir | ingres_close


ingres_close

(PHP 4 >= 4.0.2)

ingres_close -- Close an Ingres II database connection

Description

bool ingres_close ( [resource link])

Returns TRUE on success, or FALSE on failure.

ingres_close() closes the connection to the Ingres server that's associated with the specified link. If the link parameter isn't specified, the last opened link is used.

ingres_close() isn't usually necessary, as it won't close persistent connections and all non-persistent connections are automatically closed at the end of the script.

See also ingres_connect(), and ingres_pconnect().

Anterior | Inicio | Siguiente
ingres_pconnect | Subir | ingres_query


ingres_query

(PHP 4 >= 4.0.2)

ingres_query -- Send a SQL query to Ingres II

Description

bool ingres_query ( string query [, resource link])

Returns TRUE on success, or FALSE on failure.

ingres_query() sends the given query to the Ingres server. This query must be a valid SQL query (see the Ingres SQL reference guide)

The query becomes part of the currently open transaction. If there is no open transaction, ingres_query() opens a new transaction. To close the transaction, you can either call ingres_commit() to commit the changes made to the database or ingres_rollback() to cancel these changes. When the script ends, any open transaction is rolled back (by calling ingres_rollback()). You can also use ingres_autocommit() before opening a new transaction to have every SQL query immediatly commited.

Some types of SQL queries can't be sent with this function :

  • close (see ingres_close()).

  • commit (see ingres_commit()).

  • connect (see ingres_connect()).

  • disconnect (see ingres_close()).

  • get dbevent

  • prepare to commit

  • rollback (see ingres_rollback()).

  • savepoint

  • set autocommit (see ingres_autocommit()).

  • all cursor related queries are unsupported

Ejemplo 1. ingres_query() example

<?php
ingres_connect ($database, $user, $password);

ingres_query ("select * from table");
while ($row = ingres_fetch_row()) {
    echo $row[1];
    echo $row[2];
}
?>

See also
ingres_fetch_array(),
ingres_fetch_object(),
ingres_fetch_row(),
ingres_commit(),
ingres_rollback() and
ingres_autocommit().

Anterior | Inicio | Siguiente
ingres_close | Subir | ingres_num_rows


ingres_num_rows

(PHP 4 >= 4.0.2)

ingres_num_rows -- Get the number of rows affected or returned by the last query

Description

int ingres_num_rows ( [resource link])

For delete, insert or update queries, ingres_num_rows() returns the number of rows affected by the query. For other queries, ingres_num_rows() returns the number of rows in the query's result.

Nota: This function is mainly meant to get the number of rows modified in the database. If this function is called before using ingres_fetch_array(), ingres_fetch_object() or ingres_fetch_row() the server will delete the result's data and the script won't be able to get them.

You should instead retrieve the result's data using one of these fetch functions in a loop until it returns FALSE, indicating that no more results are available.

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_query | Subir | ingres_num_fields


ingres_num_fields

(PHP 4 >= 4.0.2)

ingres_num_fields -- Get the number of fields returned by the last query

Description

int ingres_num_fields ( [resource link])

ingres_num_fields() returns the number of fields in the results returned by the Ingres server after a call to ingres_query()

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_num_rows | Subir | ingres_field_name


ingres_field_name

(PHP 4 >= 4.0.2)

ingres_field_name -- Get the name of a field in a query result.

Description

string ingres_field_name ( int index [, resource link])

ingres_field_name() returns the name of a field in a query result, or FALSE on failure.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_num_fields | Subir | ingres_field_type


ingres_field_type

(PHP 4 >= 4.0.2)

ingres_field_type -- Get the type of a field in a query result.

Description

string ingres_field_type ( int index [, resource link])

ingres_field_type() returns the type of a field in a query result, or FALSE on failure. Examples of types returned are "IIAPI_BYTE_TYPE", "IIAPI_CHA_TYPE", "IIAPI_DTE_TYPE", "IIAPI_FLT_TYPE", "IIAPI_INT_TYPE", "IIAPI_VCH_TYPE". Some of these types can map to more than one SQL type depending on the length of the field (see ingres_field_length()). For example "IIAPI_FLT_TYPE" can be a float4 or a float8. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_field_name | Subir | ingres_field_nullable


ingres_field_nullable

(PHP 4 >= 4.0.2)

ingres_field_nullable -- Test if a field is nullable.

Description

bool ingres_field_nullable ( int index [, resource link])

ingres_field_nullable() returns TRUE if the field can be set to the NULL value and FALSE if it can't.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_field_type | Subir | ingres_field_length


ingres_field_length

(PHP 4 >= 4.0.2)

ingres_field_length -- Get the length of a field.

Description

int ingres_field_length ( int index [, resource link])

ingres_field_length() returns the length of a field. This is the number of bytes used by the server to store the field. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_field_nullable | Subir | ingres_field_precision


ingres_field_precision

(PHP 4 >= 4.0.2)

ingres_field_precision -- Get the precision of a field.

Description

int ingres_field_precision ( int index [, resource link])

ingres_field_precision() returns the precision of a field. This value is used only for decimal, float and money SQL data types. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_field_length | Subir | ingres_field_scale


ingres_field_scale

(PHP 4 >= 4.0.2)

ingres_field_scale -- Get the scale of a field.

Description

int ingres_field_scale ( int index [, resource link])

ingres_field_scale() returns the scale of a field. This value is used only for the decimal SQL data type. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

See also
ingres_query(),
ingres_fetch_array(),
ingres_fetch_object() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_field_precision | Subir | ingres_fetch_array


ingres_fetch_array

(PHP 4 >= 4.0.2)

ingres_fetch_array -- Fetch a row of result into an array.

Description

array ingres_fetch_array ( [int result_type [, resource link]])

ingres_fetch_array() Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

This function is an extended version of ingres_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must use the numeric index of the column or make an alias for the column.

ingres_query(select t1.f1 as foo t2.f1 as bar from t1, t2);
$result = ingres_fetch_array();
$foo = $result["foo"];
$bar = $result["bar"];

result_type can be II_NUM for enumerated array, II_ASSOC for associative array, or II_BOTH (default).

Speed-wise, the function is identical to ingres_fetch_object(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

Ejemplo 1. ingres_fetch_array() example

<?php
ingres_connect ($database, $user, $password);

ingres_query ("select * from table");
while ($row = ingres_fetch_array()) {
    echo $row["user_id"];  # using associative array
    echo $row["fullname"];
    echo $row[1];          # using enumerated array
    echo $row[2];
}
?>

See also
ingres_query(),
ingres_num_fields(),
ingres_field_name(),
ingres_fetch_object() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_field_scale | Subir | ingres_fetch_row


ingres_fetch_row

(PHP 4 >= 4.0.2)

ingres_fetch_row -- Fetch a row of result into an enumerated array.

Description

array ingres_fetch_row ( [resource link])

ingres_fetch_row() returns an array that corresponds to the fetched row, or FALSE if there are no more rows. Each result column is stored in an array offset, starting at offset 1.

Subsequent call to ingres_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Ejemplo 1. ingres_fetch_row() example

<?php
ingres_connect ($database, $user, $password);

ingres_query ("select * from table");
while ($row = ingres_fetch_row()) {
    echo $row[1];
    echo $row[2];
}
?>

See also
ingres_num_fields(),
ingres_query(),
ingres_fetch_array() and
ingres_fetch_object().

Anterior | Inicio | Siguiente
ingres_fetch_array | Subir | ingres_fetch_object


ingres_fetch_object

(PHP 4 >= 4.0.2)

ingres_fetch_object -- Fetch a row of result into an object.

Description

object ingres_fetch_object ( [int result_type [, resource link]])

ingres_fetch_object() Returns an object that corresponds to the fetched row, or FALSE if there are no more rows.

This function is similar to ingres_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

The optional argument result_type is a constant and can take the following values: II_ASSOC, II_NUM, and II_BOTH.

Speed-wise, the function is identical to ingres_fetch_array(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

Ejemplo 1. ingres_fetch_object() example

<?php
ingres_connect ($database, $user, $password);
ingres_query ("select * from table");
while ($row = ingres_fetch_object()) {
    echo $row->user_id;
    echo $row->fullname;
}
?>

See also
ingres_query(),
ingres_num_fields(),
ingres_field_name(),
ingres_fetch_array() and
ingres_fetch_row().

Anterior | Inicio | Siguiente
ingres_fetch_row | Subir | ingres_rollback


ingres_rollback

(PHP 4 >= 4.0.2)

ingres_rollback -- Roll back a transaction.

Description

bool ingres_rollback ( [resource link])

ingres_rollback() rolls back the currently open transaction, actualy canceling all changes made to the database during the transaction.

This closes the transaction. A new one can be open by sending a query with ingres_query().

See also
ingres_query(),
ingres_commit() and
ingres_autocommit().

Anterior | Inicio | Siguiente
ingres_fetch_object | Subir | ingres_commit


ingres_commit

(PHP 4 >= 4.0.2)

ingres_commit -- Commit a transaction.

Description

bool ingres_commit ( [resource link])

ingres_commit() commits the currently open transaction, making all changes made to the database permanent.

This closes the transaction. A new one can be open by sending a query with ingres_query().

You can also have the server commit automaticaly after every query by calling ingres_autocommit() before opening the transaction.

See also
ingres_query(),
ingres_rollback() and
ingres_autocommit().

Anterior | Inicio | Siguiente
ingres_rollback | Subir | ingres_autocommit


ingres_autocommit

(PHP 4 >= 4.0.2)

ingres_autocommit -- Switch autocommit on or off.

Description

bool ingres_autocommit ( [resource link])

ingres_autocommit() is called before opening a transaction (before the first call to ingres_query() or just after a call to ingres_rollback() or ingres_autocommit()) to switch the "autocommit" mode of the server on or off (when the script begins the autocommit mode is off).

When the autocommit mode is on, every query is automaticaly commited by the server, as if ingres_commit() was called after every call to ingres_query().

See also
ingres_query(),
ingres_rollback() and
ingres_commit().

Anterior | Inicio | Siguiente
ingres_commit | Subir | IRC Gateway Functions


IRC Gateway Functions

Manual de PHP
Anterior Siguiente

XLVI. IRC Gateway Functions

What is ircg?

With ircg you can build powerful, fast and scalable webchat solutions in conjunction with dedicated or public IRC servers.

Platforms

IRCG runs under

  • AIX

  • FreeBSD

  • HP-UX

  • Irix

  • Linux

  • Solaris

  • Tru64

Requirements

To install and use IRCG you need the following software:

  1. IRCG-Library from Sascha Schumann.

  2. SGI Static Threads Library

  3. thttpd webserver

Installation

A detailed installation instruction can be found here.

Tabla de contenidos
ircg_pconnect — Connect to an IRC server
ircg_fetch_error_msg — Returns the error from previous ircg operation
ircg_set_current — Set current connection for output
ircg_join — Join a channel on a connected server
ircg_part — Leave a channel on server
ircg_msg — Send message to channel or user on server
ircg_notice — Send a notice to a user on server
ircg_nick — Change nickname on server
ircg_topic — Set topic for channel on server
ircg_channel_mode — Set channel mode flags for user
ircg_html_encode — Encodes HTML preserving output
ircg_whois — Query user information for nick on server
ircg_kick — Kick a user out of a channel on server
ircg_ignore_add — Add a user to your ignore list on a server
ircg_ignore_del — Remove a user from your ignore list on a server
ircg_disconnect — Close connection to server
ircg_is_conn_alive — Check connection status
ircg_lookup_format_messages — Select a set of format strings for display of IRC messages
ircg_register_format_messages — Register a set of format strings for display of IRC messages
ircg_set_on_die — Set hostaction to be execute when connection dies
ircg_set_file — Set logfile for connection
ircg_get_username — Get username for connection
ircg_nickname_escape — Encode special characters in nickname to be IRC-compliant
ircg_nickname_unescape — Decodes encoded nickname

Anterior | Inicio | Siguiente
ingres_autocommit | Subir | ircg_pconnect


ircg_pconnect

(PHP 4 >= 4.0.4)

ircg_pconnect -- Connect to an IRC server

Description

resource ircg_pconnect ( string username [, string server_ip [, int server_port [, string msg_format [, array ctcp_messages [, array user_settings]]]]])

ircg_pconnect() will try to establish a connection to an IRC server and return a connection resource handle for further use.

The only mandatory parameter is username, this will set your initial nickname on the server. server_ip and server_port are optional and default to 127.0.0.1 and 6667.

Nota: For now parameter server_ip will not do any hostname lookups and will only accept IP addresses in numerical form.

Currently ircg_pconnect() always returns a valid handle, even if the connection failed.

You can customize the output of IRC messages and events by selection a format string set previously created with ircg_register_format_messages() by specifing the sets name in msg_format.

ctcp_messages

user_settings

See also: ircg_disconnect(),
ircg_is_conn_alive(),
ircg_register_format_messages().

Anterior | Inicio | Siguiente
IRC Gateway Functions | Subir | ircg_fetch_error_msg


ircg_fetch_error_msg

(PHP 4 >= 4.1.0)

ircg_fetch_error_msg -- Returns the error from previous ircg operation

Description

array ircg_fetch_error_msg ( resource connection)

ircg_fetch_error_msg() returns the error from the last called ircg function.

Nota: Errorcode is stored in first array element, errortext in second.

Ejemplo 1. ircg_fetch_error_msg() example

if (!ircg_join ($id, "#php")) {
    $error = ircg_fetch_error_msg($id);
    print ("Can't join channel #php. Errorcode:
            $error[0] Description: $error[1]");
}

Anterior | Inicio | Siguiente
ircg_pconnect | Subir | ircg_set_current


ircg_set_current

(PHP 4 >= 4.0.4)

ircg_set_current -- Set current connection for output

Description

boolean ircg_set_current ( resource connection)

Select the current connection for output in this execution context. Every output sent from the server connected to by connection will be copied to standard output while using default formatting or a format string set specified by ircg_register_format_messages() and selected by ircg_lookup_format_messages().

See also: ircg_register_format_messages() and ircg_lookup_format_messages().

Anterior | Inicio | Siguiente
ircg_fetch_error_msg | Subir | ircg_join


ircg_join

(PHP 4 >= 4.0.4)

ircg_join -- Join a channel on a connected server

Description

boolean ircg_join ( resource connection, string channel)

Join the channel channel on the server connected to by connection.

Anterior | Inicio | Siguiente
ircg_set_current | Subir | ircg_part


ircg_part

(PHP 4 >= 4.0.4)

ircg_part -- Leave a channel on server

Description

boolean ircg_part ( resource connection, string channel)

Leave the channel channel on the server connected to by connection.

Anterior | Inicio | Siguiente
ircg_join | Subir | ircg_msg


ircg_msg

(PHP 4 >= 4.0.4)

ircg_msg -- Send message to channel or user on server

Description

boolean ircg_msg ( resource connection, string recipient, string message [, boolean suppress])

ircg_msg() will send the message to a channel or user on the server connected to by connection. A recipient starting with # or & will send the message to a channel, anything else will be interpreted as a username.

Setting the optional parameter suppress to a TRUE value will suppress output of your message to your own connection.

Anterior | Inicio | Siguiente
ircg_part | Subir | ircg_notice


ircg_notice

(PHP 4 >= 4.0.5)

ircg_notice -- Send a notice to a user on server

Description

boolean ircg_notice ( resource connection, string , string message)

This function will send the message text to the user nick on the server connected to by connection. Query your IRC documentation of choice for the exact difference between a MSG and a NOTICE.

Anterior | Inicio | Siguiente
ircg_msg | Subir | ircg_nick


ircg_nick

(PHP 4 >= 4.0.5)

ircg_nick -- Change nickname on server

Description

boolean ircg_nick ( resource connection, string nick)

Change your nickname on the given connection to the one given in nick if possible.

Will return TRUE on success and FALSE on failure.

Anterior | Inicio | Siguiente
ircg_notice | Subir | ircg_topic


ircg_topic

(PHP 4 >= 4.0.5)

ircg_topic -- Set topic for channel on server

Description

boolean ircg_topic ( resource connection, string channel, string new_topic)

Change the topic for channel channel on the server connected to by connection to new_topic.

Anterior | Inicio | Siguiente
ircg_nick | Subir | ircg_channel_mode


ircg_channel_mode

(PHP 4 >= 4.0.5)

ircg_channel_mode -- Set channel mode flags for user

Description

boolean ircg_channel_mode ( resource connection, string channel, string mode_spec, string nick)

Set channel mode flags for channel on server connected to by connection. Mode flags are passed in mode_spec and are applied to the user specified by nick.

Mode flags are set or cleared by specifind a mode character and prepending it with a plus or minus character respectively. E.g. operator mode is granted by '+o' and revoked by '-o' passed as mode_spec.

Anterior | Inicio | Siguiente
ircg_topic | Subir | ircg_html_encode


ircg_html_encode

(PHP 4 >= 4.0.5)

ircg_html_encode -- Encodes HTML preserving output

Description

boolean ircg_html_encode ( string html_string)

Encodes a HTML string html_string for output. This feature could be usable, e.g. if someone wants to discuss about an html problem.

Anterior | Inicio | Siguiente
ircg_channel_mode | Subir | ircg_whois


ircg_whois

(PHP 4 >= 4.0.5)

ircg_whois -- Query user information for nick on server

Description

boolean ircg_whois ( resource connection, string nick)

Sends a query to the connected server connection to send information for the specified user nick.

Anterior | Inicio | Siguiente
ircg_html_encode | Subir | ircg_kick


ircg_kick

(PHP 4 >= 4.0.5)

ircg_kick -- Kick a user out of a channel on server

Description

boolean ircg_kick ( resource connection, string channel, string nick, string reason)

Kick user nick from channel on server connected to by connection. reason should give a short message describing why this action was performed.

Anterior | Inicio | Siguiente
ircg_whois | Subir | ircg_ignore_add


ircg_ignore_add

(PHP 4 >= 4.0.5)

ircg_ignore_add -- Add a user to your ignore list on a server

Description

boolean ircg_ignore_add ( resource connection, string nick)

This function will add user nick to your ignore list on the server connected to by connection. By doing so you will suppress all messages from this user from being send to you.

See also: ircg_ignore_del().

Anterior | Inicio | Siguiente
ircg_kick | Subir | ircg_ignore_del


ircg_ignore_del

(PHP 4 >= 4.0.5)

ircg_ignore_del -- Remove a user from your ignore list on a server

Description

boolean ircg_ignore_del ( resource connection, string nick)

This function remove user nick from your ignore list on the server connected to by connection.

See also: ircg_ignore_add().

Anterior | Inicio | Siguiente
ircg_ignore_add | Subir | ircg_disconnect


ircg_disconnect

(PHP 4 >= 4.0.4)

ircg_disconnect -- Close connection to server

Description

boolean ircg_disconnect ( resource connection, string reason)

ircg_disconnect() will close a connection to a server previously established with ircg-pconnect().

See also: ircg_pconnect().

Anterior | Inicio | Siguiente
ircg_ignore_del | Subir | ircg_is_conn_alive


ircg_is_conn_alive

(PHP 4 >= 4.0.5)

ircg_is_conn_alive -- Check connection status

Description

boolean ircg_is_conn_alive ( resource connection)

ircg_is_conn_alive() returns TRUE if connection is still alive and working or FALSE if the server no longer talks to us.

Anterior | Inicio | Siguiente
ircg_disconnect | Subir | ircg_lookup_format_messages


ircg_lookup_format_messages

(PHP 4 >= 4.0.5)

ircg_lookup_format_messages -- Select a set of format strings for display of IRC messages

Description

boolean ircg_lookup_format_messages ( string name)

Select the set of format strings to use for display of IRC messages and events. Sets may be registered with ircg_register_format_messages(), a default set named ircg is always available.

See also: ircg_register_format_messages()

Anterior | Inicio | Siguiente
ircg_is_conn_alive | Subir | ircg_register_format_messages


ircg_register_format_messages

(PHP 4 >= 4.0.5)

ircg_register_format_messages -- Register a set of format strings for display of IRC messages

Description

boolean ircg_register_format_messages ( string name, array messages)

With ircg_register_format_messages() you can customize the way your IRC output looks like. You can even register different format string sets and switch between them on the fly with ircg_lookup_format_messages().

  • Plain channel message

  • Private message received

  • Private message sent

  • Some user leaves channel

  • Some user enters channel

  • Some user was kicked from the channel

  • Topic has been changed

  • Error

  • Fatal error

  • Join list end(?)

  • Self part(?)

  • Some user changes his nick

  • Some user quits his connection

  • Mass join begin

  • Mass join element

  • Mass join end

  • Whois user

  • Whois server

  • Whois idle

  • Whois channel

  • Whois end

  • Voice status change on user

  • Operator status change on user

  • Banlist

  • Banlist end

  • %f - from

  • %t - to

  • %c - channel

  • %r - plain message

  • %m - encoded message

  • %j - js encoded message

  • 1 - mod encode

  • 2 - nickname decode

See also: ircg_lookup_format_messages().

Anterior | Inicio | Siguiente
ircg_lookup_format_messages | Subir | ircg_set_on_die


ircg_set_on_die

(PHP 4 >= 4.2.0)

ircg_set_on_die -- Set hostaction to be execute when connection dies

Description

bool ircg_set_on_die ( int connection, string host, int port, string data)

In case of the termination of connection connection IRCG will connect to host at port (Note: host must be an IPv4 address, IRCG does not resolve host-names due to blocking issues), send data to the new host connection and will wait until the remote part closes connection. This can be used to trigger a php script for example.

Anterior | Inicio | Siguiente
ircg_register_format_messages | Subir | ircg_set_file


ircg_set_file

(PHP 4 >= 4.2.0)

ircg_set_file -- Set logfile for connection

Description

bool ircg_set_file ( int connection, string path)

Function ircg_set_file() specifies a logfile path in which all output from connection connection will be logged. Returns TRUE on success, otherwise FALSE.

Anterior | Inicio | Siguiente
ircg_set_on_die | Subir | ircg_get_username


ircg_get_username

(PHP 4 >= 4.1.0)

ircg_get_username -- Get username for connection

Description

string ircg_get_username ( int connection)

Function ircg_get_username() returns the username for specified connection connection. Returns FALSE if connection died or is not valid.

Anterior | Inicio | Siguiente
ircg_set_file | Subir | ircg_nickname_escape


ircg_nickname_escape

(PHP 4 >= 4.0.6)

ircg_nickname_escape -- Encode special characters in nickname to be IRC-compliant

Description

string ircg_nickname_escape ( string nick)

Function ircg_nickname_escape() returns a decoded nickname specified by nick wich is IRC-compliant.

See also: ircg_nickname_unescape()

Anterior | Inicio | Siguiente
ircg_get_username | Subir | ircg_nickname_unescape


ircg_nickname_unescape

(PHP 4 >= 4.0.6)

ircg_nickname_unescape -- Decodes encoded nickname

Description

string ircg_nickname_unescape ( string nick)

Function ircg_nickname_unescape() returns a decoded nickname, which is specified in nick.

See also: ircg_nickname_escape()

Anterior | Inicio | Siguiente
ircg_nickname_escape | Subir | Java


Java

Manual de PHP
Anterior Siguiente

XLVII. Java

There are two possible ways to bridge PHP and Java: you can either integrate PHP into a Java Servlet environment, which is the more stable and efficient solution, or integrate Java support into PHP. The former is provided by a SAPI module that interfaces with the Servlet server, the latter by the Java extension.

PHP 4 ext/java provides a simple and effective means for creating and invoking methods on Java objects from PHP. The JVM is created using JNI, and everything runs in-process. Build instructions for ext/java can be found in php4/ext/java/README.

Ejemplo 1. Java Example

<?php
  // get instance of Java class java.lang.System in PHP
  $system = new Java('java.lang.System');

  // demonstrate property access
  print 'Java version='.$system->getProperty('java.version').' <br>';
  print 'Java vendor=' .$system->getProperty('java.vendor').'  <br>';
  print 'OS='.$system->getProperty('os.name').' '.
              $system->getProperty('os.version').' on '.
              $system->getProperty('os.arch').' <br>';

  // java.util.Date example
  $formatter = new Java('java.text.SimpleDateFormat',
                        "EEEE, MMMM dd, yyyy 'at' h:mm:ss a zzzz");

  print $formatter->format(new Java('java.util.Date'));
?>

Ejemplo 2. AWT Example

<?php
  // This example is only intented to be run as a CGI.

  $frame  = new Java('java.awt.Frame', 'PHP');
  $button = new Java('java.awt.Button', 'Hello Java World!');

  $frame->add('North', $button);
  $frame->validate();
  $frame->pack();
  $frame->visible = True;

  $thread = new Java('java.lang.Thread');
  $thread->sleep(10000);

  $frame->dispose();
?>
Notes:

  • new Java() will create an instance of a class if a suitable constructor is available. If no parameters are passed and the default constructor is useful as it provides access to classes like java.lang.System which expose most of their functionallity through static methods.

  • Accessing a member of an instance will first look for bean properties then public fields. In other words, print $date.time will first attempt to be resolved as $date.getTime(), then as $date.time.

  • Both static and instance members can be accessed on an object with the same syntax. Furthermore, if the java object is of type java.lang.Class, then static members of the class (fields and methods) can be accessed.

  • Exceptions raised result in PHP warnings, and NULL results. The warnings may be eliminated by prefixing the method call with an "@" sign. The following APIs may be used to retrieve and reset the last error:

    • java_last_exception_get()

    • java_last_exception_clear()

  • Overload resolution is in general a hard problem given the differences in types between the two languages. The PHP Java extension employs a simple, but fairly effective, metric for determining which overload is the best match.

    Additionally, method names in PHP are not case sensitive, potentially increasing the number of overloads to select from.

    Once a method is selected, the parameters are cooerced if necessary, possibly with a loss of data (example: double precision floating point numbers will be converted to boolean).

  • In the tradition of PHP, arrays and hashtables may pretty much be used interchangably. Note that hashtables in PHP may only be indexed by integers or strings; and that arrays of primitive types in Java can not be sparse. Also note that these constructs are passed by value, so may be expensive in terms of memory and time.

sapi/servlet builds upon the mechanism defined by ext/java to enable the entire PHP processor to be run as a servlet. The primary advanatage of this from a PHP perspective is that web servers which support servlets typically take great care in pooling and reusing JVMs. Build instructions for the Servlet SAPI module can be found in php4/sapi/README. Notes:

  • While this code is intended to be able to run on any servlet engine, it has only been tested on Apache's Jakarta/tomcat to date. Bug reports, success stories and/or patches required to get this code to run on other engines would be appreciated.

  • PHP has a habit of changing the working directory. sapi/servlet will eventually change it back, but while PHP is running the servlet engine may not be able to load any classes from the CLASSPATH which are specified using a relative directory syntax, or find the work directory used for administration and JSP compilation tasks.

Tabla de contenidos
java_last_exception_clear — Clear last Java exception
java_last_exception_get — Get last Java exception

Anterior | Inicio | Siguiente
ircg_nickname_unescape | Subir | java_last_exception_clear


java_last_exception_clear

(PHP 4 >= 4.0.2)

java_last_exception_clear -- Clear last Java exception

Description

void java_last_exception_clear ( void)

Anterior | Inicio | Siguiente
Java | Subir | java_last_exception_get


java_last_exception_get

(PHP 4 >= 4.0.2)

java_last_exception_get -- Get last Java exception

Description

exception java_last_exception_get ( void)

The following example demonstrates the usage of Java's exception handler from within PHP:

Ejemplo 1. Java exception handler

<?php
  $stack = new Java('java.util.Stack');
  $stack->push(1);

  // This should succeed
  $result = $stack->pop();
  $ex = java_last_exception_get();
  if (!$ex) print "$result\n";

  // This should fail (error suppressed by @)
  $result = @$stack->pop();
  $ex = java_last_exception_get();
  if ($ex) print $ex->toString();

  // Clear last exception
  java_last_exception_clear();
?>

Anterior | Inicio | Siguiente
java_last_exception_clear | Subir | Funciones LDAP


Funciones LDAP

Manual de PHP
Anterior Siguiente

XLVIII. Funciones LDAP

Introducción a LDAP

LDAP es el protocolo de acceso a directorios ligero (Lightweight Directory Access Protocol), un protocolo usado para acceder a "Servidores de Directorio". El directorio es una clase especial de base de datos que contiene información estructurada en forma de árbol.

El concepto es similar a la estructura de directorios de los discos duros, pero en este caso, el directorio raiz es "El Mundo" y los subdirectorios de primer nivel son los "países". Niveles inferiores de la estructura de directorio contienen entradas para compañías, organizaciones o lugares, y en niveles aún inferiores se encuentran las entradas para la gente, y quizás de equipos informáticos y documentos.

Para referirse a un fichero en un subdirectorio del disco duro se usa algo como

/usr/local/misapps/docs

Las barras marcan cada división en la referencia al fichero, y la secuencia es leida de izquierda a derecha.

El equivalente a la referencia a un fichero en LDAP es el "distinguished name" (nombre distinguible), abreviado como "db". Un ejemplo de dn podría ser.

cn=Pedro Pérez,ou=Contabilidad,o=Mi Compañía,c=ES

Las comas marcan cada división en la referencia, y la secuencia se lee de derecha a izquierda. Este dn se leería como ..

country = ES
organization = Mi Compañía
organizationalUnit = Contabilidad
commonName = Pedro Pérez

De la misma manera que no hay reglas estrictas sobre como organizar la estructura de directorios de un disco duro, un administrador de un servidor de directorio puede establecer cualquier estructura que sea útil para sus propósitos. Sin embargo hay algunos acuerdos tácitos que siempre deben seguirse. El mensaje es que no se puede escribir código para acceder un directorio si no se conoce algo de su estructura, igual que no se puede usar una base de datos sin algún conocimiento sobre lo que está disponible en ella.

Ejemplo de código completo

Recuperar informacion para todas las entradas donde el apellido empiece por "P" de un servidor de directorio, mostrando un extracto con el nombre y dirección de correo electrónico.

Ejemplo 1. ejemplo de búsqueda LDAP

<?php
// La secuencia básica para trabajar con LDAP es conectar, autentificarse,
// buscar, interpretar el resultado de la búsqueda y cerrar la conexión.

echo "<h3>Prueba de consulta LDAP</h3>";
echo "Conectando ...";
$ds=ldap_connect("localhost");  // Debe ser un servidor LDAP válido!
echo "El resultado de la conexión es ".$ds."<p>";

if ($ds) {
    echo "Autentificandose  ...";
    $r=ldap_bind($ds);     // Autentificación anónima, típicamente con
                           // acceso de lectura
    echo "El resultado de la autentificación es ".$r."<p>";

    echo "Buscando (sn=P*) ...";
    // Busqueda de entradas por apellidos
    $sr=ldap_search($ds,"o=Mi Compañia, c=ES", "sn=P*");
    echo "El resultado de la búsqueda es ".$sr."<p>";

    echo "El número de entradas devueltas es ".ldap_count_entries($ds,$sr)."<p>";

    echo "Recuperando entradas ...<p>";
    $info = ldap_get_entries($ds, $sr);
    echo "Devueltos datos de ".$info["count"]." entradas:<p>";

    for ($i=0; $i<$info["count"]; $i++) {
        echo "dn es: ". $info[$i]["dn"] ."<br>";
        echo "La primera entrada cn es: ". $info[$i]["cn"][0] ."<br>";
        echo "La primera entrada email es: ". $info[$i]["mail"][0] ."<p>";
    }

    echo "Cerrando conexión";
    ldap_close($ds);

} else {
    echo "<h4>Ha sido imposible conectar al servidor LDAP</h4>";
}
?>

Usando las llamadas LDAP de PHP

Es necesario conseguir y compilar la librerías cliente de LDAP ya sea del paquete ldap-3.3 de la Universidad de Michigan o del Netscape Directory SDK. También es necesario recompilar PHP con soporte LDAP activado para que la funciones LDAP de PHP funcionen.

Antes de usarse las llamadas LDAP se debe saber ..

  • El nombre o dirección del servidor de directorio que se va a usar

  • El "dn base" del servidor (la parte del directorio global contenida en ese servidor, que puede ser por ejemplo "o=Mi Compañia,c=ES")

  • Si es necesaria contraseña para acceder al servidor (muchos servidores ofrecen acceso de lectura para usuarios anónimos pero requieren un password para cualquier otro acceso)

La secuencia típica de llamadas LDAP suele implementarse en aplicaciones que siguen el siguiente patrón:

ldap_connect() // establecer la conexión con el servidor
|
ldap_bind() // login anónimo o autentificado
|
Hacer búsquedas o actualizaciones en el directorio
y mostrar los resultados
|
ldap_close() // Cerrar la conexión

Más información

Mucha información acerca de LDAP puede ser consultada en

  • Netscape

  • Universidad de Michigan

  • Proyecto OpenLDAP

  • LDAP World

El SDK de Netscape contiene una Guía de Programación muy útil en formato html.

Tabla de contenidos
ldap_add — Añade entradas a un directorio LDAP
ldap_bind — Autentifica en un directorio LDAP
ldap_close — Cierra una conexión a un servidor LDAP
ldap_connect — Conecta con un servidor LDAP
ldap_count_entries — Cuenta el número de entradas de una búsqueda
ldap_delete — Borra una entrada de un directorio
ldap_dn2ufn — Convierte un dn al formato User Friendly Naming
ldap_err2str — Convierte un código numérico de error LDAP en un mensaje.
ldap_errno — Devuelve el código numérico de error para el último comando LDAP.
ldap_error — Devuelte el mensaje de error del último comando LDAP
ldap_explode_dn — Divide un DN en las partes que le componen
ldap_first_attribute — Devuelte el primer atributo
ldap_first_entry — Devuelve el identificador del primer resultado
ldap_free_result — Libera la memoria que almacena los resultados
ldap_get_attributes — Obtiene los atributos de una entrada de un resultado de búsqueda
ldap_get_dn — Obtiene el DN de una entrada de un resultado
ldap_get_entries — Obtiene todas las entradas de un resultado
ldap_get_values — Obtiene todos los valores de un atributo de una entrada
ldap_get_values_len — Obtiene todos los valores binarios de un atributo de una entrada
ldap_list — Búsqueda Single-level (Nivel Único)
ldap_mod_add — Añade valores de atributos
ldap_mod_del — Borra valores de atributos
ldap_mod_replace — Reemplaza valores de atributos
ldap_modify — Modifica una entrada LDAP
ldap_next_attribute — Obtiene el siguiente atributo de una entrada
ldap_next_entry — Obtiene la siguiente entrada de un resultado
ldap_read — Lee una entrada
ldap_search — Busca en un arbol LDAP
ldap_unbind — Hace logout de un directorio LDAP

Anterior | Inicio | Siguiente
java_last_exception_get | Subir | ldap_add


ldap_add

(PHP 3, PHP 4 >= 4.0.0)

ldap_add -- Añade entradas a un directorio LDAP

Descripción

int ldap_add ( int identificador_de_conexion, string dn, array entrada)

Devuelve verdadero cuando finaliza correctamente y falso se produce un error.

La función ldap_add() se usa para añadir entradas o registros a un directorio LDAP. El DN ("distinguished name", nombre distinguible, la referencia de cualquier entrada LDAP) es especificado por dn. El array entrada especifica la información que quiere añadirse. Los valores del array son indexados por sus propios atributos. En caso de valores múltiples para un mismo atributo, son indexados usando enteros empezando con 0.

entry["atributo1"] = valor
entry["atributo2"][0] = valor1
entry["atributo2"][1] = valor2

Ejemplo 1. Ejemplo completo con login atentificado

<?php
$ds=ldap_connect("localhost");  // Asumimos que el servidor LDAP está en el
                                // servidor local

if ($ds) {
    // autentificarse con el dn apropiado para tener permisos de modificación
    $r=ldap_bind($ds,"cn=root, o=Mi Compañia, c=ES", "secreto");

    // prepare data
    $info["cn"]="Pedro Pérez";
    $info["sn"]="Pedro";
    $info["mail"]="pedro.p@algun.sitio";
    $info["objectclass"]="persona";

    // add data to directory
    $r=ldap_add($ds, "cn=Pedro Pérez, o=Mi Compañia, c=ES", $info);

    ldap_close($ds);
} else {
    echo "Ha sido imposible conectar al servidor LDAP";
}
?>

Anterior | Inicio | Siguiente
Funciones LDAP | Subir | ldap_bind


ldap_mod_add

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

ldap_mod_add -- Añade valores de atributos

Descripción

int ldap_mod_add ( int identificador_de_conexion, string dn, array entrada)

Devuelve verdadero cuando finaliza correctamente y falso se produce un error.

Esta función añadir uno o varios atributos al dn especificado. Realiza la modificación al nivel de atributos, en vez de hacerlo al nivel de objetos. Las modificaciones a nivel de objeto son propocionadas por la función ldap_add().

Anterior | Inicio | Siguiente
ldap_list | Subir | ldap_mod_del


ldap_mod_del

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

ldap_mod_del -- Borra valores de atributos

Descripción

int ldap_mod_del ( int identificador_de_conexion, string dn, array entrada)

returns TRUE on success and FALSE on error.

Esta función elimina atributos del dn especificado. Realiza la modificación a nivel de atributos, en vez de hacerlo a nivel de objetos. Las modificaciones a nivel de objeto son proporcionadas por la función ldap_del().

Anterior | Inicio | Siguiente
ldap_mod_add | Subir | ldap_mod_replace


ldap_mod_replace

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

ldap_mod_replace -- Reemplaza valores de atributos

Descripción

int ldap_mod_replace ( int identificador_de_conexion, string dn, array entrada)

Devuelve verdadero cuando finaliza correctamente y falso se produce un error.

Esta función reemplaza atributos del dn especificado. Realiza la modificación a nivel de atributos, en vez de hacerlo a nivel de objetos. Las modificaciones a nivel de objeto son proporcionadas por la función ldap_modify().

Anterior | Inicio | Siguiente
ldap_mod_del | Subir | ldap_modify


ldap_bind

(PHP 3, PHP 4 >= 4.0.0)

ldap_bind -- Autentifica en un directorio LDAP

Descripción

int ldap_bind ( int identificador_de_conexion [, string rdn_del_usuario [, string contraseña]])

Se conecta a un directorio LDAP con un RDN y su contraseña. Devuelve verdadero cuando finaliza correctamente y falso se produce un error.

ldap_bind() se conecta al directorio con un determinado usuario. rdn_de_usuario y contraseña son opcionales. Si no son especificados, se intenta el acceso anónimo.

Anterior | Inicio | Siguiente
ldap_add | Subir | ldap_close


ldap_close

(PHP 3, PHP 4 >= 4.0.0)

ldap_close -- Cierra una conexión a un servidor LDAP

Descripción

int ldap_close ( int identificador_de_conexion)

Devuelve verdadero cuando finaliza correctamente y falso se produce un error.

ldap_close() cierra la conexión con el servidor LDAP asociada con el identificador_de_conexion especificado.

Esta llamada es idéntica internamente a ldap_unbind(). La API LDAP usa la llamada ldap_unbind(), y por lo tanto quizás deba usar esta llamada en lugar de ldap_close().

Anterior | Inicio | Siguiente
ldap_bind | Subir | ldap_connect


ldap_connect

(PHP 3, PHP 4 >= 4.0.0)

ldap_connect -- Conecta con un servidor LDAP

Descripción

int ldap_connect ( [string nombre_host [, int puerto]])

Devuelve un identificador de conexión positivo en caso de éxito, ó falso si ocurre algún error.

ldap_connect() establece una conexión con el servidor LDAP especificado en nombre_host y puerto. Ambos argumentos son opcionales. Si no se especifican, el identificador de la conexión LDAP actualmente abierta es devuelto. Si sólo es especificado nombre_host el puerto tomado por defecto es el 389.

Anterior | Inicio | Siguiente
ldap_close | Subir | ldap_count_entries


ldap_count_entries

(PHP 3, PHP 4 >= 4.0.0)

ldap_count_entries -- Cuenta el número de entradas de una búsqueda

Descripción

int ldap_count_entries ( int identificador_de_conexion, int identificador_de_resultado)

Devuelve el número de entradas del resultado o falso si ha ocurrido algún error.

ldap_count_entries() devuelce el número de entradas almacenadas en el resultado de operaciones de búsqueda previas. identificador_de_resultado identifica el resultado ldap interno al que hacemos referencia.

Anterior | Inicio | Siguiente
ldap_connect | Subir | ldap_delete


ldap_delete

(PHP 3, PHP 4 >= 4.0.0)

ldap_delete -- Borra una entrada de un directorio

Descripción

int ldap_delete ( int identificador_de_conexion, string dn)

Devuelve verdadero cuando finaliza correctamente y falso se produce un error.

La función ldap_delete() borra la entrada particular dn del directorio LDAP.

Anterior | Inicio | Siguiente
ldap_count_entries | Subir | ldap_dn2ufn


ldap_dn2ufn

(PHP 3, PHP 4 >= 4.0.0)

ldap_dn2ufn -- Convierte un dn al formato User Friendly Naming

Descripción

string ldap_dn2ufn ( string dn)

La función ldap_dn2ufn() es usada para convertir un DN en un formato más amigable para el usuario.

Anterior | Inicio | Siguiente
ldap_delete | Subir | ldap_err2str


ldap_explode_dn

(PHP 3, PHP 4 >= 4.0.0)

ldap_explode_dn -- Divide un DN en las partes que le componen

Descripción

array ldap_explode_dn ( string dn, int con_atributos)

La función ldap_explode_dn() es usada para dividir un DN devuelto por ldap_get_dn() en las partes que le componen. Cada parte es conocida como Relative Distinguished Name (Nombre Relativo Distinguible) abreviado como RDN. ldap_explode_dn() devuelve un array con todos esos componentes. con_atributos sirve para especificar si los RDN se devuelven sólo como valores o con sus atributos también (es decir, en un formato atributo=valor). Hay que poner with_attrib a 0 para obtener también los atributos y a 1 para obtener sólo los valores.

Anterior | Inicio | Siguiente
ldap_error | Subir | ldap_first_attribute


ldap_first_attribute

(PHP 3, PHP 4 >= 4.0.0)

ldap_first_attribute -- Devuelte el primer atributo

Descripción

string ldap_first_attribute ( int identificador_de_conexion, int identificador_de_entrada_en_resultado, int identificador_ber)

Devuelte el primer atributo en la entrada o falso si ocurre algún error.

De manera similar a leer entradas, los atributos también son leidos de uno en uno de una entrada en particular del directorio. ldap_first_attribute() devuelve el primer atributo en la entrada a la que apunta el identificador_de_entrada_en_resultado El resto de los atributos son obtenidos llamanda a la función ldap_next_attribute() sucesivamente. El parámetro indetificador_ber es el identificador del puntero interno a memoria. Es pasado por referencia. El mismo indetificador_ber es pasado a la función ldap_next_attribute() que modifica dicho puntero.

Ver también ldap_get_attributes()

Anterior | Inicio | Siguiente
ldap_explode_dn | Subir | ldap_first_entry


ldap_first_entry

(PHP 3, PHP 4 >= 4.0.0)

ldap_first_entry -- Devuelve el identificador del primer resultado

Descripción

int ldap_first_entry ( int identificador_de_conexion, int identificador_de_resultado)

Devuelve el identificador de la primera entrada del resultado ó falso en caso de error.

Las entradas en un resultado LDAP son leidas secuencialmente usando las funciones ldap_first_entry() y ldap_next_entry(). ldap_first_entry() devuelve el identificador de la primera entrada del resultado. Este identificador es entonces suministrado a la rutina lap_next_entry() pata obtener sucesivas entradas del resultado.

Ver también ldap_get_entries().

Anterior | Inicio | Siguiente
ldap_first_attribute | Subir | ldap_free_result


ldap_free_result

(PHP 3, PHP 4 >= 4.0.0)

ldap_free_result -- Libera la memoria que almacena los resultados

Descripción

int ldap_free_result ( int identificador_de_resultado)

Devuelve verdadero cuando finaliza correctamente y falso se produce un error.

ldap_free_result() libera la memoria reservada internamente para almacenar el resultado de búsquedas LDAP asociada al identificador identificador_de_resultado. Toda la memoria de resultados es automáticamente liberada al finalizarse la ejecución de un script.

Normalmente la memoria reservada para resultados ldap se libera al final del script. En caso de que el script realice sucesivas búsquedas que devuelvan conjuntos de resultados grandes, puede utilizarse ldap_free_result() para mantener bajo el uso de memoria del script durante su ejecución.

Anterior | Inicio | Siguiente
ldap_first_entry | Subir | ldap_get_attributes


ldap_get_attributes

(PHP 3, PHP 4 >= 4.0.0)

ldap_get_attributes -- Obtiene los atributos de una entrada de un resultado de búsqueda

Descripción

array ldap_get_attributes ( int identificador_de_conexion, int identificador_de_entrada_de_resultado)

Devuelve una completa información de la entrada en un array multidimensional o falso en caso de error.

La función ldap_get_attributes() es usada para simplificar el leer atributos y valores de una entrada de un resultado de búsqueda. El valor de retorno es un array multidimensional de atributos y sus valores.

Teniendo localizado una entrada específica en el directorio se puede conseguir la información que contiene dicha entrada usando esta llamada. Puede usar esta función para aplicaciones que naveguen por las entradas del directorio y/o cuando no se conoce la estructura de las entradas del directorio. En otras aplicaciones se busca un atributo específico, como la dirección de email o los apellidos y no importa el resto de información contenida..

valor_devuelto["count"] = número de atributos en la entrada
valor_devuelto[0] = primer atributo
valor_devuelto[n] = enésimo atributo

valor_devuelto["atributo"]["count"] = número de vaslores del atributo
valor_devuelto["atributo"][0] = primer valor del atributo
valor_devuelto["atributo"][i] = iésimo valor del atributo

Ejemplo 1. Mostrar la lista de atributos contenida en una entrada específica de un directorio

// $ds es un identificador de conexión al directorio

// $sr es un resultado de búsqueda válido de una llamada
// anterior a una de las funciones de búsqueda en directorios
// ldap.

$entrada = ldap_first_entry($ds, $sr);

$atributos = ldap_get_attributes($ds, $entrada);

echo $atributos["count"]." atributos contenidos en esta entrada:<p>";

for ($i=0; $i<$atributos["count"]; $i++)
    echo $atributos[$i]."<br>";

Ver también ldap_first_attribute() y ldap_next_attribute()

Anterior | Inicio | Siguiente
ldap_free_result | Subir | ldap_get_dn


ldap_get_dn

(PHP 3, PHP 4 >= 4.0.0)

ldap_get_dn -- Obtiene el DN de una entrada de un resultado

Descripción

string ldap_get_dn ( int indentificador_de_conexion, int indentificador_de_entrada_de_resultado)

Devuelve el DN de la entrada del resultado o falso en caso de error.

La función ldap_get_dn() se utiliza para obtener el DN de una entrada de un resultado de búsqueda.

Anterior | Inicio | Siguiente
ldap_get_attributes | Subir | ldap_get_entries


ldap_get_entries

(PHP 3, PHP 4 >= 4.0.0)

ldap_get_entries -- Obtiene todas las entradas de un resultado

Descripción

array ldap_get_entries ( int indentificador_de_conexion, int indentificador_de_resultado)

Devuelve una completa información de un resultado de búsqueda en un array multidimensional o falso en caso de error.

La función ldap_get_entries() es usada para simplificar el leer múltiples entradas de de un resultado y después leer sus atributos y multiples valores. Toda la información es devuelta por una llamada a una función en forma de array multidimensional. La estructura del array es como se muestra más abajo.

Los indices de atributos son convertidos a minúsculas. (Los atributos de servidores de directorios son indiferentes a las mayusculas/minusculas, pero no cuando son usados como indices de arrays)

valor_devuelto["count"] = número de entradas del resultado
valor_devuelto[0] : contiene los detalles de la primera entrada

valor_devuelto[i]["dn"] = DN de la entrada iésima del resultado

valor_devuelto[i]["count"] = número de atributos de la entrada iésima
valor_devuelto[i][j] = jésimo atributo de la iésima entrada del resultado

valor_devuelto[i]["atributo"]["count"] = número de valores para "atributo"
en la entrada iésima
valor_devuelto[i]["atributo"][j] = jésimo valor de "atributo" en la entrada
iésima

Ver también ldap_first_entry() y ldap_next_entry()

Anterior | Inicio | Siguiente
ldap_get_dn | Subir | ldap_get_values


ldap_get_values

(PHP 3, PHP 4 >= 4.0.0)

ldap_get_values -- Obtiene todos los valores de un atributo de una entrada

Descripción

array ldap_get_values ( int identificador_de_conexion, int identificador_de_entrada_de_resultado, string atributo)

Devuelve un array de valores del atributo o falso en caso de error.

La función ldap_get_values() se utiliza para obtener todos los valores de un atributo de una entrada. La entrada del resultado es especificada por el identificador_de_entrada_de_resultado. El número de valores se almacena en el índice "count" del array devuelto. Los valores individuales se almacenan con índices enteros en el array. El primer índice es 0.

Esta llamada necesita un identificador_de_entrada_de_resultado, por lo que necesita ser precedida por una de las llamadas de búsqueda ldap y una llamada para obtener una entrada en particular del resultado.

La aplicación debe ser o bien programada específicamente para buscar ciertos atributos (como apellidos o email) o bien utilizar la función ldap_get_attributes() para averiguar que atributos existen para una entrada dada, antes de llamar a ldap_get_values().

LDAP permite mas de un valor para cada atributo, por lo que se puede, por ejemplo, almacenar varias direcciones de email para una persona en el directorio y nombrar a ese atributo como "email"

valor_devuelto["count"] = número de valores del atributo
valor_devuelto[0] = primer valor del atributo
valor_devuelto[i] = iésimo valor del atributo

Ejemplo 1. Listar todos los valores del atributo "email" de una entrada de un directorio

// $ds es un identificador de conexión al directorio

// $sr es un resultado de búsqueda válido de una llamada
// anterior a una de las funciones de búsqueda en directorios
// ldap.

// $entrada es un identificador de entrada válido de una llamada
// anterior a una de las funciones que devuelven una entrada de
// directorio

$valores = ldap_get_values($ds, $entrada,"email");

echo $valores["count"]." direcciones de email para esta entrada.<p>";

for ($i=0; $i < $valores["count"]; $i++)
    echo $valores[$i]."<br>";

Anterior | Inicio | Siguiente
ldap_get_entries | Subir | ldap_get_values_len


ldap_get_values_len

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ldap_get_values_len -- Obtiene todos los valores binarios de un atributo de una entrada

Description

array ldap_get_values_len ( int indentificador_de_conexion, int indentificador_de_entrada_de_resultado, string atributo)

Devuelve un array de valores del atributo o falso en caso de error.

La función ldap_get_values_len() se utiliza para obtener todos los valores de un atributo de una entrada de un resultado de búsqueda. La entrada es especificada por el indentificador_de_entrada_de_resultado. El número de valores se almacena en el índice "count" del array devuelto. Los valores individuales se almacenan con índices enteros en el array. El primer índice es 0.

Esta función se utiliza exactamente como ldap_get_values() salvo que permite manejar datos binarios y no cadenas de caracteres.

Anterior | Inicio | Siguiente
ldap_get_values | Subir | ldap_list


ldap_list

(PHP 3, PHP 4 >= 4.0.0)

ldap_list -- Búsqueda Single-level (Nivel Único)

Descripción

int ldap_list ( int identificador_de_conexion, string dn_base, string filtro [, array atributos])

Devuelve un identificador de resultado de búsqueda o falso en caso de error.

ldap_list() realiza la búsqueda según el filtro especificado en el directorio con el alcance LDAP_SCOPE_ONELEVEL.

LDAP_SCOPE_ONELEVEL significa que la búsqueda solo devuelve información que se encuentre en el nivel inmediatamente inferior al dn_base especificado en la llamada a la función. (Equivalente a ejecutar "ls" en un unix y obtener un listado de ficheros y carpetas en el directorio de trabajo actual.)

Esta llamada toma un cuarto parámetro opcional, que es un array de los atributos requeridos. Consulte las notas de la función ldap_search().

Ejemplo 1. Produce una lista de todas las unidades organizativas de una compañía

// $ds es un identificador de conexión válido.

$dnbase = "o=Mi Compañía, c=ES";
$solonecesito = array("ou");

$sr=ldap_list($ds, $dnbase, "ou=*", $solonecesito);

$info = ldap_get_entries($ds, $sr);

for ($i=0; $i<$info["count"]; $i++)
    echo $info[$i]["ou"][0] ;

Anterior | Inicio | Siguiente
ldap_get_values_len | Subir | ldap_mod_add


ldap_modify

(PHP 3, PHP 4 >= 4.0.0)

ldap_modify -- Modifica una entrada LDAP

Descripción

int ldap_modify ( int identificador_de_conexion, string dn, array entrada)

Devuelve verdadero cuando finaliza correctamente y falso se produce un error.

La función ldap_modify() se utiliza para modificar entradas existentes en un directorio LDAP. La estructura de la entrada es igual a la de ldap_add().

Anterior | Inicio | Siguiente
ldap_mod_replace | Subir | ldap_next_attribute


ldap_next_attribute

(PHP 3, PHP 4 >= 4.0.0)

ldap_next_attribute -- Obtiene el siguiente atributo de una entrada

Descripción

string ldap_next_attribute ( int identificador_de_conexion, int identificador_de_entrada_de_resultado, int identificador_ber)

Devuelve el siguiente atributo de una entrada o falso en caso de error.

ldap_next_attribute() es llamado para recuperar los atributos de una entrada. El estado interno del puntero es mantenido por el identificador_ber, que es pasado por referencia a la función. La primera llamada a ldap_next_attribute() es realizada con el identificador_de_entrada_de_resultado devuelto por la función ldap_first_attribute().

Ver también ldap_get_attributes()

Anterior | Inicio | Siguiente
ldap_modify | Subir | ldap_next_entry


ldap_next_entry

(PHP 3, PHP 4 >= 4.0.0)

ldap_next_entry -- Obtiene la siguiente entrada de un resultado

Descripción

int ldap_next_entry ( int identificador_de_conexion, int identificador_de_entrada_de_resultado)

Devuelve el identificador de la siguiente entrada del resultado. Las entradas deben haber sido leidas al principio con ldap_first_entry(). Si no hay más entradas en el resultado devuelve falso.

La función ldap_next_entry() se utiliza para obtener las entradas almacenadas en un resultado. Llamadas sucesivas a la función ldap_next_entry() devuelven las entradas una a una hasta que ya no queden más entradas. La primera llamada a ldap_next_entry() se realiza después de llamar a ldap_first_entry().

Ver también ldap_get_entries()

Anterior | Inicio | Siguiente
ldap_next_attribute | Subir | ldap_read


ldap_read

(PHP 3, PHP 4 >= 4.0.0)

ldap_read -- Lee una entrada

Descripción

int ldap_read ( int identificador_de_conexión, string dn_base, string filtro [, array atributos])

Devuelve un identificador de resultado de búsqueda o falso en caso de error.

ldap_read() realiza la búsqueda según el filtro especificado con alcance LDAP_SCOPE_BASE, por lo que es equivalente a leer cualquier entrada del directorio.

No se permiten filtros vacios. Si se pretende obtener absolutamente toda la información, se debe usar un filtro del tipo "objectClass=*". Si conoce que tipos de entradas son usadas en el servidor de directorio es conveniente usar el filtro apropiado, como por ejemplo "objectClass=inetOrgPerson".

Esta llamada toma un cuarto parámetro opcional que es un array de los atributos requeridos. Consulte las notas de la función ldap_search().

Anterior | Inicio | Siguiente
ldap_next_entry | Subir | ldap_search


ldap_search

(PHP 3, PHP 4 >= 4.0.0)

ldap_search -- Busca en un arbol LDAP

Descripción

int ldap_search ( int identificador_de_conexion, string dn_base, string filtro [, array atributos])

Devuelve un identificador de resultado de búsqueda o falso en caso de error.

ldap_search() realiza la búsqueda según el filtro especificado con alcance LDAP_SCOPE_SUBTREE. Esto es equivalente a buscar en el directorio entero. dn_base especifica el DN base para el directorio.

Existe un cuarto parámetro opcional que puede ser añadido para restringir los atributos y valores devueltos por el servidor a sólo los requeridos. Es mucho más eficiente que la acción por defecto (que devolverá todos los atributos y sus valores asociados). El uso del cuarto parámetro debe ser por tanto considerado una práctica recomendable.

El cuerto parámetro es un array estándar de PHP con los atributos requeridos, por ejemplo array("email","sn","cn"). Nota: "dn" siempre es devuelto independientemente de que tipos de atributos sean solicitados.

También es necesario resaltar que algunos servidores de directorio están configurados para devolver un cierto número de entradas como máximo. Si esto ocurre, el servidor indicará que solo devuelve un conjunto de resultados parcial.

El filtro de búsqueda puede ser simple o avanzado, usando operadores booleanos en el formato descrito en la documentación sobre LDAP (Consulte el Netscape Directory SDK para obtener completa información sobre filtros).

El ejemplo de abajo recupera la unidad organizativa (ou), apellidos nombre común y dirección de email para todas las personas de "Mi Compañía" donde los apellidos o el nombre común contiene la subcadena $persona. Este ejemplo usa un filtro booleano para indicar al servidor que busque la información en más de un atributo.

Ejemplo 1. Búsqueda LDAP

// $ds es un identificador de conexión válido

// $persona es todo o parte del nombre de una persona, por ejemplo "Pe"

$dn = "o=Mi Compañía, c=ES";
$filtro="(|(sn=$persona*)(givenname=$persona*))";
$solonecesito = array( "ou", "sn", "givenname", "mail");

$sr=ldap_search($ds, $dn, $filtro, $solonecesito);

$info = ldap_get_entries($ds, $sr);

print $info["count"]." entradas devueltas<p>";

Anterior | Inicio | Siguiente
ldap_read | Subir | ldap_unbind


ldap_unbind

(PHP 3, PHP 4 >= 4.0.0)

ldap_unbind -- Hace logout de un directorio LDAP

Descripción

int ldap_unbind ( int identificador_de_conexion)

Devuelve verdadero cuando finaliza correctamente y falso se produce un error.

La función ldap_unbind() hace logout, desautentifica de un directorio LDAP.

Anterior | Inicio | Siguiente
ldap_search | Subir | Funciones de Correo


ldap_err2str

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

ldap_err2str -- Convierte un código numérico de error LDAP en un mensaje.

Descripción

string ldap_err2str ( int numerr)

Devuelve una cadena con el mensaje de error.

Esta función devuelve una cadena con el mensaje de error explicativo del código numérico de error numerr. Aunque los códigos de error LDAP están estandarizados, diferentes librerías devuelven mensajes textuales de error diferentes o incluso localizados. Nunca se debe comprobar la existencia de un error específico por el mensaje textual, sino por el código numérico.

Var también ldap_errno() y ldap_error().

Ejemplo 1. Enumerando todos los mensajes de error LDAP

<?php
  for($i=0; $i<100; $i++) {
    printf("Error $i: %s<br>\n", ldap_str2err($i));
  }
?>

Anterior | Inicio | Siguiente
ldap_dn2ufn | Subir | ldap_errno


ldap_errno

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

ldap_errno -- Devuelve el código numérico de error para el último comando LDAP.

Descripción

int ldap_errno ( int identificador_de_conexión)

Devuelve el código de error del último comando LDAP para la conexión especificada.

Esta función devuelve el código numérico de error, que está estandarizado, producido por el último comando LDAP y en la conexión especificada. Este número puede ser convertido en un mensaje textual de error usando ldap_err2str().

A menos que decremente el nivel de alerta en su fichero php3.ini (ó php.ini) o anteponga a los comandos LDAP en símbolo @ (arroba) para suprimir las alertas y warnings, los errores producidos serán mostrados automáticamente en el código HTML generado.

Ejemplo 1. Generando y capturando un error

<?php
// Este ejemplo contiene un error, que será capturado.
$ld = ldap_connect("localhost");
$bind = ldap_bind($ld);
// error de sintaxis en la expresión del filtro (codigo
// de error 87). Debería ser "objectclass=*".
$res =  @ldap_search($ld, "o=Mi Compañía, c=ES", "objectclass");
if (!$res) {
    printf("LDAP-Código  Error: %s<br>\n", ldap_errno($ld));
    printf("LDAP-Mensaje Error: %s<br>\n", ldap_error($ld));
    die("Argh!<br>\n");
}
$info = ldap_get_entries($ld, $res);
printf("%d entradas encontradas.<br>\n", $info["count"]);
?>

Ver también ldap_err2str() y ldap_error().

Anterior | Inicio | Siguiente
ldap_err2str | Subir | ldap_error


ldap_error

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

ldap_error -- Devuelte el mensaje de error del último comando LDAP

Descripción

string ldap_error ( int identificador_de_conexión)

Devuelve una cadena con el mensaje de error.

Esta función devuelve una cadena con el mensaje de error explicativo del error generado por el último comando LDAP en la conexión especificada. Aunque los códigos de error LDAP están estandarizados, diferentes librerías devuelven mensajes textuales de error diferentes o incluso localizados. Nunca se debe comprobar la existencia de un error específico por el mensaje textual, sino por el código numérico.

A menos que decremente el nivel de alerta en su fichero php3.ini (ó php.ini) o anteponga a los comandos LDAP en símbolo @ (arroba) para suprimir las alertas y warnings, los errores producidos serán mostrados automáticamente en el código HTML generado.

Ver también ldap_err2str() y ldap_errno().

Anterior | Inicio | Siguiente
ldap_errno | Subir | ldap_explode_dn


Funciones de Correo

Manual de PHP
Anterior Siguiente

XLIX. Funciones de Correo

The mail() Funciones que permiten enviar correo.

Tabla de contenidos
mail — Envía correo

Anterior | Inicio | Siguiente
ldap_unbind | Subir | mail


mail

(PHP 3, PHP 4 >= 4.0.0)

mail -- Envía correo

Descripción

bool mail ( string para, string sobre, string mensaje [, string cabeceras_adicionales])

mail() envía automáticamente el mensaje especificado en mensage al destinatario especificado en para. Para especificar múltiples destinatarios se puede hacer incluyendo una coma entre las direcciones en para.

Ejemplo 1. Enviando correo.

mail("pepito@loquesea.es", "Sobre este tema", "Linea 1\nLinea 2\nLinea 3");

Si se añadiera una cadena como cuarto argumento, esta cadena sería enviada al final de la cabecera. Esto se usa normalmente para enviar cabeceras extra en los mensajes. Si se desea enviar varias cabeceras extra el mecanismo será el mismo separándolas una linea.

Ejemplo 2. Enviando correo con varias cabeceras.

mail("pepito@loquesea.es", "El tema", $message,
     "From: webmaster@$SERVER_NAME\nReply-To: webmaster@$SERVER_NAME\nX-Mailer: PHP/" . phpversion());

Anterior | Inicio | Siguiente
Funciones de Correo | Subir | mailparse functions


mailparse functions

Manual de PHP
Anterior Siguiente

L. mailparse functions

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

Tabla de contenidos
mailparse_uudecode_all — Scans the data from fp and extract each embedded uuencoded file. Returns an array listing filename information
mailparse_rfc822_parse_addresses — Parse addresses and returns a hash containing that data
mailparse_determine_best_xfer_encoding — Figures out the best way of encoding the content read from the file pointer fp, which must be seek-able
mailparse_stream_encode — Streams data from source file pointer, apply encoding and write to destfp
mailparse_msg_parse — Incrementally parse data into buffer
mailparse_msg_parse_file — Parse file and return a resource representing the structure
mailparse_msg_free — Frees a handle allocated by mailparse_msg_crea
mailparse_msg_create — Returns a handle that can be used to parse a message
mailparse_msg_get_structure — Returns an array of mime section names in the supplied message
mailparse_msg_extract_part — Extracts/decodes a message section. If callbackfunc is not specified, the contents will be sent to "stdout"
mailparse_msg_extract_part_file — Extracts/decodes a message section, decoding the transfer encoding
mailparse_msg_get_part_data — Returns an associative array of info about the message
mailparse_msg_get_part — Returns a handle on a given section in a mimemessage

Anterior | Inicio | Siguiente
mail | Subir | mailparse_uudecode_all


mailparse_uudecode_all

(PHP 4 4.2.0 only)

mailparse_uudecode_all -- Scans the data from fp and extract each embedded uuencoded file. Returns an array listing filename information

Description

array mailparse_uudecode_all ( resource fp)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse functions | Subir | mailparse_rfc822_parse_addresses


mailparse_rfc822_parse_addresses

(4.1.0 - 4.2.0 only)

mailparse_rfc822_parse_addresses -- Parse addresses and returns a hash containing that data

Description

array mailparse_rfc822_parse_addresses ( string addresses)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_uudecode_all | Subir | mailparse_determine_best_xfer_encoding


mailparse_determine_best_xfer_encoding

(4.1.0 - 4.2.0 only)

mailparse_determine_best_xfer_encoding -- Figures out the best way of encoding the content read from the file pointer fp, which must be seek-able

Description

int mailparse_determine_best_xfer_encoding ( resource fp)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_rfc822_parse_addresses | Subir | mailparse_stream_encode


mailparse_stream_encode

(4.1.0 - 4.2.0 only)

mailparse_stream_encode -- Streams data from source file pointer, apply encoding and write to destfp

Description

bool mailparse_stream_encode ( resource sourcefp, resource destfp, string encoding)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_determine_best_xfer_encoding | Subir | mailparse_msg_parse


mailparse_msg_parse

(4.1.0 - 4.2.0 only)

mailparse_msg_parse -- Incrementally parse data into buffer

Description

void mailparse_msg_parse ( resource rfc2045buf, string data)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_stream_encode | Subir | mailparse_msg_parse_file


mailparse_msg_parse_file

(4.1.0 - 4.2.0 only)

mailparse_msg_parse_file -- Parse file and return a resource representing the structure

Description

resource mailparse_msg_parse_file ( string filename)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_msg_parse | Subir | mailparse_msg_free


mailparse_msg_free

(4.1.0 - 4.2.0 only)

mailparse_msg_free -- Frees a handle allocated by mailparse_msg_crea

Description

void mailparse_msg_free ( resource rfc2045buf)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_msg_parse_file | Subir | mailparse_msg_create


mailparse_msg_create

(4.1.0 - 4.2.0 only)

mailparse_msg_create -- Returns a handle that can be used to parse a message

Description

int mailparse_msg_create ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_msg_free | Subir | mailparse_msg_get_structure


mailparse_msg_get_structure

(4.1.0 - 4.2.0 only)

mailparse_msg_get_structure -- Returns an array of mime section names in the supplied message

Description

array mailparse_msg_get_structure ( resource rfc2045)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_msg_create | Subir | mailparse_msg_extract_part


mailparse_msg_extract_part

(4.1.0 - 4.2.0 only)

mailparse_msg_extract_part -- Extracts/decodes a message section. If callbackfunc is not specified, the contents will be sent to "stdout"

Description

void mailparse_msg_extract_part ( resource rfc2045, string msgbody [, string callbackfunc])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_msg_get_structure | Subir | mailparse_msg_extract_part_file


mailparse_msg_extract_part_file

(4.1.0 - 4.2.0 only)

mailparse_msg_extract_part_file -- Extracts/decodes a message section, decoding the transfer encoding

Description

string mailparse_msg_extract_part_file ( resource rfc2045, string filename [, string callbackfunc])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_msg_extract_part | Subir | mailparse_msg_get_part_data


mailparse_msg_get_part_data

(4.1.0 - 4.2.0 only)

mailparse_msg_get_part_data -- Returns an associative array of info about the message

Description

array mailparse_msg_get_part_data ( resource rfc2045)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_msg_extract_part_file | Subir | mailparse_msg_get_part


mailparse_msg_get_part

(4.1.0 - 4.2.0 only)

mailparse_msg_get_part -- Returns a handle on a given section in a mimemessage

Description

int mailparse_msg_get_part ( resource rfc2045, string mimesection)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
mailparse_msg_get_part_data | Subir | Funciones matemáticas


Funciones matemáticas

Manual de PHP
Anterior Siguiente

LI. Funciones matemáticas

Introducción

Estas funciones matemáticas solo manejan valores dentro de los rangos de los tipos long y double de su ordenador. Si necesita manejar números mayores, pege un vistazo a funciones matemáticas de precisión arbitraria.

Constantes matemáticas

Los siguientes valores estan definidos como constantes en PHP por la extensión matemática:

Tabla 1. Constantes matemáticas

Constante | Valor | Descripción
M_PI | 3.14159265358979323846 | El valor de ¶ (pi)

Tabla de contenidos
abs — Valor absoluto
acos — Arco coseno
asin — Arco seno
atan — Arco tangente
atan2 — Arco tangente de dos variables
base_convert — Convierte un número entre bases arbitrarias
BinDec — binario a decimal
ceil — Redondea fracciones hacia arriba
cos — coseno
DecBin — decimal a binario
DecHex — decimal a hexadecimal
DecOct — decimal a octal
exp — e elevado a...
floor — redondea fracciones hacia abajo
getrandmax — Muestra el mayor valor aleatorio posible
HexDec — hexadecimal a decimal
log — Logaritmo natural
log10 — Logaritmo en base-10
max — encuentra el valor mayor
min — encuentra el valor menor
mt_getrandmax — muestra el mayor valor aleatorio posible
mt_rand — genera un valor aleatorio mejorado
mt_srand — Introduce la semilla del generador de números aleatorios mejorado
number_format — formatea un número en grupos de miles
OctDec — octal a decimal
pi — devuelve el valor de pi
pow — expresión exponencial
rand — genera un valor aleatorio
round — Redondea un float.
sin — seno
sqrt — Raíz cuadrada
srand — introduce la semilla del generador de números aleatorios
tan — tangente

Anterior | Inicio | Siguiente
mailparse_msg_get_part | Subir | abs


abs

(PHP 3, PHP 4 >= 4.0.0)

abs -- Valor absoluto

Descripción

mixed abs ( mixed number)

Devuelve el valor absoluto de un número. Si el número del argumento es decimal, el tipo de retorno también es decimal, de otra manera devuelve un entero.

Anterior | Inicio | Siguiente
Funciones matemáticas | Subir | acos


acos

(PHP 3, PHP 4 >= 4.0.0)

acos -- Arco coseno

Descripción

float acos ( float arg)

Devuelve el arco coseno de arg en radianes.

Vea también asin() y atan().

Anterior | Inicio | Siguiente
abs | Subir | asin


asin

(PHP 3, PHP 4 >= 4.0.0)

asin -- Arco seno

Descripción

float asin ( float arg)

Devuelve el arco seno de arg en radianes.

Vea también acos() y atan().

Anterior | Inicio | Siguiente
acos | Subir | atan


atan

(PHP 3, PHP 4 >= 4.0.0)

atan -- Arco tangente

Descripción

float atan ( float arg)

Devuelve la arco tangente de arg en radianes.

Vea también acos() y atan().

Anterior | Inicio | Siguiente
asin | Subir | atan2


atan2

(PHP 3>= 3.0.5, PHP 4 >= 4.0.0)

atan2 -- Arco tangente de dos variables

Descripción

float atan2 ( float y, float x)

Esta función calcula la arco tangente de las dos variables x e y. Es similar a el cálculo de la arco tangente de y / x, excepto que los signos de ambos argumentos son usados para determinar el cuadrante del resultado

La función devuelve el resultado en radianes, el cual está entre -PI y PI (inclusive).

Vea también acos() y atan().

Anterior | Inicio | Siguiente
atan | Subir | base_convert


base_convert

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

base_convert -- Convierte un número entre bases arbitrarias

Descripción

strin base_convert ( string number, int frombase, int tobase)

Devuelve una cadena conteniendo el number representado en base tobase. La base en la cual number es dado viene especificada en frombase. Tanto frombase y tobase tienen que estar entre 2 y 36, inclusive. Los dígitos en números con una base mayor que 10 serán representados con las letras a-z, a vale 10, b vale 11 y z vale 36.

Ejemplo 1. base_convert()

$binary = base_convert($hexadecimal, 16, 2);

Anterior | Inicio | Siguiente
atan2 | Subir | BinDec


BinDec

(PHP 3, PHP 4 >= 4.0.0)

BinDec -- binario a decimal

Descripción

int bindec ( string binary_string)

Devuelve el equivalente decimal del número binario representado por el argumento binary_string.

BinDec convierte un número binario en un número decimal. El mayor número que puede ser convertido son 31 bits de unos o 2147483647 en decimal.

Vea también la función decbin() .

Anterior | Inicio | Siguiente
base_convert | Subir | ceil


ceil

(PHP 3, PHP 4 >= 4.0.0)

ceil -- Redondea fracciones hacia arriba

Descripción

int ceil ( float number)

Devuelve el valor entero superior más cercano a number. El uso de ceil() con enteros es una perdida de tiempo absoluta.

NOTA: PHP/FI 2's ceil() devuelve un float. Use: $new = (double)ceil($number); para tener el comportamiento antiguo.

Vea también floor() y round().

Anterior | Inicio | Siguiente
BinDec | Subir | cos


cos

(PHP 3, PHP 4 >= 4.0.0)

cos -- coseno

Descripción

float cos ( float arg)

Devuelve el coseno de arg en radianes.

Vea también sin() y tan().

Anterior | Inicio | Siguiente
ceil | Subir | DecBin


DecBin

(PHP 3, PHP 4 >= 4.0.0)

DecBin -- decimal a binario

Descripción

string decbin ( int number)

Devuelve una cadena conteniendo la representación en binario de el número dado en el argumento. El número mayor que puede ser convertido es 2147483647 en decimal que resulta una cadena de 31 unos.

Vea también la función bindec() .

Anterior | Inicio | Siguiente
cos | Subir | DecHex


DecHex

(PHP 3, PHP 4 >= 4.0.0)

DecHex -- decimal a hexadecimal

Descripción

string dechex ( int number)

Devuelve una cadena conteniendo la representación hexadecimal del número dado en el argumento. El mayor número que puede ser convertido es 2147483647 en decimal resultando "7fffffff".

Vea también la función hexdec() .

Anterior | Inicio | Siguiente
DecBin | Subir | DecOct


DecOct

(PHP 3, PHP 4 >= 4.0.0)

DecOct -- decimal a octal

Descripción

string decoct ( int number)

Devuelve una cadena conteniendo la representación octal del número dado en el argumento. Returns a string containing an octal representation of the given number argument. El mayor número que puede ser ocnvertido es 2147483647 en decimal resultando "17777777777". Vea también octdec().

Anterior | Inicio | Siguiente
DecHex | Subir | exp


exp

(PHP 3, PHP 4 >= 4.0.0)

exp -- e elevado a...

Descripción

float exp ( float arg)

Devuelve el número e elevado a la potencia de arg.

Vea también pow().

Anterior | Inicio | Siguiente
DecOct | Subir | floor


floor

(PHP 3, PHP 4 >= 4.0.0)

floor -- redondea fracciones hacia abajo

Descripción

int floor ( float number)

Devuelve el valor entero inferior más cercano a number. El uso de floor() con enteros es una perdida de tiempo absoluta.

NOTA: PHP/FI 2's floor() devuelve un float. Use: $new = (double)floor($number); para tener el comportamiento antiguo.

Vea también ceil() y round().

Anterior | Inicio | Siguiente
exp | Subir | getrandmax


getrandmax

(PHP 3, PHP 4 >= 4.0.0)

getrandmax -- Muestra el mayor valor aleatorio posible

Descripción

int getrandmax ( void)

Devuelve el valor máximo que puede devolver una llamada a rand().

Vea también rand(),
srand()
mt_rand(),
mt_srand() y
mt_getrandmax().

Anterior | Inicio | Siguiente
floor | Subir | HexDec


HexDec

(PHP 3, PHP 4 >= 4.0.0)

HexDec -- hexadecimal a decimal

Descripción

int hexdec ( string hex_string)

Devuelve el equivalente decimal de el número hexadecimal representado por el argumento hex_string. HexDec convierte una cadena hexadecimal en un número decimal. El número mayor que puede ser convertido es 7fffffff o 2147483647 en decimal.

Vea también la función dechex() .

Anterior | Inicio | Siguiente
getrandmax | Subir | log


log

(PHP 3, PHP 4 >= 4.0.0)

log -- Logaritmo natural

Descripción

float log ( float arg)

Devuelve el logaritmo de arg.

Anterior | Inicio | Siguiente
HexDec | Subir | log10


log10

(PHP 3, PHP 4 >= 4.0.0)

log10 -- Logaritmo en base-10

Descripción

float log10 ( float arg)

Devuelve el logaritmo en base-10 de arg.

Anterior | Inicio | Siguiente
log | Subir | max


max

(PHP 3, PHP 4 >= 4.0.0)

max -- encuentra el valor mayor

Descripción

mixed max ( mixed arg1, mixed arg2, mixed argn)

max() devuelve el número mayor de los valores de los parámetros.

Si el primer parámetro es un array, max() devuelve el mayor valor en ese array. Si el primer parámetro es un entero, string o double, necesita al menos dos parámetros y max() devuelve el mayor número de estos valores. Puede comparar un número ilimitado de valores.

Si uno o más de los valores es un double, todos los valores serán tratados como doubles, y devolverá un double. Si ninguno de los valores es un double, todos ellos serán tratados como enteros, y se devolverá un entero.

Anterior | Inicio | Siguiente
log10 | Subir | min


min

(PHP 3, PHP 4 >= 4.0.0)

min -- encuentra el valor menor

Descripción

mixed min ( mixed arg1, mixed arg2, mixed argn)

min() returns the numerically lowest of the parameter values.

Si el primer parámetro es un array, min() devuelve el menor valor en ese array. Si el primer parámetro es un entero, string o double, necesita al menos dos parámetros y min() devuelve el número menor de estos valores. Puede comparar un número ilimitado de valores.

Si uno o más de los valores es un double, todos los valores serán tratados como doubles, y devolverá un double. Si ninguno de los valores es un double, todos ellos serán tratados como enteros, y se devolverá un entero.

Anterior | Inicio | Siguiente
max | Subir | mt_getrandmax


mt_rand

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

mt_rand -- genera un valor aleatorio mejorado

Descripción

int mt_rand ( [int min [, int max]])

Muchos generadores de números aleatorios de libcs antiguas tienen características dudosas o desconocidas y son lentas. Por defecto, PHP usa el generador de números aleatorios de libc con la función rand(). La función mt_rand() es un reemplazo para esta. Usa un generador de números aleatorios con características conocidas, el Tornado de Mersenne, que es capaz de producir números aleatorios que incluso se pueden emplear para propósitos criptográficos y es cuatro veces más rápido que la media de los que provee libc. La página principal del Tornado de Mersenne puede encontrarse en http://www.math.keio.ac.jp/~matumoto/emt.html, y una versión optimizada del código del TM esta disponible en http://www.scp.syr.edu/~marc/hawk/twister.html.

Si es llamada sin los parámetros opcionales min y max mt_rand() devuelve un valor pseudo-aleatorio entre 0 y RAND_MAX. Si quiere un número aleatorio entre 5 y 15 (inclusive), use mt_rand(5,15).

Recuerde introducir la semilla del generador de números aleatorios antes de usar la instrucción con mt_srand().

Vea también mt_srand(),
mt_getrandmax(),
srand(),
rand() y
getrandmax().

Anterior | Inicio | Siguiente
mt_getrandmax | Subir | mt_srand


mt_srand

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

mt_srand -- Introduce la semilla del generador de números aleatorios mejorado

Descripción

void mt_srand ( int seed)

Introduce la semilla seed en el generador de números aleatorios mejorado.

// seed son los microsegundos desde el último segundo "entero"
mt_srand((double)microtime()*1000000);
$randval = mt_rand();

Vea también mt_rand(),
mt_getrandmax(),
srand(),
rand() y
getrandmax().

Anterior | Inicio | Siguiente
mt_rand | Subir | number_format


mt_getrandmax

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

mt_getrandmax -- muestra el mayor valor aleatorio posible

Descripción

int mt_getrandmax ( void)

Devuelve el valor máximo que se puede obtener con una llamada a mt_rand().

Vea también mt_rand(),
mt_srand()
rand(),
srand() y
getrandmax().

Anterior | Inicio | Siguiente
min | Subir | mt_rand


number_format

(PHP 3, PHP 4 >= 4.0.0)

number_format -- formatea un número en grupos de miles

Descripción

string number_format ( float number, int decimals, string dec_point, string thousands_sep)

number_format() devuelve la versión formateada de number. Esta función acepta tanto uno, como dos o cuatro parámetros (tres no):

Si sólo se da un parámetro, number será formateado sin decimales, pero con una coma (",") entre cada grupo de miles.

Si se dan dos parámetros, number será formateado con decimals decimales con un punto (".") al principio, y una coma (",") entre cada grupo de miles.

Si se dan cuatro parámetros, number será formateado con decimals decimales, dec_point en vez del punto (".") antes de los decimales y thousands_sep en vez de la coma (",") entre cada grupo de miles.

Anterior | Inicio | Siguiente
mt_srand | Subir | OctDec


OctDec

(PHP 3, PHP 4 >= 4.0.0)

OctDec -- octal a decimal

Descripción

int octdec ( string octal_string)

Devuelve el equivalente decimal del número octal representado por el argumento octal_string. OctDec convierte una cadena octal en un número decimal. El mayor número que puede ser convertido es 17777777777 o 2147483647 en decimal.

Vea también decoct().

Anterior | Inicio | Siguiente
number_format | Subir | pi


pi

(PHP 3, PHP 4 >= 4.0.0)

pi -- devuelve el valor de pi

Descripción

double pi ( void)

Devuelve una aproximación de pi.

Anterior | Inicio | Siguiente
OctDec | Subir | pow


pow

(PHP 3, PHP 4 >= 4.0.0)

pow -- expresión exponencial

Descripción

float pow ( float base, float exp)

Devuelve base elevado a la potencia de exp.

Vea también exp().

Anterior | Inicio | Siguiente
pi | Subir | rand


rand

(PHP 3, PHP 4 >= 4.0.0)

rand -- genera un valor aleatorio

Descripción

int rand ( [int min [, int max]])

Si es llamada sin los argumentos opcionales min y max, rand() devuelve un valor pseudo-aleatorio entre 0 y RAND_MAX. Si quiere un número aleatorio entre 5 y 15 (inclusive), por ejemplo, use rand(5,15).

Recuerde introducir la semilla del generador de números aleatorios antes de usar srand().

Vea también srand(),
getrandmax(),
mt_rand(),
mt_srand() y
mt_getrandmax().

Anterior | Inicio | Siguiente
pow | Subir | round


round

(PHP 3, PHP 4 >= 4.0.0)

round -- Redondea un float.

Descripción

double round ( double val)

Devuelve el valor redondeado de val.

$foo = round( 3.4 );   // $foo == 3.0
$foo = round( 3.5 );   // $foo == 4.0
$foo = round( 3.6 );   // $foo == 4.0

Vea también ceil() y floor().

Anterior | Inicio | Siguiente
rand | Subir | sin


sin

(PHP 3, PHP 4 >= 4.0.0)

sin -- seno

Descripción

float sin ( float arg)

Devuelve el seno de arg en radianes.

Vea también cos() y tan().

Anterior | Inicio | Siguiente
round | Subir | sqrt


sqrt

(PHP 3, PHP 4 >= 4.0.0)

sqrt -- Raíz cuadrada

Descripción

float sqrt ( float arg)

Devuelve la raíz cuadrada de arg.

Anterior | Inicio | Siguiente
sin | Subir | srand


srand

(PHP 3, PHP 4 >= 4.0.0)

srand -- introduce la semilla del generador de números aleatorios

Descripción

void srand ( int seed)

Inicializa el generador de números aleatorios con seed.

// seed son los microsegundos desde el último segundo "entero"
srand((double)microtime()*1000000);
$randval = rand();

Vea también rand(),
getrandmax(),
mt_rand(),
mt_srand() y
mt_getrandmax().

Anterior | Inicio | Siguiente
sqrt | Subir | tan


tan

(PHP 3, PHP 4 >= 4.0.0)

tan -- tangente

Descripción

float tan ( float arg)

Devuelve la tangente de arg en radianes.

Vea también sin() y cos().

Anterior | Inicio | Siguiente
srand | Subir | Multi-Byte String Functions


Multi-Byte String Functions

Manual de PHP
Anterior Siguiente

LII. Multi-Byte String Functions

Introduction

There are many languages in which all characters can be expressed by single byte. Multi-byte character codes are used to express many characters for many languages. mbstring is developed to handle Japanese characters. However, many mbstring functions are able to handle character encoding other than Japanese.

A multi-byte character encoding represents single character with consecutive bytes. Some character encoding has shift(escape) sequences to start/end multi-byte character strings. Therefore, a multi-byte character string may be destroyed when it is divided and/or counted unless multi-byte character encoding safe method is used. This module provides multi-byte character safe string functions and other utility functions such as conversion functions.

Since PHP is basically designed for ISO-8859-1, some multi-byte character encoding does not work well with PHP. Therefore, it is important to set mbstring.internal_encoding to a character encoding that works with PHP.

PHP4 Character Encoding Requirements

  • Per byte encoding

  • Single byte characters in range of 00h-7fh which is compatible with ASCII

  • Multi-byte characters without 00h-7fh

These are examples of internal character encoding that works with PHP and does NOT work with PHP.

Character encodings work with PHP:
ISO-8859-*, EUC-JP, UTF-8

Character encodings do NOT work with PHP:
JIS, SJIS

Character encoding, that does not work with PHP, may be converted with mbstring's HTTP input/output conversion feature/function.

Nota: SJIS should not be used for internal encoding unless the reader is familiar with parser/compiler, character encoding and character encoding issues.

Nota: If you use database with PHP, it is recommended that you use the same character encoding for both database and internal encoding for ease of use and better performance.

If you are using PostgreSQL, it supports character encoding that is different from backend character encoding. See the PostgreSQL manual for details.

How to Enable mbstring

mbstring is an extended module. You must enable module with configure script. Refer to the Install section for details.

The following configure options are related to mbstring module.

  • --enable-mbstring : Enable mbstring functions. This option is required to use mbstring functions.

  • --enable-mbstr-enc-trans : Enable HTTP input character encoding conversion using mbstring conversion engine. If this feature is enabled, HTTP input character encoding may be converted to mbstring.internal_encoding automatically.

HTTP Input and Output

HTTP input/output character encoding conversion may convert binary data also. Users are supposed to control character encoding conversion if binary data is used for HTTP input/output.

If enctype for HTML form is set to multipart/form-data, mbstring does not convert character encoding in POST data. If it is the case, strings are needed to be converted to internal character encoding.

  • HTTP Input

    There is no way to control HTTP input character conversion from PHP script. To disable HTTP input character conversion, it has to be done in php.ini.

    Ejemplo 1. Disable HTTP input conversion in php.ini

    ;; Disable HTTP Input conversion
mbstring.http_input = pass

    When using PHP as an Apache module, it is possible to override PHP ini setting per Virtual Host in httpd.conf or per directory with .htaccess. Refer to the Configuration section and Apache Manual for details.

  • HTTP Output

    There are several ways to enable output character encoding conversion. One is using php.ini, another is using ob_start() with mb_output_handler() as ob_start callback function.

    Nota: For PHP3-i18n users, mbstring's output conversion differs from PHP3-i18n. Character encoding is converted using output buffer.

Ejemplo 2. php.ini setting example

;; Enable output character encoding conversion for all PHP pages

;; Enable Output Buffering
output_buffering    = On

;; Set mb_output_handler to enable output conversion
output_handler      = mb_output_handler

Ejemplo 3. Script example

<?php

// Enable output character encoding conversion only for this page

// Set HTTP output character encoding to SJIS
mb_http_output('SJIS');

// Start buffering and specify "mb_output_handler" as
// callback function
ob_start('mb_output_handler');

?>

Supported Character Encoding

Currently, the following character encoding is supported by mbstring module. Caracter encoding may be specified for mbstring functions' encoding parameter.

The following character encoding is supported in this PHP extension :

UCS-4, UCS-4BE, UCS-4LE, UCS-2, UCS-2BE, UCS-2LE, UTF-32, UTF-32BE, UTF-32LE, UCS-2LE, UTF-16, UTF-16BE, UTF-16LE, UTF-8, UTF-7, ASCII, EUC-JP, SJIS, eucJP-win, SJIS-win, ISO-2022-JP, JIS, ISO-8859-1, ISO-8859-2, ISO-8859-3, ISO-8859-4, ISO-8859-5, ISO-8859-6, ISO-8859-7, ISO-8859-8, ISO-8859-9, ISO-8859-10, ISO-8859-13, ISO-8859-14, ISO-8859-15, byte2be, byte2le, byte4be, byte4le, BASE64, 7bit, 8bit and UTF7-IMAP.

php.ini entry, which accepts encoding name, accepts "auto" and "pass" also. mbstring functions, which accepts encoding name, and accepts "auto".

If "pass" is set, no character encoding conversion is performed.

If "auto" is set, it is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS".

See also mb_detect_order()

Nota: "Supported character encoding" does not mean that it works as internal character code.

php.ini settings

  • mbstring.internal_encoding defines default internal character encoding.

  • mbstring.http_input defines default HTTP input character encoding.

  • mbstring.http_output defines default HTTP output character encoding.

  • mbstring.detect_order defines default character code detection order. See also mb_detect_order().

  • mbstring.substitute_character defines character to substitute for invalid character encoding.

Web Browsers are supposed to use the same character encoding when submitting form. However, browsers may not use the same character encoding. See mb_http_input() to detect character encoding used by browsers.

If enctype is set to multipart/form-data in HTML forms, mbstring does not convert character encoding in POST data. The user must convert them in the script, if conversion is needed.

Although, browsers are smart enough to detect character encoding in HTML. charset is better to be set in HTTP header. Change default_charset according to character encoding.

Ejemplo 4. php.ini setting example

;; Set default internal encoding
;; Note: Make sure to use character encoding works with PHP
mbstring.internal_encoding    = UTF-8  ; Set internal encoding to UTF-8

;; Set default HTTP input character encoding
;; Note: Script cannot change http_input setting.
mbstring.http_input           = pass    ; No conversion.
mbstring.http_input           = auto    ; Set HTTP input to auto
                                ; "auto" is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS"
mbstring.http_input           = SJIS    ; Set HTTP2 input to  SJIS
mbstring.http_input           = UTF-8,SJIS,EUC-JP ; Specify order

;; Set default HTTP output character encoding
mbstring.http_output          = pass    ; No conversion
mbstring.http_output          = UTF-8   ; Set HTTP output encoding to UTF-8

;; Set default character encoding detection order
mbstring.detect_order         = auto    ; Set detect order to auto
mbstring.detect_order         = ASCII,JIS,UTF-8,SJIS,EUC-JP ; Specify order

;; Set default substitute character
mbstring.substitute_character = 12307   ; Specify Unicode value
mbstring.substitute_character = none    ; Do not print character
mbstring.substitute_character = long    ; Long Example: U+3000,JIS+7E7E

Ejemplo 5. php.ini setting for EUC-JP users

;; Disable Output Buffering
output_buffering      = Off

;; Set HTTP header charset
default_charset       = EUC-JP

;; Set HTTP input encoding conversion to auto
mbstring.http_input   = auto

;; Convert HTTP output to EUC-JP
mbstring.http_output  = EUC-JP

;; Set internal encoding to EUC-JP
mbstring.internal_encoding = EUC-JP

;; Do not print invalid characters
mbstring.substitute_character = none

Ejemplo 6. php.ini setting for SJIS users

;; Enable Output Buffering
output_buffering     = On

;; Set mb_output_handler to enable output conversion
output_handler       = mb_output_handler

;; Set HTTP header charset
default_charset      = Shift_JIS

;; Set http input encoding conversion to auto
mbstring.http_input  = auto

;; Convert to SJIS
mbstring.http_output = SJIS

;; Set internal encoding to EUC-JP
mbstring.internal_encoding = EUC-JP

;; Do not print invalid characters
mbstring.substitute_character = none

Overload of PHP string functions by mbstring functions with multibyte support

Because almost PHP application written for language using single-byte character encoding, there are some difficulties for multibyte string handling including japanese. Almost PHP string functions such as substr() do not support multibyte string.

Multibyte extension (mbstring) has some PHP string functions with multibyte support (ex. substr() supports mb_substr()).

Multibyte extension (mbstring) also supports 'function overloading' to add multibyte string functionality without code modification. Using function overloading, some PHP string functions will be oveloaded multibyte string functions. For example, mb_substr() is called instead of substr() if function overloading is enabled. Function overload makes easy to port application supporting only single-byte encoding for multibyte application.

mbstring.func_overload in php.ini should be set some positive value to use function overloading. The value should specify the category of overloading functions, sbould be set 1 to enable mail function overloading. 2 to enable string functions, 4 to regular expression functions. For example, if is set for 7, mail, strings, regex functions should be overloaded. The list of overloaded functions are shown in below.

Tabla 1. Functions to be overloaded

value of mbstring.func_overload | original function | overloaded function
1 | mail() | mb_send_mail()
2 | strlen() | mb_strlen()
2 | strpos() | mb_strpos()
2 | strrpos() | mb_strrpos()
2 | substr() | mb_substr()
4 | ereg() | mb_ereg()
4 | eregi() | mb_eregi()
4 | ereg_replace() | mb_ereg_replace()
4 | eregi_replace() | mb_eregi_replace()
4 | split() | mb_split()

Basics for Japanese multi-byte character

Most Japanese characters need more than 1 byte per character. In addition, several character encoding schemas are used under a Japanese environment. There are EUC-JP, Shift_JIS(SJIS) and ISO-2022-JP(JIS) character encoding. As Unicode becomes popular, UTF-8 is used also. To develop Web applications for a Japanese environment, it is important to use the character set for the task in hand, whether HTTP input/output, RDBMS and E-mail.

  • Storage for a character can be up to six bytes

  • A multi-byte character is usually twice of the width compared to single-byte characters. Wider characters are called "zen-kaku" - meaning full width, narrower characters are called "han-kaku" - meaning half width. "zen-kaku" characters are usually fixed width.

  • Some character encoding defines shift(escape) sequence for entering/exiting multi-byte character strings.

  • ISO-2022-JP must be used for SMTP/NNTP.

  • "i-mode" web site is supposed to use SJIS.

References

Multi-byte character encoding and its related issues are very complex. It is impossible to cover in sufficient detail here. Please refer to the following URLs and other resources for further readings.

  • Unicode/UTF/UCS/etc

    http://www.unicode.org/

  • Japanese/Korean/Chinese character information

    ftp://ftp.ora.com/pub/examples/nutshell/ujip/doc/cjk.inf

Tabla de contenidos
mb_language — Set/Get current language
mb_parse_str — Parse GET/POST/COOKIE data and set global variable
mb_internal_encoding — Set/Get internal character encoding
mb_http_input — Detect HTTP input character encoding
mb_http_output — Set/Get HTTP output character encoding
mb_detect_order — Set/Get character encoding detection order
mb_substitute_character — Set/Get substitution character
mb_output_handler — Callback function converts character encoding in output buffer
mb_preferred_mime_name — Get MIME charset string
mb_strlen — Get string length
mb_strpos — Find position of first occurrence of string in a string
mb_strrpos — Find position of last occurrence of a string in a string
mb_substr — Get part of string
mb_strcut — Get part of string
mb_strwidth — Return width of string
mb_strimwidth — Get truncated string with specified width
mb_convert_encoding — Convert character encoding
mb_detect_encoding — Detect character encoding
mb_convert_kana — Convert "kana" one from another ("zen-kaku" ,"han-kaku" and more)
mb_encode_mimeheader — Encode string for MIME header
mb_decode_mimeheader — Decode string in MIME header field
mb_convert_variables — Convert character code in variable(s)
mb_encode_numericentity — Encode character to HTML numeric string reference
mb_decode_numericentity — Decode HTML numeric string reference to character
mb_send_mail — Send encoded mail.
mb_get_info — Get internal settings of mbstring
mb_regex_encoding — Returns current encoding for multibyte regex as string
mb_ereg — Regular expression match with multibyte support
mb_eregi — Regular expression match ignoring case with multibyte support
mb_ereg_replace — Replace regular expression with multibyte support
mb_eregi_replace — Replace regular expression with multibyte support ignoring case
mb_split — Split multibyte string using regular expression
mb_ereg_match — Regular expression match for multibyte string
mb_ereg_search — Multibyte regular expression match for predefined multibyte string
mb_ereg_search_pos — Return position and length of matched part of multibyte regular expression for predefined multibyte string
mb_ereg_search_regs — Returns the matched part of multibyte regular expression
mb_ereg_search_init — Setup string and regular expression for multibyte regular expression match
mb_ereg_search_getregs — Retrive the result from the last multibyte regular expression match
mb_ereg_search_getpos — Returns start point for next regular expression match
mb_ereg_search_setpos — Set start point of next regular expression match

Anterior | Inicio | Siguiente
tan | Subir | mb_language


mb_language

(PHP 4 >= 4.0.6)

mb_language -- Set/Get current language

Description

string mb_language ( [string language])

mb_language() sets language. If language is omitted, it returns current language as string.

language setting is used for encoding e-mail messages. Valid languages are "Japanese", "ja","English","en" and "uni" (UTF-8). mb_send_mail() uses this setting to encode e-mail.

Language and its setting is ISO-2022-JP/Base64 for Japanese, UTF-8/Base64 for uni, ISO-8859-1/quoted printable for English.

Return Value: If language is set and language is valid, it returns TRUE. Otherwise, it returns FALSE. When language is omitted, it returns language name as string. If no language is set previously, it returns FALSE.

See also mb_send_mail().

Anterior | Inicio | Siguiente
Multi-Byte String Functions | Subir | mb_parse_str


mb_parse_str

(PHP 4 >= 4.0.6)

mb_parse_str -- Parse GET/POST/COOKIE data and set global variable

Description

boolean mb_parse_str ( string encoded_string [, array result])

mb_parse_str() parses GET/POST/COOKIE data and sets global variables. Since PHP does not provide raw POST/COOKIE data, it can only used for GET data for now. It preses URL encoded data, detects encoding, converts coding to internal encoding and set values to result array or global variables.

encoded_string: URL encoded data.

result: Array contains decoded and character encoding converted values.

Return Value: It returns TRUE for success or FALSE for failure.

See also mb_detect_order(), mb_internal_encoding().

Anterior | Inicio | Siguiente
mb_language | Subir | mb_internal_encoding


mb_internal_encoding

(PHP 4 >= 4.0.6)

mb_internal_encoding -- Set/Get internal character encoding

Description

string mb_internal_encoding ( [string encoding])

mb_internal_encoding() sets internal character encoding to encoding If parameter is omitted, it returns current internal encoding.

encoding is used for HTTP input character encoding conversion, HTTP output character encoding conversion and default character encoding for string functions defined by mbstring module.

encoding: Character encoding name

Return Value: If encoding is set,mb_internal_encoding() returns TRUE for success, otherwise returns FALSE. If encoding is omitted, it returns current character encoding name.

Ejemplo 1. mb_internal_encoding() example

/* Set internal character encoding to UTF-8 */
mb_internal_encoding("UTF-8");

/* Display current internal character encoding */
echo mb_internal_encoding();

See also mb_http_input(),
mb_http_output(),
mb_detect_order().

Anterior | Inicio | Siguiente
mb_parse_str | Subir | mb_http_input


mb_http_input

(PHP 4 >= 4.0.6)

mb_http_input -- Detect HTTP input character encoding

Description

string mb_http_input ( [string type])

mb_http_input() returns result of HTTP input character encoding detection.

type: Input string specifies input type. "G" for GET, "P" for POST, "C" for COOKIE. If type is omitted, it returns last input type processed.

Return Value: Character encoding name. If mb_http_input() does not process specified HTTP input, it returns FALSE.

See also mb_internal_encoding(),
mb_http_output(),
mb_detect_order().

Anterior | Inicio | Siguiente
mb_internal_encoding | Subir | mb_http_output


mb_http_output

(PHP 4 >= 4.0.6)

mb_http_output -- Set/Get HTTP output character encoding

Description

string mb_http_output ( [string encoding])

If encoding is set, mb_http_output() sets HTTP output character encoding to encoding. Output after this function is converted to encoding. mb_http_output() returns TRUE for success and FALSE for failure.

If encoding is omitted, mb_http_output() returns current HTTP output character encoding.

See also mb_internal_encoding(),
mb_http_input(),
mb_detect_order().

Anterior | Inicio | Siguiente
mb_http_input | Subir | mb_detect_order


mb_detect_order

(PHP 4 >= 4.0.6)

mb_detect_order -- Set/Get character encoding detection order

Description

array mb_detect_order ( [mixed encoding-list])

mb_detect_order() sets automatic character encoding detection order to encoding-list. It returns TRUE for success, FALSE for failure.

encoding-list is array or comma separated list of character encoding. ("auto" is expanded to "ASCII, JIS, UTF-8, EUC-JP, SJIS")

If encoding-list is omitted, it returns current character encoding detection order as array.

This setting affects mb_detect_encoding() and mb_send_mail().

Nota: mbstring currently implements following encoding detection filters. If there is a invalid byte sequence for following encoding, encoding detection will fail.

Nota: UTF-8, UTF-7, ASCII, EUC-JP,SJIS, eucJP-win, SJIS-win, JIS, ISO-2022-JP

For ISO-8859-*, mbstring always detects as ISO-8859-*.

For UTF-16, UTF-32, UCS2 and UCS4, encoding detection will fail always.

Ejemplo 1. Useless detect order example

; Always detect as ISO-8859-1
detect_order = ISO-8859-1, UTF-8

; Always detect as UTF-8, since ASCII/UTF-7 values are
; valid for UTF-8
detect_order = UTF-8, ASCII, UTF-7

Ejemplo 2. mb_detect_order() examples

/* Set detection order by enumerated list */
mb_detect_order("eucjp-win,sjis-win,UTF-8");

/* Set detection order by array */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
mb_detect_order($ary);

/* Display current detection order */
echo implode(", ", mb_detect_order());

See also mb_internal_encoding(),
mb_http_input(),
mb_http_output()
mb_send_mail().

Anterior | Inicio | Siguiente
mb_http_output | Subir | mb_substitute_character


mb_substitute_character

(PHP 4 >= 4.0.6)

mb_substitute_character -- Set/Get substitution character

Description

mixed mb_substitute_character ( [mixed substrchar])

mb_substitute_character() specifies substitution character when input character encoding is invalid or character code is not exist in output character encoding. Invalid characters may be substituted NULL(no output), string or integer value (Unicode character code value).

This setting affects mb_detect_encoding() and mb_send_mail().

substchar : Specify Unicode value as integer or specify as string as follows

  • "none" : no output

  • "long" : Output character code value (Example: U+3000,JIS+7E7E)

Return Value: If substchar is set, it returns TRUE for success, otherwise returns FALSE. If substchar is not set, it returns Unicode value or "none"/"long".

Ejemplo 1. mb_substitute_character() example

/* Set with Unicode U+3013 (GETA MARK) */
mb_substitute_character(0x3013);

/* Set hex format */
mb_substitute_character("long");

/* Display current setting */
echo mb_substitute_character();

Anterior | Inicio | Siguiente
mb_detect_order | Subir | mb_output_handler


mb_output_handler

(PHP 4 >= 4.0.6)

mb_output_handler -- Callback function converts character encoding in output buffer

Description

string mb_output_handler ( string contents, int status)

mb_output_handler() is
ob_start() callback
function. mb_output_handler() converts
characters in output buffer from internal character encoding to
HTTP output character encoding.

4.1.0 or later version, this hanlder adds charset HTTP header when following conditions are met:

  • Does not set Content-Type by header()

  • Default MIME type begins with text/

  • http_output setting is other than pass

contents : Output buffer contents

status : Output buffer status

Return Value: String converted

Ejemplo 1. mb_output_handler() example

mb_http_output("UTF-8");
ob_start("mb_output_handler");

Nota: If you want to output some binary data such as image from PHP script, you must set output encoding to "pass" using mb_http_output().

See also ob_start().

Anterior | Inicio | Siguiente
mb_substitute_character | Subir | mb_preferred_mime_name


mb_preferred_mime_name

(PHP 4 >= 4.0.6)

mb_preferred_mime_name -- Get MIME charset string

Description

string mb_preferred_mime_name ( string encoding)

mb_preferred_mime_name() returns MIME charset string for character encoding encoding. It returns charset string.

Ejemplo 1. mb_preferred_mime_string() example

$outputenc = "sjis-win";
mb_http_output($outputenc);
ob_start("mb_output_handler");
header("Content-Type: text/html; charset=" . mb_preferred_mime_name($outputenc));

Anterior | Inicio | Siguiente
mb_output_handler | Subir | mb_strlen


mb_strlen

(PHP 4 >= 4.0.6)

mb_strlen -- Get string length

Description

string mb_strlen ( string str [, string encoding])

mb_strlen() returns number of characters in string str having character encoding encoding. A multi-byte character is counted as 1.

encoding is character encoding for str. If encoding is omitted, internal character encoding is used.

See also mb_internal_encoding(), strlen().

Anterior | Inicio | Siguiente
mb_preferred_mime_name | Subir | mb_strpos


mb_strpos

(PHP 4 >= 4.0.6)

mb_strpos -- Find position of first occurrence of string in a string

Description

int mb_strpos ( string haystack, string needle [, int offset [, string encoding]])

mb_strpos() returns the numeric position of the first occurrence of needle in the haystack string. If needle is not found, it returns FALSE.

mb_strpos() performs multi-byte safe strpos() operation based on number of characters. needle position is counted from the beginning of the haystack. First character's position is 0. Second character position is 1, and so on.

If encoding is omitted, internal character encoding is used. mb_strrpos() accepts string for needle where strrpos() accepts only character.

offset is search offset. If it is not specified, 0 is used.

encoding is character encoding name. If it is omitted, internal character encoding is used.

See also mb_strpos(),
mb_internal_encoding(),
strpos()

Anterior | Inicio | Siguiente
mb_strlen | Subir | mb_strrpos


mb_strrpos

(PHP 4 >= 4.0.6)

mb_strrpos -- Find position of last occurrence of a string in a string

Description

int mb_strrpos ( string haystack, string needle [, string encoding])

mb_strrpos() returns the numeric position of the last occurrence of needle in the haystack string. If needle is not found, it returns FALSE.

mb_strrpos() performs multi-byte safe strrpos() operation based on number of characters. needle position is counted from the beginning of haystack. First character's position is 0. Second character position is 1.

If encoding is omitted, internal encoding is assumed. mb_strrpos() accepts string for needle where strrpos() accepts only character.

encoding is character encoding. If it is not specified, internal character encoding is used.

See also mb_strpos(),
mb_internal_encoding(),
strrpos().

Anterior | Inicio | Siguiente
mb_strpos | Subir | mb_substr


mb_substr

(PHP 4 >= 4.0.6)

mb_substr -- Get part of string

Description

string mb_substr ( string str, int start [, int length [, string encoding]])

mb_substr() returns the portion of str specified by the start and length parameters.

mb_substr() performs multi-byte safe substr() operation based on number of characters. Position is counted from the beginning of str. First character's position is 0. Second character position is 1, and so on.

If encoding is omitted, internal encoding is assumed.

encoding is character encoding. If it is omitted, internal character encoding is used.

See also mb_strcut(), mb_internal_encoding().

Anterior | Inicio | Siguiente
mb_strrpos | Subir | mb_strcut


mb_strcut

(PHP 4 >= 4.0.6)

mb_strcut -- Get part of string

Description

string mb_strcut ( string str, int start [, int length [, string encoding]])

mb_strcut() returns the portion of str specified by the start and length parameters.

mb_strcut() performs equivalent operation as mb_substr() with different method. If start position is multi-byte character's second byte or larger, it starts from first byte of multi-byte character.

It subtracts string from str that is shorter than length AND character that is not part of multi-byte string or not being middle of shift sequence.

encoding is character encoding. If it is not set, internal character encoding is used.

See also mb_substr(), mb_internal_encoding().

Anterior | Inicio | Siguiente
mb_substr | Subir | mb_strwidth


mb_strwidth

(PHP 4 >= 4.0.6)

mb_strwidth -- Return width of string

Description

int mb_strwidth ( string str [, string encoding])

mb_strwidth() returns width of string str.

Multi-byte character usually twice of width compare to single byte character.

Character width

       U+0000 - U+0019   0
       U+0020 - U+1FFF   1
       U+2000 - U+FF60   2
       U+FF61 - U+FF9F   1
       U+FFA0 -          2

encoding is character encoding. If it is omitted, internal encoding is used.

See also: mb_strimwidth(), mb_internal_encoding().

Anterior | Inicio | Siguiente
mb_strcut | Subir | mb_strimwidth


mb_strimwidth

(PHP 4 >= 4.0.6)

mb_strimwidth -- Get truncated string with specified width

Description

string mb_strimwidth ( string str, int start, int width, string trimmarker [, string encoding])

mb_strimwidth() truncates string str to specified width. It returns truncated string.

If trimmarker is set, trimmarker is appended to return value.

start is start position offset. Number of characters from the beginning of string. (First character is 0)

trimmarker is string that is added to the end of string when string is truncated.

encoding is character encoding. If it is omitted, internal encoding is used.

Ejemplo 1. mb_strimwidth() example

$str = mb_strimwidth($str, 0, 40, "..>");

See also: mb_strwidth(), mb_internal_encoding().

Anterior | Inicio | Siguiente
mb_strwidth | Subir | mb_convert_encoding


mb_convert_encoding

(PHP 4 >= 4.0.6)

mb_convert_encoding -- Convert character encoding

Description

string mb_convert_encoding ( string str, string to-encoding [, mixed from-encoding])

mb_convert_encoding() converts character encoding of string str from from-encoding to to-encoding.

str : String to be converted.

from-encoding is specified by character code name before conversion. it can be array or string - comma separated enumerated list. If it is not specified, the internal encoding will be used.

Ejemplo 1. mb_convert_encoding() example

/* Convert internal character encoding to SJIS */
$str = mb_convert_encoding($str, "SJIS");

/* Convert EUC-JP to UTF-7 */
$str = mb_convert_encoding($str, "UTF-7", "EUC-JP");

/* Auto detect encoding from JIS, eucjp-win, sjis-win, then convert str to UCS-2LE */
$str = mb_convert_encoding($str, "UCS-2LE", "JIS, eucjp-win, sjis-win");

/* "auto" is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS" */
$str = mb_convert_encoding($str, "EUC-JP", "auto");

See also: mb_detect_order().

Anterior | Inicio | Siguiente
mb_strimwidth | Subir | mb_detect_encoding


mb_detect_encoding

(PHP 4 >= 4.0.6)

mb_detect_encoding -- Detect character encoding

Description

string mb_detect_encoding ( string str [, mixed encoding-list])

mb_detect_encoding() detects character encoding in string str. It returns detected character encoding.

encoding-list is list of character encoding. Encoding order may be specified by array or comma separated list string.

If encoding_list is omitted, detect_order is used.

Ejemplo 1. mb_detect_encoding() example

/* Detect character encoding with current detect_order */
echo mb_detect_encoding($str);

/* "auto" is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS" */
echo mb_detect_encoding($str, "auto");

/* Specify encoding_list character encoding by comma separated list */
echo mb_detect_encoding($str, "JIS, eucjp-win, sjis-win");

/* Use array to specify encoding_list  */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
echo mb_detect_encoding($str, $ary);

See also: mb_detect_order().

Anterior | Inicio | Siguiente
mb_convert_encoding | Subir | mb_convert_kana


mb_convert_kana

(PHP 4 >= 4.0.6)

mb_convert_kana -- Convert "kana" one from another ("zen-kaku" ,"han-kaku" and more)

Description

string mb_convert_kana ( string str, string option [, mixed encoding])

mb_convert_kana() performs "han-kaku" - "zen-kaku" conversion for string str. It returns converted string. This function is only useful for Japanese.

option is conversion option. Default value is "KV".

encoding is character encoding. If it is omitted, internal character encoding is used.

Applicable Conversion Options

       option : Specify with conversion of following options. Default "KV"
       "r" :  Convert "zen-kaku" alphabets to "han-kaku"
       "R" :  Convert "han-kaku" alphabets to "zen-kaku"
       "n" :  Convert "zen-kaku" numbers to "han-kaku"
       "N" :  Convert "han-kaku" numbers to "zen-kaku"
       "a" :  Convert "zen-kaku" alphabets and numbers to "han-kaku"
       "A" :  Convert "zen-kaku" alphabets and numbers to "han-kaku"
       (Characters included in "a", "A" options are
       U+0021 - U+007E excluding U+0022, U+0027, U+005C, U+007E)
       "s" :  Convert "zen-kaku" space to "han-kaku" (U+3000 -> U+0020)
       "S" :  Convert "han-kaku" space to "zen-kaku" (U+0020 -> U+3000)
       "k" :  Convert "zen-kaku kata-kana" to "han-kaku kata-kana"
       "K" :  Convert "han-kaku kata-kana" to "zen-kaku kata-kana"
       "h" :  Convert "zen-kaku hira-gana" to "han-kaku kata-kana"
       "H" :  Convert "han-kaku kata-kana" to "zen-kaku hira-gana"
       "c" :  Convert "zen-kaku kata-kana" to "zen-kaku hira-gana"
       "C" :  Convert "zen-kaku hira-gana" to "zen-kaku kata-kana"
       "V" :  Collapse voiced sound notation and convert them into a character. Use with "K","H"

Ejemplo 1. mb_convert_kana() example

/* Convert all "kana" to "zen-kaku" "kata-kana" */
$str = mb_convert_kana($str, "KVC");

/* Convert "han-kaku" "kata-kana" to "zen-kaku" "kata-kana"
   and "zen-kaku" alpha-numeric to "han-kaku" */
$str = mb_convert_kana($str, "KVa");

Anterior | Inicio | Siguiente
mb_detect_encoding | Subir | mb_encode_mimeheader


mb_encode_mimeheader

(PHP 4 >= 4.0.6)

mb_encode_mimeheader -- Encode string for MIME header

Description

string mb_encode_mimeheader ( string str [, string charset [, string transfer-encoding [, string linefeed]]])

mb_encode_mimeheader() converts string str to encoded-word for header field. It returns converted string in ASCII encoding.

charset is character encoding name. Default is ISO-2022-JP.

transfer-encoding is transfer encoding. It should be one of "B" (Base64) or "Q" (Quoted-Printable). Default is "B".

linefeed is end of line marker. Default is "\r\n" (CRLF).

Ejemplo 1. mb_convert_kana() example

$name = ""; // kanji
$mbox = "kru";
$doma = "gtinn.mon";
$addr = mb_encode_mimeheader($name, "UTF-7", "Q") . " <" . $mbox . "@" . $doma . ">";
echo $addr;

See also mb_decode_mimeheader().

Anterior | Inicio | Siguiente
mb_convert_kana | Subir | mb_decode_mimeheader


mb_decode_mimeheader

(PHP 4 >= 4.0.6)

mb_decode_mimeheader -- Decode string in MIME header field

Description

string mb_decode_mimeheader ( string str)

mb_decode_mimeheader() decodes encoded-word string str in MIME header.

It returns decoded string in internal character encoding.

See also mb_encode_mimeheader().

Anterior | Inicio | Siguiente
mb_encode_mimeheader | Subir | mb_convert_variables


mb_convert_variables

(PHP 4 >= 4.0.6)

mb_convert_variables -- Convert character code in variable(s)

Description

string mb_convert_variables ( string to-encoding, mixed from-encoding, mixed vars)

mb_convert_variables() convert character encoding of variables vars in encoding from-encoding to encoding to-encoding. It returns character encoding before conversion for success, FALSE for failure.

mb_convert_variables() join strings in Array or Object to detect encoding, since encoding detection tends to fail for short strings. Therefore, it is impossible to mix encoding in single array or object.

It from-encoding is specified by array or comma separated string, it tries to detect encoding from from-coding. When encoding is omitted, detect_order is used.

vars (3rd and larger) is reference to variable to be converted. String, Array and Object are accepted. mb_convert_variables() assumes all parameters have the same encoding.

Ejemplo 1. mb_convert_variables() example

/* Convert variables $post1, $post2 to internal encoding */
$interenc = mb_internal_encoding();
$inputenc = mb_convert_variables($interenc, "ASCII,UTF-8,SJIS-win", $post1, $post2);

Anterior | Inicio | Siguiente
mb_decode_mimeheader | Subir | mb_encode_numericentity


mb_encode_numericentity

(PHP 4 >= 4.0.6)

mb_encode_numericentity -- Encode character to HTML numeric string reference

Description

string mb_encode_numericentity ( string str, array convmap [, string encoding])

mb_encode_numericentity() converts specified character codes in string str from HTML numeric character reference to character code. It returns converted string.

array is array specifies code area to convert.

encoding is character encoding.

Ejemplo 1. convmap example

$convmap = array (
 int start_code1, int end_code1, int offset1, int mask1,
 int start_code2, int end_code2, int offset2, int mask2,
 ........
 int start_codeN, int end_codeN, int offsetN, int maskN );
// Specify Unicode value for start_codeN and end_codeN
// Add offsetN to value and take bit-wise 'AND' with maskN, then
// it converts value to numeric string reference.

Ejemplo 2. mb_encode_numericentity() example

/* Convert Left side of ISO-8859-1 to HTML numeric character reference */
$convmap = array(0x80, 0xff, 0, 0xff);
$str = mb_encode_numericentity($str, $convmap, "ISO-8859-1");

/* Convert user defined SJIS-win code in block 95-104 to numeric
   string reference */
$convmap = array(
       0xe000, 0xe03e, 0x1040, 0xffff,
       0xe03f, 0xe0bb, 0x1041, 0xffff,
       0xe0bc, 0xe0fa, 0x1084, 0xffff,
       0xe0fb, 0xe177, 0x1085, 0xffff,
       0xe178, 0xe1b6, 0x10c8, 0xffff,
       0xe1b7, 0xe233, 0x10c9, 0xffff,
       0xe234, 0xe272, 0x110c, 0xffff,
       0xe273, 0xe2ef, 0x110d, 0xffff,
       0xe2f0, 0xe32e, 0x1150, 0xffff,
       0xe32f, 0xe3ab, 0x1151, 0xffff );
$str = mb_encode_numericentity($str, $convmap, "sjis-win");

See also: mb_decode_numericentity().

Anterior | Inicio | Siguiente
mb_convert_variables | Subir | mb_decode_numericentity


mb_decode_numericentity

(PHP 4 >= 4.0.6)

mb_decode_numericentity -- Decode HTML numeric string reference to character

Description

string mb_decode_numericentity ( string str, array convmap [, string encoding])

Convert numeric string reference of string str in specified block to character. It returns converted string.

array is array to specifies code area to convert.

encoding is character encoding. If it is omitted, internal character encoding is used.

Ejemplo 1. convmap example

$convmap = array (
   int start_code1, int end_code1, int offset1, int mask1,
   int start_code2, int end_code2, int offset2, int mask2,
   ........
   int start_codeN, int end_codeN, int offsetN, int maskN );
// Specify Unicode value for start_codeN and end_codeN
// Add offsetN to value and take bit-wise 'AND' with maskN,
// then convert value to numeric string reference.

See also: mb_encode_numericentity().

Anterior | Inicio | Siguiente
mb_encode_numericentity | Subir | mb_send_mail


mb_send_mail

(PHP 4 >= 4.0.6)

mb_send_mail -- Send encoded mail.

Description

boolean mb_send_mail ( string to, string subject, string message [, string additional_headers [, string additional_parameter]])

mb_send_mail() sends email. Headers and
message are converted and encoded according to
mb_language() setting.
mb_send_mail() is wrapper
function of mail(). See
mail() for details.

to is mail addresses send to. Multiple recipients can be specified by putting a comma between each address in to. This parameter is not automatically encoded.

subject is subject of mail.

message is mail message.

additional_headers is inserted at the end of the header. This is typically used to add extra headers. Multiple extra headers are separated with a newline ("\n").

additional_parameter is a MTA command line parameter. It is useful when setting the correct Return-Path header when using sendmail.

Returns TRUE on succes, FALSE on failure.

See also mail(),
mb_encode_mimeheader(), and
mb_language().

Anterior | Inicio | Siguiente
mb_decode_numericentity | Subir | mb_get_info


mb_get_info

(PHP 4 >= 4.2.0)

mb_get_info -- Get internal settings of mbstring

Description

string mb_get_info ( [string type])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_get_info() returns internal setting parameter of mbstring.

If type isn't specified or is specified to "all", an array having the elements "internal_encoding", "http_output", "http_input", "func_overload" will be returned.

If type is specified for "http_output", "http_input", "internal_encoding", "func_overload", the specified setting parameter will be returned.

See also mb_internal_encoding(), mb_http_output().

Anterior | Inicio | Siguiente
mb_send_mail | Subir | mb_regex_encoding


mb_regex_encoding

(PHP 4 >= 4.2.0)

mb_regex_encoding -- Returns current encoding for multibyte regex as string

Description

string mb_regex_encoding ( [string encoding])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_regex_encoding() returns the character encoding used by multibyte regex functions.

If the optional parameter encoding is specified, it is set to the character encoding for multibyte regex. The default value is the internal character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_internal_encoding(), mb_ereg()

Anterior | Inicio | Siguiente
mb_get_info | Subir | mb_ereg


mb_ereg

(PHP 4 >= 4.2.0)

mb_ereg -- Regular expression match with multibyte support

Description

int mb_ereg ( string pattern, string string [, array regs])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg() executes the regular expression match with multibyte support, and returns 1 if matches are found. If the optional third parameter was specified, the function returns the byte length of matched part, and therarray regs will contain the substring of matched string. The functions returns 1 if it matches with the empty string. It no matche found or error happend, FALSE will be returned.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_eregi()

Anterior | Inicio | Siguiente
mb_regex_encoding | Subir | mb_eregi


mb_eregi

(PHP 4 >= 4.2.0)

mb_eregi -- Regular expression match ignoring case with multibyte support

Description

int mb_eregi ( string pattern, string string [, array regs])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_eregi() executes the regular expression match with multibyte support, and returns 1 if matches are found. This function ignore case. If the optional third parameter was specified, the function returns the byte length of matched part, and therarray regs will contain the substring of matched string. The functions returns 1 if it matches with the empty string. It no matche found or error happend, FALSE will be returned.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg().

Anterior | Inicio | Siguiente
mb_ereg | Subir | mb_ereg_replace


mb_ereg_replace

(PHP 4 >= 4.2.0)

mb_ereg_replace -- Replace regular expression with multibyte support

Description

string mb_ereg_replace ( string pattern, string replacement, string string [, array option])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_replace() scans string for matches to pattern, then replaces the matched text with replacement and returns the result string or FALSE on error. Multibyte character can be used in pattern.

Matching condition can be set by option parameter. If i is specified for this parameter, the case will be ignored. If x is specified, white space will be ignored. If m is specified, match will be executed in multiline mode and line break will be included in '.'. If p is specified, match will be executed in POSIX mode, line break will be considered as normal character. If e is specified, replacement string will be evaluated as PHP expression.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_eregi_replace().

Anterior | Inicio | Siguiente
mb_eregi | Subir | mb_eregi_replace


mb_eregi_replace

(PHP 4 >= 4.2.0)

mb_eregi_replace -- Replace regular expression with multibyte support ignoring case

Description

string mb_eregi_replace ( string pattern, string replace, string string)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_replace() scans string for matches to pattern, then replaces the matched text with replacement and returns the result string or FALSE on error. Multibyte character can be used in pattern. The case will be ignored.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_replace().

Anterior | Inicio | Siguiente
mb_ereg_replace | Subir | mb_split


mb_split

(PHP 4 >= 4.2.0)

mb_split -- Split multibyte string using regular expression

Description

array mb_split ( string pattern, string string [, int limit])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_split() split multibyte string using regular expression pattern and returns the result as an array.

If optional parameter limit is specified, it will be split in limit elements as maximum.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg().

Anterior | Inicio | Siguiente
mb_eregi_replace | Subir | mb_ereg_match


mb_ereg_match

(PHP 4 >= 4.2.0)

mb_ereg_match -- Regular expression match for multibyte string

Description

bool mb_ereg_match ( string pattern, string string [, string option])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_match() returns TRUE if string matches regular expression pattern, FALSE if not.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg().

Anterior | Inicio | Siguiente
mb_split | Subir | mb_ereg_search


mb_ereg_search

(PHP 4 >= 4.2.0)

mb_ereg_search -- Multibyte regular expression match for predefined multibyte string

Description

bool mb_ereg_search ( [string pattern [, string option]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_search() returns TRUE if the multibyte string matches with the regular expression, FALSE for otherwise. The string for matching is set by mb_ereg_search_init(). If pattern is not specified, the previous one is used.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

Anterior | Inicio | Siguiente
mb_ereg_match | Subir | mb_ereg_search_pos


mb_ereg_search_pos

(PHP 4 >= 4.2.0)

mb_ereg_search_pos -- Return position and length of matched part of multibyte regular expression for predefined multibyte string

Description

array mb_ereg_search_pos ( [string pattern [, string option]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_search_pos() returns an array including position of matched part for multibyte regular expression. The first element of the array will be the beggining of matched part, the second element will be length (bytes) of matched part. It returns FALSE on error.

The string for match is specified by mb_ereg_search_init(). It it is not specified, the previous one will be used.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

Anterior | Inicio | Siguiente
mb_ereg_search | Subir | mb_ereg_search_regs


mb_ereg_search_regs

(PHP 4 >= 4.2.0)

mb_ereg_search_regs -- Returns the matched part of multibyte regular expression

Description

array mb_ereg_search_regs ( [string pattern [, string option]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_search_regs() executes the multibyte regular expression match, and if there are some matched part, it returns an array including substring of matched part as first element, the first grouped part with brackets as second element, the second grouped part as third element, and so on. It returns FALSE on error.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

Anterior | Inicio | Siguiente
mb_ereg_search_pos | Subir | mb_ereg_search_init


mb_ereg_search_init

(PHP 4 >= 4.2.0)

mb_ereg_search_init -- Setup string and regular expression for multibyte regular expression match

Description

array mb_ereg_search_init ( string string [, string pattern [, string option]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_search_init() sets string and pattern for multibyte regular expression. These values are used for mb_ereg_search(), mb_ereg_search_pos(), mb_ereg_search_regs(). It returns TRUE for success, FALSE for error.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_regs().

Anterior | Inicio | Siguiente
mb_ereg_search_regs | Subir | mb_ereg_search_getregs


mb_ereg_search_getregs

(PHP 4 >= 4.2.0)

mb_ereg_search_getregs -- Retrive the result from the last multibyte regular expression match

Description

array mb_ereg_search_getregs ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_search_getregs() returns an array including the sub-string of matched part by last mb_ereg_search(), mb_ereg_search_pos(), mb_ereg_search_regs(). If there are some maches, the first element will have the matched sub-string, the second element will have the first part grouped with brackets, the third element will have the second part grouped with brackets, and so on. It returns FALSE on error;

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

Anterior | Inicio | Siguiente
mb_ereg_search_init | Subir | mb_ereg_search_getpos


mb_ereg_search_getpos

(PHP 4 >= 4.2.0)

mb_ereg_search_getpos -- Returns start point for next regular expression match

Description

array mb_ereg_search_getpos ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_search_getpos() returns
the point to start regular expression match for
mb_ereg_search(),
mb_ereg_search_pos(),
mb_ereg_search_regs(). The position is
represented by bytes from the head of string.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_setpos().

Anterior | Inicio | Siguiente
mb_ereg_search_getregs | Subir | mb_ereg_search_setpos


mb_ereg_search_setpos

(PHP 4 >= 4.2.0)

mb_ereg_search_setpos -- Set start point of next regular expression match

Description

array mb_ereg_search_setpos ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

mb_ereg_search_setpos() sets the starting point of match for mb_ereg_search().

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

Nota: This function is supported in PHP 4.2.0 or higher.

See also: mb_regex_encoding(), mb_ereg_search_init().

Anterior | Inicio | Siguiente
mb_ereg_search_getpos | Subir | MCAL functions


MCAL functions

Manual de PHP
Anterior Siguiente

LIII. MCAL functions

MCAL stands for Modular Calendar Access Library.

Libmcal is a C library for accessing calendars. It's written to be very modular, with plugable drivers. MCAL is the calendar equivalent of the IMAP module for mailboxes.

With mcal support, a calendar stream can be opened much like the mailbox stream with the IMAP support. Calendars can be local file stores, remote ICAP servers, or other formats that are supported by the mcal library.

Calendar events can be pulled up, queried, and stored. There is also support for calendar triggers (alarms) and reoccuring events.

With libmcal, central calendar servers can be accessed and used, removing the need for any specific database or local file programming.

To get these functions to work, you have to compile PHP with --with-mcal. That requires the mcal library to be installed. Grab the latest version from http://mcal.chek.com/ and compile and install it.

The following constants are defined when using the MCAL module: MCAL_SUNDAY, MCAL_MONDAY, MCAL_TUESDAY, MCAL_WEDNESDAY, MCAL_THURSDAY, MCAL_FRIDAY, MCAL_SATURDAY, MCAL_RECUR_NONE, MCAL_RECUR_DAILY, MCAL_RECUR_WEEKLY, MCAL_RECUR_MONTHLY_MDAY, MCAL_RECUR_MONTHLY_WDAY, MCAL_RECUR_YEARLY, MCAL_JANUARY, MCAL_FEBRUARY, MCAL_MARCH, MCAL_APRIL, MCAL_MAY, MCAL_JUNE, MCAL_JULY, MCAL_AUGUGT, MCAL_SEPTEMBER, MCAL_OCTOBER, MCAL_NOVEMBER, and MCAL_DECEMBER. Most of the functions use an internal event structure that is unique for each stream. This alleviates the need to pass around large objects between functions. There are convenience functions for setting, initializing, and retrieving the event structure values.

Tabla de contenidos
mcal_append_event — Store a new event into an MCAL calendar
mcal_close — Close an MCAL stream
mcal_date_compare — Compares two dates
mcal_date_valid — Returns TRUE if the given year, month, day is a valid date
mcal_day_of_week — Returns the day of the week of the given date
mcal_day_of_year — Returns the day of the year of the given date
mcal_days_in_month — Returns the number of days in the given month
mcal_delete_event — Delete an event from an MCAL calendar
mcal_event_add_attribute — Adds an attribute and a value to the streams global event structure
mcal_event_init — Initializes a streams global event structure
mcal_event_set_alarm — Sets the alarm of the streams global event structure
mcal_event_set_category — Sets the category of the streams global event structure
mcal_event_set_class — Sets the class of the streams global event structure
mcal_event_set_description — Sets the description of the streams global event structure
mcal_event_set_end — Sets the end date and time of the streams global event structure
mcal_event_set_recur_daily — Sets the recurrence of the streams global event structure
mcal_event_set_recur_monthly_mday — Sets the recurrence of the streams global event structure
mcal_event_set_recur_monthly_wday — Sets the recurrence of the streams global event structure
mcal_event_set_recur_none — Sets the recurrence of the streams global event structure
mcal_event_set_recur_weekly — Sets the recurrence of the streams global event structure
mcal_event_set_recur_yearly — Sets the recurrence of the streams global event structure
mcal_event_set_start — Sets the start date and time of the streams global event structure
mcal_event_set_title — Sets the title of the streams global event structure
mcal_fetch_current_stream_event — Returns an object containing the current streams event structure
mcal_fetch_event — Fetches an event from the calendar stream
mcal_is_leap_year — Returns if the given year is a leap year or not
mcal_list_alarms — Return a list of events that has an alarm triggered at the given datetime
mcal_list_events — Return a list of events between two given datetimes
mcal_next_recurrence — Returns the next recurrence of the event
mcal_open — Opens up an MCAL connection
mcal_snooze — Turn off an alarm for an event
mcal_store_event — Modify an existing event in an MCAL calendar
mcal_time_valid — Returns TRUE if the given year, month, day is a valid time

Anterior | Inicio | Siguiente
mb_ereg_search_setpos | Subir | mcal_append_event


mcal_open

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_open -- Opens up an MCAL connection

Description

int mcal_open ( string calendar, string username, string password, string options)

Returns an MCAL stream on success, FALSE on error.

mcal_open() opens up an MCAL connection to the specified calendar store. If the optional options is specified, passes the options to that mailbox also. The streams internal event structure is also initialized upon connection.

Anterior | Inicio | Siguiente
mcal_next_recurrence | Subir | mcal_snooze


mcal_close

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_close -- Close an MCAL stream

Description

int mcal_close ( int mcal_stream, int flags)

Closes the given mcal stream.

Anterior | Inicio | Siguiente
mcal_append_event | Subir | mcal_date_compare


mcal_fetch_event

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_fetch_event -- Fetches an event from the calendar stream

Description

object mcal_fetch_event ( int mcal_stream, int event_id [, int options])

mcal_fetch_event() fetches an event from the calendar stream specified by id.

Returns an event object consisting of:

  • int id - ID of that event.

  • int public - TRUE if the event if public, FALSE if it is private.

  • string category - Category string of the event.

  • string title - Title string of the event.

  • string description - Description string of the event.

  • int alarm - number of minutes before the event to send an alarm/reminder.

  • object start - Object containing a datetime entry.

  • object end - Object containing a datetime entry.

  • int recur_type - recurrence type

  • int recur_interval - recurrence interval

  • datetime recur_enddate - recurrence end date

  • int recur_data - recurrence data

All datetime entries consist of an object that contains:

  • int year - year

  • int month - month

  • int mday - day of month

  • int hour - hour

  • int min - minutes

  • int sec - seconds

  • int alarm - minutes before event to send an alarm

Anterior | Inicio | Siguiente
mcal_fetch_current_stream_event | Subir | mcal_is_leap_year


mcal_list_events

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_list_events -- Return a list of events between two given datetimes

Description

array mcal_list_events ( int mcal_stream [, int begin_year [, int begin_month [, int begin_day [, int end_year [, int end_month [, int end_day]]]]]])

Returns an array of event ID's that are between the start and end dates, or if just a stream is given, uses the start and end dates in the global event structure.

mcal_list_events() function takes in an optional beginning date and an end date for a calendar stream. An array of event id's that are between the given dates or the internal event dates are returned.

Anterior | Inicio | Siguiente
mcal_list_alarms | Subir | mcal_next_recurrence


mcal_append_event

(PHP 4 >= 4.0.0)

mcal_append_event -- Store a new event into an MCAL calendar

Description

int mcal_append_event ( int mcal_stream)

mcal_append_event() Stores the global event into an MCAL calendar for the given stream.

Returns the uid of the newly inserted event.

Anterior | Inicio | Siguiente
MCAL functions | Subir | mcal_close


mcal_store_event

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_store_event -- Modify an existing event in an MCAL calendar

Description

int mcal_store_event ( int mcal_stream)

mcal_store_event() Stores the modifications to the current global event for the given stream.

Returns TRUE on success and FALSE on error.

Anterior | Inicio | Siguiente
mcal_snooze | Subir | mcal_time_valid


mcal_delete_event

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_delete_event -- Delete an event from an MCAL calendar

Description

int mcal_delete_event ( int uid)

mcal_delete_event() deletes the calendar event specified by the uid.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_days_in_month | Subir | mcal_event_add_attribute


mcal_snooze

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_snooze -- Turn off an alarm for an event

Description

int mcal_snooze ( int uid)

mcal_snooze() turns off an alarm for a calendar event specified by the uid.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_open | Subir | mcal_store_event


mcal_list_alarms

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_list_alarms -- Return a list of events that has an alarm triggered at the given datetime

Description

array mcal_list_events ( int mcal_stream [, int begin_year [, int begin_month [, int begin_day [, int end_year [, int end_month [, int end_day]]]]]])

Returns an array of event ID's that has an alarm going off between the start and end dates, or if just a stream is given, uses the start and end dates in the global event structure.

mcal_list_events() function takes in an optional beginning date and an end date for a calendar stream. An array of event id's that are between the given dates or the internal event dates are returned.

Anterior | Inicio | Siguiente
mcal_is_leap_year | Subir | mcal_list_events


mcal_event_init

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_init -- Initializes a streams global event structure

Description

int mcal_event_init ( int stream)

mcal_event_init() initializes a streams global event structure. this effectively sets all elements of the structure to 0, or the default settings.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_event_add_attribute | Subir | mcal_event_set_alarm


mcal_event_set_category

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_category -- Sets the category of the streams global event structure

Description

int mcal_event_set_category ( int stream, string category)

mcal_event_set_category() sets the streams global event structure's category to the given string.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_event_set_alarm | Subir | mcal_event_set_class


mcal_event_set_title

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_title -- Sets the title of the streams global event structure

Description

int mcal_event_set_title ( int stream, string title)

mcal_event_set_title() sets the streams global event structure's title to the given string.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_event_set_start | Subir | mcal_fetch_current_stream_event


mcal_event_set_description

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_description -- Sets the description of the streams global event structure

Description

int mcal_event_set_description ( int stream, string description)

mcal_event_set_description() sets the streams global event structure's description to the given string.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_event_set_class | Subir | mcal_event_set_end


mcal_event_set_start

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_start -- Sets the start date and time of the streams global event structure

Description

int mcal_event_set_start ( int stream, int year, int month [, int day [, int hour [, int min [, int sec]]]])

mcal_event_set_start() sets the streams global event structure's start date and time to the given values.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_event_set_recur_yearly | Subir | mcal_event_set_title


mcal_event_set_end

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_end -- Sets the end date and time of the streams global event structure

Description

int mcal_event_set_end ( int stream, int year, int month [, int day [, int hour [, int min [, int sec]]]])

mcal_event_set_end() sets the streams global event structure's end date and time to the given values.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_event_set_description | Subir | mcal_event_set_recur_daily


mcal_event_set_alarm

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_alarm -- Sets the alarm of the streams global event structure

Description

int mcal_event_set_alarm ( int stream, int alarm)

mcal_event_set_alarm() sets the streams global event structure's alarm to the given minutes before the event.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_event_init | Subir | mcal_event_set_category


mcal_event_set_class

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_class -- Sets the class of the streams global event structure

Description

int mcal_event_set_class ( int stream, int class)

mcal_event_set_class() sets the streams global event structure's class to the given value. The class is either 1 for public, or 0 for private.

Returns TRUE.

Anterior | Inicio | Siguiente
mcal_event_set_category | Subir | mcal_event_set_description


mcal_is_leap_year

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_is_leap_year -- Returns if the given year is a leap year or not

Description

int mcal_is_leap_year ( int year)

mcal_is_leap_year() returns 1 if the given year is a leap year, 1 if not.

Anterior | Inicio | Siguiente
mcal_fetch_event | Subir | mcal_list_alarms


mcal_days_in_month

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_days_in_month -- Returns the number of days in the given month

Description

int mcal_days_in_month ( int month, int leap year)

mcal_days_in_month() Returns the number of days in the given month, taking into account if the given year is a leap year or not.

Anterior | Inicio | Siguiente
mcal_day_of_year | Subir | mcal_delete_event


mcal_date_valid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_date_valid -- Returns TRUE if the given year, month, day is a valid date

Description

int mcal_date_valid ( int year, int month, int day)

mcal_date_valid() Returns TRUE if the given year, month and day is a valid date, FALSE if not.

Anterior | Inicio | Siguiente
mcal_date_compare | Subir | mcal_day_of_week


mcal_time_valid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_time_valid -- Returns TRUE if the given year, month, day is a valid time

Description

int mcal_time_valid ( int hour, int minutes, int seconds)

mcal_time_valid() Returns TRUE if the given hour, minutes and seconds is a valid time, FALSE if not.

Anterior | Inicio | Siguiente
mcal_store_event | Subir | Funciones Criptográficas


mcal_day_of_week

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_day_of_week -- Returns the day of the week of the given date

Description

int mcal_ ( int year, int month, int day)

mcal_day_of_week() returns the day of the week of the given date

Anterior | Inicio | Siguiente
mcal_date_valid | Subir | mcal_day_of_year


mcal_day_of_year

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_day_of_year -- Returns the day of the year of the given date

Description

int mcal_ ( int year, int month, int day)

mcal_day_of_year() returns the day of the year of the given date

Anterior | Inicio | Siguiente
mcal_day_of_week | Subir | mcal_days_in_month


mcal_date_compare

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_date_compare -- Compares two dates

Description

int mcal_date_compare ( int a_year, int a_month, int a_day, int b_year, int b_month, int b_day)

mcal_date_compare() Compares the two given dates, returns <0, 0, >0 if a<b, a==b, a>b respectively

Anterior | Inicio | Siguiente
mcal_close | Subir | mcal_date_valid


mcal_next_recurrence

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_next_recurrence -- Returns the next recurrence of the event

Description

int mcal_next_recurrence ( int stream, int weekstart, array next)

mcal_next_recurrence() returns an object filled with the next date the event occurs, on or after the supplied date. Returns empty date field if event does not occur or something is invalid. Uses weekstart to determine what day is considered the beginning of the week.

Anterior | Inicio | Siguiente
mcal_list_events | Subir | mcal_open


mcal_event_set_recur_none

(PHP 3>= 3.0.15, PHP 4 >= 4.0.0)

mcal_event_set_recur_none -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_none ( int stream)

mcal_event_set_recur_none() sets the streams global event structure to not recur (event->recur_type is set to MCAL_RECUR_NONE).

Anterior | Inicio | Siguiente
mcal_event_set_recur_monthly_wday | Subir | mcal_event_set_recur_weekly


mcal_event_set_recur_daily

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_recur_daily -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_daily ( int stream, int year, int month, int day, int interval)

mcal_event_set_recur_daily() sets the streams global event structure's recurrence to the given value to be reoccuring on a daily basis, ending at the given date.

Anterior | Inicio | Siguiente
mcal_event_set_end | Subir | mcal_event_set_recur_monthly_mday


mcal_event_set_recur_weekly

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_recur_weekly -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_weekly ( int stream, int year, int month, int day, int interval, int weekdays)

mcal_event_set_recur_weekly() sets the streams global event structure's recurrence to the given value to be reoccuring on a weekly basis, ending at the given date.

Anterior | Inicio | Siguiente
mcal_event_set_recur_none | Subir | mcal_event_set_recur_yearly


mcal_event_set_recur_monthly_mday

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_recur_monthly_mday -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_monthly_mday ( int stream, int year, int month, int day, int interval)

mcal_event_set_recur_monthly_mday() sets the streams global event structure's recurrence to the given value to be reoccuring on a monthly by month day basis, ending at the given date.

Anterior | Inicio | Siguiente
mcal_event_set_recur_daily | Subir | mcal_event_set_recur_monthly_wday


mcal_event_set_recur_monthly_wday

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_recur_monthly_wday -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_monthly_wday ( int stream, int year, int month, int day, int interval)

mcal_event_set_recur_monthly_wday() sets the streams global event structure's recurrence to the given value to be reoccuring on a monthly by week basis, ending at the given date.

Anterior | Inicio | Siguiente
mcal_event_set_recur_monthly_mday | Subir | mcal_event_set_recur_none


mcal_event_set_recur_yearly

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_event_set_recur_yearly -- Sets the recurrence of the streams global event structure

Description

int mcal_event_set_recur_yearly ( int stream, int year, int month, int day, int interval)

mcal_event_set_recur_yearly() sets the streams global event structure's recurrence to the given value to be reoccuring on a yearly basis,ending at the given date .

Anterior | Inicio | Siguiente
mcal_event_set_recur_weekly | Subir | mcal_event_set_start


mcal_fetch_current_stream_event

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

mcal_fetch_current_stream_event -- Returns an object containing the current streams event structure

Description

int mcal_fetch_current_stream_event ( int stream)

mcal_event_fetch_current_stream_event() returns the current stream's event structure as an object containing:

  • int id - ID of that event.

  • int public - TRUE if the event if public, FALSE if it is private.

  • string category - Category string of the event.

  • string title - Title string of the event.

  • string description - Description string of the event.

  • int alarm - number of minutes before the event to send an alarm/reminder.

  • object start - Object containing a datetime entry.

  • object end - Object containing a datetime entry.

  • int recur_type - recurrence type

  • int recur_interval - recurrence interval

  • datetime recur_enddate - recurrence end date

  • int recur_data - recurrence data

All datetime entries consist of an object that contains:

  • int year - year

  • int month - month

  • int mday - day of month

  • int hour - hour

  • int min - minutes

  • int sec - seconds

  • int alarm - minutes before event to send an alarm

Anterior | Inicio | Siguiente
mcal_event_set_title | Subir | mcal_fetch_event


mcal_event_add_attribute

(PHP 3>= 3.0.15, PHP 4 >= 4.0.0)

mcal_event_add_attribute -- Adds an attribute and a value to the streams global event structure

Description

void mcal_event_add_attribute ( int stream, string attribute, string value)

mcal_event_add_attribute() adds an attribute to the stream's global event structure with the value given by "value" .

Anterior | Inicio | Siguiente
mcal_delete_event | Subir | mcal_event_init


Funciones Criptográficas

Manual de PHP
Anterior Siguiente

LIV. Funciones Criptográficas

Estas funciones trabajan usando mcrypt.

Esta es una interfaz a la librería mcrypt, que soporta una gran variedad de algoritmos de bloque como DES, TripleDES, Blowfish (por defecto), 3-WAY, SAFER-SK64, SAFER-SK128, TWOFISH, TEA, RC2 y GOST en los modos de cifrado CBC, OFB, CFB y ECB. Adicionalmente, soporta RC6 e IDEA que se consideran "no-libres".

Para usarlos, descarga libmcrypt-x.x.tar.gz de aquí y sigue las instrucciones de instalación incluidas. Necesitas compilar PHP con el parámetro --with-mcrypt para activar esta extensión.

mcrypt puede usarse para encriptar y desencriptar usando los cifrados mencionados arriba. Los cuatro comandos importantes de mcrypt (mcrypt_cfb(), mcrypt_cbc(), mcrypt_ecb(), y mcrypt_ofb()) pueden operar en ambos modos que se llaman MCRYPT_ENCRYPT y MCRYPT_DECRYPT, respectivamente.

Ejemplo 1. Encripta un valor de entrada con TripleDES en modo ECB

<?php
$key = "esta es una clave muy secreta";
$input = "Nos vemos a las 9 en punto en el lugar secreto.";

$encrypted_data = mcrypt_ecb(MCRYPT_TripleDES, $key, $input, MCRYPT_ENCRYPT);
?>
Este ejemplo devolverá los datos encriptados como una cadena en $encrypted_data.

mcrypt puede operar en cuatro modos de cifrado (CBC, OFB, CFB y ECB). Perfilaremos el uso normal de cada uno de estos modos. Para una mejor referencia y una discusión más completa ver Applied Cryptography by Schneier (ISBN 0-471-11709-9).

  • ECB (electronic codebook o libro de códigos electrónico) va bien para datos aleatorios, tales como encriptar otras claves. Puesto que los datos son cortos y aleatorios, las desventajas de ECB tienen un efecto negativo favorable.

  • CBC (cipher block chaining o cifrado en bloque encadenado) es especialmente útil para encriptar ficheros, donde incrementa significativamente la seguridad por encima de ECB.

  • CFB (cipher feedback o cifrado realimentado) es el mejor modo de encriptar flujos de bytes donde cada byte debe ser encriptado.

  • OFB (output feedback o salida realimentada) es comparable al CFB, pero puede usarse en aplicaciones donde la propagación de errores no puede tolerarse.

Actualmente PHP no soporta el encriptado/desencriptado de flujos de bits. Por ahora, sólo soporta el manejo de cadenas.

Para una lista completa de los cifrados soportados, ver las definiciones al final de mcrypt.h. La regla general es que se puede acceder al cifrado desde PHP con MCRYPT_nombredelcifrado.

Aquí hay una pequeña lista de los cifrados que estan soportados actualmente por la extensión mcrypt. Si un cifrado no está listado aquí, pero está listado por mcrypt como soportado, puedes asumir con seguridad que ésta documentación está caduca.

  • MCRYPT_BLOWFISH

  • MCRYPT_DES

  • MCRYPT_TripleDES

  • MCRYPT_ThreeWAY

  • MCRYPT_GOST

  • MCRYPT_CRYPT

  • MCRYPT_DES_COMPAT

  • MCRYPT_SAFER64

  • MCRYPT_SAFER128

  • MCRYPT_CAST128

  • MCRYPT_TEAN

  • MCRYPT_RC2

  • MCRYPT_TWOFISH (para las antiguas versiones mcrypt 2.x)

  • MCRYPT_TWOFISH128 (TWOFISHxxx está disponible en las versiones más nuevas 2.x)

  • MCRYPT_TWOFISH192

  • MCRYPT_TWOFISH256

  • MCRYPT_RC6

  • MCRYPT_IDEA

Debes (en los modos CFB y OFB) o puedes (en el modo CBC) suministrar un vector de inicialización (IV) a la correspondiente función de cifrado. El IV debe ser único y debe ser el mismo cuando desencriptas o encriptas. Con datos que son guardados encriptados, puedes cojer la salida de una función de índice bajo la cual los datos son almacenados (ej. la clave MD5 de un fichero). Alternativamente, puedes transmitir el IV junto con los datos encriptados (ver capítulo 9.3 de Applied Cryptography by Schneier (ISBN 0-471-11709-9) para una discusión de éste asunto).

Tabla de contenidos
mcrypt_cbc — Encripta/desencripta datos en modo CBC
mcrypt_cfb — Encripta/desencripta datos en modo CFB
mcrypt_create_iv — Crea un vector de inicialización (IV) a partir de una fuente aleatoria
mcrypt_ecb — Encripta/desencripta datos en modo ECB
mcrypt_get_block_size — Obtiene el tamaño de bloque del cifrado indicado
mcrypt_get_cipher_name — Obtiene el nombre del cifrado especificado
mcrypt_get_key_size — Obtiene el tamaño de la clave de un cifrado
mcrypt_ofb — Encripta/desencripta datos en modo OFB

Anterior | Inicio | Siguiente
mcal_time_valid | Subir | mcrypt_cbc


mcrypt_get_cipher_name

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

mcrypt_get_cipher_name -- Obtiene el nombre del cifrado especificado

Descripción

string mcrypt_get_cipher_name ( int cipher)

mcrypt_get_cipher_name() se usa para obtener el nombre del cifrado especificado.

mcrypt_get_cipher_name() toma como argumento el número de cifrado y devuelve el nombre del cifrado o FALSE, si el cifrado no existe.

Ejemplo 1. Ejemplo de mcrypt_get_cipher_name

<?php
$cipher = MCRYPT_TripleDES;

print mcrypt_get_cipher_name($cipher);
?>

El ejemplo de más arriba da como resultado:
TripleDES

Anterior | Inicio | Siguiente
mcrypt_get_block_size | Subir | mcrypt_get_key_size


mcrypt_get_block_size

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

mcrypt_get_block_size -- Obtiene el tamaño de bloque del cifrado indicado

Descripción

int mcrypt_get_block_size ( int cipher)

mcrypt_get_block_size() se usa para obtener el tamaño de bloque del cifrado indicado en cipher.

mcrypt_get_block_size() toma un argumento, el cifrado cipher y devuelve el tamaño en bytes.

Ver también: mcrypt_get_key_size()

Anterior | Inicio | Siguiente
mcrypt_ecb | Subir | mcrypt_get_cipher_name


mcrypt_get_key_size

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

mcrypt_get_key_size -- Obtiene el tamaño de la clave de un cifrado

Descripción

int mcrypt_get_key_size ( int cipher)

mcrypt_get_key_size() se usa para obtener el tamaño de la clave del cifrado indicado en cipher.

mcrypt_get_key_size() toma un argumento, el cifrado cipher y devuelve el tamaño de la clave en bytes.

Ver también: mcrypt_get_block_size()

Anterior | Inicio | Siguiente
mcrypt_get_cipher_name | Subir | mcrypt_ofb


mcrypt_create_iv

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

mcrypt_create_iv -- Crea un vector de inicialización (IV) a partir de una fuente aleatoria

Descripción

string mcrypt_create_iv ( int size, int source)

mcrypt_create_iv() se usa para crear un IV.

mcrypt_create_iv() toma dos argumentos, size determina el tamaño del IV, source especifica la fuente del IV.

La fuente puede ser MCRYPT_RAND (generador de números aleatorios del sistema), MCRYPT_DEV_RANDOM (que lee datos de /dev/random) y MCRYPT_DEV_URANDOM (que lee datos de /dev/urandom). Si usas MCRYPT_RAND, asegurate de llamar antes a srand() para inicializar el generador de números aleatorios.

Ejemplo 1. Ejemplo de mcrypt_create_iv

<?php
$cipher = MCRYPT_TripleDES;
$block_size = mcrypt_get_block_size($cipher);
$iv = mcrypt_create_iv($block_size, MCRYPT_DEV_RANDOM);
?>

Anterior | Inicio | Siguiente
mcrypt_cfb | Subir | mcrypt_ecb


mcrypt_cbc

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

mcrypt_cbc -- Encripta/desencripta datos en modo CBC

Descripción

int mcrypt_cbc ( int cipher, string key, string data, int mode [, string iv])

mcrypt_cbc() encripta o desencripta (dependiendo de mode) los datos data con el cifrado cipher y la clave key en el modo de cifrado CBC y devuelve la cadena resultante.

El parámetro cipher es una de las constantes con nombre MCRYPT_nombrecifrado.

key es la clave suministrada al algoritmo. Debe guardarse en secreto.

data son los datos que serán encriptados/desencriptados.

mode es MCRYPT_ENCRYPT o MCRYPT_DECRYPT.

iv es el vector de inicialización opcional.

Ver también:
mcrypt_cfb(),
mcrypt_ecb(),
mcrypt_ofb()

Anterior | Inicio | Siguiente
Funciones Criptográficas | Subir | mcrypt_cfb


mcrypt_cfb

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

mcrypt_cfb -- Encripta/desencripta datos en modo CFB

Descripción

int mcrypt_cfb ( int cipher, string key, string data, int mode, string iv)

mcrypt_cfb() encripta o desencripta (dependiendo de mode) los datos data con el cifrado cipher y la clave key en el modo de cifrado CFB y devuelve la cadena resultante.

El parámetro cipher es una de las constantes con nombre MCRYPT_nombrecifrado.

key es la clave suministrada al algoritmo. Debe guardarse en secreto.

data son los datos que serán encriptados/desencriptados.

mode es MCRYPT_ENCRYPT o MCRYPT_DECRYPT.

iv es el vector de inicialización.

Ver también:
mcrypt_cbc(),
mcrypt_ecb(),
mcrypt_ofb()

Anterior | Inicio | Siguiente
mcrypt_cbc | Subir | mcrypt_create_iv


mcrypt_ecb

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

mcrypt_ecb -- Encripta/desencripta datos en modo ECB

Descripción

int mcrypt_ecb ( int cipher, string key, string data, int mode)

mcrypt_ecb() encripta o desencripta (dependiendo de mode) los datos data con el cifrado cipher y la clave key en el modo de cifrado ECB y devuelve la cadena resultante.

El parámetro cipher es una de las constantes con nombre MCRYPT_nombrecifrado.

key es la clave suministrada al algoritmo. Debe guardarse en secreto.

data son los datos que serán encriptados/desencriptados.

mode es MCRYPT_ENCRYPT o MCRYPT_DECRYPT.

Ver también:
mcrypt_cbc(),
mcrypt_cfb(),
mcrypt_ofb()

Anterior | Inicio | Siguiente
mcrypt_create_iv | Subir | mcrypt_get_block_size


mcrypt_ofb

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

mcrypt_ofb -- Encripta/desencripta datos en modo OFB

Descripción

int mcrypt_ofb ( int cipher, string key, string data, int mode, string iv)

mcrypt_ofb() encripta o desencripta (dependiendo de mode) los datos data con el cifrado cipher y la clave key en el modo de cifrado OFB y devuelve la cadena resultante.

El parámetro cipher es una de las constantes con nombre MCRYPT_nombrecifrado.

key es la clave suministrada al algoritmo. Debe guardarse en secreto.

data son los datos que serán encriptados/desencriptados.

mode es MCRYPT_ENCRYPT o MCRYPT_DECRYPT.

iv es el vector de inicialización.

Ver también:
mcrypt_cbc(),
mcrypt_cfb(),
mcrypt_ecb()

Anterior | Inicio | Siguiente
mcrypt_get_key_size | Subir | Funciones Hash


Funciones Hash

Manual de PHP
Anterior Siguiente

LV. Funciones Hash

Estas funciones han sido realizadas para trabajar con mhash.

Esta es una interfaz con al libreria mhash. mhash soporta una amplia variedad de algoritmos hash como MD5, SHA1, GOST, y muchos otros.

Para usarla, hay que descargar la distribucion desde su sitio web y seguir las intrucciones de instalacion. Se necesita compilar PHP con el parametr --with-mhash para activar esta extension.

mhash puede ser usado para crear checksums, message digests, y mas.

Ejemplo 1. Generar una clave SHA1 e imprimirla en hexadecimal

<?php
$input = "Let us meet at 9 o' clock at the secret place.";
$hash = mhash(MHASH_SHA1, $input);

print "The hash is ".bin2hex($hash)."\n";

?>
Esto generara:
The hash is d3b85d710d8f6e4e5efd4d5e67d041f9cecedafe
PAra una lista complera de hash soportados, refierase a la documentacion de mhash. La regla general es que se puede acceder a los algoritmos hash desde PHP con MHASH_HASHNAME. Como ejemplo, para acceder a HAVAL se debe usar la constante de PHP llamada MHASH_HAVAL.

Aqui hay una lista de hashes que esta actualmente soportada por mhash. Si un hash no esta en dicha lista pero aparece como soportado por mhash, entonces se asume con plena seguridad que esta documentacion esta desfasada.

  • MHASH_MD5

  • MHASH_SHA1

  • MHASH_HAVAL

  • MHASH_RIPEMD160

  • MHASH_RIPEMD128

  • MHASH_SNEFRU

  • MHASH_TIGER

  • MHASH_GOST

  • MHASH_CRC32

  • MHASH_CRC32B

Tabla de contenidos
mhash — Calcular el hash
mhash_count — Obtener el valor mayor del id hash disponible
mhash_get_block_size — Conseguir el tamaño de bloque de el hash especificado
mhash_get_hash_name — Conseguir el nombre de un hash especifico

Anterior | Inicio | Siguiente
mcrypt_ofb | Subir | mhash


mhash_get_hash_name

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

mhash_get_hash_name -- Conseguir el nombre de un hash especifico

Descripcion

string mhash_get_hash_name ( int hash)

mhash_get_hash_name() es usado para conseguir el nombre de el hash determinado.

mhash_get_hash_name() toma el id del hash como un argumento y devuelve el nombre de el hash o FALSE, si el hash no existe.

Ejemplo 1. mhash_get_hash_name example

<?php
$hash = MHASH_MD5;

print mhash_get_hash_name($hash);
?>
El ejemplo anterior mostrara:
MD5

Anterior | Inicio | Siguiente
mhash_get_block_size | Subir | Funciones de Microsoft SQL Server


mhash_get_block_size

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

mhash_get_block_size -- Conseguir el tamaño de bloque de el hash especificado

Descripcion

int mhash_get_block_size ( int hash)

mhash_get_block_size() es usado para obtener el tamaño de un bloque de el hash determinado.

mhash_get_block_size() toma un argumento, el hash y devuelve el tamaño en bytes o FALSE, si el hash no existe.

Anterior | Inicio | Siguiente
mhash_count | Subir | mhash_get_hash_name


mhash_count

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

mhash_count -- Obtener el valor mayor del id hash disponible

Descripcion

int mhash_count ( void)

mhash_count() devuelve el valor mas alto id hash disponible. Los hash estan numerados desde 0 hasta este valor.

Ejemplo 1. Recorriendo todos los hash

<?php

$nr = mhash_count();

for($i = 0; $i <= $nr; $i++) {
    echo sprintf("The blocksize of %s is %d\n",
            mhash_get_hash_name($i),
            mhash_get_block_size($i));
}
?>

Anterior | Inicio | Siguiente
mhash | Subir | mhash_get_block_size


mhash

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

mhash -- Calcular el hash

Descripcion

string mhash ( int hash, string data)

mhash() aplica una funcion hash especificada por hash a data y devuelve el valor hash resultante (tambien llamdo digest).

Anterior | Inicio | Siguiente
Funciones Hash | Subir | mhash_count


Funciones de Microsoft SQL Server

Manual de PHP
Anterior Siguiente

LVI. Funciones de Microsoft SQL Server

Tabla de contenidos
mssql_close — cierra una conexión con MS SQL Server
mssql_connect — abre una conexión con MS SQL server
mssql_data_seek — mueve el puntero interno de las filas
mssql_fetch_array — Captura la fila en un array
mssql_fetch_field — obtiene la información de los campos
mssql_fetch_object — captura la fila como un objeto
mssql_fetch_row — obtiene la fila como un array numerado
mssql_field_seek — set field offset
mssql_free_result — libera de la memoria el resultado de una consulta
mssql_num_fields — obtiene el número de campos de la consulta
mssql_num_rows — obtiene el número de filas de la consulta
mssql_pconnect — abre una conexión persistenete con MS SQL
mssql_query — envia una consulta MS SQL
mssql_result — get result data
mssql_select_db — selecciona una base de datos MS SQL

Anterior | Inicio | Siguiente
mhash_get_hash_name | Subir | mssql_close


mssql_close

(PHP 3, PHP 4 >= 4.0.0)

mssql_close -- cierra una conexión con MS SQL Server

Descripción

int mssql_close ( int link_identifier)

Devuleve: TRUE si se finaliza con éxito, FALSE si se produce un error

mssql_close() cierra la conexión con una base de datos MS SQL Server que está asociada al identificador especificado. Si el identificador no se especifica, se asume la última conexión abierta.

Observe que normalmente esto no es necesario, ya que las conexiones no-persistentes abiertas se cierran automaticamente en cuanto finaliza el script.

mssql_close() no cerrará conexiones persistentes generadas por mssql_pconnect().

Ver también: mssql_connect(), mssql_pconnect().

Anterior | Inicio | Siguiente
Funciones de Microsoft SQL Server | Subir | mssql_connect


mssql_connect

(PHP 3, PHP 4 >= 4.0.0)

mssql_connect -- abre una conexión con MS SQL server

Descripción

int mssql_connect ( string servername, string username, string password)

Devuelve: Un identificador de MSSQL si se ejecuta correctamente, o FALSE si se produce un error.

mssql_connect() establece una conexión con MS SQL server. El argumento servername debe ser un nombre de servidor válido, que está definido en el fichero 'interfaces'.

En caso de hacer una segunda llamada a mssql_connect() con los mismos argumentos, no se establecerá una nueva conexión, sino que se devolverá el identificador de la conexión establecida anteriormente.

La conexión con el servidor se cerrará tan pronto como finalice el script, a menos que se cierre antes, mediante una llamada explicita a la función mssql_close().

Ver también mssql_pconnect(), mssql_close().

Anterior | Inicio | Siguiente
mssql_close | Subir | mssql_data_seek


mssql_data_seek

(PHP 3, PHP 4 >= 4.0.0)

mssql_data_seek -- mueve el puntero interno de las filas

Descripción

int mssql_data_seek ( int result_identifier, int row_number)

Devuelve: TRUE si se ejecuta con éxito, FALSE si falla.

mssql_data_seek() mueve el puntero interno de la consulta MS SQL asociada al result_identifier especificado, para que apunte al número de fila especificada. La siguiente llamada a mssql_fetch_row() devolverá esa fila.

Ver también: mssql_data_seek().

Anterior | Inicio | Siguiente
mssql_connect | Subir | mssql_fetch_array


mssql_fetch_array

(PHP 3, PHP 4 >= 4.0.0)

mssql_fetch_array -- Captura la fila en un array

Descripción

int mssql_fetch_array ( int result)

Devuelve: Un array que corresponde a la fila capturada, o FALSE si no hay más filas.

mssql_fetch_array() es una versión extendida de mssql_fetch_row(). A¤ade el almacenar los datos en los índices numéricos del array resultante, también almacena los datos en índices asociativos, usando los nombres de los campos como claves.

Una observación a tener en cuenta es, que usar mssql_fetch_array() NO es más lento que usar mssql_fetch_row(), mientras que esta provee un valor a¤adido significativo.

Para más detalles, ver también mssql_fetch_row()

Anterior | Inicio | Siguiente
mssql_data_seek | Subir | mssql_fetch_field


mssql_fetch_field

(PHP 3, PHP 4 >= 4.0.0)

mssql_fetch_field -- obtiene la información de los campos

Descripción

object mssql_fetch_field ( int result, int field_offset)

Devuleve un objeto que contiene información de los campos.

mssql_fetch_field() se puede usar para obtener información acerca de los campos pertenecientes al resultado de una consulta. Si el parámetro field_offset no es especificado, se devuelve la información del siguiente campo que todavía no ha sido devuelto por mssql_fetch_field().

Las propiedades de este objeto son:

  • name - nombre de la columna. si la columna es el resultado de una función, esta propiedad vale #N, donde #N es un número de serie.

  • column_source - la tabla de donde se tomó la columna

  • max_length - longitud máxima de columna

  • numeric - 1 si la columna es numérica

Ver también mssql_field_seek()

Anterior | Inicio | Siguiente
mssql_fetch_array | Subir | mssql_fetch_object


mssql_fetch_object

(PHP 3, PHP 4 >= 4.0.0)

mssql_fetch_object -- captura la fila como un objeto

Descripción

int mssql_fetch_object ( int result)

Devuelve: Un objeto con propiedades que se corresponden con la fila capturada, o FALSE si no hay más filas.

mssql_fetch_object() es parecida a mssql_fetch_array(), con una diferencia - devuelve un objeto en vez de un array. Indirectamente, esto significa que sólo se puede acceder a los datos por el nombre de los campos, y no por sus posiciones en el objeto (los números no son nombres de propiedades válidas).

La función es idéntica a mssql_fetch_array(), y casi tan rápida como mssql_fetch_row() (la diferencia es insignificante).

Ver también: mssql_fetch-array() and mssql_fetch-row().

Anterior | Inicio | Siguiente
mssql_fetch_field | Subir | mssql_fetch_row


mssql_fetch_row

(PHP 3, PHP 4 >= 4.0.0)

mssql_fetch_row -- obtiene la fila como un array numerado

Descripción

array mssql_fetch_row ( int result)

Devuleve: Un array que corresponde a la fila capturada, o FALSE si no hay más filas.

mssql_fetch_row() captura una fila de datos pertenecientes al resultado asociado con el identificador de resultado especificado. La fila es devuelta como un array. Cada columna de resultados es almacenada en una posición del array, comenzando en la posición 0.

Siguientes llamadas a mssql_fetch_rows() devolverían las filas siguientes del result set, o FALSE si no hay mas filas.

Ver también: mssql_fetch_array(),
          mssql_fetch_object(),
          mssql_data_seek(),
          mssql_fetch_lengths(), and
          mssql_result().

Anterior | Inicio | Siguiente
mssql_fetch_object | Subir | mssql_field_seek


mssql_field_seek

(PHP 3, PHP 4 >= 4.0.0)

mssql_field_seek -- set field offset

Descripción

int mssql_field_seek ( int result, int field_offset)

Se posiciona en el campo especificado por el parámetro field_offset. Si la siguiente llamada a mssql_fetch_field() no incluye el parámetro field_offset, lo que devuelve la función es el campo.

Ver también: mssql_fetch_field().

Anterior | Inicio | Siguiente
mssql_fetch_row | Subir | mssql_free_result


mssql_free_result

(PHP 3, PHP 4 >= 4.0.0)

mssql_free_result -- libera de la memoria el resultado de una consulta

Descripción

int mssql_free_result ( int result)

mssql_free_result() sólo se necesita llamarla si le preocupa el estar usando mucha memoria mientras se está ejecutando el script. Toda el resultado en memoria será liberado automaticamente cuando finalice el script, puede llamar a mssql_free_result() con el identificador de la consulta como argumento y la consulta asociada será liberada de la memoria.

Anterior | Inicio | Siguiente
mssql_field_seek | Subir | mssql_num_fields


mssql_num_fields

(PHP 3, PHP 4 >= 4.0.0)

mssql_num_fields -- obtiene el número de campos de la consulta

Descripción

int mssql_num_fields ( int result)

mssql_num_fields() devuelve el número de campos de la consulta o result set.

Ver también:
mssql_db_query(),
mssql_query(),
mssql_fetch_field(),
mssql_num_rows().

Anterior | Inicio | Siguiente
mssql_free_result | Subir | mssql_num_rows


mssql_num_rows

(PHP 3, PHP 4 >= 4.0.0)

mssql_num_rows -- obtiene el número de filas de la consulta

Descripción

int mssql_num_rows ( string result)

mssql_num_rows() devuelve el número de filas de la consulta o result set.

Ver también:
mssql_db_query(),
mssql_query() and,
mssql_fetch_row().

Anterior | Inicio | Siguiente
mssql_num_fields | Subir | mssql_pconnect


mssql_pconnect

(PHP 3, PHP 4 >= 4.0.0)

mssql_pconnect -- abre una conexión persistenete con MS SQL

Descripción

int mssql_pconnect ( string servername, string username, string password)

Devuelve: Un identificador persistente postivo si no hay error, o FALSE si se produce alguno

mssql_pconnect() funciona de la misma forma que mssql_connect() aunque con dos grandes diferencias.

La primera es que cuando intenta conectar, la función intentará encontrar un enlace (persistente) que ya esté abierto en el mismo ordenador, nombre de usuario y contrase¤a. Si lo encuentra, la funcion devolverá el identificador de esta en vez de abrir una nueva conexión.

Y la segunda, la conexión con el servidor no se cerrará cuando finalice la ejecución del script. En vez de esto, el enlace permanecerá abierto para un uso futuro. (mssql_close() no cerrará enlaces establecidos por mssql_pconnect()).

Por consiguiente, este tipo de enlace es llamado 'persistente'.

Anterior | Inicio | Siguiente
mssql_num_rows | Subir | mssql_query


mssql_query

(PHP 3, PHP 4 >= 4.0.0)

mssql_query -- envia una consulta MS SQL

Descripción

int mssql_query ( string query, int link_identifier)

Devuelve: Un identificado de resultado valido si no hay error, o FALSE en caso contrario.

mssql_query() envia una petición de consulta a la base de datos activa en el servidor asociada al identificador de enlace especificado. Si el identificador del enlace no es especificado, se asume como abierto el último enlace. Si no hay ningún enlace abierto, la función intenta establecer un enlace como si mssql_connect() hubiera sido llamada, y lo usa.

Ver también:
mssql_db_query(),
mssql_select_db(), and
mssql_connect().

Anterior | Inicio | Siguiente
mssql_pconnect | Subir | mssql_result


mssql_result

(PHP 3, PHP 4 >= 4.0.0)

mssql_result -- get result data

Descripción

int mssql_result ( int result, int i, mixed field)

Devuelve: El contenido de la celda en la fila y posición del result set especificado.

mssql_result() devuelve el contenido de una celda del result set. El parametro field puede ser la posición del campo, o el nombre del campo o bién nombretabla.nombrecampo. Si el nombre de la columna ha sido renombrado ('select foo as bar from...'), use el alias en vez del nombre de la columna.

Trabajando con result sets de gran tama¤o, debería considerar el uso de una de las funciones que capturan una fila completa (especificadas abajo). Como estas funciones devuelven el contenido de múltiples celdas en una sóla llamada, estas son MUCHO más rápidas que mssql_result(). También, observe que especificar una posición númerica para el argumento field es mucho mas rápido que especificar el nombre de un campo o utilizar la forma nombretabla.nombrecampo como argumento.

Alternativas recomendadas para mayor rendimiento :
mssql_fetch_row(),
mssql_fetch_array(), y
mssql_fetch_object().

Anterior | Inicio | Siguiente
mssql_query | Subir | mssql_select_db


mssql_select_db

(PHP 3, PHP 4 >= 4.0.0)

mssql_select_db -- selecciona una base de datos MS SQL

Descripción

int mssql_select_db ( string database_name, int link_identifier)

Devuelve: TRUE si todo va bién, FALSE si se produce un error

mssql_select_db() selecciona como base de datos activa del servidor, la que está asociada al identificador de enlace especificado. Si no se especifica nigún identificador, se asume el último enlace. Si no hay ningún enlace abierto, la función intentará establecer un enlace como si se llamara a la función mssql_connect(), y lo usa.

Cada llamada a mssql_query() será realizada sobre la base de datos activa.

Ver también:
    mssql_connect(),
    mssql_pconnect(), y
    mssql_query()

Anterior | Inicio | Siguiente
mssql_result | Subir | Ming functions for Flash


Ming functions for Flash

Manual de PHP
Anterior Siguiente

LVII. Ming functions for Flash

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

Introduction

Ming is an open-source (LGPL) library which allows you to create SWF ("Flash") format movies. Ming supports almost all of Flash 4's features, including: shapes, gradients, bitmaps (pngs and jpegs), morphs ("shape tweens"), text, buttons, actions, sprites ("movie clips"), streaming mp3, and color transforms--the only thing that's missing is sound events.

Ming is not an acronym.

Note that all values specifying length, distance, size, etc. are in "twips", twenty units per pixel. That's pretty much arbitrary, though, since the player scales the movie to whatever pixel size is specified in the embed/object tag, or the entire frame if not embedded.

Ming offers a number of advantages over the existing PHP/libswf module. You can use Ming anywhere you can compile the code, whereas libswf is closed-source and only available for a few platforms, Windows not one of them. Ming provides some insulation from the mundane details of the SWF file format, wrapping the movie elements in PHP objects. Also, Ming is still being maintained; if there's a feature that you want to see, just let us know ming@opaque.net.

Ming was added in PHP 4.0.5.

Installation

To use Ming with PHP, you first need to build and install the Ming library. Source code and installation instructions are available at the Ming home page : http://www.opaque.net/ming/ along with examples, a small tutorial, and the latest news.

Download the ming archive. Unpack the archive. Go in the Ming directory. make. make install.

This will build libming.so and install it into /usr/lib/, and copy ming.h into /usr/include/. Edit the PREFIX= line in the Makefile to change the installation directory.

built into php (unix)

mkdir <phpdir>/ext/ming
cp php_ext/* <phpdir>/ext/ming
cd <phpdir>
./buildconf
./configure --with-ming <other config options>

Build and install php as usual, Restart web server if necessary

built into php (unix)

download php_ming.so.gz. uncompress it and copy it to your php modules directory. (you can find your php module directory by running php-config --extension-dir). Now either just add extension=php_ming.so to your php.ini file, or put dl('php_ming.so'); at the head of all of your Ming scripts.

How to use Ming

Ming introduces 13 new objects in PHP, all with matching methods and attributes. To use them, you need to know about objects.

  • swfmovie().

  • swfshape().

  • swfdisplayitem().

  • swfgradient().

  • swfbitmap().

  • swffill().

  • swfmorph().

  • swftext().

  • swffont().

  • swftextfield().

  • swfsprite().

  • swfbutton().

  • swfaction().

Tabla de contenidos
ming_setcubicthreshold — Set cubic threshold (?)
ming_setscale — Set scale (?)
ming_useswfversion — Use SWF version (?)
swfbutton_keypress — Returns the action flag for keyPress(char)
SWFMovie — Creates a new movie object, representing an SWF version 4 movie.
SWFMovie->output — Dumps your lovingly prepared movie out.
SWFMovie->save — Saves your movie in a file.
SWFMovie->add — Adds any type of data to a movie.
SWFMovie->remove — Removes the object instance from the display list.
SWFMovie->setbackground — Sets the background color.
SWFMovie->setrate — Sets the animation's frame rate.
SWFMovie->setdimension — Sets the movie's width and height.
SWFMovie->setframes — Sets the total number of frames in the animation.
SWFMovie->nextframe — Moves to the next frame of the animation.
SWFMovie->streammp3 — Streams a MP3 file.
SWFDisplayItem — Creates a new displayitem object.
SWFDisplayItem->moveTo — Moves object in global coordinates.
SWFDisplayItem->move — Moves object in relative coordinates.
SWFDisplayItem->scaleTo — Scales the object in global coordinates.
SWFDisplayItem->scale — Scales the object in relative coordinates.
SWFDisplayItem->rotateTo — Rotates the object in global coordinates.
SWFDisplayItem->Rotate — Rotates in relative coordinates.
SWFDisplayItem->skewXTo — Sets the X-skew.
SWFDisplayItem->skewX — Sets the X-skew.
SWFDisplayItem->skewYTo — Sets the Y-skew.
SWFDisplayItem->skewY — Sets the Y-skew.
SWFDisplayItem->setDepth — Sets z-order
SWFDisplayItem->remove — Removes the object from the movie
SWFDisplayItem->setName — Sets the object's name
SWFDisplayItem->setRatio — Sets the object's ratio.
SWFDisplayItem->addColor — Adds the given color to this item's color transform.
SWFDisplayItem->multColor — Multiplies the item's color transform.
SWFShape — Creates a new shape object.
SWFShape->setLine — Sets the shape's line style.
SWFShape->addFill — Adds a solid fill to the shape.
SWFShape->setLeftFill — Sets left rasterizing color.
SWFShape->setRightFill — Sets right rasterizing color.
SWFShape->movePenTo — Moves the shape's pen.
SWFShape->movePen — Moves the shape's pen (relative).
SWFShape->drawLineTo — Draws a line.
SWFShape->drawLine — Draws a line (relative).
SWFShape->drawCurveTo — Draws a curve.
SWFShape->drawCurve — Draws a curve (relative).
SWFGradient — Creates a gradient object
SWFGradient->addEntry — Adds an entry to the gradient list.
SWFBitmap — Loads Bitmap object
SWFBitmap->getWidth — Returns the bitmap's width.
SWFBitmap->getHeight — Returns the bitmap's height.
SWFFill — Loads SWFFill object
SWFFill->moveTo — Moves fill origin
SWFFill->scaleTo — Sets fill's scale
SWFFill->rotateTo — Sets fill's rotation
SWFFill->skewXTo — Sets fill x-skew
SWFFill->skewYTo — Sets fill y-skew
SWFMorph — Creates a new SWFMorph object.
SWFMorph->getshape1 — Gets a handle to the starting shape
SWFMorph->getshape2 — Gets a handle to the ending shape
SWFText — Creates a new SWFText object.
SWFText->setFont — Sets the current font
SWFText->setHeight — Sets the current font height
SWFText->setSpacing — Sets the current font spacing
SWFText->setColor — Sets the current font color
SWFText->moveTo — Moves the pen
SWFText->addString — Draws a string
SWFText->getWidth — Computes string's width
SWFFont — Loads a font definition
swffont->getwidth — Returns the string's width
SWFTextField — Creates a text field object
SWFTextField->setFont — Sets the text field font
SWFTextField->setbounds — Sets the text field width and height
SWFTextField->align — Sets the text field alignment
SWFTextField->setHeight — Sets the font height of this text field font.
SWFTextField->setLeftMargin — Sets the left margin width of the text field.
SWFTextField->setrightMargin — Sets the right margin width of the text field.
SWFTextField->setMargins — Sets the margins width of the text field.
SWFTextField->setindentation — Sets the indentation of the first line.
SWFTextField->setLineSpacing — Sets the line spacing of the text field.
SWFTextField->setcolor — Sets the color of the text field.
SWFTextField->setname — Sets the variable name
SWFTextField->addstring — Concatenates the given string to the text field
SWFSprite — Creates a movie clip (a sprite)
SWFSprite->add — Adds an object to a sprite
SWFSprite->remove — Removes an object to a sprite
SWFSprite->setframes — Sets the total number of frames in the animation.
SWFSprite->nextframe — Moves to the next frame of the animation.
SWFbutton — Creates a new Button.
SWFbutton->addShape — Adds a shape to a button
SWFbutton->setUp — Alias for addShape(shape, SWFBUTTON_UP)
SWFbutton->setOver — Alias for addShape(shape, SWFBUTTON_OVER)
SWFbutton->setdown — Alias for addShape(shape, SWFBUTTON_DOWN))
SWFbutton->setHit — Alias for addShape(shape, SWFBUTTON_HIT)
SWFbutton->addAction — Adds an action
SWFbutton->setAction — Sets the action
SWFAction — Creates a new Action.

Anterior | Inicio | Siguiente
mssql_select_db | Subir | ming_setcubicthreshold


ming_setcubicthreshold

(PHP 4 >= 4.0.5)

ming_setcubicthreshold -- Set cubic threshold (?)

Description

void ming_setcubicthreshold ( int threshold)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
Ming functions for Flash | Subir | ming_setscale


ming_setscale

(PHP 4 >= 4.0.5)

ming_setscale -- Set scale (?)

Description

void ming_setscale ( int scale)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ming_setcubicthreshold | Subir | ming_useswfversion


ming_useswfversion

(PHP 4 >= 4.2.0)

ming_useswfversion -- Use SWF version (?)

Description

void ming_useswfversion ( int version)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ming_setscale | Subir | swfbutton_keypress


swfbutton_keypress

(PHP 4 >= 4.0.5)

swfbutton_keypress -- Returns the action flag for keyPress(char)

Description

int swfbutton_keypress ( string str)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
ming_useswfversion | Subir | SWFMovie


SWFMovie

(PHP 4 >= 4.0.5)

SWFMovie -- Creates a new movie object, representing an SWF version 4 movie.

Description

new swfmovie ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie() creates a new movie object, representing an SWF version 4 movie.

SWFMovie has the following methods :
swfmovie->output(),swfmovie->save(),
swfmovie->add(), swfmovie->remove(),
swfmovie->nextframe(), swfmovie->setbackground(),
swfmovie->setrate(), swfmovie->setdimension(),
swfmovie->setframes() and swfmovie->streammp3().

See examples in : swfdisplayitem->rotateto(), swfshape->setline(), swfshape->addfill()... Any example will use this object.

Anterior | Inicio | Siguiente
swfbutton_keypress | Subir | SWFMovie->output


SWFMovie->output

(unknown)

SWFMovie->output -- Dumps your lovingly prepared movie out.

Description

void swfmovie->output ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->output() dumps your lovingly prepared movie out. In PHP, preceding this with the command
<?php
header('Content-type: application/x-shockwave-flash');
?>
convinces the browser to display this as a flash movie.

See also swfmovie->save().

See examples in :
swfmovie->streammp3(),
swfdisplayitem->rotateto(),
swfaction()...
Any example will use this method.

Anterior | Inicio | Siguiente
SWFMovie | Subir | SWFMovie->save


SWFMovie->save

(unknown)

SWFMovie->save -- Saves your movie in a file.

Description

void swfmovie->save ( string filename)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->save() saves your movie to the file named filename.

See also output().

Anterior | Inicio | Siguiente
SWFMovie->output | Subir | SWFMovie->add


SWFMovie->add

(unknown)

SWFMovie->add -- Adds any type of data to a movie.

Description

void swfmovie->add ( ressource instance)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->add() adds instance to the current movie. instance is any type of data : Shapes, text, fonts, etc. must all be add'ed to the movie to make this work.

For displayable types (shape, text, button, sprite), this returns an SWFDisplayItem(), a handle to the object in a display list. Thus, you can add the same shape to a movie multiple times and get separate handles back for each separate instance.

See also all other objects (adding this later), and swfmovie->remove()

See examples in : swfdisplayitem->rotateto() and swfshape->addfill().

Anterior | Inicio | Siguiente
SWFMovie->save | Subir | SWFMovie->remove


SWFMovie->remove

(unknown)

SWFMovie->remove -- Removes the object instance from the display list.

Description

void swfmovie->remove ( resource instance)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->remove() removes the object instance instance from the display list.

See also swfmovie->add().

Anterior | Inicio | Siguiente
SWFMovie->add | Subir | SWFMovie->setbackground


SWFMovie->setbackground

(unknown)

SWFMovie->setbackground -- Sets the background color.

Description

void swfmovie->setbackground ( int red, int green, int blue)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->setbackground() sets the background color. Why is there no rgba version? Think about it. (Actually, that's not such a dumb question after all- you might want to let the html background show through. There's a way to do that, but it only works on IE4. Search the http://www.macromedia.com/ site for details.)

Anterior | Inicio | Siguiente
SWFMovie->remove | Subir | SWFMovie->setrate


SWFMovie->setrate

(unknown)

SWFMovie->setrate -- Sets the animation's frame rate.

Description

void swfmovie->setrate ( int rate)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->setrate() sets the frame rate to rate, in frame per seconds. Animation will slow down if the player can't render frames fast enough- unless there's a streaming sound, in which case display frames are sacrificed to keep sound from skipping.

Anterior | Inicio | Siguiente
SWFMovie->setbackground | Subir | SWFMovie->setdimension


SWFMovie->setdimension

(unknown)

SWFMovie->setdimension -- Sets the movie's width and height.

Description

void swfmovie->setdimension ( int width, int height)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->setdimension() sets the movie's width to width and height to height.

Anterior | Inicio | Siguiente
SWFMovie->setrate | Subir | SWFMovie->setframes


SWFMovie->setframes

(unknown)

SWFMovie->setframes -- Sets the total number of frames in the animation.

Description

void swfmovie->setframes ( string numberofframes)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->setframes() sets the total number of frames in the animation to numberofframes.

Anterior | Inicio | Siguiente
SWFMovie->setdimension | Subir | SWFMovie->nextframe


SWFMovie->nextframe

(unknown)

SWFMovie->nextframe -- Moves to the next frame of the animation.

Description

void swfmovie->nextframe ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->setframes() moves to the next frame of the animation.

Anterior | Inicio | Siguiente
SWFMovie->setframes | Subir | SWFMovie->streammp3


SWFMovie->streammp3

(unknown)

SWFMovie->streammp3 -- Streams a MP3 file.

Description

void swfmovie->streammp3 ( string mp3FileName)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmovie->streammp3() streams the mp3 file mp3FileName. Not very robust in dealing with oddities (can skip over an initial ID3 tag, but that's about it). Like SWFShape->addJpegFill(), this isn't a stable function- we'll probably need to make a separate SWFSound object to contain sound types.

Note that the movie isn't smart enough to put enough frames in to contain the entire mp3 stream- you'll have to add (length of song * frames per second) frames to get the entire stream in.

Yes, now you can use ming to put that rock and roll devil worship music into your SWF files. Just don't tell the RIAA.

Ejemplo 1. swfmovie->streammp3() example

<?php
  $m = new SWFMovie();
  $m->setRate(12.0);
  $m->streamMp3("distortobass.mp3");
  // use your own MP3

  // 11.85 seconds at 12.0 fps = 142 frames
  $m->setFrames(142);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFMovie->nextframe | Subir | SWFDisplayItem


SWFDisplayItem

(unknown)

SWFDisplayItem -- Creates a new displayitem object.

Description

new swfdisplayitem ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem() creates a new swfdisplayitem object.

Here's where all the animation takes place. After you define a shape, a text object, a sprite, or a button, you add it to the movie, then use the returned handle to move, rotate, scale, or skew the thing.

SWFDisplayItem has the following methods : swfdisplayitem->move(),
swfdisplayitem->moveto(), swfdisplayitem->scaleto(),
swfdisplayitem->scale(), swfdisplayitem->rotate(),
swfdisplayitem->rotateto(), swfdisplayitem->skewxto(),
swfdisplayitem->skewx(), swfdisplayitem->skewyto()
swfdisplayitem->skewyto(), swfdisplayitem->setdepth()
swfdisplayitem->remove(), swfdisplayitem->setname()
swfdisplayitem->setratio(), swfdisplayitem->addcolor()
and swfdisplayitem->multcolor().

Anterior | Inicio | Siguiente
SWFMovie->streammp3 | Subir | SWFDisplayItem->moveTo


SWFDisplayItem->moveTo

(unknown)

SWFDisplayItem->moveTo -- Moves object in global coordinates.

Description

void swfdisplayitem->moveto ( int x, int y)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->moveto() moves the current object to (x,y) in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->move().

Anterior | Inicio | Siguiente
SWFDisplayItem | Subir | SWFDisplayItem->move


SWFDisplayItem->move

(unknown)

SWFDisplayItem->move -- Moves object in relative coordinates.

Description

void swfdisplayitem->move ( int dx, int dy)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->move() moves the current object by (dx,dy) from its current position.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->moveto().

Anterior | Inicio | Siguiente
SWFDisplayItem->moveTo | Subir | SWFDisplayItem->scaleTo


SWFDisplayItem->scaleTo

(unknown)

SWFDisplayItem->scaleTo -- Scales the object in global coordinates.

Description

void swfdisplayitem->scaleto ( int x, int y)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->scaleto() scales the current object to (x,y) in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->scale().

Anterior | Inicio | Siguiente
SWFDisplayItem->move | Subir | SWFDisplayItem->scale


SWFDisplayItem->scale

(unknown)

SWFDisplayItem->scale -- Scales the object in relative coordinates.

Description

void swfdisplayitem->scale ( int dx, int dy)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->scale() scales the current object by (dx,dy) from its current size.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->scaleto().

Anterior | Inicio | Siguiente
SWFDisplayItem->scaleTo | Subir | SWFDisplayItem->rotateTo


SWFDisplayItem->rotateTo

(unknown)

SWFDisplayItem->rotateTo -- Rotates the object in global coordinates.

Description

void swfdisplayitem->rotateto ( float degrees)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->rotateto() set the current object rotation to degrees degrees in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

This example bring three rotating string from the background to the foreground. Pretty nice.

Ejemplo 1. swfdisplayitem->rotateto() example

<?php
  $thetext =  "ming!";

  $f = new SWFFont("Bauhaus 93.fdb");

  $m = new SWFMovie();
  $m->setRate(24.0);
  $m->setDimension(2400, 1600);
  $m->setBackground(0xff, 0xff, 0xff);

  // functions with huge numbers of arbitrary
  // arguments are always a good idea!  Really!

  function text($r, $g, $b, $a, $rot, $x, $y, $scale, $string)
  {
    global $f, $m;

    $t = new SWFText();
    $t->setFont($f);
    $t->setColor($r, $g, $b, $a);
    $t->setHeight(960);
    $t->moveTo(-($f->getWidth($string))/2, $f->getAscent()/2);
    $t->addString($string);

    // we can add properties just like a normal php var,
    // as long as the names aren't already used.
    // e.g., we can't set $i->scale, because that's a function

    $i = $m->add($t);
    $i->x = $x;
    $i->y = $y;
    $i->rot = $rot;
    $i->s = $scale;
    $i->rotateTo($rot);
    $i->scale($scale, $scale);

    // but the changes are local to the function, so we have to
    // return the changed object.  kinda weird..

    return $i;
 }

  function step($i)
  {
    $oldrot = $i->rot;
    $i->rot = 19*$i->rot/20;
    $i->x = (19*$i->x + 1200)/20;
    $i->y = (19*$i->y + 800)/20;
    $i->s = (19*$i->s + 1.0)/20;

    $i->rotateTo($i->rot);
    $i->scaleTo($i->s, $i->s);
    $i->moveTo($i->x, $i->y);

    return $i;
  }

  // see?  it sure paid off in legibility:

  $i1 = text(0xff, 0x33, 0x33, 0xff, 900, 1200, 800, 0.03, $thetext);
  $i2 = text(0x00, 0x33, 0xff, 0x7f, -560, 1200, 800, 0.04, $thetext);
  $i3 = text(0xff, 0xff, 0xff, 0x9f, 180, 1200, 800, 0.001, $thetext);

  for($i=1; $i<=100; ++$i)
  {
    $i1 = step($i1);
    $i2 = step($i2);
    $i3 = step($i3);

    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

See also swfdisplayitem->rotate().

Anterior | Inicio | Siguiente
SWFDisplayItem->scale | Subir | SWFDisplayItem->Rotate


SWFDisplayItem->Rotate

(unknown)

SWFDisplayItem->Rotate -- Rotates in relative coordinates.

Description

void swfdisplayitem->rotate ( float ddegrees)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->rotate() rotates the current object by ddegrees degrees from its current rotation.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfdisplayitem->rotateto().

Anterior | Inicio | Siguiente
SWFDisplayItem->rotateTo | Subir | SWFDisplayItem->skewXTo


SWFDisplayItem->skewXTo

(unknown)

SWFDisplayItem->skewXTo -- Sets the X-skew.

Description

void swfdisplayitem->skewxto ( float degrees)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->skewxto() sets the x-skew to degrees. For degrees is 1.0, it means a 45-degree forward slant. More is more forward, less is more backward.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also
swfdisplayitem->skewx(),
swfdisplayitem->skewy() and
swfdisplayitem->skewyto().

Anterior | Inicio | Siguiente
SWFDisplayItem->Rotate | Subir | SWFDisplayItem->skewX


SWFDisplayItem->skewX

(unknown)

SWFDisplayItem->skewX -- Sets the X-skew.

Description

void swfdisplayitem->skewx ( float ddegrees)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->skewx() adds ddegrees to current x-skew.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also
swfdisplayitem->skewx(),
swfdisplayitem->skewy() and
swfdisplayitem->skewyto().

Anterior | Inicio | Siguiente
SWFDisplayItem->skewXTo | Subir | SWFDisplayItem->skewYTo


SWFDisplayItem->skewYTo

(unknown)

SWFDisplayItem->skewYTo -- Sets the Y-skew.

Description

void swfdisplayitem->skewyto ( float degrees)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->skewyto() sets the y-skew to degrees. For degrees is 1.0, it means a 45-degree forward slant. More is more upward, less is more downward.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also
swfdisplayitem->skewy(),
swfdisplayitem->skewx() and
swfdisplayitem->skewxto().

Anterior | Inicio | Siguiente
SWFDisplayItem->skewX | Subir | SWFDisplayItem->skewY


SWFDisplayItem->skewY

(unknown)

SWFDisplayItem->skewY -- Sets the Y-skew.

Description

void swfdisplayitem->skewy ( float ddegrees)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->skewy() adds ddegrees to current y-skew.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also
swfdisplayitem->skewyto(),
swfdisplayitem->skewx() and
swfdisplayitem->skewxto().

Anterior | Inicio | Siguiente
SWFDisplayItem->skewYTo | Subir | SWFDisplayItem->setDepth


SWFDisplayItem->setDepth

(unknown)

SWFDisplayItem->setDepth -- Sets z-order

Description

void swfdisplayitem->setdepth ( float depth)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->rotate() sets the object's z-order to depth. Depth defaults to the order in which instances are created (by add'ing a shape/text to a movie)- newer ones are on top of older ones. If two objects are given the same depth, only the later-defined one can be moved.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Anterior | Inicio | Siguiente
SWFDisplayItem->skewY | Subir | SWFDisplayItem->remove


SWFDisplayItem->remove

(unknown)

SWFDisplayItem->remove -- Removes the object from the movie

Description

void swfdisplayitem->remove ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->remove() removes this object from the movie's display list.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

See also swfmovie->add().

Anterior | Inicio | Siguiente
SWFDisplayItem->setDepth | Subir | SWFDisplayItem->setName


SWFDisplayItem->setName

(unknown)

SWFDisplayItem->setName -- Sets the object's name

Description

void swfdisplayitem->setname ( string name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->setname() sets the object's name to name, for targetting with action script. Only useful on sprites.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Anterior | Inicio | Siguiente
SWFDisplayItem->remove | Subir | SWFDisplayItem->setRatio


SWFDisplayItem->setRatio

(unknown)

SWFDisplayItem->setRatio -- Sets the object's ratio.

Description

void swfdisplayitem->setratio ( float ratio)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->setratio() sets the object's ratio to ratio. Obviously only useful for morphs.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

This simple example will morph nicely three concentric circles.

Ejemplo 1. swfdisplayitem->setname() example

<?php

  $p = new SWFMorph();

  $g = new SWFGradient();
  $g->addEntry(0.0, 0, 0, 0);
  $g->addEntry(0.16, 0xff, 0xff, 0xff);
  $g->addEntry(0.32, 0, 0, 0);
  $g->addEntry(0.48, 0xff, 0xff, 0xff);
  $g->addEntry(0.64, 0, 0, 0);
  $g->addEntry(0.80, 0xff, 0xff, 0xff);
  $g->addEntry(1.00, 0, 0, 0);

  $s = $p->getShape1();
  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.05);
  $s->setLeftFill($f);
  $s->movePenTo(-160, -120);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $g = new SWFGradient();
  $g->addEntry(0.0, 0, 0, 0);
  $g->addEntry(0.16, 0xff, 0, 0);
  $g->addEntry(0.32, 0, 0, 0);
  $g->addEntry(0.48, 0, 0xff, 0);
  $g->addEntry(0.64, 0, 0, 0);
  $g->addEntry(0.80, 0, 0, 0xff);
  $g->addEntry(1.00, 0, 0, 0);

  $s = $p->getShape2();
  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.05);
  $f->skewXTo(1.0);
  $s->setLeftFill($f);
  $s->movePenTo(-160, -120);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m = new SWFMovie();
  $m->setDimension(320, 240);
  $i = $m->add($p);
  $i->moveTo(160, 120);

  for($n=0; $n<=1.001; $n+=0.01)
  {
    $i->setRatio($n);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFDisplayItem->setName | Subir | SWFDisplayItem->addColor


SWFDisplayItem->addColor

(unknown)

SWFDisplayItem->addColor -- Adds the given color to this item's color transform.

Description

void swfdisplayitem->addcolor ( [int red [, int green [, int blue [, int a]]]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->addcolor() adds the color to this item's color transform. The color is given in its RGB form.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Anterior | Inicio | Siguiente
SWFDisplayItem->setRatio | Subir | SWFDisplayItem->multColor


SWFDisplayItem->multColor

(unknown)

SWFDisplayItem->multColor -- Multiplies the item's color transform.

Description

void swfdisplayitem->multcolor ( [int red [, int green [, int blue [, int a]]]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfdisplayitem->multcolor() multiplies the item's color transform by the given values.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

This simple example will modify your picture's atmospher to Halloween (use a landscape or bright picture).

Ejemplo 1. swfdisplayitem->multcolor() example

<?php

  $b = new SWFBitmap("backyard.jpg");
  // note use your own picture :-)
  $s = new SWFShape();
  $s->setRightFill($s->addFill($b));
  $s->drawLine($b->getWidth(), 0);
  $s->drawLine(0, $b->getHeight());
  $s->drawLine(-$b->getWidth(), 0);
  $s->drawLine(0, -$b->getHeight());

  $m = new SWFMovie();
  $m->setDimension($b->getWidth(), $b->getHeight());

  $i = $m->add($s);

  for($n=0; $n<=20; ++$n)
  {
    $i->multColor(1.0-$n/10, 1.0, 1.0);
    $i->addColor(0xff*$n/20, 0, 0);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFDisplayItem->addColor | Subir | SWFShape


SWFShape

(PHP 4 >= 4.0.5)

SWFShape -- Creates a new shape object.

Description

new swfshape ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfshape() creates a new shape object.

SWFShape has the following methods : swfshape->setline(),
swfshape->addfill(), swfshape->setleftfill(),
swfshape->setrightfill(), swfshape->movepento(),
swfshape->movepen(), swfshape->drawlineto(),
swfshape->drawline(), swfshape->drawcurveto()
and swfshape->drawcurve().

This simple example will draw a big red elliptic quadrant.

Ejemplo 1. swfshape() example

<?php
  $s = new SWFShape();
  $s->setLine(40, 0x7f, 0, 0);
  $s->setRightFill($s->addFill(0xff, 0, 0));
  $s->movePenTo(200, 200);
  $s->drawLineTo(6200, 200);
  $s->drawLineTo(6200, 4600);
  $s->drawCurveTo(200, 4600, 200, 200);

  $m = new SWFMovie();
  $m->setDimension(6400, 4800);
  $m->setRate(12.0);
  $m->add($s);
  $m->nextFrame();

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFDisplayItem->multColor | Subir | SWFShape->setLine


SWFShape->setLine

(unknown)

SWFShape->setLine -- Sets the shape's line style.

Description

void swfshape->setline ( int width [, int red [, int green [, int blue [, int a]]]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfshape->setline() sets the shape's line style. width is the line's width. If width is 0, the line's style is removed (then, all other arguments are ignored). If width > 0, then line's color is set to red, green, blue. Last parameter a is optional.

swfshape->setline() accepts 1, 4 or 5 arguments (not 3 or 2).

You must declare all line styles before you use them (see example).

This simple example will draw a big "!#%*@", in funny colors and gracious style.

Ejemplo 1. swfshape->setline() example

<?php
  $s = new SWFShape();
  $f1 = $s->addFill(0xff, 0, 0);
  $f2 = $s->addFill(0xff, 0x7f, 0);
  $f3 = $s->addFill(0xff, 0xff, 0);
  $f4 = $s->addFill(0, 0xff, 0);
  $f5 = $s->addFill(0, 0, 0xff);

  // bug: have to declare all line styles before you use them
  $s->setLine(40, 0x7f, 0, 0);
  $s->setLine(40, 0x7f, 0x3f, 0);
  $s->setLine(40, 0x7f, 0x7f, 0);
  $s->setLine(40, 0, 0x7f, 0);
  $s->setLine(40, 0, 0, 0x7f);

  $f = new SWFFont('Techno.fdb');

  $s->setRightFill($f1);
  $s->setLine(40, 0x7f, 0, 0);
  $s->drawGlyph($f, '!');
  $s->movePen($f->getWidth('!'), 0);

  $s->setRightFill($f2);
  $s->setLine(40, 0x7f, 0x3f, 0);
  $s->drawGlyph($f, '#');
  $s->movePen($f->getWidth('#'), 0);

  $s->setRightFill($f3);
  $s->setLine(40, 0x7f, 0x7f, 0);
  $s->drawGlyph($f, '%');
  $s->movePen($f->getWidth('%'), 0);

  $s->setRightFill($f4);
  $s->setLine(40, 0, 0x7f, 0);
  $s->drawGlyph($f, '*');
  $s->movePen($f->getWidth('*'), 0);

  $s->setRightFill($f5);
  $s->setLine(40, 0, 0, 0x7f);
  $s->drawGlyph($f, '@');

  $m = new SWFMovie();
  $m->setDimension(3000,2000);
  $m->setRate(12.0);
  $i = $m->add($s);
  $i->moveTo(1500-$f->getWidth("!#%*@")/2, 1000+$f->getAscent()/2);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFShape | Subir | SWFShape->addFill


SWFShape->addFill

(unknown)

SWFShape->addFill -- Adds a solid fill to the shape.

Description

void swfshape->addfill ( int red, int green, int blue [, int a])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

void swfshape->addfill ( SWFbitmap bitmap [, int flags])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

void swfshape->addfill ( SWFGradient gradient [, int flags])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfshape->addfill() adds a solid fill to the shape's list of fill styles. swfshape->addfill() accepts three different types of arguments.

red, green, blue is a color (RGB mode). Last parameter a is optional.

The bitmap argument is an swfbitmap() object. The flags argument can be one of the following values : SWFFILL_CLIPPED_BITMAP or SWFFILL_TILED_BITMAP. Default is SWFFILL_TILED_BITMAP. I think.

The gradient argument is an swfgradient() object. The flags argument can be one of the following values : SWFFILL_RADIAL_GRADIENT or SWFFILL_LINEAR_GRADIENT. Default is SWFFILL_LINEAR_GRADIENT. I'm sure about this one. Really.

swfshape->addfill() returns an swffill()
object for use with the swfshape->setleftfill()
and swfshape->setrightfill() functions
described below.

See also swfshape->setleftfill() and swfshape->setrightfill().

This simple example will draw a frame on a bitmap. Ah, here's another buglet in the flash player- it doesn't seem to care about the second shape's bitmap's transformation in a morph. According to spec, the bitmap should stretch along with the shape in this example..

Ejemplo 1. swfshape->addfill() example

<?php

  $p = new SWFMorph();

  $b = new SWFBitmap("alphafill.jpg");
  // use your own bitmap
  $width = $b->getWidth();
  $height = $b->getHeight();

  $s = $p->getShape1();
  $f = $s->addFill($b, SWFFILL_TILED_BITMAP);
  $f->moveTo(-$width/2, -$height/4);
  $f->scaleTo(1.0, 0.5);
  $s->setLeftFill($f);
  $s->movePenTo(-$width/2, -$height/4);
  $s->drawLine($width, 0);
  $s->drawLine(0, $height/2);
  $s->drawLine(-$width, 0);
  $s->drawLine(0, -$height/2);

  $s = $p->getShape2();
  $f = $s->addFill($b, SWFFILL_TILED_BITMAP);

  // these two have no effect!
  $f->moveTo(-$width/4, -$height/2);
  $f->scaleTo(0.5, 1.0);

  $s->setLeftFill($f);
  $s->movePenTo(-$width/4, -$height/2);
  $s->drawLine($width/2, 0);
  $s->drawLine(0, $height);
  $s->drawLine(-$width/2, 0);
  $s->drawLine(0, -$height);

  $m = new SWFMovie();
  $m->setDimension($width, $height);
  $i = $m->add($p);
  $i->moveTo($width/2, $height/2);

  for($n=0; $n<1.001; $n+=0.03)
  {
    $i->setRatio($n);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFShape->setLine | Subir | SWFShape->setLeftFill


SWFShape->setLeftFill

(unknown)

SWFShape->setLeftFill -- Sets left rasterizing color.

Description

void swfshape->setleftfill ( swfgradient fill)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

void swfshape->setleftfill ( int red, int green, int blue [, int a])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

What this nonsense is about is, every edge segment borders at most two fills. When rasterizing the object, it's pretty handy to know what those fills are ahead of time, so the swf format requires these to be specified.

swfshape->setleftfill() sets the fill on the left side of the edge- that is, on the interior if you're defining the outline of the shape in a counter-clockwise fashion. The fill object is an SWFFill object returned from one of the addFill functions above.

This seems to be reversed when you're defining a shape in a morph, though. If your browser crashes, just try setting the fill on the other side.

Shortcut for swfshape->setleftfill($s->addfill($r, $g, $b [, $a]));.

See also swfshape->setrightfill().

Anterior | Inicio | Siguiente
SWFShape->addFill | Subir | SWFShape->setRightFill


SWFShape->setRightFill

(unknown)

SWFShape->setRightFill -- Sets right rasterizing color.

Description

void swfshape->setrightfill ( swfgradient fill)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

void swfshape->setrightfill ( int red, int green, int blue [, int a])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

See also swfshape->setleftfill().

Shortcut for swfshape->setrightfill($s->addfill($r, $g, $b [, $a]));.

Anterior | Inicio | Siguiente
SWFShape->setLeftFill | Subir | SWFShape->movePenTo


SWFShape->movePenTo

(unknown)

SWFShape->movePenTo -- Moves the shape's pen.

Description

void swfshape->movepento ( int x, int y)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfshape->setrightfill() move the shape's pen to (x,y) in the shape's coordinate space.

See also
swfshape->movepen(),
swfshape->drawcurveto(),
swfshape->drawlineto() and
swfshape->drawline().

Anterior | Inicio | Siguiente
SWFShape->setRightFill | Subir | SWFShape->movePen


SWFShape->movePen

(unknown)

SWFShape->movePen -- Moves the shape's pen (relative).

Description

void swfshape->movepen ( int dx, int dy)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfshape->setrightfill() move the shape's pen from coordinates (current x,current y) to (current x + dx, current y + dy) in the shape's coordinate space.

See also
swfshape->movepento(),
swfshape->drawcurveto(),
swfshape->drawlineto() and
swfshape->drawline().

Anterior | Inicio | Siguiente
SWFShape->movePenTo | Subir | SWFShape->drawLineTo


SWFShape->drawLineTo

(unknown)

SWFShape->drawLineTo -- Draws a line.

Description

void swfshape->drawlineto ( int x, int y)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfshape->setrightfill() draws a line (using the current line style, set by swfshape->setline()) from the current pen position to point (x,y) in the shape's coordinate space.

See also
swfshape->movepento(),
swfshape->drawcurveto(),
swfshape->movepen() and
swfshape->drawline().

Anterior | Inicio | Siguiente
SWFShape->movePen | Subir | SWFShape->drawLine


SWFShape->drawLine

(unknown)

SWFShape->drawLine -- Draws a line (relative).

Description

void swfshape->drawline ( int dx, int dy)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfshape->drawline() draws a line (using the current line style set by swfshape->setline()) from the current pen position to displacement (dx,dy).

See also
swfshape->movepento(),
swfshape->drawcurveto(),
swfshape->movepen() and
swfshape->drawlineto().

Anterior | Inicio | Siguiente
SWFShape->drawLineTo | Subir | SWFShape->drawCurveTo


SWFShape->drawCurveTo

(unknown)

SWFShape->drawCurveTo -- Draws a curve.

Description

void swfshape->drawcurveto ( int controlx, int controly, int anchorx, int anchory)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfshape->drawcurveto() draws a quadratic curve (using the current line style, set by swfshape->setline()) from the current pen position to (anchorx,anchory) using (controlx,controly) as a control point. That is, head towards the control point, then smoothly turn to the anchor point.

See also
swfshape->drawlineto(),
swfshape->drawline(),
swfshape->movepento() and
swfshape->movepen().

Anterior | Inicio | Siguiente
SWFShape->drawLine | Subir | SWFShape->drawCurve


SWFShape->drawCurve

(unknown)

SWFShape->drawCurve -- Draws a curve (relative).

Description

void swfshape->drawcurve ( int controldx, int controldy, int anchordx, int anchordy)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfshape->drawcurve() draws a quadratic curve (using the current line style,set by swfshape->setline()) from the current pen position to the relative position (anchorx,anchory) using relative control point (controlx,controly). That is, head towards the control point, then smoothly turn to the anchor point.

See also
swfshape->drawlineto(),
swfshape->drawline(),
swfshape->movepento() and
swfshape->movepen().

Anterior | Inicio | Siguiente
SWFShape->drawCurveTo | Subir | SWFGradient


SWFGradient

(PHP 4 >= 4.0.5)

SWFGradient -- Creates a gradient object

Description

new swfgradient ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfgradient() creates a new SWFGradient object.

After you've added the entries to your gradient, you can use the gradient in a shape fill with the swfshape->addfill() method.

SWFGradient has the following methods : swfgradient->addentry().

This simple example will draw a big black-to-white gradient as background, and a redish disc in its center.

Ejemplo 1. swfgradient() example

<?php

  $m = new SWFMovie();
  $m->setDimension(320, 240);

  $s = new SWFShape();

  // first gradient- black to white
  $g = new SWFGradient();
  $g->addEntry(0.0, 0, 0, 0);
  $g->addEntry(1.0, 0xff, 0xff, 0xff);

  $f = $s->addFill($g, SWFFILL_LINEAR_GRADIENT);
  $f->scaleTo(0.01);
  $f->moveTo(160, 120);
  $s->setRightFill($f);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m->add($s);

  $s = new SWFShape();

  // second gradient- radial gradient from red to transparent
  $g = new SWFGradient();
  $g->addEntry(0.0, 0xff, 0, 0, 0xff);
  $g->addEntry(1.0, 0xff, 0, 0, 0);

  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.005);
  $f->moveTo(160, 120);
  $s->setRightFill($f);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m->add($s);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFShape->drawCurve | Subir | SWFGradient->addEntry


SWFGradient->addEntry

(unknown)

SWFGradient->addEntry -- Adds an entry to the gradient list.

Description

void swfgradient->addentry ( float ratio, int red, int green, int blue [, int a])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfgradient->addentry() adds an entry to the gradient list. ratio is a number between 0 and 1 indicating where in the gradient this color appears. Thou shalt add entries in order of increasing ratio.

red, green, blue is a color (RGB mode). Last parameter a is optional.

Anterior | Inicio | Siguiente
SWFGradient | Subir | SWFBitmap


SWFBitmap

(PHP 4 >= 4.0.5)

SWFBitmap -- Loads Bitmap object

Description

new swfbitmap ( string filename [, int alphafilename])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbitmap() creates a new SWFBitmap object from the Jpeg or DBL file named filename. alphafilename indicates a MSK file to be used as an alpha mask for a Jpeg image.

Nota: We can only deal with baseline (frame 0) jpegs, no baseline optimized or progressive scan jpegs!

SWFBitmap has the following methods : swfbitmap->getwidth() and swfbitmap->getheight().

You can't import png images directly, though- have to use the png2dbl utility to make a dbl ("define bits lossless") file from the png. The reason for this is that I don't want a dependency on the png library in ming- autoconf should solve this, but that's not set up yet.

Ejemplo 1. Import PNG files

<?php
  $s = new SWFShape();
  $f = $s->addFill(new SWFBitmap("png.dbl"));
  $s->setRightFill($f);

  $s->drawLine(32, 0);
  $s->drawLine(0, 32);
  $s->drawLine(-32, 0);
  $s->drawLine(0, -32);

  $m = new SWFMovie();
  $m->setDimension(32, 32);
  $m->add($s);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

And you can put an alpha mask on a jpeg fill.

Ejemplo 2. swfbitmap() example

<?php

  $s = new SWFShape();

  // .msk file generated with "gif2mask" utility
  $f = $s->addFill(new SWFBitmap("alphafill.jpg", "alphafill.msk"));
  $s->setRightFill($f);

  $s->drawLine(640, 0);
  $s->drawLine(0, 480);
  $s->drawLine(-640, 0);
  $s->drawLine(0, -480);

  $c = new SWFShape();
  $c->setRightFill($c->addFill(0x99, 0x99, 0x99));
  $c->drawLine(40, 0);
  $c->drawLine(0, 40);
  $c->drawLine(-40, 0);
  $c->drawLine(0, -40);

  $m = new SWFMovie();
  $m->setDimension(640, 480);
  $m->setBackground(0xcc, 0xcc, 0xcc);

  // draw checkerboard background
  for($y=0; $y<480; $y+=40)
  {
    for($x=0; $x<640; $x+=80)
    {
      $i = $m->add($c);
      $i->moveTo($x, $y);
    }

    $y+=40;

    for($x=40; $x<640; $x+=80)
    {
      $i = $m->add($c);
      $i->moveTo($x, $y);
    }
  }

  $m->add($s);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFGradient->addEntry | Subir | SWFBitmap->getWidth


SWFBitmap->getWidth

(unknown)

SWFBitmap->getWidth -- Returns the bitmap's width.

Description

int swfbitmap->getwidth ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbitmap->getwidth() returns the bitmap's width in pixels.

See also swfbitmap->getheight().

Anterior | Inicio | Siguiente
SWFBitmap | Subir | SWFBitmap->getHeight


SWFBitmap->getHeight

(unknown)

SWFBitmap->getHeight -- Returns the bitmap's height.

Description

int swfbitmap->getheight ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbitmap->getheight() returns the bitmap's height in pixels.

See also swfbitmap->getwidth().

Anterior | Inicio | Siguiente
SWFBitmap->getWidth | Subir | SWFFill


SWFFill

(PHP 4 >= 4.0.5)

SWFFill -- Loads SWFFill object

Description

The swffill() object allows you to transform (scale, skew, rotate) bitmap and gradient fills. swffill() objects are created by the swfshape->addfill() methods.

SWFFill has the following methods : swffill->moveto() and swffill->scaleto(), swffill->rotateto(), swffill->skewxto() and swffill->skewyto().

Anterior | Inicio | Siguiente
SWFBitmap->getHeight | Subir | SWFFill->moveTo


SWFFill->moveTo

(unknown)

SWFFill->moveTo -- Moves fill origin

Description

void swffill->moveto ( int x, int y)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swffill->moveto() moves fill's origin to (x,y) in global coordinates.

Anterior | Inicio | Siguiente
SWFFill | Subir | SWFFill->scaleTo


SWFFill->scaleTo

(unknown)

SWFFill->scaleTo -- Sets fill's scale

Description

void swffill->scaleto ( int x, int y)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swffill->scaleto() sets fill's scale to x in the x-direction, y in the y-direction.

Anterior | Inicio | Siguiente
SWFFill->moveTo | Subir | SWFFill->rotateTo


SWFFill->rotateTo

(unknown)

SWFFill->rotateTo -- Sets fill's rotation

Description

void swffill->rotateto ( float degrees)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swffill->rotateto() sets fill's rotation to degrees degrees.

Anterior | Inicio | Siguiente
SWFFill->scaleTo | Subir | SWFFill->skewXTo


SWFFill->skewXTo

(unknown)

SWFFill->skewXTo -- Sets fill x-skew

Description

void swffill->skewxto ( float x)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swffill->skewxto() sets fill x-skew to x. For x is 1.0, it is a is a 45-degree forward slant. More is more forward, less is more backward.

Anterior | Inicio | Siguiente
SWFFill->rotateTo | Subir | SWFFill->skewYTo


SWFFill->skewYTo

(unknown)

SWFFill->skewYTo -- Sets fill y-skew

Description

void swffill->skewyto ( float y)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swffill->skewyto() sets fill y-skew to y. For y is 1.0, it is a is a 45-degree upward slant. More is more upward, less is more downward.

Anterior | Inicio | Siguiente
SWFFill->skewXTo | Subir | SWFMorph


SWFMorph

(PHP 4 >= 4.0.5)

SWFMorph -- Creates a new SWFMorph object.

Description

new swfmorph ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmorph() creates a new SWFMorph object.

Also called a "shape tween". This thing lets you make those tacky twisting things that make your computer choke. Oh, joy!

The methods here are sort of weird. It would make more sense to just have newSWFMorph(shape1, shape2);, but as things are now, shape2 needs to know that it's the second part of a morph. (This, because it starts writing its output as soon as it gets drawing commands- if it kept its own description of its shapes and wrote on completion this and some other things would be much easier.)

SWFMorph has the following methods : swfmorph->getshape1() and swfmorph->getshape1().

This simple example will morph a big red square into a smaller blue black-bordered square.

Ejemplo 1. swfmorph() example

<?php
  $p = new SWFMorph();

  $s = $p->getShape1();
  $s->setLine(0,0,0,0);

  /* Note that this is backwards from normal shapes (left instead of right).
     I have no idea why, but this seems to work.. */

  $s->setLeftFill($s->addFill(0xff, 0, 0));
  $s->movePenTo(-1000,-1000);
  $s->drawLine(2000,0);
  $s->drawLine(0,2000);
  $s->drawLine(-2000,0);
  $s->drawLine(0,-2000);

  $s = $p->getShape2();
  $s->setLine(60,0,0,0);
  $s->setLeftFill($s->addFill(0, 0, 0xff));
  $s->movePenTo(0,-1000);
  $s->drawLine(1000,1000);
  $s->drawLine(-1000,1000);
  $s->drawLine(-1000,-1000);
  $s->drawLine(1000,-1000);

  $m = new SWFMovie();
  $m->setDimension(3000,2000);
  $m->setBackground(0xff, 0xff, 0xff);

  $i = $m->add($p);
  $i->moveTo(1500,1000);

  for($r=0.0; $r<=1.0; $r+=0.1)
  {
    $i->setRatio($r);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFFill->skewYTo | Subir | SWFMorph->getshape1


SWFMorph->getshape1

(unknown)

SWFMorph->getshape1 -- Gets a handle to the starting shape

Description

mixed swfmorph->getshape1 ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmorph->getshape1() gets a handle to the morph's starting shape. swfmorph->getshape1() returns an swfshape() object.

Anterior | Inicio | Siguiente
SWFMorph | Subir | SWFMorph->getshape2


SWFMorph->getshape2

(unknown)

SWFMorph->getshape2 -- Gets a handle to the ending shape

Description

mixed swfmorph->getshape2 ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfmorph->getshape2() gets a handle to the morph's ending shape. swfmorph->getshape2() returns an swfshape() object.

Anterior | Inicio | Siguiente
SWFMorph->getshape1 | Subir | SWFText


SWFText

(PHP 4 >= 4.0.5)

SWFText -- Creates a new SWFText object.

Description

new swftext ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftext() creates a new SWFText object, fresh for manipulating.

SWFText has the following methods : swftext->setfont(),
swftext->setheight(), swftext->setspacing(),
swftext->setcolor(), swftext->moveto(),
swftext->addstring() and swftext->getwidth().

This simple example will draw a big yellow "PHP generates Flash with Ming" text, on white background.

Ejemplo 1. swftext() example

<?php
  $f = new SWFFont("Techno.fdb");
  $t = new SWFText();
  $t->setFont($f);
  $t->moveTo(200, 2400);
  $t->setColor(0xff, 0xff, 0);
  $t->setHeight(1200);
  $t->addString("PHP generates Flash with Ming!!");

  $m = new SWFMovie();
  $m->setDimension(5400, 3600);

  $m->add($t);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFMorph->getshape2 | Subir | SWFText->setFont


SWFText->setFont

(unknown)

SWFText->setFont -- Sets the current font

Description

void swftext->setfont ( string font)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftext->setfont() sets the current font to font.

Anterior | Inicio | Siguiente
SWFText | Subir | SWFText->setHeight


SWFText->setHeight

(unknown)

SWFText->setHeight -- Sets the current font height

Description

void swftext->setheight ( int height)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftext->setheight() sets the current font height to height. Default is 240.

Anterior | Inicio | Siguiente
SWFText->setFont | Subir | SWFText->setSpacing


SWFText->setSpacing

(unknown)

SWFText->setSpacing -- Sets the current font spacing

Description

void swftext->setspacing ( float spacing)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftext->setspacing() sets the current font spacing to spacingspacing. Default is 1.0. 0 is all of the letters written at the same point. This doesn't really work that well because it inflates the advance across the letter, doesn't add the same amount of spacing between the letters. I should try and explain that better, prolly. Or just fix the damn thing to do constant spacing. This was really just a way to figure out how letter advances work, anyway.. So nyah.

Anterior | Inicio | Siguiente
SWFText->setHeight | Subir | SWFText->setColor


SWFText->setColor

(unknown)

SWFText->setColor -- Sets the current font color

Description

void swftext->setcolor ( int red, int green, int blue [, int a])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftext->setspacing() changes the current text color. Default is black. I think. Color is represented using the RGB system.

Anterior | Inicio | Siguiente
SWFText->setSpacing | Subir | SWFText->moveTo


SWFText->moveTo

(unknown)

SWFText->moveTo -- Moves the pen

Description

void swftext->moveto ( int x, int y)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftext->moveto() moves the pen (or cursor, if that makes more sense) to (x,y) in text object's coordinate space. If either is zero, though, value in that dimension stays the same. Annoying, should be fixed.

Anterior | Inicio | Siguiente
SWFText->setColor | Subir | SWFText->addString


SWFText->addString

(unknown)

SWFText->addString -- Draws a string

Description

void swftext->addstring ( string string)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftext->addstring() draws the string string at the current pen (cursor) location. Pen is at the baseline of the text; i.e., ascending text is in the -y direction.

Anterior | Inicio | Siguiente
SWFText->moveTo | Subir | SWFText->getWidth


SWFText->getWidth

(unknown)

SWFText->getWidth -- Computes string's width

Description

void swftext->addstring ( string string)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftext->addstring() returns the rendered width of the string string at the text object's current font, scale, and spacing settings.

Anterior | Inicio | Siguiente
SWFText->addString | Subir | SWFFont


SWFFont

(PHP 4 >= 4.0.5)

SWFFont -- Loads a font definition

Description

new swffont ( string filename)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

If filename is the name of an FDB file (i.e., it ends in ".fdb"), load the font definition found in said file. Otherwise, create a browser-defined font reference.

FDB ("font definition block") is a very simple wrapper for the SWF DefineFont2 block which contains a full description of a font. One may create FDB files from SWT Generator template files with the included makefdb utility- look in the util directory off the main ming distribution directory.

Browser-defined fonts don't contain any information about the font other than its name. It is assumed that the font definition will be provided by the movie player. The fonts _serif, _sans, and _typewriter should always be available. For example:
<?php
$f = newSWFFont("_sans");
?>
will give you the standard sans-serif font, probably the same as what you'd get with <font name="sans-serif"> in HTML.

swffont() returns a reference to the font definition, for use in the SWFText->setFont() and the SWFTextField->setFont() methods.

SWFFont has the following methods : swffont->getwidth().

Anterior | Inicio | Siguiente
SWFText->getWidth | Subir | swffont->getwidth


swffont->getwidth

(unknown)

swffont->getwidth -- Returns the string's width

Description

int swffont->getwidth ( string string)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swffont->getwidth() returns the string string's width, using font's default scaling. You'll probably want to use the SWFText() version of this method which uses the text object's scale.

Anterior | Inicio | Siguiente
SWFFont | Subir | SWFTextField


SWFTextField

(PHP 4 >= 4.0.5)

SWFTextField -- Creates a text field object

Description

new swftextfield ( [int flags])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield() creates a new text field object. Text Fields are less flexible than swftext() objects- they can't be rotated, scaled non-proportionally, or skewed, but they can be used as form entries, and they can use browser-defined fonts.

The optional flags change the text field's behavior. It has the following possibles values :

  • SWFTEXTFIELD_NOEDIT indicates that the field shouldn't be user-editable

  • SWFTEXTFIELD_PASSWORD obscures the data entry

  • SWFTEXTFIELD_DRAWBOX draws the outline of the textfield

  • SWFTEXTFIELD_MULTILINE allows multiple lines

  • SWFTEXTFIELD_WORDWRAP allows text to wrap

  • SWFTEXTFIELD_NOSELECT makes the field non-selectable

Flags are combined with the bitwise OR operation. For example,
<?php
$t = newSWFTextField(SWFTEXTFIELD_PASSWORD | SWFTEXTFIELD_NOEDIT);
?>
creates a totally useless non-editable password field.

SWFTextField has the following methods : swftextfield->setfont(),
swftextfield->setbounds(), swftextfield->align(),
swftextfield->setheight(), swftextfield->setleftmargin(),
swftextfield->setrightmargin(), swftextfield->setmargins(),
swftextfield->setindentation(), swftextfield->setlinespacing(),
swftextfield->setcolor(), swftextfield->setname() and
swftextfield->addstring().

Anterior | Inicio | Siguiente
swffont->getwidth | Subir | SWFTextField->setFont


SWFTextField->setFont

(unknown)

SWFTextField->setFont -- Sets the text field font

Description

void swftextfield->setfont ( string font)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setfont() sets the text field font to the [browser-defined?] font font.

Anterior | Inicio | Siguiente
SWFTextField | Subir | SWFTextField->setbounds


SWFTextField->setbounds

(unknown)

SWFTextField->setbounds -- Sets the text field width and height

Description

void swftextfield->setbounds ( int width, int height)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setbounds() sets the text field width to width and height to height. If you don't set the bounds yourself, Ming makes a poor guess at what the bounds are.

Anterior | Inicio | Siguiente
SWFTextField->setFont | Subir | SWFTextField->align


SWFTextField->align

(unknown)

SWFTextField->align -- Sets the text field alignment

Description

void swftextfield->align ( int alignement)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->align() sets the text field alignment to alignement. Valid values for alignement are : SWFTEXTFIELD_ALIGN_LEFT, SWFTEXTFIELD_ALIGN_RIGHT, SWFTEXTFIELD_ALIGN_CENTER and SWFTEXTFIELD_ALIGN_JUSTIFY.

Anterior | Inicio | Siguiente
SWFTextField->setbounds | Subir | SWFTextField->setHeight


SWFTextField->setHeight

(unknown)

SWFTextField->setHeight -- Sets the font height of this text field font.

Description

void swftextfield->setheight ( int height)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setheight() sets the font height of this text field font to the given height height. Default is 240.

Anterior | Inicio | Siguiente
SWFTextField->align | Subir | SWFTextField->setLeftMargin


SWFTextField->setLeftMargin

(unknown)

SWFTextField->setLeftMargin -- Sets the left margin width of the text field.

Description

void swftextfield->setleftmargin ( int width)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setleftmargin() sets the left margin width of the text field to width. Default is 0.

Anterior | Inicio | Siguiente
SWFTextField->setHeight | Subir | SWFTextField->setrightMargin


SWFTextField->setrightMargin

(unknown)

SWFTextField->setrightMargin -- Sets the right margin width of the text field.

Description

void swftextfield->setrightmargin ( int width)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setrightmargin() sets the right margin width of the text field to width. Default is 0.

Anterior | Inicio | Siguiente
SWFTextField->setLeftMargin | Subir | SWFTextField->setMargins


SWFTextField->setMargins

(unknown)

SWFTextField->setMargins -- Sets the margins width of the text field.

Description

void swftextfield->setmargins ( int left, int right)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setmargins() set both margins at once, for the man on the go.

Anterior | Inicio | Siguiente
SWFTextField->setrightMargin | Subir | SWFTextField->setindentation


SWFTextField->setindentation

(unknown)

SWFTextField->setindentation -- Sets the indentation of the first line.

Description

void swftextfield->setindentation ( int width)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setindentation() sets the indentation of the first line in the text field, to width.

Anterior | Inicio | Siguiente
SWFTextField->setMargins | Subir | SWFTextField->setLineSpacing


SWFTextField->setLineSpacing

(unknown)

SWFTextField->setLineSpacing -- Sets the line spacing of the text field.

Description

void swftextfield->setlinespacing ( int height)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setlinespacing() sets the line spacing of the text field to the height of height. Default is 40.

Anterior | Inicio | Siguiente
SWFTextField->setindentation | Subir | SWFTextField->setcolor


SWFTextField->setcolor

(unknown)

SWFTextField->setcolor -- Sets the color of the text field.

Description

void swftextfield->setcolor ( int red, int green, int blue [, int a])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setcolor() sets the color of the text field. Default is fully opaque black. Color is represented using RGB system.

Anterior | Inicio | Siguiente
SWFTextField->setLineSpacing | Subir | SWFTextField->setname


SWFTextField->setname

(unknown)

SWFTextField->setname -- Sets the variable name

Description

void swftextfield->setname ( string name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setname() sets the variable name of this text field to name, for form posting and action scripting purposes.

Anterior | Inicio | Siguiente
SWFTextField->setcolor | Subir | SWFTextField->addstring


SWFTextField->addstring

(unknown)

SWFTextField->addstring -- Concatenates the given string to the text field

Description

void swftextfield->addstring ( string string)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swftextfield->setname() concatenates the string string to the text field.

Anterior | Inicio | Siguiente
SWFTextField->setname | Subir | SWFSprite


SWFSprite

(PHP 4 >= 4.0.5)

SWFSprite -- Creates a movie clip (a sprite)

Description

new swfsprite ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfsprite() are also known as a "movie clip", this allows one to create objects which are animated in their own timelines. Hence, the sprite has most of the same methods as the movie.

swfsprite() has the following methods :
swfsprite->add(),
swfsprite->remove(), swfsprite->nextframe()
and swfsprite->setframes().

This simple example will spin gracefully a big red square.

Ejemplo 1. swfsprite() example

<?php
  $s = new SWFShape();
  $s->setRightFill($s->addFill(0xff, 0, 0));
  $s->movePenTo(-500,-500);
  $s->drawLineTo(500,-500);
  $s->drawLineTo(500,500);
  $s->drawLineTo(-500,500);
  $s->drawLineTo(-500,-500);

  $p = new SWFSprite();
  $i = $p->add($s);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();
  $i->rotate(15);
  $p->nextFrame();

  $m = new SWFMovie();
  $i = $m->add($p);
  $i->moveTo(1500,1000);
  $i->setName("blah");

  $m->setBackground(0xff, 0xff, 0xff);
  $m->setDimension(3000,2000);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFTextField->addstring | Subir | SWFSprite->add


SWFSprite->add

(unknown)

SWFSprite->add -- Adds an object to a sprite

Description

void swfsprite->add ( resource object)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfsprite->add() adds a swfshape(), a
swfbutton(), a swftext(),
a swfaction() or a swfsprite() object.

For displayable types (swfshape(),
swfbutton(), swftext(),
swfaction() or swfsprite()),
this returns a handle  to the object in a display list.

Anterior | Inicio | Siguiente
SWFSprite | Subir | SWFSprite->remove


SWFSprite->remove

(unknown)

SWFSprite->remove -- Removes an object to a sprite

Description

void swfsprite->remove ( ressource object)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfsprite->remove() remove a swfshape(), a
swfbutton(), a swftext(),
a swfaction() or a swfsprite() object
from the sprite.

Anterior | Inicio | Siguiente
SWFSprite->add | Subir | SWFSprite->setframes


SWFSprite->setframes

(unknown)

SWFSprite->setframes -- Sets the total number of frames in the animation.

Description

void swfsprite->setframes ( int numberofframes)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfsprite->setframes() sets the total number of frames in the animation to numberofframes.

Anterior | Inicio | Siguiente
SWFSprite->remove | Subir | SWFSprite->nextframe


SWFSprite->nextframe

(unknown)

SWFSprite->nextframe -- Moves to the next frame of the animation.

Description

void swfsprite->nextframe ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfsprite->setframes() moves to the next frame of the animation.

Anterior | Inicio | Siguiente
SWFSprite->setframes | Subir | SWFbutton


SWFbutton

(PHP 4 >= 4.0.5)

SWFbutton -- Creates a new Button.

Description

new swfbutton ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbutton() creates a new Button. Roll over it, click it, see it call action code. Swank.

SWFButton has the following methods : swfbutton->addshape(),
swfbutton->setup(), swfbutton->setover()
swfbutton->setdown(), swfbutton->sethit()
swfbutton->setaction() and
swfbutton->addaction().

This simple example will show your usual interactions with buttons : rollover, rollon, mouseup, mousedown, noaction.

Ejemplo 1. swfbutton() example

<?php

  $f = new SWFFont("_serif");

  $p = new SWFSprite();

  function label($string)
  {
    global $f;

    $t = new SWFTextField();
    $t->setFont($f);
    $t->addString($string);
    $t->setHeight(200);
    $t->setBounds(3200,200);
    return $t;
  }
  function addLabel($string)
  {
    global $p;

    $i = $p->add(label($string));
    $p->nextFrame();
    $p->remove($i);
  }

  $p->add(new SWFAction("stop();"));
  addLabel("NO ACTION");
  addLabel("SWFBUTTON_MOUSEUP");
  addLabel("SWFBUTTON_MOUSEDOWN");
  addLabel("SWFBUTTON_MOUSEOVER");
  addLabel("SWFBUTTON_MOUSEOUT");
  addLabel("SWFBUTTON_MOUSEUPOUTSIDE");
  addLabel("SWFBUTTON_DRAGOVER");
  addLabel("SWFBUTTON_DRAGOUT");

  function rect($r, $g, $b)
  {
    $s = new SWFShape();
    $s->setRightFill($s->addFill($r, $g, $b));
    $s->drawLine(600,0);
    $s->drawLine(0,600);
    $s->drawLine(-600,0);
    $s->drawLine(0,-600);

    return $s;
  }

  $b = new SWFButton();
  $b->addShape(rect(0xff, 0, 0), SWFBUTTON_UP | SWFBUTTON_HIT);
  $b->addShape(rect(0, 0xff, 0), SWFBUTTON_OVER);
  $b->addShape(rect(0, 0, 0xff), SWFBUTTON_DOWN);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(1);"),
            SWFBUTTON_MOUSEUP);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(2);"),
        SWFBUTTON_MOUSEDOWN);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(3);"),
        SWFBUTTON_MOUSEOVER);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(4);"),
        SWFBUTTON_MOUSEOUT);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(5);"),
        SWFBUTTON_MOUSEUPOUTSIDE);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(6);"),
        SWFBUTTON_DRAGOVER);

  $b->addAction(new SWFAction("setTarget('/label'); gotoFrame(7);"),
        SWFBUTTON_DRAGOUT);

  $m = new SWFMovie();
  $m->setDimension(4000,3000);

  $i = $m->add($p);
  $i->setName("label");
  $i->moveTo(400,1900);

  $i = $m->add($b);
  $i->moveTo(400,900);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

This simple example will enables you to drag draw a big red button on the windows. No drag-and-drop, just moving around.

Ejemplo 2. swfbutton->addaction() example

<?php

  $s = new SWFShape();
  $s->setRightFill($s->addFill(0xff, 0, 0));
  $s->drawLine(1000,0);
  $s->drawLine(0,1000);
  $s->drawLine(-1000,0);
  $s->drawLine(0,-1000);

  $b = new SWFButton();
  $b->addShape($s, SWFBUTTON_HIT | SWFBUTTON_UP | SWFBUTTON_DOWN | SWFBUTTON_OVER);

  $b->addAction(new SWFAction("startDrag('/test', 0);"), // '0' means don't lock to mouse
        SWFBUTTON_MOUSEDOWN);

  $b->addAction(new SWFAction("stopDrag();"),
        SWFBUTTON_MOUSEUP | SWFBUTTON_MOUSEUPOUTSIDE);

  $p = new SWFSprite();
  $p->add($b);
  $p->nextFrame();

  $m = new SWFMovie();
  $i = $m->add($p);
  $i->setName('test');
  $i->moveTo(1000,1000);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Anterior | Inicio | Siguiente
SWFSprite->nextframe | Subir | SWFbutton->addShape


SWFbutton->addShape

(unknown)

SWFbutton->addShape -- Adds a shape to a button

Description

void swfbutton->addshape ( ressource shape, int flags)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbutton->addshape() adds the shape shape to this button. The following flags' values are valid: SWFBUTTON_UP, SWFBUTTON_OVER, SWFBUTTON_DOWN or SWFBUTTON_HIT. SWFBUTTON_HIT isn't ever displayed, it defines the hit region for the button. That is, everywhere the hit shape would be drawn is considered a "touchable" part of the button.

Anterior | Inicio | Siguiente
SWFbutton | Subir | SWFbutton->setUp


SWFbutton->setUp

(unknown)

SWFbutton->setUp -- Alias for addShape(shape, SWFBUTTON_UP)

Description

void swfbutton->setup ( ressource shape)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbutton->setup() alias for addShape(shape, SWFBUTTON_UP).

See also swfbutton->addshape() and SWFAction().

Anterior | Inicio | Siguiente
SWFbutton->addShape | Subir | SWFbutton->setOver


SWFbutton->setOver

(unknown)

SWFbutton->setOver -- Alias for addShape(shape, SWFBUTTON_OVER)

Description

void swfbutton->setover ( ressource shape)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbutton->setover() alias for addShape(shape, SWFBUTTON_OVER).

See also swfbutton->addshape() and SWFAction().

Anterior | Inicio | Siguiente
SWFbutton->setUp | Subir | SWFbutton->setdown


SWFbutton->setdown

(unknown)

SWFbutton->setdown -- Alias for addShape(shape, SWFBUTTON_DOWN))

Description

void swfbutton->setdown ( ressource shape)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbutton->setdown() alias for addShape(shape, SWFBUTTON_DOWN).

See also swfbutton->addshape() and SWFAction().

Anterior | Inicio | Siguiente
SWFbutton->setOver | Subir | SWFbutton->setHit


SWFbutton->setHit

(unknown)

SWFbutton->setHit -- Alias for addShape(shape, SWFBUTTON_HIT)

Description

void swfbutton->sethit ( ressource shape)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbutton->sethit() alias for addShape(shape, SWFBUTTON_HIT).

See also swfbutton->addshape() and SWFAction().

Anterior | Inicio | Siguiente
SWFbutton->setdown | Subir | SWFbutton->addAction


SWFbutton->addAction

(unknown)

SWFbutton->addAction -- Adds an action

Description

void swfbutton->addaction ( ressource action, int flags)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbutton->addaction() adds the action action to this button for the given conditions. The following flags are valid: SWFBUTTON_MOUSEOVER, SWFBUTTON_MOUSEOUT, SWFBUTTON_MOUSEUP, SWFBUTTON_MOUSEUPOUTSIDE, SWFBUTTON_MOUSEDOWN, SWFBUTTON_DRAGOUT and SWFBUTTON_DRAGOVER.

See also swfbutton->addshape() and SWFAction().

Anterior | Inicio | Siguiente
SWFbutton->setHit | Subir | SWFbutton->setAction


SWFbutton->setAction

(unknown)

SWFbutton->setAction -- Sets the action

Description

void swfbutton->setaction ( ressource action)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfbutton->setaction() sets the action to be performed when the button is clicked. Alias for addAction(shape, SWFBUTTON_MOUSEUP). action is a swfaction().

See also swfbutton->addshape() and SWFAction().

Anterior | Inicio | Siguiente
SWFbutton->addAction | Subir | SWFAction


SWFAction

(PHP 4 >= 4.0.5)

SWFAction -- Creates a new Action.

Description

new swfaction ( string script)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

swfaction() creates a new Action, and compiles the given script into an SWFAction object.

The script syntax is based on the C language, but with a lot taken out- the SWF bytecode machine is just too simpleminded to do a lot of things we might like. For instance, we can't implement function calls without a tremendous amount of hackery because the jump bytecode has a hardcoded offset value. No pushing your calling address to the stack and returning- every function would have to know exactly where to return to.

So what's left? The compiler recognises the following tokens:

  • break

  • for

  • continue

  • if

  • else

  • do

  • while

There is no typed data; all values in the SWF action machine are stored as strings. The following functions can be used in expressions:

time()

Returns the number of milliseconds (?) elapsed since the movie started.

random(seed)

Returns a pseudo-random number in the range 0-seed.

length(expr)

Returns the length of the given expression.

int(number)

Returns the given number rounded down to the nearest integer.

concat(expr, expr)

Returns the concatenation of the given expressions.

ord(expr)

Returns the ASCII code for the given character

chr(num)

Returns the character for the given ASCII code

substr(string, location, length)

Returns the substring of length length at location location of the given string string.

Additionally, the following commands may be used:

duplicateClip(clip, name, depth)

Duplicate the named movie clip (aka sprite). The new movie clip has name name and is at depth depth.

removeClip(expr)

Removes the named movie clip.

trace(expr)

Write the given expression to the trace log. Doubtful that the browser plugin does anything with this.

startDrag(target, lock, [left, top, right, bottom])

Start dragging the movie clip target. The lock argument indicates whether to lock the mouse (?)- use 0 (FALSE) or 1 (TRUE). Optional parameters define a bounding area for the dragging.

stopDrag()

Stop dragging my heart around. And this movie clip, too.

callFrame(expr)

Call the named frame as a function.

getURL(url, target, [method])

Load the given URL into the named target. The target argument corresponds to HTML document targets (such as "_top" or "_blank"). The optional method argument can be POST or GET if you want to submit variables back to the server.

loadMovie(url, target)

Load the given URL into the named target. The target argument can be a frame name (I think), or one of the magical values "_level0" (replaces current movie) or "_level1" (loads new movie on top of current movie).

nextFrame()

Go to the next frame.

prevFrame()

Go to the last (or, rather, previous) frame.

play()

Start playing the movie.

stop()

Stop playing the movie.

toggleQuality()

Toggle between high and low quality.

stopSounds()

Stop playing all sounds.

gotoFrame(num)

Go to frame number num. Frame numbers start at 0.

gotoFrame(name)

Go to the frame named name. Which does a lot of good, since I haven't added frame labels yet.

setTarget(expr)

Sets the context for action. Or so they say- I really have no idea what this does.

And there's one weird extra thing. The expression frameLoaded(num) can be used in if statements and while loops to check if the given frame number has been loaded yet. Well, it's supposed to, anyway, but I've never tested it and I seriously doubt it actually works. You can just use /:framesLoaded instead.

Movie clips (all together now- aka sprites) have properties. You can read all of them (or can you?), you can set some of them, and here they are:

  • x

  • y

  • xScale

  • yScale

  • currentFrame - (read-only)

  • totalFrames - (read-only)

  • alpha - transparency level

  • visible - 1=on, 0=off (?)

  • width - (read-only)

  • height - (read-only)

  • rotation

  • target - (read-only) (???)

  • framesLoaded - (read-only)

  • name

  • dropTarget - (read-only) (???)

  • url - (read-only) (???)

  • highQuality - 1=high, 0=low (?)

  • focusRect - (???)

  • soundBufTime - (???)

So, setting a sprite's x position is as simple as /box.x = 100;. Why the slash in front of the box, though? That's how flash keeps track of the sprites in the movie, just like a unix filesystem- here it shows that box is at the top level. If the sprite named box had another sprite named biff inside of it, you'd set its x position with /box/biff.x = 100;. At least, I think so; correct me if I'm wrong here.

This simple example will move the red square across the window.

Ejemplo 1. swfaction() example

<?php
 $s = new SWFShape();
  $f = $s->addFill(0xff, 0, 0);
  $s->setRightFill($f);

  $s->movePenTo(-500,-500);
  $s->drawLineTo(500,-500);
  $s->drawLineTo(500,500);
  $s->drawLineTo(-500,500);
  $s->drawLineTo(-500,-500);

  $p = new SWFSprite();
  $i = $p->add($s);
  $i->setDepth(1);
  $p->nextFrame();

  for($n=0; $n<5; ++$n)
  {
    $i->rotate(-15);
    $p->nextFrame();
  }

  $m = new SWFMovie();
  $m->setBackground(0xff, 0xff, 0xff);
  $m->setDimension(6000,4000);

  $i = $m->add($p);
  $i->setDepth(1);
  $i->moveTo(-500,2000);
  $i->setName("box");

  $m->add(new SWFAction("/box.x += 3;"));
  $m->nextFrame();
  $m->add(new SWFAction("gotoFrame(0); play();"));
  $m->nextFrame();

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

This simple example tracks down your mouse on the screen.

Ejemplo 2. swfaction() example

<?php

  $m = new SWFMovie();
  $m->setRate(36.0);
  $m->setDimension(1200, 800);
  $m->setBackground(0, 0, 0);

  /* mouse tracking sprite - empty, but follows mouse so we can
     get its x and y coordinates */

  $i = $m->add(new SWFSprite());
  $i->setName('mouse');

  $m->add(new SWFAction("
    startDrag('/mouse', 1); /* '1' means lock sprite to the mouse */
  "));

  /* might as well turn off antialiasing, since these are just squares. */

  $m->add(new SWFAction("
    this.quality = 0;
  "));

  /* morphing box */
  $r = new SWFMorph();
  $s = $r->getShape1();

  /* Note this is backwards from normal shapes.  No idea why. */
  $s->setLeftFill($s->addFill(0xff, 0xff, 0xff));
  $s->movePenTo(-40, -40);
  $s->drawLine(80, 0);
  $s->drawLine(0, 80);
  $s->drawLine(-80, 0);
  $s->drawLine(0, -80);

  $s = $r->getShape2();

  $s->setLeftFill($s->addFill(0x00, 0x00, 0x00));
  $s->movePenTo(-1, -1);
  $s->drawLine(2, 0);
  $s->drawLine(0, 2);
  $s->drawLine(-2, 0);
  $s->drawLine(0, -2);

  /* sprite container for morphing box -
     this is just a timeline w/ the box morphing */

  $box = new SWFSprite();
  $box->add(new SWFAction("
    stop();
  "));
  $i = $box->add($r);

  for($n=0; $n<=20; ++$n)
  {
    $i->setRatio($n/20);
    $box->nextFrame();
  }

  /* this container sprite allows us to use the same action code many times */

  $cell = new SWFSprite();
  $i = $cell->add($box);
  $i->setName('box');

  $cell->add(new SWFAction("

    setTarget('box');

    /* ...x means the x coordinate of the parent, i.e. (..).x */
    dx = (/mouse.x + random(6)-3 - ...x)/5;
    dy = (/mouse.y + random(6)-3 - ...y)/5;
    gotoFrame(int(dx*dx + dy*dy));

  "));

  $cell->nextFrame();
  $cell->add(new SWFAction("

    gotoFrame(0);
    play();

  "));

  $cell->nextFrame();

  /* finally, add a bunch of the cells to the movie */

  for($x=0; $x<12; ++$x)
  {
    for($y=0; $y<8; ++$y)
    {
      $i = $m->add($cell);
      $i->moveTo(100*$x+50, 100*$y+50);
    }
  }

  $m->nextFrame();

  $m->add(new SWFAction("

    gotoFrame(1);
    play();

  "));

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Same as above, but with nice colored balls...

Ejemplo 3. swfaction() example

<?php

  $m = new SWFMovie();
  $m->setDimension(11000, 8000);
  $m->setBackground(0x00, 0x00, 0x00);

  $m->add(new SWFAction("

this.quality = 0;
/frames.visible = 0;
startDrag('/mouse', 1);

  "));

  // mouse tracking sprite
  $t = new SWFSprite();
  $i = $m->add($t);
  $i->setName('mouse');

  $g = new SWFGradient();
  $g->addEntry(0, 0xff, 0xff, 0xff, 0xff);
  $g->addEntry(0.1, 0xff, 0xff, 0xff, 0xff);
  $g->addEntry(0.5, 0xff, 0xff, 0xff, 0x5f);
  $g->addEntry(1.0, 0xff, 0xff, 0xff, 0);

  // gradient shape thing
  $s = new SWFShape();
  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.03);
  $s->setRightFill($f);
  $s->movePenTo(-600, -600);
  $s->drawLine(1200, 0);
  $s->drawLine(0, 1200);
  $s->drawLine(-1200, 0);
  $s->drawLine(0, -1200);

  // need to make this a sprite so we can multColor it
  $p = new SWFSprite();
  $p->add($s);
  $p->nextFrame();

  // put the shape in here, each frame a different color
  $q = new SWFSprite();
  $q->add(new SWFAction("gotoFrame(random(7)+1); stop();"));
  $i = $q->add($p);

  $i->multColor(1.0, 1.0, 1.0);
  $q->nextFrame();
  $i->multColor(1.0, 0.5, 0.5);
  $q->nextFrame();
  $i->multColor(1.0, 0.75, 0.5);
  $q->nextFrame();
  $i->multColor(1.0, 1.0, 0.5);
  $q->nextFrame();
  $i->multColor(0.5, 1.0, 0.5);
  $q->nextFrame();
  $i->multColor(0.5, 0.5, 1.0);
  $q->nextFrame();
  $i->multColor(1.0, 0.5, 1.0);
  $q->nextFrame();

  // finally, this one contains the action code
  $p = new SWFSprite();
  $i = $p->add($q);
  $i->setName('frames');
  $p->add(new SWFAction("

dx = (/:mousex-/:lastx)/3 + random(10)-5;
dy = (/:mousey-/:lasty)/3;
x = /:mousex;
y = /:mousey;
alpha = 100;

  "));
  $p->nextFrame();

  $p->add(new SWFAction("

this.x = x;
this.y = y;
this.alpha = alpha;
x += dx;
y += dy;
dy += 3;
alpha -= 8;

  "));
  $p->nextFrame();

  $p->add(new SWFAction("prevFrame(); play();"));
  $p->nextFrame();

  $i = $m->add($p);
  $i->setName('frames');
  $m->nextFrame();

  $m->add(new SWFAction("

lastx = mousex;
lasty = mousey;
mousex = /mouse.x;
mousey = /mouse.y;

++num;

if(num == 11)
  num = 1;

removeClip('char' & num);
duplicateClip(/frames, 'char' & num, num);

  "));

  $m->nextFrame();
  $m->add(new SWFAction("prevFrame(); play();"));

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

This simple example will handles keyboard actions. (You'll probably have to click in the window to give it focus. And you'll probably have to leave your mouse in the frame, too. If you know how to give buttons focus programatically, feel free to share, won't you?)

Ejemplo 4. swfaction() example

<?php

  /* sprite has one letter per frame */

  $p = new SWFSprite();
  $p->add(new SWFAction("stop();"));

  $chars = "abcdefghijklmnopqrstuvwxyz".
       "ABCDEFGHIJKLMNOPQRSTUVWXYZ".
           "1234567890!@#$%^&/*()_+-=/[]{}|;:,.<>?`~";

  $f = new SWFFont("_sans");

  for($n=0; $nremove($i);
    $t = new SWFTextField();
    $t->setFont($f);
    $t->setHeight(240);
    $t->setBounds(600,240);
    $t->align(SWFTEXTFIELD_ALIGN_CENTER);
    $t->addString($c);
    $i = $p->add($t);
    $p->labelFrame($c);
    $p->nextFrame();
  }

  /* hit region for button - the entire frame */

  $s = new SWFShape();
  $s->setFillStyle0($s->addSolidFill(0, 0, 0, 0));
  $s->drawLine(600, 0);
  $s->drawLine(0, 400);
  $s->drawLine(-600, 0);
  $s->drawLine(0, -400);

  /* button checks for pressed key, sends sprite to the right frame */

  $b = new SWFButton();
  $b->addShape($s, SWFBUTTON_HIT);

  for($n=0; $naddAction(new SWFAction("

setTarget('/char');
gotoFrame('$c');

    "), SWFBUTTON_KEYPRESS($c));
  }

  $m = new SWFMovie();
  $m->setDimension(600,400);
  $i = $m->add($p);
  $i->setName('char');
  $i->moveTo(0,80);

  $m->add($b);

  header('Content-type: application/x-shockwave-flash');
  $m->output();

?>

Anterior | Inicio | Siguiente
SWFbutton->setAction | Subir | Miscelánea de funciones


Miscelánea de funciones

Manual de PHP
Anterior Siguiente

LVIII. Miscelánea de funciones

Estas funciones están colacadas aquí debido a que no parecen ajustarse a ninguna otra categoría.

Tabla de contenidos
connection_aborted — Devuelve TRUE si el cliente está desconectado
connection_status — Devuelve el estado de la conexión en un campo de bits
connection_timeout — Devuelve TRUE si el script ha alcanzado su time out
define — Define una constante con nombre.
defined — Comprueba que una constante con nombre dada existe.
die — Envía a la salida un mensaje y finaliza el script actual
eval — Evalúa una cadena de carácteres como código PHP
exit — Finaliza el script actual
get_browser — Informa sobre lo que es capaz de hacer el navegador (browser) del usuario.
ignore_user_abort — Establece si la desconexión de un cliente debe suspender la ejecución del script
iptcparse — Divide un bloque binario IPTC http://www.xe.net/iptc/ en su tags (etiquetas) individuales.
leak — Filtra memoria
pack — empaqueta datos en una cadena binaria
serialize — genera una representación almacenable de un valor
sleep — Ejecución retardada
uniqid — Genera un id único.
unpack — desempaqueta datos de una cadena binaria
unserialize — crea un valor PHP de una representación almacenada
usleep — Retrasa la ejecución, en microsegundos

Anterior | Inicio | Siguiente
SWFAction | Subir | connection_aborted


connection_aborted

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

connection_aborted -- Devuelve TRUE si el cliente está desconectado

Descripción

int connection_aborted ( void )

Devuelve TRUE si el cliente está desconectado. Vea la descripción de la Gestión de la Conexión en el capítulo Características para una explicación completa.

Anterior | Inicio | Siguiente
Miscelánea de funciones | Subir | connection_status


connection_status

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

connection_status -- Devuelve el estado de la conexión en un campo de bits

Descripción

int connection_status ( void )

Devuelve el estado de la conexión en un campo de bits. Vea la descripción de la Gestión de la Conexión en el capítulo Características para una explicación completa.

Anterior | Inicio | Siguiente
connection_aborted | Subir | connection_timeout


connection_timeout

(PHP 3>= 3.0.7, 4.0.0 - 4.0.4 only)

connection_timeout -- Devuelve TRUE si el script ha alcanzado su time out

Descripción

int connection_timeout ( void )

Devuelve TRUE si el script ha alcanzado su time out. Vea la descripción de la Gestión de la Conexión en el capítulo Características para una explicación completa.

Anterior | Inicio | Siguiente
connection_status | Subir | define


define

(PHP 3, PHP 4 >= 4.0.0)

define -- Define una constante con nombre.

Descripción

int define ( string name, mixed value [, int case_insensitive])

Define una constante con nombre, que es similar a una variable, excepto que:

  • Las constantes no tienen un símbolo dólar '$' precediéndolas;

  • Las constantes son accesibles desde cualquier lugar sin tener en cuenta las reglas de ámbito de las variables.

  • Las constantes no pueden ser redefinidas o iniciadas una vez que han sido establecidas, y

  • Las constantes sólo pueden evaluar valores escalares

El nombre de la constante se da en name (nombre); el valor se da en value (valor).

El tercer parámetro opcional case_insensitive también se encuentra disponible. Si se da el valor 1, la constante se definirá no dintinguiendo mayúsculas/minusculas. El comportamiento por defecto es si distinguir; i.e. CONSTANT y Constant representan valores diferentes.

Ejemplo 1. Definición de Constantes

<?php
define("CONSTANT", "Hello world.");
echo CONSTANT; // outputs "Hello world."
?>

define() devuelve TRUE en caso de éxito y FALSE si ocurre un error.

Véase también defined() y la sección Constantes.

Anterior | Inicio | Siguiente
connection_timeout | Subir | defined


defined

(PHP 3, PHP 4 >= 4.0.0)

defined -- Comprueba que una constante con nombre dada existe.

Descripción

int defined ( string name)

Devuelve TRUE si la constante con nombre dada en name (nombre) ha sido definida, FALSE en otro caso.

Véase también define() y la sección Constantes.

Anterior | Inicio | Siguiente
define | Subir | die


die

(unknown)

die -- Envía a la salida un mensaje y finaliza el script actual

Descripción

void die ( string message)

Esta construcción del lenguaje envía a la salida un mensaje y finaliza la ejecución del script. No devuelve nada.

Ejemplo 1. Ejemplo die

<?php
$filename = '/path/to/data-file';
$file = fopen($filename, 'r')
  or die "unable to open file ($filename)";
?>

Anterior | Inicio | Siguiente
defined | Subir | eval


eval

(unknown)

eval -- Evalúa una cadena de carácteres como código PHP

Descripción

void eval ( string code_str)

eval() evalúa la cadena de carácteres dada en code_str como código PHP. Entre otras cosas, ésto puede ser útil para almacenar código en un campo de texto de base de datos para una ejecución posterior.

Hay algunos aspectos a tener en cuenta cuando se utiliza eval(). Recuerde que la cadena de carácteres pasada debe ser código PHP válido, incluyendo aspectos como sentencias de terminación con un punto y coma para que el parser no finalice en la línea después de eval(), y secuencias de formato correctas en code_str.

Recuerde también que las variables a las que se les da valor en eval() retendrán estos valores posteriormente en el script principal.

Ejemplo 1. Ejemplo eval() - fusión en un único texo

<?php
$string = 'cup';
$name = 'coffee';
$str = 'This is a $string with my $name in it.<br>';
echo $str;
eval( "\$str = \"$str\";" );
echo $str;
?>

El ejemplo anterior mostrará:
This is a $string with my $name in it.
This is a cup with my coffee in it.

Anterior | Inicio | Siguiente
die | Subir | exit


exit

(unknown)

exit -- Finaliza el script actual

Descripción

void exit ( void)

Esta construcción del lenguaje finaliza la ejecución del script. No devuelve nada.

Anterior | Inicio | Siguiente
eval | Subir | get_browser


get_browser

(PHP 3, PHP 4 >= 4.0.0)

get_browser -- Informa sobre lo que es capaz de hacer el navegador (browser) del usuario.

Descripción

object get_browser ( [string user_agent])

get_browser() intenta determinar las características del navegador del usuario. Para ello consulta el fichero de información del navegador, browscap.ini. Por defecto, se utiliza el valor de $HTTP_USER_AGENT; sin embargo, puede alterar ésto (i.e., consultando otra información del navegador) pasando el parámetro opcional user_agent a get_browser().

La información se devuelve en un objto, que contendrá varios elementos de datos que representan, por ejemplo, los números de versión (mayor y menor) del navegador y la cadena ID; valores TRUE/false para características como los marcos, JavaScript, y cookies; etc.

browscap.ini contiene información de muchos navegadores, depende de las actualizaciones del usuario para mantener la base de datos actualizada. El formato del fichero es claramente auto-explicativo.

El ejemplo siguiente muestra como se puede listar toda la información disponible recuperada del navegador del usuario.

Ejemplo 1. ejemplo get_browser()

<?php
function list_array( $array ) {
   while ( list( $key, $value ) = each( $array ) ) {
      $str .= "<b>$key:</b> $value<br>\n";
   }
   return $str;
}
echo "$HTTP_USER_AGENT<hr>\n";
$browser = get_browser();
echo list_array( (array) $browser );
?>

La salida del script anterior debería paracerse a ésto:

Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586)<hr>
<b>browser_name_pattern:</b> Mozilla/4\.5.*<br>
<b>parent:</b> Netscape 4.0<br>
<b>platform:</b> Unknown<br>
<b>majorver:</b> 4<br>
<b>minorver:</b> 5<br>
<b>browser:</b> Netscape<br>
<b>version:</b> 4<br>
<b>frames:</b> 1<br>
<b>tables:</b> 1<br>
<b>cookies:</b> 1<br>
<b>backgroundsounds:</b> <br>
<b>vbscript:</b> <br>
<b>javascript:</b> 1<br>
<b>javaapplets:</b> 1<br>
<b>activexcontrols:</b> <br>
<b>beta:</b> <br>
<b>crawler:</b> <br>
<b>authenticodeupdate:</b> <br>
<b>msn:</b> <br>

Para conseguir ésto, su opción de fichero de configuración browscap debe apuntar a la correcta localización del fichero browscap.ini.

Para más información (incluyendo localizaciones desde las que puede obtener un fichero browscap.ini), consulte las FAQ sobre PHP en http://www.php.net/FAQ.html.

Nota: el soporte para browscap fue añadido en la versión 3.0b2 de PHP.

Anterior | Inicio | Siguiente
exit | Subir | ignore_user_abort


ignore_user_abort

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

ignore_user_abort -- Establece si la desconexión de un cliente debe suspender la ejecución del script

Descripción

int ignore_user_abort ( [int setting])

Esta función establece si la desconexión de un cliente debe provocar la suspensión del script. Devolverá el valor previo y puede ser llamada sin argumentos para devolver el valor actual y no cambiarlo. Véase la sección sobre la Gestión de la Conexión en el capítulo Características para una descripción completa de la gestión de la conexión en PHP.

Anterior | Inicio | Siguiente
get_browser | Subir | iptcparse


iptcparse

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

iptcparse -- Divide un bloque binario IPTC http://www.xe.net/iptc/ en su tags (etiquetas) individuales.

Descripción

array iptcparse ( string iptcblock)

Esta función divide un bloque binario IPTC en sus tags individuales. Devuelve un array utilizando el tagmarker (marcador de etiqueta) como un índice y el valor como valor. Devuelve FALSE en caso de error o si no hubiese datos IPTC. Véase GetImageSize() para un ejemplo.

Anterior | Inicio | Siguiente
ignore_user_abort | Subir | leak


leak

(PHP 3, PHP 4 >= 4.0.0)

leak -- Filtra memoria

Descripción

void leak ( int bytes)

leak() filtra la cantidad de memoria especificada.

Es muy útil cuando se depura el gestor de memoria, que automáticamente libera la memoria "filtrada" después de que se completa cada petición.

Anterior | Inicio | Siguiente
iptcparse | Subir | pack


pack

(PHP 3, PHP 4 >= 4.0.0)

pack -- empaqueta datos en una cadena binaria

Descripción

string pack ( string format [, mixed args])

Empaqueta los argumentos dados en una cadena binaria siguiendo el formato format. Devuelve la cadena binaria que contiene los datos.

El concepto de esta función fue tomado de Perl y todos los códigos de formateo realizan la misma función. La cadena de formato consiste en códigos de formato seguidos por un argumento opcional de repetición. El argumento de repetición puede ser un valor entero o * para repetir hasta el fin de la entrada de datos. Para a, A, h, H la cuenta de repetición representa cuántos caracteres se toman de un argumento de datos, para @ es la posición absoluta donde poner los datos siguientes, para todo lo demás la cuenta de repetición especifica cuántos argumentos de datos se toman y empaquetan en la cadena binaria resultante. Actualmente están implementados:

  • a cadena rellena de NUL

  • A cadena rellena de ESPACIOS

  • h cadena Hex, primero el medio byte inferior

  • H cadena Hex, primero el medio byte superior

  • c signed (con signo) char

  • C unsigned (sin signo) char

  • s signed short (siempre 16 bits, distribución de bytes de la máquina)

  • S unsigned short (siempre 16 bits, distribución de bytes de la máquina)

  • n unsigned short (siempre 16 bits, distribución de bytes gran endian)

  • v unsigned short (siempre 16 bits, distribución de bytes pequeño endian)

  • i signed integer (distribución de bytes y tamaños dependientes de la máquina)

  • I unsigned integer (distribución de bytes y tamaños dependientes de la máquina)

  • l signed long (siempre 32 bits, distribución de bytes de la máquina)

  • L unsigned long (siempre 32 bits, distribución de bytes de la máquina)

  • N unsigned long (siempre 32 bits, distribución de bytes gran endian)

  • V unsigned long (siempre 32 bits, distribución de bytes pequeño endian)

  • f float (representación y tamaño dependientes de la máquina)

  • d double (representación y tamaño dependientes de la máquina)

  • x byte NUL

  • X Un byte hacia atrás

  • @ relleno con NUL en la posición absoluta

Ejemplo 1. cadena de formato para pack

$binarydata = pack("nvc*", 0x1234, 0x5678, 65, 66);

La cadena binaria resultante tendrá 6 bytes de longitud y contendrá la secuencia de bytes 0x12, 0x34, 0x78, 0x56, 0x41, 0x42.

Adviértase que la distinción entre valores signed (con signo) y unsigned (sin signo) sólo afecta a la función unpack(), ya que la función pack() da el mismo resultado para códigos de formato con signo y sin signo.

Nótese también que internamente PHP almacena valores enteros como valores con signo de un tamaño dependiente de la máquina. Si le da un valor entero sin signo demasiado grande para ser almacenado, será convertido a un double (doble), lo que a menudo produce resultados no deseados.

Anterior | Inicio | Siguiente
leak | Subir | serialize


serialize

(PHP 3>= 3.0.5, PHP 4 >= 4.0.0)

serialize -- genera una representación almacenable de un valor

Descripción

string serialize ( mixed value)

serialize() devuelve una cadena que contiene una representación byte-stream de value (valor) que puede ser almacenada en algún lugar.

Esto es útil para almacenar o pasar valores PHP sin pérdida de su tipo y estructura.

Para convertir de nuevo la cadena serializada en un valor PHP, utilice unserialize(). serialize() gestiona los tipos integer, double, string, array (multidimensional) y object (las propiedades del objeto pueden ser serializadas, pero se pierden los métodos).

Ejemplo 1. ejemplo serialize

// $session_data contains a multi-dimensional array with session
// information for the current user.  We use serialize() to store
// it in a database at the end of the request.

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn,
                     "UPDATE sessions SET data = ? WHERE id = ?");
$sqldata = array(serialize($session_data), $PHP_AUTH_USER);
if (!odbc_execute($stmt, &$sqldata)) {
    $stmt = odbc_prepare($conn,
                         "INSERT INTO sessions (id, data) VALUES(?, ?)");
    if (!odbc_execute($stmt, &$sqldata)) {
        /* Something went wrong.  Bitch, whine and moan. */
    }
}

Anterior | Inicio | Siguiente
pack | Subir | sleep


sleep

(PHP 3, PHP 4 >= 4.0.0)

sleep -- Ejecución retardada

Descripción

void sleep ( int seconds)

La función sleep retarda la ejecución del programa durante el número de seconds (segundos) dado.

Véase también usleep().

Anterior | Inicio | Siguiente
serialize | Subir | uniqid


uniqid

(PHP 3, PHP 4 >= 4.0.0)

uniqid -- Genera un id único.

Descripción

int uniqid ( string prefix [, boolean lcg])

uniqid() devuelve un identificador único con un prefijo basado en la hora actual en microsegundos. El prefijo puede ser práctico por ejemplo si se generan identificadores simultáneamente en varios host que pueden haber generado el identificador en el mismo microsegundo. prefix (prefijo) puede ser de hasta 114 carácteres de longitud.

Si el parámetro opcional lcg es TRUE, uniqid() añadirá entropía "LCG combinada" al final del valor devuelto, que hará el resultado más único.

Con un prefix (prefijo) vacío, la cadena devuelta tendrá una longitud de 13 carácteres. Si lcg es TRUE, tendrá 23 carácteres.

Nota: El parámetro lcg está disponible sólo en PHP 4 y PHP 3.0.13 y posteriores.

Si necesita un identificador único o testigo, y tiene la intención de hacer público ese testigo al usuario por medio de una red (i.e. cookies de sesión) se recomienda que utilice algo parecido a estas líneas

$token = md5(uniqid("")); // no random portion
$better_token = md5(uniqid(rand())); // better, difficult to guess

Esto creará un identificador de 32 carácteres (un número hexadecimal de 128 bits) que es extremadamente difícil de predecir.

Anterior | Inicio | Siguiente
sleep | Subir | unpack


unpack

(PHP 3, PHP 4 >= 4.0.0)

unpack -- desempaqueta datos de una cadena binaria

Descripción

array unpack ( string format, string data)

Desempaqueta datos de una cadena binaria en un array, de acuerdo al formato format. Devuelve un array que contiene los elementos de la cadena binaria desempaquetados.

Unpack funciona de manera ligeramente diferente a Perl, ya que los datos desempaquetados se almacenan en un array asociativo. Para conseguir ésto debe nombrar los diferentes códigos de formato y separarlos por una barra inclinada /.

Ejemplo 1. cadena de formato unpack

$array = unpack("c2chars/nint", $binarydata);

El array resultante contendrá las entradas "chars1", "chars2" y "int".

Para una explicación de los códigos de formato véase también: pack()

Advierta que PHP almacena internamente los valores enteros con signo. Si desempaqueta un unsigned long (largo sin signo) demasiado grande y es del mismo tamaño tal como PHP almacena internamente los valores, el resultado será un número negativo a pesar de que se especificara desempaquetamiento sin signo.

Anterior | Inicio | Siguiente
uniqid | Subir | unserialize


unserialize

(PHP 3>= 3.0.5, PHP 4 >= 4.0.0)

unserialize -- crea un valor PHP de una representación almacenada

Descripción

mixed unserialize ( string str)

unserialize() toma una variable serializada (véase serialize()) y la convierte en un valor PHP. Se devuelve el valor convertido, y puede ser un integer (entero), double (doble), string (cadena), array o object (objeto). Si fue serializado un objeto, sus métodos no son conservados en el valor devuelto.

Ejemplo 1. ejemplo unserialize

// Here, we use unserialize() to load session data from a database
// into $session_data.  This example complements the one described
// with serialize().

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn, "SELECT data FROM sessions WHERE id = ?");
$sqldata = array($PHP_AUTH_USER);
if (!odbc_execute($stmt, &$sqldata) || !odbc_fetch_into($stmt, &$tmp)) {
    // if the execute or fetch fails, initialize to empty array
    $session_data = array();
} else {
    // we should now have the serialized data in $tmp[0].
    $session_data = unserialize($tmp[0]);
    if (!is_array($session_data)) {
        // something went wrong, initialize to empty array
        $session_data = array();
    }
}

Anterior | Inicio | Siguiente
unpack | Subir | usleep


usleep

(PHP 3, PHP 4 >= 4.0.0)

usleep -- Retrasa la ejecución, en microsegundos

Descripción

void usleep ( int micro_seconds)

La función usleep retrasa la ejecución del programa durante un número de micro_seconds (microsegundos) dado.

Véase también sleep().

Anterior | Inicio | Siguiente
unserialize | Subir | mnoGoSearch Functions


mnoGoSearch Functions

Manual de PHP
Anterior Siguiente

LIX. mnoGoSearch Functions

These functions allow you to access mnoGoSearch (former UdmSearch) free search engine. In order to have these functions available, you must compile php with mnogosearch support by using the --with-mnogosearch option. If you use this option without specifying the path to mnogosearch, php will look for mnogosearch under /usr/local/mnogosearch path by default. If you installed mnogosearch at other path you should specify it: --with-mnogosearch=DIR.

mnoGoSearch is a full-featured search engine software for intranet and internet servers, distributed under the GNU license. mnoGoSearch has number of unique features, which makes it appropriate for a wide range of application from search within your site to a specialized search system such as cooking recipes or newspaper search, ftp archive search, news articles search, etc. It offers full-text indexing and searching for HTML, PDF, and text documents. mnoGoSearch consists of two parts. The first is an indexing mechanism (indexer). The purpose of indexer is to walk through HTTP, FTP, NEWS servers or local files, recursively grabbing all the documents and storing meta-data about that documents in a SQL database in a smart and effective manner. After every document is referenced by its corresponding URL, meta-data collected by indexer is used later in a search process. The search is performed via Web interface. C CGI, PHP and Perl search front ends are included.

Nota: php contains built-in mysql access library, which can be used to access mysql. It is known that mnoGoSearch is not compatible with this built-in library and can work only with generic mysql libraries. Thus, if you use mnoGoSearch with mysql, during php configuration you have to indicate directory of mysql installation, that was used during mnoGoSearch configuration, i.e. for example: --with-mnogosearch --with-mysql=/usr.

You need at least 3.1.10 version of mnoGoSearch installed to use these functions.

More information about mnoGoSearch can be found at http://www.mnogosearch.ru/.

Tabla de contenidos
udm_add_search_limit — Add various search limits
udm_alloc_agent — Allocate mnoGoSearch session
udm_api_version — Get mnoGoSearch API version.
udm_cat_path — Get the path to the current category.
udm_cat_list — Get all the categories on the same level with the current one.
udm_clear_search_limits — Clear all mnoGoSearch search restrictions
udm_errno — Get mnoGoSearch error number
udm_error — Get mnoGoSearch error message
udm_find — Perform search
udm_free_agent — Free mnoGoSearch session
udm_free_ispell_data — Free memory allocated for ispell data
udm_free_res — Free mnoGoSearch result
udm_get_doc_count — Get total number of documents in database.
udm_get_res_field — Fetch mnoGoSearch result field
udm_get_res_param — Get mnoGoSearch result parameters
udm_load_ispell_data — Load ispell data
udm_set_agent_param — Set mnoGoSearch agent session parameters
udm_check_charset — Check if the given charset is known to mnogosearch
udm_check_stored — Check connection to stored
udm_close_stored — Close connection to stored
udm_crc32 — Return CRC32 checksum of gived string
udm_open_stored — Open connection to stored

Anterior | Inicio | Siguiente
usleep | Subir | udm_add_search_limit


udm_add_search_limit

(PHP 4 >= 4.0.5)

udm_add_search_limit -- Add various search limits

Description

int udm_add_search_limit ( int agent, int var, string val)

udm_add_search_limit() returns TRUE on success, FALSE on error. Adds search restrictions.

agent - a link to Agent, received after call to udm_alloc_agent().

var - defines parameter, indicating limit.

val - defines value of the current parameter.

Possible var values:

  • UDM_LIMIT_URL - defines document URL limitations to limit search through subsection of database. It supports SQL % and _ LIKE wildcards, where % matches any number of characters, even zero characters, and _ matches exactly one character. E.g. http://my.domain.__/catalog may stand for http://my.domain.ru/catalog and http://my.domain.ua/catalog.

  • UDM_LIMIT_TAG - defines site TAG limitations. In indexer-conf you can assign specific TAGs to various sites and parts of a site. Tags in mnoGoSearch 3.1.x are lines, that may contain metasymbols % and _. Metasymbols allow searching among groups of tags. E.g. there are links with tags ABCD and ABCE, and search restriction is by ABC_ - the search will be made among both of the tags.

  • UDM_LIMIT_LANG - defines document language limitations.

  • UDM_LIMIT_CAT - defines document category limitations. Categories are similar to tag feature, but nested. So you can have one category inside another and so on. You have to use two characters for each level. Use a hex number going from 0-F or a 36 base number going from 0-Z. Therefore a top-level category like 'Auto' would be 01. If it has a subcategory like 'Ford', then it would be 01 (the parent category) and then 'Ford' which we will give 01. Put those together and you get 0101. If 'Auto' had another subcategory named 'VW', then it's id would be 01 because it belongs to the 'Ford' category and then 02 because it's the next category. So it's id would be 0102. If VW had a sub category called 'Engine' then it's id would start at 01 again and it would get the 'VW' id 02 and 'Auto' id of 01, making it 010201. If you want to search for sites under that category then you pass it cat=010201 in the url.

  • UDM_LIMIT_DATE - defines limitation by date document was modified.

    Format of parameter value: a string with first character < or >, then with no space - date in unixtime format, for example:

    Udm_Add_Search_Limit($udm,UDM_LIMIT_DATE,"<908012006");

    If > character is used, then search will be restricted to those documents having modification date greater than entered. If <, then smaller.

Anterior | Inicio | Siguiente
mnoGoSearch Functions | Subir | udm_alloc_agent


udm_alloc_agent

(PHP 4 >= 4.0.5)

udm_alloc_agent -- Allocate mnoGoSearch session

Description

int udm_alloc_agent ( string dbaddr [, string dbmode])

udm_alloc_agent() returns mnogosearch agent identifier on success, FALSE on error. This function creates a session with database parameters.

dbaddr - URL-style database description. Options (type, host, database name, port, user and password) to connect to SQL database. Do not matter for built-in text files support. Format: DBAddr DBType:[//[DBUser[:DBPass]@]DBHost[:DBPort]]/DBName/ Currently supported DBType values are: mysql, pgsql, msql, solid, mssql, oracle, ibase. Actually, it does not matter for native libraries support. But ODBC users should specify one of supported values. If your database type is not supported, you may use "unknown" instead.

dbmode - You may select SQL database mode of words storage. When "single" is specified, all words are stored in the same table. If "multi" is selected, words will be located in different tables depending of their lengths. "multi" mode is usually faster but requires more tables in database. If "crc" mode is selected, mnoGoSearch will store 32 bit integer word IDs calculated by CRC32 algorythm instead of words. This mode requres less disk space and it is faster comparing with "single" and "multi" modes. "crc-multi" uses the same storage structure with the "crc" mode, but also stores words in different tables depending on words lengths like "multi" mode. Format: DBMode single/multi/crc/crc-multi

Nota: dbaddr and dbmode must match those used during indexing.

Nota: In fact this function does not open connection to database and thus does not check entered login and password. Actual connection to database and login/password verification is done by udm_find().

Anterior | Inicio | Siguiente
udm_add_search_limit | Subir | udm_api_version


udm_api_version

(PHP 4 >= 4.0.5)

udm_api_version -- Get mnoGoSearch API version.

Description

int udm_api_version ( void)

udm_api_version() returns mnoGoSearch API version number. E.g. if mnoGoSearch 3.1.10 API is used, this function will return 30110.

This function allows user to identify which API functions are available, e.g. udm_get_doc_count() function is only available in mnoGoSearch 3.1.11 or later.

Example:

if (udm_api_version() >= 30111) {
   print  "Total number of urls in database: ".udm_get_doc_count($udm)."<br>\n";
   }

Anterior | Inicio | Siguiente
udm_alloc_agent | Subir | udm_cat_path


udm_cat_path

(PHP 4 >= 4.0.6)

udm_cat_path -- Get the path to the current category.

Description

array udm_cat_path ( int agent, string category)

udm_cat_path() returns array describing path in the categories tree from the tree root to the current category.

agent - agent link identifier.

category - current category - the one to get path to.

Returns array with the following format:

The array consists of pairs. Elements with even index numbers contain category paths, odd elements contain corresponding category names.

For example, the call $array=udm_cat_path($agent, '02031D'); may return the following array:

$array[0] will contain ''
$array[1] will contain 'Root'
$array[2] will contain '02'
$array[3] will contain 'Sport'
$array[4] will contain '0203'
$array[5] will contain 'Auto'
$array[4] will contain '02031D'
$array[5] will contain 'Ferrari'

Ejemplo 1. Specifying path to the current category in the following format: '> Root > Sport > Auto > Ferrari'

<?php
  $cat_path_arr = udm_cat_path($udm_agent,$cat);
  $cat_path = '';
  for ($i=0; $i<count($cat_path_arr); $i+=2) {
    $path = $cat_path_arr[$i];
    $name = $cat_path_arr[$i+1];
    $cat_path .= " > <a href=\"$PHP_SELF?cat=$path\">$name</a> ";
  }
?>

Anterior | Inicio | Siguiente
udm_api_version | Subir | udm_cat_list


udm_cat_list

(PHP 4 >= 4.0.6)

udm_cat_list -- Get all the categories on the same level with the current one.

Description

array udm_cat_list ( int agent, string category)

udm_cat_list() returns array listing all categories of the same level as current category in the categories tree.

The function can be useful for developing categories tree browser.

Returns array with the following format:

The array consists of pairs. Elements with even index numbers contain category paths, odd elements contain corresponding category names.

$array[0] will contain '020300'
$array[1] will contain 'Audi'
$array[2] will contain '020301'
$array[3] will contain 'BMW'
$array[4] will contain '020302'
$array[5] will contain 'Opel'
...
etc.

Following is an example of displaying links of the current level in format:
Audi
BMW
Opel
...

<?php
 $cat_list_arr = udm_cat_list($udm_agent,$cat);
 $cat_list = '';
 for ($i=0; $i<count($cat_list_arr); $i+=2) {
   $path = $cat_list_arr[$i];
   $name = $cat_list_arr[$i+1];
   $cat_list .= "<a href=\"$PHP_SELF?cat=$path\">$name</a><br>";
 }
?>

Anterior | Inicio | Siguiente
udm_cat_path | Subir | udm_clear_search_limits


udm_clear_search_limits

(PHP 4 >= 4.0.5)

udm_clear_search_limits -- Clear all mnoGoSearch search restrictions

Description

int udm_clear_search_limits ( int agent)

udm_clear_search_limits() resets defined search limitations and returns TRUE.

Anterior | Inicio | Siguiente
udm_cat_list | Subir | udm_errno


udm_errno

(PHP 4 >= 4.0.5)

udm_errno -- Get mnoGoSearch error number

Description

int udm_errno ( int agent)

udm_errno() returns mnoGoSearch error number, zero if no error.

agent - link to agent identifier, received after call to udm_alloc_agent().

Receiving numeric agent error code.

Anterior | Inicio | Siguiente
udm_clear_search_limits | Subir | udm_error


udm_error

(PHP 4 >= 4.0.5)

udm_error -- Get mnoGoSearch error message

Description

string udm_error ( int agent)

udm_error() returns mnoGoSearch error message, empty string if no error.

agent - link to agent identifier, received after call to udm_alloc_agent().

Receiving agent error message.

Anterior | Inicio | Siguiente
udm_errno | Subir | udm_find


udm_find

(PHP 4 >= 4.0.5)

udm_find -- Perform search

Description

int udm_find ( int agent, string query)

udm_find() returns result link identifier on success, FALSE on error.

The search itself. The first argument - session, the next one - query itself. To find something just type words you want to find and press SUBMIT button. For example, "mysql odbc". You should not use quotes " in query, they are written here only to divide a query from other text. mnoGoSearch will find all documents that contain word "mysql" and/or word "odbc". Best documents having bigger weights will be displayed first. If you use search mode ALL, search will return documents that contain both (or more) words you entered. In case you use mode ANY, the search will return list of documents that contain any of the words you entered. If you want more advanced results you may use query language. You should select "bool" match mode in the search from.

mnoGoSearch understands the following boolean operators:

& - logical AND. For example, "mysql & odbc". mnoGoSearch will find any URLs that contain both "mysql" and "odbc".

| - logical OR. For example "mysql|odbc". mnoGoSearch will find any URLs, that contain word "mysql" or word "odbc".

~ - logical NOT. For example "mysql & ~odbc". mnoGoSearch will find URLs that contain word "mysql" and do not contain word "odbc" at the same time. Note that ~ just excludes given word from results. Query "~odbc" will find nothing!

() - group command to compose more complex queries. For example "(mysql | msql) & ~postgres". Query language is simple and powerful at the same time. Just consider query as usual boolean expression.

Anterior | Inicio | Siguiente
udm_error | Subir | udm_free_agent


udm_free_agent

(PHP 4 >= 4.0.5)

udm_free_agent -- Free mnoGoSearch session

Description

int udm_free_agent ( int agent)

udm_free_agent() returns TRUE on success, FALSE on error.

agent - link to agent identifier, received ` after call to udm_alloc_agent().

Freeing up memory allocated for agent session.

Anterior | Inicio | Siguiente
udm_find | Subir | udm_free_ispell_data


udm_free_ispell_data

(PHP 4 >= 4.0.5)

udm_free_ispell_data -- Free memory allocated for ispell data

Description

int udm_free_ispell_data ( int agent)

udm_free_ispell_data() always returns TRUE.

agent - agent link identifier, received after call to udm_alloc_agent().

Nota: This function is supported beginning from version 3.1.12 of mnoGoSearch and it does not do anything in previous versions.

Anterior | Inicio | Siguiente
udm_free_agent | Subir | udm_free_res


udm_free_res

(PHP 4 >= 4.0.5)

udm_free_res -- Free mnoGoSearch result

Description

int udm_free_res ( int res)

udm_free_res() returns TRUE on success, FALSE on error.

res - a link to result identifier, received after call to udm_find().

Freeing up memory allocated for results.

Anterior | Inicio | Siguiente
udm_free_ispell_data | Subir | udm_get_doc_count


udm_get_doc_count

(PHP 4 >= 4.0.5)

udm_get_doc_count -- Get total number of documents in database.

Description

int udm_get_doc_count ( int agent)

udm_get_doc_count() returns number of documents in database.

agent - link to agent identifier, received after call to udm_alloc_agent().

Nota: This function is supported only in mnoGoSearch 3.1.11 or later.

Anterior | Inicio | Siguiente
udm_free_res | Subir | udm_get_res_field


udm_get_res_field

(PHP 4 >= 4.0.5)

udm_get_res_field -- Fetch mnoGoSearch result field

Description

string udm_get_res_field ( int res, int row, int field)

udm_get_res_field() returns result field value on success, FALSE on error.

res - a link to result identifier, received after call to udm_find().

row - the number of the link on the current page. May have values from 0 to UDM_PARAM_NUM_ROWS-1.

field - field identifier, may have the following values:

  • UDM_FIELD_URL - document URL field

  • UDM_FIELD_CONTENT - document Content-type field (for example, text/html).

  • UDM_FIELD_CATEGORY - document category field. Use udm_cat_path() to get full path to current category from the categories tree root. (This parameter is available only in PHP 4.0.6 or later).

  • UDM_FIELD_TITLE - document title field.

  • UDM_FIELD_KEYWORDS - document keywords field (from META KEYWORDS tag).

  • UDM_FIELD_DESC - document description field (from META DESCRIPTION tag).

  • UDM_FIELD_TEXT - document body text (the first couple of lines to give an idea of what the document is about).

  • UDM_FIELD_SIZE - document size.

  • UDM_FIELD_URLID - unique URL ID of the link.

  • UDM_FIELD_RATING - page rating (as calculated by mnoGoSearch).

  • UDM_FIELD_MODIFIED - last-modified field in unixtime format.

  • UDM_FIELD_ORDER - the number of the current document in set of found documents.

  • UDM_FIELD_CRC - document CRC.

Anterior | Inicio | Siguiente
udm_get_doc_count | Subir | udm_get_res_param


udm_get_res_param

(PHP 4 >= 4.0.5)

udm_get_res_param -- Get mnoGoSearch result parameters

Description

string udm_get_res_param ( int res, int param)

udm_get_res_param() returns result parameter value on success, FALSE on error.

res - a link to result identifier, received after call to udm_find().

param - parameter identifier, may have the following values:

  • UDM_PARAM_NUM_ROWS - number of received found links on the current page. It is equal to UDM_PARAM_PAGE_SIZE for all search pages, on the last page - the rest of links.

  • UDM_PARAM_FOUND - total number of results matching the query.

  • UDM_PARAM_WORDINFO - information on the words found. E.g. search for "a good book" will return "a: stopword, good:5637, book: 120"

  • UDM_PARAM_SEARCHTIME - search time in seconds.

  • UDM_PARAM_FIRST_DOC - the number of the first document displayed on current page.

  • UDM_PARAM_LAST_DOC - the number of the last document displayed on current page.

Anterior | Inicio | Siguiente
udm_get_res_field | Subir | udm_load_ispell_data


udm_load_ispell_data

(PHP 4 >= 4.0.5)

udm_load_ispell_data -- Load ispell data

Description

int udm_load_ispell_data ( int agent, int var, string val1, string val2, int flag)

udm_load_ispell_data() loads ispell data. Returns TRUE on success, FALSE on error.

agent - agent link identifier, received after call to udm_alloc_agent().

var - parameter, indicating the source for ispell data. May have the following values:

After using this function to free memory allocated for ispell data, please use udm_free_ispell_data(), even if you use UDM_ISPELL_TYPE_SERVER mode.

The fastest mode is UDM_ISPELL_TYPE_SERVER. UDM_ISPELL_TYPE_TEXT is slower and UDM_ISPELL_TYPE_DB is the slowest. The above pattern is TRUE for mnoGoSearch 3.1.10 - 3.1.11. It is planned to speed up DB mode in future versions and it is going to be faster than TEXT mode.

  • UDM_ISPELL_TYPE_DB - indicates that ispell data should be loaded from SQL. In this case, parameters val1 and val2 are ignored and should be left blank. flag should be equal to 1.

    Nota: flag indicates that after loading ispell data from defined source it sould be sorted (it is necessary for correct functioning of ispell). In case of loading ispell data from files there may be several calls to udm_load_ispell_data(), and there is no sense to sort data after every call, but only after the last one. Since in db mode all the data is loaded by one call, this parameter should have the value 1. In this mode in case of error, e.g. if ispell tables are absent, the function will return FALSE and code and error message will be accessible through udm_error() and udm_errno().

    Example:

    if (! udm_load_ispell_data($udm,UDM_ISPELL_TYPE_DB,'','',1)) {
  printf("Error #%d: '%s'\n", udm_errno($udm), udm_error($udm));
  exit;
}

  • UDM_ISPELL_TYPE_AFFIX - indicates that ispell data should be loaded from file and initiates loading affixes file. In this case val1 defines double letter language code for which affixes are loaded, and val2 - file path. Please note, that if a relative path entered, the module looks for the file not in UDM_CONF_DIR, but in relation to current path, i.e. to the path where the script is executed. In case of error in this mode, e.g. if file is absent, the function will return FALSE, and an error message will be displayed. Error message text cannot be accessed through udm_error() and udm_errno(), since those functions can only return messages associated with SQL. Please, see flag parameter description in UDM_ISPELL_TYPE_DB.

    Example:

    if ((! udm_load_ispell_data($udm,UDM_ISPELL_TYPE_AFFIX,'en','/opt/ispell/en.aff',0)) ||
        (! udm_load_ispell_data($udm,UDM_ISPELL_TYPE_AFFIX,'ru','/opt/ispell/ru.aff',0)) ||
        (! udm_load_ispell_data($udm,UDM_ISPELL_TYPE_SPELL,'en','/opt/ispell/en.dict',0)) ||
        (! udm_load_ispell_data($udm,UDM_ISPELL_TYPE_SPELL,'ru','/opt/ispell/ru.dict',1))) {
     exit;
     }

    Nota: flag is equal to 1 only in the last call.

  • UDM_ISPELL_TYPE_SPELL - indicates that ispell data should be loaded from file and initiates loading of ispell dictionary file. In this case val1 defines double letter language code for which affixes are loaded, and val2 - file path. Please note, that if a relative path entered, the module looks for the file not in UDM_CONF_DIR, but in relation to current path, i.e. to the path where the script is executed. In case of error in this mode, e.g. if file is absent, the function will return FALSE, and an error message will be displayed. Error message text cannot be accessed through udm_error() and udm_errno(), since those functions can only return messages associated with SQL. Please, see flag parameter description in UDM_ISPELL_TYPE_DB.

    if ((! Udm_Load_Ispell_Data($udm,UDM_ISPELL_TYPE_AFFIX,'en','/opt/ispell/en.aff',0)) ||
        (! Udm_Load_Ispell_Data($udm,UDM_ISPELL_TYPE_AFFIX,'ru','/opt/ispell/ru.aff',0)) ||
        (! Udm_Load_Ispell_Data($udm,UDM_ISPELL_TYPE_SPELL,'en','/opt/ispell/en.dict',0)) ||
        (! Udm_Load_Ispell_Data($udm,UDM_ISPELL_TYPE_SPELL,'ru','/opt/ispell/ru.dict',1))) {
      exit;
      }

    Nota: flag is equal to 1 only in the last call.

  • UDM_ISPELL_TYPE_SERVER - enables spell server support. val1 parameter indicates address of the host running spell server. val2 ` is not used yet, but in future releases it is going to indicate number of port used by spell server. flag parameter in this case is not needed since ispell data is stored on spellserver already sorted.

    Spelld server reads spell-data from a separate configuration file (/usr/local/mnogosearch/etc/spelld.conf by default), sorts it and stores in memory. With clients server communicates in two ways: to indexer all the data is transferred (so that indexer starts faster), from search.cgi server receives word to normalize and then passes over to client (search.cgi) list of normalized word forms. This allows fastest, compared to db and text modes processing of search queries (by omitting loading and sorting all the spell data).

    udm_load_ispell_data() function in UDM_ISPELL_TYPE_SERVER mode does not actually load ispell data, but only defines server address. In fact, server is automatically used by udm_find() function when performing search. In case of errors, e.g. if spellserver is not running or invalid host indicated, there are no messages returned and ispell conversion does not work.

    Nota: This function is available in mnoGoSearch 3.1.12 or later.

    Example:

    if (!udm_load_ispell_data($udm,UDM_ISPELL_TYPE_SERVER,'','',1)) {
    printf("Error loading ispell data from server<br>\n");
    exit;
}

Anterior | Inicio | Siguiente
udm_get_res_param | Subir | udm_set_agent_param


udm_set_agent_param

(PHP 4 >= 4.0.5)

udm_set_agent_param -- Set mnoGoSearch agent session parameters

Description

int udm_set_agent_param ( int agent, int var, string val)

udm_set_agent_param() returns TRUE on success, FALSE on error. Defines mnoGoSearch session parameters.

The following parameters and their values are available:

  • UDM_PARAM_PAGE_NUM - used to choose search results page number (results are returned by pages beginning from 0, with UDM_PARAM_PAGE_SIZE results per page).

  • UDM_PARAM_PAGE_SIZE - number of search results displayed on one page.

  • UDM_PARAM_SEARCH_MODE - search mode. The following values available: UDM_MODE_ALL - search for all words; UDM_MODE_ANY - search for any word; UDM_MODE_PHRASE - phrase search; UDM_MODE_BOOL - boolean search. See udm_find() for details on boolean search.

  • UDM_PARAM_CACHE_MODE - turns on or off search result cache mode. When enabled, the search engine will store search results to disk. In case a similar search is performed later, the engine will take results from the cache for faster performance. Available values: UDM_CACHE_ENABLED, UDM_CACHE_DISABLED.

  • UDM_PARAM_TRACK_MODE - turns on or off trackquery mode. Since version 3.1.2 mnoGoSearch has a query tracking support. Note that tracking is implemented in SQL version only and not available in built-in database. To use tracking, you have to create tables for tracking support. For MySQL, use create/mysql/track.txt. When doing a search, front-end uses those tables to store query words, a number of found documents and current UNIX timestamp in seconds. Available values: UDM_TRACK_ENABLED, UDM_TRACK_DISABLED.

  • UDM_PARAM_PHRASE_MODE - defines whether index database using phrases ("phrase" parameter in indexer.conf). Possible values: UDM_PHRASE_ENABLED and UDM_PHRASE_DISABLED. Please note, that if phrase search is enabled (UDM_PHRASE_ENABLED), it is still possible to do search in any mode (ANY, ALL, BOOL or PHRASE). In 3.1.10 version of mnoGoSearch phrase search is supported only in sql and built-in database modes, while beginning with 3.1.11 phrases are supported in cachemode as well.

    Examples of phrase search:

    "Arizona desert" - This query returns all indexed documents that contain "Arizona desert" as a phrase. Notice that you need to put double quotes around the phrase

  • UDM_PARAM_CHARSET - defines local charset. Available values: set of charsets supported by mnoGoSearch, e.g. koi8-r, cp1251, ...

  • UDM_PARAM_STOPFILE - Defines name and path to stopwords file. (There is a small difference with mnoGoSearch - while in mnoGoSearch if relative path or no path entered, it looks for this file in relation to UDM_CONF_DIR, the module looks for the file in relation to current path, i.e. to the path where the php script is executed.)

  • UDM_PARAM_STOPTABLE - Load stop words from the given SQL table. You may use several StopwordTable commands. This command has no effect when compiled without SQL database support.

  • UDM_PARAM_WEIGHT_FACTOR - represents weight factors for specific document parts. Currently body, title, keywords, description, url are supported. To activate this feature please use degrees of 2 in *Weight commands of the indexer.conf. Let's imagine that we have these weights:

    URLWeight 1
    BodyWeight 2
    TitleWeight 4
    KeywordWeight 8
    DescWeight 16

    As far as indexer uses bit OR operation for word weights when some word presents several time in the same document, it is possible at search time to detect word appearance in different document parts. Word which appears only in the body will have 00000010 argegate weight (in binary notation). Word used in all document parts will have 00011111 aggregate weight.

    This parameter's value is a string of hex digits ABCDE. Each digit is a factor for corresponding bit in word weight. For the given above weights configuration:

    E is a factor for weight 1 (URL Weight bit)
    D is a factor for weight 2 (BodyWeight bit)
    C is a factor for weight 4 (TitleWeight bit)
    B is a factor for weight 8 (KeywordWeight bit)
    A is a factor for weight 16 (DescWeight bit)

    Examples:

    UDM_PARAM_WEIGHT_FACTOR=00001 will search through URLs only.

    UDM_PARAM_WEIGHT_FACTOR=00100 will search through Titles only.

    UDM_PARAM_WEIGHT_FACTOR=11100 will search through Title,Keywords,Description but not through URL and Body.

    UDM_PARAM_WEIGHT_FACTOR=F9421 will search through:

    Description with factor 15 (F hex)
    Keywords with factor 9
    Title with factor 4
    Body with factor 2
    URL with factor 1

    If UDM_PARAM_WEIGHT_FACTOR variable is ommited, original weight value is taken to sort results. For a given above weight configuration it means that document description has a most big weight 16.

  • UDM_PARAM_WORD_MATCH - word match. You may use this parameter to choose word match type. This feature works only in "single" and "multi" modes using SQL based and built-in database. It does not work in cachemode and other modes since they use word CRC and do not support substring search. Available values:

    UDM_MATCH_BEGIN - word beginning match;

    UDM_MATCH_END - word ending match;

    UDM_MATCH_WORD - whole word match;

    UDM_MATCH_SUBSTR - word substring match.

  • UDM_PARAM_MIN_WORD_LEN - defines minimal word length. Any word shorter this limit is considered to be a stopword. Please note that this parameter value is inclusive, i.e. if UDM_PARAM_MIN_WORD_LEN=3, a word 3 characters long will not be considered a stopword, while a word 2 characters long will be. Default value is 1.

  • UDM_PARAM_ISPELL_PREFIXES - Possible values: UDM_PREFIXES_ENABLED and UDM_PREFIXES_DISABLED, that respectively enable or disable using prefixes. E.g. if a word "tested" is in search query, also words like "test", "testing", etc. Only suffixes are supported by default. Prefixes usually change word meanings, for example if somebody is searching for the word "tested" one hardly wants "untested" to be found. Prefixes support may also be found useful for site's spelling checking purposes. In order to enable ispell, you have to load ispell data with udm_load_ispell_data().

  • UDM_PARAM_CROSS_WORDS - enables or disables crosswords support. Possible values: UDM_CROSS_WORDS_ENABLED and UDM_CROSS_WORDS_DISABLED.

    The corsswords feature allows to assign words between <a href="xxx"> and </a> also to a document this link leads to. It works in SQL database mode and is not supported in built-in database and Cachemode.

    Nota: Crosswords are supported only in mnoGoSearch 3.1.11 or later.

  • UDM_PARAM_VARDIR - specifies a custom path to directory where indexer stores data when using built-in database and in cache mode. By default /var directory of mnoGoSearch installation is used. Can have only string values. The parameter is available in PHP 4.1.0 or later.

  • UDM_PARAM_VARDIR - specifies a custom path to directory where indexer stores data when using built-in database and in cache mode. By default /var directory of mnoGoSearch installation is used. Can have only string values. The parameter is available in PHP 4.1.0 or later.

Anterior | Inicio | Siguiente
udm_load_ispell_data | Subir | udm_check_charset


udm_check_charset

(PHP 4 >= 4.2.0)

udm_check_charset -- Check if the given charset is known to mnogosearch

Description

int udm_check_charset ( int agent, string charset)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
udm_set_agent_param | Subir | udm_check_stored


udm_check_stored

(PHP 4 >= 4.2.0)

udm_check_stored -- Check connection to stored

Description

int udm_check_stored ( int agent, int link, string doc_id)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
udm_check_charset | Subir | udm_close_stored


udm_close_stored

(PHP 4 >= 4.2.0)

udm_close_stored -- Close connection to stored

Description

int udm_close_stored ( int agent, int link)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
udm_check_stored | Subir | udm_crc32


udm_crc32

(PHP 4 >= 4.2.0)

udm_crc32 -- Return CRC32 checksum of gived string

Description

int udm_crc32 ( int agent, string str)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
udm_close_stored | Subir | udm_open_stored


udm_open_stored

(PHP 4 >= 4.2.0)

udm_open_stored -- Open connection to stored

Description

int udm_open_stored ( int agent, string storedaddr)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
udm_crc32 | Subir | funciones mSQL


funciones mSQL

Manual de PHP
Anterior Siguiente

LX. funciones mSQL

Tabla de contenidos
msql — ejecuta una consulta mSQL
msql_affected_rows — devuelve el número de filas involucradas
msql_close — cierra una conexión mSQL
msql_connect — abre una conexión mSQL
msql_create_db — crea una base de datos mSQL
msql_createdb — crea una base de datos mSQL
msql_data_seek — desplaza el puntero interno de fila
msql_dbname — obtiene el nombre de la base de datos mSQL actual
msql_drop_db — elimina (suprime) una base de datos mSQL
msql_dropdb — elimina (suprime) una base de datos mSQL
msql_error — devuelve el mensaje de error de la última llamada msql
msql_fetch_array — recupera una fila como un array
msql_fetch_field — obtiene información de campo
msql_fetch_object — recupera una fila como un objeto
msql_fetch_row — obtiene una fila como un array enumerado
msql_field_seek — establece el desplazamiento del campo
msql_fieldflags — obtiene los flags del campo
msql_fieldlen — obtiene la longitud del campo
msql_fieldname — obtiene el nombre del campo
msql_fieldtable — obtiene el nombre de la tabla de un campo
msql_fieldtype — obtiene el tipo del campo
msql_free_result — libera la memoria del resultado
msql_freeresult — libera la memoria del resultado
msql_list_dbs — lista las bases de datos mSQL en el servidor
msql_list_fields — lista los campos del resultado
msql_list_tables — lista las tablas de una base de datos mSQL
msql_listdbs — lista las bases de datos mSQL en el servidor
msql_listfields — lista los campos del resultado
msql_listtables — lista las tablas de una base de datos mSQL
msql_num_fields — obtiene el número de campos de un resultado
msql_num_rows — obtiene el número de filas de un resultado
msql_numfields — obtiene el número de campos de un resultado
msql_numrows — obtiene el número de filas en el resultado
msql_pconnect — abre una conexión mSQL persistente
msql_query — envía una consulta mSQL
msql_regcase — construye una expresión regular para una búsqueda que no distinga mayúsculas/minúsculas
msql_result — obtiene datos resultado
msql_select_db — selecciona una base de datos mSQL
msql_selectdb — selecciona una base de datos mSQL
msql_tablename — obtiene el nombre de la tabla de un campo

Anterior | Inicio | Siguiente
udm_open_stored | Subir | msql


msql

(PHP 3, PHP 4 >= 4.0.0)

msql -- ejecuta una consulta mSQL

Descripción

int msql ( string database, string query, int link_identifier)

Devuelve un identificador de consulta mSQL positivo en el resultado de la consulta, o FALSE en caso de error.

msql() selecciona una base de datos y ejecuta una consulta en ella. Si no se especifica el identificador de conexión (link identifier), la función intentará encontrar una conexión abierta en el servidor mSQL y en el caso de que no se encontrase intentará crear uno como si se llamase a msql_connect() sin parámetros (véase msql_connect()).

Anterior | Inicio | Siguiente
funciones mSQL | Subir | msql_affected_rows


msql_affected_rows

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

msql_affected_rows -- devuelve el número de filas involucradas

Descripción

int msql_affected_rows ( int query_identifier)

Devuelve el número de filas involucradas ("tocadas") por una consulta específica (i.e. el número de filas devueltas por una SELECT, el número de filas modificadas por una actualización (update), o el número de filas suprimidas por una eliminación (delete)).

Véase también: msql_query()

Anterior | Inicio | Siguiente
msql | Subir | msql_close


msql_close

(PHP 3, PHP 4 >= 4.0.0)

msql_close -- cierra una conexión mSQL

Descripción

int msql_close ( int link_identifier)

Devuelve TRUE si tiene éxito, FALSE en caso de error.

msql_close() cierra la conexión con una base de datos mSQL que está asociada con el identificador de conexión (link identifier) especificado. Si no se especifica el identificador de conexión, se asume la última conexión abierta.

Advierta que ésto no es necesario habitualmente, las conexiones abiertas no-persistentes son cerradas automáticamente a la conclusión de la ejecución del script.

msql_close() no cerrará las conexiones permanentes creadas por msql_pconnect().

Véase también: msql_connect() y msql_pconnect().

Anterior | Inicio | Siguiente
msql_affected_rows | Subir | msql_connect


msql_connect

(PHP 3, PHP 4 >= 4.0.0)

msql_connect -- abre una conexión mSQL

Descripción

int msql_connect ( string hostname)

Devuelve un identificador de conexión mSQL positivo si tiene éxito, o FALSE en caso de error.

msql_connect() establece una conexión con un servidor mSQL. El argumento hostname es opcional, y en caso de que falte, se asume localhost.

En caso de que se haga una segunda llamada a msql_connect() con los mismos argumentos, no se establece una nueva conexión, en lugar de eso, se devuelve el identificador de conexión ya abierto.

La conexión con el servidor se cerrará tan pronto como la ejecución del script finalice, a menos que sea cerrada antes explícitamente por una llamada a msql_close().

Véase también: msql_pconnect(), msql_close().

Anterior | Inicio | Siguiente
msql_close | Subir | msql_create_db


msql_create_db

(PHP 3, PHP 4 >= 4.0.0)

msql_create_db -- crea una base de datos mSQL

Descripción

int msql_create_db ( string database name [, int link_identifier])

msql_create_db() intenta crear una base de datos nueva en el servidor asociado con el identificador de conexión (link identifier) especificado.

Véase también: msql_drop_db().

Anterior | Inicio | Siguiente
msql_connect | Subir | msql_createdb


msql_createdb

(PHP 3, PHP 4 >= 4.0.0)

msql_createdb -- crea una base de datos mSQL

Descripción

int msql_createdb ( string database name [, int link_identifier])

Idéntica a msql_create_db().

Anterior | Inicio | Siguiente
msql_create_db | Subir | msql_data_seek


msql_data_seek

(PHP 3, PHP 4 >= 4.0.0)

msql_data_seek -- desplaza el puntero interno de fila

Descripción

int msql_data_seek ( int query_identifier, int row_number)

Devuelve TRUE si tiene éxito, FALSE en caso de fallo.

msql_data_seek() desplaza el puntero interno de fila del resultado mSQL asociado con el identificador de consulta (query identifier) especificado para que apunte al número de fila (row number) proporcionado. La llamada posterior a msql_fetch_row() devolverá esa fila.

Véase también: msql_fetch_row().

Anterior | Inicio | Siguiente
msql_createdb | Subir | msql_dbname


msql_dbname

(PHP 3, PHP 4 >= 4.0.0)

msql_dbname -- obtiene el nombre de la base de datos mSQL actual

Descripción

string msql_dbname ( int query_identifier, int i)

msql_dbname() devuelve el nombre de base de datos almacenado en la posición i del puntero devuelto desde la función msql_listdbs(). La función msql_numrows() puede utilizarse para determinar cuantos nombres de base de datos hay disponibles.

Anterior | Inicio | Siguiente
msql_data_seek | Subir | msql_drop_db


msql_drop_db

(PHP 3, PHP 4 >= 4.0.0)

msql_drop_db -- elimina (suprime) una base de datos mSQL

Descripción

int msql_drop_db ( string database_name, int link_identifier)

Devuelve TRUE si tiene éxito, FALSE en caso de fallo.

msql_drop_db() intenta eliminar (suprimir) una base de datos completa del servidor asociado con el identificador de conexión (link identifier) especificado.

Véase también: msql_create_db().

Anterior | Inicio | Siguiente
msql_dbname | Subir | msql_dropdb


msql_dropdb

(PHP 3, PHP 4 >= 4.0.0)

msql_dropdb -- elimina (suprime) una base de datos mSQL

Descripción

Véase msql_drop_db().

Anterior | Inicio | Siguiente
msql_drop_db | Subir | msql_error


msql_error

(PHP 3, PHP 4 >= 4.0.0)

msql_error -- devuelve el mensaje de error de la última llamada msql

Descripción

string msql_error ( )

Los errores que devuelve el servidor de base de datos mSQL no dan mucha información sobre el problema. Por este motivo, utilice estas funciones para recuperar la cadena de carácteres del error.

Anterior | Inicio | Siguiente
msql_dropdb | Subir | msql_fetch_array


msql_fetch_array

(PHP 3, PHP 4 >= 4.0.0)

msql_fetch_array -- recupera una fila como un array

Descripción

int msql_fetch_array ( int query_identifier [, int result_type])

Devuelve un array que se corresponde con la fila recuperada, o FALSE si no hay más filas.

msql_fetch_array() es una versión ampliada de msql_fetch_row(). Además de almacenar los datos en los índices numéricos del array resultado, también almacena los datos en índices asociativos, utilizando los nombres de los campos como claves.

El segundo argumento opcional result_type en msql_fetch_array() es una constante y puede tomar los valores siguientes: MSQL_ASSOC, MSQL_NUM, y MYSQL_BOTH.

Sea precavido si está recuperando resultados de una consulta que puede devolver un registro que contiene un único campo que tiene un valor de 0 (o una cadena de carácteres vacía, o NULL).

Un aspecto importante a tener en cuenta es que el uso de msql_fetch_array() NO es significativamente más lento que el uso de msql_fetch_row(), mientras que proporciona un valor añadido significativo.

Para detalles adicionales, véase también msql_fetch_row()

Anterior | Inicio | Siguiente
msql_error | Subir | msql_fetch_field


msql_fetch_field

(PHP 3, PHP 4 >= 4.0.0)

msql_fetch_field -- obtiene información de campo

Descripción

object msql_fetch_field ( int query_identifier, int field_offset)

Devuelve un objeto que contiene la información del campo

msql_fetch_field() puede utilizarse para obtener información sobre campos del resultado de una consulta. Si no se especifica el desplazamiento del campo, se recupera el campo siguiente que no haya sido aún recuperado por msql_fetch_field().

Las propiedades del objeto son:

  • name - nombre de la columna

  • table - nombre de la tabla a la que pertenece la columna

  • not_null - 1 si la columna no puede ser nula

  • primary_key - 1 si la columna es una clave primaria

  • unique - 1 si la columna es una clave única

  • type - tipo de la columna

Véase también msql_field_seek().

Anterior | Inicio | Siguiente
msql_fetch_array | Subir | msql_fetch_object


msql_fetch_object

(PHP 3, PHP 4 >= 4.0.0)

msql_fetch_object -- recupera una fila como un objeto

Descripción

int msql_fetch_object ( int query_identifier [, int result_type])

Devuelve un objeto con las propiedades que corresponden a la fila recuperada, o FALSE si no hay más filas.

msql_fetch_object() es similar a msql_fetch_array(), con una diferencia - se devuelve un objeto en vez de un array. Indirectamente esto significa que sólo tiene acceso a los datos por los nombres de los campos, y no por sus desplazamientos (los números son nombres de propiedad no válidos).

El segundo parámetro opcional result_type en msql_fetch_array() es una constante y puede tomar los valores siguientes: MSQL_ASSOC, MSQL_NUM, y MSQL_BOTH.

Resumiendo, la función es indéntica a msql_fetch_array(), y casi tan rápida como msql_fetch_row() (la diferencia es insignificante).

Véase también: msql_fetch_array() y msql_fetch_row().

Anterior | Inicio | Siguiente
msql_fetch_field | Subir | msql_fetch_row


msql_fetch_row

(PHP 3, PHP 4 >= 4.0.0)

msql_fetch_row -- obtiene una fila como un array enumerado

Descripción

array msql_fetch_row ( int query_identifier)

Devuelve un array que se corresponde con la fila recuperada, o FALSE si no hay más filas.

msql_fetch_row() recupera una fila de datos del resultado asociado con el identificador de consulta (query identifier) especificado. La fila se devuelve en un array. Cada columna devuelta se almacena en un desplazamiento del array, comenzando en el desplazamiento 0.

Una llamada posterior a msql_fetch_row() devería devolver la fila siguiente del conjunto resultado, o FALSE si no hay más filas.

Véase también:
    msql_fetch_array(),
    msql_fetch_object(),
    msql_data_seek(), y
    msql_result().

Anterior | Inicio | Siguiente
msql_fetch_object | Subir | msql_field_seek


msql_fieldname

(PHP 3, PHP 4 >= 4.0.0)

msql_fieldname -- obtiene el nombre del campo

Descripción

string msql_fieldname ( int query_identifier, int field)

msql_fieldname() devuelve el nombre del campo especificado. query_identifier es el identificador de consulta, y field es el índice del campo. msql_fieldname($result, 2); devolverá el nombre del segundo campo del resultado asociado con el identificador result.

Anterior | Inicio | Siguiente
msql_fieldlen | Subir | msql_fieldtable


msql_field_seek

(PHP 3, PHP 4 >= 4.0.0)

msql_field_seek -- establece el desplazamiento del campo

Descripción

int msql_field_seek ( int query_identifier, int field_offset)

Se posiciona en el desplazamiento de campo (field offset) especificado. Si la siguiente llamada a msql_fetch_field() no incluye un desplazamiento de campo, este campo será el que se devuelva.

Véase también: msql_fetch_field().

Anterior | Inicio | Siguiente
msql_fetch_row | Subir | msql_fieldflags


msql_fieldtable

(PHP 3, PHP 4 >= 4.0.0)

msql_fieldtable -- obtiene el nombre de la tabla de un campo

Descripción

int msql_fieldtable ( int query_identifier, int field)

Devuelve el nombre de la tabla desde la que se ha recuperado el campo (field)

Anterior | Inicio | Siguiente
msql_fieldname | Subir | msql_fieldtype


msql_fieldtype

(PHP 3, PHP 4 >= 4.0.0)

msql_fieldtype -- obtiene el tipo del campo

Descripción

string msql_fieldtype ( int query_identifier, int i)

msql_fieldtype() es similar a la función msql_fieldname(). Los argumentos son idénticos, pero se devuelve el tipo del campo. Este será "int", "char" o "real".

Anterior | Inicio | Siguiente
msql_fieldtable | Subir | msql_free_result


msql_fieldflags

(PHP 3, PHP 4 >= 4.0.0)

msql_fieldflags -- obtiene los flags del campo

Descripción

string msql_fieldflags ( int query_identifier, int i)

msql_fieldflags() obtiene los flags del campo (field) especificado. Actualmente pueden ser, "not NULL", "primary key", una combinación de ambos, o "" (cadena vacía).

Anterior | Inicio | Siguiente
msql_field_seek | Subir | msql_fieldlen


msql_fieldlen

(PHP 3, PHP 4 >= 4.0.0)

msql_fieldlen -- obtiene la longitud del campo

Descripción

int msql_fieldlen ( int query_identifier, int i)

msql_fieldlen() devuelve la longitud del campo especificado.

Anterior | Inicio | Siguiente
msql_fieldflags | Subir | msql_fieldname


msql_free_result

(PHP 3, PHP 4 >= 4.0.0)

msql_free_result -- libera la memoria del resultado

Descripción

int msql_free_result ( int query_identifier)

msql_free_result() libera la memoria asociada con query_identifier. Cuando PHP completa una petición, esta memoria es liberada automáticamente, por este motivo solo es necesario llamar a esta función cuando se desea estar seguro de que no se utiliza demasiada memoria mientras se está ejecutando el script.

Anterior | Inicio | Siguiente
msql_fieldtype | Subir | msql_freeresult


msql_freeresult

(PHP 3, PHP 4 >= 4.0.0)

msql_freeresult -- libera la memoria del resultado

Descripción

Véase msql_free_result()

Anterior | Inicio | Siguiente
msql_free_result | Subir | msql_list_dbs


msql_list_fields

(PHP 3, PHP 4 >= 4.0.0)

msql_list_fields -- lista los campos del resultado

Descripción

int msql_list_fields ( string database, string tablename)

msql_list_fields() recupera información sobre el nombre de tabla (tablename) dado. Los argumentos son el nombre de la base de datos (database name) y el nombre de la tabla (table name). Se devuelve un puntero al resultado que puede utilizarse con msql_fieldflags(), msql_fieldlen(), msql_fieldname(), y msql_fieldtype(). Un indetificador de consulta (query identifier) es un entero positivo. La función devuelve -1 si ocurre un error. En $phperrmsg se almacena una cadena de carácteres describiendo el error, y a menos que la función sea llamada como @msql_list_fields() esta cadena de error puede ser impresa.

Véase también msql_error().

Anterior | Inicio | Siguiente
msql_list_dbs | Subir | msql_list_tables


msql_listfields

(PHP 3, PHP 4 >= 4.0.0)

msql_listfields -- lista los campos del resultado

Descripción

Véase msql_list_fields().

Anterior | Inicio | Siguiente
msql_listdbs | Subir | msql_listtables


msql_list_dbs

(PHP 3, PHP 4 >= 4.0.0)

msql_list_dbs -- lista las bases de datos mSQL en el servidor

Descripción

int msql_list_dbs ( void)

msql_list_dbs() devolverá un puntero al resultado que contiene las bases de datos disponibles desde el daemon msql en uso. Utilice la función msql_dbname() para recorrer este puntero.

Anterior | Inicio | Siguiente
msql_freeresult | Subir | msql_list_fields


msql_listdbs

(PHP 3, PHP 4 >= 4.0.0)

msql_listdbs -- lista las bases de datos mSQL en el servidor

Descripción

Véase msql_list_dbs().

Anterior | Inicio | Siguiente
msql_list_tables | Subir | msql_listfields


msql_list_tables

(PHP 3, PHP 4 >= 4.0.0)

msql_list_tables -- lista las tablas de una base de datos mSQL

Descripción

int msql_list_tables ( string database)

msql_list_tables() toma un nombre de base de datos y devuelve un puntero similar al de la función msql() La función msql_tablename() debería utilizarse para obtener los nombres reales de las tablas del puntero devuelto.

Anterior | Inicio | Siguiente
msql_list_fields | Subir | msql_listdbs


msql_listtables

(PHP 3, PHP 4 >= 4.0.0)

msql_listtables -- lista las tablas de una base de datos mSQL

Descripción

Véase msql_list_tables().

Anterior | Inicio | Siguiente
msql_listfields | Subir | msql_num_fields


msql_num_fields

(PHP 3, PHP 4 >= 4.0.0)

msql_num_fields -- obtiene el número de campos de un resultado

Descripción

int msql_num_fields ( int query_identifier)

msql_num_fields() devuelve el número de campos de un conjunto resultado.

Véase también:
msql(),
msql_query(),
msql_fetch_field(), y
msql_num_rows().

Anterior | Inicio | Siguiente
msql_listtables | Subir | msql_num_rows


msql_num_rows

(PHP 3, PHP 4 >= 4.0.0)

msql_num_rows -- obtiene el número de filas de un resultado

Descripción

int msql_num_rows ( int query_identifier)

msql_num_rows() devuelve el número de filas de un conjunto resultado.

Véase también:
msql(),
msql_query(), y
msql_fetch_row().

Anterior | Inicio | Siguiente
msql_num_fields | Subir | msql_numfields


msql_numfields

(PHP 3, PHP 4 >= 4.0.0)

msql_numfields -- obtiene el número de campos de un resultado

Descripción

int msql_numfields ( int query_identifier)

Idéntica a msql_num_fields().

Anterior | Inicio | Siguiente
msql_num_rows | Subir | msql_numrows


msql_numrows

(PHP 3, PHP 4 >= 4.0.0)

msql_numrows -- obtiene el número de filas en el resultado

Descripción

int msql_numrows ( void)

Idéntica a msql_num_rows().

Anterior | Inicio | Siguiente
msql_numfields | Subir | msql_pconnect


msql_pconnect

(PHP 3, PHP 4 >= 4.0.0)

msql_pconnect -- abre una conexión mSQL persistente

Descripción

int msql_pconnect ( string hostname)

En caso de éxito devuelve un identificador de conexión mSQL persistente positivo, o FALSE en caso de error.

msql_pconnect() se comporta de forma similar a msql_connect() con dos diferencias importantes.

Primero, cuando se conecta, la función debe intentar primero localizar una conexión (persistente) que ya esté abierta en el mismo host. Si se encuentra uno, se devuelve un identificador para el mismo en vez de abrir una conexión nueva.

Segundo, la conexión con el servidor SQL no se cerrará cuando la ejecución del script finalice. Al contrario, la conexión permanecerá abierta para un uso futuro (msql_close() no cerrará las conexiones abiertas por msql_pconnect()).

Este tipo de conexiones son por ello denominadas 'persistentes'.

Anterior | Inicio | Siguiente
msql_numrows | Subir | msql_query


msql_query

(PHP 3, PHP 4 >= 4.0.0)

msql_query -- envía una consulta mSQL

Descripción

int msql_query ( string query, int link_identifier)

msql_query() envía una consulta a la base de datos activa actual en el servidor que está asociada con el identificador de conexión (link identifier) especificado. Si no se especifica el identificador de conexión, se asume la última conexión abierta. Si no hay ninguna conexión abierta, la función intenta establecer una conexión como si se hubiera llamado a msql_connect(), y la utiliza.

En caso de éxito devuelve un identificador de consulta mSQL positivo, o FALSE en caso de error.

Véase también:
msql(),
msql_select_db(), y
msql_connect().

Anterior | Inicio | Siguiente
msql_pconnect | Subir | msql_regcase


msql_regcase

(PHP 3, PHP 4 >= 4.0.0)

msql_regcase -- construye una expresión regular para una búsqueda que no distinga mayúsculas/minúsculas

Descripción

Véase sql_regcase().

Anterior | Inicio | Siguiente
msql_query | Subir | msql_result


msql_result

(PHP 3, PHP 4 >= 4.0.0)

msql_result -- obtiene datos resultado

Descripción

int msql_result ( int query_identifier, int i, mixed field)

Devuelve el contenido de la celda en la fila y desplazamiento del conjunto resultado mSQL especificado.

msql_result() devuelve el contenido de una celda de un conjunto resultado mSQL. El argumento campo (field) puede ser el desplazamiento del campo, el nombre del campo, o el nombre de la tabla punto nombre del campo (nombretabla.nombrecampo). Si el nombre de la columna tiene un alias ('select foo as bar from...'), utilice el alias en vez del nombre de la columna.

Cuando se trabaja con conjuntos de resultados grandes, debería considerar el uso de las funciones que recuperen filas completas (especificadas más abajo). Como estas funciones recuperan el contenido de varias celdas en una única llamada de función, son MUCHO más rápidas que msql_result(). Advierta también que especificar un desplazamiento numérico para el argumento campo (field) es mucho más rápido que especificar un argumento nombrecampo o nombretabla.nombrecampo.

Alternativas de alto-rendimiento recomendadas:
msql_fetch_row(),
msql_fetch_array(), y
msql_fetch_object().

Anterior | Inicio | Siguiente
msql_regcase | Subir | msql_select_db


msql_select_db

(PHP 3, PHP 4 >= 4.0.0)

msql_select_db -- selecciona una base de datos mSQL

Descripción

int msql_select_db ( string database_name, int link_identifier)

Devuelve TRUE si tiene éxito, FALSE en caso contrario.

msql_select_db() establece la base de datos activa actual en el servidor que está asociada con el identificador de conexión (link identifier) suministrado. Si no se especifica el identificador de conexión, se asumne la última conexión abierta. Si no hay ninguna conexión abierta la función intentará establecer una conexión como si se hubiera llamado a sql_connect(), y la utiliza.

Cada llamada posterior a msql_query() se hará en la base de datos activa.

Véase también:
msql_connect(),
msql_pconnect(), y
msql_query().

Anterior | Inicio | Siguiente
msql_result | Subir | msql_selectdb


msql_selectdb

(PHP 3, PHP 4 >= 4.0.0)

msql_selectdb -- selecciona una base de datos mSQL

Descripción

Véase msql_select_db().

Anterior | Inicio | Siguiente
msql_select_db | Subir | msql_tablename


msql_tablename

(PHP 3, PHP 4 >= 4.0.0)

msql_tablename -- obtiene el nombre de la tabla de un campo

Descripción

string msql_tablename ( int query_identifier, int field)

msql_tablename() toma un puntero resultado devuelto por la función msql_list_tables() como un índice entero y devuelve el nombre de una tabla. La función msql_numrows() puede utilizarse para determinar el número de tablas del puntero resultado.

Ejemplo 1. msql_tablename() example

<?php
msql_connect ("localhost");
$result = msql_list_tables("wisconsin");
$i = 0;
while ($i < msql_numrows($result)) {
    $tb_names[$i] = msql_tablename($result, $i);
    echo $tb_names[$i] . "<BR>";
    $i++;
}
?>

Anterior | Inicio | Siguiente
msql_selectdb | Subir | Funciones MySQL


Funciones MySQL

Manual de PHP
Anterior Siguiente

LXI. Funciones MySQL

Estas funciones le permiten acceder a servidores de bases de datos MySQL.

Puede encontrar más información sobre MySQL en http://www.mysql.com/.

Tabla de contenidos
mysql_affected_rows — Devuelve el número de filas afectadas de la última operación MySQL
mysql_change_user — Cambia el usuario conectado en la conexión activa
mysql_close — cierra el enlace con MySQL
mysql_connect — Abre una conexión a un servidor MySQL
mysql_create_db — Crea una base MySQL
mysql_data_seek — Mueve el puntero interno
mysql_db_query — Envia una sentencia MySQL al servidor
mysql_drop_db — Borra una base de datos MySQL
mysql_errno — Deuelve el número del mensaje de error de la última operación MySQL
mysql_error — Devuelve el texto del mensaje de error de la última operación MySQL
mysql_fetch_array — Extrae la fila de resultado como una matriz asociativa
mysql_fetch_field — Extrae la información de una columna y la devuelve como un objeto.
mysql_fetch_lengths — Devuelve la longitud de cada salida en un resultado
mysql_fetch_object — Extrae una fila de resultado como un objeto
mysql_fetch_row — Devuelve una fila de resultado como matriz
mysql_field_flags — Devuelve los flags asociados con el campo especificado en un resultado
mysql_field_len — Devuelve la longitud del campo especificado
mysql_field_name — Devuelve el nombre del campo especificado en un resultado
mysql_field_seek — Asigna el puntero del resultado al offset del campo especificado
mysql_field_table — Devuelve el nombre de la tabla donde esta el campo especificado
mysql_field_type — Devuelve el tipo del campo especificado en un resultado
mysql_free_result — Libera la memoria del resultado
mysql_insert_id — Devuelve el identificador generado en la última llamada a INSERT
mysql_list_dbs — Lista las bases de datos disponibles en el servidor MySQL
mysql_list_fields — Lista los campos del resultado de MySQL
mysql_list_tables — Lista las tablas en una base de datos MySQL
mysql_num_fields — devuelve el numero de campos de un resultado
mysql_num_rows — Devuelve el numero de filas de un resultado
mysql_pconnect — Abre una conexión persistente al servidor MySQL
mysql_query — Envia una sentencia SQL a MySQL
mysql_result — Devuelve datos de un resultado
mysql_select_db — Selecciona un base de datos MySQL
mysql_tablename — Devuelve el nombre de la tabla de un campo

Anterior | Inicio | Siguiente
msql_tablename | Subir | mysql_affected_rows


mysql_affected_rows

(PHP 3, PHP 4 >= 4.0.0)

mysql_affected_rows -- Devuelve el número de filas afectadas de la última operación MySQL

Descripción

int mysql_affected_rows ( [int identificador_de_enlace])

mysql_affected_rows() devuelve el número de filas afectadas en la ultima sentencia INSERT, UPDATE o DELETE sobre el servidor asociado con el identificador de enlace especificado. Si el identificador de enlace no ha sido especificado, se asume por defecto el último enlace.

Si la última sentencia fue un DELETE sin clausula WHERE, todos los registros han sido borrados de la tabla pero esta función devolvera cero.

Este comando no es efectivo para las sentencias SELECT, sino sólo para las sentencias que modifican registros. Para conseguir el número de lineas devueltos por un SELECT, usar mysql_num_rows().

Anterior | Inicio | Siguiente
Funciones MySQL | Subir | mysql_change_user


mysql_change_user

(PHP 3>= 3.0.13)

mysql_change_user -- Cambia el usuario conectado en la conexión activa

Descripción

int mysql_change_user ( string usuario, string password [, string base_de_datos [, int identificador_de_enlace]])

mysql_change_user() cambia el usuario conectado en la actual conexión activa, o si se especifica, en la conexión determinada por el identificador de enlace. Si se especifica la base de datos, esta será la base por defecto después del cambio de usuario. Si la nueva combinación de usuario/ password no esta autorizada, el usuario actualmente conectado permanece activo.

Nota: Esta función fue introducida en PHP 3.0.13 y requiere MySQL 3.23.3 o superior.

Anterior | Inicio | Siguiente
mysql_affected_rows | Subir | mysql_close


mysql_close

(PHP 3, PHP 4 >= 4.0.0)

mysql_close -- cierra el enlace con MySQL

Descripción

int mysql_close ( [int identificador_de_enlace])

Devuelve: verdadero si exito, falso si error.

mysql_close() cierra el enlace con la base MySQL que esta asociada con el identificador de enlace especificado. Si no se especifica el identificador de enlace, se asume por defecto el último enlace.

Nota: Normalmente no es necesario ya que la aperturas no-persistentes son cerradas automaticamente al final de la ejecución del script.

mysql_close() no cerrará los enlaces persistentes generados con mysql_pconnect().

Ejemplo 1. Ejemplo de MySQL close

<?php
    $link = mysql_connect ("kraemer", "marliesle", "secret") {
        or die ("Could not connect");
    }
    print ("Connected successfully");
    mysql_close ($link);
?>

Ver también: mysql_connect(), y mysql_pconnect().

Anterior | Inicio | Siguiente
mysql_change_user | Subir | mysql_connect


mysql_connect

(PHP 3, PHP 4 >= 4.0.0)

mysql_connect -- Abre una conexión a un servidor MySQL

Descripción

int mysql_connect ( [string server [, string usuario [, string password]]])

Devuelve: Un identificador de enlace positivo si tiene exito, o falso si error.

mysql_connect()establece una conexión a un servidor MySQL. Todos los argumentos son opcionales, y si no hay , se asumen los valores por defecto ('localhost', usuario propietario del proceso del servidor, password vacia).

El hostname puede incluir tambien un número de puerto . ej. "hostname:puerto" o un camino al socket ej. ":/camino/al/socket" para localhost.

Nota: Soporte para ":puerto" fue añadido en PHP 3.0B4.

Soporte para ":/camino/al/socket" fue añadido en PHP 3.0.10.

En el caso de que se haga una llamada a mysql_connect() con los mismos argumentos, no se establecerá un nuevo enlace, sino que se devolverá el enlace ya abierto.

El enlace al servidor sera cerrado tan pronto como la ejecución del script finalice, a menos que se cierre antes explicitamente llamando a mysql_close().

Ejemplo 1. Ejemplo de MySQL connect

<?php
    $link = mysql_connect ("kraemer", "marliesle", "secret") {
        or die ("Could not connect");
    }
    print ("Connected successfully");
    mysql_close ($link);
?>

Ver también : mysql_pconnect(), y mysql_close().

Anterior | Inicio | Siguiente
mysql_close | Subir | mysql_create_db


mysql_create_db

(PHP 3, PHP 4 >= 4.0.0)

mysql_create_db -- Crea una base MySQL

Descripción

int mysql_create_db ( string base_de_datos [, int identificador_de_enlace])

mysql_create_db() intenta crear una base nueva en el servidor asociado al identificador de enlace.

Ejemplo 1. Ejemplo de MySQL create

<?php
    $link = mysql_pconnect ("kron", "jutta", "geheim") {
        or die ("Could not connect");
    }
    if (mysql_create_db ("my_db")) {
        print ("Database created successfully\n");
    } else {
        printf ("Error creating database: %s\n", mysql_error ());
    }
?>

Por razones de compatibilidad puede usarse mysql_createdb() igualmente.

Ver también: mysql_drop_db().

Anterior | Inicio | Siguiente
mysql_connect | Subir | mysql_data_seek


mysql_data_seek

(PHP 3, PHP 4 >= 4.0.0)

mysql_data_seek -- Mueve el puntero interno

Descripción

int mysql_data_seek ( int id_resultado, int numero_de_fila)

Devuelve: verdadero si exito, falso si error.

mysql_data_seek() mueve el puntero de fila interno a la fila especificada para el identificador de resultado. La próxima llamada a mysql_fetch_row() devolverá esa fila.

numero_de_fila empieza en 0.

Ejemplo 1. Ejemplo de MySQL data seek

<?php
    $link = mysql_pconnect ("kron", "jutta", "geheim") {
        or die ("Could not connect");
    }

    mysql_select_db ("samp_db") {
        or die ("Could not select database");
    }

    $query = "SELECT last_name, first_name FROM friends";
    $result = mysql_query ($query) {
        or die ("Query failed");
    }

    # fetch rows in reverse order

    for ($i = mysql_num_rows ($result) - 1; $i >=0; $i--) {
        if (!mysql_data_seek ($result, $i)) {
            printf ("Cannot seek to row %d\n", $i);
            continue;
        }

        if(!($row = mysql_fetch_object ($result)))
            continue;

        printf ("%s %s<BR>\n", $row->last_name, $row->first_name);
    }

    mysql_free_result ($result);
?>

Anterior | Inicio | Siguiente
mysql_create_db | Subir | mysql_db_query


mysql_db_query

(PHP 3, PHP 4 >= 4.0.0)

mysql_db_query -- Envia una sentencia MySQL al servidor

Descripción

int mysql_db_query ( string base_de_datos, string sentencia [, int identificador_de_enlace])

Devuelve: Un identificador de resultado positivo o falso si error.

mysql_db_query() selecciona una base y ejecuta una sentencia en ella. Si el identificador de enlace no ha sido especificado, la función intenta encontrar un enlace abierto al servidor MySQL y si no lo encuentra, intetará crear uno como si fuera llamado mysql_connect() sin argumentos

Ver tambiénmysql_connect().

Por razones de compatibilidad puede usarse mysql() igualmente.

Anterior | Inicio | Siguiente
mysql_data_seek | Subir | mysql_drop_db


mysql_drop_db

(PHP 3, PHP 4 >= 4.0.0)

mysql_drop_db -- Borra una base de datos MySQL

Descripción

int mysql_drop_db ( string base_de_datos [, int identificador_de_enlace])

Devuelve: verdadero si éxito, falso si error.

mysql_drop_db() intenta suprimir una base de datos completa del servidor asociado al identificador de enlace.

Ver también: mysql_create_db(). Por razones de compatibilidad puede usarse mysql_dropdb() igualmente.

Anterior | Inicio | Siguiente
mysql_db_query | Subir | mysql_errno


mysql_errno

(PHP 3, PHP 4 >= 4.0.0)

mysql_errno -- Deuelve el número del mensaje de error de la última operación MySQL

Descripción

int mysql_errno ( [int identificador_de_enlace])

Los errores devueltos por mySQL no indican los warnings. Usar estas funciones para encontrar el número de error.

<?php
mysql_connect("marliesle");
echo mysql_errno().": ".mysql_error()."<BR>";
mysql_select_db("nonexistentdb");
echo mysql_errno().": ".mysql_error()."<BR>";
$conn = mysql_query("SELECT * FROM nonexistenttable");
echo mysql_errno().": ".mysql_error()."<BR>";
?>

Ver también: mysql_error()

Anterior | Inicio | Siguiente
mysql_drop_db | Subir | mysql_error


mysql_error

(PHP 3, PHP 4 >= 4.0.0)

mysql_error -- Devuelve el texto del mensaje de error de la última operación MySQL

Descripción

string mysql_error ( [int identificador_de_enlace])

Los errores devueltos por mySQL no indican los warnings. Usar estas funciones para encontrar el número de error.

<?php
mysql_connect("marliesle");
echo mysql_errno().": ".mysql_error()."<BR>";
mysql_select_db("nonexistentdb");
echo mysql_errno().": ".mysql_error()."<BR>";
$conn = mysql_query("SELECT * FROM nonexistenttable");
echo mysql_errno().": ".mysql_error()."<BR>";
?>

Ver también: mysql_errno()

Anterior | Inicio | Siguiente
mysql_errno | Subir | mysql_fetch_array


mysql_fetch_array

(PHP 3, PHP 4 >= 4.0.0)

mysql_fetch_array -- Extrae la fila de resultado como una matriz asociativa

Descripción

array mysql_fetch_array ( int id_resultado [, int tipo_de_resultado])

Devuelve una matriz que corresponde a la sentencia extraida, o falso si no quedan más filas.

mysql_fetch_array() es una versión extendida de mysql_fetch_row(). Además de guardar los datos en el indice numerico de la matriz, guarda también los datos en los indices asociativos, usando el nombre de campo como clave.

Si dos o más columnas del resultado tienen el mismo nombre de campo, la última columna toma la prioridad. Para acceder a la(s) otra(s) columna(s) con el mismo nombre, se debe escificar el indice numerico o definir un alias para la columna.

select t1.f1 as foo t2.f1 as bar from t1, t2

La función mysql_fetch_array() no es significativemente mas lenta que mysql_fetch_row(), sin embargo tiene un valor añadido importante.

El segundo argumento opcional tipo_de_resultado en mysql_fetch_array() es una constante y puede tomar los valores siguientes: MYSQL_ASSOC, MYSQL_NUM, y MYSQL_BOTH. (Esta funcionalidad fue añadida en PHP 3.0.7)

Para más detalles, ver también mysql_fetch_row().

Ejemplo 1. mysql fetch array

<?php
mysql_connect($host,$user,$password);
$result = mysql_db_query("database","select * from table");
while($row = mysql_fetch_array($result)) {
    echo $row["user_id"];
    echo $row["fullname"];
}
mysql_free_result($result);
?>

Anterior | Inicio | Siguiente
mysql_error | Subir | mysql_fetch_field


mysql_fetch_field

(PHP 3, PHP 4 >= 4.0.0)

mysql_fetch_field -- Extrae la información de una columna y la devuelve como un objeto.

Descripción

object mysql_fetch_field ( int id_resultado [, int salto])

Devuelve un objeto que contiene la información del campo.

Puede usarse mysql_fetch_field() para obtener información sobre campos en un resultado. Si no se especifica el salto, se extrae el siguiente campo que todavia no ha sido extraido. con mysql_fetch_field().

Las propiedades del objeto son:

  • name - nombre de la columna

  • table - name de la tabla a la que pertenece la columna

  • max_length - longitud máxima de la columna

  • not_null - 1 si la columna no puede contener un valor nulo

  • primary_key - 1 si la columna es clave primaria

  • unique_key - 1 si la columna es clave unica

  • multiple_key - 1 si la columna es clave no unica

  • numeric - 1 si la columna es numerica

  • blob - 1 si la columna es un BLOB

  • type - el tipo de la columna

  • unsigned - 1 si la columna es unsigned

  • zerofill - 1 si la columna es zero-filled

Ver también mysql_field_seek()

Anterior | Inicio | Siguiente
mysql_fetch_array | Subir | mysql_fetch_lengths


mysql_fetch_lengths

(PHP 3, PHP 4 >= 4.0.0)

mysql_fetch_lengths -- Devuelve la longitud de cada salida en un resultado

Descripción

array mysql_fetch_lengths ( int id_resultado)

Devuelve: Una matriz que contiene las longitudes de cada campo de la última fila extraida por mysql_fetch_row(), o falso si error.

mysql_fetch_lengths() almacena las longitudes de cada columna en la última fila devuelta por mysql_fetch_row(), mysql_fetch_array(), y mysql_fetch_object() en una matriz, empezando por 0.

Ver también: mysql_fetch_row().

Anterior | Inicio | Siguiente
mysql_fetch_field | Subir | mysql_fetch_object


mysql_fetch_object

(PHP 3, PHP 4 >= 4.0.0)

mysql_fetch_object -- Extrae una fila de resultado como un objeto

Descripción

object mysql_fetch_object ( int id_resultado [, int tipo_de_resultado])

Devuelve un objeto con las propiedades aur corresponden a la última fila extraida, o falso si no quedan más filas.

mysql_fetch_object() es similar a mysql_fetch_array(), con la diferencia que un objeto es devuelto en lugar de una matriz. Indirectamente, quiere decir que solo se puede aceder a los datos por el nombre del campo, y no por su posición.

El argumento opcional tipo_de_resultado es una constante y puede tomar los valores siguientes: MYSQL_ASSOC, MYSQL_NUM, y MYSQL_BOTH.

La función es identica a mysql_fetch_array(), y casi tan rápida como mysql_fetch_row() (la diferencia es insignificante).

Ejemplo 1. mysql fetch object

<?php
mysql_connect($host,$user,$password);
$result = mysql_db_query("database","select * from table");
while($row = mysql_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
mysql_free_result($result);
?>

Ver también: mysql_fetch_array() y mysql_fetch_row().

Anterior | Inicio | Siguiente
mysql_fetch_lengths | Subir | mysql_fetch_row


mysql_fetch_row

(PHP 3, PHP 4 >= 4.0.0)

mysql_fetch_row -- Devuelve una fila de resultado como matriz

Descripción

array mysql_fetch_row ( int id_resultado)

Devuelve: Una matriz que corresponde a la fila selecionada, o falso si no quedan más lineas.

mysql_fetch_row() seleciona una fila de datos del resultado asociado al identificador de resultado especificado. La fila es devuelta como una matriz. Cada columna del resultdo es guardada en un offset de la matriz, empezando por el offset 0.

La llamada a mysql_fetch_row() debería devolver la próxima fila del resultado, o falso si no quedan más filas.

Ver también: mysql_fetch_array(),
mysql_fetch_object(),
mysql_data_seek(),
mysql_fetch_lengths(), and
mysql_result().

Anterior | Inicio | Siguiente
mysql_fetch_object | Subir | mysql_field_flags


mysql_field_name

(PHP 3, PHP 4 >= 4.0.0)

mysql_field_name -- Devuelve el nombre del campo especificado en un resultado

Descripción

string mysql_field_name ( int id_resultado, int indice_del_campo)

mysql_field_name() devuelve el nombre del campo especificado. Los argumentos de la función son el identificador de resultado y el indice del campo. Por ejemplo: mysql_field_name($result,2);

Devolverá el nombre del segundo campo asociado al identificador de resultado.

Por razones de compatibilidad puede usarse tambien mysql_fieldname().

Anterior | Inicio | Siguiente
mysql_field_len | Subir | mysql_field_seek


mysql_field_seek

(PHP 3, PHP 4 >= 4.0.0)

mysql_field_seek -- Asigna el puntero del resultado al offset del campo especificado

Descripción

int mysql_field_seek ( int id_resultado, int offset_del_campo)

Busca el offset del campo especificado. Si la próxima llamada a mysql_fetch_field() no incluye un offset de campo, se devolverá ese campo.

Ver también: mysql_fetch_field().

Anterior | Inicio | Siguiente
mysql_field_name | Subir | mysql_field_table


mysql_field_table

(PHP 3, PHP 4 >= 4.0.0)

mysql_field_table -- Devuelve el nombre de la tabla donde esta el campo especificado

Descripción

string mysql_field_table ( int id_resultado, int offset_del_campo)

Devuelve el nombre de la tabla del campo. Por razones de compatibilidad puede usarse tambien mysql_fieldtable().

Anterior | Inicio | Siguiente
mysql_field_seek | Subir | mysql_field_type


mysql_field_type

(PHP 3, PHP 4 >= 4.0.0)

mysql_field_type -- Devuelve el tipo del campo especificado en un resultado

Descripción

string mysql_field_type ( int id_resultado, int offset_del_campo)

mysql_field_type() es similar a la función mysql_field_name(). Los argumentos son identicos, pero se devuelve el tipo de campo. El tipo sera "int", "real", "string", "blob", o otros detallados en la documentación de MySQL.

Ejemplo 1. mysql field types

<?php
mysql_connect("localhost:3306");
mysql_select_db("wisconsin");
$result = mysql_query("SELECT * FROM onek");
$fields = mysql_num_fields($result);
$rows   = mysql_num_rows($result);
$i = 0;
$table = mysql_field_table($result, $i);
echo "Your '".$table."' table has ".$fields." fields and ".$rows." records <BR>";
echo "The table has the following fields <BR>";
while ($i < $fields) {
    $type  = mysql_field_type  ($result, $i);
    $name  = mysql_field_name  ($result, $i);
    $len   = mysql_field_len   ($result, $i);
    $flags = mysql_field_flags ($result, $i);
    echo $type." ".$name." ".$len." ".$flags."<BR>";
    $i++;
}
mysql_close();
?>

Por razones de compatibilidad puede usarse tambien mysql_fieldtype().

Anterior | Inicio | Siguiente
mysql_field_table | Subir | mysql_free_result


mysql_field_flags

(PHP 3, PHP 4 >= 4.0.0)

mysql_field_flags -- Devuelve los flags asociados con el campo especificado en un resultado

Descripción

string mysql_field_flags ( int id_resultado, int offset_del_campo)

mysql_field_flags() devuelve los flags del campo especificado. Cada flag es devuelto como una palabra y estan separados un unico espacio, se puede dividir el resultado devuelto utilizando explode().

Los siguientes flags pueden ser devueltos si tu versión de MySQL los soporta: "not_null", "primary_key", "unique_key", "multiple_key", "blob", "unsigned", "zerofill", "binary", "enum", "auto_increment", "timestamp".

Por razones de compatibilidad puede usarse tambien mysql_fieldflags().

Anterior | Inicio | Siguiente
mysql_fetch_row | Subir | mysql_field_len


mysql_field_len

(PHP 3, PHP 4 >= 4.0.0)

mysql_field_len -- Devuelve la longitud del campo especificado

Descripción

int mysql_field_len ( int id_resultado, int offset_del_campo)

mysql_field_len() devuelve la longitud del campo especificado. Por razones de compatibilidad puede usarse tambien mysql_fieldlen().

Anterior | Inicio | Siguiente
mysql_field_flags | Subir | mysql_field_name


mysql_free_result

(PHP 3, PHP 4 >= 4.0.0)

mysql_free_result -- Libera la memoria del resultado

Descripción

int mysql_free_result ( int id_resultado)

mysql_free_result() solo necesita ser llamada si te preocupa usar demasiado memoria durante la ejecución de tu script. Toda la memoria del resultado especificado en el parametro del identificador de resultado sera automaticamente liberada.

Por razones de compatibilidad puede usarse tambien mysql_freeresult().

Anterior | Inicio | Siguiente
mysql_field_type | Subir | mysql_insert_id


mysql_insert_id

(PHP 3, PHP 4 >= 4.0.0)

mysql_insert_id -- Devuelve el identificador generado en la última llamada a INSERT

Descripción

int mysql_insert_id ( [int identificador_de_enlace])

mysql_insert_id() devuelve el identificador generado para un campo de tipo AUTO_INCREMENTED. Se devolvera el identificador genrado por el último INSERT para el identificador_de_enlace. Si no se especifica el identificador_de_enlace, se asume por defecto el último enlace abierto.

Anterior | Inicio | Siguiente
mysql_free_result | Subir | mysql_list_dbs


mysql_list_fields

(PHP 3, PHP 4 >= 4.0.0)

mysql_list_fields -- Lista los campos del resultado de MySQL

Descripción

int mysql_list_fields ( string base_de_datos, string tabla [, int identificador_de_enlace])

mysql_list_fields() lista información
sobre la tabla. Los argumentos son la base de datos y el nombre de
la tabla. Se devuelve un puntero que puede ser usado por las
funciónes mysql_field_flags(),
mysql_field_len(),
mysql_field_name(), y
mysql_field_type().

Un identificador de resultado es un entero positivo. La función devuelve -1 si se produce un error. Una cadena de caracteres describiendo el error sera introducida en $phperrmsg, y a menos que la función sea llamada como @mysql() el literal del error tambien sera impreso.

Por razones de compatibilidad puede usarse tambien mysql_listfields().

Anterior | Inicio | Siguiente
mysql_list_dbs | Subir | mysql_list_tables


mysql_list_dbs

(PHP 3, PHP 4 >= 4.0.0)

mysql_list_dbs -- Lista las bases de datos disponibles en el servidor MySQL

Descripción

int mysql_list_dbs ( [int identificador_de_enlace])

mysql_list_dbs() devuelve un puntero de resultado que contiene las bases disponibles en el actual demonio mysql. Utiliza la función mysql_tablename() para explotar el puntero de resultado.

Por razones de compatibilidad puede usarse tambien mysql_listdbs().

Anterior | Inicio | Siguiente
mysql_insert_id | Subir | mysql_list_fields


mysql_list_tables

(PHP 3, PHP 4 >= 4.0.0)

mysql_list_tables -- Lista las tablas en una base de datos MySQL

Descripción

int mysql_list_tables ( string base_de_datos [, int identificador_de_enlace])

mysql_list_tables() toma el nombre de la base y devuelve un puntero de resultado como la función mysql_db_query(). La función mysql_tablename() debe ser usada para extraer los nombres de las tablas del puntero.

Por razones de compatibilidad puede usarse tambien mysql_listtables(). can also be used.

Anterior | Inicio | Siguiente
mysql_list_fields | Subir | mysql_num_fields


mysql_num_fields

(PHP 3, PHP 4 >= 4.0.0)

mysql_num_fields -- devuelve el numero de campos de un resultado

Descripción

int mysql_num_fields ( int id_resultado)

mysql_num_fields() devuelve el numero de campos de un identificador de resultado.

Ver también:
mysql_db_query(),
mysql_query(),
mysql_fetch_field(),
mysql_num_rows().

Por razones de compatibilidad puede usarse tambien mysql_numfields().

Anterior | Inicio | Siguiente
mysql_list_tables | Subir | mysql_num_rows


mysql_num_rows

(PHP 3, PHP 4 >= 4.0.0)

mysql_num_rows -- Devuelve el numero de filas de un resultado

Descripción

int mysql_num_rows ( int id_resultado)

mysql_num_rows() Devuelve el numero de filas de un identificador de resultado.

Ver también:
mysql_db_query(),
mysql_query() and,
mysql_fetch_row().

Por razones de compatibilidad puede usarse tambien mysql_numrows().

Anterior | Inicio | Siguiente
mysql_num_fields | Subir | mysql_pconnect


mysql_pconnect

(PHP 3, PHP 4 >= 4.0.0)

mysql_pconnect -- Abre una conexión persistente al servidor MySQL

Descripción

int mysql_pconnect ( [string server [, string usuario [, string password]]])

Devuelve: un identificador de enlace persistente, o falso si se produce un error.

mysql_pconnect() establece una conexión a un servidor MySQL. Todos los argumentos son opcionales, y si no existen, se asumen los valores por defecto ('localhost', nombre del usuario propietario del proceso, password vacia).

El hostname puede incluir un numero de puerto. ej. "hostname:port" o un camino al socket ej. ":/camino/al/socket" para el puerto para el host local.

Nota: Soporte para ":puerto" fue añadido en 3.0B4.

Soporte para ":/camino/al/socket" fue añadido en 3.0.10.

mysql_pconnect() actua como mysql_connect() con dos diferencias fundamentales.

Primero, durante la conexión, la función intenta primero encontrar un enlace persistente abierto con el mismo host, usuario y password. Si lo encuentra, devuelve el identificador de enlace en lugar de abrir otra conexión.

Segundo, la conexión no sera cerrado cuando acabe la ejecución del script. El enlace permanecera abierta para ser usado en el futuro (mysql_close() will not cierra el enlace establecido con mysql_pconnect()).

Este tipo de enlaces son llamados 'persistentes'.

Anterior | Inicio | Siguiente
mysql_num_rows | Subir | mysql_query


mysql_query

(PHP 3, PHP 4 >= 4.0.0)

mysql_query -- Envia una sentencia SQL a MySQL

Descripción

int mysql_query ( string sentencia [, int identificador_de_enlace])

mysql_query() envia una sentencia a la base activa en el servidor asociado al identificador de enlace. Si no es especificado un identificador_de_enlace, se asumira el ultilmo enlace abierto. Si no hay ningun enlace abierto, la función intenta estalecer un enlace como si se llamara función mysql_connect() sin argumentos, y lo utiliza.

La sentencia no puede terminar por punto y coma.

mysql_query() devuelve TRUE (no-cero) o FALSE para indicar si la sentencia se ha ejecutado correctamente o no. Un valor TRUE significa que la sentencia era correcta y pudo ser ejecutada en el servidor. No indica nada sobre el numero de fila devueltas. Es perfectamente posible que la sentencia se ejecute correctamente pero que no devuelve ninguna fila.

La siguiente sentencia es invalida sintacticamente, asi que mysql_query() falla y devuelve FALSE:

Ejemplo 1. mysql_query()

<?php
$result = mysql_query ("SELECT * WHERE 1=1")
    or die ("Invalid query");
?>

La siguiente sentencia es invalida semanticamente si my_col no es una columna de la tabla my_tbl, asi que mysql_query() falla y devuelve FALSE:

Ejemplo 2. mysql_query()

<?php
$result = mysql_query ("SELECT my_col FROM my_tbl")
    or die ("Invalid query");
?>

mysql_query() fallara tambien y devolvera FALSE si no se tiene el permiso de acceso a la tabla especificada en la sentencia.

Asumiendo la sentencia tenga exito, se puede llamar a mysql_affected_rows() para saber cuantas filas fueron afectadas (para DELETE, INSERT, REPLACE, o UPDATE ) Para las sentencias SELECT, mysql_query() devuelve un nuevo identificador de resultado que se puede pasar a mysql_result(). Cuando se acabe de utilizar el resultado, se pueden liberar los recursos asociados utilizando mysql_free_result().

Ver también: mysql_affected_rows(),
mysql_db_query(),
mysql_free_result(),
mysql_result(),
mysql_select_db(), and
mysql_connect().

Anterior | Inicio | Siguiente
mysql_pconnect | Subir | mysql_result


mysql_result

(PHP 3, PHP 4 >= 4.0.0)

mysql_result -- Devuelve datos de un resultado

Descripción

int mysql_result ( int id_resultado, int numero_de_fila [, mixed campo])

mysql_result() devuelve el contenido de una celda de un resultado MySQL. El campo argumento puede ser el nombre del campo o el offset o tabla.nombre_del_campo. Si el nombre de la columna tiene un alias ('select foo as bar from...'), utilice el alias en lugar del nombre de la columna.

Cuando se trabaja un un gran resultado, debe considerarse la utilizacion de una funcion que devuelva una fila entera ya que estas funciones son MUCHO mas rapidas que mysql_result(). Tambien, especificando un offset numerico en lugar del nombre del campo, la ejecucion sera mas rapida.

Las llamadas a mysql_result() no deben mezclarse con llamadas a las otras sentencias que trabajan con un identificador de resultado.

Alternativas recomendadas:
mysql_fetch_row(),
mysql_fetch_array(), y
mysql_fetch_object().

Anterior | Inicio | Siguiente
mysql_query | Subir | mysql_select_db


mysql_select_db

(PHP 3, PHP 4 >= 4.0.0)

mysql_select_db -- Selecciona un base de datos MySQL

Descripción

int mysql_select_db ( string base_de_datos [, int identificador_de_enlace])

Devuelve : TRUE si exito, FALSE si error.

mysql_select_db() establece la base activa que estara asociada con el identificador de enlace especificado. Si no se especifica un identificador de enlace, se asume el ultimo enlace abierto. Si no hay ningun enlace abierto, la función intentara establecer un enlace como si se llamara a mysql_connect().

Toda llamada posterior a mysql_query() utilizara la base activada.

Ver también:
    mysql_connect(),
    mysql_pconnect(), and
    mysql_query().

Por razones de compatibilidad puede usarse tambien mysql_selectdb().

Anterior | Inicio | Siguiente
mysql_result | Subir | mysql_tablename


mysql_tablename

(PHP 3, PHP 4 >= 4.0.0)

mysql_tablename -- Devuelve el nombre de la tabla de un campo

Descripción

string mysql_tablename ( int id_resultado, int i)

mysql_tablename() toma un puntero de resultado devuelto por mysql_list_tables() asi como un indice (integer) y devuelve el nomnre de una tabla. Se puede usar la función mysql_num_rows() para determinar el nombre de tablas en el puntero de resultado.

Ejemplo 1. mysql_tablename() Example

<?php
mysql_connect ("localhost:3306");
$result = mysql_list_tables ("wisconsin");
$i = 0;
while ($i < mysql_num_rows ($result)) {
    $tb_names[$i] = mysql_tablename ($result, $i);
    echo $tb_names[$i] . "<BR>";
    $i++;
}
?>

Anterior | Inicio | Siguiente
mysql_select_db | Subir | Mohawk Software session handler functions


Mohawk Software session handler functions

Manual de PHP
Anterior Siguiente

LXII. Mohawk Software session handler functions

msession is an interface to a high speed session daemon which can run either locally or remotely. It is designed to provide consistent session management for a PHP web farm.

The session server software can be found at http://www.mohawksoft.com/phoenix/.

Tabla de contenidos
msession_connect — Connect to msession server
msession_disconnect — Close connection to msession server
msession_count — Get session count
msession_create — Create a session
msession_destroy — Destroy a session
msession_lock — Lock a session
msession_unlock — Unlock a session
msession_set — Set value in session
msession_get — Get value from session
msession_uniq — Get uniq id
msession_randstr — Get random string
msession_find — Find value
msession_list — List ... ?
msession_get_array — Get array of ... ?
msession_set_array — Set array of ...
msession_listvar — List sessions with variable
msession_timeout — Set/get session timeout
msession_inc — Increment value in session
msession_getdata — Get data ... ?
msession_setdata — Set data ... ?
msession_plugin — Call an escape function within the msession personality plugin

Anterior | Inicio | Siguiente
mysql_tablename | Subir | msession_connect


msession_connect

(PHP 4 >= 4.2.0)

msession_connect -- Connect to msession server

Description

bool msession_connect ( string host, string port)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
Mohawk Software session handler functions | Subir | msession_disconnect


msession_disconnect

(PHP 4 >= 4.2.0)

msession_disconnect -- Close connection to msession server

Description

void msession_disconnect ( void)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_connect | Subir | msession_count


msession_count

(PHP 4 >= 4.2.0)

msession_count -- Get session count

Description

int msession_count ( void)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_disconnect | Subir | msession_create


msession_create

(PHP 4 >= 4.2.0)

msession_create -- Create a session

Description

bool msession_create ( string session)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_count | Subir | msession_destroy


msession_destroy

(PHP 4 >= 4.2.0)

msession_destroy -- Destroy a session

Description

bool msession_destroy ( string name)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_create | Subir | msession_lock


msession_lock

(PHP 4 >= 4.2.0)

msession_lock -- Lock a session

Description

int msession_lock ( string name)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_destroy | Subir | msession_unlock


msession_unlock

(PHP 4 >= 4.2.0)

msession_unlock -- Unlock a session

Description

int msession_unlock ( string session, int key)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_lock | Subir | msession_set


msession_set

(PHP 4 >= 4.2.0)

msession_set -- Set value in session

Description

bool msession_set ( string session, string name, string value)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_unlock | Subir | msession_get


msession_get

(PHP 4 >= 4.2.0)

msession_get -- Get value from session

Description

string msession_get ( string session, string name, string value)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_set | Subir | msession_uniq


msession_uniq

(PHP 4 >= 4.2.0)

msession_uniq -- Get uniq id

Description

string msession_uniq ( int param)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_get | Subir | msession_randstr


msession_randstr

(PHP 4 >= 4.2.0)

msession_randstr -- Get random string

Description

string msession_randstr ( int param)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_uniq | Subir | msession_find


msession_find

(PHP 4 >= 4.2.0)

msession_find -- Find value

Description

array msession_find ( string name, string value)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_randstr | Subir | msession_list


msession_list

(PHP 4 >= 4.2.0)

msession_list -- List ... ?

Description

array msession_list ( void)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_find | Subir | msession_get_array


msession_get_array

(PHP 4 >= 4.2.0)

msession_get_array -- Get array of ... ?

Description

array msession_get_array ( string session)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_list | Subir | msession_set_array


msession_set_array

(PHP 4 >= 4.2.0)

msession_set_array -- Set array of ...

Description

bool msession_set_array ( string session, array tuples)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_get_array | Subir | msession_listvar


msession_listvar

(PHP 4 >= 4.2.0)

msession_listvar -- List sessions with variable

Description

array msession_listvar ( string name)

Returns an associative array of value, session for all sessions with a variable named name.

Used for searching sessions with common attributes.

Anterior | Inicio | Siguiente
msession_set_array | Subir | msession_timeout


msession_timeout

(PHP 4 >= 4.2.0)

msession_timeout -- Set/get session timeout

Description

int msession_timeout ( string session [, int param])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_listvar | Subir | msession_inc


msession_inc

(PHP 4 >= 4.2.0)

msession_inc -- Increment value in session

Description

string msession_inc ( string session, string name)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_timeout | Subir | msession_getdata


msession_getdata

(unknown)

msession_getdata -- Get data ... ?

Description

string msession_getdata ( string session)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_inc | Subir | msession_setdata


msession_setdata

(unknown)

msession_setdata -- Set data ... ?

Description

bool msession_setdata ( string session, string value)

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_getdata | Subir | msession_plugin


msession_plugin

(PHP 4 >= 4.2.0)

msession_plugin -- Call an escape function within the msession personality plugin

Description

string msession_plugin ( string session, string val [, string param])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
msession_setdata | Subir | muscat functions


muscat functions

Manual de PHP
Anterior Siguiente

LXIII. muscat functions

Tabla de contenidos
muscat_setup — Creates a new muscat session and returns the handle. Size is the ammount of memory in bytes to allocate for muscat muscat_dir is the muscat installation dir e.g. "/usr/local/empower", it defaults to the compile time muscat directory
muscat_setup_net — Creates a new muscat session and returns the handle. muscat_host is the hostname to connect to port is the port number to connect to - actually takes exactly the same args as fsockopen
muscat_give — Sends string to the core muscat api
muscat_get — Gets a line back from the core muscat api. Returns a literal FALSE when there is no more to get (as opposed to ""). Use === FALSE or !== FALSE to check for this
muscat_close — Shuts down the muscat session and releases any memory back to php. [Not back to the system, note!]

Anterior | Inicio | Siguiente
msession_plugin | Subir | muscat_setup


muscat_setup

(4.0.5 - 4.2.0 only)

muscat_setup -- Creates a new muscat session and returns the handle. Size is the ammount of memory in bytes to allocate for muscat muscat_dir is the muscat installation dir e.g. "/usr/local/empower", it defaults to the compile time muscat directory

Description

resource muscat_setup ( int size [, string muscat_dir])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
muscat functions | Subir | muscat_setup_net


muscat_setup_net

(4.0.5 - 4.2.0 only)

muscat_setup_net -- Creates a new muscat session and returns the handle. muscat_host is the hostname to connect to port is the port number to connect to - actually takes exactly the same args as fsockopen

Description

resource muscat_setup_net ( string muscat_host, int port)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
muscat_setup | Subir | muscat_give


muscat_give

(4.0.5 - 4.2.0 only)

muscat_give -- Sends string to the core muscat api

Description

int muscat_give ( resource muscat_handle, string string)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
muscat_setup_net | Subir | muscat_get


muscat_get

(4.0.5 - 4.2.0 only)

muscat_get -- Gets a line back from the core muscat api. Returns a literal FALSE when there is no more to get (as opposed to ""). Use === FALSE or !== FALSE to check for this

Description

string muscat_get ( resource muscat_handle)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
muscat_give | Subir | muscat_close


muscat_close

(4.0.5 - 4.2.0 only)

muscat_close -- Shuts down the muscat session and releases any memory back to php. [Not back to the system, note!]

Description

int muscat_close ( resource muscat_handle)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
muscat_get | Subir | Funciones de Red


Funciones de Red

Manual de PHP
Anterior Siguiente

LXIV. Funciones de Red

Tabla de contenidos
checkdnsrr — Comprueba registros DNS correspondientes a nombres de máquinas en Internet o direcciones IP.
closelog — cierra la conexión con el logger del sistema
debugger_off — deshabilita el depurador interno de PHP
debugger_on — habilita el depurador interno de PHP
fsockopen — Abre una conexión de dominio Internet o Unix via sockets.
gethostbyaddr — Obtiene el nombre de una máquina en Internet mediante su dirección IP.
gethostbyname — Obtiene la dirección IP correspondiente al nombre de una máquina conectada a Internet.
gethostbynamel — Obtiene una lista de direcciones IP correspondientea a los nombres de máquinas conectadas a Internet.
getmxrr — Obtiene registros MX correspondientes a una máquina conectada a Internet.
getprotobyname — Obtiene el n£mero asociado al nombre del protocolo
getprotobynumber — obtiene el nombre asociado al n£mero de protocolo
getservbyname — obtiene el n£mero del puerto asociado al servicio Internet especificado
getservbyport — obtiene el servicio Internet que correspondiente al puerto del protocolo especificado
openlog — abre una conexión con el logger del sistema
pfsockopen — Abre conexiones persistentes de dominio Internet o Unix.
set_socket_blocking — Set blocking/non-blocking modo de un socket
syslog — genera un mensaje de sistema

Anterior | Inicio | Siguiente
muscat_close | Subir | checkdnsrr


checkdnsrr

(PHP 3, PHP 4 >= 4.0.0)

checkdnsrr -- Comprueba registros DNS correspondientes a nombres de máquinas en Internet o direcciones IP.

Descripción

int checkdnsrr ( string host [, string type])

Busca en DNS entradas del tipo type correspondientes a host. Devuelve verdadero si encuentra algún registro; devuelve falso si no encuentra ninguno o sucedió algún error.

type puede ser: A, MX, NS, SOA, PTR, CNAME, o ANY. Por defecto es MX.

host puede ser o la dirección IP de la forma xxxx.xxxx.xxxx.xxxx o el nombre de la máquina.

Ver también
getmxrr(),
gethostbyaddr(),
gethostbyname(),
gethostbynamel(), y
 named(8) en las páginas del manual.

Anterior | Inicio | Siguiente
Funciones de Red | Subir | closelog


closelog

(PHP 3, PHP 4 >= 4.0.0)

closelog -- cierra la conexión con el logger del sistema

Descripción

int closelog ( void)

closelog() cierra el descriptor que se está usando para escribir en el logger del sistema. El uso de closelog() es opcional.

Anterior | Inicio | Siguiente
checkdnsrr | Subir | debugger_off


debugger_off

(PHP 3)

debugger_off -- deshabilita el depurador interno de PHP

Descripción

int debugger_off ( void)

Deshabilita el depurador interno de PHP. El depurador está aún en desarrollo.

Anterior | Inicio | Siguiente
closelog | Subir | debugger_on


debugger_on

(PHP 3)

debugger_on -- habilita el depurador interno de PHP

Descripción

int debugger_on ( string address)

Habilita el depurador interno de PHP, conectándolo a address. El depurador esta aún en desarrollo.

Anterior | Inicio | Siguiente
debugger_off | Subir | fsockopen


fsockopen

(PHP 3, PHP 4 >= 4.0.0)

fsockopen -- Abre una conexión de dominio Internet o Unix via sockets.

Descripción

int fsockopen ( string hostname, int port [, int errno [, string errstr [, double timeout]]])

Inicia una conexión de dominio Internet (AF_INET) o Unix (AF_UNIX). Para el domino Internet, abrirá una conexión TCP hacia el ordenador hostname en el puerto port. Para el dominio Unix, hostname se usará como ruta al socket, port debe ser 0 para este caso. El parámetro opcional timeout se puede usar para especificar un timeout en segundos para establecer la conexión.

fsockopen() devuelve un puntero a fichero, el cual
se puede usar junto con las otras funciones de ficheros (como
fgets(), fgetss(),
fputs(), fclose(),
feof()).

Si la llamada falla, esta devolverá falso y si los parámetros opcionales errno y errstr están presentes, indicarán el error del sistema que ocurrió en la llamada connect(). Si errno es 0 y la función devolviá falso, nos indica que el error ocurrió antes de la llamada connect(). Esto es debido principalmente a problemas inicializando el socket. Observe que los argumentos errno y errstr deben ser pasados por referencia.

Dependiendo del entorno, el dominio Unix o el parámetro opcional, timeout puede no estar disponible.

Por defecto, el socket será abierto en modo de bloqueo. Puede cambiarlo a modo de no bloqueo usando set_socket_blocking().

Ejemplo 1. ejemplo con fsockopen

$fp = fsockopen("www.php.net", 80, &$errno, &$errstr, 30);
if(!$fp) {
    echo "$errstr ($errno)<br>\n";
} else {
    fputs($fp,"GET / HTTP/1.0\n\n");
    while(!feof($fp)) {
        echo fgets($fp,128);
    }
    fclose($fp);
}
Ver también: pfsockopen()

Anterior | Inicio | Siguiente
debugger_on | Subir | gethostbyaddr


gethostbyaddr

(PHP 3, PHP 4 >= 4.0.0)

gethostbyaddr -- Obtiene el nombre de una máquina en Internet mediante su dirección IP.

Descripción

string gethostbyaddr ( string ip_address)

Devuelve el nombre del ordenador conectado a Internet espeficado por el parámetro ip_address. Si ocurre un error, devuelve ip_address.

Ver también gethostbyname().

Anterior | Inicio | Siguiente
fsockopen | Subir | gethostbyname


gethostbyname

(PHP 3, PHP 4 >= 4.0.0)

gethostbyname -- Obtiene la dirección IP correspondiente al nombre de una máquina conectada a Internet.

Descripción

string gethostbyname ( string hostname)

Devuelve la dirección IP de una máquina conectada a Internet especificada por hostname.

Ver también gethostbyaddr().

Anterior | Inicio | Siguiente
gethostbyaddr | Subir | gethostbynamel


gethostbynamel

(PHP 3, PHP 4 >= 4.0.0)

gethostbynamel -- Obtiene una lista de direcciones IP correspondientea a los nombres de máquinas conectadas a Internet.

Descripción

array gethostbynamel ( string hostname)

Devuleve una lista de direcciones IP pertenecientes a ordenadores especificados por hostname.

Ver también
gethostbyname(),
gethostbyaddr(),
checkdnsrr(),
getmxrr(), y
named(8) en las páginas del manual.

Anterior | Inicio | Siguiente
gethostbyname | Subir | getmxrr


getmxrr

(PHP 3, PHP 4 >= 4.0.0)

getmxrr -- Obtiene registros MX correspondientes a una máquina conectada a Internet.

Descripción

int getmxrr ( string hostname, array mxhosts [, array weight])

Busca DNS de registros MX correspondientes a hostname. Devuelve verdadero si encuentra alg£n registro; devuelve falso si no encuentra ninguno o se produce un error.

La lista de registros MX encontrados se colocan en el array mxhosts. Si se proporciona el array weight, se rellenará con la información obtenida.

Ver también
checkdnsrr(),
gethostbyname(),
gethostbynamel(),
gethostbyaddr(), y
 named(8) de las páginas del manual.

Anterior | Inicio | Siguiente
gethostbynamel | Subir | getprotobyname


getprotobyname

(PHP 4 >= 4.0.0)

getprotobyname -- Obtiene el n£mero asociado al nombre del protocolo

Descripción

int getprotobyname ( string name)

getprotobyname() devuelve el n£mero asociado al nombre del protocolo name del fichero /etc/protocols. Ver también getprotobynumber().

Anterior | Inicio | Siguiente
getmxrr | Subir | getprotobynumber


getprotobynumber

(PHP 4 >= 4.0.0)

getprotobynumber -- obtiene el nombre asociado al n£mero de protocolo

Descripción

string getprotobynumber ( int number)

getprotobynumber() devuelve el nombre del protocolo asociado al number del protocolo en el fichero /etc/protocols. Ver también getprotobyname().

Anterior | Inicio | Siguiente
getprotobyname | Subir | getservbyname


getservbyname

(PHP 4 >= 4.0.0)

getservbyname -- obtiene el n£mero del puerto asociado al servicio Internet especificado

Descripción

int getservbyname ( string service, string protocol)

getservbyname() devuelve el puerto que corresponde al service especificado por el protocol en /etc/services. protocol puede ser tcp o udp. Ver también getservbyport().

Anterior | Inicio | Siguiente
getprotobynumber | Subir | getservbyport


getservbyport

(PHP 4 >= 4.0.0)

getservbyport -- obtiene el servicio Internet que correspondiente al puerto del protocolo especificado

Descripción

string getservbyport ( int port, string protocol)

getservbyport() delvuelve el servicio Internet asociado al port para el protocol especificado en /etc/services. protocol puede ser tcp o udp. Ver también getservbyname().

Anterior | Inicio | Siguiente
getservbyname | Subir | openlog


openlog

(PHP 3, PHP 4 >= 4.0.0)

openlog -- abre una conexión con el logger del sistema

Descripción

int openlog ( string ident, int option, int facility)

openlog() abre una conexión con el logger del sistema. La cadena ident se a¤ade a cada mensaje. Los valores de option y facility se exponen en la siguiente sección. El uso de openlog() is opcional; Esta será llamada automaticamente por syslog() si fuera necesario, en este caso ident valdrá por defecto FALSE. Ver también syslog() y closelog().

Anterior | Inicio | Siguiente
getservbyport | Subir | pfsockopen


pfsockopen

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

pfsockopen -- Abre conexiones persistentes de dominio Internet o Unix.

Descripción

int pfsockopen ( string hostname, int port [, int errno [, string errstr [, int timeout]]])

Esta función se comporta exactamente como fsockopen() con la diferencia que la conexion no se cierra después de que termine el script. Esta es la versión persistente de fsockopen().

Anterior | Inicio | Siguiente
openlog | Subir | set_socket_blocking


set_socket_blocking

(PHP 3, PHP 4 >= 4.0.0)

set_socket_blocking -- Set blocking/non-blocking modo de un socket

Descripción

int set_socket_blocking ( int socket descriptor, int mode)

Si mode es falso, el socket estará descriptor will be switched to non-blocking mode, y si es TRUE, este pasara a modo bloqueo. Esto afecta a llamadas como fgets() que leen del socket. En el modo de no-bloqueo una llamada fgets() devolverá la información en el acto, mientras que en modo bloqueo esperará a que la información esté disponible en el socket.

Anterior | Inicio | Siguiente
pfsockopen | Subir | syslog


syslog

(PHP 3, PHP 4 >= 4.0.0)

syslog -- genera un mensaje de sistema

Descripción

int syslog ( int priority, string message)

syslog() genera un mensaje que será distribuido por el logger del sistema. priority es una combinación de la facility y el level, los valores se indicarán en la sección siguiente. El argumento restante es el mensaje a enviar, excepto que los dos caracteres %m sean reemplazados por la cadena de error (strerror) correspondiente al valor actual de errno.

Más información acerca de syslog se puede encontrar en las páginas del manual en equipos Unix.

En Windows NT, el servicio syslog es emulado usando el Log de Eventos.

Anterior | Inicio | Siguiente
set_socket_blocking | Subir | Ncurses terminal screen control functions


Ncurses terminal screen control functions

Manual de PHP
Anterior Siguiente

LXV. Ncurses terminal screen control functions

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

What is ncurses?

ncurses (new curses) is a free software emulation of curses in System V Rel 4.0 (and above). It uses terminfo format, supports pads, colors, multiple highlights, form characters and function key mapping.

Platforms

Ncurses is available for the following platforms:

  • AIX

  • BeOS

  • Cygwin

  • Digital Unix (aka OSF1)

  • FreeBSD

  • GNU/Linux

  • HPUX

  • IRIX

  • OS/2

  • SCO OpenServer

  • Solaris

  • SunOS

Requirements

You need the ncurses libraries and headerfiles. Download the latest version from the ftp://ftp.gnu.org/pub/gnu/ncurses/ or from an other GNU-Mirror.

Installation

To get these functions to work, you have to compile the CGI version of PHP with --with-ncurses.

Ncurses predefined constants

Error codes

On error ncurses functions return NCURSES_ERR.

Colors

Tabla 1. ncurses color constants

constant | meaning
NCURSES_COLOR_BLACK | no color (black)
NCURSES_COLOR_WHITE | white
NCURSES_COLOR_RED | red - supported when terminal is in color mode
NCURSES_COLOR_GREEN | green - supported when terminal is in color mod
NCURSES_COLOR_YELLOW | yellow - supported when terminal is in color mod
NCURSES_COLOR_BLUE | blue - supported when terminal is in color mod
NCURSES_COLOR_CYAN | cyan - supported when terminal is in color mod
NCURSES_COLOR_MAGENTA | magenta - supported when terminal is in color mod

Keys

Tabla 2. ncurses key constants

constant | meaning
NCURSES_KEY_F0 - NCURSES_KEY_F64 | function keys F1 - F64
NCURSES_KEY_DOWN | down arrow
NCURSES_KEY_UP | up arrow
NCURSES_KEY_LEFT | left arrow
NCURSES_KEY_RIGHT | right arrow
NCURSES_KEY_HOME | home key (upward+left arrow)
NCURSES_KEY_BACKSPACE | backspace
NCURSES_KEY_DL | delete line
NCURSES_KEY_IL | insert line
NCURSES_KEY_DC | delete character
NCURSES_KEY_IC | insert char or enter insert mode
NCURSES_KEY_EIC | exit insert char mode
NCURSES_KEY_CLEAR | clear screen
NCURSES_KEY_EOS | clear to end of screen
NCURSES_KEY_EOL | clear to end of line
NCURSES_KEY_SF | scroll one line forward
NCURSES_KEY_SR | scroll one line backward
NCURSES_KEY_NPAGE | next page
NCURSES_KEY_PPAGE | previous page
NCURSES_KEY_STAB | set tab
NCURSES_KEY_CTAB | clear tab
NCURSES_KEY_CATAB | clear all tabs
NCURSES_KEY_SRESET | soft (partial) reset
NCURSES_KEY_RESET | reset or hard reset
NCURSES_KEY_PRINT | print
NCURSES_KEY_LL | lower left
NCURSES_KEY_A1 | upper left of keypad
NCURSES_KEY_A3 | upper right of keypad
NCURSES_KEY_B2 | center of keypad
NCURSES_KEY_C1 | lower left of keypad
NCURSES_KEY_C3 | lower right of keypad
NCURSES_KEY_BTAB | back tab
NCURSES_KEY_BEG | beginning
NCURSES_KEY_CANCEL | cancel
NCURSES_KEY_CLOSE | close
NCURSES_KEY_COMMAND | cmd (command)
NCURSES_KEY_COPY | copy
NCURSES_KEY_CREATE | create
NCURSES_KEY_END | end
NCURSES_KEY_EXIT | exit
NCURSES_KEY_FIND | find
NCURSES_KEY_HELP | help
NCURSES_KEY_MARK | mark
NCURSES_KEY_MESSAGE | message
NCURSES_KEY_MOVE | move
NCURSES_KEY_NEXT | next
NCURSES_KEY_OPEN | open
NCURSES_KEY_OPTIONS | options
NCURSES_KEY_PREVIOUS | previous
NCURSES_KEY_REDO | redo
NCURSES_KEY_REFERENCE | ref (reference)
NCURSES_KEY_REFRESH | refresh
NCURSES_KEY_REPLACE | replace
NCURSES_KEY_RESTART | restart
NCURSES_KEY_RESUME | resume
NCURSES_KEY_SAVE | save
NCURSES_KEY_SBEG | shiftet beg (beginning)
NCURSES_KEY_SCANCEL | shifted cancel
NCURSES_KEY_SCOMMAND | shifted command
NCURSES_KEY_SCOPY | shifted copy
NCURSES_KEY_SCREATE | shifted create
NCURSES_KEY_SDC | shifted delete char
NCURSES_KEY_SDL | shifted delete line
NCURSES_KEY_SELECT | select
NCURSES_KEY_SEND | shifted end
NCURSES_KEY_SEOL | shifted end of line
NCURSES_KEY_SEXIT | shifted exit
NCURSES_KEY_SFIND | shifted find
NCURSES_KEY_SHELP | shifted help
NCURSES_KEY_SHOME | shifted home
NCURSES_KEY_SIC | shifted input
NCURSES_KEY_SLEFT | shifted left arrow
NCURSES_KEY_SMESSAGE | shifted message
NCURSES_KEY_SMOVE | shifted move
NCURSES_KEY_SNEXT | shifted next
NCURSES_KEY_SOPTIONS | shifted options
NCURSES_KEY_SPREVIOUS | shifted previous
NCURSES_KEY_SPRINT | shifted print
NCURSES_KEY_SREDO | shifted redo
NCURSES_KEY_SREPLACE | shifted replace
NCURSES_KEY_SRIGHT | shifted right arrow
NCURSES_KEY_SRSUME | shifted resume
NCURSES_KEY_SSAVE | shifted save
NCURSES_KEY_SSUSPEND | shifted suspend
NCURSES_KEY_UNDO | undo
NCURSES_KEY_MOUSE | mouse event has occured
NCURSES_KEY_MAX | maximum key value

Mouse

Tabla 3. mouse constants

Constant | meaning
NCURSES_BUTTON1_RELEASED - NCURSES_BUTTON4_RELEASED | button (1-4) released
NCURSES_BUTTON1_PRESSED - NCURSES_BUTTON4_PRESSED | button (1-4) pressed
NCURSES_BUTTON1_CLICKED - NCURSES_BUTTON4_CLICKED | button (1-4) clicked
NCURSES_BUTTON1_DOUBLE_CLICKED - NCURSES_BUTTON4_DOUBLE_CLICKED | button (1-4) double clicked
NCURSES_BUTTON1_TRIPLE_CLICKED - NCURSES_BUTTON4_TRIPLE_CLICKED | button (1-4) triple clicked
NCURSES_BUTTON_CTRL | ctrl pressed during click
NCURSES_BUTTON_SHIFT | shift pressed during click
NCURSES_BUTTON_ALT | alt pressed during click
NCURSES_ALL_MOUSE_EVENTS | report all mouse events
NCURSES_REPORT_MOUSE_POSITION | report mouse position
Tabla de contenidos
ncurses_can_change_color — Check if we can change terminals colors
ncurses_cbreak — Switch of input buffering
ncurses_clear — Clear screen
ncurses_clrtobot — Clear screen from current position to bottom
ncurses_clrtoeol — Clear screen from current position to end of line
ncurses_def_prog_mode — Saves terminals (program) mode
ncurses_def_shell_mode — Saves terminals (shell) mode
ncurses_delch — Delete character at current position, move rest of line left
ncurses_deleteln — Delete line at current position, move rest of screen up
ncurses_doupdate — Write all prepared refreshes to terminal
ncurses_echo — Activate keyboard input echo
ncurses_erase — Erase terminal screen
ncurses_erasechar — Returns current erase character
ncurses_flash — Flash terminal screen (visual bell)
ncurses_flushinp — Flush keyboard input buffer
ncurses_has_colors — Check if terminal has colors
ncurses_has_ic — Check for insert- and delete-capabilities
ncurses_has_il — Check for line insert- and delete-capabilities
ncurses_inch — Get character and attribute at current position
ncurses_insertln — Insert a line, move rest of screen down
ncurses_isendwin — Ncurses is in endwin mode, normal screen output may be performed
ncurses_killchar — Returns current line kill character
ncurses_nl — Translate newline and carriage return / line feed
ncurses_nocbreak — Switch terminal to cooked mode
ncurses_noecho — Switch off keyboard input echo
ncurses_nonl — Do not translate newline and carriage return / line feed
ncurses_noraw — Switch terminal out of raw mode
ncurses_raw — Switch terminal into raw mode
ncurses_resetty — Restores saved terminal state
ncurses_savetty — Saves terminal state
ncurses_slk_init — Initializes soft label key functions
ncurses_slk_attr — Returns current soft label key attribute
ncurses_slk_clear — Clears soft labels from screen
ncurses_slk_noutrefresh — Copies soft label keys to virtual screen
ncurses_slk_refresh — Copies soft label keys to screen
ncurses_slk_restore — Restores soft label keys
ncurses_slk_touch — Fources output when ncurses_slk_noutrefresh is performed
ncurses_termattrs — Returns a logical OR of all attribute flags supported by terminal
ncurses_use_default_colors — Assign terminal default colors to color id -1
ncurses_addch — Add character at current position and advance cursor
ncurses_addchnstr — Add attributed string with specified length at current position
ncurses_addchstr — Add attributed string at current position
ncurses_addnstr — Add string with specified length at current position
ncurses_addstr — Output text at current position
ncurses_assume_default_colors — Define default colors for color 0
ncurses_attroff — Turn off the given attributes
ncurses_attron — Turn on the given attributes
ncurses_attrset — Set given attributes
ncurses_baudrate — Returns baudrate of terminal
ncurses_beep — Let the terminal beep
ncurses_bkgd — Set background property for terminal screen
ncurses_border — Draw a border around the screen using attributed characters
ncurses_color_set — Set fore- and background color
ncurses_curs_set — Set cursor state
ncurses_define_key — Define a keycode
ncurses_delay_output — Delay output on terminal using padding characters
ncurses_delwin — Delete a ncurses window
ncurses_echochar — Single character output including refresh
ncurses_end — Stop using ncurses, clean up the screen
ncurses_filter —
ncurses_getch — Read a character from keyboard
ncurses_halfdelay — Put terminal into halfdelay mode
ncurses_has_key — Check for presence of a function key on terminal keyboard
ncurses_hline — Draw a horizontal line at current position using an attributed character and max. n characters long
ncurses_init — Initialize ncurses
ncurses_init_color — Set new RGB value for color
ncurses_init_pair — Allocate a color pair
ncurses_insch — Insert character moving rest of line including character at current position
ncurses_insdelln — Insert lines before current line scrolling down (negative numbers delete and scroll up)
ncurses_insstr — Insert string at current position, moving rest of line right
ncurses_instr — Reads string from terminal screen
ncurses_keyok — Enable or disable a keycode
ncurses_mouseinterval — Set timeout for mouse button clicks
ncurses_move — Move output position
ncurses_mvaddch — Move current position and add character
ncurses_mvaddchnstr — Move position and add attrributed string with specified length
ncurses_mvaddchstr — Move position and add attributed string
ncurses_mvaddnstr — Move position and add string with specified length
ncurses_mvaddstr — Move position and add string
ncurses_mvcur — Move cursor immediately
ncurses_mvdelch — Move position and delete character, shift rest of line left
ncurses_mvgetch — Move position and get character at new position
ncurses_mvhline — Set new position and draw a horizontal line using an attributed character and max. n characters long
ncurses_mvinch — Move position and get attributed character at new position
ncurses_mvvline — Set new position and draw a vertical line using an attributed character and max. n characters long
ncurses_mvwaddstr — Add string at new position in window
ncurses_napms — Sleep
ncurses_newwin — Create a new window
ncurses_noqiflush — Do not flush on signal characters
ncurses_putp —
ncurses_qiflush — Flush on signal characters
ncurses_refresh — Refresh screen
ncurses_scr_dump — Dump screen content to file
ncurses_scr_init — Initialize screen from file dump
ncurses_scr_restore — Restore screen from file dump
ncurses_scr_set — Inherit screen from file dump
ncurses_scrl — Scroll window content up or down without changing current position
ncurses_slk_attroff —
ncurses_slk_attron —
ncurses_slk_attrset —
ncurses_slk_color — Sets color for soft label keys
ncurses_standend — Stop using 'standout' attribute
ncurses_standout — Start using 'standout' attribute
ncurses_start_color — Start using colors
ncurses_typeahead — Specify different filedescriptor for typeahead checking
ncurses_ungetch — Put a character back into the input stream
ncurses_use_extended_names — Control use of extended names in terminfo descriptions
ncurses_vidattr —
ncurses_vline — Draw a vertical line at current position using an attributed character and max. n characters long
ncurses_wrefresh — Refresh window on terminal screen
ncurses_bkgdset — Control screen background
ncurses_timeout — Set timeout for special key sequences
ncurses_use_env — Control use of environment information about terminal size
ncurses_termname — Returns terminals (short)-name
ncurses_longname — Returns terminals description
ncurses_mousemask — Sets mouse options
ncurses_getmouse — Reads mouse event
ncurses_ungetmouse — Pushes mouse event to queue

Anterior | Inicio | Siguiente
syslog | Subir | ncurses_can_change_color


ncurses_can_change_color

(PHP 4 >= 4.1.0)

ncurses_can_change_color -- Check if we can change terminals colors

Description

bool ncurses_can_change_color ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

The function ncurses_can_change_color() returns TRUE or FALSE, depending on whether the terminal has color capabilities and whether the programmer can change the colors.

Anterior | Inicio | Siguiente
Ncurses terminal screen control functions | Subir | ncurses_cbreak


ncurses_cbreak

(PHP 4 >= 4.1.0)

ncurses_cbreak -- Switch of input buffering

Description

bool ncurses_cbreak ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_cbreak() disables line buffering and character processing (interrupt and flow control characters are unaffected), making characters typed by the user immediately available to the program.

ncurses_cbreak() returns TRUE or NCURSES_ERR if any error occured.

See also: ncurses_nocbreak()

Anterior | Inicio | Siguiente
ncurses_can_change_color | Subir | ncurses_clear


ncurses_clear

(PHP 4 >= 4.1.0)

ncurses_clear -- Clear screen

Description

bool ncurses_clear ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_clear() clears the screen completely without setting blanks. Returns FALSE on success, otherwise TRUE.

Note: ncurses_clear() clears the screen without setting blanks, which have the current background rendition. To clear screen with blanks, use ncurses_erase().

See also: ncurses_erase()

Anterior | Inicio | Siguiente
ncurses_cbreak | Subir | ncurses_clrtobot


ncurses_clrtobot

(PHP 4 >= 4.1.0)

ncurses_clrtobot -- Clear screen from current position to bottom

Description

bool ncurses_clrtobot ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_clrtobot() erases all lines from cursor to end of screen and creates blanks. Blanks created by ncurses_clrtobot() have the current background rendition. Returns TRUE if any error occured, otherwise FALSE.

See also: ncurses_clear(), ncurses_clrtoeol()

Anterior | Inicio | Siguiente
ncurses_clear | Subir | ncurses_clrtoeol


ncurses_clrtoeol

(PHP 4 >= 4.1.0)

ncurses_clrtoeol -- Clear screen from current position to end of line

Description

bool ncurses_clrtoeol ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_clrtoeol() erases the current line from cursor position to the end. Blanks created by ncurses_clrtoeol() have the current background rendition. Returns TRUE if any error occured, otherwise FALSE.

See also: ncurses_clear(), ncurses_clrtobot()

Anterior | Inicio | Siguiente
ncurses_clrtobot | Subir | ncurses_def_prog_mode


ncurses_def_prog_mode

(PHP 4 >= 4.1.0)

ncurses_def_prog_mode -- Saves terminals (program) mode

Description

bool ncurses_def_prog_mode ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_def_prog_mode() saves the current terminal modes for program (in curses) for use by ncurses_reset_prog_mode(). Returns FALSE on success, otherwise TRUE.

See also: ncurses_reset_prog_mode()

Anterior | Inicio | Siguiente
ncurses_clrtoeol | Subir | ncurses_def_shell_mode


ncurses_def_shell_mode

(PHP 4 >= 4.1.0)

ncurses_def_shell_mode -- Saves terminals (shell) mode

Description

bool ncurses_def_shell_mode ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_def_shell_mode() saves the current terminal modes for shell (not in curses) for use by ncurses_reset_shell_mode(). Returns FALSE on success, otherwise TRUE.

See also: ncurses_reset_shell_mode()

Anterior | Inicio | Siguiente
ncurses_def_prog_mode | Subir | ncurses_delch


ncurses_delch

(PHP 4 >= 4.1.0)

ncurses_delch -- Delete character at current position, move rest of line left

Description

bool ncurses_delch ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_delch() deletes the character under the cursor. All characters to the right of the cursor on the same line are moved to the left one position and the last character on the line is filled with a blank. The cursor position does not change. Returns FALSE on success, otherwise TRUE.

See also: ncurses_deleteln()

Anterior | Inicio | Siguiente
ncurses_def_shell_mode | Subir | ncurses_deleteln


ncurses_deleteln

(PHP 4 >= 4.1.0)

ncurses_deleteln -- Delete line at current position, move rest of screen up

Description

bool ncurses_deleteln ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_deleteln() deletes the current line under cursorposition. All lines below the current line are moved up one line. The bottom line of window is cleared. Cursor position does not change. Returns FALSE on success, otherwise TRUE.

See also: ncurses_delch()

Anterior | Inicio | Siguiente
ncurses_delch | Subir | ncurses_doupdate


ncurses_doupdate

(PHP 4 >= 4.1.0)

ncurses_doupdate -- Write all prepared refreshes to terminal

Description

bool ncurses_doupdate ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_doupdate()() compares the virtual screen to the physical screen and updates the physical screen. This way is more effective than using multiple refresh calls. Returns FALSE on success, TRUE if any error occured.

Anterior | Inicio | Siguiente
ncurses_deleteln | Subir | ncurses_echo


ncurses_echo

(PHP 4 >= 4.1.0)

ncurses_echo -- Activate keyboard input echo

Description

bool ncurses_echo ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_echo() enables echo mode. All characters typed by user are echoed by ncurses_getch(). Returns FALSE on success, TRUE if any error occured.

To disable echo mode use ncurses_noecho().

Anterior | Inicio | Siguiente
ncurses_doupdate | Subir | ncurses_erase


ncurses_erase

(PHP 4 >= 4.1.0)

ncurses_erase -- Erase terminal screen

Description

bool ncurses_erase ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_erase() fills the terminal screen with blanks. Created blanks have the current background rendition, set by ncurses_bkgd(). Returns FALSE on success, TRUE if any error occured.

See also: ncurses_bkgd(), ncurses_clear()

Anterior | Inicio | Siguiente
ncurses_echo | Subir | ncurses_erasechar


ncurses_erasechar

(PHP 4 >= 4.1.0)

ncurses_erasechar -- Returns current erase character

Description

string ncurses_erasechar ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_erasechar() returns the current erase char character.

See also: ncurses_killchar()

Anterior | Inicio | Siguiente
ncurses_erase | Subir | ncurses_flash


ncurses_flash

(PHP 4 >= 4.1.0)

ncurses_flash -- Flash terminal screen (visual bell)

Description

bool ncurses_flash ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_flash() flashes the screen, and if its not possible, sends an audible alert (bell). Returns FALSE on success, otherwise TRUE.

See also: ncurses_beep()

Anterior | Inicio | Siguiente
ncurses_erasechar | Subir | ncurses_flushinp


ncurses_flushinp

(PHP 4 >= 4.1.0)

ncurses_flushinp -- Flush keyboard input buffer

Description

bool ncurses_flushinp ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

The ncurses_flushinp() throws away any typeahead that has been typed and has not yet been read by your program. Returns FALSE on success, otherwise TRUE.

Anterior | Inicio | Siguiente
ncurses_flash | Subir | ncurses_has_colors


ncurses_has_colors

(PHP 4 >= 4.1.0)

ncurses_has_colors -- Check if terminal has colors

Description

bool ncurses_has_colors ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_has_colors() returns TRUE or FALSE depending on whether the terminal has color capacitites.

See also: ncurses_can_change_color()

Anterior | Inicio | Siguiente
ncurses_flushinp | Subir | ncurses_has_ic


ncurses_has_ic

(PHP 4 >= 4.1.0)

ncurses_has_ic -- Check for insert- and delete-capabilities

Description

bool ncurses_has_ic ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_has_ic() checks terminals insert- and delete capabilitites. It returns TRUE when terminal has insert/delete-capabilities, otherwise FALSE.

See also: ncurses_has_il()

Anterior | Inicio | Siguiente
ncurses_has_colors | Subir | ncurses_has_il


ncurses_has_il

(PHP 4 >= 4.1.0)

ncurses_has_il -- Check for line insert- and delete-capabilities

Description

bool ncurses_has_il ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_has_il() checks terminals insert- and delete-line-capabilities. It returns TRUE when terminal has insert/delete-line capabilities, otherwise FALSE

See also: ncurses_has_ic()

Anterior | Inicio | Siguiente
ncurses_has_ic | Subir | ncurses_inch


ncurses_inch

(PHP 4 >= 4.1.0)

ncurses_inch -- Get character and attribute at current position

Description

string ncurses_inch ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_inch() returns the character from the current position.

Anterior | Inicio | Siguiente
ncurses_has_il | Subir | ncurses_insertln


ncurses_insertln

(PHP 4 >= 4.1.0)

ncurses_insertln -- Insert a line, move rest of screen down

Description

bool ncurses_insertln ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_insertln() inserts a new line above the current line. The bottom line will be lost.

Anterior | Inicio | Siguiente
ncurses_inch | Subir | ncurses_isendwin


ncurses_isendwin

(PHP 4 >= 4.1.0)

ncurses_isendwin -- Ncurses is in endwin mode, normal screen output may be performed

Description

bool ncurses_isendwin ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_isendwin() returns TRUE, if
ncurses_endwin() has been called without any
subsequent calls to ncurses_wrefresh(),
otherwise FALSE.

See also: ncurses_endwin() ncurses_wrefresh()()

Anterior | Inicio | Siguiente
ncurses_insertln | Subir | ncurses_killchar


ncurses_killchar

(PHP 4 >= 4.1.0)

ncurses_killchar -- Returns current line kill character

Description

bool ncurses_killchar ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_killchar() returns the current line kill character.

See also: ncurses_erasechar()

Anterior | Inicio | Siguiente
ncurses_isendwin | Subir | ncurses_nl


ncurses_nl

(PHP 4 >= 4.1.0)

ncurses_nl -- Translate newline and carriage return / line feed

Description

bool ncurses_nl ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_killchar | Subir | ncurses_nocbreak


ncurses_nocbreak

(PHP 4 >= 4.1.0)

ncurses_nocbreak -- Switch terminal to cooked mode

Description

bool ncurses_nocbreak ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_nocbreak() routine returns terminal to normal (cooked) mode. Initially the terminal may or may not in cbreak mode as the mode is inherited. Therefore a program should call ncurses_cbreak() and ncurses_nocbreak() explicitly. Returns TRUE if any error occured, otherwise FALSE.

See also: ncurses_cbreak()

Anterior | Inicio | Siguiente
ncurses_nl | Subir | ncurses_noecho


ncurses_noecho

(PHP 4 >= 4.1.0)

ncurses_noecho -- Switch off keyboard input echo

Description

bool ncurses_noecho ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_noecho() prevents echoing of user typed characters. Returns TRUE if any error occured, otherwise FALSE.

See also: ncurses_echo(), ncurses_getch()

Anterior | Inicio | Siguiente
ncurses_nocbreak | Subir | ncurses_nonl


ncurses_nonl

(PHP 4 >= 4.1.0)

ncurses_nonl -- Do not translate newline and carriage return / line feed

Description

bool ncurses_nonl ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_noecho | Subir | ncurses_noraw


ncurses_noraw

(PHP 4 >= 4.1.0)

ncurses_noraw -- Switch terminal out of raw mode

Description

bool ncurses_noraw ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_noraw() switches the terminal out of raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The differences that are that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal. Returns TRUE if any error occured, otherwise FALSE.

See also: ncurses_raw(),
ncurses_cbreak(),
ncurses_nocbreak()

Anterior | Inicio | Siguiente
ncurses_nonl | Subir | ncurses_raw


ncurses_raw

(PHP 4 >= 4.1.0)

ncurses_raw -- Switch terminal into raw mode

Description

bool ncurses_raw ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_raw() places the terminal in raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The differences that are that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal. Returns TRUE if any error occured, otherwise FALSE.

See also: ncurses_noraw(),
ncurses_cbreak(),
ncurses_nocbreak()

Anterior | Inicio | Siguiente
ncurses_noraw | Subir | ncurses_resetty


ncurses_resetty

(PHP 4 >= 4.1.0)

ncurses_resetty -- Restores saved terminal state

Description

bool ncurses_resetty ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Function ncurses_resetty() restores the terminal state, which was previously saved by calling ncurses_savetty(). This function always returns FALSE.

See also: ncurses_savetty()

Anterior | Inicio | Siguiente
ncurses_raw | Subir | ncurses_savetty


ncurses_savetty

(PHP 4 >= 4.1.0)

ncurses_savetty -- Saves terminal state

Description

bool ncurses_savetty ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Function ncurses_savetty() saves the current terminal state. The saved terminal state can be restored with function ncurses_resetty(). ncurses_savetty() always returns FALSE.

See also: ncurses_resetty()

Anterior | Inicio | Siguiente
ncurses_resetty | Subir | ncurses_slk_init


ncurses_slk_init

(PHP 4 >= 4.1.0)

ncurses_slk_init -- Initializes soft label key functions

Description

bool ncurses_slk_init ( int format)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Funtion ncurses_slk_init() must be called before ncurses_initscr() or ncurses_newterm() is called. If ncurses_initscr() eventually uses a line from stdscr to emulate the soft labels, then format determines how the labels are arranged of the screen. Setting format to 0 indicates a 3-2-3 arrangement of the labels, 1 indicates a 4-4 arrangement and 2 indicates the PC like 4-4-4 mode, but in addition an index line will be created.

Anterior | Inicio | Siguiente
ncurses_savetty | Subir | ncurses_slk_attr


ncurses_slk_attr

(PHP 4 >= 4.1.0)

ncurses_slk_attr -- Returns current soft label key attribute

Description

bool ncurses_slk_attr ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_slk_attr() returns the current soft label key attribute. On error returns TRUE, otherwise FALSE.

Anterior | Inicio | Siguiente
ncurses_slk_init | Subir | ncurses_slk_clear


ncurses_slk_clear

(PHP 4 >= 4.1.0)

ncurses_slk_clear -- Clears soft labels from screen

Description

bool ncurses_slk_clear ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

The function ncurses_slk_clear() clears soft label keys from screen. Returns TRUE on error, otherwise FALSE.

Anterior | Inicio | Siguiente
ncurses_slk_attr | Subir | ncurses_slk_noutrefresh


ncurses_slk_noutrefresh

(PHP 4 >= 4.1.0)

ncurses_slk_noutrefresh -- Copies soft label keys to virtual screen

Description

bool ncurses_slk_noutrefresh ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_slk_clear | Subir | ncurses_slk_refresh


ncurses_slk_refresh

(PHP 4 >= 4.1.0)

ncurses_slk_refresh -- Copies soft label keys to screen

Description

bool ncurses_slk_refresh ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_slk_refresh() copies soft label keys from virtual screen to physical screen. Returns TRUE on error, otherwise FALSE.

Anterior | Inicio | Siguiente
ncurses_slk_noutrefresh | Subir | ncurses_slk_restore


ncurses_slk_restore

(PHP 4 >= 4.1.0)

ncurses_slk_restore -- Restores soft label keys

Description

bool ncurses_slk_restore ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

The function ncurses_slk_restore() restores the soft label keys after ncurses_slk_clear() has been performed.

Anterior | Inicio | Siguiente
ncurses_slk_refresh | Subir | ncurses_slk_touch


ncurses_slk_touch

(PHP 4 >= 4.1.0)

ncurses_slk_touch -- Fources output when ncurses_slk_noutrefresh is performed

Description

bool ncurses_slk_touch ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

The ncurses_slk_touch() function forces all the soft labels to be output the next time a ncurses_slk_noutrefresh() is performed.

Anterior | Inicio | Siguiente
ncurses_slk_restore | Subir | ncurses_termattrs


ncurses_termattrs

(PHP 4 >= 4.1.0)

ncurses_termattrs -- Returns a logical OR of all attribute flags supported by terminal

Description

bool ncurses_termattrs ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_slk_touch | Subir | ncurses_use_default_colors


ncurses_use_default_colors

(PHP 4 >= 4.1.0)

ncurses_use_default_colors -- Assign terminal default colors to color id -1

Description

bool ncurses_use_default_colors ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_termattrs | Subir | ncurses_addch


ncurses_addch

(PHP 4 >= 4.1.0)

ncurses_addch -- Add character at current position and advance cursor

Description

int ncurses_addch ( int ch)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_use_default_colors | Subir | ncurses_addchnstr


ncurses_addchnstr

(PHP 4 >= 4.2.0)

ncurses_addchnstr -- Add attributed string with specified length at current position

Description

int ncurses_addchnstr ( string s, int n)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_addch | Subir | ncurses_addchstr


ncurses_addchstr

(PHP 4 >= 4.2.0)

ncurses_addchstr -- Add attributed string at current position

Description

int ncurses_addchstr ( string s)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_addchnstr | Subir | ncurses_addnstr


ncurses_addnstr

(PHP 4 >= 4.2.0)

ncurses_addnstr -- Add string with specified length at current position

Description

int ncurses_addnstr ( string s, int n)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_addchstr | Subir | ncurses_addstr


ncurses_addstr

(PHP 4 >= 4.2.0)

ncurses_addstr -- Output text at current position

Description

int ncurses_addstr ( string text)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_addnstr | Subir | ncurses_assume_default_colors


ncurses_assume_default_colors

(PHP 4 >= 4.2.0)

ncurses_assume_default_colors -- Define default colors for color 0

Description

int ncurses_assume_default_colors ( int fg, int bg)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_addstr | Subir | ncurses_attroff


ncurses_attroff

(PHP 4 >= 4.1.0)

ncurses_attroff -- Turn off the given attributes

Description

int ncurses_attroff ( int attributes)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_assume_default_colors | Subir | ncurses_attron


ncurses_attron

(PHP 4 >= 4.1.0)

ncurses_attron -- Turn on the given attributes

Description

int ncurses_attron ( int attributes)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_attroff | Subir | ncurses_attrset


ncurses_attrset

(PHP 4 >= 4.1.0)

ncurses_attrset -- Set given attributes

Description

int ncurses_attrset ( int attributes)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_attron | Subir | ncurses_baudrate


ncurses_baudrate

(PHP 4 >= 4.1.0)

ncurses_baudrate -- Returns baudrate of terminal

Description

int ncurses_baudrate ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_attrset | Subir | ncurses_beep


ncurses_beep

(PHP 4 >= 4.1.0)

ncurses_beep -- Let the terminal beep

Description

int ncurses_beep ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_beep() sends an audlible alert (bell) and if its not possible flashes the screen. Returns FALSE on success, otherwise TRUE.

See also: ncurses_flash()

Anterior | Inicio | Siguiente
ncurses_baudrate | Subir | ncurses_bkgd


ncurses_bkgd

(PHP 4 >= 4.1.0)

ncurses_bkgd -- Set background property for terminal screen

Description

int ncurses_bkgd ( int attrchar)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_beep | Subir | ncurses_border


ncurses_border

(PHP 4 >= 4.2.0)

ncurses_border -- Draw a border around the screen using attributed characters

Description

int ncurses_border ( int left, int right, int top, int bottom, int tl_corner, int tr_corner, int bl_corner, int br_corner)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_bkgd | Subir | ncurses_color_set


ncurses_color_set

(PHP 4 >= 4.1.0)

ncurses_color_set -- Set fore- and background color

Description

int ncurses_color_set ( int pair)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_border | Subir | ncurses_curs_set


ncurses_curs_set

(PHP 4 >= 4.1.0)

ncurses_curs_set -- Set cursor state

Description

int ncurses_curs_set ( int visibility)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_color_set | Subir | ncurses_define_key


ncurses_define_key

(PHP 4 >= 4.2.0)

ncurses_define_key -- Define a keycode

Description

int ncurses_define_key ( string definition, int keycode)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_curs_set | Subir | ncurses_delay_output


ncurses_delay_output

(PHP 4 >= 4.1.0)

ncurses_delay_output -- Delay output on terminal using padding characters

Description

int ncurses_delay_output ( int milliseconds)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_define_key | Subir | ncurses_delwin


ncurses_delwin

(PHP 4 >= 4.1.0)

ncurses_delwin -- Delete a ncurses window

Description

int ncurses_delwin ( resource window)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_delay_output | Subir | ncurses_echochar


ncurses_echochar

(PHP 4 >= 4.1.0)

ncurses_echochar -- Single character output including refresh

Description

int ncurses_echochar ( int character)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_delwin | Subir | ncurses_end


ncurses_end

(PHP 4 >= 4.1.0)

ncurses_end -- Stop using ncurses, clean up the screen

Description

int ncurses_end ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_echochar | Subir | ncurses_filter


ncurses_filter

(PHP 4 >= 4.1.0)

ncurses_filter --

Description

int ncurses_filter ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_end | Subir | ncurses_getch


ncurses_getch

(PHP 4 >= 4.1.0)

ncurses_getch -- Read a character from keyboard

Description

int ncurses_getch ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_filter | Subir | ncurses_halfdelay


ncurses_halfdelay

(PHP 4 >= 4.1.0)

ncurses_halfdelay -- Put terminal into halfdelay mode

Description

int ncurses_halfdelay ( int tenth)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_getch | Subir | ncurses_has_key


ncurses_has_key

(PHP 4 >= 4.1.0)

ncurses_has_key -- Check for presence of a function key on terminal keyboard

Description

int ncurses_has_key ( int keycode)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_halfdelay | Subir | ncurses_hline


ncurses_hline

(PHP 4 >= 4.2.0)

ncurses_hline -- Draw a horizontal line at current position using an attributed character and max. n characters long

Description

int ncurses_hline ( int charattr, int n)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_has_key | Subir | ncurses_init


ncurses_init

(PHP 4 >= 4.1.0)

ncurses_init -- Initialize ncurses

Description

int ncurses_init ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_hline | Subir | ncurses_init_color


ncurses_init_color

(PHP 4 >= 4.2.0)

ncurses_init_color -- Set new RGB value for color

Description

int ncurses_init_color ( int color, int r, int g, int b)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_init | Subir | ncurses_init_pair


ncurses_init_pair

(PHP 4 >= 4.1.0)

ncurses_init_pair -- Allocate a color pair

Description

int ncurses_init_pair ( int pair, int fg, int bg)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_init_color | Subir | ncurses_insch


ncurses_insch

(PHP 4 >= 4.1.0)

ncurses_insch -- Insert character moving rest of line including character at current position

Description

int ncurses_insch ( int character)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_init_pair | Subir | ncurses_insdelln


ncurses_insdelln

(PHP 4 >= 4.1.0)

ncurses_insdelln -- Insert lines before current line scrolling down (negative numbers delete and scroll up)

Description

int ncurses_insdelln ( int count)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_insch | Subir | ncurses_insstr


ncurses_insstr

(PHP 4 >= 4.2.0)

ncurses_insstr -- Insert string at current position, moving rest of line right

Description

int ncurses_insstr ( string text)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_insdelln | Subir | ncurses_instr


ncurses_instr

(PHP 4 >= 4.2.0)

ncurses_instr -- Reads string from terminal screen

Description

int ncurses_instr ( string buffer)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_instr() returns the number of charaters read from the current character position until end of line. buffer contains the characters. Atrributes are stripped from the characters.

Anterior | Inicio | Siguiente
ncurses_insstr | Subir | ncurses_keyok


ncurses_keyok

(PHP 4 >= 4.2.0)

ncurses_keyok -- Enable or disable a keycode

Description

int ncurses_keyok ( int keycode, bool enable)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_instr | Subir | ncurses_mouseinterval


ncurses_mouseinterval

(PHP 4 >= 4.1.0)

ncurses_mouseinterval -- Set timeout for mouse button clicks

Description

int ncurses_mouseinterval ( int milliseconds)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_keyok | Subir | ncurses_move


ncurses_move

(PHP 4 >= 4.1.0)

ncurses_move -- Move output position

Description

int ncurses_move ( int y, int x)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mouseinterval | Subir | ncurses_mvaddch


ncurses_mvaddch

(PHP 4 >= 4.2.0)

ncurses_mvaddch -- Move current position and add character

Description

int ncurses_mvaddch ( int y, int x, int c)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_move | Subir | ncurses_mvaddchnstr


ncurses_mvaddchnstr

(PHP 4 >= 4.2.0)

ncurses_mvaddchnstr -- Move position and add attrributed string with specified length

Description

int ncurses_mvaddchnstr ( int y, int x, string s, int n)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvaddch | Subir | ncurses_mvaddchstr


ncurses_mvaddchstr

(PHP 4 >= 4.2.0)

ncurses_mvaddchstr -- Move position and add attributed string

Description

int ncurses_mvaddchstr ( int y, int x, string s)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvaddchnstr | Subir | ncurses_mvaddnstr


ncurses_mvaddnstr

(PHP 4 >= 4.2.0)

ncurses_mvaddnstr -- Move position and add string with specified length

Description

int ncurses_mvaddnstr ( int y, int x, string s, int n)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvaddchstr | Subir | ncurses_mvaddstr


ncurses_mvaddstr

(PHP 4 >= 4.2.0)

ncurses_mvaddstr -- Move position and add string

Description

int ncurses_mvaddstr ( int y, int x, string s)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvaddnstr | Subir | ncurses_mvcur


ncurses_mvcur

(PHP 4 >= 4.2.0)

ncurses_mvcur -- Move cursor immediately

Description

int ncurses_mvcur ( int old_y, int old_x, int new_y, int new_x)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvaddstr | Subir | ncurses_mvdelch


ncurses_mvdelch

(PHP 4 >= 4.2.0)

ncurses_mvdelch -- Move position and delete character, shift rest of line left

Description

int ncurses_mvdelch ( int y, int x)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvcur | Subir | ncurses_mvgetch


ncurses_mvgetch

(PHP 4 >= 4.2.0)

ncurses_mvgetch -- Move position and get character at new position

Description

int ncurses_mvgetch ( int y, int x)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvdelch | Subir | ncurses_mvhline


ncurses_mvhline

(PHP 4 >= 4.2.0)

ncurses_mvhline -- Set new position and draw a horizontal line using an attributed character and max. n characters long

Description

int ncurses_mvhline ( int y, int x, int attrchar, int n)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvgetch | Subir | ncurses_mvinch


ncurses_mvinch

(PHP 4 >= 4.2.0)

ncurses_mvinch -- Move position and get attributed character at new position

Description

int ncurses_mvinch ( int y, int x)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvhline | Subir | ncurses_mvvline


ncurses_mvvline

(unknown)

ncurses_mvvline -- Set new position and draw a vertical line using an attributed character and max. n characters long

Description

int ncurses_mvvline ( int y, int x, int attrchar, int n)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvinch | Subir | ncurses_mvwaddstr


ncurses_mvwaddstr

(PHP 4 >= 4.2.0)

ncurses_mvwaddstr -- Add string at new position in window

Description

int ncurses_mvwaddstr ( resource window, int y, int x, string text)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvvline | Subir | ncurses_napms


ncurses_napms

(PHP 4 >= 4.1.0)

ncurses_napms -- Sleep

Description

int ncurses_napms ( int milliseconds)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_mvwaddstr | Subir | ncurses_newwin


ncurses_newwin

(PHP 4 >= 4.1.0)

ncurses_newwin -- Create a new window

Description

int ncurses_newwin ( int rows, int cols, int y, int x)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_napms | Subir | ncurses_noqiflush


ncurses_noqiflush

(PHP 4 >= 4.1.0)

ncurses_noqiflush -- Do not flush on signal characters

Description

int ncurses_noqiflush ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_newwin | Subir | ncurses_putp


ncurses_putp

(PHP 4 >= 4.2.0)

ncurses_putp --

Description

int ncurses_putp ( string text)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_noqiflush | Subir | ncurses_qiflush


ncurses_qiflush

(PHP 4 >= 4.1.0)

ncurses_qiflush -- Flush on signal characters

Description

int ncurses_qiflush ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_putp | Subir | ncurses_refresh


ncurses_refresh

(PHP 4 >= 4.1.0)

ncurses_refresh -- Refresh screen

Description

int ncurses_refresh ( int ch)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_qiflush | Subir | ncurses_scr_dump


ncurses_scr_dump

(PHP 4 >= 4.2.0)

ncurses_scr_dump -- Dump screen content to file

Description

int ncurses_scr_dump ( string filename)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_refresh | Subir | ncurses_scr_init


ncurses_scr_init

(PHP 4 >= 4.2.0)

ncurses_scr_init -- Initialize screen from file dump

Description

int ncurses_scr_init ( string filename)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_scr_dump | Subir | ncurses_scr_restore


ncurses_scr_restore

(PHP 4 >= 4.2.0)

ncurses_scr_restore -- Restore screen from file dump

Description

int ncurses_scr_restore ( string filename)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_scr_init | Subir | ncurses_scr_set


ncurses_scr_set

(PHP 4 >= 4.2.0)

ncurses_scr_set -- Inherit screen from file dump

Description

int ncurses_scr_set ( string filename)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_scr_restore | Subir | ncurses_scrl


ncurses_scrl

(PHP 4 >= 4.1.0)

ncurses_scrl -- Scroll window content up or down without changing current position

Description

int ncurses_scrl ( int count)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_scr_set | Subir | ncurses_slk_attroff


ncurses_slk_attroff

(PHP 4 >= 4.1.0)

ncurses_slk_attroff --

Description

int ncurses_slk_attroff ( int intarg)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_scrl | Subir | ncurses_slk_attron


ncurses_slk_attron

(PHP 4 >= 4.1.0)

ncurses_slk_attron --

Description

int ncurses_slk_attron ( int intarg)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_slk_attroff | Subir | ncurses_slk_attrset


ncurses_slk_attrset

(PHP 4 >= 4.1.0)

ncurses_slk_attrset --

Description

int ncurses_slk_attrset ( int intarg)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_slk_attron | Subir | ncurses_slk_color


ncurses_slk_color

(PHP 4 >= 4.1.0)

ncurses_slk_color -- Sets color for soft label keys

Description

int ncurses_slk_color ( int intarg)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_slk_attrset | Subir | ncurses_standend


ncurses_standend

(PHP 4 >= 4.1.0)

ncurses_standend -- Stop using 'standout' attribute

Description

int ncurses_standend ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_slk_color | Subir | ncurses_standout


ncurses_standout

(PHP 4 >= 4.1.0)

ncurses_standout -- Start using 'standout' attribute

Description

int ncurses_standout ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_standend | Subir | ncurses_start_color


ncurses_start_color

(PHP 4 >= 4.1.0)

ncurses_start_color -- Start using colors

Description

int ncurses_start_color ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_standout | Subir | ncurses_typeahead


ncurses_typeahead

(PHP 4 >= 4.1.0)

ncurses_typeahead -- Specify different filedescriptor for typeahead checking

Description

int ncurses_typeahead ( int fd)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_start_color | Subir | ncurses_ungetch


ncurses_ungetch

(PHP 4 >= 4.1.0)

ncurses_ungetch -- Put a character back into the input stream

Description

int ncurses_ungetch ( int keycode)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_typeahead | Subir | ncurses_use_extended_names


ncurses_use_extended_names

(PHP 4 >= 4.1.0)

ncurses_use_extended_names -- Control use of extended names in terminfo descriptions

Description

int ncurses_use_extended_names ( bool flag)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_ungetch | Subir | ncurses_vidattr


ncurses_vidattr

(PHP 4 >= 4.1.0)

ncurses_vidattr --

Description

int ncurses_vidattr ( int intarg)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_use_extended_names | Subir | ncurses_vline


ncurses_vline

(PHP 4 >= 4.2.0)

ncurses_vline -- Draw a vertical line at current position using an attributed character and max. n characters long

Description

int ncurses_vline ( int charattr, int n)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_vidattr | Subir | ncurses_wrefresh


ncurses_wrefresh

(PHP 4 >= 4.2.0)

ncurses_wrefresh -- Refresh window on terminal screen

Description

int ncurses_wrefresh ( resource window)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_vline | Subir | ncurses_bkgdset


ncurses_bkgdset

(PHP 4 >= 4.1.0)

ncurses_bkgdset -- Control screen background

Description

void ncurses_bkgdset ( int attrchar)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_wrefresh | Subir | ncurses_timeout


ncurses_timeout

(PHP 4 >= 4.1.0)

ncurses_timeout -- Set timeout for special key sequences

Description

void ncurses_timeout ( int millisec)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_bkgdset | Subir | ncurses_use_env


ncurses_use_env

(PHP 4 >= 4.1.0)

ncurses_use_env -- Control use of environment information about terminal size

Description

void ncurses_use_env ( bool flag)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

undocumented

Anterior | Inicio | Siguiente
ncurses_timeout | Subir | ncurses_termname


ncurses_termname

(PHP 4 >= 4.2.0)

ncurses_termname -- Returns terminals (short)-name

Description

string ncurses_termname ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_termname() returns terminals shortname. The shortname is truncated to 14 characters. On error ncurses_termname() returns NULL.

See also: ncurses_longname()

Anterior | Inicio | Siguiente
ncurses_use_env | Subir | ncurses_longname


ncurses_longname

(PHP 4 >= 4.2.0)

ncurses_longname -- Returns terminals description

Description

string ncurses_longname ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_longname() returns a verbose description of the terminal. The descritpion is truncated to 128 characters. On Error ncurses_longname() returns NULL.

See also: ncurses_termname()

Anterior | Inicio | Siguiente
ncurses_termname | Subir | ncurses_mousemask


ncurses_mousemask

(PHP 4 >= 4.2.0)

ncurses_mousemask -- Sets mouse options

Description

int ncurses_mousemask ( int newmask, int oldmask)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Function ncurses_mousemask() will set mouse events to be reported. By default no mouse events will be reported. The function ncurses_mousemask() will return a mask to indicated which of the in parameter newmask specified mouse events can be reported. On complete failure, it returns 0. In parameter oldmask, which is passed by reference ncurses_mousemask() returns the previous value of mouse event mask. Mouse events are represented bei NCURSES_KEY_MOUSE in the ncurses_wgetch() input stream. To read the event data and pop the event of of queue, call ncurses_getmouse().

As a side effect, setting a zero mousemask in newmask turns off the mouse pointer. Setting a non zero value turns mouse pointer on.

mouse mask options can be set with the following predefined constants:

  • NCURSES_BUTTON1_PRESSED

  • NCURSES_BUTTON1_RELEASED

  • NCURSES_BUTTON1_CLICKED

  • NCURSES_BUTTON1_DOUBLE_CLICKED

  • NCURSES_BUTTON1_TRIPLE_CLICKED

  • NCURSES_BUTTON2_PRESSED

  • NCURSES_BUTTON2_RELEASED

  • NCURSES_BUTTON2_CLICKED

  • NCURSES_BUTTON2_DOUBLE_CLICKED

  • NCURSES_BUTTON2_TRIPLE_CLICKED

  • NCURSES_BUTTON3_PRESSED

  • NCURSES_BUTTON3_RELEASED

  • NCURSES_BUTTON3_CLICKED

  • NCURSES_BUTTON3_DOUBLE_CLICKED

  • NCURSES_BUTTON3_TRIPLE_CLICKED

  • NCURSES_BUTTON4_PRESSED

  • NCURSES_BUTTON4_RELEASED

  • NCURSES_BUTTON4_CLICKED

  • NCURSES_BUTTON4_DOUBLE_CLICKED

  • NCURSES_BUTTON4_TRIPLE_CLICKED

  • NCURSES_BUTTON_SHIFT>

  • NCURSES_BUTTON_CTRL

  • NCURSES_BUTTON_ALT

  • NCURSES_ALL_MOUSE_EVENTS

  • NCURSES_REPORT_MOUSE_POSITION

See also: ncurses_getmouse(),
          ncurses_ungetmouse()
          ncurese_getch()

Ejemplo 1. ncurses_mousemask() example

$newmask = NCURSES_BUTTON1_CLICKED + NCURSES_BUTTON1_RELEASED;
$mask = ncurses_mousemask($newmask, &$oldmask);
if ($mask & $newmask){
  printf ("All specified mouse options will be supported\n");
}

Anterior | Inicio | Siguiente
ncurses_longname | Subir | ncurses_getmouse


ncurses_getmouse

(PHP 4 >= 4.2.0)

ncurses_getmouse -- Reads mouse event

Description

bool ncurses_getmouse ( array mevent)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_getmouse() reads mouse event out of queue. Function ncurses_getmouse() will return ;FALSE if a mouse event is actually visible in the given window, otherwise it will return TRUE. Event options will be delivered in parameter mevent, which has to be an array, passed by reference (see example below). On success an associative array with following keys will be delivered:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

Ejemplo 1. ncurses_getmouse() example

switch (ncurses_getch){
  case NCURSES_KEY_MOUSE:
    if (!ncurses_getmouse(&$mevent)){
      if ($mevent["mmask"] & NCURSES_MOUSE_BUTTON1_PRESSED){
        $mouse_x = $mevent["x"]; // Save mouse position
        $mouse_y = $mevent["y"];
      }
    }
  break;

  default:
    ....
}

See also: ncurses_ungetmouse()

Anterior | Inicio | Siguiente
ncurses_mousemask | Subir | ncurses_ungetmouse


ncurses_ungetmouse

(PHP 4 >= 4.2.0)

ncurses_ungetmouse -- Pushes mouse event to queue

Description

bool ncurses_ungetmouse ( array mevent)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

ncurses_getmouse() pushes a KEY_MOUSE event onto the unput queue and associates with this event the given state sata and screen-relative character cell coordinates, specified in mevent. Event options will be specified in associative array mevent:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

ncurses_ungetmouse() returns FALSE on success, otherwise TRUE.

See also: ncurses_getmouse()

Anterior | Inicio | Siguiente
ncurses_getmouse | Subir | Lotus Notes functions


Lotus Notes functions

Manual de PHP
Anterior Siguiente

LXVI. Lotus Notes functions

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

Tabla de contenidos
notes_create_db — Create a Lotus Notes database
notes_drop_db — Drop a Lotus Notes database
notes_version — Get the version Lotus Notes
notes_create_note — Create a note using form form_name
notes_mark_read — Mark a note_id as read for the User user_name
notes_mark_unread — Mark a note_id as unread for the User user_name
notes_unread — Returns the unread note id's for the current User user_name
notes_header_info — Open the message msg_number in the specified mailbox on the specified server (leave serv
notes_body — Open the message msg_number in the specified mailbox on the specified server (leave serv
notes_find_note — Returns a note id found in database_name. Specify the name of the note. Leaving type bla
notes_nav_create — Create a navigator name, in database_name
notes_search — Find notes that match keywords in database_name
notes_copy_db — Create a note using form form_name
notes_list_msgs — Returns the notes from a selected database_name

Anterior | Inicio | Siguiente
ncurses_ungetmouse | Subir | notes_create_db


notes_create_db

(PHP 4 >= 4.0.5)

notes_create_db -- Create a Lotus Notes database

Description

bool notes_create_db ( string database_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
Lotus Notes functions | Subir | notes_drop_db


notes_drop_db

(PHP 4 >= 4.0.5)

notes_drop_db -- Drop a Lotus Notes database

Description

bool notes_drop_db ( string database_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_create_db | Subir | notes_version


notes_version

(PHP 4 >= 4.0.5)

notes_version -- Get the version Lotus Notes

Description

string notes_version ( string database_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_drop_db | Subir | notes_create_note


notes_create_note

(PHP 4 >= 4.0.5)

notes_create_note -- Create a note using form form_name

Description

string notes_create_note ( string database_name, string form_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_version | Subir | notes_mark_read


notes_mark_read

(PHP 4 >= 4.0.5)

notes_mark_read -- Mark a note_id as read for the User user_name

Description

string notes_mark_read ( string database_name, string user_name, string note_id)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_create_note | Subir | notes_mark_unread


notes_mark_unread

(PHP 4 >= 4.0.5)

notes_mark_unread -- Mark a note_id as unread for the User user_name

Description

string notes_mark_unread ( string database_name, string user_name, string note_id)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_mark_read | Subir | notes_unread


notes_unread

(PHP 4 >= 4.0.5)

notes_unread -- Returns the unread note id's for the current User user_name

Description

string notes_unread ( string database_name, string user_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_mark_unread | Subir | notes_header_info


notes_header_info

(PHP 4 >= 4.0.5)

notes_header_info -- Open the message msg_number in the specified mailbox on the specified server (leave serv

Description

object notes_header_info ( string server, string mailbox, int msg_number)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_unread | Subir | notes_body


notes_body

(PHP 4 >= 4.0.5)

notes_body -- Open the message msg_number in the specified mailbox on the specified server (leave serv

Description

array notes_body ( string server, string mailbox, int msg_number)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_header_info | Subir | notes_find_note


notes_find_note

(PHP 4 >= 4.0.5)

notes_find_note -- Returns a note id found in database_name. Specify the name of the note. Leaving type bla

Description

bool notes_find_note ( string database_name, string name [, string type])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_body | Subir | notes_nav_create


notes_nav_create

(PHP 4 >= 4.0.5)

notes_nav_create -- Create a navigator name, in database_name

Description

bool notes_nav_create ( string database_name, string name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_find_note | Subir | notes_search


notes_search

(PHP 4 >= 4.0.5)

notes_search -- Find notes that match keywords in database_name

Description

string notes_search ( string database_name, string keywords)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_nav_create | Subir | notes_copy_db


notes_copy_db

(PHP 4 >= 4.0.5)

notes_copy_db -- Create a note using form form_name

Description

string notes_copy_db ( string from_database_name, string to_database_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_search | Subir | notes_list_msgs


notes_list_msgs

(PHP 4 >= 4.0.5)

notes_list_msgs -- Returns the notes from a selected database_name

Description

bool notes_list_msgs ( string db)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
notes_copy_db | Subir | ODBC functions


ODBC functions

Manual de PHP
Anterior Siguiente

LXVII. ODBC functions

Tabla de contenidos
odbc_autocommit — Interruptor de comportamiento de auto-entrega
odbc_binmode — Manejo de campos de datos binarios
odbc_close — Cierra una conexion ODBC
odbc_close_all — Cierra todas las conexiones ODBC
odbc_commit — Entrega una transaccion ODBC
odbc_connect — Conecta a una fuente de datos
odbc_cursor — Toma un nombre de cursor
odbc_do — sinonimo de odbc_exec()
odbc_exec — Prepara o ejecuta una declaracion SQL
odbc_execute — ejecuta una declaracion preparada
odbc_fetch_into — Busca un registro de resutados dentro de un vector
odbc_fetch_row — Busca un registro
odbc_field_len — Da la longitud de un campo
odbc_field_name — Devuelve el nombre de campo
odbc_field_num — Devuelve el numero de campo
odbc_field_type — Tipo de datos de un campo
odbc_free_result — recursos libres asociados con un resultado
odbc_longreadlen — manejo de LONGITUD de columnas
odbc_num_fields — numero de campos de un resultado
odbc_num_rows — Numero de campos en un resultado
odbc_pconnect — Abre una conexion permanente de base de datos
odbc_prepare — Prepara una declaracion para su ejecucion
odbc_result — coge informacion de un campo
odbc_result_all — Print result as HTML table
odbc_rollback — Volver a pasar una transacion
odbc_setoption — Ajusta la configuracion de ODBC. Devuelve FALSE en caso de error, en otro caso TRUE.

Anterior | Inicio | Siguiente
notes_list_msgs | Subir | odbc_autocommit


odbc_autocommit

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_autocommit -- Interruptor de comportamiento de auto-entrega

Descripcion

int odbc_autocommit ( int connection_id [, int OnOff])

Sin el parametro OnOff, esta funcion devuelve el estado de auto-entrega para connection_id. Devuelve TRUE si auto-entrega esta habilitado, y FALSE si no lo esta o ha ocurrido un error.

Si OnOff es TRUE, auto-entrega esta activado, si es FALSE auto-entrega esta desactivado. Devuelve TRUE cuando se cumple, FALSE cuando falla.

Por defecto, auto-entrega es para una conexion. Desabilitar auto-entrega es como comenzar una transaccion.

Ver tambien odbc_commit() y odbc_rollback().

Anterior | Inicio | Siguiente
ODBC functions | Subir | odbc_binmode


odbc_binmode

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_binmode -- Manejo de campos de datos binarios

Descripcion

int odbc_binmode ( int result_id, int mode)

(Elementos afectados ODBC SQL: BINARY, VARBINARY, LONGVARBINARY)

  • ODBC_BINMODE_PASSTHRU: Paso a traves de datos binarios

  • ODBC_BINMODE_RETURN: Devuelve como es

  • ODBC_BINMODE_CONVERT: Devuelve convertido en caracter

Cuando los datos binarios en SQL son convertidos a datos caracter en C, cada byte (8 bits) de datos fuente es representada como dos caracteres en ASCII. Esos caracteres son la representacion en ASCII de los numeros en su forma Hexadecimal. Por ejemplo, un 00000001 binario es convertido a "01" y un 11111111 binario es convertido a "FF".

Tabla 1. Manejo de LONGVARBINARY

modo binario | longreadlen | resultado
ODBC_BINMODE_PASSTHRU | 0 | passthru
ODBC_BINMODE_RETURN | 0 | passthru
ODBC_BINMODE_CONVERT | 0 | passthru
ODBC_BINMODE_PASSTHRU | 0 | passthru
ODBC_BINMODE_PASSTHRU | >0 | passthru
ODBC_BINMODE_RETURN | >0 | Devuleve como es
ODBC_BINMODE_CONVERT | >0 | Devuelve como caracter

Si usamos odbc_fetch_into(), passthru significara que una cadena vacia es devuelta por esas campos.

Si result_id es 0, las definiciones se aplican por defecto para nuevos resultados.

Nota: Por defecto, longreadlen es 4096 y el modo binario por defecto es ODBC_BINMODE_RETURN. El manejo de campos binarias largas tambien esta afectado por odbc_longreadlen()

Anterior | Inicio | Siguiente
odbc_autocommit | Subir | odbc_close


odbc_close

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_close -- Cierra una conexion ODBC

Descripcion

void odbc_close ( int connection_id)

odbc_close() cerrara la conexion al servidor de bases datos asociado con el identificador de conexion dado.

Nota: Esta funcion fallara si hay transacciones abiertas sobre esta conexion. La conexion quedara abierta en ese caso.

Anterior | Inicio | Siguiente
odbc_binmode | Subir | odbc_close_all


odbc_close_all

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_close_all -- Cierra todas las conexiones ODBC

Descripcion

void odbc_close_all ( void)

odbc_close_all() cerrara todas las conexiones a servidor(es) de bases de datos.

Nota: Esta funcion fallara si hay transacciones abiertas sobre esta conexion. La conexion quedara abierta en ese caso.

Anterior | Inicio | Siguiente
odbc_close | Subir | odbc_commit


odbc_commit

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_commit -- Entrega una transaccion ODBC

Descripcion

int odbc_commit ( int connection_id)

Devuelve: TRUE si la operacion se realiza con exito, FALSE si falla. Todas las transacciones pendientes sobre connection_id son entregadas.

Anterior | Inicio | Siguiente
odbc_close_all | Subir | odbc_connect


odbc_connect

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_connect -- Conecta a una fuente de datos

Descripcion

int odbc_connect ( string dsn, string user, string password [, int cursor_type])

Devuelve una conexion ODBC id, o 0 (FALSE) cuando ocurre un error.

La conexion id devuelta por estas funciones es necesaria para otras funciones ODBC. Se pueden tener multiples conexiones abiertas a la vez. El opcional cuarto parametro asigna el tipo de cursor que va a ser usado para esta conexion. Este parametro normalmente no es necesario, pero puede ser util para trabajar sobre problemas con algunos drivers ODBC.

Con algunos drivers ODBC, si ejecutamos un procedimiento complejo, este puede fallar con un error similar a: "Cannot open a cursor on a stored procedure that has anything other than a single select statement in it". Usando SQL_CUR_USE_ODBC se puede evitar ese error. Algunos drivers tampoco soportan el parametro row_number en odbc_fetch_row(). SQL_CUR_USE_ODBC tambien podria ayudar en ese caso.

Las siguientes constantes son definidas por tipos de cursor:

  • SQL_CUR_USE_IF_NEEDED

  • SQL_CUR_USE_ODBC

  • SQL_CUR_USE_DRIVER

  • SQL_CUR_DEFAULT

Para conexiones persistentes ver odbc_pconnect().

Anterior | Inicio | Siguiente
odbc_commit | Subir | odbc_cursor


odbc_cursor

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_cursor -- Toma un nombre de cursor

Descripcion

string odbc_cursor ( int result_id)

odbc_cursor devolvera un nombre de cursor para el result_id dado.

Anterior | Inicio | Siguiente
odbc_connect | Subir | odbc_do


odbc_do

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_do -- sinonimo de odbc_exec()

Descripcion

string odbc_do ( int conn_id, string query)

odbc_do ejecutara una consulta (query) sobre la conexion dada

Anterior | Inicio | Siguiente
odbc_cursor | Subir | odbc_exec


odbc_exec

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_exec -- Prepara o ejecuta una declaracion SQL

Descripcion

int odbc_exec ( int connection_id, string query_string)

Devuelve FALSE en caso de error. Devuelve un indetificador ODBC si el comando SQL fue ejecutado satisfactoriamente.

odbc_exec() enviara una declaracion SQL al servidor de bases de datos specificado por connection_id. Este parametro debe ser un indetificador valido devuelto por odbc_connect() o odbc_pconnect().

Ver tambien: odbc_prepare() y odbc_execute() para ejecucion multiple de declaraciones SQL.

Anterior | Inicio | Siguiente
odbc_do | Subir | odbc_execute


odbc_execute

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_execute -- ejecuta una declaracion preparada

Descripcion

int odbc_execute ( int result_id [, array parameters_array])

Ejecuta uan declaracion preparada con odbc_prepare(). Devuelve TRUE cuando la ejecucion es satisfactoria, FALSE en otro caso. Introducir el vector arameters_array solo es necesario si realmente tenemos parametros en la declaracion.

Anterior | Inicio | Siguiente
odbc_exec | Subir | odbc_fetch_into


odbc_fetch_into

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_fetch_into -- Busca un registro de resutados dentro de un vector

Descripcion

int odbc_fetch_into ( int result_id [, int rownumber, array result_array])

Devuelve el numero de campos en el resultado; FALSE on error. result_array debe ser pasado por referencia, pero puede ser de cualquier tipo, desde este sera convertido a tipo vector. El vector contendra el valor de campo inicial empezando en indice de vector 0.

Anterior | Inicio | Siguiente
odbc_execute | Subir | odbc_fetch_row


odbc_fetch_row

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_fetch_row -- Busca un registro

Descripcion

int odbc_fetch_row ( int result_id [, int row_number])

Si odbc_fetch_row() fue succesful (there was a row), TRUE is returned. If there are no more rows, FALSE is returned.

odbc_fetch_row() busca un registro de datos
que fue devuelta por odbc_do() /
odbc_exec().  Despues de que
odbc_fetch_row() sea llamado, se puede acceder a los campos
de este registro con odbc_result().

Si no se especifica row_number, odbc_fetch_row() intentara buscar el siguiente registro en los resultados. Lamar a odbc_fetch_row() con o sin row_number puede ser mezclado.

Para pasar a traves del resultado mas de una vez, se puede llamar a odbc_fetch_row() con row_number 1, y despues continuar haciendo odbc_fetch_row() sin row_number para revisar el resultado. Si un driver no admitiese busquedas de registros por numero, el parametro row_number seria ignorado.

Anterior | Inicio | Siguiente
odbc_fetch_into | Subir | odbc_field_len


odbc_field_name

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_field_name -- Devuelve el nombre de campo

Descripcion

string odbc_fieldname ( int result_id, int field_number)

odbc_field_name() devolvera el nombre del campo almacenado en el numero de campo elegido dentro del identificador ODBC. La numeracion de campos comienza en 1. En caso de error devolveria FALSE.

Anterior | Inicio | Siguiente
odbc_field_len | Subir | odbc_field_num


odbc_field_type

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_field_type -- Tipo de datos de un campo

Descripcion

string odbc_field_type ( int result_id, int field_number)

odbc_field_type() Devolvera el tipo SQL de un campo referenciado por numero en el identificador ODBC. identifier. La numeracion de campos comienza en 1.

Anterior | Inicio | Siguiente
odbc_field_num | Subir | odbc_free_result


odbc_field_len

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_field_len -- Da la longitud de un campo

Descripcion

int odbc_field_len ( int result_id, int field_number)

odbc_field_len() devolvera la longitud de un campo referenciado por numero en un identificador ODBC La numeracion de campos comienza en 1.

Anterior | Inicio | Siguiente
odbc_fetch_row | Subir | odbc_field_name


odbc_free_result

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_free_result -- recursos libres asociados con un resultado

Descripcion

int odbc_free_result ( int result_id)

Always returns TRUE.

odbc_free_result() solo necesita ser llamado en caso de preocupacion por demasiado uso de memoria cuando se ejecuta un script. Toda la memoria resultante quedara automaticamente liberada cuando el script finalice. Pero si es seguro que no se vaya a necesitar la informacion nada mas que en un script, se debera llamar a la funcion odbc_free_result(), y la memoria asociada con result_id sera liberada.

Nota: Si la auto-entrega no esta activada la (ver odbc_autocommit()) y se ejecuta odbc_free_result() antes de la entrega, todo queda pendiente de las transaciones que esten en lista.

Anterior | Inicio | Siguiente
odbc_field_type | Subir | odbc_longreadlen


odbc_longreadlen

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_longreadlen -- manejo de LONGITUD de columnas

Descripcion

int odbc_longreadlen ( int result_id, int length)

(ODBC SQL tipos relaccionados: LONG, LONGVARBINARY) El numero de bytes devueltos para PHP es controlado por el parametro length. Si es asignado a 0, la longitud del campo es pasado al cliente.

Nota: El manejo de campos LONGVARBINARY tambien esta afectado por odbc_binmode()

Anterior | Inicio | Siguiente
odbc_free_result | Subir | odbc_num_fields


odbc_num_fields

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_num_fields -- numero de campos de un resultado

Descripcion

int odbc_num_fields ( int result_id)

odbc_num_fields() devolvera el numero de campos dentro de un ODBC. Esta funcion devolvera -1 en caso de error. El argumento es un identificador valido devuelto por odbc_exec().

Anterior | Inicio | Siguiente
odbc_longreadlen | Subir | odbc_num_rows


odbc_pconnect

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_pconnect -- Abre una conexion permanente de base de datos

Descripcion

int odbc_pconnect ( string dsn, string user, string password [, int cursor_type])

Devuelve un identificador de conexion ODBC o 0 (FALSE) en caso de error. Esta funcion es odbc_connect(), excepto que la conexion no sea realmente cerrada cuando el script ha finalizado. Las respuestas futuras para una conexion con la misma combinacion dsn, user, password (via odbc_connect() y odbc_pconnect()) puede reusar la conexion permanente.

Nota: Las conexiones permanentes no tienen efecto si PHP es usado como programa CGI.

Para informacion acerca del paramentor opcional cursor_type ver la funcion odbc_connect(). Para mas informacion sobre conexiones permanentes, ir al apartado PHP FAQ.

Anterior | Inicio | Siguiente
odbc_num_rows | Subir | odbc_prepare


odbc_prepare

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_prepare -- Prepara una declaracion para su ejecucion

Descripcion

int odbc_prepare ( int connection_id, string query_string)

Devuelve FALSE en caso de error.

Devuelve un identificador ODBC si el comando SQL esta preparado. El identificador resultante puede ser usado mas tarde para ejecutar la declaracion con odbc_execute().

Anterior | Inicio | Siguiente
odbc_pconnect | Subir | odbc_result


odbc_num_rows

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_num_rows -- Numero de campos en un resultado

Descripcion

int odbc_num_rows ( int result_id)

odbc_num_rows() devolvera el numero de registros de un ODBC. Esta funcion devolvera -1 en caso de error. Para declaraciones INSERT, UPDATE y DELETE odbc_num_rows() devolvera el numero de registros afectados. Para una clausula SELECT esta puede ser el numero de registros permitidos.

Nota: El uso de odbc_num_rows() para determinar el numero de registros permitidos despues de un SELECT devolvera -1.

Anterior | Inicio | Siguiente
odbc_num_fields | Subir | odbc_pconnect


odbc_result

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_result -- coge informacion de un campo

Descripcion

string odbc_result ( int result_id, mixed field)

Devuelve el contenido de un campo.

field puede ser cualquier contenido del campo que queramos; o puede ser una cadena que contenga el nombre del campo; Por ejemplo:

$item_3 = odbc_result($Query_ID, 3 );
     $item_val = odbc_result($Query_ID, "val");

La primera sentencia odbc_result() devuelve el valor del tercer campo detro del registro actual de la cola resultante. La segunda funcion llama a odbc_result() y devuelve el valor de un campo cuyo nombre es "val" en el registro actual de la cola resultante. Ocurre un error si un numero de columna para un campo es menor que uno o excede el numero de campos en el registro actual. Similarmente, ocurre un error si un campo con un nombre que no sea uno de los nombres de campo de una talba o tablas que sea o sean encoladas.

Los indices de campo comienzan en 1. Recordando el metodo binario de campos con gran informacion, es devuleto con referencia a odbc_binmode () y odbc_longreadlen().

Anterior | Inicio | Siguiente
odbc_prepare | Subir | odbc_result_all


odbc_result_all

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_result_all -- Print result as HTML table

Descripcion

int odbc_result_all ( int result_id [, string format])

En caso de error, como resultado, devuelve FALSE.

odbc_result_all() Imprimira todos los registros de un identificador prducidoo por odbc_exec(). El resultado es impreso en una tabla formato HTML. Con el argumento de cadena opcional format, ademas, todas los formatos de tablas pueden ser realizadas.

Anterior | Inicio | Siguiente
odbc_result | Subir | odbc_rollback


odbc_rollback

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_rollback -- Volver a pasar una transacion

Descripcion

int odbc_rollback ( int connection_id)

Vuelve a pasar todas las declaraciones pendientes connection_id. Devuelve TRUE cuando el resultado es satisfactorio, FALSE cuando no lo es.

Anterior | Inicio | Siguiente
odbc_result_all | Subir | odbc_setoption


odbc_setoption

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_setoption -- Ajusta la configuracion de ODBC. Devuelve FALSE en caso de error, en otro caso TRUE.

Descripcion

int odbc_setoption ( int id, int function, int option, int param)

Esta funcion permite buscar las opciones ODBC para una conexion particular o consulta resultante. Esto esta escrito para trabajar sobre problemas en peculiaries drivers ODBC. Esta funcion Solo se deberia usar siendo un programador de ODBC y entendiendo los efectos que las opciones tendran. Debemos tener la certeza de que necesitamos una buena referencia de reference to explicar todas las diferentes opciones y valores que pueden ser usados. Las diferentes versiones de drivers soportan diferentes opciones.

Ya que los efectos pueden variar dependiendo del driver ODBC, deberiamos usar la function en scripts para ser hecho publico lo que permitira que sea fuertemente desalentado. Algunas opciones ODBC no estan permitidas para esta funcion porque debe ser configurada antes de que la conexion sea establecida o la consulta este preparada. Sin embargo, si un determinado trabajo hace la tarea de PHP, el jefe no contaria con nosotros para usar un producto comercial, esto es lo que realmente suele pasar.

Id es una coexion id o resultado id sobre la que cambiaremos la configuracion. Para SQLSetConnectOption(), esta es una conexion id. Para SQLSetStmtOption(), este es un resultado id.

function es la funcion ODBC a usar. El valor deberia ser 1 para SQLSetConnectOption() y 2 para SQLSetStmtOption().

Parmeter option es la opcion a configurar.

El parametro param es el valor para la escogida opcion option.

Ejemplo 1. Ejemplos ODBC Setoption

// 1. Option 102 of SQLSetConnectOption() is SQL_AUTOCOMMIT.
//    Value 1 of SQL_AUTOCOMMIT is SQL_AUTOCOMMIT_ON.
//    Este ejemplo tiene el mismo efecto que
//    odbc_autocommit($conn, true);

odbc_setoption ($conn, 1, 102, 1);

// 2. Option 0 of SQLSetStmtOption() is SQL_QUERY_TIMEOUT.
//    Este ejemplo asigna el tiempo de espera de la consulta a 30 segundos.

$result = odbc_prepare ($conn, $sql);
odbc_setoption ($result, 2, 0, 30);
odbc_execute ($result);

Anterior | Inicio | Siguiente
odbc_rollback | Subir | Funciones de Oracle 8


Funciones de Oracle 8

Manual de PHP
Anterior Siguiente

LXVIII. Funciones de Oracle 8

Estas funciones permiten acceder a bases de datos Oracle8 y Oracle7. Estas usan la Oracle8 Call-Interface (OCI8). Necesitará las librerías clientes de Oracle8 para usar esta extensión.

Esta extensión es más flexible que las estándar de Oracle. Soporta el enlace de variables locales y globales de PHP con placeholders de Oracle, tiene soporte completo para LOB, FILE y ROWID y le permiten usar las variables definidas por el usuario.

Tabla de contenidos
OCIBindByName — Enlaza una variable PHP a un Placeholder de Oracle
OCIColumnIsNULL — comprueba si una una columna es NULL
OCIColumnName — Devuelve el nombre de una columna.
OCIColumnSize — devuelve el tamaño de la columna
OCIColumnType — Devuelve el tipo de dato de una columna.
OCICommit — Confirma transacciones pendientes
OCIDefineByName — Usa una variable de PHP para el define-step durante una sentencia SELECT
OCIError — Devuelve el último error de stmt|conn|global. Si no ocurre ningún error devuelve falso.
OCIExecute — Ejecuta una sentencia
OCIFetch — Busca la siguiente fila en el result-buffer
OCIFetchInto — Busca la siguiente fila dentro del result-array
OCIFetchStatement — Busca todas la filas de un resultset dentro de un array.
OCIFreeCursor — Libera todos los recursos asociados con cursor.
OCIFreeStatement — Libera todos los recursos asociados con una sentencia.
OCIInternalDebug — Habilita o deshabilita la salida del depurador interno. Por defecto este está deshabiltado
OCILogOff — Termina la conexion con Oracle
OCILogon — Establece la conexión con Oracle
OCINewCursor — devuelve un cursor nuevo (Statement-Handle) - use esto para enlazar ref-cursors!
OCINewDescriptor — Inicializa un nuevo descriptor vacío LOB/FILE (LOB por defecto)
OCINLogon — Conecta con una base de datos Oracle usando una nueva conexión. Devuelve una nueva sesión.
OCINumCols — Devuelve el número de columnas resultantes en una sentencia
OCIParse — Analiza una consulta y devuelve una sentencia
OCIPLogon — Conecta con una base de datos Oracle usando una conexión persistente. Devuelve una nueva sesión.
OCIResult — Devuelve el valor de una columna en la fila buscada
OCIRollback — Restablece todas las transaciones sin confirmar
OCIRowCount — Obtiene el número de filas afectadas
OCIServerVersion — Devuelve una cadena conteniendo información a cerca de la version del servidor.
OCIStatementType — Devuelve el tipo de una sentencia OCI.

Anterior | Inicio | Siguiente
odbc_setoption | Subir | OCIBindByName


OCIDefineByName

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

OCIDefineByName -- Usa una variable de PHP para el define-step durante una sentencia SELECT

Descripción

int OCIDefineByName ( int stmt, string Column-Name, mixed & variable [, int type])

OCIDefineByName() busca el valor de las Columnas-SQL dentro de variables PHP definidas por el usuario. Cuidado que Oracle nombra todas las columnas en MAYUSCULAS, mientras que en su select puede usar también minúsculas write lower-case. OCIDefineByName() espera que Column-Name esté en mayúsculas. Si define una variable que no existe en la sentecia SELECT, no se producirá ningún error.

Si necesita definir un tipo de dato abstracto (LOB/ROWID/BFILE) tendrá que alojarlo primero usando la función OCINewDescriptor() function. Vea también la función OCIBindByName().

Ejemplo 1. OCIDefineByName

<?php
/* OCIDefineByPos example thies@digicol.de (980219) */

$conn = OCILogon("scott","tiger");

$stmt = OCIParse($conn,"select empno, ename from emp");

/* la definición DEBE hacerse ANTES del ociexecute! */

OCIDefineByName($stmt,"EMPNO",&$empno);
OCIDefineByName($stmt,"ENAME",&$ename);

OCIExecute($stmt);

while (OCIFetch($stmt)) {
    echo "empno:".$empno."\n";
    echo "ename:".$ename."\n";
}

OCIFreeStatement($stmt);
OCILogoff($conn);
?>

Anterior | Inicio | Siguiente
OCICommit | Subir | OCIError


OCIBindByName

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIBindByName -- Enlaza una variable PHP a un Placeholder de Oracle

Descripción

int OCIBindByName ( int stmt, string ph_name, mixed & variable, int length [, int type])

OCIBindByName() enlaza la variable PHP variable a un placeholder de Oracle ph_name. Si esta será usada para entrada o salida se determinará en tiempo de ejecución, y sera resevado el espacio necesario de almacenamiento. El parámetro length establece el tamaño máximo del enlace. Si establece length a -1 OCIBindByName() usará el tamaño de la variable para establecer el tamaño máximo.

Si necesita enlazar tipos de datos abstractos (LOB/ROWID/BFILE) necesitará primero reservar la memoria con la función OCINewDescriptor(). length no se usa para tipos de datos abstractos y debería establecerse a -1. La variable type le informa a Oracle, que tipo de descriptor queremos usar. Los valores posibles son: OCI_B_FILE (Binary-File), OCI_B_CFILE (Character-File), OCI_B_CLOB (Character-LOB), OCI_B_BLOB (Binary-LOB) and OCI_B_ROWID (ROWID).

Ejemplo 1. OCIDefineByName

<?php
/* OCIBindByPos example thies@digicol.de (980221)

  inserts 3 resords into emp, and uses the ROWID for updating the
  records just after the insert.
*/

$conn = OCILogon("scott","tiger");

$stmt = OCIParse($conn,"insert into emp (empno, ename) ".
                       "values (:empno,:ename) ".
                       "returning ROWID into :rid");

$data = array(1111 => "Larry", 2222 => "Bill", 3333 => "Jim");

$rowid = OCINewDescriptor($conn,OCI_D_ROWID);

OCIBindByName($stmt,":empno",&$empno,32);
OCIBindByName($stmt,":ename",&$ename,32);
OCIBindByName($stmt,":rid",&$rowid,-1,OCI_B_ROWID);

$update = OCIParse($conn,"update emp set sal = :sal where ROWID = :rid");
OCIBindByName($update,":rid",&$rowid,-1,OCI_B_ROWID);
OCIBindByName($update,":sal",&$sal,32);

$sal = 10000;

while (list($empno,$ename) = each($data)) {
    OCIExecute($stmt);
    OCIExecute($update);
}

$rowid->free();

OCIFreeStatement($update);
OCIFreeStatement($stmt);

$stmt = OCIParse($conn,"select * from emp where empno in (1111,2222,3333)");
OCIExecute($stmt);
while (OCIFetchInto($stmt,&$arr,OCI_ASSOC)) {
    var_dump($arr);
}
OCIFreeStatement($stmt);

/* delete our "junk" from the emp table.... */
$stmt = OCIParse($conn,"delete from emp where empno in (1111,2222,3333)");
OCIExecute($stmt);
OCIFreeStatement($stmt);

OCILogoff($conn);
?>

Anterior | Inicio | Siguiente
Funciones de Oracle 8 | Subir | OCIColumnIsNULL


OCILogon

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCILogon -- Establece la conexión con Oracle

Descripción

int OCILogon ( string username, string password [, string db])

OCILogon() devuelve el identificador de conexión necesario en la mayoria de las funciones OCI. El tercer parámetro, que es opcional, puede contener el nombre de la instancia a Oracle o el nombre dado en el fichero tnsnames.ora de la base de datos a la que nos queremos conectar. Si este parámetro no se especifica, PHP usa la variable de entorno ORACLE_SID (Oracle instance) o TWO_TASK (tnsnames.ora) para determinar la base de datos con la que queremos conectar.

Las conexiones son compartidas a nivel de página cuando usemos OCILogon(). Lo cual significa que los "commits" y "rollbacks" son aplicadas a todas las transacciones abiertas en la página, incluso si usted ha creado conexiones múltiples.

Este ejemplo demuestra como son compartidas las conexiones.

Ejemplo 1. OCILogon

<?php
print "<HTML><PRE>";
$db = "";

$c1 = ocilogon("scott","tiger",$db);
$c2 = ocilogon("scott","tiger",$db);

function create_table($conn)
{ $stmt = ociparse($conn,"create table scott.hallo (test varchar2(64))");
  ociexecute($stmt);
  echo $conn." created table\n\n";
}

function drop_table($conn)
{ $stmt = ociparse($conn,"drop table scott.hallo");
  ociexecute($stmt);
  echo $conn." dropped table\n\n";
}

function insert_data($conn)
{ $stmt = ociparse($conn,"insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn." inserted hallo\n\n";
}

function delete_data($conn)
{ $stmt = ociparse($conn,"delete from scott.hallo");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn." deleted hallo\n\n";
}

function commit($conn)
{ ocicommit($conn);
  echo $conn." commited\n\n";
}

function rollback($conn)
{ ocirollback($conn);
  echo $conn." rollback\n\n";
}

function select_data($conn)
{ $stmt = ociparse($conn,"select * from scott.hallo");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn."----selecting\n\n";
  while (ocifetch($stmt))
    echo $conn." <".ociresult($stmt,"TEST").">\n\n";
  echo $conn."----done\n\n";
}

create_table($c1);
insert_data($c1);   // Insert a row using c1
insert_data($c2);   // Insert a row using c2

select_data($c1);   // Results of both inserts are returned
select_data($c2);

rollback($c1);      // Rollback using c1

select_data($c1);   // Both inserts have been rolled back
select_data($c2);

insert_data($c2);   // Insert a row using c2
commit($c2);        // commit using c2

select_data($c1);   // result of c2 insert is returned

delete_data($c1);   // delete all rows in table using c1
select_data($c1);   // no rows returned
select_data($c2);   // no rows returned
commit($c1);        // commit using c1

select_data($c1);   // no rows returned
select_data($c2);   // no rows returned

drop_table($c1);
print "</PRE></HTML>";
?>

See also OCIPLogon() and OCINLogon().

Anterior | Inicio | Siguiente
OCILogOff | Subir | OCINewCursor


OCIPLogon

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

OCIPLogon -- Conecta con una base de datos Oracle usando una conexión persistente. Devuelve una nueva sesión.

Descripción

int OCIPLogon ( string username, string password [, string db])

OCIPLogon() crea una conexión persistente con una base de datos Oracle 8. El tercer parámetro, que es opcional, puede contener el nombre de la instancia a Oracle o el nombre dado en el fichero tnsnames.ora de la base de datos a la que nos queremos conectar. Si este parámetro no se especifica, PHP usa la variable de entorno ORACLE_SID (Oracle instance) o TWO_TASK (tnsnames.ora) para determinar la base de datos con la que queremos conectar.

Vea también OCILogon() y OCINLogon().

Anterior | Inicio | Siguiente
OCIParse | Subir | OCIResult


OCINLogon

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

OCINLogon -- Conecta con una base de datos Oracle usando una nueva conexión. Devuelve una nueva sesión.

Descripción

int OCINLogon ( string username, string password [, string db])

OCINLogon() crea una nueva conexión con una base de datos Oracle 8. El tercer parámetro, que es opcional, puede contener el nombre de la instancia a Oracle o el nombre dado en el fichero tnsnames.ora de la base de datos a la que nos queremos conectar. Si este parámetro no se especifica, PHP usa la variable de entorno ORACLE_SID (Oracle instance) o TWO_TASK (tnsnames.ora) para determinar la base de datos con la que queremos conectar.

OCINLogon() fuerza una nueva conexión. Se debe usar si necesita aislar un conjunto de transacciones. Por defecto, las conexiones son compartidas a nivel de página si usa OCILogon() o a nivel del proceso del servidor web si usa OCIPLogon(). Si posee múltiples conexiones abiertas usando OCINLogon(), todos los "commits" y "rollbacks" se aplican sólo a la conexion especificada.

Este ejemplo demuestra como las conexiones están separadas.

Ejemplo 1. OCINLogon

<?php
print "<HTML><PRE>";
$db = "";

$c1 = ocilogon("scott","tiger",$db);
$c2 = ocinlogon("scott","tiger",$db);

function create_table($conn)
{ $stmt = ociparse($conn,"create table scott.hallo (test
varchar2(64))");
  ociexecute($stmt);
  echo $conn." created table\n\n";
}

function drop_table($conn)
{ $stmt = ociparse($conn,"drop table scott.hallo");
  ociexecute($stmt);
  echo $conn." dropped table\n\n";
}

function insert_data($conn)
{ $stmt = ociparse($conn,"insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn." inserted hallo\n\n";
}

function delete_data($conn)
{ $stmt = ociparse($conn,"delete from scott.hallo");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn." deleted hallo\n\n";
}
function commit($conn)
{ ocicommit($conn);
  echo $conn." commited\n\n";
}

function rollback($conn)
{ ocirollback($conn);
  echo $conn." rollback\n\n";
}

function select_data($conn)
{ $stmt = ociparse($conn,"select * from scott.hallo");
  ociexecute($stmt,OCI_DEFAULT);
  echo $conn."----selecting\n\n";
  while (ocifetch($stmt))
    echo $conn." <".ociresult($stmt,"TEST").">\n\n";
  echo $conn."----done\n\n";
}

create_table($c1);
insert_data($c1);

select_data($c1);
select_data($c2);

rollback($c1);

select_data($c1);
select_data($c2);

insert_data($c2);
commit($c2);

select_data($c1);

delete_data($c1);
select_data($c1);
select_data($c2);
commit($c1);

select_data($c1);
select_data($c2);

drop_table($c1);
print "</PRE></HTML>";
?>

See also OCILogon() and OCIPLogon().

Anterior | Inicio | Siguiente
OCINewDescriptor | Subir | OCINumCols


OCILogOff

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCILogOff -- Termina la conexion con Oracle

Descripción

int OCILogOff ( int connection)

OCILogOff() cierra una conexión con Oracle.

Anterior | Inicio | Siguiente
OCIInternalDebug | Subir | OCILogon


OCIExecute

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIExecute -- Ejecuta una sentencia

Descripción

int OCIExecute ( int statement [, int mode])

OCIExecute() ejecuta una sentencia previamente analizada. (see OCIParse()). El parámetro opcional mode le permite especificar el modo de ejecución (default is OCI_COMMIT_ON_SUCCESS). Si no desea que las sentencias se confirmen automaticamente, especifique OCI_DEFAULT como su modo.

Anterior | Inicio | Siguiente
OCIError | Subir | OCIFetch


OCICommit

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

OCICommit -- Confirma transacciones pendientes

Descripción

int OCICommit ( int connection)

OCICommit() confirma todas las sentencias pendientes para la conexión con Oracle connection.

Anterior | Inicio | Siguiente
OCIColumnType | Subir | OCIDefineByName


OCIRollback

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

OCIRollback -- Restablece todas las transaciones sin confirmar

Descripción

int OCIRollback ( int connection)

OCIRollback() restablece todas las transacciones sin confirmar para la conexión Oracle connection.

Anterior | Inicio | Siguiente
OCIResult | Subir | OCIRowCount


OCINewDescriptor

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

OCINewDescriptor -- Inicializa un nuevo descriptor vacío LOB/FILE (LOB por defecto)

Descripción

string OCINewDescriptor ( int connection [, int type])

OCINewDescriptor() Reserva espacio para mantener descriptores o localizadores LOB. Los valores válidos para el tipo type son OCI_D_FILE, OCI_D_LOB, OCI_D_ROWID. Para descriptores LOB, los métodos load, save, y savefile están asociados con el descriptor, para BFILE sólo el método load existe. Vea el segundo ejemplo.

Ejemplo 1. OCINewDescriptor

<?php
    /* This script is designed to be called from a HTML form.
     * It expects $user, $password, $table, $where, and $commitsize
     * to be passed in from the form.  The script then deletes
     * the selected rows using the ROWID and commits after each
     * set of $commitsize rows. (Use with care, there is no rollback)
     */
    $conn = OCILogon($user, $password);
    $stmt = OCIParse($conn,"select rowid from $table $where");
    $rowid = OCINewDescriptor($conn,OCI_D_ROWID);
    OCIDefineByName($stmt,"ROWID",&$rowid);
    OCIExecute($stmt);
    while ( OCIFetch($stmt) ) {
       $nrows = OCIRowCount($stmt);
       $delete = OCIParse($conn,"delete from $table where ROWID = :rid");
       OCIBindByName($delete,":rid",&$rowid,-1,OCI_B_ROWID);
       OCIExecute($delete);
       print "$nrows\n";
       if ( ($nrows % $commitsize) == 0 ) {
           OCICommit($conn);
       }
    }
    $nrows = OCIRowCount($stmt);
    print "$nrows deleted...\n";
    OCIFreeStatement($stmt);
    OCILogoff($conn);
?>
<?php
    /* This script demonstrates file upload to LOB columns
     * The formfield used for this example looks like this
     * <form action="upload.php3" method="post" enctype="multipart/form-data">
     * <input type="file" name="lob_upload">
     * ...
     */
  if(!isset($lob_upload) || $lob_upload == 'none'){
?>
<form action="upload.php3" method="post" enctype="multipart/form-data">
Upload file: <input type="file" name="lob_upload"><br>
<input type="submit" value="Upload"> - <input type="reset">
</form>
<?php
  } else {
     // $lob_upload contains the temporary filename of the uploaded file
     $conn = OCILogon($user, $password);
     $lob = OCINewDescriptor($conn, OCI_D_LOB);
     $stmt = OCIParse($conn,"insert into $table (id, the_blob)
               values(my_seq.NEXTVAL, EMPTY_BLOB()) returning the_blob into :the_blob");
     OCIBindByName($stmt, ':the_blob', &$lob, -1, OCI_B_BLOB);
     OCIExecute($stmt);
     if($lob->savefile($lob_upload)){
        OCICommit($conn);
        echo "Blob successfully uploaded\n";
     }else{
        echo "Couldn't upload Blob\n";
     }
     OCIFreeDescriptor($lob);
     OCIFreeStatement($stmt);
     OCILogoff($conn);
  }
?>

Anterior | Inicio | Siguiente
OCINewCursor | Subir | OCINLogon


OCIRowCount

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

OCIRowCount -- Obtiene el número de filas afectadas

Descripción

int OCIRowCount ( int statement)

OCIRowCount() devuelve el número de filas afectadas, por ej. en sentencias de actualización. !Esta función no indicará el número de de filas que devuelve una sentencia SELECT!

Ejemplo 1. OCIRowCount

<?php
    print "<HTML><PRE>";
    $conn = OCILogon("scott","tiger");
    $stmt = OCIParse($conn,"create table emp2 as select * from emp");
    OCIExecute($stmt);
    print OCIRowCount($stmt) . " rows inserted.<BR>";
    OCIFreeStatement($stmt);
    $stmt = OCIParse($conn,"delete from emp2");
    OCIExecute($stmt);
    print OCIRowCount($stmt) . " rows deleted.<BR>";
    OCICommit($conn);
    OCIFreeStatement($stmt);
    $stmt = OCIParse($conn,"drop table emp2");
    OCIExecute($stmt);
    OCIFreeStatement($stmt);
    OCILogOff($conn);
    print "</PRE></HTML>";
?>

Anterior | Inicio | Siguiente
OCIRollback | Subir | OCIServerVersion


OCINumCols

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCINumCols -- Devuelve el número de columnas resultantes en una sentencia

Descripción

int OCINumCols ( int stmt)

OCINumCols() devuelve el número de columnas en una sentencia

Ejemplo 1. OCINumCols

<?php
    print "<HTML><PRE>\n";
    $conn = OCILogon("scott", "tiger");
    $stmt = OCIParse($conn,"select * from emp");
    OCIExecute($stmt);
    while ( OCIFetch($stmt) ) {
        print "\n";
        $ncols = OCINumCols($stmt);
        for ( $i = 1; $i <= $ncols; $i++ ) {
            $column_name  = OCIColumnName($stmt,$i);
            $column_value = OCIResult($stmt,$i);
            print $column_name . ': ' . $column_value . "\n";
        }
        print "\n";
    }
    OCIFreeStatement($stmt);
    OCILogoff($conn);
    print "</PRE>";
    print "</HTML>\n";
?>

Anterior | Inicio | Siguiente
OCINLogon | Subir | OCIParse


OCIResult

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIResult -- Devuelve el valor de una columna en la fila buscada

Descripción

mixed OCIResult ( int statement, mixed column)

OCIResult() devuelve el valor de la columna column de la fila actual (vea OCIFetch()).OCIResult() devolverá todo como una cadena excepto para los tipo de datos abstractos (ROWIDs, LOBs and FILEs).

Anterior | Inicio | Siguiente
OCIPLogon | Subir | OCIRollback


OCIFetch

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIFetch -- Busca la siguiente fila en el result-buffer

Descripción

int OCIFetch ( int statement)

OCIFetch() Busca la siguiente fila (para sentencias SELECT) dentro del result-buffer interno.

Anterior | Inicio | Siguiente
OCIExecute | Subir | OCIFetchInto


OCIFetchInto

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIFetchInto -- Busca la siguiente fila dentro del result-array

Descripción

int OCIFetchInto ( int stmt, array & result [, int mode])

OCIFetchInto() busca la siguiente fila (for SELECT statements) dentro del array result. OCIFetchInto() sobreescribirá el contenido previo de result. Por defecto result contendrá un array basado en todas las columnas que no son NULL.

El parámetro mode le permite cambiar el comportamineto por defecto. Puede especificar más de una flag simplemente añadiendolas (ej. OCI_ASSOC+OCI_RETURN_NULLS). Las flags son:

OCI_ASSOC Devuelve un array asociativo.
OCI_NUM Devuelve un array numerado empezando en 1. (POR DEFECTO)
OCI_RETURN_NULLS Devuelve columnas vacias.
OCI_RETURN_LOBS Devuelve el valor de un LOB en vez de el descriptor.

Anterior | Inicio | Siguiente
OCIFetch | Subir | OCIFetchStatement


OCIFetchStatement

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

OCIFetchStatement -- Busca todas la filas de un resultset dentro de un array.

Descripción

int OCIFetchStatement ( int stmt, array & variable)

OCIFetchStatement() busca todas las filas de un resultset dentro de un array definido por el usuario. OCIFetchStatement() devuelve el numero de filas buscadas.

Ejemplo 1. OCIFetchStatement

<?php
/* OCIFetchStatement example mbritton@verinet.com (990624) */

$conn = OCILogon("scott","tiger");

$stmt = OCIParse($conn,"select * from emp");

OCIExecute($stmt);

$nrows = OCIFetchStatement($stmt,$results);
if ( $nrows > 0 ) {
   print "<TABLE BORDER=\"1\">\n";
   print "<TR>\n";
   while ( list( $key, $val ) = each( $results ) ) {
      print "<TH>$key</TH>\n";
   }
   print "</TR>\n";

   for ( $i = 0; $i < $nrows; $i++ ) {
      reset($results);
      print "<TR>\n";
      while ( $column = each($results) ) {
         $data = $column['value'];
         print "<TD>$data[$i]</TD>\n";
      }
      print "</TR>\n";
   }
   print "</TABLE>\n";
} else {
   echo "No data found<BR>\n";
}
print "$nrows Records Selected<BR>\n";

OCIFreeStatement($stmt);
OCILogoff($conn);

?>

Anterior | Inicio | Siguiente
OCIFetchInto | Subir | OCIFreeCursor


OCIColumnIsNULL

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIColumnIsNULL -- comprueba si una una columna es NULL

Descripción

int OCIColumnIsNULL ( int stmt, mixed column)

OCIColumnIsNULL() devuelve vedadero si la columna devuelta column en el resultset de la sentencia stmt es NULL. Puede usar el número de la columna (1-Based) o el nombre de la columa indicado por el parámetro col.

Anterior | Inicio | Siguiente
OCIBindByName | Subir | OCIColumnName


OCIColumnSize

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIColumnSize -- devuelve el tamaño de la columna

Descripción

int OCIColumnSize ( int stmt, mixed column)

OCIColumnSize() devuelve el tamaño de la columna indicada por Oracle Puede utilizar el número de la columna (1-Based) o el nombre indicado en el parámetro col.

Ejemplo 1. OCIColumnSize

<?php
    print "<HTML><PRE>\n";
    $conn = OCILogon("scott", "tiger");
    $stmt = OCIParse($conn,"select * from emp");
    OCIExecute($stmt);
    print "<TABLE BORDER=\"1\">";
    print "<TR>";
    print "<TH>Name</TH>";
    print "<TH>Type</TH>";
    print "<TH>Length</TH>";
    print "</TR>";
    $ncols = OCINumCols($stmt);
    for ( $i = 1; $i <= $ncols; $i++ ) {
        $column_name  = OCIColumnName($stmt,$i);
        $column_type  = OCIColumnType($stmt,$i);
        $column_size  = OCIColumnSize($stmt,$i);
        print "<TR>";
        print "<TD>$column_name</TD>";
        print "<TD>$column_type</TD>";
        print "<TD>$column_size</TD>";
        print "</TR>";
    }
    print "</TABLE>";
    OCIFreeStatement($stmt);
    OCILogoff($conn);
    print "</PRE>";
    print "</HTML>\n";
?>

Vea también OCINumCols(), OCIColumnName(), y OCIColumnSize().

Anterior | Inicio | Siguiente
OCIColumnName | Subir | OCIColumnType


OCIServerVersion

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIServerVersion -- Devuelve una cadena conteniendo información a cerca de la version del servidor.

Descripción

string OCIServerVersion ( int conn)

Ejemplo 1. OCIServerVersion

<?php
   $conn = OCILogon("scott","tiger");
   print "Server Version: " . OCIServerVersion($conn);
   OCILogOff($conn);
?>

Anterior | Inicio | Siguiente
OCIRowCount | Subir | OCIStatementType


OCIStatementType

(PHP 3>= 3.0.5, PHP 4 >= 4.0.0)

OCIStatementType -- Devuelve el tipo de una sentencia OCI.

Descripción

string OCIStatementType ( int stmt)

OCIStatementType() devuelve uno de los siguiente valores:

  1. "SELECT"

  2. "UPDATE"

  3. "DELETE"

  4. "INSERT"

  5. "CREATE"

  6. "DROP"

  7. "ALTER"

  8. "BEGIN"

  9. "DECLARE"

  10. "UNKNOWN"

Ejemplo 1. Code examples

<?php
    print "<HTML><PRE>";
    $conn = OCILogon("scott","tiger");
    $sql  = "delete from emp where deptno = 10";

    $stmt = OCIParse($conn,$sql);
    if ( OCIStatementType($stmt) == "DELETE" ) {
        die "You are not allowed to delete from this table<BR>";
    }

    OCILogoff($conn);
    print "</PRE></HTML>";
?>

Anterior | Inicio | Siguiente
OCIServerVersion | Subir | OpenSSL functions


OCINewCursor

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

OCINewCursor -- devuelve un cursor nuevo (Statement-Handle) - use esto para enlazar ref-cursors!

Descripción

int OCINewCursor ( int conn)

OCINewCursor() allocates a new statement handle on the specified connection.

Ejemplo 1. Usando un REF CURSOR de un procedimiento almacenado

<?php
// suppose your stored procedure info.output returns a ref cursor in :data

$conn = OCILogon("scott","tiger");
$curs = OCINewCursor($conn);
$stmt = OCIParse($conn,"begin info.output(:data); end;");

ocibindbyname($stmt,"data",&$curs,-1,OCI_B_CURSOR);
ociexecute($stmt);
ociexecute($curs);

while (OCIFetchInto($curs,&$data)) {
    var_dump($data);
}

OCIFreeCursor($stmt);
OCIFreeStatement($curs);
OCILogoff($conn);
?>

Ejemplo 2. Usando un REF CURSOR en una sentencia select

<?php
print "<HTML><BODY>";
$conn = OCILogon("scott","tiger");
$count_cursor = "CURSOR(select count(empno) num_emps from emp " .
                "where emp.deptno = dept.deptno) as EMPCNT from dept";
$stmt = OCIParse($conn,"select deptno,dname,$count_cursor");

ociexecute($stmt);
print "<TABLE BORDER=\"1\">";
print "<TR>";
print "<TH>DEPT NAME</TH>";
print "<TH>DEPT #</TH>";
print "<TH># EMPLOYEES</TH>";
print "</TR>";

while (OCIFetchInto($stmt,&$data,OCI_ASSOC)) {
    print "<TR>";
    $dname  = $data["DNAME"];
    $deptno = $data["DEPTNO"];
    print "<TD>$dname</TD>";
    print "<TD>$deptno</TD>";
    ociexecute($data[ "EMPCNT" ]);
    while (OCIFetchInto($data[ "EMPCNT" ],&$subdata,OCI_ASSOC)) {
        $num_emps = $subdata["NUM_EMPS"];
        print  "<TD>$num_emps</TD>";
    }
    print "</TR>";
}
print "</TABLE>";
print "</BODY></HTML>";
OCIFreeStatement($stmt);
OCILogoff($conn);
?>

Anterior | Inicio | Siguiente
OCILogon | Subir | OCINewDescriptor


OCIFreeStatement

(PHP 3>= 3.0.5, PHP 4 >= 4.0.0)

OCIFreeStatement -- Libera todos los recursos asociados con una sentencia.

Descripción

int OCIFreeStatement ( int stmt)

OCIFreeStatement() devuelve cierto si la operacion se lleva a cabo, o falso en caso contrario.

Anterior | Inicio | Siguiente
OCIFreeCursor | Subir | OCIInternalDebug


OCIFreeCursor

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

OCIFreeCursor -- Libera todos los recursos asociados con cursor.

Descripción

int OCIFreeCursor ( int stmt)

OCIFreeCursor() devuelve cierto si la operacion se lleva a cabo, o falso en caso contrario.

Anterior | Inicio | Siguiente
OCIFetchStatement | Subir | OCIFreeStatement


OCIColumnName

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIColumnName -- Devuelve el nombre de una columna.

Descripción

string OCIColumnName ( int stmt, int col)

OCIColumnName() Devuelve el nombre de la columna correspondiente al número de la columna (1-based) que es pasado.

Ejemplo 1. OCIColumnName

<?php
    print "<HTML><PRE>\n";
    $conn = OCILogon("scott", "tiger");
    $stmt = OCIParse($conn,"select * from emp");
    OCIExecute($stmt);
    print "<TABLE BORDER=\"1\">";
    print "<TR>";
    print "<TH>Name</TH>";
    print "<TH>Type</TH>";
    print "<TH>Length</TH>";
    print "</TR>";
    $ncols = OCINumCols($stmt);
    for ( $i = 1; $i <= $ncols; $i++ ) {
        $column_name  = OCIColumnName($stmt,$i);
        $column_type  = OCIColumnType($stmt,$i);
        $column_size  = OCIColumnSize($stmt,$i);
        print "<TR>";
        print "<TD>$column_name</TD>";
        print "<TD>$column_type</TD>";
        print "<TD>$column_size</TD>";
        print "</TR>";
    }
    OCIFreeStatement($stmt);
    OCILogoff($conn);
    print "</PRE>";
    print "</HTML>\n";
?>

Vea también OCINumCols(), OCIColumnType(), y OCIColumnSize().

Anterior | Inicio | Siguiente
OCIColumnIsNULL | Subir | OCIColumnSize


OCIColumnType

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIColumnType -- Devuelve el tipo de dato de una columna.

Descripción

mixed OCIColumnType ( int stmt, int col)

OCIColumnType() devuelve el tipo de dato de una columna correspondiente al número de la columna (1-based) que es pasado.

Ejemplo 1. OCIColumnType

<?php
    print "<HTML><PRE>\n";
    $conn = OCILogon("scott", "tiger");
    $stmt = OCIParse($conn,"select * from emp");
    OCIExecute($stmt);
    print "<TABLE BORDER=\"1\">";
    print "<TR>";
    print "<TH>Name</TH>";
    print "<TH>Type</TH>";
    print "<TH>Length</TH>";
    print "</TR>";
    $ncols = OCINumCols($stmt);
    for ( $i = 1; $i <= $ncols; $i++ ) {
        $column_name  = OCIColumnName($stmt,$i);
        $column_type  = OCIColumnType($stmt,$i);
        $column_size  = OCIColumnSize($stmt,$i);
        print "<TR>";
        print "<TD>$column_name</TD>";
        print "<TD>$column_type</TD>";
        print "<TD>$column_size</TD>";
        print "</TR>";
    }
    OCIFreeStatement($stmt);
    OCILogoff($conn);
    print "</PRE>";
    print "</HTML>\n";
?>

Vea también OCINumCols(), OCIColumnName(), y OCIColumnSize().

Anterior | Inicio | Siguiente
OCIColumnSize | Subir | OCICommit


OCIParse

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIParse -- Analiza una consulta y devuelve una sentencia

Descripción

int OCIParse ( int conn, strint query)

OCIParse() analiza la query usando conn. Devuelve el identificador de la sentencia si la consulta es válida, y falso si no lo es. La query puede ser cualquier sentencia SQL válida.

Anterior | Inicio | Siguiente
OCINumCols | Subir | OCIPLogon


OCIError

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

OCIError -- Devuelve el último error de stmt|conn|global. Si no ocurre ningún error devuelve falso.

Descripción

array OCIError ( [int stmt|conn|global])

OCIError() devuelve el último error encontrado. Si el parámetro opcional stmt|conn|global no es usado, es devuelto el último error encontrado. Si no se encuentra ningún error, OCIError() devuelve falso. OCIError() devuelve el error como un array asociativo. En este array, code consiste en el código de error de Oracle y message en la cadena de descripción del error.

Anterior | Inicio | Siguiente
OCIDefineByName | Subir | OCIExecute


OCIInternalDebug

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

OCIInternalDebug -- Habilita o deshabilita la salida del depurador interno. Por defecto este está deshabiltado

Descripción

void OCIInternalDebug ( int onoff)

OCIInternalDebug() habilita la salida del depurador interno. Asigne 0 a onoff para deshabilitar la salida y 1 para habilitarla.

Anterior | Inicio | Siguiente
OCIFreeStatement | Subir | OCILogOff


OpenSSL functions

Manual de PHP
Anterior Siguiente

LXIX. OpenSSL functions

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

Introduction

This module uses the functions of OpenSSL for generation and verification of signatures and for sealing (encrypting) and opening (decrypting) data. PHP-4.0.4pl1 requires OpenSSL >= 0.9.6, but PHP-4.0.5 and greater with also work with OpenSSL >= 0.9.5.

Nota: Please keep in mind that this extension is still considered experimental!

OpenSSL offers many features that this module currently doesn't support. Some of these may be added in the future.

Key/Certificate parameters

Quite a few of the openssl functions require a key or a certificate parameter. PHP 4.0.5 and earlier have to use a key or certificate resource returned by one of the openssl_get_xxx functions. Later versions may use one of the following methods:

  • Certificates

    1. An X.509 resource returned from openssl_x509_read

    2. A string having the format file://path/to/cert.pem; the named file must contain a PEM encoded certificate

    3. A string containing the content of a certificate, PEM encoded

  • Public/Private Keys

    1. A key resource returned from openssl_get_publickey() or openssl_get_privatekey()

    2. For public keys only: an X.509 resource

    3. A string having the format file://path/to/file.pem - the named file must contain a PEM encoded certificate/private key (it may contain both)

    4. A string containing the content of a certificate/key, PEM encoded

    5. For private keys, you may also use the syntax array($key, $passphrase) where $key represents a key specified using the file:// or textual content notation above, and $passphrase represents a string containing the passphrase for that private key

Certificate Verification

When calling a function that will verify a signature/certificate, the cainfo parameter is an array containing file and directory names the specify the locations of trusted CA files. If a directory is specified, then it must be a correctly formed hashed directory as the openssl command would use.

PKCS7 Flags/Constants

The S/MIME functions make use of flags which are specified using a bitfield which can include one or more of the following values:

Tabla 1. PKCS7 CONSTANTS

Constant | Description
PKCS7_TEXT | adds text/plain content type headers to encrypted/signed message. If decrypting or verifying, it strips those headers from the output - if the decrypted or verified message is not of MIME type text/plain then an error will occur.
PKCS7_BINARY | normally the input message is converted to "canonical" format which is effectively using CR and LF as end of line: as required by the S/MIME specification. When this options is present, no translation occurs. This is useful when handling binary data which may not be in MIME format.
PKCS7_NOINTERN | when verifying a message, certificates (if any) included in the message are normally searched for the signing certificate. With this option only the certificates specified in the extracerts parameter of openssl_pkcs7_verify() are used. The supplied certificates can still be used as untrusted CAs however.
PKCS7_NOVERIFY | do not verify the signers certificate of a signed message.
PKCS7_NOCHAIN | do not chain verification of signers certificates: that is don't use the certificates in the signed message as untrusted CAs.
PKCS7_NOCERTS | when signing a message the signer's certificate is normally included - with this option it is excluded. This will reduce the size of the signed message but the verifier must have a copy of the signers certificate available locally (passed using the extracerts to openssl_pkcs7_verify() for example.
PKCS7_NOATTR | normally when a message is signed, a set of attributes are included which include the signing time and the supported symmetric algorithms. With this option they are not included.
PKCS7_DETACHED | When signing a message, use cleartext signing with the MIME type multipart/signed. This is the default if the flags parameter to openssl_pkcs7_sign() if you do not specify any flags. If you turn this option off, the message will be signed using opaque signing, which is more resistant to translation by mail relays but cannot be read by mail agents that do not support S/MIME.
PKCS7_NOSIGS | Don't try and verify the signatures on a message

Nota: These constants were added in 4.0.6.

Tabla de contenidos
openssl_error_string — Return openSSL error message
openssl_free_key — Free key resource
openssl_get_privatekey — Prepare a PEM formatted private key for use
openssl_get_publickey — Extract public key from certificate and prepare it for use
openssl_open — Open sealed data
openssl_seal — Seal (encrypt) data
openssl_sign — Generate signature
openssl_verify — Verify signature
openssl_pkcs7_decrypt — Decrypts an S/MIME encrypted message
openssl_pkcs7_encrypt — Encrypt an S/MIME message
openssl_pkcs7_sign — sign an S/MIME message
openssl_pkcs7_verify — Verifies the signature of an S/MIME signed message
openssl_x509_checkpurpose — Verifies if a certificate can be used for a particular purpose
openssl_x509_free — Free certificate resource
openssl_x509_parse — Parse an X509 certificate and return the information as an array
openssl_x509_read — Parse an X.509 certificate and return a resource identifier for it
openssl_x509_export_to_file — Exports a CERT to file or a var
openssl_x509_export — Exports a CERT to file or a var
openssl_x509_check_private_key — Checks if a private key corresponds to a CERT
openssl_csr_export_to_file — Exports a CSR to file or a var
openssl_csr_export — Exports a CSR to file or a var
openssl_csr_sign — Signs a cert with another CERT
openssl_csr_new — Generates a privkey and CSR
openssl_pkey_new — Generates a new private key
openssl_pkey_export_to_file — Gets an exportable representation of a key into a file
openssl_pkey_export — Gets an exportable representation of a key into a string or file
openssl_private_encrypt — Encrypts data with private key
openssl_private_decrypt — Decrypts data with private key
openssl_public_encrypt — Encrypts data with public key
openssl_public_decrypt — Decrypts data with public key

Anterior | Inicio | Siguiente
OCIStatementType | Subir | openssl_error_string


openssl_error_string

(PHP 4 >= 4.0.6)

openssl_error_string -- Return openSSL error message

Description

mixed openssl_error_string ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Returns an error message string, or FALSE if there are no more error messages to return.

openssl_error_string() returns the last error from the openSSL library. Error messages are stacked, so this function should be called multiple times to collect all of the information.

The parameters/return type of this function may change before it appears in a release version of PHP

Ejemplo 1. openssl_error_string() example

// lets assume you just called an openssl function that failed
while($msg = openssl_error_string())
    echo $msg . "<br />\n";

Nota: This function was added in 4.0.6.

Anterior | Inicio | Siguiente
OpenSSL functions | Subir | openssl_free_key


openssl_free_key

(PHP 4 >= 4.0.4)

openssl_free_key -- Free key resource

Description

void openssl_free_key ( resource key_identifier)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

openssl_free_key() frees the key associated with the specified key_identifier from memory.

Anterior | Inicio | Siguiente
openssl_error_string | Subir | openssl_get_privatekey


openssl_get_privatekey

(PHP 4 >= 4.0.4)

openssl_get_privatekey -- Prepare a PEM formatted private key for use

Description

resource openssl_get_privatekey ( mixed key [, string passphrase])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Returns a positive key resource identifier on success, or FALSE on error.

openssl_get_privatekey() parses the PEM formatted private key specified by key and prepares it for use by other functions. The optional parameter passphrase must be used if the specified key is encrypted (protected by a passphrase).

Anterior | Inicio | Siguiente
openssl_free_key | Subir | openssl_get_publickey


openssl_get_publickey

(PHP 4 >= 4.0.4)

openssl_get_publickey -- Extract public key from certificate and prepare it for use

Description

resource openssl_get_publickey ( mixed certificate)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Returns a positive key resource identifier on success, or FALSE on error.

openssl_get_publickey() extracts the public key from an X.509 certificate specified by certificate and prepares it for use by other functions.

Anterior | Inicio | Siguiente
openssl_get_privatekey | Subir | openssl_open


openssl_open

(PHP 4 >= 4.0.4)

openssl_open -- Open sealed data

Description

bool openssl_open ( string sealed_data, string open_data, string env_key, mixed priv_key_id)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Returns TRUE on succes, FALSE on failure. If successful the opened data is returned in open_data.

openssl_open() opens (decrypts) sealed_data using the private key associated with the key identifier priv_key_id and the envelope key env_key, and fills open_data with the decrypted data. The envelope key is generated when the data are sealed and can only be used by one specific private key. See openssl_seal() for more information.

Ejemplo 1. openssl_open() example

// $sealed and $env_key are assumed to contain the sealed data
// and our envelope key, both given to us by the sealer.

// fetch private key from file and ready it
$fp = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$priv_key = fread($fp, 8192);
fclose($fp);
$pkeyid = openssl_get_privatekey($priv_key);

// decrypt the data and store it in $open
if (openssl_open($sealed, $open, $env_key, $pkeyid))
    echo "here is the opened data: ", $open;
else
    echo "failed to open data";

// free the private key from memory
openssl_free_key($pkeyid);

See also openssl_seal().

Anterior | Inicio | Siguiente
openssl_get_publickey | Subir | openssl_seal


openssl_seal

(PHP 4 >= 4.0.4)

openssl_seal -- Seal (encrypt) data

Description

int openssl_seal ( string data, string sealed_data, array env_keys, array pub_key_ids)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Returns the length of the sealed data on success, or FALSE on error. If successful the sealed data is returned in sealed_data, and the envelope keys in env_keys.

openssl_seal() seals (encrypts) data by using RC4 with a randomly generated secret key. The key is encrypted with each of the public keys associated with the identifiers in pub_key_ids and each encrypted key is returned in env_keys. This means that one can send sealed data to multiple recipients (provided one has obtained their public keys). Each recipient must receive both the sealed data and the envelope key that was encrypted with the recipient's public key.

Ejemplo 1. openssl_seal() example

// $data is assumed to contain the data to be sealed

// fetch public keys for our recipients, and ready them
$fp = fopen("/src/openssl-0.9.6/demos/maurice/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk1 = openssl_get_publickey($cert);
// Repeat for second recipient
$fp = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk2 = openssl_get_publickey($cert);

// seal message, only owners of $pk1 and $pk2 can decrypt $sealed with keys
// $ekeys[0] and $ekeys[1] respectively.
openssl_seal($data, $sealed, $ekeys, array($pk1,$pk2));

// free the keys from memory
openssl_free_key($pk1);
openssl_free_key($pk2);

See also openssl_open().

Anterior | Inicio | Siguiente
openssl_open | Subir | openssl_sign


openssl_sign

(PHP 4 >= 4.0.4)

openssl_sign -- Generate signature

Description

bool openssl_sign ( string data, string signature, mixed priv_key_id)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Returns TRUE on succes, FALSE on failure. If successful the signature is returned in signature.

openssl_sign() computes a signature for the specified data by using SHA1 for hashing followed by encryption using the private key associated with priv_key_id. Note that the data itself is not encrypted.

Ejemplo 1. openssl_sign() example

// $data is assumed to contain the data to be signed

// fetch private key from file and ready it
$fp = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$priv_key = fread($fp, 8192);
fclose($fp);
$pkeyid = openssl_get_privatekey($priv_key);

// compute signature
openssl_sign($data, $signature, $pkeyid);

// free the key from memory
openssl_free_key($pkeyid);

See also openssl_verify().

Anterior | Inicio | Siguiente
openssl_seal | Subir | openssl_verify


openssl_verify

(PHP 4 >= 4.0.4)

openssl_verify -- Verify signature

Description

int openssl_verify ( string data, string signature, mixed pub_key_id)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Returns 1 if the signature is correct, 0 if it is incorrect, and -1 on error.

openssl_verify() verifies that the signature is correct for the specified data using the public key associated with pub_key_id. This must be the public key corresponding to the private key used for signing.

Ejemplo 1. openssl_verify() example

// $data and $signature are assumed to contain the data and the signature

// fetch public key from certificate and ready it
$fp = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pubkeyid = openssl_get_publickey($cert);

// state whether signature is okay or not
$ok = openssl_verify($data, $signature, $pubkeyid);
if ($ok == 1)
    echo "good";
elseif ($ok == 0)
    echo "bad";
else
    echo "ugly, error checking signature";

// free the key from memory
openssl_free_key($pubkeyid);

See also openssl_sign().

Anterior | Inicio | Siguiente
openssl_sign | Subir | openssl_pkcs7_decrypt


openssl_pkcs7_decrypt

(PHP 4 >= 4.0.6)

openssl_pkcs7_decrypt -- Decrypts an S/MIME encrypted message

Description

bool openssl_pkcs7_decrypt ( string infilename, string outfilename, mixed recipcert, mixed recipkey)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Decrypts the S/MIME encrypted message contained in the file specified by infilename using the certificate and it's associated private key specified by recipcert and recipkey.

The decrypted message is output to the file specified by outfilename

Ejemplo 1. openssl_pkcs7_decrypt() example

// $cert and $key are assumed to contain your personal certificate and private
// key pair, and that you are the recipient of an S/MIME message
$infilename = "encrypted.msg";  // this file holds your encrypted message
$outfilename = "decrypted.msg"; // make sure you can write to this file

if (openssl_pkcs7_decrypt($infilename, $outfilename, $cert, $key))
    echo "decrypted!";
else
    echo "failed to decrypt!";

Nota: This function was added in 4.0.6.

Anterior | Inicio | Siguiente
openssl_verify | Subir | openssl_pkcs7_encrypt


openssl_pkcs7_encrypt

(PHP 4 >= 4.0.6)

openssl_pkcs7_encrypt -- Encrypt an S/MIME message

Description

bool openssl_pkcs7_encrypt ( string infilename, string outfilename, mixed recipcerts, array headers [, long flags])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

openssl_pkcs7_encrypt() takes the contents of the file named infilename and encrypts them using an RC2 40-bit cipher so that they can only be read by the intended recipients specified by recipcerts, which is either a lone X.509 certificate, or an array of X.509 certificates. headers is an array of headers that will be prepended to the data after it has been encrypted. flags can be used to specify options that affect the encoding process - see PKCS7 constants. headers can be either an associative array keyed by header name, or an indexed array, where each element contains a single header line.

Ejemplo 1. openssl_pkcs7_encrypt() example

// the message you want to encrypt and send to your secret agent
// in the field, known as nighthawk.  You have his certificate
// in the file nighthawk.pem
$data = <<<EOD
Nighthawk,

Top secret, for your eyes only!

The enemy is closing in! Meet me at the cafe at 8.30am
to collect your forged passport!

HQ
EOD;
// save message to file
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);
// encrypt it
if (openssl_pkcs7_encrypt("msg.txt", "enc.txt", "nighthawk.pem",
    array("To" => "nighthawk@agent.com", // keyed syntax
          "From: HQ <hq@cia.com>", // indexed syntax
          "Subject" => "Eyes only")))
{
    // message encrypted - send it!
    exec(ini_get("sendmail_path") . " < enc.txt");
}

Nota: This function was added in 4.0.6.

Anterior | Inicio | Siguiente
openssl_pkcs7_decrypt | Subir | openssl_pkcs7_sign


openssl_pkcs7_sign

(PHP 4 >= 4.0.6)

openssl_pkcs7_sign -- sign an S/MIME message

Description

bool openssl_pkcs7_sign ( string infilename, string outfilename, mixed signcert, mixed privkey, array headers [, long flags [, string extracertsfilename]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

openssl_pkcs7_sign() takes the contents of the file named infilename and signs them using the certificate and it's matching private key specified by signcert and privkey parameters.

headers is an array of headers that will be prepended to the data after it has been signed (see openssl_pkcs7_encrypt() for more information about the format of this parameter.

flags can be used to alter the output - see PKCS7 constants - if not specified, it defaults to PKCS7_DETACHED.

extracerts specifies the name of a file containing a bunch of extra certificates to include in the signature which can for example be used to help the recipient to verify the certificate that you used.

Ejemplo 1. openssl_pkcs7_sign() example

// the message you want to sign so that recipient can be sure it was you that
// sent it
$data = <<<EOD

You have my authorization to spend $10,000 on dinner expenses.

The CEO
EOD;
// save message to file
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);
// encrypt it
if (openssl_pkcs7_sign("msg.txt", "signed.txt", "mycert.pem",
    array("mycert.pem", "mypassphrase"),
    array("To" => "joes@sales.com", // keyed syntax
          "From: HQ <ceo@sales.com>", // indexed syntax
          "Subject" => "Eyes only"))
{
    // message signed - send it!
    exec(ini_get("sendmail_path") . " < signed.txt");
}

Nota: This function was added in 4.0.6.

Anterior | Inicio | Siguiente
openssl_pkcs7_encrypt | Subir | openssl_pkcs7_verify


openssl_pkcs7_verify

(PHP 4 >= 4.0.6)

openssl_pkcs7_verify -- Verifies the signature of an S/MIME signed message

Description

bool openssl_pkcs7_verify ( string filename, int flags [, string outfilename [, array cainfo [, string extracerts]]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

openssl_pkcs7_verify() reads the S/MIME message contained in the filename specified by filename and examines the digital signature. It returns TRUE if the signature is verified, FALSE if it is not correct (the message has been tampered with, or the signing certificate is invalid), or -1 on error.

flags can be used to affect how the signature is verified - see PKCS7 constants for more information.

If the outfilename is specified, it should be a string holding the name of a file into which the certificates of the persons that signed the messages will be stored in PEM format.

If the cainfo is specified, it should hold information about the trusted CA certificates to use in the verification process - see certificate verification for more information about this parameter.

If the extracerts is specified, it is the filename of a file containing a bunch of certificates to use as untrusted CAs.

Nota: This function was added in 4.0.6.

Anterior | Inicio | Siguiente
openssl_pkcs7_sign | Subir | openssl_x509_checkpurpose


openssl_x509_checkpurpose

(PHP 4 >= 4.0.6)

openssl_x509_checkpurpose -- Verifies if a certificate can be used for a particular purpose

Description

bool openssl_x509_checkpurpose ( mixed x509cert, int purpose, array cainfo [, string untrustedfile])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Returns TRUE if the certificate can be used for the intended purpose, FALSE if it cannot, or -1 on error.

openssl_x509_checkpurpose() examines the certificate specified by x509cert to see if it can be used for the purpose specified by purpose.

cainfo should be an array of trusted CA files/dirs as described in Certificate Verification.

untrustedfile, if specified, is the name of a PEM encoded file holding certificates that can be used to help verify the certificate, although no trust in placed in the certificates that come from that file.

Tabla 1. openssl_x509_checkpurpose() purposes

Constant | Description
X509_PURPOSE_SSL_CLIENT | Can the certificate be used for the client side of an SSL connection?
X509_PURPOSE_SSL_SERVER | Can the certificate be used for the server side of an SSL connection?
X509_PURPOSE_NS_SSL_SERVER | Can the cert be used for Netscape SSL server?
X509_PURPOSE_SMIME_SIGN | Can the cert be used to sign S/MIME email?
X509_PURPOSE_SMIME_ENCRYPT | Can the cert be used to encrypt S/MIME email?
X509_PURPOSE_CRL_SIGN | Can the cert be used to sign a certificate revocation list (CRL)?
X509_PURPOSE_ANY | Can the cert be used for Any/All purposes?
These options are not bitfields - you may specify one only!

Nota: This function was added in 4.0.6.

Anterior | Inicio | Siguiente
openssl_pkcs7_verify | Subir | openssl_x509_free


openssl_x509_free

(PHP 4 >= 4.0.6)

openssl_x509_free -- Free certificate resource

Description

void openssl_x509_free ( resource x509cert)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

openssl_x509_free() frees the certificate associated with the specified x509cert resource from memory.

Nota: This function was added in 4.0.6.

Anterior | Inicio | Siguiente
openssl_x509_checkpurpose | Subir | openssl_x509_parse


openssl_x509_parse

(PHP 4 >= 4.0.6)

openssl_x509_parse -- Parse an X509 certificate and return the information as an array

Description

array openssl_x509_parse ( mixed x509cert [, bool shortnames])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

openssl_x509_parse() returns information about the supplied x509cert, including fields such as subject name, issuer name, purposes, valid from and valid to dates etc. shortnames controls how the data is indexed in the array - if shortnames is TRUE (the default) then fields will be indexed with the short name form, otherwise, the long name form will be used - e.g.: CN is the shortname form of commonName.

The structure of the returned data is (deliberately) not yet documented, as it is still subject to change.

Nota: This function was added in 4.0.6.

Anterior | Inicio | Siguiente
openssl_x509_free | Subir | openssl_x509_read


openssl_x509_read

(PHP 4 >= 4.0.6)

openssl_x509_read -- Parse an X.509 certificate and return a resource identifier for it

Description

resource openssl_x509_read ( mixed x509certdata)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

openssl_x509_read() parses the certificate supplied by x509certdata and returns a resource identifier for it.

Nota: This function was added in 4.0.6.

Anterior | Inicio | Siguiente
openssl_x509_parse | Subir | openssl_x509_export_to_file


openssl_x509_export_to_file

(PHP 4 >= 4.2.0)

openssl_x509_export_to_file -- Exports a CERT to file or a var

Description

bool openssl_x509_export_to_file ( mixed x509, string outfilename [, bool notext])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_x509_read | Subir | openssl_x509_export


openssl_x509_export

(PHP 4 >= 4.2.0)

openssl_x509_export -- Exports a CERT to file or a var

Description

bool openssl_x509_export ( mixed x509, string outfilename [, bool notext])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_x509_export_to_file | Subir | openssl_x509_check_private_key


openssl_x509_check_private_key

(PHP 4 >= 4.2.0)

openssl_x509_check_private_key -- Checks if a private key corresponds to a CERT

Description

bool openssl_x509_check_private_key ( mixed cert, mixed key)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_x509_export | Subir | openssl_csr_export_to_file


openssl_csr_export_to_file

(PHP 4 >= 4.2.0)

openssl_csr_export_to_file -- Exports a CSR to file or a var

Description

bool openssl_csr_export_to_file ( resource csr, string outfilename [, bool notext])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_x509_check_private_key | Subir | openssl_csr_export


openssl_csr_export

(PHP 4 >= 4.2.0)

openssl_csr_export -- Exports a CSR to file or a var

Description

bool openssl_csr_export ( resource csr, string out [, bool notext])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_csr_export_to_file | Subir | openssl_csr_sign


openssl_csr_sign

(PHP 4 >= 4.2.0)

openssl_csr_sign -- Signs a cert with another CERT

Description

resource openssl_csr_sign ( mixed csr, mixed x509, mixed priv_key, long days)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_csr_export | Subir | openssl_csr_new


openssl_csr_new

(PHP 4 >= 4.2.0)

openssl_csr_new -- Generates a privkey and CSR

Description

bool openssl_csr_new ( array dn, resource privkey [, array extraattribs [, array configargs]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_csr_sign | Subir | openssl_pkey_new


openssl_pkey_new

(PHP 4 >= 4.2.0)

openssl_pkey_new -- Generates a new private key

Description

resource openssl_pkey_new ( [array configargs])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_csr_new | Subir | openssl_pkey_export_to_file


openssl_pkey_export_to_file

(PHP 4 >= 4.2.0)

openssl_pkey_export_to_file -- Gets an exportable representation of a key into a file

Description

bool openssl_pkey_export_to_file ( mixed key, string outfilename [, string passphrase [, array config_args]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_pkey_new | Subir | openssl_pkey_export


openssl_pkey_export

(PHP 4 >= 4.2.0)

openssl_pkey_export -- Gets an exportable representation of a key into a string or file

Description

bool openssl_pkey_export ( mixed key, mixed out [, string passphrase [, array config_args]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_pkey_export_to_file | Subir | openssl_private_encrypt


openssl_private_encrypt

(PHP 4 >= 4.0.6)

openssl_private_encrypt -- Encrypts data with private key

Description

bool openssl_private_encrypt ( string data, string crypted, mixed key [, int padding])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_pkey_export | Subir | openssl_private_decrypt


openssl_private_decrypt

(PHP 4 >= 4.0.6)

openssl_private_decrypt -- Decrypts data with private key

Description

bool openssl_private_decrypt ( string data, string crypted, mixed key [, int padding])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_private_encrypt | Subir | openssl_public_encrypt


openssl_public_encrypt

(PHP 4 >= 4.0.6)

openssl_public_encrypt -- Encrypts data with public key

Description

bool openssl_public_encrypt ( string data, string crypted, mixed key [, int padding])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_private_decrypt | Subir | openssl_public_decrypt


openssl_public_decrypt

(PHP 4 >= 4.0.6)

openssl_public_decrypt -- Decrypts data with public key

Description

bool openssl_public_decrypt ( string data, string crypted, resource key [, int padding])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
openssl_public_encrypt | Subir | Funciones Oracle


Funciones Oracle

Manual de PHP
Anterior Siguiente

LXX. Funciones Oracle

Tabla de contenidos
Ora_Bind — Vincula una variable PHP a un parámetro Oracle
Ora_Close — Cierra un cursor Oracle
Ora_ColumnName — toma el nombre de una columna de resultados Oracle
Ora_ColumnType — toma el tipo de una columna de resultados Oracle
Ora_Commit — realiza una transacción Oracle
Ora_CommitOff — deshabilita el modo automatico de ejecucion de tareas (autocommit)
Ora_CommitOn — Habilita la ejecucion automática de tareas (autocommit)
Ora_Error — toma los mensajes de error de Oracle
Ora_ErrorCode — captura el código de error Oracle
Ora_Exec — ejecuta las declaraciones interpretadas en un cursor Oracle
Ora_Fetch — extrae una fila de datos a partir de un cursor
Ora_GetColumn — toma datos de la fila extraída
Ora_Logoff — cierra una conexión Oracle
Ora_Logon — Abre una conexión Oracle
Ora_Open — abre un cursor Oracle
Ora_Parse — interpreta una declaración SQL
Ora_Rollback — retrocede en la lista de transacciones (hace un roll back)

Anterior | Inicio | Siguiente
openssl_public_decrypt | Subir | Ora_Bind


Ora_Bind

(PHP 3, PHP 4 >= 4.0.0)

Ora_Bind -- Vincula una variable PHP a un parámetro Oracle

Descripción

int ora_bind ( int cursor, string nombre de variable PHP, string nombre de parámetro SQL, int longitud [, int tipo])

Devuelve verdadero si el vínculo se realiza con éxito, y sino devuelve falso. Los detalles de los errores pueden examinarse usando la funciones ora_error() y ora_errorcode().

Esta función liga la variable PHP nombrada con el parámetro SQL. El parámtro SQL debe estar en la forma ":name". Con el parámetro optativo tipo, se define si el parámetro SQL se trata de un parámetro de entrada/salida (0 y por defecto), entrada (1) o salida (2). Como en PHP 3.0.1, se puede usar las constantes ORA_BIND_INOUT, ORA_BIND_IN y ORA_BIND_OUT en lugar de los números.

ora_bind debe ser llamada después de ora_parse() y antes de ora_exec(). Los valores de entrada pueden pasarse por asignación a las variables PHP vinculadas, despues de la llamada a ora_exec() dichas variables contendrán los valores de salida, si éstos estuvieran disponibles.

<?php
ora_parse($curs, "declare tmp INTEGER; begin tmp := :in; :out := tmp; :x := 7.77; end;");
ora_bind($curs, "result", ":x", $len, 2);
ora_bind($curs, "input", ":in", 5, 1);
ora_bind($curs, "output", ":out", 5, 2);
$input = 765;
ora_exec($curs);
echo "Result: $result<BR>Out: $output<BR>In: $input";
?>

Anterior | Inicio | Siguiente
Funciones Oracle | Subir | Ora_Close


Ora_Close

(PHP 3, PHP 4 >= 4.0.0)

Ora_Close -- Cierra un cursor Oracle

Descripción

int ora_close ( int cursor)

Devuelve verdadero si el cierre fué exitoso, o falso de lo contrario. Los detalles de los errores se recuperan usando las funciones ora_error() y ora_errorcode().

Esta función cierra un cursor de datos abierto con ora_open().

Anterior | Inicio | Siguiente
Ora_Bind | Subir | Ora_ColumnName


Ora_ColumnName

(PHP 3, PHP 4 >= 4.0.0)

Ora_ColumnName -- toma el nombre de una columna de resultados Oracle

Descripción

string Ora_ColumnName ( int cursor, int column)

Devuelve el nomre de un campo/columna column en el cursor cursor. el nombre devuelto estará en letras mayúsculas.

Anterior | Inicio | Siguiente
Ora_Close | Subir | Ora_ColumnType


Ora_ColumnType

(PHP 3, PHP 4 >= 4.0.0)

Ora_ColumnType -- toma el tipo de una columna de resultados Oracle

Descripción

string Ora_ColumnType ( int cursor, int column)

Devuelve el nombre del tipo de datos del campo o columna column en el cursor cursor. Se devolverá un tipo de datos, de entre los siguientes:

"VARCHAR2"
"VARCHAR"
"CHAR"
"NUMBER"
"LONG"
"LONG RAW"
"ROWID"
"DATE"
"CURSOR"

Anterior | Inicio | Siguiente
Ora_ColumnName | Subir | Ora_Commit


Ora_Commit

(PHP 3, PHP 4 >= 4.0.0)

Ora_Commit -- realiza una transacción Oracle

Descripción

int ora_commit ( int conn)

Devuelve verdadero si es exitosa, de lo cantrario devuelve falso. Puede verse los detalles del error usando las funciones ora_error() y ora_errorcode(). Esta función realiza una transacción Oracle. Se define como transacción cualquier cambio en una conexión dada, desde la última tarea/retroceso en la ejecucion (rollback), anulación de la ejecución automática de tareas (autocommit), o cuando se ha establecido la conexión.

Anterior | Inicio | Siguiente
Ora_ColumnType | Subir | Ora_CommitOff


Ora_CommitOff

(PHP 3, PHP 4 >= 4.0.0)

Ora_CommitOff -- deshabilita el modo automatico de ejecucion de tareas (autocommit)

Descripción

int ora_commitoff ( int conn)

Devuelve verdadero si se ejecuta con éxito, sino devuelve falso. Los pormenores del error en cuestion, pueden revisarse invocando las funciones ora_error() y ora_errorcode().

Esta función deshabilita la ejecucion automatica luego de cada instancia ora_exec().

Anterior | Inicio | Siguiente
Ora_Commit | Subir | Ora_CommitOn


Ora_CommitOn

(PHP 3, PHP 4 >= 4.0.0)

Ora_CommitOn -- Habilita la ejecucion automática de tareas (autocommit)

Descripción

int ora_commiton ( int conn)

Esta función habilita la ejecucion automatica luego de cada instancia ora_exec() en la conexión dada.

Devuelve verdadero si se ejecuta con éxito, sino devuelve falso. Los pormenores del error en cuestion, pueden revisarse invocando las funciones ora_error() y ora_errorcode().

Anterior | Inicio | Siguiente
Ora_CommitOff | Subir | Ora_Error


Ora_Error

(PHP 3, PHP 4 >= 4.0.0)

Ora_Error -- toma los mensajes de error de Oracle

Descripción

string Ora_Error ( int cursor_or_connection)

Devuelve los mensajes de error en la forma XXX-NNNNN donde XXX es la procedencia del error y NNNNN es la identificación del mensaje de error.

Nota: El soporte para las identificaciones de conexión fue agregado en la versión 3.0.4.

En las versiones UNIX de Oracle, pueden encontrarse detalles acerca de un mensaje de error como este: $ oerr ora 00001 00001, 00000, "unique constraint (%s.%s) violated" // *Cause: An update or insert statement attempted to insert a duplicate key // For Trusted ORACLE configured in DBMS MAC mode, you may see // this message if a duplicate entry exists at a different level. // *Action: Either remove the unique restriction or do not insert the key

Anterior | Inicio | Siguiente
Ora_CommitOn | Subir | Ora_ErrorCode


Ora_ErrorCode

(PHP 3, PHP 4 >= 4.0.0)

Ora_ErrorCode -- captura el código de error Oracle

Descripción

int Ora_ErrorCode ( int cursor_or_connection)

Devuelve el codigo numérico de error de la última declaración ejecutada en el cursor o conexion espacificada.

Nota: El soporte para las identificaciones de conexión fue agregado en la versión 3.0.4.

Anterior | Inicio | Siguiente
Ora_Error | Subir | Ora_Exec


Ora_Exec

(PHP 3, PHP 4 >= 4.0.0)

Ora_Exec -- ejecuta las declaraciones interpretadas en un cursor Oracle

Descripción

int ora_exec ( int cursor)

Devuelve verdadero ante la ejecución exitosa, de lo contrario, devuelve falso. Los detalles del error pueden verse invocando las funciones ora_error() y ora_errorcode().

Anterior | Inicio | Siguiente
Ora_ErrorCode | Subir | Ora_Fetch


Ora_Fetch

(PHP 3, PHP 4 >= 4.0.0)

Ora_Fetch -- extrae una fila de datos a partir de un cursor

Descripción

int ora_fetch ( int cursor)

Devuelve verdadero (se extrajo una fila) o falso (no hay mas filas, o ha ocurrido un error). Si ocurre un error, los detalles del mismo pueden verse invocando las funciones ora_error() y ora_errorcode(). Si no hubo errores, ora_errorcode() devolverá 0. Recupera una hilera de datos partiendo de un cursor especificado.

Anterior | Inicio | Siguiente
Ora_Exec | Subir | Ora_GetColumn


Ora_GetColumn

(PHP 3, PHP 4 >= 4.0.0)

Ora_GetColumn -- toma datos de la fila extraída

Descripción

mixed ora_getcolumn ( int cursor, mixed column)

Devuelve la columna de datos. Si hay un error, se devuelve falso y ora_errorcode() devulve un valor distinto de cero. Note, de igual manera, que la busqueda de un resultado Falso en esta función, puede resultar verdadera, aún en casos en que no ocurran errores:(resultado NULO, cadenas vacias, valor 0 o cadenas "0"). Extrae los datos para una columna o resultado de función.

Anterior | Inicio | Siguiente
Ora_Fetch | Subir | Ora_Logoff


Ora_Logoff

(PHP 3, PHP 4 >= 4.0.0)

Ora_Logoff -- cierra una conexión Oracle

Descripción

int ora_logoff ( int connection)

Devuelve verdadero si es exitosa, o falso si hay errores. Los detalles del error pueden verse invocando las funciones ora_error() y ora_errorcode(). Cierra la sesión de trabajo del usuario, y lo desconecta del servidor.

Anterior | Inicio | Siguiente
Ora_GetColumn | Subir | Ora_Logon


Ora_Logon

(PHP 3, PHP 4 >= 4.0.0)

Ora_Logon -- Abre una conexión Oracle

Descripción

int ora_logon ( string usuario, string contraseña)

Establece una conexión entre PHP y una base de datos Oracle, con los datos de nombre de usuario y contraseña especificados.

Las conexiones pueden llevarse adelante usando SQL*Net indicando el nombre TNS al usuario de este modo:

$conn = Ora_Logon("usuario@TNSNAME", "contraseña");

Si hubiesen datos con caracteres no-ASCII, habría que asegurarse de que esté presente la variable de entorno NLS_LANG en el sistema. Para los modulos de servidor, deberían definirse en el entorno del servidor antes de iniciarlo.

Devuelve el índice de la conexión si aquella tuvo éxito, de lo cantrario devuelve falso. Los detalles del error pueden verse invocando las funciones ora_error() y ora_errorcode().

Anterior | Inicio | Siguiente
Ora_Logoff | Subir | Ora_Open


Ora_Open

(PHP 3, PHP 4 >= 4.0.0)

Ora_Open -- abre un cursor Oracle

Descripción

int ora_open ( int connection)

Abre un cursor asociado con la conexión.

Devuelve el índice del cursor o Falso si hay un error. Los detalles del error pueden verse invocando las funciones ora_error() y ora_errorcode().

Anterior | Inicio | Siguiente
Ora_Logon | Subir | Ora_Parse


Ora_Parse

(PHP 3, PHP 4 >= 4.0.0)

Ora_Parse -- interpreta una declaración SQL

Descripción

int ora_parse ( int cursor_ind, string sql_statement, int defer)

Esta función interpreta una declaración SQL o un bloque PL/SQL y los asocia con el cursor dado. Devuelve 0 si se ejecuta con exito, o -1 ante un error.

Anterior | Inicio | Siguiente
Ora_Open | Subir | Ora_Rollback


Ora_Rollback

(PHP 3, PHP 4 >= 4.0.0)

Ora_Rollback -- retrocede en la lista de transacciones (hace un roll back)

Descripción

int ora_rollback ( int connection)

Deshace una transaccion Oracle. (Ver ora_commit() para la definición de transacción.)

Devuelve verdadero si tiene éxito, o falso si hay un error. Los detalles del error pueden verse invocando las funciones ora_error() y ora_errorcode().

Anterior | Inicio | Siguiente
Ora_Parse | Subir | Ovrimos SQL functions


Ovrimos SQL functions

Manual de PHP
Anterior Siguiente

LXXI. Ovrimos SQL functions

Ovrimos SQL Server, is a client/server, transactional RDBMS combined with Web capabilities and fast transactions.

Ovrimos SQL Server is available at www.ovrimos.com. To enable ovrimos support in PHP just compile php with the '--with-ovrimos' parameter to configure script. You'll need to install the sqlcli library available in the Ovrimos SQL Server distribution.

Ejemplo 1. Connect to Ovrimos SQL Server and select from a system table

<?php
$conn = ovrimos_connect ("server.domain.com", "8001", "admin", "password");
if ($conn != 0) {
    echo ("Connection ok!");
    $res = ovrimos_exec ($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        ovrimos_result_all ($res);
        ovrimos_free_result ($res);
    }
    ovrimos_close($conn);
}
?>
This will just connect to SQL Server.

Tabla de contenidos
ovrimos_close — Closes the connection to ovrimos
ovrimos_close_all — Closes all the connections to ovrimos
ovrimos_commit — Commits the transaction
ovrimos_connect — Connect to the specified database
ovrimos_cursor — Returns the name of the cursor
ovrimos_exec — Executes an SQL statement
ovrimos_execute — Executes a prepared SQL statement
ovrimos_fetch_into — Fetches a row from the result set
ovrimos_fetch_row — Fetches a row from the result set
ovrimos_field_len — Returns the length of the output column
ovrimos_field_name — Returns the output column name
ovrimos_field_num — Returns the (1-based) index of the output column
ovrimos_field_type — Returns the (numeric) type of the output column
ovrimos_free_result — Frees the specified result_id
ovrimos_longreadlen — Specifies how many bytes are to be retrieved from long datatypes
ovrimos_num_fields — Returns the number of columns
ovrimos_num_rows — Returns the number of rows affected by update operations
ovrimos_prepare — Prepares an SQL statement
ovrimos_result — Retrieves the output column
ovrimos_result_all — Prints the whole result set as an HTML table
ovrimos_rollback — Rolls back the transaction

Anterior | Inicio | Siguiente
Ora_Rollback | Subir | ovrimos_close


ovrimos_connect

(PHP 4 >= 4.0.3)

ovrimos_connect -- Connect to the specified database

Description

int ovrimos_connect ( string host, string db, string user, string password)

ovrimos_connect() is used to connect to the specified database.

ovrimos_connect() returns a connection id (greater than 0) or 0 for failure. The meaning of 'host' and 'port' are those used everywhere in Ovrimos APIs. 'Host' is a host name or IP address and 'db' is either a database name, or a string containing the port number.

Ejemplo 1. ovrimos_connect() Example

<?php
$conn = ovrimos_connect ("server.domain.com", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res=ovrimos_exec ($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        ovrimos_result_all ($res);
        ovrimos_free_result ($res);
    }
    ovrimos_close ($conn);
}
?>
The above example will connect to the database and print out the specified table.

Anterior | Inicio | Siguiente
ovrimos_commit | Subir | ovrimos_cursor


ovrimos_close

(PHP 4 >= 4.0.3)

ovrimos_close -- Closes the connection to ovrimos

Description

void ovrimos_close ( int connection)

ovrimos_close() is used to close the specified connection.

ovrimos_close() closes a connection to Ovrimos. This has the effect of rolling back uncommitted transactions.

Anterior | Inicio | Siguiente
Ovrimos SQL functions | Subir | ovrimos_close_all


ovrimos_close_all

(4.0.3 - 4.0.6 only)

ovrimos_close_all -- Closes all the connections to ovrimos

Description

void ovrimos_close_all ( void)

ovrimos_close_all() is used to close all the connections.

ovrimos_close_all() closes all connections to Ovrimos. This has the effect of rolling back uncommitted transactions.

Anterior | Inicio | Siguiente
ovrimos_close | Subir | ovrimos_commit


ovrimos_longreadlen

(PHP 4 >= 4.0.3)

ovrimos_longreadlen -- Specifies how many bytes are to be retrieved from long datatypes

Description

int ovrimos_longreadlen ( int result_id, int length)

ovrimos_longreadlen() is used to specify how many bytes are to be retrieved from long datatypes.

ovrimos_longreadlen() specifies how many bytes are to be retrieved from long datatypes (long varchar and long varbinary). Default is zero. Regardless of its taking a result_id as an argument, it currently sets this parameter for all result sets. Returns TRUE.

Anterior | Inicio | Siguiente
ovrimos_free_result | Subir | ovrimos_num_fields


ovrimos_prepare

(PHP 4 >= 4.0.3)

ovrimos_prepare -- Prepares an SQL statement

Description

int ovrimos_prepare ( int connection_id, string query)

ovrimos_prepare() is used to prepare an SQL statement.

ovrimos_prepare() prepares an SQL statement and returns a result_id (or FALSE on failure).

Ejemplo 1. Connect to Ovrimos SQL Server and prepare a statement

<?php
$conn=ovrimos_connect ("db_host", "8001", "admin", "password");
if ($conn!=0) {
    echo "Connection ok!";
    $res=ovrimos_prepare ($conn, "select table_id, table_name
                                  from sys.tables where table_id=1");
    if ($res != 0) {
        echo "Prepare ok!";
        if (ovrimos_execute ($res)) {
            echo "Execute ok!\n";
            ovrimos_result_all ($res);
        } else {
            echo "Execute not ok!";
        }
        ovrimos_free_result ($res);
    } else {
        echo "Prepare not ok!\n";
    }
    ovrimos_close ($conn);
}
?>
This will connect to Ovrimos SQL Server, prepare a statement and the execute it.

Anterior | Inicio | Siguiente
ovrimos_num_rows | Subir | ovrimos_result


ovrimos_execute

(PHP 4 >= 4.0.3)

ovrimos_execute -- Executes a prepared SQL statement

Description

int ovrimos_execute ( int result_id [, array parameters_array])

ovrimos_execute() is used to execute an SQL statement.

ovrimos_execute() executes a prepared statement. Returns TRUE or FALSE. If the prepared statement contained parameters (question marks in the statement), the correct number of parameters should be passed in an array. Notice that I don't follow the PHP convention of placing just the name of the optional parameter inside square brackets. I couldn't bring myself on liking it.

Anterior | Inicio | Siguiente
ovrimos_exec | Subir | ovrimos_fetch_into


ovrimos_cursor

(PHP 4 >= 4.0.3)

ovrimos_cursor -- Returns the name of the cursor

Description

int ovrimos_cursor ( int result_id)

ovrimos_cursor() is used to get the name of the cursor.

ovrimos_cursor() returns the name of the cursor. Useful when wishing to perform positioned updates or deletes.

Anterior | Inicio | Siguiente
ovrimos_connect | Subir | ovrimos_exec


ovrimos_exec

(PHP 4 >= 4.0.3)

ovrimos_exec -- Executes an SQL statement

Description

int ovrimos_exec ( int connection_id, string query)

ovrimos_exec() is used to execute an SQL statement.

ovrimos_exec() executes an SQL statement (query or update) and returns a result_id or FALSE. Evidently, the SQL statement should not contain parameters.

Anterior | Inicio | Siguiente
ovrimos_cursor | Subir | ovrimos_execute


ovrimos_fetch_into

(PHP 4 >= 4.0.3)

ovrimos_fetch_into -- Fetches a row from the result set

Description

int ovrimos_fetch_into ( int result_id, array result_array [, string how [, int rownumber]])

ovrimos_fetch_into() is used to fetch a row from the result set.

ovrimos_fetch_into() fetches a row from the result set into 'result_array', which should be passed by reference. Which row is fetched is determined by the two last parameters. 'how' is one of 'Next' (default), 'Prev', 'First', 'Last', 'Absolute', corresponding to forward direction from current position, backward direction from current position, forward direction from the start, backward direction from the end and absolute position from the start (essentially equivalent to 'first' but needs 'rownumber'). Case is not significant. 'Rownumber' is optional except for absolute positioning. Returns TRUE or FALSE.

Ejemplo 1. A fetch into example

<?php
$conn=ovrimos_connect ("neptune", "8001", "admin", "password");
if ($conn!=0) {
    echo "Connection ok!";
    $res=ovrimos_exec ($conn,"select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        if (ovrimos_fetch_into ($res, &$row)) {
            list ($table_id, $table_name) = $row;
            echo "table_id=".$table_id.", table_name=".$table_name."\n";
            if (ovrimos_fetch_into ($res, &$row)) {
                list ($table_id, $table_name) = $row;
                echo "table_id=".$table_id.", table_name=".$table_name."\n";
            } else {
                echo "Next: error\n";
            }
        } else {
            echo "First: error\n";
        }
        ovrimos_free_result ($res);
    }
    ovrimos_close ($conn);
}
?>
This example will fetch a row.

Anterior | Inicio | Siguiente
ovrimos_execute | Subir | ovrimos_fetch_row


ovrimos_fetch_row

(PHP 4 >= 4.0.3)

ovrimos_fetch_row -- Fetches a row from the result set

Description

int ovrimos_fetch_row ( int result_id [, int how [, int row_number]])

ovrimos_fetch_row() is used to fetch a row from the result set.

ovrimos_fetch_row() fetches a row from the result set. Column values should be retrieved with other calls. Returns TRUE or FALSE.

Ejemplo 1. A fetch row example

<?php
$conn = ovrimos_connect ("remote.host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res=ovrimos_exec ($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        if (ovrimos_fetch_row ($res, "First")) {
            $table_id = ovrimos_result ($res, 1);
            $table_name = ovrimos_result ($res, 2);
            echo "table_id=".$table_id.", table_name=".$table_name."\n";
            if (ovrimos_fetch_row ($res, "Next")) {
                $table_id = ovrimos_result ($res, "table_id");
                $table_name = ovrimos_result ($res, "table_name");
                echo "table_id=".$table_id.", table_name=".$table_name."\n";
            } else {
                echo "Next: error\n";
            }
        } else {
            echo "First: error\n";
        }
        ovrimos_free_result ($res);
    }
    ovrimos_close ($conn);
}
?>
This will fetch a row and print the result.

Anterior | Inicio | Siguiente
ovrimos_fetch_into | Subir | ovrimos_field_len


ovrimos_result

(PHP 4 >= 4.0.3)

ovrimos_result -- Retrieves the output column

Description

int ovrimos_result ( int result_id, mixed field)

ovrimos_result() is used to retrieve the output column.

ovrimos_result() retrieves the output column specified by 'field', either as a string or as an 1-based index.

Anterior | Inicio | Siguiente
ovrimos_prepare | Subir | ovrimos_result_all


ovrimos_result_all

(PHP 4 >= 4.0.3)

ovrimos_result_all -- Prints the whole result set as an HTML table

Description

int ovrimos_result_all ( int result_id [, string format])

ovrimos_result_all() is used to print an HTML table containing the whole result set.

ovrimos_result_all() prints the whole result set as an HTML table. Returns TRUE or FALSE.

Ejemplo 1. Prepare a statement, execute, and view the result

<?php
$conn = ovrimos_connect ("db_host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_prepare ($conn, "select table_id, table_name
                                    from sys.tables where table_id = 7");
    if ($res != 0) {
        echo "Prepare ok!";
        if (ovrimos_execute ($res, array(3))) {
            echo "Execute ok!\n";
            ovrimos_result_all ($res);
        } else {
            echo "Execute not ok!";
        }
        ovrimos_free_result ($res);
    } else {
        echo "Prepare not ok!\n";
    }
    ovrimos_close ($conn);
}
?>
This will execute an SQL statement and print the result in an HTML table.

Ejemplo 2. Ovrimos_result_all with meta-information

<?php
$conn = ovrimos_connect ("db_host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_exec ($conn, "select table_id, table_name
                                 from sys.tables where table_id = 1")
    if ($res != 0) {
        echo "Statement ok! cursor=".ovrimos_cursor ($res)."\n";
        $colnb = ovrimos_num_fields ($res);
        echo "Output columns=".$colnb."\n";
        for ($i=1; $i<=$colnb; $i++) {
            $name = ovrimos_field_name ($res, $i);
            $type = ovrimos_field_type ($res, $i);
            $len = ovrimos_field_len ($res, $i);
            echo "Column ".$i." name=".$name." type=".$type." len=".$len."\n";
        }
        ovrimos_result_all ($res);
        ovrimos_free_result ($res);
    }
    ovrimos_close ($conn);
}
?>

Ejemplo 3. ovrimos_result_all example

<?php
$conn = ovrimos_connect ("db_host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_exec ($conn, "update test set i=5");
    if ($res != 0) {
        echo "Statement ok!";
        echo ovrimos_num_rows ($res)." rows affected\n";
        ovrimos_free_result ($res);
    }
    ovrimos_close ($conn);
}
?>

Anterior | Inicio | Siguiente
ovrimos_result | Subir | ovrimos_rollback


ovrimos_num_rows

(PHP 4 >= 4.0.3)

ovrimos_num_rows -- Returns the number of rows affected by update operations

Description

int ovrimos_num_rows ( int result_id)

ovrimos_num_rows() is used to get the number of rows affected by update operations.

ovrimos_num_rows() returns the number of rows affected by update operations.

Anterior | Inicio | Siguiente
ovrimos_num_fields | Subir | ovrimos_prepare


ovrimos_num_fields

(PHP 4 >= 4.0.3)

ovrimos_num_fields -- Returns the number of columns

Description

int ovrimos_num_fields ( int result_id)

ovrimos_num_fields() is used to get the number of columns.

ovrimos_num_fields() returns the number of columns in a result_id resulting from a query.

Anterior | Inicio | Siguiente
ovrimos_longreadlen | Subir | ovrimos_num_rows


ovrimos_field_name

(PHP 4 >= 4.0.3)

ovrimos_field_name -- Returns the output column name

Description

int ovrimos_field_name ( int result_id, int field_number)

ovrimos_field_name() is used to get the output column name.

ovrimos_field_name() returns the output column name at the (1-based) index specified.

Anterior | Inicio | Siguiente
ovrimos_field_len | Subir | ovrimos_field_num


ovrimos_field_type

(PHP 4 >= 4.0.3)

ovrimos_field_type -- Returns the (numeric) type of the output column

Description

int ovrimos_field_type ( int result_id, int field_number)

ovrimos_field_type() is used to get the (numeric) type of the output column.

ovrimos_field_type() returns the (numeric) type of the output column at the (1-based) index specified.

Anterior | Inicio | Siguiente
ovrimos_field_num | Subir | ovrimos_free_result


ovrimos_field_len

(PHP 4 >= 4.0.3)

ovrimos_field_len -- Returns the length of the output column

Description

int ovrimos_field_len ( int result_id, int field_number)

ovrimos_field_len() is used to get the length of the output column.

ovrimos_field_len() returns the length of the output column at the (1-based) index specified.

Anterior | Inicio | Siguiente
ovrimos_fetch_row | Subir | ovrimos_field_name


ovrimos_field_num

(PHP 4 >= 4.0.3)

ovrimos_field_num -- Returns the (1-based) index of the output column

Description

int ovrimos_field_num ( int result_id, string field_name)

ovrimos_field_num() is used to get the (1-based) index of the output column.

ovrimos_field_num() returns the (1-based) index of the output column specified by name, or FALSE.

Anterior | Inicio | Siguiente
ovrimos_field_name | Subir | ovrimos_field_type


ovrimos_free_result

(PHP 4 >= 4.0.3)

ovrimos_free_result -- Frees the specified result_id

Description

int ovrimos_free_result ( int result_id)

ovrimos_free_result() is used to free the result_id.

ovrimos_free_result() frees the specified result_id. Returns TRUE.

Anterior | Inicio | Siguiente
ovrimos_field_type | Subir | ovrimos_longreadlen


ovrimos_commit

(PHP 4 >= 4.0.3)

ovrimos_commit -- Commits the transaction

Description

int ovrimos_commit ( int connection_id)

ovrimos_commit() is used to commit the transaction.

ovrimos_commit() commits the transaction.

Anterior | Inicio | Siguiente
ovrimos_close_all | Subir | ovrimos_connect


ovrimos_rollback

(PHP 4 >= 4.0.3)

ovrimos_rollback -- Rolls back the transaction

Description

int ovrimos_rollback ( int connection_id)

ovrimos_rollback() is used to roll back the transaction.

ovrimos_rollback() rolls back the transaction.

Anterior | Inicio | Siguiente
ovrimos_result_all | Subir | Output Control Functions


Output Control Functions

Manual de PHP
Anterior Siguiente

LXXII. Output Control Functions

The Output Control functions allow you to control when output is sent from the script. This can be useful in several different situations, especially if you need to send headers to the browser after your script has began outputing data. The Output Control functions do not affect headers sent using header() or setcookie(), only functions such as echo() and data between blocks of PHP code.

Ejemplo 1. Output Control example

<?php

ob_start();
echo "Hello\n";

setcookie ("cookiename", "cookiedata");

ob_end_flush();

?>

In the above example, the output from echo() would be stored in the output buffer until ob_end_flush() was called. In the mean time, the call to setcookie() successfully stored a cookie without causing an error. (You can not normally send headers to the browser after data has already been sent.)

See also header() and setcookie().

Tabla de contenidos
flush — Flush the output buffer
ob_end_clean — Clean (erase) the output buffer and turn off output buffering
ob_end_flush — Flush (send) the output buffer and turn off output buffering
ob_get_contents — Return the contents of the output buffer
ob_get_length — Return the length of the output buffer
ob_implicit_flush — Turn implicit flush on/off
ob_start — Turn on output buffering

Anterior | Inicio | Siguiente
ovrimos_rollback | Subir | flush


flush

(PHP 3, PHP 4 >= 4.0.0)

flush -- Flush the output buffer

Description

void flush ( void)

Flushes the output buffers of PHP and whatever backend PHP is using (CGI, a web server, etc.) This effectively tries to push all the output so far to the user's browser.

Anterior | Inicio | Siguiente
Output Control Functions | Subir | ob_end_clean


ob_start

(PHP 4 >= 4.0.0)

ob_start -- Turn on output buffering

Description

void ob_start ( void)

This function will turn output buffering on. While output buffering is active no output is sent from the script, instead the output is stored in an internal buffer.

The contents of this internal buffer may be copied into a string variable using ob_get_contents(). To output what is stored in the internal buffer, use ob_end_flush(). Alternatively, ob_end_clean() will silently discard the buffer contents.

See also ob_get_contents(),
ob_end_flush(),
ob_end_clean(), and
ob_implicit_flush()

Anterior | Inicio | Siguiente
ob_implicit_flush | Subir | Object property and method call overloading


ob_get_contents

(PHP 4 >= 4.0.0)

ob_get_contents -- Return the contents of the output buffer

Description

string ob_get_contents ( void)

This will return the contents of the output buffer or FALSE, if output buffering isn't active.

See also ob_start() and ob_get_length().

Anterior | Inicio | Siguiente
ob_end_flush | Subir | ob_get_length


ob_get_length

(PHP 4 >= 4.0.2)

ob_get_length -- Return the length of the output buffer

Description

string ob_get_length ( void)

This will return the length of the contents in the output buffer or FALSE, if output buffering isnt't active.

See also ob_start() and ob_get_contents().

Anterior | Inicio | Siguiente
ob_get_contents | Subir | ob_implicit_flush


ob_end_flush

(PHP 4 >= 4.0.0)

ob_end_flush -- Flush (send) the output buffer and turn off output buffering

Description

void ob_end_flush ( void)

This function will send the contents of the output buffer (if any) and turn output buffering off. If you want to further process the buffer's contents you have to call ob_get_contents() before ob_end_flush() as the buffer contents are discarded after ob_get_contents() is called.

See also ob_start(),
ob_get_contents(), and
ob_end_clean().

Anterior | Inicio | Siguiente
ob_end_clean | Subir | ob_get_contents


ob_end_clean

(PHP 4 >= 4.0.0)

ob_end_clean -- Clean (erase) the output buffer and turn off output buffering

Description

void ob_end_clean ( void)

This function discards the contents of the output buffer and turns off output buffering.

See also ob_start() and ob_end_flush().

Anterior | Inicio | Siguiente
flush | Subir | ob_end_flush


ob_implicit_flush

(PHP 4 >= 4.0.0)

ob_implicit_flush -- Turn implicit flush on/off

Description

void ob_implicit_flush ( [int flag])

ob_implicit_flush() will turn implicit flushing on or off (if no flag is given, it defaults to on). Implicit flushing will result in a flush operation after every output call, so that explicit calls to flush() will no longer be needed.

Turning implicit flushing on will disable output buffering, the output buffers current output will be sent as if ob_end_flush() had been called.

See also flush(),
ob_start(), and
ob_end_flush().

Anterior | Inicio | Siguiente
ob_get_length | Subir | ob_start


Object property and method call overloading

Manual de PHP
Anterior Siguiente

LXXIII. Object property and method call overloading

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

The purpose of this extension is to allow overloading of object property access and method calls. Only one function is defined in this extension, overload() which takes the name of the class that should have this functionality enabled. The class named has to define appropriate methods if it wants to have this functionality: __get(), __set() and __call() respectively for getting/setting a property, or calling a method. This way overloading can be selective. Inside these handler functions the overloading is disabled so you can access object properties normally.

Some simple examples on using the overload() function:

Ejemplo 1. Overloading a PHP class

<?php

class OO
{
    var $a = 111;
    var $elem = array('b' => 9, 'c' => 42);

    // Callback method for getting a property
    function __get($prop_name, &$prop_value)
    {
        if (isset($this->elem[$prop_name])) {
            $prop_value = $this->elem[$prop_name];
            return true;
        } else {
            return false;
        }
    }

    // Callback method for setting a property
    function __set($prop_name, $prop_value)
    {
        $this->elem[$prop_name] = $prop_value;
        return true;
    }
}

// Here we overload the OO object
overload('OO');

$o = new OO;
print "\$o->a: $o->a\n"; // print: $o->a:
print "\$o->b: $o->b\n"; // print: $o->b: 9
print "\$o->c: $o->c\n"; // print: $o->c: 42
print "\$o->d: $o->d\n"; // print: $o->d:

// add a new item to the $elem array in OO
$o->x = 56;

// instantiate stdclass (it is built-in in PHP 4)
// $val is not overloaded!
$val = new stdclass;
$val->prop = 555;

// Set "a" to be an array with the $val object in it
// But __set() will put this in the $elem array
$o->a = array($val);
var_dump($o->a[0]->prop);

?>

Aviso

As this is an experimental extension, not all things work. There is no __call() support currently, you can only overload the get and set operations for properties. You cannot invoke the original overloading handlers of the class, and __set() only works to one level of property access.

Tabla de contenidos
overload — Enable property and method call overloading for a class

Anterior | Inicio | Siguiente
ob_start | Subir | overload


overload

(PHP 4 >= 4.2.0)

overload -- Enable property and method call overloading for a class

Description

void overload ( [string class_name])

The overload() function will enable property and method call overloading for a class identified by class_name. See an example in the introductory section of this part.

Anterior | Inicio | Siguiente
Object property and method call overloading | Subir | PDF functions


PDF functions

Manual de PHP
Anterior Siguiente

LXXIV. PDF functions

You can use the PDF functions in PHP to create PDF files if you have the PDF library by Thomas Merz (available at http://www.pdflib.com/pdflib/index.html; you will also need the JPEG library and the TIFF library to compile this. These two libs also quite often make problems when configuring php. Follow the messages of configure to fix possible problems. If you use pdflib 2.01 check how the lib was installed. There should be file or link libpdf.so. Version 2.01 just creates a lib with the name libpdf2.01.so which cannot be found when linking the test programm in configure. You will have to create a symbolic link from libpdf.so to libpdf2.01.so.).

Version 2.20 of pdflib has introduced more changes to its API and support for chinese and japanese fonts. This unfortunately causes some changes of the pdf module of php4 (not php3). If you use pdflib 2.20 handle the in memory generation of PDF documents with care. Until pdflib 3.0 is released it might be unstable. The encoding parameter of pdf_set_font() has changed to a string. This means that instead of e.g. 4 you have to use 'winansi'.

If you use pdflib 2.30 the pdf_set_text_matrix() will have gone. It is not supported any more. In general it is a good advise to consult the release notes of the used version of pdflib for possible changes.

Since version 3.0 of pdflib you should configure pdflib with the option --enable-shared-pdflib.

Any version of PHP4 after March, 9th 2000 do not support versions of pdflib older than 3.0. PHP3 on the other hand should not be used with version newer than 2.01.

Please consult the excellent documentation for pdflib shipped with the source distribution of pdflib. It provides a very good overview of what pdflib capable of doing. Most of the functions in pdflib and the PHP module have the same name. The parameters are also identical. You should also understand some of the concepts of PDF or Postscript to efficiently use this module. All lengths and coordinates are measured in Postscript points. There are generally 72 PostScript points to an inch, but this depends on the output resolution.

There is another PHP module for pdf document creation based on FastIO's. ClibPDF. It has a slightly different API. Check the ClibPDF functions section for details.

Currently all versions of pdflib are supported. It is recommended that you use the newest version since it has more features and fixes some problems which required a patch for the old version. Unfortunately, the changes of the pdflib API in 2.x compared to 0.6 have been so severe that even some PHP functions had to be altered. Here is a list of changes:

  • The Info structure does not exist anymore. Therefore the function
pdf_get_info() is obsolete and the functions
pdf_set_info_creator(),
pdf_set_info_title(),
pdf_set_info_author(),
pdf_set_info_subject() and
pdf_set_info_keywords() do not take the
info structure as the first parameter but the pdf document. This
also means that the pdf document must be opened before these functions
can be called. The above functions can and should also be replaced by
pdf_set_info()

  • The way a new document is opened has changed. The function pdf_open() takes only one parameter which is the file handle of a file opened with fopen().

There were some more changes with the release 2.01 of pdflib which should be covered by PHP. Some functions are not required anymore (e.g. pdf_put_image()). You will get a warning so don't be shocked.

The pdf module introduces two new types of variables (if pdflib 2.x is used it is only one new type). They are called pdfdoc and pdfinfo (pdfinfo is not existent if pdflib 2.x is used. pdfdoc is a pointer to a pdf document and almost all functions need it as its first parameter. pdfinfo contains meta data about the PDF document. It has to be set before pdf_open() is called.

Nota: The following is only TRUE for pdflib 0.6. Read the pdflib manual for newer version

In order to output text into a PDF document you will need to provide the afm file for each font. Afm files contain font metrics for a Postscript font. By default these afm files are searched for in a directory named 'fonts' relative to the directory where the PHP script is located. (Again, this was TRUE for pdflib 0.6, newer versions do not not neccessarily need the afm files.)

Most of the functions are fairly easy to use. The most difficult part is probably to create a very simple pdf document at all. The following example should help to get started. It uses the PHP functions for pdflib 0.6. It creates the file test.pdf with one page. The page contains the text "Times-Roman" in an outlined 30pt font. The text is also underlined.

Ejemplo 1. Creating a PDF document with pdflib 0.6

<?php
$fp = fopen("test.pdf", "w");
$info = PDF_get_info();
pdf_set_info_author($info, "Uwe Steinmann");
PDF_set_info_title($info, "Test for PHP wrapper of PDFlib 0.6");
PDF_set_info_author($info, "Name of Author");
pdf_set_info_creator($info, "See Author");
pdf_set_info_subject($info, "Testing");
$pdf = PDF_open($fp, $info);
PDF_begin_page($pdf, 595, 842);
PDF_add_outline($pdf, "Page 1");
pdf_set_font($pdf, "Times-Roman", 30, 4);
pdf_set_text_rendering($pdf, 1);
PDF_show_xy($pdf, "Times Roman outlined", 50, 750);
pdf_moveto($pdf, 50, 740);
pdf_lineto($pdf, 330, 740);
pdf_stroke($pdf);
PDF_end_page($pdf);
PDF_close($pdf);
fclose($fp);
echo "<A HREF=getpdf.php3>finished</A>";
?>

The PHP script getpdf.php3 just outputs the pdf document.

<?php
$fp = fopen("test.pdf", "r");
header("Content-type: application/pdf");
fpassthru($fp);
fclose($fp);
?>

Doing the same with pdflib 2.x looks like the following:

Ejemplo 2. Creating a PDF document with pdflib 2.x

<?php
$fp = fopen("test.pdf", "w");
$pdf = PDF_open($fp);
pdf_set_info_author($pdf, "Uwe Steinmann");
PDF_set_info_title($pdf, "Test for PHP wrapper of PDFlib 2.0");
PDF_set_info_author($pdf, "Name of Author");
pdf_set_info_creator($pdf, "See Author");
pdf_set_info_subject($pdf, "Testing");
PDF_begin_page($pdf, 595, 842);
PDF_add_outline($pdf, "Page 1");
pdf_set_font($pdf, "Times-Roman", 30, 4);
pdf_set_text_rendering($pdf, 1);
PDF_show_xy($pdf, "Times Roman outlined", 50, 750);
pdf_moveto($pdf, 50, 740);
pdf_lineto($pdf, 330, 740);
pdf_stroke($pdf);
PDF_end_page($pdf);
PDF_close($pdf);
fclose($fp);
echo "<A HREF=getpdf.php3>finished</A>";
?>

The PHP script getpdf.php3 is the same as above.

The pdflib distribution contains a more complex example which creates a serious of pages with an analog clock. This example converted into PHP using pdflib 2.x looks as the following (you can see the same example in the documentation for the clibpdf module):

Ejemplo 3. pdfclock example from pdflib 2.x distribution

<?php
$pdffilename = "clock.pdf";
$radius = 200;
$margin = 20;
$pagecount = 40;

$fp = fopen($pdffilename, "w");
$pdf = pdf_open($fp);
pdf_set_info_creator($pdf, "pdf_clock.php3");
pdf_set_info_author($pdf, "Uwe Steinmann");
pdf_set_info_title($pdf, "Analog Clock");

while($pagecount-- > 0) {
    pdf_begin_page($pdf, 2 * ($radius + $margin), 2 * ($radius + $margin));

    pdf_set_transition($pdf, 4);  /* wipe */
    pdf_set_duration($pdf, 0.5);

    pdf_translate($pdf, $radius + $margin, $radius + $margin);
    pdf_save($pdf);
    pdf_setrgbcolor($pdf, 0.0, 0.0, 1.0);

    /* minute strokes */
    pdf_setlinewidth($pdf, 2.0);
    for ($alpha = 0; $alpha < 360; $alpha += 6) {
        pdf_rotate($pdf, 6.0);
        pdf_moveto($pdf, $radius, 0.0);
        pdf_lineto($pdf, $radius-$margin/3, 0.0);
        pdf_stroke($pdf);
    }

    pdf_restore($pdf);
    pdf_save($pdf);

    /* 5 minute strokes */
    pdf_setlinewidth($pdf, 3.0);
    for ($alpha = 0; $alpha < 360; $alpha += 30) {
        pdf_rotate($pdf, 30.0);
        pdf_moveto($pdf, $radius, 0.0);
        pdf_lineto($pdf, $radius-$margin, 0.0);
        pdf_stroke($pdf);
    }

    $ltime = getdate();

    /* draw hour hand */
    pdf_save($pdf);
    pdf_rotate($pdf,-(($ltime['minutes']/60.0)+$ltime['hours']-3.0)*30.0);
    pdf_moveto($pdf, -$radius/10, -$radius/20);
    pdf_lineto($pdf, $radius/2, 0.0);
    pdf_lineto($pdf, -$radius/10, $radius/20);
    pdf_closepath($pdf);
    pdf_fill($pdf);
    pdf_restore($pdf);

    /* draw minute hand */
    pdf_save($pdf);
    pdf_rotate($pdf,-(($ltime['seconds']/60.0)+$ltime['minutes']-15.0)*6.0);
    pdf_moveto($pdf, -$radius/10, -$radius/20);
    pdf_lineto($pdf, $radius * 0.8, 0.0);
    pdf_lineto($pdf, -$radius/10, $radius/20);
    pdf_closepath($pdf);
    pdf_fill($pdf);
    pdf_restore($pdf);

    /* draw second hand */
    pdf_setrgbcolor($pdf, 1.0, 0.0, 0.0);
    pdf_setlinewidth($pdf, 2);
    pdf_save($pdf);
    pdf_rotate($pdf, -(($ltime['seconds'] - 15.0) * 6.0));
    pdf_moveto($pdf, -$radius/5, 0.0);
    pdf_lineto($pdf, $radius, 0.0);
    pdf_stroke($pdf);
    pdf_restore($pdf);

    /* draw little circle at center */
    pdf_circle($pdf, 0, 0, $radius/30);
    pdf_fill($pdf);

    pdf_restore($pdf);

    pdf_end_page($pdf);
}

$pdf = pdf_close($pdf);
fclose($fp);
echo "<A HREF=getpdf.php3?filename=".$pdffilename.">finished</A>";
?>

The PHP script getpdf.php3 just outputs the pdf document.
<?php
$fp = fopen($filename, "r");
header("Content-type: application/pdf");
fpassthru($fp);
fclose($fp);
?>

Tabla de contenidos
pdf_add_annotation — Adds annotation
PDF_add_outline — Adds bookmark for current page
PDF_arc — Draws an arc
PDF_begin_page — Starts new page
PDF_circle — Draws a circle
PDF_clip — Clips to current path
PDF_close — Closes a pdf document
PDF_close_image — Closes an image
PDF_closepath — Closes path
PDF_closepath_fill_stroke — Closes, fills and strokes current path
PDF_closepath_stroke — Closes path and draws line along path
PDF_continue_text — Outputs text in next line
PDF_curveto — Draws a curve
PDF_end_page — Ends a page
PDF_endpath — Ends current path
PDF_execute_image — Places a stored image on the page
PDF_fill — Fills current path
PDF_fill_stroke — Fills and strokes current path
PDF_get_info — Returns an empty info structure for a pdf document
PDF_get_parameter — Gets certain parameters
PDF_get_value — Gets certain numerical value
PDF_lineto — Draws a line
PDF_moveto — Sets current point
PDF_open — Opens a new pdf document
PDF_open_gif — Opens a GIF image
PDF_open_jpeg — Opens a JPEG image
PDF_open_memory_image — Opens an image created with PHP's image functions
PDF_open_png — Opens a PNG image
PDF_place_image — Places an image on the page
PDF_put_image — Stores an image in the PDF for later use
PDF_rect — Draws a rectangle
PDF_restore — Restores formerly saved environment
PDF_rotate — Sets rotation
PDF_save — Saves the current environment
PDF_scale — Sets scaling
PDF_set_border_color — Sets color of border around links and annotations
PDF_set_border_dash — Sets dash style of border around links and annotations
PDF_set_border_style — Sets style of border around links and annotations
PDF_set_char_spacing — Sets character spacing
PDF_set_duration — Sets duration between pages
PDF_set_font — Selects a font face and size
PDF_set_horiz_scaling — Sets horizontal scaling of text
PDF_set_info — Fills a field of the document information
PDF_set_leading — Sets distance between text lines
PDF_set_parameter — Sets certain parameters
PDF_set_text_matrix — Sets the text matrix
PDF_set_text_pos — Sets text position
PDF_set_text_rendering — Determines how text is rendered
PDF_set_text_rise — Sets the text rise
PDF_set_transition — Sets transition between pages
PDF_set_value — Sets certain numerical value
PDF_set_word_spacing — Sets spacing between words
PDF_setdash — Sets dash pattern
PDF_setflat — Sets flatness
PDF_setgray — Sets drawing and filling color to gray value
PDF_setgray_fill — Sets filling color to gray value
PDF_setgray_stroke — Sets drawing color to gray value
PDF_setlinecap — Sets linecap parameter
PDF_setlinejoin — Sets linejoin parameter
PDF_setlinewidth — Sets line width
PDF_setmiterlimit — Sets miter limit
PDF_setrgbcolor — Sets drawing and filling color to rgb color value
PDF_setrgbcolor_fill — Sets filling color to rgb color value
PDF_setrgbcolor_stroke — Sets drawing color to rgb color value
PDF_show — Output text at current position
PDF_show_boxed — Output text in a box
PDF_show_xy — Output text at given position
PDF_skew — Skews the coordinate system
PDF_stringwidth — Returns width of text using current font
PDF_stroke — Draws line along path
PDF_translate — Sets origin of coordinate system

Anterior | Inicio | Siguiente
overload | Subir | pdf_add_annotation


PDF_get_info

(PHP 3>= 3.0.6)

PDF_get_info -- Returns an empty info structure for a pdf document

Description

info pdf_get_info ( string filename)

The PDF_get_info() function returns an empty info structure for the pdf document. It should be filled with appropriate information like the author, subject etc. of the document.

Nota: This functions is not available if pdflib 2.x support is activated.

See also PDF_set_info_creator(),
         PDF_set_info_author(),
         PDF_set_info_keywords(),
         PDF_set_info_title(),
         PDF_set_info_subject().

Anterior | Inicio | Siguiente
PDF_fill_stroke | Subir | PDF_get_parameter


PDF_set_info

(PHP 4 )

PDF_set_info -- Fills a field of the document information

Description

void pdf_set_info ( int pdf document, string fieldname, string value)

The PDF_set_info() function sets an information field of a pdf document. Possible values for the fieldname are 'Subject', 'Title', 'Creator', 'Author', 'Keywords' and one user-defined name. It can be called before beginning a page.

Ejemplo 1. Setting document information

<?php
$fd = fopen("test.pdf", "w");
$pdfdoc = pdf_open($fd);
pdf_set_info($pdfdoc, "Author", "Uwe Steinmann");
pdf_set_info($pdfdoc, "Creator", "Uwe Steinmann");
pdf_set_info($pdfdoc, "Title", "Testing Info Fields");
pdf_set_info($pdfdoc, "Subject", "Test");
pdf_set_info($pdfdoc, "Keywords", "Test, Fields");
pdf_set_info($pdfdoc, "CustomField", "What ever makes sense");
pdf_begin_page($pdfdoc, 595, 842);
pdf_end_page($pdfdoc);
pdf_close($pdfdoc);
?>

Nota:
     This function replaces PDF_set_info_keywords(),
              PDF_set_info_title(),
              PDF_set_info_subject(),
              PDF_set_info_creator(),
              PDF_set_info_sybject().

Anterior | Inicio | Siguiente
PDF_set_horiz_scaling | Subir | PDF_set_leading


PDF_open

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_open -- Opens a new pdf document

Description

int pdf_open ( int file, int info)

The PDF_open() function opens a new pdf document. The corresponding file has to be opened with fopen() and the file descriptor passed as argument file. info is the info structure that has to be created with pdf_get_info(). The info structure will be deleted within this function.

Nota: The return value is needed as the first parameter in all other functions writing to the pdf document.

Nota: This function does not allow the second parameter if pdflib 2.0 support is activated.

See also fopen(),
         PDF_get_info(),
         PDF_close().

Anterior | Inicio | Siguiente
PDF_moveto | Subir | PDF_open_gif


PDF_close

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_close -- Closes a pdf document

Description

void pdf_close ( int pdf document)

The PDF_close() function closes the pdf document.

Nota: Due to an unclean implementation of the pdflib 0.6 the internal closing of the document also closes the file. This should not be done because pdflib did not open the file, but expects an already open file when PDF_open() is called. Consequently it shouldn't close the file. In order to fix this just take out line 190 of the file p_basic.c in the pdflib 0.6 source distribution until the next release of pdflib will fix this.

Nota: This function works properly without any patches to pdflib if pdflib 2.0 support is activated.

See also PDF_open(), fclose().

Anterior | Inicio | Siguiente
PDF_clip | Subir | PDF_close_image


PDF_begin_page

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_begin_page -- Starts new page

Description

void pdf_begin_page ( int pdf document, double width, double height)

The PDF_begin_page() function starts a new page with height height and width width. In order to create a valid document you must call this function and PDF_end_page().

See also PDF_end_page().

Anterior | Inicio | Siguiente
PDF_arc | Subir | PDF_circle


PDF_end_page

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_end_page -- Ends a page

Description

void pdf_end_page ( int pdf document)

The PDF_end_page() function ends a page. Once a page is ended it cannot be modified anymore.

See also PDF_begin_page().

Anterior | Inicio | Siguiente
PDF_curveto | Subir | PDF_endpath


PDF_show

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_show -- Output text at current position

Description

void pdf_show ( int pdf document, string text)

The PDF_show() function outputs the string text at the current position using the current font.

See also PDF_show_xy(),
         PDF_set_text_pos(),
         PDF_set_font().

Anterior | Inicio | Siguiente
PDF_setrgbcolor_stroke | Subir | PDF_show_boxed


PDF_show_boxed

(PHP 4 >= 4.0.0)

PDF_show_boxed -- Output text in a box

Description

int pdf_show_boxed ( int pdf document, string text, double x-coor, double y-coor, double width, double height, string mode)

The PDF_show_boxed() function outputs the string text in a box with its lower left position at (x-coor, y-coor). The boxes dimension is height by width. The parameter mode determines how the text is type set. If width and height are zero, the mode can be "left", "right" or "center". If width or height is unequal zero it can also be "justify" and "fulljustify".

Returns the number of characters that could not be processed because they did not fit into the box.

See also PDF_show(), PDF_show_xy().

Anterior | Inicio | Siguiente
PDF_show | Subir | PDF_show_xy


PDF_show_xy

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_show_xy -- Output text at given position

Description

void pdf_show_xy ( int pdf document, string text, double x-coor, double y-coor)

The PDF_show_xy() function outputs the string text at position (x-coor, y-coor).

See also PDF_show().

Anterior | Inicio | Siguiente
PDF_show_boxed | Subir | PDF_skew


PDF_set_font

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_font -- Selects a font face and size

Description

void pdf_set_font ( int pdf document, string font name, double size, string encoding [, int embed])

The PDF_set_font() function sets the current font face, font size and encoding. If you use pdflib 0.6 you will need to provide the Adobe Font Metrics (afm-files) for the font in the font path (default is ./fonts). If you use php3 or a version of pdflib older than 2.20 the fourth parameter encoding can take the following values: 0 = builtin, 1 = pdfdoc, 2 = macroman, 3 = macexpert, 4 = winansi. An encoding greater than 4 and less than 0 will default to winansi. winansi is often a good choice. If you use php4 and a version of pdflib >= 2.20 the encoding parameter has changed to a string. Use 'winansi', 'builtin', 'host', 'macroman' etc. instead. If the last parameter is set to 1 the font is embedded into the pdf document otherwise it is not. To embed a font is usually a good idea if the font is not widely spread and you cannot ensure that the person watching your document has access on fonts in the document. I font is only embedded once even if you call PDF_set_font() several times.

Nota: This function has to be called after PDF_begin_page() in order to create a valid pdf document.

Nota: If you reference a font in a .upr file make sure the name in the afm file and the font name are the same. Otherwise, the font will be embedded several times (Thanks to Paul Haddon for finding this.)

Anterior | Inicio | Siguiente
PDF_set_duration | Subir | PDF_set_horiz_scaling


PDF_set_leading

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_leading -- Sets distance between text lines

Description

void pdf_set_leading ( int pdf document, double distance)

The PDF_set_leading() function sets the distance between text lines. This will be used if text is output by PDF_continue_text().

See also PDF_continue_text().

Anterior | Inicio | Siguiente
PDF_set_info | Subir | PDF_set_parameter


PDF_set_parameter

(PHP 4 >= 4.0.0)

PDF_set_parameter -- Sets certain parameters

Description

void pdf_set_parameter ( int pdf document, string name, string value)

The PDF_set_parameter() function sets several parameters of pdflib which are of the type string.

See also PDF_get_value(),
         PDF_set_value(),
         PDF_get_parameter().

Anterior | Inicio | Siguiente
PDF_set_leading | Subir | PDF_set_text_matrix


PDF_get_parameter

(PHP 4 )

PDF_get_parameter -- Gets certain parameters

Description

string pdf_get_parameter ( int pdf document, string name, double modifier)

The PDF_get_parameter() function gets several parameters of pdflib which are of the type string. The function parameter modifier characterizes the parameter to get. If the modifier is not needed it has to be 0.

See also PDF_get_value(),
         PDF_set_value(),
         PDF_set_parameter().

Anterior | Inicio | Siguiente
PDF_get_info | Subir | PDF_get_value


PDF_set_value

(PHP 4 )

PDF_set_value -- Sets certain numerical value

Description

void pdf_set_value ( int pdf document, string name, double value)

The PDF_set_value() function sets several numerical parameters of pdflib.

See also PDF_get_value(),
         PDF_get_parameter(),
         PDF_set_parameter().

Anterior | Inicio | Siguiente
PDF_set_transition | Subir | PDF_set_word_spacing


PDF_get_value

(PHP 4 )

PDF_get_value -- Gets certain numerical value

Description

double pdf_get_value ( int pdf document, string name, double modifier)

The PDF_get_value() function gets several numerical parameters of pdflib. The function parameter modifier characterizes the parameter to get. If the modifier is not needed it has to be 0.

See also PDF_set_value(),
         PDF_get_parameter(),
         PDF_set_parameter().

Anterior | Inicio | Siguiente
PDF_get_parameter | Subir | PDF_lineto


PDF_set_text_rendering

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_text_rendering -- Determines how text is rendered

Description

void pdf_set_text_rendering ( int pdf document, int mode)

The PDF_set_text_rendering() function determines how text is rendered. The possible values for mode are 0=fill text, 1=stroke text, 2=fill and stroke text, 3=invisible, 4=fill text and add it to cliping path, 5=stroke text and add it to clipping path, 6=fill and stroke text and add it to cliping path, 7=add it to clipping path.

Anterior | Inicio | Siguiente
PDF_set_text_pos | Subir | PDF_set_text_rise


PDF_set_horiz_scaling

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_horiz_scaling -- Sets horizontal scaling of text

Description

void pdf_set_horiz_scaling ( int pdf document, double scale)

The PDF_set_horiz_scaling() function sets the horizontal scaling to scale percent.

Anterior | Inicio | Siguiente
PDF_set_font | Subir | PDF_set_info


PDF_set_text_rise

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_text_rise -- Sets the text rise

Description

void pdf_set_text_rise ( int pdf document, double rise)

The PDF_set_text_rise() function sets the text rising to rise points.

Anterior | Inicio | Siguiente
PDF_set_text_rendering | Subir | PDF_set_transition


PDF_set_text_matrix

(PHP 3>= 3.0.6)

PDF_set_text_matrix -- Sets the text matrix

Description

void pdf_set_text_matrix ( int pdf document, array matrix)

The PDF_set_text_matrix() function sets a matrix which describes a transformation applied on the current text font. The matrix has to passed as an array with six elements.

Anterior | Inicio | Siguiente
PDF_set_parameter | Subir | PDF_set_text_pos


PDF_set_text_pos

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_text_pos -- Sets text position

Description

void pdf_set_text_pos ( int pdf document, double x-coor, double y-coor)

The PDF_set_text_pos() function sets the position of text for the next pdf_show() function call.

See also PDF_show(), PDF_show_xy().

Anterior | Inicio | Siguiente
PDF_set_text_matrix | Subir | PDF_set_text_rendering


PDF_set_char_spacing

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_char_spacing -- Sets character spacing

Description

void pdf_set_char_spacing ( int pdf document, double space)

The PDF_set_char_spacing() function sets the spacing between characters.

See also PDF_set_word_spacing(), PDF_set_leading().

Anterior | Inicio | Siguiente
PDF_set_border_style | Subir | PDF_set_duration


PDF_set_word_spacing

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_word_spacing -- Sets spacing between words

Description

void pdf_set_word_spacing ( int pdf document, double space)

The PDF_set_word_spacing() function sets the spacing between words.

See also PDF_set_char_spacing(), PDF_set_leading().

Anterior | Inicio | Siguiente
PDF_set_value | Subir | PDF_setdash


PDF_skew

(PHP 4 >= 4.0.0)

PDF_skew -- Skews the coordinate system

Description

void pdf_skew ( int pdf document, double alpha, double beta)

The PDF_skew() function skew the coordinate system by alpha (x) and beta (y) degrees. alpha and beta may not be 90 or 270 degrees.

Anterior | Inicio | Siguiente
PDF_show_xy | Subir | PDF_stringwidth


PDF_continue_text

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_continue_text -- Outputs text in next line

Description

void pdf_continue_text ( int pdf document, string text)

The PDF_continue_text() function outputs the string in text in the next line. The distance between the lines can be set with PDF_set_leading().

See also PDF_show_xy(),
         PDF_set_leading(),
         PDF_set_text_pos().

Anterior | Inicio | Siguiente
PDF_closepath_stroke | Subir | PDF_curveto


PDF_stringwidth

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_stringwidth -- Returns width of text using current font

Description

double pdf_stringwidth ( int pdf document, string text)

The PDF_stringwidth() function returns the width of the string in text by using the current font. It requires a font to be set before with PDF_set_font().

See also PDF_set_font().

Anterior | Inicio | Siguiente
PDF_skew | Subir | PDF_stroke


PDF_save

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_save -- Saves the current environment

Description

void pdf_save ( int pdf document)

The PDF_save() function saves the current environment. It works like the postscript command gsave. Very useful if you want to translate or rotate an object without effecting other objects. PDF_save() should always be followed by PDF_restore() to restore the environment before PDF_save().

See also PDF_restore().

Anterior | Inicio | Siguiente
PDF_rotate | Subir | PDF_scale


PDF_restore

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_restore -- Restores formerly saved environment

Description

void pdf_restore ( int pdf document)

The PDF_restore() function restores the environment saved with PDF_save(). It works like the postscript command grestore.

Ejemplo 1. Save and Restore

<?php PDF_save($pdf);
// do all kinds of rotations, transformations, ...
PDF_restore($pdf) ?>

See also PDF_save().

Anterior | Inicio | Siguiente
PDF_rect | Subir | PDF_rotate


PDF_translate

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_translate -- Sets origin of coordinate system

Description

void pdf_translate ( int pdf document, double x-coor, double y-coor)

The PDF_translate() function sets the origin of coordinate system to the point (x-coor, y-coor) relativ the current origin. The following example draws a line from (0, 0) to (200, 200) relative to the initial coordinate system. You have to set the current point after PDF_translate() and before you start drawing more objects.

Ejemplo 1. Translation

<?php PDF_moveto($pdf, 0, 0);
PDF_lineto($pdf, 100, 100);
PDF_stroke($pdf);
PDF_translate($pdf, 100, 100);
PDF_moveto($pdf, 0, 0);
PDF_lineto($pdf, 100, 100);
PDF_stroke($pdf);
?>

Anterior | Inicio | Siguiente
PDF_stroke | Subir | Verisign Payflow Pro functions


PDF_scale

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_scale -- Sets scaling

Description

void pdf_scale ( int pdf document, double x-scale, double y-scale)

The PDF_scale() function sets the scaling factor in both directions. The following example scales x and y direction by 72. The following line will therefore be drawn one inch in both directions.

Ejemplo 1. Scaling

<?php PDF_scale($pdf, 72.0, 72.0);
PDF_lineto($pdf, 1, 1);
PDF_stroke($pdf);
?>

Anterior | Inicio | Siguiente
PDF_save | Subir | PDF_set_border_color


PDF_rotate

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_rotate -- Sets rotation

Description

void pdf_rotate ( int pdf document, double angle)

The PDF_rotate() function sets the rotation in degress to angle.

Anterior | Inicio | Siguiente
PDF_restore | Subir | PDF_save


PDF_setflat

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setflat -- Sets flatness

Description

void pdf_setflat ( int pdf document, double value)

The PDF_setflat() function sets the flatness to a value between 0 and 100.

Anterior | Inicio | Siguiente
PDF_setdash | Subir | PDF_setgray


PDF_setlinejoin

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setlinejoin -- Sets linejoin parameter

Description

void pdf_setlinejoin ( int pdf document, long value)

The PDF_setlinejoin() function sets the linejoin parameter between a value of 0 and 2.

Anterior | Inicio | Siguiente
PDF_setlinecap | Subir | PDF_setlinewidth


PDF_setlinecap

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setlinecap -- Sets linecap parameter

Description

void pdf_setlinecap ( int pdf document, int value)

The PDF_setlinecap() function sets the linecap parameter between a value of 0 and 2.

Anterior | Inicio | Siguiente
PDF_setgray_stroke | Subir | PDF_setlinejoin


PDF_setmiterlimit

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setmiterlimit -- Sets miter limit

Description

void pdf_setmiterlimit ( int pdf document, double value)

The PDF_setmiterlimit() function sets the miter limit to a value greater of equal than 1.

Anterior | Inicio | Siguiente
PDF_setlinewidth | Subir | PDF_setrgbcolor


PDF_setlinewidth

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setlinewidth -- Sets line width

Description

void pdf_setlinewidth ( int pdf document, double width)

The PDF_setlinewidth() function sets the line width to width.

Anterior | Inicio | Siguiente
PDF_setlinejoin | Subir | PDF_setmiterlimit


PDF_setdash

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setdash -- Sets dash pattern

Description

void pdf_setdash ( int pdf document, double white, double black)

The PDF_setdash() function sets the dash pattern white white points and black black points. If both are 0 a solid line is set.

Anterior | Inicio | Siguiente
PDF_set_word_spacing | Subir | PDF_setflat


PDF_moveto

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_moveto -- Sets current point

Description

void pdf_moveto ( int pdf document, double x-coor, double y-coor)

The PDF_moveto() function sets the current point to the coordinates x-coor and y-coor.

Anterior | Inicio | Siguiente
PDF_lineto | Subir | PDF_open


PDF_curveto

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_curveto -- Draws a curve

Description

void pdf_curveto ( int pdf document, double x1, double y1, double x2, double y2, double x3, double y3)

The PDF_curveto() function draws a Bezier curve from the current point to the point (x3, y3) using (x1, y1) and (x2, y2) as control points.

See also PDF_moveto(),
         PDF_lineto(),
         PDF_stroke().

Anterior | Inicio | Siguiente
PDF_continue_text | Subir | PDF_end_page


PDF_lineto

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_lineto -- Draws a line

Description

void pdf_lineto ( int pdf document, double x-coor, double y-coor)

The PDF_lineto() function draws a line from the current point to the point with coordinates (x-coor, y-coor).

See also PDF_moveto(),
         PDF_curveto(),
         PDF_stroke().

Anterior | Inicio | Siguiente
PDF_get_value | Subir | PDF_moveto


PDF_circle

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_circle -- Draws a circle

Description

void pdf_circle ( int pdf document, double x-coor, double y-coor, double radius)

The PDF_circle() function draws a circle with center at point (x-coor, y-coor) and radius radius.

See also PDF_arc(), PDF_stroke().

Anterior | Inicio | Siguiente
PDF_begin_page | Subir | PDF_clip


PDF_arc

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_arc -- Draws an arc

Description

void pdf_arc ( int pdf document, double x-coor, double y-coor, double radius, double start, double end)

The PDF_arc() function draws an arc with center at point (x-coor, y-coor) and radius radius, starting at angle start and ending at angle end.

See also PDF_circle(), PDF_stroke().

Anterior | Inicio | Siguiente
PDF_add_outline | Subir | PDF_begin_page


PDF_rect

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_rect -- Draws a rectangle

Description

void pdf_rect ( int pdf document, double x-coor, double y-coor, double width, double height)

The PDF_rect() function draws a rectangle with its lower left corner at point (x-coor, y-coor). This width is set to widgth. This height is set to height.

See also PDF_stroke().

Anterior | Inicio | Siguiente
PDF_put_image | Subir | PDF_restore


PDF_closepath

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_closepath -- Closes path

Description

void pdf_closepath ( int pdf document)

The PDF_closepath() function closes the current path. This means, it draws a line from current point to the point where the first line was started. Many functions like PDF_moveto(), PDF_circle() and PDF_rect() start a new path.

Anterior | Inicio | Siguiente
PDF_close_image | Subir | PDF_closepath_fill_stroke


PDF_stroke

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_stroke -- Draws line along path

Description

void pdf_stroke ( int pdf document)

The PDF_stroke() function draws a line along current path. The current path is the sum of all line drawing. Without this function the line would not be drawn.

See also PDF_closepath(), PDF_closepath_stroke().

Anterior | Inicio | Siguiente
PDF_stringwidth | Subir | PDF_translate


PDF_closepath_stroke

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_closepath_stroke -- Closes path and draws line along path

Description

void pdf_closepath_stroke ( int pdf document)

The PDF_closepath_stroke() function is a
combination of PDF_closepath() and
PDF_stroke(). It also clears the path.

See also PDF_closepath(), PDF_stroke().

Anterior | Inicio | Siguiente
PDF_closepath_fill_stroke | Subir | PDF_continue_text


PDF_fill

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_fill -- Fills current path

Description

void pdf_fill ( int pdf document)

The PDF_fill() function fills the interior of the current path with the current fill color.

See also PDF_closepath(),
         PDF_stroke(),
         PDF_setgray_fill(),
         PDF_setgray(),
         PDF_setrgbcolor_fill(),
         PDF_setrgbcolor().

Anterior | Inicio | Siguiente
PDF_execute_image | Subir | PDF_fill_stroke


PDF_fill_stroke

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_fill_stroke -- Fills and strokes current path

Description

void pdf_fill_stroke ( int pdf document)

The PDF_fill_stroke() function fills the interior of the current path with the current fill color and draws current path.

See also PDF_closepath(),
         PDF_stroke(),
         PDF_fill(),
         PDF_setgray_fill(),
         PDF_setgray(),
         PDF_setrgbcolor_fill(),
         PDF_setrgbcolor().

Anterior | Inicio | Siguiente
PDF_fill | Subir | PDF_get_info


PDF_closepath_fill_stroke

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_closepath_fill_stroke -- Closes, fills and strokes current path

Description

void pdf_closepath_fill_stroke ( int pdf document)

The PDF_closepath_fill_stroke() function closes, fills the interior of the current path with the current fill color and draws current path.

See also PDF_closepath(),
         PDF_stroke(),
         PDF_fill(),
         PDF_setgray_fill(),
         PDF_setgray(),
         PDF_setrgbcolor_fill(),
         PDF_setrgbcolor().

Anterior | Inicio | Siguiente
PDF_closepath | Subir | PDF_closepath_stroke


PDF_endpath

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_endpath -- Ends current path

Description

void pdf_endpath ( int pdf document)

The PDF_endpath() function ends the current path but does not close it.

See also PDF_closepath().

Anterior | Inicio | Siguiente
PDF_end_page | Subir | PDF_execute_image


PDF_clip

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_clip -- Clips to current path

Description

void pdf_clip ( int pdf document)

The PDF_clip() function clips all drawing to the current path.

Anterior | Inicio | Siguiente
PDF_circle | Subir | PDF_close


PDF_setgray_fill

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setgray_fill -- Sets filling color to gray value

Description

void pdf_setgray_fill ( int pdf document, double gray value)

The PDF_setgray_fill() function sets the current gray value to fill a path.

See also PDF_setrgbcolor_fill().

Anterior | Inicio | Siguiente
PDF_setgray | Subir | PDF_setgray_stroke


PDF_setgray_stroke

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setgray_stroke -- Sets drawing color to gray value

Description

void pdf_setgray_stroke ( int pdf document, double gray value)

The PDF_setgray_stroke() function sets the current drawing color to the given gray value.

See also PDF_setrgbcolor_stroke().

Anterior | Inicio | Siguiente
PDF_setgray_fill | Subir | PDF_setlinecap


PDF_setgray

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setgray -- Sets drawing and filling color to gray value

Description

void pdf_setgray ( int pdf document, double gray value)

The PDF_setgray() function sets the current drawing and filling color to the given gray value.

See also PDF_setrgbcolor_stroke(), PDF_setrgbcolor_fill().

Anterior | Inicio | Siguiente
PDF_setflat | Subir | PDF_setgray_fill


PDF_setrgbcolor_fill

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setrgbcolor_fill -- Sets filling color to rgb color value

Description

void pdf_setrgbcolor_fill ( int pdf document, double red value, double green value, double blue value)

The PDF_setrgbcolor_fill() function sets the current rgb color value to fill a path.

See also PDF_setrgbcolor_fill().

Anterior | Inicio | Siguiente
PDF_setrgbcolor | Subir | PDF_setrgbcolor_stroke


PDF_setrgbcolor_stroke

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setrgbcolor_stroke -- Sets drawing color to rgb color value

Description

void pdf_setrgbcolor_stroke ( int pdf document, double red value, double green value, double blue value)

The PDF_setrgbcolor_stroke() function sets the current drawing color to the given rgb color value.

See also PDF_setrgbcolor_stroke().

Anterior | Inicio | Siguiente
PDF_setrgbcolor_fill | Subir | PDF_show


PDF_setrgbcolor

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_setrgbcolor -- Sets drawing and filling color to rgb color value

Description

void pdf_setrgbcolor ( int pdf document, double red value, double green value, double blue value)

The PDF_setrgbcolor_stroke() function sets the current drawing and filling color to the given rgb color value.

See also PDF_setrgbcolor_stroke(), PDF_setrgbcolor_fill().

Anterior | Inicio | Siguiente
PDF_setmiterlimit | Subir | PDF_setrgbcolor_fill


PDF_add_outline

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_add_outline -- Adds bookmark for current page

Description

int pdf_add_outline ( int pdf document, string text [, int parent [, int open]])

The PDF_add_outline() function adds a bookmark with text text that points to the current page. The bookmark is inserted as a child of parent and is by default open if open is not 0. The return value is an identifier for the bookmark which can be used as a parent for other bookmarks. Therefore you can build up hierarchies of bookmarks.

Unfortunately pdflib does not make a copy of the string, which forces PHP to allocate the memory. Currently this piece of memory is not been freed by any PDF function but it will be taken care of by the PHP memory manager.

Anterior | Inicio | Siguiente
pdf_add_annotation | Subir | PDF_arc


PDF_set_transition

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_transition -- Sets transition between pages

Description

void pdf_set_transition ( int pdf document, int transition)

The PDF_set_transition() function set the transition between following pages. The value of transition can be

0 for none,
1 for two lines sweeping across the screen reveal the page,
2 for multiple lines sweeping across the screen reveal the page,
3 for a box reveals the page,
4 for a single line sweeping across the screen reveals the page,
5 for the old page dissolves to reveal the page,
6 for the dissolve effect moves from one screen edge to another,
7 for the old page is simply replaced by the new page (default)

See also PDF_set_duration().

Anterior | Inicio | Siguiente
PDF_set_text_rise | Subir | PDF_set_value


PDF_set_duration

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

PDF_set_duration -- Sets duration between pages

Description

void pdf_set_duration ( int pdf document, double duration)

The PDF_set_duration() function set the duration between following pages in seconds.

See also PDF_set_transition().

Anterior | Inicio | Siguiente
PDF_set_char_spacing | Subir | PDF_set_font


PDF_open_gif

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

PDF_open_gif -- Opens a GIF image

Description

int pdf_open_gif ( int pdf document, string filename)

The PDF_open_gif() function opens an image stored in the file with the name filename. The format of the image has to be gif. The function returns a pdf image identifier.

Ejemplo 1. Including a gif image

<?php
$im = PDF_open_gif($pdf, "test.gif");
pdf_place_image($pdf, $im, 100, 100, 1);
pdf_close_image($pdf, $im);
?>

See also PDF_close_image(),
         PDF_open_jpeg(),
         PDF_open_memory_image(),
         PDF_execute_image(),
         PDF_place_image(),
         PDF_put_image().

Anterior | Inicio | Siguiente
PDF_open | Subir | PDF_open_jpeg


PDF_open_png

(PHP 4 >= 4.0.0)

PDF_open_png -- Opens a PNG image

Description

int pdf_open_png ( int pdf, string png_file)

The PDF_open_png() function opens an image stored in the file with the name filename. The format of the image has to be png. The function returns a pdf image identifier.

Ejemplo 1. Including a PNG image

<?php
$im = PDF_open_png ($pdf, "test.png");
pdf_place_image ($pdf, $im, 100, 100, 1);
pdf_close_image ($pdf, $im);
?>

See also PDF_close_image(),
         PDF_open_jpeg(),
         PDF_open_gif(),
         PDF_open_memory_image(),
         PDF_execute_image(),
         PDF_place_image(),
         PDF_put_image().

Anterior | Inicio | Siguiente
PDF_open_memory_image | Subir | PDF_place_image


PDF_open_memory_image

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

PDF_open_memory_image -- Opens an image created with PHP's image functions

Description

int pdf_open_memory_image ( int pdf document, int image)

The PDF_open_memory_image() function takes an image created with the PHP's image functions and makes it available for the pdf document. The function returns a pdf image identifier.

Ejemplo 1. Including a memory image

<?php
$im = ImageCreate(100, 100);
$col = ImageColorAllocate($im, 80, 45, 190);
ImageFill($im, 10, 10, $col);
$pim = PDF_open_memory_image($pdf, $im);
ImageDestroy($im);
pdf_place_image($pdf, $pim, 100, 100, 1);
pdf_close_image($pdf, $pim);
?>

See also PDF_close_image(),
         PDF_open_jpeg(),
         PDF_open_gif(),
         PDF_open_png()
         PDF_execute_image(),
         PDF_place_image(),
         PDF_put_image().

Anterior | Inicio | Siguiente
PDF_open_jpeg | Subir | PDF_open_png


PDF_open_jpeg

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

PDF_open_jpeg -- Opens a JPEG image

Description

int pdf_open_jpeg ( int pdf document, string filename)

The PDF_open_jpeg() function opens an image stored in the file with the name filename. The format of the image has to be jpeg. The function returns a pdf image identifier.

See also PDF_close_image(),
         PDF_open_gif(),
         PDF_open_png(),
         PDF_open_memory_image(),
         PDF_execute_image(),
         PDF_place_image(),
         PDF_put_image().

Anterior | Inicio | Siguiente
PDF_open_gif | Subir | PDF_open_memory_image


PDF_close_image

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

PDF_close_image -- Closes an image

Description

void pdf_close_image ( int image)

The PDF_close_image() function closes an image which has been opened with any of the PDF_open_xxx() functions.

See also PDF_open_jpeg(),
         PDF_open_gif(),
         PDF_open_memory_image().

Anterior | Inicio | Siguiente
PDF_close | Subir | PDF_closepath


PDF_place_image

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

PDF_place_image -- Places an image on the page

Description

void pdf_place_image ( int pdf document, int image, double x-coor, double y-coor, double scale)

The PDF_place_image() function places an image on the page at postion (x-coor, x-coor). The image can be scaled at the same time.

See also PDF_put_image().

Anterior | Inicio | Siguiente
PDF_open_png | Subir | PDF_put_image


PDF_put_image

(PHP 3>= 3.0.7)

PDF_put_image -- Stores an image in the PDF for later use

Description

void pdf_put_image ( int pdf document, int image)

The PDF_put_image() function places an image in the PDF file without showing it. The stored image can be displayed with the PDF_execute_image() function as many times as needed. This is useful when using the same image multiple times in order to keep the file size small. Using PDF_put_image() and PDF_execute_image() is highly recommended for larger images (several kb) if they show up more than once in the document.

Nota: This function has become meaningless with version 2.01 of pdflib. It will just output a warning.

See also PDF_put_image(),
         PDF_place_image(),
         PDF_execute_image().

Anterior | Inicio | Siguiente
PDF_place_image | Subir | PDF_rect


PDF_execute_image

(PHP 3>= 3.0.7)

PDF_execute_image -- Places a stored image on the page

Description

void pdf_execute_image ( int pdf document, int image, double x-coor, double y-coor, double scale)

The PDF_execute_image() function displays an image that has been put in the PDF file with the PDF_put_image() function on the current page at the given coordinates.

The image can be scaled while displaying it. A scale of 1.0 will show the image in the original size.

Nota: This function has become meaningless with version 2.01 of pdflib. It will just output a warning.

Ejemplo 1. Multiple show of an image

<?php
$im = ImageCreate(100, 100);
$col1 = ImageColorAllocate($im, 80, 45, 190);
ImageFill($im, 10, 10, $col1);
$pim = PDF_open_memory_image($pdf, $im);
pdf_put_image($pdf, $pim);
pdf_execute_image($pdf, $pim, 100, 100, 1);
pdf_execute_image($pdf, $pim, 200, 200, 2);
pdf_close_image($pdf, $pim);
?>

Anterior | Inicio | Siguiente
PDF_endpath | Subir | PDF_fill


pdf_add_annotation

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

pdf_add_annotation -- Adds annotation

Description

void pdf_add_annotation ( int pdf document, double llx, double lly, double urx, double ury, string title, string content)

The pdf_add_annotation() adds a note with the lower left corner at (llx, lly) and the upper right corner at (urx, ury).

Anterior | Inicio | Siguiente
PDF functions | Subir | PDF_add_outline


PDF_set_border_style

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

PDF_set_border_style -- Sets style of border around links and annotations

Description

void pdf_set_border_style ( int pdf document, string style, double width)

The PDF_set_border_style() function sets the style and width of the suroundig box of links and annotations. The parameter style can be 'solid' or 'dashed'.

See also PDF_set_border_color(), PDF_set_border_dash().

Anterior | Inicio | Siguiente
PDF_set_border_dash | Subir | PDF_set_char_spacing


PDF_set_border_color

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

PDF_set_border_color -- Sets color of border around links and annotations

Description

void pdf_set_border_color ( int pdf document, double red, double green, double blue)

The PDF_set_border_color() function sets the color of the suroundig box of links and annotations. The three color components have to have a value between 0.0 and 1.0.

See also PDF_set_border_style(), PDF_set_border_dash().

Anterior | Inicio | Siguiente
PDF_scale | Subir | PDF_set_border_dash


PDF_set_border_dash

(PHP 4 )

PDF_set_border_dash -- Sets dash style of border around links and annotations

Description

void pdf_set_border_dash ( int pdf document, double black, double white)

The PDF_set_border_dash() function sets the lenght of black and white areas of a dashed line of the suroundig box of links and annotations.

See also PDF_set_border_style(), PDF_set_border_color().

Anterior | Inicio | Siguiente
PDF_set_border_color | Subir | PDF_set_border_style


Verisign Payflow Pro functions

Manual de PHP
Anterior Siguiente

LXXV. Verisign Payflow Pro functions

This extension allows you to process credit cards and other financial transactions using Verisign Payment Services, formerly known as Signio (http://www.verisign.com/payment/).

These functions are only available if PHP has been compiled with the --with-pfpro[=DIR] option. You will require the appropriate SDK for your platform, which may be downloaded from within the manager interface once you have registered.

Once you have downloaded the SDK you should copy the files from the lib directory of the distribution. Copy the header file pfpro.h to /usr/local/include and the library file libpfpro.so to /usr/local/lib.

When using these functions, you may omit calls to pfpro_init() and pfpro_cleanup() as this extension will do so automatically if required. However the functions are still available in case you are processing a number of transactions and require fine control over the library. You may perform any number of transactions using pfpro_process() between the two.

These functions have been added in PHP 4.0.2.

Nota: These functions only provide a link to Verisign Payment Services. Be sure to read the Payflow Pro Developers Guide for full details of the required parameters.

Tabla de contenidos
pfpro_cleanup — Shuts down the Payflow Pro library
pfpro_init — Initialises the Payflow Pro library
pfpro_process — Process a transaction with Payflow Pro
pfpro_process_raw — Process a raw transaction with Payflow Pro
pfpro_version — Returns the version of the Payflow Pro software

Anterior | Inicio | Siguiente
PDF_translate | Subir | pfpro_cleanup


pfpro_init

(PHP 4 >= 4.0.2)

pfpro_init -- Initialises the Payflow Pro library

Description

void pfpro_init ( void)

pfpro_init() is used to initialise the Payflow Pro library. You may omit this call, in which case this extension will automatically call pfpro_init() before the first transaction.

See also pfpro_cleanup().

Anterior | Inicio | Siguiente
pfpro_cleanup | Subir | pfpro_process


pfpro_cleanup

(PHP 4 >= 4.0.2)

pfpro_cleanup -- Shuts down the Payflow Pro library

Description

void pfpro_cleanup ( void)

pfpro_cleanup() is used to shutdown the Payflow Pro library cleanly. It should be called after you have processed any transactions and before the end of your script. However you may omit this call, in which case this extension will automatically call pfpro_cleanup() after your script terminates.

See also pfpro_init().

Anterior | Inicio | Siguiente
Verisign Payflow Pro functions | Subir | pfpro_init


pfpro_process

(PHP 4 >= 4.0.2)

pfpro_process -- Process a transaction with Payflow Pro

Description

array pfpro_process ( array parameters [, string address [, int port [, int timeout [, string proxy address [, int proxy port [, string proxy logon [, string proxy password]]]]]]])

Returns: An associative array containing the response

pfpro_process() processes a transaction with Payflow Pro. The first parameter is an associative array containing keys and values that will be encoded and passed to the processor.

The second parameter is optional and specifies the host to connect to. By default this is "test.signio.com", so you will certainly want to change this to "connect.signio.com" in order to process live transactions.

The third parameter specifies the port to connect on. It defaults to 443, the standard SSL port.

The fourth parameter specifies the timeout to be used, in seconds. This defaults to 30 seconds. Note that this timeout appears to only begin once a link to the processor has been established and so your script could potentially continue for a very long time in the event of DNS or network problems.

The fifth parameter, if required, specifies the hostname of your SSL proxy. The sixth parameter specifies the port to use.

The seventh and eighth parameters specify the logon identity and password to use on the proxy.

The function returns an associative array of the keys and values in the response.

Nota: Be sure to read the Payflow Pro Developers Guide for full details of the required parameters.

Ejemplo 1. Payflow Pro example

<?php

pfpro_init();

$transaction = array(USER	=> 'mylogin',
             PWD	=> 'mypassword',
             TRXTYPE	=> 'S',
             TENDER	=> 'C',
             AMT	=> 1.50,
             ACCT	=> '4111111111111111',
             EXPDATE	=> '0904'
             );

$response = pfpro_process($transaction);

if (!$response) {
  die("Couldn't establish link to Verisign.\n");
}

echo "Verisign response code was ".$response[RESULT];
echo ", which means: ".$response[RESPMSG]."\n";

echo "\nThe transaction request: ";
print_r($transaction);

echo "\nThe response: ";
print_r($response);

pfpro_cleanup();

?>

Anterior | Inicio | Siguiente
pfpro_init | Subir | pfpro_process_raw


pfpro_process_raw

(PHP 4 >= 4.0.2)

pfpro_process_raw -- Process a raw transaction with Payflow Pro

Description

string pfpro_process_raw ( string parameters [, string address [, int port [, int timeout [, string proxy address [, int proxy port [, string proxy logon [, string proxy password]]]]]]])

Returns: A string containing the response.

pfpro_process_raw() processes a raw transaction string with Payflow Pro. You should really use pfpro_process() instead, as the encoding rules of these transactions are non-standard.

The first parameter in this case is a string containing the raw transaction request. All other parameters are the same as with pfpro_process(). The return value is a string containing the raw response.

Nota: Be sure to read the Payflow Pro Developers Guide for full details of the required parameters and encoding rules. You would be well advised to use pfpro_process() instead.

Ejemplo 1. Payflow Pro raw example

<?php

pfpro_init();

$response = pfpro_process("USER=mylogin&PWD[5]=m&ndy&TRXTYPE=S&TENDER=C&AMT=1.50&ACCT=4111111111111111&EXPDATE=0904");

if (!$response) {
  die("Couldn't establish link to Verisign.\n");
}

echo "Verisign raw response was ".$response;

pfpro_cleanup();

?>

Anterior | Inicio | Siguiente
pfpro_process | Subir | pfpro_version


pfpro_version

(PHP 4 >= 4.0.2)

pfpro_version -- Returns the version of the Payflow Pro software

Description

string pfpro_version ( void)

pfpro_version() returns the version string of the Payflow Pro library. At the time of writing, this was L211.

Anterior | Inicio | Siguiente
pfpro_process_raw | Subir | opciones e información de PHP


opciones e información de PHP

Manual de PHP
Anterior Siguiente

LXXVI. opciones e información de PHP

Tabla de contenidos
extension_loaded — averigua si una extensión ha sido cargada
get_cfg_var — Obtiene el valor de una opción de configuración de PHP.
get_current_user — Obtiene el nombre del propietario del script PHP actual.
get_magic_quotes_gpc — Obtiene el valor de la configuración activa actual de las comillas mágicas gpc.
get_magic_quotes_runtime — Obtiene el valor de la configuración activa actual de magic_quotes_runtime.
getenv — Obtiene el valor de una variable de entorno
getlastmod — Recupera la fecha/hora de la última modificación de la página.
getmyinode — Recupera el inodo del script actual.
getmypid — Obtiene el ID de proceso de PHP.
getmyuid — Obtiene el UID del propietario del script PHP.
getrusage — Obtiene el consumo actual de recursos.
php_logo_guid — Obtiene el guid logo
phpinfo — Recupera gran cantidad de información de PHP.
phpversion — Obtiene la versión actual de PHP.
putenv — Establece el valor de una variable de entorno.
set_magic_quotes_runtime — Establece el valor de la configuración activa actual de magic_quotes_runtime.
set_time_limit — limita el tiempo máximo de ejecución
zend_logo_guid — Obtiene el guid zend

Anterior | Inicio | Siguiente
pfpro_version | Subir | extension_loaded


extension_loaded

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

extension_loaded -- averigua si una extensión ha sido cargada

Descripción

bool extension_loaded ( string name)

Devuelve TRUE si la extensión identificada por name (nombre) está cargada. Puede ver el nombre de varias extensiones utilizando phpinfo().

Véase también phpinfo().

Nota: Esta función fue añadida en 3.0.10.

Anterior | Inicio | Siguiente
opciones e información de PHP | Subir | get_cfg_var


getenv

(PHP 3, PHP 4 >= 4.0.0)

getenv -- Obtiene el valor de una variable de entorno

Descripción

string getenv ( string varname)

Devuelve el valor de la variable de entorno varname, o FALSE en caso de error.

$ip = getenv("REMOTE_ADDR"); // get the ip number of the user

Puede ver una lista de todas las variables de entorno utilizando phpinfo(). Puede encontrar el significado de la mayoría echando un vistazo en CGI specification (especificación CGI), especialmente en page on environmental variables (página de variables de entorno).

Anterior | Inicio | Siguiente
get_magic_quotes_runtime | Subir | getlastmod


get_cfg_var

(PHP 3, PHP 4 >= 4.0.0)

get_cfg_var -- Obtiene el valor de una opción de configuración de PHP.

Descripción

string get_cfg_var ( string varname)

Devuelve el valor actual de una variable de configuración de PHP especificada en varname, o FALSE si ocurre un error.

No devolverá información de la configuracion cuando el PHP fue compilado, o leído desde un fichero de configuración Apache (utilizando las directivas php3_configuration_option directives).

Para comprobar si el sistema está utilizando un fichero de configuración, intente recuperar el valor de cfg_file_path. Si está disponible, se está utilizando un fichero de configuración.

Anterior | Inicio | Siguiente
extension_loaded | Subir | get_current_user


get_current_user

(PHP 3, PHP 4 >= 4.0.0)

get_current_user -- Obtiene el nombre del propietario del script PHP actual.

Descripción

string get_current_user ( void)

Devuelve el nombre del propietario del script PHP actual.

Véase también getmyuid(),
getmypid(), getmyinode(),
y getlastmod().

Anterior | Inicio | Siguiente
get_cfg_var | Subir | get_magic_quotes_gpc


get_magic_quotes_gpc

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

get_magic_quotes_gpc -- Obtiene el valor de la configuración activa actual de las comillas mágicas gpc.

Descripción

long get_magic_quotes_gpc ( void)

Devuelve el valor de la configuración activa actual de magic_quotes_gpc. (0 desactivado, 1 activado)

Véase también get_magic_quotes_runtime(), set_magic_quotes_runtime().

Anterior | Inicio | Siguiente
get_current_user | Subir | get_magic_quotes_runtime


get_magic_quotes_runtime

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

get_magic_quotes_runtime -- Obtiene el valor de la configuración activa actual de magic_quotes_runtime.

Descripción

long get_magic_quotes_runtime ( void)

Devuelve el valor de la configuración activa actual de magic_quotes_runtime. (0 desactivado, 1 activado)

Véase también get_magic_quotes_gpc(), set_magic_quotes_runtime().

Anterior | Inicio | Siguiente
get_magic_quotes_gpc | Subir | getenv


getlastmod

(PHP 3, PHP 4 >= 4.0.0)

getlastmod -- Recupera la fecha/hora de la última modificación de la página.

Descripción

int getlastmod ( void)

Devuelve la fecha/hora de la última modificación de la página actual. El valor devuelto está en formato de fecha/hora Unix, adecuado para que sirva a date(). Devuelve FALSE en caso de error.

Ejemplo 1. ejemplo getlastmod()

// outputs e.g. 'Last modified: March 04 1998 20:43:59.'
echo "Last modified: ".date( "F d Y H:i:s.", getlastmod() );

Véase también date(),
getmyuid(),
get_current_user(),
getmyinode(), y
getmypid().

Anterior | Inicio | Siguiente
getenv | Subir | getmyinode


getmyinode

(PHP 3, PHP 4 >= 4.0.0)

getmyinode -- Recupera el inodo del script actual.

Descripción

int getmyinode ( void)

Devuelve el inodo del script actual, o FALSE en caso de error.

Véase también getmyuid(),
get_current_user(),
getmypid(), y
getlastmod().

Anterior | Inicio | Siguiente
getlastmod | Subir | getmypid


getmypid

(PHP 3, PHP 4 >= 4.0.0)

getmypid -- Obtiene el ID de proceso de PHP.

Descripción

int getmypid ( void)

Devuelve el ID del proceso PHP actual, o FALSE en caso de error.

Advierta que cuando se ejecuta como un módulo de servidor, diferentes llamadas del script no garantizan que tengan distintos pids.

Véase también getmyuid(),
get_current_user(),
getmyinode(), y
getlastmod().

Anterior | Inicio | Siguiente
getmyinode | Subir | getmyuid


getmyuid

(PHP 3, PHP 4 >= 4.0.0)

getmyuid -- Obtiene el UID del propietario del script PHP.

Descripción

int getmyuid ( void)

Devuelve el ID de usuario del script actual, o FALSE en caso de error.

Véase también getmypid(),
get_current_user(),
getmyinode(), y
getlastmod().

Anterior | Inicio | Siguiente
getmypid | Subir | getrusage


getrusage

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

getrusage -- Obtiene el consumo actual de recursos.

Descripción

array getrusage ( [int who])

Es un interface a getrusage(2). Devuelve un array asociativo que contiene los datos devueltos de la llamada del sistema. Si who (quien) es 1, getrusage debería llamarse con RUSAGE_CHILDREN. Todas las entradas son accesibles utilizando sus nombres de campo documentados.

Ejemplo 1. Ejemplo Getrusage

$dat = getrusage();
echo $dat["ru_nswap"];         # number of swaps
echo $dat["ru_majflt"];        # number of page faults
echo $dat["ru_utime.tv_sec"];  # user time used (seconds)
echo $dat["ru_utime.tv_usec"]; # user time used (microseconds)
Vea la página man de system para más detalles.

Anterior | Inicio | Siguiente
getmyuid | Subir | php_logo_guid


phpinfo

(PHP 3, PHP 4 >= 4.0.0)

phpinfo -- Recupera gran cantidad de información de PHP.

Descripción

int phpinfo ( void)

Obtiene gran cantidad de información sobre el estado actual de PHP. Esto incluye información sobre las opciones de compilación y extensiones de PHP, la versión PHP, información y entorno del servidor (si está compilado como un módulo), el entorno PHP, información sobre la versión del SO, rutas, opciones de configuración maestras y locales, cabeceras HTTP, y la Licencia Pública GNU.

Véase también phpversion().

Anterior | Inicio | Siguiente
php_logo_guid | Subir | phpversion


phpversion

(PHP 3, PHP 4 >= 4.0.0)

phpversion -- Obtiene la versión actual de PHP.

Descripción

string phpversion ( void)

Devuelve una cadena de carácteres que contiene la versión del parser PHP que está ejecutándose actualmente.

Ejemplo 1. ejemplo phpversion()

// prints e.g. 'Current PHP version: 3.0rel-dev'
echo "Current PHP version: ".phpversion();

Véase también phpinfo().

Anterior | Inicio | Siguiente
phpinfo | Subir | putenv


php_logo_guid

(PHP 4 >= 4.0.0)

php_logo_guid -- Obtiene el guid logo

Descripción

string php_logo_guid ( void)

Nota: Esta funcionalidad fue añadida en PHP4 Beta 4.

Anterior | Inicio | Siguiente
getrusage | Subir | phpinfo


putenv

(PHP 3, PHP 4 >= 4.0.0)

putenv -- Establece el valor de una variable de entorno.

Descripción

void putenv ( string setting)

Añade setting (valor) al entorno.

Ejemplo 1. Establecer una Variable de Entorno

putenv("UNIQID=$uniqid");

Anterior | Inicio | Siguiente
phpversion | Subir | set_magic_quotes_runtime


set_magic_quotes_runtime

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

set_magic_quotes_runtime -- Establece el valor de la configuración activa actual de magic_quotes_runtime.

Descripción

long set_magic_quotes_runtime ( int new_setting)

Establece el valor de la configuración activa actual de magic_quotes_runtime. (0 desactivado, 1 activado)

Véase también get_magic_quotes_gpc(), get_magic_quotes_runtime().

Anterior | Inicio | Siguiente
putenv | Subir | set_time_limit


set_time_limit

(PHP 3, PHP 4 >= 4.0.0)

set_time_limit -- limita el tiempo máximo de ejecución

Descripción

void set_time_limit ( int seconds)

Establece el número de segundos que se le permite a un script ejecutarse. Si éste es alcanzado, el script devuelve un error de tipo fatal. El límite por defecto es 30 segundos o, si existe, el valor max_execution_time definido en el fichero de configuración. Si seconds (segundos) se establece a cero, no se impone ningún límite.

Cuando se llama, set_time_limit() reinicia el contador del timeout a cero. En otras palabras, si el timeout es el de por defecto de 30 segundos, y después de 25 segundos de ejecución del script se realiza una llamada set_time_limit(20), el script se ejecutará durante un total de 45 segundos antes de alcanzar su límite.

Advierta que set_time_limit() no tiene efecto cuando PHP se ejecuta en modo seguro (safe mode). No hay otra opción que que desactivar el modo seguro o cambiar el límite de tiempo en el fichero de configuración.

Anterior | Inicio | Siguiente
set_magic_quotes_runtime | Subir | zend_logo_guid


zend_logo_guid

(PHP 4 >= 4.0.0)

zend_logo_guid -- Obtiene el guid zend

Descripción

string zend_logo_guid ( void)

Nota: Esta funcionalidad fue añadida en PHP4 Beta 4.

Anterior | Inicio | Siguiente
set_time_limit | Subir | Funciones POSIX


Funciones POSIX

Manual de PHP
Anterior Siguiente

LXXVII. Funciones POSIX

Este módulo contiene una interfaz a aquellas funciones definidas en el documento estandar IEEE 1003.1 (POSIX.1) que no son accesibles de otra manera. POSIX.1 por ejemplo definió las funciones open(),read(), write() y close(), las cuales han sido parte de PHP durante mucho tiempo.Algunas funciones específicas del sistema no habian estado disponibles antes, aunque con este módulo se intenta remediar esto ofreciendo un acceso fácil a esas funciones.

Tabla de contenidos
posix_ctermid — Recoge el nombre de ruta de la terminal de control
posix_getcwd — Nombre de ruta del directorio actual
posix_getegid — Devuelve el ID de grupo efectivo del proceso actual
posix_geteuid — Devuelve el ID de usuario efectivo del proceso actual
posix_getgid — Devuelve el ID de grupo real del proceso actual
posix_getgrgid — Devuelve información sobre un grupo a trave del id de grupo
posix_getgrnam — Devuelve información sobre un grupo a traves del nombre
posix_getgroups — Devuelve el conjunto de grupos del proceso actual
posix_getlogin — Devuelve el nombre de usuario
posix_getpgid — Recoge el id del grupo de procesos para el control de trabajo
posix_getpgrp — Devuelve el identificador de grupo del proceso actual
posix_getpid — Devuelve el identificador del proceso actual
posix_getppid — Devuelve el identificador del proceso padre
posix_getpwnam — Devuelve información sobre un usuario a traves del nombre de usuario
posix_getpwuid — Devuelve información sobre un usuario a traves de su id
posix_getrlimit — Devuelve información sobre los limites de recursos del sistema
posix_getsid — Consigue el sid actual del proceso
posix_getuid — Devuelve el ID de usuario real del proceso actual
posix_isatty — Determina si un descriptor de fichero esta en una terminal interactiva
posix_kill — Manda una señal a un proceso
posix_mkfifo — Crea un fichero especial fifo (los llamados pipe o tuberias)
posix_setgid — Asigna el GID efectivo del proceso actual
posix_setpgid — Asigna el id de grupo de procesos para el control de trabajos
posix_setsid — Convierte el proceso actual en lider de sesión
posix_setuid — Asigna el UID efectivo del proceso actual
posix_times — Recoge el tiempo de los procesos
posix_ttyname — Determina el nombre del dispositivo terminal
posix_uname — Consigue el nombre del sistema

Anterior | Inicio | Siguiente
zend_logo_guid | Subir | posix_ctermid


posix_kill

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_kill -- Manda una señal a un proceso

Descripción

bool posix_kill ( int pid, int sig)

Manda la señal sig al proceso con el identificador de proceso pid. Devuelve FALSE, si no puede enviar la señal.Si sí la envia devuelve TRUE .

Vea también la página de manual kill(2) de su sistema POSIX, la cual contiene información adicional sobre los identificadores de proceso negativos, el pid especial 0, el pid especial -1, y la señal numero 0.

Anterior | Inicio | Siguiente
posix_isatty | Subir | posix_mkfifo


posix_getpid

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getpid -- Devuelve el identificador del proceso actual

Descripción

int posix_getpid ( void )

Devuelve el identificador de proceso del proceso actual.

Anterior | Inicio | Siguiente
posix_getpgrp | Subir | posix_getppid


posix_getppid

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getppid -- Devuelve el identificador del proceso padre

Descripción

int posix_getppid ( void )

Devuelve el identificador de proceso del proceso padre del proceso actual.

Anterior | Inicio | Siguiente
posix_getpid | Subir | posix_getpwnam


posix_getuid

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getuid -- Devuelve el ID de usuario real del proceso actual

Descripción

int posix_getuid ( void )

Devuelve el valor numerico ID de usuario real del proceso actual. Vea también posix_getpwuid() para información sobre como convertir este ID en un nombre de usuario manejable.

Anterior | Inicio | Siguiente
posix_getsid | Subir | posix_isatty


posix_geteuid

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_geteuid -- Devuelve el ID de usuario efectivo del proceso actual

Descripción

int posix_geteuid ( void )

Devuelve el valor numérico ID de usuario efectivo del proceso actual. Vea también posix_getpwuid() para información sobre como convertir este número en un nombre de usuario manejable.

Anterior | Inicio | Siguiente
posix_getegid | Subir | posix_getgid


posix_getgid

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getgid -- Devuelve el ID de grupo real del proceso actual

Descripción

int posix_getgid ( void )

Devuelve el valor númerico ID de grupo real del proceso actual. Vea también posix_getgrgid() para información sobre como convertir esto en un nombre de grupo manejable.

Anterior | Inicio | Siguiente
posix_geteuid | Subir | posix_getgrgid


posix_getegid

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getegid -- Devuelve el ID de grupo efectivo del proceso actual

Descripción

int posix_getegid ( void )

Devuelve el valor numérico ID de grupo efectivo del proceso actual. Vea también posix_getgrgid() para información sobre como convertir este número en un nombre de grupo manejable.

Anterior | Inicio | Siguiente
posix_getcwd | Subir | posix_geteuid


posix_setuid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_setuid -- Asigna el UID efectivo del proceso actual

Descripción

bool posix_setuid ( int uid)

Asigna el ID de usuario real al proceso actual. Esta es una función privilegiada y necesitas los privilegios apropiados (normalmente root) en tu sistema para realizar esta función.

Devuelve TRUE si tiene exito, FALSE en caso contrario. Vea también posix_setgid().

Anterior | Inicio | Siguiente
posix_setsid | Subir | posix_times


posix_setgid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_setgid -- Asigna el GID efectivo del proceso actual

Descripción

bool posix_setgid ( int gid)

Asigna el ID de grupo real del proceso actual. Esta es una función privilegiada y necesitas los privilegion apropiados (normalmente root) en tu sistema para realizar esta función. El orden apropiado de llamada es posix_setgid() primero, posix_setuid() después.

Devuelve TRUE si tiene éxito, FALSE en caso contrario.

Anterior | Inicio | Siguiente
posix_mkfifo | Subir | posix_setpgid


posix_getgroups

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getgroups -- Devuelve el conjunto de grupos del proceso actual

Descripción

array posix_getgroups ( void )

Devuelve un vector de enteros que contiene los ids numéricos de grupo de el conjunto de grupos del proceso actual. Vea también posix_getgrgid() para información sobre como convertir esto en nombres de grupo manejables.

Anterior | Inicio | Siguiente
posix_getgrnam | Subir | posix_getlogin


posix_getlogin

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_getlogin -- Devuelve el nombre de usuario

Descripción

string posix_getlogin ( void )

Devuelve el nombre de usuario (login) que es dueño del proceso actual. Vea posix_getpwnam() para información sobre como conseguir mas datos de este usuario.

Anterior | Inicio | Siguiente
posix_getgroups | Subir | posix_getpgid


posix_getpgrp

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getpgrp -- Devuelve el identificador de grupo del proceso actual

Descripción

int posix_getpgrp ( void )

Devuelve el identificador de grupo de proceso del proceso actual. Vea POSIX.1 y la página de manual getpgrp(2) de su sistema POSIX para más información de grupos de procesos.

Anterior | Inicio | Siguiente
posix_getpgid | Subir | posix_getpid


posix_setsid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_setsid -- Convierte el proceso actual en lider de sesión

Descripción

int posix_setsid ( void )

Convierte el proceso actual en lider de sesión. Vea POSIX.1 y la página de manual setsid(2) en su sistema POSIX para más informacion en grupos de proceso y control de trabajos. Devuelve el id de sesión.

Anterior | Inicio | Siguiente
posix_setpgid | Subir | posix_setuid


posix_setpgid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_setpgid -- Asigna el id de grupo de procesos para el control de trabajos

Descripción

int posix_setpgid ( int pid, int pgid)

Inserta el proceso pid en el grupo de procesos pgid. Vea POSIX.1 y la página de manual setsid(2) de su sistema POSIX para más información sobre grupos de procesos y control de trabajo. Devuelve TRUE si tiene éxito y FALSE en caso contrario.

Anterior | Inicio | Siguiente
posix_setgid | Subir | posix_setsid


posix_getpgid

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getpgid -- Recoge el id del grupo de procesos para el control de trabajo

Descripción

int posix_getpgid ( int pid)

Devuelve el identificador de grupo de procesos del proceso pid.

Esta no es una función POSIX, pero es normal en sistemas BSD y System V. Si su sistema no soporta esta función a nivel de sistema, esta función PHP devolverá siempre FALSE.

Anterior | Inicio | Siguiente
posix_getlogin | Subir | posix_getpgrp


posix_getsid

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getsid -- Consigue el sid actual del proceso

Descripción

int posix_getsid ( int pid)

Devuelve el sid del proceso pid. Si pid es 0, se devolverá el sid del proceso actual.

Esta no es una función POSIX, pero es normal en sistemas System V. Si su sistema no soporta esta función a nivel de sistema, esta función PHP devolverá siempre FALSE.

Anterior | Inicio | Siguiente
posix_getrlimit | Subir | posix_getuid


posix_uname

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_uname -- Consigue el nombre del sistema

Descripción

array posix_uname ( void )

Devuelve un hash de cadenas con información sobre el sistema. Los índices del hash son

  • sysname - nombre del sistema operativo (e.g. Linux)

  • nodename - nombre del sistema (e.g. valiant)

  • release - release del sistema operativo (e.g. 2.2.10)

  • version - versión del sistema operativo (e.g. #4 Tue Jul 20 17:01:36 MEST 1999)

  • machine - arquitectura del sistema (e.g. i586)

Posix requiere que usted no debe hacer ninguna suposición sobre el formato de los valores, por ejemplo usted no puede confiar en los tres dígitos de la version o cualquier cosa devuelta por esta función.

Anterior | Inicio | Siguiente
posix_ttyname | Subir | Funciones de PostgreSQL


posix_times

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_times -- Recoge el tiempo de los procesos

Descripción

array posix_times ( void )

Devuelve un hash de cadenas con información sobre el uso de CPU del proceso actual. Los índices del hash son

  • ticks - el numero de ticks de reloj que han pasado desde el reinicio.

  • utime - tiempo de usuario usado por el proceso actual.

  • stime - tiempo de sistema usado por el proceso actual.

  • cutime - tiempo de usuario usado por el proceso actual e hijos.

  • cstime - tiempo de sistema usado por el proceso actual e hijos.

Anterior | Inicio | Siguiente
posix_setuid | Subir | posix_ttyname


posix_ctermid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_ctermid -- Recoge el nombre de ruta de la terminal de control

Descripción

string posix_ctermid ( void )

Necesita ser escrito.

Anterior | Inicio | Siguiente
Funciones POSIX | Subir | posix_getcwd


posix_ttyname

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_ttyname -- Determina el nombre del dispositivo terminal

Descripción

string posix_ttyname ( int fd)

Necesita ser escrito.

Anterior | Inicio | Siguiente
posix_times | Subir | posix_uname


posix_isatty

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_isatty -- Determina si un descriptor de fichero esta en una terminal interactiva

Descripción

bool posix_isatty ( int fd)

Necesita ser escrito.

Anterior | Inicio | Siguiente
posix_getuid | Subir | posix_kill


posix_getcwd

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_getcwd -- Nombre de ruta del directorio actual

Descripción

string posix_getcwd ( void )

Necesita ser escrito cuanto antes.

Anterior | Inicio | Siguiente
posix_ctermid | Subir | posix_getegid


posix_mkfifo

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_mkfifo -- Crea un fichero especial fifo (los llamados pipe o tuberias)

Descripción

bool posix_getcwd ( string pathname, int mode)

Necesita ser escrito lo más pronto posible.

Anterior | Inicio | Siguiente
posix_kill | Subir | posix_setgid


posix_getgrnam

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_getgrnam -- Devuelve información sobre un grupo a traves del nombre

Descripción

array posix_getgrnam ( string name)

Necesita ser escrito.

Anterior | Inicio | Siguiente
posix_getgrgid | Subir | posix_getgroups


posix_getgrgid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_getgrgid -- Devuelve información sobre un grupo a trave del id de grupo

Descripción

array posix_getgrgid ( int gid)

Necesita ser escrito.

Anterior | Inicio | Siguiente
posix_getgid | Subir | posix_getgrnam


posix_getpwnam

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_getpwnam -- Devuelve información sobre un usuario a traves del nombre de usuario

Description

array posix_getpwnam ( string username)

Devuelve un vector asociativo conteniendo información sobre un usuario referenciado por un nombre alfanumérico, pasado a la función en el parametro username.

Los elementos del vector devuelto son:

Tabla 1. El vector de información de usuario

Elemento | Descripción
name | El elemento name contiene el nombre de usuario del usuario. Este es un nombre, normalmente menor de 16 caracteres, que no es su nombre completo, pero identifica al usario. Este debe ser el mismo que el parámetro username usado en la llamada a la función y por lo tanto es redundante.
passwd | El elemento passwd contiene la contraseña del usuario en un formato encriptado. Normalmente, por ejemplo en un sistema que este utilizando contraseñas "shadow", devolverá un asterisco.
uid | El ID de usuario del usuario en formato numérico.
gid | El ID de grupo del usuario. Utiliza la función posix_getgrgid() para resolver el nombre del grupo y una lista de sus miembros.
gecos | GECOS es un término obsoleto que se refiere al campo apuntado de información en un sistema de procesamiento batch Honeywell. El campo y sus contenidos han sido formalizado por POSIX y contiene una lista separada por comas con el nombre completo del usuario, teléfono del trabajo, número de oficina y télefono de casa. En muchos sistemas solo está disponible el nombre completo del usuario.
dir | Este elemento contiene la ruta absoluta al directorio del usuario (directorio home).
shell | El elemento shell contiene la ruta absoluta al ejecutable del shell por defecto del usuario.

Anterior | Inicio | Siguiente
posix_getppid | Subir | posix_getpwuid


posix_getpwuid

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

posix_getpwuid -- Devuelve información sobre un usuario a traves de su id

Descripción

array posix_getpwuid ( int uid)

Devuelve un vector asociativo que contiene información sobre un usuario referenciado con un ID de usuario, pasado por el parámetro uid.

Los elementos del array son:

Tabla 1. El vector de información del usuario

Elemento | Descripción
name | El elemento name contiene el nombre de usuario del usuario. Este es un nombre, normalmente menor de 16 caracteres, que no es su verdadero nombre.
passwd | El elemento passwd contiene la contraseña del usuario en un formato encriptado. Normalmente, por ejemplo en un sistema con contraseñas "shadow", devolverá un asterisco.
uid | ID del usuario, debe ser el mismo que el parametro uid usado en la llamada a la función, y por lo tanto redundante.
gid | El ID del grupo del usuario. Utiliza la función posix_getgrgid() para resolver el nombre del grupo y una lista de sus miembros.
gecos | GECOS es un término obsoleto que se refiere al campo apuntado de de información en un sistema de procesamiento batch Honeywell. El campo y sus contenidos han sido formalizados por POSIX y contiene una lista separada por comas con el nombre completo del usuario, teléfono del trabajo, número de oficina y teléfono de casa. En muchos sistemas solo está disponible el nombre completo del usuario.
dir | Este elemento contiene la ruta absoluta al directorio del usuario (directorio home).
shell | El elemento shell contiene la ruta absoluta al ejecutable del shell por defecto del usuario.

Anterior | Inicio | Siguiente
posix_getpwnam | Subir | posix_getrlimit


posix_getrlimit

(PHP 3>= 3.0.10, PHP 4 >= 4.0.0)

posix_getrlimit -- Devuelve información sobre los limites de recursos del sistema

Descripción

array posix_getrlimit ( void )

Necesita ser escrita tan pronto como sea posible.

Anterior | Inicio | Siguiente
posix_getpwuid | Subir | posix_getsid


Funciones de PostgreSQL

Manual de PHP
Anterior Siguiente

LXXVIII. Funciones de PostgreSQL

Postgres, desarrollado originalmente en el UC Berkeley Computer Science Department, ha sido pionero en muchos de los conceptos relacionales/orientados a objeto que ahora están empezando a estar disponibles en algunas bases de datos comperciales. Tiene soporte de lenguaje SQL92/SQL3, integridad transaccional, y extensibilidad de tipos. PostgreSQL es un descendiente de dominio público, más concretamente open source, del código original de Berkeley.

PostgreSQL se encuentra disponible sin coste alguno. La versión actual la tienes a tu disposición en www.PostgreSQL.org.

Desde la versión 6.3 (02/03/1998) PostgreSQL usa sockets tipo Unix. Abajo se da una tabla con las diferentes posibilidades. El socket se encuentra en el ficheero /tmp/.s.PGSQL.5432. Esta opción se controla mediante el flag '-i' del postmaster y cuando se incluye significa "escuchar sockets TCP/IP además de los de dominio Unix" ya que si no se le dice nada solo escucha sockets tipo Unix.

Tabla 1. Postmaster y PHP

Postmaster | PHP | Estado
postmaster & | pg_connect("", "", "", "", "dbname"); | OK
postmaster -i & | pg_connect("", "", "", "", "dbname"); | OK
postmaster & | pg_connect("localhost", "", "", "", "dbname"); | Unable to connect to PostgreSQL server: connectDB() failed: Is the postmaster running and accepting TCP/IP (with -i) connection at 'localhost' on port '5432'? in /path/to/file.php3 on line 20. (Imposible conectar al servidor PostgreSQL, la llamada connectDB() ha fallado: ¿Está funcionando el postmaster aceptando conextiones TCP/IP (con -i) en 'localhost' en el puerto '5432'? en /path/to/file.php3 en linea 20.
postmaster -i & | pg_connect("localhost", "", "", "", "dbname"); | OK

Uno puede establecer una conexión con el siguiente comando:

Para usar el interface de objetos grandes (large object o lo), es necesario encapsularlo en un bloque de transacción. Un bloque de transacción empieza con un begin y si la transacción fue valida termina con commit y end. Si la transacción falla debe ser cerrada con abort y rollback.

Ejemplo 1. Usando Objetos Grandes (lo)

<?php
$database = pg_Connect ("", "", "", "", "jacarta");
pg_exec ($database, "begin");
    $oid = pg_locreate ($database);
    echo ("$oid\n");
    $handle = pg_loopen ($database, $oid, "w");
    echo ("$handle\n");
    pg_lowrite ($handle, "gaga");
    pg_loclose ($handle);
pg_exec ($database, "commit")
pg_exec ($database, "end")
?>

Tabla de contenidos
pg_Close — Cierra una conexión PostgreSQL
pg_cmdTuples — Devuelve el número de tuplas afectadas
pg_Connect — Abre una conexión
pg_DBname — Nombre de la base de datos
pg_ErrorMessage — mensaje de error
pg_Exec — Ejecuta una consulta (query)
pg_Fetch_Array — obtiene una fila en la forma de un array
pg_Fetch_Object — obtener una fila en forma de objeto
pg_Fetch_Row — obtiene la fila como un array enumerado
pg_FieldIsNull — Comprueba si un campo es NULO
pg_FieldName — Devuelve el nombre de un campo
pg_FieldNum — Devuelve el número de una columna
pg_FieldPrtLen — Devuelve la longitud impresa
pg_FieldSize — Devuelve el tamaño de almacenamiento interno de un campo en concreto
pg_FieldType — Devuelve el nombre del tipo de dato correspondiente al campo cuyo número pasamos como parámetro
pg_FreeResult — Libera memoria
pg_GetLastOid — Devuelve el identificador del último objeto insertado
pg_Host — Devuelve el nombre del host
pg_loclose — Cierra un objeto grande (large object)
pg_locreate — Crea un objeto grande
pg_loopen — Abre un objeto grande
pg_loread — lee un large object (objeto grande)
pg_loreadall — Lee un objeto grande entero
pg_lounlink — borra un large object
pg_lowrite — escribe en un objeto grande
pg_NumFields — Devuelve el número de campos
pg_NumRows — Devuelve el número de filas
pg_Options — Devuelve opciones
pg_pConnect — Crea una conexión persistente con una base de datos
pg_Port — Devuelve el número de puerto
pg_Result — Devuelve valores a partir de un identificador de resultado
pg_tty — Devuelve el nombre del tty

Anterior | Inicio | Siguiente
posix_uname | Subir | pg_Close


pg_Close

(PHP 3, PHP 4 >= 4.0.0)

pg_Close -- Cierra una conexión PostgreSQL

Descripción

bool pg_close ( int connection)

Devuelve FALSE si connection no es un indice de conexión valido y TRUE en cualquier otro caso. Cierra la conexión a la base de datos PostgreSQL asociada con el indice de conexión pasado como parámetro.

Anterior | Inicio | Siguiente
Funciones de PostgreSQL | Subir | pg_cmdTuples


pg_cmdTuples

(PHP 3, PHP 4 >= 4.0.0)

pg_cmdTuples -- Devuelve el número de tuplas afectadas

Descripción

int pg_cmdtuples ( int result_id)

pg_cmdTuples() devuelve el número de tuplas (instancias o filas) afectadas por consultas INSERT, UPDATE y DELETE. Si no hay ninguna tupla afectada la función devolverá 0.

Ejemplo 1. pg_cmdtuples

<?php
$result = pg_exec($conn, "INSERT INTO verlag VALUES ('Autor')");
$cmdtuples = pg_cmdtuples($result);
echo $cmdtuples . " <- cmdtuples affected.";
?>

Anterior | Inicio | Siguiente
pg_Close | Subir | pg_Connect


pg_Connect

(PHP 3, PHP 4 >= 4.0.0)

pg_Connect -- Abre una conexión

Descripción

int pg_connect ( string host, string port, string options, string tty, string dbname)

Devuelve un índice de conexión en caso de éxito, o falso si la conexión no se puede realizar. Esta función abre una conexión a una base de datos PostgreSQL. Cada uno de los argumentos debe ser una cadena entrecomillada, incluyendo el número de puerto. Los parámetros options y tty son opcionales y pueden ser omitidos. Esta función devuelve un índice de conexión que se necesitará para otras funciones PostgreSQL. Puedes tener multiples conexiones abiertas al mismo tiempo.

Una conexión también se puede establecer con el siguiente comando: $conn = pg_connect("dbname=marliese port=5432"); Otros parámetros aparte de dbname y port son host, tty, options, user y password.

Ver también pg_pConnect().

Anterior | Inicio | Siguiente
pg_cmdTuples | Subir | pg_DBname


pg_DBname

(PHP 3, PHP 4 >= 4.0.0)

pg_DBname -- Nombre de la base de datos

Descripción

string pg_dbname ( int connection)

Devuelve el nombre de la base de datos a la cual es el índice de conexión con PostgreSQL está conectado, o FALSE si connection no es un índice de conexión válido.

Anterior | Inicio | Siguiente
pg_Connect | Subir | pg_ErrorMessage


pg_ErrorMessage

(PHP 3, PHP 4 >= 4.0.0)

pg_ErrorMessage -- mensaje de error

Descripción

string pg_errormessage ( int connection)

Devuelve una cadena que contiene el mensaje de error, o FALSE en caso de fallo. Probablemente no se podrán obtener los detalles del error a través de la función pg_errormessage() si ocurre un error en la última acción de base de datos para la cual existe una conexión valida, esta función retornará una cadena conteniendo el mensaje de error generado por el servidor "backend".

Anterior | Inicio | Siguiente
pg_DBname | Subir | pg_Exec


pg_Exec

(PHP 3, PHP 4 >= 4.0.0)

pg_Exec -- Ejecuta una consulta (query)

Descripción

int pg_exec ( int connection, string query)

Devuelve un índice de resultado si se pudo ejecutar la consulta, o FALSE en caso de fallo o si connection no es un índice de conexión válido. Se pueden obtener detalles acerca del error mediante la función pg_ErrorMessage() siempre que conection sea válido. Envia una sentencia SQL a la base de datos PostgreSQL especificada por el índice de conexión. connection debe ser un índice válido devuelto por pg_Connect(). El valor de devuelto por esta función es un índice para ser usado al acceder a los resultados de la consulta desde otras funciones PostgreSQL.

Nota: PHP/FI devuelvía 1 si no es una consulta que tenga que devolver datos (inserts o updates, por ejemplo) y un valor mayor que 1 incluso en el caso de selects que no devolvieron nada. En PHP no se puede contar con ninguna de esas suposiciones.

Anterior | Inicio | Siguiente
pg_ErrorMessage | Subir | pg_Fetch_Array


pg_Fetch_Array

(PHP 3>= 3.0.1, PHP 4 >= 4.0.0)

pg_Fetch_Array -- obtiene una fila en la forma de un array

Descripción

array pg_fetch_array ( int result, int row [, int result_type])

Devuelve: Un array que se corresponde con la fila obtenida, o FALSE si no hay más filas.

pg_fetch_array() es una versión extendida de pg_fetch_row(). Además de almacenar los datos en los índices numericos del array resultante, también almacena los datos usando índices asociativos, empleando para ello el nombre del campo como la llave o índice.

El tercer parámetro opcional result_type en pg_fetch_array() es una constante y puede tomar cualquiera de los siguientes valores: PGSQL_ASSOC, PGSQL_NUM, y PGSQL_BOTH.

Nota: Result_type se añadio en PHP 4.0.

Una cosa importante a tener en cuenta es que usar pg_fetch_array() NO es significativamente más lento que usar pg_fetch_row(), y sin embargo el valor añadido que aporta sí lo es.

Para más detalles, ver pg_fetch_row()

Ejemplo 1. PostgreSQL fetch array

<?php
$conn = pg_pconnect("","","","","publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

$result = pg_Exec ($conn, "SELECT * FROM authors");
if (!$result) {
    echo "An error occured.\n";
    exit;
}

$arr = pg_fetch_array ($result, 0);
echo $arr[0] . " <- array\n";

$arr = pg_fetch_array ($result, 1);
echo $arr["author"] . " <- array\n";
?>

Anterior | Inicio | Siguiente
pg_Exec | Subir | pg_Fetch_Object


pg_Fetch_Object

(PHP 3>= 3.0.1, PHP 4 >= 4.0.0)

pg_Fetch_Object -- obtener una fila en forma de objeto

Descripción

object pg_fetch_object ( int result, int row [, int result_type])

Devuelve: Un objeto cuyas propiedades se corresponden con los campos de la fila obtenida, o FALSE si no hay más filas.

pg_fetch_object() es parecida a pg_fetch_array(), con una diferencia - se devuelve un objeto, en vez de un array. Indirectamente, eso significa que solo puedes acceder a los datos por medio de su nombre de campo, y no a través de sus posiciones (los números son nombres de propiedad invalidos).

El tercer parámetro opcional result_type en pg_fetch_object() es una constante y puede tomar cualquiera de los siguientes valores: PGSQL_ASSOC, PGSQL_NUM, y PGSQL_BOTH.

Nota: Result_type se añadio en PHP 4.0.

Referente a la velocidad, la función es identica a pg_fetch_array(), y practicamente tan rápida como pg_fetch_row() (la diferencia es insignificante).

Ver también: pg_fetch_array() y pg_fetch_row().

Ejemplo 1. Postgres fetch object

<?php
$database = "verlag";
$db_conn = pg_connect ("localhost", "5432", "", "", $database);
if (!$db_conn): ?>
    <H1>Failed connecting to postgres database <? echo $database ?></H1> <?
    exit;
endif;

$qu = pg_exec ($db_conn, "SELECT * FROM verlag ORDER BY autor");
$row = 0; // postgres needs a row counter other dbs might not

while ($data = pg_fetch_object ($qu, $row)):
    echo $data->autor." (";
    echo $data->jahr ."): ";
    echo $data->titel."<BR>";
    $row++;
endwhile; ?>

<PRE><?php
$fields[] = Array ("autor", "Author");
$fields[] = Array ("jahr",  "  Year");
$fields[] = Array ("titel", " Title");

$row= 0; // postgres needs a row counter other dbs might not
while ($data = pg_fetch_object ($qu, $row)):
    echo "----------\n";
    reset ($fields);
    while (list (,$item) = each ($fields)):
        echo $item[1].": ".$data->$item[0]."\n";
    endwhile;
    $row++;
endwhile;
echo "----------\n"; ?>
</PRE> <?php
pg_freeResult ($qu);
pg_close ($db_conn);
?>

Anterior | Inicio | Siguiente
pg_Fetch_Array | Subir | pg_Fetch_Row


pg_Fetch_Row

(PHP 3>= 3.0.1, PHP 4 >= 4.0.0)

pg_Fetch_Row -- obtiene la fila como un array enumerado

Descripción

array pg_fetch_row ( int result, int row)

Devuelve: Un array que se corresponde con la fila obtenida, o FALSE en el caso de que no haya más filas.

pg_fetch_row() obtiene una fila de datos a partir del resultado asociado con el identificador de resultado especificado. La fila se devuelve en forma de array. Cada columna del resultado se almacena en una posición del array, empezando a partir de la posición 0.

Las siguientes llamadas a pg_fetch_row() devolverán la fila siguiente en el conjunto resultado, o falso en el caso de que no haya más filas que devolver.

Ver también: pg_fetch_array(), pg_fetch_object(), pg_result().

Ejemplo 1. Postgres fetch row

<?php
$conn = pg_pconnect("","","","","publisher");
if (!$conn) {
    echo "An error occured.\n";
    exit;
}

$result = pg_Exec ($conn, "SELECT * FROM authors");
if (!$result) {
    echo "An error occured.\n";
    exit;
}

$row = pg_fetch_row ($result, 0);
echo $row[0] . " <- row\n";

$row = pg_fetch_row ($result, 1);
echo $row[0] . " <- row\n";

$row = pg_fetch_row ($result, 2);
echo $row[1] . " <- row\n";
?>

Anterior | Inicio | Siguiente
pg_Fetch_Object | Subir | pg_FieldIsNull


pg_FieldIsNull

(PHP 3, PHP 4 >= 4.0.0)

pg_FieldIsNull -- Comprueba si un campo es NULO

Descripción

int pg_fieldisnull ( int result_id, int row, mixed field)

Comprueba si un campo vale NULL o no. Devuleve 0 si el campo en la fila dada no es NULO y uno en el caso de que lo sea. El campo se puede especificar mediante un número o un nombre de campo. La numeración de filas empieza en 0.

Anterior | Inicio | Siguiente
pg_Fetch_Row | Subir | pg_FieldName


pg_FieldName

(PHP 3, PHP 4 >= 4.0.0)

pg_FieldName -- Devuelve el nombre de un campo

Descripción

string pg_fieldname ( int result_id, int field_number)

pg_FieldName() devolverá el nombre del campo que ocupa el número de columna dado en el identificador de resultado de PostgreSQL. La numeración de los campos empieza con 0.

Anterior | Inicio | Siguiente
pg_FieldIsNull | Subir | pg_FieldNum


pg_FieldNum

(PHP 3, PHP 4 >= 4.0.0)

pg_FieldNum -- Devuelve el número de una columna

Descripción

int pg_fieldnum ( int result_id, string field_name)

pg_FieldNum() devolverá el número de la columna que corresponde al campo cuyo nombre le damos, dentro del identificador de resultado de PostgreSQL. La numeración de campos comienza en 0. Esta función devolverá -1 en caso de error.

Anterior | Inicio | Siguiente
pg_FieldName | Subir | pg_FieldPrtLen


pg_FieldPrtLen

(PHP 3, PHP 4 >= 4.0.0)

pg_FieldPrtLen -- Devuelve la longitud impresa

Descripción

int pg_fieldprtlen ( int result_id, int row_number, string field_name)

pg_FieldPrtLen() devolverá la longitud impresa real (número de caracteres) de un valor específico dentro del identificador de resultado PostgreSQL. La numeración de filas comienza en 0. Esta función devolverá -1 en caso de error.

Anterior | Inicio | Siguiente
pg_FieldNum | Subir | pg_FieldSize


pg_FieldSize

(PHP 3, PHP 4 >= 4.0.0)

pg_FieldSize -- Devuelve el tamaño de almacenamiento interno de un campo en concreto

Descripción

int pg_fieldsize ( int result_id, int field_number)

pg_FieldSize() devolverá el tamaño de almacenamiento interno (en bytes) de uno de los campos del resultado PostgreSQL que le hemos pasado. La numeración de campos empieza en 0. Un tamaño de campo de -1 indica que se trata de un campo de longitud variable. La función devolverá FALSE en caso de error.

Anterior | Inicio | Siguiente
pg_FieldPrtLen | Subir | pg_FieldType


pg_FieldType

(PHP 3, PHP 4 >= 4.0.0)

pg_FieldType -- Devuelve el nombre del tipo de dato correspondiente al campo cuyo número pasamos como parámetro

Descripción

int pg_fieldtype ( int result_id, int field_number)

pg_FieldType() devolverá una cadena con el nombre del tipo de datos de un campo dado dentro del identificador de resultado PostgreSQL result_id. La numeración de campos empieza en 0.

Anterior | Inicio | Siguiente
pg_FieldSize | Subir | pg_FreeResult


pg_FreeResult

(PHP 3, PHP 4 >= 4.0.0)

pg_FreeResult -- Libera memoria

Descripción

int pg_freeresult ( int result_id)

pg_FreeResult() solo necesita ser llamada si estamos preocupados por usar demasiada memoria mientras el script se está ejecutando. La memoria correspondiente a todos los resultados de consulta se libera automáticamente cuando termina el script. Pero, si estás seguro de que no vas a necesitar más los datos del resultado en el script, puedes llamar a pg_FreeResult() con el identificador del resultado como parámetro y la memoria asociada al resultado será liberada.

Anterior | Inicio | Siguiente
pg_FieldType | Subir | pg_GetLastOid


pg_GetLastOid

(PHP 3, PHP 4 >= 4.0.0)

pg_GetLastOid -- Devuelve el identificador del último objeto insertado

Descripción

int pg_getlastoid ( int result_id)

pg_GetLastOid() se puede usar para conseguir el Oid (identificador de objeto) asignado a una tupla insertada si el identificador de resultado proviene de una llamada a pg_Exec() que fuese un INSERT SQL. Esta función devuelve un entero positivo si hay un Oid válido y -1 en caso de que ocurriese un error durante el último comando enviado a través de la función pg_Exec() o si esta no fuese un INSERT.

Anterior | Inicio | Siguiente
pg_FreeResult | Subir | pg_Host


pg_Host

(PHP 3, PHP 4 >= 4.0.0)

pg_Host -- Devuelve el nombre del host

Descripción

string pg_host ( int connection_id)

pg_Host() devuelve el nombre del host al que identificador conexión PostgreSQL pasado está conectado.

Anterior | Inicio | Siguiente
pg_GetLastOid | Subir | pg_loclose


pg_loclose

(PHP 3, PHP 4 >= 4.0.0)

pg_loclose -- Cierra un objeto grande (large object)

Descripción

void pg_loclose ( int fd)

pg_loclose() cierra un Large Object. fd es el descriptor de fichero del fichero grande obtenido a través de pg_loopen().

Anterior | Inicio | Siguiente
pg_Host | Subir | pg_locreate


pg_locreate

(PHP 3, PHP 4 >= 4.0.0)

pg_locreate -- Crea un objeto grande

Descripción

int pg_locreate ( int conn)

pg_locreate() Crea un Large Object y devuelve su oid. conn determina una conexión de base de datos válida. Los modos de acceso INV_READ, INV_WRITE, y INV_ARCHIVE de PostgreSQL no están soportados, el objeto se crea siempre con acceso tanto de lectura como de escritura. modo El INV_ARCHIVE ha desaparecido incluso de PostgreSQL mismo (a partir de la versión 6.3).

Anterior | Inicio | Siguiente
pg_loclose | Subir | pg_loopen


pg_loopen

(PHP 3, PHP 4 >= 4.0.0)

pg_loopen -- Abre un objeto grande

Descripción

int pg_loopen ( int conn, int objoid, string mode)

pg_loopen() abre un Large Object (objeto grande) y devuelve un descriptor de fichero para el objeto grande. El descriptor de fichero encapsula información acerca de la conexión. No se debe cerrar la conexión antes de cerrar el descriptor de fichero al objeto grande. objoid especifica un oid válido para un objeto grande y mode puede ser "r", "w", o "rw".

Anterior | Inicio | Siguiente
pg_locreate | Subir | pg_loread


pg_loread

(PHP 3, PHP 4 >= 4.0.0)

pg_loread -- lee un large object (objeto grande)

Descripción

string pg_loread ( int fd, int len)

pg_loread() lee como mucho len bytes a partir de un objeto grande y lo devuelve como una cadena. fd especifica un descriptor de fichero de objeto grande válido y len especifica máximo número de bytes que se deben leer del objeto grande.

Anterior | Inicio | Siguiente
pg_loopen | Subir | pg_loreadall


pg_loreadall

(PHP 3, PHP 4 >= 4.0.0)

pg_loreadall -- Lee un objeto grande entero

Descripción

void pg_loreadall ( int fd)

pg_loreadall() lee un objeto grande y lo pasa tal cual al browser después de enviar todas las cabeceras pendientes. Principalmente dirijido a mandar datos binarios como imagenes o sonido.

Anterior | Inicio | Siguiente
pg_loread | Subir | pg_lounlink


pg_lounlink

(PHP 3, PHP 4 >= 4.0.0)

pg_lounlink -- borra un large object

Descripción

void pg_lounlink ( int conn, int lobjid)

pg_lounlink() borra el objeto grande con identificador lobjid.

Anterior | Inicio | Siguiente
pg_loreadall | Subir | pg_lowrite


pg_lowrite

(PHP 3, PHP 4 >= 4.0.0)

pg_lowrite -- escribe en un objeto grande

Descripción

int pg_lowrite ( int fd, string buf)

pg_lowrite() escribe todo lo que puede en un objeto grande a partir de la variable buf y devuelve el número de bytes realmente escritos, o falso si ocurre algún error. fd es un descriptor de fichero para el objeto grande obtenido a través de pg_loopen().

Anterior | Inicio | Siguiente
pg_lounlink | Subir | pg_NumFields


pg_NumFields

(PHP 3, PHP 4 >= 4.0.0)

pg_NumFields -- Devuelve el número de campos

Descripción

int pg_numfields ( int result_id)

pg_NumFields() devuelve el número de campos (columnas) en un resultado PostgreSQL. El parámetro es un identificador de resultado válido devuelto por pg_Exec(). La función devuelve -1 en caso de error.

Anterior | Inicio | Siguiente
pg_lowrite | Subir | pg_NumRows


pg_NumRows

(PHP 3, PHP 4 >= 4.0.0)

pg_NumRows -- Devuelve el número de filas

Descripción

int pg_numrows ( int result_id)

pg_NumRows() devuelve el número de filas en un resultado PostgreSQL. El parámetro es un identificador de resultado PostgreSQL válido devuelto por pg_Exec(). En caso de error se devuelve -1.

Anterior | Inicio | Siguiente
pg_NumFields | Subir | pg_Options


pg_Options

(PHP 3, PHP 4 >= 4.0.0)

pg_Options -- Devuelve opciones

Descripción

string pg_options ( int connection_id)

pg_Options() devuelve una cadena que contiene las opciones especificadas en el identificador de conexión con PostgreSQL dado.

Anterior | Inicio | Siguiente
pg_NumRows | Subir | pg_pConnect


pg_pConnect

(PHP 3, PHP 4 >= 4.0.0)

pg_pConnect -- Crea una conexión persistente con una base de datos

Descripción

int pg_pconnect ( string host, string port, string options, string tty, string dbname)

Devuelve un índice de conexión en caso de éxito, o FALSE si no es posible realizar la conexión. Abre una conexión persistente hacia una base de datos de PostgreSQL. Cada uno de los parámetros puede ser una cadena entrecomillada (quoted), incluyendo el número de puerto. Los parámetros options y tty son opcionales y pueden omitirse. Esta función devuelve un índice de conexión que luego será empleado al llamar a otras funciones PostgreSQL. Puedes tener multiples conexiones persistentes abiertas al mismo tiempo. Ver también pg_Connect().

Una conexión también se puede establecer con el comando siguiente: $conn = pg_pconnect("dbname=marliese port=5432"); Otros parámetros además de dbname y port son host, tty, options, user y password.

Anterior | Inicio | Siguiente
pg_Options | Subir | pg_Port


pg_Port

(PHP 3, PHP 4 >= 4.0.0)

pg_Port -- Devuelve el número de puerto

Descripción

int pg_port ( int connection_id)

pg_Port() devuelve el número del puerto al que el identificador de conexión con PostgreSQL está conectado.

Anterior | Inicio | Siguiente
pg_pConnect | Subir | pg_Result


pg_Result

(PHP 3, PHP 4 >= 4.0.0)

pg_Result -- Devuelve valores a partir de un identificador de resultado

Descripción

mixed pg_result ( int result_id, int row_number, mixed fieldname)

pg_Result() devuelve valores a partir de un identificador de resultado generado en la función pg_Exec(). Los parámetros row_number y fieldname especifican que celda en la tabla queremos obtener. La numeración de filas comienza en 0. En vez de usar el nombre del campo también puedes usar el índice del campo como un número sin entrecomillar. Los índices de campo comienzan también en 0.

PostgreSQL tiene muchos tipos y solo los básicos están soportados directamente aquí. Todas las formas de enteros, boleanos y oids se devuelven como valores enteros. Todas las formas de los tipos float y real se devuelven como valores double. Todos los demás tipos, incluyendo los arrays se devuelven como cadenas formateadas de la misma manera en que PostgreSQL usa por defecto. De la misma forma en que lo verías en el programa psql.

Anterior | Inicio | Siguiente
pg_Port | Subir | pg_tty


pg_tty

(PHP 3, PHP 4 >= 4.0.0)

pg_tty -- Devuelve el nombre del tty

Descripción

string pg_tty ( int connection_id)

pg_tty() devuelve el nombre del tty hacia el que se dirije la salida de depuración del lado del servidor en el identificador de conexión de PostgreSQL dado.

Anterior | Inicio | Siguiente
pg_Result | Subir | Process Control Functions


Process Control Functions

Manual de PHP
Anterior Siguiente

LXXIX. Process Control Functions

Process Control support in PHP implements the Unix style of process creation, program execution, signal handling and process termination. Process Control should not be enabled within a webserver environment and unexpected results may happen if any Process Control functions are used within a webserver environment.

This documentation is intended to explain the general usage of each of the Process Control functions. For detailed information about Unix process control you are encouraged to consult your systems documentation including fork(2), waitpid(2) and signal(2) or a comprehensive reference such as Advanced Programming in the UNIX Environment by W. Richard Stevens (Addison-Wesley).

Process Control support in PHP is not enabled by default. You will need to use the --enable-pcntl configuration option when compiling PHP to enable Process Control support.

Nota: Currently, this module will not function on non-Unix platforms (Windows).

The following list of signals are supported by the Process Control functions. Please see your systems signal(7) man page for details of the default behavior of these signals.

Tabla 1. Supported Signals

SIGFPE | SIGCONT | SIGKILL
SIGSTOP | SIGUSR1 | SIGTSTP
SIGHUP | SIGUSR2 | SIGTTIN
SIGINT | SIGSEGV | SIGTTOU
SIGQUIT | SIGPIPE | SIGURG
SIGILL | SIGALRM | SIGXCPU
SIGTRAP | SIGTERM | SIGXFSZ
SIGABRT | SIGSTKFLT | SIGVTALRM
SIGIOT | SIGCHLD | SIGPROF
SIGBUS | SIGCLD | SIGWINCH
SIGPOLL | SIGIO | SIGPWR
SIGSYS |  |

Process Control Example

This example forks off a daemon process with a signal handler.

Ejemplo 1. Process Control Example

<?php

$pid = pcntl_fork();
if ($pid == -1) {
     die("could not fork");
} else if ($pid) {
     exit(); // we are the parent
} else {
     // we are the child
}

// detatch from the controlling terminal
if (!posix_setsid()) {
    die("could not detach from terminal");
}

// setup signal handlers
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP, "sig_handler");

// loop forever performing tasks
while(1) {

    // do something interesting here

}

function sig_handler($signo) {

     switch($signo) {
         case SIGTERM:
             // handle shutdown tasks
             exit;
             break;
         case SIGHUP:
             // handle restart tasks
             break;
         default:
             // handle all other signals
     }

}

?>
Tabla de contenidos
pcntl_fork — Forks the currently running process
pcntl_signal — Installs a signal handler
pcntl_waitpid — Waits on or returns the status of a forked child
pcntl_wexitstatus — Returns the return code of a terminated child
pcntl_wifexited — Returns TRUE if status code represents a successful exit
pcntl_wifsignaled — Returns TRUE if status code represents a termination due to a signal
pcntl_wifstopped — Returns TRUE if child process is currently stopped
pcntl_wstopsig — Returns the signal which caused the child to stop
pcntl_wtermsig — Returns the signal which caused the child to terminate
pcntl_exec — Executes specified program in current process space

Anterior | Inicio | Siguiente
pg_tty | Subir | pcntl_fork


pcntl_fork

(PHP 4 >= 4.1.0)

pcntl_fork -- Forks the currently running process

Description

int pcntl_fork ( void)

The pcntl_fork() function creates a child process that differs from the parent process only in it's PID and PPID. Please see your system's fork(2) man page for specific details as to how fork works on your system.

On success, the PID of the child process is returned in the parent's thread of execution, and a 0 is returned in the child's thread of execution. On failure, a -1 will be returned in the parent's context, no child process will be created, and a PHP error is raised.

Ejemplo 1. pcntl_fork() Example

<?php

$pid = pcntl_fork();
if ($pid == -1) {
     die("could not fork");
} else if ($pid) {
     // we are the parent
} else {
     // we are the child
}

?>

See also pcntl_waitpid() and pcntl_signal().

Anterior | Inicio | Siguiente
Process Control Functions | Subir | pcntl_signal


pcntl_signal

(PHP 4 >= 4.1.0)

pcntl_signal -- Installs a signal handler

Description

bool pcntl_signal ( int signo, mixed handle)

The pcntl_signal() function installs a new signal handler for the signal indicated by signo. The signal handler is set to handler which may be the name of a user created function, or either of the two global constants SIG_IGN or SIG_DFL.

pcntl_signal() returns TRUE on success or FALSE on failure.

Ejemplo 1. pcntl_signal() Example

<?php

// signal handler function
function sig_handler($signo) {

     switch($signo) {
         case SIGTERM:
             // handle shutdown tasks
             exit;
             break;
         case SIGHUP:
             // handle restart tasks
             break;
         case SIGUSR1:
             print "Caught SIGUSR1...\n";
             break;
         default:
             // handle all other signals
     }

}

print "Installing signal handler...\n";

// setup signal handlers
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP, "sig_handler");
pcntl_signal(SIGUSR1, "sig_handler");

print "Generating signal SIGTERM to self...\n";

// send SIGUSR1 to current process id
posix_kill(posix_getpid(), SIGUSR1);

print "Done\n"

?>

See also pcntl_fork() and pcntl_waitpid().

Anterior | Inicio | Siguiente
pcntl_fork | Subir | pcntl_waitpid


pcntl_waitpid

(PHP 4 >= 4.1.0)

pcntl_waitpid -- Waits on or returns the status of a forked child

Description

int pcntl_waitpid ( int pid, int status, int options)

The pcntl_waitpid() function suspends execution of the current process until a child as specified by the pid argument has exited, or until a signal is delivered whose action is to terminate the current process or to call a signal handling function. If a child as requested by pid has already exited by the time of the call (a so-called "zombie" process), the function returns immediately. Any system resources used by the child are freed. Please see your system's waitpid(2) man page for specific details as to how waitpid works on your system.

pcntl_waitpid() returns the process ID of the child which exited, -1 on error or zero if WNOHANG was used and no child was available

The value of pid can be one of the following:

Tabla 1. possible values for pid

< -1 | wait for any child process whose process group ID is equal to the absolute value of pid.
-1 | wait for any child process; this is the same behaviour that the wait function exhibits.
0 | wait for any child process whose process group ID is equal to that of the calling process.
> 0 | wait for the child whose process ID is equal to the value of pid.

pcntl_waitpid() will store status information
in the status parameter which can be
evaluated using the following functions:
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() and
pcntl_wstopsig().

The value of options is the value of zero or more of the following two global constants OR'ed together:

Tabla 2. possible values for options

WNOHANG | return immediately if no child has exited.
WUNTRACED | return for children which are stopped, and whose status has not been reported.

See also pcntl_fork(),
pcntl_signal(),
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() and
pcntl_wstopsig().

Anterior | Inicio | Siguiente
pcntl_signal | Subir | pcntl_wexitstatus


pcntl_wexitstatus

(PHP 4 >= 4.1.0)

pcntl_wexitstatus -- Returns the return code of a terminated child

Description

int pcntl_wexitstatus ( int status)

Returns the return code of a terminated child. This function is only useful if pcntl_wifexited() returned TRUE.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid() and pcntl_wifexited().

Anterior | Inicio | Siguiente
pcntl_waitpid | Subir | pcntl_wifexited


pcntl_wifexited

(PHP 4 >= 4.1.0)

pcntl_wifexited -- Returns TRUE if status code represents a successful exit

Description

int pcntl_wifexited ( int status)

Returns TRUE if the child status code represents a successful exit.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid() and pcntl_wexitstatus().

Anterior | Inicio | Siguiente
pcntl_wexitstatus | Subir | pcntl_wifsignaled


pcntl_wifsignaled

(PHP 4 >= 4.1.0)

pcntl_wifsignaled -- Returns TRUE if status code represents a termination due to a signal

Description

int pcntl_wifsignaled ( int status)

Returns TRUE if the child process exited because of a signal which was not caught.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid() and pcntl_signal().

Anterior | Inicio | Siguiente
pcntl_wifexited | Subir | pcntl_wifstopped


pcntl_wifstopped

(PHP 4 >= 4.1.0)

pcntl_wifstopped -- Returns TRUE if child process is currently stopped

Description

int pcntl_wifstopped ( int status)

Returns TRUE if the child process which caused the return is currently stopped; this is only possible if the call to pcntl_waitpid() was done using the option WUNTRACED.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid().

Anterior | Inicio | Siguiente
pcntl_wifsignaled | Subir | pcntl_wstopsig


pcntl_wstopsig

(PHP 4 >= 4.1.0)

pcntl_wstopsig -- Returns the signal which caused the child to stop

Description

int pcntl_wstopsig ( int status)

Returns the number of the signal which caused the child to stop. This function is only useful if pcntl_wifstopped() returned TRUE.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid() and pcntl_wifstopped().

Anterior | Inicio | Siguiente
pcntl_wifstopped | Subir | pcntl_wtermsig


pcntl_wtermsig

(PHP 4 >= 4.1.0)

pcntl_wtermsig -- Returns the signal which caused the child to terminate

Description

int pcntl_wtermsig ( int status)

Returns the number of the signal that caused the child process to terminate. This function is only useful if pcntl_wifsignaled() returned TRUE.

The parameter status is the status parameter supplied to a successfull call to pcntl_waitpid().

See also pcntl_waitpid(),
pcntl_signal() and
pcntl_wifsignaled().

Anterior | Inicio | Siguiente
pcntl_wstopsig | Subir | pcntl_exec


pcntl_exec

(PHP 4 >= 4.2.0)

pcntl_exec -- Executes specified program in current process space

Description

bool pcntl_exec ( string path [, array args [, array envs]])

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
pcntl_wtermsig | Subir | Funciones de ejecución de programas


Funciones de ejecución de programas

Manual de PHP
Anterior Siguiente

LXXX. Funciones de ejecución de programas

Tabla de contenidos
escapeshellcmd — enmascara los metacaracteres del intérprete de ordenes
exec — Ejecuta un programa externo
passthru — Ejecuta un programa externo y muestra su salida literal
system — Ejecuta un programa externo y muestra su salida

Anterior | Inicio | Siguiente
pcntl_exec | Subir | escapeshellcmd


escapeshellcmd

(PHP 3, PHP 4 >= 4.0.0)

escapeshellcmd -- enmascara los metacaracteres del intérprete de ordenes

Descripción

string escapeshellcmd ( string command)

EscapeShellCmd() enmascara cualquier carácter en una cadena de caracteres que pueda usarse para introducir fraudulentamente una orden al intérprete de órdenes para que éste ejecute instrucciones arbitrarias. Esta función se debería usar para asegurarse que cualquier dato que venga del usuario se enmascare antes de que éste se le pase a las funciones exec() o system(), o al operador ` (apóstrofe invertido) . Un uso habitual podría ser:

system(EscapeShellCmd($cmd))

Véase también exec(), popen(), system(), y el operador ` (apóstrofe invertido).

Anterior | Inicio | Siguiente
Funciones de ejecución de programas | Subir | exec


exec

(PHP 3, PHP 4 >= 4.0.0)

exec -- Ejecuta un programa externo

Descripción

string exec ( string command [, string array [, int return_var]])

exec() ejecuta la orden indicada en command, sin embargo no produce ninguna salida. Simplemente devuelve la última línea de la salida resultado de la orden. Si necesita ejecutar una orden y obtener directamente todos los datos devueltos por la orden sin ninguna interferencia, use la función PassThru().

Si el parámetro array existe, entonces el array especificado se rellenará con cada una de las líneas de la salida producida por la orden. Notar que si el array ya contiene algunos elementos, exec() los añadirá al final del array. Si no quiere que la función añada dichos elementos, haga un unset() sobre el array antes de pasárselo a exec().

Si el parámetro return_var existe a la vez que el parámetro array, entonces el valor de retorno de la orden ejecutada se guardará en dicha variable.

Destacar que si usted va a permitir que se pasen datos provenientes de usuarios a esta función, entonces debería usar EscapeShellCmd() para asegurarse de que los usuarios no pueden engañar al sistema para ejecutar instrucciones arbitrarias.

Véase también system(),
PassThru(), popen(),
EscapeShellCmd(), y el operador ` (apóstrofe
       invertido).

Anterior | Inicio | Siguiente
escapeshellcmd | Subir | passthru


passthru

(PHP 3, PHP 4 >= 4.0.0)

passthru -- Ejecuta un programa externo y muestra su salida literal

Descripción

string passthru ( string command [, int return_var])

La función passthru() es similar a la función exec() en que ejecuta una orden (command). Si existe el parámetro return_var, el valor de estado devuelto por la orden Unix se guardará ahí. Esta función debería usarse en lugar de exec() o system() cuando la salida de la orden Unix sean datos binarios que deban ser pasados directamente al navegador. Un uso típico de ello es ejecutar algo como las utilidades pbmplus las cuales pueden dar como resultado directamente el flujo de datos de una imagen. Poniendo el content-type a image/gif y llamando al programa pbmplus para mostrar un gif, usted puede crear archivos de órdenes PHP que generen directamente imágenes.

Véase también exec(),
system(), popen(),
EscapeShellCmd(), y el operador ` (apóstrofe
       invertido).

Anterior | Inicio | Siguiente
exec | Subir | system


system

(PHP 3, PHP 4 >= 4.0.0)

system -- Ejecuta un programa externo y muestra su salida

Description

string system ( string command [, int return_var])

system() se parece a la versión C de la función de mismo nombre en que ejecuta la orden indicada en command y muestra el resultado. Si se indica una variable como segundo parámetro, el código de estado devuelto por la orden ejecutada se guardará en esta variable.

Destacar que si usted va a permitir que se pasen datos provenientes de usuarios a esta función, entonces debería usar EscapeShellCmd() para asegurarse de que los usuarios no pueden engañar al sistema para ejecutar instrucciones arbitrarias.

La llamada a system() también intenta vaciar automáticamente el buffer de salida del servidor web después de cada línea de salida si PHP está funcionando como un módulo del servidor.

Devuelve la última línea de la orden en caso de éxito, y falso en caso de fallo.

Si necesita ejecutar una orden y obtener de vuelta todo los datos del mismo sin interferencias, use la función PassThru().

Véase también exec(),
PassThru(), popen(),
EscapeShellCmd(), y el operador ` (apóstrofe
       invertido).

Anterior | Inicio | Siguiente
passthru | Subir | Printer functions


Printer functions

Manual de PHP
Anterior Siguiente

LXXXI. Printer functions

These functions are only available under Windows 9.x, ME, NT4 and 2000. They have been added in PHP 4 (4.0.4).

Tabla de contenidos
printer_open — Open connection to a printer
printer_abort — Deletes the printer's spool file
printer_close — Close an open printer connection
printer_write — Write data to the printer
printer_list — Return an array of printers attached to the server
printer_set_option — Configure the printer connection
printer_get_option — Retrieve printer configuration data
printer_create_dc — Create a new device context
printer_delete_dc — Delete a device context
printer_start_doc — Start a new document
printer_end_doc — Close document
printer_start_page — Start a new page
printer_end_page — Close active page
printer_create_pen — Create a new pen
printer_delete_pen — Delete a pen
printer_select_pen — Select a pen
printer_create_brush — Create a new brush
printer_delete_brush — Delete a brush
printer_select_brush — Select a brush
printer_create_font — Create a new font
printer_delete_font — Delete a font
printer_select_font — Select a font
printer_logical_fontheight — Get logical font height
printer_draw_roundrect — Draw a rectangle with rounded corners
printer_draw_rectangle — Draw a rectangle
printer_draw_elipse — Draw an ellipse
printer_draw_text — Draw text
printer_draw_line — Draw a line
printer_draw_chord — Draw a chord
printer_draw_pie — Draw a pie
printer_draw_bmp — Draw a bmp

Anterior | Inicio | Siguiente
system | Subir | printer_open


printer_open

(unknown)

printer_open -- Open connection to a printer

Description

mixed printer_open ( [string devicename])

This function tries to open a connection to the printer devicename, and returns a handle on success or FALSE on failure.

If no parameter was given it tries to open a connection to the default printer (if not specified in php.ini as printer.default_printer, php tries to detect it).

printer_open() also starts a device context.

Ejemplo 1. printer_open() example

$handle = printer_open("HP Deskjet 930c");
$handle = printer_open();

Anterior | Inicio | Siguiente
Printer functions | Subir | printer_abort


printer_abort

(unknown)

printer_abort -- Deletes the printer's spool file

Description

void printer_abort ( resource handle)

This function deletes the printers spool file.

handle must be a valid handle to a printer.

Ejemplo 1. printer_abort() example

$handle = printer_open();
printer_abort($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_open | Subir | printer_close


printer_close

(unknown)

printer_close -- Close an open printer connection

Description

void printer_close ( resource handle)

This function closes the printer connection. printer_close() also closes the active device context.

handle must be a valid handle to a printer.

Ejemplo 1. printer_close() example

$handle = printer_open();
printer_close($handle);

Anterior | Inicio | Siguiente
printer_abort | Subir | printer_write


printer_write

(unknown)

printer_write -- Write data to the printer

Description

bool printer_write ( resource handle, string content)

Writes content directly to the printer, and returns TRUE on success or FALSE if it failed.

handle must be a valid handle to a printer.

Ejemplo 1. printer_write() example

$handle = printer_open();
printer_write($handle, "Text to print");
printer_close($handle);

Anterior | Inicio | Siguiente
printer_close | Subir | printer_list


printer_list

(unknown)

printer_list -- Return an array of printers attached to the server

Description

array printer_list ( int enumtype [, string name [, int level]])

The function enumerates available printers and their capabilities. level sets the level of information request. Can be 1,2,4 or 5. enumtype must be one of the following predefined constants:

  • PRINTER_ENUM_LOCAL: enumerates the locally installed printers.

  • PRINTER_ENUM_NAME: enumerates the printer of name, can be a server, domain or print provider.

  • PRINTER_ENUM_SHARED: this parameter can't be used alone, it has to be OR'ed with other parameters, i.e. PRINTER_ENUM_LOCAL to detect the locally shared printers.

  • PRINTER_ENUM_DEFAULT: (Win9.x only) enumerates the default printer.

  • PRINTER_ENUM_CONNECTIONS: (WinNT/2000 only) enumerates the printers to which the user has made connections.

  • PRINTER_ENUM_NETWORK: (WinNT/2000 only) enumerates network printers in the computer's domain. Only valid if level is 1.

  • PRINTER_ENUM_REMOTE: (WinNT/2000 only) enumerates network printers and print servers in the computer's domain. Only valid if level is 1.

Ejemplo 1. printer_list() example

/* detect locally shared printer */
var_dump( printer_list(PRINTER_ENUM_LOCAL | PRINTER_ENUM_SHARED) );

Anterior | Inicio | Siguiente
printer_write | Subir | printer_set_option


printer_set_option

(unknown)

printer_set_option -- Configure the printer connection

Description

bool printer_set_option ( resource handle, int option, mixed value)

The function sets the following options for the current connection: handle must be a valid handle to a printer. For option can be one of the following constants:

  • PRINTER_COPIES: sets how many copies should be printed, value must be an integer.

  • PRINTER_MODE: specifies the type of data (text, raw or emf), value must be a string.

  • PRINTER_TITLE: specifies the name of the document, value must be a string.

  • PRINTER_ORIENTATION: specifies the orientation of the paper, value can be either PRINTER_ORIENTATION_PORTRAIT or PRINTER_ORIENTATION_LANDSCAPE

  • PRINTER_RESOLUTION_Y: specifies the y-resolution in DPI, value must be an integer.

  • PRINTER_RESOLUTION_X: specifies the x-resolution in DPI, value must be an integer.

  • PRINTER_PAPER_FORMAT: specifies the a predefined paper format, set value to PRINTER_FORMAT_CUSTOM if you want to specify a custom format with PRINTER_PAPER_WIDTH and PRINTER_PAPER_LENGTH. value can be one of the following constants.

    • PRINTER_FORMAT_CUSTOM: let's you specify a custom paper format.

    • PRINTER_FORMAT_LETTER: specifies standard letter format (8 1/2- by 11-inches).

    • PRINTER_FORMAT_LETTER: specifies standard legal format (8 1/2- by 14-inches).

    • PRINTER_FORMAT_A3: specifies standard A3 format (297- by 420-millimeters).

    • PRINTER_FORMAT_A4: specifies standard A4 format (210- by 297-millimeters).

    • PRINTER_FORMAT_A5: specifies standard A5 format (148- by 210-millimeters).

    • PRINTER_FORMAT_B4: specifies standard B4 format (250- by 354-millimeters).

    • PRINTER_FORMAT_B5: specifies standard B5 format (182- by 257-millimeter).

    • PRINTER_FORMAT_FOLIO: specifies standard FOLIO format (8 1/2- by 13-inch).

  • PRINTER_PAPER_LENGTH: if PRINTER_PAPER_FORMAT is set to PRINTER_FORMAT_CUSTOM, PRINTER_PAPER_LENGTH specifies a custom paper length in mm, value must be an integer.

  • PRINTER_PAPER_WIDTH: if PRINTER_PAPER_FORMAT is set to PRINTER_FORMAT_CUSTOM, PRINTER_PAPER_WIDTH specifies a custom paper width in mm, value must be an integer.

  • PRINTER_SCALE: specifies the factor by which the printed output is to be scaled. the page size is scaled from the physical page size by a factor of scale/100. for example if you set the scale to 50, the output would be half of it's original size. value must be an integer.

  • PRINTER_BACKGROUND_COLOR: specifies the background color for the actual device context, value must be a string containing the rgb information in hex format i.e. "005533".

  • PRINTER_TEXT_COLOR: specifies the text color for the actual device context, value must be a string containing the rgb information in hex format i.e. "005533".

  • PRINTER_TEXT_ALIGN: specifies the text alignment for the actual device context, value can be combined through OR'ing the following constants:

    • PRINTER_TA_BASELINE: text will be aligned at the base line.

    • PRINTER_TA_BOTTOM: text will be aligned at the bottom.

    • PRINTER_TA_TOP: text will be aligned at the top.

    • PRINTER_TA_CENTER: text will be aligned at the center.

    • PRINTER_TA_LEFT: text will be aligned at the left.

    • PRINTER_TA_RIGHT: text will be aligned at the right.

Ejemplo 1. printer_set_option() example

$handle = printer_open();
printer_set_option($handle, PRINTER_SCALE, 75);
printer_set_option($handle, PRINTER_TEXT_ALIGN, PRINTER_TA_LEFT);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_list | Subir | printer_get_option


printer_get_option

(unknown)

printer_get_option -- Retrieve printer configuration data

Description

mixed printer_get_option ( resource handle, string option)

The function retrieves the configuration setting of option. handle must be a valid handle to a printer. Take a look at printer_set_option() for the settings that can be retrieved, additionally the following settings can be retrieved:

  • PRINTER_DEVICENAME returns the devicename of the printer.

  • PRINTER_DRIVERVERSION returns the printer driver version.

Ejemplo 1. printer_get_option() example

$handle = printer_open();
print printer_get_option($handle, PRINTER_DRIVERVERSION);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_set_option | Subir | printer_create_dc


printer_create_dc

(unknown)

printer_create_dc -- Create a new device context

Description

void printer_create_dc ( resource handle)

The function creates a new device context. A device context is used to customize the graphic objects of the document. handle must be a valid handle to a printer.

Ejemplo 1. printer_create_dc() example

$handle = printer_open();
printer_start_doc($handle);
printer_start_page($handle);

printer_create_dc($handle);
/* do some stuff with the dc */
printer_set_option($handle, PRINTER_TEXT_COLOR, "333333");
printer_draw_text($handle, 1, 1, "text");
printer_delete_dc($handle);

/* create another dc */
printer_create_dc($handle);
printer_set_option($handle, PRINTER_TEXT_COLOR, "000000");
printer_draw_text($handle, 1, 1, "text");
/* do some stuff with the dc */

printer_delete_dc($handle);

printer_endpage($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_get_option | Subir | printer_delete_dc


printer_delete_dc

(unknown)

printer_delete_dc -- Delete a device context

Description

bool printer_delete_dc ( resource handle)

The function deletes the device context and returns TRUE on success, or FALSE if an error occurred. For an example see printer_create_dc(). handle must be a valid handle to a printer.

Anterior | Inicio | Siguiente
printer_create_dc | Subir | printer_start_doc


printer_start_doc

(unknown)

printer_start_doc -- Start a new document

Description

bool printer_start_doc ( resource handle [, string document])

The function creates a new document in the printer spooler. A document can contain multiple pages, it's used to schedule the print job in the spooler. handle must be a valid handle to a printer. The optional parameter document can be used to set an alternative document name.

Ejemplo 1. printer_start_doc() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_delete_dc | Subir | printer_end_doc


printer_end_doc

(unknown)

printer_end_doc -- Close document

Description

bool printer_end_doc ( resource handle)

Closes a new document in the printer spooler. The document is now ready for printing. For an example see printer_start_doc(). handle must be a valid handle to a printer.

Anterior | Inicio | Siguiente
printer_start_doc | Subir | printer_start_page


printer_start_page

(unknown)

printer_start_page -- Start a new page

Description

bool printer_start_page ( resource handle)

The function creates a new page in the active document. For an example see printer_start_doc(). handle must be a valid handle to a printer.

Anterior | Inicio | Siguiente
printer_end_doc | Subir | printer_end_page


printer_end_page

(unknown)

printer_end_page -- Close active page

Description

bool printer_end_page ( resource handle)

The function closes the active page in the active document. For an example see printer_start_doc(). handle must be a valid handle to a printer.

Anterior | Inicio | Siguiente
printer_start_page | Subir | printer_create_pen


printer_create_pen

(unknown)

printer_create_pen -- Create a new pen

Description

mixed printer_create_pen ( int style, int width, string color)

The function creates a new pen and returns a handle to it. A pen is used to draw lines and curves. For an example see printer_select_pen(). color must be a color in RGB hex format, i.e. "000000" for black, width specifies the width of the pen whereas style must be one of the following constants:

  • PRINTER_PEN_SOLID: creates a solid pen.

  • PRINTER_PEN_DASH: creates a dashed pen.

  • PRINTER_PEN_DOT: creates a dotted pen.

  • PRINTER_PEN_DASHDOT: creates a pen with dashes and dots.

  • PRINTER_PEN_DASHDOTDOT: creates a pen with dashes and double dots.

  • PRINTER_PEN_INVISIBLE: creates an invisible pen.

Anterior | Inicio | Siguiente
printer_end_page | Subir | printer_delete_pen


printer_delete_pen

(unknown)

printer_delete_pen -- Delete a pen

Description

bool printer_delete_pen ( resource handle)

The function deletes the selected pen. For an example see printer_select_pen(). It returns TRUE on success, or FALSE otherwise. handle must be a valid handle to a pen.

Anterior | Inicio | Siguiente
printer_create_pen | Subir | printer_select_pen


printer_select_pen

(unknown)

printer_select_pen -- Select a pen

Description

void printer_select_pen ( resource printer_handle, resource pen_handle)

The function selects a pen as the active drawing object of the actual device context. A pen is used to draw lines and curves. I.e. if you draw a single line the pen is used. If you draw an rectangle the pen is used to draw the borders, while the brush is used to fill the shape. If you haven't selected a pen before drawing shapes, the shape won't be outlined. printer_handle must be a valid handle to a printer. pen_handle must be a valid handle to a pen.

Ejemplo 1. printer_select_pen() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 30, "2222FF");
printer_select_pen($handle, $pen);

printer_draw_line($handle, 1, 60, 500, 60);

printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_delete_pen | Subir | printer_create_brush


printer_create_brush

(unknown)

printer_create_brush -- Create a new brush

Description

mixed printer_create_brush ( int style, string color)

The function creates a new brush and returns a handle to it. A brush is used to fill shapes. For an example see printer_select_brush(). color must be a color in RGB hex format, i.e. "000000" for black, style must be one of the following constants:

  • PRINTER_BRUSH_SOLID: creates a brush with a solid color.

  • PRINTER_BRUSH_DIAGONAL: creates a brush with a 45-degree upward left-to-right hatch ( / ).

  • PRINTER_BRUSH_CROSS: creates a brush with a cross hatch ( + ).

  • PRINTER_BRUSH_DIAGCROSS: creates a brush with a 45 cross hatch ( x ).

  • PRINTER_BRUSH_FDIAGONAL: creates a brush with a 45-degree downward left-to-right hatch ( \ ).

  • PRINTER_BRUSH_HORIZONTAL: creates a brush with a horizontal hatch ( - ).

  • PRINTER_BRUSH_VERTICAL: creates a brush with a vertical hatch ( | ).

  • PRINTER_BRUSH_CUSTOM: creates a custom brush from an BMP file. The second parameter is used to specify the BMP instead of the RGB color code.

Anterior | Inicio | Siguiente
printer_select_pen | Subir | printer_delete_brush


printer_delete_brush

(unknown)

printer_delete_brush -- Delete a brush

Description

bool printer_delete_brush ( resource handle)

The function deletes the selected brush. For an example see printer_select_brush(). It returns TRUE on success, or FALSE otherwise. handle must be a valid handle to a brush.

Anterior | Inicio | Siguiente
printer_create_brush | Subir | printer_select_brush


printer_select_brush

(unknown)

printer_select_brush -- Select a brush

Description

void printer_select_brush ( resource printer_handle, resource brush_handle)

The function selects a brush as the active drawing object of the actual device context. A brush is used to fill shapes. If you draw an rectangle the brush is used to draw the shapes, while the pen is used to draw the border. If you haven't selected a brush before drawing shapes, the shape won't be filled. printer_handle must be a valid handle to a printer. brush_handle must be a valid handle to a brush.

Ejemplo 1. printer_select_brush() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);
$brush = printer_create_brush(PRINTER_BRUSH_CUSTOM, "c:\\brush.bmp");
printer_select_brush($handle, $brush);

printer_draw_rectangle($handle, 1,1,500,500);

printer_delete_brush($brush);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "000000");
printer_select_brush($handle, $brush);
printer_draw_rectangle($handle, 1,501,500,1001);
printer_delete_brush($brush);

printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_delete_brush | Subir | printer_create_font


printer_create_font

(unknown)

printer_create_font -- Create a new font

Description

mixed printer_create_font ( string face, int height, int width, int font_weight, bool italic, bool underline, bool strikeout, int orientaton)

The function creates a new font and returns a handle to it. A font is used to draw text. For an example see printer_select_font(). face must be a string specifying the font face. height specifies the font height, and width the font width. The font_weight specifies the font weight (400 is normal), and can be one of the following predefined constants.

  • PRINTER_FW_THIN: sets the font weight to thin (100).

  • PRINTER_FW_ULTRALIGHT: sets the font weight to ultra light (200).

  • PRINTER_FW_LIGHT: sets the font weight to light (300).

  • PRINTER_FW_NORMAL: sets the font weight to normal (400).

  • PRINTER_FW_MEDIUM: sets the font weight to medium (500).

  • PRINTER_FW_BOLD: sets the font weight to bold (700).

  • PRINTER_FW_ULTRABOLD: sets the font weight to ultra bold (800).

  • PRINTER_FW_HEAVY: sets the font weight to heavy (900).

italic can be TRUE or FALSE, and sets whether the font should be italic.

underline can be TRUE or FALSE, and sets whether the font should be underlined.

strikeout can be TRUE or FALSE, and sets whether the font should be striked out.

orientation specifies a rotation. For an example see printer_select_font().

Anterior | Inicio | Siguiente
printer_select_brush | Subir | printer_delete_font


printer_delete_font

(unknown)

printer_delete_font -- Delete a font

Description

bool printer_delete_font ( resource handle)

The function deletes the selected font. For an example see printer_select_font(). It returns TRUE on success, or FALSE otherwise. handle must be a valid handle to a font.

Anterior | Inicio | Siguiente
printer_create_font | Subir | printer_select_font


printer_select_font

(unknown)

printer_select_font -- Select a font

Description

void printer_select_font ( resource printer_handle, resource font_handle)

The function selects a font to draw text. printer_handle must be a valid handle to a printer. font_handle must be a valid handle to a font.

Ejemplo 1. printer_select_font() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$font = printer_create_font("Arial", 148, 76, PRINTER_FW_MEDIUM, false, false, false, -50);
printer_select_font($handle, $font);
printer_draw_text($handle, "PHP is simply cool", 40, 40);
printer_delete_font($font);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_delete_font | Subir | printer_logical_fontheight


printer_logical_fontheight

(unknown)

printer_logical_fontheight -- Get logical font height

Description

int printer_logical_fontheight ( resource handle, int height)

The function calculates the logical font height of height. handle must be a valid handle to a printer.

Ejemplo 1. printer_logical_fontheight() example

$handle = printer_open();
print printer_logical_fontheight($handle, 72);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_select_font | Subir | printer_draw_roundrect


printer_draw_roundrect

(unknown)

printer_draw_roundrect -- Draw a rectangle with rounded corners

Description

void printer_draw_roundrect ( resource handle, int ul_x, int ul_y, int lr_x, int lr_y, int width, int height)

The function simply draws a rectangle with rounded corners.

handle must be a valid handle to a printer.

ul_x is the upper left x coordinate of the rectangle.

ul_y is the upper left y coordinate of the rectangle.

lr_x is the lower right x coordinate of the rectangle.

lr_y is the lower right y coordinate of the rectangle.

width is the width of the ellipse.

height is the height of the ellipse.

Ejemplo 1. printer_draw_roundrect() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_roundrect($handle, 1, 1, 500, 500, 200, 200);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_logical_fontheight | Subir | printer_draw_rectangle


printer_draw_rectangle

(unknown)

printer_draw_rectangle -- Draw a rectangle

Description

void printer_draw_rectangle ( resource handle, int ul_x, int ul_y, int lr_x, int lr_y)

The function simply draws a rectangle.

handle must be a valid handle to a printer.

ul_x is the upper left x coordinate of the rectangle.

ul_y is the upper left y coordinate of the rectangle.

lr_x is the lower right x coordinate of the rectangle.

lr_y is the lower right y coordinate of the rectangle.

Ejemplo 1. printer_draw_rectangle() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_rectangle($handle, 1, 1, 500, 500);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_draw_roundrect | Subir | printer_draw_elipse


printer_draw_elipse

(unknown)

printer_draw_elipse -- Draw an ellipse

Description

void printer_draw_elipse ( resource handle, int ul_x, int ul_y, int lr_x, int lr_y)

The function simply draws an ellipse. handle must be a valid handle to a printer.

ul_x is the upper left x coordinate of the ellipse.

ul_y is the upper left y coordinate of the ellipse.

lr_x is the lower right x coordinate of the ellipse.

lr_y is the lower right y coordinate of the ellipse.

Ejemplo 1. printer_draw_elipse() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_elipse($handle, 1, 1, 500, 500);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_draw_rectangle | Subir | printer_draw_text


printer_draw_text

(unknown)

printer_draw_text -- Draw text

Description

void printer_draw_text ( resource printer_handle, string text, int x, int y)

The function simply draws text at position x, y using the selected font. printer_handle must be a valid handle to a printer.

Ejemplo 1. printer_draw_text() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$font = printer_create_font("Arial",72,48,400,false,false,false,0);
printer_select_font($handle, $font);
printer_draw_text($handle, "test", 10, 10);
printer_delete_font($font);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_draw_elipse | Subir | printer_draw_line


printer_draw_line

(unknown)

printer_draw_line -- Draw a line

Description

void printer_draw_line ( resource printer_handle, int from_x, int from_y, int to_x, int to_y)

The function simply draws a line from position from_x, from_y to position to_x, to_y using the selected pen. printer_handle must be a valid handle to a printer.

Ejemplo 1. printer_draw_line() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 30, "000000");
printer_select_pen($handle, $pen);

printer_draw_line($handle, 1, 10, 1000, 10);
printer_draw_line($handle, 1, 60, 500, 60);

printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_draw_text | Subir | printer_draw_chord


printer_draw_chord

(unknown)

printer_draw_chord -- Draw a chord

Description

void printer_draw_chord ( resource handle, int rec_x, int rec_y, int rec_x1, int rec_y1, int rad_x, int rad_y, int rad_x1, int rad_y1)

The function simply draws an chord. handle must be a valid handle to a printer.

rec_x is the upper left x coordinate of the bounding rectangle.

rec_y is the upper left y coordinate of the bounding rectangle.

rec_x1 is the lower right x coordinate of the bounding rectangle.

rec_y1 is the lower right y coordinate of the bounding rectangle.

rad_x is x coordinate of the radial defining the beginning of the chord.

rad_y is y coordinate of the radial defining the beginning of the chord.

rad_x1 is x coordinate of the radial defining the end of the chord.

rad_y1 is y coordinate of the radial defining the end of the chord.

Ejemplo 1. printer_draw_chord() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_chord($handle, 1, 1, 500, 500, 1, 1, 500, 1);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_draw_line | Subir | printer_draw_pie


printer_draw_pie

(unknown)

printer_draw_pie -- Draw a pie

Description

void printer_draw_pie ( resource handle, int rec_x, int rec_y, int rec_x1, int rec_y1, int rad1_x, int rad1_y, int rad2_x, int rad2_y)

The function simply draws an pie. handle must be a valid handle to a printer.

rec_x is the upper left x coordinate of the bounding rectangle.

rec_y is the upper left y coordinate of the bounding rectangle.

rec_x1 is the lower right x coordinate of the bounding rectangle.

rec_y1 is the lower right y coordinate of the bounding rectangle.

rad1_x is x coordinate of the first radial's ending.

rad1_y is y coordinate of the first radial's ending.

rad2_x is x coordinate of the second radial's ending.

rad2_y is y coordinate of the second radial's ending.

Ejemplo 1. printer_draw_chord() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_pie($handle, 1, 1, 500, 500, 1, 1, 500, 1);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_draw_chord | Subir | printer_draw_bmp


printer_draw_bmp

(unknown)

printer_draw_bmp -- Draw a bmp

Description

void printer_draw_bmp ( resource handle, string filename, int x, int y)

The function simply draws an bmp the bitmap filename at position x, y. handle must be a valid handle to a printer.

The function returns TRUE on success, or otherwise FALSE.

Ejemplo 1. printer_draw_bmp() example

$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

printer_draw_bmp($handle, "c:\\image.bmp", 1, 1);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);

Anterior | Inicio | Siguiente
printer_draw_pie | Subir | Pspell Functions


Pspell Functions

Manual de PHP
Anterior Siguiente

LXXXII. Pspell Functions

The pspell() functions allow you to check the spelling of a word and offer suggestions.

You need the aspell and pspell libraries, available from http://aspell.sourceforge.net/ and http://pspell.sourceforge.net/ respectively, and add the --with-pspell[=dir] option when compiling php.

Tabla de contenidos
pspell_check — Check a word
pspell_new — Load a new dictionary
pspell_suggest — Suggest spellings of a word

Anterior | Inicio | Siguiente
printer_draw_bmp | Subir | pspell_check


pspell_new

(PHP 4 >= 4.0.2)

pspell_new -- Load a new dictionary

Description

int pspell_new ( string language [, string spelling [, string jargon [, string encoding [, int mode]]]])

pspell_new() opens up a new dictionary and returns the dictionary link identifier for use in other pspell functions.

The language parameter is the language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

The spelling parameter is the requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

The jargon parameter contains extra information to distinguish two different words lists that have the same language and spelling parameters.

The encoding parameter is the encoding that words are expected to be in. Valid values are 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32'. This parameter is largely untested, so be careful when using.

The mode parameter is the mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)

  • PSPELL_NORMAL - Normal mode (more suggestions)

  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)

  • PSPELL_RUN_TOGETHER - Consider run-together words as legal compounds. That is, "thecat" will be a legal compound, athough there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.

Mode is a bitmask constructed from different constants listed above. However, PSPELL_FAST, PSPELL_NORMAL and PSPELL_BAD_SPELLERS are mutually exclusive, so you should select only one of them.

For more information and examples, check out inline manual pspell website:http://pspell.sourceforge.net/.

Ejemplo 1. pspell_new()

$pspell_link = pspell_new ("en", "", "", "",
                           (PSPELL_FAST|PSPELL_RUN_TOGETHER));

Anterior | Inicio | Siguiente
pspell_check | Subir | pspell_suggest


pspell_check

(PHP 4 >= 4.0.2)

pspell_check -- Check a word

Description

boolean pspell_check ( int dictionary_link, string word)

pspell_check() checks the spelling of a word and returns TRUE if the spelling is correct, FALSE if not.

Ejemplo 1. pspell_check()

$pspell_link = pspell_new ("en");

if (pspell_check ($pspell_link, "testt")) {
    echo "This is a valid spelling";
} else {
    echo "Sorry, wrong spelling";
}

Anterior | Inicio | Siguiente
Pspell Functions | Subir | pspell_new


pspell_suggest

(PHP 4 >= 4.0.2)

pspell_suggest -- Suggest spellings of a word

Description

array pspell_suggest ( int dictionary_link, string word)

pspell_suggest() returns an array of possible spellings for the given word.

Ejemplo 1. pspell_suggest()

$pspell_link = pspell_new ("en");

if (!pspell_check ($pspell_link, "testt")) {
    $suggestions = pspell_suggest ($pspell_link, "testt");

    for ($i=0; $i < count ($suggestions); $i++) {
        echo "Possible spelling: " . $suggestions[$i] . "<br>";
    }
}

Anterior | Inicio | Siguiente
pspell_new | Subir | GNU Readline


GNU Readline

Manual de PHP
Anterior Siguiente

LXXXIII. GNU Readline

Las funciones readline() implementan una interfaz con la librería GNU Readline. Un ejemplo de la manera de funcionar podría ser la forma en que el Bash permite usar las flechas de dirección para insertar carácteres o desplazarse a través del historial de comandos. Debido a la naturaleza interactiva de esta libreria, tendrá un uso muy reducido en la escritura de aplicaciones Web, aunque puede ser útil para scripts que han de ser ejecutados desde la consola.

La página principal del proyecto GNU Readline es http://cnswww.cns.cwru.edu/~chet/readline/rltop.html. Está actualizada por Chet Ramey, quien además es el autor de Bash.

Tabla de contenidos
readline — Lee una línea
readline_add_history — Añade una línea al historial
readline_clear_history — Borra el historial
readline_completion_function — Registra una función de completitud
readline_info — Establece/Obtiene diversas variables internas de readline
readline_list_history — Lista el historial
readline_read_history — Lee un historial
readline_write_history — Escribe el historial

Anterior | Inicio | Siguiente
pspell_suggest | Subir | readline


readline

(PHP 4 >= 4.0.0)

readline -- Lee una línea

Descripción

string readline ( [string prompt])

Esta función devuelve una única cadena del usuario. Puede especificar una cadena que se mostrará al usuario. La línea devuelta tiene el indicador final de nueva línea eliminado. Necesita añadir esta línea al historial usando la función readline_add_history().

Ejemplo 1. readline()

//obtiene 3 comandos del usuario
for ($i=0; $i < 3; $i++) {
        $line = readline ("Comando: ");
        readline_add_history ($line);
}

//Vuelca el historial
print_r (readline_list_history());

//Vuelca las variables
print_r (readline_info());

Anterior | Inicio | Siguiente
GNU Readline | Subir | readline_add_history


readline_add_history

(PHP 4 >= 4.0.0)

readline_add_history -- Añade una línea al historial

Descripción

void readline_add_history ( string line)

Esta función añade una línea al historial de líneas de comandos.

Anterior | Inicio | Siguiente
readline | Subir | readline_clear_history


readline_clear_history

(PHP 4 >= 4.0.0)

readline_clear_history -- Borra el historial

Descripción

boolean readline_clear_history ( void )

Esta función borra por completo el historial de la línea de comandos.

Anterior | Inicio | Siguiente
readline_add_history | Subir | readline_completion_function


readline_completion_function

(PHP 4 >= 4.0.0)

readline_completion_function -- Registra una función de completitud

Descripción

boolean readline_completion_function ( string line)

Esta función registra una función de completitud. Debe proporcionar el nombre de una función existente que acepte una línea de comandos parcial y devuelva una array con posibles coincidencias. Es el mismo tipo de funcionalidad que se obtiene al pulsar la tecla de tabulación cuando se está usando el Bash.

Anterior | Inicio | Siguiente
readline_clear_history | Subir | readline_info


readline_info

(PHP 4 >= 4.0.0)

readline_info -- Establece/Obtiene diversas variables internas de readline

Descripción

mixed readline_info ( [string varname [, string newvalue]])

Si es llamada sin parámetros, esta función devuelve un array con los valores de todas las opciones que readline usa. Los elementos vendrán indexados por los siguientes valores: done, end, erase_empty_line, library_version, line_buffer, mark, pending_input, point, prompt, readline_name, y terminal_name.

Si es llamada con un parámetros, devuelve el valor de esa opción. Si es llamada con dos parámetros, el valor de la opción será cambiado al parámetro dado.

Anterior | Inicio | Siguiente
readline_completion_function | Subir | readline_list_history


readline_list_history

(PHP 4 >= 4.0.0)

readline_list_history -- Lista el historial

Descripción

array readline_list_history ( void )

Esta función devuelve un array con el historial de líneas de comandos completo. Los elementos están indexados por enteros comenzando por el cero.

Anterior | Inicio | Siguiente
readline_info | Subir | readline_read_history


readline_read_history

(PHP 4 >= 4.0.0)

readline_read_history -- Lee un historial

Descripción

boolean readline_read_history ( string filename)

Esta función lee un historial de comandos desde un fichero.

Anterior | Inicio | Siguiente
readline_list_history | Subir | readline_write_history


readline_write_history

(PHP 4 >= 4.0.0)

readline_write_history -- Escribe el historial

Descripción

boolean readline_write_history ( string filename)

Esta función escribe el historial de comandos en un archivo.

Anterior | Inicio | Siguiente
readline_read_history | Subir | Funciones GNU Recode


Funciones GNU Recode

Manual de PHP
Anterior Siguiente

LXXXIV. Funciones GNU Recode

Este modulo contiene un interfaz para la biblioteca GNU Recode version 3.5. Para poder usar las funciones definidas en este modulo, debereis de compilar el interprete PHP con la opcion --with-recode. Para poder hacer esto debereis tener instalado en vuestro sistema GNU Recode 3.5 o superior.

La biblioteca GNU Recode convierte entre ficheros con diferentes codigos de caracteres y codificacion. Cuando esto no puede realizarse exactamente, puede desahacerse de los caracteres problematicos o crear una aproximacion. La biblioteca reconoce o produce alrededor de 150 codigos de caracteres y puede convertir ficheros entre casi todos los pares posibles. La gran mayoria de de codigos de caracteres RFC 1345 estan soportados.

Tabla de contenidos
recode_file — Recodifica de fichero a fichero segun una peticion de recodificacion.
recode_string — Recodifica una cadena literal segun una peticion de recodificacion.

Anterior | Inicio | Siguiente
readline_write_history | Subir | recode_file


recode_string

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

recode_string -- Recodifica una cadena literal segun una peticion de recodificacion.

Description

string recode_string ( string request, string string)

Recodifica la cadena string segun una peticion de recodificacion request. Devuelve FALSE si no puede realizar la recodificacion, TRUE si todo va bien.

Una simple peticion "recode" podria ser "lat1..iso646-de". Ver tambien la documentacion de GNU Recode de tu instalacion para obtener instrucciones detalladas sobre peticiones de recodificacion.

Anterior | Inicio | Siguiente
recode_file | Subir | Funciones de expresiones regulares compatibles con Perl


recode_file

(PHP 3>= 3.0.13, PHP 4 >= 4.0.0)

recode_file -- Recodifica de fichero a fichero segun una peticion de recodificacion.

Description

bool recode_file ( int input, int output)

Recodifica el fichero definido por input a el fichero definido por output, segun la peticion de recodificacion request. Devuelve FALSE si no puede realizar la recodificacion, TRUE si todo va bien.

Esta funcion no procesa ficheros remotos (URLs). Los dos ficheros deben de ser locales en el sistema.

Anterior | Inicio | Siguiente
Funciones GNU Recode | Subir | recode_string


Funciones de expresiones regulares compatibles con Perl

Manual de PHP
Anterior Siguiente

LXXXV. Funciones de expresiones regulares compatibles con Perl

La sintaxis, para los patrones usados en estas funciones, es muy semejante al Perl. Las expresiones estarán encerradas por delimitadores, por ejemplo una barra de dividir (/). Cualquier carácter puede ser usado para delimitar incluso los que no son caracteres alfanuméricos o la barra invertida (\). Si el carácter delimitador ha sido usado en la propia expresión, es necesario que sea precedido por una barra inversa.

El delimitador de fin puede ser seguido por varios modificadores que afectarán al resultado. Examina Modificadores de Patrones.

Ejemplo 1. Ejemplos de patrones válidos

  • /<\/\w+>/

  • |(\d{3})-\d+|Sm

  • /^(?i)php[34]/

Ejemplo 2. Ejemplos de patrones no válidos

  • /href='(.*)' - falta el delimitador de fin

  • /\w+\s*\w+/J - el modificador 'J' es desconocido

  • 1-\d3-\d3-\d4| - falta el delimitador de inicio

Nota: Para las funciones de expresiones compatibles con Perl se necesita PHP 4 o PHP 3.0.9 o superior.

Tabla de contenidos
Modificadores de Patrones — describe los modificadores posibles en los patrones de expresiones regulares (regex)
Sintaxis de los Patrones — describe la sintaxis de PCRE regex
preg_grep — Devuelve un array con los elementos que casen con el patrón
preg_match — Realiza un emparejamiento dada una expresión
preg_match_all — Realiza un completo emparejamiento de expresiones
preg_quote — Prepara los caracteres de expresiones
preg_replace — Lleva a cabo la búsqueda de una expresión y su sustitución
preg_split — Divide una cadena dada una expresión

Anterior | Inicio | Siguiente
recode_string | Subir | Modificadores de Patrones


preg_match

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

preg_match -- Realiza un emparejamiento dada una expresión

Descripción

int preg_match ( string pattern, string subject [, array matches])

Busca en subject para un emparejamiento, dada la expresión pattern.

Si matches es dado, entonces será definido con el resultado de la búsqueda. $matches[0] contendrá el texto que empareja con el patrón en su totalidad. $matches[1] tendrá la cadena que empareje con el primer subpatrón que esté entre paréntesis y así sucesivamente.

Devuelve TRUE si se encontró en la cadena un emparejamiento dado el patrón pattern, FALSE si no se produjo o hubo un error.

Ejemplo 1. Obtener el número de la siguiente página dada una cadena

if (preg_match("/page\s+#(\d+)/i", "Go to page #9.", $parts))
    print "Next page is $parts[1]";             // La siguiente página es $parts[1]
else
    print "Page not found.";                    // Página no encontrada
Examinar también preg_match_all(), preg_replace(), y preg_split().

Anterior | Inicio | Siguiente
preg_grep | Subir | preg_match_all


preg_match_all

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

preg_match_all -- Realiza un completo emparejamiento de expresiones

Descripción

int preg_match_all ( string pattern, string subject, array matches [, int order])

Busca en subject todos los emparejamientos de la expresión pattern y los pone en matches de la forma indicada por order.

Después de encontrar el primer emparejamiento, las subsiguientes búsquedas empiezan desde el punto del último casamiento.

order puede tener los siguientes valores:

PREG_PATTERN_ORDER

Los resultados serán devueltos de manera que $matches[0] es un array con el patrón de búsqueda completo, $matches[1] es una array de las cadenas casadas por el primer subpatrón que esté entre paréntesis y así sucesivamente.

preg_match_all("|<[^>]+>(.*)</[^>]+>|U", "<b>example: </b><div align=left>this is a test</div>", $out, PREG_PATTERN_ORDER);
print $out[0][0].", ".$out[0][1]."\n";
print $out[1][0].", ".$out[1][1]."\n"

Esta ejemplo dará como resultado:

<b>example: </b>, <div align=left>this is a test</div>
example: , this is a test

Así, $out[0] contiene el array con las cadena que casan completamente con el patrón y $out[1] con las cadenas que se encuentran entre los tags.

PREG_SET_ORDER

Los resultados son dados de manera que $matches[0] es una array del primer conjunto de emparejamientos, $matches[1] es un array de los segundos conjuntos de casamientos y así sucesivamente.

preg_match_all("|<[^>]+>(.*)</[^>]+>|U", "<b>example: </b><div align=left>this is a test</div>", $out, PREG_SET_ORDER);
print $out[0][0].", ".$out[0][1]."\n";
print $out[1][0].", ".$out[1][1]."\n"

Este ejemplo dará como resultado:

<b>example: </b>, example:
<div align=left>this is a test</div>, this is a test

En este caso, $matches[0] es el primer conjunto de emparejamientos y $matches[0][0] tiene el casamiento completo, $matches[0][1] el del primer subpatrón y así sucesivamente. Similarmente, $matches[1] es el segundo conjunto de emparejamientos, etc.

Si order no es dado, se asume PREG_PATTERN_ORDER.

Devuelve el número de casamientos completos, FALSE si no hubo o se produjo error.

Ejemplo 1. Obtener los número de teléfonos de un texto.

preg_match_all("/\(?  (\d{3})?  \)?  (?(1)  [\-\s] ) \d{3}-\d{4}/x",
               "Call 555-1212 or 1-800-555-1212", $phones);

Examina también preg_match(), preg_replace() y preg_split().

Anterior | Inicio | Siguiente
preg_match | Subir | preg_quote


preg_replace

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

preg_replace -- Lleva a cabo la búsqueda de una expresión y su sustitución

Descripción

mixed preg_replace ( mixed pattern, mixed replacement, mixed subject)

Busca en subject los emparejamientos con pattern y los sustituye por replacement.

replacement puede contener referencias de la forma \\n. Éstas serán sustituidas por el texto obtenido por el patrón del paréntesis nésimo. n puede tener un valor de cero a noventa y nueve, y \\0 se refiere al texto casado por el patrón completo. Para obtener el número del subpatrón de búsqueda, los paréntesis abiertos son contados de izquierda derecha tomando el primero como uno.

Si el patrón no es encontrado en subject, entonces no se realizarán cambios.

Todos los parámetros de la función preg_replace() pueden ser un array.

Si subject es un array, entonces la búsqueda y sustitución es realizada para todos los elementos de subject, y el valor devuelto es también un array.

Si pattern y replacement son arrays, entonces preg_replace() toma un valor desde cada array y los usas para buscar y sustituir sobre subject. Si replacement tiene menos valores que pattern, entonces la cadena vacía es usada como valor para el resto de sustituciones. Si pattern es una array y replacement es una cadena, entonces esta cadena de sustitución es usada para todos los valores de pattern. Sin embargo, lo contrario no tiene sentido.

El modificador /e hace que la función preg_replace() trate el parámetro replacement como código PHP después de que la apropiada sustitución sea hecha. Atención, asegúrate que replacement es un código PHP correcto, de otro modo PHP dará un error de parse en la línea que contenga preg_replace().

Nota: Este modificador fue añadido en PHP 4.0.

Ejemplo 1. Sustituir varios valores

$patterns = array("/(19|20\d{2})-(\d{1,2})-(\d{1,2})/", "/^\s*{(\w+)}\s*=/");
$replace = array("\\3/\\4/\\1", "$\\1 =");
print preg_replace($patterns, $replace, "{startDate} = 1999-5-27");
Esta ejemplo dará como resultado:
$startDate = 5/27/1999

Ejemplo 2. Usar el modificador /e

preg_replace("/(<\/?)(\w+)([^>]*>)/e", "'\\1'.strtoupper('\\2').'\\3'", $html_body);

Pondrá en mayúscula todos los tags HTML del texto de entrada.

Examina también preg_match(),
preg_match_all(), y
preg_split().

Anterior | Inicio | Siguiente
preg_quote | Subir | preg_split


preg_split

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

preg_split -- Divide una cadena dada una expresión

Descripción

array preg_split ( string pattern, string subject [, int limit [, int flags]])

Nota: El parámetro flags fue añadido en la Beta 3 de PHP

Devuelve un array conteniendo las subcadenas de subject divididas mediante los emparejamientos limitados por pattern.

Si limit es proporcionado, entonces sólo limit subcadenas son devueltas.

Si el flags es PREG_SPLIT_NO_EMPTY entonces las cadenas vacías no serán devueltas por preg_split().

Ejemplo 1. Obtener las partes de una cadena de búsqueda

$keywords = preg_split("/[\s,]+/", "hypertext language, programming");
Examinar también preg_match(), preg_match_all(), y preg_replace().

Anterior | Inicio | Siguiente
preg_replace | Subir | qtdom functions


preg_quote

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

preg_quote -- Prepara los caracteres de expresiones

Descripción

string preg_quote ( string str)

preg_quote() toma str y pone una barra invertida (\) delante de todo carácter que sea parte de la sintaxis de las expresiones. Es útil si tienes una cadena en tiempo de ejecución y puede contener caracteres especiales.

Los caracteres especiales de las expresiones son:
. \\ + * ? [ ^ ] $ ( ) { } = ! < > | :

Nota: Esta función fue añadida en PHP 3.0.9.

Anterior | Inicio | Siguiente
preg_match_all | Subir | preg_replace


preg_grep

(PHP 4 >= 4.0.0)

preg_grep -- Devuelve un array con los elementos que casen con el patrón

Descripción

array preg_grep ( string pattern, array input)

preg_grep() devuelve un array conteniendo los elementos del array input que emparejen con el patrón (pattern) dado.

Ejemplo 1. Ejemplo de la función preg_grep()

preg_grep("/^(\d+)?\.\d+$/", $array); // encuentra todos los números reales en el array

Nota: Esta función fue añadida en PHP 4.0.

Anterior | Inicio | Siguiente
Sintaxis de los Patrones | Subir | preg_match


Modificadores de Patrones

(unknown)

Modificadores de Patrones -- describe los modificadores posibles en los patrones de expresiones regulares (regex)

Descripción

Los posibles modificadores PRCE (Funciones de Expresiones Compatibles con Perl), en este momento, son mostrados a continuación. Los nombres entre paréntesis se refieren a nombres internos PCRE para dichos modificadores.

i (PCRE_CASELESS)

Si es usado, no se distinguirá entre mayúsculas y minúsculas.

m (PCRE_MULTILINE)

Por defecto, PCRE trata la cadena de entrada como si fuera una sola línea de caracteres (aun cuando tenga varias). El carácter especial de "inicio de línea" (^) empareja sólo al principio de la cadena, mientras el carácter especial de "fin de línea" ($) casa sólo el fin de la entrada, o antes un carácter de nueva línea (a menos que el modificador E sea definido). Esto es lo mismo que en Perl.

Cuando este modificador es utilizado, los constructores de "inicio de línea" y "fin de línea" son emparejados con el carácter de nueva línea. Esto es equivalente al modificador /m del Perl. Si no hay caracteres "\n" en la cadena de entrada, o no existen ^ o $ en el patrón, entonces este modificador no alterará el resultado.

s (PCRE_DOTALL)

Si se usa, el carácter especial de un punto en el patrón emparejará todos los caracteres, incluyendo el de nueva línea. Sin él, el carácter de nueva línea es excluido. Este modificador equivale a /s en Perl. Una cláusula como [^a] siempre casa con un carácter de nueva línea, independientemente de la utilización de este modificador.

x (PCRE_EXTENDED)

Si es definido, los caracteres de información con espacios en blanco en el patrón son ignorados excepto cuando son precedidos por una barra invertida o dentro de una clase carácter, y los caracteres entre un # fuera de una clase carácter y los siguientes caracteres de nueva línea, incluidos, son ignorados también. Esto es equivalente al /x en Perl y hace posible incluir comentarios dentro de patrones complejos. Sin embargo, esto es sólo aplicable a caracteres de información. Los caracteres de espacio en blanco nunca pueden aparecer en la secuencia de caracteres especiales de un patrón, por ejemplo en la secuencia (?( la cual introduce un subpatrón condicional.

e

Si es usado, preg_replace() hace las sustituciones \\ de forma habitual, evalúa el código PHP y usa el resultado para realizar una sustitución en la cadena de búsqueda.

Sólo preg_replace() hace uso de este modificador y es ignorado por las otras funciones PCRE.

Nota: Este modificador fue añadido en PHP 4.0.

A (PCRE_ANCHORED)

Si es definido, el patrón es forzado a ser "anclado", esto es, es obligado a emparejar sólo desde el inicio de la cadena (el "subject string"). Esta característica también puede realizarse con el apropiado patrón, y esta es la única manera de hacerlo en Perl.

E (PCRE_DOLLAR_ENDONLY)

Si es usado, el carácter del dólar en el patrón casará sólo con fin de la cadena de entrada (subject).Sin este modificador, un dólar es también emparejado con el carácter inmediatamente antes del de una nueva línea (pero no antes de cualquier otra nueva línea). Este modificador es ignorado si m es definido. No hay equivalente en Perl para este modificador.

S

Cuando un patrón va a ser usado varias veces, es mejor dedicar más tiempo a analizarlo para acelerar el proceso de casamientos. Si es definido entonces se realizar un análisis adicional. Estudiar a un patrón es sólo útil para los no anclados, esto es, no tienen un carácter de inicio fijado.

U (PCRE_UNGREEDY)

Este modificador invierte la "codicia" de los cuantificadores aunque no son ansiosos por defecto, se vuelven codiciosos si son seguidos por un "?". No es compatible con Perl. también puede usarse dentro del patrón.

X (PCRE_EXTRA)

Este modificador activa características adicionales del PCRE que no son compatible con Perl. Cualquier barra invertida en el patrón que sea seguida por una letra que no tenga una interpretación especial provocará un error, estas combinaciones están reservado para futuras ampliaciones. Por defecto, como en Perl, una barra invertida seguida por una letra sin un significado especial es tratada literalmente. No hay otras características controladas por este modificador a la fecha de hoy.

Anterior | Inicio | Siguiente
Funciones de expresiones regulares compatibles con Perl | Subir | Sintaxis de los Patrones


Sintaxis de los Patrones

(unknown)

Sintaxis de los Patrones -- describe la sintaxis de PCRE regex

Descripción

La librería PCRE es un conjunto de funciones que implementan emparejamientos
dados patrones de expresiones regulares usando la misma sintaxis y semántica que
Perl 5, con unas pocas diferencias (ver más adelante). La actual versión
corresponde a Perl 5.005.

Diferencias frente a Perl

Las diferencias descritas aquí son con respecto a Perl 5.005.

1. Por defecto, un carácter de espacio en blanco es cualquier carácter
que la función isspace() de la librería C reconozca, así es posible
compilar PCRE con tablas alternativas de tipos de caracteres. Normalmente
isspace() casa con el espacio, salto de pagina, nueva línea, retorno de carro,
tabulador horizontal y vertical. Perl 5 ya no incluye el tabulador vertical
en su conjunto de caracteres de espacio en blanco. La secuencia de
escape \n que estuvo durante mucho tiempo en la documentación de Perl nunca
fue reconocida. Sin embargo, el carácter fue tratado como espacio en blanco
hasta la 5.002. En 5.004 y 5.005 no casa \s.

2. PCRE no permite repetir cuantificadores sobre sentencias hacia adelante.
Perl las permite, pero no de la forma que puedas pensar.
Por ejemplo, (?!a){3} no dice que los próximos tres caracteres no son "a".
En realidad significa que los siguientes caracteres no son "a" tres veces.

3. Los subpatrones encontrados dentro de sentencias de más adelante
negativas son contados, pero sus entradas en el vector de desplazamientos
no son definidas. Perl define sus variables numéricas desde cualquiera de
tales patrones que son casados antes de que la sentencia falle emparejar
algo, pero solo si las sentencies de más adelante negativas contienen una
opción sola.

4. Aunque los caracteres de cero binario son soportados en la cadena de
entrada, no son permitidos en un patrón porque son pasados como un cadena
típica de C, terminada por cero. La secuencia de escape "\0" puede ser
usada en el patrón para representar el cero binario.

5. Las siguientes secuencias de Perl no son soportadas:
\l, \u, \L, \U, \E, \Q. En efecto, estas son implementadas por
manipuladores de cadenas típicos de Perl y no son parte de los patrones del
motor de búsqueda.

6. La secuencia \G de Perl no es soportada ya que no es relevante para
emparejamientos de patrones sencillos.

7. Obviamente, PCRE no soporta el constructor (?{code})

8. Hay algunas diferencias en Perl 5.005_02 respecto a las definiciones
de las cadenas de captura cuando parte de un patrón es repetido. Por
ejemplo, casando "aba" con el patrón /^(a(b)?)+$/ define $2 al valor "b",
pero emparejando "aabbaa" con /^(aa(bb)?)+$/ deja $2 sin definir. Sin
embargo, si el patrón es cambiado a /^(aa(b(b))?)+$/ entones $2 (y $3) son
definidos.

En Perl 5.004 $2 es definido en ambos casos, y también es cierto en PCRE.
Si en el futuro Perl cambia a una regla diferente, PCRE puede cambiar para
seguirla.

9. Otra discrepancia aún no resuelta es que en Perl 5.005_02 el patrón
/^(a)?(?(1)a|b)+$/ casa la cadena "a", pero en PCRE eso no es así. Sin
embargo, en ambos Perl y PCRE /^(a)?a/ empareja "a" dejando $1 sin definir.

10. PCRE da algunas extensiones para facilitar las expresiones de PERL:

(a) Aunque las sentencias de más adelante deben emparejar cadenas de longitud fija,
cada opción de una sentencia de punto actual puede casar con una cadena de
longitud diferente. Perl 5.005 requiere que todas ellas tengan la misma
longitud.

(b) Si es definido PCRE_DOLLAR_ENDONLY y PCRE_MULTILINE no lo es, el
carácter especial $ sólo casa con el final de la cadena.

(c) Si se define PCRE_EXTRA, una barra invertida seguida de una letra sin
un significado especial provoca un error.

(d) Si defines PCRE_UNGREEDY, la voracidad de los cuantificadores de
repetición es invertida, esto es, por defecto son no codiciosos, pero
seguidos por una interrogación si lo son.

Detalles de las expresiones

La sintaxis y la semántica de las expresiones soportadas por PCRE es
descrita a continuación. Las expresiones son descritas en la documentación
del Perl y en numerosos libros, algunos de los cuales tienen mucho
ejemplares, Jeffrey Friedl's "Mastering Regular Expressions", publicado
por O'Reilly (ISBN 1-56592-257-3), las cubre con gran detalle. La presente
descripción es propuesta como documentación de referencia.

Una expresión es un patrón que es emparejada repetidamente, dada una cadena
de entrada, de izquierda a derecha. Muchos caracteres se representan a ellos
mismos en el patrón. Como un ejemplo trivial, el patrón

The quick brown fox

casa una parte de una cadena de entrada que es idéntica a ella. El poder
de las expresiones proviene de la posibilidad de incluir alternativas y
repeticiones en el patrón. Éstos son codificados en el patrón usando
meta-characters (caracteres
especiales también llamados meta caracteres), los cuales no se representan
a ellos mismos, en vez de eso, son interpretados de una manera especial.

Hay dos diferentes conjuntos de caracteres especiales: aquellos que son
reconocidos en cualquier parte en el patrón excepto dentro corchetes ('[' y ']'),
y aquellos que son reconocidos dentro. Fuera de los corchetes, los caracteres
especiales son:

\ carácter de escape genérico con diferentes usos
^ secuencia de inicio de la cadena de entrada (o línea, en modo multilínea)
$ secuencia de fin de la cadena de entrada (o línea, en modo multilínea)
. empareja cualquier carácter excepto el de nueva línea (por defecto)
[ inicia definición de clase de caracteres
| inicio de opción alternativa
( inicio de subpatrón
) fin de subpatrón
? amplia el significado de (
también es el cuantificador 0 ó 1
también es el cuantificador minimizado
* cero o más cuantificadores
+ uno o más cuantificadores
{ inicia el cuantificador min/max

Parte de un patrón dentro de corchetes ([]) es llamado un "character class"
(clase de caracteres). En una clase de caracteres los únicos caracteres
especiales son:

\ carácter de escape genérico
^ niega la clase, pero sólo si el primer carácter
- indica un rango de caracteres
] finaliza la clase de caracteres

Las secciones siguientes describen el uso de cada uno de los caracteres
especiales (meta caracteres).

BARRA INVERTIDA

El carácter de barra invertida tiene varios usos. Primero, si es seguido
por un carácter que no sea alfanumérico, toma el significado que el
carácter pueda tener. Este uso de la barra invertida, como un carácter de
escape, se aplica tanto dentro como fuera de las clases de caracteres.

Por ejemplo, si quieres casar un carácter "*", debes escribir "\*" en el patrón.
Esto es aplicable ya sea o no el carácter siguiente interpretado como un
carácter especial, por eso siempre es aconsejable preceder un carácter
no alfanumérico con "\" para especificar que se representa a él mismo. En
particular, si quieres casar una barra invertida, escribe "\\".

Si el patrón es compilado con la opción PCRE_EXTENDED , los espacios en
blanco en el patrón (fuera de una clase de caracteres) y los caracteres entre
un "#" fuera de una clase de caracteres y el carácter de nueva línea
son ignorado. Una barra invertida de escape puede usarse para
incluir un espacio en blanco o el carácter "#" como parte del patrón.

Un segundo uso de la barra invertida sirve para codificar caracteres no
imprimibles en los patrones de una manera visible. No hay restricciones
sobre la apariencia de los caracteres no imprimibles, quitando el cero
binario de terminación de un patrón, pero cuando un patrón es preparado
con un editor de texto, normalmente es fácil utilizar una de las siguientes
secuencias de escape que representan sus caracteres binarios:

\a alarma, esto es, el carácter BEL (07 en hexadecimal)
\cx "control-x", donde x es cualquier carácter
\e escape (1B en hexadecimal)
\f nueva página (0C en hexadecimal)
\n nueva línea (0A en hexadecimal)
\r retorno de carro (0D en hexadecimal)
\t tabulador (09 en hexadecimal)
\xhh carácter con código hh en hexadecimal
\ddd carácter con código ddd en octal

El efecto de "\cx" es como sigue: si "x" es una letra minúscula,
es convertida a mayúscula. Entonces el sexto bit del carácter (40 en
hexadecimal) es invertido. Esto es, "\cz" es 1A en hexadecimal, pero "\c{"
es 3B en hexadecimal, mientras "\c;" es 7B en hexadecimal.

Después de "\x", hasta dos dígitos hexadecimales son leídos (las letras
pueden ser mayúsculas o minúsculas).

Después de "\0" son leídos dos dígitos octales más. En ambos casos, si hay
menos de dos dígitos, se usrará lo que haya. Esto es, la secuencia "\0\x\07"
indica dos ceros binarios seguidos por un carácter BEL. Asegúrate dar dos
dígitos después del inicial cero si el carácter que sigue es un dígito octal.

El uso de una barra invertida seguido por otro dígito que no sea el cero
es complejo. Fuera de una clase carácter, PCRE interpreta cualquier dígito
como un número decimal. Si el número es menor que diez, o si ha habido
al menos tantos paréntesis capturados a la izquierda en la expresión,
entonces la secuencia entera es tomada como una back
reference (referencia atrás). Una descripción
de como trabaja esto es dada después, siguiendo la discusión de subpatrones
con paréntesis.

Dentro de una clase carácter, o si el número decimal es mayor que nueve y
no ha habido tantos subpatrones capturados PCRE relee los tres dígitos
octales siguientes a la barra invertida y genera un byte desde los ocho
bits menos significativos del valor. Cualquier dígito a continuación se
representa a él mismo. Por ejemplo:

\040 es otro modo de escribir un espacio
\40 es lo mismo, siempre que haya menos de cuarenta subpatrones abiertos
\7 siempre es una referencia atrás
\11 puede ser una referencia atrás o un tabulador
\011 siempre es un tabulador
\0113 es el carácter con código octal 113 (ya que no puede haber más de
noventa y nueve referencias atrás)
\377 es un byte con todos sus bits a uno
\81 puede ser una referencia atrás o un cero binario seguido por
dos caracteres "8" y "1"

Ten en cuenta que el valor octal de un número mayor o igual a cien no debe
ser precedido por un cero ya que no son leídos más de tres dígitos octales.

Todas las secuencias que definen el valor de un byte pueden ser usadas
tanto dentro como fuera de la clase carácter. Además, la secuencia
"\b" es interpretada como el carácter backspace (hex 08) dentro. Fuera es
definido de otra manera (ver más adelante).

El tercer uso de la barra invertida es para especificar los tipos de
caracteres genéricos:

\d cualquier un dígito decimal
\D cualquier carácter que no sea un dígito decimal
\s cualquier carácter de espacio en blanco (whitespace)
\S cualquier carácter que no sea un espacio en blanco
\w cualquier carácter de "palabra"
\W cualquier carácter que no se de "palabra"

Cada pareja de secuencia de escape divide el conjunto global de caracteres
en dos. Cualquier carácter dado empareja en uno y sólo uno de cada pareja.

Un carácter de "palabra" es cualquier letra o dígito o el carácter subrayado,
esto es, cualquier carácter puede ser parte de una "palabra" en Perl. La
definición de letras y dígitos es controlada por la tabla de caracteres de
PERL, y puede ser variada si las especificaciones regionales son tomadas en
cuenta (ver "Soporte regional más adelante"). Por ejemplo, en Francia algunos
caracteres tienen un código superior a 128, para representar las letras
acentuadas, y son emparejados por \w.

Estas secuencias de tipos de caracteres pueden aparecer tanto dentro como
fuera de las clases carácter. Cada una casa un carácter del tipo apropiado.
Si el punto de casamiento actual es el final de la cadena, todo ello falla,
ya que no hay más caracteres que casar.

El cuarto uso de la barra invertida es para ciertas sentencias (assertions).
Una sentencia especifica una condición que tiene que ser encontrada en
un punto particular de un emparejamiento, sin utilizar ningún carácter de la
cadena de entrada. El uso de subpatrones para sentencias más complicadas
es descrito después. Las sentencias de barra invertida son

\b limites de palabra
\B no sean limites de palabra
\A inicio de la cadena de entrada (independiente del modo multilínea)
\Z fin de la cadena de entrada o de una nueva línea delante del final
(independiente del modo multilínea)
\z fin de la cadena de entrada (independiente de modo multilínea)

Estas sentencias no pueden aparecer dentro de una clase carácter (pero ten
en cuenta que "\b" tiene un significado diferente, quiere decir el carácter
backspace dentro de una clase carácter)

Un límite de palabra es una posición en la cadena de entrada donde un
carácter y el anterior no emparejan con \w o \W (por ejemplo, uno casa con
\w y el otro con \W), o el principio o el final de la cadena si el primero
o el último carácter emparejan con \w, respectivamente.

Las sentencias \A, \Z y \z se diferencian de los tradicionales circunflejo
y dólar (ver más adelante) en que sólo emparejan el inicio y fin de la
cadena de entrada sin tener en cuenta las opciones definidas. No les afectan
las opciones PCRE_NOTBOL o PCRE_NOTEOL. La diferencia entre \Z y \z es que
\Z casa antes una nueva línea que es el último carácter de la cadena como
también el final de la cadena, sin embargo \z sólo casa el final.

CIRCUNFLEJO Y DOLAR

Fuera de una clase carácter, en el modo de emparejamiento por defecto, el
carácter circunflejo es una sentencia la cual es verdadera sólo si el punto
de casamiento actual es el inicio de la cadena de entrada. Dentro de una
clase carácter, el circunflejo tiene significado completamente distinto
(ver más adelante).

El circunflejo no necesita ser el primer carácter del patrón si son posibles
un número de alternativas, pero será la primera cosa en cada alternativa
en la cual aparezca si el patrón casa esa opción.
Si todas las alternativas posibles empiezan con un circunflejo, esto es,
si el patrón es obligado a casar sólo con en el inicio de la cadena de entrada,
se dice que es un patrón "anclado". También hay otros constructores que
pueden hacer que un patrón sea anclado.

Un carácter de dólar es una sentencia que es verdadera sólo si el
punto de emparejamiento actual es el final de la cadena de entrada, o
inmediatamente antes de un carácter de nueva línea, el cual es el último
carácter en la cadena, por defecto. El dólar no necesita ser el último
carácter del patrón si hay varias alternativas, pero será el último elemento
en cualquier alternativa en el que aparezca. El dólar no tiene
un significado especial en una clase carácter.

El significado del dólar puede ser cambiado para que sólo empareje el
final de la cadena de entrada definiendo la opción PCRE_DOLLAR_ENDONLY a la
hora de compilar o tiempo de ejecución. Esto no afecta a la sentencia \Z.

El significado de los caracteres circunflejo y dólar cambia si la opción
PCRE_MULTILINE es definida. Cuando éste es el caso, casan, respectivamente,
inmediatamente antes y después de un carácter "\n" interno,
además de emparejar con el inicio y el final de la cadena. Por ejemplo, el
patrón /^abc$/ casa con la cadena de entrada "def\nabc" en modo multilínea,
pero en otro modo no. Consecuentemente, los patrones anclados son en modo
línea ya que todas las opciones que empiezan con "^" no son ancladas en modo
multilínea. La opción PCRE_DOLLAR_ENDONLY es ignorada si PCRE_MULTILINE es
definido.

Ten en cuenta que las secuencias \A, \Z y \z pueden ser usadas para casar
el inicio y el final de la cadena en ambos modos, y si todas las opciones
de un patrón empiezan con \A siempre es anclado, independientemente de si
PCRE_MULTILINE es definido o no.

FINAL (PUNTO)
Fuera de una clase carácter, un punto en el patrón casa con un carácter
cualquiera en la cadena de entrada, incluyendo un carácter no imprimible,
exceptuando el de nueva línea (por defecto). Si la opción PCRE_DOTALL es
definida, entonces los puntos casan con los de nueva línea también. El
manejo de puntos es completamente independiente del uso del circunflejo y el
dólar, la única relación entre ellos son los caracteres de nueva línea. Los
puntos no tienen un significado especial dentro de una clase carácter.

CORCHETES

Un corchete de apertura crea una clase carácter, terminada por uno de cierre.
Un corchete de cierre no tiene un significado especial. Si un corchete de
cierre es necesitado como un miembro de la clase, será el primer carácter
de datos en la clase (después de un circunflejo inicial, si está presente)
o con una barra invertida antes.

Si una clase carácter casa con un carácter único en la cadena; el carácter
debe estar en el conjunto de los caracteres definidos por la clase, a menos
que el primero sea un circunflejo, en cuyo caso el carácter de la cadena de
entrada no debe estar en el conjunto definido por la clase. Si un circunflejo
es necesitado como un miembro de la clase, asegúrate que no es el primero o
es precedido por una barra invertida.

Por ejemplo, la clase carácter [aeiou] empareja cualquier vocal minúscula,
mientras [^aeiou] casa cualquier carácter que no sea una vocal minúscula.
Ten en cuenta que un circunflejo es una notación convenida para especificar
los caracteres que están en la clase enumerando los que no lo están. No es
una sentencia: consume un carácter de la cadena de entrada y falla si
el punto actual es final.

Cuando se define el emparejamiento sin tener en cuenta mayúsculas y minúsculas
(caseless), cualquier letra en una clase representa ambas, por ejemplo,
un patrón caseless [aeiou] empareja tanto "A" como "a" y un caseless
[^aeiou] no casa con "A"

El carácter de nueva línea nunca es tratado de un modo especial en una
clase carácter, aunque se hallan definido cualquiera de las opciones
PCRE_DOTALL o PCRE_MULTILINE. Una clase como [^a] siempre casa con una
nueva línea.

El carácter de menos puede ser usado para especificar un rango de caracteres
en una clase miembro. Por ejemplo, [d-m] casa con cualquier letra entre d
y m ambas incluidas. Si un carácter de menos es necesitado en una clase,
debe ser precedido por una barra invertida o aparecer en una posición donde
no pueda ser interpretado como indicador de una rango, normalmente al inicio
o al final de la clase.

No es posible tener el carácter literal "]" como el de final de un rango.
Un patrón como [W-]46] es interpretado como una clase de dos caracteres
("W" y "-") seguido por la cadena literal "46]", por lo que emparejaría con
"W46]" o "-46]". Sin embargo, si el carácter "]" es precedido con una barra
invertida es tomado por el final del rango, así [W-\]46] es interpretado
como una clase conteniendo un rango seguido por dos caracteres. La
representación octal o hexadecimal de "]" puede ser usada para finalizar
un rango.

Los rangos trabajan en la secuencia ASCII. Se pueden especificar mediante
la representación numérica de los mismos, por ejemplo [\000-\037]. Si
un rango que incluye letras es usado cuando es definida la opción de no
tener en cuenta mayúsculas y minúsculas casan ambas. Por ejemplo, [W-c]
es equivalente a [][\^_`wxyzabc], teniendo en cuenta mayúsculas y
minúsculas, y si la tabla de caracteres para la región "fr" es usada,
entonces [\xc8-\xcb] empareja los caracteres E acentuados en ambos casos.

Los tipos de caracteres \d, \D, \s, \S, \w, y \W también pueden aparecer
en una clase carácter y añaden los caracteres que ellos casen para la clase.
Por ejemplo, [\dABCDEF] casa cualquier dígito hexadecimal. Un circunflejo
puede ser usado convenientemente con el tipo de carácter mayúsculo para
especificar un conjunto más restrictivo de caracteres que el de un casamiento
con tipo de carácter minúsculo. Por ejemplo, la clase [^\W_] empareja
cualquier letra o digito pero no el subrayado.

Todos los caracteres no alfanuméricos y los diferentes a \, -, ^ (al
principio) y ] no tienen un significado especial en una clase, y éstos
tampoco si son definidos convenientemente.

BARRA VERTICAL

Los caracteres de barra vertical son usados para separar patrones
alternativos. Por ejemplo, el patrón

gilbert|sullivan

casa con "gilbert" o "sullivan". Cualquier cantidad de opciones pueden ser
implementadas, y una alternativa vacía se permite (emparejando la
cadena vacía). El proceso de casamiento intenta cada una de izquierda a
derecha, y la primera que valga es usada. Si las alternativas están dentro
de un subpatrón, "valga" significa que casa el resto del patrón principal
como también la alternativa en el subpatrón.

DEFINIENDO LAS OPCIONES INTERNAS

Las definiciones de PCRE_CASELESS, PCRE_MULTILINE, PCRE_DOTALL,
y PCRE_EXTENDED pueden ser cambiadas desde dentro del patrón mediante
una secuencia de letras de opciones de Perl encerradas entre "(?" y ")".
Las letras de opciones son

i para PCRE_CASELESS
m para PCRE_MULTILINE
s para PCRE_DOTALL
x para PCRE_EXTENDED

Por ejemplo, (?im) define sin tener en cuenta mayúsculas y minúsculas y modo
multilínea. También es posible eliminar estas opciones precediendo las
letras con un menos y una combinación de definiciones y eliminaciones tal
como (?im-sx), la cual define PCRE_CASELESS y PCRE_MULTILINE mientras
elimina PCRE_DOTALL y PCRE_EXTENDED, también se permite. Si una letra
aparece antes y después del menos, la opción es eliminada.

El ámbito de estas opciones cambia dependiendo dónde ocurra la definición.
Las definiciones que son hechas fuera de subpatrones (como antes), el efecto es
el mismo que si la opción se define o elimina al inicio del casamiento. Los
siguientes patrones se comportan todos de la misma manera:

(?i)abc
a(?i)bc
ab(?i)c
abc(?i)

el cual tiene el mismo efecto que compilar el patrón abc con la opción
PCRE_CASELESS. En otras palabras, tales definiciones de "nivel superior"
se aplican a todo el patrón (a menos que haya otro cambio dentro del
subpatrón). Si hay más de una definición de la misma opción en el mismo
nivel superior, la definición más a la derecha se usa.

Si un cambio de opción sucede dentro de un subpatrón, el efecto es diferente.
Esto es un cambio respecto de la conducta de Perl 5.005. Un cambio de opción
dentro de un subpatrón afecta sólo a la parte del subpatrón que lo sigue,
por eso

(a(?i)b)c

empareja abc y aBc y ninguna otra cadena (asumiendo que no es usado
PCRE_CASELESS). De este modo, las opciones pueden ser hechas para
tener diferente significado en diferente partes del patrón. Cualquier
cambio realizado en una alternativa provoca que todo el subpatrón la use.
Por ejemplo,

(a(?i)b|c)

empareja "ab", "aB", "c", y "C", siempre y cuando case "C" la primera
opción es abandonada antes de definir la opción. Esto es porque los efectos
de definiciones de opción ocurren en tiempo de compilación. De otro modo,
éstos sería una conducta muy rara.

Las opciones específicas PCRE PCRE_UNGREEDY y PCRE_EXTRA pueden ser
cambiadas del mismo modo que las opciones compatibles con Perl usando
los caracteres U y X respectivamente. La bandera (?X) es especial ya que
siempre debe aparecer antes que cualquier otra en el patrón, incluso cuando
es definida a nivel superior. Es mejor ponerla en el inicio.

SUBPATRONES

Los subpatrones son delimitados por paréntesis y pueden estar anidados.
Marcando parte de un patrón como un subpatrón permite dos cosas:

1. Define un conjunto de opciones. Por ejemplo, el patrón

cat(aract|erpillar|)

empareja con "cat", "cataract", or "caterpillar". Sin los paréntesis,
casaría "cataract", "erpillar" o la cadena vacía.

2. Define el subpatrón como un subpatrón capturado. Cuando el patrón sea
emparejado por completo, esa porción de la cadena de entrada que casa con
el subpatrón es devuelta mediante el argumento ovector
de pcre_exec(). Los paréntesis abiertos son contados de
izquierda a derecha (empezando por uno) para definir los números de
subpatrones capturados.

Por ejemplo, si la cadena "the red king" es casada con el patrón

the ((red|white) (king|queen))

las subcadenas capturadas son "red king", "red", y "king" y los números
son 1,2 y 3

El hecho de que los paréntesis realicen dos funciones no siempre es útil.
A menudo, hay veces que un subpatrón agrupado es necesitado sin una
querer una captura. Si un paréntesis abierto le sigue "?:", el
subpatrón no hace ninguna captura, y no es contado cuando compute el
número de subpatrones capturados. Por ejemplo, si la cadena "the white
queen" es casada con el patrón

the ((?:red|white) (king|queen))

las subcadenas capturadas son "white queen" y "queen" y son numeradas como
1 y 2. El número máximo de subcadenas es de 99 y el número máximo de
subpatrones, capturados o no, es de 200.

Como un atajo, si cualquier definición de opción es necesitada al inicio
de un subpatrón no capturado, las letras de opciones pueden aparecer entre
"?" y ":". Así los dos patrones

(?i:saturday|sunday)
(?:(?i)saturday|sunday)

emparejan como el mismo conjunto de cadena de entrada exactamente. Ya que
las alternativas son intentadas de izquierda a derecha, y las opciones
no son dejadas de tener en cuenta hasta que el final de subpatrón se
alcanza, una definición de opción en una alternativa afecta al resto, por
eso el patrón anterior empareja tanto con "SUNDAY" como con "Saturday".

REPETICION

La repetición es especificada por cuantificadores, la cual puede utilizarla
cualquiera de los siguientes elementos:

un carácter, posiblemente precedido por el meta carácter .
una clase carácter
una referencia atrás (ver la próxima sección)
un subpatrón con paréntesis (a menos que sea una sentencia, ver más adelante)

El cuantificador de repetición general indica un número mínimo y un máximo
de casamientos permitidos, dando los dos números entre llaves, separados
por coma. El número debe ser menor que 65536, y el primero debe ser menor
o igual que el segundo. Por ejemplo:

z{2,4}

casa con "zz", "zzz", o "zzzz". Una llave de cierre por si misma no es un
carácter especial. Si el segundo número es omitido, pero aparece la coma,
entonces no hay límite superior; si el segundo número y la coma son
omitidos, el cuantificador indica el número exacto de repeticiones. Así

[aeiou]{3,}

empareja al menos tres vocales seguidas, pero pueden ser muchas más, mientras

\d{8}

casa exactamente ocho dígitos. Una llave abierta en una posición donde un
cuantificador no es permitido o una que no empareje con la sintaxis de un
cuantificador es tomada como un carácter literal. Por ejemplo, {,6} no es
un cuantificador, pero sí una cadena literal de cuatro caracteres.

Se permite el cuantificado {0}, provocando que la expresión se comporte
como si el elemento anterior y el cuantificador no estuvieran presentes.

Por conveniencia (y compatibilidad histórica) los cuantificadores más comunes
tienen abreviaciones de un solo carácter.

* es equivalente a {0,}
+ es equivalente a {1,}
? es equivalente a {0,1}

Es posible construir bucles infinitos mediante un subpatrón que pueda
casar ningún carácter con un cuantificador que no tenga límite superior,
por ejemplo:

(a?)*

Las primeras versiones de Perl y PCRE dan un error en tiempo de compilación
para tales patrones. Sin embargo, ya que existen casos donde esto puede ser
útil, esto patrones son aceptados ahora, pero si cualquier repetición del
subpatrón no casa ningún carácter, el bucle es roto.

Por defecto, los cuantificadores son "codiciosos", esto es, casan tantas
veces como les es posible (hasta el número máximo de veces permitido), sin
provocar que el resto del patrón falle. El ejemplo clásico de donde viene
este problema es en intentar casar comentarios en los programas en C.
Estos aparecen entre las secuencias /* y */ y dentro de la secuencia los
caracteres * y / pueden aparecer individualmente. Un modo de casar
comentarios en C es aplicando el patrón

/\*.*\*/

para la cadena

/* first command */ not comment /* second comment */

falla, porque casa la cadena entera debido a la voracidad del elemento .*

Sin embargo, si un cuantificador le siguw un signo de interrogación
entonces cesa la voracidad y empareja el mínimo número de veces posibles,
así el patrón

/\*.*?\*/

hace las cosas correctamente con los comentarios en C. El significado de
los cuantificadores variables no es cambiado en otro modo, justo el número
preferido de casamientos. No confundas el uso de las interrogaciones con
su uso como un cuantificador mas. Ya que tiene dos usos, a veces puede
parecer doble, como en

\d??\d

el cual empareja un dígito normalmente, pero puede casar dos si ese el
único modo de casar el resto del patrón.

Si se define la opción PCRE_UNGREEDY (la cual no es posible en Perl)
entonces los cuantificadores no son voraces por defecto, pero uno puede
serlo seguido por una interrogación. En otras palabras, invierte la conducta
por defecto.

Cuando un subpatrón entre paréntesis es cuantificado con un número mínimo
de repeticiones superior a uno o con un límite máximo, se necesita más
almacenamiento para compilar el patrón, en proporción al tamaño del mínimo
o del máximo.

Si un patrón empieza con .* o .{0,} y la opción PCRE_DOTALL (equivalente
a /s del Perl) es definida, esta permitiendo el . para casar nuevas líneas,
entonces el patrón es anclado implícitamente. PCRE trata tales patrones
como si estuvieran precedidos por \A. En los casos donde se conoce que la
cadena de entrada no contiene nuevas líneas, es conveniente definir
PCRE_DOTALL cuando el patrón empieza con .* para obtener esta optimización
o usar ^ para indicar explícitamente anclamiento.

Cuando un subpatrón capturado es repetido, el valor capturado es la
subcadena que empareja la iteración final. Por ejemplo, el patrón

(tweedle[dume]{3}\s*)+

con la cadena de entrada "tweedledum tweedledee" el valor de la subcadena
capturada es "tweedledee". Sin embargo, si hay subpatrones capturados
anidadamente, los valores capturados correspondientes pueden haber sido
definidos en las iteraciones anteriores. Por ejemplo, después de casar
"aba" con

/(a|(b))+/

el valor de la segunda subcadena capturada es "b".

REFERENCIAS ATRAS

Fuera de una clase carácter, una barra invertida seguida por un digito
mayor que cero (y posiblemente más dígitos) es una referencia atrás a un
subpatrón capturado antes (a su izquierda) en el patrón, siempre que haya
habido tantos paréntesis a la izquierda capturados.

Sin embargo, si el número decimal seguido por la barra invertida es menor
que diez, siempre es tomado como una referencia atrás, y da error sólo si
no hay los suficientes subpatrones capturados en todo el patrón. En otras
palabras, los paréntesis que son referidos no necesitan estar a la
izquierda de la referencia para un número menor de diez. Examina la sección
anterior titulada "Barra invertida" para más detalles del manejo de los
dígitos con la barra invertida.

Una referencia atrás empareja si casa el subpatrón capturado en el actual
punto de la cadena de entrada, mejor que casar cualquier subpatrón de la
misma. Así el patrón

(sens|respons)e and \1ibility

casa con "sense and sensibility" y "response and responsi bility", pero
no "sense and responsibility". Si el casamiento con la distinción entre
minúsculas y mayúsculas está activado en el momento de la referencia atrás,
entonces la distinción de las letras es relevante. Por ejemplo,

((?i)rah)\s+\1

casa con "rah rah" y "RAH RAH", pero no "RAH rah", pero el subpatrón
capturado originalmente es emparejado sin la distinción.

Puede haber más de una referencia atrás en el mismo subpatrón. Si un
subpatrón no ha sido usado en un emparejamiento particular, entonces
cualquier referencia atrás siempre fallara. Por ejemplo, el patrón

(a|(bc))\2

fallará siempre si inicia a casar con "a" mejor que con "bc". Ya que puede
haber hasta 99 referencias atrás, todos los dígitos seguidos por una barra
invertida son tomados como parte de número potencial de referencias atrás.
Si el patrón continua con un carácter de dígito, entonces algún delimitador
debe ser usado para terminar la referencia atrás. Si la opción PCRE_EXTENDED
es definida, este puede ser el espacio en blanco. De otro modo un comentario
vació puede ser usado.

Una referencia atrás ocurre dentro del paréntesis al cual refiere, falla
cuando el subpatrón es usado por primera vez, así por ejemplo, (a\1) nunca
emparejará. Sin embargo, tal referencia puede ser útil dentro de los
subpatrones repetidos. Por ejemplo, el patrón

(a|b\1)+

casa con cualquier número de "a"s y también con "aba", "ababaa" etc. Para
cada iteración del subpatrón, la referencia atrás casa la cadena de
caracteres correspondiente a la iteración anterior. Para que esto trabaje,
el patrón debe ser tal que la primera iteración no necesite casar la referencia
atrás. Esto puede hacerse usando alternativas, como en el ejemplo anterior,
o por medio de cuantificadores con un número mínimo de cero.

SENTENCIAS

Una sentencia es un test sobre los caracteres siguiendo o precediendo el
punto actual de emparejamiento que no consume caracteres. Las sentencias
codificadas como \b, \B, \A, \Z, \z, ^ y $ son descritas después. Las
sentencias más complejas son codificadas como subpatrones. Hay dos clases:
aquellas que condicionan más adelante de la posición actual en la cadena
de entrada (lookahead)y las que lo hacen en este punto (lookbehind).

Un subpatrón de sentencia es emparejado del modo típico, excepto que no
hace que el punto actual de emparejamiento cambie. Sentencias que condicionan
más adelante empiezan con (?= para sentencias afirmativas y (?! para las
negativas

\w+(?=;)

empareja una palabra seguida por un punto y coma. pero no incluye el
punto y coma en el casamiento, y

foo(?!bar)

casa cualquier ocurrencia de "foo" que no es seguida por "bar". Ten en cuenta
que el patrón similar

(?!foo)bar

no encuentra una ocurrencia de "bar" que es precedida por algo que no sea "foo";
encuentra cualquier ocurrencia de "bar", ya que la sentencia (?!foo) es siempre
verdadera cuando los tres primeros caracteres son "bar". Una sentencia en el
punto actual es necesaria para realizar este efecto. Las sentencias de punto
actual empiezan con (?<= para sentencias afirmativas y (?<! para las
negativas. Por ejemplo,

(?<!foo)bar

encuentra una ocurrencia de "bar" que no es precedida por "foo".
Los contenidos de un sentencia de punto actual están limitados para que todas
las cadenas que emparejen deban tener una longitud fijada. Sin embargo, si
hay varias alternativas, no todas tienen que tener la misma longitud. Así

(?<=bullock|donkey)

es permitido, pero

(?<!dogs?|cats?)

da error en tiempo de compilación. Opciones que emparejen diferentes
longitudes de cadenas son permitidas sólo a nivel superior de la sentencia
de punto actual. Ésta es una extensión comparada con Perl 5.005, la cual
requiere que todas las opciones a casar tengan la misma longitud. Una
sentencia como

(?<=ab(c|de))

no es permitida, ya que sus opciones a nivel superior pueden casar dos
longitudes diferentes, pero es aceptable si se rescribe para usar dos
opciones a nivel superior:

(?<=abc|abde)

La implementación de sentencias de punto actual es, para cada alternativa,
mover temporalmente la posición actual hacia atrás por la longitud fijada
e intentar casar. Si no hay suficientes caracteres antes de la posición
actual, fallará. Las sentencias de punto actual en unión con subpatrones de
sólo una vez pueden ser particularmente útiles para emparejamientos de finales
de cadenas; un ejemplo es dado al final de la sección sobre subpatrones
de una sola vez.

Varias sentencias (de cualquier tipo) pueden suceder consecutivamente.
Por ejemplo,

(?<=\d{3})(?<!999)foo

empareja "foo" precedido por tres dígitos que no sean "999".
Además, las sentencias puede ser anidadas en cualquier combinación. Por
ejemplo,

(?<=(?<!foo)bar)baz

empareja una ocurrencia de "baz" que es precedida por "bar" la cual no sea
precedida por "foo".

Los subpatrones de sentencias no son subpatrones capturados, y no pueden
ser repetidos, ya que no tiene sentido la misma cosa varias veces. Si una
sentencia contiene subpatrones capturados dentro de ella, éstos son siempre
contados para el propósito de la numeración de los subpatrones capturados
en todo el patrón. Las subcadenas capturadas son tenidas en cuenta para
las sentencias afirmativas, pero no para las negativas (no tiene sentido).

El contador de sentencias llega hasta un máximo de doscientos subpatrones
con paréntesis.

SUBPATRONES DE UNA SOLA VEZ

Maximizando y minimizando las repeticiones para ver si un número diferente
de éstas permite al resto del patrón emparejar, causa múltiples evaluaciones
de la cadena de entrada. A veces es útil prevenir esto, cambiando el patrón
o provocando que la repetición falle pronto, cuando el creador del patrón
conoce que no hay puntos en común.

Considera, por ejemplo, el patrón \d+foo cuando se aplica a esta cadena de
entrada

123456bar

Después de emparejar los seis dígitos falla al emparejar "foo", la acción
normal del casamiento es intentar otra vez con sólo cinco dígitos que
emparejen con el elemento \d+, y entonces con cuatro, y así, antes de fallar.
Subpatrones de una sola vez dan el modo de especificar que una parte del
patrón tiene que emparejar, no es re-evaluado de esta manera, así el
casamiento fallará al emparejar "foo" la primera vez. La notación es otra
clase de paréntesis especial, iniciado con (?gt; como en este ejemplo:

(?>\d+)bar

Esta clase de paréntesis "bloquean" la parte del patrón que tiene que
ser emparejada una vez y un fallo impide que la re-evalue.

Una descripción alternativa es que un subpatrón de este tipo case los
caracteres de la cadena que un patrón fijo emparejaría, si estuviera anclado
en el punto actual de la cadena de entrada.

Subpatrones de una sola vez no son subpatrones capturados. Estos casos tal
como el ejemplo anterior pueden ser interpretado como de una repetición
maximizada que debe tragar todo lo que pueda.
Por esto, mientras ambos \d+ y \d? están preparados para ajustar el número
de dígitos que emparejan para hacer que el resto del patrón case, (?>\d+)
sólo puede emparejar un secuencia de dígitos entera.

Esta construcción, por supuesto, puede contener subpatrones arbitriamente
complicados y pueden estar anidados.

Subpatrones de una sola vez pueden usarse con sentencias de punto actual
para especificar eficientes emparejamientos al final de la cadena de entrada.
Consideremos un patrón sencillo como este

abcd$

cuando se aplica a una cadena larga con la cual no empareja. Ya que el
casamiento va de izquierda a derecha, PCRE buscará cada "a" en la cadena
y entonces verá si lo que sigue casa con el resto del patrón. Si el patrón
se escribe así

^.*abcd$

entonces el .* inicial casará primero la cadena entera, pero cuando esto
falle, volverá atrás para emparejar todo menos el último carácter, entonces
los dos últimos y así sucesivamente. Otra vez la búsqueda de "a" cubre la
cadena completa, de derecha a izquierda, de esta manera no se mejora. Sin
embargo, si el patrón fuese este

^(?>.*)(?<=abcd)

entonces no hay vuelta atrás para el elemento .*; sólo puede casar la cadena
entera. La sentencia de punto actual subsiguiente hace un test sencillo
sobre los últimos cuatro caracteres. Si falla, el casamiento inmediatamente
da un resultado negativo. Para cadena largas, este acercamiento da una
diferencia significativa en tiempo de ejecución.

SUBPATRONES CONDICIONALES

Es posible hacer que el casamiento procese un subpatrón condicionalmente
o elegir entre dos subpatrones alternativos, dependiendo del resultado
de una sentencia o si un subpatrón capturado previamente casó o no.

Las dos formas posibles de subpatrones condicionales son

(?(condition)yes-pattern)
(?(condition)yes-pattern|no-pattern)

Si la condición es satisfecha, el yes-pattern es usado; sino el no-pattern
es utilizado si existe. Si hay más de dos alternativas en el subpatrón, se
produce un error en tiempo de compilación.

Hay dos clases de condiciones. Si el texto entre los paréntesis consiste
de una secuencia de dígitos, entonces la condición es verdadera si el
subpatrón capturado de ese número ha sido casado previamente. Consideremos
el siguiente patrón, contiene espacios en blanco para hacerlo más leíble
(asumimos la opción PCRE_EXTENDED) y lo dividimos en tres partes para
facilitar la discusión:

( \( )? [^()]+ (?(1) \) )

La primera parte empareja un paréntesis opcional abierto, y si el carácter
esta presente, lo define como la primera subcadena capturada. La segunda
parte casa uno o más caracteres que no están entre paréntesis. La tercera
parte es un subpatrón condicional que examina si el primer conjunto de
paréntesis casa o no. Si fuera así, esto es, si la cadena de entrada
empieza por un paréntesis abierto, la condición es cierta, y el yes-pattern
es ejecutado y un paréntesis de cierre es requerido. De otro modo, ya que
no-pattern no esta presente, el subpatrón no casa con nada. En otras
palabras, este patrón casa una secuencia de datos sin paréntesis
opcionalmente limitada por ellos.

Si la condición no es una secuencia de dígitos, debe ser una sentencia.
Esto puede ser una sentencia de más adelante positiva o negativa o una
de punto actual. Consideremos este patrón, otra vez conteniendo espacios
en blanco sin significado y con la segunda alternativa en la siguiente línea:

(?(?=[^a-z]*[a-z])
\d{2}[a-z]{3}-\d{2} | \d{2}-\d{2}-\d{2} )

La condición es una sentencia de más adelante positiva que empareja una
secuencia opcional de cualquier cosas menos letras seguido por una letra.
En otras palabras, examina la presencia de al menos una letra en la cadena
de entrada. Si una letra es encontrada, la cadena es casada con la primera
alternativa; sino lo es con la segunda. Este patrón casa cadenas de una de
estas dos formas dd-aaa-dd o dd-dd-dd, donde aaa son letra y dd son dígitos.

COMENTARIOS

La secuencia (?# marca el inicio de un comentario el cual continua hasta
el primer paréntesis. Los paréntesis anidados no son permitidos. Los
caracteres que forman un comentario no forman parte del patrón de
emparejamiento.

Si la opción PCRE_EXTENDED es definida, un carácter # fuera de una clase
carácter crea un comentario que continua hasta la próxima línea del patrón.

RENDIMIENTO

Ciertos elementos que pueden aparecer en los patrones son más eficientes
que otros. Es más eficiente usar una clase carácter como [aeiou] que un
conjunto de alternativas tal como (a|e|i|o|u). En general, los constructores
más sencillos que dan la conducta requerida son, normalmente, más eficientes.
El libro de Jeffrey Friedl contiene un montón de discusiones sobre la
optimización de expresiones regulares para un rendimiento eficiente.

Cuando un patrón empieza con .* y la opción PCRE_DOTALL está definida, el
patrón es anclado implícitamente por PCRE, ya que sólo puede casar el inicio
de la cadena de entrada. Sin embargo, si PCRE_DOTALL no es definido, PCRE
no puede hacer esta optimización, ya que el meta carácter . no tiene porque
casar con una nueva línea y si la cadena de entrada contiene varias nuevas
líneas, el patrón puede emparejar desde el carácter inmediatamente siguiente
a uno de ellos en vez del inicio. Por ejemplo, el patrón

(.*) second

casa la cadena de entrada "first\nand second" (donde \n representa un carácter
de nueva línea) con la primera subcadena capturada empezando con "and".
En otras palabras, PCRE tiene que intentar los casamientos iniciándolos
después de cada nueva línea en la cadena de entrada.

Si estas usando un patrón con cadenas de entrada que no contienen nuevas
líneas, el mejor rendimiento se obtiene definiendo PCRE_DOTALL o iniciando
el patrón con ^.* para indicar anclamiento explícito. Esto previene a PCRE
tener que examinar toda la cadena de entrada buscando nuevas líneas para
empezar de nuevo.

Anterior | Inicio | Siguiente
Modificadores de Patrones | Subir | preg_grep


qtdom functions

Manual de PHP
Anterior Siguiente

LXXXVI. qtdom functions

Tabla de contenidos
qdom_tree — creates a tree of an xml string
qdom_error — Returns the error string from the last QDOM operation or FALSE if no errors occured

Anterior | Inicio | Siguiente
preg_split | Subir | qdom_tree


qdom_tree

(PHP 4 >= 4.0.4)

qdom_tree -- creates a tree of an xml string

Description

object qdom_tree ( string )

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
qtdom functions | Subir | qdom_error


qdom_error

(PHP 4 >= 4.0.5)

qdom_error -- Returns the error string from the last QDOM operation or FALSE if no errors occured

Description

string qdom_error ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
qdom_tree | Subir | Funciones para expresiones regulares


Funciones para expresiones regulares

Manual de PHP
Anterior Siguiente

LXXXVII. Funciones para expresiones regulares

Las expresiones regulares se usan en PHP para manipular cadenas complejas. Las funciones que soportan expresiones regulares son:

  • ereg()

  • ereg_replace()

  • eregi()

  • eregi_replace()

  • split()

En todas estas funciones, el primer argumento es una expresión regular. PHP utiliza las expresiones regulares extendidas de POSIX, definidas en POSIX 1003.2. Para una descripción completa de las expresiones regulares POSIX, ver las páginas de manual de regex incluidas en el directorio regex de la distribución de PHP. Están en formato de página de manual, por lo que se deben leer con una orden como man /usr/local/src/regex/regex.7.

Ejemplo 1. Ejemplos de expresiones regulares

ereg("abc",$string);
/* Devuelve true si "abc"
   se encuentra en $string. */

ereg("^abc",$string);
/* Devuelve true si "abc"
   se encuentra al comienzo de $string. */

ereg("abc$",$string);
/* Devuelve true si "abc"
   se encuentra al final de $string. */

eregi("(ozilla.[23]|MSIE.3)",$HTTP_USER_AGENT);
/* Devuelve true si el navegador cliente
   es Netscape 2, 3 o MSIE 3. */

ereg("([[:alnum:]]+) ([[:alnum:]]+) ([[:alnum:]]+)",
     $string,$regs);
/* Pone tres palabras separadas por espacios
   en $regs[1], $regs[2] y $regs[3]. */

$string = ereg_replace("^","<BR>",$string);
/* Coloca la etiqueta <BR> al comienzo de $string. */

$string = ereg_replace("$","<BR>",$string);
/* Coloca la etiqueta <BR> al final de $string. */

$string = ereg_replace("\n","",$string);
/* Elimina los caracteres fin-de-línea de $string. */

Tabla de contenidos
ereg — Coincidencia de expresiones regulares
ereg_replace — reemplaza expresiones regulares
eregi — coincidencia de expresiones regulares sin diferenciar mayúsculas y minúsculas
eregi_replace — reemplaza expresiones regularse sin diferenciar mayúsculas y minúsculas
split — divide la cadena en elementos de un array según una expresión regular
sql_regcase — construye una expresión regular para buscar coincidencias sin diferenciar mayúsculas y minúsculas

Anterior | Inicio | Siguiente
qdom_error | Subir | ereg


ereg

(PHP 3, PHP 4 >= 4.0.0)

ereg -- Coincidencia de expresiones regulares

Descripción

int ereg ( string pattern, string string [, array regs])

Busca en string las coincidencias con la expresión regular pattern.

Si se encuentran coincidencias con subcadenas entre paréntesis de pattern y la función se ha llamado con el tercer argumento regs, las coincidencias se almacenarán en los elementos de regs. $regs[1] contendrá la subcadena que empieza en el primer paréntesis izquierdo; $regs[2] la que comienza en el segundo, etc. $regs[0] contendrá una copia de string.

La búsqueda diferencia mayúsculas y minúsculas.

Devuelve un valor verdadero si se encontró alguna coincidencia, o falso in no se encontraron coincidencias u ocurrió algún error.

El siguiente fragmento de código toma una fecha en formato ISO (AAAA-MM-DD) y la imprime en formato DD.MM.AAAA:

Ejemplo 1. ereg() example

if ( ereg( "([0-9]{4})-([0-9]{1,2})-([0-9]{1,2})", $date, $regs ) ) {
    echo "$regs[3].$regs[2].$regs[1]";
} else {
    echo "Invalid date format: $date";
}

Ver también eregi(),
ereg_replace(), y
eregi_replace().

Anterior | Inicio | Siguiente
Funciones para expresiones regulares | Subir | ereg_replace


ereg_replace

(PHP 3, PHP 4 >= 4.0.0)

ereg_replace -- reemplaza expresiones regulares

Descripción

string ereg_replace ( string pattern, string replacement, string string)

Esta función examina string buscando coincidencias de pattern, y reemplaza el texto encontrado con replacement.

Devuelve la cadena modificada. Si no hay coincidencias que reemplazar, devuelve la cadena original.

Si pattern contiene subcadenas entre paréntesis, replacement puede contener subcadenas de la forma \\cifra, que serán reemplazadas por el texto que coincide con la subcadena entre paréntesis que ocupa el lugar indicado por la cifra; \\0 produce el contenido total de la cadena. Se pueden usar hasta nueve subcadenas. Los paréntesis pueden anidarse; en este caso se cuentan los paréntesis de apertura.

Si no se encuentran coincidencias en string, se devuelve string sin cambios.

Por ejemplo, el siguiente fragmento de código imprime "This was a test" tres veces:

Ejemplo 1. ereg_replace() example

$string = "This is a test";
echo ereg_replace( " is", " was", $string );
echo ereg_replace( "( )is", "\\1was", $string );
echo ereg_replace( "(( )is)", "\\2was", $string );

Ver también ereg(), eregi(), y eregi_replace().

Anterior | Inicio | Siguiente
ereg | Subir | eregi


eregi

(PHP 3, PHP 4 >= 4.0.0)

eregi -- coincidencia de expresiones regulares sin diferenciar mayúsculas y minúsculas

Descripción

int eregi ( string pattern, string string [, array regs])

Esta función es idéntica a ereg(), excepto en que ignora la distinción entre mayúsculas y minúsculas.

Ver también ereg(),
ereg_replace(), y
eregi_replace().

Anterior | Inicio | Siguiente
ereg_replace | Subir | eregi_replace


eregi_replace

(PHP 3, PHP 4 >= 4.0.0)

eregi_replace -- reemplaza expresiones regularse sin diferenciar mayúsculas y minúsculas

Descripción

string eregi_replace ( string pattern, string replacement, string string)

Esta función es idéntica a ereg_replace(), excepto en que ignora la distinción entre mayúsculas y minúsculas.

Ver también ereg(),
eregi(), y
ereg_replace().

Anterior | Inicio | Siguiente
eregi | Subir | split


split

(PHP 3, PHP 4 >= 4.0.0)

split -- divide la cadena en elementos de un array según una expresión regular

Descripción

array split ( string pattern, string string [, int limit])

Devuelve un array de cadenas, cada una de las cuales es una subcadena de string formada al dividir esta en los límites formados por la expresión regular pattern. Si ocurre un error, devuelve un valor falso.

Para obtener los cinco primeros campos de una línea de /etc/passwd:

Ejemplo 1. split() example

$passwd_list = split( ":", $passwd_line, 5 );

Para examinar una fecha que puede estar delimitada por barras, puntos o guiones:

Ejemplo 2. split() example

$date = "04/30/1973";  // Los delimitadores pueden ser barras, puntos o guiones
list( $month, $day, $year ) = split( '[/.-]', $date );
echo "Month: $month; Day: $day; Year: $year<br>\n";

Observar que pattern distingue entre mayúsculas y minúsculas.

Observar que si no se necesita la potencia de las expresiones regulares, es más rápido utilizar explode(), que no carga el motor de expresiones regulares.

Por favor, observar que pattern es una expresión regular. Si se quiere dividir con alguno de los caracteres especiales de las expresiones regulares, se necesita protegerlo antes. Si pareciera que split() (o cualquier otra función de regex) está haciendo algo irregular, léase el archivo regex.7, incluido en el subdirectorio regex de la distribución de PHP. Está en formato de página de manual, por lo que para leerlo es necesaria una orden como man /usr/local/src/regex/regex.7.

Ver también: explode() e implode().

Anterior | Inicio | Siguiente
eregi_replace | Subir | sql_regcase


sql_regcase

(PHP 3, PHP 4 >= 4.0.0)

sql_regcase -- construye una expresión regular para buscar coincidencias sin diferenciar mayúsculas y minúsculas

Descripción

string sql_regcase ( string string)

Devuelve una expresión regular válida que coincide con string sin distinguir mayúsculas y minúsculas. Esta expresión es string con cada carácter convertido a una expresión entre corchetes que contiene el carácter en mayúscula y minúscula, si es posible; en caso contrario, contiene el carácter original dos veces.

Ejemplo 1. sql_regcase() example

echo sql_regcase( "Foo bar" );
imprime
[Ff][Oo][Oo][  ][Bb][Aa][Rr]
.

Se puede utilizar para lograr coincidencias que no diferencien mayúsculas de minúsculas en productos que sólo soportan expresiones regulares que sí distinguen.

Anterior | Inicio | Siguiente
split | Subir | Funciones Semáforo y de memoria compartida


Funciones Semáforo y de memoria compartida

Manual de PHP
Anterior Siguiente

LXXXVIII. Funciones Semáforo y de memoria compartida

Este módulo provee funciones semáforo utilizando los semaforos de System V. Los semáforos pueden usarse para obtener acceso exclusivo a algun recurso del ordenador en cuestión, o para limitar el número de procesos que pueden usar un recurso simultaneamente.

Este módulo provee tambien funciones de memoria compartida, usando el compartimiento de memoria de System V. La memoria compartida puede usarse para proveer acceso a variables globales. Los diferentes demonios http e incluso otros programas, (como Perl, C, ...) son capaces de utilizar estos datos, para intercambiarlos de modo global. Recuerde que, la memoria compartida NO es segura para los accesos simultáneos. Use los semáforos para obtener sincronismo.

Tabla 1. Limites de la memoria compartida del SO Unix

SHMMAX | máximo tamaño de memoria compartida, normalmente 131072 bytes
SHMMIN | minimo tamaño de memoria compartida, por lo general 1 byte
SHMMNI | máxima cantidad de segmentos de memoria compartida, normalmente 100
SHMSEG | máximo de memoria compartida por proceso, normalmente 6

Tabla de contenidos
sem_acquire — adquiere un semáforo, lo toma para sí
sem_get — obtiene la identificacion de un semáforo (semaphore id)
sem_release — release a semaphore
shm_attach — Crea o abre un segmento de memoria compartida
shm_detach — Finaliza conexión con un segmento de memoria compartida
shm_get_var — Devuelve una variable de la memoria compartida
shm_put_var — Inserta o actualiza una variable en la memoria compartida
shm_remove — Elimina memoria compartida del sistma Unix
shm_remove_var — Elimina una variable de la memoria compartida

Anterior | Inicio | Siguiente
sql_regcase | Subir | sem_acquire


sem_get

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

sem_get -- obtiene la identificacion de un semáforo (semaphore id)

Descripción

int sem_get ( int key [, int max_acquire [, int perm]])

Devuelve: Un identificador positivo de semáforo en caso de éxito, o falso en caso de error.

sem_get() Devuelve un id que puede usarse para acceder al semáforo de System V con la llave dada. El semáforo se usa si es necesario usando los bits de permisos especificados en perm (por defecto 0666). El número de procesos que pueden adquirir el semáforo simultáneamente, se define en max_acquire (por defecto es 1). Actualmente este valor se fija sólo si el proceso determina que es el único relacionado actualmente al semáforo.

Una segunda llamada a sem_get() para la misma llave, devolverá un id de semáforo diferente, pero con ambos identificadoes, se accederá al mismo semáforo.

Véase también: sem_acquire() y sem_release().

Anterior | Inicio | Siguiente
sem_acquire | Subir | sem_release


sem_acquire

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

sem_acquire -- adquiere un semáforo, lo toma para sí

Descripción

int sem_acquire ( int sem_identifier)

Devuelve: Verdadero si hay éxito, falso si hay errores

sem_acquire() Produce un bloqueo (de ser necesario) hasta que el semáforo puede adquirirse. Un proceso intentando adquirir un semáforo ya adquirido, se bloqueará permanentemente si adquiriendo el semáforo, excede su valor de max_acquire.

Despues de procesar una petición, cualquier semáforo adquirido por un proceso, que no sea explícitamente liberado, será liberado automñaticamente, generando un mensaje de alerta.

Véase tambien: sem_get() and sem_release().

Anterior | Inicio | Siguiente
Funciones Semáforo y de memoria compartida | Subir | sem_get


sem_release

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

sem_release -- release a semaphore

Descripción

int sem_release ( int sem_identifier)

Returns: TRUE on success, FALSE on error

sem_release() releases the semaphore if it is currently acquired by the calling process, otherwise a warning is generated.

After releasing the semaphore, sem_acquire() may be called to re-acquire it.

Véase tambien: sem_get() y sem_acquire().

Anterior | Inicio | Siguiente
sem_get | Subir | shm_attach


shm_attach

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

shm_attach -- Crea o abre un segmento de memoria compartida

Descripción

int shm_attach ( int key [, int memsize [, int perm]])

shm_attach() devuelve un identificador que puede usarse para acceder a la memoria compartida de SystemV, con la llave dada, la primera llamada creará el segmento de memoria compartida con mem_size de tamaño (por defecto: sysvshm.init_mem en el archivo de configuración, o bien de 10000 bytes) y los bits de permiso mas apropiados (por defecto: 0666).

Una segunda llamada a shm_attach() con la misma llave devolvera un id diferente de memoria compartida, pero ambos identificadores acceden a la misma porción de memoria compartida. memsize y perm serán ignorados.

Anterior | Inicio | Siguiente
sem_release | Subir | shm_detach


shm_detach

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

shm_detach -- Finaliza conexión con un segmento de memoria compartida

Descripción

int shm_detach ( int shm_identifier)

shm_detach() finaliza la conexión con la memoria compartida, especificada por el identificador shm_identifier creado con shm_attach(). Hay que recordar que la memoria compartida aún existe en el sistema Unix, y los datos aún están presentes.

Anterior | Inicio | Siguiente
shm_attach | Subir | shm_get_var


shm_remove

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

shm_remove -- Elimina memoria compartida del sistma Unix

Descripción

int shm_remove ( int shm_identifier)

Elimina la memoria compartida de un sistema Unix, Todos los datos serán destruídos.

Anterior | Inicio | Siguiente
shm_put_var | Subir | shm_remove_var


shm_put_var

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

shm_put_var -- Inserta o actualiza una variable en la memoria compartida

Descripción

int shm_put_var ( int shm_identifier, int variable_key, mixed variable)

Inserta o actualiza una variable con una llave variable_key. Son válidos todos los tipos de variable (doble, entera, cadena, arreglo).

Anterior | Inicio | Siguiente
shm_get_var | Subir | shm_remove


shm_get_var

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

shm_get_var -- Devuelve una variable de la memoria compartida

Descripción

mixed shm_get_var ( int id, int variable_key)

shm_get_var() devuelve la variable con la llave variable_key dada. La variable, queda presente en la memoria compartida.

Anterior | Inicio | Siguiente
shm_detach | Subir | shm_put_var


shm_remove_var

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

shm_remove_var -- Elimina una variable de la memoria compartida

Descripción

int shm_remove_var ( int id, int variable_key)

Elimina la varible que se corresponde con la llave variable_key dada, liberando la memoria que ocupaba aquella.

Anterior | Inicio | Siguiente
shm_remove | Subir | SESAM database functions


SESAM database functions

Manual de PHP
Anterior Siguiente

LXXXIX. SESAM database functions

SESAM/SQL-Server is a mainframe database system, developed by Fujitsu Siemens Computers, Germany. It runs on high-end mainframe servers using the operating system BS2000/OSD.

In numerous productive BS2000 installations, SESAM/SQL-Server has proven ...

  • the ease of use of Java-, Web- and client/server connectivity,

  • the capability to work with an availability of more than 99.99%,

  • the ability to manage tens and even hundreds of thousands of users.

Now there is a PHP3 SESAM interface available which allows database operations via PHP-scripts.

Configuration notes: There is no standalone support for the PHP SESAM interface, it works only as an integrated Apache module. In the Apache PHP module, this SESAM interface is configured using Apache directives.

Tabla 1. SESAM Configuration directives

Directive Meaning
php3_sesam_oml Name of BS2000 PLAM library containing the loadable SESAM driver modules. Required for using SESAM functions.

Example:

php3_sesam_oml $.SYSLNK.SESAM-SQL.030

php3_sesam_configfile Name of SESAM application configuration file. Required for using SESAM functions.

Example:

php3_sesam_configfile $SESAM.SESAM.CONF.AW

It will usually contain a configuration like (see SESAM reference manual):

CNF=B
NAM=K
NOTYPE

php3_sesam_messagecatalog Name of SESAM message catalog file. In most cases, this directive is not neccessary. Only if the SESAM message file is not installed in the system's BS2000 message file table, it can be set with this directive.

Example:

php3_sesam_messagecatalog $.SYSMES.SESAM-SQL.030

In addition to the configuration of the PHP/SESAM interface, you have to configure the SESAM-Database server itself on your mainframe as usual. That means:

  • starting the SESAM database handler (DBH), and

  • connecting the databases with the SESAM database handler

To get a connection between a PHP script and the database handler, the CNF and NAM parameters of the selected SESAM configuration file must match the id of the started database handler.

In case of distributed databases you have to start a SESAM/SQL-DCN agent with the distribution table including the host and database names.

The communication between PHP (running in the POSIX subsystem) and the database handler (running outside the POSIX subsystem) is realized by a special driver module called SQLSCI and SESAM connection modules using common memory. Because of the common memory access, and because PHP is a static part of the web server, database accesses are very fast, as they do not require remote accesses via ODBC, JDBC or UTM.

Only a small stub loader (SESMOD) is linked with PHP, and the SESAM connection modules are pulled in from SESAM's OML PLAM library. In the configuration, you must tell PHP the name of this PLAM library, and the file link to use for the SESAM configuration file (As of SESAM V3.0, SQLSCI is available in the SESAM Tool Library, which is part of the standard distribution).

Because the SQL command quoting for single quotes uses duplicated single quotes (as opposed to a single quote preceded by a backslash, used in some other databases), it is advisable to set the PHP configuration directives php3_magic_quotes_gpc and php3_magic_quotes_sybase to On for all PHP scripts using the SESAM interface.

Runtime considerations: Because of limitations of the BS2000 process model, the driver can be loaded only after the Apache server has forked off its server child processes. This will slightly slow down the initial SESAM request of each child, but subsequent accesses will respond at full speed.

When explicitly defining a Message Catalog for SESAM, that catalog will be loaded each time the driver is loaded (i.e., at the initial SESAM request). The BS2000 operating system prints a message after successful load of the message catalog, which will be sent to Apache's error_log file. BS2000 currently does not allow suppression of this message, it will slowly fill up the log.

Make sure that the SESAM OML PLAM library and SESAM configuration file are readable by the user id running the web server. Otherwise, the server will be unable to load the driver, and will not allow to call any SESAM functions. Also, access to the database must be granted to the user id under which the Apache server is running. Otherwise, connections to the SESAM database handler will fail.

Cursor Types: The result cursors which are allocated for SQL "select type" queries can be either "sequential" or "scrollable". Because of the larger memory overhead needed by "scrollable" cursors, the default is "sequential".

When using "scrollable" cursors, the cursor can be freely positioned on the result set. For each "scrollable" query, there are global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT) and the scrolling offset which can either be set once by sesam_seek_row() or each time when fetching a row using sesam_fetch_row(). When fetching a row using a "scrollable" cursor, the following post-processing is done for the global default values for the scrolling type and scrolling offset:

Tabla 2. Scrolled Cursor Post-Processing

Scroll Type | Action
SESAM_SEEK_NEXT | none
SESAM_SEEK_PRIOR | none
SESAM_SEEK_FIRST | set scroll type to SESAM_SEEK_NEXT
SESAM_SEEK_LAST | set scroll type to SESAM_SEEK_PRIOR
SESAM_SEEK_ABSOLUTE | Auto-Increment internal offset value
SESAM_SEEK_RELATIVE | none. (maintain global default offset value, which allows for, e.g., fetching each 10th row backwards)

Porting note: Because in the PHP world it is natural to start indexes at zero (rather than 1), some adaptions have been made to the SESAM interface: whenever an indexed array is starting with index 1 in the native SESAM interface, the PHP interface uses index 0 as a starting point. E.g., when retrieving columns with sesam_fetch_row(), the first column has the index 0, and the subsequent columns have indexes up to (but not including) the column count ($array["count"]). When porting SESAM applications from other high level languages to PHP, be aware of this changed interface. Where appropriate, the description of the respective php sesam functions include a note that the index is zero based.

Security concerns: When allowing access to the SESAM databases, the web server user should only have as little privileges as possible. For most databases, only read access privilege should be granted. Depending on your usage scenario, add more access rights as you see fit. Never allow full control to any database for any user from the 'net! Restrict access to php scripts which must administer the database by using password control and/or SSL security.

Migration from other SQL databases: No two SQL dialects are ever 100% compatible. When porting SQL applications from other database interfaces to SESAM, some adaption may be required. The following typical differences should be noted:

  • Vendor specific data types

    Some vendor specific data types may have to be replaced by standard SQL data types (e.g., TEXT could be replaced by VARCHAR(max. size)).

  • Keywords as SQL identifiers

    In SESAM (as in standard SQL), such identifiers must be enclosed in double quotes (or renamed).

  • Display length in data types

    SESAM data types have a precision, not a display length. Instead of int(4) (intended use: integers up to '9999'), SESAM requires simply int for an implied size of 31 bits. Also, the only datetime data types available in SESAM are: DATE, TIME(3) and TIMESTAMP(3).

  • SQL types with vendor-specific unsigned, zerofill, or auto_increment attributes

    Unsigned and zerofill are not supported. Auto_increment is automatic (use "INSERT ... VALUES(*, ...)" instead of "... VALUES(0, ...)" to take advantage of SESAM-implied auto-increment.

  • int ... DEFAULT '0000'

    Numeric variables must not be initialized with string constants. Use DEFAULT 0 instead. To initialize variables of the datetime SQL data types, the initialization string must be prefixed with the respective type keyword, as in: CREATE TABLE exmpl ( xtime timestamp(3) DEFAULT TIMESTAMP '1970-01-01 00:00:00.000' NOT NULL );

  • $count = xxxx_num_rows();

    Some databases promise to guess/estimate the number of the rows in a query result, even though the returned value is grossly incorrect. SESAM does not know the number of rows in a query result before actually fetching them. If you REALLY need the count, try SELECT COUNT(...) WHERE ..., it will tell you the number of hits. A second query will (hopefully) return the results.

  • DROP TABLE thename;

    In SESAM, in the DROP TABLE command, the table name must be either followed by the keyword RESTRICT or CASCADE. When specifying RESTRICT, an error is returned if there are dependent objects (e.g., VIEWs), while with CASCADE, dependent objects will be deleted along with the specified table.

Notes on the use of various SQL types: SESAM does not currently support the BLOB type. A future version of SESAM will have support for BLOB.

At the PHP interface, the following type conversions are automatically applied when retrieving SQL fields:

Tabla 3. SQL to PHP Type Conversions

SQL Type | PHP Type
SMALLINT, INTEGER | "integer"
NUMERIC, DECIMAL, FLOAT, REAL, DOUBLE | "double"
DATE, TIME, TIMESTAMP | "string"
VARCHAR, CHARACTER | "string"
When retrieving a complete row, the result is returned as an array. Empty fields are not filled in, so you will have to check for the existence of the individual fields yourself (use isset() or empty() to test for empty fields). That allows more user control over the appearance of empty fields (than in the case of an empty string as the representation of an empty field).

Support of SESAM's "multiple fields" feature: The special "multiple fields" feature of SESAM allows a column to consist of an array of fields. Such a "multiple field" column can be created like this:

Ejemplo 1. Creating a "multiple field" column

CREATE TABLE multi_field_test (
    pkey CHAR(20) PRIMARY KEY,
    multi(3) CHAR(12)
)
and can be filled in using:

Ejemplo 2. Filling a "multiple field" column

INSERT INTO multi_field_test (pkey, multi(2..3) )
    VALUES ('Second', <'first_val', 'second_val'>)
Note that (like in this case) leading empty sub-fields are ignored, and the filled-in values are collapsed, so that in the above example the result will appear as multi(1..2) instead of multi(2..3).

When retrieving a result row, "multiple columns" are accessed like "inlined" additional columns. In the example above, "pkey" will have the index 0, and the three "multi(1..3)" columns will be accessible as indices 1 through 3.

For specific SESAM details, please refer to the SESAM/SQL-Server documentation (english) or the SESAM/SQL-Server documentation (german), both available online, or use the respective manuals.

Tabla de contenidos
sesam_affected_rows — Get number of rows affected by an immediate query
sesam_commit — Commit pending updates to the SESAM database
sesam_connect — Open SESAM database connection
sesam_diagnostic — Return status information for last SESAM call
sesam_disconnect — Detach from SESAM connection
sesam_errormsg — Returns error message of last SESAM call
sesam_execimm — Execute an "immediate" SQL-statement
sesam_fetch_array — Fetch one row as an associative array
sesam_fetch_result — Return all or part of a query result
sesam_fetch_row — Fetch one row as an array
sesam_field_array — Return meta information about individual columns in a result
sesam_field_name — Return one column name of the result set
sesam_free_result — Releases resources for the query
sesam_num_fields — Return the number of fields/columns in a result set
sesam_query — Perform a SESAM SQL query and prepare the result
sesam_rollback — Discard any pending updates to the SESAM database
sesam_seek_row — Set scrollable cursor mode for subsequent fetches
sesam_settransaction — Set SESAM transaction parameters

Anterior | Inicio | Siguiente
shm_remove_var | Subir | sesam_affected_rows


sesam_connect

(PHP 3 CVS only)

sesam_connect -- Open SESAM database connection

Description

bool sesam_connect ( string catalog, string schema, string user)

Returns TRUE if a connection to the SESAM database was made, or FALSE on error.

sesam_connect() establishes a connection to an SESAM database handler task. The connection is always "persistant" in the sense that only the very first invocation will actually load the driver from the configured SESAM OML PLAM library. Subsequent calls will reuse the driver and will immediately use the given catalog, schema, and user.

When creating a database, the "catalog" name is specified in the SESAM configuration directive //ADD-SQL-DATABASE-CATALOG-LIST ENTRY-1 = *CATALOG(CATALOG-NAME = catalogname,...)

The "schema" references the desired database schema (see SESAM handbook).

The "user" argument references one of the users which are allowed to access this "catalog" / "schema" combination. Note that "user" is completely independent from both the system's user id's and from HTTP user/password protection. It appears in the SESAM configuration only.

See also sesam_disconnect().

Ejemplo 1. Connect to a SESAM database

<?php
if (!sesam_connect ("mycatalog", "myschema", "otto")
    die("Unable to connect to SESAM";
?>

Anterior | Inicio | Siguiente
sesam_commit | Subir | sesam_diagnostic


sesam_disconnect

(PHP 3 CVS only)

sesam_disconnect -- Detach from SESAM connection

Description

bool sesam_disconnect ( void)

Returns: always TRUE.

sesam_disconnect() closes the logical link to a SESAM database (without actually disconnecting and unloading the driver).

Note that this isn't usually necessary, as the open connection is automatically closed at the end of the script's execution. Uncommitted data will be discarded, because an implicit sesam_rollback() is executed.

sesam_disconnect() will not close the persistent link, it will only invalidate the currently defined "catalog", "schema" and "user" triple, so that any sesam function called after sesam_disconnect() will fail.

See also: sesam_connect().

Ejemplo 1. Closing a SESAM connection

if (sesam_connect ("mycatalog", "myschema", "otto")) {
    ... some queries and stuff ...
    sesam_disconnect();
}

Anterior | Inicio | Siguiente
sesam_diagnostic | Subir | sesam_errormsg


sesam_settransaction

(PHP 3 CVS only)

sesam_settransaction -- Set SESAM transaction parameters

Description

bool sesam_settransaction ( int isolation_level, int read_only)

Returns: TRUE if the values are valid, and the settransaction() operation was successful, FALSE otherwise.

sesam_settransaction() overrides the default values for the "isolation level" and "read-only" transaction parameters (which are set in the SESAM configuration file), in order to optimize subsequent queries and guarantee database consistency. The overridden values are used for the next transaction only.

sesam_settransaction() can only be called before starting a transaction, not after the transaction has been started already.

To simplify the use in php scripts, the following constants have been predefined in php (see SESAM handbook for detailed explanation of the semantics):

Tabla 1. Valid values for "Isolation_Level" parameter

Value | Constant | Meaning
1 | SESAM_TXISOL_READ_UNCOMMITTED | Read Uncommitted
2 | SESAM_TXISOL_READ_COMMITTED | Read Committed
3 | SESAM_TXISOL_REPEATABLE_READ | Repeatable Read
4 | SESAM_TXISOL_SERIALIZABLE | Serializable

Tabla 2. Valid values for "Read_Only" parameter

Value | Constant | Meaning
0 | SESAM_TXREAD_READWRITE | Read/Write
1 | SESAM_TXREAD_READONLY | Read-Only

The values set by sesam_settransaction() will override the default setting specified in the SESAM configuration file.

Ejemplo 1. Setting SESAM transaction parameters

<?php
sesam_settransaction (SESAM_TXISOL_REPEATABLE_READ,
                     SESAM_TXREAD_READONLY);
?>

Anterior | Inicio | Siguiente
sesam_seek_row | Subir | Session handling functions


sesam_commit

(PHP 3 CVS only)

sesam_commit -- Commit pending updates to the SESAM database

Description

bool sesam_commit ( void)

Returns: TRUE on success, FALSE on errors

sesam_commit() commits any pending updates to the database.

Note that there is no "auto-commit" feature as in other databases, as it could lead to accidental data loss. Uncommitted data at the end of the current script (or when calling sesam_disconnect()) will be discarded by an implied sesam_rollback() call.

See also: sesam_rollback().

Ejemplo 1. Committing an update to the SESAM database

<?php
if (sesam_connect ("mycatalog", "myschema", "otto")) {
    if (!sesam_execimm ("INSERT INTO mytable VALUES (*, 'Small Test', <0, 8, 15>)"))
        die("insert failed");
    if (!sesam_commit())
        die("commit failed");
}
?>

Anterior | Inicio | Siguiente
sesam_affected_rows | Subir | sesam_connect


sesam_rollback

(PHP 3 CVS only)

sesam_rollback -- Discard any pending updates to the SESAM database

Description

bool sesam_rollback ( void)

Returns: TRUE on success, FALSE on errors

sesam_rollback() discards any pending updates to the database. Also affected are result cursors and result descriptors.

At the end of each script, and as part of the sesam_disconnect() function, an implied sesam_rollback() is executed, discarding any pending changes to the database.

See also: sesam_commit().

Ejemplo 1. Discarding an update to the SESAM database

<?php
if (sesam_connect ("mycatalog", "myschema", "otto")) {
    if (sesam_execimm ("INSERT INTO mytable VALUES (*, 'Small Test', <0, 8, 15>)")
        && sesam_execimm ("INSERT INTO othertable VALUES (*, 'Another Test', 1)"))
        sesam_commit();
    else
        sesam_rollback();
}
?>

Anterior | Inicio | Siguiente
sesam_query | Subir | sesam_seek_row


sesam_execimm

(PHP 3 CVS only)

sesam_execimm -- Execute an "immediate" SQL-statement

Description

string sesam_execimm ( string query)

Returns: A SESAM "result identifier" on success, or FALSE on error.

sesam_execimm() executes an "immediate" statement (i.e., a statement like UPDATE, INSERT or DELETE which returns no result, and has no INPUT or OUTPUT variables). "select type" queries can not be used with sesam_execimm(). Sets the affected_rows value for retrieval by the sesam_affected_rows() function.

Note that sesam_query() can handle both "immediate" and "select-type" queries. Use sesam_execimm() only if you know beforehand what type of statement will be executed. An attempt to use SELECT type queries with sesam_execimm() will return $err["sqlstate"] == "42SBW".

The returned "result identifier" can not be used for retrieving anything but the sesam_affected_rows(); it is only returned for symmetry with the sesam_query() function.

$stmt = "INSERT INTO mytable VALUES ('one', 'two')";
$result = sesam_execimm ($stmt);
$err = sesam_diagnostic();
print ("sqlstate = ".$err["sqlstate"]."\n".
       "Affected rows = ".$err["rowcount"]." == ".
       sesam_affected_rows($result)."\n");

See also: sesam_query() and sesam_affected_rows().

Anterior | Inicio | Siguiente
sesam_errormsg | Subir | sesam_fetch_array


sesam_query

(PHP 3 CVS only)

sesam_query -- Perform a SESAM SQL query and prepare the result

Description

string sesam_query ( string query [, bool scrollable])

Returns: A SESAM "result identifier" on success, or FALSE on error.

A "result_id" resource is used by other functions to retrieve the query results.

sesam_query() sends a query to the currently active database on the server. It can execute both "immediate" SQL statements and "select type" queries. If an "immediate" statement is executed, then no cursor is allocated, and any subsequent sesam_fetch_row() or sesam_fetch_result() call will return an empty result (zero columns, indicating end-of-result). For "select type" statements, a result descriptor and a (scrollable or sequential, depending on the optional boolean scrollable parameter) cursor will be allocated. If scrollable is omitted, the cursor will be sequential.

When using "scrollable" cursors, the cursor can be freely positioned on the result set. For each "scrollable" query, there are global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT) and the scrolling offset which can either be set once by sesam_seek_row() or each time when fetching a row using sesam_fetch_row().

For "immediate" statements, the number of affected rows is saved for retrieval by the sesam_affected_rows() function.

See also: sesam_fetch_row() and sesam_fetch_result().

Ejemplo 1. Show all rows of the "phone" table as a html table

<?php
if (!sesam_connect ("phonedb", "demo", "otto"))
    die ("cannot connect");
$result = sesam_query ("select * from phone");
if (!$result) {
    $err = sesam_diagnostic();
    die ($err["errmsg"]);
}
echo "<TABLE BORDER>\n";
// Add title header with column names above the result:
if ($cols = sesam_field_array ($result)) {
    echo " <TR><TH COLSPAN=".$cols["count"].">Result:</TH></TR>\n";
    echo " <TR>\n";
    for ($col = 0; $col < $cols["count"]; ++$col) {
        $colattr = $cols[$col];
        /* Span the table head over SESAM's "Multiple Fields": */
        if ($colattr["count"] > 1) {
            echo "  <TH COLSPAN=".$colattr["count"].">".$colattr["name"].
                "(1..".$colattr["count"].")</TH>\n";
            $col += $colattr["count"] - 1;
        } else
            echo "  <TH>" . $colattr["name"] . "</TH>\n";
    }
    echo " </TR>\n";
}

do {
    // Fetch the result in chunks of 100 rows max.
    $ok = sesam_fetch_result ($result, 100);
    for ($row=0; $row < $ok["rows"]; ++$row) {
        echo " <TR>\n";
        for ($col = 0; $col < $ok["cols"]; ++$col) {
            if (isset($ok[$col][$row]))
                echo "  <TD>" . $ok[$col][$row] . "</TD>\n";
            } else {
                echo "  <TD>-empty-</TD>\n";
            }
        }
        echo " </TR>\n";
    }
}
while ($ok["truncated"]) { // while there may be more data
    echo "</TABLE>\n";
}
// free result id
sesam_free_result($result);
?>

Anterior | Inicio | Siguiente
sesam_num_fields | Subir | sesam_rollback


sesam_num_fields

(PHP 3 CVS only)

sesam_num_fields -- Return the number of fields/columns in a result set

Description

int sesam_num_fields ( string result_id)

After calling sesam_query() with a "select type" query, this function gives you the number of columns in the result. Returns an integer describing the total number of columns (aka. fields) in the current result_id result set or FALSE on error.

For "immediate" statements, the value zero is returned. The SESAM "multiple field" columns count as their respective dimension, i.e., a three-column "multiple field" counts as three columns.

See also: sesam_query() and sesam_field_array() for a way to distinguish between "multiple field" columns and regular columns.

Anterior | Inicio | Siguiente
sesam_free_result | Subir | sesam_query


sesam_field_name

(PHP 3 CVS only)

sesam_field_name -- Return one column name of the result set

Description

int sesam_field_name ( string result_id, int index)

Returns the name of a field (i.e., the column name) in the result set, or FALSE on error.

For "immediate" queries, or for dynamic columns, an empty string is returned.

Nota: The column index is zero-based, not one-based as in SESAM.

See also: sesam_field_array(). It provides an easier interface to access the column names and types, and allows for detection of "multiple fields".

Anterior | Inicio | Siguiente
sesam_field_array | Subir | sesam_free_result


sesam_diagnostic

(PHP 3 CVS only)

sesam_diagnostic -- Return status information for last SESAM call

Description

array sesam_diagnostic ( void)

Returns an associative array of status and return codes for the last SQL query/statement/command. Elements of the array are:

Tabla 1. Status information returned by sesam_diagnostic()

Element | Contents
$array["sqlstate"] | 5 digit SQL return code (see the SESAM manual for the description of the possible values of SQLSTATE)
$array["rowcount"] | number of affected rows in last update/insert/delete (set after "immediate" statements only)
$array["errmsg"] | "human readable" error message string (set after errors only)
$array["errcol"] | error column number of previous error (0-based; or -1 if undefined. Set after errors only)
$array["errlin"] | error line number of previous error (0-based; or -1 if undefined. Set after errors only)

In the following example, a syntax error (E SEW42AE ILLEGAL CHARACTER) is displayed by including the offending SQL statement and pointing to the error location:

Ejemplo 1. Displaying SESAM error messages with error position

<?php
// Function which prints a formatted error message,
// displaying a pointer to the syntax error in the
// SQL statement
function PrintReturncode ($exec_str) {
    $err = Sesam_Diagnostic();
    $colspan=4; // 4 cols for: sqlstate, errlin, errcol, rowcount
    if ($err["errlin"] == -1)
        --$colspan;
    if ($err["errcol"] == -1)
        --$colspan;
    if ($err["rowcount"] == 0)
        --$colspan;
    echo "<TABLE BORDER>\n";
    echo "<TR><TH COLSPAN=".$colspan."><FONT COLOR=red>ERROR:</FONT> ".
          htmlspecialchars($err["errmsg"])."</TH></TR>\n";
    if ($err["errcol"] >= 0) {
        echo "<TR><TD COLSPAN=".$colspan."><PRE>\n";
        $errstmt = $exec_str."\n";
        for ($lin=0; $errstmt != ""; ++$lin) {
            if ($lin != $err["errlin"]) { // $lin is less or greater than errlin
                if (!($i = strchr ($errstmt, "\n")))
                    $i = "";
                $line = substr ($errstmt, 0, strlen($errstmt)-strlen($i)+1);
                $errstmt = substr($i, 1);
                if ($line != "\n")
                    print htmlspecialchars ($line);
            } else {
                if (! ($i = strchr ($errstmt, "\n")))
                    $i = "";
                $line = substr ($errstmt, 0, strlen ($errstmt)-strlen($i)+1);
                $errstmt = substr($i, 1);
                for ($col=0; $col < $err["errcol"]; ++$col)
                    echo (substr($line, $col, 1) == "\t") ? "\t" : ".";
                echo "<FONT COLOR=RED><BLINK>\\</BLINK></FONT>\n";
                print "<FONT COLOR=\"#880000\">".htmlspecialchars($line)."</FONT>";
                for ($col=0; $col < $err["errcol"]; ++$col)
                    echo (substr ($line, $col, 1) == "\t") ? "\t" : ".";
                echo "<FONT COLOR=RED><BLINK>/</BLINK></FONT>\n";
            }
        }
        echo "</PRE></TD></TR>\n";
    }
    echo "<TR>\n";
    echo " <TD>sqlstate=" . $err["sqlstate"] . "</TD>\n";
    if ($err["errlin"] != -1)
        echo " <TD>errlin=" . $err["errlin"] . "</TD>\n";
    if ($err["errcol"] != -1)
        echo " <TD>errcol=" . $err["errcol"] . "</TD>\n";
    if ($err["rowcount"] != 0)
         echo " <TD>rowcount=" . $err["rowcount"] . "</TD>\n";
    echo "</TR>\n";
    echo "</TABLE>\n";
}

if (!sesam_connect ("mycatalog", "phoneno", "otto"))
  die ("cannot connect");

$stmt = "SELECT * FROM phone\n".
        " WHERE@ LASTNAME='KRAEMER'\n".
        " ORDER BY FIRSTNAME";
if (!($result = sesam_query ($stmt)))
    PrintReturncode ($stmt);
?>

See also: sesam_errormsg() for simple access to the error string only

Anterior | Inicio | Siguiente
sesam_connect | Subir | sesam_disconnect


sesam_fetch_result

(PHP 3 CVS only)

sesam_fetch_result -- Return all or part of a query result

Description

mixed sesam_fetch_result ( string result_id [, int max_rows])

Returns a mixed array with the query result entries, optionally limited to a maximum of max_rows rows. Note that both row and column indexes are zero-based.

Tabla 1. Mixed result set returned by sesam_fetch_result()

Array Element | Contents
int $arr["count"] | number of columns in result set (or zero if this was an "immediate" query)
int $arr["rows"] | number of rows in result set (between zero and max_rows)
bool $arr["truncated"] | TRUE if the number of rows was at least max_rows, FALSE otherwise. Note that even when this is TRUE, the next sesam_fetch_result() call may return zero rows because there are no more result entries.
mixed $arr[col][row] | result data for all the fields at row(row) and column(col), (where the integer index row is between 0 and $arr["rows"]-1, and col is between 0 and $arr["count"]-1). Fields may be empty, so you must check for the existence of a field by using the php isset() function. The type of the returned fields depend on the respective SQL type declared for its column (see SESAM overview for the conversions applied). SESAM "multiple fields" are "inlined" and treated like a sequence of columns.
Note that the amount of memory used up by a large query may be gigantic. Use the max_rows parameter to limit the maximum number of rows returned, unless you are absolutely sure that your result will not use up all available memory.

See also: sesam_fetch_row(), and sesam_field_array() to check for "multiple fields". See the description of the sesam_query() function for a complete example using sesam_fetch_result().

Anterior | Inicio | Siguiente
sesam_fetch_array | Subir | sesam_fetch_row


sesam_affected_rows

(PHP 3 CVS only)

sesam_affected_rows -- Get number of rows affected by an immediate query

Description

int sesam_affected_rows ( string result_id)

result_id is a valid result id returned by sesam_query().

Returns the number of rows affected by a query associated with result_id.

The sesam_affected_rows() function can only return useful values when used in combination with "immediate" SQL statements (updating operations like INSERT, UPDATE and DELETE) because SESAM does not deliver any "affected rows" information for "select type" queries. The number returned is the number of affected rows.

See also: sesam_query() and sesam_execimm()

$result = sesam_execimm ("DELETE FROM PHONE WHERE LASTNAME = '".strtoupper ($name)."'");
if (!$result) {
    ... error ...
}
print sesam_affected_rows ($result).
    " entries with last name ".$name." deleted.\n"

Anterior | Inicio | Siguiente
SESAM database functions | Subir | sesam_commit


sesam_errormsg

(PHP 3 CVS only)

sesam_errormsg -- Returns error message of last SESAM call

Description

string sesam_errormsg ( void)

Returns the SESAM error message associated with the most recent SESAM error.

if (!sesam_execimm ($stmt))
  printf ("%s<br>\n", sesam_errormsg());

See also: sesam_diagnostic() for the full set of SESAM SQL status information

Anterior | Inicio | Siguiente
sesam_disconnect | Subir | sesam_execimm


sesam_field_array

(PHP 3 CVS only)

sesam_field_array -- Return meta information about individual columns in a result

Description

array sesam_field_array ( string result_id)

result_id is a valid result id returned by sesam_query().

Returns a mixed associative/indexed array with meta information (column name, type, precision, ...) about individual columns of the result after the query associated with result_id.

Tabla 1. Mixed result set returned by sesam_field_array()

Array Element | Contents
int $arr["count"] | Total number of columns in result set (or zero if this was an "immediate" query). SESAM "multiple fields" are "inlined" and treated like the respective number of columns.
string $arr[col]["name"] | column name for column(col), where col is between 0 and $arr["count"]-1. The returned value can be the empty string (for dynamically computed columns). SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same column name.
string $arr[col]["count"] | The "count" attribute describes the repetition factor when the column has been declared as a "multiple field". Usually, the "count" attribute is 1. The first column of a "multiple field" column however contains the number of repetitions (the second and following column of the "multiple field" contain a "count" attribute of 1). This can be used to detect "multiple fields" in the result set. See the example shown in the sesam_query() description for a sample use of the "count" attribute.
string $arr[col]["type"] php variable type of the data for column(col), where col is between 0 and $arr["count"]-1. The returned value can be one of

  • "integer"

  • "double"

  • "string"

depending on the SQL type of the result. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same php type.
string $arr[col]["sqltype"] SQL variable type of the column data for column(col), where col is between 0 and $arr["count"]-1. The returned value can be one of

  • "CHARACTER"

  • "VARCHAR"

  • "NUMERIC"

  • "DECIMAL"

  • "INTEGER"

  • "SMALLINT"

  • "FLOAT"

  • "REAL"

  • "DOUBLE"

  • "DATE"

  • "TIME"

  • "TIMESTAMP"

describing the SQL type of the result. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same SQL type.
string $arr[col]["length"] | The SQL "length" attribute of the SQL variable in column(col), where col is between 0 and $arr["count"]-1. The "length" attribute is used with "CHARACTER" and "VARCHAR" SQL types to specify the (maximum) length of the string variable. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same length attribute.
string $arr[col]["precision"] | The "precision" attribute of the SQL variable in column(col), where col is between 0 and $arr["count"]-1. The "precision" attribute is used with numeric and time data types. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same precision attribute.
string $arr[col]["scale"] | The "scale" attribute of the SQL variable in column(col), where col is between 0 and $arr["count"]-1. The "scale" attribute is used with numeric data types. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same scale attribute.

See the sesam_query() function for an example of the sesam_field_array() use.

Anterior | Inicio | Siguiente
sesam_fetch_row | Subir | sesam_field_name


sesam_fetch_row

(PHP 3 CVS only)

sesam_fetch_row -- Fetch one row as an array

Description

array sesam_fetch_row ( string result_id [, int whence [, int offset]])

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

The number of columns in the result set is returned in an associative array element $array["count"]. Because some of the result columns may be empty, the count() function can not be used on the result row returned by sesam_fetch_row().

result_id is a valid result id returned by sesam_query() (select type queries only!).

whence is an optional parameter for a fetch operation on "scrollable" cursors, which can be set to the following predefined constants:

Tabla 1. Valid values for "whence" parameter

Value | Constant | Meaning
0 | SESAM_SEEK_NEXT | read sequentially (after fetch, the internal default is set to SESAM_SEEK_NEXT)
1 | SESAM_SEEK_PRIOR | read sequentially backwards (after fetch, the internal default is set to SESAM_SEEK_PRIOR)
2 | SESAM_SEEK_FIRST | rewind to first row (after fetch, the default is set to SESAM_SEEK_NEXT)
3 | SESAM_SEEK_LAST | seek to last row (after fetch, the default is set to SESAM_SEEK_PRIOR)
4 | SESAM_SEEK_ABSOLUTE | seek to absolute row number given as offset (Zero-based. After fetch, the internal default is set to SESAM_SEEK_ABSOLUTE, and the internal offset value is auto-incremented)
5 | SESAM_SEEK_RELATIVE | seek relative to current scroll position, where offset can be a positive or negative offset value.
This parameter is only valid for "scrollable" cursors.

When using "scrollable" cursors, the cursor can be freely positioned on the result set. If the whence parameter is omitted, the global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT, and settable by sesam_seek_row()) are used. If whence is supplied, its value replaces the global default.

offset is an optional parameter which is only evaluated (and required) if whence is either SESAM_SEEK_RELATIVE or SESAM_SEEK_ABSOLUTE. This parameter is only valid for "scrollable" cursors.

sesam_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array (indexed by values between 0 and $array["count"]-1). Fields may be empty, so you must check for the existence of a field by using the php isset() function. The type of the returned fields depend on the respective SQL type declared for its column (see SESAM overview for the conversions applied). SESAM "multiple fields" are "inlined" and treated like a sequence of columns.

Subsequent calls to sesam_fetch_row() would return the next (or prior, or n'th next/prior, depending on the scroll attributes) row in the result set, or FALSE if there are no more rows.

Ejemplo 1. SESAM fetch rows

<?php
$result = sesam_query ("SELECT * FROM phone\n".
                       "  WHERE LASTNAME='".strtoupper($name)."'\n".
                       "  ORDER BY FIRSTNAME", 1);
if (!$result) {
    ... error ...
}
// print the table in backward order
print "<TABLE BORDER>\n";
$row = sesam_fetch_row ($result, SESAM_SEEK_LAST);
while (is_array ($row)) {
    print " <TR>\n";
    for ($col = 0; $col < $row["count"]; ++$col) {
        print "  <TD>".htmlspecialchars ($row[$col])."</TD>\n";
    }
    print " </TR>\n";
    // use implied SESAM_SEEK_PRIOR
    $row = sesam_fetch_row ($result);
}
print "</TABLE>\n";
sesam_free_result ($result);
?>

See also: sesam_fetch_array() which returns an associative array, and sesam_fetch_result() which returns many rows per invocation.

Anterior | Inicio | Siguiente
sesam_fetch_result | Subir | sesam_field_array


sesam_fetch_array

(PHP 3 CVS only)

sesam_fetch_array -- Fetch one row as an associative array

Description

array sesam_fetch_array ( string result_id [, int whence [, int offset]])

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

sesam_fetch_array() is an alternative version of sesam_fetch_row(). Instead of storing the data in the numeric indices of the result array, it stores the data in associative indices, using the field names as keys.

result_id is a valid result id returned by sesam_query() (select type queries only!).

For the valid values of the optional whenceand offset parameters, see the sesam_fetch_row() function for details.

sesam_fetch_array() fetches one row of data from the result associated with the specified result identifier. The row is returned as an associative array. Each result column is stored with an associative index equal to its column (aka. field) name. The column names are converted to lower case.

Columns without a field name (e.g., results of arithmetic operations) and empty fields are not stored in the array. Also, if two or more columns of the result have the same column names, the later column will take precedence. In this situation, either call sesam_fetch_row() or make an alias for the column.

SELECT TBL1.COL AS FOO, TBL2.COL AS BAR FROM TBL1, TBL2

A special handling allows fetching "multiple field" columns (which would otherwise all have the same column names). For each column of a "multiple field", the index name is constructed by appending the string "(n)" where n is the sub-index of the multiple field column, ranging from 1 to its declared repetition factor. The indices are NOT zero based, in order to match the nomenclature used in the respective query syntax. For a column declared as:

CREATE TABLE ... ( ... MULTI(3) INT )

the associative indices used for the individual "multiple field" columns would be "multi(1)", "multi(2)", and "multi(3)" respectively.

Subsequent calls to sesam_fetch_array() would return the next (or prior, or n'th next/prior, depending on the scroll attributes) row in the result set, or FALSE if there are no more rows.

Ejemplo 1. SESAM fetch array

<?php
$result = sesam_query ("SELECT * FROM phone\n".
                       "  WHERE LASTNAME='".strtoupper($name)."'\n".
                       "  ORDER BY FIRSTNAME", 1);
if (!$result) {
    ... error ...
}
// print the table:
print "<TABLE BORDER>\n";
while (($row = sesam_fetch_array ($result)) && count ($row) > 0) {
    print " <TR>\n";
    print " <TD>".htmlspecialchars ($row["firstname"])."</TD>\n";
    print " <TD>".htmlspecialchars ($row["lastname"])."</TD>\n";
    print " <TD>".htmlspecialchars ($row["phoneno"])."</TD>\n";
    print " </TR>\n";
}
print "</TABLE>\n";
sesam_free_result ($result);
?>

See also: sesam_fetch_row() which returns an indexed array.

Anterior | Inicio | Siguiente
sesam_execimm | Subir | sesam_fetch_result


sesam_seek_row

(PHP 3 CVS only)

sesam_seek_row -- Set scrollable cursor mode for subsequent fetches

Description

bool sesam_seek_row ( string result_id, int whence [, int offset])

result_id is a valid result id (select type queries only, and only if a "scrollable" cursor was requested when calling sesam_query()).

whence sets the global default value for the scrolling type, it specifies the scroll type to use in subsequent fetch operations on "scrollable" cursors, which can be set to the following predefined constants:

Tabla 1. Valid values for "whence" parameter

Value | Constant | Meaning
0 | SESAM_SEEK_NEXT | read sequentially
1 | SESAM_SEEK_PRIOR | read sequentially backwards
2 | SESAM_SEEK_FIRST | fetch first row (after fetch, the default is set to SESAM_SEEK_NEXT)
3 | SESAM_SEEK_LAST | fetch last row (after fetch, the default is set to SESAM_SEEK_PRIOR)
4 | SESAM_SEEK_ABSOLUTE | fetch absolute row number given as offset (Zero-based. After fetch, the default is set to SESAM_SEEK_ABSOLUTE, and the offset value is auto-incremented)
5 | SESAM_SEEK_RELATIVE | fetch relative to current scroll position, where offset can be a positive or negative offset value (this also sets the default "offset" value for subsequent fetches).

offset is an optional parameter which is only evaluated (and required) if whence is either SESAM_SEEK_RELATIVE or SESAM_SEEK_ABSOLUTE.

Anterior | Inicio | Siguiente
sesam_rollback | Subir | sesam_settransaction


sesam_free_result

(PHP 3 CVS only)

sesam_free_result -- Releases resources for the query

Description

int sesam_free_result ( string result_id)

Releases resources for the query associated with result_id. Returns FALSE on error.

Anterior | Inicio | Siguiente
sesam_field_name | Subir | sesam_num_fields


Session handling functions

Manual de PHP
Anterior Siguiente

XC. Session handling functions

Session support in PHP consists of a way to preserve certain data across subsequent accesses. This enables you to build more customized applications and increase the appeal of your web site.

If you are familiar with the session management of PHPLIB, you will notice that some concepts are similar to PHP's session support.

A visitor accessing your web site is assigned an unique id, the so-called session id. This is either stored in a cookie on the user side or is propagated in the URL.

The session support allows you to register arbitrary numbers of variables to be preserved across requests. When a visitor accesses your site, PHP will check automatically (if session.auto_start is set to 1) or on your request (explicitly through session_start() or implicitly through session_register()) whether a specific session id has been sent with the request. If this is the case, the prior saved environment is recreated.

All registered variables are serialized after the request finishes. Registered variables which are undefined are marked as being not defined. On subsequent accesses, these are not defined by the session module unless the user defines them later.

The track_vars and register_globals configuration settings influence how the session variables get stored and restored.

Nota: As of PHP 4.0.3, track_vars is always turned on.

Nota: As of PHP 4.1.0, $_SESSION is available as global variable just like $_POST, $_GET, $_REQUEST and so on. Not like $HTTP_SESSION_VARS, $_SESSION is always global. Therefore, global should not be used for $_SESSION.

If track_vars is enabled and register_globals is disabled, only members of the global associative array $HTTP_SESSION_VARS can be registered as session variables. The restored session variables will only be available in the array $HTTP_SESSION_VARS.

Ejemplo 1. Registering a variable with track_vars enabled

<?php
if (isset($HTTP_SESSION_VARS['count'])) {
   $HTTP_SESSION_VARS['count']++;
}
else {
   $HTTP_SESSION_VARS['count'] = 0;
}
?>

Use of $_SESSION (or $HTTP_SESSION_VARS with PHP 4.0.6 or less) is recommended for security and code readablity. With $_SESSION or $HTTP_SESSION_VARS, there is no need to use session_register()/session_unregister()/session_is_registered() functions. Users can access session variable like a normal variable.

Ejemplo 2. Registering a variable with $_SESSION.

<?php
// Use $HTTP_SESSION_VARS with PHP 4.0.6 or less
if (!isset($_SESSION['count'])) {
    $_SESSION['count'] = 0;
} else {
    $_SESSION['count']++;
}
?>

Ejemplo 3. Unregistering a variable with $_SESSION.

<?php
// Use $HTTP_SESSION_VARS with PHP 4.0.6 or less
unset($_SESSION['count']);

?>

If register_globals is enabled, then all global variables can be registered as session variables and the session variables will be restored to corresponding global variables. Since PHP must know which global variables are registered as session variables, users must register variables with session_register() function while $HTTP_SESSION_VARS/$_SESSION does not need to use session_register().

Atención

If you are using $HTTP_SESSION_VARS/$_SESSION and disable register_globals, do not use session_register(), session_is_registered() and session_unregister().

If you enable register_globals, session_unregister() should be used since session variables are registered as global variables when session data is deserialized. Disabling register_globals is recommended for both security and performance reason.

Ejemplo 4. Registering a variable with register_globals enabled

<?php
if (!session_is_registered('count')) {
    session_register("count");
    $count = 0;
}
else {
    $count++;
}
?>

If both track_vars and register_globals are enabled, then the globals variables and the $HTTP_SESSION_VARS/$_SESSION entries will reference the same value for already registered variables.

If user use session_register() to register session variable, $HTTP_SESSION_VARS/$_SESSION will not have these variable in array until it is loaded from session storage. (i.e. until next request)

There are two methods to propagate a session id:

  • Cookies

  • URL parameter

The session module supports both methods. Cookies are optimal, but since they are not reliable (clients are not bound to accept them), we cannot rely on them. The second method embeds the session id directly into URLs.

PHP is capable of doing this transparently when compiled with --enable-trans-sid. If you enable this option, relative URIs will be changed to contain the session id automatically. Alternatively, you can use the constant SID which is defined, if the client did not send the appropriate cookie. SID is either of the form session_name=session_id or is an empty string.

The following example demonstrates how to register a variable, and how to link correctly to another page using SID.

Ejemplo 5. Counting the number of hits of a single user

<?php
if (!session_is_registered('count')) {
    session_register('count');
    $count = 1;
}
else {
    $count++;
}
?>

Hello visitor, you have seen this page <?php echo $count; ?> times.<p>;

<?php
# the <?php echo SID?> (<?=SID?> can be used if short tag is enabled)
# is necessary to preserve the session id
# in the case that the user has disabled cookies
?>

To continue, <A HREF="nextpage.php?<?php echo SID?>">click here</A>

The <?=SID?> is not necessary, if --enable-trans-sid was used to compile PHP.

Nota: Non-relative URLs are assumed to point to external sites and hence don't append the SID, as it would be a security risk to leak the SID to a different server.

To implement database storage, or any other storage method, you will need to use session_set_save_handler() to create a set of user-level storage functions.

The session management system supports a number of configuration options which you can place in your php.ini file. We will give a short overview.

  • session.save_handler defines the name of the handler which is used for storing and retrieving data associated with a session. Defaults to files.

  • session.save_path defines the argument which is passed to the save handler. If you choose the default files handler, this is the path where the files are created. Defaults to /tmp. If session.save_path's path depth is more than 2, garbage collection will not be performed.

    Aviso

    If you leave this set to a world-readable directory, such as /tmp (the default), other users on the server may be able to hijack sessions by getting the list of files in that directory.

  • session.name specifies the name of the session which is used as cookie name. It should only contain alphanumeric characters. Defaults to PHPSESSID.

  • session.auto_start specifies whether the session module starts a session automatically on request startup. Defaults to 0 (disabled).

  • session.cookie_lifetime specifies the lifetime of the cookie in seconds which is sent to the browser. The value 0 means "until the browser is closed." Defaults to 0.

  • session.serialize_handler defines the name of the handler which is used to serialize/deserialize data. Currently, a PHP internal format (name php) and WDDX is supported (name wddx). WDDX is only available, if PHP is compiled with WDDX support. Defaults to php.

  • session.gc_probability specifies the probability that the gc (garbage collection) routine is started on each request in percent. Defaults to 1.

  • session.gc_maxlifetime specifies the number of seconds after which data will be seen as 'garbage' and cleaned up.

  • session.referer_check contains the substring you want to check each HTTP Referer for. If the Referer was sent by the client and the substring was not found, the embedded session id will be marked as invalid. Defaults to the empty string.

  • session.entropy_file gives a path to an external resource (file) which will be used as an additional entropy source in the session id creation process. Examples are /dev/random or /dev/urandom which are available on many Unix systems.

  • session.entropy_length specifies the number of bytes which will be read from the file specified above. Defaults to 0 (disabled).

  • session.use_cookies specifies whether the module will use cookies to store the session id on the client side. Defaults to 1 (enabled).

  • session.cookie_path specifies path to set in session_cookie. Defaults to /.

  • session.cookie_domain specifies domain to set in session_cookie. Default is none at all.

  • session.cache_limiter specifies cache control method to use for session pages (none/nocache/private/private_no_expire/public). Defaults to nocache.

  • session.cache_expire specifies time-to-live for cached session pages in minutes, this has no effect for nocache limiter. Defaults to 180.

  • session.use_trans_sid whether transparent sid support is enabled or not if enabled by compiling with --enable-trans-sid. Defaults to 1 (enabled).

  • url_rewriter.tags spefifies which html tags are rewritten to include session id if transparent sid support is enabled. Defaults to a=href,area=href,frame=src,input=src,form=fakeentry

Nota: Session handling was added in PHP 4.0.

Tabla de contenidos
session_start — Initialize session data
session_destroy — Destroys all data registered to a session
session_name — Get and/or set the current session name
session_module_name — Get and/or set the current session module
session_save_path — Get and/or set the current session save path
session_id — Get and/or set the current session id
session_register — Register one or more variables with the current session
session_unregister — Unregister a variable from the current session
session_unset — Free all session variables
session_is_registered — Find out if a variable is registered in a session
session_get_cookie_params — Get the session cookie parameters
session_set_cookie_params — Set the session cookie parameters
session_decode — Decodes session data from a string
session_encode — Encodes the current session data as a string
session_set_save_handler — Sets user-level session storage functions
session_cache_limiter — Get and/or set the current cache limiter
session_cache_expire — Return current cache expire
session_write_close — Write session data and end session

Anterior | Inicio | Siguiente
sesam_settransaction | Subir | session_start


session_start

(PHP 4 >= 4.0.0)

session_start -- Initialize session data

Description

bool session_start ( void)

session_start() creates a session (or resumes the current one based on the session id being passed via a GET variable or a cookie).

If you want to use a named session, you must call session_name() before calling session_start().

This function always returns TRUE.

Nota: If you are using cookie-based sessions, you must call session_start() before anything is output to the browser.

session_start() will register internal output handler for URL rewriting when trans-sid is enabled. If a user uses ob_gzhandler or like with ob_start(), the order of output handler is important for proper output. For example, user must register ob_gzhandler before session start.

Nota: Use of zlib.output_compression is recommended rather than ob_gzhandler

Anterior | Inicio | Siguiente
Session handling functions | Subir | session_destroy


session_destroy

(PHP 4 >= 4.0.0)

session_destroy -- Destroys all data registered to a session

Description

bool session_destroy ( void)

session_destroy() destroys all of the data associated with the current session. It does not unset any of the global variables associated with the session, or unset the session cookie.

This function returns TRUE on success and FALSE on failure to destroy the session data.

Ejemplo 1. Destroying a session

<?php

// Initialize the session.
// If you are using session_name("something"), don't forget it now!
session_start();
// Unset all of the session variables.
session_unset();
// Finally, destroy the session.
session_destroy();

?>

Ejemplo 2. Destroying a session with $_SESSION

<?php

// Initialize the session.
// If you are using session_name("something"), don't forget it now!
session_start();
// Unset all of the session variables.
$_SESSION = array();
// Finally, destroy the session.
session_destroy();

?>

Anterior | Inicio | Siguiente
session_start | Subir | session_name


session_name

(PHP 4 >= 4.0.0)

session_name -- Get and/or set the current session name

Description

string session_name ( [string name])

session_name() returns the name of the current session. If name is specified, the name of the current session is changed to its value.

The session name references the session id in cookies and URLs. It should contain only alphanumeric characters; it should be short and descriptive (i.e. for users with enabled cookie warnings). The session name is reset to the default value stored in session.name at request startup time. Thus, you need to call session_name() for every request (and before session_start() or session_register() are called).

Ejemplo 1. session_name() examples

<?php

// set the session name to WebsiteID

$previous_name = session_name("WebsiteID");

echo "The previous session name was $previous_name<p>";
?>

Anterior | Inicio | Siguiente
session_destroy | Subir | session_module_name


session_module_name

(PHP 4 >= 4.0.0)

session_module_name -- Get and/or set the current session module

Description

string session_module_name ( [string module])

session_module_name() returns the name of the current session module. If module is specified, that module will be used instead.

Anterior | Inicio | Siguiente
session_name | Subir | session_save_path


session_save_path

(PHP 4 >= 4.0.0)

session_save_path -- Get and/or set the current session save path

Description

string session_save_path ( [string path])

session_save_path() returns the path of the current directory used to save session data. If path is specified, the path to which data is saved will be changed.

Nota: On some operating systems, you may want to specify a path on a filesystem that handles lots of small files efficiently. For example, on Linux, reiserfs may provide better performance than ext2fs.

Anterior | Inicio | Siguiente
session_module_name | Subir | session_id


session_id

(PHP 4 >= 4.0.0)

session_id -- Get and/or set the current session id

Description

string session_id ( [string id])

session_id() returns the session id for the current session. If id is specified, it will replace the current session id.

The constant SID can also be used to retrieve the current name and session id as a string suitable for adding to URLs.

Anterior | Inicio | Siguiente
session_save_path | Subir | session_register


session_register

(PHP 4 >= 4.0.0)

session_register -- Register one or more variables with the current session

Description

bool session_register ( mixed name [, mixed ...])

session_register() accepts a variable number of arguments, any of which can be either a string holding the name of a variable or an array consisting of variable names or other arrays. For each name, session_register() registers the global variable with that name in the current session.

Atención

This registers a global variable. If you want to register a session variable inside a function, you need to make sure to make it global using global() or use the session arrays as noted below.

Atención

If you are using $HTTP_SESSION_VARS/$_SESSION, do not use session_register(), session_is_registered() and session_unregister().

This function returns TRUE when all of the variables are successfully registered with the session.

If session_start() was not called before this function is called, an implicit call to session_start() with no parameters will be made.

You can also create a session variable by simply setting the appropriate member of the $HTTP_SESSION_VARS or $_SESSION (PHP >= 4.1.0) array.

$barney = "A big purple dinosaur.";
session_register("barney");

$HTTP_SESSION_VARS["zim"] = "An invader from another planet.";

# the auto-global $_SESSION array was introduced in PHP 4.1.0
$_SESSION["spongebob"] = "He's got square pants.";

Nota: It is not currently possible to register resource variables in a session. For example, you can not create a connection to a database and store the connection id as a session variable and expect the connection to still be valid the next time the session is restored. PHP functions that return a resource are identified by having a return type of resource in their function definitions. A list of functions that return resources are available in the resource types appendix.

If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, assign variable to $_SESSION. i.e. $_SESSION['var'] = 'ABC';

See also session_is_registered() and session_unregister().

Anterior | Inicio | Siguiente
session_id | Subir | session_unregister


session_unregister

(PHP 4 >= 4.0.0)

session_unregister -- Unregister a variable from the current session

Description

bool session_unregister ( string name)

session_unregister() unregisters (forgets) the global variable named name from the current session.

This function returns TRUE when the variable is successfully unregistered from the session.

Nota: If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, use unset() to unregister a session variable.

Atención

This function doesn't unset the corresponding global variable for name, it only prevents the variable from being saved as part of the session. You must call unset() to remove the corresponding global variable.

Atención

If you are using $HTTP_SESSION_VARS/$_SESSION, do not use session_register(), session_is_registered() and session_unregister().

Anterior | Inicio | Siguiente
session_register | Subir | session_unset


session_unset

(PHP 4 >= 4.0.0)

session_unset -- Free all session variables

Description

void session_unset ( void)

The session_unset() function free's all session variables currently registered.

Nota: If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, use unset() to unregister session variable. i.e. $_SESSION = array();

Anterior | Inicio | Siguiente
session_unregister | Subir | session_is_registered


session_is_registered

(PHP 4 >= 4.0.0)

session_is_registered -- Find out if a variable is registered in a session

Description

bool session_is_registered ( string name)

session_is_registered() returns TRUE if there is a variable with the name name registered in the current session.

Nota: If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, use isset() to check a variable is registered in $_SESSION.

Atención

If you are using $HTTP_SESSION_VARS/$_SESSION, do not use session_register(), session_is_registered() and session_unregister().

Anterior | Inicio | Siguiente
session_unset | Subir | session_get_cookie_params


session_get_cookie_params

(PHP 4 >= 4.0.0)

session_get_cookie_params -- Get the session cookie parameters

Description

array session_get_cookie_params ( void)

The session_get_cookie_params() function returns an array with the current session cookie information, the array contains the following items:

  • "lifetime" - The lifetime of the cookie.

  • "path" - The path where information is stored.

  • "domain" - The domain of the cookie.

  • "secure" - The cookie should only be sent over secure connections. (This item was added in PHP 4.0.4.)

Anterior | Inicio | Siguiente
session_is_registered | Subir | session_set_cookie_params


session_set_cookie_params

(PHP 4 >= 4.0.0)

session_set_cookie_params -- Set the session cookie parameters

Description

void session_set_cookie_params ( int lifetime [, string path [, string domain [, bool secure]]])

Set cookie parameters defined in the php.ini file. The effect of this function only lasts for the duration of the script.

Nota: The secure parameter was added in PHP 4.0.4.

Anterior | Inicio | Siguiente
session_get_cookie_params | Subir | session_decode


session_decode

(PHP 4 >= 4.0.0)

session_decode -- Decodes session data from a string

Description

bool session_decode ( string data)

session_decode() decodes the session data in data, setting variables stored in the session.

Anterior | Inicio | Siguiente
session_set_cookie_params | Subir | session_encode


session_encode

(PHP 4 >= 4.0.0)

session_encode -- Encodes the current session data as a string

Description

string session_encode ( void)

session_encode() returns a string with the contents of the current session encoded within.

Anterior | Inicio | Siguiente
session_decode | Subir | session_set_save_handler


session_set_save_handler

(PHP 4 >= 4.0.0)

session_set_save_handler -- Sets user-level session storage functions

Description

void session_set_save_handler ( string open, string close, string read, string write, string destroy, string gc)

session_set_save_handler() sets the user-level session storage functions which are used for storing and retrieving data associated with a session. This is most useful when a storage method other than those supplied by PHP sessions is preferred. i.e. Storing the session data in a local database.

Nota: You must set the configuration option session.save_handler to user in your php.ini file for session_set_save_handler() to take effect.

Nota: The "write" handler is not executed until after the output stream is closed. Thus, output from debugging statements in the "write" handler will never be seen in the browser. If debugging output is necessary, it is suggested that the debug output be written to a file instead.

The following example provides file based session storage similar to the PHP sessions default save handler files. This example could easily be extended to cover database storage using your favorite PHP supported database engine.

Read function must return string value always to make save handler work as expected. Return empty string if there is no data to read. Return values from other handlers are converted to boolean expression. TRUE for success, FALSE for failure.

Ejemplo 1. session_set_save_handler() example

<?php
function open ($save_path, $session_name) {
  global $sess_save_path, $sess_session_name;

  $sess_save_path = $save_path;
  $sess_session_name = $session_name;
  return(true);
}

function close() {
  return(true);
}

function read ($id) {
  global $sess_save_path, $sess_session_name;

  $sess_file = "$sess_save_path/sess_$id";
  if ($fp = @fopen($sess_file, "r")) {
    $sess_data = fread($fp, filesize($sess_file));
    return($sess_data);
  } else {
    return(""); // Must return "" here.
  }

}

function write ($id, $sess_data) {
  global $sess_save_path, $sess_session_name;

  $sess_file = "$sess_save_path/sess_$id";
  if ($fp = @fopen($sess_file, "w")) {
    return(fwrite($fp, $sess_data));
  } else {
    return(false);
  }

}

function destroy ($id) {
  global $sess_save_path, $sess_session_name;

  $sess_file = "$sess_save_path/sess_$id";
  return(@unlink($sess_file));
}

/*********************************************
 * WARNING - You will need to implement some *
 * sort of garbage collection routine here.  *
 *********************************************/
function gc ($maxlifetime) {
  return true;
}

session_set_save_handler ("open", "close", "read", "write", "destroy", "gc");

session_start();

// proceed to use sessions normally

?>

Anterior | Inicio | Siguiente
session_encode | Subir | session_cache_limiter


session_cache_limiter

(PHP 4 >= 4.0.3)

session_cache_limiter -- Get and/or set the current cache limiter

Description

string session_cache_limiter ( [string cache_limiter])

session_cache_limiter() returns the name of the current cache limiter. If cache_limiter is specified, the name of the current cache limiter is changed to the new value.

The cache limiter controls the cache control HTTP headers sent to the client. These headers determine the rules by which the page content may be cached. Setting the cache limiter to nocache, for example, would disallow any client-side caching. A value of public, however, would permit caching. It can also be set to private, which is slightly more restrictive than public.

In private mode, Expire header sent to the client, may cause confusion for some browser including Mozilla. You can avoid this problem with private_no_expire mode. Expire header is never sent to the client in this mode.

Nota: private_no_expire was added in PHP 4.2.0dev.

The cache limiter is reset to the default value stored in session.cache_limiter at request startup time. Thus, you need to call session_cache_limiter() for every request (and before session_start() is called).

Ejemplo 1. session_cache_limiter() examples

<?php

# set the cache limiter to 'private'

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

echo "The cache limiter is now set to $cache_limiter<p>";
?>

Anterior | Inicio | Siguiente
session_set_save_handler | Subir | session_cache_expire


session_cache_expire

(PHP 4 >= 4.2.0)

session_cache_expire -- Return current cache expire

Description

int session_cache_expire ( [int new_cache_expire])

session_cache_expire() returns current cache expire. If new_cache_expire is given, the current cache expire is replaced with new_cache_expire.

Anterior | Inicio | Siguiente
session_cache_limiter | Subir | session_write_close


session_write_close

(PHP 4 >= 4.0.4)

session_write_close -- Write session data and end session

Description

void session_write_close ( void)

End the current session and store session data.

Session data is usually stored after your script terminated without the need to call session_write_close(), but as session data is locked to prevent concurrent writes only one script may operate on a session at any time. When using framesets together with sessions you will experience the frames loading one by one due to this locking. You can reduce the time needed to load all the frames by ending the session as soon as all changes to session variables are done.

Anterior | Inicio | Siguiente
session_cache_expire | Subir | Shared Memory Functions


Shared Memory Functions

Manual de PHP
Anterior Siguiente

XCI. Shared Memory Functions

Shmop is an easy to use set of functions that allows php to read, write, create and delete UNIX shared memory segments. The functions will not work on windows, as it does not support shared memory. To use shmop you will need to compile php with the --enable-shmop parameter in your configure line.

Nota: The functions explained in the chapter begin all with shm_() in PHP 4.0.3, but in PHP 4.0.4 and later versions these names are changed to begin with shmop_().

Ejemplo 1. Shared Memory Operations Overview

<?php

// Create 100 byte shared memory block with system id if 0xff3
$shm_id = shmop_open(0xff3, "c", 0644, 100);
if(!$shm_id) {
    echo "Couldn't create shared memory segment\n";
}

// Get shared memory block's size
$shm_size = shmop_size($shm_id);
echo "SHM Block Size: ".$shm_size. " has been created.\n";

// Lets write a test string into shared memory
$shm_bytes_written = shmop_write($shm_id, "my shared memory block", 0);
if($shm_bytes_written != strlen("my shared memory block")) {
    echo "Couldn't write the entire length of data\n";
}

// Now lets read the string back
$my_string = shmop_read($shm_id, 0, $shm_size);
if(!$my_string) {
    echo "Couldn't read from shared memory block\n";
}
echo "The data inside shared memory was: ".$my_string."\n";

//Now lets delete the block and close the shared memory segment
if(!shmop_delete($shm_id)) {
    echo "Couldn't mark shared memory block for deletion.
}
shmop_close($shm_id);

?>

Tabla de contenidos
shmop_close — Close shared memory block
shmop_delete — Delete shared memory block
shmop_open — Create or open shared memory block
shmop_read — Read data from shared memory block
shmop_write — Write data into shared memory block
shmop_size — Get size of shared memory block

Anterior | Inicio | Siguiente
session_write_close | Subir | shmop_close


shmop_open

(PHP 4 >= 4.0.4)

shmop_open -- Create or open shared memory block

Description

int shmop_open ( int key, string flags, int mode, int size)

shmop_open() can create or open a shared memory block.

shmop_open() takes 4 parameters: key, which is the system's id for the shared memory block, this parameter can be passed as a decimal or hex. The second parameter are the flags that you can use:

  • "a" for access (sets IPC_EXCL) use this flag when you need to open an existing shared memory segment

  • "c" for create (sets IPC_CREATE) use this flag when you need to create a new shared memory segment.

The third parameter is the mode, which are the permissions that you wish to assign to your memory segment, those are the same as permission for a file. Permissions need to be passed in octal form ex. 0644. The last parameter is size of the shared memory block you wish to create in bytes.

Nota: Note: the 3rd and 4th should be entered as 0 if you are opening an existing memory segment. On success shmop_open() will return an id that you can use to access the shared memory segment you've created.

Ejemplo 1. Create a new shared memory block

<?php
$shm_id = shmop_open(0x0fff, "c", 0644, 100);
?>

This example opened a shared memory block with a system id of 0x0fff.

Anterior | Inicio | Siguiente
shmop_delete | Subir | shmop_read


shmop_read

(PHP 4 >= 4.0.4)

shmop_read -- Read data from shared memory block

Description

string shmop_read ( int shmid, int start, int count)

shmop_read() will read a string from shared memory block.

shmop_read() takes 3 parameters: shmid, which is the shared memory block identifier created by shmop_open(), offset from which to start reading and count on the number of bytes to read.

Ejemplo 1. Reading shared memory block

<?php
$shm_data = shmop_read($shm_id, 0, 50);
?>

This example will read 50 bytes from shared memory block and place the data inside $shm_data.

Anterior | Inicio | Siguiente
shmop_open | Subir | shmop_write


shmop_write

(PHP 4 >= 4.0.4)

shmop_write -- Write data into shared memory block

Description

int shmop_write ( int shmid, string data, int offset)

shmop_write() will write a string into shared memory block.

shmop_write() takes 3 parameters: shmid, which is the shared memory block identifier created by shmop_open(), data, a string that you want to write into shared memory block and offset, which specifies where to start writing data inside the shared memory segment.

Ejemplo 1. Writing to shared memory block

<?php
$shm_bytes_written = shmop_write($shm_id, $my_string, 0);
?>

This example will write data inside $my_string into shared memory block, $shm_bytes_written will contain the number of bytes written.

Anterior | Inicio | Siguiente
shmop_read | Subir | shmop_size


shmop_size

(PHP 4 >= 4.0.4)

shmop_size -- Get size of shared memory block

Description

int shmop_size ( int shmid)

shmop_size() is used to get the size, in bytes of the shared memory block.

shmop_size() takes the shmid, which is the shared memory block identifier created by shmop_open(), the function will return and int, which represents the number of bytes the shared memory block occupies.

Ejemplo 1. Getting the size of the shared memory block

<?php
$shm_size = shmop_size($shm_id);
?>

This example will put the size of shared memory block identified by $shm_id into $shm_size.

Anterior | Inicio | Siguiente
shmop_write | Subir | Shockwave Flash functions


shmop_delete

(PHP 4 >= 4.0.4)

shmop_delete -- Delete shared memory block

Description

int shmop_delete ( int shmid)

shmop_delete() is used to delete a shared memory block.

shmop_delete() takes the shmid, which is the shared memory block identifier created by shmop_open(). On success 1 is returned, on failure 0 is returned.

Ejemplo 1. Deleting shared memory block

<?php
shmop_delete($shm_id);
?>

This example will delete shared memory block identified by $shm_id.

Anterior | Inicio | Siguiente
shmop_close | Subir | shmop_open


shmop_close

(PHP 4 >= 4.0.4)

shmop_close -- Close shared memory block

Description

int shmop_close ( int shmid)

shmop_close() is used to close a shared memory block.

shmop_close() takes the shmid, which is the shared memory block identifier created by shmop_open().

Ejemplo 1. Closing shared memory block

<?php
shmop_close($shm_id);
?>

This example will close shared memory block identified by $shm_id.

Anterior | Inicio | Siguiente
Shared Memory Functions | Subir | shmop_delete


Shockwave Flash functions

Manual de PHP
Anterior Siguiente

XCII. Shockwave Flash functions

PHP offers the ability to create Shockwave Flash files via Paul Haeberli's libswf module. You can download libswf at ftp://ftp.sgi.com/sgi/graphics/grafica/flash. Once you have libswf all you need to do is to configure --with-swf[=DIR] where DIR is a location containing the directories include and lib. The include directory has to contain the swf.h file and the lib directory has to contain the libswf.a file. If you unpack the libswf distribution the two files will be in one directory. Consequently you will have to copy the files to the proper location manually.

Once you've successfully installed PHP with Shockwave Flash support you can then go about creating Shockwave files from PHP. You would be surprised at what you can do, take the following code:

Ejemplo 1. SWF example

<?php
swf_openfile ("test.swf", 256, 256, 30, 1, 1, 1);
swf_ortho2 (-100, 100, -100, 100);
swf_defineline (1, -70, 0, 70, 0, .2);
swf_definerect (4, 60, -10, 70, 0, 0);
swf_definerect (5, -60, 0, -70, 10, 0);
swf_addcolor (0, 0, 0, 0);

swf_definefont (10, "Mod");
swf_fontsize (5);
swf_fontslant (10);
swf_definetext (11, "This be Flash wit PHP!", 1);

swf_pushmatrix ();
swf_translate (-50, 80, 0);
swf_placeobject (11, 60);
swf_popmatrix ();

for ($i = 0; $i < 30; $i++) {
    $p = $i/(30-1);
    swf_pushmatrix ();
    swf_scale (1-($p*.9), 1, 1);
    swf_rotate (60*$p,  'z');
    swf_translate (20+20*$p, $p/1.5, 0);
    swf_rotate (270*$p,  'z');
    swf_addcolor ($p, 0, $p/1.2, -$p);
    swf_placeobject (1, 50);
    swf_placeobject (4, 50);
    swf_placeobject (5, 50);
    swf_popmatrix ();
    swf_showframe ();
}

for ($i = 0; $i < 30; $i++) {
    swf_removeobject (50);
    if (($i%4) == 0) {
        swf_showframe ();
    }
}

swf_startdoaction ();
swf_actionstop ();
swf_enddoaction ();

swf_closefile ();
?>
It will produce the animation found at the following url.

Nota: SWF support was added in PHP4 RC2.

Tabla de contenidos
swf_actiongeturl — Get a URL from a Shockwave Flash movie
swf_actiongotoframe — Play a frame and then stop
swf_actiongotolabel — Display a frame with the specified label
swf_actionnextframe — Go foward one frame
swf_actionplay — Start playing the flash movie from the current frame
swf_actionprevframe — Go backwards one frame
swf_actionsettarget — Set the context for actions
swf_actionstop — Stop playing the flash movie at the current frame
swf_actiontogglequality — Toggle between low and high quality
swf_actionwaitforframe — Skip actions if a frame has not been loaded
swf_addbuttonrecord — Controls location, appearance and active area of the current button
swf_addcolor — Set the global add color to the rgba value specified
swf_closefile — Close the current Shockwave Flash file
swf_definebitmap — Define a bitmap
swf_definefont — Defines a font
swf_defineline — Define a line
swf_definepoly — Define a polygon
swf_definerect — Define a rectangle
swf_definetext — Define a text string
swf_endbutton — End the definition of the current button
swf_enddoaction — End the current action
swf_endshape — Completes the definition of the current shape
swf_endsymbol — End the definition of a symbol
swf_fontsize — Change the font size
swf_fontslant — Set the font slant
swf_fonttracking — Set the current font tracking
swf_getbitmapinfo — Get information about a bitmap
swf_getfontinfo — The height in pixels of a capital A and a lowercase x
swf_getframe — Get the frame number of the current frame
swf_labelframe — Label the current frame
swf_lookat — Define a viewing transformation
swf_modifyobject — Modify an object
swf_mulcolor — Sets the global multiply color to the rgba value specified
swf_nextid — Returns the next free object id
swf_oncondition — Describe a transition used to trigger an action list
swf_openfile — Open a new Shockwave Flash file
swf_ortho — Defines an orthographic mapping of user coordinates onto the current viewport
swf_ortho2 — Defines 2D orthographic mapping of user coordinates onto the current viewport
swf_perspective — Define a perspective projection transformation
swf_placeobject — Place an object onto the screen
swf_polarview — Define the viewer's position with polar coordinates
swf_popmatrix — Restore a previous transformation matrix
swf_posround — Enables or Disables the rounding of the translation when objects are placed or moved
swf_pushmatrix — Push the current transformation matrix back unto the stack
swf_removeobject — Remove an object
swf_rotate — Rotate the current transformation
swf_scale — Scale the current transformation
swf_setfont — Change the current font
swf_setframe — Switch to a specified frame
swf_shapearc — Draw a circular arc
swf_shapecurveto — Draw a quadratic bezier curve between two points
swf_shapecurveto3 — Draw a cubic bezier curve
swf_shapefillbitmapclip — Set current fill mode to clipped bitmap
swf_shapefillbitmaptile — Set current fill mode to tiled bitmap
swf_shapefilloff — Turns off filling
swf_shapefillsolid — Set the current fill style to the specified color
swf_shapelinesolid — Set the current line style
swf_shapelineto — Draw a line
swf_shapemoveto — Move the current position
swf_showframe — Display the current frame
swf_startbutton — Start the definition of a button
swf_startdoaction — Start a description of an action list for the current frame
swf_startshape — Start a complex shape
swf_startsymbol — Define a symbol
swf_textwidth — Get the width of a string
swf_translate — Translate the current transformations
swf_viewport — Select an area for future drawing

Anterior | Inicio | Siguiente
shmop_size | Subir | swf_actiongeturl


swf_openfile

(PHP 4 >= 4.0.0)

swf_openfile -- Open a new Shockwave Flash file

Description

void swf_openfile ( string filename, float width, float height, float framerate, float r, float g, float b)

The swf_openfile() function opens a new file named filename with a width of width and a height of height a frame rate of framerate and background with a red color of r a green color of g and a blue color of b.

The swf_openfile() must be the first function you call, otherwise your script will cause a segfault. If you want to send your output to the screen make the filename: "php://stdout" (support for this is in 4.0.1 and up).

Anterior | Inicio | Siguiente
swf_oncondition | Subir | swf_ortho


swf_closefile

(PHP 4 >= 4.0.0)

swf_closefile -- Close the current Shockwave Flash file

Description

void swf_closefile ( void)

Close a file that was opened by the swf_openfile() function.

Anterior | Inicio | Siguiente
swf_addcolor | Subir | swf_definebitmap


swf_labelframe

(PHP 4 >= 4.0.0)

swf_labelframe -- Label the current frame

Description

void swf_labelframe ( string name)

Label the current frame with the name given by the name parameter.

Anterior | Inicio | Siguiente
swf_getframe | Subir | swf_lookat


swf_showframe

(PHP 4 >= 4.0.0)

swf_showframe -- Display the current frame

Description

void swf_showframe ( void)

The swf_showframe function will output the current frame.

Anterior | Inicio | Siguiente
swf_shapemoveto | Subir | swf_startbutton


swf_setframe

(PHP 4 >= 4.0.0)

swf_setframe -- Switch to a specified frame

Description

void swf_setframe ( int framenumber)

The swf_setframe() changes the active frame to the frame specified by framenumber.

Anterior | Inicio | Siguiente
swf_setfont | Subir | swf_shapearc


swf_getframe

(PHP 4 >= 4.0.0)

swf_getframe -- Get the frame number of the current frame

Description

int swf_getframe ( void)

The swf_getframe() function gets the number of the current frame.

Anterior | Inicio | Siguiente
swf_getfontinfo | Subir | swf_labelframe


swf_mulcolor

(PHP 4 >= 4.0.0)

swf_mulcolor -- Sets the global multiply color to the rgba value specified

Description

void swf_mulcolor ( float r, float g, float b, float a)

The swf_mulcolor() function sets the global multiply color to the rgba color specified. This color is then used (implicitly) by the swf_placeobject(), swf_modifyobject() and the swf_addbuttonrecord() functions. The color of the object will be multiplied by the rgba values when the object is written to the screen.

Nota: The rgba values can be either positive or negative.

Anterior | Inicio | Siguiente
swf_modifyobject | Subir | swf_nextid


swf_addcolor

(PHP 4 >= 4.0.0)

swf_addcolor -- Set the global add color to the rgba value specified

Description

void swf_addcolor ( float r, float g, float b, float a)

The swf_addcolor() function sets the global add color to the rgba color specified. This color is then used (implicitly) by the swf_placeobject(), swf_modifyobject() and the swf_addbuttonrecord() functions. The color of the object will be add by the rgba values when the object is written to the screen.

Nota: The rgba values can be either positive or negative.

Anterior | Inicio | Siguiente
swf_addbuttonrecord | Subir | swf_closefile


swf_placeobject

(PHP 4 >= 4.0.0)

swf_placeobject -- Place an object onto the screen

Description

void swf_placeobject ( int objid, int depth)

Places the object specified by objid in the current frame at a depth of depth. The objid parameter and the depth must be between 1 and 65535.

This uses the current mulcolor (specified by swf_mulcolor()) and the current addcolor (specified by swf_addcolor()) to color the object and it uses the current matrix to position the object.

Nota: Full RGBA colors are supported.

Anterior | Inicio | Siguiente
swf_perspective | Subir | swf_polarview


swf_modifyobject

(PHP 4 >= 4.0.0)

swf_modifyobject -- Modify an object

Description

void swf_modifyobject ( int depth, int how)

Updates the position and/or color of the object at the specified depth, depth. The parameter how determines what is updated. how can either be the constant MOD_MATRIX or MOD_COLOR or it can be a combination of both (MOD_MATRIX|MOD_COLOR).

MOD_COLOR uses the current mulcolor (specified by the function swf_mulcolor()) and addcolor (specified by the function swf_addcolor()) to color the object. MOD_MATRIX uses the current matrix to position the object.

Anterior | Inicio | Siguiente
swf_lookat | Subir | swf_mulcolor


swf_removeobject

(PHP 4 >= 4.0.0)

swf_removeobject -- Remove an object

Description

void swf_removeobject ( int depth)

Removes the object at the depth specified by depth.

Anterior | Inicio | Siguiente
swf_pushmatrix | Subir | swf_rotate


swf_nextid

(PHP 4 >= 4.0.0)

swf_nextid -- Returns the next free object id

Description

int swf_nextid ( void)

The swf_nextid() function returns the next available object id.

Anterior | Inicio | Siguiente
swf_mulcolor | Subir | swf_oncondition


swf_startdoaction

(PHP 4 >= 4.0.0)

swf_startdoaction -- Start a description of an action list for the current frame

Description

void swf_startdoaction ( void)

The swf_startdoaction() function starts the description of an action list for the current frame. This must be called before actions are defined for the current frame.

Anterior | Inicio | Siguiente
swf_startbutton | Subir | swf_startshape


swf_actiongotoframe

(PHP 4 >= 4.0.0)

swf_actiongotoframe -- Play a frame and then stop

Description

void swf_actiongotoframe ( int framenumber)

The swf_actionGotoFrame() function will go to the frame specified by framenumber, play it, and then stop.

Anterior | Inicio | Siguiente
swf_actiongeturl | Subir | swf_actiongotolabel


swf_actiongeturl

(PHP 4 >= 4.0.0)

swf_actiongeturl -- Get a URL from a Shockwave Flash movie

Description

void swf_actiongeturl ( string url, string target)

The swf_actionGetUrl() function gets the URL specified by the parameter url with the target target.

Anterior | Inicio | Siguiente
Shockwave Flash functions | Subir | swf_actiongotoframe


swf_actionnextframe

(PHP 4 >= 4.0.0)

swf_actionnextframe -- Go foward one frame

Description

void swf_actionnextframe ( void)

Go foward one frame.

Anterior | Inicio | Siguiente
swf_actiongotolabel | Subir | swf_actionplay


swf_actionprevframe

(PHP 4 >= 4.0.0)

swf_actionprevframe -- Go backwards one frame

Description

void swf_actionprevframe ( void)

Anterior | Inicio | Siguiente
swf_actionplay | Subir | swf_actionsettarget


swf_actionplay

(PHP 4 >= 4.0.0)

swf_actionplay -- Start playing the flash movie from the current frame

Description

void swf_actionplay ( void)

Start playing the flash movie from the current frame.

Anterior | Inicio | Siguiente
swf_actionnextframe | Subir | swf_actionprevframe


swf_actionstop

(PHP 4 >= 4.0.0)

swf_actionstop -- Stop playing the flash movie at the current frame

Description

void swf_actionstop ( void)

Stop playing the flash movie at the current frame.

Anterior | Inicio | Siguiente
swf_actionsettarget | Subir | swf_actiontogglequality


swf_actiontogglequality

(PHP 4 >= 4.0.0)

swf_actiontogglequality -- Toggle between low and high quality

Description

void swf_actiontogglequality ( void)

Toggle the flash movie between high and low quality.

Anterior | Inicio | Siguiente
swf_actionstop | Subir | swf_actionwaitforframe


swf_actionwaitforframe

(PHP 4 >= 4.0.0)

swf_actionwaitforframe -- Skip actions if a frame has not been loaded

Description

void swf_actionwaitforframe ( int framenumber, int skipcount)

The swf_actionWaitForFrame() function will check to see if the frame, specified by the framenumber parameter has been loaded, if not it will skip the number of actions specified by the skipcount parameter. This can be useful for "Loading..." type animations.

Anterior | Inicio | Siguiente
swf_actiontogglequality | Subir | swf_addbuttonrecord


swf_actionsettarget

(PHP 4 >= 4.0.0)

swf_actionsettarget -- Set the context for actions

Description

void swf_actionsettarget ( string target)

The swf_actionSetTarget() function sets the context for all actions. You can use this to control other flash movies that are currently playing.

Anterior | Inicio | Siguiente
swf_actionprevframe | Subir | swf_actionstop


swf_actiongotolabel

(PHP 4 >= 4.0.0)

swf_actiongotolabel -- Display a frame with the specified label

Description

void swf_actiongotolabel ( string label)

The swf_actionGotoLabel() function displays the frame with the label given by the label parameter and then stops.

Anterior | Inicio | Siguiente
swf_actiongotoframe | Subir | swf_actionnextframe


swf_enddoaction

(PHP 4 >= 4.0.0)

swf_enddoaction -- End the current action

Description

void swf_enddoaction ( void)

Ends the current action started by the swf_startdoaction() function.

Anterior | Inicio | Siguiente
swf_endbutton | Subir | swf_endshape


swf_defineline

(PHP 4 >= 4.0.0)

swf_defineline -- Define a line

Description

void swf_defineline ( int objid, float x1, float y1, float x2, float y2, float width)

The swf_defineline() defines a line starting from the x coordinate given by x1 and the y coordinate given by y1 parameter. Up to the x coordinate given by the x2 parameter and the y coordinate given by the y2 parameter. It will have a width defined by the width parameter.

Anterior | Inicio | Siguiente
swf_definefont | Subir | swf_definepoly


swf_definerect

(PHP 4 >= 4.0.0)

swf_definerect -- Define a rectangle

Description

void swf_definerect ( int objid, float x1, float y1, float x2, float y2, float width)

The swf_definerect() defines a rectangle with an upper left hand coordinate given by the x, x1, and the y, y1. And a lower right hand coordinate given by the x coordinate, x2, and the y coordinate, y2 . Width of the rectangles border is given by the width parameter, if the width is 0.0 then the rectangle is filled.

Anterior | Inicio | Siguiente
swf_definepoly | Subir | swf_definetext


swf_definepoly

(PHP 4 >= 4.0.0)

swf_definepoly -- Define a polygon

Description

void swf_definepoly ( int objid, array coords, int npoints, float width)

The swf_definepoly() function defines a polygon given an array of x, y coordinates (the coordinates are defined in the parameter coords). The parameter npoints is the number of overall points that are contained in the array given by coords. The width is the width of the polygon's border, if set to 0.0 the polygon is filled.

Anterior | Inicio | Siguiente
swf_defineline | Subir | swf_definerect


swf_startshape

(PHP 4 >= 4.0.0)

swf_startshape -- Start a complex shape

Description

void swf_startshape ( int objid)

The swf_startshape() function starts a complex shape, with an object id given by the objid parameter.

Anterior | Inicio | Siguiente
swf_startdoaction | Subir | swf_startsymbol


swf_shapelinesolid

(PHP 4 >= 4.0.0)

swf_shapelinesolid -- Set the current line style

Description

void swf_shapelinesolid ( float r, float g, float b, float a, float width)

The swf_shapeLineSolid() function sets the current line style to the color of the rgba parameters and width to the width parameter. If 0.0 is given as a width then no lines are drawn.

Anterior | Inicio | Siguiente
swf_shapefillsolid | Subir | swf_shapelineto


swf_shapefilloff

(PHP 4 >= 4.0.0)

swf_shapefilloff -- Turns off filling

Description

void swf_shapefilloff ( void)

The swf_shapeFillOff() function turns off filling for the current shape.

Anterior | Inicio | Siguiente
swf_shapefillbitmaptile | Subir | swf_shapefillsolid


swf_shapefillsolid

(PHP 4 >= 4.0.0)

swf_shapefillsolid -- Set the current fill style to the specified color

Description

void swf_shapefillsolid ( float r, float g, float b, float a)

The swf_shapeFillSolid() function sets the current fill style to solid, and then sets the fill color to the values of the rgba parameters.

Anterior | Inicio | Siguiente
swf_shapefilloff | Subir | swf_shapelinesolid


swf_shapefillbitmapclip

(PHP 4 >= 4.0.0)

swf_shapefillbitmapclip -- Set current fill mode to clipped bitmap

Description

void swf_shapefillbitmapclip ( int bitmapid)

Sets the fill to bitmap clipped, empty spaces will be filled by the bitmap given by the bitmapid parameter.

Anterior | Inicio | Siguiente
swf_shapecurveto3 | Subir | swf_shapefillbitmaptile


swf_shapefillbitmaptile

(PHP 4 >= 4.0.0)

swf_shapefillbitmaptile -- Set current fill mode to tiled bitmap

Description

void swf_shapefillbitmaptile ( int bitmapid)

Sets the fill to bitmap tile, empty spaces will be filled by the bitmap given by the bitmapid parameter (tiled).

Anterior | Inicio | Siguiente
swf_shapefillbitmapclip | Subir | swf_shapefilloff


swf_shapemoveto

(PHP 4 >= 4.0.0)

swf_shapemoveto -- Move the current position

Description

void swf_shapemoveto ( float x, float y)

The swf_shapeMoveTo() function moves the current position to the x coordinate given by the x parameter and the y position given by the y parameter.

Anterior | Inicio | Siguiente
swf_shapelineto | Subir | swf_showframe


swf_shapelineto

(PHP 4 >= 4.0.0)

swf_shapelineto -- Draw a line

Description

void swf_shapelineto ( float x, float y)

The swf_shapeLineTo() draws a line to the x,y coordinates given by the x parameter & the y parameter. The current position is then set to the x,y parameters.

Anterior | Inicio | Siguiente
swf_shapelinesolid | Subir | swf_shapemoveto


swf_shapecurveto

(PHP 4 >= 4.0.0)

swf_shapecurveto -- Draw a quadratic bezier curve between two points

Description

void swf_shapecurveto ( float x1, float y1, float x2, float y2)

The swf_shapecurveto() function draws a quadratic bezier curve from the x coordinate given by x1 and the y coordinate given by y1 to the x coordinate given by x2 and the y coordinate given by y2. The current position is then set to the x,y coordinates given by the x2 and y2 parameters

Anterior | Inicio | Siguiente
swf_shapearc | Subir | swf_shapecurveto3


swf_shapecurveto3

(PHP 4 >= 4.0.0)

swf_shapecurveto3 -- Draw a cubic bezier curve

Description

void swf_shapecurveto3 ( float x1, float y1, float x2, float y2, float x3, float y3)

Draw a cubic bezier curve using the x,y coordinate pairs x1, y1 and x2,y2 as off curve control points and the x,y coordinate x3, y3 as an endpoint. The current position is then set to the x,y coordinate pair given by x3,y3.

Anterior | Inicio | Siguiente
swf_shapecurveto | Subir | swf_shapefillbitmapclip


swf_shapearc

(PHP 4 >= 4.0.0)

swf_shapearc -- Draw a circular arc

Description

void swf_shapearc ( float x, float y, float r, float ang1, float ang2)

The swf_shapeArc() function draws a circular arc from angle A given by the ang1 parameter to angle B given by the ang2 parameter. The center of the circle has an x coordinate given by the x parameter and a y coordinate given by the y, the radius of the circle is given by the r parameter.

Anterior | Inicio | Siguiente
swf_setframe | Subir | swf_shapecurveto


swf_endshape

(PHP 4 >= 4.0.0)

swf_endshape -- Completes the definition of the current shape

Description

void swf_endshape ( void)

The swf_endshape() completes the definition of the current shape.

Anterior | Inicio | Siguiente
swf_enddoaction | Subir | swf_endsymbol


swf_definefont

(PHP 4 >= 4.0.0)

swf_definefont -- Defines a font

Description

void swf_definefont ( int fontid, string fontname)

The swf_definefont() function defines a font given by the fontname parameter and gives it the id specified by the fontid parameter. It then sets the font given by fontname to the current font.

Anterior | Inicio | Siguiente
swf_definebitmap | Subir | swf_defineline


swf_setfont

(PHP 4 >= 4.0.0)

swf_setfont -- Change the current font

Description

void swf_setfont ( int fontid)

The swf_setfont() sets the current font to the value given by the fontid parameter.

Anterior | Inicio | Siguiente
swf_scale | Subir | swf_setframe


swf_fontsize

(PHP 4 >= 4.0.0)

swf_fontsize -- Change the font size

Description

void swf_fontsize ( float size)

The swf_fontsize() function changes the font size to the value given by the size parameter.

Anterior | Inicio | Siguiente
swf_endsymbol | Subir | swf_fontslant


swf_fontslant

(PHP 4 >= 4.0.0)

swf_fontslant -- Set the font slant

Description

void swf_fontslant ( float slant)

Set the current font slant to the angle indicated by the slant parameter. Positive values create a foward slant, negative values create a negative slant.

Anterior | Inicio | Siguiente
swf_fontsize | Subir | swf_fonttracking


swf_fonttracking

(PHP 4 >= 4.0.0)

swf_fonttracking -- Set the current font tracking

Description

void swf_fonttracking ( float tracking)

Set the font tracking to the value specified by the tracking parameter. This function is used to increase the spacing between letters and text, positive values increase the space and negative values decrease the space between letters.

Anterior | Inicio | Siguiente
swf_fontslant | Subir | swf_getbitmapinfo


swf_getfontinfo

(PHP 4 >= 4.0.0)

swf_getfontinfo -- The height in pixels of a capital A and a lowercase x

Description

array swf_getfontinfo ( void)

The swf_getfontinfo() function returns an associative array with the following parameters:

  • Aheight - The height in pixels of a capital A.

  • xheight - The height in pixels of a lowercase x.

Anterior | Inicio | Siguiente
swf_getbitmapinfo | Subir | swf_getframe


swf_definetext

(PHP 4 >= 4.0.0)

swf_definetext -- Define a text string

Description

void swf_definetext ( int objid, string str, int docenter)

Define a text string (the str parameter) using the current font and font size. The docenter is where the word is centered, if docenter is 1, then the word is centered in x.

Anterior | Inicio | Siguiente
swf_definerect | Subir | swf_endbutton


swf_textwidth

(PHP 4 >= 4.0.0)

swf_textwidth -- Get the width of a string

Description

float swf_textwidth ( string str)

The swf_textwidth() function gives the width of the string, str, in pixels, using the current font and font size.

Anterior | Inicio | Siguiente
swf_startsymbol | Subir | swf_translate


swf_definebitmap

(PHP 4 >= 4.0.0)

swf_definebitmap -- Define a bitmap

Description

void swf_definebitmap ( int objid, string image_name)

The swf_definebitmap() function defines a bitmap given a GIF, JPEG, RGB or FI image. The image will be converted into a Flash JPEG or Flash color map format.

Anterior | Inicio | Siguiente
swf_closefile | Subir | swf_definefont


swf_getbitmapinfo

(PHP 4 >= 4.0.0)

swf_getbitmapinfo -- Get information about a bitmap

Description

array swf_getbitmapinfo ( int bitmapid)

The swf_getbitmapinfo() function returns an array of information about a bitmap given by the bitmapid parameter. The returned array has the following elements:

  • "size" - The size in bytes of the bitmap.

  • "width" - The width in pixels of the bitmap.

  • "height" - The height in pixels of the bitmap.

Anterior | Inicio | Siguiente
swf_fonttracking | Subir | swf_getfontinfo


swf_startsymbol

(PHP 4 >= 4.0.0)

swf_startsymbol -- Define a symbol

Description

void swf_startsymbol ( int objid)

Define an object id as a symbol. Symbols are tiny flash movies that can be played simultaneously. The objid parameter is the object id you want to define as a symbol.

Anterior | Inicio | Siguiente
swf_startshape | Subir | swf_textwidth


swf_endsymbol

(PHP 4 >= 4.0.0)

swf_endsymbol -- End the definition of a symbol

Description

void swf_endsymbol ( void)

The swf_endsymbol() function ends the definition of a symbol that was started by the swf_startsymbol() function.

Anterior | Inicio | Siguiente
swf_endshape | Subir | swf_fontsize


swf_startbutton

(PHP 4 >= 4.0.0)

swf_startbutton -- Start the definition of a button

Description

void swf_startbutton ( int objid, int type)

The swf_startbutton() function starts off the definition of a button. The type parameter can either be TYPE_MENUBUTTON or TYPE_PUSHBUTTON. The TYPE_MENUBUTTON constant allows the focus to travel from the button when the mouse is down, TYPE_PUSHBUTTON does not allow the focus to travel when the mouse is down.

Anterior | Inicio | Siguiente
swf_showframe | Subir | swf_startdoaction


swf_addbuttonrecord

(PHP 4 >= 4.0.0)

swf_addbuttonrecord -- Controls location, appearance and active area of the current button

Description

void swf_addbuttonrecord ( int states, int shapeid, int depth)

The swf_addbuttonrecord() function allows you to define the specifics of using a button. The first parameter, states, defines what states the button can have, these can be any or all of the following constants: BSHitTest, BSDown, BSOver or BSUp. The second parameter, the shapeid is the look of the button, this is usually the object id of the shape of the button. The depth parameter is the placement of the button in the current frame.

Ejemplo 1. swf_addbuttonrecord() function example

swf_startButton ($objid, TYPE_MENUBUTTON);
    swf_addButtonRecord (BSDown|BSOver, $buttonImageId, 340);
    swf_onCondition (MenuEnter);
        swf_actionGetUrl ("http://www.designmultimedia.com", "_level1");
    swf_onCondition (MenuExit);
        swf_actionGetUrl ("", "_level1");
swf_endButton ();

Anterior | Inicio | Siguiente
swf_actionwaitforframe | Subir | swf_addcolor


swf_oncondition

(PHP 4 >= 4.0.0)

swf_oncondition -- Describe a transition used to trigger an action list

Description

void swf_oncondition ( int transition)

The swf_onCondition() function describes a transition that will trigger an action list. There are several types of possible transitions, the following are for buttons defined as TYPE_MENUBUTTON:

  • IdletoOverUp

  • OverUptoIdle

  • OverUptoOverDown

  • OverDowntoOverUp

  • IdletoOverDown

  • OutDowntoIdle

  • MenuEnter (IdletoOverUp|IdletoOverDown)

  • MenuExit (OverUptoIdle|OverDowntoIdle)

For TYPE_PUSHBUTTON there are the following options:

  • IdletoOverUp

  • OverUptoIdle

  • OverUptoOverDown

  • OverDowntoOverUp

  • OverDowntoOutDown

  • OutDowntoOverDown

  • OutDowntoIdle

  • ButtonEnter (IdletoOverUp|OutDowntoOverDown)

  • ButtonExit (OverUptoIdle|OverDowntoOutDown)

Anterior | Inicio | Siguiente
swf_nextid | Subir | swf_openfile


swf_endbutton

(PHP 4 >= 4.0.0)

swf_endbutton -- End the definition of the current button

Description

void swf_endbutton ( void)

The swf_endButton() function ends the definition of the current button.

Anterior | Inicio | Siguiente
swf_definetext | Subir | swf_enddoaction


swf_viewport

(PHP 4 >= 4.0.0)

swf_viewport -- Select an area for future drawing

Description

void swf_viewport ( double xmin, double xmax, double ymin, double ymax)

The swf_viewport() function selects an area for future drawing for xmin to xmax and ymin to ymax, if this function is not called the area defaults to the size of the screen.

Anterior | Inicio | Siguiente
swf_translate | Subir | Funciones SNMP


swf_ortho

(PHP 4 )

swf_ortho -- Defines an orthographic mapping of user coordinates onto the current viewport

Description

void swf_ortho ( double xmin, double xmax, double ymin, double ymax, double zmin, double zmax)

The swf_ortho() funcion defines a orthographic mapping of user coordinates onto the current viewport.

Anterior | Inicio | Siguiente
swf_openfile | Subir | swf_ortho2


swf_ortho2

(PHP 4 >= 4.0.0)

swf_ortho2 -- Defines 2D orthographic mapping of user coordinates onto the current viewport

Description

void swf_ortho2 ( double xmin, double xmax, double ymin, double ymax)

The swf_ortho2() function defines a two dimensional orthographic mapping of user coordinates onto the current viewport, this defaults to one to one mapping of the area of the Flash movie. If a perspective transformation is desired, the swf_perspective () function can be used.

Anterior | Inicio | Siguiente
swf_ortho | Subir | swf_perspective


swf_perspective

(PHP 4 >= 4.0.0)

swf_perspective -- Define a perspective projection transformation

Description

void swf_perspective ( double fovy, double aspect, double near, double far)

The swf_perspective() function defines a perspective projection transformation. The fovy parameter is field-of-view angle in the y direction. The aspect parameter should be set to the aspect ratio of the viewport that is being drawn onto. The near parameter is the near clipping plane and the far parameter is the far clipping plane.

Nota: Various distortion artifacts may appear when performing a perspective projection, this is because Flash players only have a two dimensional matrix. Some are not to pretty.

Anterior | Inicio | Siguiente
swf_ortho2 | Subir | swf_placeobject


swf_polarview

(PHP 4 >= 4.0.0)

swf_polarview -- Define the viewer's position with polar coordinates

Description

void swf_polarview ( double dist, double azimuth, double incidence, double twist)

The swf_polarview() function defines the viewer's position in polar coordinates. The dist parameter gives the distance between the viewpoint to the world space origin. The azimuth parameter defines the azimuthal angle in the x,y coordinate plane, measured in distance from the y axis. The incidence parameter defines the angle of incidence in the y,z plane, measured in distance from the z axis. The incidence angle is defined as the angle of the viewport relative to the z axis. Finally the twist specifies the amount that the viewpoint is to be rotated about the line of sight using the right hand rule.

Anterior | Inicio | Siguiente
swf_placeobject | Subir | swf_popmatrix


swf_lookat

(PHP 4 >= 4.0.0)

swf_lookat -- Define a viewing transformation

Description

void swf_lookat ( double view_x, double view_y, double view_z, double reference_x, double reference_y, double reference_z, double twist)

The swf_lookat() function defines a viewing transformation by giving the viewing position (the parameters view_x, view_y, and view_z) and the coordinates of a reference point in the scene, the reference point is defined by the reference_x, reference_y , and reference_z parameters. The twist controls the rotation along with viewer's z axis.

Anterior | Inicio | Siguiente
swf_labelframe | Subir | swf_modifyobject


swf_pushmatrix

(PHP 4 >= 4.0.0)

swf_pushmatrix -- Push the current transformation matrix back unto the stack

Description

void swf_pushmatrix ( void)

The swf_pushmatrix() function pushes the current transformation matrix back onto the stack.

Anterior | Inicio | Siguiente
swf_posround | Subir | swf_removeobject


swf_popmatrix

(PHP 4 >= 4.0.0)

swf_popmatrix -- Restore a previous transformation matrix

Description

void swf_popmatrix ( void)

The swf_popmatrix() function pushes the current transformation matrix back onto the stack.

Anterior | Inicio | Siguiente
swf_polarview | Subir | swf_posround


swf_scale

(PHP 4 >= 4.0.0)

swf_scale -- Scale the current transformation

Description

void swf_scale ( double x, double y, double z)

The swf_scale() scales the x coordinate of the curve by the value of the x parameter, the y coordinate of the curve by the value of the y parameter, and the z coordinate of the curve by the value of the z parameter.

Anterior | Inicio | Siguiente
swf_rotate | Subir | swf_setfont


swf_translate

(PHP 4 >= 4.0.0)

swf_translate -- Translate the current transformations

Description

void swf_translate ( double x, double y, double z)

The swf_translate() function translates the current transformation by the x, y, and z values given.

Anterior | Inicio | Siguiente
swf_textwidth | Subir | swf_viewport


swf_rotate

(PHP 4 >= 4.0.0)

swf_rotate -- Rotate the current transformation

Description

void swf_rotate ( double angle, string axis)

The swf_rotate() rotates the current transformation by the angle given by the angle parameter around the axis given by the axis parameter. Valid values for the axis are 'x' (the x axis), 'y' (the y axis) or 'z' (the z axis).

Anterior | Inicio | Siguiente
swf_removeobject | Subir | swf_scale


swf_posround

(PHP 4 >= 4.0.0)

swf_posround -- Enables or Disables the rounding of the translation when objects are placed or moved

Description

void swf_posround ( int round)

The swf_posround() function enables or disables the rounding of the translation when objects are placed or moved, there are times when text becomes more readable because rounding has been enabled. The round is whether to enable rounding or not, if set to the value of 1, then rounding is enabled, if set to 0 then rounding is disabled.

Anterior | Inicio | Siguiente
swf_popmatrix | Subir | swf_pushmatrix


Funciones SNMP

Manual de PHP
Anterior Siguiente

XCIII. Funciones SNMP

Para usar las funciones SNMP en Unix necesita instalar el paquete UCD SNMP. En Windows estas funciones están solamente disponibles en NT y no en Win95/98.

Importante: Para usar el paquete UCD SNMP, necesita definir NO_ZEROLENGTH_COMMUNITY a 1 antes de compilarlo. Despues de configurar UCD SNMP, edite config.h y busque NO_ZEROLENGTH_COMMUNITY. Descomente la línea #define. Debería de verse como sigue:

#define NO_ZEROLENGTH_COMMUNITY 1

Si ve faltas de segmentación desconocidas en combinación con los comandos SNMP, no siga las siguientes instrucciones. Si no desea recompilar UCD SNMP, puede compilar PHP con la opción --enable-ucd-snmp-hack la cual trabajará entorno a las mismas características.

Tabla de contenidos
snmp_get_quick_print — Va a buscar el valor actual de la biblioteca UCD estableciendo quick_print
snmp_set_quick_print — Establece el valor de quick_print con el de la biblioteca UCD SNMP.
snmpget — Va a buscar un objeto SNMP
snmpset — Va a buscar un objeto SNMP
snmpwalk — Busqueda por un arbol de información acerca de un entidad de red
snmpwalkoid — Busqueda por un arbol de información acerca de un entidad de red

Anterior | Inicio | Siguiente
swf_viewport | Subir | snmp_get_quick_print


snmpget

(PHP 3, PHP 4 >= 4.0.0)

snmpget -- Va a buscar un objeto SNMP

Descripción

string snmpget ( string hostname, string community, string object_id [, int timeout [, int retries]])

Devuelve el valor de un objeto SNMP en caso de exito y FALSE en caso de error.

La función snmpget() es usada para leer el valor de un objeto SNMP especificado por el object_id. El agente SNMP es especificado por el hostname y la comunidad lectora es especificada por el parametro community.

$syscontact = snmpget("127.0.0.1", "public", "system.SysContact.0")

Anterior | Inicio | Siguiente
snmp_set_quick_print | Subir | snmpset


snmpset

(PHP 3>= 3.0.12, PHP 4 >= 4.0.0)

snmpset -- Va a buscar un objeto SNMP

Descripción

string snmpget ( string hostname, string community, string object_id, string type, mixed value [, int timeout [, int retries]])

Establece el valor especificado para el objeto SNMP, devolviendo TRUE en caso de exito o FALSE en caso de error.

La función snmpset() es usada para establecer el valor de un objeto SNMP especificado por el object_id. El agente SNMP es espcificado por el hostname y la comunidad lectora por el parametro community.

Anterior | Inicio | Siguiente
snmpget | Subir | snmpwalk


snmpwalk

(PHP 3, PHP 4 >= 4.0.0)

snmpwalk -- Busqueda por un arbol de información acerca de un entidad de red

Descripción

array snmpwalk ( string hostname, string community, string object_id [, int timeout [, int retries]])

Devuelve una matriz de valores de objetos SMNP comenzando por el object_id() como raíz y FALSE en caso de error.

La función snmpwalk() es usada para leer todos los valores de un agente SNMP especificado por el hostname. Community especifica la comunidad lectora para el agente. Un object_id nulo se toma como la raíz del arbol de los objetos SNMP y todos los objetos por debajo de ese arbol son devueltos como una matriz. Si object_id es especificado, todos los objetos SNMP por debajo de object_id son devueltos.

$a = snmpwalk("127.0.0.1", "public", "");

Encima de una función de llamada podrían devolverse todos los objetos SNMP del agente SNMP en ejecución en el servidor local. Uno puede pasar por todos los valores con un bucle.

for ($i=0; $i<count($a); $i++) {
    echo $a[$i];
}

Anterior | Inicio | Siguiente
snmpset | Subir | snmpwalkoid


snmpwalkoid

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

snmpwalkoid -- Busqueda por un arbol de información acerca de un entidad de red

Descripción

array snmpwalkoid ( string hostname, string community, string object_id [, int timeout [, int retries]])

Devuelve una matriz asociativa con los identificadores de los objetos y sus respectivos valores comenzando por el object_id como raíz y FALSE en caso de error.

La función snmpwalkoid() es usada para leer todos los identificadores de objetos y sus respectivos valores de un agente SNMP especificado por el nombre del servidor. La lectura de community especifica la comunidad para el agente. Un object_id nulo es tomado como la raíz del arbol de objetos SNMP y todos los objetos por debajo de este arbol son devueltos como una matriz. Si object_id es especificado, todos los objetos SNMP inferiores al object_id son devueltos.

La existencia de snmpwalkoid() y snmpwalk() tiene razones historicas. Ambas funciones son proporcionadas para compatibilidad hacia atrás.

$a = snmpwalkoid("127.0.0.1", "public", "");

La llamada a las funciones superiores devuelve todos los objetos SNMP del agente SNMP en ejecución en el servidor local. Uno puede pasar por todos los valores con un bucle.

for (reset($a); $i = key($a); next($a)) {
    echo "$i: $a[$i]<br>\n";
}

Anterior | Inicio | Siguiente
snmpwalk | Subir | Socket functions


snmp_get_quick_print

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

snmp_get_quick_print -- Va a buscar el valor actual de la biblioteca UCD estableciendo quick_print

Descripción

boolean snmp_get_quick_print ( void )

Delvuele el valor actual almacenado en la biblioteca UCD para quick_print. quick_print está desactivado por defecto.

$quickprint = snmp_get_quick_print();

La llamada a la función superior podría devolver FALSE si quick_print está activo, y TRUE si quick_print está activo.

snmp_get_quick_print() está solamente disponible cuando estemos usando la biblioteca UCD SNMP. Esta función no está disponible cuando estemos usando la biblioteca Windows SNMP.

Ver: snmp_get_quick_print() para una descripción completa de lo que hace quick_print.

Anterior | Inicio | Siguiente
Funciones SNMP | Subir | snmp_set_quick_print


snmp_set_quick_print

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

snmp_set_quick_print -- Establece el valor de quick_print con el de la biblioteca UCD SNMP.

Descripción

void snmp_set_quick_print ( boolean quick_print)

Establece el valor de quick_print con la biblioteca UCD SNMP. Cuando esto está establecido (1), la biblioteca SNMP devolverá valores 'quick printed'. De esta manera sólo el valor será impreso. Cuando quick_print no está activada (por defecto) la biblioteca UCD SNMP imprime información extra incluyendo el tipo del valor (p. Ej. IPAddress o OID). Adicionalmente, si quick_print no está activado, la biblioteca imprime valores hexadecimales adicionales para todas las cadenas de 3 o menos caracteres.

El ajuste de quick_print es generalmente usado cuando usando la información devuelta con anterioridad se muestra.

snmp_set_quick_print(0);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a<BR>\n";
snmp_set_quick_print(1);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a<BR>\n";

El primer valor impreso debe de ser: 'Timeticks: (0) 0:00:00.00', donde qick_print se activa, solo se imprimira '0:00:00.00'.

Por defecto la biblioteca UCD SNMP devuelve valores detallados, quick_print es usado para devolver solamente el valor.

Las cadenas son mantenidas normalmente con comillas extra, esto será corregido en versiones posteriores.

snmp_get_quick_print() está sólo disponible cuando estemos usando la biblioteca UCD SNMP. Esta función no está disponible cuando estemos usando la biblioteca Windows SNMP.

Anterior | Inicio | Siguiente
snmp_get_quick_print | Subir | snmpget


Socket functions

Manual de PHP
Anterior Siguiente

XCIV. Socket functions

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

The socket extension implements a low-level interface to the socket communication functions, providing the possibility to act as a socket server as well as a client.

For a more generic client-side socket interface, see fsockopen() and pfsockopen().

When using the socket functions described here, it is important to remember that while many of them have identical names to their C counterparts, they often have different declarations. Please be sure to read the descriptions to avoid confusion.

That said, those unfamiliar with socket programming can still find a lot of useful material in the appropriate Unix man pages, and there is a great deal of tutorial information on socket programming in C on the web, much of which can be applied, with slight modifications, to socket programming in PHP.

Ejemplo 1. Socket example: Simple TCP/IP server

This example shows a simple talkback server. Change the address and port variables to suit your setup and execute. You may then connect to the server with a command similar to: telnet 192.168.1.53 10000 (where the address and port match your setup). Anything you type will then be output on the server side, and echoed back to you. To disconnect, enter 'quit'.

<?php
error_reporting(E_ALL);

/* Allow the script to hang around waiting for connections. */
set_time_limit(0);

$address = '192.168.1.53';
$port = 10000;

if (($sock = socket(AF_INET, SOCK_STREAM, 0)) < 0) {
    echo "socket() failed: reason: " . strerror($sock) . "\n";
}

if (($ret = bind($sock, $address, $port)) < 0) {
    echo "bind() failed: reason: " . strerror($ret) . "\n";
}

if (($ret = listen($sock, 5)) < 0) {
    echo "listen() failed: reason: " . strerror($ret) . "\n";
}

do {
    if (($msgsock = accept_connect($sock)) < 0) {
        echo "accept_connect() failed: reason: " . strerror($msgsock) . "\n";
        break;
    }
    do {
        $buf = '';
        $ret = read($msgsock, $buf, 2048);
        if ($ret < 0) {
            echo "read() failed: reason: " . strerror($ret) . "\n";
            break 2;
        }
        if ($ret == 0) {
            break 2;
        }
        $buf = trim($buf);
        if ($buf == 'quit') {
            close($msgsock);
            break 2;
        }
        $talkback = "PHP: You said '$buf'.\n";
        write($msgsock, $talkback, strlen($talkback));
        echo "$buf\n";
    } while (true);
    close($msgsock);
} while (true);

close($sock);
?>

Ejemplo 2. Socket example: Simple TCP/IP client

This example shows a simple, one-shot HTTP client. It simply connects to a page, submits a HEAD request, echoes the reply, and exits.

<?php
error_reporting(E_ALL);

echo "<h2>TCP/IP Connection</h2>\n";

/* Get the port for the WWW service. */
$service_port = getservbyname('www', 'tcp');

/* Get the IP address for the target host. */
$address = gethostbyname('www.php.net');

/* Create a TCP/IP socket. */
$socket = socket(AF_INET, SOCK_STREAM, 0);
if ($socket < 0) {
    echo "socket() failed: reason: " . strerror($socket) . "\n";
} else {
    "socket() successful: " . strerror($socket) . "\n";
}

echo "Attempting to connect to '$address' on port '$service_port'...";
$result = connect($socket, $address, $service_port);
if ($result < 0) {
    echo "connect() failed.\nReason: ($result) " . strerror($result) . "\n";
} else {
    echo "OK.\n";
}

$in = "HEAD / HTTP/1.0\r\n\r\n";
$out = '';

echo "Sending HTTP HEAD request...";
write($socket, $in, strlen($in));
echo "OK.\n";

echo "Reading response:\n\n";
while (read($socket, $out, 2048)) {
    echo $out;
}

echo "Closing socket...";
close($socket);
echo "OK.\n\n";
?>

Tabla de contenidos
accept_connect — Accepts a connection on a socket.
bind — Binds a name to a socket.
connect — Initiates a connection on a socket.
listen — Listens for a connection on a socket.
socket — Create a socket (endpoint for communication).
strerror — Return a string describing a socket error.

Anterior | Inicio | Siguiente
snmpwalkoid | Subir | accept_connect


accept_connect

(4.0.2 - 4.0.6 only)

accept_connect -- Accepts a connection on a socket.

Description

int accept_connect ( int socket)

After the socket socket has been created using socket(), bound to a name with bind(), and told to listen for connections with listen(), this function will accept incoming connections on that socket. Once a successful connection is made, a new socket descriptor is returned, which may be used for communication. If there are multiple connections queued on the socket, the first will be used. If there are no pending connections, accept_connect() will block until a connection becomes present. If socket has been made non-blocking using socket_set_blocking() or set_nonblock(), an error code will be returned.

The socket descriptor returned by accept_connect() may not be used to accept new connections. The original listening socket socket, however, remains open and may be reused.

Returns a new socket descriptor on success, or a negative error code on failure. This code may be passed to strerror() to get a textual explanation of the error.

See also
bind(),
connect(),
listen(),
socket(), and
strerror().

Anterior | Inicio | Siguiente
Socket functions | Subir | bind


bind

(4.0.2 - 4.0.6 only)

bind -- Binds a name to a socket.

Description

int bind ( int socket, string address [, int protocol])

bind() binds the name given in address to the socket described by socket, which must be a valid socket descriptor created with socket().

The address parameter is either an IP address in dotted-quad notation (e.g. 127.0.0.1), if the socket is of the AF_INET family; or the pathname of a Unix-domain socket, if the socket family is AF_UNIX.

The port parameter is only used when connecting to an AF_INET socket, and designates the port on the remote host to which a connection should be made.

Returns zero on success, or a negative error code on failure. This code may be passed to strerror() to get a textual explanation of the error.

See also
accept_connect(),
connect(),
listen(),
socket(), and
strerror().

Anterior | Inicio | Siguiente
accept_connect | Subir | connect


connect

(4.0.2 - 4.0.6 only)

connect -- Initiates a connection on a socket.

Description

int connect ( int socket, string address [, int port])

Initiates a connection using the socket descriptor socket, which must be a valid socket descriptor created with socket().

The address parameter is either an IP address in dotted-quad notation (e.g. 127.0.0.1), if the socket is of the AF_INET family; or the pathname of a Unix-domain socket, if the socket family is AF_UNIX.

The port parameter is only used when connecting to an AF_INET socket, and designates the port on the remote host to which a connection should be made.

Returns zero on success, or a negative error code on failure. This code may be passed to strerror() to get a textual explanation of the error.

See also
bind(),
listen(),
socket(), and
strerror().

Anterior | Inicio | Siguiente
bind | Subir | listen


listen

(4.0.2 - 4.0.6 only)

listen -- Listens for a connection on a socket.

Description

int listen ( int socket, int backlog)

After the socket socket has been created using socket() and bound to a name with bind(), it may be told to listen for incoming connections on socket. A maximum of backlog incoming connections will be queued for processing.

listen() is applicable only to sockets with type SOCK_STREAM or SOCK_SEQPACKET.

Returns zero on success, or a negative error code on failure. This code may be passed to strerror() to get a textual explanation of the error.

See also
accept_connect(),
bind(),
connect(),
socket(), and
strerror().

Anterior | Inicio | Siguiente
connect | Subir | socket


socket

(4.0.2 - 4.0.6 only)

socket -- Create a socket (endpoint for communication).

Description

int socket ( int domain, int type, int protocol)

Creates a communication endpoint (a socket), and returns a descriptor to the socket.

The domain parameter sets the domain. Currently, AF_INET and AF_UNIX are understood.

The type parameter selects the socket type. This is one of SOCK_STREAM, SOCK_DGRAM, SOCK_SEQPACKET, SOCK_RAW, SOCK_RDM, or SOCK_PACKET.

protocol sets the protocol.

Returns a valid socket descriptor on success, or a negative error code on failure. This code may be passed to strerror() to get a textual explanation of the error.

For more information on the usage of socket(), as well as on the meanings of the various parameters, see the Unix man page socket (2).

See also
accept_connect(),
bind(),
connect(),
listen(), and
strerror().

Anterior | Inicio | Siguiente
listen | Subir | strerror


strerror

(4.0.2 - 4.0.6 only)

strerror -- Return a string describing a socket error.

Description

string strerror ( int errno)

strerror() takes as its errno parameter the return value of one of the socket functions, and returns the corresponding explanatory text. This makes it a bit more pleasant to figure out why something didn't work; for instance, instead of having to track down a system include file to find out what '-111' means, you just pass it to strerror(), and it tells you what happened.

Ejemplo 1. strerror() example

<?php
if (($socket = socket(AF_INET, SOCK_STREAM, 0)) < 0) {
   echo "socket() failed: reason: " . strerror($socket) . "\n";
}

if (($ret = bind($socket, '127.0.0.1', 80)) < 0) {
   echo "bind() failed: reason: " . strerror($ret) . "\n";
}
?>

The expected output from the above example (assuming the script is not run with root privileges):
bind() failed: reason: Permission denied

See also
accept_connect(),
bind(),
connect(),
listen(), and
socket().

Anterior | Inicio | Siguiente
socket | Subir | Funciones de cadenas


Funciones de cadenas

Manual de PHP
Anterior Siguiente

XCV. Funciones de cadenas

Todas estas funciones manipulan cadenas de varias maneras. En las secciones sobre expresiones regulares y manejo de URL se pueden encontrar secciones más especializadas.

Tabla de contenidos
AddCSlashes — Marca una cadena con barras al estilo del C
AddSlashes — Marca una cadena con barras
bin2hex — Convierte datos binarios en su representación hexadecimal
chop — Elimina espacios sobrantes al final
chr — Devuelve un caracter específico
chunk_split — Divide una cadena en trozos más pequeños
convert_cyr_string — Convierte de un juego de caracteres Cirílico a otro
count_chars — Devuelve información sobre los caracteres usados en una cadena
crc32 — Calcula el polinomio crc32 de una cadena
crypt — Encripta una cadena mediante DES
echo — Da salida a una o más cadenas
explode — Divide una cadena por otra
get_html_translation_table — Devuelve la tabla de traducción utilizada por htmlspecialchars() y htmlentities()
get_meta_tags — Extrae todas las etiquetas meta de un archivo y retorna una matriz
hebrev — Convierte Hebreo lógico a texto visual
hebrevc — Convierte Hebreo lógico a texto visual con conversión de saltos de línea
htmlentities — Convierte todos los caracteres aplicables a entidades HTML
htmlspecialchars — Convierte caracteres especiales a entidades HTML
implode — Unir elementos de una matriz mediante una cadena
join — Une elementos de una tabla mediante una cadena
levenshtein — Calcula la distancia Levenshtein entre dos cadenas
ltrim — Elimina el espacio en blanco del principio de una cadena
md5 — Calcula el hash md5 de una cadena
metaphone — Calcula la clave "metáfona" de una cadena
nl2br — Convierte nuevas líneas a saltos de línea HTML
ord — Devuelve el valor ASCII de un caracter
parse_str — Divide la cadena en variables
print — Emite una cadena
printf — Emite una cadena con formato
quoted_printable_decode — Convierte una cadena con marcación imprimible a una cadena de 8 bits
quotemeta — Quote meta characters
rtrim — Elimina espacios en blanco al final de la cadena.
setlocale — Fija la información de localidad
similar_text — Calcula la similitud entre dos cadenas
soundex — Calcula la clave soundex de una cadena
sprintf — Devuelve una cadena con formato
sscanf — Trocea la entrada desde una cadena según un formato dado
str_pad — Rellena una cadena con otra hasta una longitud dada
str_repeat — Repite una cadena
str_replace — Sustitiye todas las apariciones de la aguja en el pajar por la cadena
strcasecmp — Comparación de cadenas insensible a mayúsculas y minúsculas y segura en modo binario
strchr — Encuentra la primera aparición de un caracter
strcmp — Comparación de cadenas con seguridad binaria
strcspn — Encuentra la longitud del elemento inicial que no coincide con la máscara
strip_tags — Elimina marcas HTML y PHP de una cadena
stripcslashes — Desmarca la cadena marcada con addcslashes()
stripslashes — Desmarca la cadena marcada con addslashes()
stristr — strstr() sin tener en cuenta mayúsculas o minúsculas
strlen — Obtiene la longitud de la cadena
strnatcasecmp — Comparación de cadenas insensible a mayúsculas y minúsculas usando un algoritmo de "orden natural"
strnatcmp — Compara cadenas usando un algoritmo de "orden natural"
strncmp — Comparación de los n primeros caracteres de cadenas, con seguridad binaria
strpos — Encuentra la posición de la primera aparición de una cadena
strrchr — Encuentra la última aparición de un caracter en una cadena
strrev — Invierte una cadena
strrpos — Encuentra la posición de la última aparición de un caracter en una cadena
strspn — Encuentra la longitud del segmento inicial que coincide con la máscara
strstr — Encuentra la primera aparición de una cadena
strtok — Divide una cadena en elementos
strtolower — Pasa a minúsculas una cadena
strtoupper — Pasa a mayúsculas una cadena
strtr — Traduce ciertos caracteres
substr — Devuelve parte de una cadena
substr_count — Cuenta el número de apariciones de la subcadena
substr_replace — Sustituye texto en una parte de una cadena
trim — Elimina espacios del principio y final de una cadena
ucfirst — Pasar a mayúsculas el primer caracter de una cadena
ucwords — Pone en mayúsculas el primer caracter de cada palabra de una cadena
wordwrap — Corta una cadena en un número dado de caracteres usando un caracter de ruptura de cadenas.

Anterior | Inicio | Siguiente
strerror | Subir | AddCSlashes


AddCSlashes

(PHP 4 >= 4.0.0)

AddCSlashes -- Marca una cadena con barras al estilo del C

Descripción

string addcslashes ( string cad, string listcar)

Devuelve una cadena con barras invertidas antes de los caracteres listados en el parámetro listcar. También marca \n, \r etc. Al estilo del C, los caracteres con códico ASCII inferior a 32 y superior a 126 son convertidos a representación octal. Tenga cuidado cuando marque caracteres alfanuméricos. Puede especificar un rango en listcar como el "\0..\37", que marcaría todos los caracteres con código ASCII entre 0 y 31.

Ejemplo 1. Ejemplo de addcslashes()

$tradformado = addcslashes ($no_transf, "\0..\37!@\177..\377");

Nota: Añadida en PHP4b3-dev.

Vea también stripcslashes(),
stripslashes(),
htmlspecialchars(),
htmlspecialchars(), y
quotemeta().

Anterior | Inicio | Siguiente
Funciones de cadenas | Subir | AddSlashes


AddSlashes

(PHP 3, PHP 4 >= 4.0.0)

AddSlashes -- Marca una cadena con barras

Descripción

string addslashes ( string cad)

Devuelve una cadena con barras invertidas frente a los caracteres que necesitan marcarse en consultas de bases de datos, etc. Estos son la comilla simple ('), comilla doble ("), barra invertida (\) y NUL (el byte nulo).

Vea también stripslashes(),
htmlspecialchars(), y
quotemeta().

Anterior | Inicio | Siguiente
AddCSlashes | Subir | bin2hex


bin2hex

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

bin2hex -- Convierte datos binarios en su representación hexadecimal

Descripción

string bin2hex ( string cad)

Devuelve una cadena ASCII que contiene la representación hexadecimal de cad. La conversión se realiza byte a byte, con los 4 bits superiores primero.

Anterior | Inicio | Siguiente
AddSlashes | Subir | chop


chop

(PHP 3, PHP 4 >= 4.0.0)

chop -- Elimina espacios sobrantes al final

Descripción

string chop ( string cad)

Devuelve la cadena argumento sin los espacios sobrantes, incluyendo los saltos de línea.

Ejemplo 1. Ejemplo de chop()

$recortada = chop ($linea);

Vea también trim().

Anterior | Inicio | Siguiente
bin2hex | Subir | chr


chr

(PHP 3, PHP 4 >= 4.0.0)

chr -- Devuelve un caracter específico

Descripción

string chr ( int ascii)

Devuelve una cadena de un caracter que congiene el caracter especificado por ascii.

Ejemplo 1. Ejemplo de chr()

$cad .= chr (27); /* añade un caracter de escape al final de $cad */

/* A veces esto es más útil */

$cad = sprintf ("La cadena termina en escape: %c", 27);
Esta función complementa a ord(). Vea también sprintf() con una cadena de formato %c.

Anterior | Inicio | Siguiente
chop | Subir | chunk_split


chunk_split

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

chunk_split -- Divide una cadena en trozos más pequeños

Descripción

string chunk_split ( string cadena [, int tamatrozo [, string final]])

Se puede utilizar para trocear una cadena en pedazos más pequeños, lo que es útil, p.ej., para convertir la salida de la función base64_encode a la semántica del RFC 2045. Inserta la cadena final cada tamatrozo (por defecto vale 76) caracteres. Devuelve la nueva cadena y deja intacta la original.

Ejemplo 1. Ejemplo de chunk_split()

# formatear $datos usando la semántica del RFC 2045

$nueva_cad = chunk_split (base64_encode($datos));
Esta función es notablemente más rápida que ereg_replace().

Nota: Esta función se añadió en la 3.0.6.

Anterior | Inicio | Siguiente
chr | Subir | convert_cyr_string


convert_cyr_string

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

convert_cyr_string -- Convierte de un juego de caracteres Cirílico a otro

Descripción

string convert_cyr_string ( string cad, string desde, string hasta)

Esta función convierte la cadena dada de un juego de caracteres Cirílico a otro. Los argumentos desde y hasta son caracteres sencillos que representan los juegos de caracteres Cirílicos fuente y destino. Los tipos soportados son:

  • k - koi8-r

  • w - windows-1251

  • i - iso8859-5

  • a - x-cp866

  • d - x-cp866

  • m - x-mac-cyrillic

Anterior | Inicio | Siguiente
chunk_split | Subir | count_chars


count_chars

(PHP 4 >= 4.0.0)

count_chars -- Devuelve información sobre los caracteres usados en una cadena

Descripción

mixed count_chars ( string cadena [, modo])

Cuenta el número de apariciones de cada valor de byte (0..255) en cadena y lo devuelve de varias maneras. El parámetro opcional modo vale por defecto 0. Dependiendo de modo, count_chars() puede devolver:

  • 0 - una matriz con el valor del byte como clave y la frecuencia de cada uno como valor.

  • 1 - como el 0, pero listando únicamente los valores de byte con frecuencia superior a cero.

  • 2 - como el 0, pero listando únicamente los valores de byte con frecuencia igual a 0.

  • 3 - se devuelve una cadena que contiene todos los valores de byte utilizados.

  • 4 - se devuelve una cadena que contiene todos los valores de byte no utilizados.

Nota: Esta función se añadió en el PHP 4.0.

Anterior | Inicio | Siguiente
convert_cyr_string | Subir | crc32


crc32

(PHP 4 )

crc32 -- Calcula el polinomio crc32 de una cadena

Descripción

int crc32 ( string cad)

Genera el polinomio de comprobación de reduncancia cíclica de 32 bits de cad. Se suele utilizar para validad la integridad de los datos transmitidos.

Vea también: md5()

Anterior | Inicio | Siguiente
count_chars | Subir | crypt


crypt

(PHP 3, PHP 4 >= 4.0.0)

crypt -- Encripta una cadena mediante DES

Descripción

string crypt ( string cad [, string semilla])

crypt() encriptará una cadena utilizando el método estándar de encriptación del Unix DES. Los argumentos son una cadena a encriptar y una cadena semilla de 2 caracteres en la que basar la encriptación. Vea la página de manual de Unix sobre crypt para más información.

Si el argumento de semilla no se proporciona, será generado aleatoriamente por el PHP.

Algunos sistemas operativos soportan más de un tipo de encriptación. De hecho, algunas veces la encriptación estándar DES es sustituída por un algoritmo de encriptación basado en MD5. El tipo de encriptación es disparado por el argumento semilla. En tiempo de instalación, el PHP determina la capacidad de la función de encriptación y aceptará semillas para otros tipos de encriptación. Si no se proporciona la semilla, el PHP intentará generar una semilla estándar DES de 2 caraceres por defecto, excepto si el tipo de encriptación estándar del sistema es el MD5, en cuyo caso se generará una semilla aleatoria compatible con MD5. El PHP fija una constante llamada CRYPT_SALT_LENGTH que le especifica si su sistema soporta una semilla de 2 caracteres o si se debe usar la semilla de 12 caracteres del NDS.

La función estándar de encriptación crypt() contiene la semilla como los dos primeros caracteres de la salida.

En los sistemas en los que la función crypt() soporta múltiples tipos de encriptación, las siguienes constantes son fijadas a 0 ó 1 dependiendo de si está disponible el tipo dado:

  • CRYPT_STD_DES - Encriptación DES estándar con semilla de 2 caracteres

  • CRYPT_EXT_DES - Encriptación DES extendida con semilla de 9 caracteres

  • CRYPT_MD5 - Encriptación MD5 con semilla de 12 caracteres y comenzando por $1$

  • CRYPT_BLOWFISH - Encriptación DES extendida con semilla de 16 caracteres y comenzando por $2$

No hay función de desencriptado porque crypt() utiliza un algoritmo de una sola vía.

Vea también: md5().

Anterior | Inicio | Siguiente
crc32 | Subir | echo


echo

(unknown)

echo -- Da salida a una o más cadenas

Descripción

echo ( string arg1 [, string argn...])

Da salida a todos sus parámetros.

echo() no es realmente una función (es una sentencia del lenguaje) de modo que no se requiere el uso de los paréntesis.

Ejemplo 1. Ejemplo de echo()

echo "Hola Mundo";

echo "Esto se extiende
por varias líneas. Los saltos de línea
también se envían";

echo "Esto se extiende\npor varias líneas. Los saltos de línea\ntambién se envían";

Nota: De hecho, si desea pasar más de un parámetro a echo no debe encerrarlos entre paréntesis.

Vea también:
print(),
printf(), y
flush().

Anterior | Inicio | Siguiente
crypt | Subir | explode


explode

(PHP 3, PHP 4 >= 4.0.0)

explode -- Divide una cadena por otra

Descripción

array explode ( string separador, string cadena [, int limite])

Devuelve una matriz de cadenas, cada una de las cuales es una subcadena de cadena formada mediante su división en las fronteras marcadas por la cadena separador. Si se especifica limite, la matriz devuelta contendrá un máximo de limite elementos con el último conteniendo el resto de la cadena.

Ejemplo 1. Ejemplo de explode()

$pizza = "trozo1 trozo2 trozo3 trozo4 trozo5 trozo6";
$trozos = explode (" ", $pizza);

Vea también split() e implode().

Anterior | Inicio | Siguiente
echo | Subir | get_html_translation_table


get_html_translation_table

(PHP 4 >= 4.0.0)

get_html_translation_table -- Devuelve la tabla de traducción utilizada por htmlspecialchars() y htmlentities()

Descripción

string get_html_translation_table ( int tabla)

get_html_translation_table() devolverá la tabla de traducción que se usa internamente para htmlspecialchars() y htmlentities(). Hay dos nuevas definiciones (HTML_ENTITIES, HTML_SPECIALCHARS) que le permiten especificar la tabla deseada.

Ejemplo 1. Ejemplo de Tabla de Traducción

$trad = get_html_translation_table (HTML_ENTITIES);
$cad = "Hallo & <Frau> & Krämer";
$codif = strtr ($cad, $trad);
La variable $codif contendrá ahora: "Hallo &amp; &lt;Frau&gt; &amp; Kr&auml;mer".

Lo interesante es usar la función array_flip() para cambiar la dirección de la traducción.

$trad = array_flip ($trad);
$original = strtr ($cad, $trad);

El contenido de $original sería: "Hallo & <Frau> & Krämer".

Nota: Esta función fue añadida en PHP 4.0.

Vea también: htmlspecialchars(),
htmlentities(), strtr(),
y array_flip().

Anterior | Inicio | Siguiente
explode | Subir | get_meta_tags


get_meta_tags

(PHP 3>= 3.0.4, PHP 4 >= 4.0.0)

get_meta_tags -- Extrae todas las etiquetas meta de un archivo y retorna una matriz

Descripción

array get_meta_tags ( string nombrefich [, int use_ruta_include])

Abre el nombrefich y lo trocea línea a línea buscando etiquetas <meta> de la forma

Ejemplo 1. Ejemplo de Etiquetas Meta

<meta name="autor" content="nombre">
<meta name="etiquetas" content="documentación de php3">
</head> <!-- el proceso se detiene aquí -->
(preste atención a los finales de línea - el PHP utiliza una función nativa para trocear la entrada, de modo que un archivo de Mac no funcionará en Unix).

El valor de la propiedad name queda como clave y el valor de la propiedad content queda como el valor de la matriz devuelta, de modo que pueda usar fácilmente funciones estándar de matrices para recorrerla o para acceder a valores individuales. Los caracteres especiales en el valor de name son sustituídos por '_' y el resto es convertido a minúsculas.

Fijando use_ruta_include a 1 hará que el PHP intente abrir el archivo a través de la ruta de inclusión.

Anterior | Inicio | Siguiente
get_html_translation_table | Subir | hebrev


hebrev

(PHP 3, PHP 4 >= 4.0.0)

hebrev -- Convierte Hebreo lógico a texto visual

Descripción

string hebrev ( string texto_hebreo [, int max_cars_por_linea])

El parámetro opcional max_cars_por_linea indica el máximo número de caracteres que se emitirán por línea. La función intenta evitar cortar palabras.

Vea también hebrevc()

Anterior | Inicio | Siguiente
get_meta_tags | Subir | hebrevc


hebrevc

(PHP 3, PHP 4 >= 4.0.0)

hebrevc -- Convierte Hebreo lógico a texto visual con conversión de saltos de línea

Descripción

string hebrevc ( string texto_hebreo [, int max_cars_por_linea])

Esta funcion es similar a hebrev() con la diferencia que convierte las nuevas líneas (\n) a "<br>\n". El parámetro opcional max_cars_por_linea indica el máximo número de caracteres que se emitirán por línea. La función intenta evitar cortar palabras.

Vea también hebrev()

Anterior | Inicio | Siguiente
hebrev | Subir | htmlentities


htmlentities

(PHP 3, PHP 4 >= 4.0.0)

htmlentities -- Convierte todos los caracteres aplicables a entidades HTML

Descripción

string htmlentities ( string cadena)

Esta función es del todo idéntica a htmlspecialchars(), excepto que traduce todos los caracteres que tienen equivalente como entidad HTML.

Actualmente se utiliza el juego de caracteres ISO-8859-1.

Vea también htmlspecialchars() y nl2br().

Anterior | Inicio | Siguiente
hebrevc | Subir | htmlspecialchars


htmlspecialchars

(PHP 3, PHP 4 >= 4.0.0)

htmlspecialchars -- Convierte caracteres especiales a entidades HTML

Descripción

string htmlspecialchars ( string cadena)

Ciertos caracteres tienen significados especiales en HTML, y deben ser representados por entidades HTML si se desea preservar su significado. Esta función devuelve una cadena con dichas conversiones realizadas.

Esta función es útil para evitar que el texo entrado por el usuario contenga marcas HTML, como ocurre en aplicaciones de foros o libros de visita.

Actualmente, las traducciones hechas son:

  • '&' (ampersand) se convierte en '&amp;'

  • '"' (doble comilla) se convierte en '&quot;'

  • '<' (menor que) se convierte en '&lt;'

  • '>' (mayor que) se convierte en '&gt;'

Nótese que esta función no traduce nada más que lo mostrado más arriba. Para una traducción de entidades completa, vea htmlentities().

Vea también htmlentities() y nl2br().

Anterior | Inicio | Siguiente
htmlentities | Subir | implode


implode

(PHP 3, PHP 4 >= 4.0.0)

implode -- Unir elementos de una matriz mediante una cadena

Descripción

string implode ( string cola, array piezas)

Devuelve una cadena que contiene una representación de todos los elementos de la matriz en el mismo orden, pero con la cadena cola en medio de los mismos.

Ejemplo 1. Ejemplo de implode()

$separada_dospuntos = implode (":", $matrizay);

Vea también explode(), join(), y split().

Anterior | Inicio | Siguiente
htmlspecialchars | Subir | join


join

(PHP 3, PHP 4 >= 4.0.0)

join -- Une elementos de una tabla mediante una cadena

Descripción

string join ( string cola, array piezas)

join() es un alias para implode(), y es idéntica en todo.

Vea también explode(), implode(), y split().

Anterior | Inicio | Siguiente
implode | Subir | levenshtein


levenshtein

(PHP 3>= 3.0.17, PHP 4 )

levenshtein -- Calcula la distancia Levenshtein entre dos cadenas

Descripción

int levenshtein ( string cad1, string cad2)

Esta función devuelve la distancia Levenshtein entre las dos cadenas argumento, ó -1 si alguna de las cadenas tiene más de 255 caracteres.

La distancia Levenshtein se define como el mínimo número de caracteres que se tienen que sustituir, insertar o borrar para transformar cad1 en cad2. La complejidad del algoritmo es O(m*n), donde n y m son las longitudes de cad1 y cad2 (bastante bueno si se la compara con similar_text(), que es O(max(n,m)**3), pero aún es cara).

Vea también soundex(),
similar_text() y
metaphone().

Anterior | Inicio | Siguiente
join | Subir | ltrim


ltrim

(PHP 3, PHP 4 >= 4.0.0)

ltrim -- Elimina el espacio en blanco del principio de una cadena

Descripción

string ltrim ( string cad)

Esta función elimina el espacio en blanco del principio de una cadena y devuelve la cadena resultante. Los caracteres de espacio que elimina realmente son: "\n", "\r", "\t", "\v", "\0", y el espacio en sí.

Vea también chop() y trim().

Anterior | Inicio | Siguiente
levenshtein | Subir | md5


md5

(PHP 3, PHP 4 >= 4.0.0)

md5 -- Calcula el hash md5 de una cadena

Descripción

string md5 ( string cad)

Calcula el hash (extracto) MD5 de cad usaneo el Algoritmo de Resumen de Mensajes MD5 de RSA Data Security, Inc. .

Vea también: crc32()

Anterior | Inicio | Siguiente
ltrim | Subir | metaphone


metaphone

(PHP 4 >= 4.0.0)

metaphone -- Calcula la clave "metáfona" de una cadena

Descripción

string metaphone ( string cad)

Calcula la clave "metáfona" de cad.

Similarmente a soundex(), metaphone crea la misma clave para palabras que suenan parecidas. Es más precisa que la función soundex(), pues conoce las reglas básicas de la pronunciación del Inglés. Las claves metafónicas generadas son de longitud variable.

Metaphone fue desarrollado por Lawrence Philips <lphilips@verity.com>. Se describe en ["Practical Algorithms for Programmers", Binstock & Rex, Addison Wesley, 1995].

Nota: Esta función se añadió en PHP 4.0.

Anterior | Inicio | Siguiente
md5 | Subir | nl2br


nl2br

(PHP 3, PHP 4 >= 4.0.0)

nl2br -- Convierte nuevas líneas a saltos de línea HTML

Descripción

string nl2br ( string cadena)

Devuelve la cadena con '<BR>' insertados antes de cada nueva línea.

Vea también htmlspecialchars(),
htmlentities() y
wordwrap().

Anterior | Inicio | Siguiente
metaphone | Subir | ord


ord

(PHP 3, PHP 4 >= 4.0.0)

ord -- Devuelve el valor ASCII de un caracter

Descripción

int ord ( string cadena)

Devuelve el valor ASCII del primer caracter de cadena. Esta función complementa a chr().

Ejemplo 1. Ejemplo de ord()

if (ord ($cad) == 10) {
    echo "El primer caracter de \$cad es un salto de línea.\n";
}

Vea también chr().

Anterior | Inicio | Siguiente
nl2br | Subir | parse_str


parse_str

(PHP 3, PHP 4 >= 4.0.0)

parse_str -- Divide la cadena en variables

Descripción

void parse_str ( string cad)

Divide cad como si fuera la cadena de consulta enviada por un URL y crea las variables en el ámbito actual.

Ejemplo 1. Usando parse_str()

$cad = "primero=valor&segundo[]=esto+funciona&segundo[]=otro";
parse_str($cad);
echo $primero;    /* escribe "valor" */
echo $segundo[0]; /* escribe "esto funciona" */
echo $segundo[1]; /* escribe "otro" */

Anterior | Inicio | Siguiente
ord | Subir | print


print

(unknown)

print -- Emite una cadena

Descripción

print ( string arg)

Emite arg.

Vea también: echo(), printf(), y flush().

Anterior | Inicio | Siguiente
parse_str | Subir | printf


printf

(PHP 3, PHP 4 >= 4.0.0)

printf -- Emite una cadena con formato

Descripción

int printf ( string formato [, mixed args])

Produce una salida según el formato, que es descrito en la documentación para sprintf().

Vea también: print(), sprintf(),
    sscanf(), fscanf(),
    y flush().

Anterior | Inicio | Siguiente
print | Subir | quoted_printable_decode


quoted_printable_decode

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

quoted_printable_decode -- Convierte una cadena con marcación imprimible a una cadena de 8 bits

Descripción

string quoted_printable_decode ( string cad)

Esta función devuelve una cadena binaria de 8 bit que se corresponde con la cadena con marcación imprimible decodificada. Esta función es similar a imap_qprint(), pero sin requerir que el módulo IMAP funcione.

Anterior | Inicio | Siguiente
printf | Subir | quotemeta


quotemeta

(PHP 3, PHP 4 >= 4.0.0)

quotemeta -- Quote meta characters

Descripción

string quotemeta ( string cad)

Devuelve una versión de la cadena con una barra invertida (\) antes de cada caracter de este conjunto:
. \\ + * ? [ ^ ] ( $ )

Vea también addslashes(),
htmlentities(),
htmlspecialchars(),
nl2br(), y
stripslashes().

Anterior | Inicio | Siguiente
quoted_printable_decode | Subir | rtrim


rtrim

(PHP 3, PHP 4 >= 4.0.0)

rtrim -- Elimina espacios en blanco al final de la cadena.

Descripción

string rtrim ( string cad)

Devuelve la cadena argumento sin espacios en blanco ni saltos de línea al final. Es un alias para chop().

Ejemplo 1. Ejemplo de rtrim()

$recortada = rtrim ($linea);

Vea también trim(), ltrim().

Anterior | Inicio | Siguiente
quotemeta | Subir | setlocale


sscanf

(PHP 4 )

sscanf -- Trocea la entrada desde una cadena según un formato dado

Descripción

mixed sscanf ( string cad, string formato [, string var1])

La funciónsscanf() es la función de entrada análoga de printf(). sscanf() lee del parámetro de cadena cad y lo interpreta según el formato especificado. Si sólo se pasan dos parámetros a esta función, los valores devueltos se harán en una matriz.

Ejemplo 1. Ejemplo de sscanf()

// obteniendo el número de serie
$numserie = sscanf("SN/2350001","SN/%d");
// y la fecha de fabricación
$fecha = "01 Enero 2000";
list($dia, $mes, $anno) = sscanf($fecha,"%d %s %d");
echo "El objeto $numserie fue fabricado el: $anno-".substr($mes,0,3)."-$dia\n";
Si se pasan los parámetros opcionales, la función devolverá el número de valores asignados. Los parámetros opcionales deben ser pasados por referencia.

Ejemplo 2. Ejemplo de sscanf() - usando parámetros opcionales

// obtener autor y generar la ficha DocBook
$autor = "24\tLewis Carroll";
$n = sscanf($autor,"%d\t%s %s", &$id, &$nombre, &$apell);
echo "<autor id='$id'>
        <firstname>$nombre</firstname>
        <surname>$apell</surname>
</author>\n";

Vea también: fscanf(), printf(), y sprintf().

Anterior | Inicio | Siguiente
sprintf | Subir | str_pad


setlocale

(PHP 3, PHP 4 >= 4.0.0)

setlocale -- Fija la información de localidad

Descripción

string setlocale ( string categoria, string localidad)

categoria es una cadena que especifica la categoría de las funciones afectadas por el ajuste de localidad:

  • LC_ALL para todas las funciones

  • LC_COLLATE para la comparación de cadenas - aún no incluída en el PHP

  • LC_CTYPE para la conversión y clasificación de caracteres, como por ejemplo strtoupper()

  • LC_MONETARY para localeconv() - aún no incluída en el PHP

  • LC_NUMERIC para el separador decimal

  • LC_TIME para el formato de fecha y hora con strftime()

Si localidad es la cadena vacía "", los nombres de localidad se fijarán a partir de las variables de entorno con los mismos nombres de las categorías anteriores, o desde "LANG".

Si la localidad es cero o "0", el ajuste de localidad no se ve afectado y sólo se devuelve el ajuste actual.

setlocale devuelve la nueva localidad, o FALSE si la funcionalidad de localización no está disponible en la plataforma, la localidad especificada no existe o el nombre de categoría no es válido. Un nombre de categoría no válido también produce un mensaje de aviso.

Anterior | Inicio | Siguiente
rtrim | Subir | similar_text


similar_text

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

similar_text -- Calcula la similitud entre dos cadenas

Descripción

int similar_text ( string primera, string segunda [, double porcentaje])

Esta función calcula la similitud entre dos cadenas según se describe en Oliver [1993]. Nótese que esta implementación no utiliza una pila como en el pseudo-código de Oliver, sino llamadas recursivas que pueden o no acelerar el proceso completo. Nótese también que la complejidad de este algoritmo es O(N**3), donde N es la longitud de la cadena más larga.

Pasando una referencia como tercer argumento, similar_text() calculará para usted la similitud como porcentaje. Devuelve el número de caracteres coincidentes en ambas cadenas.

Anterior | Inicio | Siguiente
setlocale | Subir | soundex


soundex

(PHP 3, PHP 4 >= 4.0.0)

soundex -- Calcula la clave soundex de una cadena

Descripción

string soundex ( string cad)

Calcula la clave soundex de cad.

Las claves soundex tienen la propiedad de que las palabras que se pronuncian de forma parecida tienen la misma clave, de modo que se pueden usar para simplificar la búsqueda en las bases de datos cuando se conoce la pronunciación pero no la transcripción. Esta función soundex devuelve una cadena de 4 caracteres que comienza por una letra.

Esta función soundex en particular es la descrita por Donald Knuth en "The Art Of Computer Programming, vol. 3: Sorting And Searching", Addison-Wesley (1973), pp. 391-392.

Ejemplo 1. Ejemplos de Soundex

soundex ("Euler") == soundex ("Ellery") == 'E460';
soundex ("Gauss") == soundex ("Ghosh") == 'G200';
soundex ("Knuth") == soundex ("Kant") == 'H416';
soundex ("Lloyd") == soundex ("Ladd") == 'L300';
soundex ("Lukasiewicz") == soundex ("Lissajous") == 'L222';

Anterior | Inicio | Siguiente
similar_text | Subir | sprintf


sprintf

(PHP 3, PHP 4 >= 4.0.0)

sprintf -- Devuelve una cadena con formato

Descripción

string sprintf ( string formato [, mixed args])

Devuelve una cadena producida de acuerdo a la cadena de formato.

La cadena de formato está compuesta por cero o más directivas: caracteres ordinarios (excepto %) que son copiados directamente al resultado, y especificaciones de conversión, cada una de las cuales provoca la obtención de su propio parámetro. Esto se aplica tanto a sprintf() como a printf().

Cada especificación de conversión consiste en uno de estos elementos, por orden:

  1. Un especificador de relleno opcional que indica qué caracter se utilizará para rellenar el resultado hasta el tamaño de cadena correcto. Este puede ser un espacio o un 0 (caracter cero). El valor por defecto es rellenar con espacios. Un caracter de relleno alternativo se puede especificar prefijándolo con una comilla simple ('). Vea los ejemplos más abajo.

  2. Un especificador de alineación opcional que indica si el resultado debe ser alineado a la izquierda o a la derecha. Por defecto se alinea a la derecha; un caracter - aquí lo justificará a la izquierda.

  3. Un número opcional, un especificador de ancho que dice el número de caracteres (mínimo) en que debería resultar esta conversión.

  4. Un especificador de precisión opcional que indica cuántos dígitos decimales deben mostrarse para los números en coma flotante. Esta opción no tienen efecto para otros tipos que no sean double. (Otra función útil para formatear números es number_format()).

  5. Un especificador de tipo que indica el tipo a usar para tratar los datos de los argumentos. Los tipos posibles son:

    % - un caracter literal de porcentaje. No se precisa argumento.
    b - el argumento es tratado como un entero y presentado como un número binario.
    c - el argumento es tratado como un entero, y presentado como el caracter con dicho valor ASCII.
    d - el argumento es tratado como un entero y presentado como un número decimal.
    f - el argumento es tratado como un doble y presentado como un número de coma flotante.
    o - el argumento es tratado como un entero, y presentado como un número octal.
    s - el argumento es tratado como una cadena y es presentado como tal.
    x - el argumento es tratado como un entero y presentado como un número hexadecimal (con minúsculas).
    X - el argumento es tratado como un entero y presentado como un número hexadecimal (con mayúsculas).

Vea también: printf(), sscanf(), fscanf(), y number_format().

Ejemplos

Ejemplo 1. Ejemplo de sprintf(): enteros rellenos con ceros

$fechaiso = sprintf ("%04d-%02d-%02d", $anno, $mes, $dia);

Ejemplo 2. Ejemplo de sprintf(): formateando monedas

$pelas1 = 68.75;
$pelas2 = 54.35;
$pelas = $pelas1 + $pelas2;
// echo $pelas mostrará "123.1";
$formateado = sprintf ("%01.2f", $pelas);
// echo $formateado mostrará "123.10"

Anterior | Inicio | Siguiente
soundex | Subir | sscanf


strcasecmp

(PHP 3>= 3.0.2, PHP 4 >= 4.0.0)

strcasecmp -- Comparación de cadenas insensible a mayúsculas y minúsculas y segura en modo binario

Descripción

int strcasecmp ( string cad1, string cad2)

Devuelve < 0 si cad1 es menor que cad2; > 0 si cad1 es mayor que cad2, y 0 si son iguales.

Ejemplo 1. Ejemplo de strcasecmp()

$var1 = "Hello";
$var2 = "hello";
if (!strcasecmp ($var1, $var2)) {
    echo '$var1 es igual a $var2 en una comparación sin tener en cuenta '
     .'mayúsculas o minúsculas';
}

Vea también ereg(), strcmp(),
substr(), stristr(), y
strstr().

Anterior | Inicio | Siguiente
str_replace | Subir | strchr


strchr

(PHP 3, PHP 4 >= 4.0.0)

strchr -- Encuentra la primera aparición de un caracter

Descripción

string strchr ( string pajar, string aguja)

Esta función es un alias para strstr(), y es idéntica en todo.

Anterior | Inicio | Siguiente
strcasecmp | Subir | strcmp


strcmp

(PHP 3, PHP 4 >= 4.0.0)

strcmp -- Comparación de cadenas con seguridad binaria

Descripción

int strcmp ( string cad1, string cad2)

Devuelve < 0 si cad1 es menor que cad2; > 0 si cad1 es mayor que cad2, y 0 si son iguales.

Nótese que esta comparación es sensible a mayúsculas y minúsculas.

Vea también ereg(),
strcasecmp(), substr(),
stristr(), strncmp(),
    y strstr().

Anterior | Inicio | Siguiente
strchr | Subir | strcspn


strcspn

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

strcspn -- Encuentra la longitud del elemento inicial que no coincide con la máscara

Descripción

int strcspn ( string cad1, string cad2)

Devuelve la longitud del segmento inicial de cad1 que no contiene ninguno de los caracteres de cad2.

Vea también strspn().

Anterior | Inicio | Siguiente
strcmp | Subir | strip_tags


strip_tags

(PHP 3>= 3.0.8, PHP 4 >= 4.0.0)

strip_tags -- Elimina marcas HTML y PHP de una cadena

Descripción

string strip_tags ( string cad [, string etiq_permitidas])

Esta función intenta eliminar todas las etiquetas HTML y PHP de la cadena dada. Causa error por precaución en caso de etiquetas incompletas o falsas. Utiliza la misma máquina de estados para eliminar las etiquetas que la función fgetss().

Puede usar el parámetro opcional para especificar las etiquetas que no deben eliminarse.

Nota: etiq_permitidas fue añadido en PHP 3.0.13, PHP4B3.

Anterior | Inicio | Siguiente
strcspn | Subir | stripcslashes


stripcslashes

(PHP 4 >= 4.0.0)

stripcslashes -- Desmarca la cadena marcada con addcslashes()

Descripción

string stripcslashes ( string cad)

Devuelve una cadena con las barras invertidas eliminadas. Reconoce las marcas tipo C \n, \r ..., y la representación octal y hexadecimal.

Nota: Añadida en PHP4b3-dev.

Vea también addcslashes().

Anterior | Inicio | Siguiente
strip_tags | Subir | stripslashes


stripslashes

(PHP 3, PHP 4 >= 4.0.0)

stripslashes -- Desmarca la cadena marcada con addslashes()

Descripción

string stripslashes ( string cad)

Devuelve una cadena con las barras invertidas eliminadas (\' se convierte en ', etc.). Las barras invertidas dobles se convierten en sencillas.

Vea también addslashes().

Anterior | Inicio | Siguiente
stripcslashes | Subir | stristr


stristr

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

stristr -- strstr() sin tener en cuenta mayúsculas o minúsculas

Descripción

string stristr ( string pajar, string aguja)

Devuelve todo el pajar desde la primera aparición de la aguja, siendo el pajar examinado sin tener en cuenta mayúsculas o minúsculas.

Si la aguja no se encuentra, devuelve FALSE.

Si la aguja no es una cadena, es convertida a entero y usada como código de un carácter ASCII.

Vea también strchr(),
strrchr(), substr(), y
ereg().

Anterior | Inicio | Siguiente
stripslashes | Subir | strlen


strlen

(PHP 3, PHP 4 >= 4.0.0)

strlen -- Obtiene la longitud de la cadena

Descripción

int strlen ( string cad)

Devuelve la longitud de la cadena.

Anterior | Inicio | Siguiente
stristr | Subir | strnatcasecmp


strnatcmp

(PHP 4 >= 4.0.0)

strnatcmp -- Compara cadenas usando un algoritmo de "orden natural"

Descripción

int strnatcmp ( string cad1, string cad2)

Esta función implementa un algoritmo de comparación que ordena las cadenas alfanuméricas como lo haría un ser humano, que es lo que se denomina "orden natural". A continuación se puede ver un ejemplo de la diferencia entre este algoritmo y los algoritmos de ordenación de cadenas habituales en los ordenadores (utilizados en strcmp()):

$matriz1 = $matriz2 = array ("img12.png","img10.png","img2.png","img1.png");
echo "Comparación de cadenas estándar\n";
usort($matriz1,"strcmp");
print_r($matriz1);
echo "\nComparación de cadenas en orden natural\n";
usort($matriz2,"strnatcmp");
print_r($matriz2);

El código anterior generará la siguiente salida:

Comparación de cadenas estándar
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Comparación de cadenas en orden natural
Array
(
    [0] => img1.png
    [1] => img2.png
    [2] => img10.png
    [3] => img12.png
)

Para más información, vea la página de Martin Pool sobre Comparación de Cadenas en Orden Natural.

De forma similar a otras funciones de comparación de cadenas, esta devuelve < 0 si cad1 es menor que cad2; > 0 si cad1 es mayor que cad2, y 0 si son iguales.

Nótese que esta comparación es sensible a mayúsculas y minúsculas.

Vea también ereg(),
strcasecmp(), substr(),
stristr(), strcmp(),
strncmp(), strnatcasecmp(),
    y strstr().

Anterior | Inicio | Siguiente
strnatcasecmp | Subir | strncmp


strnatcasecmp

(PHP 4 >= 4.0.0)

strnatcasecmp -- Comparación de cadenas insensible a mayúsculas y minúsculas usando un algoritmo de "orden natural"

Descripción

int strnatcasecmp ( string cad1, string cad2)

Esta función implementa un algoritmo de comparación que ordena las cadenas alfanuméricas como lo haría un ser humano. El comportamiento de esta función es similar a strnatcmp(), pero la comparación no es sensible a mayúsculas y minúsculas. Para más información, vea la página de Martin Pool sobre Comparación de Cadenas en Orden Natural.

De forma similar a otras funciones de comparación de cadenas, esta devuelve < 0 si cad1 es menor que cad2; > 0 si cad1 es mayor que cad2, y 0 si son iguales.

Vea también ereg(),
strcasecmp(), substr(),
stristr(), strcmp(),
strncmp(), strnatcmp(),
    y strstr().

Anterior | Inicio | Siguiente
strlen | Subir | strnatcmp


strncmp

(PHP 4 >= 4.0.0)

strncmp -- Comparación de los n primeros caracteres de cadenas, con seguridad binaria

Descripción

int strncmp ( string cad1, string cad2, int largo)

Esta función es similar a strcmp(), con la diferencia que se puede especificar el (límite superior del) número de caractares (largo) de cada cadena que se usarán en la comparación. Si alguna de las cadenas es menor que el largo, se usará su longitud para la comparación.

Devuelve < 0 si cad1 es menor que cad2; > 0 si cad1 es mayor que cad2, y 0 si son iguales.

Nótese que esta comparación es sensible a mayúsculas y minúsculas.

Vea también ereg(),
strcasecmp(), substr(),
stristr(), strcmp(),
    y strstr().

Anterior | Inicio | Siguiente
strnatcmp | Subir | strpos


str_pad

(PHP 4 )

str_pad -- Rellena una cadena con otra hasta una longitud dada

Descripción

string str_pad ( string entrada, int tama_relleno [, string cad_relleno [, int tipo_relleno]])

Esta función rellena la cadena entrada por la derecha, la izquierda o por ambos lados hasta el largo indicado. Si no se especifica el argumento opcional cad_relleno, entrada es rellenada con espacios. En caso contrario, será rellenada con los caracteres de cad_relleno hasta el límite.

El argumento opcional tipo_relleno puede valer STR_PAD_RIGHT, STR_PAD_LEFT, o STR_PAD_BOTH. Si no se especifica, se asume que vale STR_PAD_RIGHT.

Si el valor de tama_relleno es negativo o menor que la longitud de la cadena de entrada, no se produce rellenado alguno.

Ejemplo 1. Ejemplo de str_pad()

$entrada = "Alien";
print str_pad($entrada, 10);                      // produce "Alien     "
print str_pad($entrada, 10, "-=", STR_PAD_LEFT);  // produce "-=-=-Alien"
print str_pad($entrada, 10, "_", STR_PAD_BOTH);   // produce "__Alien___"

Anterior | Inicio | Siguiente
sscanf | Subir | str_repeat


strpos

(PHP 3, PHP 4 >= 4.0.0)

strpos -- Encuentra la posición de la primera aparición de una cadena

Descripción

int strpos ( string pajar, string aguja [, int desplazamiento])

Devuelve la posición numérica de la primera aparición de la aguja en la cadena pajar. A diferencia de strrpos(), esta función puede tomar una cadena completa como aguja y se utilizará en su totalidad.

Si la aguja no es hayada, devuelve FALSE.

Nota: Es fácil confundir los valores de retorno para "caracter encontrado en la posición 0" y "caracter no encontrado". Aquí se indica cómo detectar la diferencia:

// en PHP 4.0b3 y posteriores:
$pos = strpos ($micadena, "b");
if ($pos === false) { // nota: tres signos igual
    // no encontrado ...
}

// en versiones anteriores a la 4.0b3:
$pos = strpos ($micadena, "b");
if (is_string ($pos) && !$pos) {
    // no encontrado ...
}

Si la aguja no es una cadena, se convierte a entero y se aplica como el valor ordinal de un caracter.

El parámetro opcional desplazamiento le permite especificar a partir de qué caracter del pajar comenzar a buscar. La posición devuelta es aún relativa al comienzo de pajar.

Vea también strrpos(),
strrchr(), substr(),
stristr(), y strstr().

Anterior | Inicio | Siguiente
strncmp | Subir | strrchr


strrchr

(PHP 3, PHP 4 >= 4.0.0)

strrchr -- Encuentra la última aparición de un caracter en una cadena

Descripción

string strrchr ( string pajar, string aguja)

Esta función devuelve la porción del pajar que comienza en la última aparición de la aguja y continúa hasta el final del pajar.

Devuelve FALSE si la aguja no es hallada.

Si la aguja contiene más de un caracter, sólo se usará el primero.

Si la aguja no es una cadena, se convierte a entero y se aplica como el valor ordinal de un caracter.

Ejemplo 1. Ejemplo de strrchr()

// obtener el último directorio de $PATH
$dir = substr (strrchr ($PATH, ":"), 1);

// obtener todo tras el último salto de línea
$texto = "Line 1\nLine 2\nLine 3";
$apell = substr (strrchr ($texto, 10), 1 );

Vea también substr(), stristr(), y strstr().

Anterior | Inicio | Siguiente
strpos | Subir | strrev


str_repeat

(PHP 4 >= 4.0.0)

str_repeat -- Repite una cadena

Descripción

string str_repeat ( string cad_entrada, int veces)

Devuelve la cad_entrada repetida veces. veces debe ser mayor que 0.

Ejemplo 1. Ejemplo de str_repeat()

echo str_repeat ("-=", 10);

Esto mostrará "-=-=-=-=-=-=-=-=-=-=".

Nota: Esta función fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
str_pad | Subir | str_replace


strrev

(PHP 3, PHP 4 >= 4.0.0)

strrev -- Invierte una cadena

Descripción

string strrev ( string cadena)

Devuele la cadena invertida.

Anterior | Inicio | Siguiente
strrchr | Subir | strrpos


strrpos

(PHP 3, PHP 4 >= 4.0.0)

strrpos -- Encuentra la posición de la última aparición de un caracter en una cadena

Descripción

int strrpos ( string pajar, char aguja)

Devuele la posición numérica de la última aparición de la aguja en el pajar. Nótese que la aguja en este caso sólo puede ser un caracter único. Si se pasa una cadena como aguja, sólo se utilizará el primer caracter de la misma.

Si la aguja no es hayada, devuelve FALSE.

Si la aguja no es una cadena, se convierte a entero y se aplica como el valor ordinal de un caracter.

Vea también strpos(),
strrchr(), substr(),
stristr(), y strstr().

Anterior | Inicio | Siguiente
strrev | Subir | strspn


strspn

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

strspn -- Encuentra la longitud del segmento inicial que coincide con la máscara

Descripción

int strspn ( string cad1, string cad2)

Devuelve la longitud del segmento inicial de cad1 que consiste por entero en caracteres contenidos en cad2.

strspn ("42 es la respuesta. ¿Cuál es la pregunta ...?", "1234567890");

devolverá 2 como resultado.

Vea también strcspn().

Anterior | Inicio | Siguiente
strrpos | Subir | strstr


strstr

(PHP 3, PHP 4 >= 4.0.0)

strstr -- Encuentra la primera aparición de una cadena

Descripción

string strstr ( string pajar, string aguja)

Devuelve todo el pajar desde la primera aparición de la aguja hasta el final.

Si la aguja no es hayada, devuelve FALSE.

Si la aguja no es una cadena, se convierte a entero y se aplica como el valor ordinal de un caracter.

Nota: Nótese que esta función es sensible a mayúsculas y minúsculas. Para búsquedas no sensibles, utilice stristr().

Ejemplo 1. Ejemplo de strstr()

$email = 'sterling@designmultimedia.com';
$dominio = strstr ($email, '@');
print $dominio; // imprime @designmultimedia.com

Vea también stristr(),
strrchr(), substr(), y
ereg().

Anterior | Inicio | Siguiente
strspn | Subir | strtok


strtok

(PHP 3, PHP 4 >= 4.0.0)

strtok -- Divide una cadena en elementos

Descripción

string strtok ( string arg1, string arg2)

strtok() se usa para dividir en elementos una cadena. Es decir, que si tiene una cadena como "Esta es una cadena de ejemplo" podría dividirla en palabras individuales utilizando el espacio como divisor.

Ejemplo 1. Ejemplo de strtok()

$cadena = "Esta es una cadena de ejemplo";
$tok = strtok ($cadena," ");
while ($tok) {
    echo "Palabra=$tok<br>";
    $tok = strtok (" ");
}

Nótese que sólo la primera llamada a strtok utiliza el argumento cadena. Cada llamada subsiguiente necesita sólo el divisor a utilizar, puesto que ella guarda la posición actual en la cadena. Para comenzar de nuevo o para dividir otra cadena, simplemente llame a strtok con el argumento de cadena y se inicializará. Nótese que puede poner divisores múltiples como parámetro. La cadena será dividida cuando alguno de los caracteres del argumento sea hallado.

Además tenga cuidado si sus divisores valen "0", pues evalúa como FALSE en las expresiones condicionales.

Vea también split() y explode().

Anterior | Inicio | Siguiente
strstr | Subir | strtolower


strtolower

(PHP 3, PHP 4 >= 4.0.0)

strtolower -- Pasa a minúsculas una cadena

Descripción

string strtolower ( string cad)

Devuelve la cadena con todas sus letras en minúsculas.

Nótese que las letras son definidad por el locale actual. Esto quiere decir que, por ejemplo, en el locale por defecto ("C"), los caracteres como la Ñ no serán convertidos.

Ejemplo 1. Ejemplo de strtolower()

$cad = "María Tenía Un Corderito al que QUERÍA Mucho";
$cad = strtolower($cad);
print $cad; # Visualiza maría tenía un corderito al que querÍa mucho

Vea también strtoupper() y ucfirst().

Anterior | Inicio | Siguiente
strtok | Subir | strtoupper


strtoupper

(PHP 3, PHP 4 >= 4.0.0)

strtoupper -- Pasa a mayúsculas una cadena

Descripción

string strtoupper ( string cadena)

Devuelve la cadena con todas sus letras en mayúsculas.

Nótese que las letras son definidad por el locale actual. Esto quiere decir que, por ejemplo, en el locale por defecto ("C"), los caracteres como la ñ no serán convertidos.

Ejemplo 1. Ejemplo de strtoupper()

$cad = "María Tenía Un Corderito al que QUERÍA Mucho";
$cad = strtoupper ($cad);
print $cad; # Visuaiza MARíA TENíA UN CORDERITO AL QUE QUERÍA MUCHO

Vea también strtolower() and ucfirst().

Anterior | Inicio | Siguiente
strtolower | Subir | strtr


str_replace

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

str_replace -- Sustitiye todas las apariciones de la aguja en el pajar por la cadena

Descripción

string str_replace ( string aguja, string cad, string pajar)

Esta función sustituye todas las apariciones de la aguja en el pajar por la cad dada. Si no precisa reglas especiales de sustitución, deberá usar siempre esta función en lugar de ereg_replace().

Ejemplo 1. Ejemplo de str_replace()

$bodytag = str_replace ("%cuerpo%", "negro", "<body text=%cuerpo%>");

Esta función tiene seguridad binaria.

Nota: str_replace() fue añadida en PHP 3.0.6, pero tuvo errores hasta el PHP 3.0.8.

Vea también ereg_replace() y strtr().

Anterior | Inicio | Siguiente
str_repeat | Subir | strcasecmp


strtr

(PHP 3, PHP 4 >= 4.0.0)

strtr -- Traduce ciertos caracteres

Descripción

string strtr ( string cad, string desde, string hasta)

Esta función trabaja sobre cad, traduciendo todas las apariciones de cada caracter en desde por el caracter correspondiente en hasta y devolviendo el resultado.

Si desde y hasta son de distinta longitud, los caracteres extra en la más larga son ignorados.

Ejemplo 1. Ejemplo de strtr()

$addr = strtr($addr, "äåö", "aao");

strtr() puede llamarso sólo con dos argumentos. Si se llama de esta manera, se comporta de otro modo: desde debe ser entonces una matriz que contenga pares cadena -> cadena que serán sustituídos en la cadena fuente. strtr() siempre buscará la coincidencia más larga primero y *NO* intentará sustituir nada en lo que haya trabajado ya.

Ejemplos:

$trad = array ("hola" => "hey", "hey" => "hola");
echo strtr("hey a todos, dije hola", $trad) . "\n";

Mostrará: "hola a todos, dije hey",

Nota: Esta característica (2 argumentos) fue añadida en el PHP 4.0

Vea también ereg_replace().

Anterior | Inicio | Siguiente
strtoupper | Subir | substr


substr

(PHP 3, PHP 4 >= 4.0.0)

substr -- Devuelve parte de una cadena

Descripción

string substr ( string cadena, int comienzo [, int largo])

substr devuelve la porción de cadena especificada por los parámetros comienzo y largo.

Si comienzo es positivo, la cadena devuelta comenzará en dicho caracter de cadena.

Ejemplos:

$resto = substr ("abcdef", 1);    // devuelve "bcdef"
$resto = substr ("abcdef", 1, 3); // devuelve "bcd"

Si comienzo es negativo, la cadena devuelta comenzará en dicha posición desde el final de cadena.

Ejemplos:

$resto = substr ("abcdef", -1);    // devuelve "f"
$resto = substr ("abcdef", -2);    // devuelve "ef"
$resto = substr ("abcdef", -3, 1); // devuelve "d"

Si se especifica largo y es positivo, la cadena devuelta terminará largo caracteres tras el comienzo. Si esto resulta en una cadena con longitud negativa (porque el comienzo está pasado el final de la cadena), la cadena devuelta contendrá únicamente el caracter que haya en comienzo.

Si se especifica largo y es negativo, la cadena devuelta terminará a largo caracteres desde el final de cadena. Si esto resulta en una cadena con longitud negativa, la cadena devuelta contendrá únicamente el caracter que haya en comienzo.

Examples:

$resto = substr ("abcdef", 1, -1); // devuelve "bcde"

Vea también strrchr() y ereg().

Anterior | Inicio | Siguiente
strtr | Subir | substr_count


substr_count

(PHP 4 >= 4.0.0)

substr_count -- Cuenta el número de apariciones de la subcadena

Descripción

int substr_count ( string pajar, string aguja)

substr_count() devuelve el número de veces que la subcadena aguja se encuentra en la cadena pajar.

Ejemplo 1. Ejemplo de substr_count()

print substr_count("This is a test", "is"); // prints out 2

Anterior | Inicio | Siguiente
substr | Subir | substr_replace


substr_replace

(PHP 4 >= 4.0.0)

substr_replace -- Sustituye texto en una parte de una cadena

Descripción

string substr_replace ( string cadena, string sustituto, int comienzo [, int largo])

substr_replace() sustituye la parte de cadena delimitada por los parámetros comienzo y (opcionalmente) largo por la cadena dada en sustituto. Se devuelve el resultado.

Si comienzo es positivo, la sustitución comenzará en dicha posición dentro de la cadena.

Si comienzo es negativo, la sustitución comenzará en dicha posición pero contando desde el final de cadena.

Si se especifica el largo y es positivo, representa el largo de la porción de cadena a sustituir. Si es negativo, representa el número de caracteres desde el final de cadena en los que dejar de sustituir. Si no se especifica, valdrá por defecto strlen(cadena); es decir, que acabará la sustitución al final de cadena.

Ejemplo 1. Ejemplo de substr_replace()

<?php
$var = 'ABCDEFGH:/MNRPQR/';
echo "Original: $var<hr>\n";

/* Estos dos ejemplos sustituyen toda $var por 'bob'. */
echo substr_replace ($var, 'bob', 0) . "<br>\n";
echo substr_replace ($var, 'bob', 0, strlen ($var)) . "<br>\n";

/* Inserta 'bob' justo al inicio de $var. */
echo substr_replace ($var, 'bob', 0, 0) . "<br>\n";

/* Los dos siguientes cambian 'MNRPQR' en $var por 'bob'. */
echo substr_replace ($var, 'bob', 10, -1) . "<br>\n";
echo substr_replace ($var, 'bob', -7, -1) . "<br>\n";

/* Borrar 'MNRPQR' de $var. */
echo substr_replace ($var, '', 10, -1) . "<br>\n";
?>

Vea también str_replace() y substr().

Nota: substr_replace() fue añadida en el PHP 4.0.

Anterior | Inicio | Siguiente
substr_count | Subir | trim


trim

(PHP 3, PHP 4 >= 4.0.0)

trim -- Elimina espacios del principio y final de una cadena

Descripción

string trim ( string cad)

Esta función elimina los espacios en blanco del comienzo y del final de una cadena y devuelve el resultado. Los caracteres de espacio que elimina realmente son: "\n", "\r", "\t", "\v", "\0", y el espacio en sí.

Vea también chop() y ltrim().

Anterior | Inicio | Siguiente
substr_replace | Subir | ucfirst


ucfirst

(PHP 3, PHP 4 >= 4.0.0)

ucfirst -- Pasar a mayúsculas el primer caracter de una cadena

Descripción

string ucfirst ( string cad)

Pone en mayúsculas el primer carácter de cad si es alfabético.

Nótese que 'alfabético' está determinado por la localidad actual. Por ejemplo, en la localidad por defecto "C", los caracteres como la a con diéresis (ä) no serán convertidos.

Ejemplo 1. Ejemplo de ucfirst()

$texto = 'susanita tiene un ratón, un ratón chiquitín.';
$texto = ucfirst ($texto); // $texto vale ahora: Susanita tiene un
            // ratón, un ratón chiquitín.

Vea también strtoupper() y strtolower()

Anterior | Inicio | Siguiente
trim | Subir | ucwords


ucwords

(PHP 3>= 3.0.3, PHP 4 >= 4.0.0)

ucwords -- Pone en mayúsculas el primer caracter de cada palabra de una cadena

Descripción

string ucwords ( string cad)

Pasa a mayúsculas la primera letra de cada palabra en cad si dicho caracter es alfabético.

Ejemplo 1. Ejemplo de ucwords()

$texto = "susanita tiene un ratón, un ratón chiquitín.";
$texto = ucwords($texto); // $texto vale ahora: Susanita Tiene Un
                        // Ratón, Un Ratón Chiquitín.

Vea también strtoupper(), strtolower() y ucfirst().

Anterior | Inicio | Siguiente
ucfirst | Subir | wordwrap


wordwrap

(PHP 4 >= 4.0.2)

wordwrap -- Corta una cadena en un número dado de caracteres usando un caracter de ruptura de cadenas.

Descripción

string wordwrap ( string cad [, int ancho [, string ruptura]])

Corta la cadena cad en la columna especificada por el parámetro (opcional) ancho. La línea se rompe utilizando el parámetro (opcional) ruptura.

wordwrap() automáticamente cortará en la columna 75 y usará '\n' (nueva línea) si no se especifican el ancho o la ruptura.

Ejemplo 1. Ejemplo de wordwrap()

$texto = "El veloz murciélago hindú comía feliz cardillo y kiwi.";
$textonuevo = wordwrap( $texto, 20 );

echo "$textonuevo\n";

Este ejemplo mostraría:

El veloz murciélago
hindú comía feliz cardillo y kiwi.

Vea también nl2br().

Anterior | Inicio | Siguiente
ucwords | Subir | Funciones de Sybase


Funciones de Sybase

Manual de PHP
Anterior Siguiente

XCVI. Funciones de Sybase

Tabla de contenidos
sybase_affected_rows — obtiene el número de filas afectadas por la última consulta
sybase_close — cierra una conexión Sybase
sybase_connect — abre una conexión con un servidor Sybase
sybase_data_seek — mueve el puntero interno de la fila
sybase_fetch_array — carga una fila como un array
sybase_fetch_field — obtiene la información del campo
sybase_fetch_object — carga una fila como un objeto
sybase_fetch_row — obtiene una fila como un array enumerado
sybase_field_seek — establece el offset de un campo
sybase_free_result — libera el resultado de la memoria
sybase_num_fields — obtiene el número de campos de un resultado
sybase_num_rows — obtiene el número de filas de un resultado
sybase_pconnect — abre una conexión con Sybase persistente
sybase_query — envía una consulta a Sybase
sybase_result — obtiene datos de un resultado
sybase_select_db — seleccciona una base de datos Sybase

Anterior | Inicio | Siguiente
wordwrap | Subir | sybase_affected_rows


sybase_affected_rows

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

sybase_affected_rows -- obtiene el número de filas afectadas por la última consulta

Descripción

int sybase_affected_rows ( [int link_identifier])

Devuelve: El número de filas afectadas por la última consulta.

sybase_affected_rows() devuelve el número de filas afectadas por la última acción e tipo INSERT, UPDATE o DELETE en el servidor asociado al identificador de enlace especificado. Si no se especifica un identificador de enlace, se asume el último enlace abierto.

Esta instrucción no es efectiva para sentencias de tipo SELECT, sólo en sentencias que modifican registros. Para obtener el número de filas afectadas por un SELECT, use sybase_num_rows().

Nota: Esta función sólo esta disponible usando el interface de la librería CT, y no con la librería DB.

Anterior | Inicio | Siguiente
Funciones de Sybase | Subir | sybase_close


sybase_close

(PHP 3, PHP 4 >= 4.0.0)

sybase_close -- cierra una conexión Sybase

Descripción

int sybase_close ( int link_identifier)

Devuelve: TRUE si lo consigue, FALSE ante un error

sybase_close() cierra el enlace a la base de datos Sybase asociada con el identificador de enlace especificado. Si no se especifica un identificador de enlace, se asume el último enlace abierto.

Note que esto no es necesario usualmente, ya que los enlaces no persistentes abiertos son cerrados automaticamente al final de la ejecución del script.

sybase_close() no cerrará enlaces persistentes generados por sybase_pconnect().

Vea también: sybase_connect(), sybase_pconnect().

Anterior | Inicio | Siguiente
sybase_affected_rows | Subir | sybase_connect


sybase_connect

(PHP 3, PHP 4 >= 4.0.0)

sybase_connect -- abre una conexión con un servidor Sybase

Descripción

int sybase_connect ( string servername, string username, string password)

Devuelve: Un identificador de enlace Sybase positivo, o FALSE ante un error.

sybase_connect() establece una conexión son un servidor Sybase. El parámetro servername tiene que ser un nombre de servidor válido que esta definido en el fichero 'interfaces'.

En el caso que se haga una segunda llamada a sybase_connect() con los mismos argumentos, no se establecerá un nuevo enlace, en vez de esto, se devolverá el identificador de enlace que ya está abierto.

El enlace al servidor será cerrado tan pronto como la ejecución del script finalice, a menos que sea cerrado antes llamando explicitamente a sybase_close().

Vea también sybase_pconnect(), sybase_close().

Anterior | Inicio | Siguiente
sybase_close | Subir | sybase_data_seek


sybase_data_seek

(PHP 3, PHP 4 >= 4.0.0)

sybase_data_seek -- mueve el puntero interno de la fila

Descripción

int sybase_data_seek ( int result_identifier, int row_number)

Devuelve: TRUE si lo hace, FALSE en caso de fallo

sybase_data_seek() mueve el puntero interno de la fila del resultado asociado con el identificador de resultado especificado hacia el número de fila introducido. La siguiente llamada a sybase_fetch_row() devolverá esa fila.

Vea también: sybase_data_seek().

Anterior | Inicio | Siguiente
sybase_connect | Subir | sybase_fetch_array


sybase_fetch_array

(PHP 3, PHP 4 >= 4.0.0)

sybase_fetch_array -- carga una fila como un array

Descripción

int sybase_fetch_array ( int result)

Returns: An array that corresponds to the fetched row, or FALSE if there are no more rows.

sybase_fetch_array() es la versión extendida de sybase_fetch_row(). Además de almacenar los datos en los indices numericos del array de resultados, también almacena los datos en indices asociativos, usando los nombres de campo como claves.

Una cosa importante a remarcar es que el uso de sybase_fetch_array() NO es significativamente más lento que el uso de sybase_fetch_row(), mientrás que proporciona un valor añadido significativo.

Para más detalles, vea también sybase_fetch_row()

Anterior | Inicio | Siguiente
sybase_data_seek | Subir | sybase_fetch_field


sybase_fetch_field

(PHP 3, PHP 4 >= 4.0.0)

sybase_fetch_field -- obtiene la información del campo

Descripción

object sybase_fetch_field ( int result, int field_offset)

Devuelve un objeto conteniendo la información del campo

sybase_fetch_field() puede usarse para obtener información sobre los campos de una consulta determinada. Si no se especifica el offset del campo, el siguiente campo que aún no halla sido tomado por sybase_fetch_field() es el que se obtiene.

Las propiedades del objeto son:

  • name - column name. si la columna es el resultado de una función, esta propiedad se establece a computed#N, donde #N es un número de serie.

  • column_source - la tabla de la cual se ha cogido la columna

  • max_length - máxima longitud de la columna

  • numeric - 1 si la columna es numérica

Vea también sybase_field_seek()

Anterior | Inicio | Siguiente
sybase_fetch_array | Subir | sybase_fetch_object


sybase_fetch_object

(PHP 3, PHP 4 >= 4.0.0)

sybase_fetch_object -- carga una fila como un objeto

Descripción

int sybase_fetch_object ( int result)

Devuelve: Un objeto con las propiedades que corresponden a la fila tomada, o FALSE si no hay más filas.

sybase_fetch_object() es similar a sybase_fetch_array(), con una diferencia - se devuelve un objeto, en vez de un array. Indirectamente, esto significa que sólo se puede acceder a los datos por los nombres de campo, y no por sus offsets (los números son nombres de propiedades ilegales).

En el tema de velocidad, la función es idéntica a sybase_fetch_array(), y al menos tan rápida como sybase_fetch_row() (la diferencia es insignificante).

Vea también: sybase_fetch-array() y sybase_fetch-row().

Anterior | Inicio | Siguiente
sybase_fetch_field | Subir | sybase_fetch_row


sybase_fetch_row

(PHP 3, PHP 4 >= 4.0.0)

sybase_fetch_row -- obtiene una fila como un array enumerado

Descripción

array sybase_fetch_row ( int result)

Devuelve: Un array que corresponde a la fila obtenida, o FALSE si no hay más filas.

sybase_fetch_row() obtiene una fila de datos del resultado asociado con el identificador de resultado especificado. La fila se devuelve como un array. Cada columna del resultado es almacenada en un offset del arrat, comenzando en el offset 0.

Las siguientes llamadas a sybase_fetch_rows() devolverán la siguiente fila del conjunto de resultados, o FALSE si no hay más filas.

Vea también: sybase_fetch_array(),
          sybase_fetch_object(),
          sybase_data_seek(),
          sybase_fetch_lengths(), y
          sybase_result().

Anterior | Inicio | Siguiente
sybase_fetch_object | Subir | sybase_field_seek


sybase_field_seek

(PHP 3, PHP 4 >= 4.0.0)

sybase_field_seek -- establece el offset de un campo

Descripción

int sybase_field_seek ( int result, int field_offset)

Localiza el campo especificado por el offset. Si la siguiente llamada sybase_fetch_field() no incluye un offset se devuelve este campo.

Vea también: sybase_fetch_field().

Anterior | Inicio | Siguiente
sybase_fetch_row | Subir | sybase_free_result


sybase_free_result

(PHP 3, PHP 4 >= 4.0.0)

sybase_free_result -- libera el resultado de la memoria

Descripción

int sybase_free_result ( int result)

sybase_free_result() sólo se necesita usar en el caso de que este preocupado por el uso de demasiada memoria mientras se ejecuta su script. Todos los resultados en memoria son liberados cuando el script finaliza, puede llamar a sybase_free_result() con el identificador de resultado como argumento y la memoria asociada a ese resultado será liberada.

Anterior | Inicio | Siguiente
sybase_field_seek | Subir | sybase_num_fields


sybase_num_fields

(PHP 3, PHP 4 >= 4.0.0)

sybase_num_fields -- obtiene el número de campos de un resultado

Descripción

int sybase_num_fields ( int result)

sybase_num_fields() devuelve el número de campos en un conjunto de resultados.

Vea también:
sybase_db_query(),
sybase_query(),
sybase_fetch_field(),
sybase_num_rows().

Anterior | Inicio | Siguiente
sybase_free_result | Subir | sybase_num_rows


sybase_num_rows

(PHP 3, PHP 4 >= 4.0.0)

sybase_num_rows -- obtiene el número de filas de un resultado

Descripción

int sybase_num_rows ( string result)

sybase_num_rows() devuelve el número de filas de un conjunto de resultados.

Vea también:
sybase_db_query(),
sybase_query() and,
sybase_fetch_row().

Anterior | Inicio | Siguiente
sybase_num_fields | Subir | sybase_pconnect


sybase_pconnect

(PHP 3, PHP 4 >= 4.0.0)

sybase_pconnect -- abre una conexión con Sybase persistente

Descripción

int sybase_pconnect ( string servername, string username, string password)

Devuelve: Un identificador de enlace persistente de Sybase positivo en caso de que pueda abrirlo, en caso de error devuelve FALSE

sybase_pconnect() actua de una forma muy parecida a sybase_connect() con dos grandes diferencias.

Primera, cuando se conecta, esta función primero tratará de encontrar un enlace (persistente) que ya este abierto con el mismo host, nombre de usuario y contraseña. Si encuentra uno, devolverá un identificador para él en vez de abrir una nueva conexión.

Segunda, la conexión al servidor SQL no se cerrará cuando finalice la ejecución del script. En vez de esto, el enlace permanecerá abierto para un futuro uso (sybase_close() no podrá cerrar enlaces establecidos consybase_pconnect()).

Este tipo de enlaces son llamados 'persistentes'.

Anterior | Inicio | Siguiente
sybase_num_rows | Subir | sybase_query


sybase_query

(PHP 3, PHP 4 >= 4.0.0)

sybase_query -- envía una consulta a Sybase

Descripción

int sybase_query ( string query, int link_identifier)

Devuelve: Un identificador de resultado Sybase positivo si va bien, o FALSE ante un error.

sybase_query() envía una consulta a la actual base de datos activa en el servidor que está asociada con el identificador de enlace especificado. Si no se especifica un identificador de enlace, se asume el último enlace abierto. Si no hay un enlace abierto, la función intentará establecer un enlace como si sybase_connect() fuese llamada, y lo usará.

Vea también:
sybase_db_query(),
sybase_select_db(), y
sybase_connect().

Anterior | Inicio | Siguiente
sybase_pconnect | Subir | sybase_result


sybase_result

(PHP 3, PHP 4 >= 4.0.0)

sybase_result -- obtiene datos de un resultado

Descripción

int sybase_result ( int result, int i, mixed field)

Devuelve: El contenido de la celda en la fila y el offset especificado de un conjunto de resultados de Sybase.

sybase_result() devuelve el contenido de una celda de un conjunto de resultados de Sybase. El parámetro field puede ser el offset del campo, o el nombre del campo, o el nombre de la tabla, un punto y el nombre del campo (nombre_tabla.nombre_campo). Si el nombre de la columna tiene un alias ('select foo as bar from...'), use el alias en vez del nombre de la columna.

Cuando trabaje con conjuntos de resultados grandes, debe considerar el uso de alguna de las funciones que cargan una fila entera (especificadas abajo). Ya que estas funciones devuelven el contenido de multiples celdas en una única llamada, son MUCHO más rápidas que sybase_result(). Además, note que especificar un offset númerico en el parámetro field es mucho más rápido que especificar un nombre de campo o nombre_tabla.nombre_campo.

Alternativas recomendadas para alto rendimiento:
sybase_fetch_row(),
sybase_fetch_array(), y
sybase_fetch_object().

Anterior | Inicio | Siguiente
sybase_query | Subir | sybase_select_db


sybase_select_db

(PHP 3, PHP 4 >= 4.0.0)

sybase_select_db -- seleccciona una base de datos Sybase

Descripción

int sybase_select_db ( string database_name, int link_identifier)

Returns: TRUE on success, FALSE on error

sybase_select_db() establece como activa la base de datos en el servidor asociada con el identificador de enlace especificado. Si no se especifica un identificador de enlace, se asume el último enlace abierto. Si no hay un enlace abierto, la función intentará establecer un enlace como si sybase_connect() fuese llamada, y lo usará.

Cada llamada subsiguiente a sybase_query() será hecha en la base de datos activa.

Vea también:
    sybase_connect(),
    sybase_pconnect(), y
    sybase_query()

Anterior | Inicio | Siguiente
sybase_result | Subir | Funciones URL


Funciones URL

Manual de PHP
Anterior Siguiente

XCVII. Funciones URL

Tabla de contenidos
base64_decode — decodifica datos cifrados con MIME base64
base64_encode — Codifica datos en MIME base64
parse_url — Analiza una URL y devuelve sus componentes
urldecode — decodifica URL-cifradas en una cadena de texto
urlencode — Codifica una URL en una cadena de texto

Anterior | Inicio | Siguiente
sybase_select_db | Subir | base64_decode


base64_decode

(PHP 3, PHP 4 >= 4.0.0)

base64_decode -- decodifica datos cifrados con MIME base64

Descripción

string base64_decode ( string datos_cifrados)

base64_decode() decodifica datos_cifrados y devuelve los datos originales. Los datos devueltos pueden ser binarios.

Vea también: base64_encode(), RFC-2045 sección 6.8.

Anterior | Inicio | Siguiente
Funciones URL | Subir | base64_encode


base64_encode

(PHP 3, PHP 4 >= 4.0.0)

base64_encode -- Codifica datos en MIME base64

Descripción

string base64_encode ( string datos)

base64_encode() devuelve datos cifrados en base64. Esta codificación está pensada para que los datos binarios sobrevivan al transporte a través de capas que no son de 8 bits, como por ejemplo los cuerpos de los mensajes de correo.

Los datos codificados con Base64 ocupan aproximadamente un 33% más de espacio que los datos originales.

Vea también: base64_decode(), chunk_split(), RFC-2045 sección 6.8.

Anterior | Inicio | Siguiente
base64_decode | Subir | parse_url


parse_url

(PHP 3, PHP 4 >= 4.0.0)

parse_url -- Analiza una URL y devuelve sus componentes

Descripción

array parse_url ( string url)

Esta función devuelve una matriz que apunta a alguno de los componentes de la URL que estén presentes. Esto incluye el "esquema", "host", "puerto", "usuario", "pass", "path", "consulta", y "fragmento".

Anterior | Inicio | Siguiente
base64_encode | Subir | urldecode


urldecode

(PHP 3, PHP 4 >= 4.0.0)

urldecode -- decodifica URL-cifradas en una cadena de texto

Descripción

string urldecode ( string cadena)

Decodifica cualquier %## cifrado en la cadena dada. Se devuelve la cadena decodificada.

Ejemplo 1. Ejemplo urldecode()

$a = split ('&', $querystring);
$i = 0;
while ($i < count ($a)) {
  $b = split ('=', $a [$i]);
  echo 'El valor para el parámetro ', htmlspecialchars (urldecode ($b [0])),
       ' es ', htmlspecialchars (urldecode ($b [1])), "<BR>";
  $i++;
}

Vea también urlencode()

Anterior | Inicio | Siguiente
parse_url | Subir | urlencode


urlencode

(PHP 3, PHP 4 >= 4.0.0)

urlencode -- Codifica una URL en una cadena de texto

Descripción

string urlencode ( string cadena)

Devuelve una cadena en la que todos los carácteres no alfanuméricos excepto -_. han sido reemplazados con un signo de porcentaje (%) seguido por dos dígitos hexadecimales y los espacios han sido codificados como signos positivos (+). Está codificado de la misma manera que los datos que se envian desde un formulario WWW, es decir de la misma forma que el tipo application/x-www-form-urlencoded. Esto difiere del cifrado RFC1738 (vea rawurlencode() ) en el que por razones históricas, los espacios son codificados como signos positivos (+ ). Esta función es conveniente para codificar una cadena de texto que va a ser usada como parte de una consulta de una URL, y es una forma adecuada de pasar variables a la página siguiente:

Ejemplo 1. Ejemplo urlencode()

echo '<A HREF="mycgi?foo=', urlencode ($userinput), '">';

Vea también urldecode()

Anterior | Inicio | Siguiente
urldecode | Subir | Funciones sobre variables


Funciones sobre variables

Manual de PHP
Anterior Siguiente

XCVIII. Funciones sobre variables

Tabla de contenidos
doubleval — Obtiene el valor double (decimal) de una variable.
empty — Determina si una variable está definida
gettype — Obtiene el tipo de una variable.
intval — Obtiene el valor entero de una variable.
is_array — Averigua si una variable es un array.
is_double — Averigua si una variable es un valor double (número decimal).
is_float — Averigua si una variable es un flotante.
is_int — Averigua si una variable es un valor entero.
is_integer — Averigua si una variable es un valor entero.
is_long — Averigua si una varible es un valor entero.
is_object — Averigua si una varible es un objeto.
is_real — Averigua si una varible es un número real.
is_string — Averigua si una varible es una cadena de caracteres (string).
isset — Determina si una varible está definida
settype — Establece el tipo de una variable.
strval — Obtiene una cadena de caracteres a partir de una variable.
unset — Destruye una variable dada

Anterior | Inicio | Siguiente
urlencode | Subir | doubleval


doubleval

(PHP 3, PHP 4 >= 4.0.0)

doubleval -- Obtiene el valor double (decimal) de una variable.

Descripción

double doubleval ( mixed var)

Devuelve el valor double (decimal en punto flotante) de var.

var puede ser cualquier tipo escalar. No se puede usar doubleval() sobre arrays u objetos.

Ver también intval(),
strval(),
settype() y Type juggling.

Anterior | Inicio | Siguiente
Funciones sobre variables | Subir | empty


empty

(unknown)

empty -- Determina si una variable está definida

Descripción

int empty ( mixed var)

Devuelve FALSE si var está definida y tiene un valor no-vacío o distinto de cero; en otro caso devuelve TRUE.

Ver también isset() y unset().

Anterior | Inicio | Siguiente
doubleval | Subir | gettype


gettype

(PHP 3, PHP 4 >= 4.0.0)

gettype -- Obtiene el tipo de una variable.

Descripción

string gettype ( mixed var)

Devuelve el tipo de la variable PHP var.

Los valores posibles de la cadena devuelta son:

  • "integer"

  • "double"

  • "string"

  • "array"

  • "object"

  • "unknown type"

Ver también settype().

Anterior | Inicio | Siguiente
empty | Subir | intval


intval

(PHP 3, PHP 4 >= 4.0.0)

intval -- Obtiene el valor entero de una variable.

Descripción

int intval ( mixed var [, int base])

Devuelve el valor entero de var, usando la base de conversión especificada (por defecto es base 10).

var puede ser cualquier tipo escalar. No se puede usar intval() sobre arrays u objetos.

Ver también doubleval(),
strval(),
settype() y Type juggling.

Anterior | Inicio | Siguiente
gettype | Subir | is_array


is_array

(PHP 3, PHP 4 >= 4.0.0)

is_array -- Averigua si una variable es un array.

Descripción

int is_array ( mixed var)

Devuelve TRUE si var es un array, y FALSE en otro caso.

Ver también is_double(),
is_float(),
is_int(),
is_integer(),
is_real(),
is_string(),
is_long(), y
is_object().

Anterior | Inicio | Siguiente
intval | Subir | is_double


is_double

(PHP 3, PHP 4 >= 4.0.0)

is_double -- Averigua si una variable es un valor double (número decimal).

Descripción

int is_double ( mixed var)

Devuelve TRUE si var es un double (número decimal), y FALSE en otro caso.

Ver también is_array(),
is_float(),
is_int(),
is_integer(),
is_real(),
is_string(),
is_long(), y
is_object().

Anterior | Inicio | Siguiente
is_array | Subir | is_float


is_float

(PHP 3, PHP 4 >= 4.0.0)

is_float -- Averigua si una variable es un flotante.

Descripción

int is_float ( mixed var)

Esta función es un alias de is_double().

Ver también is_double(),
is_real(),
is_int(),
is_integer(),
is_string(),
is_object(),
is_array(), y
is_long().

Anterior | Inicio | Siguiente
is_double | Subir | is_int


is_int

(PHP 3, PHP 4 >= 4.0.0)

is_int -- Averigua si una variable es un valor entero.

Descripción

int is_int ( mixed var)

Esta función es un alias de is_long().

Ver también is_double(),
is_float(),
is_integer(),
is_string(),
is_real(),
is_object(),
is_array(), y
is_long().

Anterior | Inicio | Siguiente
is_float | Subir | is_integer


is_integer

(PHP 3, PHP 4 >= 4.0.0)

is_integer -- Averigua si una variable es un valor entero.

Descripción

int is_integer ( mixed var)

Esta función es un alias de is_long().

Ver también is_double(),
is_float(),
is_int(),
is_string(),
is_real(),
is_object(),
is_array(), y
is_long().

Anterior | Inicio | Siguiente
is_int | Subir | is_long


is_long

(PHP 3, PHP 4 >= 4.0.0)

is_long -- Averigua si una varible es un valor entero.

Descripción

int is_long ( mixed var)

Devuelve TRUE si var es un entero (long), y FALSE en otro caso.

Ver también is_double(),
is_float(),
is_int(),
is_real(),
is_string(),
is_object(),
is_array(), y
is_integer().

Anterior | Inicio | Siguiente
is_integer | Subir | is_object


is_object

(PHP 3, PHP 4 >= 4.0.0)

is_object -- Averigua si una varible es un objeto.

Descripción

int is_object ( mixed var)

Devuelve TRUE si var es un objeto, y FALSE en otro caso.

Ver también is_long(),
is_int(),
is_integer(),
is_float(),
is_double(),
is_real(),
is_string(), y
is_array().

Anterior | Inicio | Siguiente
is_long | Subir | is_real


is_real

(PHP 3, PHP 4 >= 4.0.0)

is_real -- Averigua si una varible es un número real.

Descripción

int is_real ( mixed var)

Esta función es un alias de is_double().

Ver también is_long(),
is_int(),
is_integer(),
is_float(),
is_double(),
is_object(),
is_string(), y
is_array().

Anterior | Inicio | Siguiente
is_object | Subir | is_string


is_string

(PHP 3, PHP 4 >= 4.0.0)

is_string -- Averigua si una varible es una cadena de caracteres (string).

Descripción

int is_string ( mixed var)

Devuelve TRUE si var es una cadena, y FALSE en otro caso.

Ver también is_long(),
is_int(),
is_integer(),
is_float(),
is_double(),
is_real(),
is_object(), y
is_array().

Anterior | Inicio | Siguiente
is_real | Subir | isset


isset

(unknown)

isset -- Determina si una varible está definida

Descripción

int isset ( mixed var)

Devuelve TRUE si var existe; y FALSE en otro caso.

Si una variable ha sido destruida con unset(), ya no estará definida (no será isset()).

$a = "test";
echo isset($a); // true
unset($a);
echo isset($a); // false

Ver también empty() y unset().

Anterior | Inicio | Siguiente
is_string | Subir | settype


settype

(PHP 3, PHP 4 >= 4.0.0)

settype -- Establece el tipo de una variable.

Descripción

int settype ( string var, string type)

Establece el tipo de la varible var como type.

Los valores posibles para type son:

  • "integer"

  • "double"

  • "string"

  • "array"

  • "object"

Devuelve TRUE si se lleva a cabo con éxito; en otro caso devuelve FALSE.

Ver también gettype().

Anterior | Inicio | Siguiente
isset | Subir | strval


strval

(PHP 3, PHP 4 >= 4.0.0)

strval -- Obtiene una cadena de caracteres a partir de una variable.

Descripción

string strval ( mixed var)

Devuelve una cadena con el valor de var.

var puede ser cualquier tipo escalar. No se puede usar strval() sobre arrays u objetos.

Ver también doubleval(),
intval(),
settype() y Type juggling.

Anterior | Inicio | Siguiente
settype | Subir | unset


unset

(unknown)

unset -- Destruye una variable dada

Descripción

int unset ( mixed var)

unset() destruye la variable especificada y devuelve TRUE.

Ejemplo 1. Ejemplo de unset()

unset( $foo );
unset( $bar['quux'] );

Ver también isset() y empty().

Anterior | Inicio | Siguiente
strval | Subir | vpopmail functions


vpopmail functions

Manual de PHP
Anterior Siguiente

XCIX. vpopmail functions

Tabla de contenidos
vpopmail_add_domain — Add a new virtual domain
vpopmail_del_domain — Delete a virtual domain
vpopmail_add_alias_domain — Add an alias for a virtual domain
vpopmail_add_domain_ex — Add a new virtual domain
vpopmail_del_domain_ex — Delete a virtual domain
vpopmail_add_alias_domain_ex — Add alias to an existing virtual domain
vpopmail_add_user — Add a new user to the specified virtual domain
vpopmail_del_user — Delete a user from a virtual domain
vpopmail_passwd — Change a virtual user's password
vpopmail_set_user_quota — Sets a virtual user's quota
vpopmail_auth_user — Attempt to validate a username/domain/password. Returns true/false
vpopmail_alias_add — insert a virtual alias
vpopmail_alias_del — deletes all virtual aliases of a user
vpopmail_alias_del_domain — deletes all virtual aliases of a domain
vpopmail_alias_get — get all lines of an alias for a domain
vpopmail_alias_get_all — get all lines of an alias for a domain
vpopmail_error — Get text message for last vpopmail error. Returns string

Anterior | Inicio | Siguiente
unset | Subir | vpopmail_add_domain


vpopmail_add_domain

(PHP 4 >= 4.0.5)

vpopmail_add_domain -- Add a new virtual domain

Description

bool vpopmail_add_domain ( string domain, string dir, int uid, int gid)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail functions | Subir | vpopmail_del_domain


vpopmail_del_domain

(PHP 4 >= 4.0.5)

vpopmail_del_domain -- Delete a virtual domain

Description

bool vpopmail_del_domain ( string domain)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_add_domain | Subir | vpopmail_add_alias_domain


vpopmail_add_alias_domain

(PHP 4 >= 4.0.5)

vpopmail_add_alias_domain -- Add an alias for a virtual domain

Description

bool vpopmail_add_alias_domain ( string domain, string aliasdomain)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_del_domain | Subir | vpopmail_add_domain_ex


vpopmail_add_domain_ex

(PHP 4 >= 4.0.5)

vpopmail_add_domain_ex -- Add a new virtual domain

Description

bool vpopmail_add_domain_ex ( string domain, string passwd [, string quota [, string bounce [, bool apop]]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_add_alias_domain | Subir | vpopmail_del_domain_ex


vpopmail_del_domain_ex

(PHP 4 >= 4.0.5)

vpopmail_del_domain_ex -- Delete a virtual domain

Description

bool vpopmail_del_domain_ex ( string domain)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_add_domain_ex | Subir | vpopmail_add_alias_domain_ex


vpopmail_add_alias_domain_ex

(PHP 4 >= 4.0.5)

vpopmail_add_alias_domain_ex -- Add alias to an existing virtual domain

Description

bool vpopmail_add_alias_domain_ex ( string olddomain, string newdomain)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_del_domain_ex | Subir | vpopmail_add_user


vpopmail_add_user

(PHP 4 >= 4.0.5)

vpopmail_add_user -- Add a new user to the specified virtual domain

Description

bool vpopmail_add_user ( string user, string domain, string password [, string gecos [, bool apop]])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_add_alias_domain_ex | Subir | vpopmail_del_user


vpopmail_del_user

(PHP 4 >= 4.0.5)

vpopmail_del_user -- Delete a user from a virtual domain

Description

bool vpopmail_del_user ( string user, string domain)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_add_user | Subir | vpopmail_passwd


vpopmail_passwd

(PHP 4 >= 4.0.5)

vpopmail_passwd -- Change a virtual user's password

Description

bool vpopmail_passwd ( string user, string domain, string password)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_del_user | Subir | vpopmail_set_user_quota


vpopmail_set_user_quota

(PHP 4 >= 4.0.5)

vpopmail_set_user_quota -- Sets a virtual user's quota

Description

bool vpopmail_set_user_quota ( string user, string domain, string quota)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_passwd | Subir | vpopmail_auth_user


vpopmail_auth_user

(PHP 4 >= 4.0.5)

vpopmail_auth_user -- Attempt to validate a username/domain/password. Returns true/false

Description

bool vpopmail_auth_user ( string user, string domain, string password [, string apop])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_set_user_quota | Subir | vpopmail_alias_add


vpopmail_alias_add

(PHP 4 >= 4.1.0)

vpopmail_alias_add -- insert a virtual alias

Description

bool vpopmail_alias_add ( string user, string domain, string alias)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_auth_user | Subir | vpopmail_alias_del


vpopmail_alias_del

(PHP 4 >= 4.1.0)

vpopmail_alias_del -- deletes all virtual aliases of a user

Description

bool vpopmail_alias_del ( string user, string domain)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_alias_add | Subir | vpopmail_alias_del_domain


vpopmail_alias_del_domain

(PHP 4 >= 4.1.0)

vpopmail_alias_del_domain -- deletes all virtual aliases of a domain

Description

bool vpopmail_alias_del_domain ( string domain)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_alias_del | Subir | vpopmail_alias_get


vpopmail_alias_get

(PHP 4 >= 4.1.0)

vpopmail_alias_get -- get all lines of an alias for a domain

Description

array vpopmail_alias_get ( string alias, string domain)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_alias_del_domain | Subir | vpopmail_alias_get_all


vpopmail_alias_get_all

(PHP 4 >= 4.1.0)

vpopmail_alias_get_all -- get all lines of an alias for a domain

Description

array vpopmail_alias_get_all ( string domain)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_alias_get | Subir | vpopmail_error


vpopmail_error

(PHP 4 >= 4.0.5)

vpopmail_error -- Get text message for last vpopmail error. Returns string

Description

string vpopmail_error ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
vpopmail_alias_get_all | Subir | W32api functions


W32api functions

Manual de PHP
Anterior Siguiente

C. W32api functions

Tabla de contenidos
w32api_set_call_method — Sets the calling method used
w32api_register_function — Registers function function_name from library with PHP
w32api_invoke_function — Invokes function funcname with the arguments passed after the function name
w32api_deftype — Defines a type for use with other w32api_functions
w32api_init_dtype — Creates an instance to the data type typename and fills it with the values val1, val2, the function then returns a DYNAPARM which can be passed when invoking a function as a parameter

Anterior | Inicio | Siguiente
vpopmail_error | Subir | w32api_set_call_method


w32api_set_call_method

(PHP 4 >= 4.2.0)

w32api_set_call_method -- Sets the calling method used

Description

void w32api_set_call_method ( int method)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
W32api functions | Subir | w32api_register_function


w32api_register_function

(PHP 4 >= 4.2.0)

w32api_register_function -- Registers function function_name from library with PHP

Description

bool w32api_register_function ( string libary, string function_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
w32api_set_call_method | Subir | w32api_invoke_function


w32api_invoke_function

(unknown)

w32api_invoke_function -- Invokes function funcname with the arguments passed after the function name

Description

mixed w32api_invoke_function ( string funcname)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
w32api_register_function | Subir | w32api_deftype


w32api_deftype

(PHP 4 >= 4.2.0)

w32api_deftype -- Defines a type for use with other w32api_functions

Description

int w32api_deftype ( string typename, string member1_type, string member1_name)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
w32api_invoke_function | Subir | w32api_init_dtype


w32api_init_dtype

(PHP 4 >= 4.2.0)

w32api_init_dtype -- Creates an instance to the data type typename and fills it with the values val1, val2, the function then returns a DYNAPARM which can be passed when invoking a function as a parameter

Description

resource w32api_init_dtype ( string typename, mixed val1, mixed val2)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
w32api_deftype | Subir | Funciones WDDX


Funciones WDDX

Manual de PHP
Anterior Siguiente

CI. Funciones WDDX

Estas funciones permiten el uso de WDDX.

Debe saber que todas las funciones que serializan variables usan el primer elemento de un array para determinar si este ha de serializarse en forma de array o como estructura. Si el primer elemento esta indexado por una cadena, se serializa como estructura, y en caso contrario, como array.

Ejemplo 1. Serializacion de un valor simple

<?php
print wddx_serialize_value("Ejemplo de PHP a paquete WDDX", "Paquete PHP");
?>

Este ejemplo producira:

<wddxPacket version='0.9'><header comment='Paquete PHP'/><data>
<string>Ejemplo de PHP a paquete WDDX</string></data></wddxPacket>

Ejemplo 2. Uso de paquetes incrementales

<?php
$pi = 3.1415926;
$packet_id = wddx_packet_start("PHP");
wddx_add_vars($packet_id, "pi");

/* Suponga que $ciudades se ha obtenido de una base de datos */
$ciudades = array("Austin", "Novato", "Seattle");
wddx_add_vars($packet_id, "ciudades");

$packet = wddx_packet_end($packet_id);
print $packet;
?>

Este ejemplo producira:

<wddxPacket version='0.9'><header comment='PHP'/><data><struct>
<var name='pi'><number>3.1415926</number></var><var name='ciudades'>
<array length='3'><string>Austin</string><string>Novato</string>
<string>Seattle</string></array></var></struct></data></wddxPacket>

Tabla de contenidos
wddx_add_vars — Finaliza un paquete WDDX con el identificador dado
wddx_deserialize — Des-serializa un paquete WDDX
wddx_packet_end — Finaliza un paquete WDDX con el identificador dado
wddx_packet_start — Comienza un nuevo paquete WDDX con una estructura dentro
wddx_serialize_value — Serializa un valor simple en un paquete WDDX
wddx_serialize_vars — Serializa variables en un paquete WDDX

Anterior | Inicio | Siguiente
w32api_init_dtype | Subir | wddx_add_vars


wddx_serialize_value

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

wddx_serialize_value -- Serializa un valor simple en un paquete WDDX

Descripcion

cadena wddx_serialize_value ( varios-tipos var [, cadena comentario])

wddx_serialize_value() se utiliza para crear un paquete WDDX desde un valor simple dado. Toma el valor contenido en var, y una cadena comentario opcional que aparecera en la cabecera del paquete, y devuelve el paquete WDDX.

Anterior | Inicio | Siguiente
wddx_packet_start | Subir | wddx_serialize_vars


wddx_serialize_vars

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

wddx_serialize_vars -- Serializa variables en un paquete WDDX

Descripcion

cadena wddx_serialize_vars ( varios-tipos nombre_var [, varios-tipos ...])

wddx_serialize_vars() se utiliza para crear un paquete WDDX con una estructura que contiene la representacion serializada de las variables pasadas como parametros.

wddx_serialize_vars() toma un numero variable de argumentos, cada uno de los cuales puede ser una cadena con el nombre de una variable o un array con nombres de variables, o de otro array, etc.

Ejemplo 1. wddx_serialize_vars example

<?php
$a = 1;
$b = 5.5;
$c = array("azul", "naranja", "violeta");
$d = "colores";

$clvars = array("c", "d");
print wddx_serialize_vars("a", "b", $clvars);
?>

El ejemplo anterior producira:
<wddxPacket version='0.9'><header/><data><struct><var name='a'><number>1</number></var>
<var name='b'><number>5.5</number></var><var name='c'><array length='3'>
<string>azul</string><string>naranja</string><string>violeta</string></array></var>
<var name='d'><string>colores</string></var></struct></data></wddxPacket>

Anterior | Inicio | Siguiente
wddx_serialize_value | Subir | Funciones de intérprete XML


wddx_packet_start

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

wddx_packet_start -- Comienza un nuevo paquete WDDX con una estructura dentro

Descripcion

entero wddx_packet_start ( [cadena comentario])

Utilice wddx_packet_start() para comenzar un nuevo paquete WDDX que permita la adicion sucesiva de variables. Recibe el parametro opcional comentario y devuelve un identificador de paquete para su uso en posteriores llamadas. Automaticamente define una estructura dentro del paquete para contener las variables.

Anterior | Inicio | Siguiente
wddx_packet_end | Subir | wddx_serialize_value


wddx_packet_end

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

wddx_packet_end -- Finaliza un paquete WDDX con el identificador dado

Descripcion

cadena wddx_packet_end ( entero packet_id)

wddx_packet_end() finaliza el paquete WDDX especificado por el packet_id y devuelve la cadena con el paquete.

Anterior | Inicio | Siguiente
wddx_deserialize | Subir | wddx_packet_start


wddx_add_vars

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

wddx_add_vars -- Finaliza un paquete WDDX con el identificador dado

Descripcion

wddx_add_vars ( entero packet_id, varios-tipos name_var [, varios-tipos ...])

wddx_add_vars() se utiliza para serializar las variables dadas e incorporar el resultado al paquete especificado por packet_id. Las variables a serializar se especifican exactamente igual que en wddx_serialize_vars().

Anterior | Inicio | Siguiente
Funciones WDDX | Subir | wddx_deserialize


wddx_deserialize

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

wddx_deserialize -- Des-serializa un paquete WDDX

Descripcion

varios-tipos wddx_deserialize ( cadena packet)

wddx_deserialized() toma una cadena packet y la desserializa. Devuelve el resultado que puede ser de tipo cadena, numerico o array. Las estructuras son desserializadas en forma de arrays asociativos.

Anterior | Inicio | Siguiente
wddx_add_vars | Subir | wddx_packet_end


Funciones de intérprete XML

Manual de PHP
Anterior Siguiente

CII. Funciones de intérprete XML

Introducción

Acerca de XML

XML (eXtensible Markup Language) es un formato de información para el intercambio de documentos estructurado en la "Web" Es un estándar definido por el consorcio de la "World Wide Web" (W3C). Se puede encontrar información sobre XML y tecnologís relacionadas en http://www.w3.org/XML/.

Instalación

Esta extensión usa expat, que se puede encontrar en http://www.jclark.com/xml/. El Makefile que viene con expat no crea una biblioteca por defecto, se puede usar esta regla de make para eso:
libexpat.a: $(OBJS)
    ar -rc $@ $(OBJS)
    ranlib $@
Se puede conseguir un paquete RPM de expat en http://sourceforge.net/projects/expat/.

Nota que si se usa Apache-1.3.7 o posterior, ya tienes la biblioteca requerida expat. Simplemente, configura PHP usando --with-xml (sin ninguna ruta adicional) y usará automáticamente la biblioteca expat incluida en Apache.

En UNIX, ejecuta configure con la opción --with-xml. La biblioteca expat debería ser instalada en algún lugar donde el compilador pueda encontrarlo. Si se compila PHP como un módulo para Apache 1.3.9 o posterior, PHP automáticamente usará la biblioteca integrada expat de Apache. Puede necesitar establecer CPPFLAGS y LDFLAGS en su entorno antes de ejecutar "configure" si se ha instalado expat en algún lugar exótico.

Compila PHP. ¡Ta-tam! Ya debería estar.

Sobre Esta Extensión

Esta extensión de PHP implementa soporte para expat de James Clarkin en PHP. Este conjunto de herramientas permite interpretar, pero no validar, documentos XML. Soporta tres codificaciones de caracteres fuente, también proporcionados por PHP: US-ASCII, ISO-8859-1 y UTF-8. UTF-16 no está soportado.

Esta extensión permite crear intérpretes de XML y definir entonces gestores para diferentes eventos XML. Cada intérprete XML tiene también unos cuantos parámetros que se pueden ajustar.

Los gestores de eventos XML definidos son:

Tabla 1. Gestores de XML soportados

Función PHP para establecer gestor | Descripción del evento
xml_set_element_handler() | Los eventos de elemento ("element") se producen cuando el intérprete XML encuentra etiquetas de comienzo o fin. Hay gestores separados para etiquetas de comienzo y etiquetas de fin.
xml_set_character_data_handler() | La información de caracteres es, por definición, todo el contenido no "marcado" de los documentos XML, incluidos los espacios en blanco entre etiquetas. Nota que el intérprete XML no añade o elimina ningún espacio en blanco, depende de la aplicación (de ti) decidir si el espacio en blanco es significativo.
xml_set_processing_instruction_handler() | Los programadores de PHP deberían estar ya familiarizados con las instrucciones de procesado (PI). <?php ?> es una instrucción de procesado, donde php se denomina el "objetivo de procesado". El manejo de éstos es específico a cada aplicación, salvo que todos los objetivos PI que comienzan con "XML" están reservados.
xml_set_default_handler() | Todo lo que no va a otro gestor, va al gestor por defecto. Se tendrán en el gestor por defecto cosas como las declaraciones de tipos de documento y XML.
xml_set_unparsed_entity_decl_handler() | Este gestor se llamará para la declaración de una entidad no analizada (NDATA).
xml_set_notation_decl_handler() | Este gestor se llama para la declaración de una anotación.
xml_set_external_entity_ref_handler() | Este gestor se llama cuando el intérprete XML encuentra una referencia a una entidad general interpretada externa. Puede ser una referencia a un archivo o URL, por ejemplo. Ver el ejemplo de entidad externa para demostración.

Case Folding

Las funciones manejadoras de elementos pueden tomar sus nombres de elementos "case-folded". Case-folding se define en el estándar XML como "un proceso aplicado a una secuencia de caracteres, en el cual aquellos identificados como sin-mayúsculas son reemplazados por sus equivalentes en mayúsculas". En otras palabras, cuando se trata de XML, case-folding simplemente significa poner en mayúsculas.

Por defecto, todos los nombres de elementos que se pasan a las funciones gestoras estan "pasados a mayúsculas". Esta conducta puede ser observada y controlada por el analizador XML con las funciones xml_parser_get_option() y xml_parser_set_option(), respectivamente.

Códigos de Error

Las siguientes constantes se definen para códigos de error XML (como los devuelve xml_parse()):

XML_ERROR_NONE
XML_ERROR_NO_MEMORY
XML_ERROR_SYNTAX
XML_ERROR_NO_ELEMENTS
XML_ERROR_INVALID_TOKEN
XML_ERROR_UNCLOSED_TOKEN
XML_ERROR_PARTIAL_CHAR
XML_ERROR_TAG_MISMATCH
XML_ERROR_DUPLICATE_ATTRIBUTE
XML_ERROR_JUNK_AFTER_DOC_ELEMENT
XML_ERROR_PARAM_ENTITY_REF
XML_ERROR_UNDEFINED_ENTITY
XML_ERROR_RECURSIVE_ENTITY_REF
XML_ERROR_ASYNC_ENTITY
XML_ERROR_BAD_CHAR_REF
XML_ERROR_BINARY_ENTITY_REF
XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF
XML_ERROR_MISPLACED_XML_PI
XML_ERROR_UNKNOWN_ENCODING
XML_ERROR_INCORRECT_ENCODING
XML_ERROR_UNCLOSED_CDATA_SECTION
XML_ERROR_EXTERNAL_ENTITY_HANDLING

Codificación de caracteres

La extension XML de PHP soporta el conjunto de caracteres Unicode a través de diferentes codificaciones de caracteres. Hay dos tipos de codificaciones de caracteres, coficación de fuente y codificación de destino. La representación interna de PHP del documento está siempre codificada con UTF-8.

La codificación de fuente se hace cuando un documento XML es interpretado. Al crear un intérprete XML , se puede especificar una codificación de fuente (esta codificación no se puede cambiar má tarde durante el tiempo de vida del intérprete XML). Las codificaciones de fuente soportadas son ISO-8859-1, US-ASCII y UTF-8. Las dos primeras son codificaciones de byte-único, lo que significa que cada carácter se representa por un solo byte. UTF-8 puede codificar caracteres compuestos por un número variable de bits (hasta 21) en de uno a cuatro bytes. La codificación fuente por defecto usada por PHP es ISO-8859-1.

La codificación de destino se hace cuando PHP pasa datos a las funciones gestoras XML. Cuando se crea un intérprete XML, la codificación de destino se crea igual a la codificación de fuente, pero se puede cambiar en cualquier momento. La codificación de destino afectará a la información de los caracteres así como a los nombres de las etiquetas y a los objetivos de instrucciones de procesado.

Si el intérprete XML encuentra caracteres fuera del rango que su codificación de fuente es capaz de representar, devolverá un error.

Si PHP encuentra caracteres en el documento XML interpretado que no pueden ser representados en la codificación de destino elegida, los caracteres problema serán "degradados". Actualmente, esto significa que tales caracteres se reemplazan por un signo de interrogación.

Algunos Ejemplos

Aquí hay algunos ejemplos de archivos de comandos PHP que interpretan documentos XML.

Ejemplos de Estructuras de Elementos XML

Este primer ejemplo muestra la estructura del elemento inicio en un documento con indentación.

Ejemplo 1. Muestra la Estructura del Elemento XML

$file = "data.xml";
$depth = array();

function startElement($parser, $name, $attrs) {
    global $depth;
    for ($i = 0; $i < $depth[$parser]; $i++) {
        print "  ";
    }
    print "$name\n";
    $depth[$parser]++;
}

function endElement($parser, $name) {
    global $depth;
    $depth[$parser]--;
}

$xml_parser = xml_parser_create();
xml_set_element_handler($xml_parser, "startElement", "endElement");
if (!($fp = fopen($file, "r"))) {
    die("could not open XML input");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);

Ejemplo de Mapeo de Etiquetas XML

Ejemplo 2. Traduciendo XML a HTML

Este ejemplo transforma etiquetas de un documento XML directamente a etiquetas HTML. Los elementos no encontrados en el "array de traducción ("map array") son ignorados. Por supuesto, este ejemplo solamente funcionará con un tipo de documentos XML específico.
$file = "data.xml";
$map_array = array(
    "BOLD"     => "B",
    "EMPHASIS" => "I",
    "LITERAL"  => "TT"
);

function startElement($parser, $name, $attrs) {
    global $map_array;
    if ($htmltag = $map_array[$name]) {
        print "<$htmltag>";
    }
}

function endElement($parser, $name) {
    global $map_array;
    if ($htmltag = $map_array[$name]) {
        print "</$htmltag>";
    }
}

function characterData($parser, $data) {
    print $data;
}

$xml_parser = xml_parser_create();
// usa case-folding para que estemos seguros de encontrar la etiqueta
// en $map_array
xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, true);
xml_set_element_handler($xml_parser, "startElement", "endElement");
xml_set_character_data_handler($xml_parser, "characterData");
if (!($fp = fopen($file, "r"))) {
    die("could not open XML input");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);

Ejemplo de Entidad Externa XML

Este ejemplo resalta el código XML. Ilustra cómo usar un gestor de referencia de entidades extenas para incluir y analizar otros documentos, así como cuúntos PIs pueden ser procesados, y un modo de determinar "confianza" para PIs que contienen código.

Los documentos XML que se pueden usar en este ejemplo se encuentran bajo el ejemplo (xmltest.xml y xmltest2.xml.)

Ejemplo 3. Ejemplo de Entidades Externas

$file = "xmltest.xml";

function trustedFile($file) {
    // solamente confía en archivos locales que nos pertenezcan
    if (!eregi("^([a-z]+)://", $file)
        && fileowner($file) == getmyuid()) {
            return true;
    }
    return false;
}

function startElement($parser, $name, $attribs) {
    print "&lt;<font color=\"#0000cc\">$name</font>";
    if (sizeof($attribs)) {
        while (list($k, $v) = each($attribs)) {
            print " <font color=\"#009900\">$k</font>=\"<font
                   color=\"#990000\">$v</font>\"";
        }
    }
    print "&gt;";
}

function endElement($parser, $name) {
    print "&lt;/<font color=\"#0000cc\">$name</font>&gt;";
}

function characterData($parser, $data) {
    print "<b>$data</b>";
}

function PIHandler($parser, $target, $data) {
    switch (strtolower($target)) {
        case "php":
            global $parser_file;
            // Si el documento analizado es "de confianza", diremos
            // que es seguro ejecutar código PHP en su interior.
            // Si no, en vez de ello mostrará el código.
            if (trustedFile($parser_file[$parser])) {
                eval($data);
            } else {
                printf("Untrusted PHP code: <i>%s</i>",
                        htmlspecialchars($data));
            }
            break;
    }
}

function defaultHandler($parser, $data) {
    if (substr($data, 0, 1) == "&" && substr($data, -1, 1) == ";") {
        printf('<font color="#aa00aa">%s</font>',
                htmlspecialchars($data));
    } else {
        printf('<font size="-1">%s</font>',
                htmlspecialchars($data));
    }
}

function externalEntityRefHandler($parser, $openEntityNames, $base, $systemId,
                                  $publicId) {
    if ($systemId) {
        if (!list($parser, $fp) = new_xml_parser($systemId)) {
            printf("Could not open entity %s at %s\n", $openEntityNames,
                   $systemId);
            return false;
        }
        while ($data = fread($fp, 4096)) {
            if (!xml_parse($parser, $data, feof($fp))) {
                printf("XML error: %s at line %d while parsing entity %s\n",
                       xml_error_string(xml_get_error_code($parser)),
                       xml_get_current_line_number($parser), $openEntityNames);
                xml_parser_free($parser);
                return false;
            }
        }
        xml_parser_free($parser);
        return true;
    }
    return false;
}

function new_xml_parser($file) {
    global $parser_file;

    $xml_parser = xml_parser_create();
    xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, 1);
    xml_set_element_handler($xml_parser, "startElement", "endElement");
    xml_set_character_data_handler($xml_parser, "characterData");
    xml_set_processing_instruction_handler($xml_parser, "PIHandler");
    xml_set_default_handler($xml_parser, "defaultHandler");
    xml_set_external_entity_ref_handler($xml_parser, "externalEntityRefHandler");

    if (!($fp = @fopen($file, "r"))) {
        return false;
    }
    if (!is_array($parser_file)) {
        settype($parser_file, "array");
    }
    $parser_file[$xml_parser] = $file;
    return array($xml_parser, $fp);
}

if (!(list($xml_parser, $fp) = new_xml_parser($file))) {
    die("could not open XML input");
}

print "<pre>";
while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d\n",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
print "</pre>";
print "parse complete\n";
xml_parser_free($xml_parser);

?>

Ejemplo 4. xmltest.xml

<?xml version='1.0'?>
<!DOCTYPE chapter SYSTEM "/just/a/test.dtd" [
<!ENTITY plainEntity "FOO entity">
<!ENTITY systemEntity SYSTEM "xmltest2.xml">
]>
<chapter>
 <TITLE>Title &plainEntity;</TITLE>
 <para>
  <informaltable>
   <tgroup cols="3">
    <tbody>
     <row><entry>a1</entry><entry morerows="1">b1</entry><entry>c1</entry></row>
     <row><entry>a2</entry><entry>c2</entry></row>
     <row><entry>a3</entry><entry>b3</entry><entry>c3</entry></row>
    </tbody>
   </tgroup>
  </informaltable>
 </para>
 &systemEntity;
 <sect1 id="about">
  <title>About this Document</title>
  <para>
   <!-- this is a comment -->
   <?php print 'Hi!  This is PHP version '.phpversion(); ?>
  </para>
 </sect1>
</chapter>

Este archivo se incluye desde xmltest.xml:

Ejemplo 5. xmltest2.xml

<?xml version="1.0"?>
<!DOCTYPE foo [
<!ENTITY testEnt "test entity">
]>
<foo>
   <element attrib="value"/>
   &testEnt;
   <?php print "This is some more PHP code being executed."; ?>
</foo>

Tabla de contenidos
utf8_decode — Convierte una cadena codificada UTF-8 a ISO-8859-1
utf8_encode — codifica una cadena ISO-8859-1 a UTF-8
xml_error_string — obtiene la cadena de error del analizador XML
xml_get_current_byte_index — obtiene el índice del byte actual para un analizador XML
xml_get_current_column_number — Obtiene el número de columna actual para un analizador XML.
xml_get_current_line_number — obtiene el número de línea actual de un analizador XML
xml_get_error_code — obtiene el código de error del analizador XML
xml_parse — comienza a analizar un documento XML
xml_parser_create — crea un analizador de XML
xml_parser_free — Libera un analizador XML
xml_parser_get_option — obtiene las opciones de un analizador XML
xml_parser_set_option — establece las opciones de un analizador XML
xml_set_character_data_handler — Establece gestores de datos de caracteres
xml_set_default_handler — set up default handler
xml_set_element_handler — establece gestores de los elementos principio y fin
xml_set_external_entity_ref_handler — Establece gestores de referencia de entidades externas
xml_set_notation_decl_handler — Establece gestores de declaraciones de notación
xml_set_object — Usa un analizador XML dentro de un objecto
xml_set_processing_instruction_handler — Establece el gestor de instrucciones de procesado (PI)
xml_set_unparsed_entity_decl_handler — Establece un gestor de declaraciones de entidades no analizadas

Anterior | Inicio | Siguiente
wddx_serialize_vars | Subir | utf8_decode


xml_parser_create

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_parser_create -- crea un analizador de XML

Descripción

int xml_parser_create ( [string encoding])

encoding (opcional)

Qué codificación de caracteres debería usar el analizador. Las siguientes codificación de caracteres están soportadas:

ISO-8859-1 (por defecto)
US-ASCII
UTF-8

Esta función crea un analizador XML y devuelve un índice para usarlo con otras funciones XML. Devuelve FALSE en caso de fallo.

Anterior | Inicio | Siguiente
xml_parse | Subir | xml_parser_free


xml_set_object

(PHP 4 >= 4.0.0)

xml_set_object -- Usa un analizador XML dentro de un objecto

Descripción

void xml_set_object ( int parser, object &object)

Esta función hace a parser utilizable dentro de object. Todas las funciones de callback establecidas por xml_set_element_handler() etc se asumen como métodos de object.

<?php
class xml  {
var $parser;

function xml() {
    $this->parser = xml_parser_create();
    xml_set_object($this->parser,&$this);
    xml_set_element_handler($this->parser,"tag_open","tag_close");
    xml_set_character_data_handler($this->parser,"cdata");
}

function parse($data) {
    xml_parse($this->parser,$data);
}

function tag_open($parser,$tag,$attributes) {
    var_dump($parser,$tag,$attributes);
}

function cdata($parser,$cdata) {
    var_dump($parser,$cdata);
}

function tag_close($parser,$tag) {
    var_dump($parser,$tag);
}

} // end of class xml

$xml_parser = new xml();
$xml_parser->parse("<A ID=\"hallo\">PHP</A>");
?>

Nota: xml_set_object() es gestionable a partir de PHP 4.0.

Anterior | Inicio | Siguiente
xml_set_notation_decl_handler | Subir | xml_set_processing_instruction_handler


xml_set_element_handler

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_set_element_handler -- establece gestores de los elementos principio y fin

Descripción

int xml_set_element_handler ( int parser, string startElementHandler, string endElementHandler)

Establece las funciones de gestion de elementos para el analizador XML parser. startElementHandler y endElementHandler son strings que contienen los nombres de las funciones que deben existir cuando xml_parse() es llamado por parser.

La función denominada startElementHandler debe aceptar tres parámetros: startElementHandler ( int parser, string name, string attribs)

parser

El primer parámetro, parser, es una referencia al analizador XML que llama al gestor.

name

El segundo parámetro, name, contiene el nombre del elemento para el que se llama a este gestor. Si la propiedad de case-folding tiene efecto para este analizador, el nombre del elemento estará en mayúsculas.

attribs

El tercer parámetro, attribs, contiene un array asociativo con los atributos de los elementos (si hay). Las claves de este array son los nombres de los atributos, los valores son los valores de los atributos. Los nombres de los atributos están en mayúsculas (case-folded) con el mismo criterio que los nombres de los elementos. Los valores de los atributos no sufren las consecuencias de case-folding.

El orden original de los atributos se puede recuperar recorriendo attribs del modo usual, usando each(). La primera clave del array es el el primer atributo, y así sucesivamente.

La función llamada endElementHandler debe aceptar dos parámetros: endElementHandler ( int parser, string name)

parser

El primer parámetro, parser, es una referencia al analizador XML que llama al gestor.

name

El segundo parámetro, name, contiene el nombre del elemento para el que se llama a este gestor. Si la propiedad de case-folding tiene efecto para este analizador, el nombre del elemento estará en mayúsculas.

Si una función gestora se establece como la cadena vacía, o FALSE, el gestor en cuestión se deshabilita.

Se devuelve TRUE si se establecieron los gestores, FALSE si parser no es un analizador.

En la actualidad no hay soporte para gestores objeto/método.

Anterior | Inicio | Siguiente
xml_set_default_handler | Subir | xml_set_external_entity_ref_handler


xml_set_character_data_handler

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_set_character_data_handler -- Establece gestores de datos de caracteres

Descripción

int xml_set_character_data_handler ( int parser, string handler)

Establece la función gestora de datos de caracteres para el analizador XML parser. handler es un string que contiene el nombre de la función que debe existir cuando xml_parse() es llamado por parser.

La función nombrada en handler debe aceptar dos parámetros: handler ( int parser, string data)

parser

El primer parámetro, parser, es una referencia al analizador XML que llama al gestor.

data

El segundo parámetro, data, contiene los datos caracteres como string.

Si una función gestora se establece como la cadena vacía, o FALSE, el gestor en cuestión se deshabilita.

Se devuelve TRUE si se estableció el gestor, FALSE si parser no es un analizador.

En la actualidad no hay soporte para gestores objeto/método.

Anterior | Inicio | Siguiente
xml_parser_set_option | Subir | xml_set_default_handler


xml_set_processing_instruction_handler

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_set_processing_instruction_handler -- Establece el gestor de instrucciones de procesado (PI)

Descripción

int xml_set_processing_instruction_handler ( int parser, string handler)

Establece ela función de gestión de instrucciones de procesado (PI) para el analizador XML parser. handler es un string que contiene el nombre de una función que debe existir cuando xml_parse() es llamada por parser.

Una instrucción de procedado tiene el siguiente formato:

<?
       target
       data?>

Puedes poner código PHP en esa etiqueta, pero ten en cuenta una limitación: en una PI XML, la etiqueta de fin de la PI (?>) no puede ser citada, por lo que esta secuencia de caracteres no debería aparecer en el código PHP que insertes con las PIs en documentos XML. Si lo hace, el resto del código PHP, así como la etiqueta de fin de PI "real", serán tratados como datos de caracteres.

La función nombrada en handler debe aceptar tres parámetros: handler ( int parser, string target, string data)

parser

El primer parámetro, parser, es una referencia al analizador XML que llama al gestor.

target

El segundo parámetro, target, contiene el objetivo PI.

data

El tercer parámetro, data, contiene los datos PI.

Si una función gestora se establece como la cadena vacía, o FALSE, el gestor en cuestión se deshabilita.

Se devuelve TRUE si se estableció el gestor, FALSE si parser no es un analizador.

En la actualidad no hay soporte para gestores objeto/método.

Anterior | Inicio | Siguiente
xml_set_object | Subir | xml_set_unparsed_entity_decl_handler


xml_set_default_handler

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_set_default_handler -- set up default handler

Descripción

int xml_set_default_handler ( int parser, string handler)

Establece la función gestora por defecto para un analizador XML parser. handler es un string que contiene el nombre de la función que debe existir cuando xml_parse() es llamado por parser.

La función nombrada en handler debe aceptar dos parámetros: handler ( int parser, string data)

parser

El primer parámetro, parser, es una referencia al analizador XML que llama al gestor.

data

El segundo parámetro, data, contiene los caracteres de dato. Esto puede ser la declaración XML, la declaración de tipo de documento, entidades u otros datos para los cuales no existe otro gestor.

Si una función gestora se establece como la cadena vacía, o FALSE, el gestor en cuestión se deshabilita.

Se devuelve TRUE si se estableció el gestor, FALSE si parser no es un analizador.

En la actualidad no hay soporte para gestores objeto/método.

Anterior | Inicio | Siguiente
xml_set_character_data_handler | Subir | xml_set_element_handler


xml_set_unparsed_entity_decl_handler

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_set_unparsed_entity_decl_handler -- Establece un gestor de declaraciones de entidades no analizadas

Descripción

int xml_set_unparsed_entity_decl_handler ( int parser, string handler)

Establece la función gestora de declaración de entidades no analizadas para el analizador XML parser. handler es una cadena que contiene el nombre de una función que debe existir cuando xml_parse() es llamada por parser.

Este gestor será llamado si el analizador XML encuentra una declaración de entidades externas con una declaración NDATA, como la siguiente:
<!ENTITY name {publicId | systemId}
        NDATA notationName>

Mira la sección 4.2.2 de las especificaciones XML 1.0 para la definición de entidades externas de notación declarada.

La función nombrada en handler debe aceptar seis parámetros: handler ( int parser, string entityName, string base, string systemId, string publicId, string notationName)

parser

El primer parámetro, parser, es una referencia al analizador XML que llama al gestor.

entityName

El nombre de la entidad que va a ser definida.

base

Esta es la base para resolver el identificador de sistema (systemId) de la entidad externa. Actualmente este parámetro siempre será una cadena vacía.

systemId

Identificador de Sistema para la entidad externa.

publicId

Identificador público para la entidad externa.

notationName

Nombre de la notación de esta entidad (ver xml_set_notation_decl_handler()).

Si una función gestora se establece como la cadena vacía, o FALSE, el gestor en cuestión se deshabilita.

Se devuelve TRUE si se estableció el gestor, FALSE si parser no es un analizador.

En la actualidad no hay soporte para gestores objeto/método.

Anterior | Inicio | Siguiente
xml_set_processing_instruction_handler | Subir | XMLRPC functions


xml_set_notation_decl_handler

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_set_notation_decl_handler -- Establece gestores de declaraciones de notación

Descripción

int xml_set_notation_decl_handler ( int parser, string handler)

Establece las funciones gestoras de declaraciones de notación para el analizador XML parser. handler es un string que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

Una declaración de notación es parte del DTD del documento y tiene el siguiente formato:
<!NOTATION name
     {systemId | publicId}
     >
Ver la sección 4.7 de las especificaciones XML 1.0 para la definición de declaraciones de notación.

La función llamada por handler debe aceptar cinco parámetros: handler ( int parser, string notationName, string base, string systemId, string publicId)

parser

El primer parámetro, parser, es una referencia al analizador XML que llama al gestor.

notationName

Este es el nombre de la notación, como se describió arriba en el formato de notación.

base

Esta es la base para resolver el identificador de sistema (systemId) de la declaración. En la actualidad este parámetro es siempre la cadena vacía.

systemId

Identificador de sistema de la declaración de notación externa.

publicId

Identificador público de la declaración de notación externa.

Si una función gestora se establece como la cadena vacía, o FALSE, el gestor en cuestión se deshabilita.

Se devuelve TRUE si se estableció el gestor, FALSE si parser no es un analizador.

En la actualidad no hay soporte para gestores objeto/método.

Anterior | Inicio | Siguiente
xml_set_external_entity_ref_handler | Subir | xml_set_object


xml_set_external_entity_ref_handler

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_set_external_entity_ref_handler -- Establece gestores de referencia de entidades externas

Descripción

int xml_set_external_entity_ref_handler ( int parser, string handler)

Establece la función gestora de declaraciones de notación para el analizador XML parser. handler es un string que contiene el nombre de una función que debe existir cuando xml_parse() es llamado por parser.

La función llamada por handler debe aceptar cinco parámetros, y debería devolver un valor entero. Si el valor devuelto desde el gestor (handler) es falso (lo cual ocurrirá si no se devuelve un valor), el analizador XML dejará de analizar y xml_get_error_code() devolverá XML_ERROR_EXTERNAL_ENTITY_HANDLING. int handler ( int parser, string openEntityNames, string base, string systemId, string publicId)

parser

El primer parámetro, parser, es una referencia al analizador XML que llama al gestor.

openEntityNames

El segundo parámetro, openEntityNames, es una lista, separada por espacios, de los nombres de las entidades que se abren para el análisis de esta entidad (incluido el nombre de la entidad referenciada).

base

Esta es la base para resolver el identificador de sistema (systemid) de la entidad externa. En la actualidad este parámetro es siempre la cadena vacía.

systemId

El cuarto parámetro, systemId, es el identificador del sistema tal como se especificó en la declaración de la entidad.

publicId

El quinto parámetro, publicId, es el identificador público como se especificó en la declaración de la entidad, o una cadena vacía si no se especificó ninguno; el espacio en blanco en el identificador público se habrá normalizado como se requiere en las especificaciones XML.

Si una función gestora se establece como la cadena vacía, o FALSE, el gestor en cuestión se deshabilita.

Se devuelve TRUE si se estableció el gestor, FALSE si parser no es un analizador.

En la actualidad no hay soporte para gestores objeto/método.

Anterior | Inicio | Siguiente
xml_set_element_handler | Subir | xml_set_notation_decl_handler


xml_parse

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_parse -- comienza a analizar un documento XML

Descripción

int xml_parse ( int parser, string data [, int isFinal])

parser

Una referencia al analizador XML que se va a utilizar.

data

Conjunto de información que se analizará. Un documento puede ser analizado por trozos llamando varias veces a xml_parse() con nueva información, siempre que se establezca el parámetro isFinal y sea TRUE cuando el último dato sea analizado.

isFinal (optional)

Si existe y es TRUE, data es el último pedazo de información envíado en este análisis.

Cuando el documento XML es analizado, se hacen llamadas a los gestores para los eventos configurados tantas veces como sea necesario, después de que esta función devuelva TRUE o FALSE.

Devuelve TRUE si el análisis se realiza con éxito, FALSE si no tiene éxito, o si parser no referencia a un analizador válido. Para análisis fallidos, se puede recuperar información de error con xml_get_error_code(), xml_error_string(), xml_get_current_line_number(), xml_get_current_column_number() y xml_get_current_byte_index().

Anterior | Inicio | Siguiente
xml_get_error_code | Subir | xml_parser_create


xml_get_error_code

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_get_error_code -- obtiene el código de error del analizador XML

Descripción

int xml_get_error_code ( int parser)

parser

Una referencia al analizador XML del que obtener el código de error.

Esta función devuelve FALSE si parser no referencia un analizador válido, o si no devuelve uno de los códigos de error listados en la sección de códigos de error.

Anterior | Inicio | Siguiente
xml_get_current_line_number | Subir | xml_parse


xml_error_string

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_error_string -- obtiene la cadena de error del analizador XML

Descripción

string xml_error_string ( int code)

code

Un código de error de xml_get_error_code().

Devuelve una cadena con una descripción textual del código de error code, o FALSE si no se encontró descripción.

Anterior | Inicio | Siguiente
utf8_encode | Subir | xml_get_current_byte_index


xml_get_current_line_number

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_get_current_line_number -- obtiene el número de línea actual de un analizador XML

Descripción

int xml_get_current_line_number ( int parser)

parser

Una referencia al analizador XML del que obtener el número de línea.

Esta función devuelve FALSE si parser no referencia un analizador válido, o si no devuelve en qué línea se encuentra actualmente el buffer de datos del analizador.

Anterior | Inicio | Siguiente
xml_get_current_column_number | Subir | xml_get_error_code


xml_get_current_column_number

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_get_current_column_number -- Obtiene el número de columna actual para un analizador XML.

Descripción

int xml_get_current_column_number ( int parser)

parser

Una referencia al analizador XML del que obtener el número de columna.

Esta función devuelve FALSE si parser no referencia un analizador válido, o si no devuelve en qué columna de la línea actual (como se obtiene de xml_get_current_line_number()) en la que se encuentra el analizador.

Anterior | Inicio | Siguiente
xml_get_current_byte_index | Subir | xml_get_current_line_number


xml_get_current_byte_index

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_get_current_byte_index -- obtiene el índice del byte actual para un analizador XML

Descripción

int xml_get_current_byte_index ( int parser)

parser

Una referencia al analizador XML del que obtener el índice del byte.

Esta función devuelve FALSE si parser no referencia un analizador válido, o si no devuelve en qué índice de byte se encuentra el buffer de datos del analizador (empezando en 0).

Anterior | Inicio | Siguiente
xml_error_string | Subir | xml_get_current_column_number


xml_parser_free

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_parser_free -- Libera un analizador XML

Descripción

string xml_parser_free ( int parser)

parser

Una referencia al analizador XML que se liberará.

Esta función devuelve FALSE si parser no referencia un analizador válido, o si no libera el analizador y devuelve TRUE.

Anterior | Inicio | Siguiente
xml_parser_create | Subir | xml_parser_get_option


xml_parser_set_option

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_parser_set_option -- establece las opciones de un analizador XML

Descripción

int xml_parser_set_option ( int parser, int option, mixed value)

parser

Una referencia al analizador XML en el que establecer opciones.

option

Opción que se establecerá. Ver más abajo.

value

El nuevo valor de la opción.

Esta función devuelve FALSE si parser no referencia un analizador válido, o si la opción no pudo ser establecida. Si no, la opción se establece y devuelve TRUE.

Las opciones siguientes están disponibles:

Tabla 1. Opciones de analizador XML

Opción constante | Tipo de Datos | Descripción
XML_OPTION_CASE_FOLDING | integer | Controla si case-folding se habilita para este analizador XML. Habilitado por defecto.
XML_OPTION_TARGET_ENCODING | string | Establece qué codificación destino se usa en este analizador XML. Por defecto, esta puesta al mismo que la codificación fuente usada por xml_parser_create(). Las codificaciones de destino soportadas son ISO-8859-1, US-ASCII y UTF-8.

Anterior | Inicio | Siguiente
xml_parser_get_option | Subir | xml_set_character_data_handler


xml_parser_get_option

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

xml_parser_get_option -- obtiene las opciones de un analizador XML

Descripción

mixed xml_parser_get_option ( int parser, int option)

parser

Una referencia al analizador XML del que obtener opciones.

option

Qué opción recuperar. Ver xml_parser_set_option() para una lista de opciones.

Esta función devuelve FALSE si parser no referencia un analizador válido, o si la opción no pudo ser establecida. Si no, se devuelve la opción.

Mirar xml_parser_set_option() para la lista de opciones.

Anterior | Inicio | Siguiente
xml_parser_free | Subir | xml_parser_set_option


utf8_decode

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

utf8_decode -- Convierte una cadena codificada UTF-8 a ISO-8859-1

Descripción

string utf8_decode ( string data)

Esta función decodificadata, asume codificación UTF-8 , a ISO-8859-1.

Mira utf8_encode() para una explicación de codificación UTF-8.

Anterior | Inicio | Siguiente
Funciones de intérprete XML | Subir | utf8_encode


utf8_encode

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

utf8_encode -- codifica una cadena ISO-8859-1 a UTF-8

Descripción

string utf8_encode ( string data)

Esta función codifica la cadena data a UTF-8, y devuelve la versión codificada. UTF-8 es un mecanismo estándar usado por Unicodepara codificar valores de caracteres amplios en un chorro de bytes. UTF-8 es transparente a caracteres de ASCII plano, es auto-sincronizado (significa que es posible para un programa averiguar dónde comienzan los caracteres en el chorro de bytes) y se puede usar con funciones de comparación de cadenas normales para ordenar y otros fines. PHP codifica caracteres UTF-8 en hasta cuatro bytes, como esto:

Tabla 1. Codificación UTF-8

bytes | bits | representación
1 | 7 | 0bbbbbbb
2 | 11 | 110bbbbb 10bbbbbb
3 | 16 | 1110bbbb 10bbbbbb 10bbbbbb
4 | 21 | 11110bbb 10bbbbbb 10bbbbbb 10bbbbbb
Cada b representa un bit que puede ser usado para almacenar datos de caracteres.

Anterior | Inicio | Siguiente
utf8_decode | Subir | xml_error_string


XMLRPC functions

Manual de PHP
Anterior Siguiente

CIII. XMLRPC functions

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

Tabla de contenidos
xmlrpc_encode_request — Generates XML for a method request
xmlrpc_encode — Generates XML for a PHP value
xmlrpc_decode_request — Decodes XML into native PHP types
xmlrpc_decode — Decodes XML into native PHP types
xmlrpc_server_create — Creates an xmlrpc server
xmlrpc_server_destroy — Destroys server resources
xmlrpc_server_register_method — Register a PHP function to resource method matching method_name
xmlrpc_server_register_introspection_callback — Register a PHP function to generate documentation
xmlrpc_server_call_method — Parses XML requests and call methods
xmlrpc_server_add_introspection_data — Adds introspection documentation
xmlrpc_parse_method_descriptions — Decodes XML into a list of method descriptions
xmlrpc_set_type — Sets xmlrpc type, base64 or datetime, for a PHP string value
xmlrpc_get_type — Gets xmlrpc type for a PHP value. Especially useful for base64 and datetime strings

Anterior | Inicio | Siguiente
xml_set_unparsed_entity_decl_handler | Subir | xmlrpc_encode_request


xmlrpc_encode_request

(PHP 4 >= 4.1.0)

xmlrpc_encode_request -- Generates XML for a method request

Description

string xmlrpc_encode_request ( string method, mixed params)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
XMLRPC functions | Subir | xmlrpc_encode


xmlrpc_encode

(PHP 4 >= 4.1.0)

xmlrpc_encode -- Generates XML for a PHP value

Description

string xmlrpc_encode ( mixed value)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_encode_request | Subir | xmlrpc_decode_request


xmlrpc_decode_request

(PHP 4 >= 4.1.0)

xmlrpc_decode_request -- Decodes XML into native PHP types

Description

array xmlrpc_decode_request ( string xml, string method [, string encoding])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_encode | Subir | xmlrpc_decode


xmlrpc_decode

(PHP 4 >= 4.1.0)

xmlrpc_decode -- Decodes XML into native PHP types

Description

array xmlrpc_decode ( string xml [, string encoding])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_decode_request | Subir | xmlrpc_server_create


xmlrpc_server_create

(PHP 4 >= 4.1.0)

xmlrpc_server_create -- Creates an xmlrpc server

Description

resource xmlrpc_server_create ( void)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_decode | Subir | xmlrpc_server_destroy


xmlrpc_server_destroy

(PHP 4 >= 4.1.0)

xmlrpc_server_destroy -- Destroys server resources

Description

void xmlrpc_server_destroy ( resource server)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_server_create | Subir | xmlrpc_server_register_method


xmlrpc_server_register_method

(PHP 4 >= 4.1.0)

xmlrpc_server_register_method -- Register a PHP function to resource method matching method_name

Description

bool xmlrpc_server_register_method ( resource server, string method_name, string function)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_server_destroy | Subir | xmlrpc_server_register_introspection_callback


xmlrpc_server_register_introspection_callback

(PHP 4 >= 4.1.0)

xmlrpc_server_register_introspection_callback -- Register a PHP function to generate documentation

Description

bool xmlrpc_server_register_introspection_callback ( resource server, string function)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_server_register_method | Subir | xmlrpc_server_call_method


xmlrpc_server_call_method

(PHP 4 >= 4.1.0)

xmlrpc_server_call_method -- Parses XML requests and call methods

Description

mixed xmlrpc_server_call_method ( resource server, string xml, mixed user_data [, array output_options])

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_server_register_introspection_callback | Subir | xmlrpc_server_add_introspection_data


xmlrpc_server_add_introspection_data

(PHP 4 >= 4.1.0)

xmlrpc_server_add_introspection_data -- Adds introspection documentation

Description

int xmlrpc_server_add_introspection_data ( resource server, array desc)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_server_call_method | Subir | xmlrpc_parse_method_descriptions


xmlrpc_parse_method_descriptions

(PHP 4 >= 4.1.0)

xmlrpc_parse_method_descriptions -- Decodes XML into a list of method descriptions

Description

array xmlrpc_parse_method_descriptions ( string xml)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_server_add_introspection_data | Subir | xmlrpc_set_type


xmlrpc_set_type

(PHP 4 >= 4.1.0)

xmlrpc_set_type -- Sets xmlrpc type, base64 or datetime, for a PHP string value

Description

bool xmlrpc_set_type ( string value, string type)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_parse_method_descriptions | Subir | xmlrpc_get_type


xmlrpc_get_type

(PHP 4 >= 4.1.0)

xmlrpc_get_type -- Gets xmlrpc type for a PHP value. Especially useful for base64 and datetime strings

Description

string xmlrpc_get_type ( mixed value)

Aviso

This function is EXPERIMENTAL. That means, that the behaviour of this function, this function name, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this function at your own risk.

Aviso

This function is currently not documented, only the argument list is available.

Anterior | Inicio | Siguiente
xmlrpc_set_type | Subir | XSLT functions


XSLT functions

Manual de PHP
Anterior Siguiente

CIV. XSLT functions

Aviso

This module is EXPERIMENTAL. That means, that the behaviour of these functions, these function names, in concreto ANYTHING documented here can change in a future release of PHP WITHOUT NOTICE. Be warned, and use this module at your own risk.

Introduction

About XSLT and Sablotron

XSLT (Extensible Stylesheet Language (XSL) Transformations) is a language for transforming XML documents into other XML documents. It is a standard defined by The World Wide Web consortium (W3C). Information about XSLT and related technologies can be found at http://www.w3.org/TR/xslt.

Installation

This extension uses Sabloton and expat, which can both be found at http://www.gingerall.com/. Binaries are provided as well as source.

On UNIX, run configure with the --with-sablot and --enable-sablot-errors-descriptive options. The Sablotron library should be installed somewhere your compiler can find it.

About This Extension

This PHP extension implements support Sablotron from Ginger Alliance in PHP. This toolkit lets you transform XML documents into other documents, including new XML documents, but also into HTML or other target formats. It basically provides a standardized and portable template mechanism, separating content and design of a website.

Tabla de contenidos
xslt_closelog — Clear the logfile for a given instance of Sablotron
xslt_create — Create a new XSL processor.
xslt_errno — Return the current error number
xslt_error — Return the current error string
xslt_fetch_result — Fetch a (named) result buffer
xslt_free — Free XSLT processor
xslt_openlog — Set a logfile for XSLT processor messages
xslt_output_begintransform — unknown
xslt_output_endtransform — unknown
xslt_output_process — unknown
xslt_run — Apply a XSLT stylesheet to a file.
xslt_set_sax_handler — Set SAX handlers for a XSLT processor
xslt_transform — unknown

Anterior | Inicio | Siguiente
xmlrpc_get_type | Subir | xslt_closelog


xslt_closelog

(4.0.3 - 4.0.6 only)

xslt_closelog -- Clear the logfile for a given instance of Sablotron

Description

bool xslt_closelog ( resource xh)

xh

A reference to the XSLT parser.

This function returns FALSE if parser does not refer to a valid parser, or if the closing of the logfile fails. Otherwise it returns TRUE.

Anterior | Inicio | Siguiente
XSLT functions | Subir | xslt_create


xslt_create

(PHP 4 >= 4.0.3)

xslt_create -- Create a new XSL processor.

Description

resource xslt_create ( void)

This function returns a handle for a new XSL processor. This handle is needed in all subsequent calls to XSL functions.

Anterior | Inicio | Siguiente
xslt_closelog | Subir | xslt_errno


xslt_errno

(PHP 4 >= 4.0.3)

xslt_errno -- Return the current error number

Description

int xslt_errno ( [ int xh])

Return the current error number of the given XSL processor. If no handle is given, the last error number that occured anywhere is returned.

Anterior | Inicio | Siguiente
xslt_create | Subir | xslt_error


xslt_error

(PHP 4 >= 4.0.3)

xslt_error -- Return the current error string

Description

mixed xslt_error ( [ int xh])

Return the current error string of the given XSL processor. If no handle is given, the last error string that occured anywhere is returned.

Anterior | Inicio | Siguiente
xslt_errno | Subir | xslt_fetch_result


xslt_fetch_result

(4.0.3 - 4.0.6 only)

xslt_fetch_result -- Fetch a (named) result buffer

Description

string xslt_fetch_result ( int xh [, string result_name])

Fetch a result buffer from the XSLT processor identified by the given handle. If no result name is given, the buffer named "/_result" is fetched.

Anterior | Inicio | Siguiente
xslt_error | Subir | xslt_free


xslt_free

(PHP 4 >= 4.0.3)

xslt_free -- Free XSLT processor

Description

void xslt_free ( resource xh)

Free the XSLT processor identified by the given handle.

Anterior | Inicio | Siguiente
xslt_fetch_result | Subir | xslt_openlog


xslt_openlog

(4.0.3 - 4.0.6 only)

xslt_openlog -- Set a logfile for XSLT processor messages

Description

bool xslt_openlog ( resource xh, string logfile [, int loglevel])

Set a logfile for the XSLT processor to place all of its error messages.

Anterior | Inicio | Siguiente
xslt_free | Subir | xslt_output_begintransform


xslt_output_begintransform

(4.0.3 - 4.0.6 only)

xslt_output_begintransform -- unknown

Description

unknown xslt_output_begintransform ( unknown)

This function lacks a prototype definition.

Anterior | Inicio | Siguiente
xslt_openlog | Subir | xslt_output_endtransform


xslt_output_endtransform

(4.0.3 - 4.0.6 only)

xslt_output_endtransform -- unknown

Description

unknown xslt_output_endtransform ( unknown)

This function lacks a prototype definition.

Anterior | Inicio | Siguiente
xslt_output_begintransform | Subir | xslt_output_process


xslt_output_process

(unknown)

xslt_output_process -- unknown

Description

unknown xslt_process ( unknown)

This function lacks a prototype definition.

Anterior | Inicio | Siguiente
xslt_output_endtransform | Subir | xslt_run


xslt_run

(4.0.3 - 4.0.6 only)

xslt_run -- Apply a XSLT stylesheet to a file.

Description

bool xslt_run ( resource xh, string xslt_file, string xml_data_file [, string result [, array xslt_params [, array xslt_args]]])

Process the xml_data_file by applying the xslt_file stylesheet to it. The stylesheet has access to xslt_params and the processor is started with xslt_args. The result of the XSLT transformation is placed in the named buffer (default is "/_result").

Anterior | Inicio | Siguiente
xslt_output_process | Subir | xslt_set_sax_handler


xslt_set_sax_handler

(4.0.3 - 4.0.6 only)

xslt_set_sax_handler -- Set SAX handlers for a XSLT processor

Description

bool xslt_set_sax_handler ( resource xh, handlers)

Set SAX handlers on the ressource handle given by xh.

Anterior | Inicio | Siguiente
xslt_run | Subir | xslt_transform


xslt_transform

(4.0.3 - 4.0.6 only)

xslt_transform -- unknown

Description

unknown xslt_transform ( unknown)

This function lacks a prototype definition.

Anterior | Inicio | Siguiente
xslt_set_sax_handler | Subir | YAZ


YAZ

Manual de PHP
Anterior Siguiente

CV. YAZ

The yaz() functions wrap the YAZ API. The home page of the project is http://www.indexdata.dk/yaz/. Information about the phpyaz module can be found at http://www.indexdata.dk/phpyaz/.

PHP/YAZ is much simpler to use than the C API for YAZ but less flexible. The intent is to make it easy to build basic client functions. It supports persistent stateless connections very similar to those offered by the various SQL APIs that are available for PHP. This means that sessions are stateless but shared amongst users, thus saving the connect and INIT steps in many cases.

Before compiling PHP with the PHP/YAZ module you'll need the YAZ toolkit. Build YAZ and install it. Build PHP with your favourite modules and add option --with-yaz. Your task is roughly the following:

gunzip -c yaz-1.6.tar.gz|tar xf -
gunzip -c php-4.0.X.tar.gz|tar xf -
cd yaz-1.6
./configure --prefix=/usr
make
make install
cd ../php-4.0.X
./configure --with-yaz=/usr/bin
make
make install

PHP/YAZ keeps track of connections with targets (Z-Associations). A positive integer represents the ID of a particular association.

The script below demonstrates the parallel searching feature of the API. When invoked it either prints a query form (if no arguments are supplied) or if there are arguments (term and one or more hosts) it searches the targets in array host.

Ejemplo 1. YAZ()

$num_hosts = count ($host);
if (empty($term) || count($host) == 0) {
    echo '<form method="get">
    <input type="checkbox"
    name="host[]" value="bagel.indexdata.dk/gils">
        GILS test
    <input type="checkbox"
    name="host[]" value="localhost:9999/Default">
        local test
    <input type="checkbox" checked="1"
    name="host[]" value="z3950.bell-labs.com/books">
        BELL Labs Library
    <br>
    RPN Query:
    <input type="text" size="30" name="term">
    <input type="submit" name="action" value="Search">
    ';
} else {
    echo 'You searced for ' . htmlspecialchars($term) . '<br>';
    for ($i = 0; $i > $num_hosts; $i++) {
        $id[] = yaz_connect($host[$i]);
        yaz_syntax($id[$i],"sutrs");
        yaz_search($id[$i],"rpn",$term);
    }
    yaz_wait();
    for ($i = 0; $i < $num_hosts; $i++) {
        echo '<hr>' . $host[$i] . ":";
        $error = yaz_error($id[$i]);
        if (!empty($error)) {
            echo "Error: $error";
        } else {
            $hits = yaz_hits($id[$i]);
            echo "Result Count $hits";
        }
        echo '<dl>';
        for ($p = 1; $p <= 10; $p++) {
            $rec = yaz_record($id[$i],$p,"string");
            if (empty($rec)) continue;
            echo "<dt><b>$p</b></dt><dd>";
            echo ereg_replace("\n", "<br>\n",$rec);
            echo "</dd>";
        }
        echo '</dl>';
    }
}
Tabla de contenidos
yaz_addinfo — Returns additional error information
yaz_close — Closes a YAZ connection
yaz_connect — Returns a positive association ID on success; zero on failure
yaz_errno — Returns error number
yaz_error — Returns error description
yaz_hits — Returns number of hits for last search
yaz_range — Specifies the maximum number of records to retrieve
yaz_record — Returns a record
yaz_search — Prepares for a search
yaz_syntax — Specifies the preferred record syntax for retrieval
yaz_wait — Executes queries

Anterior | Inicio | Siguiente
xslt_transform | Subir | yaz_addinfo


yaz_addinfo

(PHP 4 )

yaz_addinfo -- Returns additional error information

Description

int yaz_addinfo ( int id)

Returns additional error message for target (last request). An empty string is returned if last operation was a success or if no additional information was provided by the target.

Anterior | Inicio | Siguiente
YAZ | Subir | yaz_close


yaz_close

(PHP 4 )

yaz_close -- Closes a YAZ connection

Description

int yaz_close ( int id)

Closes a connection to a target. The application can no longer refer to the target with the given id.

Anterior | Inicio | Siguiente
yaz_addinfo | Subir | yaz_connect


yaz_connect

(PHP 4 )

yaz_connect -- Returns a positive association ID on success; zero on failure

Description

int yaz_connect ( string zurl)

yaz_connect() prepares for a connection to a Z39.50 target. The zurl argument takes the form host[:port][/database]. If port is omitted 210 is used. If database is omitted Default is used. This function is non-blocking and doesn't attempt to establish a socket - it merely prepares a connect to be performed later when yaz_wait() is called.

Anterior | Inicio | Siguiente
yaz_close | Subir | yaz_errno


yaz_errno

(PHP 4 )

yaz_errno -- Returns error number

Description

int yaz_errno ( int id)

Returns error for target (last request). A positive value is returned if the target returned a diagnostic code; a value of zero is returned if no errors occurred (success); negative value is returned for other errors targets didn't indicate the error in question.

yaz_errno() should be called after network activity for each target - (after yaz_wait() returns) to determine the success or failure of the last operation (e.g. search).

Anterior | Inicio | Siguiente
yaz_connect | Subir | yaz_error


yaz_error

(PHP 4 )

yaz_error -- Returns error description

Description

int yaz_error ( int id)

Returns error message for target (last request). An empty string is returned if last operation was a success.

yaz_error() returns a english message corresponding to the last error number as returned by yaz_errno().

Anterior | Inicio | Siguiente
yaz_errno | Subir | yaz_hits


yaz_hits

(PHP 4 )

yaz_hits -- Returns number of hits for last search

Description

int yaz_hits ( int id)

yaz_hits() returns number of hits for last search.

Anterior | Inicio | Siguiente
yaz_error | Subir | yaz_range


yaz_range

(PHP 4 )

yaz_range -- Specifies the maximum number of records to retrieve

Description

int yaz_range ( int id, int start, int number)

This function is used in conjunction with yaz_search() to specify the maximum number of records to retrieve (number) and the first record position (start). If this function is not invoked (only yaz_search()) start is set to 1 and number is set to 10.

Returns TRUE on success; FALSE on error.

Anterior | Inicio | Siguiente
yaz_hits | Subir | yaz_record


yaz_record

(PHP 4 )

yaz_record -- Returns a record

Description

int yaz_record ( int id, int pos, string type)

Returns record at position or empty string if no record exists at given position.

The yaz_record() function inspects a record in the current result set at the position specified. If no database record exists at the given position an empty string is returned. The argument, type, specifies the form of the returned record. If type is "string" the record is returned in a string representation suitable for printing (for XML and SUTRS). If type is "array" the record is returned as an array representation (for structured records).

Anterior | Inicio | Siguiente
yaz_range | Subir | yaz_search


yaz_search

(PHP 4 )

yaz_search -- Prepares for a search

Description

int yaz_search ( int id, string type, string query)

yaz_search() prepares for a search on the target with given id. The type represents the query type - only "rpn" is supported now in which case the third argument is a prefix notation query as used by YAZ. Like yaz_connect() this function is non-blocking and only prepares for a search to be executed later when yaz_wait() is called.

Anterior | Inicio | Siguiente
yaz_record | Subir | yaz_syntax


yaz_syntax

(PHP 4 )

yaz_syntax -- Specifies the preferred record syntax for retrieval

Description

int yaz_syntax ( int id, string syntax)

This function is used in conjunction with yaz_search() to specify the preferred record syntax for retrieval.

Anterior | Inicio | Siguiente
yaz_search | Subir | yaz_wait


yaz_wait

(PHP 4 )

yaz_wait -- Executes queries

Description

int yaz_wait ( int id, string syntax)

This function carries out networked (blocked) activity for outstanding requests which have been prepared by the functions yaz_connect(), yaz_search(). yaz_wait() returns when all targets have either completed all requests or otherwise completed (in case of errors).

Anterior | Inicio | Siguiente
yaz_syntax | Subir | NIS funciona


NIS funciona

Manual de PHP
Anterior Siguiente

CVI. NIS funciona

NIS ( anteriormente llamado Paginas Amarillas ) permite la administracion de red de los archivos de administracion importantes (e.g.El archivo de contraseñas). Para mas informacion dirigirse a las paginas de ayuda de NIS y a la direccion. Introduccion a YP/NIS Hay tambien un libro llamado gestionando NFS Y NIS por Hal Stern.

Para obtener estas funciones de trabajo, usted tiene que configure PHP con -- con- yp.

Tabla de contenidos
yp_master — Retorna el nombre del servidor de NIS maestro para el mapa.
yp_order — Retorna el numero de orden para el mapa.
yp_err_string — devuelve el mensaje de error asociado con la operacion previa.Util que indica el problema exacto.
yp_errno — Retorna el codigo de error de la operacion previa.
yp_first — devuelve la primera clave emparejada con el nombrado mapa.
yp_get_default_domain — Trae el valor por omision de dominios de maquina NIS.
yp_match — Retorna la linea compañera (pareja).
yp_next — Devuelve la siguiente clave tecleada en el nombre de mapa

Anterior | Inicio | Siguiente
yaz_wait | Subir | yp_master


yp_get_default_domain

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

yp_get_default_domain -- Trae el valor por omision de dominios de maquina NIS.

Descripcion

int yp get_default_domain ( void)

yp_ get_default_domain() Retorna el valor por omision del dominio del nodo o FALSO. Puede ser usado el parametro de dominio para sucesivas llamadas a NIS.

Un dominio de NIS puede ser descrito en un grupo de mapas NIS. Cada host necesita buscar uniones de informacion en un mismo dominio. Acudir a los documentos mencionados en el comienzo para mas informacion.

Ejemplo 1. Ejemplo para el dominio por omision

                 Ver tambien:
         yp_ errno (nombre de la funcion)
           y
         yp_err_string (nombre de la funcion)

Anterior | Inicio | Siguiente
yp_first | Subir | yp_match


yp_order

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

yp_order -- Retorna el numero de orden para el mapa.

Descripcion

int yp_ order (nombre de la funcion) ( cadena dominio, cadena mapa)

yp_ order(nombre de la funcion)() Retorna el numero de orden para un mapa o FALSO.

Ejemplo 1. Ejemplo para ordenar el NIS

Ver tambien:
     yp get_default_domain
     yp_errno
     yp_err_string

Anterior | Inicio | Siguiente
yp_master | Subir | yp_err_string


yp_master

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

yp_master -- Retorna el nombre del servidor de NIS maestro para el mapa.

Descripcion

cadena yp_master ( cadena dominio, cadena mapa)

yp_master() Retorna el nombre de maquina del servidor de NIS maestro para un mapa.

Ejemplo 1. Ejemplo para el NIS domina

     Ver tambien:
              yp_get_default_domain(nombre de la funcion)
              yp_errno(nombre de la funcion)
                y
              yp_err_string(nombre de la funcion)

Anterior | Inicio | Siguiente
NIS funciona | Subir | yp_order


yp_match

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

yp_match -- Retorna la linea compañera (pareja).

Descripcion

cadena yp match ( cadena dominio, cadena mapa, cadena teclea)

yp_match(nombre de la funcion)() Retorna el valor asociado con la llave pasada fuera del mapa especificado o FALSO. esta llave tiene que ser exacta.

Ejemplo 1. Ejemplo para NIS parejo

       En este caso esto puede ser:
                 Joe:##joe:11111:100:joe
                 usuario:/hogar/j/joe:
                 User:/usr/local/bin/bash

             Ver tambien:
    yp_get_default_domain
    yp_errno
     y
    yp_err_string

Anterior | Inicio | Siguiente
yp_get_default_domain | Subir | yp_next


yp_first

(unknown)

yp_first -- devuelve la primera clave emparejada con el nombrado mapa.

Descripcion

string[] yp_first (cadena dominio, cadena mapa)

yp_first(nombre de la funcion)() Retorna la primera clave de valor pareada del mapa nombrado en el dominio, de otra manera FALSO.

Ejemplo 1. Ejemplo para el primer NIS

 Ver tambien:
  yp_get_default_domain
  yp_errno
  y
  yp_err_string

Anterior | Inicio | Siguiente
yp_errno | Subir | yp_get_default_domain


yp_next

(PHP 3>= 3.0.7, PHP 4 >= 4.0.0)

yp_next -- Devuelve la siguiente clave tecleada en el nombre de mapa

Descripcion

string[] yp_next ( cadena dominio, cadena mapa, cadena teclea)

yp_next() devuelve el siguiente par de valor tecleado en el mapa de nombres despues de la clave especificada o FALSO.

Ejemplo 1. Ejemplo para NIS siguiente

        Ver tambien:
yp_get_default_domain
yp_errno
y
yp_err_string

Anterior | Inicio | Siguiente
yp_match | Subir | Zip File Functions (Read Only Access)


yp_errno

(PHP 4 >= 4.0.6)

yp_errno -- Retorna el codigo de error de la operacion previa.

Descripcion

int yp_errno ( void)

yp_errno() retorna el codigo de error de la operacion previa.

Los errores posibles son:

1 args para funcionar son malos
2 fallo de RPC- dominio ha sido unbound
3 no puede unir a servidor en este dominio
4 ningun tal mapa en dominio de servidor
5 ninguna tal llave en
6 interno yp error de cliente o servidor
7 fallo de asignacion de recurso
8 ningunos más registros en base de datos de mapa
9 no puede comunicar wiTh portmapper
10 no puede comunicar con ypbind
11 no puede comunicar con ypserv
12 nombre de dominio local no conjunto
13 yp base de datos es malo
14 yp La version mismatch
15 violacion de acceso
16 base de datos ocupar

Ver tambien: yp_err_string

Anterior | Inicio | Siguiente
yp_err_string | Subir | yp_first


yp_err_string

(PHP 4 >= 4.0.6)

yp_err_string -- devuelve el mensaje de error asociado con la operacion previa.Util que indica el problema exacto.

Descripcion

cadena yp_err_string ( void)

yp_err_string() Retorna el mensaje de error asociado con la operacion previa.Util para indicar que salio mal exactamente.

Ejemplo 1. Ejemplo para errores de NIS

              Vea tambien:
               yp errno

Anterior | Inicio | Siguiente
yp_order | Subir | yp_errno


Zip File Functions (Read Only Access)

Manual de PHP
Anterior Siguiente

CVII. Zip File Functions (Read Only Access)

This module uses the functions of the ZZIPlib library by Guido Draheim to transparently read ZIP compressed archives and the files inside them.

Please note that ZZIPlib only provides a subset of functions provided in a full implementation of the ZIP compression algorithm and can only read ZIP file archives. A normal ZIP utility is needed to create the ZIP file archives read by this library.

Zip support in PHP is not enabled by default. You will need to use the --with-zip configuration option when compiling PHP to enable zip support. This module requires ZZIPlib version >= 0.10.6.

Nota: Zip support before PHP 4.1.0 is experimental. This section reflects the Zip extension as it exists in PHP 4.1.0 and later.

Example Usage

This example opens a ZIP file archive, reads each file in the archive and prints out its contents. The test2.zip archive used in this example is one of the test archives in the ZZIPlib source distribution.

Ejemplo 1. Zip Usage Example

<?php

$zip = zip_open("/tmp/test2.zip");

if ($zip) {

    while ($zip_entry = zip_read($zip)) {
        echo "Name:               " . zip_entry_name($zip_entry) . "\n";
        echo "Actual Filesize:    " . zip_entry_filesize($zip_entry) . "\n";
        echo "Compressed Size:    " . zip_entry_compressedsize($zip_entry) . "\n";
        echo "Compression Method: " . zip_entry_compressionmethod($zip_entry) . "\n";

        if (zip_entry_open($zip, $zip_entry, "r")) {
            echo "File Contents:\n";
            $buf = zip_entry_read($zip_entry, zip_entry_filesize($zip_entry));
            echo "$buf\n";

            zip_entry_close($zip_entry);
        }
        echo "\n";

    }

    zip_close($zip);

}

?>
Tabla de contenidos
zip_close — Close a Zip File Archive
zip_entry_close — Close a Directory Entry
zip_entry_compressedsize — Retrieve the Compressed Size of a Directory Entry
zip_entry_compressionmethod — Retrieve the Compression Method of a Directory Entry
zip_entry_filesize — Retrieve the Actual File Size of a Directory Entry
zip_entry_name — Retrieve the Name of a Directory Entry
zip_entry_open — Open a Directory Entry for Reading
zip_entry_read — Read From an Open Directory Entry
zip_open — Open a Zip File Archive
zip_read — Read Next Entry in a Zip File Archive

Anterior | Inicio | Siguiente
yp_next | Subir | zip_close


zip_close

(PHP 4 >= 4.1.0)

zip_close -- Close a Zip File Archive

Description

void zip_close ( resource zip)

Closes a zip file archive. The parameter zip must be a zip archive previously opened by zip_open().

This function has no return value.

See also zip_open() and zip_read().

Anterior | Inicio | Siguiente
Zip File Functions (Read Only Access) | Subir | zip_entry_close


zip_entry_close

(PHP 4 >= 4.1.0)

zip_entry_close -- Close a Directory Entry

Description

void zip_entry_close ( resource zip_entry)

Closes a directory entry specified by zip_entry. The parameter zip_entry must be a valid directory entry opened by zip_entry_open().

This function has no return value.

See also zip_entry_open() and zip_entry_read().

Anterior | Inicio | Siguiente
zip_close | Subir | zip_entry_compressedsize


zip_entry_compressedsize

(PHP 4 >= 4.1.0)

zip_entry_compressedsize -- Retrieve the Compressed Size of a Directory Entry

Description

int zip_entry_compressedsize ( resource zip_entry)

Returns the compressed size of the directory entry specified by zip_entry. The parameter zip_entry is a valid directory entry returned by zip_read().

See also zip_open() and zip_read().

Anterior | Inicio | Siguiente
zip_entry_close | Subir | zip_entry_compressionmethod


zip_entry_compressionmethod

(PHP 4 >= 4.1.0)

zip_entry_compressionmethod -- Retrieve the Compression Method of a Directory Entry

Description

string zip_entry_compressionmethod ( resource zip_entry)

Returns the compression method of the directory entry specified by zip_entry. The parameter zip_entry is a valid directory entry returned by zip_read().

See also zip_open() and zip_read().

Anterior | Inicio | Siguiente
zip_entry_compressedsize | Subir | zip_entry_filesize


zip_entry_filesize

(PHP 4 >= 4.1.0)

zip_entry_filesize -- Retrieve the Actual File Size of a Directory Entry

Description

int zip_entry_filesize ( resource zip_entry)

Returns the actual size of the directory entry specified by zip_entry. The parameter zip_entry is a valid directory entry returned by zip_read().

See also zip_open() and zip_read().

Anterior | Inicio | Siguiente
zip_entry_compressionmethod | Subir | zip_entry_name


zip_entry_name

(PHP 4 >= 4.1.0)

zip_entry_name -- Retrieve the Name of a Directory Entry

Description

string zip_entry_name ( resource zip_entry)

Returns the name of the directory entry specified by zip_entry. The parameter zip_entry is a valid directory entry returned by zip_read().

See also zip_open() and zip_read().

Anterior | Inicio | Siguiente
zip_entry_filesize | Subir | zip_entry_open


zip_entry_open

(PHP 4 >= 4.1.0)

zip_entry_open -- Open a Directory Entry for Reading

Description

bool zip_entry_open ( resource zip, resource zip_entry [, string mode])

Opens a directory entry in a zip file for reading. The parameter zip is a valid resource handle returned by zip_open(). The parameter zip_entry is a directory entry resource returned by zip_read(). The optional parameter mode can be any of the modes specified in the documentaion for fopen().

Nota: Currently, mode is ignored and is always "rb". This is due to the fact that zip support in PHP is read only access. Please see fopen() for an explanation of various modes, including "rb".

Returns TRUE on succes, FALSE on failure.

Nota: Unlike fopen() and other similar functions, the return value of zip_entry_open() only indicates the result of the operation and is not needed for reading or closing the directory entry.

See also zip_entry_read() and zip_entry_close().

Anterior | Inicio | Siguiente
zip_entry_name | Subir | zip_entry_read


zip_entry_read

(PHP 4 >= 4.1.0)

zip_entry_read -- Read From an Open Directory Entry

Description

string zip_entry_read ( resource zip_entry [, int length])

Reads up to length bytes from an open directory entry. If length is not specified, then zip_entry_read() will attempt to read 1024 bytes. The parameter zip_entry is a valid directory entry returned by zip_read().

Nota: The length parameter should be the uncompressed length you wish to read.

Returns the data read, or FALSE if the end of the file is reached.

See also zip_entry_open(),
zip_entry_close() and
zip_entry_filesize().

Anterior | Inicio | Siguiente
zip_entry_open | Subir | zip_open


zip_open

(PHP 4 >= 4.1.0)

zip_open -- Open a Zip File Archive

Description

resource zip_open ( string filename)

Opens a new zip archive for reading. The filename parameter is the filename of the zip archive to open.

Returns a resource handle for later use with zip_read() and zip_close() or returns FALSE if filename does not exist.

See also zip_read() and zip_close().

Anterior | Inicio | Siguiente
zip_entry_read | Subir | zip_read


zip_read

(PHP 4 >= 4.1.0)

zip_read -- Read Next Entry in a Zip File Archive

Description

resource zip_read ( resource zip)

Reads the next entry in a zip file archive. The parameter zip must be a zip archive previously opened by zip_open().

Returns a directory entry resource for later use with the zip_entry_...() functions.

See also zip_open(),
zip_close(),
zip_entry_open(), and
zip_entry_read().

Anterior | Inicio | Siguiente
zip_open | Subir | Funciones de Compresión


Funciones de Compresión

Manual de PHP
Anterior Siguiente

CVIII. Funciones de Compresión

Este módulo usa la función de zlib de Jean-loup Gailly y Mark Adler para leer y grabar archivos comprimidos .gz, de un modo transparente. Con este módulo, es requisito usar una versión de zlib igual o posterior a 1.0.9.

Este módulo contiene versiones de la mayoría de las funciones de Sistema de archivos que funcionan con los archivos comprimidos con gzip (y con los no-comprimidos tambien, pero no con conectores (sockets)).

Pequeño código de ejemlo

Abre un archivo temporal y escribe en él, una cadena de prueba, y luego presenta el cotenido del archivo dos veces

Ejemplo 1. Ejemplo de Zlib

<?php
  $filename = tempnam('/tmp', 'zlibtest').'.gz';
  print "<html>\n<head></head>\n<body>\n<pre>\n";
  $s = "Sólo es una prueba, prueba, prueba,prueba, prueba, prueba!\n";
  // Abre el archivo para escribirlo con máximo de compresión
  $zp = gzopen($filename, "w9");
  // Escribe la cadena en él
  gzwrite($zp, $s);
  // Cierra el fichero
  gzclose($zp);
  // Abre el fichero para lectura
  $zp = gzopen($filename, "r");
  // Lee 3 caracteres
  print gzread($zp, 3);
  // Salida hasta el final del fichero, para cerrarlo luego.
  gzpassthru($zp);
  print "\n";
  // Abre el fichero y muestra su contenido (por segunda vez).
  if (readgzfile($filename) != strlen($s)) {
          echo "Error con las funciones zlib!";
  }
  unlink($filename);
  print "<pre>\n</h1></body>\n</html>\n";
?>
Tabla de contenidos
gzclose — cierra un puntero a archivo-gz abierto
gzeof — prueba el fin-de-archivo de un puntero de archivo-gz
gzfile — lee el archivo gz completo en un arreglo
gzgetc — toma caracteres de un archivo-gz
gzgets — toma una linea del archivo apuntado
gzgetss — toma una linea del archivo-gz apuntado y le quita los tags HTML
gzopen — open gz-file
gzpassthru — Devuelve el remanente de datos de un fichero-gz
gzputs — escribe al fichero-gz que se apunta
gzread — Lee archivos-gz en modo Binario
gzrewind — Reposiciona al puntero de archivo-gz, al inicio de aquel
gzseek — Posiciona el puntero del archivo-gz
gztell — Indica la posición de lecto-escritura en el archivo
gzwrite — Escritura de ficheros gz en modo Binario
readgzfile — devuelve el fichero-gz

Anterior | Inicio | Siguiente
zip_read | Subir | gzclose


gzclose

(PHP 3, PHP 4 >= 4.0.0)

gzclose -- cierra un puntero a archivo-gz abierto

Descripción

int gzclose ( int zp)

El archivo-gz al que apunta zp se cierra.

Devuelve TRUE (verdadero) si fue exitoso, si hubo errores devuelve FALSE.

El puntero al archivo-gz debe ser válido y debe apuntar a un archivo correctamente abierto con gzopen().

Anterior | Inicio | Siguiente
Funciones de Compresión | Subir | gzeof


gzeof

(PHP 3, PHP 4 >= 4.0.0)

gzeof -- prueba el fin-de-archivo de un puntero de archivo-gz

Descripción

int gzeof ( int zp)

Devuelve verdadero si el puntero-a-archivo está en el fin-de-archivo, o ha ocurrido un error. De otro modo devuelve falso.

El puntero al archivo-gz debe ser válido y debe apuntar a un archivo correctamente abierto con gzopen().

Anterior | Inicio | Siguiente
gzclose | Subir | gzfile


gzfile

(PHP 3, PHP 4 >= 4.0.0)

gzfile -- lee el archivo gz completo en un arreglo

Descripción

array gzfile ( string nombre_archivo [, int usar_include_path])

Identico a readgzfile(), solo que gzfile() devuelve el fichero en un arreglo.

Se puede usar el segundo parámetro opcional poniéndolo a "1", si se quiere que la función busque también el archivo en la trayectoria definida como include_path.

Vea también readgzfile(), y gzopen().

Anterior | Inicio | Siguiente
gzeof | Subir | gzgetc


gzgetc

(PHP 3, PHP 4 >= 4.0.0)

gzgetc -- toma caracteres de un archivo-gz

Descripción

cadena gzgetc ( int zp)

Devuelve una cadena conteniendo un caracter en particular (sin comprimir) leído del archivo al que apunta zp. Devuelve FALSE cuando está al final del archivo (al igual que gzeof()).

El puntero al archivo-gz debe ser válido y debe apuntar a un archivo correctamente abierto con gzopen().

Vea también gzopen(), y gzgets().

Anterior | Inicio | Siguiente
gzfile | Subir | gzgets


gzgets

(PHP 3, PHP 4 >= 4.0.0)

gzgets -- toma una linea del archivo apuntado

Descripción

string gzgets ( int zp, int longitud)

Devuelve una cadena (descomprimida) con longitud - 1 bytes de largo, leída del archivo apuntado por fp. La lectura finaliza cuando se han leído longitud - 1 bytes, ante un salto de linea o un fin-de-archivo (lo que ocurra primero).

Si ocurre un error, devuelve falso.

El puntero al archivo-gz debe ser válido y debe apuntar a un archivo correctamente abierto con gzopen().

Vea también gzopen(), gzgetc(), y fgets().

Anterior | Inicio | Siguiente
gzgetc | Subir | gzgetss


gzgetss

(PHP 3, PHP 4 >= 4.0.0)

gzgetss -- toma una linea del archivo-gz apuntado y le quita los tags HTML

Descripción

string gzgetss ( int zp, int longitud [, string tags_permitidos])

Idéntica a gzgets(), excepto que gzgetss intenta quitar cualquier "tag" HTML o PHP del texto que lee.

Se puede usar el tercer parámetro para indicar qué parametros no deben ser extraídos.

Nota: tags_permitidos fue agregado en la versión de PHP 3.0.13, PHP4B3.

Véase también gzgets(), gzopen(), y strip_tags().

Anterior | Inicio | Siguiente
gzgets | Subir | gzopen


gzopen

(PHP 3, PHP 4 >= 4.0.0)

gzopen -- open gz-file

Descripción

int gzopen ( string nombre_fichero, string modo [, int use_include_path])

Abre un archivo gzip (.gz) para lectura o escritura. El parámetro modo es, como en fopen() ("rb" o "wb") pero puede incluir tambien el nivel de compresión ("wb9") o la estrategia: 'f' para filtrado de datos como en "wb6f", 'h' para comprimir solo por Huffman igual que en "wb1h". (Ver la descripción de deflateInit2 en zlib.h para más información sobre el parámetro de estrategia.)

Gzopen puede usarse para leer o escribir un fichero que no esté en formato gzip; en ese caso gzread() leerá el archivo directamente, sin descomprimirlo.

Gzopen devuelve un puntero al archivo abierto y luego, cualquier proceso de lectura o escritura relacionado con ese descriptor de archivo, será transparente: se comprimirá o descomprimirá los datos según la necesidad, de manera automática.

Si la apertura fallase, se devolverá falso.

Se puede usar el tercer parámetro opcional, poniéndolo a "1", si se quiere buscar también el fichero en la trayectoria include_path.

Ejemplo 1. ejemplo de gzopen()

$fp = gzopen("/tmp/file.gz", "r");

Vea también gzclose().

Anterior | Inicio | Siguiente
gzgetss | Subir | gzpassthru


gzpassthru

(PHP 3, PHP 4 >= 4.0.0)

gzpassthru -- Devuelve el remanente de datos de un fichero-gz

Descripción

int gzpassthru ( int zp)

Lee hasta el Fin-De-Archivo del archivo gz dado, y escribe los resultados (descomprimidos) en la salida standard.

Si ocurre un error, devuelve Falso.

El puntero al archivo-gz debe ser válido y debe apuntar a un archivo correctamente abierto con gzopen().

El archivo-gz es cerrado cuando gzpassthru() termina de leerlo (dejando zp sin utilidad).

Anterior | Inicio | Siguiente
gzopen | Subir | gzputs


gzputs

(PHP 3, PHP 4 >= 4.0.0)

gzputs -- escribe al fichero-gz que se apunta

Descripción

int gzputs ( int zp, string str [, int longitud])

gzputs() es un alias a gzwrite(), y es absolutamente idéntico.

Anterior | Inicio | Siguiente
gzpassthru | Subir | gzread


gzread

(PHP 3, PHP 4 >= 4.0.0)

gzread -- Lee archivos-gz en modo Binario

Descripción

string gzread ( int zp, int longitud)

gzread() lee hasta longitud bytes del archivo-gz apuntado por el parámetro zp. La lectura termina cuando se han leído longitud bytes (descomprimidos) o se alcanza el fin-de-archivo, lo que sucediera primero.

// Pone los contenidos del gz, a una cadena
$filename = "/usr/local/algo.txt.gz";
$zd = gzopen( $filename, "r" );
$contents = gzread( $zd, 10000 );
gzclose( $zd );

Ver también gzwrite(), gzopen(),
gzgets(), gzgetss(),
gzfile(), y gzpassthru().

Anterior | Inicio | Siguiente
gzputs | Subir | gzrewind


gzrewind

(PHP 3, PHP 4 >= 4.0.0)

gzrewind -- Reposiciona al puntero de archivo-gz, al inicio de aquel

Descripción

int gzrewind ( int zp)

Reubica el indicador de posición del archivo, al comienzo del mismo.

si surge un error, devuelve 0.

El puntero al archivo-gz debe ser válido y debe apuntar a un archivo correctamente abierto con gzopen().

Ver también: gzseek() y gztell().

Anterior | Inicio | Siguiente
gzread | Subir | gzseek


gzseek

(PHP 3, PHP 4 >= 4.0.0)

gzseek -- Posiciona el puntero del archivo-gz

Descripción

int gzseek ( int zp, int offset)

Busca la posición dentro del archivo zp, indicada en bytes por el parametro de desplazamiento offset. Es equivalente a llamar (en C) gzseek( zp, offset, SEEK_SET ).

Si el archivo se abre para lectura, la función será emulada, pero puede ponerse extremadamente lenta. Si se trata de escritura, solo está soportada la búsqueda hacia adelante; gzseek comprime entonces una secuencia de ceros hasta que alcanza la nueva ubicación.

Si se completa el pedido con éxito, devuelve 0; de lo contrario, devuelve -1. Note que la busqueda más allá del fin-de-archivo no se considera un error.

Vea también gztell() y gzrewind().

Anterior | Inicio | Siguiente
gzrewind | Subir | gztell


gztell

(PHP 3, PHP 4 >= 4.0.0)

gztell -- Indica la posición de lecto-escritura en el archivo

Descripción

int gztell ( int zp)

Devuelve la posición dentro del fichero referido por zp; p.e., su desplazamiento en el cuerpo del archivo.

Si hay algún error, devuelve falso.

El puntero al archivo-gz debe ser válido y debe apuntar a un archivo correctamente abierto con gzopen().

Ver también gzopen(), gzseek() y gzrewind().

Anterior | Inicio | Siguiente
gzseek | Subir | gzwrite


gzwrite

(PHP 3, PHP 4 >= 4.0.0)

gzwrite -- Escritura de ficheros gz en modo Binario

Descripción

int gzwrite ( int zp, string cadena [, int largo])

gzwrite() escribe el contenido de cadena al fichero gz referido por zp. Si el parámetro largo está presente, se detendrá la escritura luego de escribir largo bytes (descomprimidos) o al llegar el final de la cadena, lo que ocurriese primero.

Note que si se pasa el argumento largo, la opcion magic_quotes_runtime será ignorada y no se quitarán barras de la cadena en cuestión.

Ver también gzread(), gzopen(), y gzputs().

Anterior | Inicio | Siguiente
gztell | Subir | readgzfile


readgzfile

(PHP 3, PHP 4 >= 4.0.0)

readgzfile -- devuelve el fichero-gz

Descripción

int readgzfile ( string nombre_archivo [, int usar_trayectoria_include])

Lee el archivo, lo descomprime y lo escribe en la salida estándar.

Readgzfile() puede usarse para leer un archivo comprimido o no con gzip; en cuyo caso readgzfile() leerá directamente el archivo, sin descomprimirlo.

Devuelve el numero de bytes (descomprimidos) leídos del archivo, si ocurre un error, se devuelve falso y hasta que se llame como @readgzfile, se imprime un mensaje de error.

El archivo nombre_archivo se abrirá en el sistema de archivos y su contenido enviado a la salida estándar.

Puede usarse el segundo paametro opcional dándole el valor "1", si se quiere que se busque el archivo también dentro de la trayectoria "include": include_path.

Ver también gzpassthru(), gzfile(), y gzopen().

Anterior | Inicio | Siguiente
gzwrite | Subir | Extending PHP 4.0


Extending PHP 4.0

Manual de PHP
Anterior Siguiente

V. Extending PHP 4.0

Hacking the Core of PHP

Those who know don't talk.

Those who talk don't know.

Sometimes, PHP "as is" simply isn't enough. Although these cases are rare for the average user, professional applications will soon lead PHP to the edge of its capabilities, in terms of either speed or functionality. New functionality cannot always be implemented natively due to language restrictions and inconveniences that arise when having to carry around a huge library of default code appended to every single script, so another method needs to be found for overcoming these eventual lacks in PHP.

As soon as this point is reached, it's time to touch the heart of PHP and take a look at its core, the C code that makes PHP go.

Note: This chapter only deals with the extension of PHP 4.0. Although a lot of the information is relevant to PHP 3.0, none of the examples are designed to be compatible with PHP 3.0. We believe that, if someone makes the effort to extend PHP, PHP 4.0 will be installed anyway. (Recompiling old PHP 3.0 servers doesn't make sense, considering the benefits of the new PHP version).

Also, at the time of this writing, quite a few things in PHP 4.0 were not completely finished and working yet (one of the major things is the thread-safe version of Zend).

Nota: Updates of this chapter can be found at http://www.zend.com.

Tabla de contenidos
24. Overview
25. Extension Possibilities
26. Source Layout
27. PHP's Automatic Build System
28. Creating Extensions
29. Using Extensions
30. Troubleshooting
31. Source Discussion
32. Accepting Arguments
33. Creating Variables
34. Duplicating Variable Contents: The Copy Constructor
35. Returning Values
36. Printing Information
37. Startup and Shutdown Functions
38. Calling User Functions
39. Initialization File Support
40. Where to Go from Here
41. Reference: Some Configuration Macros
42. API Macros
Hacking the Core of PHP

Anterior | Inicio | Siguiente
readgzfile |  | Overview


Overview

Manual de PHP
Anterior Siguiente

Capítulo 24. Overview

Tabla de contenidos
What Is Zend? and What Is PHP?

"Extending PHP" is easier said than done. PHP has evolved to a full-fledged tool consisting of a few megabytes of source code, and to hack a system like this quite a few things have to be learned and considered. When structuring this chapter, we finally decided on the "learn by doing" approach. This is not the most scientific and professional approach, but the method that's the most fun and gives the best end results. In the following sections, you'll learn quickly how to get the most basic extensions to work almost instantly. After that, you'll learn about Zend's advanced API functionality. The alternative would have been to try to impart the functionality, design, tips, tricks, etc. as a whole, all at once, thus giving a complete look at the big picture before doing anything practical. Although this is the "better" method, as no dirty hacks have to be made, it can be very frustrating as well as energy- and time-consuming, which is why we've decided on the direct approach.

Note that even though this chapter tries to impart as much knowledge as possible about the inner workings of PHP, it's impossible to really give a complete guide to extending PHP that works 100% of the time in all cases. PHP is such a huge and complex package that its inner workings can only be understood if you make yourself familiar with it by practicing, so we encourage you to work with the source.

What Is Zend? and What Is PHP?

The name Zend refers to the language engine, PHP's core. The term PHP refers to the complete system as it appears from the outside. This might sound a bit confusing at first, but it's not that complicated (see Figure 9.1). To implement a Web script interpreter, you need three parts:

  1. The interpreter part analyzes the input code, translates it, and executes it.

  2. The functionality part implements the functionality of the language (its functions, etc.).

  3. The interface part talks to the Web server, etc.

Zend takes part 1 completely and a bit of part 2; PHP takes parts 2 and 3. Together they form the complete PHP package. Zend itself really forms only the language core, implementing PHP at its very basics with some predefined functions. PHP contains all the modules that actually create the language's outstanding capabilities.

Figura 24-1. Figure 9.1. The internal structure of PHP.

The following sections discuss where PHP can be extended and how it's done.

Anterior | Inicio | Siguiente
Extending PHP 4.0 | Subir | Extension Possibilities


Extension Possibilities

Manual de PHP
Anterior Siguiente

Capítulo 25. Extension Possibilities

Tabla de contenidos
External Modules
Built-in Modules
The Zend Engine

As shown in Figure 9.1 above, PHP can be extended primarily at three points: external modules, built-in modules, and the Zend engine. The following sections discuss these options.

External Modules

External modules can be loaded at script runtime using the function dl(). This function loads a shared object from disk and makes its functionality available to the script to which it's being bound. After the script is terminated, the external module is discarded from memory. This method has both advantages and disadvantages, as described in the following table:

Advantages | Disadvantages
External modules don't require recompiling of PHP. | The shared objects need to be loaded every time a script is being executed (every hit), which is very slow.
The size of PHP remains small by "outsourcing" certain functionality. | External additional files clutter up the disk.
 | Every script that wants to use an external module's functionality has to specifically include a call to dl(), or the extension tag in php.ini needs to be modified (which is not always a suitable solution).

To sum up, external modules are great for third-party products, small additions to PHP that are rarely used, or just for testing purposes. To develop additional functionality quickly, external modules provide the best results. For frequent usage, larger implementations, and complex code, the disadvantages outweigh the advantages.

Third parties might consider using the extension tag in php.ini to create additional external modules to PHP. These external modules are completely detached from the main package, which is a very handy feature in commercial environments. Commercial distributors can simply ship disks or archives containing only their additional modules, without the need to create fixed and solid PHP binaries that don't allow other modules to be bound to them.

Anterior | Inicio | Siguiente
Overview | Subir | Built-in Modules


Built-in Modules

Built-in modules are compiled directly into PHP and carried around with every PHP process; their functionality is instantly available to every script that's being run. Like external modules, built-in modules have advantages and disadvantages, as described in the following table:

Advantages | Disadvantages
No need to load the module specifically; the functionality is instantly available. | Changes to built-in modules require recompiling of PHP.
No external files clutter up the disk; everything resides in the PHP binary. | The PHP binary grows and consumes more memory.

Built-in modules are best when you have a solid library of functions that remains relatively unchanged, requires better than poor-to-average performance, or is used frequently by many scripts on your site. The need to recompile PHP is quickly compensated by the benefit in speed and ease of use. However, built-in modules are not ideal when rapid development of small additions is required.

Anterior | Inicio | Siguiente
Extension Possibilities | Subir | The Zend Engine


The Zend Engine

Of course, extensions can also be implemented directly in the Zend engine. This strategy is good if you need a change in the language behavior or require special functions to be built directly into the language core. In general, however, modifications to the Zend engine should be avoided. Changes here result in incompatibilities with the rest of the world, and hardly anyone will ever adapt to specially patched Zend engines. Modifications can't be detached from the main PHP sources and are overridden with the next update using the "official" source repositories. Therefore, this method is generally considered bad practice and, due to its rarity, is not covered in this book.

Anterior | Inicio | Siguiente
Built-in Modules | Subir | Source Layout


Source Layout

Manual de PHP
Anterior Siguiente

Capítulo 26. Source Layout

Tabla de contenidos
Extension Conventions
Macros
Memory Management
Directory and File Functions
String Handling
Complex Types

Prerequisites. Prior to working through the rest of this chapter, you should retrieve clean, unmodified source trees of your favorite Web server. We're working with Apache (available at http://www.apache.org) and, of course, with PHP (available at http://www.php.net - does it need to be said?).

Alternatively, you can use the provided source archives on the CD-ROM accompanying this book. All the examples in this book work with the source archives on the CD-ROM; we can't guarantee this for every version retrieved from the Net. However, as Open Source software develops extremely rapidly, chances are that the versions on the CD-ROM are already outdated and don't have all the functionality you need. If you can't get the official archives from the corresponding Web sites to work, experiment with the CD-ROM archives and then try to go on from there.

Make sure that you can compile a working PHP environment by yourself! We won't go into this issue here, however, as you should already have this most basic ability when studying this chapter.

Before we start discussing code issues, you should familiarize yourself with the source tree to be able to quickly navigate through PHP's files. This is a must-have ability to implement and debug extensions.

After extracting the PHP archive, you'll see a directory layout similar to that in Figure 9.2.

Figura 26-1. Figure 9.2. Main directory layout of the PHP source tree.

The following table describes the contents of the major directories.

Directory | Contents
php-4 | Main PHP source files and main header files; here you'll find all of PHP's API definitions, macros, etc. (important).
ext | Repository for dynamic and built-in modules; by default, these are the "official" PHP modules that have been integrated into the main source tree. In PHP 4.0, it's possible to compile these standard extensions as dynamic loadable modules (at least, those that support it).
pear | Directory for the PHP class repository. At the time of this writing, this is still in the design phase, but it's being tried to establish something similar to CPAN for Perl here.
sapi | Contains the code for the different server abstraction layers.
TSRM | Location of the "Thread Safe Resource Manager" (TSRM) for Zend and PHP.
Zend | Location of Zend's file; here you'll find all of Zend's API definitions, macros, etc. (important).

Discussing all the files included in the PHP package is beyond the scope of this chapter. However, you should take a close look at the following files:

  • php.h, located in the main PHP directory. This file contains most of PHP's macro and API definitions.

  • zend.h, located in the main Zend directory. This file contains most of Zend's macros and definitions.

  • zend_API.h, also located in the Zend directory, which defines Zend's API.

You should also follow some sub-inclusions from these files; for example, the ones relating to the Zend executor, the PHP initialization file support, and such. After reading these files, take the time to navigate around the package a little to see the interdependencies of all files and modules - how they relate to each other and especially how they make use of each other. This also helps you to adapt to the coding style in which PHP is authored. To extend PHP, you should quickly adapt to this style.

Extension Conventions

Zend is built using certain conventions; to avoid breaking its standards, you should follow the rules described in the following sections.

Anterior | Inicio | Siguiente
The Zend Engine | Subir | Macros


Macros

For almost every important task, Zend ships predefined macros that are extremely handy. The tables and figures in the following sections describe most of the basic functions, structures, and macros. The macro definitions can be found mainly in zend.h and zend_API.h. We suggest that you take a close look at these files after having studied this chapter. (Although you can go ahead and read them now, not everything will make sense to you yet.)

Anterior | Inicio | Siguiente
Source Layout | Subir | Memory Management


Memory Management

Resource management is a crucial issue, especially in server software. One of the most valuable resources is memory, and memory management should be handled with extreme care. Memory management has been partially abstracted in Zend, and you should stick to this abstraction for obvious reasons: Due to the abstraction, Zend gets full control over all memory allocations. Zend is able to determine whether a block is in use, automatically freeing unused blocks and blocks with lost references, and thus prevent memory leaks. The functions to be used are described in the following table:

Function | Description
emalloc() | Serves as replacement for malloc().
efree() | Serves as replacement for free().
estrdup() | Serves as replacement for strdup().
estrndup() | Serves as replacement for strndup(). Faster than estrdup() and binary-safe. This is the recommended function to use if you know the string length prior to duplicating it.
ecalloc() | Serves as replacement for calloc().
erealloc() | Serves as replacement for realloc().

emalloc(), estrdup(), estrndup(), ecalloc(), and erealloc() allocate internal memory; efree() frees these previously allocated blocks. Memory handled by the e*() functions is considered local to the current process and is discarded as soon as the script executed by this process is terminated.

Aviso

To allocate resident memory that survives termination of the current script, you can use malloc() and free(). This should only be done with extreme care, however, and only in conjunction with demands of the Zend API; otherwise, you risk memory leaks.

Zend also features a thread-safe resource manager to provide better native support for multithreaded Web servers. This requires you to allocate local structures for all of your global variables to allow concurrent threads to be run. Because the thread-safe mode of Zend is not finished yet, we could not include coverage in this book.

Anterior | Inicio | Siguiente
Macros | Subir | Directory and File Functions


Directory and File Functions

The following directory and file functions should be used in Zend modules (they behave exactly like their C counterparts):

Zend Function | Regular C Function
V_GETCWD() | getcwd()
V_FOPEN() | fopen()
V_OPEN() | open()
V_CHDIR() | chdir()
V_GETWD() | getwd()
V_CHDIR_FILE() | Takes a file path as an argument and changes the current working directory to that file's directory.
V_STAT() | stat()
V_LSTAT() | lstat()

Anterior | Inicio | Siguiente
Memory Management | Subir | String Handling


String Handling

Strings are handled a bit differently by the Zend engine than other values such as integers, Booleans, etc., which don't require additional memory allocation for storing their values. If you want to return a string from a function, introduce a new string variable to the symbol table, or do something similar, you have to make sure that the memory the string will be occupying has previously been allocated, using the aforementioned e*() functions for allocation. (This might not make much sense to you yet; just keep it somewhere in your head for now - we'll get back to it shortly.)

Anterior | Inicio | Siguiente
Directory and File Functions | Subir | Complex Types


Complex Types

Complex types such as arrays and objects require different treatment. Zend features a single API for these types - they're stored using hash tables.

Note: To reduce complexity in the following source examples, we're only working with simple types such as integers at first. A discussion about creating more advanced types follows later in this chapter.

Anterior | Inicio | Siguiente
String Handling | Subir | PHP's Automatic Build System


PHP's Automatic Build System

Manual de PHP
Anterior Siguiente

Capítulo 27. PHP's Automatic Build System

PHP 4.0 features an automatic build system that's very flexible. All modules reside in a subdirectory of the ext directory. In addition to its own sources, each module consists of an M4 file (for example, see http://www.gnu.org/manual/m4/html_mono/m4.html) for configuration and a Makefile.in file, which is responsible for compilation (the results of autoconf and automake; for example, see http://sourceware.cygnus.com/autoconf/autoconf.html and http://sourceware.cygnus.com/automake/automake.html).

Both files are generated automatically, along with .cvsignore, by a little shell script named ext_skel that resides in the ext directory. As argument it takes the name of the module that you want to create. The shell script then creates a directory of the same name, along with the appropriate config.m4 and Makefile.in files.

Step by step, the process looks like this:
root@dev:/usr/local/src/php4/ext > ./ext_skel my_module
Creating directory
Creating basic files: config.m4 Makefile.in .cvsignore [done].

To use your new extension, you will have to execute the following steps:

    $ cd ..
    $ ./buildconf
    $ ./configure                 (your extension is automatically enabled)
    $ vi ext/my_module/my_module.c
    $ make

Repeat the last two steps as often as necessary.
This instruction creates the aforementioned files. To include the new module in the automatic configuration and build process, you have to run buildconf, which regenerates the configure script by searching through the ext directory and including all found config.m4 files.

Finally, running configure parses all configuration options and generates a makefile based on those options and the options you specify in Makefile.in.

Listing 9.1 shows the previously generated Makefile.in:

Figura 27-1. Listing 9.1. The default Makefile.in.

# $Id: Extending_Zend_Build.xml,v 1.1 2002/01/09 12:16:30 derick Exp $

LTLIBRARY_NAME        = libmy_module.la
LTLIBRARY_SOURCES     = my_module.c
LTLIBRARY_SHARED_NAME = my_module.la

include $(top_srcdir)/build/dynlib.mk

There's not much to tell about this one: It contains the names of the input and output files. You could also specify build instructions for other files if your module is built from multiple source files.

The default config.m4 shown in Listing 9.2 is a bit more complex:

Figura 27-2. Listing 9.2. The default config.m4.

dnl $Id: Extending_Zend_Build.xml,v 1.1 2002/01/09 12:16:30 derick Exp $
dnl config.m4 for extension my_module
dnl don't forget to call PHP_EXTENSION(my_module)

dnl If your extension references something external, use with:

PHP_ARG_WITH(my_module, for my_module support,
dnl Make sure that the comment is aligned:
[  --with-my_module             Include my_module support])

dnl Otherwise use enable:

PHP_ARG_ENABLE(my_module, whether to enable my_module support,
dnl Make sure that the comment is aligned:
[  --enable-my_module           Enable my_module support])

if test "$PHP_MY_MODULE" != "no"; then
  dnl Action..
  PHP_EXTENSION(my_module, $ext_shared)
fi

If you're unfamiliar with M4 files (now is certainly a good time to get familiar), this might be a bit confusing at first; but it's actually quite easy.

Note: Everything prefixed with dnl is treated as a comment and is not parsed.

The config.m4 file is responsible for parsing the command-line options passed to configure at configuration time. This means that it has to check for required external files and do similar configuration and setup tasks.

The default file creates two configuration directives in the configure script: --with-my_module and --enable-my_module. Use the first option when referring external files (such as the --with-apache directive that refers to the Apache directory). Use the second option when the user simply has to decide whether to enable your extension. Regardless of which option you use, you should uncomment the other, unnecessary one; that is, if you're using --enable-my_module, you should remove support for --with-my_module, and vice versa.

By default, the config.m4 file created by ext_skel accepts both directives and automatically enables your extension. Enabling the extension is done by using the PHP_EXTENSION macro. To change the default behavior to include your module into the PHP binary when desired by the user (by explicitly specifying --enable-my_module or --with-my_module), change the test for $PHP_MY_MODULE to == "yes":
if test "$PHP_MY_MODULE" == "yes"; then
  dnl Action..
  PHP_EXTENSION(my_module, $ext_shared)
fi
This would require you to use --enable-my_module each time when reconfiguring and recompiling PHP.

Note: Be sure to run buildconf every time you change config.m4!

We'll go into more details on the M4 macros available to your configuration scripts later in this chapter. For now, we'll simply use the default files. The sample sources on the CD-ROM all have working config.m4 files. To include them into the PHP build process, simply copy the source directories to your PHP ext directory, run buildconf, and then include the sample modules you want by using the appropriate --enable-* directives with configure.

Anterior | Inicio | Siguiente
Complex Types | Subir | Creating Extensions


Creating Extensions

Manual de PHP
Anterior Siguiente

Capítulo 28. Creating Extensions

Tabla de contenidos
Compiling Modules

We'll start with the creation of a very simple extension at first, which basically does nothing more than implement a function that returns the integer it receives as parameter. Listing 9.3 shows the source.

Figura 28-1. Listing 9.3. A simple extension.

/* include standard header */
#include "php.h"

/* declaration of functions to be exported */
ZEND_FUNCTION(first_module);

/* compiled function list so Zend knows what's in this module */
zend_function_entry firstmod_functions[] =
{
    ZEND_FE(first_module, NULL)
    {NULL, NULL, NULL}
};

/* compiled module information */
zend_module_entry firstmod_module_entry =
{
    STANDARD_MODULE_HEADER,
    "First Module",
    firstmod_functions,
    NULL, NULL, NULL, NULL, NULL,
    NO_VERSION_YET,
    STANDARD_MODULE_PROPERTIES
};

/* implement standard "stub" routine to introduce ourselves to Zend */
#if COMPILE_DL_FIRST_MODULE
ZEND_GET_MODULE(firstmod)
#endif

/* implement function that is meant to be made available to PHP */
ZEND_FUNCTION(first_module)
{
    long parameter;

    if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &parameter) == FAILURE) {
        return;
    }

    RETURN_LONG(parmeter);
}

This code contains a complete PHP module. We'll explain the source code in detail shortly, but first we'd like to discuss the build process. (This will allow the impatient to experiment before we dive into API discussions.)

Compiling Modules

There are basically three ways to compile modules:

  • Use the provided "make" mechanism in the dl directory.

  • Use the provided "make" mechanism in the ext directory, which also allows building of dynamic loadable modules.

  • Compile the sources manually.

The second method should definitely be favored, since, as of PHP 4.0, this has been standardized into a sophisticated build process. The fact that it is so sophisticated is also its drawback, unfortunately - it's hard to understand at first. We'll provide a more detailed introduction to this later in the chapter, but first let's work with the default files.

The make process contained in the dl directory is a bit of a dirty hack, outdated and planned for removal from the source tree. To be honest, it's much simpler to use this at first to build dynamic extensions, but because it doesn't have the possibilities of the ext directory and it's scheduled for deletion anyway, usage of the dl directory is deprecated.

The third method is good for those who (for some reason) don't have the full PHP source tree available, don't have access to all files, or just like to juggle with their keyboard. These cases should be extremely rare, but for the sake of completeness we'll also describe this method.

Compiling Using Make. To compile the sample sources using the standard mechanism, copy all their subdirectories to the ext directory of your PHP source tree. Then run buildconf, which will create a new configure script containing appropriate options. By default, all the sample sources are disabled, so you don't have to fear breaking your build process.

After you run buildconf, configure --help shows the following additional modules:
--enable-array_experiments   BOOK: Enables array experiments
  --enable-call_userland       BOOK: Enables userland module
  --enable-cross_conversion    BOOK: Enables cross-conversion module
  --enable-first_module        BOOK: Enables first module
  --enable-infoprint           BOOK: Enables infoprint module
  --enable-reference_test      BOOK: Enables reference test module
  --enable-resource_test       BOOK: Enables resource test module
  --enable-variable_creation   BOOK: Enables variable-creation module
The module shown earlier in Listing 9.3 can be enabled with --enable-first_module or --enable-first_module=yes.

Compiling Manually. To compile your modules manually, you need the following commands:

Action | Command
Compiling | cc -fpic -DCOMPILE_DL=1 -I/usr/local/include -I. -I.. -I../Zend -c -o <your_object_file> <your_c_file>
Linking | cc -shared -L/usr/local/lib -rdynamic -o <your_module_file> <your_object_file(s)>

The command to compile the module simply instructs the compiler to generate position-independent code (-fpic shouldn't be omitted) and additionally defines the constant COMPILE_DL to tell the module code that it's compiled as a dynamically loadable module (the test module above checks for this; we'll discuss it shortly). After these options, it specifies a number of standard include paths that should be used as the minimal set to compile the source files.

Note: All include paths in the example are relative to the directory ext. If you're compiling from another directory, change the pathnames accordingly. Required items are the PHP directory, the Zend directory, and (if necessary), the directory in which your module resides.

The link command is also a plain vanilla command instructing linkage as a dynamic module.

You can include optimization options in the compilation command, although these have been omitted in this example (but some are included in the makefile template described in an earlier section).

Note: Compiling and linking manually as a static module into the PHP binary involves very long instructions and thus is not discussed here. (It's not very efficient to type all those commands.)

Anterior | Inicio | Siguiente
PHP's Automatic Build System | Subir | Using Extensions


Using Extensions

Manual de PHP
Anterior Siguiente

Capítulo 29. Using Extensions

Depending on the build process you selected, you should either end up with a new PHP binary to be linked into your Web server (or run as CGI), or with an .so (shared object) file. If you compiled the example file first_module.c as a shared object, your result file should be first_module.so. To use it, you first have to copy it to a place from which it's accessible to PHP. For a simple test procedure, you can copy it to your htdocs directory and try it with the source in Listing 9.4. If you compiled it into the PHP binary, omit the call to dl(), as the module's functionality is instantly available to your scripts.

Aviso

For security reasons, you should not put your dynamic modules into publicly accessible directories. Even though it can be done and it simplifies testing, you should put them into a separate directory in production environments.

Figura 29-1. Listing 9.4. A test file for first_module.so.

<?php

//dl("first_module.so");

$param = 2;
$return = first_module($param);

print("We sent \"$param\" and got \"$return\"");

?>

Calling this PHP file in your Web browser should give you the output shown in Figure 9.3.

Figura 29-2. Figure 9.3. Output of first_module.php.

If required, the dynamic loadable module is loaded by calling the dl() function. This function looks for the specified shared object, loads it, and makes its functions available to PHP. The module exports the function first_module(), which accepts a single parameter, converts it to an integer, and returns the result of the conversion.

If you've gotten this far, congratulations! You just built your first extension to PHP.

Anterior | Inicio | Siguiente
Creating Extensions | Subir | Troubleshooting


Troubleshooting

Manual de PHP
Anterior Siguiente

Capítulo 30. Troubleshooting

Actually, not much troubleshooting can be done when compiling static or dynamic modules. The only problem that could arise is that the compiler will complain about missing definitions or something similar. In this case, make sure that all header files are available and that you specified their path correctly in the compilation command. To be sure that everything is located correctly, extract a clean PHP source tree and use the automatic build in the ext directory with the fresh files from the CD-ROM; this will guarantee a safe compilation environment. If this fails, try manual compilation.

PHP might also complain about missing functions in your module. (This shouldn't happen with the sample sources if you didn't modify them.) If the names of external functions you're trying to access from your module are misspelled, they'll remain as "unlinked symbols" in the symbol table. During dynamic loading and linkage by PHP, they won't resolve because of the typing errors - there are no corresponding symbols in the main binary. Look for incorrect declarations in your module file or incorrectly written external references. Note that this problem is specific to dynamic loadable modules; it doesn't occur with static modules. Errors in static modules show up at compile time.

Anterior | Inicio | Siguiente
Using Extensions | Subir | Source Discussion


Source Discussion

Manual de PHP
Anterior Siguiente

Capítulo 31. Source Discussion

Tabla de contenidos
Module Structure
Header File Inclusions
Declaring Exported Functions
Declaration of the Zend Function Block
Declaration of the Zend Module Block
Creation of get_module()
Implementation of All Exported Functions
Summary

Now that you've got a safe build environment and you're able to include the modules into PHP files, it's time to discuss how everything works.

Module Structure

All PHP modules follow a common structure:

  • Header file inclusions (to include all required macros, API definitions, etc.)

  • C declaration of exported functions (required to declare the Zend function block)

  • Declaration of the Zend function block

  • Declaration of the Zend module block

  • Implementation of get_module()

  • Implementation of all exported functions

Anterior | Inicio | Siguiente
Troubleshooting | Subir | Header File Inclusions


Header File Inclusions

The only header file you really have to include for your modules is php.h, located in the PHP directory. This file makes all macros and API definitions required to build new modules available to your code.

Tip: It's good practice to create a separate header file for your module that contains module-specific definitions. This header file should contain all the forward definitions for exported functions and include php.h.

Anterior | Inicio | Siguiente
Source Discussion | Subir | Declaring Exported Functions


Declaring Exported Functions

To declare functions that are to be exported (i.e., made available to PHP as new native functions), Zend provides a set of macros. A sample declaration looks like this:
ZEND_FUNCTION(my_function);

ZEND_FUNCTION declares a new C function that complies with Zend's internal API. This means that the function is of type void and accepts INTERNAL_FUNCTION_PARAMETERS (another macro) as parameters. Additionally, it prefixes the function name with zif. The immediately expanded version of the above definitions would look like this:
void zif_my_function(INTERNAL_FUNCTION_PARAMETERS);
Expanding INTERNAL_FUNCTION_PARAMETERS results in the following:
void zif_my_function(int ht, zval *return_value, zval *this_ptr, int return_value_used, zend_executor_globals *executor_globals);

Since the interpreter and executor core have been separated from the main PHP package, a second API defining macros and function sets has evolved: the Zend API. As the Zend API now handles quite a few of the responsibilities that previously belonged to PHP, a lot of PHP functions have been reduced to macros aliasing to calls into the Zend API. The recommended practice is to use the Zend API wherever possible, as the old API is only preserved for compatibility reasons. For example, the types zval and pval are identical. zval is Zend's definition; pval is PHP's definition (actually, pval is an alias for zval now). As the macro INTERNAL_FUNCTION_PARAMETERS is a Zend macro, the above declaration contains zval. When writing code, you should always use zval to conform to the new Zend API.

The parameter list of this declaration is very important; you should keep these parameters in mind (see Table 9.1 for descriptions).

Figura 31-1. Table 9.1. Zend's Parameters to Functions Called from PHP

Parameter | Description
ht | The number of arguments passed to the Zend function. You should not touch this directly, but instead use ZEND_NUM_ARGS() to obtain the value.
return_value | This variable is used to pass any return values of your function back to PHP. Access to this variable is best done using the predefined macros. For a description of these see below.
this_ptr | Using this variable, you can gain access to the object in which your function is contained, if it's used within an object. Use the function getThis() to obtain this pointer.
return_value_used | This flag indicates whether an eventual return value from this function will actually be used by the calling script. 0 indicates that the return value is not used; 1 indicates that the caller expects a return value. Evaluation of this flag can be done to verify correct usage of the function as well as speed optimizations in case returning a value requires expensive operations (for an example, see how array.c makes use of this).
executor_globals | This variable points to global settings of the Zend engine. You'll find this useful when creating new variables, for example (more about this later). The executor globals can also be introduced to your function by using the macro ELS_FETCH().

Anterior | Inicio | Siguiente
Header File Inclusions | Subir | Declaration of the Zend Function Block


Declaration of the Zend Function Block

Now that you have declared the functions to be exported, you also have to introduce them to Zend. Introducing the list of functions is done by using an array of zend_function_entry. This array consecutively contains all functions that are to be made available externally, with the function's name as it should appear in PHP and its name as defined in the C source. Internally, zend_function_entry is defined as shown in Listing 9.5.

Figura 31-2. Listing 9.5. Internal declaration of zend_function_entry.

typedef struct _zend_function_entry {
    char *fname;
    void (*handler)(INTERNAL_FUNCTION_PARAMETERS);
    unsigned char *func_arg_types;
} zend_function_entry;

Entry | Description
fname | Denotes the function name as seen in PHP (for example, fopen, mysql_connect, or, in our example, first_module).
handler | Pointer to the C function responsible for handling calls to this function. For example, see the standard macro INTERNAL_FUNCTION_PARAMETERS discussed earlier.
func_arg_types | Allows you to mark certain parameters so that they're forced to be passed by reference. You usually should set this to NULL.

In the example above, the declaration looks like this:
zend_function_entry firstmod_functions[] =
{
    ZEND_FE(first_module, NULL)
    {NULL, NULL, NULL}
};
You can see that the last entry in the list always has to be {NULL, NULL, NULL}. This marker has to be set for Zend to know when the end of the list of exported functions is reached.

Note: You cannot use the predefined macros for the end marker, as these would try to refer to a function named "NULL"!

The macro ZEND_FE simply expands to a structure entry in zend_function_entry. Note that these macros introduce a special naming scheme to your functions - your C functions will be prefixed with zif_, meaning that ZEND_FE(first_module) will refer to a C function zif_first_module(). If you want to mix macro usage with hand-coded entries (not a good practice), keep this in mind.

Tip: Compilation errors that refer to functions named zif_*() relate to functions defined with ZEND_FE.

Table 9.2 shows a list of all the macros that you can use to define functions.

Figura 31-3. Table 9.2. Macros for Defining Functions

Macro Name | Description
ZEND_FE(name, arg_types) | Defines a function entry of the name name in zend_function_entry. Requires a corresponding C function. arg_types needs to be set to NULL. This function uses automatic C function name generation by prefixing the PHP function name with zif_. For example, ZEND_FE("first_module", NULL) introduces a function first_module() to PHP and links it to the C function zif_first_module(). Use in conjunction with ZEND_FUNCTION.
ZEND_NAMED_FE(php_name, name, arg_types) | Defines a function that will be available to PHP by the name php_name and links it to the corresponding C function name. arg_types needs to be set to NULL. Use this function if you don't want the automatic name prefixing introduced by ZEND_FE. Use in conjunction with ZEND_NAMED_FUNCTION.
ZEND_FALIAS(name, alias, arg_types) | Defines an alias named alias for name. arg_types needs to be set to NULL. Doesn't require a corresponding C function; refers to the alias target instead.
PHP_FE(name, arg_types) | Old PHP API equivalent of ZEND_FE.
PHP_NAMED_FE(runtime_name, name, arg_types) | Old PHP API equivalent of ZEND_NAMED_FE.

Note: You can't use ZEND_FE in conjunction with PHP_FUNCTION, or PHP_FE in conjunction with ZEND_FUNCTION. However, it's perfectly legal to mix ZEND_FE and ZEND_FUNCTION with PHP_FE and PHP_FUNCTION when staying with the same macro set for each function to be declared. But mixing is not recommended; instead, you're advised to use the ZEND_* macros only.

Anterior | Inicio | Siguiente
Declaring Exported Functions | Subir | Declaration of the Zend Module Block


Declaration of the Zend Module Block

This block is stored in the structure zend_module_entry and contains all necessary information to describe the contents of this module to Zend. You can see the internal definition of this module in Listing 9.6.

Figura 31-4. Internal declaration of zend_module_entry.

typedef struct _zend_module_entry zend_module_entry;

struct _zend_module_entry {
    unsigned short size;
    unsigned int zend_api;
    unsigned char zend_debug;
    unsigned char zts;
    char *name;
    zend_function_entry *functions;
    int (*module_startup_func)(INIT_FUNC_ARGS);
    int (*module_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    int (*request_startup_func)(INIT_FUNC_ARGS);
    int (*request_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    void (*info_func)(ZEND_MODULE_INFO_FUNC_ARGS);
    char *version;
    int (*global_startup_func)(void);
    int (*global_shutdown_func)(void);

[ Rest of the structure is not interesting here ]

};

Entry | Description
size, zend_api, zend_debug and zts | Usually filled with the "STANDARD_MODULE_HEADER", which fills these four members with the size of the whole zend_module_entry, the ZEND_MODULE_API_NO, whether it is a debug build or normal build (ZEND_DEBUG) and if ZTS is enabled (USING_ZTS).
name | Contains the module name (for example, "File functions", "Socket functions", "Crypt", etc.). This name will show up in phpinfo(), in the section "Additional Modules."
functions | Points to the Zend function block, discussed in the preceding section.
module_startup_func | This function is called once upon module initialization and can be used to do one-time initialization steps (such as initial memory allocation, etc.). To indicate a failure during initialization, return FAILURE; otherwise, SUCCESS. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MINIT.
module_shutdown_func | This function is called once upon module shutdown and can be used to do one-time deinitialization steps (such as memory deallocation). This is the counterpart to module_startup_func(). To indicate a failure during deinitialization, return FAILURE; otherwise, SUCCESS. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MSHUTDOWN.
request_startup_func | This function is called once upon every page request and can be used to do one-time initialization steps that are required to process a request. To indicate a failure here, return FAILURE; otherwise, SUCCESS. Note: As dynamic loadable modules are loaded only on page requests, the request startup function is called right after the module startup function (both initialization events happen at the same time). To mark this field as unused, use NULL. To declare a function, use the macro ZEND_RINIT.
request_shutdown_func | This function is called once after every page request and works as counterpart to request_startup_func(). To indicate a failure here, return FAILURE; otherwise, SUCCESS. Note: As dynamic loadable modules are loaded only on page requests, the request shutdown function is immediately followed by a call to the module shutdown handler (both deinitialization events happen at the same time). To mark this field as unused, use NULL. To declare a function, use the macro ZEND_RSHUTDOWN.
info_func | When phpinfo() is called in a script, Zend cycles through all loaded modules and calls this function. Every module then has the chance to print its own "footprint" into the output page. Generally this is used to dump environmental or statistical information. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MINFO.
version | The version of the module. You can use NO_VERSION_YET if you don't want to give the module a version number yet, but we really recommend that you add a version string here. Such a version string can look like this (in chronological order): "2.5-dev", "2.5RC1", "2.5" or "2.5pl3".
global_startup_func | The global startup functions are rarely used. You should usually skip through the rest of this structure by placing the macro STANDARD_MODULE_PROPERTIES. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_GINIT.
global_shutdown_func | To mark this field as unused, use NULL. To declare a function, use the macro ZEND_GSHUTDOWN.
Remaining structure elements | These are used internally and can be prefilled by using the macro STANDARD_MODULE_PROPERTIES_EX. You should not assign any values to them. Use STANDARD_MODULE_PROPERTIES_EX only if you use global startup and shutdown functions; otherwise, use STANDARD_MODULE_PROPERTIES directly.

In our example, this structure is implemented as follows:
zend_module_entry firstmod_module_entry =
{
    STANDARD_MODULE_HEADER,
    "First Module",
    firstmod_functions,
    NULL, NULL, NULL, NULL, NULL,
    NO_VERSION_YET,
    STANDARD_MODULE_PROPERTIES,
};
This is basically the easiest and most minimal set of values you could ever use. The module name is set to First Module, then the function list is referenced, after which all startup and shutdown functions are marked as being unused.

For reference purposes, you can find a list of the macros involved in declared startup and shutdown functions in Table 9.3. These are not used in our basic example yet, but will be demonstrated later on. You should make use of these macros to declare your startup and shutdown functions, as these require special arguments to be passed (INIT_FUNC_ARGS and SHUTDOWN_FUNC_ARGS), which are automatically included into the function declaration when using the predefined macros. If you declare your functions manually and the PHP developers decide that a change in the argument list is necessary, you'll have to change your module sources to remain compatible.

Figura 31-5. Macros to Declare Startup and Shutdown Functions

Macro | Description
ZEND_MINIT(module) | Declares a function for module startup. The generated name will be zend_minit_<module> (for example, zend_minit_first_module). Use in conjunction with ZEND_MINIT_FUNCTION.
ZEND_MSHUTDOWN(module) | Declares a function for module shutdown. The generated name will be zend_mshutdown_<module> (for example, zend_mshutdown_first_module). Use in conjunction with ZEND_MSHUTDOWN_FUNCTION.
ZEND_RINIT(module) | Declares a function for request startup. The generated name will be zend_rinit_<module> (for example, zend_rinit_first_module). Use in conjunction with ZEND_RINIT_FUNCTION.
ZEND_RSHUTDOWN(module) | Declares a function for request shutdown. The generated name will be zend_rshutdown_<module> (for example, zend_rshutdown_first_module). Use in conjunction with ZEND_RSHUTDOWN_FUNCTION.
ZEND_GINIT(module) | Declares a function for global startup. The generated name will be zend_ginit_<module> (for example, zend_ginit_first_module). Use in conjunction with ZEND_GINIT_FUNCTION.
ZEND_GSHUTDOWN(module) | Declares a function for global shutdown. The generated name will be zend_gshutdown_<module> (for example, zend_gshutdown_first_module). Use in conjunction with ZEND_GSHUTDOWN_FUNCTION.
ZEND_MINFO(module) | Declares a function for printing module information, used when phpinfo() is called. The generated name will be zend_info_<module> (for example, zend_info_first_module). Use in conjunction with ZEND_MINFO_FUNCTION.

Anterior | Inicio | Siguiente
Declaration of the Zend Function Block | Subir | Creation of get_module()


Creation of get_module

Manual de PHP
Anterior Capítulo 31. Source Discussion Siguiente

Creation of get_module()

This function is special to all dynamic loadable modules. Take a look at the creation via the ZEND_GET_MODULE macro first:
#if COMPILE_DL_FIRSTMOD
ZEND_GET_MODULE(firstmod)
#endif
The function implementation is surrounded by a conditional compilation statement. This is needed since the function get_module() is only required if your module is built as a dynamic extension. By specifying a definition of COMPILE_DL_FIRSTMOD in the compiler command (see above for a discussion of the compilation instructions required to build a dynamic extension), you can instruct your module whether you intend to build it as a dynamic extension or as a built-in module. If you want a built-in module, the implementation of get_module() is simply left out.

get_module() is called by Zend at load time of the module. You can think of it as being invoked by the dl() call in your script. Its purpose is to pass the module information block back to Zend in order to inform the engine about the module contents.

If you don't implement a get_module() function in your dynamic loadable module, Zend will compliment you with an error message when trying to access it.

Anterior | Inicio | Siguiente
Declaration of the Zend Module Block | Subir | Implementation of All Exported Functions


Implementation of All Exported Functions

Implementing the exported functions is the final step. The example function in first_module looks like this:
ZEND_FUNCTION(first_module)
{
    long parameter;

    if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &parameter) == FAILURE) {
        return;
    }

    RETURN_LONG(parameter);
}
The function declaration is done using ZEND_FUNCTION, which corresponds to ZEND_FE in the function entry table (discussed earlier).

After the declaration, code for checking and retrieving the function's arguments, argument conversion, and return value generation follows (more on this later).

Anterior | Inicio | Siguiente
Creation of get_module() | Subir | Summary


Summary

That's it, basically - there's nothing more to implementing PHP modules. Built-in modules are structured similarly to dynamic modules, so, equipped with the information presented in the previous sections, you'll be able to fight the odds when encountering PHP module source files.

Now, in the following sections, read on about how to make use of PHP's internals to build powerful extensions.

Anterior | Inicio | Siguiente
Implementation of All Exported Functions | Subir | Accepting Arguments


Accepting Arguments

Manual de PHP
Anterior Siguiente

Capítulo 32. Accepting Arguments

Tabla de contenidos
Determining the Number of Arguments
Retrieving Arguments
Old way of retrieving arguments (deprecated)
Dealing with a Variable Number of Arguments/Optional Parameters
Accessing Arguments
Dealing with Arguments Passed by Reference
Assuring Write Safety for Other Parameters

One of the most important issues for language extensions is accepting and dealing with data passed via arguments. Most extensions are built to deal with specific input data (or require parameters to perform their specific actions), and function arguments are the only real way to exchange data between the PHP level and the C level. Of course, there's also the possibility of exchanging data using predefined global values (which is also discussed later), but this should be avoided by all means, as it's extremely bad practice. For details, refer to Chapter 1, "Development Concepts."

PHP doesn't make use of any formal function declarations; this is why call syntax is always completely dynamic and never checked for errors. Checking for correct call syntax is left to the user code. For example, it's possible to call a function using only one argument at one time and four arguments the next time - both invocations are syntactically absolutely correct.

Determining the Number of Arguments

Since PHP doesn't have formal function definitions with support for call syntax checking, and since PHP features variable arguments, sometimes you need to find out with how many arguments your function has been called. You can use the ZEND_NUM_ARGS macro in this case. In previous versions of PHP, this macro retrieved the number of arguments with which the function has been called based on the function's hash table entry, ht, which is passed in the INTERNAL_FUNCTION_PARAMETERS list. As ht itself now contains the number of arguments that have been passed to the function, ZEND_NUM_ARGS has been stripped down to a dummy macro (see its definition in zend_API.h). But it's still good practice to use it, to remain compatible with future changes in the call interface. Note: The old PHP equivalent of this macro is ARG_COUNT.

The following code checks for the correct number of arguments:
if(ZEND_NUM_ARGS() != 2)
    WRONG_PARAM_COUNT;
If the function is not called with two arguments, it exits with an error message. The code snippet above makes use of the tool macro WRONG_PARAM_COUNT, which can be used to generate a standard error message (see Figure 9.4).

Figura 32-1. Figure 9.4. WRONG_PARAM_COUNT in action.

This macro prints a default error message and then returns to the caller. Its definition can also be found in zend_API.h and looks like this:
ZEND_API void wrong_param_count(void);

#define WRONG_PARAM_COUNT { wrong_param_count(); return; }
As you can see, it calls an internal function named wrong_param_count() that's responsible for printing the warning. For details on generating customized error messages, see the later section "Printing Information."

Anterior | Inicio | Siguiente
Summary | Subir | Retrieving Arguments


Retrieving Arguments

New parameter parsing API: This chapter documents the new Zend parameter parsing API introduced by Andrei Zmievski. It was introduced in the development stage between PHP 4.0.6 and 4.1.0 .

Parsing parameters is a very common operation and it may get a bit tedious. It would also be nice to have standardized error checking and error messages. Since PHP 4.1.0, there is a way to do just that by using the new parameter parsing API. It greatly simplifies the process of receiving parameteres, but it has a drawback in that it can't be used for functions that expect variable number of parameters. But since the vast majority of functions do not fall into those categories, this parsing API is recommended as the new standard way.

The prototype for parameter parsing function looks like this:
int zend_parse_parameters(int num_args TSRMLS_DC, char *type_spec, ...);
The first argument to this function is supposed to be the number of actual parameters passed to your function, so ZEND_NUM_ARGS() can be used for that. The second parameter should always be TSRMLS_CC macro. The third argument is a string that specifies the number and types of arguments your function is expecting, similar to how printf format string specifies the number and format of the output values it should operate on. And finally the rest of the arguments are pointers to variables which should receive the values from the parameters.

zend_parse_parameters() also performs type conversions whenever possible, so that you always receive the data in the format you asked for. Any type of scalar can be converted to another one, but conversions between complex types (arrays, objects, and resources) and scalar types are not allowed.

If the parameters could be obtained successfully and there were no errors during type conversion, the function will return SUCCESS, otherwise it will return FAILURE. The function will output informative error messages, if the number of received parameters does not match the requested number, or if type conversion could not be performed.

Here are some sample error messages:
Warning - ini_get_all() requires at most 1 parameter, 2 given

Warning - wddx_deserialize() expects parameter 1 to be string, array given
Of course each error message is accompanied by the filename and line number on which it occurs.

Here is the full list of type specifiers:

  • l - long

  • d - double

  • s - string (with possible null bytes) and its length

  • b - boolean

  • r - resource, stored in zval*

  • a - array, stored in zval*

  • o - object (of any class), stored in zval*

  • O - object (of class specified by class entry), stored in zval*

  • z - the actual zval*

The following characters also have a meaning in the specifier string:

  • | - indicates that the remaining parameters are optional. The storage variables corresponding to these parameters should be initialized to default values by the extension, since they will not be touched by the parsing function if the parameters are not passed.

  • / - the parsing function will call SEPARATE_ZVAL_IF_NOT_REF() on the parameter it follows, to provide a copy of the parameter, unless it's a reference.

  • ! - the parameter it follows can be of specified type or NULL (only applies to a, o, O, r, and z). If NULL value is passed by the user, the storage pointer will be set to NULL.

The best way to illustrate the usage of this function is through examples:
/* Gets a long, a string and its length, and a zval. */
long l;
char *s;
int s_len;
zval *param;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC,
                          "lsz", &l, &s, &s_len, &param) == FAILURE) {
    return;
}

* Gets an object of class specified by my_ce, and an optional double. */
zval *obj;
double d = 0.5;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC,
                          "O|d", &obj, my_ce, &d) == FAILURE) {
    return;
}

/* Gets an object or null, and an array.
   If null is passed for object, obj will be set to NULL. */
zval *obj;
zval *arr;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "O!a", &obj, &arr) == FAILURE) {
    return;
}

/* Gets a separated array. */
zval *arr;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "a/", &arr) == FAILURE) {
    return;
}

/* Get only the first three parameters (useful for varargs functions). */
zval *z;
zend_bool b;
zval *r;
if (zend_parse_parameters(3, "zbr!", &z, &b, &r) == FAILURE) {
    return;
}

Note that in the last example we pass 3 for the number of received parameters, instead of ZEND_NUM_ARGS(). What this lets us do is receive the least number of parameters if our function expects a variable number of them. Of course, if you want to operate on the rest of the parameters, you will have to use zend_get_parameters_array_ex() to obtain them.

The parsing function has an extended version that allows for an additional flags argument that controls its actions.
int zend_parse_parameters_ex(int flags, int num_args TSRMLS_DC, char *type_spec, ...);

The only flag you can pass currently is ZEND_PARSE_PARAMS_QUIET, which instructs the function to not output any error messages during its operation. This is useful for functions that expect several sets of completely different arguments, but you will have to output your own error messages.

For example, here is how you would get either a set of three longs or a string:
long l1, l2, l3;
char *s;
if (zend_parse_parameters_ex(ZEND_PARSE_PARAMS_QUIET,
                             ZEND_NUM_ARGS() TSRMLS_CC,
                             "lll", &l1, &l2, &l3) == SUCCESS) {
    /* manipulate longs */
} else if (zend_parse_parameters_ex(ZEND_PARSE_PARAMS_QUIET,
                                    ZEND_NUM_ARGS(), "s", &s, &s_len) == SUCCESS) {
    /* manipulate string */
} else {
    php_error(E_WARNING, "%s() takes either three long values or a string as argument",
              get_active_function_name(TSRMLS_C));
    return;
}

With all the abovementioned ways of receiving function parameters you should have a good handle on this process. For even more example, look through the source code for extensions that are shipped with PHP - they illustrate every conceivable situation.

Anterior | Inicio | Siguiente
Accepting Arguments | Subir | Old way of retrieving arguments (deprecated)


Old way of retrieving arguments (deprecated)

Deprecated parameter parsing API: This API is deprecated and superseded by the new ZEND parameter parsing API.

After having checked the number of arguments, you need to get access to the arguments themselves. This is done with the help of zend_get_parameters_ex():
zval **parameter;

if(zend_get_parameters_ex(1, &parameter) != SUCCESS)
    WRONG_PARAM_COUNT;
All arguments are stored in a zval container, which needs to be pointed to twice. The snippet above tries to retrieve one argument and make it available to us via the parameter pointer.

zend_get_parameters_ex() accepts at least two arguments. The first argument is the number of arguments to retrieve (which should match the number of arguments with which the function has been called; this is why it's important to check for correct call syntax). The second argument (and all following arguments) are pointers to pointers to pointers to zvals. (Confusing, isn't it?) All these pointers are required because Zend works internally with **zval; to adjust a local **zval in our function,zend_get_parameters_ex() requires a pointer to it.

The return value of zend_get_parameters_ex() can either be SUCCESS or FAILURE, indicating (unsurprisingly) success or failure of the argument processing. A failure is most likely related to an incorrect number of arguments being specified, in which case you should exit with WRONG_PARAM_COUNT.

To retrieve more than one argument, you can use a similar snippet:
zval **param1, **param2, **param3, **param4;

if(zend_get_parameters_ex(4, &param1, &param2, &param3, &param4) != SUCCESS)
    WRONG_PARAM_COUNT;

zend_get_parameters_ex() only checks whether you're trying to retrieve too many parameters. If the function is called with five arguments, but you're only retrieving three of them with zend_get_parameters_ex(), you won't get an error but will get the first three parameters instead. Subsequent calls of zend_get_parameters_ex() won't retrieve the remaining arguments, but will get the same arguments again.

Anterior | Inicio | Siguiente
Retrieving Arguments | Subir | Dealing with a Variable Number of Arguments/Optional Parameters


Dealing with a Variable Number of Arguments/Optional Parameters

If your function is meant to accept a variable number of arguments, the snippets just described are sometimes suboptimal solutions. You have to create a line calling zend_get_parameters_ex() for every possible number of arguments, which is often unsatisfying.

For this case, you can use the function zend_get_parameters_array_ex(), which accepts the number of parameters to retrieve and an array in which to store them:
zval **parameter_array[4];

/* get the number of arguments */
argument_count = ZEND_NUM_ARGS();

/* see if it satisfies our minimal request (2 arguments) */
/* and our maximal acceptance (4 arguments) */
if(argument_count < 2 || argument_count > 5)
    WRONG_PARAM_COUNT;

/* argument count is correct, now retrieve arguments */
if(zend_get_parameters_array_ex(argument_count, parameter_array) != SUCCESS)
    WRONG_PARAM_COUNT;
First, the number of arguments is checked to make sure that it's in the accepted range. After that, zend_get_parameters_array_ex() is used to fill parameter_array with valid pointers to the argument values.

A very clever implementation of this can be found in the code handling PHP's fsockopen() located in ext/standard/fsock.c, as shown in Listing 9.7. Don't worry if you don't know all the functions used in this source yet; we'll get to them shortly.

Figura 32-2. Listing 9.7. PHP's implementation of variable arguments in fsockopen().

pval **args[5];
int *sock=emalloc(sizeof(int));
int *sockp;
int arg_count=ARG_COUNT(ht);
int socketd = -1;
unsigned char udp = 0;
struct timeval timeout = { 60, 0 };
unsigned short portno;
unsigned long conv;
char *key = NULL;
FLS_FETCH();

if (arg_count > 5 || arg_count < 2 || zend_get_parameters_array_ex(arg_count,args)==FAILURE) {
    CLOSE_SOCK(1);
    WRONG_PARAM_COUNT;
}

switch(arg_count) {
    case 5:
        convert_to_double_ex(args[4]);
        conv = (unsigned long) (Z_DVAL_P(args[4]) * 1000000.0);
        timeout.tv_sec = conv / 1000000;
        timeout.tv_usec = conv % 1000000;
        /* fall-through */
    case 4:
        if (!PZVAL_IS_REF(*args[3])) {
            php_error(E_WARNING,"error string argument to fsockopen not passed by reference");
        }
        pval_copy_constructor(*args[3]);
        ZVAL_EMPTY_STRING(*args[3]);
        /* fall-through */
    case 3:
        if (!PZVAL_IS_REF(*args[2])) {
            php_error(E_WARNING,"error argument to fsockopen not passed by reference");
            return;
        }
        ZVAL_LONG(*args[2], 0);
        break;
}

convert_to_string_ex(args[0]);
convert_to_long_ex(args[1]);
portno = (unsigned short) Z_LVAL_P(args[1]);

key = emalloc(Z_STRLEN_P(args[0]) + 10);

fsockopen() accepts two, three, four, or five parameters. After the obligatory variable declarations, the function checks for the correct range of arguments. Then it uses a fall-through mechanism in a switch() statement to deal with all arguments. The switch() statement starts with the maximum number of arguments being passed (five). After that, it automatically processes the case of four arguments being passed, then three, by omitting the otherwise obligatory break keyword in all stages. After having processed the last case, it exits the switch() statement and does the minimal argument processing needed if the function is invoked with only two arguments.

This multiple-stage type of processing, similar to a stairway, allows convenient processing of a variable number of arguments.

Anterior | Inicio | Siguiente
Old way of retrieving arguments (deprecated) | Subir | Accessing Arguments


Accessing Arguments

To access arguments, it's necessary for each argument to have a clearly defined type. Again, PHP's extremely dynamic nature introduces some quirks. Because PHP never does any kind of type checking, it's possible for a caller to pass any kind of data to your functions, whether you want it or not. If you expect an integer, for example, the caller might pass an array, and vice versa - PHP simply won't notice.

To work around this, you have to use a set of API functions to force a type conversion on every argument that's being passed (see Table 9.4).

Note: All conversion functions expect a **zval as parameter.

Figura 32-3. Table 9.4. Argument Conversion Functions

Function | Description
convert_to_boolean_ex() | Forces conversion to a Boolean type. Boolean values remain untouched. Longs, doubles, and strings containing 0 as well as NULL values will result in Boolean 0 (FALSE). Arrays and objects are converted based on the number of entries or properties, respectively, that they have. Empty arrays and objects are converted to FALSE; otherwise, to TRUE. All other values result in a Boolean 1 (TRUE).
convert_to_long_ex() | Forces conversion to a long, the default integer type. NULL values, Booleans, resources, and of course longs remain untouched. Doubles are truncated. Strings containing an integer are converted to their corresponding numeric representation, otherwise resulting in 0. Arrays and objects are converted to 0 if empty, 1 otherwise.
convert_to_double_ex() | Forces conversion to a double, the default floating-point type. NULL values, Booleans, resources, longs, and of course doubles remain untouched. Strings containing a number are converted to their corresponding numeric representation, otherwise resulting in 0.0. Arrays and objects are converted to 0.0 if empty, 1.0 otherwise.
convert_to_string_ex() | Forces conversion to a string. Strings remain untouched. NULL values are converted to an empty string. Booleans containing TRUE are converted to "1", otherwise resulting in an empty string. Longs and doubles are converted to their corresponding string representation. Arrays are converted to the string "Array" and objects to the string "Object".
convert_to_array_ex(value) | Forces conversion to an array. Arrays remain untouched. Objects are converted to an array by assigning all their properties to the array table. All property names are used as keys, property contents as values. NULL values are converted to an empty array. All other values are converted to an array that contains the specific source value in the element with the key 0.
convert_to_object_ex(value) | Forces conversion to an object. Objects remain untouched. NULL values are converted to an empty object. Arrays are converted to objects by introducing their keys as properties into the objects and their values as corresponding property contents in the object. All other types result in an object with the property scalar , having the corresponding source value as content.
convert_to_null_ex(value) | Forces the type to become a NULL value, meaning empty.

Nota: You can find a demonstration of the behavior in cross_conversion.php on the accompanying CD-ROM. Figure 9.5 shows the output.

Figura 32-4. Figure 9.5. Cross-conversion behavior of PHP.

Using these functions on your arguments will ensure type safety for all data that's passed to you. If the supplied type doesn't match the required type, PHP forces dummy contents on the resulting value (empty strings, arrays, or objects, 0 for numeric values, FALSE for Booleans) to ensure a defined state.

Following is a quote from the sample module discussed previously, which makes use of the conversion functions:
zval **parameter;

if((ZEND_NUM_ARGS() != 1) || (zend_get_parameters_ex(1, &parameter) != SUCCESS))
{
    WRONG_PARAM_COUNT;
}

convert_to_long_ex(parameter);

RETURN_LONG(Z_LVAL_P(parameter));
After retrieving the parameter pointer, the parameter value is converted to a long (an integer), which also forms the return value of this function. Understanding access to the contents of the value requires a short discussion of the zval type, whose definition is shown in Listing 9.8.

Figura 32-5. Listing 9.8. PHP/Zend zval type definition.

typedef pval zval;

typedef struct _zval_struct zval;

typedef union _zvalue_value {
    long lval;					/* long value */
    double dval;				/* double value */
    struct {
        char *val;
        int len;
    } str;
    HashTable *ht;				/* hash table value */
    struct {
        zend_class_entry *ce;
        HashTable *properties;
    } obj;
} zvalue_value;

struct _zval_struct {
    /* Variable information */
    zvalue_value value;		/* value */
    unsigned char type;	/* active type */
    unsigned char is_ref;
    short refcount;
};

Actually, pval (defined in php.h) is only an alias of zval (defined in zend.h), which in turn refers to _zval_struct. This is a most interesting structure. _zval_struct is the "master" structure, containing the value structure, type, and reference information. The substructure zvalue_value is a union that contains the variable's contents. Depending on the variable's type, you'll have to access different members of this union. For a description of both structures, see Tables 9.5, 9.6, and 9.7.

Figura 32-6. Table 9.5. Zend zval Structure

Entry | Description
value | Union containing this variable's contents. See Table 9.6 for a description.
type | Contains this variable's type. For a list of available types, see Table 9.7.
is_ref | 0 means that this variable is not a reference; 1 means that this variable is a reference to another variable.
refcount | The number of references that exist for this variable. For every new reference to the value stored in this variable, this counter is increased by 1. For every lost reference, this counter is decreased by 1. When the reference counter reaches 0, no references exist to this value anymore, which causes automatic freeing of the value.

Figura 32-7. Table 9.6. Zend zvalue_value Structure

Entry | Description
lval | Use this property if the variable is of the type IS_LONG, IS_BOOLEAN, or IS_RESOURCE.
dval | Use this property if the variable is of the type IS_DOUBLE.
str | This structure can be used to access variables of the type IS_STRING. The member len contains the string length; the member val points to the string itself. Zend uses C strings; thus, the string length contains a trailing 0x00.
ht | This entry points to the variable's hash table entry if the variable is an array.
obj | Use this property if the variable is of the type IS_OBJECT.

Figura 32-8. Table 9.7. Zend Variable Type Constants

Constant | Description
IS_NULL | Denotes a NULL (empty) value.
IS_LONG | A long (integer) value.
IS_DOUBLE | A double (floating point) value.
IS_STRING | A string.
IS_ARRAY | Denotes an array.
IS_OBJECT | An object.
IS_BOOL | A Boolean value.
IS_RESOURCE | A resource (for a discussion of resources, see the appropriate section below).
IS_CONSTANT | A constant (defined) value.

To access a long you access zval.value.lval, to access a double you use zval.value.dval, and so on. Because all values are stored in a union, trying to access data with incorrect union members results in meaningless output.

Accessing arrays and objects is a bit more complicated and is discussed later.

Anterior | Inicio | Siguiente
Dealing with a Variable Number of Arguments/Optional Parameters | Subir | Dealing with Arguments Passed by Reference


Dealing with Arguments Passed by Reference

If your function accepts arguments passed by reference that you intend to modify, you need to take some precautions.

What we didn't say yet is that under the circumstances presented so far, you don't have write access to any zval containers designating function parameters that have been passed to you. Of course, you can change any zval containers that you created within your function, but you mustn't change any zvals that refer to Zend-internal data!

We've only discussed the so-called *_ex() API so far. You may have noticed that the API functions we've used are called zend_get_parameters_ex() instead of zend_get_parameters(), convert_to_long_ex() instead of convert_to_long(), etc. The *_ex() functions form the so-called new "extended" Zend API. They give a minor speed increase over the old API, but as a tradeoff are only meant for providing read-only access.

Because Zend works internally with references, different variables may reference the same value. Write access to a zval container requires this container to contain an isolated value, meaning a value that's not referenced by any other containers. If a zval container were referenced by other containers and you changed the referenced zval, you would automatically change the contents of the other containers referencing this zval (because they'd simply point to the changed value and thus change their own value as well).

zend_get_parameters_ex() doesn't care about this situation, but simply returns a pointer to the desired zval containers, whether they consist of references or not. Its corresponding function in the traditional API, zend_get_parameters(), immediately checks for referenced values. If it finds a reference, it creates a new, isolated zval container; copies the referenced data into this newly allocated space; and then returns a pointer to the new, isolated value.

This action is called zval separation (or pval separation). Because the *_ex() API doesn't perform zval separation, it's considerably faster, while at the same time disabling write access.

To change parameters, however, write access is required. Zend deals with this situation in a special way: Whenever a parameter to a function is passed by reference, it performs automatic zval separation. This means that whenever you're calling a function like this in PHP, Zend will automatically ensure that $parameter is being passed as an isolated value, rendering it to a write-safe state:
my_function(&$parameter);

But this is not the case with regular parameters! All other parameters that are not passed by reference are in a read-only state.

This requires you to make sure that you're really working with a reference - otherwise you might produce unwanted results. To check for a parameter being passed by reference, you can use the macro PZVAL_IS_REF. This macro accepts a zval* to check if it is a reference or not. Examples are given in in Listing 9.6 and Figure 9.9 (see the CD-ROM for the full source).

Figura 32-9. Listing 9.6. Testing for referenced parameter passing.

zval *parameter;

if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "z", &parameter) == FAILURE)
    return;
}

/* check for parameter being passed by reference */
if (!PZVAL_IS_REF(*parameter)) {
{
    zend_error(E_WARNING, "Parameter wasn't passed by reference");
    RETURN_NULL();
}

/* make changes to the parameter */
ZVAL_LONG(*parameter, 10);

Anterior | Inicio | Siguiente
Accessing Arguments | Subir | Assuring Write Safety for Other Parameters


Assuring Write Safety for Other Parameters

You might run into a situation in which you need write access to a parameter that's retrieved with zend_get_parameters_ex() but not passed by reference. For this case, you can use the macro SEPARATE_ZVAL, which does a zval separation on the provided container. The newly generated zval is detached from internal data and has only a local scope, meaning that it can be changed or destroyed without implying global changes in the script context:
zval **parameter;

/* retrieve parameter */
zend_get_parameters_ex(1, &parameter);

/* at this stage, <parameter> still is connected */
/* to Zend's internal data buffers */

/* make <parameter> write-safe */
SEPARATE_ZVAL(parameter);

/* now we can safely modify <parameter> */
/* without implying global changes */
SEPARATE_ZVAL uses emalloc() to allocate the new zval container, which means that even if you don't deallocate this memory yourself, it will be destroyed automatically upon script termination. However, doing a lot of calls to this macro without freeing the resulting containers will clutter up your RAM.

Note: As you can easily work around the lack of write access in the "traditional" API (with zend_get_parameters() and so on), this API seems to be obsolete, and is not discussed further in this chapter.

Anterior | Inicio | Siguiente
Dealing with Arguments Passed by Reference | Subir | Creating Variables


Creating Variables

Manual de PHP
Anterior Siguiente

Capítulo 33. Creating Variables

Tabla de contenidos
Overview
Longs (Integers)
Doubles (Floats)
Strings
Booleans
Arrays
Objects
Resources
Macros for Automatic Global Variable Creation
Creating Constants

When exchanging data from your own extensions with PHP scripts, one of the most important issues is the creation of variables. This section shows you how to deal with the variable types that PHP supports.

Overview

To create new variables that can be seen "from the outside" by the executing script, you need to allocate a new zval container, fill this container with meaningful values, and then introduce it to Zend's internal symbol table. This basic process is common to all variable creations:
zval *new_variable;

/* allocate and initialize new container */
MAKE_STD_ZVAL(new_variable);

/* set type and variable contents here, see the following sections */

/* introduce this variable by the name "new_variable_name" into the symbol table */
ZEND_SET_SYMBOL(EG(active_symbol_table), "new_variable_name", new_variable);

/* the variable is now accessible to the script by using $new_variable_name */
The macro MAKE_STD_ZVAL allocates a new zval container using ALLOC_ZVAL and initializes it using INIT_ZVAL. As implemented in Zend at the time of this writing, initializing means setting the reference count to 1 and clearing the is_ref flag, but this process could be extended later - this is why it's a good idea to keep using MAKE_STD_ZVAL instead of only using ALLOC_ZVAL. If you want to optimize for speed (and you don't have to explicitly initialize the zval container here), you can use ALLOC_ZVAL, but this isn't recommended because it doesn't ensure data integrity.

ZEND_SET_SYMBOL takes care of introducing the new variable to Zend's symbol table. This macro checks whether the value already exists in the symbol table and converts the new symbol to a reference if so (with automatic deallocation of the old zval container). This is the preferred method if speed is not a crucial issue and you'd like to keep memory usage low.

Note that ZEND_SET_SYMBOL makes use of the Zend executor globals via the macro EG. By specifying EG(active_symbol_table), you get access to the currently active symbol table, dealing with the active, local scope. The local scope may differ depending on whether the function was invoked from within a function.

If you need to optimize for speed and don't care about optimal memory usage, you can omit the check for an existing variable with the same value and instead force insertion into the symbol table by using zend_hash_update():
zval *new_variable;

/* allocate and initialize new container */
MAKE_STD_ZVAL(new_variable);

/* set type and variable contents here, see the following sections */

/* introduce this variable by the name "new_variable_name" into the symbol table */
zend_hash_update(
    EG(active_symbol_table),
    "new_variable_name",
    strlen("new_variable_name") + 1,
    &new_variable,
    sizeof(zval *),
    NULL
);
This is actually the standard method used in most modules.

The variables generated with the snippet above will always be of local scope, so they reside in the context in which the function has been called. To create new variables in the global scope, use the same method but refer to another symbol table:
zval *new_variable;

// allocate and initialize new container
MAKE_STD_ZVAL(new_variable);

//
// set type and variable contents here
//

// introduce this variable by the name "new_variable_name" into the global symbol table
ZEND_SET_SYMBOL(&EG(symbol_table), "new_variable_name", new_variable);
The macro ZEND_SET_SYMBOL is now being called with a reference to the main, global symbol table by referring EG(symbol_table).

Note: The active_symbol_table variable is a pointer, but symbol_table is not. This is why you have to use EG(active_symbol_table) and &EG(symbol_table) as parameters to ZEND_SET_SYMBOL - it requires a pointer.

Similarly, to get a more efficient version, you can hardcode the symbol table update:
zval *new_variable;

// allocate and initialize new container
MAKE_STD_ZVAL(new_variable);

//
// set type and variable contents here
//

// introduce this variable by the name "new_variable_name" into the global symbol table
zend_hash_update(
    &EG(symbol_table),
    "new_variable_name",
    strlen("new_variable_name") + 1,
    &new_variable,
    sizeof(zval *),
    NULL
);
Listing 9.10 shows a sample source that creates two variables - local_variable with a local scope and global_variable with a global scope (see Figure 9.7). The full example can be found on the CD-ROM.

Note: You can see that the global variable is actually not accessible from within the function. This is because it's not imported into the local scope using global $global_variable; in the PHP source.

Figura 33-1. Listing 9.10. Creating variables with different scopes.

ZEND_FUNCTION(variable_creation)
{
    zval *new_var1, *new_var2;

    MAKE_STD_ZVAL(new_var1);
    MAKE_STD_ZVAL(new_var2);

    ZVAL_LONG(new_var1, 10);
    ZVAL_LONG(new_var2, 5);

    ZEND_SET_SYMBOL(EG(active_symbol_table), "local_variable", new_var1);
    ZEND_SET_SYMBOL(&EG(symbol_table), "global_variable", new_var2);

    RETURN_NULL();

}

Anterior | Inicio | Siguiente
Assuring Write Safety for Other Parameters | Subir | Longs (Integers)


Longs (Integers)

Now let's get to the assignment of data to variables, starting with longs. Longs are PHP's integers and are very simple to store. Looking at the zval.value container structure discussed earlier in this chapter, you can see that the long data type is directly contained in the union, namely in the lval field. The corresponding type value for longs is IS_LONG (see Listing 9.11).

Figura 33-2. Listing 9.11. Creation of a long.

zval *new_long;

MAKE_STD_ZVAL(new_long);

new_long->type = IS_LONG;
new_long->value.lval = 10;
Alternatively, you can use the macro ZVAL_LONG:
zval *new_long;

MAKE_STD_ZVAL(new_long);
ZVAL_LONG(new_long, 10);

Anterior | Inicio | Siguiente
Creating Variables | Subir | Doubles (Floats)


Doubles (Floats)

Doubles are PHP's floats and are as easy to assign as longs, because their value is also contained directly in the union. The member in the zval.value container is dval; the corresponding type is IS_DOUBLE.
zval *new_double;

MAKE_STD_ZVAL(new_double);

new_double->type = IS_DOUBLE;
new_double->value.dval = 3.45;
Alternatively, you can use the macro ZVAL_DOUBLE:
zval *new_double;

MAKE_STD_ZVAL(new_double);
ZVAL_DOUBLE(new_double, 3.45);

Anterior | Inicio | Siguiente
Longs (Integers) | Subir | Strings


Strings

Strings need slightly more effort. As mentioned earlier, all strings that will be associated with Zend's internal data structures need to be allocated using Zend's own memory-management functions. Referencing of static strings or strings allocated with standard routines is not allowed. To assign strings, you have to access the structure str in the zval.value container. The corresponding type is IS_STRING:
zval *new_string;
char *string_contents = "This is a new string variable";

MAKE_STD_ZVAL(new_string);

new_string->type = IS_STRING;
new_string->value.str.len = strlen(string_contents);
new_string->value.str.val = estrdup(string_contents);
Note the usage of Zend's estrdup() here. Of course, you can also use the predefined macro ZVAL_STRING:
zval *new_string;
char *string_contents = "This is a new string variable";

MAKE_STD_ZVAL(new_string);
ZVAL_STRING(new_string, string_contents, 1);
ZVAL_STRING accepts a third parameter that indicates whether the supplied string contents should be duplicated (using estrdup()). Setting this parameter to 1 causes the string to be duplicated; 0 simply uses the supplied pointer for the variable contents. This is most useful if you want to create a new variable referring to a string that's already allocated in Zend internal memory.

If you want to truncate the string at a certain position or you already know its length, you can use ZVAL_STRINGL(zval, string, length, duplicate), which accepts an explicit string length to be set for the new string. This macro is faster than ZVAL_STRING and also binary-safe.

To create empty strings, set the string length to 0 and use empty_string as contents:
new_string->type = IS_STRING;
new_string->value.str.len = 0;
new_string->value.str.val = empty_string;
Of course, there's a macro for this as well (ZVAL_EMPTY_STRING):
MAKE_STD_ZVAL(new_string);
ZVAL_EMPTY_STRING(new_string);

Anterior | Inicio | Siguiente
Doubles (Floats) | Subir | Booleans


Booleans

Booleans are created just like longs, but have the type IS_BOOL. Allowed values in lval are 0 and 1:
zval *new_bool;

MAKE_STD_ZVAL(new_bool);

new_bool->type = IS_BOOL;
new_bool->value.lval = 1;
The corresponding macros for this type are ZVAL_BOOL (allowing specification of the value) as well as ZVAL_TRUE and ZVAL_FALSE (which explicitly set the value to TRUE and FALSE, respectively).

Anterior | Inicio | Siguiente
Strings | Subir | Arrays


Arrays

Arrays are stored using Zend's internal hash tables, which can be accessed using the zend_hash_*() API. For every array that you want to create, you need a new hash table handle, which will be stored in the ht member of the zval.value container.

There's a whole API solely for the creation of arrays, which is extremely handy. To start a new array, you call array_init().
zval *new_array;

MAKE_STD_ZVAL(new_array);

if(array_init(new_array) != SUCCESS)
{
    // do error handling here
}
If array_init() fails to create a new array, it returns FAILURE.

To add new elements to the array, you can use numerous functions, depending on what you want to do. Tables 9.8, 9.9, and 9.10 describe these functions. All functions return FAILURE on failure and SUCCESS on success.

Figura 33-3. Table 9.8. Zend's API for Associative Arrays

Note: The functions in Table 9.8 all operate on the array "array" with the key "key". The key string doesn't have to reside in Zend internal memory; it will be duplicated by the API.

Function | Description
add_assoc_long(zval *array, char *key, long n);() | Adds an element of type long.
add_assoc_unset(zval *array, char *key);() | Adds an unset element.
add_assoc_bool(zval *array, char *key, int b);() | Adds a Boolean element.
add_assoc_resource(zval *array, char *key, int r);() | Adds a resource to the array.
add_assoc_double(zval *array, char *key, double d);() | Adds a floating-point value.
add_assoc_string(zval *array, char *key, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_assoc_stringl(zval *array, char *key, char *str, uint length, int duplicate);() | Adds a string with the desired length length to the array. Otherwise, behaves like add_assoc_string().

Figura 33-4. Table 9.9. Zend's API for Indexed Arrays, Part 1

Note: The functions in Table 9.9 all operate on the array "array" with the index "idx".
The index is always an integer.

Function | Description
add_index_long(zval *array, uint idx, long n);() | Adds an element of type long.
add_index_unset(zval *array, uint idx);() | Adds an unset element.
add_index_bool(zval *array, uint idx, int b);() | Adds a Boolean element.
add_index_resource(zval *array, uint idx, int r);() | Adds a resource to the array.
add_index_double(zval *array, uint idx, double d);() | Adds a floating-point value.
add_index_string(zval *array, uint idx, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_index_stringl(zval *array, uint idx, char *str, uint length, int duplicate);() | Adds a string with the desired length length to the array. This function is faster and binary-safe. Otherwise, behaves like add_index_string()().

Figura 33-5. Table 9.10. Zend's API for Indexed Arrays, Part 2

Note: The functions in Table 9.10 all operate on the array "array".
These functions automatically generate a new index based on the highest index found in the array.

Function | Description
add_next_index_long(zval *array, long n);() | Adds an element of type long.
add_next_index_unset(zval *array);() | Adds an unset element.
add_next_index_bool(zval *array, int b);() | Adds a Boolean element.
add_next_index_resource(zval *array, int r);() | Adds a resource to the array.
add_next_index_double(zval *array, double d);() | Adds a floating-point value.
add_next_index_string(zval *array, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_next_index_stringl(zval *array, char *str, uint length, int duplicate);() | Adds a string with the desired length length to the array. This function is faster and binary-safe. Otherwise, behaves like add_index_string()().

All these functions provide a handy abstraction to Zend's internal hash API. Of course, you can also use the hash functions directly - for example, if you already have a zval container allocated that you want to insert into an array. This is done using zend_hash_update()() for associative arrays (see Listing 9.12) and zend_hash_index_update() for indexed arrays (see Listing 9.13):

Figura 33-6. Listing 9.12. Adding an element to an associative array.

zval *new_array, *new_element;
char *key = "element_key";

MAKE_STD_ZVAL(new_array);
MAKE_STD_ZVAL(new_element);

if(array_init(new_array) == FAILURE)
{
    // do error handling here
}

ZVAL_LONG(new_element, 10);

if(zend_hash_update(new_array->value.ht, key, strlen(key) + 1, (void *)&new_element, sizeof(zval *), NULL) == FAILURE)
{
    // do error handling here
}

Figura 33-7. Listing 9.13. Adding an element to an indexed array.

zval *new_array, *new_element;
int key = 2;

MAKE_STD_ZVAL(new_array);
MAKE_STD_ZVAL(new_element);

if(array_init(new_array) == FAILURE)
{
    // do error handling here
}

ZVAL_LONG(new_element, 10);

if(zend_hash_index_update(new_array->value.ht, key, (void *)&new_element, sizeof(zval *), NULL) == FAILURE)
{
    // do error handling here
}

To emulate the functionality of add_next_index_*(), you can use this:

zend_hash_next_index_insert(ht, zval **new_element, sizeof(zval *), NULL)

Note: To return arrays from a function, use array_init() and all following actions on the predefined variable return_value (given as argument to your exported function; see the earlier discussion of the call interface). You do not have to use MAKE_STD_ZVAL on this.

Tip: To avoid having to write new_array->value.ht every time, you can use HASH_OF(new_array), which is also recommended for compatibility and style reasons.

Anterior | Inicio | Siguiente
Booleans | Subir | Objects


Objects

Since objects can be converted to arrays (and vice versa), you might have already guessed that they have a lot of similarities to arrays in PHP. Objects are maintained with the same hash functions, but there's a different API for creating them.

To initialize an object, you use the function object_init():
zval *new_object;

MAKE_STD_ZVAL(new_object);

if(object_init(new_object) != SUCCESS)
{
    // do error handling here
}
You can use the functions described in Table 9.11 to add members to your object.

Figura 33-8. Table 9.11. Zend's API for Object Creation

Note: All functions in Table 9.11 work on the object "object" with the key "key". The key forms the member name,
so the resulting member can be accessed via $object->key.

Function | Description
add_property_long(zval *object, char *key, long l);() | Adds a long to the object.
add_property_unset(zval *object, char *key);() | Adds an unset property to the object.
add_property_bool(zval *object, char *key, int b);() | Adds a Boolean to the object.
add_property_resource(zval *object, char *key, long r);() | Adds a resource to the object.
add_property_double(zval *object, char *key, double d);() | Adds a double to the object.
add_property_string(zval *object, char *key, char *str, int duplicate);() | Adds a string to the object.
add_property_stringl(zval *object, char *key, char *str, uint length, int duplicate);() | Adds a string of the specified length to the object. This function is faster than add_property_string() and also binary-safe.
add_property_zval(zval *obect, char *key, zval *container):() | Adds a zval container to the object. This is useful if you have to add properties which aren't simple types like integers or strings but arrays or other objects.

Anterior | Inicio | Siguiente
Arrays | Subir | Resources


Resources

Resources are a special kind of data type in PHP. The term resources doesn't really refer to any special kind of data, but to an abstraction method for maintaining any kind of information. Resources are kept in a special resource list within Zend. Each entry in the list has a correspondending type definition that denotes the kind of resource to which it refers. Zend then internally manages all references to this resource. Access to a resource is never possible directly - only via a provided API. As soon as all references to a specific resource are lost, a corresponding shutdown function is called.

For example, resources are used to store database links and file descriptors. The de facto standard implementation can be found in the MySQL module, but other modules such as the Oracle module also make use of resources.

Nota: In fact, a resource can be a pointer to anything you need to handle in your functions (e.g. pointer to a structure) and the user only has to pass a single resource variable to your function.

To create a new resource you need to register a resource destruction handler for it. Since you can store any kind of data as a resource, Zend needs to know how to free this resource if its not longer needed. This works by registering your own resource destruction handler to Zend which in turn gets called by Zend whenever your resource can be freed (whether manually or automatically). Registering your resource handler within Zend returns you the resource type handle for that resource. This handle is needed whenever you want to access a resource of this type later and is most of time stored in a global static variable within your extension. There is no need to worry about thread safety here because you only register your resource handler once during module initialization.

The Zend function to register your resource handler is defined as:
ZEND_API int zend_register_list_destructors_ex(rsrc_dtor_func_t ld, rsrc_dtor_func_t pld, char *type_name, int module_number);

There are two different kinds of resource destruction handlers you can pass to this function: a handler for normal resources and a handler for persistent resources. Persistent resources are for example used for database connection. When registering a resource, either of these handlers must be given. For the other handler just pass NULL.

zend_register_list_destructors_ex() accepts the following parameters:

ld | Normal resource destruction handler callback
pld | Pesistent resource destruction handler callback
type_name | A string specifying the name of your resource. It's always a good thing to specify an unique name within PHP for the resource type so when the user for example calls var_dump($resource); he also gets the name of the resource.
module_number | The module_number is automatically available in your PHP_MINIT_FUNCTION function and therefore you just pass it over.

The return value is an unique integer ID for your resource type.

The resource destruction handler (either normal or persistent resources) has the following prototype:
void resource_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC);
The passed rsrc is a pointer to the following structure:
typedef struct _zend_rsrc_list_entry {

    void *ptr;
    int type;
    int refcount;

} zend_rsrc_list_entry;
The member void *ptr is the actual pointer to your resource.

Now we know how to start things, we define our own resource we want register within Zend. It is only a simple structure with two integer members:
typedef struct {

    int resource_link;
    int resource_type;

} my_resource;
Our resource destruction handler is probably going to look something like this:
void my_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC) {

    // You most likely cast the void pointer to your structure type

    my_resource *my_rsrc = (my_resource *) rsrc->ptr;

    // Now do whatever needs to be done with you resource. Closing
    // Files, Sockets, freeing additional memory, etc.
    // Also, don't forget to actually free the memory for your resource too!

    do_whatever_needs_to_be_done_with_the_resource(my_rsrc);
}

Nota: One important thing to mention: If your resource is a rather complex structure which also contains pointers to memory you allocated during runtime you have to free them before freeing the resource itself!

Now that we have defined

  1. what our resource is and

  2. our resource destruction handler

we can go on and do the rest of the steps:

  1. create a global variable within the extension holding the resource ID so it can be accessed from every function which needs it

  2. define the resource name

  3. write the resource destruction handler

  4. and finally register the handler

// Somewhere in your extension, define the variable for your registered resources.
    // If you wondered what 'le' stands for: it simply means 'list entry'.
    static int le_myresource;

    // It's nice to define your resource name somewhere
    #define le_myresource_name  "My type of resource"

    [...]

    // Now actually define our resource destruction handler
    void my_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC) {

        my_resource *my_rsrc = (my_resource *) rsrc->ptr;
        do_whatever_needs_to_be_done_with_the_resource(my_rsrc);
    }

    [...]

    PHP_MINIT_FUNCTION(my_extension) {

        // Note that 'module_number' is already provided through the
        // PHP_MINIT_FUNCTION() function definition.

        le_myresource = zend_register_resource_destructors_ex(my_destruction_handler, NULL, le_myresource_name, module_number);

        // You can register additional resources, initialize
        // your global vars, constants, whatever.
    }

To actually register a new resource you use can either use the zend_register_resource() function or the ZEND_REGISTER_RESOURE() macro, both defined in zend_list.h . Although the arguments for both map 1:1 it's a good idea to always use macros to be upwards compatible:
int ZEND_REGISTER_RESOURCE(zval *rsrc_result, void *rsrc_pointer, int rsrc_type);

rsrc_result | This is an already initialized zval * container.
rsrc_pointer | Your resource pointer you want to store.
rsrc_type | The type which you received when you registered the resource destruction handler. If you followed the naming scheme this would be le_myresource.

The return value is an unique integer identifier for that resource.

What is really going on when you register a new resource is it gets inserted in an internal list in Zend and the result is just stored in the given zval * container:
rsrc_id = zend_list_insert(rsrc_pointer, rsrc_type);

    if (rsrc_result) {
        rsrc_result->value.lval = rsrc_id;
        rsrc_result->type = IS_RESOURCE;
    }

    return rsrc_id;
The returned rsrc_id uniquly identifies the newly registered resource. You can use the macro RETURN_RESOURE to return it to the user:
RETURN_RESOURCE(rsrc_id)

Nota: It is common practice that if you want to return the resource immidiately to the user you specify the return_value as the zval * container.

Zend now keeps track of all references to this resource. As soon as all references to the resource are lost, the destructor that you previously registered for this resource is called. The nice thing about this setup is that you don't have to worry about memory leakages introduced by allocations in your module - just register all memory allocations that your calling script will refer to as resources. As soon as the script decides it doesn't need them anymore, Zend will find out and tell you.

Now that the user got his resource, at some point he is passing it back to one of your functions. The value.lval inside the zval * container contains the key to your resource and thus can be used to fetch the resource with the following macro: ZEND_FETCH_RESOURCE:
ZEND_FETCH_RESOURCE(rsrc, rsrc_type, rsrc_id, default_rsrc_id, resource_type_name, resource_type)

rsrc | This is your pointer which will point to your previously registered resource.
rsrc_type | This is the typecast argument for your pointer, e.g. myresource *.
rsrc_id | This is the address of the zval *container the user passed to your function, e.g. &z_resource if zval *z_resource is given.
default_rsrc_id | This integer specifies the default resource ID if no resource could be fetched or -1.
resource_type_name | This is the name of the requested resource. It's a string and is used when the resource can't be found or is invalid to form a meaningful error message.
resource_type | The resource_type you got back when registering the resource destruction handler. In our example this was le_myresource.

This macro has no return value. It is for the developers convenience and takes care of TSRMLS arguments passing and also does check if the resource could be fetched. It throws a warning message and returns the current PHP function with NULL if there was a problem retrieving the resource.

To force removal of a resource from the list, use the function zend_list_delete(). You can also force the reference count to increase if you know that you're creating another reference for a previously allocated value (for example, if you're automatically reusing a default database link). For this case, use the function zend_list_addref(). To search for previously allocated resource entries, use zend_list_find(). The complete API can be found in zend_list.h.

Anterior | Inicio | Siguiente
Objects | Subir | Macros for Automatic Global Variable Creation


Macros for Automatic Global Variable Creation

In addition to the macros discussed earlier, a few macros allow easy creation of simple global variables. These are nice to know in case you want to introduce global flags, for example. This is somewhat bad practice, but Table 9.12 describes macros that do exactly this task. They don't need any zval allocation; you simply have to supply a variable name and value.

Figura 33-9. Table 9.12. Macros for Global Variable Creation

Note: All macros in Table 9.12 create a global variable of the name "name" with the value "value".

Macro | Description
SET_VAR_STRING(name, value) | Creates a new string.
SET_VAR_STRINGL(name, value, length) | Creates a new string of the specified length. This macro is faster than SET_VAR_STRING and also binary-safe.
SET_VAR_LONG(name, value) | Creates a new long.
SET_VAR_DOUBLE(name, value) | Creates a new double.

Anterior | Inicio | Siguiente
Resources | Subir | Creating Constants


Creating Constants

Zend supports the creation of true constants (as opposed to regular variables). Constants are accessed without the typical dollar sign ($) prefix and are available in all scopes. Examples include TRUE and FALSE, to name just two.

To create your own constants, you can use the macros in Table 9.13. All the macros create a constant with the specified name and value.

You can also specify flags for each constant:

  • CONST_CS - This constant's name is to be treated as case sensitive.

  • CONST_PERSISTENT - This constant is persistent and won't be "forgotten" when the current process carrying this constant shuts down.

To use the flags, combine them using a binary OR:
// register a new constant of type "long"
REGISTER_LONG_CONSTANT("NEW_MEANINGFUL_CONSTANT", 324, CONST_CS | CONST_PERSISTENT);
There are two types of macros - REGISTER_*_CONSTANT andREGISTER_MAIN_*_CONSTANT. The first type creates constants bound to the current module. These constants are dumped from the symbol table as soon as the module that registered the constant is unloaded from memory. The second type creates constants that remain in the symbol table independently of the module.

Figura 33-10. Table 9.13. Macros for Creating Constants

Macro | Description
REGISTER_LONG_CONSTANT(name, value, flags) REGISTER_MAIN_LONG_CONSTANT(name, value, flags) | Registers a new constant of type long.
REGISTER_DOUBLE_CONSTANT(name, value, flags) REGISTER_MAIN_DOUBLE_CONSTANT(name, value, flags) | Registers a new constant of type double.
REGISTER_STRING_CONSTANT(name, value, flags) REGISTER_MAIN_STRING_CONSTANT(name, value, flags) | Registers a new constant of type string. The specified string must reside in Zend's internal memory.
REGISTER_STRINGL_CONSTANT(name, value, length, flags) REGISTER_MAIN_STRINGL_CONSTANT(name, value, length, flags) | Registers a new constant of type string. The string length is explicitly set to length. The specified string must reside in Zend's internal memory.

Anterior | Inicio | Siguiente
Macros for Automatic Global Variable Creation | Subir | Duplicating Variable Contents: The Copy Constructor


Duplicating Variable Contents: The Copy Constructor

Manual de PHP
Anterior Siguiente

Capítulo 34. Duplicating Variable Contents: The Copy Constructor

Sooner or later, you may need to assign the contents of one zval container to another. This is easier said than done, since the zval container doesn't contain only type information, but also references to places in Zend's internal data. For example, depending on their size, arrays and objects may be nested with lots of hash table entries. By assigning one zval to another, you avoid duplicating the hash table entries, using only a reference to them (at most).

To copy this complex kind of data, use the copy constructor. Copy constructors are typically defined in languages that support operator overloading, with the express purpose of copying complex types. If you define an object in such a language, you have the possibility of overloading the "=" operator, which is usually responsible for assigning the contents of the lvalue (result of the evaluation of the left side of the operator) to the rvalue (same for the right side).

Overloading means assigning a different meaning to this operator, and is usually used to assign a function call to an operator. Whenever this operator would be used on such an object in a program, this function would be called with the lvalue and rvalue as parameters. Equipped with that information, it can perform the operation it intends the "=" operator to have (usually an extended form of copying).

This same form of "extended copying" is also necessary for PHP's zval containers. Again, in the case of an array, this extended copying would imply re-creation of all hash table entries relating to this array. For strings, proper memory allocation would have to be assured, and so on.

Zend ships with such a function, called zend_copy_ctor() (the previous PHP equivalent was pval_copy_constructor()).

A most useful demonstration is a function that accepts a complex type as argument, modifies it, and then returns the argument:
zval *parameter;

if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "z", &parameter) == FAILURE)
    return;
}

// do modifications to the parameter here

// now we want to return the modified container:
*return_value == *parameter;
zval_copy_ctor(return_value);
The first part of the function is plain-vanilla argument retrieval. After the (left out) modifications, however, it gets interesting: The container of parameter is assigned to the (predefined) return_value container. Now, in order to effectively duplicate its contents, the copy constructor is called. The copy constructor works directly with the supplied argument, and the standard return values are FAILURE on failure and SUCCESS on success.

If you omit the call to the copy constructor in this example, both parameter and return_value would point to the same internal data, meaning that return_value would be an illegal additional reference to the same data structures. Whenever changes occurred in the data that parameter points to, return_value might be affected. Thus, in order to create separate copies, the copy constructor must be used.

The copy constructor's counterpart in the Zend API, the destructor zval_dtor(), does the opposite of the constructor.

Anterior | Inicio | Siguiente
Creating Constants | Subir | Returning Values


Returning Values

Manual de PHP
Anterior Siguiente

Capítulo 35. Returning Values

Returning values from your functions to PHP was described briefly in an earlier section; this section gives the details. Return values are passed via the return_value variable, which is passed to your functions as argument. The return_value argument consists of a zval container (see the earlier discussion of the call interface) that you can freely modify. The container itself is already allocated, so you don't have to run MAKE_STD_ZVAL on it. Instead, you can access its members directly.

To make returning values from functions easier and to prevent hassles with accessing the internal structures of the zval container, a set of predefined macros is available (as usual). These macros automatically set the correspondent type and value, as described in Tables 9.14 and 9.15.

Figura 35-1. Table 9.14. Predefined Macros for Returning Values from a Function

Note: The macros in Table 9.14 automatically return from your function.

Macro | Description
RETURN_RESOURCE(resource) | Returns a resource.
RETURN_BOOL(bool) | Returns a Boolean.
RETURN_NULL() | Returns nothing (a NULL value).
RETURN_LONG(long) | Returns a long.
RETURN_DOUBLE(double) | Returns a double.
RETURN_STRING(string, duplicate) | Returns a string. The duplicate flag indicates whether the string should be duplicated using estrdup().
RETURN_STRINGL(string, length, duplicate) | Returns a string of the specified length; otherwise, behaves like RETURN_STRING. This macro is faster and binary-safe, however.
RETURN_EMPTY_STRING() | Returns an empty string.
RETURN_FALSE | Returns Boolean false.
RETURN_TRUE | Returns Boolean true.

Figura 35-2. Table 9.15. Predefined Macros for Setting the Return Value of a Function

Note: The macros in Table 9.15 only set the return value; they don't return from your function.

Macro | Description
RETVAL_RESOURCE(resource) | Sets the return value to the specified resource.
RETVAL_BOOL(bool) | Sets the return value to the specified Boolean value.
RETVAL_NULL | Sets the return value to NULL.
RETVAL_LONG(long) | Sets the return value to the specified long.
RETVAL_DOUBLE(double) | Sets the return value to the specified double.
RETVAL_STRING(string, duplicate) | Sets the return value to the specified string and duplicates it to Zend internal memory if desired (see also RETURN_STRING).
RETVAL_STRINGL(string, length, duplicate) | Sets the return value to the specified string and forces the length to become length (see also RETVAL_STRING). This macro is faster and binary-safe, and should be used whenever the string length is known.
RETVAL_EMPTY_STRING | Sets the return value to an empty string.
RETVAL_FALSE | Sets the return value to Boolean false.
RETVAL_TRUE | Sets the return value to Boolean true.

Complex types such as arrays and objects can be returned by using array_init() and object_init(), as well as the corresponding hash functions on return_value. Since these types cannot be constructed of trivial information, there are no predefined macros for them.

Anterior | Inicio | Siguiente
Duplicating Variable Contents: The Copy Constructor | Subir | Printing Information


Printing Information

Manual de PHP
Anterior Siguiente

Capítulo 36. Printing Information

Tabla de contenidos
zend_printf()
zend_error()
Including Output in phpinfo()
Execution Information

Often it's necessary to print messages to the output stream from your module, just as print() would be used within a script. PHP offers functions for most generic tasks, such as printing warning messages, generating output for phpinfo(), and so on. The following sections provide more details. Examples of these functions can be found on the CD-ROM.

zend_printf()

zend_printf() works like the standard printf(), except that it prints to Zend's output stream.

Anterior | Inicio | Siguiente
Returning Values | Subir | zend_error()


zend_error

Manual de PHP
Anterior Capítulo 36. Printing Information Siguiente

zend_error()

zend_error() can be used to generate error messages. This function accepts two arguments; the first is the error type (see zend_errors.h), and the second is the error message.
zend_error(E_WARNING, "This function has been called with empty arguments");
Table 9.16 shows a list of possible values (see Figure 9.8). These values are also referred to in php.ini. Depending on which error type you choose, your messages will be logged.

Figura 36-1. Table 9.16. Zend's Predefined Error Messages.

Error | Description
E_ERROR | Signals an error and terminates execution of the script immediately.
E_WARNING | Signals a generic warning. Execution continues.
E_PARSE | Signals a parser error. Execution continues.
E_NOTICE | Signals a notice. Execution continues. Note that by default the display of this type of error messages is turned off in php.ini.
E_CORE_ERROR | Internal error by the core; shouldn't be used by user-written modules.
E_COMPILE_ERROR | Internal error by the compiler; shouldn't be used by user-written modules.
E_COMPILE_WARNING | Internal warning by the compiler; shouldn't be used by user-written modules.

Figura 36-2. Figure 9.8. Display of warning messages in the browser.

Anterior | Inicio | Siguiente
Printing Information | Subir | Including Output in phpinfo()


Including Output in phpinfo

Manual de PHP
Anterior Capítulo 36. Printing Information Siguiente

Including Output in phpinfo()

After creating a real module, you'll want to show information about the module in phpinfo() (in addition to the module name, which appears in the module list by default). PHP allows you to create your own section in the phpinfo() output with the ZEND_MINFO() function. This function should be placed in the module descriptor block (discussed earlier) and is always called whenever a script calls phpinfo().

PHP automatically prints a section in phpinfo() for you if you specify the ZEND_MINFO function, including the module name in the heading. Everything else must be formatted and printed by you.

Typically, you can print an HTML table header using php_info_print_table_start() and then use the standard functions php_info_print_table_header() and php_info_print_table_row(). As arguments, both take the number of columns (as integers) and the column contents (as strings). Listing 9.14 shows a source example; Figure 9.9 shows the output. To print the table footer, use php_info_print_table_end().

Figura 36-3. Listing 9.14. Source code and screenshot for output in phpinfo().

php_info_print_table_start();
php_info_print_table_header(2, "First column", "Second column");
php_info_print_table_row(2, "Entry in first row", "Another entry");
php_info_print_table_row(2, "Just to fill", "another row here");
php_info_print_table_end();

Anterior | Inicio | Siguiente
zend_error() | Subir | Execution Information


Execution Information

You can also print execution information, such as the current file being executed. The name of the function currently being executed can be retrieved using the function get_active_function_name(). This function returns a pointer to the function name and doesn't accept any arguments. To retrieve the name of the file currently being executed, use zend_get_executed_filename(). This function accesses the executor globals, which are passed to it using the ELS_C macro. The executor globals are automatically available to every function that's called directly by Zend (they're part of the INTERNAL_FUNCTION_PARAMETERS described earlier in this chapter). If you want to access the executor globals in another function that doesn't have them available automatically, call the macro ELS_FETCH() once in that function; this will introduce them to your local scope.

Finally, the line number currently being executed can be retrieved using the function zend_get_executed_lineno(). This function also requires the executor globals as arguments. For examples of these functions, see Listing 9.15 and Figure 9.10. Of course, all the examples are also available on the CD-ROM.

Figura 36-4. Listing 9.15. Printing execution information.

zend_printf("The name of the current function is %s<br>", get_active_function_name());
zend_printf("The file currently executed is %s<br>", zend_get_executed_filename(ELS_C));
zend_printf("The current line being executed is %i<br>", zend_get_executed_lineno(ELS_C));

Anterior | Inicio | Siguiente
Including Output in phpinfo() | Subir | Startup and Shutdown Functions


Startup and Shutdown Functions

Manual de PHP
Anterior Siguiente

Capítulo 37. Startup and Shutdown Functions

Startup and shutdown functions can be used for one-time initialization and deinitialization of your modules. As discussed earlier in this chapter (see the description of the Zend module descriptor block), there are global, module, and request startup and shutdown events.

The global startup functions are called once when PHP starts up; similarly, the global shutdown functions are called once when PHP shuts down. Please note that they're really only called once, not when a new Apache process is being created!

The module startup and shutdown functions are called whenever a module is loaded and needs initialization; the request startup and shutdown functions are called every time a request is processed (meaning that a file is being executed).

For dynamic extensions, module and request startup/shutdown events happen at the same time.

Declaration and implementation of these functions can be done with macros; see the earlier section "Declaration of the Zend Module Block" for details.

Anterior | Inicio | Siguiente
Execution Information | Subir | Calling User Functions


Calling User Functions

Manual de PHP
Anterior Siguiente

Capítulo 38. Calling User Functions

You can call user functions from your own modules, which is very handy when implementing callbacks; for example, for array walking, searching, or simply for event-based programs.

User functions can be called with the function call_user_function_ex(). It requires a hash value for the function table you want to access, a pointer to an object (if you want to call a method), the function name, return value, number of arguments, argument array, and a flag indicating whether you want to perform zval separation.
ZEND_API int call_user_function_ex(HashTable *function_table, zval *object,
                                   zval *function_name, zval **retval_ptr_ptr,
                                   int param_count, zval **params[],
                                   int no_separation);
Note that you don't have to specify both function_table and object; either will do. If you want to call a method, you have to supply the object that contains this method, in which case call_user_function()automatically sets the function table to this object's function table. Otherwise, you only need to specify function_table and can set object to NULL.

Usually, the default function table is the "root" function table containing all function entries. This function table is part of the compiler globals and can be accessed using the macro CG. To introduce the compiler globals to your function, call the macro CLS_FETCH once.

The function name is specified in a zval container. This might be a bit surprising at first, but is quite a logical step, since most of the time you'll accept function names as parameters from calling functions within your script, which in turn are contained in zval containers again. Thus, you only have to pass your arguments through to this function. This zval must be of type IS_STRING.

The next argument consists of a pointer to the return value. You don't have to allocate memory for this container; the function will do so by itself. However, you have to destroy this container (using zval_dtor()) afterward!

Next is the parameter count as integer and an array containing all necessary parameters. The last argument specifies whether the function should perform zval separation - this should always be set to 0. If set to 1, the function consumes less memory but fails if any of the parameters need separation.

Listing 9.16 and Figure 9.11 show a small demonstration of calling a user function. The code calls a function that's supplied to it as argument and directly passes this function's return value through as its own return value. Note the use of the constructor and destructor calls at the end - it might not be necessary to do it this way here (since they should be separate values, the assignment might be safe), but this is bulletproof.

Figura 38-1. Listing 9.16. Calling user functions.

zval **function_name;
zval *retval;

if((ZEND_NUM_ARGS() != 1) || (zend_get_parameters_ex(1, &function_name) != SUCCESS))
{
    WRONG_PARAM_COUNT;
}

if((*function_name)->type != IS_STRING)
{
    zend_error(E_ERROR, "Function requires string argument");
}

CLS_FETCH();

if(call_user_function_ex(CG(function_table), NULL, *function_name, &retval, 0, NULL, 0) != SUCCESS)
{
    zend_error(E_ERROR, "Function call failed");
}

zend_printf("We have %i as type<br>", retval->type);

*return_value = *retval;
zval_copy_ctor(return_value);
zval_ptr_dtor();

<?php

dl("call_userland.so");

function test_function()
{

    print("We are in the test function!<br>");

    return("hello");

}

$return_value = call_userland("test_function");

print("Return value: \"$return_value\"<br>");
?>

Anterior | Inicio | Siguiente
Startup and Shutdown Functions | Subir | Initialization File Support


Initialization File Support

Manual de PHP
Anterior Siguiente

Capítulo 39. Initialization File Support

PHP 4 features a redesigned initialization file support. It's now possible to specify default initialization entries directly in your code, read and change these values at runtime, and create message handlers for change notifications.

To create an .ini section in your own module, use the macros PHP_INI_BEGIN() to mark the beginning of such a section and PHP_INI_END() to mark its end. In between you can use PHP_INI_ENTRY() to create entries.
PHP_INI_BEGIN()
    PHP_INI_ENTRY("first_ini_entry",  "has_string_value", PHP_INI_ALL, NULL)
    PHP_INI_ENTRY("second_ini_entry", "2",                PHP_INI_SYSTEM, OnChangeSecond)
    PHP_INI_ENTRY("third_ini_entry",  "xyz",              PHP_INI_USER, NULL)
PHP_INI_END()
The PHP_INI_ENTRY() macro accepts four parameters: the entry name, the entry value, its change permissions, and a pointer to a change-notification handler. Both entry name and value must be specified as strings, regardless of whether they really are strings or integers.

The permissions are grouped into three sections:PHP_INI_SYSTEM allows a change only directly in the php3.ini file; PHP_INI_USER allows a change to be overridden by a user at runtime using additional configuration files, such as .htaccess; and PHP_INI_ALL allows changes to be made without restrictions. There's also a fourth level, PHP_INI_PERDIR, for which we couldn't verify its behavior yet.

The fourth parameter consists of a pointer to a change-notification handler. Whenever one of these initialization entries is changed, this handler is called. Such a handler can be declared using the PHP_INI_MH macro:
PHP_INI_MH(OnChangeSecond);             // handler for ini-entry "second_ini_entry"

// specify ini-entries here

PHP_INI_MH(OnChangeSecond)
{

    zend_printf("Message caught, our ini entry has been changed to %s<br>", new_value);

    return(SUCCESS);

}
The new value is given to the change handler as string in the variable new_value. When looking at the definition of PHP_INI_MH, you actually have a few parameters to use:
#define PHP_INI_MH(name) int name(php_ini_entry *entry, char *new_value,
                                  uint new_value_length, void *mh_arg1,
                                  void *mh_arg2, void *mh_arg3)
All these definitions can be found in php_ini.h. Your message handler will have access to a structure that contains the full entry, the new value, its length, and three optional arguments. These optional arguments can be specified with the additional macros PHP_INI_ENTRY1 (allowing one additional argument), PHP_INI_ENTRY2 (allowing two additional arguments), and PHP_INI_ENTRY3 (allowing three additional arguments).

The change-notification handlers should be used to cache initialization entries locally for faster access or to perform certain tasks that are required if a value changes. For example, if a constant connection to a certain host is required by a module and someone changes the hostname, automatically terminate the old connection and attempt a new one.

Access to initialization entries can also be handled with the macros shown in Table 9.17.

Figura 39-1. Table 9.17. Macros to Access Initialization Entries in PHP

Macro | Description
INI_INT(name) | Returns the current value of entry name as integer (long).
INI_FLT(name) | Returns the current value of entry name as float (double).
INI_STR(name) | Returns the current value of entry name as string. Note: This string is not duplicated, but instead points to internal data. Further access requires duplication to local memory.
INI_BOOL(name) | Returns the current value of entry name as Boolean (defined as zend_bool, which currently means unsigned char).
INI_ORIG_INT(name) | Returns the original value of entry name as integer (long).
INI_ORIG_FLT(name) | Returns the original value of entry name as float (double).
INI_ORIG_STR(name) | Returns the original value of entry name as string. Note: This string is not duplicated, but instead points to internal data. Further access requires duplication to local memory.
INI_ORIG_BOOL(name) | Returns the original value of entry name as Boolean (defined as zend_bool, which currently means unsigned char).

Finally, you have to introduce your initialization entries to PHP. This can be done in the module startup and shutdown functions, using the macros REGISTER_INI_ENTRIES() and UNREGISTER_INI_ENTRIES():
ZEND_MINIT_FUNCTION(mymodule)
{

    REGISTER_INI_ENTRIES();

}

ZEND_MSHUTDOWN_FUNCTION(mymodule)
{

    UNREGISTER_INI_ENTRIES();

}

Anterior | Inicio | Siguiente
Calling User Functions | Subir | Where to Go from Here


Where to Go from Here

Manual de PHP
Anterior Siguiente

Capítulo 40. Where to Go from Here

You've learned a lot about PHP. You now know how to create dynamic loadable modules and statically linked extensions. You've learned how PHP and Zend deal with internal storage of variables and how you can create and access these variables. You know quite a set of tool functions that do a lot of routine tasks such as printing informational texts, automatically introducing variables to the symbol table, and so on.

Even though this chapter often had a mostly "referential" character, we hope that it gave you insight on how to start writing your own extensions. For the sake of space, we had to leave out a lot; we suggest that you take the time to study the header files and some modules (especially the ones in the ext/standard directory and the MySQL module, as these implement commonly known functionality). This will give you an idea of how other people have used the API functions - particularly those that didn't make it into this chapter.

Anterior | Inicio | Siguiente
Initialization File Support | Subir | Reference: Some Configuration Macros


Reference: Some Configuration Macros

Manual de PHP
Anterior Siguiente

Capítulo 41. Reference: Some Configuration Macros

Tabla de contenidos
config.m4

config.m4

The file config.m4 is processed by buildconf and must contain all the instructions to be executed during configuration. For example, these can include tests for required external files, such as header files, libraries, and so on. PHP defines a set of macros that can be used in this process, the most useful of which are described in Table 9.18.

Figura 41-1. Table 9.18. M4 Macros for config.m4

Macro | Description
AC_MSG_CHECKING(message) | Prints a "checking <message>" text during configure.
AC_MSG_RESULT(value) | Gives the result to AC_MSG_CHECKING; should specify either yes or no as value.
AC_MSG_ERROR(message) | Prints message as error message during configure and aborts the script.
AC_DEFINE(name,value,description) | Adds #define to php_config.h with the value of value and a comment that says description (this is useful for conditional compilation of your module).
AC_ADD_INCLUDE(path) | Adds a compiler include path; for example, used if the module needs to add search paths for header files.
AC_ADD_LIBRARY_WITH_PATH(libraryname,librarypath) | Specifies an additional library to link.
AC_ARG_WITH(modulename,description,unconditionaltest,conditionaltest) | Quite a powerful macro, adding the module with description to the configure --help output. PHP checks whether the option --with-<modulename> is given to the configure script. If so, it runs the script unconditionaltest (for example, --with-myext=yes), in which case the value of the option is contained in the variable $withval. Otherwise, it executes conditionaltest.
PHP_EXTENSION(modulename, [shared]) | This macro is a must to call for PHP to configure your extension. You can supply a second argument in addition to your module name, indicating whether you intend compilation as a shared module. This will result in a definition at compile time for your source as COMPILE_DL_<modulename>.

Anterior | Inicio | Siguiente
Where to Go from Here | Subir | API Macros


API Macros

Manual de PHP
Anterior Siguiente

Capítulo 42. API Macros

A set of macros was introduced into Zend's API that simplify access to zval containers (see Table 9.19).

Figura 42-1. Table 9.19. API Macros for Accessing zval Containers

Macro | Refers to
Z_LVAL(zval) | (zval).value.lval
Z_DVAL(zval) | (zval).value.dval
Z_STRVAL(zval) | (zval).value.str.val
Z_STRLEN(zval) | (zval).value.str.len
Z_ARRVAL(zval) | (zval).value.ht
Z_LVAL_P(zval) | (*zval).value.lval
Z_DVAL_P(zval) | (*zval).value.dval
Z_STRVAL_P(zval_p) | (*zval).value.str.val
Z_STRLEN_P(zval_p) | (*zval).value.str.len
Z_ARRVAL_P(zval_p) | (*zval).value.ht
Z_LVAL_PP(zval_pp) | (**zval).value.lval
Z_DVAL_PP(zval_pp) | (**zval).value.dval
Z_STRVAL_PP(zval_pp) | (**zval).value.str.val
Z_STRLEN_PP(zval_pp) | (**zval).value.str.len
Z_ARRVAL_PP(zval_pp) | (**zval).value.ht

Anterior | Inicio | Siguiente
Reference: Some Configuration Macros | Subir | FAQ: Frequently Asked Questions


FAQ: Frequently Asked Questions

Manual de PHP
Anterior Siguiente

VI. FAQ: Frequently Asked Questions

Tabla de contenidos
43. General Information
44. Mailing lists
45. Obtaining PHP
46. Database issues
47. Installation
48. Build Problems
49. Using PHP
50. PHP and HTML
51. PHP and COM
52. PHP and other languages
53. Migrating from PHP 2 to PHP 3
54. Migrating from PHP 3 to PHP 4
55. Miscellaneous Questions

Anterior | Inicio | Siguiente
API Macros |  | General Information


General Information

Manual de PHP
Anterior Siguiente

Capítulo 43. General Information

This section holds the most general questions about PHP: what it is and what it does.

1. What is PHP?
2. What does PHP stand for?
3. What is the relation between the versions?
4. Can I run several versions of PHP at the same time?
5. What are the differences between PHP 3 and PHP 4?
6. I think I found a bug! Who should I tell?

1. What is PHP?

From the preface of the manual:

PHP is an HTML-embedded scripting language. Much of its syntax is borrowed from C, Java and Perl with a couple of unique PHP-specific features thrown in. The goal of the language is to allow web developers to write dynamically generated pages quickly.

A nice introduction to PHP by Stig Sæther Bakken can be found here on the Zend website. Also, much of the PHP Conference Material is freely available.

2. What does PHP stand for?

PHP stands for PHP: Hypertext Preprocessor. This confuses many people because the first word of the acronym is the acronym. This type of acronym is called a recursive acronym. The curious can visit Free On-Line Dictionary of Computing for more information on recursive acronyms.

3. What is the relation between the versions?

PHP/FI 2.0 is an early and no longer supported version of PHP. PHP 3 is the successor to PHP/FI 2.0 and is a lot nicer. PHP 4 is the latest generation of PHP, which uses the Zend engine under the hood.

4. Can I run several versions of PHP at the same time?

Yes. See the INSTALL file that is included in the PHP 4 source distribution. Also, read the related appendix.

5. What are the differences between PHP 3 and PHP 4?

There are a couple of articles written on this by the authors of PHP 4. Here's a list of some of the more important new features:

  • Extended API module

  • Generalized build process under UNIX

  • Generic web server interface that also supports multi-threaded web servers

  • Improved syntax highlighter

  • Native HTTP session support

  • Output buffering support

  • More powerful configuration system

  • Reference counting

Please see the What's new in PHP 4 overview for a detailed explanation of these features and more. If you're migrating from PHP 3 to PHP 4, also read the related appendix.

6. I think I found a bug! Who should I tell?

You should go to the PHP Bug Database and make sure the bug isn't a known bug. If you don't see it in the database, use the reporting form to report the bug. It is important to use the bug database instead of just sending an email to one of the mailing lists because the bug will have a tracking number assigned and it will then be possible for you to go back later and check on the status of the bug. The bug database can be found at http://bugs.php.net/.

Anterior | Inicio | Siguiente
FAQ: Frequently Asked Questions | Subir | Mailing lists


Mailing lists

Manual de PHP
Anterior Siguiente

Capítulo 44. Mailing lists

This section holds questions about how to get in touch with the PHP community. The best way is the mailing lists.

1. Are there any PHP mailing lists?
2. Are there any other communities?
3. Help! I can't seem to subscribe/unsubscribe to/from one of the mailing lists!
4. Is there an archive of the mailing lists anywhere?
5. What can I ask the mailing list?
6. What information should I include when posting to the mailing list?

1. Are there any PHP mailing lists?

Of course! There are many mailing lists for several subjects. A whole list of mailing lists can be found on our Support page.

The most general mailing list is php-general. To subscribe, send mail to php-general-subscribe@lists.php.net. You don't need to include anything special in the subject or body of the message. To unsubscribe, send mail to php-general-unsubscribe@lists.php.net.

You can also subscribe and unsubscribe using the web interface on our Support page.

2. Are there any other communities?

There are countless of them around the world. We have links for example to some IRC servers and foreign language mailing lists on our Support page.

3. Help! I can't seem to subscribe/unsubscribe to/from one of the mailing lists!

If you have problems subscribing to or unsubscribing from the php-general mailing list, it may be because the mailing list software can't figure out the correct mailing address to use. If your email address was joeblow@example.com, you can send your subscription request to php-general-subscribe-joeblow=example.com@lists.php.net, or your unsubscription request to php-general-unsubscribe-joeblow=example.com@lists.php.net. Use similar addresses for the other mailing lists.

4. Is there an archive of the mailing lists anywhere?

Yes, you will find a list of archive sites on the Support page. The mailing list articles are also archived as news messages. You can access the news server at news://news.php.net/ with a news client. There is also an experimental web interface for the news server at http://news.php.net/

5. What can I ask the mailing list?

Since PHP is growing more and more popular by the day the traffic has increased on the php-general mailing list and as of now the list gets about 150 to 200 posts a day. Because of this it is in everyones interest that you use the list as a last resort when you have looked everywhere else.

Before you post to the list please have a look in this FAQ and the manual to see if you can find the help there. If there is nothing to be found there try out the mailing list archives (see above). If you're having problem with installing or configuring PHP please read through all included documentation and README's. If you still can't find any information that helps you out you're more than welcome to use the mailing list.

6. What information should I include when posting to the mailing list?

Posts like "I can't get PHP up and running! Help me! What is wrong?" are of absolutely no use to anyone. If you're having problems getting PHP up and running you must include what operating system you are running on, what version of PHP you're trying to set up, how you got it (pre-compiled, CVS, RPMs and so on), what you have done so far, where you got stuck and the exact error message.

This goes for any other problem as well. You have to include information on what you have done, where you got stuck, what you're trying to do and, if applicable, exact error messages. If you're having problems with your source code you need to include the part of the code that isn't working. Do not include more code than necessary though! It makes the post hard to read and a lot of people might just skip it all together because of this. If you're unsure about how much information to include in the mail it's better that you include to much than to little.

Another important thing to remember is to summarize your problem on the subject line. A subject like "HELP MEEEE!!!" or "What is the problem here?" will be ignored by the majority of the readers.

Anterior | Inicio | Siguiente
General Information | Subir | Obtaining PHP


Obtaining PHP

Manual de PHP
Anterior Siguiente

Capítulo 45. Obtaining PHP

This section has details about PHP download locations, and OS issues.

1. Where can I obtain PHP?
2. Are pre-compiled binary versions available?
3. Where can I get libraries needed to compile some of the optional PHP extensions?
4. How do I get these libraries to work?
5. I got the latest version of the PHP source code from the CVS repository on my Windows machine, what do I need to compile it?
6. Where do I find the Browser Capabilities File?

1. Where can I obtain PHP?

You can download PHP from any of the members of the PHP network of sites. These can be found at http://www.php.net/. You can also use anonymous CVS to get the absolute latest version of the source. For more information, go to http://cvs.php.net/.

2. Are pre-compiled binary versions available?

We only distribute precompiled binaries for Windows systems, as we are not able to compile PHP for every major Linux/Unix platform with every extension combination. Also note, that many Linux distributions come with PHP built in these days. Windows binaries can be downloaded from our Downloads page, for Linux binaries, please visit your distributions website.

3. Where can I get libraries needed to compile some of the optional PHP extensions?

Nota: Those marked with * are not thread-safe libraries, and should not be used with PHP as a server module in the multi-threaded Windows web servers (IIS, Netscape). This does not matter in Unix environments, yet.

  • LDAP (Unix).

  • LDAP* (Unix).

  • LDAP (Unix/Win) : Netscape Directory (LDAP) SDK 1.1.

  • free LDAP server.

  • Berkeley DB2 (Unix/Win) : http://www.sleepycat.com/.

  • SNMP* (Unix): .

  • GD* (Unix/Win).

  • mSQL* (Win).

  • mSQL* (Unix).

  • PostgreSQL (Unix).

  • IMAP* (Win/Unix).

  • Sybase-CT* (Linux, libc5) : Available locally.

  • FreeType (libttf):.

  • ZLib (Unix/Win32).

  • expat XML parser (Unix/Win32).

  • PDFLib.

  • mcrypt.

  • mhash.

  • t1lib.

  • dmalloc.

  • aspell.

  • readline.

4. How do I get these libraries to work?

You will need to follow instructions provided with the library. Some of these libraries are detected automatically when you run the 'configure' script of PHP (such as the GD library), and others you will have to enable using '--with-EXTENSION' options to 'configure'. Run 'configure --help' for a listing of these.

5. I got the latest version of the PHP source code from the CVS repository on my Windows machine, what do I need to compile it?

First, you will need Microsoft Visual C++ v6 (v5 may do it also, but we do it with v6), and you will need some support files. See the manual section about building PHP from source on Windows.

6. Where do I find the Browser Capabilities File?

You can find a browscap.ini file at http://www.cyscape.com/asp/browscap/.

Anterior | Inicio | Siguiente
Mailing lists | Subir | Database issues


Database issues

Manual de PHP
Anterior Siguiente

Capítulo 46. Database issues

This section holds common questions about relation between PHP and databases. Yes, PHP can access virtually any database available today.

1. I heard it's possible to access Microsoft SQL Server from PHP. How?
2. Can I access Microsoft Access databases?
3. I upgraded to PHP 4, and now mysql keeps telling me "Warning: MySQL: Unable to save result set in ...". What's up?
4. After installing shared MySQL support, Apache dumps core as soon as libphp4.so is loaded. Can this be fixed?
5. Why do I get an error that looks something like this: "Warning: 0 is not a MySQL result index in <file> on line <x>" or "Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>?

1. I heard it's possible to access Microsoft SQL Server from PHP. How?

On Windows machines, you can simply use the included ODBC support and the correct ODBC driver.

On Unix machines, you can use the Sybase-CT driver to access Microsoft SQL Servers because they are (at least mostly) protocol-compatible. Sybase has made a free version of the necessary libraries for Linux systems. For other Unix operating systems, you need to contact Sybase for the correct libraries. Also see the answer to the next question.

2. Can I access Microsoft Access databases?

Yes. You already have all the tools you need if you are running entirely under Windows 9x/Me, or NT/2000, where you can use ODBC and Microsoft's ODBC drivers for Microsoft Access databases.

If you are running PHP on a Unix box and want to talk to MS Access on a Windows box you will need Unix ODBC drivers. OpenLink Software has Unix-based ODBC drivers that can do this. There is a free pilot program where you can download an evaluation copy that doesn't expire and prices start at $675 for the commercial supported version.

Another alternative is to use an SQL server that has Windows ODBC drivers and use that to store the data, which you can then access from Microsoft Access (using ODBC) and PHP (using the built in drivers), or to use an intermediary file format that Access and PHP both understand, such as flat files or dBase databases. On this point Tim Hayes from OpenLink software writes:
Using another database as an intermediary is not a good idea, when you can
      use ODBC from PHP straight to your database - i.e. with OpenLink's drivers. If
      you do need to use an intermediary file format, OpenLink have now released
      Virtuoso (a virtual database engine) for NT, Linux and other unix platforms.
      Please visit our website for a free download.

One option that has proven successful is to use MySQL and its MyODBC drivers on Windows and synchronizing the databases. Steve Lawrence writes:

  • Install MySQL on your platform according to instructions with MySQL. Latest available from www.mysql.com (get it from your mirror!). No special configuration required except when you set up a database, and configure the user account, you should put % in the host field, or the host name of the Windows computer you wish to access MySQL with. Make a note of your server name, username, and password.

  • Download the MyODBC for Windows driver from the MySQL site. Latest release is myodbc-2_50_19-win95.zip (NT available too, as well as source code). Install it on your Windows machine. You can test the operation with the utilities included with this program.

  • Create a user or system dsn in your ODBC administrator, located in the control panel. Make up a dsn name, enter your hostname, user name, password, port, etc for you MySQL database configured in step 1.

  • Install Access with a full install, this makes sure you get the proper add-ins.. at the least you will need ODBC support and the linked table manager.

  • Now the fun part! Create a new access database. In the table window right click and select Link Tables, or under the file menu option, select Get External Data and then Link Tables. When the file browser box comes up, select files of type: ODBC. Select System dsn and the name of your dsn created in step 3. Select the table to link, press OK, and presto! You can now open the table and add/delete/edit data on your MySQL server! You can also build queries, import/export tables to MySQL, build forms and reports, etc.

Tips and Tricks:

  • You can construct your tables in access and export them to MySQL, then link them back in. That makes table creation quick.

  • When creating tables in access, you must have a primary key defined in order to have write access to the table in access. Make sure you create a primary key in MySQL before linking in access

  • If you change a table in MySQL, you have to re-link it in Access. Go to tools>add-ins>linked table manager, cruise to your ODBC DSN, and select the table to re-link from there. you can also move your dsn source around there, just hit the always prompt for new location checkbox before pressing OK.

3. I upgraded to PHP 4, and now mysql keeps telling me "Warning: MySQL: Unable to save result set in ...". What's up?

Most likely what has happened is, PHP 4 was compiled with the '--with-mysql' option, without specifying the path to MySQL. This means PHP is using its built-in MySQL client library. If your system is running applications, such as PHP 3 as a concurrent Apache module, or auth-mysql, that use other versions of MySQL clients, then there is a conflict between the two differing versions of those clients.

Recompiling PHP 4, and adding the path to MySQL to the flag, '--with-mysql=/your/path/to/mysql' usually solves the problem.

4. After installing shared MySQL support, Apache dumps core as soon as libphp4.so is loaded. Can this be fixed?

If your MySQL libs are linked against pthreads this will happen. Check using ldd. If they are, grab the MySQL tarball and compile from source, or recompile from the source rpm and remove the switch in the spec file that turns on the threaded client code. Either of these suggestions will fix this. Then recompile PHP with the new MySQL libs.

5. Why do I get an error that looks something like this: "Warning: 0 is not a MySQL result index in <file> on line <x>" or "Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>?

You are trying to use a result identifier that is 0. The 0 indicates that your query failed for some reason. You need to check for errors after submitting a query and before you attempt to use the returned result identifier. The proper way to do this is with code similar to the following:
$result = mysql_query("SELECT * FROM tables_priv");
if (!$result) {
    echo mysql_error();
    exit;
}
or
$result = mysql_query("SELECT * FROM tables_priv")
    or die("Bad query: ".mysql_error());

Anterior | Inicio | Siguiente
Obtaining PHP | Subir | Installation


Installation

Manual de PHP
Anterior Siguiente

Capítulo 47. Installation

This section holds common questions about the way to install PHP. PHP is available for almost any OS (except maybe for MacOS before OSX), and almost any web server.

To install PHP, follow the instructions in the INSTALL file located in the distribution. Windows users should also read the install.txt file. There are also some helpful hints for Windows users here.

1. Unix/Windows: Where should my php.ini file be located?
2. Unix: I installed PHP, but every time I load a document, I get the message 'Document Contains No Data'! What's going on here?
3. Unix: I installed PHP using RPMS, but Apache isn't processing the PHP pages! What's going on here?
4. Unix: I installed PHP 3 using RPMS, but it doesn't compile with the database support I need! What's going on here?
5. Unix: I patched Apache with the FrontPage extensions patch, and suddenly PHP stopped working. Is PHP incompatible with the Apache FrontPage extensions?
6. Unix/Windows: I have installed PHP, but when I try to access a PHP script file via my browser, I get a blank screen.
7. Unix/Windows: I have installed PHP, but when try to access a PHP script file via my browser, I get a server 500 error.
8. Some operating systems: I have installed PHP without errors, but when I try to start apache I get undefined symbol errors:
[mybox:user /src/php4] root# apachectl configtest
 apachectl: /usr/local/apache/bin/httpd Undefined symbols:
  _compress
  _uncompress
9. Windows: I have installed PHP, but when I to access a PHP script file via my browser, I get the error:
cgi error:
 The specified CGI application misbehaved by not
 returning a complete set of HTTP headers.
 The headers it did return are:
10. Windows: I've followed all the instructions, but still can't get PHP and IIS to work together!

1. Unix/Windows: Where should my php.ini file be located?

By default on UNIX it should be in /usr/local/lib. Most people will want to change this at compile-time with the --with-config-file-path flag. You would, for example, set it with something like:
--with-config-file-path=/etc
And then you would copy php.ini-dist from the distribution to /etc/php.ini and edit it to make any local changes you want.

On Windows the default path for the php.ini file is the Windows directory.

2. Unix: I installed PHP, but every time I load a document, I get the message 'Document Contains No Data'! What's going on here?

This probably means that PHP is having some sort of problem and is core-dumping. Look in your server error log to see if this is the case, and then try to reproduce the problem with a small test case. If you know how to use 'gdb', it is very helpful when you can provide a backtrace with your bug report to help the developers pinpoint the problem. If you are using PHP as an Apache module try something like:

  • Stop your httpd processes

  • gdb httpd

  • Stop your httpd processes

  • > run -X -f /path/to/httpd.conf

  • Then fetch the URL causing the problem with your browser

  • > run -X -f /path/to/httpd.conf

  • If you are getting a core dump, gdb should inform you of this now

  • type: bt

  • You should include your backtrace in your bug report. This should be submitted to http://bugs.php.net/

If your script uses the regular expression functions (ereg() and friends), you should make sure that you compiled PHP and Apache with the same regular expression package. This should happen automatically with PHP and Apache 1.3.x

3. Unix: I installed PHP using RPMS, but Apache isn't processing the PHP pages! What's going on here?

Assuming you installed both Apache and PHP from RPM packages, you need to uncomment or add some or all of the following lines in your http.conf file:
# Extra Modules
AddModule mod_php.c
AddModule mod_php3.c
AddModule mod_perl.c

# Extra Modules
LoadModule php_module         modules/mod_php.so
LoadModule php3_module        modules/libphp3.so     /* for PHP 3 */
LoadModule php4_module        modules/libphp4.so     /* for PHP 4 */
LoadModule perl_module        modules/libperl.so
And add:
AddType application/x-httpd-php3 .php3    /* for PHP 3 */
AddType application/x-httpd-php .php      /* for PHP 4 */
... to the global properties, or to the properties of the VirtualDomain you want to have PHP support added to.

4. Unix: I installed PHP 3 using RPMS, but it doesn't compile with the database support I need! What's going on here?

Due to the way PHP 3 built, it is not easy to build a complete flexible PHP RPM. This issue is addressed in PHP 4. For PHP 3, we currently suggest you use the mechanism described in the INSTALL.REDHAT file in the PHP distribution. If you insist on using an RPM version of PHP 3, read on...

The RPM packagers are setting up the RPMS to install without database support to simplify installations and because RPMS use /usr/ instead of the standard /usr/local/ directory for files. You need to tell the RPM spec file which databases to support and the location of the top-level of your database server.

This example will explain the process of adding support for the popular MySQL database server, using the mod installation for Apache.

Of course all of this information can be adjusted for any database server that PHP supports. We will assume you installed MySQL and Apache completely with RPMS for this example as well.

  • First remove mod_php3 :
    rpm -e mod_php3

  • Then get the source rpm and INSTALL it, NOT --rebuild
    rpm -Uvh mod_php3-3.0.5-2.src.rpm

  • Then edit the /usr/src/redhat/SPECS/mod_php3.spec file

    In the %build section add the database support you want, and the path.

    For MySQL you would add
    --with-mysql=/usr \
    The %build section will look something like this:
    ./configure --prefix=/usr \
    --with-apxs=/usr/sbin/apxs \
    --with-config-file-path=/usr/lib \
    --enable-debug=no \
    --enable-safe-mode \
    --with-exec-dir=/usr/bin \
    --with-mysql=/usr \
    --with-system-regex

  • Once this modification is made then build the binary rpm as follows:
    rpm -bb /usr/src/redhat/SPECS/mod_php3.spec

  • Then install the rpm
    rpm -ivh /usr/src/redhat/RPMS/i386/mod_php3-3.0.5-2.i386.rpm

Make sure you restart Apache, and you now have PHP 3 with MySQL support using RPM's. Note that it is probably much easier to just build from the distribution tarball of PHP 3 and follow the instructions in INSTALL.REDHAT found in that distribution.

5. Unix: I patched Apache with the FrontPage extensions patch, and suddenly PHP stopped working. Is PHP incompatible with the Apache FrontPage extensions?

No, PHP works fine with the FrontPage extensions. The problem is that the FrontPage patch modifies several Apache structures, that PHP relies on. Recompiling PHP (using 'make clean ; make') after the FP patch is applied would solve the problem.

6. Unix/Windows: I have installed PHP, but when I try to access a PHP script file via my browser, I get a blank screen.

Do a 'view source' in the web browser and you will probably find that you can see the source code of your PHP script. This means that the web server did not send the script to PHP for interpretation. Something is wrong with the server configuration - double check the server configuration against the PHP installation instructions.

7. Unix/Windows: I have installed PHP, but when try to access a PHP script file via my browser, I get a server 500 error.

Something went wrong when the server tried to run PHP. To get to see a sensible error message, from the command line, change to the directory containing the PHP executable (php.exe on Windows) and run php -i. If PHP has any problems running, then a suitable error message will be displayed which will give you a clue as to what needs to be done next. If you get a screen full of html codes (the output of the phpinfo() function) then PHP is working, and your problem may be related to your server configuration which you should double check.

8. Some operating systems: I have installed PHP without errors, but when I try to start apache I get undefined symbol errors:
[mybox:user /src/php4] root# apachectl configtest
 apachectl: /usr/local/apache/bin/httpd Undefined symbols:
  _compress
  _uncompress

This has actually nothing to do with PHP, but with the MySQL client libraries. Some need --with-zlib, others do not. This is also covered in the MySQL FAQ.

9. Windows: I have installed PHP, but when I to access a PHP script file via my browser, I get the error:
cgi error:
 The specified CGI application misbehaved by not
 returning a complete set of HTTP headers.
 The headers it did return are:

This error message means that PHP failed to output anything at all. To get to see a sensible error message, from the command line, change to the directory containing the PHP executable (php.exe on Windows) and run php -i. If PHP has any problems running, then a suitable error message will be displayed which will give you a clue as to what needs to be done next. If you get a screen full of html codes (the output of the phpinfo() function) then PHP is working.

Once PHP is working at the command line, try accessing the script via the browser again. If it still fails then it could be one of the following:

  • File permissions on your PHP script, php.exe, php4ts.dll, php.ini or any PHP extensions you are trying to load are such that the anonymous internet user ISUR_<machinename> cannot access them.

  • The script file does not exist (or possibly isn't where you think it is relative to your web root directory). Note that for IIS you can trap this error by ticking the 'check file exists' box when setting up the script mappings in the Internet Services Manager. If a script file does not exist then the server will return a 404 error instead. There is also the additional benefit that IIS will do any authentication required for you based on the NTLanMan permissions on your script file.

10. Windows: I've followed all the instructions, but still can't get PHP and IIS to work together!

Make sure any user who needs to run a PHP script has the rights to run php.exe! IIS uses an anonymous user which is added at the time IIS is installed. This user needs rights to php.exe. Also, any authenticated user will also need rights to execute php.exe. And for IIS4 you need to tell it that PHP is a script engine.

Anterior | Inicio | Siguiente
Database issues | Subir | Build Problems


Build Problems

Manual de PHP
Anterior Siguiente

Capítulo 48. Build Problems

This section gathers most common errors that occur at build time.

1. I got the latest version of PHP using the anonymous CVS service, but there's no configure script!
2. I'm having problems configuring PHP to work with Apache. It says it can't find httpd.h, but it's right where I said it is!
3. When I run configure, it says that it can't find the include files or library for GD, gdbm, or some other package!
4. When it is compiling the file language-parser.tab.c, it gives me errors that say 'yytname undeclared'.
5. When I run 'make', it seems to run fine but then fails when it tries to link the final application complaining that it can't find some files.
6. When linking PHP, it complains about a number of undefined references.
7. I can't figure out how to build PHP with Apache 1.3.
8. I have followed all the steps to install the Apache module version on UNIX, and my PHP scripts show up in my browser or I am being asked to save the file.
9. It says to use: --activate-module=src/modules/php4/libphp4.a, but that file doesn't exist, so I changed it to --activate-module=src/modules/php4/libmodphp4.a and it doesn't work!? What's going on?
10. When I try to build Apache with PHP as a static module using --activate-module=src/modules/php4/libphp4.a it tells me that my compiler is not ANSI compliant.
11. When I try to build PHP using --with-apxs I get strange error messages.
12. During 'make', I get errors in microtime, and a lot of 'RUSAGE_' stuff.
13. I want to upgrade my PHP. Where can I find the ./configure line that was used to build my current PHP installation?

1. I got the latest version of PHP using the anonymous CVS service, but there's no configure script!

You have to have the GNU autoconf package installed so you can generate the configure script from configure.in. Just run ./buildconf in the top-level directory after getting the sources from the CVS server. (Also, unless you run configure with the --enable-maintainer-mode option, the configure script will not automatically get rebuilt when the configure.in file is updated, so you should make sure to do that manually when you notice configure.in has changed. One symptom of this is finding things like @VARIABLE@ in your Makefile after configure or config.status is run.)

2. I'm having problems configuring PHP to work with Apache. It says it can't find httpd.h, but it's right where I said it is!

You need to tell the configure/setup script the location of the top-level of your Apache source tree. This means that you want to specify '--with-apache=/path/to/apache' and not '--with-apache=/path/to/apache/src'.

3. When I run configure, it says that it can't find the include files or library for GD, gdbm, or some other package!

You can make the configure script looks for header files and libraries in non-standard locations by specifying additional flags to pass to the C preprocessor and linker, such as:
CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure
If you're using a csh-variant for your login shell (why?), it would be:
env CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure

4. When it is compiling the file language-parser.tab.c, it gives me errors that say 'yytname undeclared'.

You need to update your version of Bison. You can find the latest version at ftp://ftp.gnu.org/pub/gnu/bison/.

5. When I run 'make', it seems to run fine but then fails when it tries to link the final application complaining that it can't find some files.

Some old versions of make that don't correctly put the compiled versions of the files in the functions directory into that same directory. Try running "cp *.o functions" and then re-running 'make' to see if that helps. If it does, you should really upgrade to a recent version of GNU make.

6. When linking PHP, it complains about a number of undefined references.

Take a look at the link line and make sure that all of the appropriate libraries are being included at the end. Common ones that you might have missed are '-ldl' and any libraries required for any database support you included.

If you're linking with Apache 1.2.x, did you remember to add the appropriate information to the EXTRA_LIBS line of the Configuration file and re-rerun Apache's Configure script? See the INSTALL file that comes with the distribution for more information.

Some people have also reported that they had to add '-ldl' immediately following 'libphp4.a' when linking with Apache.

7. I can't figure out how to build PHP with Apache 1.3.

This is actually quite easy. Follow these steps carefully:

  • Grab the latest Apache 1.3 distribution from http://www.apache.org/dist/.

  • Ungzip and untar it somewhere, for example /usr/local/src/apache-1.3.

  • Compile PHP by first running ./configure --with-apache=/<path>/apache-1.3 (substitute <path> for the actual path to your apache-1.3 directory.

  • Type 'make' followed by 'make install' to build PHP and copy the necessary files to the Apache distribution tree.

  • Change directories into to your /<path>/apache-1.3/src directory and edit the Configuration file. Add to the file: AddModule modules/php4/libphp4.a.

  • Type: './Configure' followed by 'make'.

  • You should now have a PHP-enabled httpd binary!

Note: : You can also use the new Apache ./configure script. See the instructions in the README.configure file which is part of your Apache distribution. Also have a look at the INSTALL file in the PHP distribution.

8. I have followed all the steps to install the Apache module version on UNIX, and my PHP scripts show up in my browser or I am being asked to save the file.

This means that the PHP module is not getting invoked for some reason. Three things to check before asking for further help:

  • Make sure that the httpd binary you are running is the actual new httpd binary you just built. To do this, try running: /path/to/binary/httpd -l

    If you don't see mod_php4.c listed then you are not running the right binary. Find and install the correct binary.

  • Make sure you have added the correct Mime Type to one of your Apache .conf files. It should be: AddType application/x-httpd-php3 .php3 (for PHP 3)

    or AddType application/x-httpd-php .php (for PHP 4)

    Also make sure that this AddType line is not hidden away inside a <Virtualhost> or <Directory> block which would prevent it from applying to the location of your test script.

  • Finally, the default location of the Apache configuration files changed between Apache 1.2 and Apache 1.3. You should check to make sure that the configuration file you are adding the AddType line to is actually being read. You can put an obvious syntax error into your httpd.conf file or some other obvious change that will tell you if the file is being read correctly.

9. It says to use: --activate-module=src/modules/php4/libphp4.a, but that file doesn't exist, so I changed it to --activate-module=src/modules/php4/libmodphp4.a and it doesn't work!? What's going on?

Note that the libphp4.a file is not supposed to exist. The apache process will create it!

10. When I try to build Apache with PHP as a static module using --activate-module=src/modules/php4/libphp4.a it tells me that my compiler is not ANSI compliant.

This is a misleading error message from Apache that has been fixed in more recent versions.

11. When I try to build PHP using --with-apxs I get strange error messages.

There are three things to check here. First, for some reason when Apache builds the apxs Perl script, it sometimes ends up getting built without the proper compiler and flags variables. Find your apxs script (try the command 'which apxs', it's sometimes found in /usr/local/apache/bin/apxs or /usr/sbin/apxs. Open it and check for lines similar to these:
my $CFG_CFLAGS_SHLIB  = ' ';          # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = ' ';          # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = ' ';          # substituted via Makefile.tmpl
If this is what you see, you have found your problem. They may contain just spaces or other incorrect values, such as 'q()'. Change these lines to say:
my $CFG_CFLAGS_SHLIB  = '-fpic -DSHARED_MODULE'; # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = 'gcc';             # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(-shared);        # substituted via Makefile.tmpl
The second possible problem should only be an issue on Red Hat 6.1 and 6.2. The apxs script Red Hat ships is broken. Look for this line:
my $CFG_LIBEXECDIR    = 'modules';         # substituted via APACI install
If you see the above line, change it to this:
my $CFG_LIBEXECDIR    = '/usr/lib/apache'; # substituted via APACI install
Last, if you reconfigure/reinstall Apache, add a 'make clean' to the process after './configure' and before 'make'.

12. During 'make', I get errors in microtime, and a lot of 'RUSAGE_' stuff.

During the 'make' portion of installation, if you encounter problems that look similar to this:
microtime.c: In function `php_if_getrusage':
    microtime.c:94: storage size of `usg' isn't known
    microtime.c:97: `RUSAGE_SELF' undeclared (first use in this function)
    microtime.c:97: (Each undeclared identifier is reported only once
    microtime.c:97: for each function it appears in.)
    microtime.c:103: `RUSAGE_CHILDREN' undeclared (first use in this function)
    make[3]: *** [microtime.lo] Error 1
    make[3]: Leaving directory `/home/master/php-4.0.1/ext/standard'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/master/php-4.0.1/ext/standard'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/master/php-4.0.1/ext'
    make: *** [all-recursive] Error 1

Your system is broken. You need to fix your /usr/include files by installing a glibc-devel package that matches your glibc. This has absolutely nothing to do with PHP. To prove this to yourself, try this simple test:
$ cat >test.c <<X
    #include <sys/resource.h>
    X
    $ gcc -E test.c >/dev/null
If that spews out errors, you know your include files are messed up.

13. I want to upgrade my PHP. Where can I find the ./configure line that was used to build my current PHP installation?

Either you look at config.nice file, in the source tree of your current PHP installation or, if this is not available, you simply run a

      script. On top of the output the ./configure line, that was used
      to build this PHP installation is shown.

Anterior | Inicio | Siguiente
Installation | Subir | Using PHP


Using PHP

Manual de PHP
Anterior Siguiente

Capítulo 49. Using PHP

This section gathers most common errors you can face, while writing PHP scripts.

1. I would like to write a generic PHP script that can handle data coming from any form. How do I know which POST method variables are available?
2. I need to convert all single-quotes (') to a backslash followed by a single-quote. How can I do this with a regular expression?
3. When I do the following, the output is printed in the wrong order:
function myfunc($argument)
{
    echo $argument + 10;
}
$variable = 10;
echo "myfunc($variable) = " . myfunc($variable);
what's going on?
4. Hey, what happened to my newlines?
<pre>
<?php echo "This should be the first line."; ?>
<?php echo "This should show up after the new line above."; ?>
</pre>
5. I get the message 'Warning: Cannot send session cookie - headers already sent...' or 'Cannot add header information - headers already sent...'.
6. I need to access information in the request header directly. How can I do this?
7. When I try to use authentication with IIS I get 'No Input file specified'.
8. My PHP script works on IE and Lynx, but on Netscape some of my output is missing. When I do a "View Source" I see the content in IE but not in Netscape.
9. How am I supposed to mix XML and PHP? It complains about my <?xml> tags!
10. How can I use PHP with FrontPage or some other HTML editor that insists on moving my code around?
11. Where can I find a complete list of pre-set variables available to me, and why are these not documented in the PHP documentation?
12. I'm trying to access one of the standard CGI variables (such as $DOCUMENT_ROOT or $HTTP_REFERER) in a user-defined function, and it can't seem to find it. What's wrong?

1. I would like to write a generic PHP script that can handle data coming from any form. How do I know which POST method variables are available?

Make sure that the track_vars feature is enabled in your php.ini file. Since PHP 4.0.3, this feature is always on. When track_vars is on, it creates some associative arrays, the most important here is: $HTTP_POST_VARS. So, to write a generic script to handle POST method variables you would need something similar to the following:
foreach ($HTTP_POST_VARS as $var => $value) {
    echo "$var = $value<br>\n";
}

2. I need to convert all single-quotes (') to a backslash followed by a single-quote. How can I do this with a regular expression?

First off, take a look at the addslashes() function. It will do exactly what you want. You should also have a look at the magic_quotes_gpc directive in your php.ini file.

3. When I do the following, the output is printed in the wrong order:
function myfunc($argument)
{
    echo $argument + 10;
}
$variable = 10;
echo "myfunc($variable) = " . myfunc($variable);
what's going on?

To be able to use the results of your function in an expression (such as concatenating it with other strings in the example above), you need to return the value, not echo() it.

4. Hey, what happened to my newlines?
<pre>
<?php echo "This should be the first line."; ?>
<?php echo "This should show up after the new line above."; ?>
</pre>

In PHP, the ending for a block of code is either "?>" or "?>\n" (where \n means a newline). So in the example above, the echoed sentences will be on one line, because PHP omits the newlines after the block ending. This means that you need to insert an extra newline after each block of PHP code to make it print out one newline.

Why does PHP do this? Because when formatting normal HTML, this usually makes your life easier because you don't want that newline, but you'd have to create extremely long lines or otherwise make the raw page source unreadable to achieve that effect.

5. I get the message 'Warning: Cannot send session cookie - headers already sent...' or 'Cannot add header information - headers already sent...'.

The functions header(), set_cookie() and the session functions need to add headers to the output stream. Headers can only be sent before all other content. function will do this if you are running PHP as an Apache module. So, the following bit of code will show you all the request headers:
$headers = getallheaders();
foreach ($headers as $name => $content) {
    echo "headers[$name] = $content<br>\n";
}

6. I need to access information in the request header directly. How can I do this?

The getallheaders() function will do this if you are running PHP as an Apache module. So, the following bit of code will show you all the request headers:
$headers = getallheaders();
foreach ($headers as $name => $content) {
    echo "headers[$name] = $content<br>\n";
}

7. When I try to use authentication with IIS I get 'No Input file specified'.

The security model of IIS is at fault here. This is a problem common to all CGI programs running under IIS. A workaround is to create a plain HTML file (not parsed by PHP) as the entry page into an authenticated directory. Then use a META tag to redirect to the PHP page, or have a link to the PHP page. PHP will then recognize the authentication correctly. With the ISAPI module, this is not a problem. This should not effect other NT web servers. For more information, see: http://support.microsoft.com/support/kb/articles/q160/4/22.asp.

8. My PHP script works on IE and Lynx, but on Netscape some of my output is missing. When I do a "View Source" I see the content in IE but not in Netscape.

Netscape is more strict regarding html tags (such as tables) then IE. Running your html output through a html validator, such as validator.w3.org, might be helpful. For example, a missing </table> might cause this.

Also, both IE and Lynx ignore any NULs (\0) in the HTML stream, Netscape does not. The best way to check for this is to compile the command line version of PHP (also known as the CGI version) and run your script from the command line. In *nix, pipe it through od -c and look for any \0 characters. If you are on Windows you need to find an editor or some other program that lets you look at binary files. When Netscape sees a NUL in a file it will typically not output anything else on that line whereas both IE and Lynx will.

9. How am I supposed to mix XML and PHP? It complains about my <?xml> tags!

You need to turn off the short tags by setting short_tags to 0 in your php.ini file, or by using the appropriate Apache directive. You could even use a <File> section to do this selectively.

10. How can I use PHP with FrontPage or some other HTML editor that insists on moving my code around?

One of the easiest things to do is to enable using ASP tags in your PHP code. This allows you to use the ASP-style <% and %> code delimiters. Some of the popular HTML editors handle those more intelligently (for now). To enable the ASP-style tags, you need to set the asp_tags php.ini variable, or use the appropriate Apache directive.

11. Where can I find a complete list of pre-set variables available to me, and why are these not documented in the PHP documentation?

The best way is to stick a <?php phpinfo(); ?> part on a page and load it up. This will show you all sorts of information about your PHP setup, including a list of both environment variables and also special variables set by your web server. This list can't really be documented in the PHP documentation because it will change from one server to another.

12. I'm trying to access one of the standard CGI variables (such as $DOCUMENT_ROOT or $HTTP_REFERER) in a user-defined function, and it can't seem to find it. What's wrong?

Environment variables are normal global variables, so you must either declare them as global variables in your function (by using "global $DOCUMENT_ROOT;", for example) or by using the global variable array (ie, "$GLOBALS["DOCUMENT_ROOT"]".

Anterior | Inicio | Siguiente
Build Problems | Subir | PHP and HTML


PHP and HTML

Manual de PHP
Anterior Siguiente

Capítulo 50. PHP and HTML

PHP and HTML interact a lot: PHP generate HTML, and HTML has informations that will be sent to PHP.

1. What encodings/decodings do I need when I pass a value on via a form? And via an URL?
2. I'm trying to use an <input type="image"> tag, but the $foo.x and $foo.y variables aren't available. Where are they?
3. How do I create arrays in a HTML <form>?
4. How do I get all the results from a select multiple HTML tag?

1. What encodings/decodings do I need when I pass a value on via a form? And via an URL?

There are several stages for which encoding is important. Assuming that you have a string $data, which contains the string you want to pass on in a non-encoded way, these are the relevant stages:

  • HTML interpretation. In order to specify a random string, you must include it in double quotes, and htmlspecialchars the the whole value.

  • URL: A URL consists of several parts. If you want your data to be interpreted as one item, you must encode it with urlencode().

Ejemplo 50-1. A hidden HTML form element

<?php
    echo "<input type=hidden value=\"" . htmlspecialchars($data) . "\">\n";
?>

Nota: It is wrong to urlencode() $data, because it's the browsers responsibility to urlencode() the data. All popular browsers do that correctly. Note that this will happen regardless of the method (i.e., GET or POST). You'll only notice this in case of GET request though, because POST requests are usually hidden.

Ejemplo 50-2. Data to be edited by the user

<?php
    echo "<textarea name=mydata>\n";
    echo htmlspecialchars($data)."\n";
    echo "</textarea>";
?>

Nota: The data is shown in the browser as intended, because the browser will interpret the html escaped symbols.

Upon submitting, either via GET or POST, the data will be urlencoded by the browser for transferring, and directly urldecoded by PHP. So in the end, you don't need to do any urlencoding/urldecoding yourself, everything is handled automagically.

Ejemplo 50-3. In an URL

<?php
    echo "<a href=\"" . htmlspecialchars("/nextpage.php?stage=23&data=" .
        urlencode($data)) . "\">\n";
?>

Nota: In fact you are faking a HTML GET request, therefore it's necessary to manually urlencode() the data.

Nota: You need to htmlspecialchars() the whole URL, because the URL occurs as value of an HTML-attribute. In this case, the browser will first un-htmlspecialchars() the value, and then pass the URL on. PHP will understand the URL correctly, because you urlencoded() the data.

You'll notice that the & in the URL is replaced by &amp;. Although most browsers will recover if you forget this, this isn't always possible. So even if your URL is not dynamic, you need to htmlspecialchars() the URL.

2. I'm trying to use an <input type="image"> tag, but the $foo.x and $foo.y variables aren't available. Where are they?

When submitting a form, it is possible to use an image instead of the standard submit button with a tag like:
<input type="image" src="image.gif" name="foo">
When the user clicks somewhere on the image, the accompanying form will be transmitted to the server with two additional variables: foo.x and foo.y.

Because $foo.x and $foo.y are invalid variable names in PHP, they are automagically converted to $foo_x and $foo_y. That is, the periods are replaced with underscores.

3. How do I create arrays in a HTML <form>?

To get your <form> result sent as an array to your PHP script you name the <input>, <select> or <textarea> elements like this:
<input name="MyArray[]">
<input name="MyArray[]">
<input name="MyArray[]">
<input name="MyArray[]">
Notice the square brackets after the variable name, that's what makes it an array. You can group the elements into different arrays by assigning the same name to different elements:
<input name="MyArray[]">
<input name="MyArray[]">
<input name="MyOtherArray[]">
<input name="MyOtherArray[]">
This produces two arrays, MyArray and MyOtherArray, that gets sent to the PHP script. It's also possible to assign specific keys to your arrays:
<input name="AnotherArray[]">
<input name="AnotherArray[]">
<input name="AnotherArray[email]">
<input name="AnotherArray[phone]">
The AnotherArray array will now contain the keys 0, 1, email and phone.

Nota: Specifying an arrays key is optional in HTML. If you do not specify the keys, the array gets filled in the order the elements appear in the form. Our first example will contain keys 0, 1, 2 and 3.

See also Array Functions and Variables from outside PHP.

4. How do I get all the results from a select multiple HTML tag?

The select multiple tag in an HTML construct allows users to select multiple items from a list. These items are then passed to the action handler for the form. The problem is that they are all passed with the same widget name. ie.
<select name="var" multiple>
Each selected option will arrive at the action handler as:
var=option1
var=option2
var=option3
Each option will overwrite the contents of the previous $var variable. The solution is to use PHP's "array from form element" feature. The following should be used:
<select name="var[]" multiple>
This tells PHP to treat $var as an array and each assignment of a value to var[] adds an item to the array. The first item becomes $var[0], the next $var[1], etc. The count() function can be used to determine how many options were selected, and the sort() function can be used to sort the option array if necessary.

Note that if you are using JavaScript the [] on the element name might cause you problems when you try to refer to the element by name. Use it's numerical form element id instead, or enclose the variable name in single quotes and use that as the index to the elements array, for example:
variable = documents.forms[0].elements['var[]'];

Anterior | Inicio | Siguiente
Using PHP | Subir | PHP and COM


PHP and COM

Manual de PHP
Anterior Siguiente

Capítulo 51. PHP and COM

PHP can be used to access COM and DCOM objects on Win32 platforms.

1. I have built a DLL to calculate something. Is there any way to run this DLL under PHP ?
2. What does 'Unsupported variant type: xxxx (0xxxxx)' mean ?
3. Is it possible manipulate visual objects in PHP ?
4. Can I store a COM object in a session ?
5. How can I trap COM errors ?
6. Can I generate DLL files from PHP scripts like i can in Perl ?
7. What does 'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}' mean ?
8. How can I run COM object from remote server ?
9. I get 'DCOM is disabled in C:\path...\scriptname.php on line 6', what can I do ?
10. Is it possible to load/manipulate an ActiveX object in a page with PHP ?
11. Is it possible to get a running instance of a component ?
12. Is there a way to handle an event sent from COM object ?
13. I'm having problems when trying to invoke a method of a COM object which exposes more than one interface. What can I do ?
14. So PHP works with COM, how about COM+ ?
15. If PHP can manipulate COM objects, can we imagine to use MTS to manage components resources, in conjunction with PHP ?

1. I have built a DLL to calculate something. Is there any way to run this DLL under PHP ?

If this is a simple DLL there is no way yet to run it from PHP. If the DLL contains a COM server you may be able to access it if it implements the IDispatch interface.

2. What does 'Unsupported variant type: xxxx (0xxxxx)' mean ?

There are dozens of VARIANT types and combinations of them. Most of them are already supported but a few still have to be implemented. Arrays are not completely supported. Only single dimensional indexed only arrays can be passed between PHP and COM. If you find other types that aren't supported, please report them as a bug (if not already reported) and provide as much information as available.

3. Is it possible manipulate visual objects in PHP ?

Generally it is, but as PHP is mostly used as a web scripting language it runs in the web servers context, thus visual objects will never appear on the servers desktop. If you use PHP for application scripting e.g. in conjunction with PHP-GTK there is no limitation in accessing and manipulating visual objects through COM.

4. Can I store a COM object in a session ?

No, you can't. COM instances are treated as resources and therefore they are only available in a single script's context.

5. How can I trap COM errors ?

Currently it's not possible to trap COM errors beside the ways provided by PHP itself (@, track_errors, ..), but we are thinking of a way to implement this.

6. Can I generate DLL files from PHP scripts like i can in Perl ?

No, unfortunately there is no such tool available for PHP.

7. What does 'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}' mean ?

This error can have multiple reasons:

  • the CLSID is wrong

  • the requested DLL is missing

  • the requested component doesn't implement the IDispatch interface

8. How can I run COM object from remote server ?

Exactly like you run local objects. You only have to pass the IP of the remote machine as second parameter to the COM constructor.

Make sure that you have set com.allow_dcom=true in your php.ini.

9. I get 'DCOM is disabled in C:\path...\scriptname.php on line 6', what can I do ?

Edit your php.ini and set com.allow_dcom=true.

10. Is it possible to load/manipulate an ActiveX object in a page with PHP ?

This has nothing to do with PHP. ActiveX objects are loaded on client side if they are requested by the HTML document. There is no relation to the PHP script and therefore there is no direct server side interaction possible.

11. Is it possible to get a running instance of a component ?

This is possible with the help of monikers. If you want to get multiple references to the same word instance you can create that instance like shown:

$word = new COM("C:\docs\word.doc");

This will create a new instance if there is no running instance available or it will return a handle to the running instance, if available.

12. Is there a way to handle an event sent from COM object ?

Not yet.

13. I'm having problems when trying to invoke a method of a COM object which exposes more than one interface. What can I do ?

The answer is as simple as unsatisfying. I don't know exactly but i think you can do nothing. If someone has specific information about this, please let me know :)

14. So PHP works with COM, how about COM+ ?

COM+ extends COM by a framework for managing components through MTS and MSMQ but there is nothing special that PHP has to support to use such components.

15. If PHP can manipulate COM objects, can we imagine to use MTS to manage components resources, in conjunction with PHP ?

PHP itself doesn't handle transactions yet. Thus if an error occurs no rollback is initiated. If you use components that support transactions you will have to implement the transaction management yourself.

Anterior | Inicio | Siguiente
PHP and HTML | Subir | PHP and other languages


PHP and other languages

Manual de PHP
Anterior Siguiente

Capítulo 52. PHP and other languages

PHP is the best language for web programing, but what about other languages?

1. PHP vs. ASP?
2. Is there an ASP to PHP converter?
3. PHP vs. Cold Fusion?
4. PHP vs. Perl?

1. PHP vs. ASP?

ASP is not really a language in itself, it's an acronym for Active Server Pages, the actual language used to program ASP with is Visual Basic Script or JScript. The biggest drawback of ASP is that it's a proprietary system that is natively used only on Microsoft Internet Information Server (IIS). This limits it's availability to Win32 based servers. There are a couple of projects in the works that allows ASP to run in other environments and webservers: InstantASP from Halcyon (commercial), Chili!Soft ASP from Chili!Soft (commercial) and OpenASP from ActiveScripting.org (free). ASP is said to be a slower and more cumbersome language than PHP, less stable as well. Some of the pros of ASP is that since it primarily uses VBScript it's relatively easy to pick up the language if you're already know how to program in Visual Basic. ASP support is also enabled by default in the IIS server making it easy to get up and running. The components built in ASP are really limited, so if you need to use "advanced" features like interacting with FTP servers, you need to buy additional components.

2. Is there an ASP to PHP converter?

Yes, asp2php is the one most often referred to.

3. PHP vs. Cold Fusion?

PHP is commonly said to be faster and more efficient for complex programming tasks and trying out new ideas. PHP is generally referred to as more stable and less resource intensive as well. Cold Fusion has better error handling, database abstraction and date parsing although database abstraction is addressed in PHP 4. Another thing that is listed as one of Cold Fusion's strengths is its excellent search engine, but it has been mentioned that a search engine is not something that should be included in a web scripting language. PHP runs on almost every platform there is; Cold Fusion is only available on Win32, Solaris, Linux and HP/UX. Cold Fusion has a good IDE and is generally easier to get started with, whereas PHP initially requires more programming knowledge. Cold Fusion is designed with non-programmers in mind, while PHP is focused on programmers.

A great summary by Michael J Sheldon on this topic has been posted to the PHP mailing list. A copy can be found here.

4. PHP vs. Perl?

The biggest advantage of PHP over Perl is that PHP was designed for scripting for the web where Perl was designed to do a lot more and can because of this get very complicated. The flexibility / complexity of Perl makes it easier to write code that another author / coder has a hard time reading. PHP has a less confusing and stricter format without losing flexibility. PHP is easier to integrate into existing HTML than Perl. PHP has pretty much all the 'good' functionality of Perl: constructs, syntax and so on, without making it as complicated as Perl can be. Perl is a very tried and true language, it's been around since the late eighties, but PHP is maturing very quickly.

Anterior | Inicio | Siguiente
PHP and COM | Subir | Migrating from PHP 2 to PHP 3


Migrating from PHP 2 to PHP 3

Manual de PHP
Anterior Siguiente

Capítulo 53. Migrating from PHP 2 to PHP 3

PHP has already a long history behind him: Legendary PHP 1.0, PHP/FI, PHP 3.0 and PHP 4.0.

1. Migrating from PHP 2 to PHP 3?

1. Migrating from PHP 2 to PHP 3?

PHP/FI 2.0 is no longer supported. Please see appropriate manual section for information about migration from PHP/FI 2.0.

If you are still working with PHP 2, we strongly recommend you to upgrade straight to PHP 4.

Anterior | Inicio | Siguiente
PHP and other languages | Subir | Migrating from PHP 3 to PHP 4


Migrating from PHP 3 to PHP 4

Manual de PHP
Anterior Siguiente

Capítulo 54. Migrating from PHP 3 to PHP 4

PHP has already a long history behind him : Legendary PHP 1.0, PHP/FI, PHP 3.0 and PHP 4.0.

1. Migrating from PHP3 to PHP4
2. Incompatible functions?

1. Migrating from PHP3 to PHP4

PHP 4 was designed to be as compatible with earlier versions of PHP as possible and very little functionality was broken in the process. If you're really unsure about compatibility you should install PHP 4 in a test environment and run your scripts there.

Also see the appropriate migration appendix of this manual.

2. Incompatible functions?

Since PHP 4 is basically a rewrite of the entire PHP engine there was very few functions that were altered and only then some of the more exotic ones.

Anterior | Inicio | Siguiente
Migrating from PHP 2 to PHP 3 | Subir | Miscellaneous Questions


Miscellaneous Questions

Manual de PHP
Anterior Siguiente

Capítulo 55. Miscellaneous Questions

There can be some questions we can't put into other categories. Here you can find them.

1. Where did the pop-ups go on the website? Can I have the code for that?
2. How can I handle the bz2 compressed manuals on Windows?

1. Where did the pop-ups go on the website? Can I have the code for that?

The yellow pop-up windows on the old site were pretty cool, but were very difficult to maintain (since some companies seem to enjoy changing the way their browsers work with every new release).

All the code for previous versions of the website is still available through CVS. Specifically, the last version of shared.inc (that had all the Javascript and DHTML to do the popups) is available here.

2. How can I handle the bz2 compressed manuals on Windows?

If you don't have an archiver-tool to handle bz2 files download the commandline tool from Redhat (please find further information below).

If you would not like to use a command line tool, you can try free tools like Stuffit Expander, UltimateZip, 7-Zip, or Quick Zip. If you have tools like WinRAR or Power Archiver, you can easily decompress the bz2 files with it. If you use Windows Commander, a bz2 plugin for that program is available freely from the Windows Commander site.

The bzip2 commandline tool from Redhat:

Win2k Sp2 users grab the latest version 1.0.2, all other Windows user should grab version 1.00. After downloading rename the executable to bzip2.exe. For convenience put it into a directory in your path, e.g. C:\Windows where C represents your windows installation drive.

Note: lang stands for your language and x for the desired format, e.g.: pdf. To uncompress the php_manual_lang.x.bz2 follow these simple instructions:

  • open a command prompt window

  • cd to the folder where you stored the downloaded php_manual_lang.x.bz2

  • invoke bzip2 -d php_manual_lang.x.bz2, extracting php_manual_lang.x in the same folder

In case you downloaded the php_manual_lang.tar.bz2 with many html-files in it, the procedure is the same. The only difference is that you got a file php_manual_lang.tar. The tar format is known to be treated with most common archivers on Windows like e.g. WinZip.

Anterior | Inicio | Siguiente
Migrating from PHP 3 to PHP 4 | Subir | Apéndices


Apéndices

Manual de PHP
Anterior Siguiente

VII. Apéndices

Tabla de contenidos
A. Using PHP from the command line
B. Migrating from PHP 3 to PHP 4
C. Migrando de PHP/FI 2.0 a PHP 3.0
D. El debugger de PHP
E. Desarrollo en PHP
F. List of Function Aliases
G. List of Reserved Words
H. List of Resource Types
I. About the manual
Function Index
J. missing stuff

Anterior | Inicio | Siguiente
Miscellaneous Questions |  | Using PHP from the command line


Using PHP from the command line

Manual de PHP
Anterior Siguiente

Apéndice A. Using PHP from the command line

The command line options of the PHP executable are useful if you would like to debug or test your PHP setup, but they can also be handy, if you would like to use PHP for a different purpose than web scripting.

Note, that you can always direct the output of the PHP executable to an external file with the > character, so php -q test.php > test.html will print out the output of test.php without HTTP headers to the test.html file in the same directory.

You can only use these command line options if you have the PHP executable. If you built the server module version, and you have no CGI version available on your machine, than you have no chance to use these options. For Windows users both the PHP executable and the server modules are in the binary package, the executable is named php.exe.

This list of command line options is consistent with PHP 4.0.6. You can get the actual list and some one line descriptions with the -h option. The output of php -h should be something like this:
Usage: php [-q] [-h] [-s [-v] [-i] [-f <file>] |  {<file> [args...]}
  -q             Quiet-mode.  Suppress HTTP Header output.
  -s             Display colour syntax highlighted source.
  -f <file>      Parse <file>.  Implies `-q'
  -v             Version number
  -C             Do not chdir to the script's directory
  -c <path>      Look for php.ini file in this directory
  -d foo[=bar]   Define INI entry foo with value 'bar'
  -e             Generate extended information for debugger/profiler
  -z <file>      Load Zend extension <file>.
  -l             Syntax check only (lint)
  -m             Show compiled in modules
  -i             PHP information
  -h             This help

Here we list some of the most important command line options with detailed explanations.

Tabla A-1. Command line options

Option | Description
-q | Suppress HTTP headers output. Normally PHP prints out HTTP headers for the calling program (ie. webserver) to hand on to the browser. When writing command line applications these headers are useless.
-s | Display the color highlighted source of the file given with its name. This is the same as if you were printing out the source using the highlight_file() function in a PHP script.
-f | Parse the file given, and search for syntactical and fatal errors. This option implies -q. Use for debugging purposes.
-v | By calling PHP with this option, you can ask it to print out its version number, ie: 4.0.6.
-C | Normally PHP changes the working directory to the running scripts directory. This makes it possible for example, to open files in the same directory, with only specifying the name of the file. If you would like to disable this directory change, use this option.
-c | Using this option, you can specify an alternative php.ini path, so PHP will search your configurations file in this path instead of the default one.
-d | With this option, you can set individual php.ini settings in the time of running a script.
-l | Check the file given for syntax errors. This option implies -q. Use for debugging purposes. This option won't find fatal errors (like undefined functions). Use -f if you would like to test for fatal errors too.
-m | Using this option, PHP prints out the built in (and loaded) PHP and Zend modules, the PHP and Zend version numbers, and a short Zend copyright notice.
-i | This command line option calls phpinfo(), and prints out the results. If PHP is not working well, it is advisable to make a php -i and see if any error messages are printed out before or in place of the information tables.
-h | With this option, you can get information about the actual list of command line options and some one line descriptions about what they do.

The PHP executable can be used to run PHP scripts absolutely independent from the web server. If you are on a Unix system, you should add a special first line to your PHP script, and make it executable, so the system will know, what program should run the script. On a Windows platform you can associate php.exe -q with the double click option of the .php files, or you can make a batch file to run the script through PHP. The first line added to the script to work on Unix won't hurt on Windows, so you can write cross platform programs this way. A simple example of writing a command line PHP program can be found below.

Ejemplo A-1. Script intended to be run from command line (script.php)

#!/usr/bin/php -q
<?php

if ($argc != 2 || in_array($argv[1], array('--help', '-help', '-h', '-?'))) {
?>

This is a command line PHP script with one option.

  Usage:
  <?php echo $argv[0]; ?> <option>

  <option> can be some word you would like
  to print out. With the --help, -help, -h,
  or -? options, you can get this help.

<?php
} else {
    echo $argv[1];
}
?>

In the script above, we used the special first line to indicate, that this file should be run by PHP and should not print out HTTP headers. There are two variables you can use while writing command line applications with PHP: $argc and $argv. The first is the number of arguments plus one (the name of the script running). The second is an array containing the arguments, starting with the script name as number zero ($argv[0]).

In the program above we checked if there are less or more than one arguments. Also if the argument was --help, -help, -h or -?, we printed out the help message, printing the script name dynamically. If we received some other argument we echoed that out.

If you would like to run the above script on Unix, you need to make it executable, and simply call it as script.php echothis or script.php -h. On Windows, you can make a batch file for this task:

Ejemplo A-2. Batch file to run a command line PHP script (script.bat)

@c:\php\php.exe -q script.php %1 %2 %3 %4

Assuming, you named the above program as script.php, and you have your php.exe in c:\php\php.exe this batch file will run it for you with your added options: script.bat echothis or script.bat -h.

See also the Readline extension documentation for more functions you can use to enhance your command line applications in PHP.

Anterior | Inicio | Siguiente
Apéndices | Subir | Migrating from PHP 3 to PHP 4


Migrating from PHP 3 to PHP 4

Manual de PHP
Anterior Siguiente

Apéndice B. Migrating from PHP 3 to PHP 4

Tabla de contenidos
What has changed in PHP 4
Running PHP 3 and PHP 4 concurrently
Migrating Configuration Files
Parser behavior
Error reporting
Initializers
empty("0")
Missing functions
PHP 3 extension
Variable substitution in strings
Cookies
Handling of global variables

What has changed in PHP 4

PHP 4 and the integrated Zend engine have greatly improved PHP's performance and capabilities, but great care has been taken to break as little existing code as possible. So migrating your code from PHP 3 to 4 should be much easier than migrating from PHP/FI 2 to PHP 3. A lot of existing PHP 3 code should be ready to run without changes, but you should still know about the few differences and take care to test your code before switching versions in production environments. The following should give you some hints about what to look for.

Anterior | Inicio | Siguiente
Using PHP from the command line | Subir | Running PHP 3 and PHP 4 concurrently


Running PHP 3 and PHP 4 concurrently

Recent operating systems provide the ability to perform versioning and scoping. This features make it possible to let PHP 3 and PHP 4 run as concurrent modules in one Apache server.

This feature is known to work on the following platforms:

  • Linux with recent binutils (binutils 2.9.1.0.25 tested)

  • Solaris 2.5 or better

  • FreeBSD (3.2, 4.0 tested)

To enable it, configure PHP3 and PHP4 to use APXS (--with-apxs) and the necessary link extensions (--enable-versioning). Otherwise, all standard installations instructions apply. For example:

$ ./configure \
  --with-apxs=/apache/bin/apxs \
  --enable-versioning \
  --with-mysql \
  --enable-track-vars

Anterior | Inicio | Siguiente
Migrating from PHP 3 to PHP 4 | Subir | Migrating Configuration Files


Migrating Configuration Files

The global configuration file, php3.ini, has changed its name to php.ini.

For the Apache configuration file, there are slightly more changes. The MIME types recognized by the PHP module have changed.

application/x-httpd-php3        -->    application/x-httpd-php
application/x-httpd-php3-source -->    application/x-httpd-php-source

You can make your configuration files work with both versions of PHP (depending on which one is currently compiled into the server), using the following syntax:

AddType  application/x-httpd-php3        .php3
AddType  application/x-httpd-php3-source .php3s

AddType  application/x-httpd-php         .php
AddType  application/x-httpd-php-source  .phps

In addition, the PHP directive names for Apache have changed.

Starting with PHP 4.0, there are only four Apache directives that relate to PHP:

php_value [PHP directive name] [value]
php_flag [PHP directive name] [On|Off]
php_admin_value [PHP directive name] [value]
php_admin_flag [PHP directive name] [On|Off]

There are two differences between the Admin values and the non admin values:

  • Admin values (or flags) can only appear in the server-wide apache configuration files (e.g., httpd.conf).

  • Standard values (or flags) cannot control certain PHP directives, for example - safe mode (if you could override safe mode settings in .htaccess files, it would defeat safe-mode's purpose). In contrast, Admin values can modify the value of any PHP directive.

To make the transition process easier, PHP 4 is bundled with scripts that automatically convert your Apache configuration and .htaccess files to work with both PHP 3 and PHP 4. These scripts do NOT convert the mime type lines! You have to convert these yourself.

To convert your Apache configuration files, run the apconf-conv.sh script (available in the scripts/apache/ directory). For example:

~/php4/scripts/apache:#  ./apconf-conv.sh /usr/local/apache/conf/httpd.conf

Your original configuration file will be saved in httpd.conf.orig.

To convert your .htaccess files, run the aphtaccess-conv.sh script (available in the scripts/apache/ directory as well):

~/php4/scripts/apache:#  find / -name .htaccess -exec ./aphtaccess-conv.sh {} \;

Likewise, your old .htaccess files will be saved with an .orig prefix.

The conversion scripts require awk to be installed.

Anterior | Inicio | Siguiente
Running PHP 3 and PHP 4 concurrently | Subir | Parser behavior


Parser behavior

Parsing and execution are now two completely separated steps, no execution of a files code will happen until the complete file and everything it requires has completely and successfully been parsed.

One of the new requirements introduced with this split is that required and included files now have to be syntactically complete. You can no longer spread the different controlling parts of a control structure across file boundaries. That is you cannot start a for or while loop, an if statement or a switch block in one file and have the end of loop, else, endif, case or break statements in a different file.

It still perfectly legal to include additional code within loops or other control structures, only the controlling keywords and corresponding curly braces {...} have to be within the same compile unit (file or eval()ed string).

This should not harm to much as spreading code like this should be considered as very bad style anyway.

Another thing no longer possible, though rarely seen in PHP 3 code is returning values from a required file. Returning a value from an included file is still possible.

Anterior | Inicio | Siguiente
Migrating Configuration Files | Subir | Error reporting


Error reporting

Configuration changes

With PHP 3 the error reporting level was set as a simple numeric value formed by summing up the numbers related to different error levels. Usual values where 15 for reporting all errors and warnings or 7 for reporting everything but simple notice messages reporting bad style and things like that.

PHP 4 has a larger set of error and warning levels and comes with a configuration parser that now allows for symbolic constants to be used for setting the intended behavior.

Error reporting level should now be configured by explicitly taking away the warning levels you do not want to generate error messages by x-oring them from the symbolic constant E_ALL. Sounds complicated? Well, lets say you want the error reporting system to report all but the simple style warnings that are categorized by the symbolic constant E_NOTICE. Then you'll put the following into your php.ini: error_reporting = E_ALL & ~ ( E_NOTICE ). If you want to suppress warnings too you add up the appropriate constant within the braces using the binary or operator '|': error_reporting= E_ALL & ~ ( E_NOTICE | E_WARNING ).

Aviso

Using the old values 7 and 15 for setting up error reporting is a very bad idea as this suppresses some of the newly added error classes including parse errors. This may lead to very strange behavior as scripts might no longer work without error messages showing up anywhere.

This has lead to a lot of unreproducible bug reports in the past where people reported script engine problems they were not capable to track down while the TRUE case was usually some missing '}' in a required file that the parser was not able to report due to a misconfigured error reporting system.

So checking your error reporting setup should be the first thing to do whenever your scripts silently die. The Zend engine can be considered mature enough nowadays to not cause this kind of strange behavior.

Additional warning messages

A lot of existing PHP 3 code uses language constructs that should be considered as very bad style as this code, while doing the intended thing now, could easily be broken by changes in other places. PHP 4 will output a lot of notice messages in such situations where PHP 3 didn't. The easy fix is to just turn off E_NOTICE messages, but it is usually a good idea to fix the code instead.

The most common case that will now produce notice messages is the use of unquoted string constants as array indices. Both PHP 3 and 4 will fall back to interpret these as strings if no keyword or constant is known by that name, but whenever a constant by that name had been defined anywhere else in the code it might break your script. This can even become a security risk if some intruder manages to redefine string constants in a way that makes your script give him access rights he wasn't intended to have. So PHP 4 will now warn you whenever you use unquoted string constants as for example in $HTTP_SERVER_VARS[REQUEST_METHOD]. Changing it to $HTTP_SERVER_VARS['REQUEST_METHOD'] will make the parser happy and greatly improve the style and security of your code.

Another thing PHP 4 will now tell you about is the use of uninitialized variables or array elements.

Anterior | Inicio | Siguiente
Parser behavior | Subir | Initializers


Initializers

Static variable and class member initializers only accept scalar values while in PHP 3 they accepted any valid expression. This is, once again, due to the split between parsing and execution as no code has yet been executed when the parser sees the initializer.

For classes you should use constructors to initialize member variables instead. For static variables anything but a simple static value rarely makes sense anyway.

Anterior | Inicio | Siguiente
Error reporting | Subir | empty("0")


empty("0")

The perhaps most controversial change in behavior has happened to the behavior of the empty(). A String containing only the character '0' (zero) is now considered empty while it wasn't in PHP 3.

This new behavior makes sense in web applications, with all input fields returning strings even if numeric input is requested, and with PHP's capabilities of automatic type conversion. But on the other had it might break your code in a rather subtle way, leading to misbehavior that is hard to track down if you do not know about what to look for.

Anterior | Inicio | Siguiente
Initializers | Subir | Missing functions


Missing functions

While PHP 4 comes with a lot of new features, functions and extensions, you may still find some functions from version 3 missing. A small number of core functions has vanished because they do not work with the new scheme of splitting parsing and execution as introduced into 4 with the Zend engine. Other functions and even complete extensions have become obsolete as newer functions and extensions serve the same task better and/or in a more general way. Some functions just simply haven't been ported yet and finally some functions or extensions may be missing due to license conflicts.

Functions missing due to conceptual changes

As PHP 4 now separates parsing from execution it is no longer possible to change the behavior of the parser (now embedded in the Zend engine) at runtime as parsing already happened by then. So the function short_tags() no longer exists. You can still change the parsers behavior by setting appropriate values in the php.ini file.

Another feature of PHP 3 that is not a part of PHP 4 is the bundled debugging interface. There are third-party add-ons for the Zend engine which add similar functionality.

Deprecate functions and extensions

The Adabas and Solid database extensions are no more. Long live the unified ODBC extension instead.

Changed status for unset()

unset(), although still available, is implemented as a language construct rather than a function.

This does not have any consequences on the behavior of unset(), but testing for "unset" using function_exists() will return FALSE as it would with other language constructs that look like functions such as echo().

Another more practical change is that it is no longer possible to call unset() indirectly, that is $func="unset"; $func($somevar) won't work anymore.

Anterior | Inicio | Siguiente
empty("0") | Subir | PHP 3 extension


PHP 3 extension

Extensions written for PHP 3 will not work with PHP 4, neither as binaries nor at the source level. It is not difficult to port extensions to PHP 4 if you have access to the original source. A detailed description of the actual porting process is not part of this text.

Anterior | Inicio | Siguiente
Missing functions | Subir | Variable substitution in strings


Variable substitution in strings

PHP 4 adds a new mechanism to variable substitution in strings. You can now finally access object member variables and elements from multidimensional arrays within strings.

To do so you have to enclose your variables with curly braces with the dollar sign immediately following the opening brace: {$...}

To embed the value of an object member variable into a string you simply write "text {$obj->member} text" while in PHP 3 you had to use something like "text ".$obj->member." text".

This should lead to more readable code, while it may break existing scripts written for PHP 3. But you can easily check for this kind of problem by checking for the character combination {$ in your code and by replacing it with \{$ with your favorite search-and-replace tool.

Anterior | Inicio | Siguiente
PHP 3 extension | Subir | Cookies


Cookies

PHP 3 had the bad habit of setting cookies in the reverse order of the setcookie() calls in your code. PHP 4 breaks with this habit and creates the cookie header lines in exactly the same order as you set the cookies in the code.

This might break some existing code, but the old behaviour was so strange to understand that it deserved a change to prevent further problems in the future.

Anterior | Inicio | Siguiente
Variable substitution in strings | Subir | Handling of global variables


Handling of global variables

While handling of global variables had the focus on to be easy in PHP 3 and early versions of PHP 4, the focus has changed to be more secure. While in PHP 3 the following example worked fine, in PHP 4 it has to be unset($GLOBALS["id"]);. This is only one issue of global variable handling. You should always have used $GLOBALS, with newer versions of PHP 4 you are forced to do so in most cases. Read more on this subject in the global references section.

Ejemplo B-1. Migration of global variables

<?php
$id = 1;
function test()
{
    global $id;
    unset($id);
}
test();
echo($id); // This will print out 1 in PHP 4
?>

Anterior | Inicio | Siguiente
Cookies | Subir | Migrando de PHP/FI 2.0 a PHP 3.0


Migrando de PHP/FI 2.0 a PHP 3.0

Manual de PHP
Anterior Siguiente

Apéndice C. Migrando de PHP/FI 2.0 a PHP 3.0

Tabla de contenidos
Acerca de las incompatibilidades en PHP 3.0
Tags de inicio y fin
sintáxis de if..endif
sintáxis de while (mientras)
Tipos de expresiones
Cambios en los mensajes de error
Evaluación booleana por corto-circuito
Retorno de valores en funciones verdadero/falso
Otras incompatibilidades

Acerca de las incompatibilidades en PHP 3.0

PHP 3.0 ha sido reescrito desde cero. Tiene un intérprete propio, que es mucho mas robusto y consistente que el de 2.0. 3.0 es también significativamente mas rápido, y usa menos memoria. De cualquier modo, algunas de estas mejoras no fueron posibles sin alterar la compatibilidad, tanto de sintaxis como de funcionamiento.

Además, los desarrolladores de PHP han intentado clarificar la sintaxis y la semántica de PHP 3.0, y eso ha causado también algunas incompatibilidades. Creemos que, a la larga, estos cambios serán para mejor.

Este capítulo, intentará guiarle a través de las incompatibilidades que encontrará si migra de PHP/FI 2.0 a PHP 3.0, además de ayudarle a resolverlas. No se mencionarán aquí las herramientas nuevas, hasta que sea necesario.

Existe un programa que convierte automáticamente sus viejos guiones PHP/FI 2.0. Puede hallarlo en el subdirectorio convertor de la distribucion 3.0 de PHP Este programa, solo actúa en referencia a los cambios sintácticos, así que debería leer este capítulo detenidamente, de todos modos.

Anterior | Inicio | Siguiente
Handling of global variables | Subir | Tags de inicio y fin


Tags de inicio y fin

Probablemente lo primero que note, es que los tags de inicio y fin de PHP han cambiado. Las vieja forma <? > ha sido reemplazada por tres nuevas formas posibles:

Ejemplo C-1. Migración: Cambio de los tags de inicio y fin

<? echo "Esto es codigo PHP/FI 2.0.\n"; >
Como en la versión 2.0, PHP/FI también soporta esta variante:

Ejemplo C-2. Migración: Nuevos tags de inicio y fin, Variante 1

<? echo "Esto es código PHP 3.0!\n"; ?>
Note que el tag de fin, consiste ahora en un signo de interrogación y un mayor-que, mientras que antes era sólo un mayor-que. Sin embargo si Ud. planea usar XML en su servidor, tendrá problemas con esta nueva variante, porque PHP tratará de ejecutar las marcas en los documentos XML, como código PHP. Es por esto que se han introducido las siguientes variantes:

Ejemplo C-3. Migración: Nuevos tags de inicio y fin, Variante 2

<?php echo "Esto es código PHP 3.0!\n"; ?>
Algunas personas han tenido problemas con editores que no reconocen del todo los tags de instrucciones de procesamiento. Microsoft FrontPage es uno de esos editores, y a modo de remedio, se ha introducido también esta otra variante:

Ejemplo C-4. Migración: Nuevos tags de inicio y fin, Variante 3

<script language="php">

  echo "Esto es código PHP 3.0!\n";

</script>

Anterior | Inicio | Siguiente
Migrando de PHP/FI 2.0 a PHP 3.0 | Subir | sintáxis de if..endif


sintáxis de if..endif

La manera `alternativa' de escribir la declaración if/elseif/else, usando if();elseif(); else; endif; no puede implementarse eficientemente sin agregar una gran complejidad al intérprete 3.0. Por eso la sintáxis ha cambiado:

Ejemplo C-5. Migración: vieja sintáxis if..endif

if ($foo);
    echo "sip\n";
elseif ($bar);
    echo "casi\n";
else;
    echo "nop\n";
endif;

Ejemplo C-6. Migración: nueva sitáxis if..endif (si...finsi)

if ($foo):
    echo "sip\n";
elseif ($bar):
    echo "casi\n";
else:
    echo "nop\n";
endif;
Nótese que los punto-y-coma, han sido reemplazados por los los dos-puntos en todas las declaraciones, excepto en la de finalización (endif).

Anterior | Inicio | Siguiente
Tags de inicio y fin | Subir | sintáxis de while (mientras)


sintáxis de while (mientras)

Al igual que para if..endif, la sintáxis de while..endwhile se ha cambiado:

Ejemplo C-7. Migración: vieja sintaxis while..endwhile

while ($more_to_come);
    ...
endwhile;

Ejemplo C-8. Migración: nueva sintáxis while..endwhile

while ($more_to_come):
    ...
endwhile;

Aviso

Si se utiliza la sintáxis vieja de mientras...fin-mientras en PHP 3.0, el resultado es un bucle infinito.

Anterior | Inicio | Siguiente
sintáxis de if..endif | Subir | Tipos de expresiones


Tipos de expresiones

PHP/FI 2.0 usó el lado izquierdo de las expresiones para determinar de qué tipo debía ser el resultado. PHP 3.0 toma ambos lados en cuenta cuando determina el tipo de resultado, y eso puede producir resultados impredecibles si ejecuta guiones 2.0 en 3.0.

Considere este ejemplo:

$a[0]=5;
$a[1]=7;

$key = key($a);
while ("" != $key) {
    echo "$keyn";
    next($a);
}

En PHP/FI 2.0, esto mostraría los dos índices de $a. En PHP 3.0, no muestra nada. El motivo es que en PHP 2.0, al ser el argumento izquierdo de tipo cadena, se comparaba cadenas, y puesto que ciertamente "" no es igual a "0", el bucle continúa. En PHP 3.0, cuando se compara una cadena con un entero, se realiza una comparación de enteros (la cadena es convertida a entero). Esto es comparar entonces atoi("") que es 0, y variablelist que tambien es 0, y como 0==0, el bucle no avanzará.

La solución a esto es simple, reemplaze la declaración while con:

while ((string)$key != "") {

Anterior | Inicio | Siguiente
sintáxis de while (mientras) | Subir | Cambios en los mensajes de error


Cambios en los mensajes de error

Los mensajes de error de PHP 3.0 son usualmente mas precisos que los de 2.0, pero ya no podrá ver el fragmento de código que causó el error. En vez de eso, se le mostrará el nombre de archivo y número de línea del error.

Anterior | Inicio | Siguiente
Tipos de expresiones | Subir | Evaluación booleana por corto-circuito


Evaluación booleana por corto-circuito

En PHP 3.0, la evaluación booleana es por cortocircuito. Eso significa que en una expresión como (1 || prueba_me()), la función prueba_me() no será ejecutada ya que nada puede cambiar el resultado de la expresión despues del 1.

Si bien es éste un detalle menor de la compatibilidad, puede provocar inesperados efectos colaterales

Anterior | Inicio | Siguiente
Cambios en los mensajes de error | Subir | Retorno de valores en funciones verdadero/falso


Retorno de valores en funciones verdadero/falso

La mayoria de las funciones internas han sido reescritas, asi que devuelven TRUE (verdadero) si hubo éxito, o FALSE (falso) si hubo falla, en oposición a los valores 0 y -1 de PHP/FI 2.0, para idénticas circunstancias. La nueva respuesta permite mas código lógico, como $fp = fopen("/su/fichero") or fail("diablos!");. Puesto que PHP/FI 2.0 no tiene reglas claras acerca de lo que devuelven las funciones cuando fallan, scripts de este tipo deberán revisarse manualmente despues de usar el conversor de 2.0 a 3.0.

Ejemplo C-9. Migración desde 2.0: Valores de retorno, codigo viejo

$fp = fopen($file, "r");
if ($fp == -1);
    echo("No se pudo abrir el fichero $file para su lectura<br>\n");
endif;

Ejemplo C-10. Migración desde 2.0: Valores de retorno, codigo nuevo

$fp = @fopen($file, "r") or print("No se pudo abrir el fichero $file para su lectura<br>\n");

Anterior | Inicio | Siguiente
Evaluación booleana por corto-circuito | Subir | Otras incompatibilidades


Otras incompatibilidades

  • El modulo Apache de 3.0 no soportará versiones de Apache anteriores a la 1.2. Es requisito Apache 1.2 o posterior.

  • echo() no soportará las cadenas de formato. Use en su lugar la función printf().

  • En PHP/FI 2.0, un efecto colateral en la implementación hacía que $foo[0] tenga el mismo efecto que $foo. Esto ya no es así en PHP 3.0.

  • La lectura de arreglos con $array[] ya no está soportada

    Esto es, no se puede recorrer un arreglo mediante un bucle que ejecute $data = $array[]. Use current() y next() en su lugar.

    Tambien, $array1[] = $array2 no agrega los valores de $array2 a $array1, pero agrega $array2 como la última entrada de $array1. Véase tambien el soporte de arreglos multidimensionales.

  • "+" ya no funciona como operador de concatenación de cadenas, sino que convierte los argumentos, a números, y realiza una suma numérica. Utilize "." en su lugar.

Ejemplo C-11. Migración desde 2.0: concatenando cadenas

echo "1" + "1";

En PHP 2.0 esto mostraría 11, en PHP 3.0 sería 2. Use en su lugar:
echo "1"."1";
$a = 1;
$b = 1;
echo $a + $b;

Esto dá 2 igualmente en PHP 2.0 y 3.0.
$a = 1;
$b = 1;
echo $a.$b;
Esto dá 11 en PHP 3.0.

Anterior | Inicio | Siguiente
Retorno de valores en funciones verdadero/falso | Subir | El debugger de PHP


El debugger de PHP

Manual de PHP
Anterior Siguiente

Apéndice D. El debugger de PHP

Tabla de contenidos
Usando el Debugger
Protocolo del debugger

Usando el Debugger

El debugger interno de PHP es útil para localizar fallos que se resisten. El debugger funciona conectandose a un puerto TCP cada vez que PHP comienza. Todos los mensajes de error de esa petición serán enviados a esta conexión TCP. Esta información se entiende que que es para un "servidor de debugger" que puede ejecutarse en un IDE o en un editor programabler (como Emacs).

Como poner en marcha el debugger:

  1. Establezca un puerto TCP para el debugger en el archivo de configuración (debugger.port) y activelo (debugger.enabled).

  2. Ponga en marcha un módulo de escucha de TCP en algun sitio (por ejemplo socket -l -s 1400 en UNIX).

  3. En su código, ejecute "debugger_on(host)", donde host es la dirección IP o el nombre de el host ejecutando un módulo de escucha de TCP.

Ahora, todos los avisos, notificaciones, etc. se mostrarán en ese módulo de escucha, incluso si lo ha desactivado con error_reporting().

Anterior | Inicio | Siguiente
Otras incompatibilidades | Subir | Protocolo del debugger


Protocolo del debugger

El protocolo del debugger está basado en líneas. Cada línea tiene un tipo, y varias línea componen un mensaje. Cada mensaje comienza con una línea del tipo start y termina con una línea del tipo end. PHP puede enviar líneas para diferentes mensajes simultaneamente.

Una línea tiene este formato:

fecha hora host(pid) tipo: datos del mensaje

fecha

Fecha en formato ISO 8601 (aaaa-mm-dd)

hora

Hora incluyendo microsegundos: hh:mm:uuuuuu

host

Nombre DNS o dirección IP del host donde el script de error fue generado.

pid

PID (id proceso) en el host del proceso en que el script de PHP generó este error.

tipo

Tipo de la línea. Dice al programa programa que recibe que debe considerar los datos siguientes como:

Tabla D-1. Tipos de línea del debugger

Nombre | Significado
start | Informa al programa que recibe que un mensaje del debugger comienza aqui. El contenido de data será el tipo del mensaje de error, listados debajo.
message | El mensaje de error de PHP.
location | Nombre del fichero y número de línea donde ocurrió el error. La primera línea con location siempre contendrá la localización de mayor nivel. data contendrá fichero:línea. Siempre habrá una línea de tipo location después de message y después de cada function.
frames | Número de marcos en la pila. Si hay cuatro marcos, espere información sobre los cuatro niveles de las funciones llamadas. Si no hay una línea de tipo "frames", la profundidad se asume que es 0 (el error ocurrió en el nivel superior).
function | Nombre de la función donde ocurrió el error. Será repetida una vez por cada nivel en la pila de funciones.
end | Informa al programa que recibe que el mensaje del debugger termina aqui.

data

Línea de datos.

Tabla D-2. Tipos de error del debugger

Debugger | PHP Internal
warning | E_WARNING
error | E_ERROR
parse | E_PARSE
notice | E_NOTICE
core-error | E_CORE_ERROR
core-warning | E_CORE_WARNING
unknown | (any other)

Ejemplo D-1. Ejemplo de mensaje del debugger

1998-04-05 23:27:400966 lucifer.guardian.no(20481) start: notice
1998-04-05 23:27:400966 lucifer.guardian.no(20481) message: Uninitialized variable
1998-04-05 23:27:400966 lucifer.guardian.no(20481) location: (NULL):7
1998-04-05 23:27:400966 lucifer.guardian.no(20481) frames: 1
1998-04-05 23:27:400966 lucifer.guardian.no(20481) function: display
1998-04-05 23:27:400966 lucifer.guardian.no(20481) location: /home/ssb/public_html/test.php3:10
1998-04-05 23:27:400966 lucifer.guardian.no(20481) end: notice

Anterior | Inicio | Siguiente
El debugger de PHP | Subir | Desarrollo en PHP


Desarrollo en PHP

Manual de PHP
Anterior Siguiente

Apéndice E. Desarrollo en PHP

Tabla de contenidos
Añadiendo funciones al PHP3
Llamando a Funciones del Usuario
Informando de errores

Añadiendo funciones al PHP3

Prototipo de Función

Todas las funciones son como esta:
void php3_algo(INTERNAL_FUNCTION_PARAMETERS) {

}
Incluso si su función no lleva argumentos, es así como se le llama.

Argumentos de Función

Los argumentos son siempre de tipo pval. Este tipo contiene una unión que es el tipo actual del argumento. Así, si su función tiene dos argumentos, deberá hacer algo como lo que sigue al principio de la misma:

Ejemplo E-1. Extrayendo argumentos de función

pval *arg1, *arg2;
if (ARG_COUNT(ht) != 2 || getParameters(ht,2,&arg1,&arg2)==FAILURE) {
   WRONG_PARAM_COUNT;
}
NOTA: Los argumentos pueden pasarse tanto por valor como por referencia. En ambos casos, necesitará pasar &(pval *) a getParameters. Si desea comprobar si el enésimo parámetro le ha sido enviado o no por referencia, puede utilizar la función ParameterPassedByReference(ht,n). Esta devolverá 1 ó 0, según corresponda.

Cuando cambie alguno de los parámetros pasados, tanto si son enviados por referencia o por valor, puede volver a comenzar con éste llamando la función pval_destructor sobre el mismo, o, si es una ARRAY a la que quiere añadir algo, puede utilizar funciones similares a las incluídas en internal_functions.h, que manipulan el valor return_value como si fuera de tipo ARRAY.

Además, si cambia un parámetro a IS_STRING, asegúrese primero de asignar el valor y el tamaño a la cadena creada por estrdup() y sólo entonces cambiar su tipo a IS_STRING. Si modifica la cadena de un parámetro que ya es IS_STRING o IS_ARRAY, deberá primero aplicarle la función pval_destructor.

Argumentos de Función Variables

Una función puede tomar un número variable de argumentos. Si su función puede tomar tanto 2 como 3 argumentos, utilice el siguiente código:

Ejemplo E-2. Argumentos de función variables

pval *arg1, *arg2, *arg3;
int arg_count = ARG_COUNT(ht);

if (arg_count < 2 || arg_count > 3 ||
    getParameters(ht,arg_count,&arg1,&arg2,&arg3)==FAILURE) {
    WRONG_PARAM_COUNT;
}

Usando los Argumentos de Función

El tipo de cada argumento se guarda en el campo type del pval. Este tipo puede ser:

Tabla E-1. Tipos Internos de PHP

IS_STRING | Cadena
IS_DOUBLE | Coma flotante de doble precisión
IS_LONG | Entero largo
IS_ARRAY | Matriz
IS_EMPTY | Nada
IS_USER_FUNCTION | ??
IS_INTERNAL_FUNCTION | ?? (N.D.: si alguno de estos no se puede pasar a una función, bórrese)
IS_CLASS | ??
IS_OBJECT | ??

Si obtiene un argumento de un tipo y desea utilizarlo como si fuera de otro, o si quiere forzar a que un argumento sea de un tipo determinado, puede usar una de las siguientes funciones de conversión:
convert_to_long(arg1);
convert_to_double(arg1);
convert_to_string(arg1);
convert_to_boolean_long(arg1); /* Si la cadena es "" o "0" pasa a ser 0; si no, vale 1 */
convert_string_to_number(arg1);  /* Convierte la cadena a LONG o a DOUBLE, dependiendo de su contenido */

Estas funciones convierten el valor in-situ. No devuelven nada.

El argumento real es almacenado en una unión cuyos miembros son:

  • IS_STRING: arg1->value.str.val

  • IS_LONG: arg1->value.lval

  • IS_DOUBLE: arg1->value.dval

Manejo de Memoria en las Funciones

La memoria necesitada por una función deberá ser asignada usando emalloc() o estrdup(). Estas son funciones abstractas de manejo de memoria que son similares a las funciones normales malloc() y strdup(). La memoria deberá liberarse con efree().

Hay dos tipos de memoria en este programa: la memoria que se devuelve al troceador (parser) en una variable, y la memoria que se necesita para almacenamiento temporal de datos en sus funciones. Cuando asigne una cadena a una variable que se devolverá al troceador deberá asegurarse previamente de asignar la memoria con emalloc() o con estrdup(). Esta memoria NUNCA debe ser liberada por usted, salvo si más adelante, en la misma función, sobreescribe la asignación original (aunque este hábito de programación no es bueno).

Para cada trozo de memoria temporal/permanente que precise en sus funciones/librería deberá utilizar las funciones emalloc(), estrdup(), y efree(). Estas se comportan EXACTAMENTE como sus funciones equivalentes. Cualquier cosa que asigne con emalloc() o estrdup() deberá liberarla con efree() en uno u otro momento, salvo que se suponga que deba permanecer activa hasta el final del programa; de otro modo, se producirá una fuga de memoria. El significado de "estas se comportan exactamente como sus funciones equivalentes" es: si llama a efree() sobre algo que no ha sido asignado previamente con emalloc() o con estrdup(), puede provocar un fallo de segmentación. Por ello debe tener cuidado y liberar toda la memoria desperdiciada.

Si compila con "-DDEBUG", el PHP3 mostrará una lista de toda la memoria que fue asignada usando emalloc() y estrdup(), pero que nunca fue liberada con efree(), al terminar de ejecutar el guión especificado.

Asignando Variables en la Tabla de Símbolos

Están disponibles una serie de macros que hacen más fácil el asignar una variale en la tabla de símbolos:

  • SET_VAR_STRING(nombre,valor) [1]

  • SET_VAR_DOUBLE(nombre,valor)

  • SET_VAR_LONG(nombre,valor)

[1]

Las tablas de símbolos en PHP 3.0 se implementan como tablas hash (con extracto). En todo momento, &symbol_table es un puntero a la tabla de símbolos 'principal', mientras que active_symbol_table apunta a la tabla de símbolos activa (pueden ser idénticas, al principio de todo, o diferentes, si se está dentro de una función).

Los ejemplos siguientes utilizan 'active_symbol_table'. Deberá reemplazarla por &symbol_table si desea trabajar específicamente con la tabla de símbolos 'principal'. También se pueden aplicar las mismas funciones a matrices, como se explica más abajo.

Ejemplo E-3. Comprobando si $algo existe en una tabla de símbolos

if (hash_exists(active_symbol_table,"algo",sizeof("algo"))) { existe... }
else { no existe }

Ejemplo E-4. Hallando el tamaño de una variable en una tabla de símbolos

hash_find(active_symbol_table,"algo",sizeof("algo"),&valptr);
check(valptr.type);
Las matrices en PHP 3.0 se implementan utilizando las mismas tablas hash que para las tablas de símbolos. Ello quiere decir que las dos funciones anteriores se pueden usar también para comprobar variables dentro de matrices.

Si desea definir un nuevo símbolo de matriz en una tabla de símbolos, deberá hacer lo que sigue.

Primero, deberá comprobar si ya existe usando hash_exists() o hash_find() y abortar la ejecución de forma apropiada.

Luego inicialice la matriz:

Ejemplo E-5. Inicializando una nueva matriz

pval matriz;

if (array_init(&matriz) == FAILURE) { falló... };
hash_update(active_symbol_table,"algo",sizeof("algo"),&matriz,sizeof(pval),NULL);
Este código declara una nueva matriz, llamada $algo, en la tabla de símbolos activa. Esta matriz está vacía.

Ahora se muestra cómo añadirle elementos:

Ejemplo E-6. Añadir entradas a una nueva matriz

pval elemento;

elemento.type = IS_LONG;
elemento.value.lval = 5;

/* define $algo["bar"] = 5 */
hash_update(matriz.value.ht,"bar",sizeof("bar"),&elemento,sizeof(pval),NULL);

/* define $algo[7] = 5 */
hash_index_update(matriz.value.ht,7,&elemento,sizeof(pval),NULL);

/* define el siguiente puesto libre en $algo[],
 * $algo[8], como 5 (funciona como en php2)
 */
hash_next_index_insert(matriz.value.ht,&elemento,sizeof(pval),NULL);
Si desea modificar un valor que ha insertado en una matriz asociativa, deberá primero extraerlo de ella. Para evitar esa sobrecarga, puede pasarle un puntero pval ** a la función para insertar en una matriz asociativa, y será actualizada con la dirección pval * del elemento insertado dentro de la matriz. Si dicho valor es NULL (como en todos los ejemplos anteriores), el parámetro se ignora.

hash_next_index_insert() usa más o menos la misma lógica que "$algo[] = bar;" en el PHP 2.0.

Si está preparando una matriz como valor devuelto por una función, puede inicializar la misma como antes, haciendo:

if (array_init(return_value) == FAILURE) { falló...; }

... y luego añadiéndole valores con las funciones auxiliares:

add_next_index_long(return_value,val_long);
add_next_index_double(return_value,val_double);
add_next_index_string(return_value,estrdup(val_cadena));

Por supuesto, si la adición no se realiza justo después de inicializar la matriz, probablemente tenga que buscarla antes:
pval *matriz;

if (hash_find(active_symbol_table,"algo",sizeof("algo"),(void **)&matriz)==FAILURE) { no se hayó... }
else { usar matriz->value.ht... }

Nótese que hash_find recibe un puntero a un puntero a pval, y no un puntero a pval.

Casi cualquier función de matrices asociativas devuelve SUCCESS o FAILURE (excepto por hash_exists(), que devuelve un valor lógico de certeza).

Devolviendo valores simples

Están disponibles varias macros para facilitar la devolución de valores de una función.

Todas las macros RETURN_* fijan el valor y retornan de la función:

  • RETURN

  • RETURN_FALSE

  • RETURN_TRUE

  • RETURN_LONG(l)

  • RETURN_STRING(s,dup) Si dup es TRUE, duplica la cadena

  • RETURN_STRINGL(s,l,dup) Devuelve la cadena (s) especificando el largo (l).

  • RETURN_DOUBLE(d)

Las macros RETVAL_* fijan el valor, pero no retornan.

  • RETVAL_FALSE

  • RETVAL_TRUE

  • RETVAL_LONG(l)

  • RETVAL_STRING(s,dup) Si dup es TRUE, duplica la cadena

  • RETVAL_STRINGL(s,l,dup) Devuelve la cadena (s) especificando el largo (l).

  • RETVAL_DOUBLE(d)

Las macros anteriores harán un estrdup() del argumento 's', de modo que puede liberar con seguridad el argumento después de llamar a la macro, o, alternativamente, utilizar memoria asignada estáticamente.

Si su función devuelve respuestas lógicas de éxito/error, use siempre RETURN_TRUE y RETURN_FALSE respectivamente.

Devolviendo valores complejos

Su función también puede devolver un tipo de datos complejo, tal como un objeto o una matriz.

Devolviendo un objeto:

  1. Llame a object_init(return_value).

  2. Rellénela con valores. Las funciones disponibles para ello son listadas más abajo.

  3. Posilemente registre funciones para este objeto. Para obtener valores del objeto, la función deberá de obtener "this" desde la active_symbol_table. Su tipo deberá ser IS_OBJECT, y básicamente se trata de una matriz asociativa estándar (es decir, que podrá usar funciones de matriz asociativa sobre .value.ht). El registro en sí de la función se puede hacer utilizando:
    add_method( return_value, nombre_func, puntero_func );

Las funciones utilizadas para rellenar un objeto son:

  • add_property_long( return_value, nombre_propiedad, l ) - Añade una propiedad llamada 'nombre_propiedad', de tipo long, y con valor 'l'

  • add_property_double( return_value, nombre_propiedad, d ) - Igual, pero añadiendo un double

  • add_property_string( return_value, nombre_propiedad, cad ) - Igual, pero añadiendo una cadena

  • add_property_stringl( return_value, nombre_propiedad, cad, l ) - Igual, pero añadiendo una cadena de longitud 'l'

Devolviendo una matriz:

  1. Llame a array_init(return_value).

  2. Rellénela con valores. Las funciones disponibles para ello son listadas más abajo.

Las funciones utilizadas para rellanar una matriz son:

  • add_assoc_long(return_value,clave,l) - añade un elemento asociativo con clave 'clave' y valor long 'l'

  • add_assoc_double(return_value,clave,d)

  • add_assoc_string(return_value,clave,cad,duplicar)

  • add_assoc_stringl(return_value,clave,cad,largo,duplicar) - especifica el largo de la cadena

  • add_index_long(return_value,indice,l) - añade un elemento en la posición 'indice' con valor long 'l'

  • add_index_double(return_value,indice,d)

  • add_index_string(return_value,indice,cad)

  • add_index_stringl(return_value,indice,cad,largo) - especifica el largo de la cadena

  • add_next_index_long(return_value,l) - añade un elemento a la matriz en la próxima posición libre con valor long 'l'

  • add_next_index_double(return_value,d)

  • add_next_index_string(return_value,cad)

  • add_next_index_stringl(return_value,cad,largo) - especifica el largo de la cadena

Usando la lista de recursos

El PHP 3.0 tiene una forma estandarizada de tratar con distintos tipos de recursos. Esto sustituye a las listas enlazadas locales del PHP 2.0.

Funciones disponibles:

  • php3_list_insert(ptr, tipo) - devuelve el 'id' del recurso recién insertado

  • php3_list_delete(id) - borra el recurso con el id especificado

  • php3_list_find(id,*tipo) - devuelve el puntero al recurso con el id especificado, y actualiza 'tipo' al tipo del mismo

Estas funciones se utilizan típicamente para controladores SQL, pero pueden utilizarse para cualquier otra cosa, como, por ejemplo, para mantener descriptores de archivo.

El código típico de un lista sería como este:

Ejemplo E-7. Añadiendo un nuevo recurso

RESOURCE *recurso;

/* ...asignar memoria para el recurso y adquirirlo... */
/* añadir un recurso a la lista */
return_value->value.lval = php3_list_insert((void *) recurso, LE_RESOURCE_TYPE);
return_value->type = IS_LONG;

Ejemplo E-8. Utilizando un recurso existente

pval *id_recurso;
RESOURCE *recurso;
int tipo;

convert_to_long(id_recurso);
recurso = php3_list_find(id_recurso->value.lval, &tipo);
if (tipo != LE_RESOURCE_TYPE) {
    php3_error(E_WARNING,"el recurso número %d tiene el tipo equivocado",id_recurso->value.lval);
    RETURN_FALSE;
}
/* ...usar recurso... */

Ejemplo E-9. Borrando un recurso

pval *id_recurso;
RESOURCE *recurso;
int tipo;

convert_to_long(id_recurso);
php3_list_delete(id_recurso->value.lval);
Los tipos de recursos deben registrarse en php3_list.h, en la enumeración list_entry_type. Además, hay que añadir código de desconexión para cada tipo de recurso definido en la función list_entry_destructor() de list.c (incluso si no hay nada que hacer para la desconexión, deberá añadir un caso vacío).

Utilizando la tabla de recursos persistentes

El PHP 3.0 tiene una forma estándar de almacenar recursos persistentes (es decir, recursos que se mantienen entre accesos). El primer módulo que utilizó esta característica fue el MySQL y tras él fue el mSQL, así que uno puede hacerse una buena idea de cómo utilizar un recurso persistente leyendo mysql.c. Las funciones a revisar son:

php3_mysql_do_connect
php3_mysql_connect()
php3_mysql_pconnect()

La idea general de los módulos persistentes es:

  1. Codifique todos sus módulos para que funcionen con la lista regulares de recursos mencionadas en la sección (9).

  2. Codifique funciones extra de conexión que comprueben si el recurso ya está en la lista de recursos persistentes. Si ya está, regístrelo en la lista regular como un puntero a la lista de recursos persistentes (debido a 1., el resto del código deberá funcionar de inmediato). Si no está en la lista, créelo, añádalo a la lista de recursos persistentes Y añada un puntero al mismo desde la lista regular de recursos. Así todo el código funcionará porque está en la lista regular, pero en la siguiente conexión el recurso ya estará en la lista persistente y podrá ser usado sin re-crearlo. Deberá registrar estos recursos con un tipo diferente (por ejemplo, LE_MYSQL_LINK para el enlace no persistente y LE_MYSQL_PLINK para un enlace persistente).

Si se leyera mysql.c, notaría que, salvo por que hay una función de conexión más compleja, no hay que cambiar nada más del resto del módulo.

Existe exactamente la misma interfaz para la lista de recursos regular y para la lista de recursos persistente, pero cambiando únicamente 'lista' por 'listap':

  • php3_plist_insert(ptr, tipo) - devuelve el 'id' del recurso recién insertado

  • php3_plist_delete(id)- borra el recurso con el id especificado

  • php3_plist_find(id,*tipo) - devuelve el puntero al recurso con el id especificado, y actualiza 'tipo' al tipo del mismo

Sin embargo, es más que probable que estas funciones se muestren inútiles cuando intente implementar un módulo persistente. Típicamente usted querrá usar el hecho de que la tabla de recursos persistentes es en realidad una matriz asociativa. Por ejemplo, en los módulos MySQL/mSQL, cuando hay una llamada a pconnect() (conexión persistente), la función combina en una cadena el servidor/usuario/clave que se pasaron a la función y codifica el enlace SQL con esta cadena como clave. La siguiente vez que alguien llame a pconnect() con el mismo servidor/usuario/clave, se generará la misma clave, y la función hayará el enlace SQL en la lista persistente.

Hasta que se documente mejor, deberá mirar en mysql.c o en msql.c para ver como utilizar las capacidades de matriz asociativa de la listap.

Una cosa importante: a los recursos que van a parar a la lista de recursos persistentes *NO* se les debe asignar memoria usando el gestor de memoria del PHP, es decir, que NO deben ser creados utilizando emalloc() o estrdup(), etc. En este caso se debe usar las funciones habituales malloc(), strdup(), etc. La razón para esto es simple: al final de la petición (final del acceso), se borran todos los trozos de memoria asignados con el gestor de memoria del PHP. Como la lista persistente se supone que no se debe borrar al final de una petición, no se debe utilizar el gestor de memoria del PHP para asignar memoria a los recursos de la misma.

Cuando registre un recuros que vaya a estar en la lista persistente, deberá añadir destructores tanto a la lista persistente como a la no persistente. El destructor de la lista no persistente no deberá hacer nada. El de la lista persistente deberá liberar adecuadamente los recursos obtenidos por dicho tipo (por ejemplo, memoria, enlaces SQL, etc.). Tal y como pasa para los recursos no persistentes, DEBERÁ añadir destructores para cada recurso aunque no sean necesarios y estén vacíos. Recuerde que como no se pueden usar emalloc() y similares en conjunción con la lista persistente, tampoco podrá utilizar efree() aquí.

Añadiendo directivas de configuración en tiempo de ejecución

Muchas de las características del PHP3 pueden ser configuradas en tiempo de ejecución. Estas directivas de configuración pueden aparecer tanto en el fichero php3.ini o, en el caso de la versión de módulo del Apache, en los archivos .conf del propio Apache. La ventaja de tenerlos en los archivos .conf del Apache es que se puden configurar directorio por directorio. Esto quiere decir que cada uno puede tener un cierto safemodeexecdir, por ejemplo, mientras otro directorio puede tener otro. Esta granularidad en la configuración es especialmente útil cuando un servidor soporta múltiples servidores virtuales.

Los pasos necesarios para añadir una nueva directiva:

  1. Añada la directiva a la estructura php3_ini_structure en mod_php3.h.

  2. En main.c, edite la función php3_module_startup y añada la llamada a cfg_get_string() o a cfg_get_long() según se requiera.

  3. Añada la directiva, las restricciones y un comentario a la estructura php3_commands en mod_php3.c. Cuidado con la parte de restricciones. Las de tipo RSRC_CONF sólo puede aparecer en los archivos .conf del Apache. Las directivas de tipo OR_OPTIONS pueden aparecer en cualquier parte, incluso en los habituales archivos .htaccess.

  4. Añada el elemento apropiado para su directiva, bien en php3take1handler(), bien en php3flaghandler().

  5. Necesita añadir su nueva directiva a la sección de configuración de la función _php3_info() en functions/info.c.

  6. Y finalmente, por supuesto, deberá utilizar su nueva directiva en algún sitio. Estará accesible como php3_ini.directiva.

Notas

[1]

Tenga cuidado aquí. El valor a usar se debe asignar dinámicamente y de forma manual, pues el código de manejo de memoria intentará liberar este puntero más adelante. Nunca pase memoria asignada de forma estática a SET_VAR_STRING.

Anterior | Inicio | Siguiente
Protocolo del debugger | Subir | Llamando a Funciones del Usuario


Llamando a Funciones del Usuario

Para llamar a funciones del usuario desde una función interna, deberá usar la función call_user_function().

call_user_function() devuelve SUCCESS si tiene éxito y FAILURE en caso de que la función no sea hallada. ¡Deberá comprobar ese valor de retorno! Si devuelve SUCCESS, debe usted ocuparse de destruir el pval devuelto (o devolverlo como el valor de retorno de su función). Si devuelve FAILURE, el valor de valret no está definido y no debe tocarlo.

Todas las funciones internas que llaman a funciones de usuario deben ser reentrantes. Entre otras cosas, esto quiere decir que no se utilicen variables globales ni estáticas.

call_user_function() lleva 6 argumentos:

HashTable *tabla_funciones

Esta es la matriz asociativa en la que se buscará la función.

pval *objeto

Este es un puntero a un objeto sobre el que se invoca la función. Deberá valer NULL si se llama a una función global. Si no es NULL (es decir, si apunta a un objeto), el argumento tabla_funciones se ignora y se toma su valor a partir de la codificación del objeto. El objeto *puede* ser modificado por dicha función (ésta accede a él a través de $this). Si por alguna razón no desea que eso ocurra, envíe entonces una copia del objeto.

pval *nombre_func

El nombre de la función a llamar. Debe ser un pval de tipo IS_STRING, con nombre_func.str.val y nombre_func.str.len fijados a los valores apropiados. El nombre_func es modificado por call_user_function(), que lo convierte a minúsculas. Si necesita preservar el nombre, envíe una copia del mismo.

pval *valret

Un puntero a una estructura pval, en la que se guarda el valor de returno de la función. Hay que asignar espacio a la estructura previamente, porque la función call_user_function() NO lo asigna por sí misma.

int num_params

El número de parámetros que se pasan a la función.

pval *params[]

Una matriz de punteros a los valores que se pasarán como argumentos a la función. El primer argumento está en el elemento 0, el segundo en el elemento 1, etc. La matriz es una matriz de punteros a pval. Los punteros se envían tal cual a la función, lo que quiere decir que si la función modifica sus argumentos, se modifican los valores originales (paso por referencia). Si no desea ese comportamiento, pase una copia.

Anterior | Inicio | Siguiente
Desarrollo en PHP | Subir | Informando de errores


Informando de errores

Para informar de errores desde una función interna, deberá llamar la función php3_error(). Esta lleva al menos dos parámetros: el primero el es nivel del error, y el segundo es la cadena de formato para el mensaje de error (como en una llamada estándar a printf()). Cualquiera de los argumentos siguientes son para la cadena de formato. Los niveles de error son:

E_NOTICE

Por defecto se visualizan las noticas, e indican que el guión encontró algo que podría indicar un error, pero que también podría ocurrir durante el curso normal de la ejecución del mismo. Por ejemplo, al intentar acceder al valor de una variable que no ha sido fijado, o llamar a stat() sobre un fichero que no existe.

E_WARNING

Por defecto se visualizan los avisos, pero no se interrumpe la ejecución del guión. Estos indican un problema que debiera haberse interceptado en el guión antes de la llamada. Por ejemplo, llamar ereg() con una expresión regular no válida.

E_ERROR

Por defecto se visualizan los errores y la ejecución del guión se detiene cuando la función retorna. Estos indican errores irrecuperables, como un problema de asignación de memoria.

E_PARSE

Los errores de troceo sólo debe generarlos el troceador. El código se lista aquí con objeto de ser exhaustivos.

E_CORE_ERROR

Este es similar al E_ERROR, pero generado por el núcleo del PHP. Las funciones no deben generar este tipo de error.

E_CORE_WARNING

Este es similar al E_WARNING, pero generado por el núcleo del PHP. Las funciones no deben generar este tipo de error.

Nota: "N.D.:" significa Nota del Documentador y es un texto interno

Anterior | Inicio | Siguiente
Llamando a Funciones del Usuario | Subir | List of Function Aliases


List of Function Aliases

Manual de PHP
Anterior Siguiente

Apéndice F. List of Function Aliases

Here is the aliases list. All aliases are listed here. It is usually a bad idea to use aliases, as they may be bound to obsolescence or renaming, which will lead to unportable script. This list is provided to help those who want to upgrade their old scripts to newer syntax.

However, some functions simply have two names, and there is no real preference. (For example, is_int() and is_integer() are equally good)

This list is consistent with PHP 4.0.6.

Tabla F-1. Aliases

Alias | Master function | Extension used
add | swfmovie_add() | Ming (flash)
add | swfsprite_add() | Ming (flash)
add_root | domxml_add_root() | DOM XML
addaction | swfbutton_addAction() | Ming (flash)
addcolor | swfdisplayitem_addColor() | Ming (flash)
addentry | swfgradient_addEntry() | Ming (flash)
addfill | swfshape_addfill() | Ming (flash)
addshape | swfbutton_addShape() | Ming (flash)
addstring | swftext_addString() | Ming (flash)
addstring | swftextfield_addString() | Ming (flash)
align | swftextfield_align() | Ming (flash)
attributes | domxml_attributes() | DOM XML
children | domxml_children() | DOM XML
chop | rtrim() | Base syntax
close | closedir() | Base syntax
com_get | com_propget() | COM
com_propset | com_propput() | COM
com_set | com_propput() | COM
cv_add | ccvs_add() | CCVS
cv_auth | ccvs_auth() | CCVS
cv_command | ccvs_command() | CCVS
cv_count | ccvs_count() | CCVS
cv_delete | ccvs_delete() | CCVS
cv_done | ccvs_done() | CCVS
cv_init | ccvs_init() | CCVS
cv_lookup | ccvs_lookup() | CCVS
cv_new | ccvs_new() | CCVS
cv_report | ccvs_report() | CCVS
cv_return | ccvs_return() | CCVS
cv_reverse | ccvs_reverse() | CCVS
cv_sale | ccvs_sale() | CCVS
cv_status | ccvs_status() | CCVS
cv_textvalue | ccvs_textvalue() | CCVS
cv_void | ccvs_void() | CCVS
die | exit() | Miscellaneous functions
dir | getdir() | Base syntax
diskfreespace | disk_free_space() | Filesystem
domxml_getattr | domxml_get_attribute() | DOM XML
domxml_setattr | domxml_set_attribute() | DOM XML
doubleval | floatval() | Base syntax
drawarc | swfshape_drawarc() | Ming (flash)
drawcircle | swfshape_drawcircle() | Ming (flash)
drawcubic | swfshape_drawcubic() | Ming (flash)
drawcubicto | swfshape_drawcubicto() | Ming (flash)
drawcurve | swfshape_drawcurve() | Ming (flash)
drawcurveto | swfshape_drawcurveto() | Ming (flash)
drawglyph | swfshape_drawglyph() | Ming (flash)
drawline | swfshape_drawline() | Ming (flash)
drawlineto | swfshape_drawlineto() | Ming (flash)
dtd | domxml_intdtd() | DOM XML
dumpmem | domxml_dumpmem() | DOM XML
fbsql | fbsql_db_query() | FrontBase
fputs | fwrite() | Base syntax
get_attribute | domxml_get_attribute() | DOM XML
getascent | swffont_getAscent() | Ming (flash)
getascent | swftext_getAscent() | Ming (flash)
getattr | domxml_get_attribute() | DOM XML
getdescent | swffont_getDescent() | Ming (flash)
getdescent | swftext_getDescent() | Ming (flash)
getheight | swfbitmap_getHeight() | Ming (flash)
getleading | swffont_getLeading() | Ming (flash)
getleading | swftext_getLeading() | Ming (flash)
getshape1 | swfmorph_getShape1() | Ming (flash)
getshape2 | swfmorph_getShape2() | Ming (flash)
getwidth | swfbitmap_getWidth() | Ming (flash)
getwidth | swffont_getWidth() | Ming (flash)
getwidth | swftext_getWidth() | Ming (flash)
gzputs | gzwrite() | Zlib
i18n_convert | mb_convert_encoding() | Multi-bytes Strings
i18n_discover_encoding | mb_detect_encoding() | Multi-bytes Strings
i18n_http_input | mb_http_input() | Multi-bytes Strings
i18n_http_output | mb_http_output() | Multi-bytes Strings
i18n_internal_encoding | mb_internal_encoding() | Multi-bytes Strings
i18n_ja_jp_hantozen | mb_convert_kana() | Multi-bytes Strings
i18n_mime_header_decode | mb_decode_mimeheader() | Multi-bytes Strings
i18n_mime_header_encode | mb_encode_mimeheader() | Multi-bytes Strings
imap_create | imap_createmailbox() | IMAP
imap_fetchtext | imap_body() | IMAP
imap_getmailboxes | imap_list_full() | IMAP
imap_getsubscribed | imap_lsub_full() | IMAP
imap_header | imap_headerinfo() | IMAP
imap_listmailbox | imap_list() | IMAP
imap_listsubscribed | imap_lsub() | IMAP
imap_rename | imap_renamemailbox() | IMAP
imap_scan | imap_listscan() | IMAP
imap_scanmailbox | imap_listscan() | IMAP
ini_alter | ini_set() | Base syntax
is_double | is_float() | Base syntax
is_integer | is_int() | Base syntax
is_long | is_int() | Base syntax
is_real | is_float() | Base syntax
is_writeable | is_writable() | Base syntax
join | implode() | Base syntax
labelframe | swfmovie_labelFrame() | Ming (flash)
labelframe | swfsprite_labelFrame() | Ming (flash)
last_child | domxml_last_child() | DOM XML
lastchild | domxml_last_child() | DOM XML
ldap_close | ldap_unbind() | LDAP
magic_quotes_runtime | set_magic_quotes_runtime() | Base syntax
mbstrcut | mb_strcut() | Multi-bytes Strings
mbstrlen | mb_strlen() | Multi-bytes Strings
mbstrpos | mb_strpos() | Multi-bytes Strings
mbstrrpos | mb_strrpos() | Multi-bytes Strings
mbsubstr | mb_substr() | Multi-bytes Strings
ming_setcubicthreshold | ming_setCubicThreshold() | Ming (flash)
ming_setscale | ming_setScale() | Ming (flash)
move | swfdisplayitem_move() | Ming (flash)
movepen | swfshape_movepen() | Ming (flash)
movepento | swfshape_movepento() | Ming (flash)
moveto | swfdisplayitem_moveTo() | Ming (flash)
moveto | swffill_moveTo() | Ming (flash)
moveto | swftext_moveTo() | Ming (flash)
msql | msql_db_query() | mSQL
msql_affected_rows | msql_affected_rows() | mSQL
msql_createdb | msql_create_db() | mSQL
msql_dbname | msql_result() | mSQL
msql_dropdb | msql_drop_db() | mSQL
msql_fieldflags | msql_field_flags() | mSQL
msql_fieldlen | msql_field_len() | mSQL
msql_fieldname | msql_field_name() | mSQL
msql_fieldtable | msql_field_table() | mSQL
msql_fieldtype | msql_field_type() | mSQL
msql_freeresult | msql_free_result() | mSQL
msql_listdbs | msql_list_dbs() | mSQL
msql_listfields | msql_list_fields() | mSQL
msql_listtables | msql_list_tables() | mSQL
msql_numfields | msql_num_fields() | mSQL
msql_numrows | msql_num_rows() | mSQL
msql_regcase | sql_regcase() | mSQL
msql_selectdb | msql_select_db() | mSQL
msql_tablename | msql_result() | mSQL
mssql_affected_rows | sybase_affected_rows() | Sybase
mssql_affected_rows | sybase_affected_rows() | Sybase
mssql_close | sybase_close() | Sybase
mssql_close | sybase_close() | Sybase
mssql_connect | sybase_connect() | Sybase
mssql_connect | sybase_connect() | Sybase
mssql_data_seek | sybase_data_seek() | Sybase
mssql_data_seek | sybase_data_seek() | Sybase
mssql_fetch_array | sybase_fetch_array() | Sybase
mssql_fetch_array | sybase_fetch_array() | Sybase
mssql_fetch_field | sybase_fetch_field() | Sybase
mssql_fetch_field | sybase_fetch_field() | Sybase
mssql_fetch_object | sybase_fetch_object() | Sybase
mssql_fetch_object | sybase_fetch_object() | Sybase
mssql_fetch_row | sybase_fetch_row() | Sybase
mssql_fetch_row | sybase_fetch_row() | Sybase
mssql_field_seek | sybase_field_seek() | Sybase
mssql_field_seek | sybase_field_seek() | Sybase
mssql_free_result | sybase_free_result() | Sybase
mssql_free_result | sybase_free_result() | Sybase
mssql_get_last_message | sybase_get_last_message() | Sybase
mssql_get_last_message | sybase_get_last_message() | Sybase
mssql_min_client_severity | sybase_min_client_severity() | Sybase
mssql_min_error_severity | sybase_min_error_severity() | Sybase
mssql_min_message_severity | sybase_min_message_severity() | Sybase
mssql_min_server_severity | sybase_min_server_severity() | Sybase
mssql_num_fields | sybase_num_fields() | Sybase
mssql_num_fields | sybase_num_fields() | Sybase
mssql_num_rows | sybase_num_rows() | Sybase
mssql_num_rows | sybase_num_rows() | Sybase
mssql_pconnect | sybase_pconnect() | Sybase
mssql_pconnect | sybase_pconnect() | Sybase
mssql_query | sybase_query() | Sybase
mssql_query | sybase_query() | Sybase
mssql_result | sybase_result() | Sybase
mssql_result | sybase_result() | Sybase
mssql_select_db | sybase_select_db() | Sybase
mssql_select_db | sybase_select_db() | Sybase
multcolor | swfdisplayitem_multColor() | Ming (flash)
mysql | mysql_db_query() | MySQL
mysql_createdb | mysql_create_db() | MySQL
mysql_db_name | mysql_result() | MySQL
mysql_dbname | mysql_result() | MySQL
mysql_dropdb | mysql_drop_db() | MySQL
mysql_fieldflags | mysql_field_flags() | MySQL
mysql_fieldlen | mysql_field_len() | MySQL
mysql_fieldname | mysql_field_name() | MySQL
mysql_fieldtable | mysql_field_table() | MySQL
mysql_fieldtype | mysql_field_type() | MySQL
mysql_freeresult | mysql_free_result() | MySQL
mysql_listdbs | mysql_list_dbs() | MySQL
mysql_listfields | mysql_list_fields() | MySQL
mysql_listtables | mysql_list_tables() | MySQL
mysql_numfields | mysql_num_fields() | MySQL
mysql_numrows | mysql_num_rows() | MySQL
mysql_selectdb | mysql_select_db() | MySQL
mysql_tablename | mysql_result() | MySQL
name | domxml_attrname() | DOM XML
new_child | domxml_new_child() | DOM XML
new_xmldoc | domxml_new_xmldoc() | DOM XML
nextframe | swfmovie_nextFrame() | Ming (flash)
nextframe | swfsprite_nextFrame() | Ming (flash)
node | domxml_node() | DOM XML
oci8append | ocicollappend() | OCI8
oci8assign | ocicollassign() | OCI8
oci8assignelem | ocicollassignelem() | OCI8
oci8close | ocicloselob() | OCI8
oci8free | ocifreecoll() | OCI8
oci8free | ocifreedesc() | OCI8
oci8getelem | ocicollgetelem() | OCI8
oci8load | ociloadlob() | OCI8
oci8max | ocicollmax() | OCI8
oci8ocifreecursor | ocifreestatement() | OCI8
oci8save | ocisavelob() | OCI8
oci8savefile | ocisavelobfile() | OCI8
oci8size | ocicollsize() | OCI8
oci8trim | ocicolltrim() | OCI8
oci8writetemporary | ociwritetemporarylob() | OCI8
oci8writetofile | ociwritelobtofile() | OCI8
odbc_do | odbc_exec() | OCI8
odbc_field_precision | odbc_field_len() | OCI8
orbit_caught_exception | satellite_caught_exception() | Satellite
orbit_exception_id | satellite_exception_id() | Satellite
orbit_exception_value | satellite_exception_value() | Satellite
orbit_get_repository_id | satellite_get_repository_id() | Satellite
orbit_load_idl | satellite_load_idl() | Satellite
output | swfmovie_output() | Ming (flash)
parent | domxml_parent() | DOM XML
pdf_add_outline | pdf_add_bookmark() | PDF
pg_clientencoding | pg_client_encoding() | PostgreSQL
pg_setclientencoding | pg_set_client_encoding() | PostgreSQL
pos | current() | Base syntax
recode | recode_string() | Recode
remove | swfmovie_remove() | Ming (flash)
remove | swfsprite_remove() | Ming (flash)
rewind | rewinddir() | Base syntax
root | domxml_root() | DOM XML
rotate | swfdisplayitem_rotate() | Ming (flash)
rotateto | swfdisplayitem_rotateTo() | Ming (flash)
rotateto | swffill_rotateTo() | Ming (flash)
save | swfmovie_save() | Ming (flash)
savetofile | swfmovie_saveToFile() | Ming (flash)
scale | swfdisplayitem_scale() | Ming (flash)
scaleto | swfdisplayitem_scaleTo() | Ming (flash)
scaleto | swffill_scaleTo() | Ming (flash)
set_attribute | domxml_set_attribute() | DOM XML
set_content | domxml_set_content() | DOM XML
setaction | swfbutton_setAction() | Ming (flash)
setattr | domxml_set_attribute() | DOM XML
setbackground | swfmovie_setBackground() | Ming (flash)
setbounds | swftextfield_setBounds() | Ming (flash)
setcolor | swftext_setColor() | Ming (flash)
setcolor | swftextfield_setColor() | Ming (flash)
setdepth | swfdisplayitem_setDepth() | Ming (flash)
setdimension | swfmovie_setDimension() | Ming (flash)
setdown | swfbutton_setDown() | Ming (flash)
setfont | swftext_setFont() | Ming (flash)
setfont | swftextfield_setFont() | Ming (flash)
setframes | swfmovie_setFrames() | Ming (flash)
setframes | swfsprite_setFrames() | Ming (flash)
setheight | swftext_setHeight() | Ming (flash)
setheight | swftextfield_setHeight() | Ming (flash)
sethit | swfbutton_setHit() | Ming (flash)
setindentation | swftextfield_setIndentation() | Ming (flash)
setleftfill | swfshape_setleftfill() | Ming (flash)
setleftmargin | swftextfield_setLeftMargin() | Ming (flash)
setline | swfshape_setline() | Ming (flash)
setlinespacing | swftextfield_setLineSpacing() | Ming (flash)
setmargins | swftextfield_setMargins() | Ming (flash)
setmatrix | swfdisplayitem_setMatrix() | Ming (flash)
setname | swfdisplayitem_setName() | Ming (flash)
setname | swftextfield_setName() | Ming (flash)
setover | swfbutton_setOver() | Ming (flash)
setrate | swfmovie_setRate() | Ming (flash)
setratio | swfdisplayitem_setRatio() | Ming (flash)
setrightfill | swfshape_setrightfill() | Ming (flash)
setrightmargin | swftextfield_setRightMargin() | Ming (flash)
setspacing | swftext_setSpacing() | Ming (flash)
setup | swfbutton_setUp() | Ming (flash)
show_source | highlight_file () | Base syntax
sizeof | count() | Base syntax
skewx | swfdisplayitem_skewX() | Ming (flash)
skewxto | swfdisplayitem_skewXTo() | Ming (flash)
skewxto | swffill_skewXTo() | Ming (flash)
skewy | swfdisplayitem_skewY() | Ming (flash)
skewyto | swfdisplayitem_skewYTo() | Ming (flash)
skewyto | swffill_skewYTo() | Ming (flash)
snmpwalkoid | snmprealwalk() | SNMP
strchr | strstr() | Base syntax
streammp3 | swfmovie_streamMp3() | Ming (flash)
swfaction | swfaction_init() | Ming (flash)
swfbitmap | swfbitmap_init() | Ming (flash)
swfbutton | swfbutton_init() | Ming (flash)
swfbutton_keypress | swfbutton_keypress() | Ming (flash)
swffill | swffill_init() | Ming (flash)
swffont | swffont_init() | Ming (flash)
swfgradient | swfgradient_init() | Ming (flash)
swfmorph | swfmorph_init() | Ming (flash)
swfmovie | swfmovie_init() | Ming (flash)
swfshape | swfshape_init() | Ming (flash)
swfsprite | swfsprite_init() | Ming (flash)
swftext | swftext_init() | Ming (flash)
swftextfield | swftextfield_init() | Ming (flash)
unlink | domxml_unlink_node() | DOM XML
xpath_eval | xpath_eval() | DOM XML
xpath_eval_expression | xpath_eval_expression() | DOM XML
xpath_init | xpath_init() | DOM XML
xpath_new_context | xpath_new_context() | DOM XML
xptr_new_context | xpath_new_context() | DOM XML

Anterior | Inicio | Siguiente
Informando de errores | Subir | List of Reserved Words


List of Reserved Words

Manual de PHP
Anterior Siguiente

Apéndice G. List of Reserved Words

Tabla de contenidos
List of Keywords
Predefined Variables
Predefined Classes
???

The following is a listing of predefined identifiers in PHP. None of the identifiers listed here should be used as identifiers in a your scripts. These lists include keywords and predefined variable, constant, and class names. These lists are neither exhaustive or complete.

List of Keywords

These words have special meaning in PHP. Some of them represent things which look like functions, some look like constants, and so on--but they're not, really: they are language constructs. You cannot use any of the following words as constants, class names, or function names. Using them as variable names is generally OK, but could lead to confusion.

Tabla G-1. PHP Keywords

and | or | xor | __FILE__
__LINE__ | array() | as | break | case
cfunction | class | const | continue | declare
default | die() | do | echo() | else
elseif | empty() | enddeclare | endfor | endforeach
endif | endswitch | endwhile | eval | exit()
extends | for | foreach | function | global
if | include() | include_once() | isset() | list()
new | old_function | print() | require() | require_once()
return() | static | switch | unset() | use
var | while |  |

Anterior | Inicio | Siguiente
List of Function Aliases | Subir | Predefined Variables


Predefined Variables

Server variables: $_SERVER

Nota: Introduced in 4.1.0. In earlier versions, use $HTTP_SERVER_VARS.

$_SERVER is an array containing information such as headers, paths, and script locations. The entries in this array are created by the webserver. There is no guarantee that every webserver will provide any of these; servers may omit some, or provide others not listed here. That said, a large number of these variables are accounted for in the CGI 1.1 specification, so you should be able to expect those.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_SERVER; to access it within functions or methods, as you do with $HTTP_SERVER_VARS.

$HTTP_SERVER_VARS contains the same information, but is not an autoglobal.

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_SERVER and $HTTP_SERVER_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not autoglobals.

You may or may not find any of the following elements in $_SERVER. Note that few, if any, of these will be available (or indeed have any meaning) if running PHP on the command line.

'PHP_SELF'

The filename of the currently executing script, relative to the document root. For instance, $_SERVER['PHP_SELF'] in a script at the address http://example.com/test.php/foo.bar would be /test.php/foo.bar.

If PHP is running as a command-line processor, this variable is not available.

'argv'

Array of arguments passed to the script. When the script is run on the command line, this gives C-style access to the command line parameters. When called via the GET method, this will contain the query string.

'argc'

Contains the number of command line parameters passed to the script (if run on the command line).

'GATEWAY_INTERFACE'

What revision of the CGI specification the server is using; i.e. 'CGI/1.1'.

'SERVER_NAME'

The name of the server host under which the current script is executing. If the script is running on a virtual host, this will be the value defined for that virtual host.

'SERVER_SOFTWARE'

Server identification string, given in the headers when responding to requests.

'SERVER_PROTOCOL'

Name and revision of the information protocol via which the page was requested; i.e. 'HTTP/1.0';

'REQUEST_METHOD'

Which request method was used to access the page; i.e. 'GET', 'HEAD', 'POST', 'PUT'.

'QUERY_STRING'

The query string, if any, via which the page was accessed.

'DOCUMENT_ROOT'

The document root directory under which the current script is executing, as defined in the server's configuration file.

'HTTP_ACCEPT'

Contents of the Accept: header from the current request, if there is one.

'HTTP_ACCEPT_CHARSET'

Contents of the Accept-Charset: header from the current request, if there is one. Example: 'iso-8859-1,*,utf-8'.

'HTTP_ACCEPT_ENCODING'

Contents of the Accept-Encoding: header from the current request, if there is one. Example: 'gzip'.

'HTTP_ACCEPT_LANGUAGE'

Contents of the Accept-Language: header from the current request, if there is one. Example: 'en'.

'HTTP_CONNECTION'

Contents of the Connection: header from the current request, if there is one. Example: 'Keep-Alive'.

'HTTP_HOST'

Contents of the Host: header from the current request, if there is one.

'HTTP_REFERER'

The address of the page (if any) which referred the user agent to the current page. This is set by the user agent. Not all user agents will set this, and some provide the ability to modify HTTP_REFERER as a feature. In short, it cannot really be trusted.

'HTTP_USER_AGENT'

Contents of the User_Agent: header from the current request, if there is one. This is a string denoting the user agent being which is accessing the page. A typical example is: Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586). Among other things, you can use this value with get_browser() to tailor your page's output to the capabilities of the user agent.

'REMOTE_ADDR'

The IP address from which the user is viewing the current page.

'REMOTE_PORT'

The port being used on the user's machine to communicate with the web server.

'SCRIPT_FILENAME'

The absolute pathname of the currently executing script.

'SERVER_ADMIN'

The value given to the SERVER_ADMIN (for Apache) directive in the web server configuration file. If the script is running on a virtual host, this will be the value defined for that virtual host.

'SERVER_PORT'

The port on the server machine being used by the web server for communication. For default setups, this will be '80'; using SSL, for instance, will change this to whatever your defined secure HTTP port is.

'SERVER_SIGNATURE'

String containing the server version and virtual host name which are added to server-generated pages, if enabled.

'PATH_TRANSLATED'

Filesystem- (not document root-) based path to the current script, after the server has done any virtual-to-real mapping.

'SCRIPT_NAME'

Contains the current script's path. This is useful for pages which need to point to themselves.

'REQUEST_URI'

The URI which was given in order to access this page; for instance, '/index.html'.

Environment variables: $_ENV

Nota: Introduced in 4.1.0. In earlier versions, use $HTTP_ENV_VARS.

These variables are imported into PHP's global namespace from the environment under which the PHP parser is running. Many are provided by the shell under which PHP is running and different systems are likely running different kinds of shells, a definitive list is impossible. Please see your shell's documentation for a list of defined environment variables.

Other environment variables include the CGI variables, placed there regardless of whether PHP is running as a server module or CGI processor.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_ENV; to access it within functions or methods, as you do with $HTTP_ENV_VARS.

$HTTP_ENV_VARS contains the same information, but is not an autoglobal.

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_ENV and $HTTP_ENV_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not autoglobals.

HTTP Cookies: $_COOKIE

Nota: Introduced in 4.1.0. In earlier versions, use $HTTP_COOKIE_VARS.

An associative array of variables passed to the current script via HTTP cookies. Automatically global in any scope.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_COOKIE; to access it within functions or methods, as you do with $HTTP_COOKIE_VARS.

$HTTP_COOKIE_VARS contains the same information, but is not an autoglobal.

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_COOKIE and $HTTP_COOKIE_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not autoglobals.

HTTP GET variables: $_GET

Nota: Introduced in 4.1.0. In earlier versions, use $HTTP_GET_VARS.

An associative array of variables passed to the current script via the HTTP GET method. Automatically global in any scope.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_GET; to access it within functions or methods, as you do with $HTTP_GET_VARS.

$HTTP_GET_VARS contains the same information, but is not an autoglobal.

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_GET and $HTTP_GET_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not autoglobals.

HTTP POST variables: $_POST

Nota: Introduced in 4.1.0. In earlier versions, use $HTTP_POST_VARS.

An associative array of variables passed to the current script via the HTTP POST method. Automatically global in any scope.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_POST; to access it within functions or methods, as you do with $HTTP_POST_VARS.

$HTTP_POST_VARS contains the same information, but is not an autoglobal.

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_POST and $HTTP_POST_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not autoglobals.

HTTP File upload variables: $_FILES

Nota: Introduced in 4.1.0. In earlier versions, use $HTTP_POST_FILES.

An associative array of items uploaded to the current script via the HTTP POST method. Automatically global in any scope.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_FILES; to access it within functions or methods, as you do with $HTTP_POST_FILES.

$HTTP_POST_FILES contains the same information, but is not an autoglobal.

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_FILES and $HTTP_POST_FILES arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not autoglobals.

Request variables: $_REQUEST

Nota: Introduced in 4.1.0. There is no equivalent array in earlier versions.

An associative array consisting of the contents of $_GET, $_POST, $_COOKIE, and $_FILES.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_REQUEST; to access it within functions or methods.

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_REQUEST array. For related information, see the security chapter titled Using Register Globals. These individual globals are not autoglobals.

Session variables: $_SESSION

Nota: Introduced in 4.1.0. In earlier versions, use $HTTP_SESSION_VARS.

An associative array containing session variables available to the current script. See the Session functions documentation for more information on how this is used.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_SESSION; to access it within functions or methods, as you do with $HTTP_SESSION_VARS.

$HTTP_SESSION_VARS contains the same information, but is not an autoglobal.

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_SESSION and $HTTP_SESSION_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not autoglobals.

Global variables: $GLOBALS

Nota: $GLOBALS has been available since PHP 3.0.0.

An associative array containing references to all variables which are currently defined in the global scope of the script. The variable names are the keys of the array.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $GLOBALS; to access it within functions or methods.

The previous error message: $php_errormsg

$php_errormsg is a variable containing the text of the last error message generated by PHP. This variable will only be available within the scope in which the error occurred, and only if the track_errors configuration option is turned on (it defaults to off).

Anterior | Inicio | Siguiente
List of Reserved Words | Subir | Predefined Classes


Predefined Classes

Standard Defined Classes

These classes are defined in the standard set of functions included in the PHP build.

Directory

The class from which dir() is instantiated.

stdClass

Ming Defined Classes

These classes are defined in the Ming extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

swfshape

swffill

swfgradient

swfbitmap

swftext

swftextfield

swffont

swfdisplayitem

swfmovie

swfbutton

swfaction

swfmorph

swfsprite

Oracle 8 Defined Classes

These classes are defined in the Oracle 8 extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

OCI-Lob

OCI-Collection

qtdom Defined Classes

These classes are defined in the qtdom extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

QDomDocument

QDomNode

Anterior | Inicio | Siguiente
Predefined Variables | Subir | ???


???

Anterior | Inicio | Siguiente
Predefined Classes | Subir | Core Predefined Constants


List of Resource Types

Manual de PHP
Anterior Siguiente

Apéndice H. List of Resource Types

The following is a list of functions which create, use or destroy PHP resources. The function is_resource() can be used to determine if a variable is a resource and get_resource_type() will return the type of resource it is.

Tabla H-1. Resource Types

Resource Type Name | Created By | Used By | Destroyed By | Definition
aspell | aspell_new() | aspell_check(), aspell_check_raw(), aspell_suggest() | None | Aspell dictionary
bzip2 | bzopen() | bzerrno(), bzerror(), bzerrstr(), bzflush(), bzread(), bzwrite() | bzclose() | Bzip2 file
COM | com_load() | com_invoke(), com_propget(), com_get(), com_propput(), com_set(), com_propput() | None | COM object reference
VARIANT
cpdf | cpdf_open() | cpdf_page_init(), cpdf_finalize_page(), cpdf_finalize(), cpdf_output_buffer(), cpdf_save_to_file(), cpdf_set_current_page(), cpdf_begin_text(), cpdf_end_text(), cpdf_show(), cpdf_show_xy(), cpdf_text(), cpdf_set_font(), cpdf_set_leading(), cpdf_set_text_rendering(), cpdf_set_horiz_scaling(), cpdf_set_text_rise(), cpdf_set_text_matrix(), cpdf_set_text_pos(), cpdf_set_text_pos(), cpdf_set_word_spacing(), cpdf_continue_text(), cpdf_stringwidth(), cpdf_save(), cpdf_translate(), cpdf_restore(), cpdf_scale(), cpdf_rotate(), cpdf_setflat(), cpdf_setlinejoin(), cpdf_setlinecap(), cpdf_setmiterlimit(), cpdf_setlinewidth(), cpdf_setdash(), cpdf_moveto(), cpdf_rmoveto(), cpdf_curveto(), cpdf_lineto(), cpdf_rlineto(), cpdf_circle(), cpdf_arc(), cpdf_rect(), cpdf_closepath(), cpdf_stroke(), cpdf_closepath_fill_stroke(), cpdf_fill_stroke(), cpdf_clip(), cpdf_fill(), cpdf_setgray_fill(), cpdf_setgray_stroke(), cpdf_setgray(), cpdf_setrgbcolor_fill(), cpdf_setrgbcolor_stroke(), cpdf_setrgbcolor(), cpdf_add_outline(), cpdf_set_page_animation(), cpdf_import_jpeg(), cpdf_place_inline_image(), cpdf_add_annotation() | cpdf_close() | PDF document with CPDF lib
cpdf outline
curl | curl_init() | curl_init(), curl_exec() | curl_close() | Curl session
dbm | dbmopen() | dbmexists(), dbmfetch(), dbminsert(), dbmreplace(), dbmdelete(), dbmfirstkey(), dbmnextkey() | dbmclose() | Link to DBM database
dba | dba_popen() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | dba_close() | Link to DBA base
dba persistent | dba_open() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | None | Persistent link to DBA base
dbase | dbase_open() | dbase_pack(), dbase_add_record(), dbase_replace_record(), dbase_delete_record(), dbase_get_record(), dbase_get_record_with_names(), dbase_numfields(), dbase_numrecords() | dbase_close() | Link to Dbase base
dbx_link_object | dbx_connect() | dbx_query() | dbx_close() | dbx connection
dbx_result_object dbx_query() () None dbx result
domxml attribute
domxml document
domxml node
xpath context
xpath object
fbsql database fbsql_select_db() () None fbsql database
fbsql link | fbsql_change_user(), fbsql_connect() | fbsql_autocommit(), fbsql_change_user(), fbsql_create_db(), fbsql_data_seek(), fbsql_db_query(), fbsql_drop_db(), (), fbsql_select_db(), fbsql_errno(), fbsql_error(), fbsql_insert_id(), fbsql_list_dbs() | fbsql_close() | Link to fbsql database
fbsql plink | fbsql_change_user(), fbsql_pconnect() | fbsql_autocommit(), fbsql_change_user(), fbsql_create_db(), fbsql_data_seek(), fbsql_db_query(), fbsql_drop_db(), (), fbsql_select_db(), fbsql_errno(), fbsql_error(), fbsql_insert_id(), fbsql_list_dbs() | None | Persistent link to fbsql database
fbsql result | fbsql_db_query(), fbsql_list_dbs(), fbsql_query(), fbsql_list_fields(), fbsql_list_tables(), fbsql_tablename() | fbsql_affected_rows(), fbsql_fetch_array(), fbsql_fetch_assoc(), fbsql_fetch_field(), fbsql_fetch_lengths(), fbsql_fetch_object(), fbsql_fetch_row(), fbsql_field_flags(), fbsql_field_name(), fbsql_field_len(), fbsql_field_seek(), fbsql_field_table(), fbsql_field_type(), fbsql_next_result(), fbsql_num_fields(), fbsql_num_rows(), fbsql_result(), fbsql_num_rows() | fbsql_free_result() | fbsql result
fdf | fdf_open() | fdf_create(), fdf_save(), fdf_get_value(), fdf_set_value(), fdf_next_field_name(), fdf_set_ap(), fdf_set_status(), fdf_get_status(), fdf_set_file(), fdf_get_file(), fdf_set_flags(), fdf_set_opt(), fdf_set_submit_form_action(), fdf_set_javascript_action() | fdf_close() | FDF File
ftp | ftp_connect() | ftp_login(), ftp_pwd(), ftp_cdup(), ftp_chdir(), ftp_mkdir(), ftp_rmdir(), ftp_nlist(), ftp_rawlist(), ftp_systype(), ftp_pasv(), ftp_get(), ftp_fget(), ftp_put(), ftp_fput(), ftp_size(), ftp_mdtm(), ftp_rename(), ftp_delete(), ftp_site() | ftp_quit() | FTP stream
gd | imagecreate(), imagecreatefromgif(), imagecreatefromjpeg(), imagecreatefrompng(), imagecreatefromwbmp(), imagecreatefromstring(), imagecreatetruecolor() | imagearc(), imagechar(), imagecharup(), imagecolorallocate(), imagecolorat(), imagecolorclosest(), imagecolorexact(), imagecolorresolve(), imagegammacorrect(), imagegammacorrect(), imagecolorset(), imagecolorsforindex(), imagecolorstotal(), imagecolortransparent(), imagecopy(), imagecopyresized(), imagedashedline(), imagefill(), imagefilledpolygon(), imagefilledrectangle(), imagefilltoborder(), imagegif(), imagepng(), imagejpeg(), imagewbmp(), imageinterlace(), imageline(), imagepolygon(), imagepstext(), imagerectangle(), imagesetpixel(), imagestring(), imagestringup(), imagesx(), imagesy(), imagettftext(), imagefilledarc(), imageellipse(), imagefilledellipse(), imagecolorclosestalpha(), imagecolorexactalpha(), imagecolorresolvealpha(), imagecopymerge(), imagecopymergegray(), imagecopyresampled(), imagetruecolortopalette(), imagesetbrush(), imagesettile(), imagesetthickness() | imagedestroy() | GD Image
gd font | imageloadfont() | imagechar(), imagecharup(), imagefontheight() | None | Font for GD
gd PS encoding
gd PS font | imagepsloadfont() | imagepstext(), imagepsslantfont(), imagepsextendfont(), imagepsencodefont(), imagepsbbox() | imagepsfreefont() | PS font for GD
GMP integer | gmp_init() | gmp_intval(), gmp_strval(), gmp_add(), gmp_sub(), gmp_mul(), gmp_div_q(), gmp_div_r(), gmp_div_qr(), gmp_div(), gmp_mod(), gmp_divexact(), gmp_cmp(), gmp_neg(), gmp_abs(), gmp_sign(), gmp_fact(), gmp_sqrt(), gmp_sqrtrm(), gmp_perfect_square(), gmp_pow(), gmp_powm(), gmp_prob_prime(), gmp_gcd(), gmp_gcdext(), gmp_invert(), gmp_legendre(), gmp_jacobi(), gmp_random(), gmp_and(), gmp_or(), gmp_xor(), gmp_setbit(), gmp_clrbit(), gmp_scan0(), gmp_scan1(), gmp_popcount(), gmp_hamdist() | None | GMP Number
hyperwave document | hw_cp(), hw_docbyanchor(), hw_getremote(), hw_getremotechildren() | hw_children(), hw_childrenobj(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getsrcbydestobj(), hw_getandlock(), hw_gettext(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_inscoll(), hw_pipedocument(), hw_unlock() | hw_deleteobject() | Hyperwave object
hyperwave link | hw_connect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | hw_close(), hw_free_document() | Link to Hyperwave server
hyperwave link persistent | hw_pconnect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | None | Persistent link to Hyperwave server
icap | icap_open() | icap_fetch_event(), icap_list_events(), icap_store_event(), icap_snooze(), icap_list_alarms(), icap_delete_event() | icap_close() | Link to icap server
imap | imap_open() | imap_append(), imap_body(), imap_check(), imap_createmailbox(), imap_delete(), imap_deletemailbox(), imap_expunge(), imap_fetchbody(), imap_fetchstructure(), imap_headerinfo(), imap_header(), imap_headers(), imap_listmailbox(), imap_getmailboxes(), imap_get_quota(), imap_status(), imap_listsubscribed(), imap_set_quota(), imap_set_quota(), imap_getsubscribed(), imap_mail_copy(), imap_mail_move(), imap_num_msg(), imap_num_recent(), imap_ping(), imap_renamemailbox(), imap_reopen(), imap_subscribe(), imap_undelete(), imap_unsubscribe(), imap_scanmailbox(), imap_mailboxmsginfo(), imap_fetchheader(), imap_uid(), imap_msgno(), imap_search(), imap_fetch_overview() | imap_close() | Link to IMAP, POP3 server
imap chain persistent
imap persistent
ingres | ingres_connect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | ingres_close() | Link to ingresII base
ingres persistent | ingres_pconnect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | None | Persistent link to ingresII base
interbase blob
interbase link | ibase_connect() | ibase_query(), ibase_prepare(), ibase_trans() | ibase_close() | Link to Interbase database
interbase link persistent | ibase_pconnect() | ibase_query(), ibase_prepare(), ibase_trans() | None | Persistent link to Interbase database
interbase query | ibase_prepare() | ibase_execute() | ibase_free_query() | Interbase query
interbase result | ibase_query() | ibase_fetch_row(), ibase_fetch_object(), ibase_field_info(), ibase_num_fields() | ibase_free_result() | Interbase Result
interbase transaction | ibase_trans() | ibase_commit() | ibase_rollback() | Interbase transaction
java
ldap link | ldap_connect(), ldap_search() | ldap_count_entries(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_next_attribute(), ldap_next_entry() | ldap_close() | ldap connection
ldap result | ldap_read() | ldap_add(), ldap_compare(), ldap_bind(), ldap_count_entries(), ldap_delete(), ldap_errno(), ldap_error(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_get_option(), ldap_list(), ldap_modify(), ldap_mod_add(), ldap_mod_replace(), ldap_next_attribute(), ldap_next_entry(), ldap_mod_del(), ldap_set_option(), ldap_unbind() | ldap_free_result() | ldap search result
ldap result entry
mcal | mcal_open(), mcal_popen() | mcal_create_calendar(), mcal_rename_calendar(), mcal_rename_calendar(), mcal_delete_calendar(), mcal_fetch_event(), mcal_list_events(), mcal_append_event(), mcal_store_event(), mcal_delete_event(), mcal_list_alarms(), mcal_event_init(), mcal_event_set_category(), mcal_event_set_title(), mcal_event_set_description(), mcal_event_set_start(), mcal_event_set_end(), mcal_event_set_alarm(), mcal_event_set_class(), mcal_next_recurrence(), mcal_event_set_recur_none(), mcal_event_set_recur_daily(), mcal_event_set_recur_weekly(), mcal_event_set_recur_monthly_mday(), mcal_event_set_recur_monthly_wday(), mcal_event_set_recur_yearly(), mcal_fetch_current_stream_event(), mcal_event_add_attribute(), mcal_expunge() | mcal_close() | Link to calendar server
SWFAction
SWFBitmap
SWFButton
SWFDisplayItem
SWFFill
SWFFont
SWFGradient
SWFMorph
SWFMovie
SWFShape
SWFSprite
SWFText
SWFTextField
mnogosearch agent
mnogosearch result
msql link | msql_connect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | msql_close() | Link to mSQL database
msql link persistent | msql_pconnect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | None | Persistent link to mSQL
msql query | msql_query() | msql(), msql_affected_rows(), msql_data_seek(), msql_dbname(), msql_fetch_array(), msql_fetch_field(), msql_fetch_object(), msql_fetch_row(), msql_fieldname(), msql_field_seek(), msql_fieldtable(), msql_fieldtype(), msql_fieldflags(), msql_fieldlen(), msql_num_fields(), msql_num_rows(), msql_numfields(), msql_numrows(), msql_result() | msql_free_result(), msql_free_result() | mSQL result
mssql link | mssql_connect() | mssql_query(), mssql_select_db() | mssql_close() | Link to Microsft SQL Server database
mssql link persistent | mssql_pconnect() | mssql_query(), mssql_select_db() | None | Persistent link to Microsft SQL Server
mssql result | mssql_query() | mssql_data_seek(), mssql_fetch_array(), mssql_fetch_field(), mssql_fetch_object(), mssql_fetch_row(), mssql_field_length(), mssql_field_name(), mssql_field_seek(), mssql_field_type(), mssql_num_fields(), mssql_num_rows(), mssql_result() | mssql_free_result() | Microsft SQL Server result
mysql link | mysql_connect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | mysql_close() | Link to MySQL database
mysql link persistent | mysql_pconnect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | None | Persistent link to MySQL database
mysql result | mysql_db_query(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query() | mysql_data_seek(), mysql_db_name(), mysql_fetch_array(), mysql_fetch_assoc(), mysql_fetch_field(), mysql_fetch_lengths(), mysql_fetch_object(), mysql_fetch_row(), mysql_fetch_row(), mysql_field_flags(), mysql_field_name(), mysql_field_len(), mysql_field_seek(), mysql_field_table(), mysql_field_type(), mysql_num_fields(), mysql_num_rows(), mysql_result(), mysql_tablename() | mysql_free_result() | MySQL result
oci8 collection
oci8 connection | ocilogon(), ociplogon(), ocinlogon() | ocicommit(), ociserverversion(), ocinewcursor(), ociparse(), ocierror() | ocilogoff() | Link to Oracle database
oci8 descriptor
oci8 server
oci8 session
oci8 statement | ocinewdescriptor() | ocirollback(), ocinewdescriptor(), ocirowcount(), ocidefinebyname(), ocibindbyname(), ociexecute(), ocinumcols(), ociresult(), ocifetch(), ocifetchinto(), ocifetchstatement(), ocicolumnisnull(), ocicolumnname(), ocicolumnsize(), ocicolumntype(), ocistatementtype(), ocierror() | ocifreestatement() | Oracle Cursor
odbc link | odbc_connect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | odbc_close() | Link to ODBC database
odbc link persistent | odbc_connect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | None | Persistent link to ODBC database
odbc result | odbc_prepare() | odbc_binmode(), odbc_cursor(), odbc_execute(), odbc_fetch_into(), odbc_fetch_row(), odbc_field_name(), odbc_field_num(), odbc_field_type(), odbc_field_len(), odbc_field_precision(), odbc_field_scale(), odbc_longreadlen(), odbc_num_fields(), odbc_num_rows(), odbc_result(), odbc_result_all(), odbc_setoption() | odbc_free_result() | ODBC result
birdstep link
birdstep result
OpenSSL key | openssl_get_privatekey(), openssl_get_publickey() | openssl_sign(), openssl_seal(), openssl_open(), openssl_verify() | openssl_free_key() | OpenSSL key
OpenSSL X.509 | openssl_x509_read() | openssl_x509_parse(), openssl_x509_checkpurpose() | openssl_x509_free() | Public Key
oracle Cursor | ora_open() | ora_bind(), ora_columnname(), ora_columnsize(), ora_columntype(), ora_error(), ora_errorcode(), ora_exec(), ora_fetch(), ora_fetch_into(), ora_getcolumn(), ora_numcols(), ora_numrows(), ora_parse() | ora_close() | Oracle cursor
oracle link | ora_logon() | ora_do(), ora_error(), ora_errorcode(), ora_rollback(), ora_commitoff(), ora_commiton(), ora_open(), ora_commit() | ora_logoff() | Link to oracle database
oracle link persistent | ora_plogon() | ora_do(), ora_error(), ora_errorcode(), ora_rollback(), ora_commitoff(), ora_commiton(), ora_open(), ora_commit() | None | Persistent link to oracle database
pdf document | pdf_new() | pdf_add_bookmark(), pdf_add_launchlink(), pdf_add_locallink(), pdf_add_note(), pdf_add_pdflink(), pdf_add_weblink(), pdf_arc(), pdf_attach_file(), pdf_begin_page(), pdf_circle(), pdf_clip(), pdf_closepath(), pdf_closepath_fill_stroke(), pdf_closepath_stroke(), pdf_concat(), pdf_continue_text(), pdf_curveto(), pdf_end_page(), pdf_endpath(), pdf_fill(), pdf_fill_stroke(), pdf_findfont(), pdf_get_buffer(), pdf_get_image_height(), pdf_get_image_width(), pdf_get_parameter(), pdf_get_value(), pdf_lineto(), pdf_moveto(), pdf_open_ccitt(), pdf_open_file(), pdf_open_image_file(), pdf_place_image(), pdf_rect(), pdf_restore(), pdf_rotate(), pdf_save(), pdf_scale(), pdf_setdash(), pdf_setflat(), pdf_setfont(), pdf_setgray(), pdf_setgray_fill(), pdf_setgray_stroke(), pdf_setlinecap(), pdf_setlinejoin(), pdf_setlinewidth(), pdf_setmiterlimit(), pdf_setpolydash(), pdf_setrgbcolor(), pdf_setrgbcolor_fill(), pdf_setrgbcolor_stroke(), pdf_set_border_color(), pdf_set_border_dash(), pdf_set_border_style(), pdf_set_char_spacing(), pdf_set_duration(), pdf_set_font(), pdf_set_horiz_scaling(), pdf_set_parameter(), pdf_set_text_pos(), pdf_set_text_rendering(), pdf_set_value(), pdf_set_word_spacing(), pdf_show(), pdf_show_boxed(), pdf_show_xy(), pdf_skew(), pdf_stringwidth(), pdf_stroke(), pdf_translate(), pdf_open_memory_image() | pdf_close(), pdf_delete() | PDF document
pdf image | pdf_open_image(), pdf_open_image_file(), pdf_open_memory_image() | pdf_get_image_height(), pdf_get_image_width(), pdf_open_CCITT(), pdf_place_image() | pdf_close_image() | Image in PDF file
pdf object
pdf outline
pgsql large object | pg_lo_open() | pg_lo_open(), pg_lo_create(), pg_lo_read(), pg_lo_read_all(), pg_lo_seek(), pg_lo_tell(), pg_lo_unlink(), pg_lo_write() | pg_lo_close() | PostgreSQL Large Object
pgsql link | pg_connect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | pg_close() | Link to PostgreSQL database
pgsql link persistent | pg_pconnect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | None | Persistent link to PostgreSQL database
pgsql result | pg_query(), pg_get_result() | pg_fetch_array(), pg_fetch_object(), pg_fetch_result(), pg_fetch_row(), pg_field_is_null(), pg_field_name(), pg_field_num(), pg_field_prtlen(), pg_field_size(), pg_field_type(), pg_last_oid(), pg_num_fields(), pg_num_rows(), pg_result_error(), pg_result_status() | pg_free_result() | PostgreSQL result
pgsql string
printer
printer brush
printer font
printer pen
pspell | pspell_new(), pspell_new_config(), pspell_new_personal() | pspell_add_to_personal(), pspell_add_to_session(), pspell_check(), pspell_clear_session(), pspell_config_ignore(), pspell_config_mode(), pspell_config_personal(), pspell_config_repl(), pspell_config_runtogether(), pspell_config_save_repl(), pspell_save_wordlist(), pspell_store_replacement(), pspell_suggest() | None | pspell dictionary
pspell config | pspell_config_create() | pspell_new_config() | None | pspell configuration
Sablotron XSLT | xslt_create() | xslt_closelog(), xslt_openlog(), xslt_run(), xslt_set_sax_handler(), xslt_errno(), xslt_error(), xslt_fetch_result(), xslt_free() | xslt_free() | XSLT parser
shmop | shmop_open() | shmop_read(), shmop_write(), shmop_size(), shmop_delete() | shmop_close()
sockets file descriptor set | socket() | accept_connect(), bind(), connect(), listen(), read(), write() | close() | Socket
sockets i/o vector
dir | dir() | readdir(), rewinddir() | closedir() | Dir handle
file | fopen() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), flock(), fpassthru(), fputs(), fwrite(), fread(), fseek(), ftell(), fstat(), ftruncate(), set_file_buffer(), rewind() | fclose() | File handle
pipe | popen() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | pclose() | Process handle
socket | fsockopen() | fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | fclose() | Socket handle
stream
sybase-db link | sybase_connect() | sybase_query(), sybase_select_db() | sybase_close() | Link to Sybase database using DB library
sybase-db link persistent | sybase_pconnect() | sybase_query(), sybase_select_db() | None | Persistent link to Sybase database using DB library
sybase-db result | sybase_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Sybase result using DB library
sybase-ct link | sybase_connect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | sybase_close() | Link to Sybase database using CT library
sybase-ct link persistent | sybase_pconnect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | None | Persistent link to Sybase database using CT library
sybase-ct result | sybase_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Sybase result using CT library
sysvsem | sem_get() | sem_acquire() | sem_release() | System V Semaphore
sysvshm | shm_attach() | shm_remove(), shm_put_var(), shm_get_var(), shm_remove_var() | shm_detach() | System V Shared Memory
wddx | wddx_packet_start() | wddx_add_vars() | wddx_packet_end() | WDDX packet
xml | xml_parser_create() | xml_set_object(), xml_set_element_handler(), xml_set_character_data_handler(), xml_set_processing_instruction_handler(), xml_set_default_handler(), xml_set_unparsed_entity_decl_handler(), xml_set_notation_decl_handler(), xml_set_external_entity_ref_handler(), xml_parse(), xml_get_error_code(), xml_error_string(), xml_get_current_line_number(), xml_get_current_column_number(), xml_get_current_byte_index(), xml_parse_into_struct(), xml_parser_set_option(), xml_parser_get_option() | xml_parser_free() | XML parser
zlib | gzopen() | gzeof(), gzgetc(), gzgets(), gzgetss(), gzpassthru(), gzputs(), gzread(), gzrewind(), gzseek(), gztell(), gzwrite() | gzclose() | gz-compressed file

Anterior | Inicio | Siguiente
zlib Predefined Constants | Subir | About the manual


About the manual

Manual de PHP
Anterior Siguiente

Apéndice I. About the manual

Tabla de contenidos
Formats
About user notes
How to find more information about PHP
How to help improve the documentation
How we generate the formats

Formats

The PHP manual is provided in several formats. These formats can be divided into two groups: online readable formats, and downloadable packages.

Nota: Some publishers have made available printed versions of this manual. We cannot recommend any of those, as they tend to become out-of-date very quickly.

You can read the manual online at http://www.php.net/ and on the numerous mirror sites. For best performance, you should choose the mirror site closest to you. You can view the manual in either its plain (print-friendly) HTML format or an HTML format that integrates the manual into the look and feel of the PHP website itself.

An advantage of the online manual over most of the offline formats is the integration of user-contributed notes. An obvious disadvantage is that you have to be online to view the manual in the online formats.

There are several offline formats of the manual, and the most appropriate format for you depends on what operating system you use and your personal reading style. For information on how the manual is generated in so many formats, read the 'How we generate the formats' section of this appendix.

The most cross-platform formats of the manual are the HTML and plain-text versions. The HTML format is provided both as a single HTML file and as a package of individual files for each section (which results in a collection of several thousand files). The HTML and plaintext formats are provided as tar files compressed using the bzip2 archiver.

Another popular cross-platform format, and the format most suited to printing, is PDF (also known as Adobe Acrobat). But before you rush to download this format and hit the Print button, be warned that the manual is nearly 2000 pages long, and constantly being revised.

Nota: If you do not already have a program capable of viewing PDF format files, you may need to download Adobe Acrobat Reader.

For owners of Palm-compatible handhelds, the Palm document and iSilo formats are ideal for this platform. You can bring your handheld with you on your daily commute and use a DOC or iSilo reader to brush up on your PHP knowledge, or just use it as a quick reference.

For Windows platforms, the Windows HTML Help version of the manual soups up the HTML format for use with the Windows HTML Help application. This version provides full-text search, a full index, and bookmarking. Many popular Windows PHP development environments also integrate with this version of the documentation to provide easy access.

Nota: A Visual Basic for Linux project is in the planning stage, which will include the development of a CHM Creator and Viewer for Linux. See their SourceForge.net page if you are interested in the progress.

Anterior | Inicio | Siguiente
List of Resource Types | Subir | About user notes


About user notes

The user-contributed notes play an important role in the development of this manual. By allowing readers of the manual to contribute examples, caveats, and further clarifications from their browser, we are able to incorporate that feedback into the main text of the manual. And until the notes have been incorporated, they can be viewed in their submitted form online and in some of the offline formats.

Nota: The user-contributed notes are not moderated before they appear online, so the quality of the writing or code examples, and even the veracity of the contribution, cannot be guaranteed. (Not that there is any guarantee of the quality or accuracy of the manual text itself.)

Anterior | Inicio | Siguiente
About the manual | Subir | How to find more information about PHP


How to find more information about PHP

This manual does not attempt to provide instruction about general programming practices. If you are a first-time, or even just a beginning, programmer, you may find it difficult to learn how to program in PHP using just this manual. You may want to seek out a text more oriented towards beginners. You can find a list of PHP-related books at http://www.php.net/books.php.

There are a number of active mailing lists for discussion of all aspects of programming with PHP. If you find yourself stuck on a problem for which you can't find your own solution, you may be able to get help from someone on these lists. You can find a list of the mailing lists at http://www.php.net/support.php, as well as links to the mailing list archives and other online support resources. Furthermore, at http://www.php.net/links.php there is a list of websites devoted to PHP articles, forums, and code galleries.

Anterior | Inicio | Siguiente
About user notes | Subir | How to help improve the documentation


How to help improve the documentation

There are two ways you can help to improve this documentation.

If you find errors in this manual, in any language, please report them using the bug system at http://bugs.php.net/. Classify the bug as "Documentation Problem". You can also submit problems related to specific manual formats here.

Nota: Please don't abuse the bug system by submitting requests for help. Use the mailing lists or community sites mentioned earlier, instead.

By contributing notes, you can provide additional examples, caveats, and clarifications for other readers. But do not submit bug reports using the annotation system please. You can read more about annotations in the 'About user notes' section of this appendix.

Anterior | Inicio | Siguiente
How to find more information about PHP | Subir | How we generate the formats


How we generate the formats

This manual is written in XML using the DocBook XML DTD, using DSSSL (Document Style and Semantics Specification Language) for formatting, and experimentally the XSLT (Extensible Stylesheet Language Transformations) for maintenance and formatting.

Using XML as a source format gives us the ability to generate many output formats from the source files, while only maintaining one source document for all formats. The tools used for formatting HTML and TeX versions are Jade, written by James Clark and The Modular DocBook Stylesheets written by Norman Walsh. We use Microsoft HTML Help Workshop to generate the Windows HTML Help format of the manual, and of course PHP itself to do some additional conversions and formatting.

You can download the manual in various languages and formats, including plain text, plain HTML, PDF, PalmPilot DOC, PalmPilot iSilo and Windows HTML Help, from http://www.php.net/docs.php. The manuals are updated automatically as the text is updated.

You can find more information about downloading the XML source code of this documentation at http://cvs.php.net/. The documentation is stored in the phpdoc module.

Anterior | Inicio | Siguiente
How to help improve the documentation | Subir | Function Index


Function Index

A

abs()
acos()
acosh()
addcslashes()
addslashes()
apache_child_terminate()
apache_lookup_uri()
apache_note()
apache_setenv()
array()
array_change_key_case()
array_chunk()
array_count_values()
array_diff()
array_fill()
array_filter()
array_flip()
array_intersect()
array_key_exists()
array_keys()
array_map()
array_merge()
array_merge_recursive()
array_multisort()
array_pad()
array_pop()
array_push()
array_rand()
array_reduce()
array_reverse()
array_search()
array_shift()
array_slice()
array_splice()
array_sum()
array_unique()
array_unshift()
array_values()
array_walk()
arsort()
ascii2ebcdic()
asin()
asinh()
asort()
aspell_check()
aspell_check_raw()
aspell_new()
aspell_suggest()
assert()
assert_options()
atan()
atan2()
atanh()

B

base64_decode()
base64_encode()
base_convert()
basename()
bcadd()
bccomp()
bcdiv()
bcmod()
bcmul()
bcpow()
bcscale()
bcsqrt()
bcsub()
bin2hex()
bind_textdomain_codeset()
bindec()
bindtextdomain()
bzclose()
bzcompress()
bzdecompress()
bzerrno()
bzerror()
bzerrstr()
bzflush()
bzopen()
bzread()
bzwrite()

C

cal_days_in_month()
cal_from_jd()
cal_info()
cal_to_jd()
call_user_func()
call_user_func_array()
call_user_method()
call_user_method_array()
ccvs_add()
ccvs_auth()
ccvs_command()
ccvs_count()
ccvs_delete()
ccvs_done()
ccvs_init()
ccvs_lookup()
ccvs_new()
ccvs_report()
ccvs_return()
ccvs_reverse()
ccvs_sale()
ccvs_status()
ccvs_textvalue()
ccvs_void()
ceil()
chdir()
checkdate()
checkdnsrr()
chgrp()
chmod()
chop()
chown()
chr()
chroot()
chunk_split()
class_exists()
clearstatcache()
closedir()
closelog()
com()
com_addref()
com_get()
com_invoke()
com_isenum()
com_load()
com_load_typelib()
com_propget()
com_propput()
com_propset()
com_release()
com_set()
compact()
connection_aborted()
connection_status()
connection_timeout()
constant()
convert_cyr_string()
copy()
cos()
cosh()
count()
count_chars()
cpdf_add_annotation()
cpdf_add_outline()
cpdf_arc()
cpdf_begin_text()
cpdf_circle()
cpdf_clip()
cpdf_close()
cpdf_closepath()
cpdf_closepath_fill_stroke()
cpdf_closepath_stroke()
cpdf_continue_text()
cpdf_curveto()
cpdf_end_text()
cpdf_fill()
cpdf_fill_stroke()
cpdf_finalize()
cpdf_finalize_page()
cpdf_global_set_document_limits()
cpdf_import_jpeg()
cpdf_lineto()
cpdf_moveto()
cpdf_newpath()
cpdf_open()
cpdf_output_buffer()
cpdf_page_init()
cpdf_place_inline_image()
cpdf_rect()
cpdf_restore()
cpdf_rlineto()
cpdf_rmoveto()
cpdf_rotate()
cpdf_rotate_text()
cpdf_save()
cpdf_save_to_file()
cpdf_scale()
cpdf_set_action_url()
cpdf_set_char_spacing()
cpdf_set_creator()
cpdf_set_current_page()
cpdf_set_font()
cpdf_set_font_directories()
cpdf_set_font_map_file()
cpdf_set_horiz_scaling()
cpdf_set_keywords()
cpdf_set_leading()
cpdf_set_page_animation()
cpdf_set_subject()
cpdf_set_text_matrix()
cpdf_set_text_pos()
cpdf_set_text_rendering()
cpdf_set_text_rise()
cpdf_set_title()
cpdf_set_viewer_preferences()
cpdf_set_word_spacing()
cpdf_setdash()
cpdf_setflat()
cpdf_setgray()
cpdf_setgray_fill()
cpdf_setgray_stroke()
cpdf_setlinecap()
cpdf_setlinejoin()
cpdf_setlinewidth()
cpdf_setmiterlimit()
cpdf_setrgbcolor()
cpdf_setrgbcolor_fill()
cpdf_setrgbcolor_stroke()
cpdf_show()
cpdf_show_xy()
cpdf_stringwidth()
cpdf_stroke()
cpdf_text()
cpdf_translate()
crack_check()
crack_closedict()
crack_getlastmessage()
crack_opendict()
crc32()
create_function()
crypt()
ctype_alnum()
ctype_alpha()
ctype_cntrl()
ctype_digit()
ctype_graph()
ctype_lower()
ctype_print()
ctype_punct()
ctype_space()
ctype_upper()
ctype_xdigit()
curl_close()
curl_errno()
curl_error()
curl_exec()
curl_getinfo()
curl_init()
curl_setopt()
curl_version()
current()
cybercash_base64_decode()
cybercash_base64_encode()
cybercash_decr()
cybercash_encr()
cybermut_creerformulairecm()
cybermut_creerreponsecm()
cybermut_testmac()
cyrus_authenticate()
cyrus_bind()
cyrus_close()
cyrus_connect()
cyrus_query()
cyrus_unbind()

D

date()
dba_close()
dba_delete()
dba_exists()
dba_fetch()
dba_firstkey()
dba_insert()
dba_nextkey()
dba_open()
dba_optimize()
dba_popen()
dba_replace()
dba_sync()
dbase_add_record()
dbase_close()
dbase_create()
dbase_delete_record()
dbase_get_record()
dbase_get_record_with_names()
dbase_numfields()
dbase_numrecords()
dbase_open()
dbase_pack()
dbase_replace_record()
dblist()
dbmclose()
dbmdelete()
dbmexists()
dbmfetch()
dbmfirstkey()
dbminsert()
dbmnextkey()
dbmopen()
dbmreplace()
dbplus_add()
dbplus_aql()
dbplus_chdir()
dbplus_close()
dbplus_curr()
dbplus_errcode()
dbplus_errno()
dbplus_find()
dbplus_first()
dbplus_flush()
dbplus_freealllocks()
dbplus_freelock()
dbplus_freerlocks()
dbplus_getlock()
dbplus_getunique()
dbplus_info()
dbplus_last()
dbplus_lockrel()
dbplus_next()
dbplus_open()
dbplus_prev()
dbplus_rchperm()
dbplus_rcreate()
dbplus_rcrtexact()
dbplus_rcrtlike()
dbplus_resolve()
dbplus_restorepos()
dbplus_rkeys()
dbplus_ropen()
dbplus_rquery()
dbplus_rrename()
dbplus_rsecindex()
dbplus_runlink()
dbplus_rzap()
dbplus_savepos()
dbplus_setindex()
dbplus_setindexbynumber()
dbplus_sql()
dbplus_tcl()
dbplus_tremove()
dbplus_undo()
dbplus_undoprepare()
dbplus_unlockrel()
dbplus_unselect()
dbplus_update()
dbplus_xlockrel()
dbplus_xunlockrel()
dbx_close()
dbx_compare()
dbx_connect()
dbx_error()
dbx_query()
dbx_sort()
dcgettext()
dcngettext()
dcngettext()
debugger_off()
debugger_on()
decbin()
dechex()
decoct()
define()
define_syslog_variables()
defined()
deg2rad()
delete()
dgettext()
die()
dio_close()
dio_fcntl()
dio_open()
dio_read()
dio_seek()
dio_stat()
dio_truncate()
dio_write()
dir()
dirname()
disk_free_space()
disk_total_space()
diskfreespace()
dl()
domxml_add_root()
domxml_attributes()
domxml_children()
domxml_dumpmem()
domxml_get_attribute()
domxml_new_child()
domxml_new_xmldoc()
domxml_node()
domxml_node_set_content()
domxml_node_unlink_node()
domxml_root()
domxml_set_attribute()
domxml_version()
dotnet_load()
doubleval()

E

each()
easter_date()
easter_days()
ebcdic2ascii()
echo()
empty()
end()
ereg()
ereg_replace()
eregi()
eregi_replace()
error_log()
error_reporting()
escapeshellarg()
escapeshellcmd()
eval()
exec()
exit()
exp()
explode()
expm1()
extension_loaded()
extract()
ezmlm_hash()

F

fbsql_affected_rows()
fbsql_autocommit()
fbsql_change_user()
fbsql_close()
fbsql_commit()
fbsql_connect()
fbsql_create_blob()
fbsql_create_clob()
fbsql_create_db()
fbsql_data_seek()
fbsql_database()
fbsql_database_password()
fbsql_db_query()
fbsql_db_status()
fbsql_drop_db()
fbsql_errno()
fbsql_error()
fbsql_fetch_array()
fbsql_fetch_assoc()
fbsql_fetch_field()
fbsql_fetch_lengths()
fbsql_fetch_object()
fbsql_fetch_row()
fbsql_field_flags()
fbsql_field_len()
fbsql_field_name()
fbsql_field_seek()
fbsql_field_table()
fbsql_field_type()
fbsql_free_result()
fbsql_get_autostart_info()
fbsql_hostname()
fbsql_insert_id()
fbsql_list_dbs()
fbsql_list_fields()
fbsql_list_tables()
fbsql_next_result()
fbsql_num_fields()
fbsql_num_rows()
fbsql_password()
fbsql_pconnect()
fbsql_query()
fbsql_read_blob()
fbsql_read_clob()
fbsql_result()
fbsql_rollback()
fbsql_select_db()
fbsql_set_lob_mode()
fbsql_set_transaction()
fbsql_start_db()
fbsql_stop_db()
fbsql_tablename()
fbsql_username()
fbsql_warnings()
fclose()
fdf_add_template()
fdf_close()
fdf_create()
fdf_get_file()
fdf_get_status()
fdf_get_value()
fdf_next_field_name()
fdf_open()
fdf_save()
fdf_set_ap()
fdf_set_encoding()
fdf_set_file()
fdf_set_flags()
fdf_set_javascript_action()
fdf_set_opt()
fdf_set_status()
fdf_set_submit_form_action()
fdf_set_value()
feof()
fflush()
fgetc()
fgetcsv()
fgets()
fgetss()
file()
file_exists()
fileatime()
filectime()
filegroup()
fileinode()
filemtime()
fileowner()
fileperms()
filepro()
filepro_fieldcount()
filepro_fieldname()
filepro_fieldtype()
filepro_fieldwidth()
filepro_retrieve()
filepro_rowcount()
filesize()
filetype()
floatval()
flock()
floor()
flush()
fopen()
fpassthru()
fputs()
fread()
frenchtojd()
fribidi_log2vis()
fscanf()
fseek()
fsockopen()
fstat()
ftell()
ftok()
ftp_cdup()
ftp_chdir()
ftp_close()
ftp_connect()
ftp_delete()
ftp_exec()
ftp_fget()
ftp_fput()
ftp_get()
ftp_get_option()
ftp_login()
ftp_mdtm()
ftp_mkdir()
ftp_nlist()
ftp_pasv()
ftp_put()
ftp_pwd()
ftp_quit()
ftp_rawlist()
ftp_rename()
ftp_rmdir()
ftp_set_option()
ftp_site()
ftp_size()
ftp_systype()
ftruncate()
func_get_arg()
func_get_args()
func_num_args()
function_exists()
fwrite()

G

get_browser()
get_cfg_var()
get_class()
get_class_methods()
get_class_vars()
get_current_user()
get_declared_classes()
get_defined_constants()
get_defined_functions()
get_defined_vars()
get_extension_funcs()
get_html_translation_table()
get_included_files()
get_loaded_extensions()
get_magic_quotes_gpc()
get_magic_quotes_runtime()
get_meta_tags()
get_object_vars()
get_parent_class()
get_required_files()
get_resource_type()
getallheaders()
getcwd()
getdate()
getenv()
gethostbyaddr()
gethostbyname()
gethostbynamel()
getimagesize()
getlastmod()
getmxrr()
getmygid()
getmyinode()
getmypid()
getmyuid()
getprotobyname()
getprotobynumber()
getrandmax()
getrusage()
getservbyname()
getservbyport()
gettext()
gettimeofday()
gettype()
gmdate()
gmmktime()
gmp_abs()
gmp_add()
gmp_and()
gmp_clrbit()
gmp_cmp()
gmp_com()
gmp_div()
gmp_div_q()
gmp_div_qr()
gmp_div_r()
gmp_divexact()
gmp_fact()
gmp_gcd()
gmp_gcdext()
gmp_hamdist()
gmp_init()
gmp_intval()
gmp_invert()
gmp_jacobi()
gmp_legendre()
gmp_mod()
gmp_mul()
gmp_neg()
gmp_or()
gmp_perfect_square()
gmp_popcount()
gmp_pow()
gmp_powm()
gmp_prob_prime()
gmp_random()
gmp_scan0()
gmp_scan1()
gmp_setbit()
gmp_sign()
gmp_sqrt()
gmp_sqrtrm()
gmp_strval()
gmp_sub()
gmp_xor()
gmstrftime()
gregoriantojd()
gzclose()
gzcompress()
gzdeflate()
gzencode()
gzeof()
gzfile()
gzgetc()
gzgets()
gzgetss()
gzinflate()
gzopen()
gzpassthru()
gzputs()
gzread()
gzrewind()
gzseek()
gztell()
gzuncompress()
gzwrite()

H

header()
headers_sent()
hebrev()
hebrevc()
hexdec()
highlight_file()
highlight_string()
htmlentities()
htmlspecialchars()
hw_array2objrec()
hw_changeobject()
hw_children()
hw_childrenobj()
hw_close()
hw_connect()
hw_connection_info()
hw_cp()
hw_deleteobject()
hw_docbyanchor()
hw_docbyanchorobj()
hw_document_attributes()
hw_document_bodytag()
hw_document_content()
hw_document_setcontent()
hw_document_size()
hw_dummy()
hw_edittext()
hw_error()
hw_errormsg()
hw_free_document()
hw_getanchors()
hw_getanchorsobj()
hw_getandlock()
hw_getchildcoll()
hw_getchildcollobj()
hw_getchilddoccoll()
hw_getchilddoccollobj()
hw_getobject()
hw_getobjectbyquery()
hw_getobjectbyquerycoll()
hw_getobjectbyquerycollobj()
hw_getobjectbyqueryobj()
hw_getparents()
hw_getparentsobj()
hw_getrellink()
hw_getremote()
hw_getremotechildren()
hw_getsrcbydestobj()
hw_gettext()
hw_getusername()
hw_identify()
hw_incollections()
hw_info()
hw_inscoll()
hw_insdoc()
hw_insertanchors()
hw_insertdocument()
hw_insertobject()
hw_mapid()
hw_modifyobject()
hw_mv()
hw_new_document()
hw_objrec2array()
hw_output_document()
hw_pconnect()
hw_pipedocument()
hw_root()
hw_setlinkroot()
hw_stat()
hw_unlock()
hw_who()
hypot()

I

ibase_blob_add()
ibase_blob_cancel()
ibase_blob_close()
ibase_blob_create()
ibase_blob_echo()
ibase_blob_get()
ibase_blob_import()
ibase_blob_info()
ibase_blob_open()
ibase_close()
ibase_commit()
ibase_connect()
ibase_errmsg()
ibase_execute()
ibase_fetch_object()
ibase_fetch_row()
ibase_field_info()
ibase_free_query()
ibase_free_result()
ibase_num_fields()
ibase_pconnect()
ibase_prepare()
ibase_query()
ibase_rollback()
ibase_timefmt()
ibase_trans()
icap_close()
icap_create_calendar()
icap_delete_calendar()
icap_delete_event()
icap_fetch_event()
icap_list_alarms()
icap_list_events()
icap_open()
icap_rename_calendar()
icap_reopen()
icap_snooze()
icap_store_event()
iconv()
iconv_get_encoding()
iconv_set_encoding()
ifx_affected_rows()
ifx_blobinfile_mode()
ifx_byteasvarchar()
ifx_close()
ifx_connect()
ifx_copy_blob()
ifx_create_blob()
ifx_create_char()
ifx_do()
ifx_error()
ifx_errormsg()
ifx_fetch_row()
ifx_fieldproperties()
ifx_fieldtypes()
ifx_free_blob()
ifx_free_char()
ifx_free_result()
ifx_get_blob()
ifx_get_char()
ifx_getsqlca()
ifx_htmltbl_result()
ifx_nullformat()
ifx_num_fields()
ifx_num_rows()
ifx_pconnect()
ifx_prepare()
ifx_query()
ifx_textasvarchar()
ifx_update_blob()
ifx_update_char()
ifxus_close_slob()
ifxus_create_slob()
ifxus_free_slob()
ifxus_open_slob()
ifxus_read_slob()
ifxus_seek_slob()
ifxus_tell_slob()
ifxus_write_slob()
ignore_user_abort()
image2wbmp()
imagealphablending()
imagearc()
imagechar()
imagecharup()
imagecolorallocate()
imagecolorat()
imagecolorclosest()
imagecolorclosestalpha()
imagecolorclosestthwb()
imagecolordeallocate()
imagecolorexact()
imagecolorexactalpha()
imagecolorresolve()
imagecolorresolvealpha()
imagecolorset()
imagecolorsforindex()
imagecolorstotal()
imagecolortransparent()
imagecopy()
imagecopymerge()
imagecopymergegray()
imagecopyresampled()
imagecopyresized()
imagecreate()
imagecreatefromgd()
imagecreatefromgd2()
imagecreatefromgd2part()
imagecreatefromgif()
imagecreatefromjpeg()
imagecreatefrompng()
imagecreatefromstring()
imagecreatefromwbmp()
imagecreatefromxbm()
imagecreatefromxpm()
imagecreatetruecolor()
imagedashedline()
imagedestroy()
imageellipse()
imagefill()
imagefilledarc()
imagefilledellipse()
imagefilledpolygon()
imagefilledrectangle()
imagefilltoborder()
imagefontheight()
imagefontwidth()
imageftbbox()
imagefttext()
imagegammacorrect()
imagegd()
imagegd2()
imagegif()
imageinterlace()
imagejpeg()
imageline()
imageloadfont()
imagepalettecopy()
imagepng()
imagepolygon()
imagepsbbox()
imagepsencodefont()
imagepsextendfont()
imagepsfreefont()
imagepsloadfont()
imagepsslantfont()
imagepstext()
imagerectangle()
imagesetbrush()
imagesetpixel()
imagesetstyle()
imagesetthickness()
imagesettile()
imagestring()
imagestringup()
imagesx()
imagesy()
imagetruecolortopalette()
imagettfbbox()
imagettftext()
imagetypes()
imagewbmp()
imap_8bit()
imap_alerts()
imap_append()
imap_base64()
imap_binary()
imap_body()
imap_bodystruct()
imap_check()
imap_clearflag_full()
imap_close()
imap_createmailbox()
imap_delete()
imap_deletemailbox()
imap_errors()
imap_expunge()
imap_fetch_overview()
imap_fetchbody()
imap_fetchheader()
imap_fetchstructure()
imap_get_quota()
imap_getmailboxes()
imap_getsubscribed()
imap_header()
imap_headerinfo()
imap_headers()
imap_last_error()
imap_listmailbox()
imap_listsubscribed()
imap_mail()
imap_mail_compose()
imap_mail_copy()
imap_mail_move()
imap_mailboxmsginfo()
imap_mime_header_decode()
imap_msgno()
imap_num_msg()
imap_num_recent()
imap_open()
imap_ping()
imap_popen()
imap_qprint()
imap_renamemailbox()
imap_reopen()
imap_rfc822_parse_adrlist()
imap_rfc822_parse_headers()
imap_rfc822_write_address()
imap_scanmailbox()
imap_search()
imap_set_quota()
imap_setacl()
imap_setflag_full()
imap_sort()
imap_status()
imap_subscribe()
imap_thread()
imap_uid()
imap_undelete()
imap_unsubscribe()
imap_utf7_decode()
imap_utf7_encode()
imap_utf8()
implode()
import_request_variables()
in_array()
ingres_autocommit()
ingres_close()
ingres_commit()
ingres_connect()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()
ingres_field_length()
ingres_field_name()
ingres_field_nullable()
ingres_field_precision()
ingres_field_scale()
ingres_field_type()
ingres_num_fields()
ingres_num_rows()
ingres_pconnect()
ingres_query()
ingres_rollback()
ini_alter()
ini_get()
ini_get_all()
ini_restore()
ini_set()
intval()
ip2long()
iptcembed()
iptcparse()
ircg_channel_mode()
ircg_disconnect()
ircg_fetch_error_msg()
ircg_get_username()
ircg_html_encode()
ircg_ignore_add()
ircg_ignore_del()
ircg_is_conn_alive()
ircg_join()
ircg_kick()
ircg_lookup_format_messages()
ircg_msg()
ircg_nick()
ircg_nickname_escape()
ircg_nickname_unescape()
ircg_notice()
ircg_part()
ircg_pconnect()
ircg_register_format_messages()
ircg_set_current()
ircg_set_file()
ircg_set_on_die()
ircg_topic()
ircg_whois()
is_array()
is_bool()
is_callable()
is_dir()
is_double()
is_executable()
is_file()
is_float()
is_int()
is_integer()
is_link()
is_long()
is_null()
is_numeric()
is_object()
is_readable()
is_real()
is_resource()
is_scalar()
is_string()
is_subclass_of()
is_uploaded_file()
is_writable()
is_writeable()
isset()

J

java_last_exception_clear()
java_last_exception_get()
jddayofweek()
jdmonthname()
jdtofrench()
jdtogregorian()
jdtojewish()
jdtojulian()
jdtounix()
jewishtojd()
join()
jpeg2wbmp()
juliantojd()

K

key()
krsort()
ksort()

L

lcg_value()
ldap_8859_to_t61()
ldap_add()
ldap_bind()
ldap_close()
ldap_compare()
ldap_connect()
ldap_count_entries()
ldap_delete()
ldap_dn2ufn()
ldap_err2str()
ldap_errno()
ldap_error()
ldap_explode_dn()
ldap_first_attribute()
ldap_first_entry()
ldap_first_reference()
ldap_free_result()
ldap_get_attributes()
ldap_get_dn()
ldap_get_entries()
ldap_get_option()
ldap_get_values()
ldap_get_values_len()
ldap_list()
ldap_mod_add()
ldap_mod_del()
ldap_mod_replace()
ldap_modify()
ldap_next_attribute()
ldap_next_entry()
ldap_next_reference()
ldap_parse_reference()
ldap_parse_result()
ldap_read()
ldap_rename()
ldap_search()
ldap_set_option()
ldap_set_rebind_proc()
ldap_sort()
ldap_start_tls()
ldap_t61_to_8859()
ldap_unbind()
leak()
levenshtein()
link()
linkinfo()
list()
localeconv()
localtime()
log()
log10()
log1p()
long2ip()
lstat()
ltrim()

M

mail()
mailparse_determine_best_xfer_encoding()
mailparse_msg_create()
mailparse_msg_extract_part()
mailparse_msg_extract_part_file()
mailparse_msg_free()
mailparse_msg_get_part()
mailparse_msg_get_part_data()
mailparse_msg_get_structure()
mailparse_msg_parse()
mailparse_msg_parse_file()
mailparse_rfc822_parse_addresses()
mailparse_stream_encode()
mailparse_uudecode_all()
max()
mb_convert_encoding()
mb_convert_kana()
mb_convert_variables()
mb_decode_mimeheader()
mb_decode_numericentity()
mb_detect_encoding()
mb_detect_order()
mb_encode_mimeheader()
mb_encode_numericentity()
mb_get_info()
mb_http_input()
mb_http_output()
mb_internal_encoding()
mb_language()
mb_output_handler()
mb_parse_str()
mb_preferred_mime_name()
mb_send_mail()
mb_strcut()
mb_strimwidth()
mb_strlen()
mb_strpos()
mb_strrpos()
mb_strwidth()
mb_substitute_character()
mb_substr()
mcal_append_event()
mcal_close()
mcal_create_calendar()
mcal_date_compare()
mcal_date_valid()
mcal_day_of_week()
mcal_day_of_year()
mcal_days_in_month()
mcal_delete_calendar()
mcal_delete_event()
mcal_event_add_attribute()
mcal_event_init()
mcal_event_set_alarm()
mcal_event_set_category()
mcal_event_set_class()
mcal_event_set_description()
mcal_event_set_end()
mcal_event_set_recur_daily()
mcal_event_set_recur_monthly_mday()
mcal_event_set_recur_monthly_wday()
mcal_event_set_recur_none()
mcal_event_set_recur_weekly()
mcal_event_set_recur_yearly()
mcal_event_set_start()
mcal_event_set_title()
mcal_expunge()
mcal_fetch_current_stream_event()
mcal_fetch_event()
mcal_is_leap_year()
mcal_list_alarms()
mcal_list_events()
mcal_next_recurrence()
mcal_open()
mcal_popen()
mcal_rename_calendar()
mcal_reopen()
mcal_snooze()
mcal_store_event()
mcal_time_valid()
mcal_week_of_year()
mcrypt_cbc()
mcrypt_cfb()
mcrypt_create_iv()
mcrypt_decrypt()
mcrypt_ecb()
mcrypt_enc_get_algorithms_name()
mcrypt_enc_get_block_size()
mcrypt_enc_get_iv_size()
mcrypt_enc_get_key_size()
mcrypt_enc_get_modes_name()
mcrypt_enc_get_supported_key_sizes()
mcrypt_enc_is_block_algorithm()
mcrypt_enc_is_block_algorithm_mode()
mcrypt_enc_is_block_mode()
mcrypt_enc_self_test()
mcrypt_encrypt()
mcrypt_generic()
mcrypt_generic_deinit()
mcrypt_generic_end()
mcrypt_generic_init()
mcrypt_get_block_size()
mcrypt_get_cipher_name()
mcrypt_get_iv_size()
mcrypt_get_key_size()
mcrypt_list_algorithms()
mcrypt_list_modes()
mcrypt_module_close()
mcrypt_module_get_algo_block_size()
mcrypt_module_get_algo_key_size()
mcrypt_module_get_supported_key_sizes()
mcrypt_module_is_block_algorithm()
mcrypt_module_is_block_algorithm_mode()
mcrypt_module_is_block_mode()
mcrypt_module_open()
mcrypt_module_self_test()
mcrypt_ofb()
md5()
md5_file()
mdecrypt_generic()
metaphone()
method_exists()
mhash()
mhash_count()
mhash_get_block_size()
mhash_get_hash_name()
mhash_keygen_s2k()
microtime()
min()
ming_setcubicthreshold()
ming_setscale()
ming_useswfversion()
mkdir()
mktime()
move_uploaded_file()
msession_connect()
msession_count()
msession_create()
msession_destroy()
msession_disconnect()
msession_find()
msession_get()
msession_get_array()
msession_getdata()
msession_inc()
msession_list()
msession_listvar()
msession_lock()
msession_plugin()
msession_randstr()
msession_set()
msession_set_array()
msession_setdata()
msession_timeout()
msession_uniq()
msession_unlock()
msql()
msql_affected_rows()
msql_close()
msql_connect()
msql_create_db()
msql_createdb()
msql_data_seek()
msql_dbname()
msql_drop_db()
msql_dropdb()
msql_error()
msql_fetch_array()
msql_fetch_field()
msql_fetch_object()
msql_fetch_row()
msql_field_seek()
msql_fieldflags()
msql_fieldlen()
msql_fieldname()
msql_fieldtable()
msql_fieldtype()
msql_free_result()
msql_freeresult()
msql_list_dbs()
msql_list_fields()
msql_list_tables()
msql_listdbs()
msql_listfields()
msql_listtables()
msql_num_fields()
msql_num_rows()
msql_numfields()
msql_numrows()
msql_pconnect()
msql_query()
msql_regcase()
msql_result()
msql_select_db()
msql_selectdb()
msql_tablename()
mssql_bind()
mssql_close()
mssql_connect()
mssql_data_seek()
mssql_execute()
mssql_fetch_array()
mssql_fetch_assoc()
mssql_fetch_batch()
mssql_fetch_field()
mssql_fetch_object()
mssql_fetch_row()
mssql_field_length()
mssql_field_name()
mssql_field_seek()
mssql_field_type()
mssql_free_result()
mssql_get_last_message()
mssql_guid_string()
mssql_init()
mssql_min_error_severity()
mssql_min_message_severity()
mssql_next_result()
mssql_num_fields()
mssql_num_rows()
mssql_pconnect()
mssql_query()
mssql_result()
mssql_rows_affected()
mssql_select_db()
mt_getrandmax()
mt_rand()
mt_srand()
muscat_close()
muscat_get()
muscat_give()
muscat_setup()
muscat_setup_net()
mysql_affected_rows()
mysql_change_user()
mysql_close()
mysql_connect()
mysql_create_db()
mysql_data_seek()
mysql_db_name()
mysql_db_query()
mysql_drop_db()
mysql_errno()
mysql_error()
mysql_escape_string()
mysql_fetch_array()
mysql_fetch_assoc()
mysql_fetch_field()
mysql_fetch_lengths()
mysql_fetch_object()
mysql_fetch_row()
mysql_field_flags()
mysql_field_len()
mysql_field_name()
mysql_field_seek()
mysql_field_table()
mysql_field_type()
mysql_free_result()
mysql_get_client_info()
mysql_get_host_info()
mysql_get_proto_info()
mysql_get_server_info()
mysql_insert_id()
mysql_list_dbs()
mysql_list_fields()
mysql_list_tables()
mysql_num_fields()
mysql_num_rows()
mysql_pconnect()
mysql_query()
mysql_result()
mysql_select_db()
mysql_tablename()
mysql_unbuffered_query()

N

natcasesort()
natsort()
ncurses_addch()
ncurses_addchnstr()
ncurses_addchstr()
ncurses_addnstr()
ncurses_addstr()
ncurses_assume_default_colors()
ncurses_attroff()
ncurses_attron()
ncurses_attrset()
ncurses_baudrate()
ncurses_beep()
ncurses_bkgd()
ncurses_bkgdset()
ncurses_border()
ncurses_can_change_color()
ncurses_cbreak()
ncurses_clear()
ncurses_clrtobot()
ncurses_clrtoeol()
ncurses_color_set()
ncurses_curs_set()
ncurses_def_prog_mode()
ncurses_def_shell_mode()
ncurses_define_key()
ncurses_delay_output()
ncurses_delch()
ncurses_deleteln()
ncurses_delwin()
ncurses_doupdate()
ncurses_echo()
ncurses_echochar()
ncurses_end()
ncurses_erase()
ncurses_erasechar()
ncurses_filter()
ncurses_flash()
ncurses_flushinp()
ncurses_getch()
ncurses_getmouse()
ncurses_halfdelay()
ncurses_has_colors()
ncurses_has_ic()
ncurses_has_il()
ncurses_has_key()
ncurses_hline()
ncurses_inch()
ncurses_init()
ncurses_init_color()
ncurses_init_pair()
ncurses_insch()
ncurses_insdelln()
ncurses_insertln()
ncurses_insstr()
ncurses_instr()
ncurses_isendwin()
ncurses_keyok()
ncurses_killchar()
ncurses_longname()
ncurses_mouseinterval()
ncurses_mousemask()
ncurses_move()
ncurses_mvaddch()
ncurses_mvaddchnstr()
ncurses_mvaddchstr()
ncurses_mvaddnstr()
ncurses_mvaddstr()
ncurses_mvcur()
ncurses_mvdelch()
ncurses_mvgetch()
ncurses_mvhline()
ncurses_mvinch()
ncurses_mvvline()
ncurses_mvwaddstr()
ncurses_napms()
ncurses_newwin()
ncurses_nl()
ncurses_nocbreak()
ncurses_noecho()
ncurses_nonl()
ncurses_noqiflush()
ncurses_noraw()
ncurses_putp()
ncurses_qiflush()
ncurses_raw()
ncurses_refresh()
ncurses_resetty()
ncurses_savetty()
ncurses_scr_dump()
ncurses_scr_init()
ncurses_scr_restore()
ncurses_scr_set()
ncurses_scrl()
ncurses_slk_attr()
ncurses_slk_attroff()
ncurses_slk_attron()
ncurses_slk_attrset()
ncurses_slk_clear()
ncurses_slk_color()
ncurses_slk_init()
ncurses_slk_noutrefresh()
ncurses_slk_refresh()
ncurses_slk_restore()
ncurses_slk_touch()
ncurses_standend()
ncurses_standout()
ncurses_start_color()
ncurses_termattrs()
ncurses_termname()
ncurses_timeout()
ncurses_typeahead()
ncurses_ungetch()
ncurses_ungetmouse()
ncurses_use_default_colors()
ncurses_use_env()
ncurses_use_extended_names()
ncurses_vidattr()
ncurses_vline()
ncurses_wrefresh()
next()
ngettext()
nl2br()
nl_langinfo()
notes_body()
notes_copy_db()
notes_create_db()
notes_create_note()
notes_drop_db()
notes_find_note()
notes_header_info()
notes_list_msgs()
notes_mark_read()
notes_mark_unread()
notes_nav_create()
notes_search()
notes_unread()
notes_version()
number_format()

O

ob_clean()
ob_end_clean()
ob_end_flush()
ob_flush()
ob_get_contents()
ob_get_length()
ob_get_level()
ob_gzhandler()
ob_iconv_handler()
ob_implicit_flush()
ob_start()
ocibindbyname()
ocicancel()
ocicollappend()
ocicollassign()
ocicollassignelem()
ocicollgetelem()
ocicollmax()
ocicollsize()
ocicolltrim()
ocicolumnisnull()
ocicolumnname()
ocicolumnprecision()
ocicolumnscale()
ocicolumnsize()
ocicolumntype()
ocicolumntyperaw()
ocicommit()
ocidefinebyname()
ocierror()
ociexecute()
ocifetch()
ocifetchinto()
ocifetchstatement()
ocifreecollection()
ocifreecursor()
ocifreedesc()
ocifreestatement()
ociinternaldebug()
ociloadlob()
ocilogoff()
ocilogon()
ocinewcollection()
ocinewcursor()
ocinewdescriptor()
ocinlogon()
ocinumcols()
ociparse()
ociplogon()
ociresult()
ocirollback()
ocirowcount()
ocisavelob()
ocisavelobfile()
ociserverversion()
ocisetprefetch()
ocistatementtype()
ociwritelobtofile()
octdec()
odbc_autocommit()
odbc_binmode()
odbc_close()
odbc_close_all()
odbc_columnprivileges()
odbc_columns()
odbc_commit()
odbc_connect()
odbc_cursor()
odbc_do()
odbc_error()
odbc_errormsg()
odbc_exec()
odbc_execute()
odbc_fetch_array()
odbc_fetch_into()
odbc_fetch_object()
odbc_fetch_row()
odbc_field_len()
odbc_field_name()
odbc_field_num()
odbc_field_precision()
odbc_field_scale()
odbc_field_type()
odbc_foreignkeys()
odbc_free_result()
odbc_gettypeinfo()
odbc_longreadlen()
odbc_next_result()
odbc_num_fields()
odbc_num_rows()
odbc_pconnect()
odbc_prepare()
odbc_primarykeys()
odbc_procedurecolumns()
odbc_procedures()
odbc_result()
odbc_result_all()
odbc_rollback()
odbc_setoption()
odbc_specialcolumns()
odbc_statistics()
odbc_tableprivileges()
odbc_tables()
opendir()
openlog()
openssl_csr_export()
openssl_csr_export_to_file()
openssl_csr_new()
openssl_csr_sign()
openssl_error_string()
openssl_free_key()
openssl_get_privatekey()
openssl_get_publickey()
openssl_open()
openssl_pkcs7_decrypt()
openssl_pkcs7_encrypt()
openssl_pkcs7_sign()
openssl_pkcs7_verify()
openssl_pkey_export()
openssl_pkey_export_to_file()
openssl_pkey_new()
openssl_private_decrypt()
openssl_private_encrypt()
openssl_public_decrypt()
openssl_public_encrypt()
openssl_seal()
openssl_sign()
openssl_verify()
openssl_x509_check_private_key()
openssl_x509_checkpurpose()
openssl_x509_export()
openssl_x509_export_to_file()
openssl_x509_free()
openssl_x509_parse()
openssl_x509_read()
ora_bind()
ora_close()
ora_columnname()
ora_columnsize()
ora_columntype()
ora_commit()
ora_commitoff()
ora_commiton()
ora_do()
ora_error()
ora_errorcode()
ora_exec()
ora_fetch()
ora_fetch_into()
ora_getcolumn()
ora_logoff()
ora_logon()
ora_numcols()
ora_numrows()
ora_open()
ora_parse()
ora_plogon()
ora_rollback()
orbitenum()
orbitobject()
orbitstruct()
ord()
overload()
ovrimos_close()
ovrimos_commit()
ovrimos_connect()
ovrimos_cursor()
ovrimos_exec()
ovrimos_execute()
ovrimos_fetch_into()
ovrimos_fetch_row()
ovrimos_field_len()
ovrimos_field_name()
ovrimos_field_num()
ovrimos_field_type()
ovrimos_free_result()
ovrimos_longreadlen()
ovrimos_num_fields()
ovrimos_num_rows()
ovrimos_prepare()
ovrimos_result()
ovrimos_result_all()
ovrimos_rollback()

P

pack()
parse_ini_file()
parse_str()
parse_url()
passthru()
pathinfo()
pattern modifiers()
pattern syntax()
pclose()
pdf_add_annotation()
pdf_add_bookmark()
pdf_add_launchlink()
pdf_add_locallink()
pdf_add_note()
pdf_add_outline()
pdf_add_pdflink()
pdf_add_thumbnail()
pdf_add_weblink()
pdf_arc()
pdf_arcn()
pdf_attach_file()
pdf_begin_page()
pdf_begin_pattern()
pdf_begin_template()
pdf_circle()
pdf_clip()
pdf_close()
pdf_close_image()
pdf_close_pdi()
pdf_close_pdi_page()
pdf_closepath()
pdf_closepath_fill_stroke()
pdf_closepath_stroke()
pdf_concat()
pdf_continue_text()
pdf_curveto()
pdf_delete()
pdf_end_page()
pdf_end_pattern()
pdf_end_template()
pdf_endpath()
pdf_fill()
pdf_fill_stroke()
pdf_findfont()
pdf_get_buffer()
pdf_get_font()
pdf_get_fontname()
pdf_get_fontsize()
pdf_get_image_height()
pdf_get_image_width()
pdf_get_majorversion()
pdf_get_minorversion()
pdf_get_parameter()
pdf_get_pdi_parameter()
pdf_get_pdi_value()
pdf_get_value()
pdf_initgraphics()
pdf_lineto()
pdf_makespotcolor()
pdf_moveto()
pdf_new()
pdf_open()
pdf_open_ccitt()
pdf_open_file()
pdf_open_gif()
pdf_open_image()
pdf_open_image_file()
pdf_open_jpeg()
pdf_open_memory_image()
pdf_open_pdi()
pdf_open_pdi_page()
pdf_open_png()
pdf_open_tiff()
pdf_place_image()
pdf_place_pdi_page()
pdf_rect()
pdf_restore()
pdf_rotate()
pdf_save()
pdf_scale()
pdf_set_border_color()
pdf_set_border_dash()
pdf_set_border_style()
pdf_set_char_spacing()
pdf_set_duration()
pdf_set_font()
pdf_set_horiz_scaling()
pdf_set_info()
pdf_set_info_author()
pdf_set_info_creator()
pdf_set_info_keywords()
pdf_set_info_subject()
pdf_set_info_title()
pdf_set_leading()
pdf_set_parameter()
pdf_set_text_matrix()
pdf_set_text_pos()
pdf_set_text_rendering()
pdf_set_text_rise()
pdf_set_value()
pdf_set_word_spacing()
pdf_setcolor()
pdf_setdash()
pdf_setflat()
pdf_setfont()
pdf_setgray()
pdf_setgray_fill()
pdf_setgray_stroke()
pdf_setlinecap()
pdf_setlinejoin()
pdf_setlinewidth()
pdf_setmatrix()
pdf_setmiterlimit()
pdf_setpolydash()
pdf_setrgbcolor()
pdf_setrgbcolor_fill()
pdf_setrgbcolor_stroke()
pdf_show()
pdf_show_boxed()
pdf_show_xy()
pdf_skew()
pdf_stringwidth()
pdf_stroke()
pdf_translate()
pfpro_cleanup()
pfpro_init()
pfpro_process()
pfpro_process_raw()
pfpro_version()
pfsockopen()
pg_cancel_query()
pg_client_encoding()
pg_close()
pg_cmdtuples()
pg_connect()
pg_connection_busy()
pg_connection_reset()
pg_connection_status()
pg_copy_from()
pg_copy_to()
pg_dbname()
pg_end_copy()
pg_errormessage()
pg_escape_bytea()
pg_escape_string()
pg_exec()
pg_fetch_array()
pg_fetch_object()
pg_fetch_row()
pg_fieldisnull()
pg_fieldname()
pg_fieldnum()
pg_fieldprtlen()
pg_fieldsize()
pg_fieldtype()
pg_freeresult()
pg_get_result()
pg_getlastoid()
pg_host()
pg_last_notice()
pg_lo_seek()
pg_lo_tell()
pg_loclose()
pg_locreate()
pg_loexport()
pg_loimport()
pg_loopen()
pg_loread()
pg_loreadall()
pg_lounlink()
pg_lowrite()
pg_numfields()
pg_numrows()
pg_options()
pg_pconnect()
pg_port()
pg_put_line()
pg_result()
pg_result_error()
pg_result_status()
pg_send_query()
pg_set_client_encoding()
pg_trace()
pg_tty()
pg_untrace()
php_logo_guid()
php_sapi_name()
php_uname()
phpcredits()
phpinfo()
phpversion()
pi()
png2wbmp()
popen()
pos()
posix_ctermid()
posix_getcwd()
posix_getegid()
posix_geteuid()
posix_getgid()
posix_getgrgid()
posix_getgrnam()
posix_getgroups()
posix_getlogin()
posix_getpgid()
posix_getpgrp()
posix_getpid()
posix_getppid()
posix_getpwnam()
posix_getpwuid()
posix_getrlimit()
posix_getsid()
posix_getuid()
posix_isatty()
posix_kill()
posix_mkfifo()
posix_setegid()
posix_seteuid()
posix_setgid()
posix_setpgid()
posix_setsid()
posix_setuid()
posix_times()
posix_ttyname()
posix_uname()
pow()
preg_grep()
preg_match()
preg_match_all()
preg_quote()
preg_replace()
preg_replace_callback()
preg_split()
prev()
print()
print_r()
printer_abort()
printer_close()
printer_create_brush()
printer_create_dc()
printer_create_font()
printer_create_pen()
printer_delete_brush()
printer_delete_dc()
printer_delete_font()
printer_delete_pen()
printer_draw_bmp()
printer_draw_chord()
printer_draw_elipse()
printer_draw_line()
printer_draw_pie()
printer_draw_rectangle()
printer_draw_roundrect()
printer_draw_text()
printer_end_doc()
printer_end_page()
printer_get_option()
printer_list()
printer_logical_fontheight()
printer_open()
printer_select_brush()
printer_select_font()
printer_select_pen()
printer_set_option()
printer_start_doc()
printer_start_page()
printer_write()
printf()
pspell_add_to_personal()
pspell_add_to_session()
pspell_check()
pspell_clear_session()
pspell_config_create()
pspell_config_ignore()
pspell_config_mode()
pspell_config_personal()
pspell_config_repl()
pspell_config_runtogether()
pspell_config_save_repl()
pspell_new()
pspell_new_config()
pspell_new_personal()
pspell_save_wordlist()
pspell_store_replacement()
pspell_suggest()
putenv()

Q

qdom_error()
qdom_tree()
quoted_printable_decode()
quotemeta()

R

rad2deg()
rand()
range()
rawurldecode()
rawurlencode()
read_exif_data()
readdir()
readfile()
readgzfile()
readline()
readline_add_history()
readline_clear_history()
readline_completion_function()
readline_info()
readline_list_history()
readline_read_history()
readline_write_history()
readlink()
realpath()
recode()
recode_file()
recode_string()
register_shutdown_function()
register_tick_function()
rename()
reset()
restore_error_handler()
rewind()
rewinddir()
rmdir()
round()
rsort()
rtrim()

S

satellite_caught_exception()
satellite_exception_id()
satellite_exception_value()
satellite_get_repository_id()
satellite_load_idl()
satellite_object_to_string()
sem_acquire()
sem_get()
sem_release()
sem_remove()
serialize()
sesam_affected_rows()
sesam_commit()
sesam_connect()
sesam_diagnostic()
sesam_disconnect()
sesam_errormsg()
sesam_execimm()
sesam_fetch_array()
sesam_fetch_result()
sesam_fetch_row()
sesam_field_array()
sesam_field_name()
sesam_free_result()
sesam_num_fields()
sesam_query()
sesam_rollback()
sesam_seek_row()
sesam_settransaction()
session_cache_expire()
session_cache_limiter()
session_decode()
session_destroy()
session_encode()
session_get_cookie_params()
session_id()
session_is_registered()
session_module_name()
session_name()
session_register()
session_save_path()
session_set_cookie_params()
session_set_save_handler()
session_start()
session_unregister()
session_unset()
session_write_close()
set_error_handler()
set_file_buffer()
set_magic_quotes_runtime()
set_time_limit()
setcookie()
setlocale()
settype()
shell_exec()
shm_attach()
shm_detach()
shm_get_var()
shm_put_var()
shm_remove()
shm_remove_var()
shmop_close()
shmop_delete()
shmop_open()
shmop_read()
shmop_size()
shmop_write()
show_source()
shuffle()
similar_text()
sin()
sinh()
sizeof()
sleep()
snmp_get_quick_print()
snmp_set_quick_print()
snmpget()
snmprealwalk()
snmpset()
snmpwalk()
snmpwalkoid()
socket_accept()
socket_bind()
socket_close()
socket_connect()
socket_create()
socket_create_listen()
socket_create_pair()
socket_fd_alloc()
socket_fd_clear()
socket_fd_free()
socket_fd_isset()
socket_fd_set()
socket_fd_zero()
socket_get_status()
socket_getopt()
socket_getpeername()
socket_getsockname()
socket_iovec_add()
socket_iovec_alloc()
socket_iovec_delete()
socket_iovec_fetch()
socket_iovec_free()
socket_iovec_set()
socket_last_error()
socket_listen()
socket_read()
socket_readv()
socket_recv()
socket_recvfrom()
socket_recvmsg()
socket_select()
socket_send()
socket_sendmsg()
socket_sendto()
socket_set_blocking()
socket_set_nonblock()
socket_set_timeout()
socket_setopt()
socket_shutdown()
socket_strerror()
socket_write()
socket_writev()
sort()
soundex()
split()
spliti()
sprintf()
sql_regcase()
sqrt()
srand()
sscanf()
stat()
str_pad()
str_repeat()
str_replace()
str_rot13()
strcasecmp()
strchr()
strcmp()
strcoll()
strcspn()
strftime()
strip_tags()
stripcslashes()
stripslashes()
stristr()
strlen()
strnatcasecmp()
strnatcmp()
strncasecmp()
strncmp()
strpos()
strrchr()
strrev()
strrpos()
strspn()
strstr()
strtok()
strtolower()
strtotime()
strtoupper()
strtr()
strval()
substr()
substr_count()
substr_replace()
swf_actiongeturl()
swf_actiongotoframe()
swf_actiongotolabel()
swf_actionnextframe()
swf_actionplay()
swf_actionprevframe()
swf_actionsettarget()
swf_actionstop()
swf_actiontogglequality()
swf_actionwaitforframe()
swf_addbuttonrecord()
swf_addcolor()
swf_closefile()
swf_definebitmap()
swf_definefont()
swf_defineline()
swf_definepoly()
swf_definerect()
swf_definetext()
swf_endbutton()
swf_enddoaction()
swf_endshape()
swf_endsymbol()
swf_fontsize()
swf_fontslant()
swf_fonttracking()
swf_getbitmapinfo()
swf_getfontinfo()
swf_getframe()
swf_labelframe()
swf_lookat()
swf_modifyobject()
swf_mulcolor()
swf_nextid()
swf_oncondition()
swf_openfile()
swf_ortho()
swf_ortho2()
swf_perspective()
swf_placeobject()
swf_polarview()
swf_popmatrix()
swf_posround()
swf_pushmatrix()
swf_removeobject()
swf_rotate()
swf_scale()
swf_setfont()
swf_setframe()
swf_shapearc()
swf_shapecurveto()
swf_shapecurveto3()
swf_shapefillbitmapclip()
swf_shapefillbitmaptile()
swf_shapefilloff()
swf_shapefillsolid()
swf_shapelinesolid()
swf_shapelineto()
swf_shapemoveto()
swf_showframe()
swf_startbutton()
swf_startdoaction()
swf_startshape()
swf_startsymbol()
swf_textwidth()
swf_translate()
swf_viewport()
swfaction()
swfbitmap()
swfbitmap->getheight()
swfbitmap->getwidth()
swfbutton()
swfbutton->addaction()
swfbutton->addshape()
swfbutton->setaction()
swfbutton->setdown()
swfbutton->sethit()
swfbutton->setover()
swfbutton->setup()
swfbutton_keypress()
swfdisplayitem()
swfdisplayitem->addcolor()
swfdisplayitem->move()
swfdisplayitem->moveto()
swfdisplayitem->multcolor()
swfdisplayitem->remove()
swfdisplayitem->rotate()
swfdisplayitem->rotateto()
swfdisplayitem->scale()
swfdisplayitem->scaleto()
swfdisplayitem->setdepth()
swfdisplayitem->setname()
swfdisplayitem->setratio()
swfdisplayitem->skewx()
swfdisplayitem->skewxto()
swfdisplayitem->skewy()
swfdisplayitem->skewyto()
swffill()
swffill->moveto()
swffill->rotateto()
swffill->scaleto()
swffill->skewxto()
swffill->skewyto()
swffont()
swffont->getwidth()
swfgradient()
swfgradient->addentry()
swfmorph()
swfmorph->getshape1()
swfmorph->getshape2()
swfmovie()
swfmovie->add()
swfmovie->nextframe()
swfmovie->output()
swfmovie->remove()
swfmovie->save()
swfmovie->setbackground()
swfmovie->setdimension()
swfmovie->setframes()
swfmovie->setrate()
swfmovie->streammp3()
swfshape()
swfshape->addfill()
swfshape->drawcurve()
swfshape->drawcurveto()
swfshape->drawline()
swfshape->drawlineto()
swfshape->movepen()
swfshape->movepento()
swfshape->setleftfill()
swfshape->setline()
swfshape->setrightfill()
swfsprite()
swfsprite->add()
swfsprite->nextframe()
swfsprite->remove()
swfsprite->setframes()
swftext()
swftext->addstring()
swftext->getwidth()
swftext->moveto()
swftext->setcolor()
swftext->setfont()
swftext->setheight()
swftext->setspacing()
swftextfield()
swftextfield->addstring()
swftextfield->align()
swftextfield->setbounds()
swftextfield->setcolor()
swftextfield->setfont()
swftextfield->setheight()
swftextfield->setindentation()
swftextfield->setleftmargin()
swftextfield->setlinespacing()
swftextfield->setmargins()
swftextfield->setname()
swftextfield->setrightmargin()
sybase_affected_rows()
sybase_close()
sybase_connect()
sybase_data_seek()
sybase_fetch_array()
sybase_fetch_field()
sybase_fetch_object()
sybase_fetch_row()
sybase_field_seek()
sybase_free_result()
sybase_get_last_message()
sybase_min_client_severity()
sybase_min_error_severity()
sybase_min_message_severity()
sybase_min_server_severity()
sybase_num_fields()
sybase_num_rows()
sybase_pconnect()
sybase_query()
sybase_result()
sybase_select_db()
symlink()
syslog()
system()

T

tan()
tanh()
tempnam()
textdomain()
time()
tmpfile()
touch()
trigger_error()
trim()

U

uasort()
ucfirst()
ucwords()
udm_add_search_limit()
udm_alloc_agent()
udm_api_version()
udm_cat_list()
udm_cat_path()
udm_check_charset()
udm_check_stored()
udm_clear_search_limits()
udm_close_stored()
udm_crc32()
udm_errno()
udm_error()
udm_find()
udm_free_agent()
udm_free_ispell_data()
udm_free_res()
udm_get_doc_count()
udm_get_res_field()
udm_get_res_param()
udm_load_ispell_data()
udm_open_stored()
udm_set_agent_param()
uksort()
umask()
uniqid()
unixtojd()
unlink()
unpack()
unregister_tick_function()
unserialize()
unset()
urldecode()
urlencode()
user_error()
usleep()
usort()
utf8_decode()
utf8_encode()

V

var_dump()
var_export()
variant()
version_compare()
virtual()
vpopmail_add_alias_domain()
vpopmail_add_alias_domain_ex()
vpopmail_add_domain()
vpopmail_add_domain_ex()
vpopmail_add_user()
vpopmail_alias_add()
vpopmail_alias_del()
vpopmail_alias_del_domain()
vpopmail_alias_get()
vpopmail_alias_get_all()
vpopmail_auth_user()
vpopmail_del_domain()
vpopmail_del_domain_ex()
vpopmail_del_user()
vpopmail_error()
vpopmail_passwd()
vpopmail_set_user_quota()
vprintf()
vsprintf()

W

w32api_deftype()
w32api_init_dtype()
w32api_invoke_function()
w32api_register_function()
w32api_set_call_method()
wddx_add_vars()
wddx_deserialize()
wddx_packet_end()
wddx_packet_start()
wddx_serialize_value()
wddx_serialize_vars()
wordwrap()

X

xml_error_string()
xml_get_current_byte_index()
xml_get_current_column_number()
xml_get_current_line_number()
xml_get_error_code()
xml_parse()
xml_parse_into_struct()
xml_parser_create()
xml_parser_create_ns()
xml_parser_free()
xml_parser_get_option()
xml_parser_set_option()
xml_set_character_data_handler()
xml_set_default_handler()
xml_set_element_handler()
xml_set_end_namespace_decl_handler()
xml_set_external_entity_ref_handler()
xml_set_notation_decl_handler()
xml_set_object()
xml_set_processing_instruction_handler()
xml_set_start_namespace_decl_handler()
xml_set_unparsed_entity_decl_handler()
xmldoc()
xmldocfile()
xmlrpc_decode()
xmlrpc_decode_request()
xmlrpc_encode()
xmlrpc_encode_request()
xmlrpc_get_type()
xmlrpc_parse_method_descriptions()
xmlrpc_server_add_introspection_data()
xmlrpc_server_call_method()
xmlrpc_server_create()
xmlrpc_server_destroy()
xmlrpc_server_register_introspection_callback()
xmlrpc_server_register_method()
xmlrpc_set_type()
xmltree()
xpath_eval()
xpath_eval_expression()
xpath_new_context()
xptr_eval()
xptr_new_context()
xslt_create()
xslt_errno()
xslt_error()
xslt_free()
xslt_process()
xslt_set_base()
xslt_set_encoding()
xslt_set_error_handler()
xslt_set_log()
xslt_set_sax_handler()
xslt_set_sax_handlers()
xslt_set_scheme_handler()
xslt_set_scheme_handlers()

Y

yaz_addinfo()
yaz_ccl_conf()
yaz_ccl_parse()
yaz_close()
yaz_connect()
yaz_database()
yaz_element()
yaz_errno()
yaz_error()
yaz_hits()
yaz_itemorder()
yaz_present()
yaz_range()
yaz_record()
yaz_scan()
yaz_scan_result()
yaz_search()
yaz_sort()
yaz_syntax()
yaz_wait()
yp_all()
yp_cat()
yp_err_string()
yp_errno()
yp_first()
yp_get_default_domain()
yp_master()
yp_match()
yp_next()
yp_order()

Z

zend_logo_guid()
zend_version()
zip_close()
zip_entry_close()
zip_entry_compressedsize()
zip_entry_compressionmethod()
zip_entry_filesize()
zip_entry_name()
zip_entry_open()
zip_entry_read()
zip_open()
zip_read()

Anterior | Inicio | Siguiente
How we generate the formats | Subir | missing stuff


missing stuff

Manual de PHP
Anterior Siguiente

Apéndice J. missing stuff

Anterior | Inicio | Siguiente
Function Index | Subir | ???


???

Manual de PHP
Anterior Siguiente

VIII. ???

Tabla de contenidos
56. About This Edition

Anterior | Inicio | Siguiente
missing stuff |  | About This Edition


About This Edition

Manual de PHP
Anterior

Capítulo 56. About This Edition

The Windows HTML Help Edition of the PHP Manual is aimed at developers, who want the manual at hand every time, and would like to read manual pages and user notes without waiting for a remote webpage to download. This edition gives you the full content of the manual plus the user notes, with some great features provided by the viewer application.

Anterior | Inicio
??? | Subir


Manual de PHP

Copyright

Este manual es © Copyright 1997, 1998, 1999, 2000, 2001, 2002 del Grupo de documentación de PHP. Los miembros de este grupo se encuentran listados en la primera página de este manual.

Este manual puede ser redistribuido bajo los términos de la "GNU General Public License" publicada por la "Free Software Foundation"; tanto bajo la versión 2 de esta licencia o bajo versiones posteriores.

Inicio


missing stuff

Manual de PHP
Anterior

Apéndice J. missing stuff

Anterior | Inicio
Function Index | Subir


ImagePSCopyFont

(PHP 3>= 3.0.9, PHP 4 >= 4.0.0)

ImagePSCopyFont -- hace una copia de una fuente ya cargada para futuras modificaciones

Descripción

int imagepscopyfont ( int fontindex)

Use esta función si necesita hacer modificaciones en la fuente, por ejemplo expander/condensar, inclinarla o cambiar su vector de codificación de caracteres, pero también necesita mantener la fuente original. Note que la fuente que quiera copiar debe haber sido obtenida usando imagepsloadfont(), no una fuente que sea una copia de otra. Aunque puede hacer modificaciones antes de copiarla.

Si usa esta función, debe liberar las fuentes obtenidas de esta manera. De otra forma su script se colgará.

En el caso de que todo vaya bien, devolverá un índice de fuente válido que puede ser usado para futuos propósitos. De otra forma la función devolverá FALSE e imprimirá un mensaje indicando que es lo que ha ido mal.

Vea también imageploadpsfont().

Anterior | Inicio | Siguiente
ImagePSBBox | Subir | ImagePSEncodeFont


odbc_field_num

(PHP 3>= 3.0.6, PHP 4 >= 4.0.0)

odbc_field_num -- Devuelve el numero de campo

Descripcion

int odbc_field_num ( int result_id, string field_name)

odbc_field_num() devolvera el numero de campo que corresponda con el campo llamado en el identificador ODBC. La numeracion de campos comienza en 1. En caso de error devolveria FALSE.

Anterior | Inicio | Siguiente
odbc_field_name | Subir | odbc_field_type


calendar Predefined Constants

(unknown)

calendar Predefined Constants -- Constants defined in the calendar extension

Description

These constants are defined by the calendar extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

CAL_GREGORIAN (integer)

CAL_JULIAN (integer)

CAL_JEWISH (integer)

CAL_FRENCH (integer)

CAL_NUM_CALS (integer)

CAL_DOW_DAYNO (integer)

CAL_DOW_SHORT (integer)

CAL_DOW_LONG (integer)

CAL_MONTH_GREGORIAN_SHORT (integer)

CAL_MONTH_GREGORIAN_LONG (integer)

CAL_MONTH_JULIAN_SHORT (integer)

CAL_MONTH_JULIAN_LONG (integer)

CAL_MONTH_JEWISH (integer)

CAL_MONTH_FRENCH (integer)

Anterior | Inicio | Siguiente
Core Predefined Constants | Subir | com Predefined Constants


com Predefined Constants

(unknown)

com Predefined Constants -- Constants defined in the com extension

Description

These constants are defined by the com extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

CLSCTX_INPROC_SERVER (integer)

CLSCTX_INPROC_HANDLER (integer)

CLSCTX_LOCAL_SERVER (integer)

CLSCTX_REMOTE_SERVER (integer)

CLSCTX_SERVER (integer)

CLSCTX_ALL (integer)

VT_NULL (integer)

VT_EMPTY (integer)

VT_UI1 (integer)

VT_I2 (integer)

VT_I4 (integer)

VT_R4 (integer)

VT_R8 (integer)

VT_BOOL (integer)

VT_ERROR (integer)

VT_CY (integer)

VT_DATE (integer)

VT_BSTR (integer)

VT_DECIMAL (integer)

VT_UNKNOWN (integer)

VT_DISPATCH (integer)

VT_VARIANT (integer)

VT_I1 (integer)

VT_UI2 (integer)

VT_UI4 (integer)

VT_INT (integer)

VT_UINT (integer)

VT_ARRAY (integer)

VT_BYREF (integer)

CP_ACP (integer)

CP_MACCP (integer)

CP_OEMCP (integer)

CP_UTF7 (integer)

CP_UTF8 (integer)

CP_SYMBOL (integer)

CP_THREAD_ACP (integer)

Anterior | Inicio | Siguiente
calendar Predefined Constants | Subir | cpdf Predefined Constants


Core Predefined Constants

(unknown)

Core Predefined Constants -- Constants defined in the PHP core, Zend, and SAPI modules

Description

These constants are defined by the PHP core. This includes PHP, the Zend engine, and SAPI modules.

PHP_VERSION (string)

PHP_OS (string)

DEFAULT_INCLUDE_PATH (string)

PEAR_INSTALL_DIR (string)

PEAR_EXTENSION_DIR (string)

PHP_EXTENSION_DIR (string)

PHP_BINDIR (string)

PHP_LIBDIR (string)

PHP_DATADIR (string)

PHP_SYSCONFDIR (string)

PHP_LOCALSTATEDIR (string)

PHP_CONFIG_FILE_PATH (string)

PHP_OUTPUT_HANDLER_START (integer)

PHP_OUTPUT_HANDLER_CONT (integer)

PHP_OUTPUT_HANDLER_END (integer)

E_ERROR (integer)

E_WARNING (integer)

E_PARSE (integer)

E_NOTICE (integer)

E_CORE_ERROR (integer)

E_CORE_WARNING (integer)

E_COMPILE_ERROR (integer)

E_COMPILE_WARNING (integer)

E_USER_ERROR (integer)

E_USER_WARNING (integer)

E_USER_NOTICE (integer)

E_ALL (integer)

Anterior | Inicio | Siguiente
??? | Subir | calendar Predefined Constants


cpdf Predefined Constants

(unknown)

cpdf Predefined Constants -- Constants defined in the cpdf extension

Description

These constants are defined by the cpdf extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

CPDF_PM_NONE (integer)

CPDF_PM_OUTLINES (integer)

CPDF_PM_THUMBS (integer)

CPDF_PM_FULLSCREEN (integer)

CPDF_PL_SINGLE (integer)

CPDF_PL_1COLUMN (integer)

CPDF_PL_2LCOLUMN (integer)

CPDF_PL_2RCOLUMN (integer)

Anterior | Inicio | Siguiente
com Predefined Constants | Subir | curl Predefined Constants


curl Predefined Constants

(unknown)

curl Predefined Constants -- Constants defined in the curl extension

Description

These constants are defined by the curl extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

CURLOPT_PORT (integer)

CURLOPT_FILE (integer)

CURLOPT_INFILE (integer)

CURLOPT_INFILESIZE (integer)

CURLOPT_URL (integer)

CURLOPT_PROXY (integer)

CURLOPT_VERBOSE (integer)

CURLOPT_HEADER (integer)

CURLOPT_HTTPHEADER (integer)

CURLOPT_NOPROGRESS (integer)

CURLOPT_NOBODY (integer)

CURLOPT_FAILONERROR (integer)

CURLOPT_UPLOAD (integer)

CURLOPT_POST (integer)

CURLOPT_FTPLISTONLY (integer)

CURLOPT_FTPAPPEND (integer)

CURLOPT_NETRC (integer)

CURLOPT_FOLLOWLOCATION (integer)

CURLOPT_FTPASCII (integer)

CURLOPT_PUT (integer)

CURLOPT_MUTE (integer)

CURLOPT_USERPWD (integer)

CURLOPT_PROXYUSERPWD (integer)

CURLOPT_RANGE (integer)

CURLOPT_TIMEOUT (integer)

CURLOPT_POSTFIELDS (integer)

CURLOPT_REFERER (integer)

CURLOPT_USERAGENT (integer)

CURLOPT_FTPPORT (integer)

CURLOPT_LOW_SPEED_LIMIT (integer)

CURLOPT_LOW_SPEED_TIME (integer)

CURLOPT_RESUME_FROM (integer)

CURLOPT_COOKIE (integer)

CURLOPT_SSLCERT (integer)

CURLOPT_SSLCERTPASSWD (integer)

CURLOPT_WRITEHEADER (integer)

CURLOPT_SSL_VERIFYHOST (integer)

CURLOPT_COOKIEFILE (integer)

CURLOPT_SSLVERSION (integer)

CURLOPT_TIMECONDITION (integer)

CURLOPT_TIMEVALUE (integer)

CURLOPT_CUSTOMREQUEST (integer)

CURLOPT_STDERR (integer)

CURLOPT_TRANSFERTEXT (integer)

CURLOPT_RETURNTRANSFER (integer)

CURLOPT_QUOTE (integer)

CURLOPT_POSTQUOTE (integer)

CURLOPT_INTERFACE (integer)

CURLOPT_KRB4LEVEL (integer)

CURLOPT_HTTPPROXYTUNNEL (integer)

CURLOPT_FILETIME (integer)

CURLOPT_WRITEFUNCTION (integer)

CURLOPT_READFUNCTION (integer)

CURLOPT_PASSWDFUNCTION (integer)

CURLOPT_HEADERFUNCTION (integer)

CURLOPT_MAXREDIRS (integer)

CURLOPT_MAXCONNECTS (integer)

CURLOPT_CLOSEPOLICY (integer)

CURLOPT_FRESH_CONNECT (integer)

CURLOPT_FORBID_REUSE (integer)

CURLOPT_RANDOM_FILE (integer)

CURLOPT_EGDSOCKET (integer)

CURLOPT_CONNECTTIMEOUT (integer)

CURLOPT_SSL_VERIFYPEER (integer)

CURLOPT_CAINFO (integer)

CURLOPT_COOKIEJAR (integer)

CURLOPT_SSL_CIPHER_LIST (integer)

CURLOPT_BINARYTRANSFER (integer)

CURLCLOSEPOLICY_LEAST_RECENTLY_USED (integer)

CURLCLOSEPOLICY_LEAST_TRAFFIC (integer)

CURLCLOSEPOLICY_SLOWEST (integer)

CURLCLOSEPOLICY_CALLBACK (integer)

CURLCLOSEPOLICY_OLDEST (integer)

CURLINFO_EFFECTIVE_URL (integer)

CURLINFO_HTTP_CODE (integer)

CURLINFO_HEADER_SIZE (integer)

CURLINFO_REQUEST_SIZE (integer)

CURLINFO_TOTAL_TIME (integer)

CURLINFO_NAMELOOKUP_TIME (integer)

CURLINFO_CONNECT_TIME (integer)

CURLINFO_PRETRANSFER_TIME (integer)

CURLINFO_SIZE_UPLOAD (integer)

CURLINFO_SIZE_DOWNLOAD (integer)

CURLINFO_SPEED_DOWNLOAD (integer)

CURLINFO_SPEED_UPLOAD (integer)

CURLINFO_FILETIME (integer)

CURLINFO_SSL_VERIFYRESULT (integer)

CURLINFO_CONTENT_LENGTH_DOWNLOAD (integer)

CURLINFO_CONTENT_LENGTH_UPLOAD (integer)

CURLE_OK (integer)

CURLE_UNSUPPORTED_PROTOCOL (integer)

CURLE_FAILED_INIT (integer)

CURLE_URL_MALFORMAT (integer)

CURLE_URL_MALFORMAT_USER (integer)

CURLE_COULDNT_RESOLVE_PROXY (integer)

CURLE_COULDNT_RESOLVE_HOST (integer)

CURLE_COULDNT_CONNECT (integer)

CURLE_FTP_WEIRD_SERVER_REPLY (integer)

CURLE_FTP_ACCESS_DENIED (integer)

CURLE_FTP_USER_PASSWORD_INCORRECT (integer)

CURLE_FTP_WEIRD_PASS_REPLY (integer)

CURLE_FTP_WEIRD_USER_REPLY (integer)

CURLE_FTP_WEIRD_PASV_REPLY (integer)

CURLE_FTP_WEIRD_227_FORMAT (integer)

CURLE_FTP_CANT_GET_HOST (integer)

CURLE_FTP_CANT_RECONNECT (integer)

CURLE_FTP_COULDNT_SET_BINARY (integer)

CURLE_PARTIAL_FILE (integer)

CURLE_FTP_COULDNT_RETR_FILE (integer)

CURLE_FTP_WRITE_ERROR (integer)

CURLE_FTP_QUOTE_ERROR (integer)

CURLE_HTTP_NOT_FOUND (integer)

CURLE_WRITE_ERROR (integer)

CURLE_MALFORMAT_USER (integer)

CURLE_FTP_COULDNT_STOR_FILE (integer)

CURLE_READ_ERROR (integer)

CURLE_OUT_OF_MEMORY (integer)

CURLE_OPERATION_TIMEOUTED (integer)

CURLE_FTP_COULDNT_SET_ASCII (integer)

CURLE_FTP_PORT_FAILED (integer)

CURLE_FTP_COULDNT_USE_REST (integer)

CURLE_FTP_COULDNT_GET_SIZE (integer)

CURLE_HTTP_RANGE_ERROR (integer)

CURLE_HTTP_POST_ERROR (integer)

CURLE_SSL_CONNECT_ERROR (integer)

CURLE_FTP_BAD_DOWNLOAD_RESUME (integer)

CURLE_FILE_COULDNT_READ_FILE (integer)

CURLE_LDAP_CANNOT_BIND (integer)

CURLE_LDAP_SEARCH_FAILED (integer)

CURLE_LIBRARY_NOT_FOUND (integer)

CURLE_FUNCTION_NOT_FOUND (integer)

CURLE_ABORTED_BY_CALLBACK (integer)

CURLE_BAD_FUNCTION_ARGUMENT (integer)

CURLE_BAD_CALLING_ORDER (integer)

CURLE_HTTP_PORT_FAILED (integer)

CURLE_BAD_PASSWORD_ENTERED (integer)

CURLE_TOO_MANY_REDIRECTS (integer)

CURLE_UNKNOWN_TELNET_OPTION (integer)

CURLE_TELNET_OPTION_SYNTAX (integer)

CURLE_OBSOLETE (integer)

CURLE_SSL_PEER_CERTIFICATE (integer)

Anterior | Inicio | Siguiente
cpdf Predefined Constants | Subir | cyrus Predefined Constants


cyrus Predefined Constants

(unknown)

cyrus Predefined Constants -- Constants defined in the cyrus extension

Description

These constants are defined by the cyrus extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

CYRUS_CONN_NONSYNCLITERAL (integer)

CYRUS_CONN_INITIALRESPONSE (integer)

CYRUS_CALLBACK_NUMBERED (integer)

CYRUS_CALLBACK_NOLITERAL (integer)

Anterior | Inicio | Siguiente
curl Predefined Constants | Subir | dbplus Predefined Constants


dbplus Predefined Constants

(unknown)

dbplus Predefined Constants -- Constants defined in the dbplus extension

Description

These constants are defined by the dbplus extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

DBPLUS_ERR_NOERR (integer)

DBPLUS_ERR_DUPLICATE (integer)

DBPLUS_ERR_EOSCAN (integer)

DBPLUS_ERR_EMPTY (integer)

DBPLUS_ERR_CLOSE (integer)

DBPLUS_ERR_WLOCKED (integer)

DBPLUS_ERR_LOCKED (integer)

DBPLUS_ERR_NOLOCK (integer)

DBPLUS_ERR_READ (integer)

DBPLUS_ERR_WRITE (integer)

DBPLUS_ERR_CREATE (integer)

DBPLUS_ERR_LSEEK (integer)

DBPLUS_ERR_LENGTH (integer)

DBPLUS_ERR_OPEN (integer)

DBPLUS_ERR_WOPEN (integer)

DBPLUS_ERR_MAGIC (integer)

DBPLUS_ERR_VERSION (integer)

DBPLUS_ERR_PGSIZE (integer)

DBPLUS_ERR_CRC (integer)

DBPLUS_ERR_PIPE (integer)

DBPLUS_ERR_NIDX (integer)

DBPLUS_ERR_MALLOC (integer)

DBPLUS_ERR_NUSERS (integer)

DBPLUS_ERR_PREEXIT (integer)

DBPLUS_ERR_ONTRAP (integer)

DBPLUS_ERR_PREPROC (integer)

DBPLUS_ERR_DBPARSE (integer)

DBPLUS_ERR_DBRUNERR (integer)

DBPLUS_ERR_DBPREEXIT (integer)

DBPLUS_ERR_WAIT (integer)

DBPLUS_ERR_CORRUPT_TUPLE (integer)

DBPLUS_ERR_WARNING0 (integer)

DBPLUS_ERR_PANIC (integer)

DBPLUS_ERR_FIFO (integer)

DBPLUS_ERR_PERM (integer)

DBPLUS_ERR_TCL (integer)

DBPLUS_ERR_RESTRICTED (integer)

DBPLUS_ERR_USER (integer)

DBPLUS_ERR_UNKNOWN (integer)

Anterior | Inicio | Siguiente
cyrus Predefined Constants | Subir | dbx Predefined Constants


dbx Predefined Constants

(unknown)

dbx Predefined Constants -- Constants defined in the dbx extension

Description

These constants are defined by the dbx extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

DBX_MYSQL (integer)

DBX_ODBC (integer)

DBX_PGSQL (integer)

DBX_MSSQL (integer)

DBX_FBSQL (integer)

DBX_OCI8 (integer)

DBX_SYBASECT (integer)

DBX_PERSISTENT (integer)

DBX_RESULT_INFO (integer)

DBX_RESULT_INDEX (integer)

DBX_RESULT_ASSOC (integer)

DBX_CMP_NATIVE (integer)

DBX_CMP_TEXT (integer)

DBX_CMP_NUMBER (integer)

DBX_CMP_ASC (integer)

DBX_CMP_DESC (integer)

Anterior | Inicio | Siguiente
dbplus Predefined Constants | Subir | domxml Predefined Constants


domxml Predefined Constants

(unknown)

domxml Predefined Constants -- Constants defined in the domxml extension

Description

These constants are defined by the domxml extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

XML_ELEMENT_NODE (integer)

XML_ATTRIBUTE_NODE (integer)

XML_TEXT_NODE (integer)

XML_CDATA_SECTION_NODE (integer)

XML_ENTITY_REF_NODE (integer)

XML_ENTITY_NODE (integer)

XML_PI_NODE (integer)

XML_COMMENT_NODE (integer)

XML_DOCUMENT_NODE (integer)

XML_DOCUMENT_TYPE_NODE (integer)

XML_DOCUMENT_FRAG_NODE (integer)

XML_NOTATION_NODE (integer)

XML_HTML_DOCUMENT_NODE (integer)

XML_DTD_NODE (integer)

XML_ELEMENT_DECL_NODE (integer)

XML_ATTRIBUTE_DECL_NODE (integer)

XML_ENTITY_DECL_NODE (integer)

XML_NAMESPACE_DECL_NODE (integer)

XML_GLOBAL_NAMESPACE (integer)

XML_LOCAL_NAMESPACE (integer)

XML_ATTRIBUTE_CDATA (integer)

XML_ATTRIBUTE_ID (integer)

XML_ATTRIBUTE_IDREF (integer)

XML_ATTRIBUTE_IDREFS (integer)

XML_ATTRIBUTE_ENTITY (integer)

XML_ATTRIBUTE_NMTOKEN (integer)

XML_ATTRIBUTE_NMTOKENS (integer)

XML_ATTRIBUTE_ENUMERATION (integer)

XML_ATTRIBUTE_NOTATION (integer)

XPATH_UNDEFINED (integer)

XPATH_NODESET (integer)

XPATH_BOOLEAN (integer)

XPATH_NUMBER (integer)

XPATH_STRING (integer)

XPATH_POINT (integer)

XPATH_RANGE (integer)

XPATH_LOCATIONSET (integer)

XPATH_USERS (integer)

Anterior | Inicio | Siguiente
dbx Predefined Constants | Subir | fbsql Predefined Constants


fbsql Predefined Constants

(unknown)

fbsql Predefined Constants -- Constants defined in the fbsql extension

Description

These constants are defined by the fbsql extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

FBSQL_ASSOC (integer)

FBSQL_NUM (integer)

FBSQL_BOTH (integer)

FBSQL_LOCK_DEFERRED (integer)

FBSQL_LOCK_OPTIMISTIC (integer)

FBSQL_LOCK_PESSIMISTIC (integer)

FBSQL_ISO_READ_UNCOMMITTED (integer)

FBSQL_ISO_READ_COMMITTED (integer)

FBSQL_ISO_REPEATABLE_READ (integer)

FBSQL_ISO_SERIALIZABLE (integer)

FBSQL_ISO_VERSIONED (integer)

FBSQL_UNKNOWN (integer)

FBSQL_STOPPED (integer)

FBSQL_STARTING (integer)

FBSQL_RUNNING (integer)

FBSQL_STOPPING (integer)

FBSQL_NOEXEC (integer)

FBSQL_LOB_DIRECT (integer)

FBSQL_LOB_HANDLE (integer)

Anterior | Inicio | Siguiente
domxml Predefined Constants | Subir | fdf Predefined Constants


fdf Predefined Constants

(unknown)

fdf Predefined Constants -- Constants defined in the fdf extension

Description

These constants are defined by the fdf extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

FDFValue (integer)

FDFStatus (integer)

FDFFile (integer)

FDFID (integer)

FDFFf (integer)

FDFSetFf (integer)

FDFClearFf (integer)

FDFFlags (integer)

FDFSetF (integer)

FDFClrF (integer)

FDFAP (integer)

FDFAS (integer)

FDFAction (integer)

FDFAA (integer)

FDFAPRef (integer)

FDFIF (integer)

FDFEnter (integer)

FDFExit (integer)

FDFDown (integer)

FDFUp (integer)

FDFFormat (integer)

FDFValidate (integer)

FDFKeystroke (integer)

FDFCalculate (integer)

Anterior | Inicio | Siguiente
fbsql Predefined Constants | Subir | fribidi Predefined Constants


fribidi Predefined Constants

(unknown)

fribidi Predefined Constants -- Constants defined in the fribidi extension

Description

These constants are defined by the fribidi extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

FRIBIDI_CHARSET_UTF8 (integer)

FRIBIDI_CHARSET_8859_6 (integer)

FRIBIDI_CHARSET_8859_8 (integer)

FRIBIDI_CHARSET_CP1255 (integer)

FRIBIDI_CHARSET_CP1256 (integer)

FRIBIDI_CHARSET_ISIRI_3342 (integer)

Anterior | Inicio | Siguiente
fdf Predefined Constants | Subir | ftp Predefined Constants


ftp Predefined Constants

(unknown)

ftp Predefined Constants -- Constants defined in the ftp extension

Description

These constants are defined by the ftp extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

FTP_ASCII (integer)

FTP_TEXT (integer)

FTP_BINARY (integer)

FTP_IMAGE (integer)

FTP_TIMEOUT_SEC (integer)

Anterior | Inicio | Siguiente
fribidi Predefined Constants | Subir | gd Predefined Constants


gd Predefined Constants

(unknown)

gd Predefined Constants -- Constants defined in the gd extension

Description

These constants are defined by the gd extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

IMG_GIF (integer)

IMG_JPG (integer)

IMG_JPEG (integer)

IMG_PNG (integer)

IMG_WBMP (integer)

IMG_XPM (integer)

IMG_COLOR_TILED (integer)

IMG_COLOR_STYLED (integer)

IMG_COLOR_BRUSHED (integer)

IMG_COLOR_STYLEDBRUSHED (integer)

IMG_COLOR_TRANSPARENT (integer)

IMG_ARC_ROUNDED (integer)

IMG_ARC_PIE (integer)

IMG_ARC_CHORD (integer)

IMG_ARC_NOFILL (integer)

IMG_ARC_EDGED (integer)

Anterior | Inicio | Siguiente
ftp Predefined Constants | Subir | gmp Predefined Constants


gmp Predefined Constants

(unknown)

gmp Predefined Constants -- Constants defined in the gmp extension

Description

These constants are defined by the gmp extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

GMP_ROUND_ZERO (integer)

GMP_ROUND_PLUSINF (integer)

GMP_ROUND_MINUSINF (integer)

Anterior | Inicio | Siguiente
gd Predefined Constants | Subir | hyperwave Predefined Constants


hyperwave Predefined Constants

(unknown)

hyperwave Predefined Constants -- Constants defined in the hyperwave extension

Description

These constants are defined by the hyperwave extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

HW_ATTR_LANG (integer)

HW_ATTR_NR (integer)

HW_ATTR_NONE (integer)

Anterior | Inicio | Siguiente
gmp Predefined Constants | Subir | imap Predefined Constants


imap Predefined Constants

(unknown)

imap Predefined Constants -- Constants defined in the imap extension

Description

These constants are defined by the imap extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

NIL (integer)

OP_DEBUG (integer)

OP_READONLY (integer)

OP_ANONYMOUS (integer)

OP_SHORTCACHE (integer)

OP_SILENT (integer)

OP_PROTOTYPE (integer)

OP_HALFOPEN (integer)

OP_EXPUNGE (integer)

OP_SECURE (integer)

CL_EXPUNGE (integer)

FT_UID (integer)

FT_PEEK (integer)

FT_NOT (integer)

FT_INTERNAL (integer)

FT_PREFETCHTEXT (integer)

ST_UID (integer)

ST_SILENT (integer)

ST_SET (integer)

CP_UID (integer)

CP_MOVE (integer)

SE_UID (integer)

SE_FREE (integer)

SE_NOPREFETCH (integer)

SO_FREE (integer)

SO_NOSERVER (integer)

SA_MESSAGES (integer)

SA_RECENT (integer)

SA_UNSEEN (integer)

SA_UIDNEXT (integer)

SA_UIDVALIDITY (integer)

SA_ALL (integer)

LATT_NOINFERIORS (integer)

LATT_NOSELECT (integer)

LATT_MARKED (integer)

LATT_UNMARKED (integer)

SORTDATE (integer)

SORTARRIVAL (integer)

SORTFROM (integer)

SORTSUBJECT (integer)

SORTTO (integer)

SORTCC (integer)

SORTSIZE (integer)

TYPETEXT (integer)

TYPEMULTIPART (integer)

TYPEMESSAGE (integer)

TYPEAPPLICATION (integer)

TYPEAUDIO (integer)

TYPEIMAGE (integer)

TYPEVIDEO (integer)

TYPEOTHER (integer)

ENC7BIT (integer)

ENC8BIT (integer)

ENCBINARY (integer)

ENCBASE64 (integer)

ENCQUOTEDPRINTABLE (integer)

ENCOTHER (integer)

Anterior | Inicio | Siguiente
hyperwave Predefined Constants | Subir | ingres Predefined Constants


ingres Predefined Constants

(unknown)

ingres Predefined Constants -- Constants defined in the ingres extension

Description

These constants are defined by the ingres extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

INGRES_ASSOC (integer)

INGRES_NUM (integer)

INGRES_BOTH (integer)

Anterior | Inicio | Siguiente
imap Predefined Constants | Subir | interbase Predefined Constants


interbase Predefined Constants

(unknown)

interbase Predefined Constants -- Constants defined in the interbase extension

Description

These constants are defined by the interbase extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

IBASE_DEFAULT (integer)

IBASE_TEXT (integer)

IBASE_UNIXTIME (integer)

IBASE_READ (integer)

IBASE_COMMITTED (integer)

IBASE_CONSISTENCY (integer)

IBASE_NOWAIT (integer)

IBASE_TIMESTAMP (integer)

IBASE_DATE (integer)

IBASE_TIME (integer)

Anterior | Inicio | Siguiente
ingres Predefined Constants | Subir | ldap Predefined Constants


ldap Predefined Constants

(unknown)

ldap Predefined Constants -- Constants defined in the ldap extension

Description

These constants are defined by the ldap extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

LDAP_DEREF_NEVER (integer)

LDAP_DEREF_SEARCHING (integer)

LDAP_DEREF_FINDING (integer)

LDAP_DEREF_ALWAYS (integer)

LDAP_OPT_DEREF (integer)

LDAP_OPT_SIZELIMIT (integer)

LDAP_OPT_TIMELIMIT (integer)

LDAP_OPT_PROTOCOL_VERSION (integer)

LDAP_OPT_ERROR_NUMBER (integer)

LDAP_OPT_REFERRALS (integer)

LDAP_OPT_RESTART (integer)

LDAP_OPT_HOST_NAME (integer)

LDAP_OPT_ERROR_STRING (integer)

LDAP_OPT_MATCHED_DN (integer)

LDAP_OPT_SERVER_CONTROLS (integer)

LDAP_OPT_CLIENT_CONTROLS (integer)

LDAP_OPT_DEBUG_LEVEL (integer)

GSLC_SSL_NO_AUTH (integer)

GSLC_SSL_ONEWAY_AUTH (integer)

GSLC_SSL_TWOWAY_AUTH (integer)

Anterior | Inicio | Siguiente
interbase Predefined Constants | Subir | mbstring Predefined Constants


mbstring Predefined Constants

(unknown)

mbstring Predefined Constants -- Constants defined in the mbstring extension

Description

These constants are defined by the mbstring extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

MB_OVERLOAD_MAIL (integer)

MB_OVERLOAD_STRING (integer)

MB_OVERLOAD_REGEX (integer)

Anterior | Inicio | Siguiente
ldap Predefined Constants | Subir | mcal Predefined Constants


mcal Predefined Constants

(unknown)

mcal Predefined Constants -- Constants defined in the mcal extension

Description

These constants are defined by the mcal extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

MCAL_SUNDAY (integer)

MCAL_MONDAY (integer)

MCAL_TUESDAY (integer)

MCAL_WEDNESDAY (integer)

MCAL_THURSDAY (integer)

MCAL_FRIDAY (integer)

MCAL_SATURDAY (integer)

MCAL_JANUARY (integer)

MCAL_FEBRUARY (integer)

MCAL_MARCH (integer)

MCAL_APRIL (integer)

MCAL_MAY (integer)

MCAL_JUNE (integer)

MCAL_JULY (integer)

MCAL_AUGUST (integer)

MCAL_SEPTEMBER (integer)

MCAL_OCTOBER (integer)

MCAL_NOVEMBER (integer)

MCAL_RECUR_NONE (integer)

MCAL_RECUR_DAILY (integer)

MCAL_RECUR_WEEKLY (integer)

MCAL_RECUR_MONTHLY_MDAY (integer)

MCAL_RECUR_MONTHLY_WDAY (integer)

MCAL_RECUR_YEARLY (integer)

MCAL_M_SUNDAY (integer)

MCAL_M_MONDAY (integer)

MCAL_M_TUESDAY (integer)

MCAL_M_WEDNESDAY (integer)

MCAL_M_THURSDAY (integer)

MCAL_M_FRIDAY (integer)

MCAL_M_SATURDAY (integer)

MCAL_M_WEEKDAYS (integer)

MCAL_M_WEEKEND (integer)

MCAL_M_ALLDAYS (integer)

Anterior | Inicio | Siguiente
mbstring Predefined Constants | Subir | mcrypt Predefined Constants


mcrypt Predefined Constants

(unknown)

mcrypt Predefined Constants -- Constants defined in the mcrypt extension

Description

These constants are defined by the mcrypt extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

MCRYPT_ENCRYPT (integer)

MCRYPT_DECRYPT (integer)

MCRYPT_DEV_RANDOM (integer)

MCRYPT_DEV_URANDOM (integer)

MCRYPT_RAND (integer)

Anterior | Inicio | Siguiente
mcal Predefined Constants | Subir | ming Predefined Constants


ming Predefined Constants

(unknown)

ming Predefined Constants -- Constants defined in the ming extension

Description

These constants are defined by the ming extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

SWFBUTTON_HIT (integer)

SWFBUTTON_DOWN (integer)

SWFBUTTON_OVER (integer)

SWFBUTTON_UP (integer)

SWFBUTTON_MOUSEUPOUTSIDE (integer)

SWFBUTTON_DRAGOVER (integer)

SWFBUTTON_DRAGOUT (integer)

SWFBUTTON_MOUSEUP (integer)

SWFBUTTON_MOUSEDOWN (integer)

SWFBUTTON_MOUSEOUT (integer)

SWFBUTTON_MOUSEOVER (integer)

SWFFILL_RADIAL_GRADIENT (integer)

SWFFILL_LINEAR_GRADIENT (integer)

SWFFILL_TILED_BITMAP (integer)

SWFFILL_CLIPPED_BITMAP (integer)

SWFTEXTFIELD_HASLENGTH (integer)

SWFTEXTFIELD_NOEDIT (integer)

SWFTEXTFIELD_PASSWORD (integer)

SWFTEXTFIELD_MULTILINE (integer)

SWFTEXTFIELD_WORDWRAP (integer)

SWFTEXTFIELD_DRAWBOX (integer)

SWFTEXTFIELD_NOSELECT (integer)

SWFTEXTFIELD_HTML (integer)

SWFTEXTFIELD_ALIGN_LEFT (integer)

SWFTEXTFIELD_ALIGN_RIGHT (integer)

SWFTEXTFIELD_ALIGN_CENTER (integer)

SWFTEXTFIELD_ALIGN_JUSTIFY (integer)

SWFACTION_ONLOAD (integer)

SWFACTION_ENTERFRAME (integer)

SWFACTION_UNLOAD (integer)

SWFACTION_MOUSEMOVE (integer)

SWFACTION_MOUSEDOWN (integer)

SWFACTION_MOUSEUP (integer)

SWFACTION_KEYDOWN (integer)

SWFACTION_KEYUP (integer)

SWFACTION_DATA (integer)

Anterior | Inicio | Siguiente
mcrypt Predefined Constants | Subir | mnogosearch Predefined Constants


mnogosearch Predefined Constants

(unknown)

mnogosearch Predefined Constants -- Constants defined in the mnogosearch extension

Description

These constants are defined by the mnogosearch extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

UDM_FIELD_URLID (integer)

UDM_FIELD_URL (integer)

UDM_FIELD_CONTENT (integer)

UDM_FIELD_TITLE (integer)

UDM_FIELD_KEYWORDS (integer)

UDM_FIELD_DESC (integer)

UDM_FIELD_DESCRIPTION (integer)

UDM_FIELD_TEXT (integer)

UDM_FIELD_SIZE (integer)

UDM_FIELD_RATING (integer)

UDM_FIELD_SCORE (integer)

UDM_FIELD_MODIFIED (integer)

UDM_FIELD_ORDER (integer)

UDM_FIELD_CRC (integer)

UDM_FIELD_CATEGORY (integer)

UDM_FIELD_LANG (integer)

UDM_FIELD_CHARSET (integer)

UDM_PARAM_PAGE_SIZE (integer)

UDM_PARAM_PAGE_NUM (integer)

UDM_PARAM_SEARCH_MODE (integer)

UDM_PARAM_CACHE_MODE (integer)

UDM_PARAM_TRACK_MODE (integer)

UDM_PARAM_PHRASE_MODE (integer)

UDM_PARAM_CHARSET (integer)

UDM_PARAM_LOCAL_CHARSET (integer)

UDM_PARAM_BROWSER_CHARSET (integer)

UDM_PARAM_STOPTABLE (integer)

UDM_PARAM_STOP_TABLE (integer)

UDM_PARAM_STOPFILE (integer)

UDM_PARAM_STOP_FILE (integer)

UDM_PARAM_WEIGHT_FACTOR (integer)

UDM_PARAM_WORD_MATCH (integer)

UDM_PARAM_MAX_WORD_LEN (integer)

UDM_PARAM_MAX_WORDLEN (integer)

UDM_PARAM_MIN_WORD_LEN (integer)

UDM_PARAM_MIN_WORDLEN (integer)

UDM_PARAM_ISPELL_PREFIXES (integer)

UDM_PARAM_ISPELL_PREFIX (integer)

UDM_PARAM_PREFIXES (integer)

UDM_PARAM_PREFIX (integer)

UDM_PARAM_CROSS_WORDS (integer)

UDM_PARAM_CROSSWORDS (integer)

UDM_PARAM_VARDIR (integer)

UDM_PARAM_DATADIR (integer)

UDM_PARAM_HLBEG (integer)

UDM_PARAM_HLEND (integer)

UDM_PARAM_SYNONYM (integer)

UDM_PARAM_SEARCHD (integer)

UDM_PARAM_QSTRING (integer)

UDM_PARAM_REMOTE_ADDR (integer)

UDM_LIMIT_CAT (integer)

UDM_LIMIT_URL (integer)

UDM_LIMIT_TAG (integer)

UDM_LIMIT_LANG (integer)

UDM_LIMIT_DATE (integer)

UDM_PARAM_FOUND (integer)

UDM_PARAM_NUM_ROWS (integer)

UDM_PARAM_WORDINFO (integer)

UDM_PARAM_WORD_INFO (integer)

UDM_PARAM_SEARCHTIME (integer)

UDM_PARAM_SEARCH_TIME (integer)

UDM_PARAM_FIRST_DOC (integer)

UDM_PARAM_LAST_DOC (integer)

UDM_MODE_ALL (integer)

UDM_MODE_ANY (integer)

UDM_MODE_BOOL (integer)

UDM_MODE_PHRASE (integer)

UDM_CACHE_ENABLED (integer)

UDM_CACHE_DISABLED (integer)

UDM_TRACK_ENABLED (integer)

UDM_TRACK_DISABLED (integer)

UDM_PHRASE_ENABLED (integer)

UDM_PHRASE_DISABLED (integer)

UDM_CROSS_WORDS_ENABLED (integer)

UDM_CROSSWORDS_ENABLED (integer)

UDM_CROSS_WORDS_DISABLED (integer)

UDM_CROSSWORDS_DISABLED (integer)

UDM_PREFIXES_ENABLED (integer)

UDM_PREFIX_ENABLED (integer)

UDM_ISPELL_PREFIXES_ENABLED (integer)

UDM_ISPELL_PREFIX_ENABLED (integer)

UDM_PREFIXES_DISABLED (integer)

UDM_PREFIX_DISABLED (integer)

UDM_ISPELL_PREFIXES_DISABLED (integer)

UDM_ISPELL_PREFIX_DISABLED (integer)

UDM_ISPELL_TYPE_AFFIX (integer)

UDM_ISPELL_TYPE_SPELL (integer)

UDM_ISPELL_TYPE_DB (integer)

UDM_ISPELL_TYPE_SERVER (integer)

UDM_MATCH_WORD (integer)

UDM_MATCH_BEGIN (integer)

UDM_MATCH_SUBSTR (integer)

UDM_MATCH_END (integer)

Anterior | Inicio | Siguiente
ming Predefined Constants | Subir | msql Predefined Constants


msql Predefined Constants

(unknown)

msql Predefined Constants -- Constants defined in the msql extension

Description

These constants are defined by the msql extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

MSQL_ASSOC (integer)

MSQL_NUM (integer)

MSQL_BOTH (integer)

Anterior | Inicio | Siguiente
mnogosearch Predefined Constants | Subir | mssql Predefined Constants


mssql Predefined Constants

(unknown)

mssql Predefined Constants -- Constants defined in the mssql extension

Description

These constants are defined by the mssql extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

MSSQL_ASSOC (integer)

MSSQL_NUM (integer)

MSSQL_BOTH (integer)

SQLTEXT (integer)

SQLVARCHAR (integer)

SQLCHAR (integer)

SQLINT1 (integer)

SQLINT2 (integer)

SQLINT4 (integer)

SQLBIT (integer)

SQLFLT8 (integer)

Anterior | Inicio | Siguiente
msql Predefined Constants | Subir | mysql Predefined Constants


mysql Predefined Constants

(unknown)

mysql Predefined Constants -- Constants defined in the mysql extension

Description

These constants are defined by the mysql extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

MYSQL_ASSOC (integer)

MYSQL_NUM (integer)

MYSQL_BOTH (integer)

MYSQL_USE_RESULT (integer)

MYSQL_STORE_RESULT (integer)

Anterior | Inicio | Siguiente
mssql Predefined Constants | Subir | ncurses Predefined Constants


ncurses Predefined Constants

(unknown)

ncurses Predefined Constants -- Constants defined in the ncurses extension

Description

These constants are defined by the ncurses extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

NCURSES_COLOR_BLACK (integer)

NCURSES_COLOR_RED (integer)

NCURSES_COLOR_GREEN (integer)

NCURSES_COLOR_YELLOW (integer)

NCURSES_COLOR_BLUE (integer)

NCURSES_COLOR_MAGENTA (integer)

NCURSES_COLOR_CYAN (integer)

NCURSES_COLOR_WHITE (integer)

NCURSES_KEY_DOWN (integer)

NCURSES_KEY_UP (integer)

NCURSES_KEY_LEFT (integer)

NCURSES_KEY_RIGHT (integer)

NCURSES_KEY_BACKSPACE (integer)

NCURSES_KEY_MOUSE (integer)

NCURSES_KEY_F0 (integer)

NCURSES_KEY_DL (integer)

NCURSES_KEY_IL (integer)

NCURSES_KEY_DC (integer)

NCURSES_KEY_IC (integer)

NCURSES_KEY_EIC (integer)

NCURSES_KEY_CLEAR (integer)

NCURSES_KEY_EOS (integer)

NCURSES_KEY_EOL (integer)

NCURSES_KEY_SF (integer)

NCURSES_KEY_SR (integer)

NCURSES_KEY_NPAGE (integer)

NCURSES_KEY_PPAGE (integer)

NCURSES_KEY_STAB (integer)

NCURSES_KEY_CTAB (integer)

NCURSES_KEY_CATAB (integer)

NCURSES_KEY_ENTER (integer)

NCURSES_KEY_SRESET (integer)

NCURSES_KEY_RESET (integer)

NCURSES_KEY_PRINT (integer)

NCURSES_KEY_LL (integer)

NCURSES_KEY_A1 (integer)

NCURSES_KEY_A3 (integer)

NCURSES_KEY_B2 (integer)

NCURSES_KEY_C1 (integer)

NCURSES_KEY_C3 (integer)

NCURSES_KEY_BTAB (integer)

NCURSES_KEY_BEG (integer)

NCURSES_KEY_CANCEL (integer)

NCURSES_KEY_CLOSE (integer)

NCURSES_KEY_COMMAND (integer)

NCURSES_KEY_COPY (integer)

NCURSES_KEY_CREATE (integer)

NCURSES_KEY_END (integer)

NCURSES_KEY_EXIT (integer)

NCURSES_KEY_FIND (integer)

NCURSES_KEY_HELP (integer)

NCURSES_KEY_MARK (integer)

NCURSES_KEY_MESSAGE (integer)

NCURSES_KEY_MOVE (integer)

NCURSES_KEY_NEXT (integer)

NCURSES_KEY_OPEN (integer)

NCURSES_KEY_OPTIONS (integer)

NCURSES_KEY_PREVIOUS (integer)

NCURSES_KEY_REDO (integer)

NCURSES_KEY_REFERENCE (integer)

NCURSES_KEY_REFRESH (integer)

NCURSES_KEY_REPLACE (integer)

NCURSES_KEY_RESTART (integer)

NCURSES_KEY_RESUME (integer)

NCURSES_KEY_SAVE (integer)

NCURSES_KEY_SBEG (integer)

NCURSES_KEY_SCANCEL (integer)

NCURSES_KEY_SCOMMAND (integer)

NCURSES_KEY_SCOPY (integer)

NCURSES_KEY_SCREATE (integer)

NCURSES_KEY_SDC (integer)

NCURSES_KEY_SDL (integer)

NCURSES_KEY_SELECT (integer)

NCURSES_KEY_SEND (integer)

NCURSES_KEY_SEOL (integer)

NCURSES_KEY_SEXIT (integer)

NCURSES_KEY_SFIND (integer)

NCURSES_KEY_SHELP (integer)

NCURSES_KEY_SHOME (integer)

NCURSES_KEY_SIC (integer)

NCURSES_KEY_SLEFT (integer)

NCURSES_KEY_SMESSAGE (integer)

NCURSES_KEY_SMOVE (integer)

NCURSES_KEY_SNEXT (integer)

NCURSES_KEY_SOPTIONS (integer)

NCURSES_KEY_SPREVIOUS (integer)

NCURSES_KEY_SPRINT (integer)

NCURSES_KEY_SREDO (integer)

NCURSES_KEY_SREPLACE (integer)

NCURSES_KEY_SRIGHT (integer)

NCURSES_KEY_SRSUME (integer)

NCURSES_KEY_SSAVE (integer)

NCURSES_KEY_SSUSPEND (integer)

NCURSES_KEY_SUNDO (integer)

NCURSES_KEY_SUSPEND (integer)

NCURSES_KEY_UNDO (integer)

NCURSES_KEY_RESIZE (integer)

NCURSES_A_NORMAL (integer)

NCURSES_A_STANDOUT (integer)

NCURSES_A_UNDERLINE (integer)

NCURSES_A_REVERSE (integer)

NCURSES_A_BLINK (integer)

NCURSES_A_DIM (integer)

NCURSES_A_BOLD (integer)

NCURSES_A_PROTECT (integer)

NCURSES_A_INVIS (integer)

NCURSES_A_ALTCHARSET (integer)

NCURSES_A_CHARTEXT (integer)

NCURSES_BUTTON1_PRESSED (integer)

NCURSES_BUTTON1_RELEASED (integer)

NCURSES_BUTTON1_CLICKED (integer)

NCURSES_BUTTON1_DOUBLE_CLICKED (integer)

NCURSES_BUTTON1_TRIPLE_CLICKED (integer)

NCURSES_BUTTON2_PRESSED (integer)

NCURSES_BUTTON2_RELEASED (integer)

NCURSES_BUTTON2_CLICKED (integer)

NCURSES_BUTTON2_DOUBLE_CLICKED (integer)

NCURSES_BUTTON2_TRIPLE_CLICKED (integer)

NCURSES_BUTTON3_PRESSED (integer)

NCURSES_BUTTON3_RELEASED (integer)

NCURSES_BUTTON3_CLICKED (integer)

NCURSES_BUTTON3_DOUBLE_CLICKED (integer)

NCURSES_BUTTON3_TRIPLE_CLICKED (integer)

NCURSES_BUTTON4_PRESSED (integer)

NCURSES_BUTTON4_RELEASED (integer)

NCURSES_BUTTON4_CLICKED (integer)

NCURSES_BUTTON4_DOUBLE_CLICKED (integer)

NCURSES_BUTTON4_TRIPLE_CLICKED (integer)

NCURSES_BUTTON_SHIFT (integer)

NCURSES_BUTTON_CTRL (integer)

NCURSES_BUTTON_ALT (integer)

NCURSES_ALL_MOUSE_EVENTS (integer)

NCURSES_REPORT_MOUSE_POSITION (integer)

Anterior | Inicio | Siguiente
mysql Predefined Constants | Subir | oci8 Predefined Constants


oci8 Predefined Constants

(unknown)

oci8 Predefined Constants -- Constants defined in the oci8 extension

Description

These constants are defined by the oci8 extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

OCI_DEFAULT (integer)

OCI_DESCRIBE_ONLY (integer)

OCI_COMMIT_ON_SUCCESS (integer)

OCI_EXACT_FETCH (integer)

SQLT_BFILEE (integer)

SQLT_CFILEE (integer)

SQLT_CLOB (integer)

SQLT_BLOB (integer)

SQLT_RDD (integer)

OCI_B_SQLT_NTY (integer)

OCI_SYSDATE (integer)

OCI_B_BFILE (integer)

OCI_B_CFILEE (integer)

OCI_B_CLOB (integer)

OCI_B_BLOB (integer)

OCI_B_ROWID (integer)

OCI_B_CURSOR (integer)

OCI_B_BIN (integer)

OCI_FETCHSTATEMENT_BY_COLUMN (integer)

OCI_FETCHSTATEMENT_BY_ROW (integer)

OCI_ASSOC (integer)

OCI_NUM (integer)

OCI_BOTH (integer)

OCI_RETURN_NULLS (integer)

OCI_RETURN_LOBS (integer)

OCI_DTYPE_FILE (integer)

OCI_DTYPE_LOB (integer)

OCI_DTYPE_ROWID (integer)

OCI_D_FILE (integer)

OCI_D_LOB (integer)

OCI_D_ROWID (integer)

Anterior | Inicio | Siguiente
ncurses Predefined Constants | Subir | odbc Predefined Constants


odbc Predefined Constants

(unknown)

odbc Predefined Constants -- Constants defined in the odbc extension

Description

These constants are defined by the odbc extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

ODBC_TYPE (integer)

ODBC_BINMODE_PASSTHRU (integer)

ODBC_BINMODE_RETURN (integer)

ODBC_BINMODE_CONVERT (integer)

SQL_ODBC_CURSORS (integer)

SQL_CUR_USE_DRIVER (integer)

SQL_CUR_USE_IF_NEEDED (integer)

SQL_CUR_USE_ODBC (integer)

SQL_CONCURRENCY (integer)

SQL_CONCUR_READ_ONLY (integer)

SQL_CONCUR_LOCK (integer)

SQL_CONCUR_ROWVER (integer)

SQL_CONCUR_VALUES (integer)

SQL_CURSOR_TYPE (integer)

SQL_CURSOR_FORWARD_ONLY (integer)

SQL_CURSOR_KEYSET_DRIVEN (integer)

SQL_CURSOR_DYNAMIC (integer)

SQL_CURSOR_STATIC (integer)

SQL_KEYSET_SIZE (integer)

SQL_CHAR (integer)

SQL_VARCHAR (integer)

SQL_LONGVARCHAR (integer)

SQL_DECIMAL (integer)

SQL_NUMERIC (integer)

SQL_BIT (integer)

SQL_TINYINT (integer)

SQL_SMALLINT (integer)

SQL_INTEGER (integer)

SQL_BIGINT (integer)

SQL_REAL (integer)

SQL_FLOAT (integer)

SQL_DOUBLE (integer)

SQL_BINARY (integer)

SQL_VARBINARY (integer)

SQL_LONGVARBINARY (integer)

SQL_DATE (integer)

SQL_TIME (integer)

SQL_TIMESTAMP (integer)

SQL_TYPE_DATE (integer)

SQL_TYPE_TIME (integer)

SQL_TYPE_TIMESTAMP (integer)

SQL_BEST_ROWID (integer)

SQL_ROWVER (integer)

SQL_SCOPE_CURROW (integer)

SQL_SCOPE_TRANSACTION (integer)

SQL_SCOPE_SESSION (integer)

SQL_NO_NULLS (integer)

SQL_NULLABLE (integer)

SQL_INDEX_UNIQUE (integer)

SQL_INDEX_ALL (integer)

SQL_ENSURE (integer)

SQL_QUICK (integer)

Anterior | Inicio | Siguiente
oci8 Predefined Constants | Subir | openssl Predefined Constants


openssl Predefined Constants

(unknown)

openssl Predefined Constants -- Constants defined in the openssl extension

Description

These constants are defined by the openssl extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

X509_PURPOSE_SSL_CLIENT (integer)

X509_PURPOSE_SSL_SERVER (integer)

X509_PURPOSE_NS_SSL_SERVER (integer)

X509_PURPOSE_SMIME_SIGN (integer)

X509_PURPOSE_SMIME_ENCRYPT (integer)

X509_PURPOSE_CRL_SIGN (integer)

X509_PURPOSE_ANY (integer)

PKCS7_DETACHED (integer)

PKCS7_TEXT (integer)

PKCS7_NOINTERN (integer)

PKCS7_NOVERIFY (integer)

PKCS7_NOCHAIN (integer)

PKCS7_NOCERTS (integer)

PKCS7_NOATTR (integer)

PKCS7_BINARY (integer)

PKCS7_NOSIGS (integer)

OPENSSL_PKCS1_PADDING (integer)

OPENSSL_SSLV23_PADDING (integer)

OPENSSL_NO_PADDING (integer)

OPENSSL_PKCS1_OAEP_PADDING (integer)

OPENSSL_KEYTYPE_RSA (integer)

OPENSSL_KEYTYPE_DSA (integer)

OPENSSL_KEYTYPE_DH (integer)

Anterior | Inicio | Siguiente
odbc Predefined Constants | Subir | oracle Predefined Constants


oracle Predefined Constants

(unknown)

oracle Predefined Constants -- Constants defined in the oracle extension

Description

These constants are defined by the oracle extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

ORA_BIND_INOUT (integer)

ORA_BIND_IN (integer)

ORA_BIND_OUT (integer)

ORA_FETCHINTO_ASSOC (integer)

ORA_FETCHINTO_NULLS (integer)

Anterior | Inicio | Siguiente
openssl Predefined Constants | Subir | pcntl Predefined Constants


pcntl Predefined Constants

(unknown)

pcntl Predefined Constants -- Constants defined in the pcntl extension

Description

These constants are defined by the pcntl extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

WNOHANG (integer)

WUNTRACED (integer)

SIG_IGN (integer)

SIG_DFL (integer)

SIG_ERR (integer)

SIGHUP (integer)

SIGINT (integer)

SIGQUIT (integer)

SIGILL (integer)

SIGTRAP (integer)

SIGABRT (integer)

SIGIOT (integer)

SIGBUS (integer)

SIGFPE (integer)

SIGKILL (integer)

SIGUSR1 (integer)

SIGSEGV (integer)

SIGUSR2 (integer)

SIGPIPE (integer)

SIGALRM (integer)

SIGTERM (integer)

SIGSTKFLT (integer)

SIGCLD (integer)

SIGCHLD (integer)

SIGCONT (integer)

SIGSTOP (integer)

SIGTSTP (integer)

SIGTTIN (integer)

SIGTTOU (integer)

SIGURG (integer)

SIGXCPU (integer)

SIGXFSZ (integer)

SIGVTALRM (integer)

SIGPROF (integer)

SIGWINCH (integer)

SIGPOLL (integer)

SIGIO (integer)

SIGPWR (integer)

SIGSYS (integer)

SIGBABY (integer)

Anterior | Inicio | Siguiente
oracle Predefined Constants | Subir | pcre Predefined Constants


pcre Predefined Constants

(unknown)

pcre Predefined Constants -- Constants defined in the pcre extension

Description

These constants are defined by the pcre extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

PREG_PATTERN_ORDER (integer)

PREG_SET_ORDER (integer)

PREG_SPLIT_NO_EMPTY (integer)

PREG_SPLIT_DELIM_CAPTURE (integer)

PREG_GREP_INVERT (integer)

Anterior | Inicio | Siguiente
pcntl Predefined Constants | Subir | pgsql Predefined Constants


pgsql Predefined Constants

(unknown)

pgsql Predefined Constants -- Constants defined in the pgsql extension

Description

These constants are defined by the pgsql extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

PGSQL_ASSOC (integer)

PGSQL_NUM (integer)

PGSQL_BOTH (integer)

PGSQL_CONNECTION_BAD (integer)

PGSQL_CONNECTION_OK (integer)

PGSQL_SEEK_SET (integer)

PGSQL_SEEK_CUR (integer)

PGSQL_SEEK_END (integer)

PGSQL_ESCAPE_STRING (integer)

PGSQL_ESCAPE_BYTEA (integer)

PGSQL_EMPTY_QUERY (integer)

PGSQL_COMMAND_OK (integer)

PGSQL_TUPLES_OK (integer)

PGSQL_COPY_OUT (integer)

PGSQL_COPY_IN (integer)

PGSQL_BAD_RESPONSE (integer)

PGSQL_NONFATAL_ERROR (integer)

PGSQL_FATAL_ERROR (integer)

Anterior | Inicio | Siguiente
pcre Predefined Constants | Subir | pspell Predefined Constants


pspell Predefined Constants

(unknown)

pspell Predefined Constants -- Constants defined in the pspell extension

Description

These constants are defined by the pspell extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

PSPELL_FAST (integer)

PSPELL_NORMAL (integer)

PSPELL_BAD_SPELLERS (integer)

PSPELL_RUN_TOGETHER (integer)

Anterior | Inicio | Siguiente
pgsql Predefined Constants | Subir | session Predefined Constants


session Predefined Constants

(unknown)

session Predefined Constants -- Constants defined in the session extension

Description

These constants are defined by the session extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

SID (integer)

SID (integer)

Anterior | Inicio | Siguiente
pspell Predefined Constants | Subir | sockets Predefined Constants


sockets Predefined Constants

(unknown)

sockets Predefined Constants -- Constants defined in the sockets extension

Description

These constants are defined by the sockets extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

AF_UNIX (integer)

AF_INET (integer)

SOCK_STREAM (integer)

SOCK_DGRAM (integer)

SOCK_RAW (integer)

SOCK_SEQPACKET (integer)

SOCK_RDM (integer)

MSG_OOB (integer)

MSG_WAITALL (integer)

MSG_PEEK (integer)

MSG_DONTROUTE (integer)

SO_DEBUG (integer)

SO_REUSEADDR (integer)

SO_KEEPALIVE (integer)

SO_DONTROUTE (integer)

SO_LINGER (integer)

SO_BROADCAST (integer)

SO_OOBINLINE (integer)

SO_SNDBUF (integer)

SO_RCVBUF (integer)

SO_SNDLOWAT (integer)

SO_RCVLOWAT (integer)

SO_SNDTIMEO (integer)

SO_RCVTIMEO (integer)

SO_TYPE (integer)

SO_ERROR (integer)

SOL_SOCKET (integer)

PHP_NORMAL_READ (integer)

PHP_BINARY_READ (integer)

SOL_TCP (integer)

SOL_UDP (integer)

Anterior | Inicio | Siguiente
session Predefined Constants | Subir | standard Predefined Constants


standard Predefined Constants

(unknown)

standard Predefined Constants -- Constants defined in the standard extension

Description

These constants are defined by the standard extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

EXTR_OVERWRITE (integer)

EXTR_SKIP (integer)

EXTR_PREFIX_SAME (integer)

EXTR_PREFIX_ALL (integer)

EXTR_PREFIX_INVALID (integer)

EXTR_PREFIX_IF_EXISTS (integer)

EXTR_IF_EXISTS (integer)

SORT_ASC (integer)

SORT_DESC (integer)

SORT_REGULAR (integer)

SORT_NUMERIC (integer)

SORT_STRING (integer)

CASE_LOWER (integer)

CASE_UPPER (integer)

COUNT_NORMAL (integer)

COUNT_RECURSIVE (integer)

ASSERT_ACTIVE (integer)

ASSERT_CALLBACK (integer)

ASSERT_BAIL (integer)

ASSERT_WARNING (integer)

ASSERT_QUIET_EVAL (integer)

CONNECTION_ABORTED (integer)

CONNECTION_NORMAL (integer)

CONNECTION_TIMEOUT (integer)

INI_USER (integer)

INI_PERDIR (integer)

INI_SYSTEM (integer)

INI_ALL (integer)

M_E (float)

M_LOG2E (float)

M_LOG10E (float)

M_LN2 (float)

M_LN10 (float)

M_PI (float)

M_PI_2 (float)

M_PI_4 (float)

M_1_PI (float)

M_2_PI (float)

M_2_SQRTPI (float)

M_SQRT2 (float)

M_SQRT1_2 (float)

CRYPT_SALT_LENGTH (integer)

CRYPT_STD_DES (integer)

CRYPT_EXT_DES (integer)

CRYPT_MD5 (integer)

CRYPT_BLOWFISH (integer)

DIRECTORY_SEPARATOR (integer)

SEEK_SET (integer)

SEEK_CUR (integer)

SEEK_END (integer)

LOCK_SH (integer)

LOCK_EX (integer)

LOCK_UN (integer)

LOCK_NB (integer)

HTML_SPECIALCHARS (integer)

HTML_ENTITIES (integer)

ENT_COMPAT (integer)

ENT_QUOTES (integer)

ENT_NOQUOTES (integer)

INFO_GENERAL (integer)

INFO_CREDITS (integer)

INFO_CONFIGURATION (integer)

INFO_MODULES (integer)

INFO_ENVIRONMENT (integer)

INFO_VARIABLES (integer)

INFO_LICENSE (integer)

INFO_ALL (integer)

CREDITS_GROUP (integer)

CREDITS_GENERAL (integer)

CREDITS_SAPI (integer)

CREDITS_MODULES (integer)

CREDITS_DOCS (integer)

CREDITS_FULLPAGE (integer)

CREDITS_QA (integer)

CREDITS_ALL (integer)

STR_PAD_LEFT (integer)

STR_PAD_RIGHT (integer)

STR_PAD_BOTH (integer)

PATHINFO_DIRNAME (integer)

PATHINFO_BASENAME (integer)

PATHINFO_EXTENSION (integer)

CHAR_MAX (integer)

LC_CTYPE (integer)

LC_NUMERIC (integer)

LC_TIME (integer)

LC_COLLATE (integer)

LC_MONETARY (integer)

LC_ALL (integer)

LC_MESSAGES (integer)

ABDAY_1 (integer)

ABDAY_2 (integer)

ABDAY_3 (integer)

ABDAY_4 (integer)

ABDAY_5 (integer)

ABDAY_6 (integer)

ABDAY_7 (integer)

DAY_1 (integer)

DAY_2 (integer)

DAY_3 (integer)

DAY_4 (integer)

DAY_5 (integer)

DAY_6 (integer)

DAY_7 (integer)

ABMON_1 (integer)

ABMON_2 (integer)

ABMON_3 (integer)

ABMON_4 (integer)

ABMON_5 (integer)

ABMON_6 (integer)

ABMON_7 (integer)

ABMON_8 (integer)

ABMON_9 (integer)

ABMON_10 (integer)

ABMON_11 (integer)

ABMON_12 (integer)

MON_1 (integer)

MON_2 (integer)

MON_3 (integer)

MON_4 (integer)

MON_5 (integer)

MON_6 (integer)

MON_7 (integer)

MON_8 (integer)

MON_9 (integer)

MON_10 (integer)

MON_11 (integer)

MON_12 (integer)

AM_STR (integer)

PM_STR (integer)

D_T_FMT (integer)

D_FMT (integer)

T_FMT (integer)

T_FMT_AMPM (integer)

ERA (integer)

ERA_YEAR (integer)

ERA_D_T_FMT (integer)

ERA_D_FMT (integer)

ERA_T_FMT (integer)

ALT_DIGITS (integer)

INT_CURR_SYMBOL (integer)

CURRENCY_SYMBOL (integer)

CRNCYSTR (integer)

MON_DECIMAL_POINT (integer)

MON_THOUSANDS_SEP (integer)

MON_GROUPING (integer)

POSITIVE_SIGN (integer)

NEGATIVE_SIGN (integer)

INT_FRAC_DIGITS (integer)

FRAC_DIGITS (integer)

P_CS_PRECEDES (integer)

P_SEP_BY_SPACE (integer)

N_CS_PRECEDES (integer)

N_SEP_BY_SPACE (integer)

P_SIGN_POSN (integer)

N_SIGN_POSN (integer)

DECIMAL_POINT (integer)

RADIXCHAR (integer)

THOUSANDS_SEP (integer)

THOUSEP (integer)

GROUPING (integer)

YESEXPR (integer)

NOEXPR (integer)

YESSTR (integer)

NOSTR (integer)

CODESET (integer)

LOG_EMERG (integer)

LOG_ALERT (integer)

LOG_CRIT (integer)

LOG_ERR (integer)

LOG_WARNING (integer)

LOG_NOTICE (integer)

LOG_INFO (integer)

LOG_DEBUG (integer)

LOG_KERN (integer)

LOG_USER (integer)

LOG_MAIL (integer)

LOG_DAEMON (integer)

LOG_AUTH (integer)

LOG_SYSLOG (integer)

LOG_LPR (integer)

LOG_NEWS (integer)

LOG_UUCP (integer)

LOG_CRON (integer)

LOG_AUTHPRIV (integer)

LOG_LOCAL0 (integer)

LOG_LOCAL1 (integer)

LOG_LOCAL2 (integer)

LOG_LOCAL3 (integer)

LOG_LOCAL4 (integer)

LOG_LOCAL5 (integer)

LOG_LOCAL6 (integer)

LOG_LOCAL7 (integer)

LOG_PID (integer)

LOG_CONS (integer)

LOG_ODELAY (integer)

LOG_NDELAY (integer)

LOG_NOWAIT (integer)

LOG_PERROR (integer)

Anterior | Inicio | Siguiente
sockets Predefined Constants | Subir | swf Predefined Constants


swf Predefined Constants

(unknown)

swf Predefined Constants -- Constants defined in the swf extension

Description

These constants are defined by the swf extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

MOD_COLOR (integer)

MOD_MATRIX (integer)

TYPE_PUSHBUTTON (integer)

TYPE_MENUBUTTON (integer)

BSHitTest (float)

BSDown (float)

BSOver (float)

BSUp (float)

OverDowntoIdle (integer)

IdletoOverDown (integer)

OutDowntoIdle (integer)

OutDowntoOverDown (integer)

OverDowntoOutDown (integer)

OverUptoOverDown (integer)

OverUptoIdle (integer)

IdletoOverUp (integer)

ButtonEnter (integer)

ButtonExit (integer)

MenuEnter (integer)

MenuExit (integer)

Anterior | Inicio | Siguiente
standard Predefined Constants | Subir | tokenizer Predefined Constants


tokenizer Predefined Constants

(unknown)

tokenizer Predefined Constants -- Constants defined in the tokenizer extension

Description

These constants are defined by the tokenizer extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

T_INCLUDE (integer)

T_INCLUDE_ONCE (integer)

T_EVAL (integer)

T_REQUIRE (integer)

T_REQUIRE_ONCE (integer)

T_LOGICAL_OR (integer)

T_LOGICAL_XOR (integer)

T_LOGICAL_AND (integer)

T_PRINT (integer)

T_PLUS_EQUAL (integer)

T_MINUS_EQUAL (integer)

T_MUL_EQUAL (integer)

T_DIV_EQUAL (integer)

T_CONCAT_EQUAL (integer)

T_MOD_EQUAL (integer)

T_AND_EQUAL (integer)

T_OR_EQUAL (integer)

T_XOR_EQUAL (integer)

T_SL_EQUAL (integer)

T_SR_EQUAL (integer)

T_BOOLEAN_OR (integer)

T_BOOLEAN_AND (integer)

T_IS_EQUAL (integer)

T_IS_NOT_EQUAL (integer)

T_IS_IDENTICAL (integer)

T_IS_NOT_IDENTICAL (integer)

T_IS_SMALLER_OR_EQUAL (integer)

T_IS_GREATER_OR_EQUAL (integer)

T_SL (integer)

T_SR (integer)

T_INC (integer)

T_DEC (integer)

T_INT_CAST (integer)

T_DOUBLE_CAST (integer)

T_STRING_CAST (integer)

T_ARRAY_CAST (integer)

T_OBJECT_CAST (integer)

T_BOOL_CAST (integer)

T_UNSET_CAST (integer)

T_NEW (integer)

T_EXIT (integer)

T_IF (integer)

T_ELSEIF (integer)

T_ELSE (integer)

T_ENDIF (integer)

T_LNUMBER (integer)

T_DNUMBER (integer)

T_STRING (integer)

T_STRING_VARNAME (integer)

T_VARIABLE (integer)

T_NUM_STRING (integer)

T_INLINE_HTML (integer)

T_CHARACTER (integer)

T_BAD_CHARACTER (integer)

T_ENCAPSED_AND_WHITESPACE (integer)

T_CONSTANT_ENCAPSED_STRING (integer)

T_ECHO (integer)

T_DO (integer)

T_WHILE (integer)

T_ENDWHILE (integer)

T_FOR (integer)

T_ENDFOR (integer)

T_FOREACH (integer)

T_ENDFOREACH (integer)

T_DECLARE (integer)

T_ENDDECLARE (integer)

T_AS (integer)

T_SWITCH (integer)

T_ENDSWITCH (integer)

T_CASE (integer)

T_DEFAULT (integer)

T_BREAK (integer)

T_CONTINUE (integer)

T_OLD_FUNCTION (integer)

T_FUNCTION (integer)

T_CONST (integer)

T_RETURN (integer)

T_USE (integer)

T_GLOBAL (integer)

T_STATIC (integer)

T_VAR (integer)

T_UNSET (integer)

T_ISSET (integer)

T_EMPTY (integer)

T_CLASS (integer)

T_EXTENDS (integer)

T_OBJECT_OPERATOR (integer)

T_DOUBLE_ARROW (integer)

T_LIST (integer)

T_ARRAY (integer)

T_LINE (integer)

T_FILE (integer)

T_COMMENT (integer)

T_ML_COMMENT (integer)

T_OPEN_TAG (integer)

T_OPEN_TAG_WITH_ECHO (integer)

T_CLOSE_TAG (integer)

T_WHITESPACE (integer)

T_START_HEREDOC (integer)

T_END_HEREDOC (integer)

T_DOLLAR_OPEN_CURLY_BRACES (integer)

T_CURLY_OPEN (integer)

T_PAAMAYIM_NEKUDOTAYIM (integer)

T_DOUBLE_COLON (integer)

Anterior | Inicio | Siguiente
swf Predefined Constants | Subir | w32api Predefined Constants


w32api Predefined Constants

(unknown)

w32api Predefined Constants -- Constants defined in the w32api extension

Description

These constants are defined by the w32api extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

DC_MICROSOFT (integer)

DC_BORLAND (integer)

DC_CALL_CDECL (integer)

DC_CALL_STD (integer)

DC_RETVAL_MATH4 (integer)

DC_RETVAL_MATH8 (integer)

DC_CALL_STD_BO (integer)

DC_CALL_STD_MS (integer)

DC_CALL_STD_M8 (integer)

DC_FLAG_ARGPTR (integer)

Anterior | Inicio | Siguiente
tokenizer Predefined Constants | Subir | xml Predefined Constants


xml Predefined Constants

(unknown)

xml Predefined Constants -- Constants defined in the xml extension

Description

These constants are defined by the xml extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

XML_ERROR_NONE (integer)

XML_ERROR_NO_MEMORY (integer)

XML_ERROR_SYNTAX (integer)

XML_ERROR_NO_ELEMENTS (integer)

XML_ERROR_INVALID_TOKEN (integer)

XML_ERROR_UNCLOSED_TOKEN (integer)

XML_ERROR_PARTIAL_CHAR (integer)

XML_ERROR_TAG_MISMATCH (integer)

XML_ERROR_DUPLICATE_ATTRIBUTE (integer)

XML_ERROR_JUNK_AFTER_DOC_ELEMENT (integer)

XML_ERROR_PARAM_ENTITY_REF (integer)

XML_ERROR_UNDEFINED_ENTITY (integer)

XML_ERROR_RECURSIVE_ENTITY_REF (integer)

XML_ERROR_ASYNC_ENTITY (integer)

XML_ERROR_BAD_CHAR_REF (integer)

XML_ERROR_BINARY_ENTITY_REF (integer)

XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF (integer)

XML_ERROR_MISPLACED_XML_PI (integer)

XML_ERROR_UNKNOWN_ENCODING (integer)

XML_ERROR_INCORRECT_ENCODING (integer)

XML_ERROR_UNCLOSED_CDATA_SECTION (integer)

XML_ERROR_EXTERNAL_ENTITY_HANDLING (integer)

XML_OPTION_CASE_FOLDING (integer)

XML_OPTION_TARGET_ENCODING (integer)

XML_OPTION_SKIP_TAGSTART (integer)

XML_OPTION_SKIP_WHITE (integer)

Anterior | Inicio | Siguiente
w32api Predefined Constants | Subir | yp Predefined Constants


yp Predefined Constants

(unknown)

yp Predefined Constants -- Constants defined in the yp extension

Description

These constants are defined by the yp extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

YPERR_BADARGS (integer)

YPERR_BADDB (integer)

YPERR_BUSY (integer)

YPERR_DOMAIN (integer)

YPERR_KEY (integer)

YPERR_MAP (integer)

YPERR_NODOM (integer)

YPERR_NOMORE (integer)

YPERR_PMAP (integer)

YPERR_RESRC (integer)

YPERR_RPC (integer)

YPERR_YPBIND (integer)

YPERR_YPERR (integer)

YPERR_YPSERV (integer)

YPERR_VERS (integer)

Anterior | Inicio | Siguiente
xml Predefined Constants | Subir | zlib Predefined Constants


zlib Predefined Constants

(unknown)

zlib Predefined Constants -- Constants defined in the zlib extension

Description

These constants are defined by the zlib extension, and will only be available when that extension has either been compiled into PHP or dynamically loaded at runtime.

FORCE_GZIP (integer)

FORCE_DEFLATE (integer)

Anterior | Inicio | Siguiente
yp Predefined Constants | Subir | List of Resource Types


Sobre la traducción

La traducción del manual de PHP al español ha sido posible gracias a la colaboración de un gran número de traductores, que desinteresadamente han usado su tiempo para que todos podamos tener una versión en nuestra lengua de esta documentación.

(Aqui vendra la lista de colaboradores)

Anterior | Inicio | Siguiente
Prefacio | Subir | Conceptos Básicos